Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.1SY
単一方向イーサネット(UDE)および単一方向リンク ルーティング(UDLR)
単一方向イーサネット(UDE)および単一方向リンク ルーティング(UDLR)
発行日;2013/10/06 | 英語版ドキュメント(2013/09/29 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

単一方向イーサネット(UDE)および単一方向リンク ルーティング(UDLR)

UDE および UDLR の前提条件

UDE および UDLR の制約事項

UDE の制約事項

UDLR バックチャネル トンネルの制約事項

UDE および UDLR について

UDE および UDLR の概要

UDE について

UDE の概要

ハードウェアベース UDE

ソフトウェアベース UDE

UDLR について

UDE および UDLR のデフォルト設定

UDE および UDLR の設定方法

UDE の設定

ハードウェアベース UDE の設定

ソフトウェアベース UDE の設定

UDLR の設定

UDE 送信専用ポートの受信専用トンネル インターフェイスの設定

UDE 受信専用ポートの送信専用トンネル インターフェイスの設定

単一方向イーサネット(UDE)および単一方向リンク ルーティング(UDLR)

「UDE および UDLR の前提条件」

「UDE および UDLR の制約事項」

「UDE および UDLR について」

「UDE および UDLR のデフォルト設定」

「UDE および UDLR の設定方法」


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。

Cisco IOS Release 15.1SY は、WS-X6704-10GE 4 ポート 10 ギガビット イーサネット スイッチング モジュール上でのみ単一方向イーサネット(UDE)および単一方向リンク ルーティング(UDLR)をサポートします。


 

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する


 

UDE および UDLR の前提条件

なし。

UDE および UDLR の制約事項

「UDE の制約事項」

「UDLR バックチャネル トンネルの制約事項」

UDE の制約事項

STP では、単一方向リンクを含むトポロジーにおいてレイヤ 2 ループを防止できません。

送信専用ポートは、BPDU を受信しないので、STP フォワーディング ステートに常に移行します。

受信専用ポートは BPDU を送信できません。

単一方向ポートでは、次のようにリンクの反対側の終端にあるポートとのネゴシエーションが必要になる機能またはプロトコルがサポートされません。

速度およびデュプレックス モードの自動ネゴシエーション

リンク ネゴシエーション

IEEE 802.3z フロー制御

ダイナミック トランキング プロトコル(DTP)

レイヤ 2 プロトコルによって一般的に制御されるパラメータは、手動で設定する必要があります。

VLAN トランキング プロトコル(VTP)サーバが VTP ドメインのすべてのスイッチに VTP フレームを送信できる場合、単一方向リンクを含むトポロジーでは、VTP だけがサポートされます。

VTP プルーニングは情報の双方向の交換によって異なるので、送信専用ポートがあるスイッチでは VTP プルーニングをディセーブルにしてください。

単一方向 EtherChannel では PAgP または LACP をサポートできません。単一方向 EtherChannel を作成するには、EtherChannel「オン」モードを設定する必要があります。

EtherChannel の物理ポートでソフトウェアベース UDE を設定できます。ポートチャネル インターフェイスなどの物理的でないインターフェイスでは、ソフトウェアベース UDE を設定できません。

ハードウェアベース UDE をポートで実装するか、ソフトウェアベース UDE をポートで設定する場合、UDLD はそのポートで自動的にディセーブルになります。

CDP は、送信専用ポートから CDP フレームを送信し、受信専用ポートから CDP フレームを受信します。つまり、単一方向リンクの送信専用側にあるスイッチは、CDP 情報を受信しません。

SPAN は、単一方向ポートの設定を送信側や宛先に限定しません。

送信専用ポートは、SPAN 宛先にすることができます。

受信専用ポートは、SPAN 送信元にすることができます。

単一方向ポートでは、IEEE 802.1X ポートベース認証がサポートされません。

IGMP スヌーピングでは、スイッチおよびマルチキャスト トラフィックを受信するホストの間に単一方向リンクがあるトポロジがサポートされません。

スイッチの IGMP スヌーピングとマルチキャスト ルータの間で単一方向リンクによる通信をサポートするには、UDLR を UDE とともに設定します。

単一方向リンクでは ARP がサポートされません。

UDLR バックチャネル トンネルの制約事項

PFC では、UDLR バックチャネル トンネルがハードウェアでサポートされません。UDLR バックチャネル トンネルはソフトウェアでサポートされます。

単一方向リンクごとに、UDLR バックチャネル トンネルを設定してください。

UDE 送信専用インターフェイスでは、UDLR バックチャネル トンネル インターフェイスを受信に設定してください。

UDE 受信専用インターフェイスでは、UDLR バックチャネル トンネル インターフェイスを送信に設定してください。

UDLR バックチャネル トンネル インターフェイスでは、IPv4 アドレスを設定する必要があります。

UDLR バックチャネル トンネル インターフェイスでは、送信元および宛先の IPv4 アドレスを設定する必要があります。

UDLR バックチャネル トンネルのデフォルト モードは GRE です。

UDLR バックチャネル トンネルでは、IPv6 または MPLS がサポートされません。

UDE および UDLR について

「UDE および UDLR の概要」

「UDE について」

「UDLR について」

UDE および UDLR の概要

単一方向リンクが双方向リンクをエミュレートする場合に限り、ルーティング プロトコルは同一インターフェイスにおけるトラフィックを送受信するはずなので、ルーティング プロトコルでは単一方向リンクがサポートされます。

単一方向リンクには有利な点があります。ほとんど確認応答されていない単一方向の大量のトラフィック(ビデオ ブロードキャスト ストリームなど)を大容量全二重双方向リンクで送信する場合は、送信元からレシーバへのリンク、および同様に大容量な逆方向リンク(レシーバから送信元への少ない確認応答を搬送する「バック チャネル」と呼ばれる)の両方を使用するからです。

UDE および UDLR では、大量トラフィック用の大容量単一方向リンクの使用が、バック チャネル用の同様に大容量のリンクを消費せずにサポートされます。UDE では、大容量単一方向リンクが提供されます。UDLR では、通常の容量のリンクで設定されるトンネルでバック チャネルが提供されます。また、トランスペアレントにバック チャネルと大容量単一方向リンクと同じインターフェイス上にあるかのようにして双方向リンクをエミュレートします。

UDE の概要

ハードウェアまたはソフトウェアで UDE を実装できます。ハードウェアベース UDE およびソフトウェアベース UDE の両方で、双方向トラフィックが必要とする 2 本のファイバではなく、1 本のファイバだけが使用されます。

サポートされる単一方向トランシーバ(WDM-XENPAK-REC)が受信専用 UDE を提供します。ソフトウェアベース UDE は、送信専用または受信専用のどちらかに設定できます。ハードウェアベース UDE を実装するポートで、ソフトウェアベース UDE を設定する必要はありません。

ハードウェアベース UDE

単一方向トランシーバを使用すると、単一方向リンクを構築できます。単一方向トランシーバは、双方向トランシーバより安価です。サポートされる単一方向トランシーバは WDM-XENPAK-REC です。

ソフトウェアベース UDE

トラフィックを単一方向で送信するか受信するように、双方向トランシーバに装備されているポートを設定し、単一方向リンクを作成できます。適切な単一方向トランシーバを使用できない場合は、ソフトウェアベース UDE を使用できます。たとえば、サポートされる送信専用トランシーバを使用しない場合は、ソフトウェアベース UDE で送信専用リンクを設定する必要があります。

UDLR について

UDLR では、単一方向大容量リンクのバック チャネルとしての単一方向トンネルが提供され、ユニキャスト トラフィックおよびマルチキャスト トラフィック用に 1 つの双方向リンクがトランスペアレントにエミュレートされます。

UDLR は、受信専用インターフェイスで送信する必要があるパケットを代行受信し、UDLR バックチャネル トンネルで送信します。ルータが UDLR バックチャネル トンネルでこのようなパケットを受信すると、パケットは、UDLR によって、送信専用インターフェイスで受信したかのような形になります。

UDLR バックチャネル トンネルでは、次の IPv4 機能がサポートされます。

アドレス解決プロトコル(ARP)

Next Hop Resolution Protocol(NHRP)

すべての IPv4 トラフィックの双方向リンクのエミュレーション(ブロードキャストおよびマルチキャストの制御トラフィックだけではない)

受信専用トンネルにおける IPv4 GRE マルチポイント


) UDLR バックチャネル トンネルでは、IPv6 または MPLS がサポートされません。


UDE および UDLR のデフォルト設定

なし。

UDE および UDLR の設定方法

「UDE の設定」

「UDLR の設定」


) 次の説明は、UDLR をサポートするリリースで公開されています。ネイバー ISIS ルータは、UDLR トポロジで認識されません (CSCee56596)。


ハードウェアベース UDE の設定

単一方向トランシーバを設置し、ハードウェアベース UDE を実装してください。ハードウェアベース UDE には、ソフトウェア設定手順は必要ありません。

ポートのハードウェアベース UDE を確認するには、次の作業を行います。

 

コマンド
目的

Router# show interfaces [{ gigabitethernet | tengigabitethernet } slot/interface }] status

設定を確認します。

次に、ギガビット イーサネット ポート 1/1 の設定を確認する例を示します。

Router# show interfaces gigabitethernet 1/1 status
 
Port Name Status Vlan Duplex Speed Type
Gi1/1 notconnect 1 full 1000 WDM-RXONLY

ソフトウェアベース UDE の設定

ポートのソフトウェアベース UDE を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface {{ gigabitethernet | tengigabitethernet } slot/interface }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# unidirectional { send-only | receive-only }

ソフトウェアベース UDE を設定します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

次に、10 ギガビット イーサネット ポート 1/1 を UDE 送信専用ポートとして設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tengigabitethernet 1/1
Router(config-if)# unidirectional send-only
Router(config-if)# end
 
Warning!
 
Enable port unidirectional mode will automatically disable port udld. You must manually ensure that the unidirectional link does not create a spanning tree loop in the network.
 
Enable l3 port unidirectional mode will automatically disable ip routing on the port. You must manually configure static ip route and arp entry in order to route ip traffic.
 

次に、10 ギガビット イーサネット ポート 1/2 を UDE 受信専用ポートとして設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tengigabitethernet 1/2
Router(config-if)# unidirectional receive-only
Router(config-if)# end
 
Warning!
 
Enable port unidirectional mode will automatically disable port udld. You must manually ensure that the unidirectional link does not create a spanning tree loop in the network.
 
Enable l3 port unidirectional mode will automatically disable ip routing on the port. You must manually configure static ip route and arp entry in order to route ip traffic.
 

次に、設定を確認する例を示します。

Router> show interface tengigabitethernet 1/1 unidirectional
Unidirectional configuration mode: send only
CDP neighbour unidirectional configuration mode: receive only
 

次に、10 ギガビット イーサネット インターフェイス 1/1 で UDE をディセーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tengigabitethernet 1/1
Router(config-if)# no unidirectional
Router(config-if)# end
 

次の例は、単一方向イーサネットをサポートしないポートで show interface コマンドを入力した結果を示しています。

Router# show interface gigabitethernet 6/1 unidirectional
Unidirectional Ethernet is not supported on GigabitEthernet6/1

UDE 送信専用ポートの受信専用トンネル インターフェイスの設定

UDE 送信専用ポートに受信専用トンネル インターフェイスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface tunnel number

トンネル インターフェイスを選択します。

ステップ 2

Router(config-if)# tunnel udlr receive-only ude_send_only_port

トンネル受信専用インターフェイスを UDE 送信専用ポートと関連付けます。

ステップ 3

Router(config-if)# ip address ipv4_address

トンネル IPv4 アドレスを設定します。

ステップ 4

Router(config-if)# tunnel source { ipv4_address | type number }

トンネル送信元を設定します。

ステップ 5

Router(config-if)# tunnel destination { hostname | ipv4_address }

トンネル宛先を設定します。

UDE 受信専用ポートの送信専用トンネル インターフェイスの設定

UDE 受信専用ポートに送信専用トンネル インターフェイスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface tunnel number

トンネル インターフェイスを選択します。

ステップ 2

Router(config-if)# tunnel udlr send-only ude_receive_only_port

トンネル送信専用インターフェイスを UDE 受信専用ポートと関連付けます。

ステップ 3

Router(config-if)# ip address ipv4_address

トンネル IPv4 アドレスを設定します。

ステップ 4

Router(config-if)# tunnel source { ipv4_address | type number }

トンネル送信元を設定します。

ステップ 5

Router(config-if)# tunnel destination { hostname | ipv4_address }

トンネル宛先を設定します。

ステップ 6

Router(config-if)# tunnel udlr address-resolution

ARP および NHRP をイネーブルにします。

次の UDE および UDLR の設定例は、次のようになっています。

ルータ A の場合:

Open Shortest Path First(OSPF)および PIM が設定されています。

10 ギガビット イーサネット ポート 1/1 が送信専用 UDE ポートになります。

UDLR バック チャネル トンネルが受信専用として設定され、10 ギガビット イーサネット ポート 1/1 に関連付けられます。

ルータ B の場合:

OSPF および PIM が設定されています。

10 ギガビット イーサネット ポート 1/2 が受信専用 UDE ポートになります。

UDLR バック チャネル トンネルが送信専用として設定され、10 ギガビット イーサネット ポート 1/2 に関連付けられます。

ARP および NHRP がイネーブルです。

ルータ A の設定

ip multicast-routing
!
! tengigabitethernet 1/1 is send-only
!
interface tengigabitethernet 1/1
unidirectional send-only
ip address 10.1.0.1 255.255.0.0
ip pim sparse-dense-mode
!
! Configure tunnel as receive-only UDLR tunnel.
!
interface tunnel 0
tunnel source 11.0.0.1
tunnel destination 11.0.0.2
tunnel udlr receive-only tengigabitethernet 1/1
!
! Configure OSPF.
!
router ospf <pid>
network 10.0.0.0 0.255.255.255 area 0

ルータ B の設定

ip multicast-routing
!
! tengigabitethernet 1/2 is receive-only
!
interface tengigabitethernet 1/2
unidirectional receive-only
ip address 10.1.0.2 255.255.0.0
ip pim sparse-dense-mode
!
! Configure tunnel as send-only UDLR tunnel.
!
interface tunnel 0
tunnel source 11.0.0.2
tunnel destination 11.0.0.1
tunnel udlr send-only tengigabitethernet 1/2
tunnel udlr address-resolution
!
! Configure OSPF.
!
router ospf <pid>
network 10.0.0.0 0.255.255.255 area 0

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する