Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.1SY
MPLS VPN サポート
MPLS VPN サポート
発行日;2013/08/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

MPLS VPN サポート

MPLS VPN の前提条件

MPLS VPN の制約事項

MPLS VPN サポートについて

MPLS VPN の設定方法

MPLS VPN の設定例

MPLS VPN サポート

「MPLS VPN の前提条件」

「MPLS VPN の制約事項」

「MPLS VPN サポートについて」

「MPLS VPN の設定方法」

「MPLS VPN の設定例」


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。


 

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する


 

MPLS VPN の前提条件

なし。

MPLS VPN の制約事項

MPLS VPN を設定する場合、VPN 数が 511 を超えると VPN が再循環されることに注意してください。

MPLS VPN では以下のコマンドがサポートされます。

address-family

exit-address-family

import map

ip route vrf

ip route forwarding

ip vrf

neighbor activate

rd

route-target

これらのコマンドの詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。

MPLS VPN サポートについて

Cisco IOS ネットワークに MPLS の IP VPN 機能を使用すると、スケーラブルな IP レイヤ 3 VPN バックボーン サービスを、共有インフラストラクチャに配置された複数のサイトに導入し、同時にプライベート ネットワークと同じアクセスまたはセキュリティを提供できます。MPLS テクノロジーに基づいた VPN には、ルーティングの隔離、セキュリティの向上、ルーティングの簡素化およびスケーラビリティの向上が実現するという利点があります。MPLS VPN の詳細については、次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios-xml/ios/mpls/config_library/15-sy/mp-15-sy-library.html

図 37-1 VPN および MPLS サービス プロバイダー バックボーン

 

PFC は入力 PE で、パケット ヘッダーに基づいて転送を判断します。PFC には、VLAN を VPN にマッピングするテーブルが格納されています。スイッチのアーキテクチャでは、システム内のすべての物理入力インターフェイスが特定の VPN に対応付けられます。PFC は CEF テーブル内で IP 宛先アドレスを検索しますが、対象となるのは特定の VPN 内のプレフィックスだけです (テーブル エントリは特定の隣接セットを指します。複数のパラレル パスが存在する場合は、ロードバランス判断によって特定の隣接が選択されます)。

テーブル エントリには、パケットに必要なレイヤ 2 ヘッダー情報、およびフレームにプッシュされる特定の MPLS ラベルが格納されます。パケット書き替え用のこの情報は、入力モジュールに送信されて書き替えが行われ、出力ライン インターフェイスに転送されます。

VPN トラフィックはプレフィックス単位のラベルまたは集約ラベルに基づいて、PE からの出口で処理されます。プレフィックス単位のラベルが使用される場合、各 VPN プレフィックスには一意のラベルが対応付けられます。これにより、PE は FIB 内のラベル検索に基づいて、パケットを最終宛先に転送できます。


) PFC が割り当てるのは、VRF ごとに 1 つの集約ラベルだけです。


出力 PE でのディスポジションに集約ラベルが使用される場合、複数のインターフェイスの多数のプレフィックスをこのラベルに対応付けることができます。この場合、PFC は IP 検索を実行して最終宛先を判別する必要があります。IP 検索には再循環が必要となる場合があります。

MPLS VPN の設定方法

MPLS VPN の設定手順については、次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios-xml/ios/mpls/config_library/15-sy/mp-15-sy-library.html


) 別の MPLS デバイスとのレイヤ 2 ポート ピアリングで MPLS アップリンクとしてレイヤ 3 VLAN インターフェイスを使用する場合は、別のレイヤ 3 VLAN インターフェイスを VRF インターフェイスとして使用できます。


MPLS VPN の設定例

次に、LAN CE 方向のインターフェイスの設定例を示します。Cisco IOS Release 15.1SY の MPLS スイッチングのコンフィギュレーションは、他のリリースでのコンフィギュレーションと同じです。

!ip vrf blues
rd 100:10
route-target export 100:1
route-target import 100:1
!
mpls label protocol ldp
mpls ldp logging neighbor-changes
!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
!
interface GigabitEthernet4/2
description Catalyst link to P2
no ip address
!
interface GigabitEthernet4/2.42
encapsulation dot1Q 42
ip address 10.0.3.2 255.255.255.0
tag-switching ip
!
interface GigabitEthernet7/3
description Catalyst link to CE2
no ip address
!
interface GigabitEthernet7/3.73
encapsulation dot1Q 73
ip vrf forwarding blues
ip address 10.19.7.1 255.255.255.0
!
router ospf 100
log-adjacency-changes
network 10.4.4.4 0.0.0.0 area 0
network 10.0.0.0 0.0.255.255 area 0
!
router ospf 65000 vrf blues
log-adjacency-changes
redistribute bgp 100 subnets
network 10.19.0.0 0.0.255.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 10.3.3.3 remote-as 100
neighbor 10.3.3.3 description MP-BGP to PE1
neighbor 10.3.3.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.3.3.3 activate
neighbor 10.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blues
redistribute connected
redistribute ospf 65000 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family
!