Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.1SY
仮想プライベート LAN サービス(VPLS)
仮想プライベート LAN サービス(VPLS)
発行日;2013/08/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

仮想プライベート LAN サービス(VPLS)

VPLS の前提条件

VPLS の制約事項

VPLS について

VPLS の概要

フルメッシュの設定

H-VPLS

サポートされる機能

マルチポイントツーマルチポイントのサポート

Non-Transparent 動作

回線多重化

MAC アドレス ラーニング、転送、およびエージング

ジャンボ フレーム サポート

Q-in-Q のサポートおよび EoMPLS への Q-in-Q のサポート

VPLS サービス

VPLS のデフォルト設定

VPLS の設定方法

CE への PE レイヤ 2 インターフェイスの設定

CE からタグ付きトラフィックを受け取る 802.1Q トランクの設定

CE からタグなしトラフィックを受け取る 802.1Q アクセス ポートの設定

すべての VLAN を単一の VPLS インスタンスに配置する Q-in-Q の設定

PE でのレイヤ 2 VLAN インスタンスの設定

PE における MPLS の設定

PE における VFI の設定

PE での接続回線と VSI の関連付け

MPLS エッジでの H-VPLS

概要

PE1 の設定

PE2 の設定

PE3 の設定

VPLS Integrated Routing and Bridging

マルチキャスト スヌーピング サポートの設定

VPLS の設定例

仮想プライベート LAN サービス(VPLS)

「VPLS の前提条件」

「VPLS の制約事項」

「VPLS について」

「VPLS のデフォルト設定」

「VPLS の設定方法」

「VPLS の設定例」


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。


 

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する


 

VPLS の前提条件

VPLS を設定する前に、ネットワークが次のように設定されていることを確認してください。

PE ルータが IP を介して相互に到達できるように、コアに IP ルーティングを設定します。

PE ルータ間にラベル スイッチド パス(LSP)が存在するように、コアに MPLS を設定します。

レイヤ 2 トラフィックの開始および終了のためのループバック インターフェイスを設定します。PE ルータが他のルータのループバック インターフェイスにアクセスできるようにします。ループバック インターフェイスは、すべてのケースで必要というわけではないことに注意してください。たとえば、VPLS が TE トンネルに直接マッピングされている場合、トンネル選択ではループバック インターフェイスは必要ありません。

VPLS 設定には、ピア PE ルータを識別する必要があり、各 PE ルータで VPLS にレイヤ 2 回線に対応付ける必要があります。

VPLS の制約事項

Supervisor Engine 2T を使用する場合、レイヤ 2 プロトコル トンネリングは、VPLS( CSCue45974 )ではサポートされません。

ブロードキャスト パケットのループを回避し、レイヤ 2 トラフィックを分離するために、スプリット ホライズンが、デフォルト設定です。スプリット ホライズンは、エミュレート VC から受信したパケットが別のエミュレート VC に転送されることを防ぎます。この方法は、フルメッシュ ネットワークにループ フリー パスを作成するために重要です。

サポートされる最大値:

VFI の総数:4,096(4K)

VFI ごとのエッジとコア ピア PE を組み合わせた最大数:

- VPLS:250

- H-VPLS 500

VC の総数:12,288(12 K)

ソフトウェア ベースのデータ プレーンはサポートされません。

自動検出メカニズムはサポートされません。

冗長 CE-PE リンクでのロード シェアリングとフェールオーバーはサポートされません。

ラベル配布プロトコル(LDP)を使用した MAC アドレスの追加または削除はサポートされません。

仮想転送インスタンス(VFI)は、interface vlan コマンドでのみサポートされています。

VPLS について

「VPLS の概要」

「フルメッシュの設定」

「H-VPLS」

「サポートされる機能」

VPLS の概要

VPLS(仮想プライベート LAN サービス)により、企業では、サービス プロバイダーから提供されたインフラストラクチャを解して、複数のサイトからのイーサネット ベースの LAN をまとめてリンクすることが可能になります。企業の側からは、サービス プロバイダーのパブリック ネットワークは、1 つの大きなイーサネット LAN のように見えます。サービス プロバイダーからすると、VPLS は、大規模な設備投資なしで、既存のネットワーク上に収益を生み出す新たなサービスを導入するチャンスになります。オペレータは、ネットワークでの機器の運用年数を延長できます。

Virtual Private LAN Services(VPLS)は、プロバイダー コアを使用して複数のアタッチメント回路を 1 つにまとめることで、複数のアタッチメント回路を 1 つに接続する仮想ブリッジをシミュレートします。VPLS のトポロジは、カスタマーからは認識されません。すべての CE デバイスは、プロバイダー コアによってエミュレートされた論理ブリッジに接続されているように見えます(図 39-1を参照)。

図 39-1 VPLS トポロジ

 

フルメッシュの設定

フルメッシュの設定では、VPLS に参加するすべての PE 間でトンネル ラベル スイッチド パス(LSP)のフルメッシュが必要です。フルメッシュでは、シグナリングのオーバーヘッドと、PE 上でプロビジョニング対象の各 VC に対するパケット複製の要件が多くなる場合があります。

VPLS のセットアップは、まず参加する各 PE ルータで Virtual Forwarding Instance(VFI)を作成して行います。VFI によって VPLS ドメインの VPN ID、そのドメインの他の PE ルータのアドレス、トンネルのシグナリングのタイプ、各ピア PE ルータのカプセル化のメカニズムが指定されます。

エミュレート VC の相互接続で形成される VFI のセットは、VPLS インスタンスと呼ばれます。これは、パケット スイッチド ネットワークを介して論理ブリッジを構成する VPLS インスタンスです。VPLS インスタンスには、一意の VPN ID が割り当てられます。

PE ルータは、VFI を使用して、エミュレートされた VC から VPLS インスタンスの他のすべての PE ルータまでのフルメッシュ LPS を確立します。PE ルータは、Cisco IOS CLI を使用して、スタティック設定を通じた VPLS インスタンスのメンバーシップを取得します。

フル メッシュ設定を行うと、PE ルータは、単一のブロードキャスト ドメインを維持できます。したがって、接続回線でブロードキャスト、マルチキャスト、または未知のユニキャスト パケットを受信すると、PE ルータは、他のすべての接続回線およびその VPLS インスタンスに属する他のすべての CE デバイスへのエミュレート回線にパケットを送信します。CE デバイスでは、VPLS インスタンスを、エミュレート LAN として認識します。

プロバイダー コアでのパケット ループの問題を回避するために、PE デバイスは、エミュレート VC に「スプリット ホライズン」の原則を適用します。つまり、エミュレート VC でパケットを受信した場合、パケットは、他のいずれのエミュレート VC にも転送されません。

VFI を定義したら、CE デバイスへの接続回線にバインドする必要があります。

パケット転送の判断は、特定の VPLS ドメインのレイヤ 2 仮想転送インスタンス(VFI)を検索することによって行われます。

特定の PE ルータの VPLS インスタンスは、特定の物理または論理ポートに着信するイーサネット フレームを受信し、イーサネット スイッチによる動作同様に、MAC テーブルに入力します。PE ルータでは、この MAC アドレスを使用して、リモート サイトにある別の PE ルータに配布するために、このようなフレームを適切な LSP に切り替えることができます。

MAC アドレスが MAC アドレス テーブルにない場合、PE ルータは、イーサネット フレームを複製し、直前に送信された入力ポートを除くその VPLS インスタンスに関連付けられたすべての論理ポートにフラッディングします。PE ルータは、個々のポートでパケットを受信したときに MAC テーブルを更新し、一定期間使用されていないアドレスを削除します。

H-VPLS

階層型 VPLS(H-VPLS)は、フルメッシュとハブ アンド スポーク構成の両方を使用することによって、シグナリングと複製の両方のオーバーヘッドを軽減します。ハブ アンド スポーク構成は、スプリット ホライズンと連動して疑似配線(PW)間でパケットをスイッチングさせるので、PE 間の PW 数が効果的に削減されます。


) ブロードキャスト パケットのループを回避するために、スプリット ホライズンがデフォルト設定です。no split-horizon キーワードを使用した場合にループを回避しようとすると、ネットワーク構成で入念な配慮が必要になります。


マルチポイントツーマルチポイントのサポート

複数のデバイスがコア ネットワーク越しに関連付けられます。いずれのデバイスもルート ノードとして指定されていない一方で、すべてのデバイスがルート ノードとして扱われます。すべてのフレームをノード間で直接交換できます。

Non-Transparent 動作

Ethernet Virtual Connection(VEC)は、Ethernet PDU(つまり、BPDU)に関して透過的である場合も非透過的である場合もあります。VEC の非透過性の目的は、レイヤ 3 デバイス間のフレーム リレー型サービスをエンド ユーザが使用できるようにすることです。

回線多重化

回線多重化を使用すると、単一のイーサネット接続を介して、ノードが複数のサービスに加入できます。複数のサービスに参加することによって、イーサネット接続は、複数の論理ネットワークに対応付けられます。可能性のあるサービス製品の例としては、サイト間の VPN サービス、インターネット サービス、企業間コミュニケーションのためとサードパーティ接続などがあります。

MAC アドレス ラーニング、転送、およびエージング

PE は、リモート MAC アドレスおよびカスタマー側ポートに直接接続された MAC アドレスを学習する必要があります。MAC アドレス ラーニングでは、カスタマー サイトから送信されるパケットからトポロジおよび転送情報を抽出することによって、これを実現します。保存された MAC アドレスにタイマーが関連付けられます。タイマーが満了すると、エントリがテーブルから削除されます。

ジャンボ フレーム サポート

ジャンボ フレームのサポートでは、1548 ~ 9216 バイトのフレーム サイズをサポートします。上の範囲内で指定した任意の値に対してジャンボ フレーム サイズを設定するには、CLI を使用します。デフォルト値は、いずれのレイヤ 2/VLAN インターフェイスでも 1500 バイトです。ジャンボ フレーム サポートは、インターフェイスごとに設定できます。

Q-in-Q のサポートおよび EoMPLS への Q-in-Q のサポート

802.1Q トンネリング(Q-in-Q)では、CE は VLAN タグ付きパケットを発行し、VPLS は、このパケットを遠端 CE に転送します。Q-in-Q は、1 つ以上の 802.1Q タグが、ネットワーク内部の 1 つのパケットに配置されることがあるという意味です。パケットが CE デバイスから受信されると、別の CE デバイスとトラフィックを区別するために、追加の VLAN タグが着信イーサネット パケットに追加されます。CE から発信されるタグなしパケットでは、VLAN スイッチド ネットワーク内部の 1 重タグが使用される一方で、CE から発信される、事前にタグの付いたパケットは、複数のタグが使用されます。

透過型 LAN サービス

透過型 LAN サービス(TLS)は、ブリッジング プロトコルの透過性(ブリッジ プロトコル データ ユニット(BPDU)など)および VLAN 値を実施するために使用される、ポイントツーポイント ポート ベース EoMPLS の拡張です。ブリッジでは、このサービスをイーサネット セグメントとして認識します。TLS を使用する場合、PE ルータでは、カスタマー側インターフェイスからに受信したすべてのイーサネット パケット(タグ付けされたパケット、タグなしパケット、BPDU を含む)を次のように転送します。

宛先 MAC アドレスがレイヤ 2 転送テーブルにある場合は、ローカル イーサネット インターフェイスまたはエミュレート VC に転送。

宛先 MAC アドレスがマルチキャスト アドレスまたはブロードキャスト アドレスであるか、宛先 MAC アドレスがレイヤ 2 転送テーブルに存在しない場合は、同じ VPLS ドメインに属する他のすべてのローカル イーサネット インターフェイスおよびエミュレート VC に転送。


) Supervisor Engine 2T を使用する場合、レイヤ 2 プロトコル トンネリングは、VPLS ではサポートされません。これにより、Cisco Discovery Protocol(CDP)、VLAN トランキング プロトコル(VTP)、および VPLS 上のスパニングツリー プロトコル(STP)の使用が回避されます(CSCue45974)。


Ethernet Virtual Connection Service

Ethernet Virtual Connection Service(EVCS)は、ルータが単一の物理ポートから複数のイントラネットおよびエクストラネット ロケーションに到達できる、ポイントツーポイント VLAN ベース EoMPLS の拡張です。ルータは、他のルータにアクセスするサブインターフェイスを認識します。EVCS を使用する場合、PE ルータでは、カスタマー側インターフェイスからに受信した特定の VLAN タグを持つイーサネット パケット(BPDU を除く)を次のように転送します。

宛先 MAC アドレスがレイヤ 2 転送テーブルにある場合は、ローカル イーサネット インターフェイスまたはエミュレート VC に転送。

宛先 MAC アドレスがマルチキャスト アドレスまたはブロードキャスト アドレスであるか、宛先 MAC アドレスがレイヤ 2 転送テーブルに存在しない場合は、同じ VPLS ドメインに属する他のすべてのローカル イーサネット インターフェイスおよびエミュレート VC に転送。


) これはローカルでのみ意味を持つため、VPLS ドメインを識別する逆多重化 VLAN タグは、出力イーサネット インターフェイスまたはエミュレート VC にパケットを転送する前に削除されます。


VPLS のデフォルト設定

なし。

VPLS の設定方法

「CE への PE レイヤ 2 インターフェイスの設定」

「PE でのレイヤ 2 VLAN インスタンスの設定」

「PE における MPLS の設定」

「PE における VFI の設定」

「PE での接続回線と VSI の関連付け」

「MPLS エッジでの H-VPLS」

「VPLS Integrated Routing and Bridging」

「マルチキャスト スヌーピング サポートの設定」


) • VPLS トラフィックの QoS を設定するには、QoS に関する章の手順を使用します。

VPLS リンクをプロビジョニングするには、関連する接続回線および VFI を PE にプロビジョニングする必要があります。


 

CE への PE レイヤ 2 インターフェイスの設定

「CE からタグ付きトラフィックを受け取る 802.1Q トランクの設定」

「CE からタグなしトラフィックを受け取る 802.1Q アクセス ポートの設定」

「すべての VLAN を単一の VPLS インスタンスに配置する Q-in-Q の設定」


) • トランク VLAN を定義することが重要です。最初の例に示すように switchport trunk vlan コマンドを使用します。

ローカル ブリッジングのスイッチポートとしてレイヤ 2 インターフェイスを設定する必要があります。CE デバイスからのタグなしトラフィックまたはタグ付きトラフィックを選択するオプションがあります。


 

CE からタグ付きトラフィックを受け取る 802.1Q トランクの設定


) EVCS が設定されている場合、PE ルータでは、宛先 MAC アドレスがレイヤ 2 転送テーブルにあれば、特定の VLAN タグを持つすべてのイーサネット パケットを、ローカル イーサネット インターフェイスまたはエミュレート VC に転送します。


 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface type number

設定するインターフェイスを選択します。

ステップ 2

Router(config)# no ip address ip_address mask [ secondary ]

IP 処理をディセーブルにして、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# switchport

レイヤ 2 スイッチド インターフェイスのスイッチング特性を変更します。

ステップ 4

Router(config-if)# switchport trunk encapsulation dot1q

スイッチ ポートのカプセル化形式を 802.1Q に設定します。

ステップ 5

Router(config-if)# switchport trunk allow vlan vlan_ID

許可 VLAN のリストを設定します。

ステップ 6

Router(config-if)# switchport mode trunk

トランキング VLAN レイヤ 2 インターフェイスへのインターフェイスを設定します。

次に、タグ付きトラフィックを設定する例を示します。

Router(config)# interface GigabitEthernet4/4
Router(config)# no ip address
Router(config-if)# switchport
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# switchport trunk allow vlan 501
Router(config-if)# switchport mode trunk
 

次に、show run interface コマンドを使用して設定を確認する例を示します。

Router# show run interface GigabitEthernet4/4
Building configuration...
 
Current configuration : 212 bytes
!
interface GigabitEthernet4/4
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 500-1999
switchport mode trunk
end

CE からタグなしトラフィックを受け取る 802.1Q アクセス ポートの設定

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface type number

設定するインターフェイスを選択します。

ステップ 2

Router(config)# no ip address ip_address mask [ secondary ]

IP 処理をディセーブルにして、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# speed [ 1000 | nonegotiate ]

イーサネット インターフェイスのポート速度を設定します。ギガビット イーサネット ポートでリンク ネゴシエーション プロトコルをイネーブルまたはディセーブルにします。

ステップ 4

Router(config-if)# switchport

レイヤ 2 スイッチド インターフェイスのスイッチング特性を変更します。

ステップ 5

Router(config-if)# switchport mode access

インターフェイスを、非トランキング、タグなし、シングル VLAN レイヤ 2 インターフェイス タイプとして設定します。

ステップ 6

Router(config-if)# switchport access vlan vlan_id

インターフェイスがアクセス モードのときに VLAN を設定します。

次に、タグなしトラフィックを設定する例を示します。

Router(config)# interface GigabitEthernet4/4
Router(config)# no ip address
Router(config-if)# speed nonegotiate
Router(config-if)# switchport
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 501
 

次に、show run interface コマンドを使用して設定を確認する例を示します。

Router# show run interface GigabitEthernet4/4
Building configuration...
 
Current configuration : 212 bytes
!
interface GigabitEthernet4/4
speed nonegotiate
switchport
switchport mode access
switchport access vlan 501
end

すべての VLAN を単一の VPLS インスタンスに配置する Q-in-Q の設定


) TLS を設定すると、MAC アドレスがレイヤ 2 転送テーブルにない場合、PE ルータでは、CE デバイスから受信したすべてのイーサネット パケットを、すべてのローカル イーサネット インターフェイスおよび同じ VPLS ドメインに属するエミュレート VC に転送します。


 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface type number

設定するインターフェイスを選択します。

ステップ 2

Router(config)# no ip address ip_address mask [ secondary ]

IP 処理をディセーブルにして、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# speed [ 1000 | nonegotiate ]

イーサネット インターフェイスのポート速度を設定します。ギガビット イーサネット ポートでリンク ネゴシエーション プロトコルをイネーブルまたはディセーブルにします。

ステップ 4

Router(config-if)# switchport

レイヤ 2 スイッチド インターフェイスのスイッチング特性を変更します。

ステップ 5

Router(config-if)# switchport access vlan vlan_id

インターフェイスがアクセス モードのときに VLAN を設定します。

ステップ 6

Router(config-if)# switchport mode dot1q-tunnel

インターフェイスを 802.1Q トンネル ポートとして設定します。

ステップ 7

Router(config-if)# l2protocol-tunnel [ cdp | stp | vtp ]

インターフェイスでプロトコル トンネリングをイネーブルにします。

次に、タグ付きトラフィックを設定する例を示します。

Router(config)# interface GigabitEthernet4/4
Router(config)# no ip address
Router(config-if)# speed nonegotiate
Router(config-if)# switchport
Router(config-if)# switchport access VLAN 501
Router(config-if)# switchport mode dot1q-tunnel
Router(config-if)# l2protocol-tunnel cdp
 

次に、show run interface コマンドを使用して設定を確認する例を示します。

Router# show run interface GigabitEthernet4/4
Building configuration...
 
Current configuration : 212 bytes
!
interface GigabitEthernet4/4
no ip address
speed nonegotiate
switchport
switchport access vlan 501
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
end
 

ポートがブロックされた状態にないことを確認するには、show spanning-tree vlan コマンドを使用します。

Router# show spanning-tree vlan 501
 
VLAN0501
Spanning tree enabled protocol ieee
Root ID Priority 33269
Address 0001.6446.2300
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
 
Bridge ID Priority 33269 (priority 32768 sys-id-ext 501)
Address 0001.6446.2300
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 0
 
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- --------
--------------------------------
Gi4/4 Desg FWD 4 128.388 P2p
 

特定の VLAN のトラフィックを送受信するように、特定のポートが設定されていることを確認するには、show vlan id コマンドを使用します。

Router# show vlan id 501
 
VLAN Name Status Ports
---- -------------------------------- ---------
501 VLAN0501 active Gi4/4
 
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1
Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------
501 enet 100501 1500 - - - - - 0 0
 
Remote SPAN VLAN
----------------
Disabled
 
Primary Secondary Type Ports
------- --------- -----------------

PE でのレイヤ 2 VLAN インスタンスの設定

PE にレイヤ 2 VLAN インターフェイスを設定すると、VLAN データベースへの PE ルータ上のレイヤ 2 VLAN インスタンスで、VPLS と VLAN 間のマッピングを設定できるようになります。

 

コマンドまたはアクション
目的

ステップ 1

vlan vlan-id

Router(config)# vlan 809

特定の仮想 LAN(VLAN)を設定します。

ステップ 2

interface vlan vlan-id

Router(config)# interface vlan 501

この VLAN にインターフェイスを設定します。

次に、レイヤ 2 VLAN インスタンスを設定する例を示します。

Router# config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# vlan 501
Router(config)# interface vlan 501
Router(config-if)#
 

VLAN がアップ状態であることを確認するには、show interfaces vlan コマンドを使用します(例示なし)。

PE における MPLS の設定

PE に MPLS を設定するには、必須 MPLS パラメータを指定する必要があります。


) MPLS を設定する前に、PE 間に Interior Gateway Protocol(IGP)(Open Shortes Path First(OSPF)または Intermediate System to Intermediate System(IS-IS))を設定にすることにより、すべての PE 間に IP 接続を設定してあることを確認します。


 

コマンドまたはアクション
目的

ステップ 1

enable

Router> enable

特権 EXEC モードをイネーブルにします。

パスワードを入力します(要求された場合)。

ステップ 2

configure terminal

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls label protocol {ldp | tdp}

Router(config)# mpls label protocol ldp

プラットフォームのデフォルト ラベル配布プロトコルを指定します。

ステップ 4

mpls ldp logging neighbor-changes

Router(config)# mpls ldp logging neighbor-changes

(任意)ネイバーの変更の記録を指定します。

ステップ 5

tag-switching tdp discovery {hello | directed hello} {holdtime | interval} seconds

Router(config)# tag-switching tdp discovery hello holdtime 5

Transmission of LDP(TDP)discovery hello メッセージの送信間隔、または LDP 転送接続のホールド タイムを設定します

ステップ 6

tag-switching tdp router-id Loopback0 force

Router(config)# tag-switching tdp router-id Loopback0 force

MPLS を設定します。

この例では、グローバルな MPLS の設定を示します。

Router(config)# mpls label protocol ldp
Router(config)# tag-switching tdp discovery directed hello
Router(config)# tag-switching tdp router-id Loopback0 force
 

LDP ラベルが割り当てられていることを確認するには、show ip cef コマンドを使用します。

 
Router# show ip cef 192.168.17.7
192.168.17.7/32, version 272, epoch 0, cached adjacency to POS4/1
0 packets, 0 bytes
tag information set
local tag: 8149
fast tag rewrite with PO4/1, point2point, tags imposed: {4017}
via 11.3.1.4, POS4/1, 283 dependencies
next hop 11.3.1.4, POS4/1
valid cached adjacency
tag rewrite with PO4/1, point2point, tags imposed: {4017}

PE における VFI の設定

仮想スイッチ インスタンス(VFI)は、VPLS ドメインの VPN ID、このドメインにある他の PE ルータのアドレス、および各ピアのトンネル シグナリングのタイプとカプセル化のメカニズムを指定します。(ここで、VSI および関連する VC を作成します)。VFI を次のように設定します。


) MPLS カプセル化だけがサポートされます。


 

コマンドまたはアクション
目的

ステップ 1

l2 vfi name manual

 

Router(config)# l2 vfi vfi17 manual

レイヤ 2 VFI 手動コンフィギュレーション モードをイネーブルにします。

ステップ 2

vpn id vpn-id

 

Router(config-vfi)# vpn id 17

VPLS ドメインの VPN ID を設定します。このレイヤ 2 VRF にバインドされたエミュレート VC では、シグナリングにこの VPN ID を使用します。

ステップ 3

neighbor remote router id {encapsulation mpls} [no-split-horizon]

 

Router(config-vfi)# neighbor 1.5.1.1 encapsulation mpls

リモート ピアリング ルータ ID と、エミュレート VC をセット アップするために使用されるトンネル カプセル化タイプまたは疑似配線プロパティを指定します。

(注) ブロードキャスト パケットのループを回避し、レイヤ 2 トラフィックを分離するために、スプリット ホライズンが、デフォルト設定です。スプリット ホライズンをディセーブルにし、スポークごとに複数の VC を同じ VFI に設定するには、no-split-horizon キーワードを使用します。

ステップ 4

shutdown

 

Router(config-vfi)# shutdown

レイヤ 2 VFI の下にこれまで確立されていたすべてのエミュレート VC を切断して、新しい接続回線の確立を防止します。

(注) これは、CLI を使用してレイヤ 2 VFI が設定された新しい接続回線の確立を防止しません。

次に、VFI の設定例を示します。

Router(config)# l2 vfi VPLSA manual
Router(config-vfi)# vpn id 100
Router(config-vfi)# neighbor 11.11.11.11 encapsulation mpls
Router(config-vfi)# neighbor 33.33.33.33 encapsulation mpls
Router(config-vfi)# neighbor 44.44.44.44 encapsulation mpls

 

次に、ハブ アンド スポークの VFI の設定例を示します。

Router(config)# l2 vfi VPLSA manual
Router(config-vfi)# vpn id 100
Router(config-vfi)# neighbor 9.9.9.9 encapsulation mpls
Router(config-vfi)# neighbor 12.12.12.12 encapsulation mpls
Router(config-vfi)# neighbor 33.33.33.33 encapsulation mpls no-split-horizon

 

show mpls 12transport vc コマンドは、PE1 に関連するさまざまな情報を表示します。


) show mpls l2transport vc [detail] コマンドは、次の例のように、PE ルータ上の VC に関する詳細を表示するためにも使用できます。


VPLS-PE2# show mpls l2transport vc 201
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
VFI test1 VFI 153.1.0.1 201 UP
VFI test1 VFI 153.3.0.1 201 UP
VFI test1 VFI 153.4.0.1 201 UP
 

) 出力の VC ID は VPN ID を表します。VC は、次の例で示すように、宛先アドレスと VC ID の組み合わせによって識別されます。


show vfi vfi name コマンドは、VFI の状態を表示します。

nPE-3# show vfi VPLS-2
VFI name: VPLS-2, state: up
Local attachment circuits:
Vlan2
Neighbors connected via pseudowires:
Peer Address VC ID Split-horizon
1.1.1.1 2 Y
1.1.1.2 2 Y
2.2.2.3 2 N

PE での接続回線と VSI の関連付け

VFI を定義したら、1 つ以上の接続回線(インターフェイス、サブインターフェイス、または仮想回線)にバインドする必要があります。

 

コマンドまたはアクション
目的

ステップ 1

interface vlan vlan-id

Router(config-if)# interface vlan 100

動的なスイッチ仮想インターフェイス(SVI)を作成するか、使用します。

ステップ 2

no ip address

Router(config-if)# no ip address

IP 処理をディセーブルにします。(IP アドレスを設定する場合は、VLAN のレイヤ 3 インターフェイスを設定します)。

ステップ 3

xconnect vfi vfi name

Router(config-if)# xconnect vfi vfi16

VLAP ポートにバインドするレイヤ 2 VFI を指定します。

この例は、インターフェイス VLAN コンフィギュレーションを示します。

Router(config-if)# interface vlan 100
Router(config-if)# no ip address
Router(config-if)# xconnect vfi VPLS_501
 

VFI ステータスを確認するには、show vfi コマンドを使用します。

Router# show vfi VPLS_501
VFI name: VPLS_501, state: up
Local attachment circuits:
vlan 100
Neighbors connected via pseudowires:
192.168.11.1 192.168.12.2 192.168.13.3 192.168.16.6
192.168.17.7

MPLS エッジでの H-VPLS

「概要」

「PE1 の設定」

「PE2 の設定」

「PE3 の設定」

概要

階層型 VPLS のモデルは、ハブ アンド スポークとフルメッシュ ネットワークで構成されます。フル メッシュ コンフィギュレーションでは、各 PE ルータは、VFI を使用して VPLS ドメインの他のすべての PE ルータとのマルチポイントツーマルチポイント転送関係を作成します。

ハブ アンド スポーク構成では、PE ルータは、VLAN にレイヤ 2 ポートを追加する必要なしで VC 間接続を実現する、非スプリットホライズン モードで動作できます。

次の例では、CE1、CE2、CE3、CE4 の VLAN(赤色)は、フルメッシュ ネットワークを介して接続します。CE2、CE5 および ISP POP 上の VLAN は、ISP POP がハブで、CE2 と CE5 がスポークである、ハブ アンド スポーク ネットワークを介して接続します。図 39-2に設定例を示します。

図 39-2 H-VPLS 設定

 

VSI および VC の設定

次に、仮想スイッチ インスタンス(VSI)と関連する VC を作成する設定例を示します。緑色の VC では、no split-horizon キーワードが必要であることに注意してください。no split-horizon コマンドは、データ パスでのデフォルトのレイヤ 2 スプリット ホライズンをディセーブルにします。

l2 vfi Internet manual
vpn id 100
neighbor 120.0.0.3 encapsulation mpls no-split-horizon
neighbor 162.0.0.2 encapsulation mpls no-split-horizon
 
l2 vfi PE1-VPLS-A manual
vpn id 200
neighbor 120.0.0.3 encapsulation mpls
neighbor 162.0.0.2 encapsulation mpls
 
interface Loopback 0
ip address 20.0.0.1 255.255.255.255

CE デバイス インターフェイスの設定

この設定例は、CE デバイス インターフェイスを示します(単一の VLAN に複数のレイヤ 2 インターフェイスがある場合があります)。

interface GigEthernet1/1
switchport
switchport mode trunk
switchport trunk encap dot1q
switchport trunk allow vlan 1001,1002-1005

接続回線と VFI の関連付け

次の設定例は、接続回線(VLAN)を VFI に関連付ける方法を示します。

interface Vlan 1001
xconnect vfi Internet
 
interface FastEthernet2/1
switchport
switchport mode trunk
switchport trunk encap dot1q
switchport trunk allow vlan 211,1002-1005
 
interface Vlan 211
xconnect vfi PE1-VPLS-A

VSI および VC の設定

次に、仮想スイッチ インスタンス(VSI)と関連する VC を作成する設定例を示します。

l2 vfi Internet manual
vpn id 100
neighbor 20.0.0.1 encapsulation mpls
 
l2 vfi PE2-VPLS-A manual
vpn id 200:1
neighbor 120.0.0.3 encapsulation mpls
neighbor 20.0.0.1 encapsulation mpls
 
interface Loopback 0
ip address 162.0.0.2 255.255.255.255

CE デバイス インターフェイスの設定

この設定例は、CE デバイス インターフェイスを示します(単一の VLAN に複数のレイヤ 2 インターフェイスがある場合があります)。

interface GigEthernet2/1
switchport
switchport mode trunk
switchport trunk encap dot1q
switchport trunk allow vlan 211,1001,1002-1005

接続回線と VFI の関連付け

次の設定例は、接続回線(VLAN)を VFI に関連付ける方法を示します。

interface Vlan 1001
xconnect vfi Internet
 
interface Vlan 211
xconnect vfi PE2-VPLS-A

VSI および VC の設定

次に、仮想スイッチ インスタンス(VSI)と関連する VC を作成する設定例を示します。

l2 vfi Internet manual
vpn id 100
neighbor 20.0.0.1 encapsulation mpls
neighbor 162.0.0.2 encapsulation mpls
neighbor 30.0.0.1 encapsulation mpls no-split horizon
 
l2 vfi PE3-VPLS-A manual
vpn id 200
neighbor 162.0.0.2 encapsulation mpls
neighbor 20.0.0.1 encapsulation mpls
 
interface Loopback 0
ip address 120.0.0.3 255.255.255.255

CE デバイス インターフェイスの設定

この設定例は、CE デバイス インターフェイスを示します(単一の VLAN に複数のレイヤ 2 インターフェイスがある場合があります)。

interface GigEthernet6/1
switchport
switchport mode trunk
switchport trunk encap dot1q
switchport trunk allow vlan 211

接続回線の設定

この設定例は、接続回線を示します。

interface Vlan 1001
xconnect vfi Internet
 
interface Vlan 211
xconnect vfi PE3-VPLS-A

uPE デバイスでのポート ベース EoMPLS の設定

この設定例では、uPE デバイスでのポート ベース EoMPLS を示します。

interface GigEthernet 1/1
xconnect 120.0.0.3 100 encapsulation mpls

VPLS Integrated Routing and Bridging

VPLS Integrated Routing and Bridging は、レイヤ 3 トラフィックをルーティングできる他、仮想プライベート LAN サービス(VPLS)マルチポイント PE を使用して、プロバイダー エッジ(PE)デバイス間の疑似配線接続のためにレイヤ 2 フレームをスイッチングできます。フレームをこれらのインターフェイスとの間でルーティングできる機能は、同じスイッチ上のレイヤ 3 ネットワーク(VPN またはグローバル)への疑似配線の終了、またはレイヤ 2 トンネルを介したレイヤ 3 フレームのトンネリング(VPLS)をサポートします。


) • VPLS Integrated Routing and Bridging は、ルーテッド疑似配線およびルーテッド VPLS とも呼ばれます。

VPLS Integrated Routing and Bridging では、マルチキャスト ルーティングをサポートしていません。


 

疑似配線のルーティング サポートを設定するには、仮想 LAN(VLAN)インターフェイス設定のレイヤ 3 ドメイン(VPN またはグローバル)の IP アドレスおよびその他のレイヤ 3 機能を設定します。

次に、IP アドレス 10.10.10.1 を VLAN 100 インターフェイスに割り当てる例を示します。(レイヤ 2 フォワーディングは VFI VFI100 によって定義されます)。

interface vlan 100
xconnect vfi VFI100
ip address 10.10.10.1 255.255.255.0
 

次の例では、VPN ドメイン VFI200 の IP アドレス 20.20.20.1 を割り当てます。(レイヤ 2 フォワーディングは VFI VFI200 によって定義されます)。

interface vlan 200
xconnect vfi VFI200
ip vrf forwarding VFI200
ip address 20.20.20.1 255.255.255.0

マルチキャスト スヌーピング サポートの設定

リリース 15.1(1)SY1 以降のリリースでは、IGMP スヌーピングおよび PIM スヌーピングにより、H-VPLS または Integrated Routing and Bridging(IRB)の場合を除く、VPLS マルチキャスト トラフィックが抑制されます。この機能は、「VPLS PIM and IGMP Snooping (LAN Interfaces)」として Cisco Feature Navigator に表示されます。

VPLS トラフィックでマルチキャスト トラフィックを受信するためには、非 mrouter の PE を含むすべての PE に、レイヤ 2 マルチキャスト エントリを作成する必要があります。マルチキャスト スヌーピングでは、ローカルで受信したすべての IGMP レポートをすべてのピアにフラッディングできます。

リモート ピアから受信した IGMP レポートや、IGMP スヌーピングによって生成されたレポートなど、ローカルで受信しなかった IGMP レポートを、すべてのピアに対してフラッディングすることはありません。IGMP 脱退、マルチキャスト トラフィックは、レイヤ 2 マルチキャスト エントリがタイムアウトするまで停止しないことがあります。

マルチキャスト スヌーピングのサポートは、 platform multicast snooping flood-to-peer コマンドによってデフォルトでイネーブルになっています。

VPLS の設定例

フルメッシュ コンフィギュレーションでは、各 PE ルータは、VFI を使用して VPLS ドメインの他のすべての PE ルータとのマルチポイントツーマルチポイント転送関係を作成します。カスタマー ネットワークから受信したイーサネット パケットまたは VLAN パケットは、1 つ以上のローカル インターフェイスおよび(または)VPLS ドメインのエミュレート VC に転送できます。ネットワークでのブロードキャスト パケットのループを回避するために、エミュレート VC から受信したパケットは、PE ルータの VPLS ドメイン内のどのエミュレート VC にも転送できません。つまり、レイヤ 2 スプリット ホライズンは、フルメッシュ ネットワークでデフォルトとして常にイネーブルにする必要があります。

図 39-3 VPLS の設定例

 

PE 1 の設定

これは、仮想スイッチ インスタンス(VSI)と関連する VC の作成を示します。

l2 vfi PE1-VPLS-A manual
vpn id 100
neighbor 2.2.2.2 encapsulation mpls
neighbor 3.3.3.3 encapsulation mpls
!
interface Loopback 0
ip address 1.1.1.1 255.255.255.255
 

これは、CE デバイス インターフェイスを設定します(単一の VLAN に複数のレイヤ 2 インターフェイスがある場合があります)。

interface FastEthernet0/0
switchport
switchport mode dot1qtunnel
switchport access vlan 100
 

ここで、接続回線(VLAN)は、VSI に関連付けられます。

interface vlan 100
no ip address
xconnect vfi PE1-VPLS-A
 

これは、レイヤ 2 VLAN インスタンスをイネーブルにします。

vlan 100
state active

PE 2 の設定

これは、仮想スイッチ インスタンス(VSI)と関連する VC の作成を示します。

l2 vfi PE2-VPLS-A manual
vpn id 100
neighbor 1.1.1.1 encapsulation mpls
neighbor 3.3.3.3 encapsulation mpls
!
interface Loopback 0
ip address 2.2.2.2 255.255.255.255
 

これは、CE デバイス インターフェイスを設定します(単一の VLAN に複数のレイヤ 2 インターフェイスがある場合があります)。

interface FastEthernet0/0
switchport
switchport mode dot1qtunnel
switchport access vlan 100
 

ここで、接続回線(VLAN)は、VSI に関連付けられます。

interface vlan 100
no ip address
xconnect vfi PE2-VPLS-A
 

これは、レイヤ 2 VLAN インスタンスをイネーブルにします。

vlan 100
state active

PE 3 の設定

これは、仮想スイッチ インスタンス(VSI)と関連する VC の作成を示します。

l2 vfi PE3-VPLS-A manual
vpn id 100
neighbor 1.1.1.1 encapsulation mpls
neighbor 2.2.2.2 encapsulation mpls
!
interface Loopback 0
ip address 3.3.3.3 255.255.255.255
 

これは、CE デバイス インターフェイスを設定します(単一の VLAN に複数のレイヤ 2 インターフェイスがある場合があります)。

interface FastEthernet0/1
switchport
switchport mode dot1qtunnel
switchport access vlan 100
!

ここで、接続回線(VLAN)は、VSI に関連付けられます。

interface vlan 100
no ip address
xconnect vfi PE3-VPLS-A .
!

これは、レイヤ 2 VLAN インスタンスをイネーブルにします。

vlan 100
state active
 

show mpls l2 vc コマンドは、VC のステータス情報を表示します。

VPLS1# show mpls l2 vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Vi1 VFI 22.22.22.22 100 DOWN
Vi1 VFI 22.22.22.22 200 UP
Vi1 VFI 33.33.33.33 100 UP
Vi1 VFI 44.44.44.44 100 UP
Vi1 VFI 44.44.44.44 200 UP
 

show vfi コマンドは VFI に関する情報を表示します。

PE-1# show vfi PE1-VPLS-A
VFI name: VPLSA, state: up
Local attachment circuits:
Vlan100
Neighbors connected via pseudowires:
2.2.2.2 3.3.3.3
 

show mpls 12transport vc コマンドは、仮想回線に関する情報を表示します。

Router# show mpls l2 vc det
Local interface: VFI vfi17 up
Destination address: 1.3.1.1, VC ID: 17, VC status: up
Tunnel label: imp-null, next hop point2point
Output interface: PO3/4, imposed label stack {18}
Create time: 3d15h, last status change time: 1d03h
Signaling protocol: LDP, peer 1.3.1.1:0 up
MPLS VC labels: local 18, remote 18
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, send 0

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する