Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.1SY
ローカル SPAN、RSPAN、および ERSPAN
ローカル SPAN、RSPAN、および ERSPAN
発行日;2013/08/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

ローカル SPAN、RSPAN、および ERSPAN

ローカル SPAN、RSPAN、および ERSPAN の前提条件

ローカル SPAN、RSPAN、および ERSPAN の制約事項

機能の非互換性

ローカル SPAN、RSPAN、および ERSPAN セッションの制限

ローカル SPAN、RSPAN、および ERSPAN インターフェイスの制限

ローカル SPAN、RSPAN、および ERSPAN の一般的な制約事項

VSPAN の制約事項

RSPAN の制約事項

ERSPAN の制約事項

分散型出力 SPAN モードの制約事項

ローカル SPAN、RSPAN、および ERSPAN について

ローカル SPAN、RSPAN、および ERSPAN の概要

SPAN の操作

ローカル SPAN の概要

RSPAN の概要

ERSPAN の概要

SPAN 送信元でのトラフィックのモニタリング

ローカル SPAN、RSPAN、および ERSPAN の送信元

送信元ポートと EtherChannel

送信元 VLAN

ローカル SPAN、RSPAN、および ERSPAN の宛先

ローカル SPAN、RSPAN、および ERSPAN のデフォルト設定

ローカル SPAN、RSPAN、および ERSPAN の設定方法

無条件トランクとしての宛先ポートの設定(任意)

宛先トランクの VLAN フィルタリングの設定(任意)

宛先ポートの許可リストの設定(任意)

出力 SPAN モードの設定(任意)

ローカル SPAN の設定

ローカル SPAN の設定(SPAN コンフィギュレーション モード)

ローカル SPAN の設定(グローバル コンフィギュレーション モード)

RSPAN の設定

RSPAN VLAN の設定

RSPAN セッションの設定(SPAN コンフィギュレーション モード)

RSPAN セッションの設定(グローバル コンフィギュレーション モード)

ERSPAN の設定

ERSPAN 送信元セッションの設定

ERSPAN 宛先セッションの設定

グローバル コンフィギュレーション モードでの送信元 VLAN フィルタリングの設定

SPAN の設定確認

SPAN のコンフィギュレーション例

ローカル SPAN、RSPAN、および ERSPAN

「ローカル SPAN、RSPAN、および ERSPAN の前提条件」

「ローカル SPAN、RSPAN、および ERSPAN の制約事項」

「ローカル SPAN、RSPAN、および ERSPAN について」

「ローカル SPAN、RSPAN、および ERSPAN のデフォルト設定」

「ローカル SPAN、RSPAN、および ERSPAN の設定方法」

「SPAN の設定確認」

「SPAN のコンフィギュレーション例」


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。


 

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する


 

ローカル SPAN、RSPAN、および ERSPAN の前提条件

なし。

ローカル SPAN、RSPAN、および ERSPAN の制約事項

「機能の非互換性」

「ローカル SPAN、RSPAN、および ERSPAN セッションの制限」

「ローカル SPAN、RSPAN、および ERSPAN インターフェイスの制限」

「ローカル SPAN、RSPAN、および ERSPAN の一般的な制約事項」

「VSPAN の制約事項」

「RSPAN の制約事項」

「ERSPAN の制約事項」

「分散型出力 SPAN モードの制約事項」

機能の非互換性

出力 SPAN は出力マルチキャスト モードではサポートされていません。(CSCsa95965)。

不明なユニキャストフラッディングのブロック(UUFB)ポートは、RSPAN またはローカル SPAN 出力専用宛先として使用できません (CSCsj27695)。

ポートチャネル インターフェイス(EtherChannel)は SPAN 送信元として使用できますが、EtherChannel のアクティブなメンバ ポートを SPAN 送信元ポートとして設定することはできません。EtherChannel の非アクティブ メンバ ポートは SPAN 送信元として設定できますが、これらのポートは中断ステートになり、トラフィックを伝送しません。

次の機能は、SPAN 宛先との互換性がありません。

プライベート VLAN

IEEE 802.1x ポートベースの認証

ポート セキュリティ

スパニングツリー プロトコル(STP)および関連機能(PortFast、PortFast BPDU フィルタリング、BPDU ガード、UplinkFast、BackboneFast、EtherChannel ガード、ルート ガード、ループ ガード)

VLAN トランキング プロトコル(VTP)

ダイナミック トランキング プロトコル(DTP)

IEEE 802.1Q トンネリング

dot1ad uni コマンド(を参照)は、次の SPAN の制約事項を適用します。

dot1ad uni コマンドでは 出力 SPAN の設定を制限しません。

dot1ad uni コマンドは、RSPAN の 入力 SPAN 送信元ポートの設定を制限しませんが、送信元 VLAN フィルタリング、 dot1ad uni コマンドを使用して設定された RSPAN の入力 SPAN 送信元ポートからのトラフィックには適用されません。

dot1ad uni コマンドを使用して設定されたポートは、ローカル SPAN または ERSPAN の入力 SPAN 送信元ポートとして使用できません。


) • SPAN 宛先は、IEEE 802.3Z フロー制御に関与できます。

出力パケット レプリケーションを使用している IP マルチキャスト スイッチングは、SPAN との互換性がありません。一部の場合、出力レプリケーションでは、SPAN 宛先ポートにマルチキャスト パケットが送信されない結果となることがあります。SPAN を使用していて、スイッチング モジュールが出力レプリケーションに対応している場合、出力レプリケーションを強制するには、 platform ip multicast replication-mode ingress コマンドを入力します。


 

ローカル SPAN、RSPAN、および ERSPAN セッションの制限

 

総セッション数
ローカル セッションと送信元セッション
宛先セッション
ローカル SPAN、
RSPAN 送信元、
ERSPAN 送信元
入力と出力のどちらか、または両方
ローカル SPAN の出力のみ
RSPAN
ERSPAN

80

2

14

64

23

ローカル SPAN、RSPAN、および ERSPAN インターフェイスの制限

 

 
ローカル SPAN セッションごと
RSPAN 送信元セッションごと
ERSPAN 送信元セッションごと
RSPAN 宛先セッションごと
ERSPAN 宛先セッションごと

出力または「両方」の送信元

128

128

128

--

--

入力送信元

128

128

128

--

--

RSPAN および ERSPAN 宛先セッションの送信元

--

--

--

1 RSPAN VLAN

1 IP アドレス

セッションごとの宛先

64

1 RSPAN VLAN

1 IP アドレス

64

64

ローカル SPAN、RSPAN、および ERSPAN の一般的な制約事項

1 つの出力 SPAN 送信元ポートからトラフィックをコピーした SPAN の宛先は、出力トラフィックだけをネットワーク アナライザに送信します。複数の出力 SPAN 送信元ポートを設定している場合、ネットワーク アナライザに送信されるトラフィックに、出力 SPAN 送信元ポートから受信した特定タイプの入力トラフィックも含まれます。この入力トラフィックのタイプは次のとおりです。

VLAN 上でフラッディングしたすべてのユニキャスト トラフィック

ブロードキャストおよびマルチキャスト トラフィック

この状況が発生するのは、出力 SPAN 送信元ポートがこれらのトラフィック タイプを VLAN から受信したあと、自身がトラフィックの送信元であることを認識し、受信したトラフィックの送信元にこのトラフィックを返送せず、ドロップしてしまうためです。SPAN はドロップする前にこのトラフィックをコピーし、SPAN の宛先に送信します。(CSCds22021)

再び monitor session コマンドを入力しても、前に設定した SPAN パラメータを消去しません。設定済みの SPAN パラメータを消去するには、 no monitor session コマンドを使用する必要があります。

ネットワーク アナライザを SPAN 宛先に接続します。

SPAN セッション内では、すべての SPAN の宛先は、すべてのトラフィックをすべての SPAN 送信元から受信します。ただし、送信元 VLAN フィルタリングが SPAN の送信元に設定されている場合を除きます。

SPAN の宛先から送信されるトラフィックを選択するよう、宛先トランク VLAN フィルタリングを設定できます。

レイヤ 2 LAN ポート( switchport コマンドで設定された LAN ポート)とレイヤ 3 LAN ポート( switchport コマンドを使用せずに設定された LAN ポート)の両方を送信元または宛先として設定できます。

1 つのセッションに、個別の送信元ポートおよび送信元 VLAN を混在させることはできません。

複数の入力送信元ポートを指定する場合、各ポートはそれぞれ異なる VLAN に属するものであってもかまいません。

セッション内では、VLAN を SPAN 送信元として設定することと、送信元 VLAN フィルタリングを行うことの、両方を設定することはできません。VLAN を SPAN 送信元として設定するか、または、送信元ポートおよび EtherChannel からのトラフィックの送信元 VLAN フィルタリングを行うことはできますが、同じセッションで両方を行うことはできません。

内部 VLAN に対し、送信元 VLAN フィルタリングは設定できません。

イネーブルなローカル SPAN、RSPAN、および ERSPAN は、すでに入力された設定があれば、その設定を使用します。

送信元を指定し、トラフィックの方向(入力、出力、または両方)を指定しない場合、「両方」がデフォルトで使用されます。

SPAN は、レイヤ 2 イーサネット フレームをコピーしますが、SPAN は送信元トランク ポート 802.1Q タグをコピーしません。宛先をトランクとして設定し、タグ付きトラフィックをトラフィック アナライザにローカルに送信できます。


) トランクとして設定した宛先は、レイヤ 3 LAN 送信元からのトラフィックを、レイヤ 3 LAN 送信元によって使用される内部 VLAN としてタグを付けます。


ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートから送信元 RSPAN VLAN トラフィックをローカルにコピーしません。

ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションは、送信元ポートからローカルに送信された ERSPAN GRE カプセル化トラフィックをコピーしません。

ポートまたは EtherChannel は、1 つの SPAN セッションでのみ SPAN の宛先にできます。SPAN セッションは、共有の宛先にはできません。

SPAN の宛先は、SPAN の送信元にはできません。

宛先は、スパニングツリー インスタンスには関与しません。ローカル SPAN はモニタ対象トラフィックに BPDU を含めます。したがってモニタリングの宛先で確認される BPDU は、送信元から送られたものです。RSPAN は BPDU モニタリングをサポートしません。

出力 SPAN 送信元として設定されているポートからの伝送用にスイッチを経由して転送されるすべてのパケットは、SPAN 宛先にコピーされます。このパケットには、STP が出力ポートをブロッキング ステートにするため出力ポート経由でスイッチから送出されないパケットや、STP が VLAN をトランク ポートでブロッキング ステートに移行するので、出力トランク ポートにあるパケットが含まれます。

VSPAN の制約事項


) ローカル SPAN、RSPAN、および ERSPAN は、すべて VSPAN をサポートします。


VSPAN セッションは、送信元 VLAN フィルタリングをサポートしません。

入力および出力の両方が設定されている VSPAN セッションについては、2 つのパケットが同じ VLAN でスイッチングされている場合、それらは宛先から(1 つは入力ポートからの入力トラフィックとして、もう 1 つは出力ポートからの出力トラフィックとして)アナライザへ転送されます。

VSPAN は、VLAN 内のレイヤ 2 ポートを出入りするトラフィックだけをモニタします。

VLAN を入力送信元として設定し、トラフィックがモニタ対象 VLAN にルーティングされる場合、ルーティングされたトラフィックは、VLAN 内のレイヤ 2 ポートで受信する入力トラフィックとして見なされないため、モニタされません。

VLAN を出力送信元として設定し、トラフィックがモニタ対象 VLAN からルーティングされる場合、ルーティングされたトラフィックは、VLAN 内のレイヤ 2 ポートから送信される出力トラフィックとして見なされないため、モニタされません。

RSPAN の制約事項

参加しているすべてのスイッチは、レイヤ 2 トランクによって接続されている必要があります。

RSPAN VLAN をサポートするネットワーク デバイスは、RSPAN 中間デバイスとすることができます。

ネットワークが伝送する RSPAN VLAN の数に制限はありません。

中間ネットワーク デバイスでは、サポートできる RSPAN VLAN の数が制限される場合があります。

すべての送信元、中間、宛先ネットワーク デバイスにおいて、RSPAN VLAN を設定しなければなりません。VLAN トランキング プロトコル(VTP)がイネーブルの場合、1 ~ 1024 の番号が付いた VLAN の設定を RSPAN VLAN として伝播できます。1024 より大きい番号の VLAN は、すべての送信元、中間、および宛先ネットワーク デバイスで、RSPAN VLAN として手動で設定する必要があります。

VTP および VTP プルーニングをイネーブルにすると、RSPAN トラフィックはトランクでプルーニングされて、RSPAN トラフィックがネットワーク全体に不必要にフラッディングするのを防ぎます。

RSPAN VLAN は、RSPAN トラフィックに対してだけ使用できます。

管理トラフィックを伝送するのに使用する VLAN を、RSPAN VLAN として設定しないでください。

アクセス ポートを RSPAN VLAN に割り当てないでください。RSPAN は、RSPAN VLAN 中のアクセス ポートを中断ステートにします。

RSPAN VLAN 内の RSPAN トラフィックの伝送用に選択されたトランク ポート以外のポートは設定しないでください。

MAC アドレス ラーニングは、RSPAN VLAN 上でディセーブルです。

RSPAN 送信元スイッチの RSPAN VLAN 上にある出力アクセス コントロール リスト(ACL)を使用して、RSPAN 宛先へ送信されるトラフィックをフィルタリングできます。

RSPAN は BPDU モニタリングをサポートしません。

RSPAN VLAN を VSPAN セッション中の送信元として設定しないでください。

すべての関与しているネットワーク デバイスが RSPAN VLAN の設定をサポートし、すべての関与しているネットワーク デバイスで各 RSPAN セッションに対して同じ RSPAN VLAN を使用する限り、VLAN を RSPAN VLAN として設定できます。

ERSPAN の制約事項

ERSPAN パケットでは、GRE ヘッダー内の「protocol type」フィールドの値は 0x88BE です。

レイヤ 3 ERSPAN パケットのペイロードは、コピーされたレイヤ 2 イーサネット フレームからすべての 802.1Q タグを取り除いたものです。

ERSPAN は、コピーされた個々のレイヤ 2 イーサネット フレームに 50 バイトのヘッダーを追加し、4 バイトの巡回冗長検査(CRC)トレーラーと置き換えます。

ERSPAN は、最大 9,202 バイトのレイヤ 3 パケットを保持するジャンボ フレームをサポートします。コピーされたレイヤ 2 イーサネット フレームの長さが 9,170(9,152 バイトのレイヤ 3 パケット)を超える場合は、ERSPAN はコピーされたレイヤ 2 イーサネット フレームを切り捨て、9,202 バイトの ERSPAN レイヤ 3 パケットを作成します。


) 切り捨てられたパケットのレイヤ 3 IP ヘッダーは切り捨てられていないレイヤ 3 パケットのサイズを保持します。6500 である ERSPAN 宛先のレイヤ 2 フレームとレイヤ 3 パケット間の長さの整合性検査は、ERSPAN 宛先 6500 スイッチで no platform verify ip length consistent グローバル コンフィギュレーション コマンドを設定しない限り、切り捨てられた ERSPAN パケットをドロップします。


設定された MTU サイズとは関係なく、ERSPAN は最長 9,202 バイトのレイヤ 3 パケットを作成します。ERSPAN トラフィックは、MTU サイズを 9,202 バイト未満に規定しているネットワーク内のインターフェイスによってドロップされる可能性があります。

デフォルトの MTU サイズ(1,500 バイト)の場合、コピーされたレイヤ 2 イーサネット フレームの長さが 1,468 バイト(1,450 バイトのレイヤ 3 パケット)を超えると、MTU サイズを 1,500 バイトに規定しているネットワーク内のインターフェイスによって ERSPAN トラフィックがドロップされます。


mtu インターフェイス コマンド、および system jumbomtu コマンド(を参照)は、レイヤ 3 パケットの最大サイズを設定します(デフォルト値は 1,500 バイト、最大値は 9,216 バイト)。


参加しているすべてのスイッチはレイヤ 3 に接続されている必要があり、ネットワーク パスが ERSPAN トラフィックのサイズをサポートしている必要があります。

ERSPAN はパケット分割をサポートしません。ERSPAN パケットの IP ヘッダー内には、「do not fragment」ビットが設定されます。ERSPAN 宛先セッションでは、分割された ERSPAN パケットを再構成できません。

ERSPAN トラフィックは、ネットワークのトラフィック負荷条件の影響を受けます。ERSPAN パケットの IP precedence または DSCP 値を設定することで、QoS において ERSPAN トラフィックを優先できます。

ERSPAN トラフィックでサポートされる唯一の宛先は、ERSPAN 宛先セッションです。

スイッチ上のすべての ERSPAN 送信元セッションには、同一の起点 IP アドレスを使用する必要があります。これは、 origin ip address コマンドで設定します(「ERSPAN 送信元セッションの設定」を参照)。

スイッチ上のすべての ERSPAN 宛先セッションは、同じ宛先インターフェイス上の同一の IP アドレスを使用する必要があります。宛先インターフェイスの IP アドレスは、 ip address コマンドを使用して入力します(「ERSPAN 宛先セッションの設定」を参照)。

ERSPAN 送信元セッションの宛先 IP アドレス(宛先スイッチのインターフェイス上で設定する必要がある)は、ERSPAN 宛先セッションが宛先ポートまで送信するトラフィックの送信元です。 ip address コマンドを使用して、送信元セッションおよび宛先セッションの両方に同一のアドレスを設定します。

ERSPAN ID は、さまざまな ERSPAN 送信元セッションから送られ、同一の宛先 IP アドレスに到着した ERSPAN トラフィックを区別します。

分散型出力 SPAN モードの制約事項

一部のスイッチング モジュールには、ERSPAN 送信元に対する分散型出力 SPAN モードをサポートしない ASIC があります。

ERSPAN 送信元に対して分散型出力 SPAN モードをサポートしないスイッチング モジュールのスロット番号を表示するには、 show monitor session egress replication-mode | include Distributed.*Distributed.*Centralized コマンドを入力します。

ERSPAN 送信元に対して分散型出力 SPAN モードがサポートされないスロットにあるスイッチング モジュールの ASIC のバージョンを表示するには、 show asic-version slot slot_number コマンドを入力します。

Hyperion ASIC バージョン レベル 5.0 以上および Metropolis ASIC のすべてのバージョンは、ERSPAN 送信元に対する分散型出力 SPAN モードをサポートします。Hyperion ASIC バージョン レベル 5.0 未満のスイッチング モジュールは、ERSPAN 送信元に対する分散型出力 SPAN モードをサポートしません。

ローカル SPAN、RSPAN、および ERSPAN について

「ローカル SPAN、RSPAN、および ERSPAN の概要」

「ローカル SPAN、RSPAN、および ERSPAN の送信元」

「ローカル SPAN、RSPAN、および ERSPAN の宛先」

SPAN の操作

SPAN は、1 つ以上のポート、1 つ以上の EtherChannel、または 1 つ以上の VLAN からトラフィックをコピーし、SwitchProbe デバイスまたは他の Remoter Monitoring(RMON)プローブなどのネットワーク アナライザが分析できるように、1 つ以上の宛先にコピーしたトラフィックを送信します。トラフィックは、 で説明されているように、ミニ プロトコル アナライザでパケットをキャプチャするために送信することもできます。

SPAN は、送信元上のトラフィックのスイッチングには影響しません。その宛先は、SPAN 専用に設定する必要があります。SPAN が生成したトラフィックのコピーは、送信元スイッチのユーザ トラフィックと競合します。

ローカル SPAN の概要

ローカル SPAN セッションは、送信元ポートおよび送信元 VLAN を、1 つまたは複数の宛先に対応付けたものです。ローカル SPAN セッションは、単一スイッチの上に設定します。ローカル SPAN には、個別の送信元および宛先のセッションはありません。

ローカル SPAN セッションは、RSPAN VLAN を伝送する送信元トランク ポートから送信元 RSPAN VLAN トラフィックをローカルにコピーしません。ローカル SPAN セッションは、送信元ポートからローカルに送信された RSPAN VLAN GRE(総称ルーティング カプセル化)カプセル化トラフィックをコピーしません。

ローカル SPAN セッションごとに、送信元としてポートまたは VLAN を使用することはできますが、両方は使用できません。

ローカル SPAN は、任意の VLAN 上の 1 つまたは複数の送信元ポートからのトラフィック、あるいは 1 つまたは複数の VLAN からのトラフィックを分析するために宛先へコピーします(図 56-1 を参照)。たとえば図 56-1 の場合、イーサネット ポート 5(送信元ポート)上の全トラフィックが、イーサネット ポート 10 にコピーされます。イーサネット ポート 10 のネットワーク アナライザは、イーサネット ポート 5 に物理的に接続していなくても、このポートからのあらゆるトラフィックを受信できます。

図 56-1 SPAN の設定例

 

RSPAN の概要

RSPAN は、さまざまなスイッチ上の送信元ポート、送信元 VLAN、および宛先をサポートし、ネットワーク全体に存在する複数のスイッチをリモート モニタします(図 56-2 を参照)。RSPAN は、レイヤ 2 VLAN を使用して、スイッチ間の SPAN トラフィックを伝送します。

RSPAN は、RSPAN 送信元セッション、RSPAN VLAN、および RSPAN 宛先セッションで構成されています。異なるスイッチで RSPAN 送信元セッションおよび宛先セッションを個別に設定します。1 つのスイッチ上で RSPAN 送信元セッションを設定するには、一連の送信元ポートまたは VLAN を 1 つの RSPAN VLAN に対応付けます。別のスイッチ上で RSPAN 宛先セッションを設定するには、宛先を RSPAN VLAN に対応付けます。

各 RSPAN セッションのトラフィックは、レイヤ 2 非ルーティング トラフィックとして、ユーザが指定した RSPAN VLAN 上で伝送されます。この RSPAN VLAN は、参加しているすべてのスイッチの RSPAN セッション専用です。参加しているすべてのスイッチは、レイヤ 2 によってトランク接続されている必要があります。

RSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートから送信元 RSPAN VLAN トラフィックをローカルにコピーしません。RSPAN 送信元セッションは、送信元 RSPAN GRE でカプセル化されたトラフィックを送信元ポートからローカルにコピーしません。

RSPAN 送信元セッションごとに、送信元としてポートまたは VLAN を使用することはできますが、両方は使用できません。

RSPAN 送信元セッションは、送信元ポートまたは送信元 VLAN からトラフィックをコピーし、RSPAN VLAN 上のトラフィックを RSPAN 宛先セッションへスイッチングします。RSPAN 宛先セッションでは、トラフィックを宛先にスイッチングします。

図 56-2 RSPAN の設定

 

ERSPAN の概要

ERSPAN は、さまざまなスイッチ上の送信元ポート、送信元 VLAN、および宛先ポートをサポートし、ネットワーク全体に存在する複数のスイッチをリモート モニタします(図 56-3 を参照)。ERSPAN は、GRE トンネルを使用して、スイッチ間のトラフィックを伝送します。

ERSPAN は、ERSPAN 送信元セッション、ルーティング可能な ERSPAN GRE カプセル化トラフィック、および ERSPAN 宛先セッションで構成されています。異なるスイッチで ERSPAN 送信元セッションおよび宛先セッションを個別に設定します。

ERSPAN 送信元セッションを 1 つのスイッチ上で設定するには、送信元ポートまたは VLAN のセットを宛先 IP アドレス、ERSPAN ID 番号、およびオプションとして VRF(VPN ルーティング/転送)名に対応付けます。ERSPAN 宛先セッションを別のスイッチ上で設定するには、宛先を送信元 IP アドレス、ERSPAN ID 番号、およびオプションとして VRF 名に対応付けます。

ERSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートから送信元 RSPAN VLAN トラフィックをローカルにコピーしません。ERSPAN 送信元セッションは、送信元 ERSPAN GRE でカプセル化されたトラフィックを送信元ポートからローカルにコピーしません。

ERSPAN 送信元セッションごとに、送信元としてポートまたは VLAN を使用することはできますが、両方は使用できません。

ERSPAN 送信元セッションは、送信元ポートまたは送信元 VLAN からのトラフィックをコピーし、このトラフィックを、ルーティング可能な GRE カプセル化パケットを使用して ERSPAN 宛先セッションに転送します。ERSPAN 宛先セッションはトラフィックを宛先へスイッチングします。

図 56-3 ERSPAN の設定

 

モニタ対象トラフィックの方向

ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションを設定して、次のトラフィックをモニタできます。

入力トラフィック

呼び出された入力 SPAN。

送信元が受信するトラフィックをコピーします(入力トラフィック)。

入力トラフィックは、コピーされるスーパーバイザ エンジン SPAN ASIC に送信されます。

出力トラフィック

呼び出された出力 SPAN。

送信元から送信するトラフィックをコピーします(出力トラフィック)。

分散型出力 SPAN モード:一部のファブリック対応スイッチング モジュールでは、出力トラフィックがスイッチング モジュール SPAN ASIC によってローカルにコピーされ、SPAN 宛先に送信されます。分散型出力 SPAN モードをサポートするスイッチング モジュールについては、「分散型出力 SPAN モードの制約事項」を参照してください。

集中型出力 SPAN モード:他のすべてのスイッチング モジュールでは、出力トラフィックがコピーされるスーパーバイザ エンジン SPAN ASIC に送信され、さらに SPAN 宛先に送信されます。

両方

受信トラフィックと送信トラフィックの両方をコピーします(入力および出力トラフィック)。

入力トラフィックと出力トラフィックのいずれも、コピーされるスーパーバイザ エンジン SPAN ASIC に送信されます。

モニタ対象トラフィックのタイプ

デフォルトでは、ローカル SPAN および ERSPAN がマルチキャスト フレームおよびブリッジ プロトコル データ ユニット(BPDU)フレームを含む、すべてのトラフィックをモニタリングします。RSPAN は BPDU モニタリングをサポートしません。

重複トラフィック

設定によっては、SPAN が、同じ送信元のトラフィックの複数のコピーを、宛先に送信します。たとえば、双方向 SPAN(入力および出力の両方)セッションが、s1 および s2 の 2 つを SPAN 送信元、d1 を SPAN の宛先として設定している場合、パケットが s1 からスイッチに入って、出力パケットとしてスイッチから s2 に送信されると、s1 の入力 SPAN および s2 の出力 SPAN 両方が、パケットのコピーを SPAN の宛先 d1 に送信します。パケットが s1 から s2 へスイッチングされたレイヤ 2 だった場合、両方の SPAN パケットは同一になります。パケットが s1 から s2 にスイッチングされたレイヤ 3 だった場合は、レイヤ 3 書き換えによって送信元および宛先レイヤ 2 アドレスが変更され、SPAN パケットは異なるものとなります。

ローカル SPAN、RSPAN、および ERSPAN の送信元

「送信元ポートと EtherChannel」

「送信元 VLAN」

送信元ポートと EtherChannel

送信元ポートまたは EtherChannel は、トラフィック分析のためにモニタされるポートまたは EtherChannel です。レイヤ 2 およびレイヤ 3 のポートと EtherChannel はいずれも、SPAN 送信元として設定できます。SPAN は、1 つまたは複数の送信元ポートまたは EtherChannel を、単一の SPAN セッションでモニタできます。任意の VLAN に、SPAN 送信元としてポートまたは EtherChannel を設定できます。トランク ポートまたは EtherChannel を、送信元として設定したり、非トランク送信元と混在させることができます。


) SPAN は、トランク送信元からのカプセル化をコピーしません。SPAN 宛先をトランクとして設定し、分析用に送信される前に、モニタ対象トラフィックにタグを付けることができます。


送信元 VLAN

送信元 VLAN は、トラフィック分析のためにモニタ対象になる VLAN です。VLAN-based SPAN(VSPAN)は、VLAN を SPAN 送信元として使用します。送信元 VLAN にあるすべてのポートおよび EtherChannel が、SPAN トラフィックの送信元になります。


) 送信元 VLAN 上のレイヤ 3 VLAN インターフェイスは、SPAN トラフィックの送信元ではありません。レイヤ 3 VLAN インターフェイスを介して VLAN に入ってくるトラフィックは、送信元 VLAN にある出力ポートまたは EtherChannel を介してスイッチから送信されるときにモニタされます。


ローカル SPAN、RSPAN、および ERSPAN の宛先

SPAN 宛先ポートは、ローカル SPAN、RSPAN、または ERSPAN が分析用のトラフィックを送信するレイヤ 2 ポート、レイヤ 3 ポートまたは EtherChannel です。ポートまたは EtherChannel を SPAN の宛先として設定すると、そのポートは SPAN 機能専用になります。

宛先 EtherChannel は、Port Aggregation Control Protocol(PAgP)または Link Aggregation Control Protocol(LACP)EtherChannel プロトコルをサポートしません。すべての EtherChannel プロトコルのサポートがディセーブルになっているときだけ、オン モードがサポートされます。

宛先 EtherChannel のメンバ リンクが、EtherChannel がサポートされるデバイスに接続される際の、要件はありません。たとえば、メンバ リンクに接続し、ネットワーク アナライザと分離できます。EtherChannel についての詳細は、を参照してください。

デフォルトでは、宛先で、任意のトラフィックを受信することはできません。任意の接続デバイスからトラフィックを受信するようにレイヤ 2 宛先を設定できます。

デフォルトでは、宛先で、SPAN 以外のトラフィックは送信されません。トラフィックを受信するために設定したレイヤ 2 の宛先は、宛先に接続された任意のデバイスのレイヤ 2 アドレスを認識し、そのデバイスあてに送信されるトラフィックを送信するよう、設定できます。

トランクは宛先として設定でき、これによってトランク宛先がカプセル化トラフィックを送信できるようになります。許可される VLAN のリストを使用して、宛先トランク VLAN フィルタリングを設定できます。

ローカル SPAN、RSPAN、および ERSPAN のデフォルト設定

ローカル SPAN:ディセーブル

RSPAN:ディセーブル

ERSPAN:ディセーブル

出力 SPAN セッションのデフォルト操作モード:集中型

ローカル SPAN、RSPAN、および ERSPAN の設定方法

「無条件トランクとしての宛先ポートの設定(任意)」

「宛先トランクの VLAN フィルタリングの設定(任意)」

「宛先ポートの許可リストの設定(任意)」

「出力 SPAN モードの設定(任意)」

「ローカル SPAN の設定」

「RSPAN の設定」

「ERSPAN の設定」

「グローバル コンフィギュレーション モードでの送信元 VLAN フィルタリングの設定」

 

無条件トランクとしての宛先ポートの設定(任意)

モニタ対象トラフィックが宛先を通過するときにタグ付けされるように宛先をトランクとして設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface { type slot/port | port-channel number }

設定するインターフェイスを選択します。

ステップ 3

Router(config-if)# switchport

インターフェイスをレイヤ 2 スイッチング用に設定します(この操作はインターフェイスがレイヤ 2 スイッチング用に設定されていない場合にだけ必要です)。

ステップ 4

Router(config-if)# switchport trunk encapsulation dot1q

カプセル化を設定して、インターフェイスを 802.1Q トランクとして設定します。

ステップ 5

Router(config-if)# switchport mode trunk

無条件にインターフェイスをトランクに設定します。

次に、無条件 IEEE 802.1Q トランクとしてポートを設定する例を示します。

Router(config)# interface gigabitethernet 5/12
Router(config-if)# switchport
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# switchport mode trunk

宛先トランクの VLAN フィルタリングの設定(任意)


) • トランク上での VLAN のフィルタリングに加え、許可される VLAN リストも適用してポートにアクセスできます。

宛先トランクの VLAN フィルタリングは、宛先に適用されます。宛先トランク VLAN フィルタリングを使用する場合、SPAN の送信元から SPAN の宛先に送信されるトラフィックの量は削減されません。


 

宛先がトランクの場合、トランクで許可される VLAN のリストを使用して宛先から送信されるトラフィックをフィルタリングできます (CSCeb01318)。

宛先トランク VLAN フィルタリングを使用すると、SPAN セッション内で、すべての宛先がすべての送信元からのトラフィックを全部受信するという制限が解除されます。宛先トランク VLAN フィルタリングを使用すると、各宛先トランクからネットワーク アナライザに送信されるトラフィックを VLAN 単位で選択できます。

宛先トランク VLAN フィルタリングを宛先トランク上に設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type slot/port

設定する宛先トランク ポートを選択します。

ステップ 3

Router(config-if)# switchport trunk allowed vlan { add | except | none | remove } vlan [, vlan [, vlan [,...]]

トランク上で許可される VLAN のリストを設定します。

vlan パラメータは、1 ~ 4094 の間の 1 つの VLAN 番号、または 2 つの VLAN 番号で指定する(小さい方の数を先にして、間をダッシュで区切る)VLAN 範囲です。カンマで区切った vlan パラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべての VLAN が許可されます。

許可リストからすべての VLAN を削除するには、 switchport trunk allowed vlan none コマンドを入力します。

許可リストに VLAN を追加するには、 switchport trunk allowed vlan add コマンドを入力します。

SPAN 設定を削除しないで、許可 VLAN リストを変更できます。

次に、複数の VLAN が送信元で複数のトランク ポートが宛先であるローカル SPAN セッションを設定する例を示します。宛先トランク VLAN フィルタリングは SPAN トラフィックをフィルタリングし、各宛先トランク ポートが、1 つの VLAN からトラフィックを伝送します。

interface GigabitEthernet1/1
description SPAN destination interface for VLAN 10
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/2
description SPAN destination interface for VLAN 11
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 11
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/3
description SPAN destination interface for VLAN 12
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 12
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/4
description SPAN destination interface for VLAN 13
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 13
switchport mode trunk
switchport nonegotiate
!
monitor session 1 source vlan 10 - 13
monitor session 1 destination interface Gi1/1 - 4

宛先ポートの許可リストの設定(任意)

ポートを誤って宛先として設定してしまうことがないように、宛先として有効なポートのリストを示す許可リストを作成できます。宛先ポートの許可リストを設定すると、許可リスト内のポートだけが宛先として設定できるようになります。

宛先ポートの許可リストを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor permit-list

宛先ポートの許可リストの使用をイネーブルにします。

ステップ 3

Router(config)# monitor permit-list destination interface type slot/port [ - port ] [ , type slot/port - port ]

宛先ポートの許可リストを設定するか、または既存の宛先ポートの許可リストに追加します。

次に、ギガビット イーサネット ポート 5/1 ~ 5/4、および 6/1 を含む宛先ポートの許可リストを設定する例を示します。

Router# configure terminal
Router(config)# monitor permit-list
Router(config)# monitor permit-list destination interface gigabitethernet 5/1-4, gigabitethernet 6/1
 

次に、設定を確認する例を示します。

Router(config)# do show monitor permit-list
SPAN Permit-list :Admin Enabled
Permit-list ports :Gi5/1-4,Gi6/1

出力 SPAN モードの設定(任意)

集中型出力 SPAN モード がデフォルトとなります。 分散型出力 SPAN モード をサポートするスイッチング モジュールについては、「分散型出力 SPAN モードの制約事項」を参照してください。

出力 SPAN モードを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session egress replication-mode distributed

分散型出力 SPAN モードをイネーブルにします。

コマンドを入力します。

ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

次に、分散型出力 SPAN モードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# monitor session egress replication-mode distributed
Router(config)# end
 

次に、分散型出力 SPAN モードをディセーブルにする例を示します。

Router# configure terminal
Router(config)# monitor session egress replication-mode centralized
Router(config)# end
 

次に、設定された出力 SPAN モードを表示する例を示します。

Router# show monitor session egress replication-mode | include Configured
Configured mode : Centralized

ローカル SPAN の設定(SPAN コンフィギュレーション モード)


) 宛先を脱退するときにモニタ対象トラフィックにタグを付けるには、無条件で宛先をトランクに設定してから、宛先として設定する必要があります(「無条件トランクとしての宛先ポートの設定(任意)」を参照)。


SPAN コンフィギュレーション モードでローカル SPAN セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session local_SPAN_session_number type [ local | local-tx ]

ローカル SPAN セッション番号を設定し、ローカル SPAN セッション コンフィギュレーション モードを開始します。

(注)

入力もしくは出力、またはその両方 の SPAN セッションを設定するには、 local キーワードを入力します。

出力だけ の SPAN セッションを設定するには、 local-tx キーワードを入力します。

ステップ 3

Router(config-mon-local)# description session_description

(任意)ローカル SPAN セッションの説明を入力します。

ステップ 4

Router(config-mon-local)# source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

ローカル SPAN セッション番号を送信元ポートまたは VLAN に関連付け、モニタするトラフィック方向を選択します。

(注)

local-tx キーワードを入力するとき、 rx および both キーワードは使用できなくなり、 tx キーワードが必要になります。

使用可能な SPAN セッションを最大限に活用するには、 tx 付きで local セッションを使用する代わりに、常に local-tx セッションを使用することを推奨します。

ステップ 5

Router(config-mon-local)# filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

(任意)ローカル SPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 6

Router(config-mon-local)# destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

ローカル SPAN セッション番号を宛先と関連付けます。

ステップ 7

Router(config-mon-local)# no shutdown

ローカル SPAN セッションを開始します。

コマンドは、local-tx 出力専用 SPAN セッションではサポートされていません。

ステップ 8

Router(config-mon-local)# end

コンフィギュレーション モードを終了します。

session_description には最大 240 文字を使用できますが、特殊文字は使用できません。説明にスペースを含めることができます。


description コマンドのあとに、240 文字を入力できます。


local_span_session_number の範囲は、1 ~ 80 です。

single_interface は次のとおりです。

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

ingress キーワードを入力し、接続デバイスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、スイッチによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。を参照してください。

宛先がトランクで、接続デバイスがタグなしトラフィックをスイッチに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

次に、セッション 1 がギガビット イーサネット ポート 1/1 からの入力トラフィックをモニタするように設定し、さらにギガビット イーサネット ポート 1/2 を宛先として設定する例を示します。

Router(config)# monitor session 1 type local
Router(config-mon-local)# source interface gigabitethernet 1/1 rx
Router(config-mon-local)# destination interface gigabitethernet 1/2
 

詳細については、「SPAN のコンフィギュレーション例」を参照してください。

ローカル SPAN の設定(グローバル コンフィギュレーション モード)


) • 宛先を脱退するときにモニタ対象トラフィックにタグを付けるには、無条件で宛先をトランクに設定してから、宛先として設定する必要があります(「無条件トランクとしての宛先ポートの設定(任意)」を参照)。

グローバル コンフィギュレーション モードでは、最大 2 つまでのローカル SPAN セッションを設定できます。

すべての SPAN 設定作業に対して、SPAN コンフィギュレーション モードを使用できます。

サポートされる最大数の SPAN を設定するには、SPAN コンフィギュレーション モードを使用する必要があります。


 

ローカル SPAN は、個別の送信元および宛先セッションを使用しません。ローカル SPAN セッションを設定するには、ローカル SPAN 送信元および宛先に同じセッション番号を設定します。ローカル SPAN セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session local_span_session_number source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

ローカル SPAN 送信元セッション番号を送信元ポートまたは VLAN に関連付け、モニタするトラフィック方向を選択します。

ステップ 3

Router(config)# monitor session local_span_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

ローカル SPAN セッション番号と宛先を関連付けます。

local_span_session_number の範囲は、1 ~ 80 です。

single_interface は次のとおりです。

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

ingress キーワードを入力し、接続デバイスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、スイッチによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。を参照してください。

宛先がトランクで、接続デバイスがタグなしトラフィックをスイッチに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

次に、セッション 1 の双方向送信元として、ギガビット イーサネット ポート 5/1 を設定する例を示します。

Router(config)# monitor session 1 source interface gigabitethernet 5/1
 

次に、SPAN セッション 1 の宛先として、ギガビット イーサネット ポート 5/48 を設定する例を示します。

Router(config)# monitor session 1 destination interface gigabitethernet 5/48
 

詳細については、「SPAN のコンフィギュレーション例」を参照してください。

RSPAN VLAN の設定

VLAN を RSPAN VLAN として設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# vlan vlan_ID [{-|,} vlan_ID ]

単独のイーサネット VLAN、イーサネット VLAN の範囲、またはカンマで区切ったリストで複数のイーサネット VLAN を作成または変更します(スペースは挿入しないでください)。

ステップ 3

Router(config-vlan)# remote-span

VLAN を RSPAN VLAN として設定します。

ステップ 4

Router(config-vlan)# end

VLAN データベースを更新して、特権 EXEC モードに戻ります。

SPAN コンフィギュレーション モードでの RSPAN 送信元セッションの設定

SPAN コンフィギュレーション モードで SPAN 送信元セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_source_session_number type rspan-source

RSPAN 送信元セッション番号を設定し、このセッションに対する RSPAN 送信元セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-rspan-src)# description session_description

(任意)RSPAN 送信元セッションの説明を入力します。

ステップ 4

Router(config-mon-rspan-src)# source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

RSPAN 送信元セッションの番号と送信元ポートまたは VLAN を対応付けて、モニタするトラフィックの方向を選択します。

ステップ 5

Router(config-mon-rspan-src)# filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

(任意)RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 6

Router(config-mon-rspan-src)# destination remote vlan rspan_vlan_ID

RSPAN 送信元セッション番号を RSPAN VLAN に関連付けます。

ステップ 7

Router(config-mon-rspan-src)# no shutdown

RSPAN 送信元セッションをアクティブにします。

ステップ 8

Router(config-mon-rspan-src)# end

コンフィギュレーション モードを終了します。

session_description には最大 240 文字を使用できますが、特殊文字は使用できません。説明にスペースを含めることができます。


description コマンドのあとに、240 文字を入力できます。


RSPAN_source_span_session_number の範囲は、1 ~ 80 です。

single_interface は次のとおりです。

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number

interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

RSPAN VLAN ID については、「RSPAN VLAN の設定」を参照してください。

次の例は、ポート GigabitEthernet 1/1 からの双方向トラフィックをモニタするようにセッション 1 を設定する方法を示します。

Router(config)# monitor session 1 type rspan-source
Router(config-mon-rspan-src)# source interface gigabitethernet 1/1
Router(config-mon-rspan-src)# destination remote vlan 2
 

詳細については、「SPAN のコンフィギュレーション例」を参照してください。

SPAN コンフィギュレーション モードでの RSPAN 宛先セッションの設定


) • モニタ対象トラフィックにタグ付けをするには、ポートを無条件にトランクに設定してから、そのポートを宛先として設定する必要があります(「無条件トランクとしての宛先ポートの設定(任意)」を参照)。

RSPAN 送信元セッション スイッチに RSPAN 宛先セッションを設定し、RSPAN トラフィックをローカルにモニタするようにできます。


 

RSPAN 宛先セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_destination_session_number type rspan-destination

RSPAN 宛先セッション番号を設定し、このセッションに対する RSPAN 宛先セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-rspan-dst)# description session_description

(任意)RSPAN 宛先セッションの説明を入力します。

ステップ 4

Router(config-mon-rspan-dst)# source remote vlan rspan_vlan_ID

RSPAN 宛先セッション番号を RSPAN VLAN に関連付けます。

ステップ 5

Router(config-mon-rspan-dst)# destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

RSPAN 宛先セッション番号を宛先に関連付けます。

ステップ 6

Router(config-mon-rspan-dst)# end

コンフィギュレーション モードを終了します。

RSPAN_destination_span_session_number は 1 ~ 80 の範囲で指定できます。

single_interface は次のとおりです。

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

ingress キーワードを入力し、接続デバイスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、スイッチによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。を参照してください。

宛先がトランクで、接続デバイスがタグなしトラフィックをスイッチに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

no shutdown コマンドおよび shutdown コマンドは、RSPAN 宛先セッションではサポートされていません。

次に、セッション 1 の送信元として、および、ギガビット イーサネット ポート 1/2 の宛先として、RSPAN VLAN 2 を設定する例を示します。

Router(config)# monitor session 1 type rspan-destination
Router(config-rspan-dst)# source remote vlan 2
Router(config-rspan-dst)# destination interface gigabitethernet 1/2
 

詳細については、「SPAN のコンフィギュレーション例」を参照してください。

グローバル コンフィギュレーション モードでの RSPAN 送信元セッションの設定

グローバル コンフィギュレーション モードで RSPAN 送信元セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_source_session_number source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

RSPAN 送信元セッションの番号と送信元ポートまたは VLAN を対応付けて、モニタするトラフィックの方向を選択します。

ステップ 3

Router(config)# monitor session RSPAN_source_session_number destination remote vlan rspan_vlan_ID

RSPAN 送信元セッション番号を RSPAN VLAN に関連付けます。

RSPAN VLAN を設定するには、「RSPAN VLAN の設定」を参照してください。

RSPAN_source_span_session_number の範囲は、1 ~ 80 です。

single_interface は次のとおりです。

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number

interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

RSPAN VLAN ID については、「RSPAN VLAN の設定」を参照してください。

次に、セッション 2 の送信元として、ポート ギガビット イーサネット ポート 5/2 を設定する例を示します。

Router(config)# monitor session 2 source interface gigabitethernet 5/2
 

次に、セッション 2 の宛先として、RSPAN VLAN 200 を設定する例を示します。

Router(config)# monitor session 2 destination remote vlan 200
 

詳細については、「SPAN のコンフィギュレーション例」を参照してください。

グローバル コンフィギュレーション モードでの RSPAN 宛先セッションの設定


) • モニタ対象トラフィックにタグ付けをするには、ポートを無条件にトランクに設定してから、そのポートを宛先として設定する必要があります(「無条件トランクとしての宛先ポートの設定(任意)」を参照)。

RSPAN 送信元セッション スイッチに RSPAN 宛先セッションを設定し、RSPAN トラフィックをローカルにモニタするようにできます。


 

グローバル コンフィギュレーション モードで RSPAN 宛先セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_destination_session_number source remote vlan rspan_vlan_ID

RSPAN 宛先セッション番号を RSPAN VLAN に関連付けます。

ステップ 3

Router(config)# monitor session RSPAN_destination_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

RSPAN 宛先セッション番号を宛先に関連付けます。

RSPAN_destination_span_session_number は 1 ~ 80 の範囲で指定できます。

RSPAN VLAN ID については、「RSPAN VLAN の設定」を参照してください。

single_interface は次のとおりです。

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

ingress キーワードを入力し、接続デバイスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、スイッチによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。を参照してください。

宛先がトランクで、接続デバイスがタグなしトラフィックをスイッチに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

次に、セッション 3 の送信元として、RSPAN VLAN 200 を設定する例を示します。

Router(config)# monitor session 3 source remote vlan 200
 

次に、セッション 3 の宛先として、ギガビット イーサネット ポート 5/47 を設定する例を示します。

Router(config)# monitor session 3 destination interface gigabitethernet 5/47
 

詳細については、「SPAN のコンフィギュレーション例」を参照してください。

ERSPAN 送信元セッションの設定

ERSPAN 送信元セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session ERSPAN_source_session_number type erspan-source

ERSPAN 送信元セッション番号を設定し、このセッションに対する ERSPAN 送信元セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-erspan-src)# description session_description

(任意)ERSPAN 送信元セッションの説明を入力します。

ステップ 4

Router(config-mon-erspan-src)# source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]}

ERSPAN 送信元セッションの番号と送信元ポートまたは VLAN を関連付けて、モニタするトラフィックの方向を選択します。

ステップ 5

Router(config-mon-erspan-src)# filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

(任意)ERSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 6

Router(config-mon-erspan-src)# destination

ERSPAN 送信元セッションの宛先コンフィギュレーション モードを開始します。

ステップ 7

Router(config-mon-erspan-src-dst)# ip address ip_address

ERSPAN フローの宛先 IP アドレスを設定します。これは、宛先スイッチのインターフェイス上でも設定する必要があるほか、ERSPAN 宛先セッションの設定でも入力する必要があります(「ERSPAN 宛先セッションの設定」ステップ 6 を参照)。

ステップ 8

Router(config-mon-erspan-src-dst)# erspan-id ERSPAN_flow_id

ERSPAN トラフィックを識別するため、送信元および宛先セッションで使用される ID 番号を設定します。これは、ERSPAN 宛先セッションの設定でも入力する必要があります(「ERSPAN 宛先セッションの設定」ステップ 7 を参照)。

ステップ 9

Router(config-mon-erspan-src-dst)# origin ip address ip_address [ force ]

ERSPAN トラフィックの送信元として使用される IP アドレスを設定します。

ステップ 10

Router(config-mon-erspan-src-dst)# ip ttl ttl_value

(任意)ERSPAN トラフィック内のパケットの IP Time to Live(TTL)値を設定します。

ステップ 11

Router(config-mon-erspan-src-dst)# ip prec ipp_value

(任意)ERSPAN トラフィック内のパケットの IP precedence 値を設定します。

ステップ 12

Router(config-mon-erspan-src-dst)# ip dscp dscp_value

(任意)ERSPAN トラフィック内のパケットの IP DSCP 値を設定します。

ステップ 13

Router(config-mon-erspan-src-dst)# vrf vrf_name

(任意)グローバル ルーティング テーブルの代わりに使用する VRF 名を設定します。

ステップ 14

Router(config-mon-erspan-src)# no shutdown

ERSPAN 送信元セッションをアクティブにします。

ステップ 15

Router(config-mon-erspan-src-dst)# end

コンフィギュレーション モードを終了します。

session_description には最大 240 文字を使用できますが、特殊文字は使用できません。説明にスペースを含めることができます。


description コマンドのあとに、240 文字を入力できます。


ERSPAN_source_span_session_number は 1 ~ 80 の範囲で指定できます。

single_interface は次のとおりです。

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

ERSPAN_flow_id の範囲は、1 ~ 1023 です。

1 つのスイッチのすべての ERSPAN 送信元セッションは、同一の送信元 IP アドレスを使用する必要があります。スイッチ上ですべての ERSPAN 送信元セッションに設定された起点 IP アドレスを変更するには、 origin ip address ip_address force コマンドを入力します。

ttl_value は 1 ~ 255 の範囲で指定できます。

ipp_value は 0 ~ 7 の範囲で指定できます。

dscp_value は 0 ~ 63 の範囲で指定できます。

次に、ギガビット イーサネット ポート 4/1 からの双方向トラフィックをモニタするようにセッション 3 を設定する例を示します。

Router(config)# monitor session 3 type erspan-source
Router(config-mon-erspan-src)# source interface gigabitethernet 4/1
Router(config-mon-erspan-src)# destination
Router(config-mon-erspan-src-dst)# ip address 10.1.1.1
Router(config-mon-erspan-src-dst)# origin ip address 20.1.1.1
Router(config-mon-erspan-src-dst)# erspan-id 101
 

詳細については、「SPAN のコンフィギュレーション例」を参照してください。

ERSPAN 宛先セッションの設定


) ERSPAN トラフィックをローカルにモニタすることはできません。


ERSPAN 宛先セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session ERSPAN_destination_session_number type erspan-destination

ERSPAN 宛先セッション番号を設定し、このセッションに対する ERSPAN 宛先セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-erspan-dst)# description session_description

(任意)ERSPAN 宛先セッションの説明を入力します。

ステップ 4

Router(config-mon-erspan-dst)# destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

ERSPAN 宛先セッション番号と宛先を対応付けます。

ステップ 5

Router(config-mon-erspan-dst)# source

ERSPAN 宛先セッションの送信元コンフィギュレーション モードを開始します。

ステップ 6

Router(config-mon-erspan-dst-src)# ip address ip_address [ force ]

ERSPAN フローの宛先 IP アドレスを設定します。これは、ローカル インターフェイス上のアドレスであり、「ERSPAN 送信元セッションの設定」ステップ 7 で入力したアドレスと一致する必要があります。

ステップ 7

Router(config-mon-erspan-dst-src)# erspan-id ERSPAN_flow_id

ERSPAN トラフィックを識別するため、宛先および宛先セッションで使用される ID 番号を設定します。これは、「ERSPAN 送信元セッションの設定」ステップ 8 で入力した ID と一致する必要があります。

ステップ 8

Router(config-mon-erspan-dst-src)# vrf vrf_name

(任意)グローバル ルーティング テーブルの代わりに使用する VRF 名を設定します。

ステップ 9

Router(config-mon-erspan-dst)# no shutdown

ERSPAN 宛先セッションをアクティブにします。

ステップ 10

Router(config-mon-erspan-dst-src)# end

コンフィギュレーション モードを終了します。

ERSPAN_destination_span_session_number は 1 ~ 80 の範囲で指定できます。

single_interface は次のとおりです。

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

スイッチ上のすべての ERSPAN 宛先セッションは、同じ宛先インターフェイス上の同一の IP アドレスを使用する必要があります。スイッチ上ですべての ERSPAN 宛先セッションに設定された IP アドレスを変更するには、 ip address ip_address force コマンドを入力します。


) また、すべての ERSPAN 送信元セッションの宛先 IP アドレスを変更することも必要です(「ERSPAN 送信元セッションの設定」ステップ 7 を参照)。


ERSPAN_flow_id の範囲は、1 ~ 1023 です。

ingress キーワードを入力し、接続デバイスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、スイッチによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。を参照してください。

宛先がトランクで、接続デバイスがタグなしトラフィックをスイッチに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

次に、IP アドレス 10.1.1.1 に着信した ERSPAN ID 101 トラフィックを、ギガビット イーサネット ポート 2/1 に送信するように ERSPAN 宛先セッションを設定する例を示します。

Router(config)# monitor session 3 type erspan-destination
Router(config-erspan-dst)# destination interface gigabitethernet 2/1
Router(config-erspan-dst)# source
Router(config-erspan-dst-src)# ip address 10.1.1.1
Router(config-erspan-dst-src)# erspan-id 101
 

詳細については、「SPAN のコンフィギュレーション例」を参照してください。

グローバル コンフィギュレーション モードでの送信元 VLAN フィルタリングの設定


) • SPAN コンフィギュレーション モードで送信元 VLAN フィルタリングを設定するには、次を参照してください。

「ローカル SPAN の設定(SPAN コンフィギュレーション モード)」

「SPAN コンフィギュレーション モードでの RSPAN 送信元セッションの設定」

「ERSPAN の設定」

送信元 VLAN フィルタリングにより、SPAN 送信元から SPAN 宛先に送信されるトラフィックの量が減ります。


 

送信元がトランク ポートである場合に、送信元 VLAN フィルタリングは特定の VLAN をモニタします。

ローカル SPAN または RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session session_number filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

ローカル SPAN または RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

次に、送信元がトランク ポートである場合に、VLAN 1 ~ 5 および VLAN 9 をモニタする例を示します。

Router(config)# monitor session 2 filter vlan 1 - 5 , 9

SPAN の設定確認

設定を確認するには、 show monitor session コマンドを入力します。

次に、セッション 2 の設定を確認する例を示します。

Router# show monitor session 2
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Gi3/1
Dest RSPAN VLAN: 901
Router#
 

次に、セッション 2 の詳細を完全に表示する例を示します。

Router# show monitor session 2 detail
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Gi1/1-3
TX Only: None
Both: None
Source VLANs:
RX Only: None
TX Only: None
Both: None
Source RSPAN VLAN: None
Destination Ports: None
Filter VLANs: None
Dest RSPAN VLAN: 901

SPAN のコンフィギュレーション例

次に、RSPAN 送信元セッション 2 の設定例を示します。

Router(config)# monitor session 2 source interface gigabitethernet1/1 - 3 rx
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッション 1 とセッション 2 の設定を消去する例を示します。

Router(config)# no monitor session range 1-2
 

次に、複数の送信元のある RSPAN 送信元セッションの設定例を示します。

Router(config)# monitor session 2 source interface gigabitethernet 5/15 , 7/3 rx
Router(config)# monitor session 2 source interface gigabitethernet 1/2 tx
Router(config)# monitor session 2 source interface port-channel 102
Router(config)# monitor session 2 source filter vlan 2 - 3
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッションの送信元を削除する例を示します。

Router(config)# no monitor session 2 source interface gigabitethernet 5/15 , 7/3
 

次に、セッションの送信元に対するオプションを削除する例を示します。

Router(config)# no monitor session 2 source interface gigabitethernet 1/2
Router(config)# no monitor session 2 source interface port-channel 102 tx
 

次に、セッションの送信元 VLAN フィルタリングを削除する例を示します。

Router(config)# no monitor session 2 filter vlan 3
 

次に、RSPAN 宛先セッション 8 の設定例を示します。

Router(config)# monitor session 8 source remote vlan 901
Router(config)# monitor session 8 destination interface gigabitethernet 1/2 , 2/3
 

次に、ERSPAN 送信元セッション 12 の設定例を示します。

monitor session 12 type erspan-source
description SOURCE_SESSION_FOR_VRF_GRAY
source interface Gi8/48 rx
destination
erspan-id 120
ip address 10.8.1.2
origin ip address 32.1.1.1
vrf gray
 

次に、ERSPAN 宛先セッション 12 の設定例を示します。

monitor session 12 type erspan-destination
description DEST_SESSION_FOR_VRF_GRAY
destination interface Gi4/48
source
erspan-id 120
ip address 10.8.1.2
vrf gray
 

次に、ERSPAN 送信元セッション 13 の設定例を示します。

monitor session 13 type erspan-source
source interface Gi6/1 tx
destination
erspan-id 130
ip address 10.11.1.1
origin ip address 32.1.1.1
 

次に、ERSPAN 宛先セッション 13 の設定例を示します。

monitor session 13 type erspan-destination
destination interface Gi6/1
source
erspan-id 130
ip address 10.11.1.1

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する