Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.1SY
Nonstop Forwarding(NSF)
Nonstop Forwarding(NSF)
発行日;2013/08/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

Nonstop Forwarding(NSF)

NSF の前提条件

NSF の制約事項

一般的な制約事項

BGP NSF の制限

EIGRP NSF の制約事項

OSPF NSF の制約事項

IS-IS NSF の制約事項

IPv6 NSF の制限

NSF について

NSF の概要

NSF による相互作用機能

シスコ エクスプレス フォワーディング

ルーティング プロトコルの動作

BGP の動作

EIGRP の動作

IS-IS の動作

OSPF の動作

IPv6 ルーティング プロトコルの動作

NSF のデフォルト設定

NSF の設定方法

NSF の BGP の設定および検証

NSF の BGP の設定

BGP での NSF の確認

EIGRP NSF の設定および検証

NSF の EIGRP の設定

NSF での EIGRP の確認

OSPF NSF の設定および検証

NSF OSPF の設定

NSF での OSPF の確認

IS-IS NSF の設定および検証

IS-IS の NSF の設定

IS-IS の NSF の確認

Cisco Nonstop Forwarding のトラブルシューティング

NSF の設定例

例:BGP NSF の設定

例:BGP NSF の隣接デバイスの設定

例:BGP NSF の確認

例:EIGRP NSF の収束タイマーの設定

例:EIGRP グレースフル リスタート パージ時間タイマーの設定

例:EIGRP NSF のルート ホールド タイマーの設定

例:EIGRP NSF の信号タイマーの設定

例:EIGRP NSF の確認

例:EIGRP NSF サポートのディセーブル化

例:OSPF NSF の設定

例:OSPF NSF の確認

例:IS-IS NSF の設定

例:IS-IS NSF の確認

Nonstop Forwarding(NSF)

「NSF の前提条件」

「NSF の制約事項」

「NSF について」

「NSF のデフォルト設定」

「NSF の設定方法」

「NSF の設定例」


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。

ステートフル スイッチオーバー(SSO)およびノンストップ フォワーディング(NSF)は IPv6 マルチキャスト トラフィックをサポートしません。


 

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する


 

NSF の前提条件

なし。

NSF の制約事項

「一般的な制約事項」

「BGP NSF の制限」

「EIGRP NSF の制約事項」

「OSPF NSF の制約事項」

「IS-IS NSF の制約事項」

「IPv6 NSF の制限」

一般的な制約事項

NSF には SSO が必要です(を参照)。

ホット スタンバイ ルーティング プロトコル(HSRP)は、Cisco NSF/SSO でサポートされていません。HSRP を Cisco NSF/SSO で使用しないでください。

BGP NSF の制限

BGP NSF に参加するすべてのネイバー デバイスが NSF 対応である必要があり、「NSF の BGP の設定および検証」で説明されているように、BGP グレースフル リスタートが設定されます。

EIGRP NSF の制約事項

EIGRP NSF 稼働に関与しているすべての隣接デバイスが NSF に対応または NSF を認識する必要があります。

NSF 認識ルータは、2 台の NSF 対応ピアが 1 つの NSF の再起動処理を同時に実行することはサポートしません。ただし、NSF 再起動処理が完了した後で、両方のネイバーがピアリング セッションを確立します。

OSPF NSF の制約事項

仮想リンク用 OSPF NSF はサポートされません。

同じネットワーク セグメント上のすべての OSPF ネットワーキング デバイスは、NSF 認識(NSF ソフトウェア イメージを稼働)である必要があります。

シャム リンクの OSPF NSF はサポートされていません。

IS-IS NSF の制約事項

IETF IS-IS の場合、ネイバー デバイスはすべて NSF 認識ソフトウェア イメージを稼働する必要があります。

IPv6 NSF の制限

IPv6 NSF をサポートするため、ルータで IPv6 をイネーブルにする必要があります。

NSF について

「NSF の概要」

「NSF による相互作用機能」

NSF の概要

NSF は、SSO と連動して、スイッチオーバー後にユーザがネットワークを使用できない時間を最小限に抑えます。Cisco NSF の主な目的は、ルート プロセッサ(RP)のスイッチオーバー後に、引き続き IP パケットを転送することです。

通常、ネットワーキング デバイスが再起動すると、そのデバイスのすべてのルーティング ピアは、デバイスがダウンし、そのあと再びアップになったことを検知します。このような移行によって、いわゆるルーティング フラップが発生します。ルーティング フラップは、複数のルーティング ドメインに広がる場合があります。ルーティングの再起動によって発生したルーティング フラップによって、ルーティングが不安定になります。これはネットワーク全体のパフォーマンスに悪影響を及ぼします。Cisco NSF は、SSO 対応のデバイスにおけるルーティング フラップを抑止することによって、ネットワークの安定性を保ちます。

Cisco NSF によって、スイッチオーバー後にルーティング プロトコル情報が復元される間、データのパケットの転送が既知のルートで続行されます。Cisco NSF を使用すると、ピア ネットワーキング デバイスでルーティング フラップが発生することがありません。データ トラフィックはインテリジェント ラインカードを介して転送されますが、スタンバイ RP では、スイッチオーバー中に障害が発生したアクティブな RP からの制御と見なされます。ラインカードの機能はスイッチオーバーの前後で維持され、アクティブな RP の転送情報ベース(FIB)が Cisco NSF 動作で最新状態が維持されます。

Cisco NSF 機能には、次のような複数の利点があります。

ネットワークのアベイラビリティの向上:NSF は、ユーザのセッション情報がスイッチオーバー後も維持されるように、ネットワーク トラフィックとアプリケーションのステート情報を転送し続けます。

ネットワーク全体の安定性:ネットワークの安定性は、ネットワーク内でルータに障害が発生し、ルーティング テーブルが失われたときに作成されるルート フラップの数を減らすことで改善できます。

隣接ルータによるリンクのフラッピングの検出防止:インターフェイスが、スイッチオーバー中もアップ状態を維持するので、隣接ルータはリンク フラップを検出しません(つまり、リンクがダウンして、再度アップするということが起こりません)。

ルーティング フラップの防止:SSO はスイッチオーバーの際もネットワーク トラフィックの転送を続けるので、ルーティング フラップが回避されます。

ユーザ セッションの維持:スイッチオーバーの前に確立されたユーザセッションは、スイッチオーバを経ても維持されます。

ネットワーキング デバイスが NSF 互換ソフトウェアを実行している場合、このデバイスは NSF 認識です。デバイスが NSF をサポートするように設定されている場合、デバイスは NSF 対応で、NSF 認識または NSF 対応ネイバーからルーティング情報を再構築します。

CEF は、Catalyst 6500 シリーズ スイッチで常にイネーブルにされ、ディセーブルにできません。ルーティング プロトコルは、スイッチオーバー中にルーティング情報ベース(RIB)テーブルを再構築している間、CEF に依存してパケット フォワーディングを行います。ルーティング プロトコルのコンバージェンスが完了すると、CEF は FIB テーブルを更新し、失効したルート エントリを削除し、CEF はラインカードを新しい FIB 情報で更新します。

シスコ エクスプレス フォワーディング

NSF の重要な要素はパケット転送です。シスコのネットワーキング デバイスでは、パケットの転送は CEF によって行われます。CEF は、Catalyst 6500 シリーズ スイッチで常にイネーブルにされ、ディセーブルにできません。CEF は FIB を維持し、スイッチオーバー時の FIB 情報を使用してスイッチオーバー中にパケットを転送し続けます。この機能により、スイッチオーバー中のトラフィックの中断を短くします。

通常の NSF 操作中に、アクティブなルート プロセッサ(RP)上の CEF は、現在の FIB と隣接データベースを、スタンバイ RP 上の FIB と隣接データベースと同期させます。アクティブな RP のスイッチオーバー時に、スタンバイ RP には最初、アクティブな RP 上で最新だったもののミラー イメージである FIB と隣接データベースがあります。インテリジェント ラインカードを備えたプラットフォームでは、ラインカードはスイッチオーバーの前後で現行の転送情報を維持します。フォワーディング エンジンを備えたプラットフォームでは、CEF は、アクティブな RP の CEF によって送信される変更を使用して、スタンバイ RP のフォワーディング エンジンを最新の状態に保ちます。この方法では、フォワーディング エンジンのラインカードは、インターフェイスとデータ パスが使用可能になるとすぐに、スイッチオーバー後に転送を続行できます。

ルーティング プロトコルがプレフィックスごとに RIB を再び読み込み始めるため、CEF に対してプレフィックスごとの更新が行われます。CEF はこれを使用して FIB と隣接データベースを更新します。既存または新規エントリは、リフレッシュされたことを示す新しいバージョン(「エポック」)番号を受信します。転送情報はラインカードまたは収束中のフォワーディング エンジンで更新されます。RIB が収束すると、RP が信号通知を行います。ソフトウェアは、現在のスイッチオーバー エポックよりも前のエポックを持った FIB および隣接エントリをすべて削除します。これで FIB は最新のルーティング プロトコル転送情報を表示するようになります。

ルーティング プロトコルの動作

ルーティング プロトコルは、アクティブな RP だけで実行され、隣接ルータからルーティングの更新を受信します。ルーティング プロトコルは、スタンバイ RP では実行されません。スイッチオーバーのあとルーティング プロトコルは、NSF 認識ネイバー デバイスがルーティング テーブルを再構築するステート情報を送信するよう要求します。またこの代わりに、ネイバー デバイスが NSF を認識しないような環境にある NSF 対応デバイスのルーティング テーブルの再構築に役立つように、アクティブ RP のステート情報をスタンバイ RP と同期させるように、IS-IS プロトコルを設定できます。

NSF 動作の場合、ルーティング プロトコルは、ルーティング情報を再構築している間にパケットを転送し続ける CEF によって異なります。

BGP の動作

NSF 対応ルータは、BGP ピアと BGP セッションを開始すると、OPEN メッセージをピアに送信します。メッセージには、NSF 対応デバイスに「グレースフル リスタート機能」があることを示す宣言が含まれています。グレースフル リスタートとは、スイッチオーバー後に BGP ルーティング ピアでルーティング フラップが発生しないようにするためのメカニズムです。BGP ピアがこの機能を受信した場合、メッセージを送信するデバイスが NSF 対応であることを認識しています。NSF 対応ルータ ピアおよび BGP ピアは両方ともセッションの確立時に、OPEN メッセージ内でグレースフル リスタート機能を交換する必要があります。両方のピアがグレースフル リスタート機能を交換しない場合、セッションはグレースフル リスタート対応になりません。

RP のスイッチオーバー中に BGP セッションが切断された場合、NSF 認識 BGP ピアは、NSF 対応ルータに関連付けられたすべてのルートを失効とマーキングします。ただし、所定の時間内は、引き続きこれらのルートを転送の決定に使用します。この機能により、新しくアクティブになった RP が BGP ピアとのルーティング情報のコンバージェンスを待機している間にパケットが消失することを防ぐことができます。

RP のスイッチオーバーが発生した後、NSF 対応ルータは BGP ピアとのセッションを再確立します。新しいセッションの確立時に、NSF 対応ルータが再起動したことを識別する新しいグレースフル リスタート メッセージを送信します。

この時点で、ルーティング情報は 2 つの BGP ピアの間で交換されます。この交換が完了すると、NSF 対応デバイスはルーティング情報を使用して、RIB と FIB を新しい転送情報で更新します。NSF 認識デバイスは、ネットワーク情報を使用して失効したルートを BGP テーブルから削除します。この後 BGP プロトコルが完全に収束します。

BGP ピアがグレースフル リスタート機能をサポートしていない場合、OPEN メッセージ内のグレースフル リスタート機能は無視されますが、NSF 対応デバイスとの BGP セッションは確立されます。この機能により、非 NSF 認識 BGP ピアとのインターオペラビリティ(および NSF 機能が無いインターオペラビリティ)を可能にしますが、非 NSF 認識 BGP ピアでの BGP セッションはグレースフル リスタート対応になりません。


) NSF の BGP サポートでは、ネイバー ネットワーキング デバイスが NSF 認識である必要があります。つまり、デバイスにはグレースフル リスタート機能があり、セッション確立中に OPEN メッセージ内でこの機能をアドバタイズする必要があります。NSF 対応ルータが特定の BGP ネイバーにグレースフル リスタート機能がないことを検出した場合、そのネイバーとの NSF 対応セッションを確立しません。グレースフル リスタート機能のある他のネイバーはすべて、NSF 対応ネットワーキング デバイスとの NSF 対応セッションを維持し続けます。


EIGRP の動作

EIGRP NSF 機能は、hello パケットで EIGRP ピアと交換されます。NSF 対応ルータは、hello パケットで再起動(RS)ビットを設定したことによって NSF の再起動処理が開始されたことをネイバーに通知します。NSF 認識ルータが NSF 対応ネイバーから、NSF の再起動処理が進行中であるという通知を受け取ると、NSF 対応ルータと NSF 認識ルータは、即座にそれぞれのトポロジ テーブルを交換します。トポロジ テーブルの送信が完了すると、NSF 認識ルータは end-of-table(EOT)アップデート パケットを送信します。次に NSF 認識ルータは、NSF 対応ルータを支援するために次のアクションを実行します。

EIGRP hello ホールド タイマーの期限を終了し、hello パケットの生成および送信の間隔を短くします。これにより、NSF 認識ルータは NSF 対応ルータにより早く応答し、NSF 対応ルータがネイバーを再検出し、トポロジ テーブルを再構築するために必要な時間を短縮します。

ルート ホールド タイマーが開始されます。このタイマーを使用して、NSF 認識ルータが NSF 対応ネイバーに対する既知のルートを保持している期間を設定します。このタイマーは、 timers nsf route-hold コマンドで設定されます。デフォルトの期間は 240 秒です。

NSF 認識ルータは、ピア リストに、NSF 対応のネイバーが再起動していることを記録するとともに、このネイバーからトポロジ テーブルを送信するように信号通知されるか、またはルート ホールド タイマーが期限切れになるまで、隣接関係を維持し、NSF 対応のネイバーの既知のルートを保持します。NSF 認識ルータでルート ホールド タイマーが期限切れになった場合、NSF 認識ルータは保留中のルートを廃棄し、NSF 対応ルータをネットワークに参加した新しいルータとして扱って、新しいルータに対して行うように隣接関係を再度確立します。

NSF 認識ルータは、スイッチオーバーの後なおコンバージェンスしている NSF 対応ルータにクエリーを送信し続けることによって、Stuck In Active(SIA)状態が発生するまでの時間を効果的に延長します。

スイッチオーバー処理が完了すると、NSF 対応ルータは、サポートしているルータに対して EOT アップデート パケットを送信することによって、再コンバージェンスされたこと、およびすべてのトポロジ テーブルを受信したことをネイバーに通知します。その後、NSF 対応ルータは通常の処理に戻ります。NSF 認識ルータは、(再起動中の)NSF 対応ルータでリフレッシュされないルートに対して、(アクティブな)別のパスを探します。その後、NSF 認識ルータは通常の処理に戻ります。NSF 対応ルータによってすべてのパスがリフレッシュされると、NSF 認識ルータはすぐに通常の処理に戻ります。


) NSF 認識ルータは、EIGRP ネットワーク内で NSF 非認識ネイバーまたは NSF 非対応ネイバーと完全に共存できます。NSF 非認識ネイバーは、NSF 対応を無視し、隣接関係をリセットするか、そうでなければピア セッションを正常に維持します。


IS-IS の動作

ピア デバイスから受信した情報の代わりに、アクティブおよびスタンバイの RP 間で同期されているステート情報を使用して、スイッチオーバー以降のルート情報を回復するよう IS-IS プロトコルを設定できます。

IS-IS NSF 対応ルータが RP のスイッチオーバーを実行する場合、リンク ステート データベースを IS-IS ネイバーと再同期するために、次の 2 つの処理を実行する必要があります。まず、ネイバー関係をリセットせずに、ネットワーク上の使用可能な IS-IS ネイバーを再学習します。次に、ネットワークに関するリンク ステート データベースの内容を再度取得します。

NSF を設定する場合、IS-IS NSF 機能には次の 2 つのオプションがあります。

Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)IS-IS

Cisco IS-IS

ネットワーク セグメント上の隣接ルータが NSF 認識の場合、つまり隣接ルータが、ルータの再起動可能性についての IETF インターネット ドラフトをサポートするソフトウェア バージョンを実行している場合、それらのルータは、再起動中の IETF NSF ルータをサポートします。IETF を使用する場合、隣接ルータはスイッチオーバー後のルーティング情報を再構築する隣接情報およびリンク ステート情報を提供します。IETF IS-IS コンフィギュレーションの利点は、提案された標準に基づいたピア デバイスの間の動作であることです。


) ネットワーキング デバイスに IETF を設定する場合で隣接ルータが IETF と互換性がないとき、NSF はスイッチオーバー後に中断します。


ネットワーク セグメント上の隣接ルータが NSF 認識でない場合、シスコのコンフィギュレーション オプションを使用する必要があります。Cisco IS-IS 設定は、プロトコル隣接関係情報とリンク ステート情報の両方をアクティブ RP からスタンバイ RP に転送します。シスコのコンフィギュレーションの利点は、NSF 認識ネイバーに依存していないことです。

IETF IS-IS コンフィギュレーション

NSF 対応ルータは、IETF IS-IS コンフィギュレーションを使用して、RP スイッチオーバーの後できるだけ迅速に、ネイバー NSF 認識デバイスに IS-IS NSF 再起動要求を送信します。ネイバー ネットワーキング デバイスは、この再起動要求をこのルータとのネイバー関係がリセットされるべきでないが、再起動ルータとの間でデータベースの再同期を開始すべきであることを示す指示として認識します。再起動するルータがネットワーク上のルータから再起動要求を受信すると、ネイバー リストの再構築を始めます。

この交換が完了すると、NSF 対応デバイスは、リンクステート情報を使用して、失効したルートを削除し、RIB を更新し、FIB を新しい転送情報で更新します。ここで IS-IS が完全にコンバージェンスされます。

あるスーパーバイザ エンジンから別の RP へのスイッチオーバーは、数秒間以内に発生します。IS-IS はルーティング テーブルを再構築し、数秒以内にネットワークと同期化します。この時点で IS-IS は次の NSF 再起動を実行する前に、指定された時間の間、待機します。この間に、新しいスタンバイ RP が起動し、そのコンフィギュレーションをアクティブ RP に同期します。IS-IS NSF を再起動しようとする前に接続を安定させるため、IS-IS NSF 動作は指定された時間の間、待機します。この機能は、IS-IS が失効情報で back-to-back NSF を再起動しないようにします。

Cisco IS-IS コンフィギュレーション

Cisco コンフィギュレーション オプションを使用することで、すべての隣接および LSP 情報を保存するか、スタンバイ RP に「チェックポイント」として設定されます。スイッチオーバーのあと、新しくアクティブになった RP はチェックポイント済みのデータを使用して隣接関係を維持し、ルーティング テーブルを迅速に再構築できます。


) スイッチオーバーのあと、Cisco IS-IS NSF には完全なネイバー隣接および LSP 情報が含まれます。ただし、スイッチオーバーの前に隣接であったすべてのインターフェイスがアップになるまで待機する必要があります。割り当てられたインターフェイス待機時間内にインターフェイスがアップにならない場合、これらのネイバー デバイスから学習したルートは、ルーティング テーブルの再計算で考慮されません。IS-IS NSF には、何らかの理由で時間内にアップ状態にならないインターフェイスに対して、待機時間を延長するコマンドがあります。


あるスーパーバイザ エンジンから別の RP へのスイッチオーバーは、数秒間以内に発生します。IS-IS はルーティング テーブルを再構築し、数秒以内にネットワークと同期化します。この時点で IS-IS は次の NSF 再起動を実行する前に、指定された時間の間、待機します。この間に、新しいスタンバイ RP が起動し、そのコンフィギュレーションをアクティブ RP に同期します。この同期が完了したあと、IS-IS 隣接および LSP データにスタンバイ RP のチェックポイントが設定されます。ただし、新しい NSF 再起動は、この期間が経過しないと IS-IS で試行されません。この機能により、IS-IS がバックツーバック NSF 再起動を試行しないようにします。

OSPF の動作

OSPF NSF 対応ルータが RP のスイッチオーバーを実行する場合、リンク ステート データベースを OSPF ネイバーと再同期するために、次の 2 つの処理を実行する必要があります。まず、ネイバー関係をリセットせずに、ネットワーク上の使用可能な OSPF ネイバーを再学習します。次に、ネットワークに関するリンク ステート データベースの内容を再度取得します。

NSF 対応ルータは、RP スイッチオーバーの後できるだけ迅速に、ネイバー NSF 認識デバイスに OSPF NSF 信号を送信します。ネイバー ネットワーキング デバイスは、この信号をこのルータとのネイバー関係がリセットされるべきでないことを示す指示として認識します。NSF 対応ルータがネットワーク上の他のルータから信号を受信すると、ネイバー リストの再構築を始めます。

ネイバー関係が再構築されると、NSF 対応ルータはすべての NSF 認識ネイバーとデータベースの再同期化を始めます。この時点でルーティング情報は OSPF ネイバーの間で交換されます。交換が完了すると、NSF 対応デバイスはルーティング情報を使用して、失効ルートを削除し、RIB を更新して、新しい転送情報で FIB を更新します。その後、OSPF プロトコルは完全に収束されます。


) OSPF NSF では、すべてのネイバー ネットワーク デバイスが NSF 認識である必要があります。NSF 対応ルータが特定のネットワーク セグメント上に NSF 認識ネイバーがないことを検出した場合、ルータはそのセグメントの NSF 機能をディセーブルにします。全体が NSF 対応または NSF 認識ルータで構成された他のネットワーク セグメントは、NSF 機能を提供し続けます。


OSPF RFC 3623 のグレースフル リスタート機能を使用すると、マルチベンダー ネットワークにおいて IETF NSF を設定できます。詳細については、『 OSPF RFC 3623 Graceful Restart 』マニュアルを参照してください。

MP-BGP IPv6 アドレス ファミリのノンストップ フォワーディングおよびグレースフル リスタート

グレースフル リスタート機能は、IPv6 BGP ユニキャスト、および VPNv6 アドレス ファミリでサポートされ、BGP IPv6 で Cisco NSF 機能を実現しています。BGP グレースフル リスタート機能を使用すると、TCP 状態を維持することなく、BGP ルーティング テーブルをピアから回復できます。

NSF では、ルーティング プロトコルのコンバージェンス時にも引き続きパケットが転送されるため、スイッチオーバー時のルート フラップが回避されます。転送は、アクティブ RP とスタンバイ RP 間で FIB を同期することで維持されます。スイッチオーバー時、転送は FIB を使用して維持されます。RIB の同期は維持されないため、RIB はスイッチオーバー時に空になります。RIB は、ルーティング プロトコルによって再入力され、次に、NSF_RIB_CONVERGED レジストリ コールを使用して RIB コンバージェンスに関する情報を FIB に伝えます FIB テーブルは、RIB から更新され、古いエントリが削除されます。RIB は、ルーティング プロトコルが RIB のコンバージェンスの通知に失敗した場合、RP スイッチオーバー時にフェールセーフ タイマーを開始します。

Cisco BGP Address Family Identifier(AFI)モデルは、モジュラ式で拡張性に優れ、複数の AFI 設定および Subsequent Address Family Identifier(SAFI)設定をサポートします。

IPv6 BGP グレースフル リスタート機能を設定する方法については『 Implementing Multiprotocol BGP for IPv6 』マニュアルを参照してください。

IPv6 RIP のノンストップ フォワーディング

RIP は IPv6 NSF クライアントとして登録されます。これにより、RIP がスタンバイ上で収束を完了するまで、シスコ エクスプレス フォワーディング テーブルにインストールされている RIP ルートを使用できるという利点が得られます。

IPv6 スタティック ルートでのノンストップ フォワーディング

Cisco NSF は IPv6 スタティック ルートをサポートしています。

NSF のデフォルト設定

なし。

NSF の設定方法

「NSF の BGP の設定および検証」(任意)

「EIGRP NSF の設定および検証」(任意)

「OSPF NSF の設定および検証」(任意)

「IS-IS NSF の設定および検証」(任意)

「Cisco Nonstop Forwarding のトラブルシューティング」(任意)

NSF の BGP の設定および検証

「NSF の BGP の設定」

「BGP での NSF の確認」

NSF の BGP の設定

NSF の BGP を設定するには、次の作業を実行します。この作業は各 BGP NSF ピア デバイスで繰り返します。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# router bgp autonomous-system-number

BGP ルーティング プロセスをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

ステップ 4

Router(config-router)# bgp graceful-restart [ restart-time seconds | stalepath-time seconds ]

BGP 対応の NSF を開始する BGP グレースフル リスタート機能をイネーブルにします。

次に、NSF の BGP を設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# router bgp 120
Router(config-router)# bgp graceful-restart

BGP での NSF の確認

グレースフル リスタート機能が SSO 対応ネットワーキング デバイスおよびネイバー デバイス上で設定されているか確認するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# show running-config

現在実行されているコンフィギュレーション ファイルの内容を表示します

「bgp graceful-restart」のフレーズが SSO 対応ルータの BGP コンフィギュレーションに表示されていることを確認します。

各 BGP ネイバーでこの手順を繰り返します。

ステップ 3

Router# show ip bgp neighbors [ ip-address [ advertised-routes | dampened-routes | flap-statistics | paths [ reg-exp ] | received prefix-filter | received-routes | routes | policy [ detail ]]]

ネイバーに対する BGP 接続と TCP 接続に関する情報を表示します。

SSO デバイスおよびネイバー デバイスで、このコマンドはグレースフル リスタート機能がアドバタイズおよび受信されたことを示していることを検証し、グレースフル リスタート機能を備えたアドレス ファミリであることを確認します。アドレス ファミリが表示されない場合、BGP NSF も発生しません。

次に、BGP の NSF を確認する例を示します。

Router> enable
Router# configure terminal
Router# show running-config
Router# show ip bgp neighbors

EIGRP NSF の設定および検証

「NSF の EIGRP の設定」

「NSF での EIGRP の確認」

NSF の EIGRP の設定


) • NSF 認識ルータがネットワークと完全にコンバージェンスされて、NSF 再起動処理で NSF 対応ルータを支援できる状態になっている必要があります。

サポートされているバージョンの Cisco IOS ソフトウェアが動作する分散プラットフォームは、完全な NSF 機能をサポートできます。このようなルータは、再起動処理を実行するとともに、他の NSF 対応のピアをサポートできます。

サポートされているバージョンの Cisco IOS ソフトウェアが動作するシングル プロセッサ プラットフォームは、NSF 認識のみをサポートします。サポートされている NSF 認識ルータは、NSF 対応ルータからトポロジ テーブルの送信を指示するか信号が届くか、またはルート ホールド タイマーが期限切れになるまで、隣接関係を維持し、NSF 対応のネイバーへの既知のルートを保持します。


 

NSF の EIGRP を設定するには、次の作業を実行します。この作業は各 EIGRP NSF ピア デバイスで繰り返します。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# router eigrp as-number

EIGRP ルーティング プロセスをイネーブルにして、ルータ コンフィギュレーション モードを開始します。

ステップ 4

Router(config-router)# nsf [{ cisco | ietf } | interface wait seconds | interval minutes | t3 [ adjacency | manual seconds ]

(任意)NSF 対応ルータで EIGRP NSF サポートをイネーブルにします。このコマンドは、NSF 対応ルータでのみ入力します。サポートする Cisco IOS ソフトウェアバージョンが、NSF 対応または NSF 認識をサポートするルータにインストールされている場合は、NSF 認識はデフォルトでイネーブルになっています。

ステップ 5

Router(config-router)# timers nsf converge seconds

再起動しているルータが NSF 対応または NSF 認識ピアから EOT 通知を待機する最大時間を調整します。

ステップ 6

Router(config-router)# timers nsf route-hold seconds

EIGRP を実行している NSF 認識ルータが、非アクティブなピア用のルートを保持する期間を決定するために、ルート ホールド タイマーを設定します。

ステップ 7

Router(config-router)# timers nsf signal seconds

初期再起動期間の最大時間を調整します。

次に、NSF の EIGRP を設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# router eigrp 109
Router(config-router)# nsf
Router(config-router)# timers nsf converge 60
Router(config-router)# timers nsf route-hold 120
Router(config-router)# timers nsf signal seconds

NSF での EIGRP の確認

NSF 認識または NSF 対応、またはその両方が SSO 対応ネットワーキング デバイスおよびネイバー デバイス上で設定されているか確認するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# show ip protocols

アクティブ ルーティング プロトコル プロセスのパラメータと現在の状態を表示します。

各 EIGRP ネイバーでこの手順を繰り返します。

次に、NSF の EIGRP を確認する例を示します。

Router> enable
Router# show ip protocols

OSPF NSF の設定および検証

「NSF OSPF の設定」

「NSF での OSPF の確認」

NSF OSPF の設定


) OSPF NSF に参加するすべてのピア デバイスは、OSPF NSF 認識にされなければなりません。サポートする Cisco IOS ソフトウェアのバージョンが NSF 対応または NSF 認識をサポートするルータにインストールされている場合は、NSF 認識はデフォルトでイネーブルになっています。


NSF の OSPF を設定するには、次の作業を実行します。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# router ospf process-id [ vrf vpn-name ]

OSPF ルーティング プロセスをイネーブルにし、ルータをルータ コンフィギュレーション モードにします。

ステップ 4

Router(config-router)# nsf [{ cisco | ietf } | interface wait seconds | interval minutes | t3 [ adjacency | manual seconds ]

NSF 対応ルータで EIGRP NSF サポートをイネーブルにします。

このコマンドは、NSF 対応ルータでのみ入力します。

次に、NSF の OSPF を設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# router ospf 12
Router(config-router)# nsf

NSF での OSPF の確認

NSF の OSPF を確認するには、次の作業を実行します。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# show ip ospf [ process-id ]

OSPF ルーティング プロセスに関する一般情報を表示します。

次に、NSF の OSPF を確認する例を示します。

Router> enable
Router# show ip ospf

IS-IS NSF の設定および検証

「IS-IS の NSF の設定」

「IS-IS の NSF の確認」

IS-IS の NSF の設定

IS-IS の NSF を設定するには、次の作業を実行します。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# router isis area-tag

IS-IS ルーティング プロトコルをイネーブルにして IS-IS プロセスを指定し、ルータをルータ コンフィギュレーション モードにします。

ステップ 4

Router(config-router)# nsf [{ cisco | ietf } | interface wait seconds | interval minutes | t3 [ adjacency | manual seconds ]

IS-IS 用 NSF をイネーブルにします。

ietf :IETF ドラフトベースの再起動をサポートするネットワーキング デバイスとの隣接関係がサポートしている同種ネットワークで IS-IS をイネーブルにする。

cisco :NSF 認識ネットワーキング デバイスとの隣接関係がない同種ネットワークで IS-IS を実行する。

ステップ 5

Router(config-router)# nsf interval minutes

Cisco NSF 再起動試行の間隔の最小時間を設定します。

ステップ 6

Router(config-router)# nsf t3 { manual seconds | adjacency }

IETF NSF が過負荷になっているリンクのステート情報を生成して、その情報をネイバーにフラッディングする前に、リンク ステート パケット(LSP)データベースが同期するまで IETF Cisco NSF が待機する時間の決定に使用される方法を指定します。

ステップ 7

Router(config-router)# nsf interface wait seconds

Cisco NSF 再起動時に、再起動が完了する前に IS-IS 隣接関係を持つすべてのインターフェイスがアップするまで待機する時間を指定します。

次に、IS-IS の NSF を設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# router isis cisco1
Router(config-router)# nsf ietf
Router(config-router)# nsf interval 2
Router(config-router)# nsf t3 manual 40
Router(config-router)# nsf interface wait 15

IS-IS の NSF の確認

IS-IS の NSF を確認するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします(プロンプトが表示されたらパスワードを入力します)。

ステップ 2

Router# show running-config

現在実行されているコンフィギュレーション ファイルの内容を表示します

ステップ 3

Router# show isis nsf

IS-IS NSF に関する現在のステート情報を表示します。

次に、IS-IS の NSF を確認する例を示します。

Router> enable
Router# show running-config
Router# show isis nsf

Cisco Nonstop Forwarding のトラブルシューティング

Cisco Nonstop Forwarding をトラブルシューティングするには、必要に応じて次のコマンドを使用します。

 

コマンド
目的

Router# debug eigrp nsf

EIGRP ルーティング プロセスの NSF イベントに関する通知と情報を表示します。

Router# debug ip eigrp notifications

EIGRP ルーティング プロセスの情報と通知を表示します。この出力には、NSF 通知とイベントが含まれています。

Router# debug isis nsf [ detail ]

Cisco NSF の再起動時の IS-IS ステートに関する情報を表示します。

Router# debug ospf nsf [ detail ]

OSPF Cisco NSF コマンドに関するデバッグ メッセージが表示されます。

Router# show cef nsf

アクティブ RP とスタンバイ RP の両方における CEF の現在の NSF ステートを表示します。

Router# show cef state

ネットワーキング デバイスでの CEF ステートを表示します。

Router# show clns neighbors

エンド システムと中継システムの両方のネイバーを表示します。

Router# show ip bgp

BGP ルーティング テーブル内のエントリを表示します。

Router# show ip bgp neighbor

ネイバー デバイスへの TCP 接続および BGP 接続についての情報を表示します。

Router# show ip cef

未解決の FIB エントリを表示するか、FIB の要約を表示します。

Router# show ip eigrp neighbors [ interface-type | as-number | static | detail ]

EIGRP によって検出されたネイバーについての詳細情報を表示します。

Router# show ip ospf

OSPF ルーティング プロセスに関する一般情報を表示します。

Router# show ip ospf neighbor [ detail ]

OSPF のネイバー情報をインターフェイス単位で表示します。

Router# show ip protocols

アクティブ ルーティング プロトコル プロセスのパラメータと現在の状態を表示します。EIGRP NSF 設定のステータスとサポートが出力に表示されます。

Router# show isis database [ detail ]

IS-IS リンクステート データベースを表示します。

Router# show isis nsf

IS-IS Cisco NSF に関する現在のステート情報を表示します。

NSF の設定例

「例:BGP NSF の設定」

「例:BGP NSF の隣接デバイスの設定」

「例:BGP NSF の確認」

「例:EIGRP NSF の収束タイマーの設定」

「例:EIGRP グレースフル リスタート パージ時間タイマーの設定」

「例:EIGRP NSF のルート ホールド タイマーの設定」

「例:EIGRP NSF の信号タイマーの設定」

「例:EIGRP NSF サポートのディセーブル化」

「例:EIGRP NSF の確認」

「例:OSPF NSF の設定」

「例:OSPF NSF の確認」

「例:IS-IS NSF の設定」

「例:IS-IS NSF の確認」

例:BGP NSF の設定

次の例に、BGP NSF をネットワーキング デバイスで設定する方法を示します。

Router# configure terminal
Router(config)# router bgp 590
Router(config-router)# bgp graceful-restart

例:BGP NSF の隣接デバイスの設定

次に、隣接ルータで BGP NSF を設定する例を示します。BGP NSF をサポートするすべてのデバイスは、NSF 認識であることが必要です。これは、これらのデバイスがグレースフル リスタート機能を認識し、アドバタイズすることを意味します。

Router# configure terminal
Router(config)# router bgp 770
Router(config-router)# bgp graceful-restart

例:BGP NSF の確認

show running-config コマンドを入力して、「bgp graceful-restart」が SSO 対応ルータの BGP コンフィギュレーションに表示されているか確認します。

Router# show running-config
 
router bgp 120
bgp graceful-restart
neighbor 10.2.2.2 remote-as 300
 

SSO デバイスおよびネイバー デバイスで、グレースフル リスタート機能がアドバタイズおよび受信されたことを示していることを確認し、グレースフル リスタート機能を備えたアドレス ファミリであることを確認します。アドレス ファミリが表示されない場合、BGP NSF も発生しません。

Router# show ip bgp neighbors x.x.x.x
 
BGP neighbor is 192.168.2.2, remote AS YY, external link
BGP version 4, remote router ID 192.168.2.2
BGP state = Established, up for 00:01:18
Last read 00:00:17, hold time is 180, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh:advertised and received(new)
Address family IPv4 Unicast:advertised and received
Address family IPv4 Multicast:advertised and received
Graceful Restart Capabilty:advertised and received
Remote Restart timer is 120 seconds
Address families preserved by peer:
IPv4 Unicast, IPv4 Multicast
Received 1539 messages, 0 notifications, 0 in queue
Sent 1544 messages, 0 notifications, 0 in queue
Default minimum time between advertisement runs is 30 seconds

例:EIGRP NSF の収束タイマーの設定

timers nsf converge コマンドを使用して、再起動しているルータが NSF 対応または NSF 認識ピアから EOT 通知を待機する最大時間を調整します。次に、収束タイマーを 1 分に設定する例を示します。

Router# configure terminal
Router(config)# router eigrp 101
Router(config-router)# timers nsf converge 60

例:EIGRP グレースフル リスタート パージ時間タイマーの設定

timers graceful-restart purge-time コマンドを使用して、ルートホールド タイマーを設定します。これにより、EIGRP を実行している NSF 認識ルータが、非アクティブなピアに対してルートを保持する期間を設定します。次の例は、ルートホールド タイマーを 2 分に設定する方法を示しています。

Router(config-router)# timers graceful-restart purge-time 120

例:EIGRP NSF のルート ホールド タイマーの設定

timers nsf route-hold コマンドを使用して、スイッチオーバーの実行中に NSF 認識ルータが NSF 対応ネイバーに対する既知のルートを保持する最大期間を設定します。次の例は、ルートホールド タイマーを 2 分に設定する方法を示しています。

Router# configure terminal
Router(config)# router eigrp 101
Router(config-router)# timers nsf route-hold 120

例:EIGRP NSF の信号タイマーの設定

timers nsf signal コマンドを使用して、初期再起動期間の最大時間を調整します。次に、信号タイマーを 10 秒に設定する例を示します。

Router# configure terminal

Router(config)# router eigrp 101

Router(config-router)# timers nsf signal 10

例:EIGRP NSF の確認

show ip protocols コマンドを入力して、インストールされている Cisco IOS ソフトウェア イメージに EIGRP NSF サポートが存在することを確認します。NSF 認識または対応がルータでサポートされている場合に、「EIGRP NSF-aware route hold timer is...」が出力に表示されます。この行に、ルートホールド タイマーのデフォルト値またはユーザ定義の値が表示されます。NSF 対応がルータでサポートされている場合にのみ、「EIGRP NSF...」が出力に表示されます。この行には、EIGRP NSF 機能のステータスによって、「disabled」または「enabled」が表示されます。

Router# show ip protocols
 
Routing Protocol is "eigrp 100"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 100
EIGRP NSF-aware route hold timer is 240s
EIGRP NSF enabled
NSF signal timer is 20s
NSF converge timer is 120s
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.4.9.0/24
Routing Information Sources:
Gateway Distance Last Update
Distance: internal 90 external 170

例:EIGRP NSF サポートのディセーブル化

EIGRP NSF 機能は、Cisco IOS ソフトウェアのサポート バージョンを実行している分散プラットフォームにおいてデフォルトでイネーブルです。EIGRP NSF 対応をイネーブルまたはディセーブルにするには nsf コマンドを使用します。次に、NSF 対応をディセーブルにする例を示します。

Router# configure terminal
Router(config)# router eigrp 101
Router(config-router)# no nsf

例:OSPF NSF の設定

次の例に、OSPF NSF をネットワーキング デバイスで設定する方法を示します。

Router# configure terminal
Router(config)# router ospf 400
Router(config-router)# nsf

例:OSPF NSF の確認

OSPF の NSF を確認するには、NSF 機能が SSO 対応ネットワーキング デバイス上で設定されていることを確認する必要があります。 show running-config コマンドを入力して、「nsf」が SSO 対応デバイスの OSPF コンフィギュレーションに表示されていることを確認します。

Router# show running-config
 
router ospf 120
log-adjacency-changes
nsf
network 192.168.20.0 0.0.0.255 area 0
network 192.168.30.0 0.0.0.255 area 1
network 192.168.40.0 0.0.0.255 area 2
 

次に、NSF がデバイス上でイネーブルであることを確認するには、 show ip ospf コマンドを入力します。

Router> show ip ospf
 
Routing Process "ospf 1" with ID 192.168.2.1 and Domain ID 0.0.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x0
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Non-Stop Forwarding enabled, last NSF restart 00:02:06 ago (took 44 secs)
Area BACKBONE(0)
Number of interfaces in this area is 1 (0 loopback)
Area has no authentication
SPF algorithm executed 3 times

例:IS-IS NSF の設定

次の例に、シスコ独自の IS-IS NSF 動作をネットワーキング デバイスで設定する方法を示します。

Router# configure terminal
Router(config)# router isis
Router(config-router)# nsf cisco
 

次の例に、IETF の IS-IS NSF 動作をネットワーキング デバイスで設定する方法を示します。

Router# configure terminal
Router(config)# router isis
Router(config-router)# nsf ietf

例:IS-IS NSF の確認

show running-config コマンドを入力して、「NSF」が SSO 対応デバイスの IS-IS コンフィギュレーションに表示されているか確認します。表示は、Cisco IS-IS または IETF IS-IS コンフィギュレーションを示しています。次の例は、デバイスが IS-IS NSF のシスコ実装を使用していることを示します。

Router# show running-config
 
router isis
nsf cisco
 

NSF コンフィギュレーションが cisco に設定されている場合、NSF がデバイス上でイネーブルかを確認するには show isis nsf コマンドを使用します。シスコのコンフィギュレーションを使用すると、コマンドの出力はアクティブ RP およびスタンバイ RP で異なります。次に、アクティブ RP 上のシスコ コンフィギュレーションの出力例を示します。この例では、「NSF restart enabled」のフレーズがあることに注意してください。

Router# show isis nsf
 
NSF is ENABLED, mode 'cisco'
 
RP is ACTIVE, standby ready, bulk sync complete
NSF interval timer expired (NSF restart enabled)
Checkpointing enabled, no errors
Local state:ACTIVE, Peer state:STANDBY HOT, Mode:SSO
 

次に、スタンバイ RP 上のシスコ コンフィギュレーションの出力例を示します。この例では、「NSF restart enabled」のフレーズがあることに注意してください。

Router# show isis nsf
 
NSF enabled, mode 'cisco'
RP is STANDBY, chkpt msg receive count:ADJ 2, LSP 7
NSF interval timer notification received (NSF restart enabled)
Checkpointing enabled, no errors
Local state:STANDBY HOT, Peer state:ACTIVE, Mode:SSO
 

次に、ネットワーキング デバイス上の IETF IS-IS コンフィギュレーションの出力例を示します。

Router# show isis nsf
 
NSF is ENABLED, mode IETF
NSF pdb state:Inactive
NSF L1 active interfaces:0
NSF L1 active LSPs:0
NSF interfaces awaiting L1 CSNP:0
Awaiting L1 LSPs:
NSF L2 active interfaces:0
NSF L2 active LSPs:0
NSF interfaces awaiting L2 CSNP:0
Awaiting L2 LSPs:
Interface:Serial3/0/2
NSF L1 Restart state:Running
NSF p2p Restart retransmissions:0
Maximum L1 NSF Restart retransmissions:3
L1 NSF ACK requested:FALSE
L1 NSF CSNP requested:FALSE
NSF L2 Restart state:Running
NSF p2p Restart retransmissions:0
Maximum L2 NSF Restart retransmissions:3
L2 NSF ACK requested:FALSE
Interface:GigabitEthernet2/0/0
NSF L1 Restart state:Running
NSF L1 Restart retransmissions:0
Maximum L1 NSF Restart retransmissions:3
L1 NSF ACK requested:FALSE
L1 NSF CSNP requested:FALSE
NSF L2 Restart state:Running
NSF L2 Restart retransmissions:0
Maximum L2 NSF Restart retransmissions:3
L2 NSF ACK requested:FALSE
L2 NSF CSNP requested:FALSE
Interface:Loopback1
NSF L1 Restart state:Running
NSF L1 Restart retransmissions:0
Maximum L1 NSF Restart retransmissions:3
L1 NSF ACK requested:FALSE
L1 NSF CSNP requested:FALSE
NSF L2 Restart state:Running
NSF L2 Restart retransmissions:0
Maximum L2 NSF Restart retransmissions:3
L2 NSF ACK requested:FALSE
L2 NSF CSNP requested:FALSE

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する