Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.1SY
MPLS QoS
MPLS QoS
発行日;2013/08/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

MPLS QoS

用語

MPLS QoS の機能

MPLS 実験フィールド

信頼

分類

ポリシングおよびマーキング

IP ToS の保持

EXP 変換

MPLS DiffServ トンネリング モード

MPLS QoS の概要

IP precedence フィールドでの QoS の指定

MPLS QoS

MPLS トポロジの概要

MPLS ネットワークの入力エッジでの LER

MPLS ネットワークのコアにある LSR

MPLS ネットワークの出力エッジでの LER

EoMPLS エッジの LER

IP エッジ(MPLS、MPLS VPN)での LER

IP to MPLS

MPLS to IP

MPLS VPN

MPLS コアでの LSR

MPLS to MPLS

MPLS QoS のデフォルト設定

MPLS QoS コマンド

MPLS QoS の制約事項

MPLS QoS の設定方法

queueing-only モードのイネーブル化

制約事項および使用上の注意事項

MPLS パケットを分類するためのクラス マップの設定

制約事項および使用上の注意事項

ポリシー マップの設定

EXP 値をすべてのインポーズされたラベルに設定するためのポリシー マップの設定

police コマンドを使用したポリシー マップの設定

ポリシー マップの表示

すべてのクラスのコンフィギュレーションの表示

MPLS QoS の出力 EXP 変換の設定

名前付き EXP 変換マップの設定

インターフェイスへの出力 EXP 変換マップの付加

EXP 値マッピングの設定

入力 EXP から内部 DSCP へのマッピングの設定

名前付き出力 DSCP から出力 EXP へのマッピングの設定

MPLS DiffServ トンネリング モード

ショート パイプ モード

ショート パイプ モードの制約事項

均一モード

均一モードの制約事項

MPLS DiffServ トンネリングの制約事項および使用上のガイドライン

ショート パイプ モードの設定例

入力 PE ルータ:カスタマー側に向かうインターフェイス

入力 PE ルータの設定:P 側に向かうインターフェイス

設定例

P ルータの設定:出力インターフェイス

設定例

出力 PE ルータの設定:カスタマー側に向かうインターフェイス

設定例

均一モードの設定方法

入力 PE ルータの設定:カスタマー側に向かうインターフェイス

設定例

入力 PE ルータの設定:P 側に向かうインターフェイス

出力 PE ルータの設定:カスタマー側に向かうインターフェイス

MPLS QoS

「用語」

「MPLS QoS の機能」

「MPLS QoS の概要」

「MPLS QoS」

「MPLS QoS のデフォルト設定」

「MPLS QoS コマンド」

「MPLS QoS の制約事項」

「MPLS QoS の設定方法」

「MPLS DiffServ トンネリング モード」

「ショート パイプ モードの設定例」

「均一モードの設定方法」


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。

MPLS QoS は、 で説明する PFC QoS 機能を MPLS トラフィックに拡張します。

ここでは、MPLS QoS の各機能についての補足情報を説明します。この章を読むには、PFC QoS 機能を理解していることが前提となります。


 

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する


 

用語

サービス クラス (CoS):スイッチド ネットワークを通過するときにイーサネット フレームのプライオリティを示す 802.1Q ヘッダーの 3 ビットのことです。802.1Q ヘッダーの CoS ビットは通常 802.1p ビットと呼ばれます。パケットがレイヤ 2 およびレイヤ 3 ドメインの両方を横断するときに QoS を維持するため、タイプ オブ サービス(ToS)値と CoS 値は互いにマッピングすることができます。

分類 :QoS をマーキングするトラフィックを選択する処理です。

DiffServ コード ポイント (DSCP):IP ヘッダーの ToS バイトの上位 6 ビットです。DSCP は、IP パケットだけに存在します。

E-LSP :ラベル スイッチド パス(LSP)の 1 つであり、ノードはここで MPLS ヘッダーの Experimental(EXP)ビットから排他的に MPLS パケットの QoS 処理を判断します。QoS 処理が EXP(クラスおよびドロップ優先順位の両方)から判断されるため、いくつかのクラスのトラフィックを 1 つの LSP に多重化することができます(同じラベルを使用)。EXP フィールドは 3 ビット フィールドであるため 1 つの LSP は最大 8 つのトラフィックのクラスをサポートすることができます。コントロール プレーン トラフィック用にいくつかの値が予約されている場合、またはクラスのいくつかがそれらに対応するドロップ優先順位を持っている場合、クラスの最大数はさらに少なくなります。

EXP ビット :ノードがパケットに与える QoS 処理(Per-Hop Behavior)を定義します。これは、IP ネットワークの DiffServ コード ポイント(DSCP)に相当します。DSCP は、クラスとドロップ優先順位を定義します。EXP ビットは、一般に IP DSCP でエンコードされた情報をすべて伝送するのに使用されます。ただし、ドロップ優先順位をエンコードするために EXP ビットが排他的に使用される場合もあります。

フレーム は、レイヤ 2 でトラフィックを伝送します。レイヤ 2 フレームは、レイヤ 3 パケットを伝送します。

IP precedence :IP ヘッダーの ToS バイトの最上位 3 ビットです。

QoS タグ :レイヤ 3 パケットおよびレイヤ 2 フレームで伝達されるプライオリティ値です。レイヤ 2 CoS ラベルは、0(ロー プライオリティ)~ 7(ハイ プライオリティ)の範囲です。レイヤ 3 IP precedence ラベルは、0(ロー プライオリティ)~ 7(ハイ プライオリティ)の範囲です。IP precedence 値は、1 バイトの ToS バイトの最上位 3 ビットで定義されます。レイヤ 3 DSCP ラベルは、0 ~ 63 の値を持つことができます。DSCP 値は 1 バイトの IP ToS フィールドのうち最上位 6 ビットで定義されます。

LER (ラベル エッジ ルータ):パケット上のラベルのインポーズおよびディスポーズを行うデバイスであり、プロバイダー エッジ(PE)ルータとも呼ばれます。

LSR (ラベル スイッチング ルータ):パケット上のラベルに基づいてトラフィックを転送するデバイスであり、プロバイダー(P)ルータとも呼ばれます。

マーキング :パケットのレイヤ 3 DSCP 値を設定するプロセスです。マーキングはまた、MPLS EXP フィールドで異なった値を選択してパケットにマーキングし、輻輳時にパケットが必要なプライオリティを持つようにするプロセスでもあります。

パケット :レイヤ 3 でトラフィックを伝送します。

ポリシング :トラフィック フローが使用する帯域幅を制限する処理です。ポリシングによって、トラフィックのマーキングまたはドロップが可能になります。

MPLS QoS の機能

「MPLS 実験フィールド」

「信頼」

「分類」

「ポリシングおよびマーキング」

「IP ToS の保持」

「EXP 変換」

「MPLS DiffServ トンネリング モード」

MPLS 実験フィールド

MPLS EXP(実験)フィールド値を設定すると、サービス プロバイダーが自己のネットワークで伝送された IP パケット内で変更された IP precedence フィールドの値を望まない場合に、サービス プロバイダーの要件を満たすことができます。

MPLS EXP フィールドで異なった値を選択することにより、輻輳時にパケットが必要なプライオリティを持つようパケットをマーキングすることができます。

デフォルトでは、インポジション中に、IP precedence 値が MPLS EXP フィールドにコピーされます。MPLS EXP ビットは、MPLS QoS ポリシーによってマーキングできます。

信頼

受信レイヤ 3 MPLS パケットに対し、PFC は、通常、受信最上位ラベルの EXP 値を信頼します。MPLS パケットは、次のいずれの影響も受けません。

インターフェイスの信頼状態

ポートの CoS 値

policy-map trust コマンド

受信レイヤ 2 MPLS パケットの場合、PFC は、CoS および出力キュー処理の目的で、受信最上位ラベルの EXP 値を信頼するか、ポートまたはポリシーの信頼を MPLS パケットに適用できます。

分類

分類とはマーキングするトラフィックを選択するプロセスです。分類は、トラフィックを複数の優先順位レベル、つまり、サービス クラスに分割することによりこのプロセスを実施します。トラフィック分類は、クラス ベースの QoS プロビジョニングのプライマリ コンポーネントです。PFC は、(ポリシーのインストール後)受信 MPLS パケットの受信最上位ラベルの EXP ビットに基づいて分類を決定します。詳細については、「MPLS パケットを分類するためのクラス マップの設定」を参照してください。

ポリシングおよびマーキング

ポリシングを行うと、設定レートを超えたトラフィックは廃棄されるか、またはより高いドロップ優先順位にマークダウンされます。マーキングは、パケット フローを識別して、これらを区別する手法です。パケット マーキングを利用すれば、ネットワークを複数の優先プライオリティ レベルまたはサービス クラスに分割することができます。

実装可能な MPLS QoS ポリシングおよびマーキング機能は、受信したトラフィック タイプ、およびトラフィックに適用される転送処理によって決まります。詳細については、「ポリシー マップの設定」を参照してください。

IP ToS の保持

PFC は、インポジション、スワッピング、ディスポジションを含むすべての MPLS 動作中、自動的に IP ToS を保持します。IP ToS を保存するコマンドを入力する必要はありません。

EXP 変換

最大 8 個の出力 EXP 変換マップを設定して、内部 EXP 値が出力 EXP 値として書き込まれる前に内部 EXP 値を変換することができます。出力 EXP 変換マップは、次のインターフェイス タイプに付加できます。

LAN ポート サブインターフェイス

レイヤ 3 VLAN インターフェイス

レイヤ 3 LAN ポート

レイヤ 2 LAN ポート( switchport コマンドにより設定されるポート)に、EXP 変換マップを付加できます。

設定の詳細については、「MPLS QoS の出力 EXP 変換の設定」を参照してください。

MPLS DiffServ トンネリング モード

PFC は、MPLS DiffServ トンネリング モードを使用します。トンネリングは、ネットワークの 1 つのエッジから、そのネットワークの別のエッジまでの QoS 透過性を提供します。詳細については、「MPLS DiffServ トンネリング モード」を参照してください。

MPLS QoS の概要

ネットワーク管理者は MPLS QoS を使用することで、差別化したサービス タイプを MPLS ネットワーク上で提供できます。差別化サービスは、QoS によって各送信パケットに指定されたサービスを提供することにより、幅広い要件を満たします。サービスは、IP パケット内の IP precedence ビット設定を使用するなどさまざまな方法で指定することができます。

IP precedence フィールドでの QoS の指定

IP パケットを 1 つのサイトから別のサイトへ送信する場合、IP precedence フィールド(IP パケットのヘッダーの DSCP フィールドの上位 3 ビット)が QoS を指定します。IP precedence マーキングに基づき、パケットにはその QoS に対して設定された処理が適用されます。サービス プロバイダー ネットワークが MPLS ネットワークである場合、ネットワークのエッジで IP precedence ビットが MPLS EXP フィールドにコピーされます。ただし、サービス プロバイダーは、ある MPLS パケットの QoS に、提供するサービスによって決定される異なった値を設定することが必要な場合もあります。

この場合、サービス プロバイダーは MPLS EXP フィールドを設定できます。IP ヘッダーはカスタマーが利用できるよう引き続き利用可能であり、IP パケットの QoS はパケットが MPLS ネットワークを移動する間は変更されません。

詳細については、「MPLS DiffServ トンネリング モード」を参照してください。

MPLS QoS

「MPLS トポロジの概要」

「MPLS ネットワークの入力エッジでの LER」

「MPLS ネットワークのコアにある LSR」

「MPLS ネットワークの出力エッジでの LER」

「EoMPLS エッジの LER」

「IP エッジ(MPLS、MPLS VPN)での LER」

「MPLS コアでの LSR」

MPLS トポロジの概要

図 67-1 カスタマーの IP ネットワークの 2 つのサイトを接続する MPLS ネットワーク

 

このネットワークは両方向ですが、ここではパケットは左から右へ移動します。

CE1:カスタマー装置 1

PE1:サービス プロバイダー入力ラベル エッジ ルータ(LER)

P1:サービス プロバイダーのネットワークのコア内のラベル スイッチ ルータ(LSR)

P2:サービス プロバイダーのネットワークのコア内の LSR

PE2:サービス プロバイダー出力 LER

CE2:カスタマー装置 2

PE1 および PE2 は、MPLS ネットワークと IP ネットワークの境界にあります。

MPLS QoS は、IP QoS をサポートしています。MPLS パケットについては、PFC が非 MPLS の QoS マーキングおよびポリシングを適用できるように、EXP 値が内部 DSCP にマッピングされます。

入力および出力ポリシーでは、MPLS QoS マーキングおよびポリシングの決定が、入力 PFC でインターフェイス単位で行われます。入力インターフェイスは物理ポート、サブインターフェイス、または VLAN です。

QoS ポリシー ACL は、入力および出力検索用に別途 QoS Ternary Content Addressable Memory(TCAM)でプログラミングされます。TCAM 出力検索は、IP 転送テーブル(Forwarding Information Base(FIB; 転送情報ベース))および NetFlow の検索が完了したあとで行われます。

各 QoS TCAM の検索結果により、ポリサー設定とポリシング カウンタを含む RAM へのインデックスが生成されます。追加 RAM には、microflow ポリサー設定が含まれ、microflow ポリシング カウンタは QoS ACL と一致する各 NetFlow エントリ内に維持されます。

入力および出力集約および microflow ポリシングの結果は統合されて最終ポリシング決定となります。不適合パケットは、ドロップするか、DSCP 内でマークダウンすることがきます。

MPLS ネットワークの入力エッジでの LER


) 着信ラベルには集約または非集約の 2 つのタイプがあります。集約ラベルの場合は、ネクスト ホップおよび発信インターフェイスを検出するときに、IP 検索を通して着信 MPLS または MPLS VPN パケットをスイッチングする必要があります。非集約ラベルの場合は、パケットに IP ネクスト ホップ情報が格納されます。


ここでは、MPLS ネットワークの入力側または出力側で、エッジ LER がどのように動作するかを説明します。

MPLS ネットワークの入力側では、LER がパケットを次のように処理します。

1. レイヤ 2 またはレイヤ 3 トラフィックはエッジ LER(PE1)で MPLS ネットワークのエッジに入ります。

2. PFC は、入力インターフェイスからトラフィックを受信し、802.1p ビットまたは IP ToS ビットを使用して EXP ビットを判別し、分類、マーキング、ポリシングを実行します。着信 IP パケットの分類については、入力サービス ポリシーもアクセス コントロール リスト(ACL)を使用することができます。

3. PFC は着信 IP パケットごとに IP アドレスの検索を行い、ネクストホップ ルータを決定します。

4. 適切なラベルがパケットにプッシュ(インポジション)され、QoS 決定の結果としての EXP 値はラベル ヘッダーの MPLS EXP フィールドにコピーされます。

5. PFC は、ラベル付きパケットを適切な処理用出力インターフェイスに転送します。

6. PFC はまた、802.1p ビットまたは IP ToS ビットを出力インターフェイスに転送します。

7. 出力インターフェイスでは、ラベル付きパケットはクラスごとに区別され、マーキングまたはポリシングが行われます。LAN インターフェイスについては、出力分類はまだ MPLS ではなく IP に基づいて行われています。

8. (EXP によってマーキングされた)ラベル付きパケットは、コア MPLS ネットワークに送信されます。

MPLS ネットワークのコアにある LSR

ここでは、MPLS ネットワーク コアで使用される LSR がパケットを処理する方法について説明します。

1. エッジ LER(または他のコア デバイス)からの着信 MPLS ラベル付きパケット(および 802.1p ビットまたは IP ToS ビット)がコア LSR に着信します。

2. PFC は、入力インターフェイスからトラフィックを受信し、EXP ビットを使用して、分類、マーキング、ポリシングを実行します。

3. PFC または DFC は、テーブルを検索してネクストホップ LSR を決定します。

4. 適切なラベルがパケットに配置(スワップ)され、MPLS EXP ビットがラベル ヘッダーにコピーされます。

5. PFC は、ラベル付きパケットを適切な処理用出力インターフェイスに転送します。

6. PFC はまた、802.1p ビットまたは IP ToS ビットを出力インターフェイスに転送します。

7. 送信パケットは、MPLS EXP フィールドによって区別され、マーキングまたはポリシングが行われます。

8. (EXP によってマーキングされた)ラベル付きパケットは、コア MPLS ネットワークの別の LSR または出力エッジの LER に送信されます。


) パケットは MPLS パケットであるため、サービス プロバイダー ネットワーク内には、使用するキューイング アルゴリズム用の IP precedence フィールドはありません。パケットは、プロバイダー エッジ ルータである PE2 に着信するまで MPLS パケットのままです。


MPLS ネットワークの出力エッジでの LER

MPLS ネットワークの出力側では、LER がパケットを次のように処理します。

1. コア LSR からの MPLS ラベル付きパケット(および 802.1p ビットまたは IP ToS ビット)が MPLS ネットワーク バックボーンから接続される出力 LER(PE2)に着信します。

2. PFC は、パケットから MPLS ラベルをポップします(ディスポジション)。集約ラベルは、元の 802.1p ビットまたは IP ToS ビットを使用して分類されます。非集約ラベルは、デフォルトでは EXP 値で分類されます。

3. 集約ラベルの場合、PFC は IP アドレスの検索を行い、パケットの宛先を決定します。次に、PFC はパケット処理のため、パケットを適切な出力インターフェイスに転送します。非集約ラベルの場合、転送はラベルに基づいて行われます。デフォルトでは、非集約ラベルは出力 PE ルータではなく最後から 2 番めのホップ ルータでポップされます。

4. PFC はまた、802.1p ビットまたは IP ToS ビットを出力インターフェイスに転送します。

5. パケットは、802.1p ビットまたは IP ToS ビットに従って区別され、それに従って処理されます。


) MPLS EXP ビットを使用すると、MPLS パケットの QoS を指定することができます。IP precedence および DSCP ビットを使用すると、IP パケットの QoS を指定することができます。


EoMPLS エッジの LER

ここでは、LER で機能する Ethernet over MPLS(EoMPLS)QoS の概要を説明します。EoMPLS QoS サポートは、IP-to-MPLS QoS に似ています。

EoMPLS では、ポートが untrusted の場合、CoS の信頼状態は自動的に VC タイプ 5(ポート モード)ではなく、VC タイプ 4(VLAN モード)に設定されます。これは、トンネル上での 802.1q CoS 保存機能に似ています。

トンネル入力で受信されたパケットは、EoMPLS インターフェイスでは untrusted として扱われます。ただし、trust CoS が入力ポートで自動的に設定され、ポリシー マーキングが適用されない VC タイプ 4 は例外です。

入力ポートが trusted として設定された場合、EoMPLS インターフェイスで受信されたパケットは元の IP パケット ヘッダーの QoS ポリシーによってマーキングされません(IP ポリシーによるマーキングは信頼できないポートで機能します)。

802.1p CoS が 802.1q ヘッダーを介して利用可能な場合、802.1p CoS は入口から出口まで保持されます。

トンネル出口から先では、1p タグが EoMPLS ヘッダー(VC タイプ 4)でトンネリングされている場合には、キューイングは保持された 802.1p CoS に基づいて行われます。それ以外の場合には、キューイングは QoS 決定から導出された CoS に基づいて行われます。

IP エッジ(MPLS、MPLS VPN)での LER

ここでは、MPLS および MPLS VPN ネットワークの入力(CE-to-PE)および出力(PE-to-CE)エッジでの LER の QoS 機能について説明します。MPLS と MPLS VPN のどちらも一般 MPLS QoS 機能をサポートします。追加的な MPLS VPN 特定 QoS については「MPLS VPN」を参照してください。

IP to MPLS の概要

PFC は IP-to-MPLS エッジで次の MPLS QoS 機能を提供します。

platform qos trust コマンドまたは policy-map コマンドに基づく EXP 値の割り当て

ポリシーを利用した EXP 値のマーキング

ポリシーを利用したトラフィックのポリシング

ここでは、IP-to-MPLS エッジで PFC がサポートする MPLS QoS 分類に関する情報を提供します。さらに、入力および出力インターフェイス モジュールによって提供される機能についても説明します。Ethernet to MPLS では、入力インターフェイス、MPLS QoS、出力インターフェイスの各機能は、IP to MPLS における該当機能と類似しています。

IP-to-MPLS 分類

PFC の IP トラフィック用入力および出力ポリシーでは、IP precedence、IP DSCP、IP ACL の match コマンドを使用して元の受信 IP でトラフィックが分類されます。出力ポリシーでは、トラフィックはインポーズされた EXP 値や入力ポリシーによって行われたマーキングに基づいて分類されません。

PFC はポートの信頼および QoS ポリシーを適用したあと、内部 DSCP を割り当てます。次に PFC は、インポーズしたラベルに内部 DSCP-to-EXP グローバル マップに基づいて EXP 値を割り当てます。複数のラベルがインポーズされている場合、EXP 値は各ラベルとも同じです。MPLS ラベルがインポーズされている場合、PFC は元の IP ToS を保持します。

PFC は、内部 DSCP-to-CoS グローバル マップに基づいて出力 CoS を割り当てます。デフォルトの内部 DSCP-to-EXP マップおよび内部 DSCP-to-CoS マップが整合している場合、出力 CoS はインポーズされた EXP と同じ値を持ちます。

入力ポートが IP-to-IP および IP-to-MPLS トラフィックの両方を受信した場合、分類を使用してこの 2 つのタイプのトラフィックを分離する必要があります。たとえば、IP-to-IP および IP-to-MPLS トラフィックの宛先アドレス範囲が異なっている場合、宛先アドレスに基づいてトラフィックを分類し、次に IP ToS ポリシーを IP-to-IP トラフィックに適用し、(インポーズされた MPLS ヘッダーに EXP 値をマーキングまたは設定する)ポリシーを IP-to-MPLS トラフィックに適用することができます。次の 2 つの例を参照してください。

IP ToS をマーキングする PFC ポリシーによって内部 DSCP を設定:このポリシーがトラフィックすべてに適用された場合は、IP-to-IP トラフィックでは出力ポートによって、出力パケット内の CoS(内部 DSCP から作成)が IP ToS バイトに書き換えられます。IP-to-MPLS トラフィックでは、PFC は、内部 DSCP をインポーズされた EXP 値にマッピングします。

MPLS EXP をマーキングする PFC ポリシーによって内部 DSCP を設定:このポリシーがトラフィックすべてに適用された場合は、IP-to-IP トラフィックでは出力ポートによって、入力 IP ポリシー(または trust)に従って IP ToS が書き換えられます。CoS は ToS からマッピングされます。IP-to-MPLS トラフィックでは、PFC は、内部 DSCP をインポーズされた EXP 値にマッピングします。

IP-to-MPLS モード MPLS QoS の分類

MPLS QoS は、PE1 への入力時に以下をサポートします。

IP precedence 値または DSCP 値に基づくマッチング、またはアクセス グループによるフィルタリング

set mpls experimental imposition および police コマンド

MPLS QoS は、PE1 からの出力時に mpls experimental topmost コマンドをサポートします。

IP-to-MPLS 入力ポートでの分類

IP-to-MPLS の分類は、IP-to-IP と同じです。LAN ポートでの分類は、受信レイヤ 2 802.1Q CoS 値に基づいて行われます。

IP-to-MPLS 出力ポートでの分類

LAN ポートでの分類は、受信した EXP 値に基づいて行われます。出力 CoS 値は、その値からマッピングされます。

出力ポートがトランクの場合は、LAN ポートは出力 CoS を出力 802.1Q フィールドにコピーします。

MPLS to IP への概要

MPLS QoS は、MPLS-to-IP エッジで次の機能をサポートします。

出力インターフェイスに従い MPLS ドメインからの送信時に EXP 値を IP DSCP に伝播するオプション

MPLS-to-IP 出力インターフェイスで IP サービス ポリシーを使用するオプション

ここでは、MPLS-to-IP MPLS QoS 分類について説明します。さらに、入力および出力モジュールによって提供される機能についても説明します。

MPLS to Ethernet の場合、入力インターフェイス、MPLS QoS、出力インターフェイスの各機能は、MPLS to IP における該当機能と類似しています。ただし、EoMPLS カプセル開放では、出力 IP ポリシーを適用できません(パケットは MPLS としてだけ分類できます)。

MPLS-to-IP 分類

PFC は QoS の結果に基づき、内部 DSCP(PFC が各フレームに割り当てる内部プライオリティ)を割り当てます。QoS 結果は次の影響を受けます。

デフォルトの信頼 EXP 値

ラベル タイプ(プレフィックス単位または集約)

VPN の数

明示的 NULL の使用

QoS ポリシー

次のような 3 つの異なった分類モードがあります。

正規 MPLS 分類:非集約ラベルについては、MPLS の再循環がないため、PFC は MPLS EXP 入力または出力ポリシーに基づいてパケットを分類します。PFC は EXP/DSCP/CoS マッピングから作成した CoS に基づき、パケットをキューイングします。この基になる IP DSCP は、出力カプセル開放後保持されるか、(EXP-to-DSCP マップを介して)EXP から上書きされます。

VPN CAM 内の集約ラベルの一致による IP 分類:PFC は、次のいずれかを行います。

基礎となる IP ToS を保存

EXP-to-DSCP グローバル マップから導出された値によって IP ToS を書き換え

IP ToS を、出力 IP ポリシーから導出された値 に変更

どの場合も、出力キューイングは DSCP-to-CoS マップから導出された最終 IP ToS に基づいています。

VPN CAM にない集約ラベルでの IP 分類:再循環のあと、PFC は MPLS カプセル開放隣接で指定された入力予約 VLAN に基づき MPLS-to-IP パケットを正規 IP-to-IP パケットと区別します。予約された VLAN は VPN および非 VPN の両方について VRF に従い割り当てられます。再循環後の入力 ToS は元の IP ToS 値でも、元の EXP 値から導出したものでもかまいません。出力 IP ポリシーはこの入力 ToS を任意の値に上書きすることができます。


) 再循環の詳細については、を参照してください。


PE-to-CE 入力上の着信 MPLS パケットの場合、PFC では MPLS 分類だけがサポートされます。入力 IP ポリシーはサポートされません。MPLS コアからの PE-to-CE トラフィックは出力時に IP として分類またはポリシングされます。

MPLS-to-IP MPLS QoS の分類

MPLS QoS は、PE2 への入力時に、EXP 値の照合および police コマンドをサポートします。

MPLS QoS は、PE2 からの出力時に、IP precedence または DSCP 値の照合、またはアクセス グループと police コマンドによるフィルタリングをサポートします。

MPLS-to-IP 入力ポートでの分類

LAN ポートでの分類は、EXP 値に基づきます。 match mpls experimental コマンドは受信最上位ラベルの EXP 値のマッチングを行います。

MPLS-to-IP 出力ポートでの分類

MPLS-to-IP の分類は、IP-to-IP と同じです。

LAN インターフェイス分類は出力 CoS に基づきます。

出力ポートがトランクの場合は、LAN ポートは出力 CoS を出力 802.1Q フィールドにコピーします。


) MPLS to IP については、出力インターフェイスの MPLS IP(またはタグ IP)がイネーブルの場合は出力 IP ACL または QoS は出力インターフェイスでは有効ではありません。例外は VPN CAM ヒットです。この場合パケットは出力では IP として分類されます。


MPLS VPN

MPLS VPN では次の PE MPLS QoS 機能がサポートされます。

VPN サブインターフェイスを介した CE-to-PE IP トラフィックの分類、ポリシング、マーキング

VPN 単位の QoS(ポート単位、VLAN 単位、またはサブインターフェイス単位)

カスタマー エッジ(CE)-to-PE トラフィック、または CE-to-PE-to-CE トラフィックでは、サブインターフェイス サポートにより IP QoS 入力または出力ポリシーをサブインターフェイスおよび物理インターフェイスに適用することができます。CE 側のある VPN に対応する特定のインターフェイスまたはサブインターフェイスでは VPN 単位のポリシングも提供されます。

複数のインターフェイスが同じ VPN に属する状況では、同じ PFC に関連付けられた類似インターフェイスすべてに対し、入力または出力サービス ポリシー内で同一の共有ポリサーを使用することで、VPN 単位のポリシング集約を実行できます。

集約 VPN ラベルについては、再循環の場合の EXP 伝播はサポートされない可能性があります。これは、最終パケットがどの出力インターフェイスを使用するのかということを、MPLS 隣接が認識していないためです。


) 再循環については、を参照してください。


VPN 内のすべてのインターフェイスが EXP 伝播をイネーブルにしている場合、PFC は EXP 値を伝播します。

次の PE MPLS QoS 機能がサポートされています。

IP パケット用の一般的な MPLS QoS 機能

VPN サブインターフェイスを介した CE-to-PE IP トラフィックの分類、ポリシング、マーキング

VPN 単位の QoS(ポート単位、VLAN 単位、またはサブインターフェイス単位)

MPLS コアでの LSR

ここでは、MPLS および MPLS VPN ネットワークのコア(MPLS-to-MPLS)での LSR の MPLS QoS 機能について説明します。Carrier Supporting Carrier(CsC)QoS 機能の入力機能、出力インターフェイス、および PFC の機能は、次の項で説明する MPLS to MPLS のものと同じです。CsC と MPLS to MPLS の相違は、CsC ラベルが MPLS ドメイン内部にインポーズできることです。

MPLS to MPLS の概要

MPLS コアでの MPLS QoS は、次の機能をサポートします。

サービス ポリシーに基づく EXP 単位のポリシング

入力最上位 EXP 値を新たにインポーズされた EXP 値へのコピーすること

MPLS ドメイン間の出力境界での EXP 変換オプション(隣り合った 2 つの MPLS ドメイン間でインターフェイス エッジ上の EXP 値を変更)

特定の EXP 値について個々のラベル フローに基づくマルチフロー ポリシング

最上位ラベルをマルチラベル スタックからポップする場合に最上位 EXP 値を基礎となる EXP 値へ伝播するオプション

ここでは、MPLS-to-MPLS QoS 分類に関する情報を提供します。さらに、入力および出力モジュールによって提供される機能についても説明します。

MPLS-to-MPLS 分類

PFC は、受信 MPLS パケットについてポート信頼状態、入力 CoS、およびあらゆる policy-map trust コマンドを無視します。その代わり、PFC は最上位ラベルの EXP 値を信頼します。


match mpls experimental コマンドを入力すると、MPLS トラフィックに対する MPLS QoS 入力ポリシーおよび出力ポリシーは、受信した最上位ラベルの EXP 値に基づきトラフィックを分類します。


MPLS QoS は、EXP-to-DSCP グローバル マップを使用して、EXP 値を内部 DSCP にマッピングします。 PFC の次の手順は、ラベルをスワッピングしているのか、新しいラベルをインポーズしているのか、それともラベルをポップしているのかによって異なります。

ラベルのスワップ:ラベルをスワップする場合、PFC は受信した最上位ラベルの EXP 値を保持し、発信する最上位ラベルの EXP 値にこの値をコピーします。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP グローバル マップが整合している場合は、出力 CoS は送信最上位ラベルの EXP に基づきます。

PFC は、 police コマンドの exceed および violate アクションを使用して、アウトオブプロファイル トラフィックをマークダウンできます。適合するトラフィックはマーキングしないため、 conform アクションは transmitted である必要があり、 set コマンドを使用することはできません。PFC がマークダウンを実行している場合、内部 DSCP は内部 DSCP マークダウン マップへのインデックスとして使用されます。PFC は、内部 DSCP-to-EXP グローバル マップを使用して内部 DSCP マークダウンの結果を EXP 値にマッピングします。PFC は新しい EXP 値を最上位送信ラベルに書き換え、新しい EXP 値をスタックの他のラベルにはコピーしません。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP マップが整合している場合は、出力 CoS は送信最上位ラベルの EXP 値に基づきます。

追加ラベルのインポーズ:新しいラベルを既存のラベル スタックにインポーズする場合、PFC は内部 DSCP-to-EXP マップを使用して内部 DSCP をインポーズされたラベルの EXP 値にマッピングします。そして次にインポーズされたラベルの EXP 値を基礎となるスワップされたラベルにコピーします。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP マップが整合している場合は、出力 CoS はインポーズされたラベルの EXP 値に基づきます。

PFC は適合するトラフィックをマーキングし、アウトオブプロファイル トラフィックをマークダウンすることができます。PFC は、内部 DSCP をマーキングしたあと、内部 DSCP-to-EXP グローバル マップを使用して内部 DSCP を新しくインポーズされたラベルの EXP 値にマッピングします。そして PFC は、インポーズされたラベルの EXP 値を基礎となるスワップされたラベルにコピーします。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。したがって、出力 CoS はインポーズされたラベルの EXP 値に基づきます。

ラベルのポップ:ラベルをマルチラベル スタックからポップする場合、PFC はエクスポーズされたラベルの EXP 値を保持します。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP マップが整合している場合は、出力 CoS はポップされたラベルの EXP 値に基づきます。

EXP 伝播が出力インターフェイスで設定されている場合、PFC は DSCP-to-EXP グローバル マップを使用して、エクスポーズされたラベルの EXP 値に内部 DSCP をマッピングします。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP マップが整合している場合は、出力 CoS はエクスポーズされたラベルの EXP 値に基づきます。

MPLS-to-MPLS QoS の分類

P1 または P2 への入力時に、MPLS QoS は次の機能をサポートします。

mpls experimental topmost コマンドによるマッチング

set mpls experimental imposition police set imposition を併用する police コマンド

MPLS QoS は、P1 または P2 からの出力時に mpls experimental topmost コマンドによる照合をサポートします。

MPLS-to-MPLS 入力ポートでの分類

LAN ポートでの分類は、PFC からの出力 CoS に基づきます。 match mpls experimental コマンドは受信最上位ラベルの EXP 値のマッチングを行います。

MPLS-to-MPLS 出力ポートでの分類

LAN ポートでの分類は、PFC からの出力 CoS 値に基づきます。 match mpls experimental コマンドは出力 CoS のマッチングを行いますが、最上位ラベルの EXP 値のマッチングは行いません。出力ポートがトランクの場合は、LAN ポートは出力 CoS を出力 802.1Q フィールドにコピーします。

MPLS QoS のデフォルト設定

 

機能
デフォルト値

PFC QoS のグローバル イネーブル ステート

デフォルト値の他のすべての PFC QoS パラメータによって、デフォルト EXP は IP precedence からマッピングされます。

PFC QoS がイネーブルで、他のすべての PFC QoS パラメータがデフォルト値の場合、PFC QoS は LAN ポート(デフォルトは untrusted)から送信されたすべてのトラフィックでレイヤ 3 DSCP を 0( untrusted ポートに限る)に、レイヤ 2 CoS を 0、インポーズされた EXP を 0 に設定します。trust CoS では、デフォルトの EXP 値が COS からマッピングされます。trust DSCP では、デフォルトの EXP 値が IP precedence からマッピングされます。

PFC QoS ポート イネーブル ステート

PFC QoS がグローバルにイネーブルの場合、イネーブル

ポートの CoS 値

0

マイクロフロー ポリシング

イネーブル

VLAN 内マイクロフロー ポリシング

ディセーブル

ポートベースまたは VLAN ベースの PFC QoS

ポートベース

EXP から DSCP へのマップ
(EXP 値から設定された DSCP)

EXP 0 = DSCP 0
EXP 1 = DSCP 8
EXP 2 = DSCP 16
EXP 3 = DSCP 24
EXP 4 = DSCP 32
EXP 5 = DSCP 40
EXP 6 = DSCP 48
EXP 7 = DSCP 56

IP precedence から DSCP へのマップ
(IP precedence 値から設定された DSCP)

IP precedence 0 = DSCP 0
IP precedence 1 = DSCP 8
IP precedence 2 = DSCP 16
IP precedence 3 = DSCP 24
IP precedence 4 = DSCP 32
IP precedence 5 = DSCP 40
IP precedence 6 = DSCP 48
IP precedence 7 = DSCP 56

DSCP から EXP へのマップ
(DSCP 値から設定された EXP)

DSCP 0-7 = EXP 0
DSCP 8-15 = EXP 1
DSCP 16-23 = EXP 2
DSCP 24-31 = EXP 3
DSCP 32-39 = EXP 4
DSCP 40-47 = EXP 5
DSCP 48-55 = EXP 6
DSCP 56-63 = EXP 7

DSCP マップからマークダウンされた DSCP

マークダウンされた DSCP 値は元の DSCP 値と等しい(マークダウンなし)

EXP 変換マップ

デフォルトでは変換マップなし

ポリサー

なし

ポリシー マップ

なし

NetFlow テーブルの MPLS フロー マスク

ラベル + EXP 値

MPLS コア QoS

MPLS コア QoS では 4 つの可能性があります。

スワッピング:着信 EXP フィールドが送信 EXP フィールドにコピーされます。

スワッピング + インポーズ:着信 EXP フィールドはスワッピングされた EXP フィールドとインポーズされた EXP フィールドの両方にコピーされます。

(注) EXP フィールドのセット付きサービス ポリシーがある場合、その EXP フィールドはインポーズされたラベルとスワッピングされたラベルに置かれます。

最上位ラベルのディスポジション:エクスポーズされた EXP フィールドは保持されます。

ラベルだけのディスポジション:エクスポーズされた IP DSCP は保持されます。

MPLS to IP エッジの QoS

エクスポーズされた IP DSCP を保持します。

MPLS QoS コマンド

  1. MPLS QoS は、次の MPLS QoS コマンドをサポートします。

match mpls experimental topmost

set mpls experimental imposition

police

platform qos map exp-dscp

platform qos map dscp-exp

platform qos map exp-mutation

platform qos exp-mutation

show platform qos mpls

no platform qos mpls trust exp


) サポートされる非 MPLS QoS コマンドについては、 を参照してください。


次のコマンドはサポートされません。

set qos-group

set discard-class

MPLS QoS の制約事項

MPLS QoS を設定する際に、以下の注意事項と制約事項に従ってください。

受信パケットが IP パケットの場合の IP-to-MPLS または EoMPLS のインポジション

QoS がディセーブルの場合、EXP 値は受信 IP ToS に基づきます。

QoS がキューイングだけの場合、EXP 値は受信 IP ToS に基づきます。

受信パケットが非 IP パケットの場合の EoMPLS インポジション

QoS がディセーブルの場合、EXP 値は入力 CoS に基づきます。

QoS がキューイングだけの場合、EXP 値は受信 IP ToS に基づきます。

MPLS-to-MPLS 動作

QoS がディセーブルのときにスワッピングする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がキューイングだけのときにスワッピングする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がディセーブルのときに追加ラベルをインポーズする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がキューイングだけのときに追加ラベルをインポーズする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がディセーブルのときに 1 つのラベルをポップする場合、EXP 値は基礎となる EXP 値に基づきます。

QoS がキューイングだけのときに 1 つのラベルをポップする場合、EXP 値は基礎となる EXP 値に基づきます。

EXP 値は MPLS-to-IP ディスポジションとは関係がありません。

no platform qos rewrite ip dscp コマンドは、MPLS とは非互換です。デフォルトの platform qos rewrite ip dscp コマンドは、PFC がインポーズしたラベルで正しい EXP 値を割り当てられるようイネーブルの状態にしておく必要があります。

no platform qos mpls trust exp コマンドを使用すると、CoS および出力キューイングの目的で、MPLS パケットをレイヤ 2 パケットと同様に扱うことができます。この場合、デフォルトの EXP 値ではなく、ポートの信頼状態またはポリシーの信頼状態が適用されます。

MPLS QoS の設定方法

「queueing-only モードのイネーブル化」

「MPLS パケットを分類するためのクラス マップの設定」

「ポリシー マップの設定」

「ポリシー マップの表示」

「MPLS QoS の出力 EXP 変換の設定」

「EXP 値マッピングの設定」

queueing-only モードのイネーブル化

queueing-only モードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# platform qos queueing-only

queueing-only モードをイネーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

queueing-only モードをイネーブルにする場合、ルータは次の処理を行います。

マーキングおよびポリシングをグローバルにディセーブルにします。

すべてのポートがレイヤ 2 CoS を信頼するように設定します。


) スイッチでは、タグなし入力トラフィックと、trust CoS に設定できないポートを介して受信されるトラフィックにポート CoS 値が適用されます。


次に、queueing-only モードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# platform qos queueing-only
Router(config)# end
Router#

制約事項および使用上の注意事項

PFC で QoS がディセーブル( no platform qos )の場合、EXP 値は次のように決定されます。

受信パケットが IP パケットのときの IP-to-MPLS または EoMPLS インポジションの場合、QoS がキューイングのみであれば( platform qos queueing-only )、EXP 値は受信した IP ToS に基づきます。

受信パケットが IP パケットでない EoMPLS インポジションの場合、QoS がキューイングのみであれば、EXP 値は受信した IP ToS に基づきます。

MPLS-to-MPLS 動作

QoS がキューイングだけのときにスワッピングする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がキューイングだけのときに追加ラベルをインポーズする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がキューイングだけのときに 1 つのラベルをポップする場合、EXP 値は基礎となる EXP 値に基づきます。

EXP 値は MPLS-to-IP ディスポジションとは関係がありません。

MPLS パケットを分類するためのクラス マップの設定

match mpls experimental topmost コマンドを使用して、パケット EXP 値による MPLS ドメイン内のトラフィック クラスを定義することができます。これにより、 police コマンドを使用してインターフェイス ベースで EXP トラフィックをポリシングするためのサービス ポリシーを定義することができます。

クラス マップを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map class_name

パケットがマッチングされるクラス マップを指定します。

ステップ 2

Router(config-cmap)# match mpls experimental topmost value

そのクラスにマッチングされるパケット特性を指定します。

ステップ 3

Router(config-cmap)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、MPLS EXP 値 3 を含むすべてのパケットが exp3 という名前のトラフィック クラスによってマッチングされる例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# class-map exp3
Router(config-cmap)# match mpls experimental topmost 3
Router(config-cmap)# exit
Router(config)# policy-map exp3
Router(config-pmap)# class exp3
Router(config-pmap-c)# police 1000000 8000000 conform-action transmit exceed-action drop
Router(config-pmap-c)# exit
Router(config-pmap)# end
Router# show class exp3
Class Map match-all exp3 (id 61)
Match mpls experimental topmost 3
Router# show policy-map exp3
Policy Map exp3
Class exp3
police cir 1000000 bc 8000000 be 8000000 conform-action transmit exceed-action drop
Router# show running-config interface gigabitethernet 3/27
Building configuration...
 
Current configuration : 173 bytes
!
interface GigabitEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
end
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface gigabitethernet 3/27
Router(config-if)# service-policy input exp3
Router(config-if)#
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router# show running-config interface gigabitethernet 3/27
Building configuration...
 
Current configuration : 173 bytes
!
interface GigabitEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
service-policy input exp3
end
 
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show platform qos mpls
QoS Summary [MPLS]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Gi3/27 5 In exp3 0 2 dscp 0 0 0
 
All 5 - Default 0 0* No 0 3466140423 0
Router# show policy-map interface gigabitethernet 3/27
GigabitEthernet3/27
 
Service-policy input: exp3
 
class-map: exp3 (match-all)
Match: mpls experimental topmost 3
police :
1000000 bps 8000000 limit 8000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface gigabitethernet 3/27
Router(config-if)# service-policy output ip2tag
Router(config-if)# end
Router# show platform qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Vl300 5 In x 44 1 No 0 0 0
Gi3/27 5 Out iptcp 24 2 -- 0 0 0
 
All 5 - Default 0 0* No 0 3466610741 0

制約事項および使用上の注意事項

match mpls experimental コマンドは、パケットがクラス マップによって指定されるクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用すべき EXP フィールド値の名前を指定します。

match mpls experimental コマンドを使用するには、まず class-map コマンドを入力して設定する一致基準のクラスの名前を指定する必要があります。クラスを識別したあとで、 match mpls experimental コマンドを使用してその一致基準を設定できます。

クラス マップで複数のコマンドを指定する場合、最後に入力されたコマンドだけが適用されます。最後のコマンドは、それ以前に入力されたコマンドを無効にします。

ポリシー マップの設定

1 つのインターフェイスに付加できるポリシー マップは、1 つに限られます。ポリシー マップには、ポリシー マップ コマンドがそれぞれ異なる 1 つまたは複数のポリシー マップ クラスを含めることができます。

インターフェイスで受信するトラフィック タイプごとに、個別のポリシー マップ クラスをポリシー マップ内に設定します。各トラフィック タイプ用の全コマンドを、同一のポリシー マップ クラスに入れます。MPLS QoS は、一致したトラフィックに複数のポリシー マップ クラスのコマンドを適用することはありません。

EXP 値をすべてのインポーズされたラベルに設定するためのポリシー マップの設定

MPLS EXP フィールドの値をすべてのインポーズされたラベル エントリに設定するには、QoS ポリシー マップ クラス コンフィギュレーション モードで set mpls experimental imposition コマンドを使用します。設定をディセーブルにするには、コマンドの no 形式を入力します。


set mpls experimental imposition コマンドは、set mpls experimental コマンドと置き換わったものです。


 

コマンド
目的

ステップ 1

Router(config)# policy-map policy_name

ポリシー マップを作成します。

ステップ 2

Router(config-pmap)# class-map name [match-all | match-any]

QoS クラス マップ コンフィギュレーション モードにアクセスして QoS クラス マップを設定します。

ステップ 3

Router(config-pmap-c)# set mpls experimental imposition {mpls-exp-value | from-field [table table-map-name]}

MPLS 実験(EXP)フィールドの値をすべてのインポーズされたラベル エントリに設定します。

ステップ 4

Router(config-pmap-c)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、MPLS EXP 値 3 で定義された DSCP 値に従って、MPLS EXP インポジション値を設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# access-l 101 p tcp any any
Router(config)# class-map iptcp
Router(config-cmap)# match acc 101
Router(config-cmap)# exit
Router(config)#
Router(config-cmap)# policy-map ip2tag
Router(config-pmap)# class iptcp
Router(config-pmap-c)# set mpls exp imposition 3
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)#
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router#
Router# show policy-map ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3
Router# show class iptcp
Class Map match-all iptcp (id 62)
Match access-group101
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface gigabitethernet 3/27
Router(config-if)# ser in ip2tag
Router(config-if)#
Routers
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show pol ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3
Router# show class-map iptcp
Class Map match-all iptcp (id 62)
Match access-group 101
 
Router# show access-l 101
Extended IP access list 101
10 permit tcp any any
Router# show policy-map interface gigabitethernet 3/27
GigabitEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
set mpls experimental 3:
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
 

次に、設定を確認する例を示します。

Router# show policy map ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3

EXP 値のインポジションに関する注意事項および制約事項

インポーズしたすべてのラベルに EXP 値を設定する場合、次の注意事項および制約事項に従ってください。

ラベル インポジション中には set mpls experimental imposition コマンドを使用してください。このコマンドは MPLS EXP フィールドをすべてのインポーズされたラベル エントリに設定します。

set mpls experimental imposition コマンドは、入力インターフェイス(インポジション)上でのみサポートされます。

set mpls experimental imposition コマンドは、EXP 値を直接マーキングしません。その代わり、このコマンドは内部 DSCP-to-EXP グローバル マップを介して EXP にマッピングされる内部 DSCP をマーキングします。

(元の受信 IP ヘッダーに基づく)分類および(内部 DSCP に行われる)マーキングでは IP-to-IP トラフィックと IP-to-MPLS トラフィックが区別されないことに十分注意してください。IP ToS および EXP のマーキングに使用されるコマンドを使用した場合、内部 DSCP のマーキングと同じ結果となります。

ラベル インポジション中に、プッシュされたラベル エントリ値をデフォルト値とは異なった値に設定するには、 set mpls experimental imposition コマンドを使用します。

また任意で IP precedence、DSCP フィールド、または QoS IP ACL とともに set mpls experimental imposition コマンドを利用して、すべてのインポーズされたラベル エントリに MPLS EXP フィールドの値を設定できます。

ラベルを PFC で受信 IP トラフィックにインポーズする場合は、 set mpls experimental imposition コマンドで EXP フィールドをマーキングすることができます。

police コマンドを使用したポリシー マップの設定

ポリシングは特定のトラフィック クラスを特定のレートに速度制限する機能を提供する PFC のハードウェアの機能です。PFC は集約ポリシングおよびマイクロフロー ポリシングをサポートします。

集約ポリシングは、送信元、宛先、プロトコル、送信元ポート、宛先ポートが異なっていても関係なくポートに着信するすべてのトラフィックを測定します。マイクロフロー ポリシングは、フロー ベース(送信元、宛先、プロトコル、送信元ポート、宛先ポート ベース)でポートに着信するすべてのトラフィックを測定します。集約ポリシングとマイクロフロー ポリシングの詳細については、を参照してください。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy_name

ポリシー マップを作成します。

ステップ 2

Router(config-pmap)# class-map name [match-all | match-any]

QoS クラス マップ コンフィギュレーション モードにアクセスして QoS クラス マップを設定します。

ステップ 3

Router(config-pmap-c)# police {aggregate name}

クラスを共有集約ポリサーに追加します。

ステップ 4

Router(config-pmap-c)# police bps burst_normal burst_max conform-action action exceed-action action violate-action action

per-class-per-interface ポリサーを作成します。

ステップ 5

Router(config-pmap-c)# police flow { bps [ burst_normal ] | [conform-action action ] [exceed-action action ]

入力フロー ポリサーを作成します (出力ポリシーではサポートされません)。

ステップ 6

Router(config-pmap-c)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、ポリサーでポリシー マップを作成する例を示します。

Router(config)# policy-map ip2tag
Router(config-pmap)# class iptcp
Router(config-pmap-c)# no set mpls exp topmost 3
Router(config-pmap-c)# police 1000000 1000000 c set-mpls-exp?
set-mpls-exp-imposition-transmit
 
Router(config-pmap-c)# police 1000000 1000000 c set-mpls-exp-imposit 3 e d
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# interface gigabitethernet 3/27
Router(config-if)# ser in ip2tag
Router(config-if)#
 

次に、設定を確認する例を示します。

Router# show pol ip2tag
Policy Map ip2tag
Class iptcp
police cir 1000000 bc 1000000 be 1000000 conform-action set-mpls-exp-imposition-transmit 3 exceed-action drop
Router# show running-config interface gigabitethernet 3/27
Building configuration...
 
Current configuration : 202 bytes
!
interface GigabitEthernet3/27
logging event link-status
service-policy input ip2tag
end
 
Router# show policy interface gigabitethernet 3/27
GigabitEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
police :
1000000 bps 1000000 limit 1000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: set-mpls-exp-imposition-transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

制約事項および使用上の注意事項

police コマンドを使用してポリシー マップを設定するときには、次の制約事項および注意事項が適用されます。

MPLS では、 exceed-action action コマンドおよび violate-action action コマンドが IP 使用と同様に動作します。パケットはドロップされる場合もあり、EXP 値がマークダウンされる場合もあります。

MPLS では、 set-dscp transmit action コマンドおよび set-prec-transmit action コマンドがキューイングに影響を与える CoS ビットにマッピングされる内部 DSCP を設定します。ただし、インポジションを除き EXP 値の変更は行いません。

受信 MPLS トラフィックのラベルを PFC でスワッピングするときは、 police コマンドの exceed-action policed-dscp-transmit および violate-action policed-dscp-transmit キーワードを使用して、アウトオブプロファイル トラフィックをマークダウンすることができます。PFC では適合するトラフィックはマーキングされません。アウトオブプロファイル トラフィックをマークダウンする場合は、PFC は送信最上位ラベルをマーキングします。PFC はマーク ダウンをラベル スタックに伝播しません。

MPLS では、フロー キーはラベルおよび EXP 値に基づきます。フローマスク オプションはありません。それ以外では、フロー キー動作は IP-to-IP と同様です。

police コマンドを使用すれば、ラベル インポジション中に、プッシュされたラベル エントリ値をデフォルト値とは異なった値に設定できます。

ラベルを PFC で受信 IP トラフィックにインポーズする場合は、 conform-action set-mpls-exp-imposition-transmit キーワードを使用して、EXP フィールドをマーキングすることができます。

IP-to-MPLS インポジション中、IP ToS マーキングはサポートされません。ポリシーを設定して IP ToS をマーキングする場合は、PFC が EXP 値をマーキングします。

ポリシー マップの表示

MPLS QoS クラスのインターフェイス サマリーまたは指定されたインターフェイス上のすべてのサービス ポリシーで設定されたすべてのクラスのコンフィギュレーションでポリシー マップを表示することができます。

すべてのクラスのコンフィギュレーションの表示

指定されたインターフェイス上のすべてのサービス ポリシーに設定されたすべてのクラスのコンフィギュレーションを表示するには、次の作業を行います。

 

コマンド
目的

Router# show policy interface interface_type interface_number

指定されたインターフェイス上のすべてのポリシー マップに設定されたすべてのクラスのコンフィギュレーションを表示します。

次に、ギガビット イーサネット インターフェイス 3/27 の全クラスのコンフィギュレーションを表示する例を示します。

Router# show policy interface gigabitethernet 3/27
GigabitEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
police :
1000000 bps 1000000 limit 1000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: set-mpls-exp-imposition-transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

名前付き EXP 変換マップの設定

名前付き EXP 変換マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# platform qos map exp-mutation name mutated_exp1 mutated_exp2 mutated_exp3 mutated_exp4 mutated_exp5 mutated_exp6 mutated_exp7 mutated_exp8

名前付き EXP 変換マップを設定します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

名前付き EXP 変換マップを設定する場合、次の点に注意してください。

変換された EXP 値にマッピングする、最大 8 つの EXP 値を入力することができます。

複数のコマンドを入力して、追加の EXP 値を変換された EXP 値にマッピングできます。

変換された EXP 値ごとに個別のコマンドを入力できます。

内部 EXP 値が入力 EXP 値として書き込まれる前に内部 EXP 値を変換するため、15 個の入力 EXP 変換マップを設定できます。入力 EXP 変換マップを、PFC QoS がサポートする任意のインターフェイスに付加できます。

PFC QoS は、内部 DSCP 値から出力 EXP 値を導出します。入力 EXP 変換を設定する場合、PFC QoS は変換された EXP 値から入力 EXP 値を導出しません。

インターフェイスへの出力 EXP 変換マップの付加

出力 EXP 変換マップをインターフェイスに付加するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface {{ vlan vlan_ID } | { type slot/port [. subinterface ]} | { port-channel number [. subinterface ]}}

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# platform qos exp-mutation exp-mutation-table-name

出力 EXP 変換マップをインターフェイスに付加します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

次に、mutemap2 という名前の出力 EXP 変換マップを付加する例を示します。

Router(config)# interface gigabitethernet 3/26
Router(config-if)# platform qos exp-mutation mutemap2
Router(config-if)# end

入力 EXP から内部 DSCP へのマッピングの設定

入力 EXP から内部 DSCP へのマッピングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# platform qos map exp-dscp values

入力 EXP 値から内部 DSCP 値へのマッピングを設定します。EXP 値に対応する 8 つの DSCP 値を入力する必要があります。有効値は 0 ~ 63 です。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

次に、入力 EXP から内部 DSCP へのマッピングを設定する例を示します。

Router(config)# platform qos map exp-dscp 43 43 43 43 43 43 43 43
Router(config)#
 

次に、設定を確認する例を示します。

Router(config)# show platform qos map exp-dscp
Exp-dscp map:
exp: 0 1 2 3 4 5 6 7
------------------------------------
dscp: 43 43 43 43 43 43 43 43

名前付き出力 DSCP から出力 EXP へのマッピングの設定

名前付き出力 DSCP から出力 EXP へのマッピングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# platform qos map dscp-exp dscp_values to exp_values

名前付き出力 DSCP から出力 EXP へのマッピングを設定します。1 つの EXP 値には 1 回に最大 8 つの DSCP 値を入力することができます。有効値は 0 ~ 7 です。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

次に、名前付き出力 DSCP から出力 EXP へのマッピングを設定する例を示します。

Router(config)# platform qos map dscp-exp 20 25 to 3
Router(config)#

MPLS DiffServ トンネリング モード

トンネリングは、QoS にネットワークの 1 つのエッジから、そのネットワークの別のエッジまでをトランスペアレントにする機能を提供します。トンネルは、ラベル インポジションのある場所から開始します。トンネルは、ラベル ディスポジションのある場所、つまり、ラベルがスタックから除去された場所で終了します。そしてパケットは下部に異なった Per-Hop Behavior(PHB)レイヤを持つ MPLS パケットとして、または IP PHB レイヤ付き IP パケットとして送信されます。

PFC では、ネットワーク経由でパケットを転送する方法が 2 つあります。

ショート パイプ モード:ショート パイプ モードでは、出力 PE ルータは中間プロバイダー(P)ルータによって使用されるマーキングの代わりに元のパケット マーキングを使用します。EXP マーキングはパケット ToS バイトには伝播しません。

モードの説明については、「ショート パイプ モード」を参照してください。

コンフィギュレーションについては、「ショート パイプ モードの設定例」を参照してください。

均一モード:均一モードでは、IP パケットのマーキングはサービス プロバイダーの QoS マーキングをコアに反映するよう操作することができます。このモードでは、CE およびコア ルータを含むネットワーク全体で矛盾のない QoS 分類およびマーキングが提供されます。EXP マーキングは基礎となる ToS バイトへ伝播されます。

説明については、「均一モード」を参照してください。

設定手順については、「均一モードの設定方法」を参照してください。

どちらのトンネリング モードもラベルがパケットに付与されたりパケットから削除されたりするエッジおよび最後から 2 番めのラベル スイッチング ルータ(LSR)の動作に影響を与えます。これらのモードは、中間ルータのラベル スワッピングには影響を与えません。サービス プロバイダーは、カスタマーごとに異なったタイプのトンネリング モードを選択することができます。

追加情報については、次の URL にある「MPLS DiffServ Tunneling Modes」を参照してください: http://www.cisco.com/en/US/docs/ios-xml/ios/mp_te_diffserv/configuration/15-mt/mp-diffserv-tun-mode.html

ショート パイプ モード

ショート パイプ モードはカスタマーおよびサービス プロバイダーが異なった DiffServ ドメインにある場合に使用されます。このモードを利用することにより、サービス プロバイダーはカスタマーの DiffServ 情報を保持しながら自身の DiffServ ポリシーを実施することができるため、サービス プロバイダー ネットワークを通して DiffServ の透過性が提供されます。

コアで実施される QoS ポリシーはパケット ToS バイトには伝播しません。MPLS EXP 値に基づく分類は、カスタマー側に向かう出力 PE インターフェイスで終了します。カスタマー側に向かう出力 PE インターフェイスは、元の IP パケット ヘッダーに基づいており、MPLS ヘッダーに基づいてはいません。


) (カスタマーの PHB マーキングに基づいており、プロバイダーの PHB マーキングには基づいていない)出力 IP ポリシーが存在する場合は自動的にショート パイプ モードとなります。


図 67-2 VPN でのショート パイプ モード動作

 

ショート パイプ モードは次のように機能します。

1. CE1 は IP パケットを IP DSCP 値 1 で PE1 に送信します。

2. PE1 はインポーズされたラベル エントリで MPLS EXP フィールドを 5 に設定します。

3. PE1 はパケットを P1 に送信します。

4. P1 はスワッピングされたラベル エントリで MPLS EXP フィールド値を 5 に設定します。

5. P1 はパケットを P2 に送信します。

6. P2 は IGP ラベル エントリをポップします。

7. P2 はパケットを PE2 に送信します。

8. PE2 は BGP ラベルをポップします。

9. PE2 はパケットを CE2 に送信しますが、QoS は IP DSCP 値に基づきます。

詳細については、次の URL にある『MPLS DiffServ Tunneling Modes』を参照してください。

http://www.cisco.com/en/US/docs/ios-xml/ios/mp_te_diffserv/configuration/15-mt/mp-diffserv-tun-mode.html

ショート パイプ モードの制約事項

MPLS-to-IP 出力インターフェイスが EoMPLS(隣接には End of Marker(EoM)ビット セットがある)である場合、ショート パイプ モードはサポートされません。

均一モード

均一モードでは、パケットは IP および MPLS ネットワークで一律に扱われます。つまり、IP precedence 値および MPLS EXP ビットは常に同じ PHB に対応しています。ルータがパケットの PHB の変更またはカラー変更をする場合はいつでも、その変更はすべてのカプセル化マーキングに伝播されなくてはなりません。パケット パス上のルータでのラベル インポジションまたはディスポジションにより PHB が追加またはエクスポーズされる場合、伝播はルータだけによって実行されます。カラーはすべてのレベルのすべての場所で反映される必要があります。たとえば、パケットの QoS マーキングが MPLS ネットワークで変更された場合、IP QoS マーキングはその変更を反映します。

図 67-3 均一モード動作

 

この手順は、IP precedence ビット マーキングまたは DSCP マーキングが存在するかどうかによって異なります。

IP precedence ビット マーキングが存在する場合は次のアクションが発生します。

1. IP パケットがサービス プロバイダー エッジ ルータである PE1 で MPLS ネットワークに着信します。

2. ラベルはパケットにコピーされます。

3. MPLS EXP フィールド値のカラー変更が行われた場合(たとえば、あまりに多くのパケットが送信中であるためパケットがレート外となった場合)、この値は IGP ラベルにコピーされます。BGP ラベルの値は変更されません。

4. 最後から 2 番めのホップでは、IGP は削除されます。この値は次の低レベルのラベルにコピーされます。

5. すべての MPLS ラベルが IP パケットとして送出されたパケットから削除されたとき、IP precedence または DSCP 値はコアで最後に変更された EXP 値として設定されます。

次に、IP precedence ビット マーキングが存在する例を示します。

1. CE1(カスタマー装置 1)で、IP パケットは IP precedence 値 3 を持っています。

2. パケットが PE1(サービス プロバイダーのエッジ ルータ)で MPLS ネットワークに着信すると、IP precedence 値 3 はパケットのインポーズされたラベル エントリにコピーされます。

3. IGP ラベル ヘッダーの MPLS EXP フィールドはマークダウンにより MPLS コア(たとえば P1)内で変更される可能性があります。


) IP precedence ビットは 3 であるため、BGP ラベルおよび IGP ラベルも 3 を含みます。均一モードではラベルは常に同一であるためです。パケットは IP ネットワークと MPLS ネットワークで一律に扱われます。


均一モードの制約事項

出力 IP ACL またはサービス ポリシーが MPLS-to-IP 出口点で設定された場合には、再循環のため均一モードが常に実施されます。

MPLS DiffServ トンネリングの制約事項および使用上のガイドライン

ここでは、MPLS DiffServ トンネリングの制約事項および使用上のガイドラインについて説明します。

MPLS EXP フィールドは 3 ビット フィールドであるため 1 つのラベルスイッチド パス(LSP)は最大 8 クラスのトラフィック(つまり、8 つの PHB)をサポートすることができます。

MPLS DiffServ トンネリング モードは E-LSP をサポートします。E-LSP は LSP の 1 つであり、ノードはここで MPLS ヘッダーの EXP ビットから排他的に MPLS パケットの QoS 処理を判別します。

次の機能は、MPLS DiffServ トンネリング モードでサポートされます。

MPLS Per-Hop Behavior(PHB)レイヤ管理。(レイヤ管理は、PHB マーキングの追加レイヤをパケットに提供する機能です)。

管理されたカスタマー エッジ(CE)ルータでの制御による MPLS レイヤ管理の拡張性向上。

MPLS はパケットの QoS をトンネリングすることができます(つまり、QoS はエッジ間でトランスペアレント)。QoS 透過性により、IP パケットの IP マーキングは MPLS ネットワーク全体で保持されます。

MPLS EXP フィールドには、IP precedence または DSCP フィールドでマーキングされた PHB とは異なった値を別途マーキングすることができます。

ショート パイプ モードの設定例

「入力 PE ルータ:カスタマー側に向かうインターフェイス」

「入力 PE ルータの設定:P 側に向かうインターフェイス」

「P ルータの設定:出力インターフェイス」

「出力 PE ルータの設定:カスタマー側に向かうインターフェイス」


) • このステップは 1 つの方法を示すものですが、ショート パイプ モードを設定する唯一の方法というわけではありません。

IP クラスを含む出力サービス ポリシーをインターフェイスに付加した場合、出力 PE(または PHP)でのショート パイプ モードは自動的に設定されます。


 

入力 PE ルータ:カスタマー側に向かうインターフェイス

この手順は、ポリシー マップを設定して、インポーズされたラベル エントリに MPLS EXP フィールドを設定するものです。

EXP 値を設定するには、入力 LAN ポートが信頼できない(untrusted)状態である必要があります。

MPLS と VPN については、入力 PE はすべての入力 PFC IP ポリシーをサポートします。

インポーズされたラベル エントリで MPLS EXP フィールドを設定するポリシー マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# access-list ipv4_acl_number_or_name permit any

IPv4 アクセス リストを作成します。

ステップ 2

Router(config)# class-map class_name

クラス マップを作成します。

ステップ 3

Router(config-cmap)# match access-group ipv4_acl_number_or_name

ステップ 1 で作成した ACL に基づくフィルタリングを行うように、クラス マップを設定します。

ステップ 4

Router(config)# policy-map policy_map_name

名前付き QoS ポリシーを作成します。

ステップ 5

Router(config-pmap)# class class_name

ステップ 2 で作成したクラス マップを使用するように、ポリシーを設定します。

ステップ 6

Router(config-pmap-c)# police bits_per_second [ normal_burst_bytes ] conform-action set-mpls-exp-transmit exp_value exceed-action drop

ポリシングを設定します。ここでは、次の内容を設定します。

サービス レベル契約(SLA)で指定されたレート制限に適合するパケットをとるアクション

SLA で指定されたレート制限を超えるパケットをとるアクション。

exp_value は、MPLS EXP フィールドを設定します。

ステップ 7

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 8

Router(config-if)# no platform qos trust

インターフェイスを untrusted として設定します。

ステップ 9

Router(config-if)# service-policy input policy_map_name

ステップ 4 で作成したポリシー マップを、入力サービス ポリシーとしてインターフェイスに付加します。

設定例

次に、インポーズされたラベル エントリで MPLS EXP フィールドを設定するポリシー マップを設定する例を示します。

Router(config)# access-list 1 permit any
Router(config)# class-map CUSTOMER-A
Router(config-cmap)# match access-group 1
Router(config)# policy-map set-MPLS-PHB
Router(config-pmap)# class CUSTOMER-A
Router(config-pmap-c)# police 50000000 conform-action set-mpls-exp-transmit 4 exceed-action drop
Router(config)# interface gigabitethernet 3/1
Router(config-if)# no platform qos trust
Router(config)# interface gigabitethernet 3/1.31
Router(config-if)# service-policy input set-MPLS-PHB

入力 PE ルータの設定:P 側に向かうインターフェイス

この手順は MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するものです。

MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 2

Router(config-c-map)# match mpls experimental exp_list

パケットがそのクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用する MPLS EXP フィールド値を指定します。

ステップ 3

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 4

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 5

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 6

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 7

Router(config-p-map-c)# random-detect

帯域幅保証を持つトラフィック クラスの WRED ドロップ ポリシーをイネーブルにします。

ステップ 8

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 9

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# class-map MPLS-EXP-4
Router(config-c-map)# match mpls experimental 4
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 4/1
Router(config-if)# service-policy output output-qos

P ルータの設定:出力インターフェイス

MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 2

Router(config-c-map)# match mpls experimental exp_list

パケットがそのクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用する MPLS EXP フィールド値を指定します。

ステップ 3

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 4

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 5

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 6

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 7

Router(config-p-map-c)# random-detect

WRED を IP precedence または MPLS EXP フィールド値に基づくポリシーに適用します。

ステップ 8

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 9

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# class-map MPLS-EXP-4
Router(config-c-map)# match mpls experimental 4
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 2/1
Router(config-if)# service-policy output output-qos

出力 PE ルータの設定:カスタマー側に向かうインターフェイス

IP DSCP 値に基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 2

Router(config-c-map)# match ip dscp dscp_values

DSCP 値を一致基準として使用します。

ステップ 3

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 4

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 5

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 6

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 7

Router(config-p-map-c)# random-detect dscp-based

帯域幅保証を持つトラフィック クラスの WRED ドロップ ポリシーをイネーブルにします。

ステップ 8

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 9

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。

設定例

次に、IP DSCP 値に基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# class-map IP-PREC-4
Router(config-c-map)# match ip precedence 4
Router(config)# policy-map output-qos
Router(config-p-map)# class IP-PREC-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface gigabitethernet 3/2.32
Router(config-if)# service-policy output output-qos

均一モードの設定方法

「入力 PE ルータの設定:カスタマー側に向かうインターフェイス」

「入力 PE ルータの設定:P 側に向かうインターフェイス」

「出力 PE ルータの設定:カスタマー側に向かうインターフェイス」


) このステップは 1 つの方法を示すものですが、均一モードを設定する唯一の方法というわけではありません。


入力 PE ルータの設定:カスタマー側に向かうインターフェイス

Uniform モードで、IP precedence または IP DSCP に信頼状態を設定すると、PFC は IP PHB を MPLS PHB にコピーできます。


) この説明は、LAN ポートの PFC に適用されます。


インポーズされたラベル エントリで MPLS EXP フィールドを設定するポリシー マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# access-list ipv4_acl_number_or_name permit any

IPv4 アクセス リストを作成します。

ステップ 2

Router(config)# class-map class_name

クラス マップを作成します。

ステップ 3

Router(config-cmap)# match access-group ipv4_acl_number_or_name

ステップ 1 で作成した ACL に基づくフィルタリングを行うように、クラス マップを設定します。

ステップ 4

Router(config)# policy-map policy_map_name

名前付き QoS ポリシーを作成します。

ステップ 5

Router(config-pmap)# class class_name

ステップ 2 で作成したクラス マップを使用するように、ポリシーを設定します。

ステップ 6

Router(config-pmap-c)# police bits_per_second [normal_burst_bytes] conform-action transmit exceed-action drop

ポリシングを設定します。ここでは、次の内容を設定します。

SLA で指定されたレート制限に適合するパケットをとるアクション。

SLA で指定されたレート制限を超えるパケットをとるアクション。

ステップ 7

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 8

Router(config-if)# platform qos trust dscp

受信した DSCP を、全ポートの入力トラフィックに対する内部 DSCP 基準値として設定します。

ステップ 9

Router(config-if)# service-policy input policy_map_name

ステップ 4 で作成したポリシー マップを、入力サービス ポリシーとしてインターフェイスに付加します。

設定例

次に、インポーズされたラベル エントリで MPLS EXP フィールドを設定するポリシー マップを設定する例を示します。

Router(config)# access-list 1 permit any
Router(config)# class-map CUSTOMER-A
Router(config-cmap)# match access-group 1
Router(config)# policy-map SLA-A
Router(config-pmap)# class CUSTOMER-A
Router(config-pmap-c)# police 50000000 conform-action transmit exceed-action drop
Router(config)# interface gigabitethernet 3/1
Router(config-if)# platform qos trust dscp
Router(config)# interface gigabitethernet 3/1.31
Router(config-if)# service-policy input SLA-A

入力 PE ルータの設定:P 側に向かうインターフェイス

MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 2

Router(config-c-map)# match mpls experimental exp_list

パケットがそのクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用する MPLS EXP フィールド値を指定します。

ステップ 3

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 4

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 5

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 6

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 7

Router(config-p-map-c)# random-detect

帯域幅保証を持つトラフィック クラスの WRED ドロップ ポリシーをイネーブルにします。

ステップ 8

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 9

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# class-map MPLS-EXP-3
Router(config-c-map)# match mpls experimental 3
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-3
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 4/1
Router(config-if)# service-policy output output-qos

出力 PE ルータの設定:カスタマー側に向かうインターフェイス

カスタマー側に向かうインターフェイスで出力 PE ルータを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 2

Router(config-c-map)# match ip precedence precedence-value

IP precedence 値を一致基準として識別します。

ステップ 3

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 4

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 5

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 6

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 7

Router(config-p-map-c)# random-detect

WRED を IP precedence または MPLS EXP フィールド値に基づくポリシーに適用します。

ステップ 8

Router(config)# interface type slot / port

設定するインターフェイスを選択します。

ステップ 9

Router(config-if) mpls propagate-cos

EXP 値が MPLS ドメイン出口 LER 出力ポートで基礎となる IP DSCP へ伝播するのをイネーブルにします。

ステップ 10

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスに着信するパケット上で適用すべきポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、カスタマー側に向かうインターフェイスで出力 PE ルータを設定する例を示します。

Router(config)# class-map IP-PREC-4
Router(config-c-map)# match ip precedence 4
Router(config)# policy-map output-qos
Router(config-p-map)# class IP-PREC-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface gigabitethernet 3/2.32
Router(config-if) mpls propagate-cos
Router(config-if)# service-policy output output-qos

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する