Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.1SY
レイヤ 2 スイッチング用 LAN ポート
レイヤ 2 スイッチング用 LAN ポート
発行日;2013/08/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

レイヤ 2 スイッチング用 LAN ポート

レイヤ 2 LAN インターフェイスの前提条件

レイヤ 2 LAN インターフェイスの制約事項

レイヤ 2 スイッチングについて

レイヤ 2 イーサネット スイッチングについて

レイヤ 2 イーサネット スイッチングの概要

MAC アドレス テーブルの作成

VLAN トランクについて

レイヤ 2 LAN ポート モード

レイヤ 2 LAN インターフェイスのデフォルト設定

レイヤ 2 スイッチング用の LAN インターフェイスの設定方法

レイヤ 2 スイッチング用の LAN ポートの設定

アウトオブバンドの MAC アドレス テーブルの同期のイネーブル化

MAC アドレス テーブル通知の設定

トランクとしてのレイヤ 2 スイッチング ポートの設定

802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定

DTP を使用するためのレイヤ 2 トランクの設定

DTP を使用しないようにするためのレイヤ 2 トランクの設定

アクセス VLAN の設定

802.1Q ネイティブ VLAN の設定

トランク上で許容される VLAN のリストの設定

プルーニング適格 VLAN のリストの設定

トランクの設定の完了

レイヤ 2 トランクの設定の確認

設定および確認の例

レイヤ 2 アクセス ポートとしての LAN インターフェイスの設定

カスタム IEEE 802.1Q EtherType フィールド値の設定

レイヤ 2 スイッチング用 LAN ポート

「レイヤ 2 LAN インターフェイスの前提条件」

「レイヤ 2 LAN インターフェイスの制約事項」

「レイヤ 2 スイッチングについて」

「レイヤ 2 LAN インターフェイスのデフォルト設定」

「レイヤ 2 スイッチング用の LAN インターフェイスの設定方法」


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。

レイヤ 3 インターフェイスの設定手順については、「レイヤ 3 インターフェイス」 を参照してください。


 

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する


 

レイヤ 2 LAN インターフェイスの前提条件

なし。

レイヤ 2 LAN インターフェイスの制約事項

802.1Q トランクを介して Cisco スイッチを接続するときは、802.1Q トランクのネイティブ VLAN がトランク リンクの両端で同じであることを確認してください。トランクの一端のネイティブ VLAN と反対側の端のネイティブ VLAN が異なると、スパニングツリー ループの原因になります。

ネットワーク上の各 VLAN のスパニングツリーをディセーブルにせずに 802.1Q トランクのネイティブ VLAN のスパニングツリーをディセーブルにすると、スパニングツリー ループが発生することがあります。802.1Q トランクのネイティブ VLAN 上で、スパニングツリーをイネーブルのままにしておくことを推奨します。この設定ができない場合は、ネットワークのすべての VLAN 上でスパニングツリーをディセーブルにしてください。スパニングツリーをディセーブルにする場合には、事前にネットワークに物理的なループが存在しないことを確認してください。

802.1Q トランクを介して 2 台の Cisco スイッチを接続すると、トランク上で許容される VLAN ごとにスパニングツリー BPDU が交換されます。トランクのネイティブ VLAN 上の BPDU は、タグなしの状態で、予約済み IEEE 802.1d スパニングツリー マルチキャスト MAC アドレス(01-80-C2-00-00-00)に送信されます。トランクの他のすべての VLAN 上の BPDU は、タグ付きの状態で、予約済み Cisco Shared Spanning Tree(SSTP)マルチキャスト MAC アドレス(01-00-0c-cc-cc-cd)に送信されます。

他社製の 802.1Q スイッチでは、すべての VLAN に対してスパニングツリー トポロジーを定義するスパニングツリーのインスタンス(Mono Spanning Tree(MST))が 1 つしか維持されません。802.1Q トランクを介してシスコ製スイッチを他社製のスイッチに接続すると、他社製のスイッチの MST とシスコ製スイッチのネイティブ VLAN スパニングツリーが組み合わされて、Common Spanning Tree(CST)と呼ばれる単一のスパニングツリー トポロジが形成されます。

Cisco スイッチは、トランクのネイティブ VLAN 以外の VLAN にある SSTP マルチキャスト MAC アドレスに BPDU を送信します。したがって、他社製のスイッチではこれらのフレームが BPDU として認識されず、対応する VLAN のすべてのポート上でフラッディングされます。他社製の 802.1Q クラウドに接続された他の Cisco スイッチは、フラッディングされたこれらの BPDU を受信します。このようにして、Cisco スイッチは、他社製の 802.1Q スイッチ クラウドにわたって、VLAN 別のスパニングツリー トポロジーを維持できます。Cisco スイッチを隔てている他社製の 802.1Q クラウドは、802.1Q トランクを介して他社製の 802.1Q クラウドに接続されたすべてのスイッチ間の単一のブロードキャスト セグメントとして処理されます。

Cisco スイッチを他社製の 802.1Q クラウドに接続するすべての 802.1Q トランク上で、ネイティブ VLAN が同じであることを確認します。

他社製の特定の 802.1Q クラウドに複数の Cisco スイッチを接続する場合は、すべての接続に 802.1Q トランクを使用する必要があります。アクセス ポートを介して、Cisco スイッチを他社製の 802.1Q クラウドに接続できません。このように接続すると、スイッチはアクセス ポートのスパニングツリー ポート ステートを「一貫性のない」状態にし、ポートを介してトラフィックが送信されなくなります。

レイヤ 2 スイッチングについて

「レイヤ 2 イーサネット スイッチングについて」

「VLAN トランクについて」

「レイヤ 2 LAN ポート モード」

レイヤ 2 イーサネット スイッチングについて

「レイヤ 2 イーサネット スイッチングの概要」

「MAC アドレス テーブルの作成」

レイヤ 2 イーサネット スイッチングの概要

Cisco スイッチ上のレイヤ 2 イーサネット ポートは、レイヤ 2 イーサネット セグメント間の同時パラレル接続をサポートしています。イーサネット セグメント間のスイッチド コネクションが維持されるのは、パケットの伝送時間の長さだけです。次のパケットには、別のセグメント間に新しい接続が確立されます。

レイヤ 2 LAN スイッチング(ハードウェアでサポートされるブリッジング)は、自身の衝突ドメインに接続されている各デバイスを割り当てることによって、輻輳を回避できます。各 LAN ポートは、それぞれ別のイーサネット衝突ドメインに接続されているので、スイッチング環境が適切に設定されていれば、接続されたデバイスはネットワークの全帯域幅にアクセスできます。

MAC アドレス テーブルの概要

異なる LAN ポートに接続しているステーションが相互に通信する必要がある場合、スイッチは、一方の LAN ポートから他方の LAN ポートにワイヤ速度でフレームを転送し、各セッションが全帯域幅を利用できるようにします。

LAN ポート間で効率的にフレームをスイッチングするために、スイッチは MAC アドレス テーブルを保持しています。フレームがスイッチに着信すると、ルータは送信元ネットワーク デバイスの MAC アドレスと、フレームを受信した LAN ポートを対応付けます。

MAC アドレス テーブルは、受信したフレームの送信元 MAC アドレスを使用して作成されます。MAC アドレス テーブルに宛先 MAC アドレスが登録されていないフレームをスイッチが受信すると、そのフレームを受信したポート以外の、同一 VLAN のすべての LAN ポートに、フレームをフラッディングします。宛先ステーションから応答があると、スイッチは関連する送信元 MAC アドレスおよびポート ID を MAC アドレス テーブルに追加します。その後、スイッチは、以降のフレームを、すべての LAN ポートにフラッディングするのではなく単一の LAN ポートへと転送します。

MAC アドレス テーブルには、エントリのフラッディングを伴わずに 128,000 以上のアドレス エントリを保管できます。スイッチでは、 mac address-table aging-time コマンドによって設定されたエージング メカニズムを使用するため、アドレスが非アクティブなまま指定した秒数が経過すると、そのアドレスはアドレス テーブルから削除されます。

アドレス テーブルの同期と共有

分散スイッチング環境で分散型フォワーディング カード(DFC)搭載の各スイッチング モジュールは MAC アドレスを学習し、アドレス テーブルを維持し、テーブル エントリを期限切れにします。Ethernet Out of Band Channel(EOBC)経由の MAC アドレス テーブルの同期は、PFC およびすべての DFC 間のアドレス テーブルを同期するため、DFC が別のモジュール上でアクティブなアドレスのためにフラッディングする必要がなくなります。MAC 同期はデフォルトでイネーブルです。

アドレス テーブル変更の通知

スイッチは、特定の LAN ポートに関連するアドレス テーブル エントリの動的な追加、および削除の履歴を保持するように設定できます。変更履歴は、SNMP トラップ通知として送信されるか、SNMP MIB から手動で読み取ることができます。

VLAN トランクについて


) VLAN の詳細については、を参照してください。


トランクとは、スイッチと他のネットワーキングデバイス間のポイントツーポイント リンクです。トランクは 1 つのリンクを介して複数の VLAN トラフィックを伝送するので、VLAN をネットワーク全体に拡張することができます。

802.1Q(業界標準のトランキング カプセル化方式)が、すべてのイーサネット ポートで使用できます。

1 つのイーサネット ポートまたは EtherChannel に対してトランクを設定できます。EtherChannel の詳細については、を参照してください。

イーサネット トランク ポートは、数種類のトランキング モードをサポートしています(表 20-1を参照)。

Dynamic Trunking Protocol(DTP)は LAN ポート上のトランク自動ネゴシエーションを管理します。

トランキングを自動ネゴシエーションするには、LAN ポートが同じ VTP ドメインに存在する必要があります。異なるドメイン内の LAN ポートを強制的にトランクするには、 trunk キーワードまたは nonegotiate キーワードを使用します。VTP ドメインの詳細については、「VLAN トランキング プロトコル(VTP)」を参照してください。

レイヤ 2 LAN ポート モード

 

表 20-1 レイヤ 2 LAN ポート モード

モード
機能

switchport mode access

LAN ポートは永続的な非トランキング モードになり、リンクを非トランク リンクに変換するようにネゴシエーションを行います。ネイバー LAN ポートが変更に同意しなくても、LAN ポートは非トランク ポートになります。

switchport mode dynamic desirable

リンクからトランク リンクへの変換を LAN ポートにアクティブに試行させます。ネイバー LAN ポートが trunk desirable 、または auto モードに設定されていれば、LAN ポートはトランク ポートになります。このモードは、すべての LAN ポートのデフォルト モードです。

switchport mode dynamic auto

LAN ポートにリンクからトランク リンクへの変換を試行させます。ネイバー LAN ポートが trunk または desirable モードに設定されていれば、LAN ポートはトランク ポートになります。

switchport mode trunk

LAN ポートは永続的なトランキング モードになり、リンクをトランク リンクに変換するようにネゴシエーションを行います。ネイバー ポートが変更に同意しなくても、LAN ポートはトランク ポートになります。

switchport nonegotiate

LAN ポートを永続的なトランキング モードにしますが、LAN ポートが DTP フレームを生成するのを防ぎます。トランク リンクを確立するには、ネイバー ポートを手動でトランク ポートとして設定する必要があります。


DTP はポイントツーポイント プロトコルです。ただし、インターネットワーキング デバイスによっては、DTP フレームが正しく転送されないことがあります。この問題を避けるために、これらのリンク上でトランキングを行わない場合は、DTP をサポートしないデバイスに接続されている LAN ポートが、access キーワードを使用して設定されていることを確認してください。DTP をサポートしないデバイスへのトランキングをイネーブルにするには、nonegotiate キーワードを使用して、LAN ポートをトランクにし、DTP フレームが生成されないようにします。


レイヤ 2 LAN インターフェイスのデフォルト設定

 

機能
デフォルト

インターフェイス モード:

 

switchport コマンドの入力前

レイヤ 3(未設定)

switchport コマンドの入力後

switchport mode dynamic desirable

VLAN 許容範囲

VLAN 1 ~ 4094(予約済み VLAN を除く)( を参照)

プルーニングに適格な VLAN 範囲

VLAN 2 ~ 1001

デフォルト アクセス VLAN

VLAN 1

ネイティブ VLAN(802.1Q トランク用)

VLAN 1

スパニングツリー プロトコル(STP)

すべての VLAN でイネーブル

STP ポート プライオリティ

128

STP ポート コスト

10 Mbps イーサネット LAN ポートでは 100

10/100 Mbps ファスト イーサネット LAN ポートでは 19

100 Mbps ファスト イーサネット LAN ポートでは 19

1,000 Mbps ギガビット イーサネット LAN ポートでは 4

10,000 Mbps 10 ギガビット イーサネット LAN ポートでは 2

レイヤ 2 スイッチング用の LAN インターフェイスの設定方法

「レイヤ 2 スイッチング用の LAN ポートの設定」

「アウトオブバンドの MAC アドレス テーブルの同期のイネーブル化」

「MAC アドレス テーブル通知の設定」

「トランクとしてのレイヤ 2 スイッチング ポートの設定」

「レイヤ 2 アクセス ポートとしての LAN インターフェイスの設定」

「カスタム IEEE 802.1Q EtherType フィールド値の設定」


) インターフェイスをデフォルト設定に戻すには、default interface {fastethernet | gigabitethernet | tengigabitethernet} slot/port コマンドを使用します。


レイヤ 2 スイッチング用の LAN ポートの設定

レイヤ 2 スイッチング用の LAN ポートを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router(config)# interface type slot/port

設定する LAN ポートを選択します。

ステップ 2

Router(config-if)# shutdown

(任意)設定が完了するまでトラフィック フローを防止するために、インターフェイスをシャットダウンします。

ステップ 3

Router(config-if)# switchport

LAN ポートをレイヤ 2 スイッチング用に設定します。

コマンドを入力してください。

ステップ 4

Router(config-if)# no shutdown

インターフェイスをアクティブにします。(インターフェイスをシャットダウンしている場合に限り必要)。

ステップ 5

Router(config-if)# end

コンフィギュレーション モードを終了します。

switchport コマンドを入力したあとのデフォルト モードは、 switchport mode dynamic desirable です。ネイバー ポートがトランキングをサポートし、かつトランキングを許可するように設定されている場合、 switchport コマンドを入力すると、リンクはレイヤ 2 トランクになります。


switchport コマンドを使用する際に、レイヤ 3 に設定するポートが現在レイヤ 2 に設定されている場合、レイヤ 3 の設定はメモリには保持されますが、実行コンフィギュレーションには保持されず、ポートがレイヤ 3 にスイッチングされるたびにポートに適用されます。また、レイヤ 2 に設定するポートが現在レイヤ 3 に設定されている場合、レイヤ 2 の設定はメモリには保持されますが、実行コンフィギュレーションには保持されず、ポートがレイヤ 2 にスイッチングされるたびにポートに適用されます。メモリおよび実行コンフィグレーションでポートのデフォルト設定を復元するには、default interface コマンドを使用します。switchport コマンドを使用したポートの役割の変更に伴う潜在的な問題を回避するには、switchport コマンドを適用する前にインターフェイスをシャットダウンします。


アウトオブバンドの MAC アドレス テーブルの同期のイネーブル化

アウトオブバンドの MAC アドレス テーブルの同期機能をイネーブルにするには、次の作業を実行します。

 

コマンド
目的

Router(config)# mac address-table synchronize [ activity-time seconds ]

DFC 搭載のスイッチング モジュール間でアウトオブバンドの MAC アドレス テーブルの同期をイネーブルにします。

activity-time seconds :(任意)アクティビティ タイマーの間隔を指定します。

アウトオブバンドの MAC アドレス テーブルの同期を設定する際は、次の点に注意してください。

デフォルトでは、アウトオブバンドの MAC アドレス テーブルの同期はディセーブルになります。

スイッチに WS-6708-10G スイッチング モジュールが搭載されている場合、アウトオブバンドの MAC アドレス テーブルの同期は自動的にイネーブルになります。

アクティビティ タイマーの間隔は、160 秒、320 秒、および 640 秒として設定できます。デフォルトは 160 秒です。

次に、アウトオブバンドの MAC アドレス テーブルの同期をイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# mac address-table synchronize activity-time 320

MAC アドレス テーブル通知の設定


) • ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。

この機能を使って SNMP トラップ通知を送信するには、snmp-server enable mac-notification change コマンドを使い、グローバル MAC トラップ フラグもイネーブルにする必要があります。


 

MAC アドレス テーブルの通知機能を設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router(config)# mac address-table notification change [ interval value ]

MAC アドレス テーブルにおける動的変更の通知送信をイネーブルにします。

(任意)変更を送信する最短の間隔を秒単位で指定します。

形式を実行すると、変更情報は送信されずにデフォルトに戻ります。

ステップ 2

Router(config)# mac address-table notification change [ history size ]

MAC アドレス テーブルにおける動的変更の通知送信をイネーブルにします。

(任意)履歴バッファ内のエントリ数を設定します。

形式を実行すると、変更情報は送信されずにデフォルトに戻ります。

ステップ 3

Router(config)# interface type slot/port

設定する LAN ポートを選択します。

ステップ 4

Router(config-if)# snmp trap mac-notification change [ added | removed ]

この LAN ポートに関連付けられている MAC アドレスで、MAC アドレスがアドレス テーブルに追加、またはアドレス テーブルから削除された場合に SNMP トラップ通知をイネーブルにします。

(任意)テーブルに MAC アドレスが追加された場合だけ通知する場合は、added オプションを使用します。テーブルから MAC アドレスが削除された場合だけ通知する場合は、removed オプションを使用します。

ステップ 5

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了します。

通知パラメータを設定する場合、次の情報に注意してください。

interval value パラメータで指定できる値は、0 秒(即時)~ 2,147,483,647 秒です。デフォルトは 1 秒です。

history size パラメータで設定できる値は、0 エントリから 500 エントリまでです。デフォルトは 1 エントリです。

次に、Gigabit Ethernet ポート 5/7 および 5/8 上のアドレスの MAC アドレス テーブルへの動的な追加に関する SNMP 通知を設定する方法の例を示します。変更の通知は、5 秒以下の間隔で送信されます。変更回数 25 回までが保存され、この間隔で送信されます。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# mac address-table notification change interval 5
Router(config)# mac address-table notification change history 25
Router(config)# interface gigabitethernet 5/7
Router(config-if)# snmp trap mac-notification change added
Router(config-if)# end
Router(config)# interface gigabitethernet 5/8
Router(config-if)# snmp trap mac-notification change added
Router(config-if)# end
Router# exit

802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定


) • ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。

キーワードを指定せずに switchport コマンドを入力する場合(前述のステップ 3)、デフォルト モードは switchport mode dynamic desirable です。


 

レイヤ 2 スイッチング ポートを 802.1Q トランクとして設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk encapsulation dot1q

(任意)カプセル化を 802.1Q として設定します。

switchport mode trunk コマンドを使用できるようにするには、カプセル化を 802.1Q として設定する必要があります。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


DTP を使用するためのレイヤ 2 トランクの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


DTP を使用するようにレイヤ 2 トランクを設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport mode dynamic { auto | desirable }

(任意)DTP を使用するようにトランクを設定します。

)に戻ります。

DTP を使用するようにレイヤ 2 トランクを設定する際、次の情報に注意してください。

インターフェイスがレイヤ 2 アクセス ポートの場合、またはトランキング モードを指定する場合に限り必須です。

トランキング モードの詳細については、表 20-1 を参照してください。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


DTP を使用しないようにするためのレイヤ 2 トランクの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


DTP を使用しないようにレイヤ 2 トランクを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router(config-if)# switchport mode trunk

(任意)無条件にポートをトランクに設定します。

ステップ 2

Router(config-if)# switchport nonegotiate

(任意)DTP を使用しないようにトランクを設定します。

形式を実行すると、ポートで DTP がイネーブルになります。

DTP を使用しないようにレイヤ 2 トランクを設定する際、次の点に注意してください。

switchport mode trunk コマンドを入力する前に、カプセル化を設定する必要があります(「802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定」を参照)。

switchport nonegotiate コマンドを使用できるようにするには、 switchport mode trunk コマンドを入力する必要があります。

switchport mode dynamic trunk コマンドを入力します。トランキング モードの詳細については、表 20-1 を参照してください。

switchport nonegotiate コマンドを入力する前にカプセル化を設定し(「802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定」を参照)、 switchport mode trunk コマンドを使用して無条件にポートをトランクに設定する必要があります(「DTP を使用するためのレイヤ 2 トランクの設定」を参照)。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


アクセス VLAN の設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


アクセス VLAN を設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport access vlan vlan_ID

(任意)インターフェイスがトランキングを停止した場合に使用するアクセス VLAN を設定します。 vlan_ID の値は 1 ~ 4094 です(予約済み VLAN は除く。 を参照)。

(注)

VLAN のロックがイネーブルになっている場合は、VLAN の番号の代わりに VLAN の名前を入力します。詳細については、を参照してください。

このコマンドの no 形式を実行すると、デフォルトの VLAN(VLAN 1)に戻ります。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


802.1Q ネイティブ VLAN の設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


802.1Q ネイティブ VLAN を設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk native vlan vlan_ID

(任意)802.1Q ネイティブ VLAN を設定します。

(注) VLAN のロックがイネーブルになっている場合は、VLAN の番号の代わりに VLAN の名前を入力します。詳細については、を参照してください。

ネイティブ VLAN を設定する際、次の点に注意してください。

vlan_ID の値は 1 ~ 4094 です(予約済み VLAN は除く。 を参照)。

アクセス VLAN がネイティブ VLAN として自動的に使用されることはありません。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


トランク上で許容される VLAN のリストの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


トランク上で許容される VLAN のリストを設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk allowed vlan [ add | except | none | remove ] vlan [, vlan [, vlan [,...]]

(任意)トランク上で許容される VLAN のリストを設定します。

(注)

VLAN のロックがイネーブルになっている場合は、VLAN の番号の代わりに VLAN の名前を入力します。詳細については、を参照してください。

このコマンドの no 形式を実行すると、デフォルト値(すべての VLAN を許可)に戻ります。

トランク上で許容される VLAN のリストを設定する際、次の情報に注意してください。

vlan パラメータは、1 ~ 4094 の間の 1 つの VLAN 番号、または 2 つの VLAN 番号で指定する(小さい方の数を先にして、間をダッシュで区切る)VLAN 範囲です。カンマで区切った vlan パラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

VLAN のロックがイネーブルになっている場合は、VLAN の番号の代わりに VLAN の名前を入力します。VLAN の名前の範囲を入力する場合は、VLAN の名前とダッシュの間にスペースを入力してください。

デフォルトでは、すべての VLAN が許可されます。

VLAN 1 を削除できます。トランクから VLAN 1 を削除した場合も、トランク インターフェイスは VLAN 1 の Cisco Discovery Protocol(CDP)、VLAN トランキング プロトコル(VTP)、ポート集約プロトコル(PAgP)、DTP などの管理トラフィックを引き続き送受信します。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


プルーニング適格 VLAN のリストの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


レイヤ 2 トランクでプルーニング適格 VLAN のリストを設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk pruning vlan { none |{{ add | except | remove } vlan [, vlan [, vlan [,...]]}}

(任意)トランクでプルーニング適格 VLAN のリストを設定します(「VTP プルーニング」を参照)。

形式を実行すると、デフォルト値(すべての VLAN がプルーニング適格)に戻ります。

トランク上で許容されるプルーニング適格 VLAN のリストを設定する際、次の点に注意してください。

vlan パラメータは、1 ~ 4094 の範囲の単一の VLAN 番号(予約済み VLAN を除く。 を参照)、または 2 つの VLAN 番号(小さい番号が先、ダッシュで区切る)で指定する VLAN 範囲です。カンマで区切った vlan パラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、プルーニングが許容される VLAN のリストには、すべての VLAN が含まれます。

VTP トランスペアレント モードのネットワーク デバイスは、VTP Join メッセージを送信しません。VTP トランスペアレント モードのネットワーク装置にトランク接続されている場合は、トランスペアレント モード ネットワーク装置によって使用される VLAN、またはプルーニング不適格としてトランスペアレント モード ネットワーク装置全体に伝送する必要がある VLAN を設定します。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


トランクの設定の完了

レイヤ 2 トランクの設定を完了するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router(config-if)# no shutdown

インターフェイスをアクティブにします。(インターフェイスをシャットダウンしている場合に限り必要)。

ステップ 2

Router(config-if)# end

コンフィギュレーション モードを終了します。

レイヤ 2 トランクの設定の確認

レイヤ 2 トランクの設定を確認するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# show running-config interface type slot/port

インターフェイスの実行コンフィギュレーションを表示します。

ステップ 2

Router# show interfaces [ type slot/port ] switchport

インターフェイスのスイッチ ポートの設定を表示します。

ステップ 3

Router# show interfaces [ type slot/port ] trunk

インターフェイスのトランクの設定を表示します。

設定および確認の例

次に、ギガビット イーサネット ポート 5/8 を 802.1Q トランクとして設定する例を示します。この例では、ネイバー ポートが 802.1Q トランキングをサポートするように設定されていることを前提としています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface gigabitethernet 5/8
Router(config-if)# shutdown
Router(config-if)# switchport
Router(config-if)# switchport mode dynamic desirable
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# no shutdown
Router(config-if)# end
Router# exit
 

次に、設定を確認する例を示します。

Router# show running-config interface gigabitethernet 5/8
Building configuration...
Current configuration:
!
interface GigabitEthernet5/8
no ip address
switchport
switchport trunk encapsulation dot1q
end
 
Router# show interfaces gigabitethernet 5/8 switchport
Name: Gi5/8
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Enabled
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: ALL
 
Router# show interfaces gigabitethernet 5/8 trunk
 
Port Mode Encapsulation Status Native vlan
Gi5/8 desirable n-802.1q trunking 1
 
Port Vlans allowed on trunk
Gi5/8 1-1005
 
Port Vlans allowed and active in management domain
Gi5/8 1-6,10,20,50,100,152,200,300,303-305,349-351,400,500,521,524,570,801-8
02,850,917,999,1002-1005
 
Port Vlans in spanning tree forwarding state and not pruned
Gi5/8 1-6,10,20,50,100,152,200,300,303-305,349-351,400,500,521,524,570,801-8
02,850,917,999,1002-1005
 
Router#

レイヤ 2 アクセス ポートとしての LAN インターフェイスの設定


) 存在しない VLAN に LAN ポートを割り当てると、VLAN データベースにその VLAN を作成するまで、LAN ポートはシャットダウンされます(を参照)。


LAN ポートをレイヤ 2 アクセス ポートとして設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router(config)# interface type slot/port

設定する LAN ポートを選択します。

ステップ 2

Router(config-if)# shutdown

(任意)設定が完了するまでトラフィック フローを防止するために、インターフェイスをシャットダウンします。

ステップ 3

Router(config-if)# switchport

LAN ポートをレイヤ 2 スイッチング用に設定します。

コマンドを入力してください。

ステップ 4

Router(config-if)# switchport mode access

LAN ポートをレイヤ 2 アクセス ポートとして設定します。

ステップ 5

Router(config-if)# switchport access vlan vlan_ID

LAN ポートを VLAN に入れます。 vlan_ID の値は 1 ~ 4094 です(予約済み VLAN は除く。 を参照)。

(注) VLAN のロックがイネーブルになっている場合は、VLAN の番号の代わりに VLAN の名前を入力します。詳細については、を参照してください。

ステップ 6

Router(config-if)# no shutdown

インターフェイスをアクティブにします。(インターフェイスをシャットダウンしている場合に限り必要)。

ステップ 7

Router(config-if)# end

コンフィギュレーション モードを終了します。

次に、ギガビット イーサネット ポート 5/6 を VLAN 200 のアクセス ポートとして設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface gigabitethernet 5/6
Router(config-if)# shutdown
Router(config-if)# switchport
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 200
Router(config-if)# no shutdown
Router(config-if)# end
Router# exit
 

次に、設定を確認する例を示します。

Router# show running-config interface gigabitethernet 5/6
Building configuration...
!
Current configuration:
interface GigabitEthernet5/6
no ip address
switchport access vlan 200
switchport mode access
end
 
Router# show interfaces gigabitethernet 5/6 switchport
Name: Gi5/6
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Enabled
Access Mode VLAN: 200 (VLAN0200)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: ALL
 
Router#

カスタム IEEE 802.1Q EtherType フィールド値の設定

802.1Q タグ付きまたは 802.1p タグ付きフレームの標準 0x8100 EtherType フィールド値を使用しないネットワーク デバイスをサポートするように、ポートでカスタム EtherType フィールド値を設定できます。

EtherType フィールドのカスタム値を設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport dot1q ethertype value

ポートの 802.1Q EtherType フィールド値を設定します。

カスタム EtherType フィールド値の設定時には、以下に注意してください。

カスタム EtherType フィールド値を使用するには、ネットワーク上のトラフィック パス内のネットワーク デバイスすべてがカスタム EtherType フィールド値をサポートする必要があります。

トランク ポート、アクセス ポート、トンネル ポート上のカスタム EtherType フィールド値を設定できます。

EtherChannel のメンバ ポート上のカスタム EtherType フィールド値を設定できます。

ポートチャネル インターフェイス上では、カスタム EtherType フィールド値を設定できません。

ポートごとに、EtherType フィールド値 1 つだけをサポートします。カスタム EtherType フィールド値で設定されたポートでは、他の EtherType フィールド値を持つフレームはタグ付きフレームとして認識されません。たとえば、カスタム EtherType フィールド値で設定されたトランク ポートでは、802.1Q タグ付きフレームの標準 0x8100 EtherType フィールド値は認識されず、このフレームが属する VLAN にフレームを配置することができません。


注意 カスタム EtherType フィールド値で設定されたポートは、他の EtherType フィールド値を持つフレームをタグなしのフレームと見なします。カスタム EtherType フィールド値を持つトランク ポートは、他の EtherType フィールド値を持つフレームをネイティブ VLAN に配置します。カスタム EtherType フィールド値を持つアクセス ポートまたはトンネル ポートは、他の EtherType フィールド値を持つフレームをアクセス VLAN に配置します。カスタム EtherType フィールド値を正しく設定しないと、フレームは間違った VLAN に配置される場合があります。

カスタム IEEE802.1Q EtherType フィールド値をサポートするモジュールの一覧については、『 Release Notes for Cisco IOS Release 15.1SY 』を参照してください。

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/15.1SY/release_notes.html

次に、EtherType フィールド値を 0x1234 に設定する例を示します。

Router (config-if)# switchport dot1q ethertype 1234
Router (config-if)#

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する