Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.1SY
Ethernet Virtual Connections(EVC; イーサネット バーチャル コネクション)
Ethernet Virtual Connections(EVC; イーサネット バーチャル コネクション)
発行日;2013/08/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

Ethernet Virtual Connections(EVC; イーサネット バーチャル コネクション)

EVC の前提条件

EVC の制約事項

EVC について

EVC の概要

イーサネット フロー ポイント

サービス インスタンスおよび EFP

カプセル化(フレキシブル サービス マッピング)

EFP および MSTP

ブリッジ ドメイン

ブリッジ ドメインの概要

イーサネット MAC アドレス ラーニング

未知の MAC アドレスおよびブロードキャスト アドレスのレイヤ 2 フレームのフラッディング

レイヤ 2 宛先 MAC アドレス ベースの転送

MAC アドレス エージング

MAC Address Table

書き換え処理

レイヤ 3 およびレイヤ 4 ACL のサポート

高度なフレーム操作

出力フレーム フィルタリング

EVC のデフォルト設定

EVC の設定方法

同じブリッジ ドメインに加わっている 2 つのサービス インスタンス

ブリッジ ドメインおよび VLAN カプセル化

Rewrite

EVC のモニタリング

Ethernet Virtual Connections(EVC; イーサネット バーチャル コネクション)

「EVC の前提条件」

「EVC の制約事項」

「EVC について」

「EVC のデフォルト設定」

「EVC の設定方法」

「EVC のモニタリング」


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。


 

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する


 

EVC の前提条件

なし。

EVC の制約事項

LACP EtherChannel と 802.1ad プロバイダー ブリッジ モードは相互に排他的です。802.1ad プロバイダー ブリッジ モードがイネーブルの場合、LACP EtherChannel はトラフィックを送信できません。

スイッチあたりの最大 EFP:10K。

ブリッジ ドメインごとの最大 EFP:124。

インターフェイスごとの最大 EFP:4K。

スイッチあたりの最大ブリッジ ドメイン:4K。

ブリッジ ドメインの設定は、EVC サービス インスタンスの設定の一部としてだけサポートされます。

EVC をサポートするための前提条件は、次のとおりです。

スパニングツリー モードは MST である必要があります。

dot1ad グローバル コンフィギュレーション モード コマンドを設定する必要があります。

サービス インスタンスは、 switchport nonegotiate コマンドによって、無条件トランクとして設定されたポートでだけ設定できます。

EVC ポートをサポートするために、PFC QoS を設定できます。

サポートされる EVC 機能には、次のものがあります。

サービス インスタンス:イーサネット インターフェイスで EFP サービス インスタンスを作成、削除、変更します。

EVC のイーサネット サービスの保護。

- イーサネット運用管理およびメンテナンス(EOAM)

- 接続障害管理(CFM)

- イーサネット ローカル管理インターフェイス(E-LMI)

IPv6 アクセス コントロール リスト(ACL)。

カプセル化:802.1Q VLAN(1 つの VLAN または VLAN のリストまたは範囲)に基づいて EFP にトラフィックをマッピングできます。

ブリッジ ドメインのメンバーとして EFP を設定できます。

ブリッジ ドメインでは、対称的なプッシュのみをサポートしています。サポートされている書き換え設定は、出力のプッシュ(タグの追加)を意味しています

ブリッジ ドメインは入力書き換えをサポートしています

EVC 転送

MAC アドレス ラーニングおよびエージング

EtherChannel の EVC

EVC MAC アドレス セキュリティ

スイッチポートと EFP のブリッジング

MSTP(EVC ブリッジ ドメインの MST)

EFP の統計情報(パケット数およびバイト数)

サービス インスタンス単位の QoS 対応 EVC/EFP

次のレイヤ 2 ポート ベースの機能は、ポートに設定された EVC で動作可能です。

PAGP

LACP

UDLD

LLDP

CDP

MSTP

次の機能は、EVC でサポートされていません。

レイヤ 2 マルチキャスト フレームのフラッディング

レイヤ 2 プロトコル トンネリング

QinQ タギング

VLAN 変換

Ethernet over MPLS(EoMPLS)

ブリッジ ドメイン ルーティング

スプリット ホライズン

サービス インスタンス グループ。別称は、イーサネット フロー ポイント(EFP)グループ

IPv6 アクセス コントロール リスト(ACL)

EVC について

「EVC の概要」

「イーサネット フロー ポイント」

「サービス インスタンスおよび EFP」

「カプセル化(フレキシブル サービス マッピング)」

「EFP および MSTP」

「ブリッジ ドメイン」

「書き換え処理」

「レイヤ 3 およびレイヤ 4 ACL のサポート」

「高度なフレーム操作」

「出力フレーム フィルタリング」

EVC の概要

イーサネット仮想回線(EVC)は、イーサネット サービスをサポートするレイヤ 2 のブリッジングアーキテクチャを定義します。EVC は、サービス プロバイダー ネットワーク内のポイントツーポイントまたはマルチポイントツーマルチポイントのパスを識別する複数のユーザ ネットワーク インターフェイス間の関連付けとして Metro Ethernet Forum(MEF)によって定義されます。EVC は、サービス プロバイダー ネットワーク内の概念的なサービス パイプです。ブリッジ ドメインは、VLAN とは別に存在するローカル ブロードキャスト ドメインです。

イーサネット フロー ポイント

イーサネット フロー ポイント(EFP)サービス インスタンスは、物理ポートまたは EtherChannel にブリッジ ドメインを接続する論理インターフェイスです。レイヤ 2 ポートにサービス インスタンスを設定すると、EVC 機能を設定する疑似ポートまたは EFP が作成されます。各サービス インスタンスは、インターフェイスごとに一意の番号を持ちますが、異なるポート上のサービス インスタンス同士は関係を持たないため、異なるインターフェイスで同じ番号を使用できます。

EFP は、ユーザ定義の基準に基づいて、同じ物理ポートからのフレームを、そのポートに関連付けられた複数のサービス インスタンスの 1 つに分類します。各 EFP に、異なる転送アクションと動作を関連付けることができます。

EFP の 3 つの主な特性(またはパラメータ)は次のとおりです。

カプセル化

書き換え情報

転送インスタンスまたは方式(ブリッジ ドメインまたは xconnect)

EVC ブロードキャスト ドメインは、ブリッジ ドメインおよびこれに接続されている EFP によって決まります。着信フレームは、インターフェイスの EFP 一致基準と照合され、一致する EFP で学習されて、ブリッジ ドメイン内の 1 つまたは複数の EFP に転送されます。一致する EFP がない場合、フレームはドロップされます。

EFP は、VLAN 変換を設定するために使用できます。たとえば、同じインターフェイスから出力に対する 2 つの EFP がある場合、異なる VLAN 書き換え処理を各 EFP に設定できます。これは、従来のスイッチ ポート VLAN 変換モデルよりも柔軟です。

EFP が作成されたとき、初期状態は UP です。次の状況では、状態が DOWN に変わります。

ユーザが EFP を明示的にシャット ダウンする。

EFP が関連付けられているメイン インターフェイスが停止しているか、削除されている。

EFP がブリッジ ドメインに属する場合に、そのブリッジ ドメインが停止している。

EFP が、特定の機能の問題防止手段として、強制停止されている。

サービス インスタンスおよび EFP

レイヤ 2 ポートまたは EtherChannel にサービス インスタンスを設定すると、EVC 機能を設定する疑似ポートまたはイーサネット フロー ポイント(EFP)が作成されます。各サービス インスタンスは、インターフェイスごとに一意の番号を持ちますが、異なるポート上のサービス インスタンス同士は関係を持たないため、異なるインターフェイスで同じ番号を使用できます。

ethernet evc evc-id グローバル コンフィギュレーション コマンドを入力して EVC を定義してあれば、EVC をサービス インスタンスと関連付けることができます(任意)。サービス インスタンスのデフォルトの動作はありません。サービス インスタンスは、許可 VLAN が設定されていないトランク ポートにのみ設定できます。その他の設定は許可されません。インターフェイスにサービス インスタンスを設定してある場合は、このインターフェイスでは switchport コマンドが許可されません。サービス インスタンスは、EtherChannel グループにも設定できます。

レイヤ 2 インターフェイスまたは EtherChannel に EFP を作成し、サービス インスタンス コンフィギュレーション モードを開始するには、 service instance number ethernet [ name ] インターフェイス コンフィギュレーション コマンドを使用します。サービス インスタンス コンフィギュレーション モードは、インターフェイス単位でサービス インスタンスに適用される、管理プレーンとコントロール日付プレーンのすべての属性とパラメータを設定するために使用します。

service instance number は EFP ID で、1 ~ 4000 の整数です。

オプションの ethernet name は事前に設定された EVC 名です。EVC name の入力は不要ですが、 ethernet の入力は必要です。同じ EVC に対応するときは、異なる EFP に同じ名前を指定できます。EFP は、共通名を使用してグローバル EVC に関連付けられます。

サービス インスタンス コンフィギュレーション モードを開始すると、次のオプションを設定できます。

default :コマンドをデフォルトに設定します

description :サービス インスタンス固有の説明を追加します

encapsulation :イーサネット フレームの一致基準を設定します

errdisable :エラー ディセーブルを設定します

ethernet :イーサネット LMI パラメータを設定します

exit :サービス インスタンス コンフィギュレーション モードを終了します

l2protocol :レイヤ 2 制御プロトコル処理を設定します

mac :MAC アドレス ベースの機能のコマンド

no :コマンドを無効にするか、デフォルト設定にします。

service-policy :EFP にポリシーマップを対応付けます

shutdown :サービス インスタンスをアウト オブ サービス状態にします

サービス インスタンスをシャット ダウンまたは起動するには、[ no ] shutdown サービス インスタンス コンフィギュレーション モードを開始します。

サービス インスタンスの設定されていないレイヤ 2 ポートでは、複数の switchport コマンドを使用できます( access backup block host mode 、および trunk )。1 つまたは複数のサービス インスタンスがレイヤ 2 ポートに設定されている場合、このインターフェイスでは、いずれの switchport コマンドも受け入れません。

カプセル化(フレキシブル サービス マッピング)

カプセル化では、次の要素の任意の組み合わせをサービス インスタンスにマッピングする一致基準を定義します。

VLAN

VLAN の範囲

サービス クラス(CoS)ビット

Ethertype

VLAN タグと CoS には、単一の値、範囲、またはリストを指定できます。Ethertype には、単一のタイプまたはタイプのリストを指定できます。次のカプセル化タイプがあります。

default

dot1q

priority-tagged

untagged

プライオリティ タグ付きフレームは常に一重タグ付きです。すべてのイーサネット トラフィックがサポートされます。次のカプセル化分類オプションがあります。

内部タグ CoS

内部タグ VLAN

カプセル化方式を設定すると、フレキシブル サービス マッピングが可能になります。これにより、設定したカプセル化方式に基づき、EFP に着信パケットをマッピングできます。

外部 802.1q VLAN タグ値に基づくフレキシブル サービス マッピングのデフォルト動作は、nonexact です。これは、EFP カプセル化の設定で内部(第 2)VLAN タグ一致基準を指定していない場合、フレームが外部 VLAN タグ値の条件を満たす限り、ソフトウェアでは、一重タグ付きフレームと二重タグ付きフレームの両方を、この EFP にマッピングすることを意味します。コマンドライン インターフェイス(CLI)では、 exact キーワードを使用した正確なマッピングを指定できます。このキーワードを指定した場合、EFP は一重タグ付きフレーム専用として指定され、二重タグ付きフレームは、この EFP に分類されません。

サービス インスタンス コンフィギュレーション モードで CLI encapsulation コマンドを使用すると、カプセル化の基準を設定できます。EFP(サービス インスタンス)ごとに encapsulation コマンドを 1 つ設定する必要があります。カプセル化方式を設定してあると、サービス インスタンス コンフィギュレーション モードで、次のコマンドを使用できます。

bridge-domain :ブリッジ ドメインを設定します。

rewrite :イーサネット書き換え基準を設定します。

 

表 41-1 サポートされているカプセル化タイプ

コマンド
説明

encapsulation dot1q { any | vlan-id [ , vlan-id [ - vlan-id ]]}

インターフェイス上の入力 802.1q フレームを、適切な EFP にマッピングするために使用する照合基準を定義します。オプションは、単一 VLAN、VLAN の範囲、または VLAN か VLAN 範囲のリストです。VLAN ID は 1 ~ 4094 です。

すべての VLANS(1 ~ 4094)と一致させるには、 any キーワードを入力します。

最も外側のタグとの完全一致には単一の VLAN ID を入力します。

最も外側の範囲との一致には VLAN の範囲を入力します。

encapsulation dot1q vlan-id cos cos-value

CoS 値のカプセル化は、C タグの CoS を組み込んだあとの一致基準を定義します。CoS 値は、1 ~ 7 の間の 1 桁です。

CoS カプセル化は、 encapsulation untagged コマンドによって設定できませんが、 encapsulation priority-tagged コマンドを使用して設定できます。結果は、最も外側で完全一致する VLAN および CoS です。VLAN の範囲も使用できます。

encapsulation untagged

インターフェイスに入るタグなしイーサネット フレームを適切な EFP にマッピングするために使用する一致基準。

タグなしカプセル化は、ポートあたり 1 つの EFP のみに設定できます。ただし、タグなしトラフィックと一致する EFP を持つポートでは、タグ付きフレームと一致する他の EFP も持つことができます。

コマンドとともにはサポートされません。

encapsulation priority-tagged

プライオリティ タグ付きフレームを指定します。プライオリティ タグ付きパケットは VLAN ID 0 および CoS 値 0 ~ 7 を持ちます。

コマンドとともにはサポートされません。

encapsulation default

他に一致する基準のないすべてのパケットと一致するデフォルト EFP をポートに設定します。ポートにデフォルト EFP のみが設定されている場合は、このポートのすべての入力フレームに一致します。

ポートにデフォルト EFP を設定した場合は、同じブリッジ ドメインを持つ他の EFP を同じポートに設定できません。

ポートに入るパケットがそのポートでカプセル化のいずれとも一致しない場合、パケットはドロップされるため、パケットをフィルタリングすることになります。フィルタリング基準を決めるためには、カプセル化は、ネットワーク上のパケットと一致する必要があります。ネットワーク上で、スイッチに入る書き換え前のパケットおよびスイッチから出る書き換え後のパケットを参照します。

EFP および MSTP

EFP ブリッジ ドメインは、マルチ スパニングツリー プロトコル(MSTP)によってでサポートされています。次の制限は、ブリッジ ドメインとともに STP を実行する場合に適用されます。

1 つのブリッジ ドメインにマッピングされたすべての着信 VLAN(最も外側または単一)は、同じ MST インスタンスに属する必要があり、そうでない場合、ループが発生するおそれがあります。

同じ MST インスタンスにマッピングされたすべての EFP について、ポートをブロックする STP が原因で接続が切断されないように、すべての冗長パスにバックアップ EFP を設定する必要があります。

STP モードが PVST+ または PVRST の場合、EFP の情報はプロトコルに渡されません。EVC は MSTP だけをサポートします。

マルチキャスト ポートの STP モードを MST から PVST+ または PVRST に変更することは許可されません。

ブリッジ ドメインの概要

ブリッジ ドメインは、プラットフォーム内部のブロードキャスト ドメインを定義し、VLAN からブロードキャスト ドメインを分離できます。この分離により、ポートごとの VLAN シグニフィカンスが可能になるため、単一のデバイスごとの VLAN ID 空間に関連する拡張性の制限がなくなります。ブリッジ ドメインに参加している EFP の 1 つから受信した、一致するフレームは、ブリッジングされます。

サービス インスタンスをブリッジ ドメインに対応付ける必要があります。ブリッジ ドメインのフラッディングおよび通信の動作は VLAN ドメインの動作と似ています。ブリッジ ドメイン メンバーシップは、ブリッジ ドメインに加入しているサービス インスタンスによって決まる一方で(カプセル化の基準に基づく)、VLAN ドメイン メンバーシップは、パケット内の VLAN タグによって決まります。


) ブリッジ ドメインを設定する前に、カプセル化を設定する必要があります。


IGMP スヌーピングはスイッチとすべての VLAN で、デフォルトでイネーブルですが、4094 未満のブリッジ ドメインを設定すると VLAN で自動的にディセーブルになります。スイッチでは、ブリッジ ドメインを 124 個までサポートします。

イーサネット MAC アドレス ラーニング

MAC アドレス ラーニングは常にイネーブルになっており、ディセーブルにできません。

未知の MAC アドレスおよびブロードキャスト アドレスのレイヤ 2 フレームのフラッディング

不明なユニキャストまたはブロードキャストの宛先 MAC アドレスを持つレイヤ 2 フレームは、発信元 EFP を除く、ブリッジ ドメイン内のすべての EFP にフラッディングされます。

フレームのレプリケーションではフレームを複数回再循環させることが必要です。再循環は、転送のパフォーマンスに悪影響を与え、全機能のパケット転送率が下がります。

レイヤ 2 宛先 MAC アドレス ベースの転送

ブリッジングが設定されている場合、EFP から受信したユニキャスト フレームは宛先レイヤ 2 MAC アドレスに基づいて転送されます。宛先アドレスがわかっている場合、フレームは宛先アドレスに関連付けられた EFP/NNI だけに転送されます。

ブリッジと EFP 設定は相関しているため、ブリッジングは EFP でのみサポートされます。複数のブリッジ ドメインをサポートするために、MAC アドレス エントリが EFP のブリッジ ドメインと関連付けられます。動的に学習する必要があるのは、ユニキャスト MAC アドレスだけです。

EVC インフラストラクチャはフレームの内容を変更しません。

MAC アドレス エージング

MAC テーブルの動的に学習された MAC アドレス エントリは、定期的にエージング アウトされ、設定した期間を超えて非アクティブなエントリは、テーブルから削減されます。エージング タイム値のサポート範囲は、5 ~ 1000000 秒で、粒度は 1 秒単位です。デフォルトは 8 分です。 aging-time パラメータはブリッジ ドメインごとに設定でき、相対値です。この値は、フレームがその MAC アドレスとともに受信された時刻に対する相対エージング タイムです。

MAC Address Table

MAC アドレス テーブルは、レイヤ 2 宛先 MAC アドレスに基づいてフレームを転送するために使用されます。テーブルには、ルート プロセッサ(RP)からダウンロードされたスタティック MAC アドレスと、データ パスによって動的に学習された MAC アドレスから構成されます。

MAC 学習機能をイネーブルにした状態で、データ パスで新しい一意の MAC アドレスを学習するとエントリが MAC テーブルに追加され、エージング アウトするとエントリがテーブルから削除されます。

書き換え処理

rewrite コマンドは 802.1ad クラウドでパケットを転送するために入力パケットに 802.1ad タグをプッシュします。

EFP に着信するフレームに追加の dot1ad タグのカプセル化を指定するには、 rewrite ingress tag push dot1ad vlan-id symmetric サービス インスタンス コンフィギュレーション モード コマンドを入力します。


) 設定への書き換えを完了するには、symmetric キーワードが必要です。


symmetric キーワードを入力した場合、出力側の対応する処理では、逆のアクションを実行し、カプセル化 VLAN をプッシュ(追加)します。

レイヤ 3 およびレイヤ 4 ACL のサポート

EFP における ACL の設定は、他のタイプのインターフェイスに ACL を設定する場合と同じです。


) ACL は、マルチプロトコル ラベル スイッチング(MPLS)ヘッダーとプレフィックスが付いたパケットではサポートされません。これには、MPLS パケットがサポートされるプロトコルのレイヤ 3 またはレイヤ 4 ヘッダーが含まれます。


高度なフレーム操作

高度なフレーム操作機能では、EFP の着信フレームと送信フレームの両方に 1 個の VLAN タグを追加する PUSH 処理をサポートしています。

VLAN タグが存在している場合に新しいタグが追加されると、新しいタグの CoS フィールドには、既存 VLAN タグの CoS フィールドと同じ値が設定されます。そうでない場合、CoS フィールドはデフォルトの 0 に設定されます。QoS マーキング コンフィギュレーション コマンドを使用して CoS マーキングを変更できます。

出力フレーム フィルタリング

出力フレーム フィルタリングは、EFP を出るフレームが EFP に関連付けられたカプセル化の特性に一致するレイヤ 2 ヘッダーを含むことを保障するために行われます。このフィルタリングは主に、意図しないフレームの漏洩を防ぐために行われ、EFP で常にイネーブルです。

EVC のデフォルト設定

なし。

EVC の設定方法

レイヤ 2 ポートにサービス インスタンスを設定すると、EVC 機能を設定できる EFP が作成されます。EFP を設定するには、次の作業を実行します。

 

 
コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします。パスワードを入力します(要求された場合)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# dot1ad

802.1ad プロバイダー ブリッジ モードをイネーブルにします。

(注) LACP EtherChannel と 802.1ad プロバイダー ブリッジ モードは相互に排他的です。802.1ad プロバイダー ブリッジ モードがイネーブルの場合、LACP EtherChannel はトラフィックを送信できません。

ステップ 4

Router(config)# interface type number

インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

Router(config-if)# switchport

ポートをレイヤ 2 スイッチング用に設定します。

コマンドを入力してください。

ステップ 6

Router(config-if)# switchport mode trunk

無条件にポートをトランクに設定します。

ステップ 7

Router(config-if)# switchport nonegotiate

DTP を使用しないようにトランクを設定します。

ステップ 8

Router(config-if)# switchport trunk encapsulation dot1q

トランク カプセル化を 802.1Q として設定します。

ステップ 9

Router(config-if)# switchport trunk allowed vlan vlan [, vlan [, vlan [,...]]

トランク上で許可される VLAN のリストを設定します。

(注) VLAN のロックがイネーブルになっている場合は、VLAN の番号の代わりに VLAN の名前を入力します。詳細については、を参照してください。

ステップ 10

Router(config-if)# dot1ad uni

802.1ad プロバイダー ブリッジのユーザネットワーク インターフェイス(UNI)ポートとしてポートを設定します。

が適用されます(を参照)。

ステップ 11

Router(config-if)# no cdp enable

ポート上で CPD をディセーブルにします。

ステップ 12

Router(config-if)# no lldp transmit

(PE ポートで必須)LLDP をディセーブルにします。

ステップ 13

Router(config-if)# spanning-tree bpdufilter enable

ポートで BPDU フィルタリングをイネーブルにします。

ステップ 14

Router(config-if)# service instance number ethernet [ name ]

イーサネット サービス インスタンス(EFP)を設定し、サービス インスタンス コンフィギュレーション モードを開始します。

number は EFP ID で、1 ~ 4000 の整数です。

(任意) ethernet name は事前に設定された EVC 名です。サービス インスタンスでは、EVC 名を使用する必要はありません。

ステップ 15

Router(config-if)# ip access-group access-list-number | access-list-name } { in | out }

(任意)インターフェイスに IP アクセス リストまたはオブジェクトグループ アクセス コントロール リスト(OGACL)を適用します。

ステップ 16

Router(config-if-srv)# encapsulation encapsulation-type vlan-id [ cos cos_value ]

サービス インスタンスのカプセル化タイプを設定します。

default :他に一致する基準のないすべてのパケットのマッチングを設定します。

dot1q :802.1Q カプセル化を設定します。詳細については、「 表 41-1 」を参照してください。

priority-tagged :プライオリティ タグ付きフレーム、VLAN-ID 0 および CoS 値 0 ~ 7 を指定します。

untagged :タグなし VLAN にマップします。タグなしカプセル化は、ポートあたり 1 つの EFP のみに設定できます。

CoS 値は、1 ~ 7 の整数で一致基準を定義します。

ステップ 17

Router(config-if-srv)# rewrite ingress tag push dot1ad vlan-id [ symmetric ]

(任意)サービス インスタンスに入るフレームで実行されるカプセル化調整を指定します。

ステップ 18

Router(config-if-srv)# bridge-domain bridge-id

ブリッジ ドメインを設定します。

ステップ 19

Router(config-if-srv)# end

特権 EXEC モードに戻ります。

複数サービス インスタンスの設定

Router(config)# interface gigabitethernet1/1
Router(config-if)# switchport mode trunk
Router(config-if)# switchport nonegotiate
Router(config-if)# service instance 1 ethernet evc1
Router(config-if-srv)# encapsulation dot1q 201 cos 1
Router(config-if-srv)# rewrite ingress tag push dot1ad 300 symmetric
Router(config-if-srv)# bridge-domain 300
Router(config-if-srv)# end
Router(config-if)# service instance 2 ethernet evc2
Router(config-if-srv)# encapsulation default
Router(config-if-srv)# rewrite ingress tag push dot1ad 301 symmetric
Router(config-if-srv)# bridge-domain 301
Router(config-if-srv)# end
Router(config-if)# service instance 3 ethernet evc3
Router(config-if-srv)# encapsulation priority-tagged cos 1
Router(config-if-srv)# rewrite ingress tag push dot1ad 302 symmetric
Router(config-if-srv)# bridge-domain 302

サービス インスタンスの設定

Router(config)# interface gigabitethernet1/1
Router(config-if)# switchport mode trunk
Router(config-if)# switchport nonegotiate
Router(config-if)# switchport trunk allowed vlan none
Router(config-if)# service instance 22 ethernet evc1
Router(config-if-srv)# encapsulation dot1q 100
Router(config-if-srv)# rewrite ingress tag push dot1ad 10 symmetric
Router(config-if-srv)# bridge-domain 10

VLAN 範囲を使用したカプセル化

Router(config)# interface gigabitethernet1/1
Router(config-if)# service instance 1 ethernet
Router(config-if-srv)# encapsulation dot1q 22-44 cos 1
Router(config-if-srv)# rewrite ingress tag push dot1ad 10 symmetric
Router(config-if-srv)# bridge-domain 10

同じブリッジ ドメインに加わっている 2 つのサービス インスタンス

この例では、ギガビット イーサネット 1/1 および 1/2 のインターフェイスのサービス インスタンス 1 を相互にブリッジングできます。

Router(config)# interface gigabitethernet1/1
Router(config-if)# service instance 1 Ethernet
Router(config-if-srv)# encapsulation dot1q 10
Router(config-if-srv)# rewrite ingress tag push dot1ad 10 symmetric
Router(config-if-srv)# bridge-domain 10
 
Router(config)# interface gigabitethernet1/2
Router(config-if)# service instance 1 Ethernet
Router(config-if-srv)# encapsulation dot1q 10
Router(config-if-srv)# rewrite ingress tag push dot1ad 10 symmetric
Router(config-if-srv)# bridge-domain 10

ブリッジ ドメインおよび VLAN カプセル化

ブリッジ ドメイン番号としては、 encapsulation dot1q コマンドで設定した VLAN ID ではなく、 rewrite ingress tag push dot1ad コマンドで設定した VLAN ID を使用します。これらの値は、一致することも異なることもあります。

Router(config)# interface gigabitethernet1/1
Router(config-if)# service instance 1 ethernet evc1
Router(config-if-srv)# encapsulation dot1q 10
Router(config-if-srv)# rewrite ingress tag push dot1ad 4000 symmetric
Router(config-if-srv)# bridge-domain 4000
 
Router(config)# interface gigabitethernet1/2
Router(config-if)# service instance 1 ethernet evc1
Router(config-if-srv)# encapsulation dot1q 10
Router(config-if-srv)# rewrite ingress tag push dot1ad 4000 symmetric
Router(config-if-srv)# bridge-domain 4000
 

encapsulation dot1q コマンドで設定した VLAN ID がブリッジ ドメイン内で一致しない限り、トラフィックは転送できません。次の例では、カプセル化 VLAN ID が一致しないため(フィルタリング基準)、ギガビット イーサネット 1/1 および 1/2 のサービス インスタンスは、相互の間で転送できません。 rewrite コマンドを使用すると、これら 2 つの間での通信を許可できます。

Router(config)# interface gigabitethernet1/1
Router(config-if)# service instance 1 ethernet evc1
Router(config-if-srv)# encapsulation dot1q 10
Router(config-if-srv)# rewrite ingress tag push dot1ad 4000 symmetric
Router(config-if-srv)# bridge-domain 4000
 
Router(config)# interface gigabitethernet1/2
Router(config-if)# service instance 1 ethernet evc1
Router(config-if-srv)# encapsulation dot1q 99
Router(config-if-srv)# rewrite ingress tag push dot1ad 4000 symmetric
Router(config-if-srv)# bridge-domain 4000

Rewrite

この例では、 rewrite ingress tag push dot1ad コマンドで設定されている VLAN ID(この例では 4000)は、 encapsulation dot1q コマンドで設定された VLAN ID(この例では 10)に一致するパケットにプッシュされます。symmetric キーワードを使用すると、逆方向のパケットで逆のアクションが可能です。このサービス インスタンスから出る VLAN ID 4000 のパケットはカプセル開放され、CoS 1 の VLAN ID 10 になります。

Router(config)# interface gigabitethernet1/1
Router(config-if)# service instance 1 ethernet
Router(config-if-srv)# encapsulation dot1q 10 cos 1
Router(config-if-srv)# rewrite ingress tag push dot1ad 4000 symmetric
Router(config-if-srv)# bridge-domain 4000

EVC のモニタリング

 

表 41-2 サポートされている show コマンド

コマンド
説明

show ethernet service evc [ id evc-id | interface i nterface-id ] [ detail ]

すべての EVC、特定の EVC(EVC ID を入力)、または特定のインターフェイスにあるすべての EVC(インターフェイス ID を入力)に関する情報を表示します。 detail オプションを指定すると、EVC の詳細情報が表示されます。

show ethernet service instance [ id instance-id interface i nterface-id | interface i nterface-id ] {[ detail ] | [ stats ]}

1 つまたは複数のサービス インスタンス(EFP)に関する情報が表示されます。EFP ID およびインターフェイスを指定すると、その具体的な EFP に関連するデータのみが表示されます。インターフェイス ID だけを指定した場合は、このインターフェイス上のすべての EFP に対するデータが表示されます。

show bridge-domain [ n ]

n を入力すると、指定された番号を持つブリッジ ドメインが存在する場合は、指定したブリッジ ドメインのすべてのメンバーがこのコマンドによって表示されます。

n を入力していない場合は、システムのすべてのブリッジ ドメインのすべてのメンバーこのコマンドによって表示されます。

show ethernet service instance detail

このコマンドは、レイヤ 2 プロトコル情報を含む詳細なサービス インスタンスの情報を表示します。出力例を次に示します。

Router# show ethernet service instance detail
Service Instance ID: 2
Associated Interface: GigabitEthernet7/2
Associated EVC: evc2
L2protocol drop
CE-Vlans:
Encapsulation: dot1q 2 vlan protocol type 0x8100
Rewrite: ingress tag push dot1ad 2 vlan-type 0x88A8 symmetric
Interface Dot1q Tunnel Ethertype: 0x8100
State: Up
EFP Statistics:
Pkts In Bytes In Pkts Out Bytes Out
0 0 0 0

show mac address-table

このコマンドは、動的に学習されたか静的に設定された MAC セキュリティ アドレスを表示します。

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する