Cisco IOS ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.1SY
マルチポイント GRE を介したレイヤ 2(L2omGRE)
マルチポイント GRE を介したレイヤ 2(L2omGRE)
発行日;2013/08/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

マルチポイント GRE を介したレイヤ 2(L2omGRE)

L2omGRE の前提条件

L2omGRE の制約事項

L2omGRE について

L2omGRE のデフォルト設定

L2omGRE の設定方法

ループバック インターフェイスの設定

mGRE トンネル インターフェイスの設定

VLAN インターフェイスの設定

L2omGRE の設定例

L2omGRE の設定の確認

マルチポイント GRE を介したレイヤ 2(L2omGRE)

「L2omGRE の前提条件」

「L2omGRE の制約事項」

「L2omGRE について」

「L2omGRE のデフォルト設定」

「L2omGRE の設定方法」

「L2omGRE の設定の確認」


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

Cisco IOS Release 15.1SY は、イーサネット インターフェイスだけをサポートしています。Cisco IOS Release 15.1SY は、WAN 機能またはコマンドをサポートしていません。


 

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する


 

L2omGRE の前提条件

なし。

L2omGRE の制約事項

L2omGRE 機能は、VSS モードでサポートされています。

L2omGRE をサポートするために使用される VLAN インターフェイスは、任意のレイヤ 3 機能もサポートするようには設定できません。

現在再学習されていない MAC レイヤ宛先アドレスにアドレス指定されているため VLAN でフラッディングされるレイヤ 2 トラフィックをポリシング(レート制限)するように QoS を設定できます(の「 match l2 miss 」を参照)。

L2omGRE について

L2omGRE 機能では、mGRE トンネルを介してレイヤ 2 ブロードキャスト ドメインのトポロジを拡張することにより、複数の個別ネットワーク サイト間のレイヤ 2 接続を提供します(図 42-1を参照)。

図 42-1 L2omGRE トポロジ

 

L2omGRE 機能は、VLAN インターフェイスを mGRE トンネル インターフェイスに関連付けます。L2omGRE 機能をサポートするように設定された mGRE トンネル インターフェイスは、VLAN のあらゆるタイプのトラフィックに対するレイヤ 2 スイッチング(ブリッジング)を提供するように、レイヤ 2 LAN ポートのように機能します。これにより、トンネルでは、この mGRE トンネルを介してアクセス可能なデバイスにアドレス指定されたトラフィックだけを伝送します、(を参照)。スイッチは mGRE トンネル経由でアクセスできる MAC アドレスを学習し、 show mac address-table コマンドは学習されたアドレスを表示します。

PFC および DFC は、ハードウェアで、ブリッジングおよび mGRE トンネルのカプセル化とカプセル開放をサポートします。

各トンネルは L2omGRE 接続された VLAN を複数伝送できます。トンネル カプセル化には VLAN ID が含まれます。トンネリングされたトラフィックがカプセル開放されると、トラフィックに適した VLAN を選択するために、トンネリング トラフィックに含まれている VLAN ID が使用されます。

L2omGRE のデフォルト設定

なし。

L2omGRE の設定方法

「ループバック インターフェイスの設定」

「mGRE トンネル インターフェイスの設定」

「VLAN インターフェイスの設定」

「L2omGRE の設定例」

ループバック インターフェイスの設定

L2omGRE をサポートするようにループバック インターフェイスを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router> enable

特権 EXEC モードをイネーブルにします。パスワードを入力します(要求された場合)。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface loopback number

ループバック インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

Router(config-if)# ip address address mask

インターフェイスの IP アドレスを設定します。

(注) 他のスイッチのトンネル インターフェイスは、このスイッチのこの IP アドレスを参照します。

ステップ 5

Router(config-if)# end

グローバル コンフィギュレーション モードに戻ります。

mGRE トンネル インターフェイスの設定

mGRE トンネル インターフェイスを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface tunnel number

トンネル インターフェイスを作成します。続いて、インターフェイス コンフィギュレーション モードを開始します。

(注) このスイッチの VLAN インターフェイスは、このトンネル番号を参照します。

ステップ 2

Router(config-if)# ip address address mask

インターフェイスの IP アドレスを設定します。

ステップ 3

Router(config-if)# ip nhrp map tunnel_address loopback_address

L2omGRE トンネル インターフェイスを持つ他のスイッチに設定されているループバック インターフェイスの IP アドレスに対して、IP/NBMA(非ブロードキャスト マルチアクセス)アドレス マッピングを設定します。

他の L2omGRE スイッチに設定されている tunnel_address loopback_address 値を入力します。

他の L2omGRE スイッチごとにこのコマンドを繰り返します。

ステップ 4

Router(config-if)# ip nhrp network-id ID

mGRE トンネル用の Next Hop Resolution Protocol(NHRP)をイネーブルにします。すべての L2omGRE トンネル インターフェイスで同じ ID 値を使用します。

ステップ 5

Router(config-if)# tunnel source loopback number

このトンネル インターフェイスを ループバック インターフェイス と関連付けます。

ステップ 6

Router(config-if)# tunnel mode gre multipoint

トンネル モードとしてマルチポイント GRE を設定します。

ステップ 7

Router(config-if)# end

グローバル コンフィギュレーション モードに戻ります。

VLAN インターフェイスの設定

L2omGRE をサポートするように VLAN インターフェイスを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface vlan number

VLAN インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# no ip address

インターフェイスに IP アドレスが設定されていないことを確認します。

ステップ 3

Router(config-if)# platform xconnect l2gre tunnel number

VLAN インターフェイスを L2omGRE トンネル インターフェイスと関連付けます。

ステップ 4

Router(config-if)# end

グローバル コンフィギュレーション モードに戻ります。

L2omGRE の設定例

L2omGRE コンフィギュレーション コマンドは次のように調整する必要があります。

各スイッチの ip nhrp map コマンドは、他の各スイッチのトンネルおよびループバック IP アドレスを指します。

各スイッチで、 tunnel source loopback コマンドは、そのスイッチに設定されているループバック インターフェイスを指します。

各スイッチで、 platform xconnect l2gre tunnel コマンドは、そのスイッチの L2omGRE トンネル インターフェイスを指します。

スイッチの L2omGRE コンフィギュレーションに関する情報を表示するには、 show platform l2transport gre summary コマンドを入力します。

 

スイッチ 1
スイッチ 2
スイッチ 3

 

interface loopback 1
ip address 10.1.1.1 255.255.255.255
interface tunnel 10
ip address 10.10.10.1 255.255.255.0
no ip redirects
ip nhrp map 10.20.20.2 10.2.2.2
ip nhrp map 10.30.30.3 10.3.3.3
ip nhrp network-id 10
tunnel source loopback 1
tunnel mode gre multipoint
interface vlan 10
no ip address
platform xconnect l2gre tunnel 10

 

interface loopback 1
ip address 10.2.2.2 255.255.255.255
interface tunnel 10
ip address 10.20.20.2 255.255.255.0
no ip redirects
ip nhrp map 10.10.10.1 10.1.1.1
ip nhrp map 10.30.30.3 10.3.3.3
ip nhrp network-id 10
tunnel source loopback 1
tunnel mode gre multipoint
interface vlan 10
no ip address
platform xconnect l2gre tunnel 10

 

interface loopback 1
ip address 10.3.3.3 255.255.255.255
interface tunnel 10
ip address 10.30.30.3 255.255.255.0
no ip redirects
ip nhrp map 10.10.10.1 10.1.1.1
ip nhrp map 10.20.20.2 10.2.2.2
ip nhrp network-id 10
tunnel source loopback1
tunnel mode gre multipoint
interface vlan 10
no ip address
platform xconnect l2gre tunnel 10

L2omGRE の設定の確認

トラフィック統計情報を含む L2omGRE に関する情報を表示するには、 show platform l2transport gre コマンドを入力します。

ヒント Cisco Catalyst 6500 シリーズ スイッチの詳細(設定例およびトラブルシューティング情報を含む)については、次のページに示されるドキュメントを参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

技術マニュアルのアイデア フォーラムに参加する