Catalyst 4500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース IOS XE 3.4.0SG および IOS 15.1(2)SG
WCCP バージョン 2 サービスの設定
WCCP バージョン 2 サービスの設定
発行日;2013/05/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 22MB) | フィードバック

目次

WCCP バージョン 2 サービスの設定

WCCP について

概要

ハードウェア アクセラレーション

WCCP 構成の概要

WCCP の機能

HTTP および非 HTTP サービスのサポート

複数ルータのサポート

MD5 セキュリティ

Web コンテンツ パケットの返送

WCCP に関する制約事項

WCCP の設定

WCCP を使用したサービス グループの設定

Web キャッシュ サービスの指定

WCCP サービス グループのアクセス リストの使用

ルータおよびキャッシュ エンジンのパスワードの設定

WCCP 設定の確認およびモニタリング

WCCP の設定例

一般的な WCCP 設定の実行例

Web キャッシュ サービスの実行例

逆プロキシ サービスの実行例

TCP 無差別サービスの実行例

リダイレクト アクセス リストの実行例

アクセス リストの使用例

スイッチおよびコンテンツ エンジンへのパスワードの設定例

WCCP 設定の確認例

WCCP バージョン 2 サービスの設定

この章では、Catalyst 4500 シリーズ スイッチを設定し、Web Cache Communication Protocol(WCCP)バージョン 2 を使用してコンテンツ エンジンWeb キャッシュ)にトラフィックをリダイレクトする方法を説明します。


) この章の WCCP は WCCP バージョン 2 を表します。WCCP バージョン 1 はサポートされません。


この章で説明する内容は、次のとおりです。

「WCCP について」

「WCCP に関する制約事項」

「WCCP の設定」

「WCCP 設定の確認およびモニタリング」

「WCCP の設定例」


) この章の作業は、コンテンツ エンジンがネットワークに設定されていることを前提にしています。Cisco コンテンツ エンジンおよび WCCP に関連付けられたハードウェアとネットワークの計画に関する情報については、次の場所にある Cisco.com から入手可能な製品マニュアルのリンクを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/configfun/configuration/guide/fcf018_ps1835_TSD_Products_Configuration_Guide_Chapter.html

および

http://www.cisco.com/en/US/tech/tk122/tk717/tsd_technology_support_protocol_home.html


WCCP について

ここでは WCCP について説明します。

「概要」

「ハードウェア アクセラレーション」

「WCCP 構成の概要」

「WCCP の機能」

概要

WCCP はシスコが開発したコンテンツ ルーティング技術で、ネットワーク インフラストラクチャにコンテンツ エンジンを統合することができます。

Cisco IOS WCCP 機能を使用すると、Cisco コンテンツ エンジン(または WCCP を実行する他のコンテンツ エンジン)を使用してネットワークの Web トラフィック パターンをローカライズし、コンテンツ要求をローカルで処理できるようになります。トラフィックのローカライズによって伝送コストが削減され、ダウンロード時間が短縮されます。

WCCP によって、Cisco IOS ルーティング プラットフォームはコンテンツ要求を透過的にリダイレクトできます。HTTP/non-http 要求の透過的なリダイレクトの主な利点は、ユーザが自分のブラウザを Web プロキシを使用するように設定しないですむことです。ユーザはターゲット URL を使用してコンテンツを要求できます。また、ユーザの要求はコンテンツ エンジンに自動的にリダイレクトされます。この場合の「透過的」とは、要求したファイル(Web ページなど)がコンテンツ エンジンから送信されたものであり、指定したサーバから送信されたものではないことがユーザにはわからないという意味です。

要求を受信したコンテンツ エンジンは、自分のローカル コンテンツを使用して要求に応じようとします。要求した情報が存在しない場合、コンテンツ エンジンから独自の要求が元のターゲット サーバに発行され、必要な情報が取得されます。コンテンツ エンジンは、要求された情報を取得すると、要求クライアントに転送し、以降の要求に対応するためにキャッシュします。そのため、ダウンロードのパフォーマンスが大きく向上し、送信コストが大幅に削減されます。

WCCP により、一連のコンテンツ エンジン(コンテンツ エンジン クラスタと呼ぶ)が 1 つまたは複数のルータにコンテンツを提供できます。ネットワーク管理者は、このようなクラスタ処理機能を使用するコンテンツ エンジンを簡単に拡張して、トラフィック負荷が重い場合でも処理することができます。シスコのクラスタ処理技術により、それぞれのコンテンツ メンバの同時動作が可能になり、直線的なスケーラビリティが実現します。クラスタ処理コンテンツ エンジンによって、キャッシュ ソリューションのスケーラビリティ、冗長性、および可用性が大幅に改善されます。最大 32 個のコンテンツ エンジンをクラスタ処理し、目的の容量まで拡張できます。

ハードウェア アクセラレーション

ハードウェア アクセラレーションは Catalyst 4500 シリーズ スイッチではデフォルトでイネーブルです。レイヤ 2 リライト フォワーディングおよびレイヤ 2 のリターン方式はハードウェアでサポートされます。

スイッチがハードウェア(TCAM)またはソフトウェアのリソースを使い果たした場合は、トラフィックはソフトウェアでリダイレクトされます。GRE リターン方式は、ソフトウェアでのみサポートされます。

直接接続されたコンテンツ エンジンを設定して、WCCP レイヤ 2 リダイレクション機能をマスク割り当てテーブルに基づいて(ロード バランシングとともに)使用するようにネゴシエーションできるようにする必要があります。how ip wccp web-cache detail コマンドを実行すると、それぞれのキャッシュで使用されるリダイレクション方式が表示されます。


) マスク割り当てテーブルと WCCP レイヤ 2 リダイレクション機能を使用するように Cisco コンテンツ エンジン リリース 2.2 以降を設定できます。


WCCP 構成の概要

1 つのキャッシュ クラスタにサービスを提供するために複数のルータで WCCP を使用できます。図 70-1 に、複数のルータを使用した構成例を示します。

図 70-1 WCCP を使用した Cisco コンテンツ エンジン ネットワーク構成

 

クラスタ内のコンテンツ エンジンと、同じサービスを実行しているクラスタに接続するルータ内のコンテンツ エンジンのサブセットは、サービス グループと呼ばれます。利用可能なサービスには、TCP およびユーザ データグラム プロトコル(UDP)リダイレクションがあります。

WCCP では、それぞれのコンテンツ エンジンは、サービス グループ内のすべてのルータを認識する必要があります。サービス グループ内のすべてのルータのアドレスを指定するには、次のいずれかの方法を選択する必要があります。

ユニキャスト:グループ内の各ルータの IP アドレス リストを、各コンテンツ エンジンで設定します。この場合、グループ内の各ルータのアドレスは、設定時に各コンテンツ エンジンについて明示的に指定する必要があります。

マルチキャスト:単一のマルチキャスト アドレスを各コンテンツ エンジンで設定します。マルチキャスト アドレス方式の場合、コンテンツ エンジンは、サービス グループのすべてのルータに提供するシングル アドレス通知を送信します。たとえば、コンテンツ エンジンは、パケットを常にマルチキャスト アドレス 224.0.0.100 に送信するように示すことができます。それによって、マルチキャスト パケットは、WCCP を使用してリッスンしているグループ用に設定されたサービス グループ内のすべてのルータに送信されます(詳細については、 ip wccp group-listen インターフェイス コンフィギュレーション コマンドを参照してください)。

マルチキャスト オプションの場合、必要な操作は各コンテンツ エンジンで単一の IP アドレスを指定することだけなので、設定が容易です。またこの方法では、コンテンツ エンジンに毎回異なるアドレスのリストを再設定せずに、サービス グループにダイナミックにルータを追加したり削除したりすることができます。

次の一連のイベントでは、WCCP がどのように機能するかについて説明します。

1. 各 WCCP クライアント(コンテンツ エンジン)は、WCCP サーバ(ルータ)のリストで設定されます。

2. 各コンテンツ エンジンは、そのプレゼンスを「Here I Am」メッセージと、通信を確立したルータのリストを使用して通知します。ルータは、「I see You」メッセージを通じて、サービス グループ内のコンテンツ エンジンのビュー(リスト)で応答します。

3. クラスタのすべてのコンテンツ エンジンのビューが同じであれば、1 つのコンテンツ エンジンが先頭として指定され、トラフィックのリダイレクション時にスイッチで適用する必要があるポリシーを設定します。

WCCP の機能

ここでは、WCCP の次の機能について説明します。

HTTP および非 HTTP サービスのサポート

複数ルータのサポート

MD5 セキュリティ

Web コンテンツ パケットの返送

HTTP および非 HTTP サービスのサポート

WCCP は HTTP トラフィック(TCP ポート 80 のトラフィック)および非 HTTP トラフィック(TCP および UDP)のリダイレクションを可能にします。WCCP は他のポート向けパケットのリダイレクションもサポートします。これには、プロキシ Web キャッシュ処理、File Transfer Protocol(FTP; ファイル転送プロトコル)キャッシング、FTP プロキシ処理、ポートの Web キャッシング(ポート 80 を除く)、および Real Audio、Video、テレフォニー アプリケーション用のパケットが含まれます。

さまざまなタイプのサービスが利用できるようにするために、WCCP には複数の サービス グループ という考え方が導入されています。ダイナミック サービス ID 番号(「98」など)または定義済みサービス キーワード(「web-cache」など)を使用して、WCCP コンフィギュレーション コマンドでサービス情報を指定します。この情報は、サービス グループ メンバーが同じサービスを使用または提供していることを確認するために使用されます。


) Catalyst 4500 シリーズ スイッチは、最大 8 つのサービス グループをサポートします。


ACNS バージョン 5.2 ソフトウェアでサポートされている WCCP バージョン 2 サービスについては、『 Release Notes for Cisco ACNS Software, Release 5.2.3』を参照してください。

サービス グループのコンテンツ エンジンは、プロトコル(TCP または UDP)およびポート(送信元または宛先)によってリダイレクトされるトラフィックを指定します。それぞれのサービス グループにはプライオリティ レベルが割り当てられています。パケットは、サービス グループに対してプライオリティ順に照合され、トラフィック特性に一致する最高のプライオリティのサービス グループによってリダイレクトされます。

複数ルータのサポート

WCCP では、複数のルータをキャッシュ エンジンのクラスタに追加できます。サービス グループで複数のルータを使用すると、冗長化、インターフェイス集約、およびリダイレクション負荷の分散が可能になります。

MD5 セキュリティ

WCCP には任意の認証機能があり、パスワードおよび HMAC MD5 標準を使用して、どのルータおよびコンテンツ エンジンがサービス グループの一部になるかを制御できます。共有秘密キー MD5 ワンタイム認証( ip wccp [ password [ 0-7 ] password ] グローバル コンフィギュレーション コマンドを使用して設定)では、メッセージを代行受信、検査、およびリプレイから保護します。

Web コンテンツ パケットの返送

エラーや過負荷のために、コンテンツ エンジンがキャッシュした要求オブジェクトを提供できない場合、コンテンツ エンジンは本来の宛先であるサーバに転送するように要求をルータに返します。WCCP は、どの要求がサービスを実行されずにコンテンツ エンジンから返されたかを確認します。ルータは、この情報を使用して、要求を本来の宛先サーバに転送します(コンテンツ クラスタに要求を再送信しません)。これにより、エラー処理はクライアントに意識されません。

コンテンツ エンジンがパケットを拒否し、パケット返送機能を開始する場合、一般的に次のような理由があります。

コンテンツ エンジンが過負荷でパケットを処理する余裕がない。

コンテンツ エンジンに一定のフィルタリングがあり、パケットのキャッシングは逆効果である(IP 認証がオンの場合など)。

WCCP に関する制約事項

WCCP には次のような制約事項があります。

WCCP は、IPv4 ネットワークだけで動作します。

マルチキャスト クラスタにサービスを提供するルータには、存続可能時間(TTL)値を 15 以下に設定する必要があります。

クラスタにサービスを提供するレイヤ 3 スイッチの存続可能時間(TTL)値は、15 秒以下でなければなりません。

ほとんどの場合、WCCP プロトコル メッセージは IP マルチキャストのため、メンバーは関係のないメッセージや重複メッセージを受信することがあります。適切なフィルタリングを実行する必要があります。

1 つのサービス グループは最大 32 のコンテンツ エンジンと 32 のルータで構成できます。

クラスタのすべてのコンテンツ エンジンは、クラスタにサービスを提供するすべてのルータと通信できるように設定する必要があります。

最大 8 個のアクティブ サービス グループがスイッチでサポートされます。最大 8 個のサービス グループが同じクライアント インターフェイスで同時に設定できます。

レイヤ 2 書き換え転送方式はハードウェアでサポートされます。GRE カプセル化転送方式はサポートされません。

GRE リターン方式はソフトウェアでサポートされます。レイヤ 2 リターン方式はハードウェアでサポートされ、推奨されます。

コンテンツ エンジンにレイヤ 3 を直接接続する必要があります。1 つまたは複数ホップ離れたレイヤ 3 接続はサポートされません。

入力および出力リダイレクション設定は、インターフェイスに接続するコンテンツ エンジンではサポートされません。

WCCP バージョン 2 規格では、最大 256 個のマスクをサポートします。ただし、Catalyst 4500 シリーズ スイッチは、単一のマスクへのマスク割り当てテーブルだけをサポートします。

有効なマルチキャスト アドレスの範囲は、224.0.0.0 ~ 239.255.255.255 です。

WCCP の設定

次の設定作業では、ネットワークに含めるコンテンツ エンジンがすでにインストールおよび設定されていることを前提としています。クラスタにコンテンツ エンジンを設定してから、ルータで WCCP 機能を設定する必要があります。コンテンツ エンジンの構成およびセットアップについては、『 Cisco Content Engine User Guide 』を参照してください。

キャッシュ エンジンに接続されているルータ インターフェイスに IP を設定する必要があります。ルータの設定作業の例は、この項で説明します。コマンド構文の詳細については、『 Cisco IOS Configuration Fundamentals Command Reference , Cisco IOS Release 12.3』を参照してください。

次の項では、WCCP の設定方法について説明します。

「WCCP を使用したサービス グループの設定」(必須)

「WCCP サービス グループのアクセス リストの使用」(任意)

「ルータおよびキャッシュ エンジンのパスワードの設定」(任意)

WCCP を使用したサービス グループの設定

WCCP は論理リダイレクション サービスに基づいてサービス グループを使用します。標準サービスはコンテンツ エンジンで、TCP ポート 80(HTTP)トラフィックを代行受信してコンテンツ エンジンにリダイレクトします。このサービスは、Web キャッシュ サービスの特徴はルータとコンテンツ エンジンの両方から認識されているため、 既知のサービス と呼ばれます。サービス ID 以外の広く知られているサービスの記述は不要です(コマンドライン インターフェイス(CLI)がコマンド構文に web-cache キーワードを提供します)。

ACNS バージョン 5.2 ソフトウェアでサポートされている WCCP サービスについては、『Release Notes for Cisco ACNS Software, Release 5.2.3』を参照してください。

Web キャッシュ サービス以外にも、最大 7 つのダイナミック サービスをスイッチで同時に実行できます。


) スイッチでは同時に複数のサービスが実行できます。また、ルータおよびコンテンツ エンジンは、同時に複数のサービス グループの一部になることができます。


ダイナミック サービスは、コンテンツ エンジンによって定義されます。コンテンツ エンジンは、代行受信するプロトコルまたはポート、およびトラフィックの分散方法をルータに指示します。ダイナミック サービス グループのトラフィックの特徴に関する情報は、ルータ自体にはありません。この情報は、グループに参加する最初のコンテンツ エンジンから提供されるためです。ダイナミック サービスでは、1 つのプロトコル(TCP または UDP)に最大 8 つのポートを指定できます。

たとえば、Cisco コンテンツ エンジンではダイナミック サービス 99 を使用して、リバース プロキシ サービスを指定します。ただし、このサービス番号は、他のコンテンツ エンジンでは他のサービスに使用されることがあります。次の設定情報は、Cisco ルータで汎用サービスをイネーブルにするためのものです。コンテンツ エンジンにサービスを設定する場合の詳細については、コンテンツ エンジンのマニュアルを参照してください。

Catalyst 4500 シリーズ スイッチでサービスをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# ip wccp { web-cache | service-number } [ group-address groupaddress ] [ redirect-list access-list ] [ group-list access-list ] [ password password ]

ダイナミック サービスをスイッチでイネーブルにするように指定し、サービス グループで使用される IP マルチキャスト アドレス(任意)、リダイレクト対象のトラフィックを制御するリダイレクト アクセス リスト(任意)、コンテンツ エンジンのメンバーシップに使用するグループ リスト(任意)を指定し、MD5 認証を使用するかどうか(任意)を指定し、WCCP サービスをイネーブルにします。

ステップ 2

Switch(config-if)# [no] ip wccp check services all

サービスがパケットに一致し、サービスにリダイレクト アクセス リストが設定されている場合、IP パケットはそのアクセス リストに対してチェックされます。アクセス リストによってパケットが拒否される場合、ip wccp check services all コマンドを設定していない限り、低いプライオリティのサービスにパケットは渡されません。ip wccp check services all コマンドを設定すると、インターフェイスに設定されている残りの低いプライオリティのサービスに対して、引き続きパケットのマッチングが試行されます。

ステップ 3

Switch(config)# interface type number

設定するクライアント インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

Switch(config-if)# ip wccp { web-cache | service-number } redirect { in | out}

入力の WCCP リダイレクションまたは指定したクライアント インターフェイスの出力トラフィックをイネーブルにします。

ステップ 5

Switch(config)# interface type number

出力リダイレクションの排除用に設定するインターフェイスを指定します。

ステップ 6

Switch(config-if)# ip wccp redirect exclude in

このインターフェイスで受信されたパケットが、出力リダイレクションから除外されることを指定します。これは、レイヤ 2 のリターン方式がコンテンツ エンジンで使用され、出力リダイレクションがサーバ インターフェイスに設定されている場合、コンテンツ エンジン インターフェイスに設定される必要があります。

ステップ 7

Switch(config)# interface type number

(マルチキャスト機能を実行する場合にだけ必要)マルチキャストを受信するように設定するコンテンツ エンジン インターフェイスを指定します。

ステップ 8

Switch(config-if)# ip wccp { web-cache | service-number } group-listen

(マルチキャスト機能を実行する場合にだけ必要)ステップ 4 で指定したインターフェイスで IP マルチキャスト パケット(コンテンツ エンジンから送信される WCCP プロトコル パケット)の受信をイネーブルにします。

Web キャッシュ サービスの指定

Web キャッシュ サービスおよび入力リダイレクションを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# ip wccp web-cache

スイッチで Web キャッシュ サービスをイネーブルにします。

ステップ 2

Switch(config)# interface type number

Web キャッシュ サービスを実行するクライアント インターフェイス番号を指定し、コンフィギュレーション モードを開始します。

ステップ 3

Switch(config-if)# ip wccp web-cache redirect in

ステップ 2 で指定したクライアント インターフェイスを使用して、コンテンツ エンジンにリダイレクトできるパケットかどうかのチェックをイネーブルにします。

Web キャッシュ サービスおよび出力リダイレクトを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# ip wccp web-cache

スイッチで Web キャッシュ サービスをイネーブルにします。

ステップ 2

Switch(config)# interface type number

Web キャッシュ サービスのサーバ インターフェイス番号を対象として、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Switch(config-if)# ip wccp web-cache redirect out

ステップ 2 で指定したクライアント インターフェイスを使用して、コンテンツ エンジンにリダイレクトできるパケットかどうかのチェックをイネーブルにします。

ステップ 4

Switch(config)# interface type number

コンテンツ エンジン インターフェイス番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

Switch(config-if)# ip wccp web-cache redirect in

このインターフェイスで受信されたパケットが、出力リダイレクションから除外されることを指定します。これは L2 リターン方式経由でコンテンツ エンジンによって返されるパケットまたはコンテンツ エンジンで生成されたパケットが、コンテンツ エンジンにリダイレクトされることを防ぎます。

WCCP サービス グループのアクセス リストの使用

Catalyst 4500 シリーズ スイッチは、アクセス リストを使用して、サービス グループに加入するコンテンツ エンジンを制限できます。

コンテンツ エンジンを制限するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# access-list access-list permit ip host host-address [ destination-address | destination-host | any ]

コンテンツ エンジンのユニキャスト アドレスに基づいたアクセス リストを作成します。

ステップ 2

Switch(config)# ip wccp web-cache group-list access-list

スイッチに、どのコンテンツ エンジンのサービス グループへの加入が許可または不許可であるかを示します。

ルータおよびキャッシュ エンジンのパスワードの設定

MD5 パスワード セキュリティでは、サービス グループに加入するコンテンツ エンジンおよび Catalyst 4500 シリーズ スイッチごとにサービス グループ パスワードを設定する必要があります。パスワードは最大 7 文字にできます。サービス グループのコンテンツ エンジンまたは Catalyst 4500 シリーズ スイッチは、WCCP メッセージ ヘッダーを確認した直後に、受信した WCCP パケットのセキュリティ コンポーネントを認証します。認証に失敗したパケットは廃棄されます。

WCCP 通信で Catalyst 4500 シリーズ スイッチが使用する MD5 パスワードを設定するには、次の作業を行います。

 

コマンド
目的

Switch(config)# ip wccp web-cache password password

Catalyst 4500 シリーズ スイッチに MD5 パスワードを設定します。

WCCP 設定の確認およびモニタリング

WCCP の設定を確認およびモニタリングするには、EXEC モードで次の作業を実行します。

 

コマンド
目的

Switch# show ip wccp [web-cache | service-number ]

WCCP に関連するグローバル情報を表示します。この情報には、実行中のプロトコルのバージョン、ルータ サービス グループのコンテンツ エンジンの数、ルータに接続可能なコンテンツ エンジン グループ、使用中のアクセス リストが含まれます。

Switch# show ip wccp { web-cache | service-number } detail

ルータが検出した、サービス グループのコンテンツ エンジンの情報を問い合わせます。Web キャッシュ サービスまたは指定のダイナミック サービスのいずれかの情報が表示されます。

Switch# show ip interface

ip wccp リダイレクション コマンドがクライアント インターフェイスで設定されているかどうかを表示します。たとえば、「Web Cache Redirect is enabled / disabled」などと表示されます。

Switch# show ip wccp { web-cache | service-number } view

特定のサービス グループで検出された装置、トラブルが発生しているコンテンツ エンジン、現在のスイッチに接続されているその他のすべてのスイッチで認識可能なコンテンツ エンジンを表示します。

view キーワードは、サービス グループのアドレス一覧を示します。Web キャッシュ サービスまたは指定のダイナミック サービスのいずれかの情報が表示されます。

詳細なトラブルシューティング情報を表示するには、
show ip wccp { web-cache | service number } service コマンドを使用します。

WCCP の設定例

ここでは、次の設定例を示します。

「一般的な WCCP 設定の実行例」

「Web キャッシュ サービスの実行例」

「逆プロキシ サービスの実行例」

「TCP 無差別サービスの実行例」

「リダイレクト アクセス リストの実行例」

「アクセス リストの使用例」

「スイッチおよびコンテンツ エンジンへのパスワードの設定例」

「WCCP 設定の確認例」

一般的な WCCP 設定の実行例

次に、一般的な WCCP 設定セッションの例を示します。VLAN 20 はクライアント インターフェイスです。VLAN 50 はコンテンツ エンジン インターフェイスです。

Switch# configure terminal
Switch(config)# ip wccp web-cache group-address 224.1.1.100 password alaska1
Switch(config)# interface vlan 20
Switch(config-if)# ip wccp web-cache redirect in
Switch(config)# interface vlan 50
Switch(config-if)# ip wccp web cache group-listen

Web キャッシュ サービスの実行例

次に、入力リダイレクションを使用した Web キャッシュ サービス設定セッションの例を示します。

Switch# configure terminal
Switch(config)# ip wccp web-cache
Switch(config)# interface vlan 20
Switch(config-if)# ip wccp web-cache redirect in
Switch(config-if)# ^Z
Switch# copy running-config startup-config
Switch# show ip interface vlan 20 | include WCCP Redirect
WCCP Redirect inbound is enabled
WCCP Redirect exclude is disabled

逆プロキシ サービスの実行例

次に、リバース プロキシ サービスの実行にダイナミック サービス 99 を使用する Cisco コンテンツ エンジンを使用してサービス グループを設定する例を示します。次に、VLAN 40 がサーバ インターフェイスを反映し、VLAN 50 がコンテンツ エンジン インターフェイスを反映する場所での出力リダイレクションの設定方法の例を示します。

Switch# configure terminal
Switch(config)# ip wccp 99
Switch(config)# interface vlan 40
Switch(config-if)# ip wccp 99 redirect in
Switch(config# interface vlan 50
Switch(config-if)# ip wccp redirect exclude in

TCP 無差別サービスの実行例

VLAN 40 がサーバ インターフェイスを表し、VLAN 50 がコンテンツ エンジン インターフェイスを表す場所での TCP 無差別サービスの設定方法の例を示します。

Switch# configure terminal
Switch(config)# ip wccp 61
Switch(config)# ip wccp 62
Switch(config)# interface vlan 30
Switch(config-if)# ip wccp 61 redirect in
Switch(config)# interface vlan 40
Switch(config-if)# ip wccp 62 redirect in
Switch(config)# interface vlan 50
Switch(config-if)# ip wccp redirect exclude in

リダイレクト アクセス リストの実行例

リダイレクト アクセス リストにより、リダイレクトされるトラフィックを制御できるようになります。次に、サブネット 10.1.1.0 からのトラフィックだけをリダイレクトする方法の例を示します。

Switch(config)# ip access-list extended 100
Switch(config-ext-nacl)# permit ip 10.1.1.0 255.255.255.0 any
Switch(config-ext-nacl)# exit
Switch(config)# ip wccp web-cache redirect-list 100
Switch(config)# interface vlan 40
Switch(config-if)# ip wccp web-cache redirect in
Switch(config)# interface vlan 50
Switch(config-if)# ip wccp redirect exclude in

アクセス リストの使用例

セキュリティを向上させるには、現在のスイッチで登録するコンテンツ エンジンのものとして有効な IP アドレスを、標準のアクセス リストを使用して Catalyst 4500 シリーズ スイッチに通知します。次に、サンプル ホストのアクセス リスト番号が 10 である標準的なアクセス リストの設定セッション例を示します。

router(config)# access-list 10 permit host 11.1.1.1
router(config)# access-list 10 permit host 11.1.1.2
router(config)# access-list 10 permit host 11.1.1.3
router(config)# ip wccp web-cache group-list 10

スイッチおよびコンテンツ エンジンへのパスワードの設定例

次に、WCCP パスワード設定セッションの例を示します。パスワードは alaska1 です。

Switch# configure terminal
router(config)# ip wccp web-cache password alaska1

WCCP 設定の確認例

設定の変更を確認するには、 more system:running-config EXEC コマンドを使用します。次に、Catalyst 4500 シリーズ スイッチの Web キャッシュ サービスとダイナミック サービス 99 がどちらもイネーブルである場合の例を示します。

WCCP ユニキャスト モード

Switch# more system:running-config
 
Building configuration...
Current configuration:
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
! !
enable secret 5 $1$nSVy$faliJsVQXVPW.KuCxZNTh1
enable password alabama1
!
ip subnet-zero
ip wccp web-cache
ip wccp 99
!
interface Vlan200
ip address 10.3.1.2 255.255.255.0
ip wccp web-cache redirect in
 
interface Vlan300
ip address 10.4.1.1 255.255.255.0
ip wccp redirect exclude in
 
interface Vlan400
ip address 10.5.1 255.255.255.0
ip wccp 99 redirect out
 
 
 
ip default-gateway 10.3.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.1.1
no ip http server
!
!

WCCP マルチキャスト モード

ip wccp web-cache group-address 224.1.1.1
ip wccp 60 group-address 224.1.1.1
ip wccp 90
ip wccp 91
 
 
interface Vlan70
ip address 70.1.1.1 255.255.255.0
ip wccp web-cache group-listen
ip wccp 60 group-listen
ip wccp redirect exclude in