Catalyst 4500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース IOS XE 3.4.0SG および IOS 15.1(2)SG
IP マルチキャストの設定
IP マルチキャストの設定
発行日;2013/05/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 22MB) | フィードバック

目次

IP マルチキャストの設定

IP マルチキャストについて

IP マルチキャスト プロトコル

インターネット グループ管理プロトコル

プロトコル独立マルチキャスト

ランデブー ポイント(RP)

IGMP スヌーピング

Catalyst 4500 シリーズ スイッチ上での IP マルチキャスト実装

IP マルチキャストの制限

CEF、MFIB、およびレイヤ 2 フォワーディング

IP マルチキャスト テーブル

ハードウェアおよびソフトウェアによる転送

非 RPF トラフィック

マルチキャスト高速ドロップ

マルチキャスト転送情報ベース

S/M,224/4

マルチキャスト HA

IP マルチキャスト ルーティングの設定

IP マルチキャスト ルーティングのデフォルト設定

IP マルチキャスト ルーティングのイネーブル化

インターフェイス上での PIM のイネーブル化

デンス モードのイネーブル化

スパース モードのイネーブル化

スパース/デンス モードのイネーブル化

双方向モードのイネーブル化

PIM-SSM マッピングのイネーブル化

RP の設定

Auto-RP の設定

単一スタティック RP の設定

IP マルチキャスト トラフィックのロード分割

IP マルチキャスト ルーティングのモニタリングおよびメンテナンス

システムおよびネットワーク統計情報の表示

マルチキャスト ルーティング テーブルの表示

IP MFIB の表示

双方向 PIM 情報の表示

PIM 統計情報の表示

テーブルおよびデータベースの削除

設定例

PIM デンス モードの例

PIM スパース モードの例

双方向 PIM モードの例

単一スタティック RP を使用するスパース モードの例

Auto-RP を使用するスパース モードの例

IP マルチキャストの設定

この章では、Catalyst 4500 シリーズ スイッチ上での IP マルチキャスト ルーティングについて説明します。IP マルチキャスト ルーティングの設定手順および設定例も示します。


) IP マルチキャストの詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/products/ps6552/products_ios_technology_home.html



) この章で使用するスイッチ コマンドの構文および使用方法の詳細については、次の URL で『Cisco Catalyst 4500 Series Switch Command Reference』と関連資料を参照してください。

http://www.cisco.com/en/US/products/hw/switches/ps4324/index.html

『Catalyst 4500 Series Switch Command Reference』に掲載されていないコマンドについては、より詳細な Cisco IOS ライブラリを参照してください。次の URL で『Cisco IOS Command Referenceと関連資料を参照してください。

http://www.cisco.com/en/US/products/ps6350/index.html


この章の主な内容は、次のとおりです。

「IP マルチキャストについて」

「IP マルチキャスト ルーティングの設定」

「IP マルチキャスト ルーティングのモニタリングおよびメンテナンス」

「設定例」

IP マルチキャストについて


) マルチキャスト グループに対する伝送速度の制御はサポートされていません。


IP 通信の一端である IP ユニキャストでは、送信元 IP ホストが特定の宛先 IP ホストにパケットを送信します。この場合、IP パケットに指定される宛先アドレスは、IP ネットワーク上で一意に識別される単一ホストのアドレスです。これらの IP パケットは、ネットワーク上の送信元ホストから、一連のルータによって宛先ホストに転送されます。送信元と宛先間のパス上の各ポイントでは、ルータがユニキャスト ルーティング テーブルを使用して、パケットの IP 宛先アドレスに基づきユニキャスト転送先を決定します。

IP 通信で IP ユニキャストの対極にある IP ブロードキャストでは、送信元ホストはネットワーク セグメント上のすべてのホストにパケットを送信します。IP ブロードキャスト パケットの宛先アドレスでは、宛先 IP アドレスのホスト部分がすべて 1 に設定され、ネットワーク部分がサブネットのアドレスに設定されています。一連の IP ホスト(ルータを含む)は、宛先アドレスとして IP ブロードキャスト アドレスを指定されたパケットが、サブネット上のすべての IP ホスト向けであることを認識しています。特に設定しない限り、ルータは IP ブロードキャスト パケットを転送しないので、一般的に IP ブロードキャスト通信はローカル サブネットに限定されます。

IP マルチキャストは、IP ユニキャスト通信と IP ブロードキャスト通信の中間に位置します。IP マルチキャスト通信によって、ホストは IP ネットワーク上の任意の場所にあるホストの グループ に IP パケットを送信します。IP マルチキャスト通信では、特定のグループに情報を送信するために、IP マルチキャスト グループ アドレス という特殊な形式の IP 宛先アドレスを使用します。IP マルチキャスト グループ アドレスは、パケットの IP 宛先アドレス フィールドに指定されます。

IP 情報をマルチキャストするには、レイヤ 3 スイッチおよびルータが、IP マルチキャスト グループの メンバ に接続するすべての出力インターフェイスに、着信 IP パケットを転送する必要があります。Catalyst 4500 シリーズ スイッチ上のマルチキャスト プロセスでは、Integrated Switching Engine でパケットが複製されて適切な出力インターフェイスに転送され、マルチキャスト グループの各メンバに送信されます。

IP マルチキャストはビデオ会議と同じものとして考えられる傾向があります。ネットワークに初めて導入する IP マルチキャスト アプリケーションは、多くの場合ビデオ会議ですが、ビデオは企業のビジネス モデルに付加価値をもたらす、さまざまな IP マルチキャスト アプリケーションの 1 つに過ぎません。生産性の向上につながるこの他の IP マルチキャスト アプリケーションとしては、マルチメディア会議、データ複製、リアルタイム データ マルチキャスト、シミュレーション アプリケーションなどがあります。

ここでは、次の内容について説明します。

「IP マルチキャスト プロトコル」

「Catalyst 4500 シリーズ スイッチ上での IP マルチキャスト実装」

「IP マルチキャスト ルーティングの設定」

IP マルチキャスト プロトコル

Catalyst 4500 シリーズ スイッチでは、主に次のプロトコルを使用して IP マルチキャスト ルーティングを実行します。

インターネット グループ管理プロトコル(IGMP)

Protocol Independent Multicast(PIM)

IGMP スヌーピングおよび Cisco Group Management Protocol

図 36-1 に、これらのプロトコルが動作する IP マルチキャスト環境内の位置を示します。

図 36-1 IP マルチキャスト ルーティング プロトコル

 

インターネット グループ管理プロトコル

IP マルチキャスト ホストは IGMP メッセージを使用して、ローカルのレイヤ 3 スイッチまたはルータに要求を送信し、特定のマルチキャスト グループに加入して、マルチキャスト トラフィックの受信を開始します。IGMPv2 の一部の拡張機能を使用すると、IP ホストはレイヤ 3 スイッチまたはルータに対し、IP マルチキャスト グループを脱退してマルチキャスト グループ トラフィックを受信しないように求める要求も送信します。

レイヤ 3 スイッチまたはルータは、IGMP によって得た情報を使用して、マルチキャスト グループ メンバーシップのリストをインターフェイス単位で維持します。インターフェイス上で少なくとも 1 つのホストが、マルチキャスト グループ トラフィックを受信するための IGMP 要求を送信している限り、そのインターフェイスのマルチキャスト グループ メンバーシップはアクティブです。

プロトコル独立マルチキャスト

PIM が プロトコルに依存しない 理由は、使用されている任意のユニキャスト ルーティング プロトコルを利用してルーティング テーブルへの書き込みを行い(Enhanced Interior Gateway Routing Protocol(EIGRP)、Open Shortest Path First(OSPF)、Border Gateway Protocol(BGP)、およびスタティック ルートを含む)、IP マルチキャストをサポートするからです。PIM はさらに、完全に独立したマルチキャスト ルーティング テーブルを作成する代わりに、ユニキャスト ルーティング テーブルを使用して Reverse Path Forwarding(RPF)チェック機能を実行します。PIM は、他のルーティング プロトコルが行うような、ルータ間でのマルチキャスト ルーティング アップデートの送受信は行いません。

PIM デンス モード(PIM-DM)

PIM Dense Mode(PIM-DM; PIM デンス モード)は、 プッシュ モデルを使用してネットワークのすべての部分にマルチキャスト トラフィックをフラッディングさせます。PIM-DM は、LAN TV や企業情報または財務情報ブロードキャストなど、大部分の LAN でマルチキャストの受信が必要とされるネットワークでの使用を目的としています。これは、ネットワーク上のすべてのサブネットにアクティブな受信者が存在する場合、効率的な配信メカニズムになります。

PIM デンス モードの詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/ios-xml/ios/ipmulti_optim/configuration/12-2sx/imc_pim_dense_rfrsh.html

PIM スパース モード

PIM スパース モード(PIM-SM)は、 プル モデルを使用してマルチキャスト トラフィックを配信します。明示的にデータを要求した、アクティブな受信者のいるネットワークだけにトラフィックが転送されます。PIM-SM は、デスクトップ ビデオ会議や企業コンピューティングなど、少数の受信者がそれぞれ異なるマルチキャストを一般に同時使用するネットワークでの使用を目的としています。

双方向 PIM モード

双方向 PIM(Bidir-PIM)モードでは、トラフィックは、グループのランデブー ポイント(RP)をルートとする双方向共有ツリーに沿ってのみルーティングされます。RP の IP アドレスはキーとして機能し、その IP アドレスをルートとするループフリーのスパニングツリー トポロジをすべてのルータが確立できるようにします。

Bidir-PIM は、個々の PIM ドメイン内の多数対多数の用途での使用を目的としています。双方向 PIM モードのマルチキャスト グループは、ソースの数によるオーバーヘッドを引き起こすことなく、任意の数のソースに拡張できます。

双方向モードの詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6552/ps6592/prod_white_paper0900aecd80310db2.pdf.

ランデブー ポイント(RP)

また、PIM をスパース モードで動作するよう構成する場合は、1 つまたは複数のルータを Rendezvous Point(RP; ランデブー ポイント)とするよう選択する必要があります。マルチキャスト グループへの送信者は、RP を使用してその存在を通知します。マルチキャスト パケットの受信者は、RP を使用して新しい送信者について学習します。1 つのマルチキャスト グループのパケットが 1 つまたは複数の RP を使用できるように Cisco IOS ソフトウェアを構成できます。

RP アドレスは、パケットをグループに送信するホストの代わりに PIM Register メッセージを送信するためにファースト ホップ ルータによって使用されます。また、ラストホップ ルータでも、PIM join および prune メッセージを RP に送信してグループ メンバーシップについて通知するために使用されます。すべてのルータ(RP ルータを含む)で RP アドレスを設定する必要があります。

1 つの PIM ルータを複数のグループの RP にすることができます。同じグループの PIM ドメイン内で一度に使用できる RP アドレスは 1 つだけです。アクセス リストで指定されている条件は、(異なるグループが異なる RP を持つことが可能なため)ルータがいずれのグループの RP であるかを決定します。

IGMP スヌーピング

IGMP スヌーピングは、レイヤ 2 スイッチング環境でのマルチキャストに使用します。IGMP スヌーピングを使用する場合、レイヤ 3 スイッチまたはルータは、ホストとルータ間で転送される IGMP パケットのレイヤ 3 情報を検証します。スイッチが特定のマルチキャスト グループのホストから IGMP Host Report を受信すると、スイッチはそのホストのポート番号を対応するマルチキャスト テーブル エントリに追加します。スイッチがホストから IGMP Leave Group メッセージを受信すると、スイッチはテーブル エントリからそのホストのポートを削除します。

IGMP 制御メッセージはマルチキャスト パケットとして送信されるので、レイヤ 2 ヘッダーだけが検証される場合は、マルチキャスト データと区別できません。IGMP スヌーピングが稼働しているスイッチは、すべてのマルチキャスト データ パケットについて、関連する IGMP 制御情報が含まれているかどうかを調べます。低速の CPU を搭載したローエンドのスイッチに IGMP スヌーピングを実装すると、データを高速で送信する場合、パフォーマンスに重大な影響が出る可能性があります。Catalyst 4500 シリーズ スイッチでは、IGMP スヌーピングがフォワーディング ASIC で実装されているので、転送速度に影響が出ることはありません。

Catalyst 4500 シリーズ スイッチ上での IP マルチキャスト実装

Catalyst 4500 シリーズ スイッチは、レイヤ 2 でイーサネット ブリッジング、レイヤ 3 で IP ルーティングを行う ASIC ベースのIntegrated Switching Engine をサポートしています。この ASIC はパケット転送専用に設計されているので、Access Control List(ACL; アクセス コントロール リスト)および QoS(Quality of Service)をイネーブルにした状態で、Integrated Switching Engineハードウェアにより非常に高いパフォーマンスを実現します。ハードウェアによるワイヤスピードでの転送は、例外パケットを処理するように設計された CPU サブシステム ソフトウェアよりもきわめて高速となります。

Integrated Switching Engineハードウェアは、VLAN 間ルーティング用のインターフェイスおよびレイヤ 2 ブリッジング用のスイッチ ポートをサポートしています。また、ホスト、スイッチ、またはルータとの接続を設定できる物理層 3 インターフェイスともなります。

図 36-2 に、Integrated Switching Engine ハードウェアでのレイヤ 2 およびレイヤ 3 フォワーディングの概念図を示します。

図 36-2 ハードウェアでのレイヤ 2 およびレイヤ 3 フォワーディングの概念図

 

ここでは、次の内容について説明します。

「IP マルチキャストの制限」

「CEF、MFIB、およびレイヤ 2 フォワーディング」

「IP マルチキャスト テーブル」

「ハードウェアおよびソフトウェアによる転送」

「非 RPF トラフィック」

「マルチキャスト高速ドロップ」

「マルチキャスト転送情報ベース」

「S/M,224/4」

「マルチキャスト HA」

IP マルチキャストの制限

IP マルチキャストの制限は、次のとおりです。

リリース IOS XE 3.3.0SG および IOS 15.1(1)SG 以降では、次の 7 つの RP の制約事項が削除されました。

IPv4 双方向(Bidir)PIM は Catalyst 4900M、Catalyst 4948E、Supervisor Engine 6-E、Supervisor Engine 6L-E、Supervisor Engine 7-E、および Supervisor Engine 7L-E でサポートされます。IPv6 Bidir PIM はサポートされません。

一部のマルチキャスト グループでは、8K を超える mroute がシステムにインストールされると、ネットワークで HA システムのスイッチオーバー時に、高いトラフィック損失が発生する可能性があります。これは新しいエントリが更新される前に古いマルチキャスト転送エントリがフラッシュされることが原因です。ルートの数が増えると、MFIB でエントリが更新されるのに必要な時間がより多くなります。このシナリオのトラフィック損失を低減するには、デフォルト(30 秒)を超える値にマルチキャスト ルート フラッシュ タイマーを(ip multicast redundancy routeflush maxtime コマンドを使用して)大きくする必要があります。

CEF、MFIB、およびレイヤ 2 フォワーディング

Catalyst 4500 シリーズ スイッチに実装された IP マルチキャストは、集中型シスコ エクスプレス フォワーディング(CEF)の拡張機能です。CEF は、ユニキャスト ルーティング テーブル(BGP、OSPF、EIGRP などのユニキャスト ルーティング プロトコルによって作成される)から情報を抽出し、この情報をハードウェアの転送情報ベース(FIB)にロードします。FIB のユニキャスト ルートを使用すると、上位層のルーティング テーブルでルートが変更された場合でも、ハードウェア ルーティング ステートの 1 つのルートを変更するだけです。ハードウェアでユニキャスト パケットを転送するために、Integrated Switching Engine は Ternary CAM(TCAM)から送信元および宛先ルートを検索し、ハードウェア FIB から隣接インデックスを取り出して、ハードウェア ネイバー テーブル関係からレイヤ 2 リライト情報およびネクストホップ アドレスを取得します。

Multicast Forwarding Information Base(MFIB; マルチキャスト転送情報ベース)サブシステムは、ユニキャスト CEF のマルチキャスト版です。この MFIB サブシステムは、PIM および IGMP によって作成されるマルチキャスト ルートを抽出し、ハードウェア転送のためのプロトコル独立フォーマットにします。MFIB サブシステムは、プロトコル固有の情報を削除し、必要なフォワーディング情報だけを残します。MFIB テーブルの各エントリは、(S,G)または(*,G)ルート、入力 RPF VLAN、およびレイヤ 3 出力インターフェイスのリストで構成されます。MFIB サブシステムは、プラットフォーム依存の管理ソフトウェアと連携して、このマルチキャスト ルーティング情報をハードウェア FIB およびハードウェア Replica Expansion Table(RET)にロードします。

Catalyst 4500 シリーズ スイッチは、レイヤ 3 ルーティングとレイヤ 2 ブリッジングを同時に実行します。いずれの VLAN インターフェイスにも複数のレイヤ 2 スイッチ ポートを設定できます。

図 36-3 に、Catalyst 4500 シリーズ スイッチがユニキャスト ルーティング、マルチキャスト ルーティング、およびレイヤ 2 ブリッジング情報を組み合わせ、ハードウェアで転送を実行する機能の概要を示します。

図 36-3 ハードウェアでの CEF、MFIB、およびレイヤ 2 転送情報の組み合わせ

 

MFIB ルートは、CEF ユニキャスト ルートと同様にレイヤ 3 であるため、該当するレイヤ 2 情報と結合する必要があります。MFIB ルートの例を示します。

(*,224.1.2.3)
RPF interface is Vlan3
Output Interfaces are:
Vlan 1
Vlan 2
 

ルート(*,224.1.2.3)がハードウェア FIB テーブルにロードされ、出力インターフェイスのリストが MET にロードされます。出力インターフェイスのリストへのポインタ、MET インデックス、および RPF インターフェイスも、(*,224.1.2.3)ルートとともにハードウェア FIB にロードされます。ハードウェアにこの情報をロードすることで、レイヤ 2 情報との結合を開始できるようになります。VLAN 1 上の出力インターフェイスについて、Integrated Switching Engine は VLAN 1 上でスパニングツリー フォワーディング ステートにあるすべてのスイッチ ポートにパケットを送信する必要があります。同じプロセスが VLAN 2 に適用されます。VLAN 2 内のスイッチ ポートのセットを決定するために、レイヤ 2 転送テーブルが使用されます。

ハードウェアがパケットをルーティングする場合、すべての出力インターフェイスのすべてのスイッチ ポートにパケットを送信するだけでなく、ハードウェアは入力 VLAN の(パケットが到着したスイッチ ポートを除く)すべてのスイッチ ポートにも、パケットを送信します。たとえば、VLAN 3 に 2 つのスイッチ ポート Gig 3/1 および Gig 3/2 があると仮定します。Gig 3/1 上のホストがマルチキャスト パケットを送信すると、Gig 3/2 上のホストもそのパケットを受信しなければならない場合があります。Gig 3/2 上のホストにマルチキャスト パケットを送信するには、MET にロードされるポート セットに入力 VLAN のすべてのスイッチ ポートを追加する必要があります。

VLAN 1 に 1/1 および 1/2、VLAN 2 に 2/1 および 2/2、VLAN 3 に 3/1 および 3/2 が含まれていれば、このルート用の MET チェーンには、スイッチ ポート 1/1、1/2、2/1、2/2、3/1、および 3/2 が含まれることになります。

IGMP スヌーピングがオンの場合、パケットは VLAN 2 のすべての出力スイッチ ポートに転送されるとは限りません。IGMP スヌーピングによって、グループ メンバまたはルータが存在すると判断されたスイッチ ポートだけに、パケットが転送されます。たとえば、VLAN 1 で IGMP スヌーピングがイネーブルで、IGMP スヌーピングによってポート 1/2 だけにグループ メンバが存在すると判断された場合、MET チェーンにはスイッチポート 1/1、1/2、2/1、2/2、3/1、および 3/2 が含まれることになります。

IP マルチキャスト テーブル

図 36-4 に、Catalyst 4500 シリーズ スイッチがハードウェアで IP マルチキャスト パケットを転送する目的で使用する主なデータ構造を示します。

図 36-4 IP マルチキャスト テーブルおよびプロトコル

 

Integrated Switching Engine は、個々の IP マルチキャスト ルートを識別する目的で、ハードウェア FIB テーブルを維持します。各エントリは、宛先グループの IP アドレスおよびオプションの送信元 IP アドレスで構成されます。マルチキャスト トラフィックは、主に(S,G)および(*,G)の 2 種類のルート上を流れます。(S,G)ルートは、マルチキャスト送信元の IP アドレスと、マルチキャスト グループ宛先の IP アドレスに基づいて、送信元からグループへ流れます。(*,G)ルート上のトラフィックは、PIM RP からグループ G のすべてのレシーバに流れます。(*,G)ルートを使用するのは、スパース モード グループだけです。Integrated Switching Engine ハードウェアには、合計 128,000 のルート用のスペースが準備されています。これらがユニキャスト ルート、マルチキャスト ルート、およびマルチキャスト高速ドロップ エントリによって共有されます。

出力インターフェイスのリストは、Multicast Expansion Table(MET)に保存されます。MET には、最大 32,000 の出力インターフェイス リスト用のスペースがあります。(RET には、最大 102 K エントリ(フラッディング セットに 32 K、マルチキャスト エントリに 70,000 使用)が可能です)。MET リソースは、レイヤ 3 マルチキャスト ルートおよびレイヤ 2 マルチキャスト エントリによって共有されます。ハードウェアで使用できる出力インターフェイス リストの実際の数は、設定によって異なります。マルチキャスト ルートの総数が 32,000 を超えると、Integrated Switching Engine によってマルチキャスト パケットをスイッチングできなくなる場合があります。そのパケットは、CPU サブシステムによってきわめて低い速度で転送されることになります。


) (RET では最大 102K エントリサポートされます(フラッディング セットに 32K、マルチキャスト エントリに 70 K 使用)。



) リリース IOS XE 3.3.0SG および IOS 15.1(1)SG よりも前では、部分的なルーティングは Catalyst 4900M、Catalyst 4948E、Supervisor Engine 6-E、Supervisor Engine 6L-E、Supervisor Engine 7-E、および Supervisor Engine 7L-E ではサポートされません。ハードウェアおよびソフトウェア ルーティングだけがサポートされます。リリース IOS XE 3.3.0SG および IOS 15.1(1)SG 以降、部分的なルーティングはすべてのスーパーバイザ エンジン上でサポートされます。


ハードウェアおよびソフトウェアによる転送

Integrated Switching Engine は通常、パケットをハードウェアで非常に高速で転送します。CPU サブシステムは、例外パケットをソフトウェアで転送します。Integrated Switching Engine が大部分のパケットをハードウェアで転送していることは、統計レポートからわかります。

図 36-5 に、ハードウェアとソフトウェアの転送コンポーネントの概念図を示します。

図 36-5 ハードウェアおよびソフトウェアの転送コンポーネント

 

Integrated Switching Engine は、通常の動作モードでは、ハードウェアで VLAN 間ルーティングを実行します。CPU サブシステムは、ソフトウェアによる転送のために、総称ルーティング カプセル化(GRE)トンネルをサポートしています。

複製は、パケットの 1 コピーを送信する代わりに、パケットを複製して複数のコピーを送信する転送の一種です。レイヤ 3 で複製が行われるのは、マルチキャスト パケットに限られます。ユニキャスト パケットが複数のレイヤ 3 インターフェイス用に複製されることはありません。IP マルチキャスト動作では、着信した IP マルチキャスト パケットごとに、そのパケットの多くの複製が送信されます。

IP マルチキャスト パケットを伝送するルートのタイプは、次のとおりです。

ハードウェア ルート

ソフトウェア ルート

部分的なルート

ハードウェア ルートは、Integrated Switching Engine ハードウェアがパケットのすべての複製を転送する場合に発生します。ソフトウェア ルートは、CPU サブシステム ソフトウェアがパケットのすべての複製を転送する場合に発生します。部分的なルートは、Integrated Switching Engine が一部の複製をハードウェアで転送し、CPU サブシステムが一部の複製をソフトウェアで転送する場合に発生します。

部分的なルート


) 以下に記載する条件が成立する場合、CPU サブシステム ソフトウェアによって複製が転送されますが、ハードウェアによる複製の転送パフォーマンスに影響はありません。


あるルートに対するパケットの複製の一部が CPU サブシステムによって転送される条件は、次のとおりです。

ip igmp join-group コマンドを使用して、マルチキャスト送信元の RPF インターフェイス上の IP マルチキャスト グループのメンバとしてスイッチを設定している場合。

スイッチが PIM スパース モードの送信元へのファースト ホップである場合。スイッチは RP に PIM Register メッセージを送信する必要があります。

ソフトウェア ルート


) RPF インターフェイスまたは出力インターフェイスの設定について次の条件が 1 つでも成立すると、出力のすべての複製はソフトウェアで実行されます。


あるルートに対するパケットの複製の一部が CPU サブシステム ソフトウェアによって転送される条件は、次のとおりです。

インターフェイスがマルチキャスト ヘルパーを使用して設定されている場合。

インターフェイスが GRE トンネルまたはディスタンス ベクトル マルチキャスト ルーティング プロトコル(DVMRP)トンネルである場合。

インターフェイスが Advanced Research Products Agency(ARPA; 高等研究計画局)以外のカプセル化を使用している場合。

次のパケットは、常にソフトウェアによって転送されます。

224.0.0.*(* は 0 ~ 255)の範囲のマルチキャスト グループに送信されるパケット。この範囲は、ルーティング プロトコルが使用します。レイヤ 3 スイッチングでは、この範囲以外のすべてのマルチキャスト グループ アドレスがサポートされています。

IP オプション付きのパケット。

非 RPF トラフィック

Reverse Path Forwarding(RPF)チェックに失敗したトラフィックを、非 RPF トラフィックといいます。Integrated Switching Engine は、非 RPF トラフィックをフィルタリング(持続的にドロップ)するか、またはレート制限して転送します。

複数の レイヤ 3 スイッチ またはルータが同一の LAN セグメントに接続されている冗長な構成で、送信元から発信インターフェイス上の受信側へマルチキャスト トラフィックを転送するのは、1 台の装置だけです。 図 36-6 に、一般的なネットワーク構成で非 RPF トラフィックが発生した状況を示します。

図 36-6 スタブ ネットワークにおける冗長マルチキャスト ルータの構成

 

この種のトポロジでは、PIM Designated Router(PIM DR; PIM 指定ルータ)であるルータ A だけが共通の VLAN にデータを転送します。ルータ B は転送されたマルチキャスト トラフィックを受信しますが、このトラフィックをドロップします。不正なインターフェイスでこのトラフィックが着信したので、RPF チェックに失敗するためです。このように RPF チェックに失敗するトラフィックを、「非 RPF トラフィック」といいます。

マルチキャスト高速ドロップ

PIM-SM、PIM-DM などの IP マルチキャスト プロトコルでは、(S,G)または(*,G)ルートごとに、対応する着信インターフェイスがあります。このインターフェイスを、RPF インターフェイスといいます。予測される RPF インターフェイスとは異なるインターフェイスにパケットが到着することもあります。その場合、PIM によってパケットに特殊なプロトコル処理を行うために、そのパケットを CPU サブシステム ソフトウェアに転送する必要があります。PIM が実行する特殊なプロトコル処理の例としては、PIM アサート プロトコルがあります。

デフォルトでは、Integrated Switching Engine ハードウェアは、非 RPF インターフェイスに着信したすべてのパケットを CPU サブシステム ソフトウェアに送信します。ただし、これらの非 RPF パケットはほとんどの場合、マルチキャスト ルーティング プロトコルに必要ではないので、多くの場合、ソフトウェアによる処理は不要です。何の処置も行わなければ、ソフトウェアに送信される非 RPF パケットのため、CPU に負荷がかかるおそれがあります。

リリース IOS XE 3.3.0SG および IOS 15.1(1)SG よりも前では、この状況の発生を避けるために、CPU サブシステム ソフトウェアは、スイッチ上で実行されている PIM プロトコルが必要としない RPF 失敗パケットを受信すると、ハードウェア内に高速ドロップ エントリをロードします。高速ドロップ エントリに一致するパケットは、入力 VLAN でブリッジングされますが、ソフトウェアには送信されません。したがって、CPU サブシステムが、これらの RPF エラーを不必要に処理して過負荷になるようなことはありません。ただし、このプロセスはハードウェア内に高速ドロップ エントリを維持する必要がありました。FLCAM スペースに制限があるため、ハードウェアにインストールされる高速ドロップ エントリの数も制限されました。

リリース IOS XE 3.3.0SG および IOS 15.1(1)SG 以降、高速ドロップ エントリをインストールするのではなく、スイッチは Dynamic Buffer Limiting(DBL)を使用します。このフローベースの輻輳回避メカニズムは、各トラフィック フローのキュー長を追跡することによりアクティブ キュー管理を提供します。フローのキュー長がその設定された制限を超える場合、DBL がパケットをドロップします。CPU が過負荷にならないように、レート DBL は、CPU サブシステムに対する非 RPF トラフィックを制限します。パケットは CPU に対してフローごとにレート制限されます。CAM に高速ドロップ エントリをインストールすることは不可能なため、スイッチで処理できる高速ドロップ フローの数を制限する必要はありません。

リンクのダウン、ユニキャスト ルーティング テーブルの変更などのプロトコル イベントによって、安全に高速ドロップが可能なパケットの集合に影響が出ることがあります。以前は高速ドロップを行っても問題のなかったパケットを、トポロジの変更後、PIM ソフトウェアに処理させるため、CPU サブシステム ソフトウェアに転送する必要があります。CPU サブシステム ソフトウェアは、プロトコル イベントに応答して高速ドロップ エントリのフラッシュを行い、IOS の PIM コードが必要な RPF エラーをすべて処理できるようにします。

RPF エラーが繰り返し発生する可能性があるため、一部の一般的なトポロジでは、ハードウェアにおいて高速ドロップ エントリを使用することが重要です。高速ドロップ エントリがなければ、処理する必要のない RPF エラー パケットによって CPU が過負荷になります。

マルチキャスト転送情報ベース

マルチキャスト転送情報ベース(MFIB)サブシステムは、Integrated Switching Engine 上の Catalyst 4500 シリーズ スイッチ ハードウェアの IP マルチキャスト ルーティングをサポートします。MFIB は、論理的には CPU サブシステム ソフトウェアの IP マルチキャスト ルーティング プロトコル(PIM、IGMP、MSDP、MBGP、および DVMRP)と、ハードウェアで IP マルチキャスト ルーティングを管理するためのプラットフォーム固有のコードとの中間に存在します。MFIB は、マルチキャスト ルーティング プロトコルによって作成されたルーティング テーブル情報を、Integrated Switching Engine ハードウェアが効率的に処理して転送に使用可能な、簡易なフォーマットに変換します。

マルチキャスト ルーティング テーブルの情報を表示するには、 show ip mroute コマンドを使用します。MFIB テーブルの情報を表示するには、 show ip mfib コマンドを使用します。

MFIB テーブルには、IP マルチキャスト ルートの集合が含まれます。IP マルチキャスト ルートには(S,G)および(*,G)が含まれます。MFIB テーブルの各ルートに、オプションの 1 つまたは複数のフラグを対応付けることができます。ルート フラグは、ルートに一致するパケットの転送方法を指示します。たとえば、MFIB ルートに付けられた Internal Copy(IC)フラグは、スイッチ上のプロセスがパケットのコピーを受信する必要があることを意味します。MFIB ルートに対応付けできるフラグは、次のとおりです。

Internal Copy(IC)フラグ:ルータ上のプロセスが、特定のルートに一致するすべてのパケットのコピーを受信する必要がある場合に設定します。

Signalling(S)フラグ:このルートに一致するパケットを受信したときに、プロセスに通知する必要がある場合に設定します。シグナリング インターフェイス上でのパケット受信に応答して、プロトコル コードが MFIB ステートを更新するなどの動作を行うことが考えられます。

Connected(C)フラグ:このフラグを MFIB ルートに設定した場合、直接接続されたホストによってルートに送信されたパケットだけをプロトコル プロセスに通知する必要があるという点を除き、Signalling(S)フラグと同じ意味を持ちます。

ルートには、1 つまたは複数のインターフェイスに対応するオプションのフラグを設定することもできます。たとえば、VLAN 1 に関するフラグを設定した(S,G)ルートは、VLAN 1 に着信するパケットをどのように扱うべきかと、このルートに一致するパケットを VLAN 1 に転送すべきかを示します。MFIB でサポートされるインターフェイス単位のフラグは、次のとおりです。

Accepting(A):マルチキャスト ルーティングで RPF インターフェイスであることが明らかなインターフェイスに設定します。Accepting(A)をマークされたインターフェイスに着信したパケットは、すべての Forwarding(F)インターフェイスに転送されます。

Forwarding(F):上記のように、Accepting(A)フラグと組み合わせて使用します。Forwarding インターフェイスの集合は、マルチキャスト olist (output interface list)と呼ばれるものを形成します。

Signalling(S):このインターフェイスにパケットが着信したとき、Cisco IOS の何らかのマルチキャスト ルーティング プロトコル プロセスに通知する必要がある場合に設定します。


) PIM-SM ルーティングを使用している場合、MFIB ルートには次の例のようなインターフェイスが含まれる場合があります。

PimTunnel [1.2.3.4].

これは、パケットが特定の宛先アドレスに対してトンネリングされていることを表すために、MFIB サブシステムが作成する仮想インターフェイスです。PimTunnel インターフェイスは、通常の show interface コマンドでは表示できません。


S/M,224/4

MFIB では、マルチキャスト対応のインターフェイスごとに(S/M,224/4)エントリが作成されます。このエントリによって、直接接続されたネイバーから送信されたすべてのパケットが、PIM-SM RP に Register カプセル化されるようになります。一般に、PIM-SM によって(S,G)ルートが確立されるまでの間、ごく少数のパケットだけが(S/M,224/4)ルートを使用して転送されます。

たとえば、IP アドレス 10.0.0.1 およびネットマスク 255.0.0.0 のインターフェイスで、送信元アドレスがクラス A ネットワーク 10 に所属する IP マルチキャスト パケットにすべて一致するルートが作成されるとします。このルートは、慣例的なサブネット/マスク長の表記では(10/8,224/4)と記述されます。インターフェイスに複数の IP アドレスが割り当てられている場合には、これらの IP アドレスごとに 1 つずつルートが作成されます。

マルチキャスト HA

リリース IOS XE 3.4.0SG および IOS 15.1(2)SG 以降、Catalyst 4500/4900/4900X シリーズ スイッチはマルチキャスト HA をサポートします。マルチキャスト HA では、スーパーバイザ エンジンの障害時に中断されないマルチキャスト トラフィック フローが保証されます。MFIB ステートは、スイッチオーバーの前にスタンバイ スーパーバイザ エンジンに同期化され、スーパーバイザ エンジンの障害時のスイッチオーバーのときに高速コンバージェンスでの NSF の可用性が確保されます。マルチキャスト HA(SSO/NSF/ISSU)は、PIM のスパース、デンス、Bidir、および SSM モードにサポートされ、IGMP および MLD スヌーピング用のレイヤ 2 でサポートされます。

マルチキャスト HA の詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/ios-xml/ios/ipmulti_resil/configuration/15-1s/Monitoring_and_Maintaining_Multicast_HA_Operations.html

http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_book.html

IP マルチキャスト ルーティングの設定

ここでは、IP マルチキャスト ルーティングの設定作業について説明します。

「IP マルチキャスト ルーティングのデフォルト設定」

「IP マルチキャスト ルーティングのイネーブル化」

「インターフェイス上での PIM のイネーブル化」

「双方向モードのイネーブル化」

「PIM-SSM マッピングのイネーブル化」

「RP の設定」

「単一スタティック RP の設定」

「IP マルチキャスト トラフィックのロード分割」

Auto-RP、PIM バージョン 2、および IP マルチキャスト スタティック ルートなどの IP マルチキャスト ルーティングの詳細については、『 Cisco IOS IP and IP Routing Configuration Guide, Cisco IOS Release 12.3 』を参照してください。

IP マルチキャスト ルーティングのデフォルト設定

表 36-1 に、IP マルチキャストのデフォルト設定を示します。

 

表 36-1 IP マルチキャストのデフォルト設定

機能
デフォルト値

RPF のレート制限

グローバルにイネーブル

IP マルチキャスト ルーティング

グローバルにディセーブル

(注) IP マルチキャスト ルーティングがディセーブルになっている場合、IP マルチキャスト トラフィック データは Catalyst 4500 シリーズ スイッチによって転送されません。ただし、IP マルチキャスト制御トラフィックは引き続き処理および転送されます。IP マルチキャスト ルーティングをディセーブルにしても、IP マルチキャスト ルートはルーティング テーブルに残ります。

PIM

すべてのインターフェイス上でディセーブル

IGMP スヌーピング

すべての VLAN インターフェイス上でイネーブル

(注) 特定のインターフェイス上で IGMP スヌーピングをディセーブルにすると、すべての出力ポートが Integrated Switching Engine によって転送されます。入力 VLAN インターフェイス上で IGMP スヌーピングをディセーブルにすると、そのインターフェイスに関連するマルチキャスト パケットは、VLAN 上のすべてのフォワーディング スイッチ ポートに送信されます。


) Source Specific Multicast および IGMPv3 がサポートされています。


IGMPv3 および IGMP を備えた Source Specific Multicast の詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_cfg_ssm.html

IP マルチキャスト ルーティングのイネーブル化

IP マルチキャスト ルーティングをイネーブルにすると、Catalyst 4500 シリーズ スイッチでマルチキャスト パケットを転送できるようになります。ルータ上で IP マルチキャスト ルーティングをイネーブルにするには、次のコマンドを入力します。

 

コマンド
目的

Switch(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

インターフェイス上での PIM のイネーブル化

インターフェイス上で PIM をイネーブルにすると、そのインターフェイス上で IGMP 動作もイネーブルになります。インターフェイスは、デンス モード、スパース モード、またはスパース/デンス モードのいずれかに設定できます。これらのモードは、レイヤ 3 スイッチまたはルータによるマルチキャスト ルーティング テーブルの書き込み方法と、レイヤ 3 スイッチまたはルータが直接接続された LAN から受信したマルチキャスト パケットの転送方法を決定します。IP マルチキャスト ルーティングを実行するには、インターフェイスに対して、これらの PIM モードのいずれかをイネーブルにする必要があります。

マルチキャスト ルーティング テーブルの書き込みでは、デンス モード インターフェイスは常にテーブルに追加されます。スパース モード インターフェイスは、ダウンストリーム ルータから定期的な Join メッセージを受信した場合、またはインターフェイス上に直接接続されたメンバが存在する場合に限り、テーブルに追加されます。LAN から転送する場合、グループが認識している RP があれば、SM 動作が行われます。その場合、パケットはカプセル化され、その RP に送信されます。認識している RP がなければ、パケットは DM 方式でフラッディングされます。特定の送信元からのマルチキャスト トラフィックが十分であれば、受信側のファーストホップ ルータがその送信元に Join メッセージを送信し、送信元を基点とするディストリビューション ツリーが構築されます。

デフォルトで設定されるモードはありません。デフォルトでは、インターフェイス上でマルチキャスト ルーティングはディセーブルに設定されています。

デンス モードのイネーブル化

インターフェイス上の PIM をデンス モードに設定するには、次のコマンドを入力します。

 

コマンド
目的

Switch(config-if)# ip pim dense-mode

インターフェイス上でデンス モード PIM をイネーブルにします。

PIM インターフェイスをデンス モードに設定する方法の例については、 PIM デンス モードの例を参照してください。

スパース モードのイネーブル化

インターフェイス上の PIM をスパース モードに設定するには、次のコマンドを入力します。

 

コマンド
目的

Switch(config-if)# ip pim sparse-mode

インターフェイス上でスパース モード PIM をイネーブルにします。

PIM インターフェイスをスパース モードに設定する方法の例については、 PIM スパース モードの例を参照してください。

スパース/デンス モードのイネーブル化

ip pim sparse-mode または ip pim dense-mode コマンドを使用すると、インターフェイス全体にスパース モードまたはデンス モードが適用されます。ただし、環境によっては、単一リージョン内の一部のグループについては PIM をスパース モードで実行し、残りのグループについてはデンス モードで実行しなければならない場合があります。

デンス モードだけ、またはスパース モードだけをイネーブルにする代わりに、スパース-デンス モードをイネーブルにできます。グループがデンス モードであればインターフェイスはデンス モードとして処理され、グループがスパース モードであればインターフェイスはスパース モードとして処理されます。グループをスパース グループとして扱い、インターフェイスがスパース/デンス モードである場合には、RP が必要です。

スパース/デンス モードを設定する場合、スパースまたはデンスの概念はスイッチ上のグループに適用され、ネットワーク管理者は同じ概念をネットワーク全体に適用する必要があります。

スパース/デンス モードのもう 1 つの利点は、Auto-RP 情報をデンス モードの方式で配布しながら、ユーザ グループのマルチキャスト グループをスパース モードの方式で使用できるという点です。リーフ ルータ上でデフォルト RP を設定する必要はありません。

インターフェイスがデンス モードで取り扱われる場合、次のいずれかの条件が満たされると、そのインターフェイスはマルチキャスト ルーティング テーブルの発信インターフェイス リストに追加されます。

メンバまたは DVMRP ネイバーがインターフェイスに存在する場合

PIM ネイバーが存在し、グループがプルーニングされていない場合

インターフェイスがスパース モードで取り扱われる場合、次のいずれかの条件が満たされると、そのインターフェイスはマルチキャスト ルーティング テーブルの発信インターフェイス リストに追加されます。

メンバまたは DVMRP ネイバーがインターフェイスに存在する場合

インターフェイス上の PIM ネイバーが明示的な Join メッセージを受信している場合

PIM がグループと同じモードで動作できるようにするには、次のコマンドを入力します。

 

コマンド
目的

Switch(config-if)# ip pim sparse-dense-mode

PIM がグループに応じて、スパース モードまたはデンス モードのいずれかで動作できるようにします。

双方向モードのイネーブル化

Bidir-PIM のほとんどの設定要件は、PIM-SM の設定要件と同じです。双方向モードでマルチキャスト グループのトラフィックを伝送する場合に、インターフェイスをイネーブルまたはディセーブルにする必要はありません。代わりに、双方向モードで動作するマルチキャスト グループを設定します。PIM-SM と同様に、Auto-RP、スタティック RP 設定、または PIM Version 2 Bootstrap Router(PIMv2 BSR; PIM バージョン 2 ブートストラップ ルータ)メカニズムを使用して、この設定を行えます。

Bidir-PIM をイネーブルにするには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Switch(config)# ip pim bidir-enable

スイッチの Bidir-PIM をイネーブルにします。

Bidir-PIM を設定するには、group-to-RP マッピングを配布するためにいずれの方法を使用するかに応じて、次のコマンドの 1 つを入力します。

 

コマンド
目的

Switch(config)# ip pim rp-address rp-address [access-list] [override] bidir

特定のグループの PIM RP のアドレスを設定し、双方向モードを指定します。

Auto-RP メカニズムまたは PIMv2 BSR メカニズムのどちらも使用せずに group-to-RP マッピングを配布する場合は、このコマンドを使用します。

Switch(config)# ip pim rp-candidate type number [group-list access-list] bidir

ルータ自体を BSR に対する PIM バージョン 2 の候補 RP としてアドバタイズし、双方向モードを指定します。

PIMv2 BSR メカニズムを使用して group-to-RP マッピングを配布する場合は、このコマンドを使用します。

Switch(config)# ip pim send-rp-address type number scope ttl-value [group-list access-list] [interval seconds] bidir

Auto-RP を使用してルータが RP として動作するグループの設定を行うようにルータを設定し、双方向モードを指定します。

group-to-RP マッピングを配布するために Auto-RP を使用している場合に、このコマンドを使用します。

Bidir-PIM を設定する方法の例については、「双方向 PIM モードの例」を参照してください。

PIM-SSM マッピングのイネーブル化

Catalyst 4500 シリーズ スイッチは、SSM マッピングをサポートし、URD も IGMP v3-lite も利用できない場合、またはエンド システム上での SSM サポートが、管理上または技術上の理由から、不可能であるか望ましくない場合に SSM 遷移をイネーブルにします。SSM マッピングにより、IGMPv3 が未サポートである従来型のセットトップ ボックス(STB)に映像を配信したり、IGMPv3 ホスト スタックを利用しないアプリケーションに対して、SSM を活用できます。

詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/docs/ios/12_3t/12_3t2/feature/guide/gtssmma.html

RP の設定

ランデブー ポイント(RP)は Protocol Independent Multicast Sparse Mode(PIM-SM)を実行しているネットワークで必要です。PIM-SM でトラフィックは、明示的にマルチキャスト データを要求したアクティブな受信者のいるネットワーク セグメントにのみ転送されます。

ランデブー ポイント(ここで説明する)を設定する最も一般的な方法には、スタティック RP を使用する方法と、Auto-RP プロトコルを使用する方法があります。もう 1 つの方法(ここでは説明しない)は、ブートストラップ ルータ(BSP)プロトコルを使用する方法です。

Auto-RP の設定

自動ランデブ― ポイント(Auto-RP)は、PIM ネットワークでの group-to-RP マッピングの配布を自動化します。Auto-RP が機能するためには、RP アナウンスメント メッセージを RP から受信して競合を解決する RP マッピング エージェントとしてルータが指定されている必要があります。その後、RP マッピング エージェントは、デンス モード フラッディングにより、一貫した group-to-RP マッピングを他のすべてのルータに送信します。

すべてのルータは、サポート対象のグループに使用する RP を自動的に検出します。インターネット割り当て番号局(IANA)は、224.0.1.39 と 224.0.1.40 という 2 つのグループ アドレスを Auto-RP 用に割り当てています。

マッピング エージェントは、Candidate-RP から RP になる意図の通知を受信します。その後、マッピング エージェントが RP 選定の結果を通知します。この通知は、他のマッピング エージェントによる決定とは別に行われます。

ランデブー ポイントを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Switch> enable

特権 EXEC モードをイネーブルにします。

ステップ 2

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Switch(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

ステップ 4

Switch(config)# interface [FastEthernet | GigabitEthernet | Loopback | Null | Port-channel | TenGigabitEthernet | Tunnel | Vlan] number

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 5

Switch(config-if)# ip pim [sparse-mode | sparse-dense-mode]

インターフェイスで PIM スパースまたはスパース/デンス モードをイネーブルにします。スパース モードで Auto-RP を設定している場合、次のステップで Auto-RP リスナーも設定する必要があります。

ステップ 6

Switch(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

すべての PIM インターフェイス上でステップ 4 および 5 を繰り返します。

--

ステップ 8

Switch(config)# ip pim autorp listener

2 つの Auto-RP グループ 224.0.1.39 と 224.0.1.40 の IP マルチキャスト トラフィックを PIM スパース モードで動作しているインターフェイスでフラッディングされる PIM デンス モードにします。

ステップ 5 でスパース/デンス モードを設定している場合、このステップはスキップします。

ステップ 9

Switch(config)# ip pim send-rp-announce { interface-type interface-number | ip-address } scope ttl-value [ group-list access-list ] [ interval seconds ] [ bidir ]

RP アナウンスメントをすべての PIM 対応インターフェイスに送信します。

RP ルータでのみこのステップを実行します。

RP アドレスとして使用する IP アドレスを定義するには、 interface-type 引数と interface-number 引数を使用します。

直接接続されている IP アドレスを RP アドレスとして指定するには、 ip-address 引数を使用します。

引数が設定されている場合、RP 通知メッセージがこのアドレスが接続されているインターフェイスによって送信されます(つまり、RP 通知メッセージの IP ヘッダーのソース アドレスがそのインターフェイスの IP アドレスです)。

次の例は、最大ホップ数が 31 でインターフェイスがイネーブルであることを示します。ルータは、ループバック インターフェイス 0 に関連付けられた IP アドレスによって RP として識別されることを望みます。アクセス リスト 5 はこのルータが RP として機能しているグループを示しています。

ステップ 10

Switch(config)# ip pim send-rp-discovery [interface-type interface-number] scope ttl-value [ interval seconds ]

ルータを RP マッピング エージェントとして設定します。

RP ルータでのみこのステップを実行します。

RP マッピング エージェントのソース アドレスとして使用する IP アドレスを定義するには、オプションの interface-type 引数と interface-number 引数を使用します。

Auto-RP 検出メッセージの IP ヘッダーで存続可能時間(TTL)値を指定するには、 scope キーワードと ttl-value 引数を使用します。

Auto-RP 検出メッセージが送信される間隔を指定するには、オプションの interval キーワードと seconds 引数を使用します。

(注) Auto-RP 検出メッセージが送信される間隔をデフォルト値の 60 秒から減らすと、group-to-RP マッピングのより頻繁なフラッディングが発生します。一部のネットワーク環境では、間隔を短縮する欠点(制御パケットのオーバーヘッドの増加)が利点(Requirementsgroup-to-RP マッピングのより頻繁な更新)を上回る場合があります。

例では、ループバック インターフェイス 1 で Auto-RP 検出メッセージを 31 ホップに制限していることを示しています。

ステップ 11

Switch(config)# ip pim rp-announce-filter rp-list access-list group-list access-list

RP から送信された着信 Auto-RP アナウンスメント メッセージをフィルタリングします。

RP ルータでのみこのステップを実行します。

このステップに適用する 2 つのアクセス リストの例は次のとおりです。

access-list 1 permit 10.0.0.1
access-list 1 permit 10.0.0.2
access-list 2 permit 224.0.0.0 15.255.255.255

ステップ 12

Switch(config)# interface type number

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 13

Switch(config-if)# interface ethernet 1

ip multicast boundary access-list [ filter-autorp ]

管理用スコープの境界を設定します。

このステップは、他のルータとの境界であるインターフェイス上で実行します。

この作業ではアクセス リストは表示されません。

deny キーワードを使用するアクセス リスト エントリはそのエントリに一致するパケットのマルチキャスト境界を作成します。

ステップ 14

Switch(config-if)# end

EXEC モードに戻ります。

ステップ 15

Switch# show ip pim autorp

(任意)Auto-RP 情報を表示します。

ステップ 16

Switch# show ip pim rp [ mapping ] [ rp-address ]

(任意)ネットワークで既知の RP を表示し、ルータが各 RP について学習する方法を示します。

ステップ 17

Switch# show ip igmp groups [group-name | group-address | interface-type interface-number] [detail]

(任意)ルータに直接接続されている、インターネット グループ管理プロトコル(IGMP)を通じて学習されたレシーバを持つマルチキャスト グループを表示します。

レシーバ情報が結果に確実に表示されるには、レシーバは、このコマンドが発行される時点でネットワーク上においてアクティブである必要があります。

ステップ 18

Switch# show ip mroute [ group-address | group-name ] [ source-address | source-name ] [ interface-type interface-number ] [ summary ] [ count ] [ active kbps ]

(任意)IP マルチキャスト ルーティング(mroute)テーブルの内容を表示します。

次に、Auto-RP を設定する例を示します。

Switch> enable

Switch# configure terminal

Switch(config)# ip multicast-routing

Switch(config)# interface ethernet 1

Switch(config-if)# ip pim sparse-mode

Switch(config-if)# end

Switch(config)# ip pim autorp listener
Switch(config)# ip pim send-rp-announce loopback0 scope 31 group-list 5
Switch(config)# ip pim send-rp-discovery loopback 1 scope 31

Switch(config)# ip pim rp-announce-filter rp-list 1 group-list 2

Switch(config)# interface ethernet 1

Switch(config-if)# ip multicast boundary 10 filter-autorp

Switch(config-if)# end

Switch# show ip pim autorp

Switch# show ip pim rp mapping

Switch# show ip igmp groups

Switch# show ip mroute cbone-audio

単一スタティック RP の設定

PIM スパース モードを設定している場合、マルチキャスト グループの PIM RP を設定する必要があります。RP は各デバイスで静的に設定するか、ダイナミック メカニズムによって学習できます。この作業は、Auto-RP のようにダイナミック メカニズムによってルータが RP を学習するのではなく、RP を静的に設定する方法を説明しています。

PIM Designated Router(DR)は共有ツリーに分散するために、直接接続されたマルチキャスト ソースから RP にデータを転送します。データは次の 2 つの方法のいずれかを使用して RP に転送されます。データは登録パケットにカプセル化され、直接 RP にユニキャストされます。または、RP がソース ツリーに参加している場合は、RPF 転送アルゴリズムによってマルチキャスト転送されます。レシーバに直接接続されたラスト ホップ ルータは、それぞれの判断でソース ツリーに参加し、共有ツリーから自身をプルーニングできます。

アクセス リストによって定義された複数のグループに単一の RP を設定できます。グループに RP が設定されていない場合、ルータは PIM デンス モード技術を使用してグループをデンスとして処理します (no ip pim dm-fallback コマンドを設定するとこれを防げます)。

ip pim rp-address コマンドによって設定された RP と Auto-RP によって学習された RP との間に矛盾がある場合は、override キーワードが設定されていない限り、Auto-RP 情報が使用されます。

単一スタティック RP を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Switch> enable

特権 EXEC モードをイネーブルにします。

ステップ 2

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Switch(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

ステップ 4

Switch(config)# interface type number

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 5

Switch(config-if)# ip pim [sparse-mode | sparse-dense-mode]

インターフェイス上の PIM をイネーブルにします。スパース モードを使用する必要があります。

ステップ 6

IP マルチキャストを使用するすべてのインターフェイスでステップ 4 と 5 を繰り返します。

--

ステップ 7

Switch(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

Switch(config)# ip pim rp-address rp-address [access-list] [override]

特定のグループの PIM RP のアドレスを設定します。

すべてのルータでこのステップを実行します。

access-list 引数は、この RP がどのマルチキャスト グループに使用されるかを定義するアクセス リストの番号または名前を指定します。

override キーワードは、このコマンドによって設定された RP と Auto-RP によって学習された RP との間に矛盾が生じた場合に、このコマンドによって設定された RP を優先することを指定します。

ステップ 9

Switch(config)# end

現在のコンフィギュレーション セッションを終了して、EXEC モードに戻ります。

ステップ 10

Switch# show ip pim rp [ mapping ] [ rp-address ]

(任意)ネットワークで既知の RP を表示し、ルータが各 RP について学習する方法を示します。

ステップ 11

Switch# show ip igmp groups [group-name | group-address | interface-type interface-number] [detail]

(任意)ルータに直接接続されている、IGMP によって学習されたレシーバを持つマルチキャスト グループを表示します。

レシーバ情報が結果に確実に表示されるには、レシーバは、このコマンドが発行される時点でネットワーク上においてアクティブである必要があります。

ステップ 12

Switch# show ip mroute [ group-address | group-name ] [ source-address | source-name ] [ interface-type interface-number ] [ summary ] [ count ] [ active kbps ]

(任意)IP マルチキャスト ルーティング(mroute)テーブルの内容を表示します。

次に、単一スタティック RP を設定する例を示します。

Switch> enable

Switch# configure terminal

Switch(config)# ip multicast-routing

Switch(config)# interface ethernet 1

Switch(config-if)# ip pim sparse-mode

Switch(config-if)# exit

Switch(config)# ip pim rp-address 192.168.0.0

Switch(config)# end

Switch# show ip pim rp mapping

Switch# show ip igmp groups

Switch# show ip mroute cbone-audio

IP マルチキャスト トラフィックのロード分割


) この機能は、Enterprise Services だけでサポートされます。これは、IP Base および LAN Base ではサポートされません。


ソースから 2 つ以上の等コスト パスが使用できる場合は、ユニキャスト トラフィックはそれらのパスの間でロード分割されます。一方、マルチキャスト トラフィックは、デフォルトでは、複数の等コスト パスの間でロード分割されません。一般的に、マルチキャスト トラフィックは、Reverse Path Forwarding(RPF)ネイバーから伝送されます。Protocol Independent Multicast(PIM)仕様に従うと、複数のネイバーが同じメトリックを持つ場合、このネイバーは最も大きい IP アドレスを持っていなければなりません。

複数の等コスト パス間で IP マルチキャスト トラフィックのロード分割をイネーブルにするには、 ip multicast multipath コマンドを使用します。


ip multicast multipath コマンドは、双方向 Protocol Independent Multicast(PIM)では動作しません。


IP マルチキャスト マルチパスをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch# config t

コンフィギュレーション モードを開始します。

ステップ 2

Switch(config)# ip multicast multipath

IP マルチキャスト マルチパスをイネーブルにします。

ステップ 3

Switch(config)# end

コンフィギュレーション モードを終了します。


ip multicast multipath コマンドは、トラフィックのロード分割を行いますが、トラフィックのロード バランシングは行いません。ソースからのトラフィックは、そのトラフィックがその他のソースからのトラフィックよりはるかに多い場合でも、1 つのパスしか使用しません。


ip multicast multipath コマンドでロード分割を設定すると、システムは、S ハッシュ アルゴリズムを使用して、ソース アドレスに基づいて、複数の等コスト パスの間でマルチキャスト トラフィックをロード分割します。 ip multicast multipath コマンドを設定していて、複数の等コスト パスが存在する場合、マルチキャスト トラフィックを伝送するパスは、ソース IP アドレスに基づいて選択されます。異なる複数のソースからのマルチキャスト トラフィックは、異なる複数の等コスト パスの間でロード分割されます。同一ソースから異なる複数のマルチキャスト グループに送信されたマルチキャスト トラフィックについては、複数の等コスト パスの間でロード分割は行われません。

次に、S ハッシュ アルゴリズムを使用する、送信元アドレスに基づいた ECMP マルチキャストのロード分割を、ルータ上でイネーブルにする例を示します。

Switch(config)# ip multicast multipath
 

次に、S-G ハッシュ アルゴリズムを使用する、送信元に基づいた ECMP マルチキャストのロード分割を、ルータ上でイネーブルにする例を示します。

Switch(config)# ip multicast multipath s-g-hash basic
 

次の例は、ネクスト ホップ ベースの S-G ハッシュ アルゴリズムを使用した、ソース アドレス、グループ アドレス、およびネクスト ホップ アドレスに基づく ECMP マルチキャスト ロード分割をルータ上でイネーブルにする方法を示します。

Switch(config)# ip multicast multipath s-g-hash next-hop-based

IP マルチキャスト ルーティングのモニタリングおよびメンテナンス

特定のキャッシュ、テーブル、またはデータベースのすべての内容を削除できます。さらに、特定の統計情報を表示することもできます。ここでは、IP マルチキャストのモニタリングおよびメンテナンス方法について説明します。

「システムおよびネットワーク統計情報の表示」

「マルチキャスト ルーティング テーブルの表示」

「IP MFIB の表示」

「双方向 PIM 情報の表示」

「PIM 統計情報の表示」

「テーブルおよびデータベースの削除」

システムおよびネットワーク統計情報の表示

IP ルーティング テーブルやデータベースの内容など、特定の統計情報を表示できます。提供される情報は、リソースの使用状況を判定してネットワークの問題を解決するために使用されます。さらに、ノードの到達可能性に関する情報を表示し、デバイスのパケットがネットワークを使用して経由するパスを検出することもできます。

各種のルーティング統計情報を表示するには、次のコマンドのいずれかを入力します。

 

コマンド
目的

Switch# ping [ group-name | group-address ]

マルチキャスト グループ アドレスにインターネット制御メッセージ プロトコル(ICMP)エコー要求を送信します。

Switch# show ip mroute [ hostname | group_number ]

IP マルチキャスト ルーティング テーブルの内容を表示します。

Switch# show ip pim interface [ type number ] [ count ]

PIM に対して設定されたインターフェイスに関する情報を表示します。

Switch# show ip interface

すべてのインターフェイスについて PIM 情報を表示します。

マルチキャスト ルーティング テーブルの表示

デンス モードで動作しているルータに関する show ip mroute コマンドの出力例を示します。このコマンドでは、マルチキャスト グループ cbone-audio に関する IP マルチキャスト FIB テーブルの内容が表示されます。

Switch# show ip mroute cbone-audio
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
R - RP-bit set, F - Register flag, T - SPT-bit set
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode
 
(*, 224.0.255.1), uptime 0:57:31, expires 0:02:59, RP is 0.0.0.0, flags: DC
Incoming interface: Null, RPF neighbor 0.0.0.0, Dvmrp
Outgoing interface list:
Ethernet0, Forward/Dense, 0:57:31/0:02:52
Tunnel0, Forward/Dense, 0:56:55/0:01:28
 
(198.92.37.100/32, 224.0.255.1), uptime 20:20:00, expires 0:02:55, flags: C
Incoming interface: Tunnel0, RPF neighbor 10.20.37.33, Dvmrp
Outgoing interface list:
Ethernet0, Forward/Dense, 20:20:00/0:02:52
 

次に、スパース モードで動作しているルータに関する show ip mroute コマンドの出力例を示します。

Switch# show ip mroute
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
R - RP-bit set, F - Register flag, T - SPT-bit set
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode
 
(*, 224.0.255.3), uptime 5:29:15, RP is 198.92.37.2, flags: SC
Incoming interface: Tunnel0, RPF neighbor 10.3.35.1, Dvmrp
Outgoing interface list:
Ethernet0, Forward/Sparse, 5:29:15/0:02:57
 
(198.92.46.0/24, 224.0.255.3), uptime 5:29:15, expires 0:02:59, flags: C
Incoming interface: Tunnel0, RPF neighbor 10.3.35.1
Outgoing interface list:
Ethernet0, Forward/Sparse, 5:29:15/0:02:57

) ハードウェアで転送されるパケットについては、インターフェイス タイマーは更新されません。エントリ タイマーは、約 5 秒ごとに更新されます。


次に、show ip mroute コマンドに summary キーワードを指定した場合の出力例を示します。

Switch# show ip mroute summary
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
Timers: Uptime/Expires
Interface state: Interface, Next-Hop, State/Mode
 
(*, 224.255.255.255), 2d16h/00:02:30, RP 171.69.10.13, flags: SJPC
 
(*, 224.2.127.253), 00:58:18/00:02:00, RP 171.69.10.13, flags: SJC
 
(*, 224.1.127.255), 00:58:21/00:02:03, RP 171.69.10.13, flags: SJC
 
(*, 224.2.127.254), 2d16h/00:00:00, RP 171.69.10.13, flags: SJCL
(128.9.160.67/32, 224.2.127.254), 00:02:46/00:00:12, flags: CLJT
(129.48.244.217/32, 224.2.127.254), 00:02:15/00:00:40, flags: CLJT
(130.207.8.33/32, 224.2.127.254), 00:00:25/00:02:32, flags: CLJT
(131.243.2.62/32, 224.2.127.254), 00:00:51/00:02:03, flags: CLJT
(140.173.8.3/32, 224.2.127.254), 00:00:26/00:02:33, flags: CLJT
(171.69.60.189/32, 224.2.127.254), 00:03:47/00:00:46, flags: CLJT
 

次に、show ip mroute コマンドに active キーワードを指定した場合の出力例を示します。

Switch# show ip mroute active
 
Active IP Multicast Sources - sending >= 4 kbps
 
Group: 224.2.127.254, (sdr.cisco.com)
Source: 146.137.28.69 (mbone.ipd.anl.gov)
Rate: 1 pps/4 kbps(1sec), 4 kbps(last 1 secs), 4 kbps(life avg)
 
Group: 224.2.201.241, ACM 97
Source: 130.129.52.160 (webcast3-e1.acm97.interop.net)
Rate: 9 pps/93 kbps(1sec), 145 kbps(last 20 secs), 85 kbps(life avg)
 
Group: 224.2.207.215, ACM 97
Source: 130.129.52.160 (webcast3-e1.acm97.interop.net)
Rate: 3 pps/31 kbps(1sec), 63 kbps(last 19 secs), 65 kbps(life avg)
 

次に、show ip mroute コマンドに count キーワードを指定した場合の出力例を示します。

Switch# show ip mroute count
 
IP Multicast Statistics - Group count: 8, Average sources per group: 9.87
Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
 
Group: 224.255.255.255, Source count: 0, Group pkt count: 0
RP-tree: 0/0/0/0
 
Group: 224.2.127.253, Source count: 0, Group pkt count: 0
RP-tree: 0/0/0/0
 
Group: 224.1.127.255, Source count: 0, Group pkt count: 0
RP-tree: 0/0/0/0
 
Group: 224.2.127.254, Source count: 9, Group pkt count: 14
RP-tree: 0/0/0/0
Source: 128.2.6.9/32, 2/0/796/0
Source: 128.32.131.87/32, 1/0/616/0
Source: 128.125.51.58/32, 1/0/412/0
Source: 130.207.8.33/32, 1/0/936/0
Source: 131.243.2.62/32, 1/0/750/0
Source: 140.173.8.3/32, 1/0/660/0
Source: 146.137.28.69/32, 1/0/584/0
Source: 171.69.60.189/32, 4/0/447/0
Source: 204.162.119.8/32, 2/0/834/0
 
Group: 224.0.1.40, Source count: 1, Group pkt count: 3606
RP-tree: 0/0/0/0
Source: 171.69.214.50/32, 3606/0/48/0, RPF Failed: 1203
 
Group: 224.2.201.241, Source count: 36, Group pkt count: 54152
RP-tree: 7/0/108/0
Source: 13.242.36.83/32, 99/0/123/0
Source: 36.29.1.3/32, 71/0/110/0
Source: 128.9.160.96/32, 505/1/106/0
Source: 128.32.163.170/32, 661/1/88/0
Source: 128.115.31.26/32, 192/0/118/0
Source: 128.146.111.45/32, 500/0/87/0
Source: 128.183.33.134/32, 248/0/119/0
Source: 128.195.7.62/32, 527/0/118/0
Source: 128.223.32.25/32, 554/0/105/0
Source: 128.223.32.151/32, 551/1/125/0
Source: 128.223.156.117/32, 535/1/114/0
Source: 128.223.225.21/32, 582/0/114/0
Source: 129.89.142.50/32, 78/0/127/0
Source: 129.99.50.14/32, 526/0/118/0
Source: 130.129.0.13/32, 522/0/95/0
Source: 130.129.52.160/32, 40839/16/920/161
Source: 130.129.52.161/32, 476/0/97/0
Source: 130.221.224.10/32, 456/0/113/0
Source: 132.146.32.108/32, 9/1/112/0

) マルチキャスト ルートのバイトおよびパケット統計情報がサポートされるのは、最初の 1024 個のマルチキャスト ルートに限られます。出力インターフェイスの統計情報は維持されません。


IP MFIB の表示

MFIB のすべてのルート(上位層のルーティング プロトコル データベースには存在しないが、高速スイッチングをさらに高速化するために使用されるルートも含む)を表示できます。これらのルートは、デンス モード転送が使用されている場合でも、MFIB に表示されます。

MFIB の各種のルーティング ルートを表示するには、次のコマンドの 1 つを入力します。

 

コマンド
目的

Switch# show ip mfib

パケット転送に使用されている(S,G)ルートおよび(*,G)ルートを表示します。すべてのマルチキャスト ルートについて、高速スイッチング、低速スイッチング、およびパーシャル スイッチングされたパケットの数が表示されます。

Switch# show ip mfib all

上位層のルーティング プロトコル データベースには直接存在しないが、高速スイッチングを高速化するために使用されるルートを含み、MFIB のすべてのルートを表示します。これらのルートには(S/M,224/4)ルートが含まれます。

Switch# show ip mfib log [n]

最近発生した n 個の MFIB 関連イベント ログを、新しい順に表示します。

n は、イベントの数を表します。

次に、 show ip mfib コマンドの出力例を示します。

IP Multicast Forwarding Information Base
Entry Flags: C - Directly Connected, S - Signal,
IC - Internal Copy
Interface Flags: A - Accept, F - Forward, S - Signal,
NP - Not platform switched
Packets: Fast/Partial/Slow Bytes: Fast/Partial/Slow:
(171.69.10.13, 224.0.1.40), flags (IC)
Packets: 2292/2292/0, Bytes: 518803/0/518803
Vlan7 (A)
Vlan100 (F NS)
Vlan105 (F NS)
(*, 224.0.1.60), flags ()
Packets: 2292/0/0, Bytes: 518803/0/0
Vlan7 (A NS)
(*, 224.0.1.75), flags ()
Vlan7 (A NS)
(10.34.2.92, 239.192.128.80), flags ()
Packets: 24579/100/0, 2113788/15000/0 bytes
Vlan7 (F NS)
Vlan100 (A)
(*, 239.193.100.70), flags ()
Packets: 1/0/0, 1500/0/0 bytes
Vlan7 (A)
..
 

高速スイッチング パケットの数は、該当するルート上でハードウェアによってスイッチングされたパケット数を表します。

部分的スイッチング パケットの数は、高速スイッチング パケットが、ソフトウェア処理のため、あるいは 1 つまたは複数の非プラットフォーム スイッチド インターフェイス(PimTunnel インターフェイスなど)に転送されるため、CPU にコピーされた回数を表します。

低速スイッチング パケットの数は、該当するルート上で完全にソフトウェアによってスイッチングされたパケット数を表します。

双方向 PIM 情報の表示

Bidir-PIM の情報を表示するには、次のコマンドの 1 つを入力します。

 

コマンド
目的

Switch(config)# show ip pim interface [type number] [df | count] [rp-address]

インターフェイスの各 RP の選択された Designated Forward(DF)についての情報を、DF に関連付けられたユニキャスト ルーティング メトリック関連とともに表示します。

Switch(config)# show ip pim rp [mapping | metric] [rp-address]

Auto-RP または BSR を使用して学習された設定済み RP についての情報を、各 RP のユニキャスト ルーティング メトリックとともに表示します。

PIM 統計情報の表示

次に、show ip pim interface コマンドの出力例を示します。

Switch# show ip pim interface
 
Address Interface Mode Neighbor Query DR
Count Interval
198.92.37.6 Ethernet0 Dense 2 30 198.92.37.33
198.92.36.129 Ethernet1 Dense 2 30 198.92.36.131
10.1.37.2 Tunnel0 Dense 1 30 0.0.0.0
 

次に、show ip pim interface コマンドに count を指定した場合の出力例を示します。

Switch# show ip pim interface count
 
Address Interface FS Mpackets In/Out
171.69.121.35 Ethernet0 * 548305239/13744856
171.69.121.35 Serial0.33 * 8256/67052912
198.92.12.73 Serial0.1719 * 219444/862191
 

次に、IP マルチキャストがイネーブルに設定されている状態で show ip pim interface コマンドに count を指定した場合の出力例を示します。この例では、高速スイッチングおよびプロセス スイッチングされる PIM インターフェイスのリストと、これらのパケット数が表示されます。IP マルチキャストがイネーブルに設定されているインターフェイスには、H が表示されます。

Switch# show ip pim interface count
 
States: FS - Fast Switched, H - Hardware Switched
Address Interface FS Mpackets In/Out
192.1.10.2 Vlan10 * H 40886/0
192.1.11.2 Vlan11 * H 0/40554
192.1.12.2 Vlan12 * H 0/40554
192.1.23.2 Vlan23 * 0/0
192.1.24.2 Vlan24 * 0/0

テーブルおよびデータベースの削除

特定のキャッシュ、テーブル、またはデータベースのすべての内容を削除できます。特定のキャッシュ、テーブル、またはデータベースの内容が無効である場合、または無効であると考えられる場合に、これらの削除が必要になります。

IP マルチキャスト キャッシュ、テーブル、およびデータベースをクリアするには、次のコマンドの 1 つを入力します。

 

コマンド
目的
Switch# clear ip mroute

IP ルーティング テーブルのエントリを削除します。

Switch# clear ip mfib counters

ルート単位およびグローバルの MFIB カウンタをすべて削除します。


) IP マルチキャスト ルートは、データ パケットが着信した時点で、プロトコル イベントへの応答として再生成されます。


設定例

ここでは、IP マルチキャスト ルーティングの設定例を示します。

「PIM デンス モードの例」

「PIM スパース モードの例」

「双方向 PIM モードの例」

「単一スタティック RP を使用するスパース モードの例」

「Auto-RP を使用するスパース モードの例」

PIM デンス モードの例

次に、イーサネット インターフェイス上のデンス モード PIM の設定例を示します。

ip multicast-routing
interface ethernet 0
ip pim dense-mode

PIM スパース モードの例

次に、スパース モード PIM の設定例を示します。RP ルータは、アドレス 10.8.0.20 のルータです。

ip multicast-routing
ip pim rp-address 10.8.0.20 1
interface ethernet 1
ip pim sparse-mode

双方向 PIM モードの例

デフォルトでは、双方向 RP により、すべてのグループが双方向としてアドバタイズされます。RP のアクセス リストを使用して、双方向としてアドバタイズされるグループのリストを指定します。deny キーワードを使用したグループは、デンス モードで動作します。単一のアクセス リストでは、permit キーワードまたは deny キーワードのどちらかだけを使用できるため、スパースモードで動作するグループには、非双方向の異なる RP アドレスが必要です。

次に、スパースモードおよび双方向モードの両方のグループの RP を設定する例を示します。224/8 と 227/8 は双方向のグループ、226/8 はスパース モード、225/8 はデンス モードです。スパース モードおよび双方向モードの動作において異なる IP アドレスを使用するには、RP を設定する必要があります。また、この設定を可能にするために 2 つのループバック インターフェイスが使用されており、PIM ドメイン内の他のルータでの Auto-RP アナウンスの受信と RP との通信を可能にするために、これらのインターフェイスのアドレスを PIM ドメイン全体にルーティングする必要があります。

ip multicast-routing !Enable IP multicast routing
ip pim bidir-enable !Enable bidir-PIM
!
interface loopback 0
description One Loopback address for this routers Bidir Mode RP function
ip address 10.0.1.1 255.255.255.0
ip pim sparse-dense-mode
!
interface loopback 1
description One Loopback address for this routers Sparse Mode RP function
ip address 10.0.2.1 255.255.255.0
ip pim sparse-dense-mode
ip pim send-rp-announce Loopback0 scope 10 group-list 45 bidir
ip pim send-rp-announce Loopback1 scope 10 group-list 46
ip pim send-rp-discovery scope 10
access-list 45 permit 224.0.0.0 0.255.255.255
access-list 45 permit 227.0.0.0 0.255.255.255
access-list 45 deny 225.0.0.0 0.255.255.255
access-list 46 permit 226.0.0.0 0.255.255.255

単一スタティック RP を使用するスパース モードの例

次に、すべてのマルチキャスト グループの PIM RP アドレスを 192.168.1.1 に設定し、すべてのグループがスパース モードで動作するように定義する例を示します。

ip multicast-routing
interface ethernet 1
ip pim sparse-mode
ip pim rp-address 192.168.1.1
no ip pim dm-fallback

) 双方向モードおよびスパース モードの両方のグループに対して同じ RP は使用できません。


次に、マルチキャスト グループ 225.2.2.2 についてのみ PIM RP アドレスを 172.16.1.1 に設定する例を示します。

access list 1 225.2.2.2 0.0.0.0
ip pim rp-address 172.17.1.1

Auto-RP を使用するスパース モードの例

次の例では、Auto-RP でスパース モードを設定しています。

ip multicast-routing
ip pim autorp listener
ip pim send-rp-announce Loopback0 scope 16 group-list 1
ip pim send-rp-discovery Loopback1 scope 16
no ip pim dm-fallback
access-list 1 permit 239.254.2.0 0.0.0.255
access-list 1 permit 239.254.3.0 0.0.0.255
.
.
access-list 10 permit 224.0.1.39
access-list 10 permit 224.0.1.40
access-list 10 permit 239.254.2.0 0.0.0.255
access-list 10 permit 239.254.3.0 0.0.0.255