Catalyst 4500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース IOS XE 3.4.0SG および IOS 15.1(2)SG
EtherChannel およびリンク ステート トラッキングの設定
EtherChannel およびリンク ステート トラッキングの設定
発行日;2013/05/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 22MB) | フィードバック

目次

EtherChannel およびリンク ステート トラッキングの設定

EtherChannel について

ポート チャネル インターフェイス

EtherChannel の設定

EtherChannel の設定の概要

EtherChannel の手動設定

PAgP EtherChannel の設定

IEEE 802.3ad LACP EtherChannel の設定

ロード バランシング

EtherChannel 設定時の注意事項および制約事項

EtherChannel の設定

レイヤ 3 EtherChannel の設定

ポートチャネル論理インターフェイスの作成

物理インターフェイスのレイヤ 3 EtherChannel としての設定

レイヤ 2 EtherChannel の設定

スタンドアロン LACP 設定または独立モード

LACP のシステム プライオリティおよびシステム ID の設定

EtherChannel ロード バランシングの設定

EtherChannel からのインターフェイスの削除

EtherChannel の削除

EtherChannel の Virtual Switch System への表示

VSS クライアントの概要

仮想スイッチ システム

デュアルアクティブ シナリオ

拡張 PAgP を使用したデュアル アクティブ検出

EtherChannel リンクの VSS への表示

リンクステート トラッキングの概要

リンクステート トラッキングの設定

デフォルトのリンクステート トラッキングの設定

リンクステート トラッキングの設定時の注意事項

リンクステート トラッキングの設定

リンクステート トラッキング ステータスの表示

EtherChannel およびリンク ステート トラッキングの設定


) Supervisor 6-E、Supervisor 6L-E、Catalyst 4900M および Catalyst 4948-E は、EtherChannel 経由でのすべての IPv6 ファースト ホップ セキュリティ機能(DHCPv6 インスペクション/ガード、レイヤ 2 の DHCPv6 リモート ID オプション、IPv6 の「完全な」RA ガードなど)についてハードウェア CoPP をサポートしません。これらの機能が EtherChannel インターフェイスに直接適用されるか、EtherChannel のポートで適用されるか、または EtherChannel が属する VLAN 経由で適用されるかの場合、それらは機能しません。


この章では、コマンドライン インターフェイス(CLI)を使用して Catalyst 4500 シリーズ スイッチ レイヤ 2 またはレイヤ 3 インターフェイス上で EtherChannel を設定する方法について説明します。設定上の注意事項、設定手順、および設定例についても示します。

EtherChannel は、他のリンクに負荷を再分散させることによって、リンク切断から自動的に回復します。リンク障害が発生した場合、EtherChannel は自動的に障害リンクからチャネル内の他のリンクにトラフィックをリダイレクトします。この章では、リンクステート トラッキングを設定する方法についても説明します。

この章の主な内容は、次のとおりです。

「EtherChannel について」

「EtherChannel 設定時の注意事項および制約事項」

「EtherChannel の設定」

「EtherChannel の Virtual Switch System への表示」

「リンクステート トラッキングの概要」

「リンクステート トラッキングの設定」


) 以降のコマンドは、スーパーバイザ エンジンのアップリンク ポートを含む Catalyst 4500 シリーズ スイッチ上のすべてのイーサネット インターフェイスで使用できます。



) この章で使用するスイッチ コマンドの構文および使用方法の詳細については、次の URL で『Cisco Catalyst 4500 Series Switch Command Reference』と関連資料を参照してください。

http://www.cisco.com/en/US/products//hw/switches/ps4324/index.html

『Catalyst 4500 Series Switch Command Reference』に掲載されていないコマンドについては、より詳細な Cisco IOS ライブラリを参照してください。次の URL で『Cisco IOS Command Referenceと関連資料を参照してください。

http://www.cisco.com/en/US/products/ps6350/index.html


EtherChannel について

EtherChannel は最大 8 個の個別イーサネット リンクを、Catalyst 4500 または 4500X シリーズ スイッチと別のスイッチまたはホスト間に最高 800 Mbps(ファスト EtherChannel)、8 Gbps(ギガビット EtherChannel)、または 80 Gbps(10 ギガビット EtherChannel)の集約帯域幅を提供する単一の論理リンクにバンドルします。


) 一部のラインカードは、バックプレーンへの最大帯域幅容量を持つため、EtherChannel のメンバが同じラインカードに属する場合に、EtherChannel の集約帯域幅を制限できます。


Catalyst 4500 シリーズ スイッチ は、最大 64 個の EtherChannel をサポートしています。Catalyst 4500 シリーズ スイッチにある複数のモジュール上の(設定に互換性のある)イーサネット インターフェイスを 8 つまで使用して、1 つの EtherChannel を形成できます。各 EtherChannel のすべてのインターフェイスは同じ速度で、レイヤ 2 またはレイヤ 3 インターフェイスとして設定されている必要があります。


) Catalyst 4500 シリーズ スイッチに接続するネットワーク デバイスによって、1 つの EtherChannel にバンドルできるインターフェイス数が制限される場合があります。


EtherChannel 内のセグメントで障害が発生すると、障害リンク上でそれまで伝送されていたトラフィックがその EtherChannel 内の残りのセグメントに切り替えられます。セグメントに障害が発生すると、スイッチ、EtherChannel、障害リンクを特定する Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)トラップが送信されます。EtherChannel の 1 つのセグメントに着信したブロードキャストおよびマルチキャスト パケットが、EtherChannel の別のセグメントに戻されることはありません。


) Catalyst 4500 シリーズ スイッチのポート チャネル リンク障害のスイッチオーバーには、50 ミリ秒かかり、SONET のようなリンク障害のスイッチオーバー時間を提供します。


ここでは、EtherChannel の機能について説明します。

「ポート チャネル インターフェイス」

「EtherChannel の設定」

「ロード バランシング」

ポート チャネル インターフェイス

各 EtherChannel には、番号付きのポート チャネル インターフェイスが 1 つずつあります。ポート チャネル インターフェイスに適用される設定は、そのインターフェイスに割り当てられたすべての物理インターフェイスに影響します。


) QoS(Quality of Service)はメンバに伝播しません。デフォルトは QoS cos = 0 および QoS dscp = 0 で、ポート チャネルに適用されます。個々のインターフェイスに適用される入力および出力ポリシーは無視されます。


EtherChannel を設定したあとで、ポート チャネル インターフェイスに適用する設定は、EtherChannel に対して有効になります。一方、物理インターフェイスに適用する設定は、適用先のインターフェイスだけに有効です。EtherChannel のすべてのポートのパラメータを変更するには、ポート チャネル インターフェイスに対してコンフィギュレーション コマンドを適用してください(このようなコマンドには、Spanning-Tree Protocol(STP; スパニングツリー プロトコル)コマンドや、レイヤ 2 EtherChannel をトランクとして設定するコマンドがあります)。

EtherChannel の設定

ここでは、EtherChannel の設定方法について説明します。

「EtherChannel の設定の概要」

「EtherChannel の手動設定」

「PAgP EtherChannel の設定」

「IEEE 802.3ad LACP EtherChannel の設定」

EtherChannel の設定の概要

EtherChannel を形成するには、EtherChannel を手動で設定するか、Port Aggregation Control Protocol(PAgP)または Link Aggregation Control Protocol(LACP)(Cisco IOS Release 12.2(25)EWA以降)を使用できます。EtherChannel プロトコルを使用すると、接続先のネットワーク デバイスとダイナミックにネゴシエーションを行うことにより、同様な特性を持つポートが EtherChannel を形成できます。PAgP はシスコ システムズ独自のプロトコルであり、LACP は IEEE 802.3ad で定義されています。

PAgP と LACP は相互動作しません。PAgP を使用するように設定されたポートは、LACP を使用するように設定されたポートと EtherChannel を形成できず、その逆もまた不可能です。

表 25-1 に、ユーザ設定可能な EtherChannel モードを示します。

 

表 25-1 EtherChannel のモード

モード
説明

on

LAN ポートを無条件かつ強制的にチャネル化するモード。 on モードでは、 on モードの LAN ポート グループが、 on モードの別の LAN ポート グループに接続されている場合にだけ、使用可能な EtherChannel が存在します。 on モードで設定されたポートはネゴシエーションを行わないため、ポート間のネゴシエーション トラフィックはありません。

auto

PAgP モード。LAN ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した PAgP パケットには応答しますが、PAgP ネゴシエーションは開始しません。

desirable

PAgP モード。LAN ポートをアクティブ ネゴシエーション ステートにします。ポートは PAgP パケットを送信して、他の LAN ポートとのネゴシエーションを開始します。

passive

LACP モード。ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した LACP パケットには応答しますが、LCAP ネゴシエーションは開始しません。

active

LACP モード。ポートをアクティブ ネゴシエーション ステートにします。ポートは LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

EtherChannel の手動設定

手動で設定された EtherChannel ポートは、EtherChannel プロトコル パケットを交換しません。EtherChannel 内のすべてのポートを互換性がある設定にした場合のみ、手動で設定された EtherChannel が形成されます。

PAgP EtherChannel の設定

PAgP を使用すると、LAN ポート間で PAgP パケットを交換することにより、EtherChannel を自動的に作成できます。PAgP パケットが交換されるのは、 auto モードおよび desirable モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能を動的に「学習」して、他の LAN ポートに通知します。PAgP は、正確に一致しているイーサネット リンクを識別すると、これらのリンクを 1 つの EtherChannel としてまとめます。その後、その EtherChannel が単一のブリッジ ポートとしてスパニングツリーに追加されます。

PAgP は、 auto モードおよび desirable モードでの両方で LAN ポート間のネゴシエーションを行い、ポート速度、トランキング ステートなどの基準に基づいて LAN ポートが EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel は VLAN 番号も使用します。

LAN ポート間で PAgP モードが異なっていても、モード間で互換性がある限り、EtherChannel を形成できます。次に例を示します。

desirable モードの LAN ポートは、 desirable モードの別の LAN ポートと EtherChannel を形成できます。

desirable モードの LAN ポートは、 auto モードの別の LAN ポートと EtherChannel を形成できます。

auto モードの LAN ポートは、双方のポートがネゴシエーションを開始しないため、 auto モードの他の LAN ポートと EtherChannel を形成できません。

IEEE 802.3ad LACP EtherChannel の設定

Cisco IOS Release 12.2(25)EWA 以降のリリースは、IEEE 802.3ad LACP EtherChannel をサポートしています。LACP では、LAN ポート間で LACP パケットを交換することによって、EtherChannel の自動作成をサポートしています。LACP パケットが交換されるのは、 passive および active モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能を動的に「学習」して、他の LAN ポートに通知します。LACP は、正確に一致しているイーサネット リンクを識別すると、それらのリンクを 1 つの EtherChannel としてまとめます。その後、その EtherChannel が単一のブリッジ ポートとしてスパニングツリーに追加されます。

passive モードおよび active モードでは、LACP は LAN ポート間でネゴシエーションを行い、ポート速度、トランキング ステートなどの一定の基準に従って EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel は VLAN 番号も使用します。

LAN ポート間で LACP モードが異なっていても、モード間で互換性がある限り、EtherChannel を形成できます。次に例を示します。

active モードの LAN ポートは、 active モードの別の LAN ポートと EtherChannel を形成できます。

active モードの LAN ポートは、 passive モードの別の LAN ポートと EtherChannel を形成できます。

passive モードの LAN ポートは、双方のポートがネゴシエーションを開始しないため、 passive モードの他の LAN ポートと EtherChannel を形成できません。

LACP では次のパラメータを使用します。

LACP システム プライオリティ:LACP が動作する各スイッチ上で、LACP システム プライオリティを設定できます。システム プライオリティは、自動的に設定することも、CLI を使用して設定することもできます。「LACP のシステム プライオリティおよびシステム ID の設定」を参照してください。LACP は、システム プライオリティとスイッチの MAC アドレスを組み合わせてシステム ID を形成します。また、これを他のシステムとのネゴシエーション時にも使用します。


LACP システム ID は、LACP システム プライオリティ値とスイッチの MAC アドレスを組み合わせたものです。


LACP ポート プライオリティ:LACP を使用するように設定されたポートごとに、LACP ポート プライオリティを設定する必要があります。ポート プライオリティは、自動的に設定することも、CLI を使用して設定することもできます。「レイヤ 2 EtherChannel の設定」を参照してください。LACP はポート プライオリティとポート番号を使用してポート ID を形成します。

LACP 管理キー:LACP は、LACP を使用するように設定されたポートごとに、チャネル グループ ID 番号と同じ管理キー値を自動的に設定します。管理用のキーは、ポートが他のポートと集約できる能力を定義します。他のポートとの集約を行うポートの能力は、次の要因によって決まります。

データ レート、デュプレックス機能、ポイントツーポイントや共有メディアなどのポートの物理特性

ユーザによる設定に関する制限事項

LACP は、最大数の互換ポートを EtherChannel に設定しようとします(ハードウェア上の最大許容数は 8 ポートです)。ポートをチャネルにアクティブとして組み込めない場合は、チャネル ポートで障害が発生した場合にも自動的に組み込まれません。


) スタンバイおよび「サブチャネル化」は LACP および PAgP でサポートされません。


ロード バランシング

EtherChannel は、チャネルのリンクに対するトラフィック負荷のバランスを取ります。つまり EtherChannel は、フレーム内のアドレスやポートで構成されるバイナリ パターンの一部を数値化し、チャネル内のリンクの 1 つを選択します。負荷のバランスを取るために、EtherChannel は、MAC アドレス、IP アドレス、またはレイヤ 4 ポート番号と、メッセージの送信元、メッセージの宛先、または両方を使用します。

設定で一番種類が多くなるオプションを使用してください。たとえば、チャネルのトラフィックが単一の MAC アドレスのみに送信される場合、宛先 MAC アドレスを使用すると、常にチャネル内の同じリンクが選択されてしまいます。送信元アドレスまたは IP アドレスを使用する方が、ロード バランシングの効果が上がります。


) ロード バランシングは、グローバルにのみ設定可能です。したがって、すべてのチャネル(手動設定、PAgP、または LACP)は同じロード バランシング方式を使用します。


ロード バランシングについての詳細は、「EtherChannel ロード バランシングの設定」を参照してください。

EtherChannel 設定時の注意事項および制約事項

EtherChannel インターフェイスの設定に問題があると、ネットワーク ループなどの問題を回避するために、EtherChannel インターフェイスが自動的にディセーブルになります。次の注意事項と制約事項に従って、設定時に問題が起こらないようにしてください。

すべてのモジュールのイーサネット インターフェイスはすべて、物理的に連続しているかまたは同一モジュール上といったインターフェイスに関する要件のない EtherChannel(最大 8 つのインターフェイス)をサポートしています。

EtherChannel のすべてのインターフェイスを、同じ速度およびデュプレックス モードで動作するように設定します。

EtherChannel のすべてのインターフェイスをイネーブルにします。EtherChannel 内のインターフェイスをディセーブルにすると、リンク障害として処理され、そのインターフェイスのトラフィックが EtherChannel 内の残りのインターフェイスの 1 つに転送されます。

インターフェイスの 1 つがスイッチド ポート アナライザ(SPAN)宛先ポートの場合、EtherChannel は形成されません。

レイヤ 3 EtherChannel の場合

レイヤ 3 アドレスを、チャネルの物理インターフェイスではなく、ポート チャネルの論理インターフェイスに割り当てます。

レイヤ 2 EtherChannel の場合

EtherChannel 内のすべてのインターフェイスを同じ VLAN に割り当てるか、またはトランクとして設定してください。

トランク インターフェイスから EtherChannel を設定する場合は、すべてのトランクでトランキング モードとネイティブ VLAN が同じであることを確認してください。EtherChannel のインターフェイスのトランク モードが異なる、またはネイティブ VLAN が異なる場合、予期しない結果を招くことがあります。

EtherChannel は、トランキング レイヤ 2 EtherChannel 内のすべてのインターフェイスで同じ許容範囲の VLAN をサポートしています。選択したインターフェイスの許容範囲が異なる場合、インターフェイスは EtherChannel を形成しません。

STP ポート パス コストが異なるインターフェイスは、互換性がある設定を行っている限り、EtherChannel を形成できます。異なる STP ポート パス コストを設定しても、EtherChannel のインターフェイスの互換性は損なわれません。

EtherChannel を設定したあとで、ポート チャネル インターフェイスに適用するすべての設定は、EtherChannel に対して有効になります。一方、物理インターフェイスに適用するすべての設定は、設定するインターフェイスだけに有効です。

ストーム制御はこの規則の例外です。たとえば、EtherChannel の一部のメンバにストーム制御を設定することはできません。ストーム制御はすべてのポートに対して設定するか、設定しないかのどちらかにする必要があります。一部のポートだけにストーム制御を設定した場合は、それらのポートが EtherChannel インターフェイスからドロップされます(suspended ステートになります)。ストーム制御は物理インターフェイス レベルではなく、ポート チャネル インターフェイス レベルで設定してください。

ポート セキュリティがイネーブルである物理インターフェイスは、ポート セキュリティが EtherChannel 上でもイネーブルである場合にのみ、レイヤ 2 EtherChannel に加入できます。イネーブルでない場合、コマンドは CLI によって拒否されます。

802.1X ポートに EtherChannel は設定できません。

EtherChannel の設定

ここでは、EtherChannel を設定する手順について説明します。

「レイヤ 3 EtherChannel の設定」

「レイヤ 2 EtherChannel の設定」

「スタンドアロン LACP 設定または独立モード」

「LACP のシステム プライオリティおよびシステム ID の設定」

「EtherChannel ロード バランシングの設定」

「EtherChannel からのインターフェイスの削除」

「EtherChannel の削除」


) インターフェイスが正しく設定されていることを確認してください。「EtherChannel 設定時の注意事項および制約事項」を参照してください。


レイヤ 3 EtherChannel の設定

レイヤ 3 EtherChannel を設定するには、ポート チャネル論理インターフェイスを作成し、イーサネット インターフェイスをポート チャネルにします。

ここでは、レイヤ 3 EtherChannel の設定について説明します。

「ポートチャネル論理インターフェイスの作成」

「物理インターフェイスのレイヤ 3 EtherChannel としての設定」

ポートチャネル論理インターフェイスの作成


) IP アドレスを物理インターフェイスから EtherChannel に移動させるには、ポート チャネル インターフェイスを設定する前に物理インターフェイスから IP アドレスを削除する必要があります。


レイヤ 3 EtherChannel 用のポート チャネル インターフェイスを作成するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# interface port-channel port_channel_number

ポート チャネル インターフェイスを作成します。 port_channel _number の値の範囲は 1 ~ 64 です。

ステップ 2

Switch(config-if)# ip address ip_address mask

EtherChannel に IP アドレスおよびサブネット マスクを割り当てます。

ステップ 3

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Switch# show running-config interface port-channel port_channel_number

設定を確認します。

次に、インターフェイス Port-channel 1 を作成する例を示します。

Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# ip address 172.32.52.10 255.255.255.0
Switch(config-if)# end
 

次に、インターフェイス Port-channel 1 の設定を確認する例を示します。

Switch# show running-config interface port-channel 1
Building configuration...
 
Current configuration:
!
interface Port-channel1
ip address 172.32.52.10 255.255.255.0
no ip directed-broadcast
end
 
Switch#

物理インターフェイスのレイヤ 3 EtherChannel としての設定

物理インターフェイスをレイヤ 3 EtherChannel として設定するには、各インターフェイスで次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port

設定する物理インターフェイスを選択します。

ステップ 2

Switch(config-if)# no switchport

このインターフェイスをレイヤ 3 ルーテッド ポートにします。

ステップ 3

Switch(config-if)# no ip address

この物理インターフェイスに IP アドレスが割り当てられていないことを確認します。

ステップ 4

Switch(config-if)# channel-group port_channel_number mode {active | on | auto | passive | desirable }

ポート チャネルでインターフェイスを設定し、PAgP または LACP モードを指定します。

PAgP を使用する場合、キーワード auto または desirable を入力します。

LACP を使用する場合は、キーワード active または passive を入力します。

ステップ 5

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 6

Switch# show running-config interface port-channel port_channel_number
 
Switch# show running-config interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port
 
Switch# show interfaces { fastethernet | gigabitethernet | tengigabitethernet } slot / port etherchannel
 
Switch# show etherchannel 1 port-channel

設定を確認します。

次に、ファスト イーサネット インターフェイス 5/4 および 5/5 を、ポート チャネル 1、PAgP モード desirable に設定する例を示します。

Switch# configure terminal
Switch(config)# interface range fastethernet 5/4 - 5 (Note: Space is mandatory.)
Switch(config-if)# no switchport
Switch(config-if)# no ip address
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# end

range キーワードの詳細については、「インターフェイス範囲の設定」を参照してください。


次に、ファスト イーサネット インターフェイス 5/4 の設定を確認する例を 2 つ示します。

Switch# show running-config interface fastethernet 5/4
Building configuration...
 
Current configuration:
!
interface FastEthernet5/4
no ip address
no switchport
no ip directed-broadcast
channel-group 1 mode desirable
end
 
Switch# show interfaces fastethernet 5/4 etherchannel
Port state = EC-Enbld Up In-Bndl Usr-Config
Channel group = 1 Mode = Desirable Gcchange = 0
Port-channel = Po1 GC = 0x00010001 Pseudo-port-channel = Po1
Port indx = 0 Load = 0x55
 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
 
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/4 SC U6/S7 30s 1 128 Any 55
 
Partner's information:
 
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa5/4 JAB031301 0050.0f10.230c 2/45 1s SAC 2D
 
Age of the port in the current state: 00h:54m:52s
 
Switch#
 

次に、インターフェイス ポート チャネル 1 を設定したあとで、インターフェイスの設定を確認する例を示します。

Switch# show etherchannel 1 port-channel
 
Channel-group listing:
----------------------
Group: 1
------------
 
Port-channels in the group:
----------------------
Port-channel: Po1
------------
 
Age of the Port-channel = 01h:56m:20s
Logical slot/port = 10/1 Number of ports = 2
GC = 0x00010001 HotStandBy port = null
Port state = Port-channel L3-Ag Ag-Inuse
 
Ports in the Port-channel:
 
Index Load Port
-------------------
1 00 Fa5/6
0 00 Fa5/7
 
Time since last port bundled: 00h:23m:33s Fa5/6
 
Switch#
 

次の例では、各チャネル グループのサマリーを 1 行で表示する方法を示します。

Switch# show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
 
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
 
Number of channel-groups in use: 2
Number of aggregators: 2
 
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SD) LACP Gi1/23(H) Gi1/24(H)
Switch#

レイヤ 2 EtherChannel の設定

レイヤ 2 EtherChannel を設定するには、 channel-group コマンドでイーサネット インターフェイスを設定します。この操作は、ポート チャネル論理インターフェイスを作成します。


channel-group コマンドでレイヤ 2 イーサネット インターフェイスを設定すると、Cisco IOS ソフトウェアはレイヤ 2 EtherChannel のポート チャネル インターフェイスを作成します。


レイヤ 2 イーサネット インターフェイスをレイヤ 2 EtherChannel として設定するには、各インターフェイスで次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port

設定する物理インターフェイスを選択します。

ステップ 2

Switch(config-if)# channel-group port_channel_number mode {active | on | auto | passive | desirable }

ポート チャネルでインターフェイスを設定し、PAgP または LACP モードを指定します。

PAgP を使用する場合、キーワード auto または desirable を入力します。

LACP を使用する場合は、キーワード active または passive を入力します。

ステップ 3

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Switch# show running-config interface { fastethernet | gigabitethernet } slot / port
 
Switch# show interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port etherchannel

設定を確認します。

次に、ファスト イーサネット インターフェイス 5/6 および 5/7 を、ポート チャネル 2、PAgP モード desirable に設定する例を示します。

Switch# configure terminal
Switch(config)# interface range fastethernet 5/6 - 7 (Note: Space is mandatory.)
Switch(config-if-range)# channel-group 2 mode desirable
Switch(config-if-range)# end
Switch# end

range キーワードの詳細については、「インターフェイス範囲の設定」を参照してください。


次に、インターフェイス Port-channel 2 の設定を確認する例を示します。

Switch# show running-config interface port-channel 2
Building configuration...
 
Current configuration:
!
interface Port-channel2
switchport access vlan 10
switchport mode access
end
 
Switch#
 

次に、ファスト イーサネット インターフェイス 5/6 の設定を確認する例を 2 つ示します。

Switch# show running-config interface fastethernet 5/6
Building configuration...
 
Current configuration:
!
interface FastEthernet5/6
switchport access vlan 10
switchport mode access
channel-group 2 mode desirable
end
 
Switch# show interfaces fastethernet 5/6 etherchannel
Port state = EC-Enbld Up In-Bndl Usr-Config
Channel group = 1 Mode = Desirable Gcchange = 0
Port-channel = Po1 GC = 0x00010001
Port indx = 0 Load = 0x55
 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa5/6 SC U6/S7 30s 1 128 Any 56
 
Partner's information:
 
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa5/6 JAB031301 0050.0f10.230c 2/47 18s SAC 2F
 
Age of the port in the current state: 00h:10m:57s
 

次に、インターフェイス ポート チャネル 2 を設定したあとで、インターフェイスの設定を確認する例を示します。

Switch# show etherchannel 2 port-channel
Port-channels in the group:
----------------------
 
Port-channel: Po2
------------
 
Age of the Port-channel = 00h:23m:33s
Logical slot/port = 10/2 Number of ports in agport = 2
GC = 0x00020001 HotStandBy port = null
Port state = Port-channel Ag-Inuse
 
Ports in the Port-channel:
 
Index Load Port
-------------------
1 00 Fa5/6
0 00 Fa5/7
 
Time since last port bundled: 00h:23m:33s Fa5/6
 
Switch#

スタンドアロン LACP 設定または独立モード

この機能は、レイヤ 2 LACP EtherChannel 内のポート(A)がピアの応答しないポート(B)に接続するときに特に関連しています。スタンドアロン LACP が EtherChannel でディセーブルの場合、A に到着したすべてのトラフィックがブロックされます(スイッチのデフォルト動作)。一部のシナリオでは、このようなポートに管理トラフィックを許可する場合があります。LACP のスタンドアロン(または独立した)モードをイネーブルにすると、この操作を実行できます。


) このport-channel standalone-disable コマンドはレイヤ 2 EtherChannel だけに適用されます。



) LACP のスタンドアロン ディセーブルはデフォルトでイネーブルです。


スタンドアロン LACP または独立モードを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# no port-channel standalone-disable
 
 
Switch(config)# port-channel standalone-disable

スタンドアロン LACP または独立モードをイネーブルにします。

デフォルト値に戻します。

ステップ 2

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 3

Switch# show running configuration { fastethernet | gigabitethernet } slot / port port-channel port_channel_number

設定を確認します。

次に、スタンドアロン LACP モードを設定する例を示します。

Switch# configure terminal
Switch(config)# interface port-channel 1
Switch(config-if)# switchport
Switch(config-if)# exit
Switch(config)# int gi3/1
Switch(config-if)# channel-group 1 mode active
Switch(config-if)# exit
Switch(config)# interface port-channel 1
Switch(config-if)# no port-channel standalone-disable
Ports of Po12 already in suspend (S) mode require a shut/no shut.
Switch(config-if)# end
 

次に、インターフェイス Port-channel 1 の設定を確認する例を示します。

Switch# show running-config interface port-channel 1
Building configuration...
 
Current configuration:
!
interface Port-channel1
switchport
no port-channel standalone-disable
end
 
Switch#
 

次に、インターフェイス Port-channel 1 の状態を確認する例を示します。

Switch# show etherchannel 1 port-channel
Port-channels in the group:
---------------------------
Port-channel: Po13 (Primary Aggregator)
------------
Age of the Port-channel = 0d:00h:07m:57s
Logical slot/port = 11/13 Number of ports = 0
Port state = Port-channel Ag-Not-Inuse
Protocol = LACP
Port security = Disabled
Standalone = Enabled (independent mode)
Switch#

LACP のシステム プライオリティおよびシステム ID の設定

LACP システム ID は、LACP システム プライオリティ値とスイッチの MAC アドレスを組み合わせたものです。

LACP システム プライオリティおよびシステム ID を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# lacp system-priority priority_value

(LACP で任意)LACP システム プライオリティおよびシステム ID を設定します。

有効な値は 1 ~ 65535 です。値が大きいほど、プライオリティは低くなります。デフォルトは 32768 です。

Switch(config)# no system port-priority

デフォルト値に戻します。

ステップ 2

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Switch# show lacp sys-id

設定を確認します。

次に、LACP のシステム プライオリティを設定する例を示します。

Switch# configure terminal
Switch(config)# lacp system-priority 23456
Switch(config)# end
Switch# show module
 
Mod Ports Card Type Model Serial No.
----+-----+--------------------------------------+-----------------+-----------
1 2 1000BaseX (GBIC) Supervisor(active) WS-X4014 JAB063808YZ
2 48 10/100BaseTX (RJ45) WS-X4148-RJ JAB0447072W
3 48 10/100BaseTX (RJ45)V WS-X4148-RJ45V JAE061704J6
4 48 10/100BaseTX (RJ45)V WS-X4148-RJ45V JAE061704ML
 
M MAC addresses Hw Fw Sw Status
--+--------------------------------+---+------------+----------------+---------
1 0005.9a39.7a80 to 0005.9a39.7a81 2.1 12.1(12r)EW 12.1(13)EW(0.26) Ok
2 0002.fd80.f530 to 0002.fd80.f55f 0.1 Ok
3 0009.7c45.67c0 to 0009.7c45.67ef 1.6 Ok
4 0009.7c45.4a80 to 0009.7c45.4aaf 1.6 Ok
 

次に、設定を確認する例を示します。

Switch# show lacp sys-id
23456,0050.3e8d.6400
Switch#
 

システム プライオリティが最初に表示され、次にスイッチの MAC アドレスが表示されます。

EtherChannel ロード バランシングの設定


) ロード バランシングは、グローバルにのみ設定可能です。したがって、すべてのチャネル(手動設定、PAgP、または LACP)は同じロード バランシング方式を使用します。


EtherChannel ロード バランシングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# [ no ] port-channel load-balance { src-mac | dst-mac | src-dst-mac | src-ip | dst-ip | src-dst-ip | src-port | dst-port | src-dst-port }

EtherChannel ロードバランスを設定します。

EtherChannel ロード バランシングをデフォルト設定に戻すには、 no キーワードを使用します。

ステップ 2

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Switch# show etherchannel load-balance

設定を確認します。

ロードバランシングのキーワードは次の値を示します。

src-mac :送信元の MAC アドレス

dst-mac :宛先 MAC アドレス

src-dst-mac :送信元および宛先の MAC アドレス

src-ip :送信元の IP アドレス

dst-ip :宛先 IP アドレス

src-dst-ip :送信元および宛先 IP アドレス(デフォルト)

src-port :送信元のレイヤ 4 ポート

dst-port :宛先レイヤ 4 ポート

src-dst-port :送信元および宛先のレイヤ 4 ポート

次に、送信元および宛先 IP アドレスを使用するように EtherChannel を設定する例を示します。

Switch# configure terminal
Switch(config)# port-channel load-balance src-dst-ip
Switch(config)# end
Switch#
 

次に、設定を確認する例を示します。

Switch# show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
src-dst-ip
 
EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source XOR Destination MAC address
IPv4: Source XOR Destination IP address
IPv6: Source XOR Destination IP address
Switch#

EtherChannel からのインターフェイスの削除

EtherChannel からイーサネット インターフェイスを削除するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port

設定する物理インターフェイスを選択します。

ステップ 2

Switch(config-if)# no channel-group

ポート チャネル インターフェイスからインターフェイスを削除します。

ステップ 3

Switch(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Switch# show running-config interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port
Switch# show interface { fastethernet | gigabitethernet | tengigabitethernet } slot / port etherchannel

設定を確認します。

次に、ファスト イーサネット インターフェイス 5/4 および 5/5 を、ポート チャネル 1 から削除する例を示します。

Switch# configure terminal
Switch(config)# interface range fastethernet 5/4 - 5 (Note: Space is mandatory.)
Switch(config-if)# no channel-group 1
Switch(config-if)# end

EtherChannel の削除

EtherChannel を削除すると、メンバ ポートがシャットダウンされ、チャネル グループから削除されます。


) EtherChannel をレイヤ 2 からレイヤ 3 に、またはレイヤ 3 からレイヤ 2 に変更する場合、EtherChannel を削除し、適切な設定で再び作成する必要があります。


EtherChannel を削除するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Switch(config)# no interface port-channel port_channel_number

ポート チャネル インターフェイスを削除します。

ステップ 2

Switch(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Switch# show etherchannel summary

設定を確認します。

次に、ポート チャネル 1 を削除する例を示します。

Switch# configure terminal
Switch(config)# no interface port-channel 1
Switch(config)# end

EtherChannel の Virtual Switch System への表示

Catalyst 4500 シリーズ スイッチは拡張 PAgP をサポートします。Catalyst 4500 シリーズ スイッチが PAgP EtherChannel を使用して Catalyst 6500 シリーズ Virtual Switch System(VSS)に接続されている場合は、Catalyst 4500 シリーズ スイッチが、自動的に、デュアルアクティブ検出用のこの EtherChannel 上で拡張 PAgP を使用して、VSS クライアントになります。この VSS クライアント機能は、Catalyst 4500 シリーズ スイッチのパフォーマンスに影響を与えることはなく、ユーザによる設定も必要ありません。

ここでは、次の内容について説明します。

「VSS クライアントの概要」

「EtherChannel リンクの VSS への表示」

VSS クライアントの概要

ここでは、次の内容について説明します。

「仮想スイッチ システム」

「デュアルアクティブ シナリオ」

「拡張 PAgP を使用したデュアル アクティブ検出」

仮想スイッチ システム

Cisco Catalyst 6500 シリーズ VSS 1440 は、ネットワーク コントロール プレーンおよび管理の観点から、1 つの論理ネットワーク エンティティに、2 つの Cisco Catalyst 6500 シリーズ スイッチを組み合わせることができます。Cisco VSS では、1 つのシャーシがアクティブな仮想スイッチに指定され、システム全体における 1 つの管理ポイントとして動作します。その他のシャーシはスタンバイ仮想スイッチに指定されます。2 つのシャーシは、Virtual Switch Link(VSL)と呼ばれる特別なリンクで 1 つにバインドされています。VSL は 2 つのシャーシ間の内部信号および制御情報を伝送します。

デュアルアクティブ シナリオ

VSS での障害シナリオの 1 つは デュアルアクティブと呼ばれ、VSL に全面的な障害が生じた場合に発生します。どちらの仮想スイッチも他のステータスを認識できません。アクティブ仮想スイッチの観点からは、スタンバイ シャーシを認識できなくなります。スタンバイ仮想スイッチも、アクティブなシャーシに障害が発生したものと見なし、SSO スイッチオーバーを使用してアクティブ ステートに移行します。同じ構成のアクティブ仮想スイッチがネットワーク上に 2 つ存在することになり、IP アドレスとブリッジ ID が重複します。このシナリオが続くと、ネットワーク トポロジおよびトラフィックに悪影響を及ぼします。

拡張 PAgP を使用したデュアル アクティブ検出

デュアルアクティブ シナリオを検出する方法の 1 つは、拡張 PAgP(PAgP+)に基づくものです。特に VSS は、現在のアクティブ仮想スイッチの ID を含む Type-Length-Value(TLV)を使用して、スケジュールされた PAgP メッセージを定期的に送信します(図 25-1)。VSL が全面的な障害が生じると、スタンバイ仮想スイッチは、拡張 PAgP デュアルアクティブ検出がイネーブルになっているすべてのポート チャネルで、自身の ID を含めた TLV を使用して非同期 PAgP メッセージを即時に送信します(図 25-2)。EtherChannel リンク経由で両方の VSS コンポーネントに接続されたリモート スイッチ
(VSS クライアント)は、受信したすべてのアクティブ ID と保存されているアクティブ ID を比較します。アクティブ ID が一致した場合、リモート スイッチは格納されたアクティブ ID を含む TLV を、定期的にスケジュールされた PAgP メッセージにある VSS に返します。アクティブ ID が一致しない場合、リモート スイッチは新しいアクティブ ID を格納し、新しいアクティブ ID を含む TLV と非同期 PAgP メッセージを即時に送信します。リモート スイッチから新しいアクティブ ID を受け取ると、元のアクティブ仮想スイッチはデュアルアクティブ シナリオを検出し、適切なアクションを実行します。

図 25-1 VSS の通常動作での拡張 PAgP

 

図 25-2 VSS のデュアルアクティブ シナリオでの拡張 PAgP

 

Catalyst 4500 シリーズ スイッチは、リモート スイッチとしてステートフル VSS クライアントをサポートします。具体的には、現在のアクティブ仮想スイッチの ID は、アクティブ スーパーバイザ エンジンから Catalyst 4500 シリーズ スイッチの冗長スーパーバイザ エンジンへ同期されます。これにより、アクティブ スーパーバイザ エンジンが冗長スーパーバイザ エンジンにスイッチオーバーするときもデュアルアクティブ検出が中断しないようにします。

EtherChannel リンクの VSS への表示

設定された PAgP ポート チャネルのデュアル アクティブ検出の機能を表示するには、show pagp port_channel_number dual-active コマンドを使用します。

コマンドは次の情報を提供します。

スイッチがデュアルアクティブ検出のために拡張 PAgP を使用するかどうか。

Catalyst 4500 スイッチでは、イネーブルになっている PAgP デュアル アクティブ表現の後に常に Yes が表示される必要があります。

設定済みの PAgP EtherChannel が Catalyst 6500 スイッチ VSS に接続しているかどうか。

この EtherChannel が VSS に接続されていない場合は、Partner Version の下に N/A が表示されます。それ以外の場合は、VSS に実装されている拡張 PAgP デュアル アクティブ検出のバージョンが表示されます。

このスイッチは、接続された VSS でデュアルアクティブ シナリオを検出できます。

設定済みの EtherChannel が、同じバージョンの拡張 PAgP デュアルアクティブ検出を使用する Catalyst 6500 シリーズ VSS に接続されている場合にのみ、Dual-Active Detect Capable の下に Yes と表示されます。


) ネイバー スイッチの名前(Partner Name)およびこの EtherChannel が接続しているポート(Partner Port)も表示されます。


Catalyst 4500 スイッチが、同じバージョンの拡張 PAgP デュアルアクティブ検出を使用する Catalyst 6500 シリーズ VSS に接続している場合、スイッチはデュアルアクティブ シナリオを検出できます。

Switch# show pagp 1 dual-active
PAgP dual-active detection enabled: Yes
PAgP dual-active version: 1.1
 
Channel group 1
Dual-Active Partner Partner Partner
Port Detect Capable Name Port Version
Gi6/5 Yes VSS Gi1/8/1 1.1
Gi6/6 Yes VSS Gi2/8/1 1.1
 

Catalyst 4500 スイッチが、Catalyst 6500 シリーズ VSS に接続していない場合、スイッチはデュアルアクティブ シナリオを検出できません。

Switch# show pagp 1 dual-active
PAgP dual-active detection enabled: Yes
PAgP dual-active version: 1.1
 
Channel group 1
Dual-Active Partner Partner Partner
Port Detect Capable Name Port Version
Gi6/5 No Switch Fa6/5 N/A
Gi6/6 No Switch Fa6/6 N/A

リンクステート トラッキングの概要

リンクステート トラッキングは、トランク フェールオーバーとも呼ばれ、複数のインターフェイスのリンクステートをバインドする機能です。たとえば、リンクステート トラッキングをサーバ NIC アダプタ チーミング機能とともに使用すると、ネットワークで冗長性が実現されます。サーバ ネットワーク アダプタが、チーミングと呼ばれるプライマリまたはセカンダリ関係で設定され、プライマリ インターフェイスでリンクが消失した場合、接続はセカンダリ インターフェイスに透過的に変更されます。

図 25-3 は、リンクステート トラッキングを使用して設定されたネットワークを示しています。リンクステート トラッキングをイネーブルにするには、 link-state group を作成し、リンクステート グループに割り当てるインターフェイスを指定します。ポートの集合(EtherChannel)、アクセス モードまたはトランク モードの単一の物理ポート、またはルーテッド ポートをインターフェイスに指定できます。リンクステート グループでは、これらのインターフェイスはまとめてバンドルされます。 ダウンストリーム インターフェイス は、 アップストリーム インターフェイス にバインドされます。サーバに接続されたインターフェイスはダウンストリーム インターフェイスと呼ばれ、ディストリビューション スイッチおよびネットワーク装置に接続されたインターフェイスはアップストリーム インターフェイスと呼ばれます。

図 25-3 の設定により、ネットワーク トラフィック フローのバランスが、次のように保たれます。

スイッチと他のネットワーク デバイスへのリンクの場合

サーバ 1 とサーバ 2 は、プライマリ リンクにスイッチ A を使用し、セカンダリ リンクにスイッチ B を使用しています。

サーバ 3 とサーバ 4 は、プライマリ リンクにスイッチ B を使用し、セカンダリ リンクにスイッチ A を使用しています。

スイッチ A のリンクステート グループ 1

スイッチ A はリンクステート グループ 1 を介して、プライマリ リンクをサーバ 1 およびサーバ 2 に使用します。ポート 1 はサーバ 1 に、ポート 2 はサーバ 2 にそれぞれ接続されます。ポート 1 およびポート 2 はリンクステート グループ 1 でダウンストリーム インターフェイスとして使用します。

ポート 5 およびポート 6 は、リンクステート グループ 1 を介して分散スイッチ 1 に接続されます。ポート 5 およびポート 6 は、リンクステート グループ 1 でアップストリーム インターフェイスとして使用します。

スイッチ A のリンクステート グループ 2

スイッチ A はリンクステートグループ 2 を介して、セカンダリ リンクをサーバ 3 およびサーバ 4 に使用します。ポート 3 はサーバ 3 に、ポート 4 はサーバ 4 にそれぞれ接続されます。ポート 3 およびポート 4 はリンクステート グループ 2 でダウンストリーム インターフェイスとして使用します。

ポート 7 およびポート 8 は、リンクステート グループ 2 を介して分散スイッチ 2 に接続されます。ポート 7 およびポート 8 は、リンクステート グループ 2 でアップストリーム インターフェイスとして使用します。

スイッチ B のリンクステート グループ 2

スイッチ B はリンクステートグループ 2 を介して、プライマリ リンクをサーバ 3 およびサーバ 4 に使用します。ポート 3 はサーバ 3 に、ポート 4 はサーバ 4 にそれぞれ接続されます。ポート 3 およびポート 4 はリンクステート グループ 2 でダウンストリーム インターフェイスとして使用します。

ポート 5 およびポート 6 は、リンクステート グループ 2 を介して分散スイッチ 2 に接続されます。ポート 5 およびポート 6 は、リンクステート グループ 2 でアップストリーム インターフェイスとして使用します。

スイッチ B のリンクステート グループ 1

スイッチ B はリンクステート グループ 1 を介して、セカンダリ リンクをサーバ 1 およびサーバ 2 に使用します。ポート 1 はサーバ 1 に、ポート 2 はサーバ 2 にそれぞれ接続されます。ポート 1 およびポート 2 はリンクステート グループ 1 でダウンストリーム インターフェイスとして使用します。

ポート 7 およびポート 8 は、リンクステート グループ 1 を介して分散スイッチ 1 に接続されます。ポート 7 およびポート 8 は、リンクステート グループ 1 でアップストリーム インターフェイスとして使用します。

分散スイッチやルータに障害が発生したり、ケーブルが切断されたり、リンクが失われたために、リンクステート グループ内でアップストリーム ポートが利用不能や接続不能になる場合があります。これらは、リンクステート トラッキングがイネーブルの際の、ダウンストリーム インターフェイスとアップストリーム インターフェイス間の相互作用です。

アップストリーム インターフェイスがリンクアップ ステートの場合、ダウンストリーム インターフェイスをリンクアップ ステートに変更したり、リンクアップ ステートのままにしたりすることができます。

すべてのアップストリーム インターフェイスが利用不能になった場合、リンクステート トラッキングが自動的にダウンストリーム インターフェイスを errdisable ステートにします。サーバ間の接続は、自動的にプライマリ サーバ インターフェイスからセカンダリ サーバ インターフェイスに変更されます。

スイッチ A のリンクステート グループ 1 からリンクステート グループ 2 への接続の変更例については、図 25-3を参照してください。ポート 6 のアップストリーム リンクが切断されても、ダウンストリーム ポート 1 および 2 のリンク ステートは変わりません。ただし、アップストリーム ポート 5 のリンクも切断された場合、ダウンストリーム ポートのリンク ステートがリンクダウン ステートに変更されます。サーバ 1 およびサーバ 2 の接続については、リンクステート グループ 1 からリンクステート グループ 2 へ変更します。ダウンストリーム ポート 3 およびダウンストリーム ポート 4 は、リンクグループ 2 であるためステートを変更しません。

リンクステート グループが設定されている場合、リンクステート トラッキングはディセーブルで、アップストリーム インターフェイスが切断され、ダウンストリーム インターフェイスのリンク ステートは変更されないままになります。サーバはこのアップストリーム接続が切断されたことを認識せず、セカンダリ インターフェイスにフェールオーバーしません。

障害のあるダウンストリーム ポートをリンクステート グループから削除することで、ダウンストリーム インターフェイスのリンクダウン状態から復旧できます。複数のダウンストリーム インターフェイスを復旧させるには、リンクステート グループをディセーブルにします。

図 25-3 一般的なリンクステート トラッキングの設定

 

リンクステート トラッキングの設定

ここでは、リンクステート トラッキング ポートの設定について説明します。

「デフォルトのリンクステート トラッキングの設定」

「リンクステート トラッキングの設定時の注意事項」

「リンクステート トラッキングの設定」

「リンクステート トラッキング ステータスの表示」

デフォルトのリンクステート トラッキングの設定

リンク ステート グループは定義されておらず、リンク ステート トラッキングはどのグループでもイネーブルではありません。

リンクステート トラッキングの設定時の注意事項

設定上の問題を回避するために、次の注意事項に従ってください。

アップストリーム インターフェイスとして定義されているインターフェイスを、同じまたは異なるリンクステート グループ内でダウンストリーム インターフェイスとして定義することはできません。その逆も同様です。

ダウン ストリーム インターフェイスを追加する前に、リンク ステート グループにアップストリーム インターフェイスを追加することを推奨します。アップストリーム インターフェイスがグループに追加されるまでは、ダウン ストリーム インターフェイスは、アップストリーム インターフェイスのないリンク ステート グループに追加されると、ダウン ストリーム インターフェイスが error-disabled ステートになるためです。

インターフェイスは、複数のリンクステート グループのメンバにはなれません。

スイッチごとに最大 10 のリンク ステート グループを設定できます。

SPAN 宛先ポートがダウン ストリーム インターフェイスとして設定されている場合、グループのすべてのアップストリーム インターフェイスがダウンすると errdisable になります。アップストリーム インターフェイスが SPAN 宛先ポートとして設定されている場合、インターフェイスでのリンク ダウン イベントと見なされます。

リンクステート トラッキングの設定

リンク ステート グループを設定し、そのグループにインターフェイスを割り当てるには、特権 EXEC モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Switch# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Switch(config)# link state track number

リンクステート グループを作成して、リンクステート トラッキングをイネーブルにします。グループ番号は 1 ~ 10 に設定できます。デフォルトは 1 です。

ステップ 3

Switch(config)# interface interface-id

設定する物理インターフェイスまたはインターフェイスの範囲を指定して、インターフェイス コンフィギュレーション モードを開始します。

有効なインターフェイスには、アクセス モードまたはトランク モード(IEEE 802.1q)のスイッチ ポート、ルーテッド ポート、EtherChannel インターフェイス(スタティックまたは LACP)にバンドルされた、トランク モードの複数ポートが含まれます。

ステップ 4

Switch(config-if)# link state group [ number ] { upstream | downstream }

リンクステート グループを指定し、グループ内のインターフェイスを upstream または downstream インターフェイスに設定します。グループ番号は 1 ~ 10 に設定できます。デフォルトは 1 です。

ステップ 5

Switch(config-if)# end

特権 EXEC モードに戻ります。

ステップ 6

Switch# show running-config

入力を確認します。

ステップ 7

Switch# copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次に、リンクステート グループを作成してインターフェイスを設定する例を示します。

Switch# configure terminal
Switch(config)# link state track 1
Switch(config)# interface gigabitethernet3/1
Switch(config-if)# link state group 1 upstream
Switch(config-if)# interface gigabitethernet3/3
Switch(config-if)# link state group 1 upstream
Switch(config-if)# interface gigabitethernet3/5
Switch(config-if)# link state group 1 downstream
Switch(config-if)# interface gigabitethernet3/7
Switch(config-if)# link state group 1 downstream
Switch(config-if)# end
 

リンクステート グループをディセーブルにするには、 no link state track number グローバル コンフィギュレーション コマンドを使用します。

リンクステート トラッキング ステータスの表示

リンク ステート グループ情報を表示するには、show show link state group コマンドを入力します。キーワードを指定せずにこのコマンドを入力すると、すべてのリンクステート グループの情報が表示されます。

特定のグループの情報を表示するには、グループ番号を入力します。グループの詳細情報を表示するには、detail キーワードを入力します。

次の例では、show link state group 1 コマンドの出力を示します。

Switch> show link state group 1
Link State Group: 1 Status: Enabled, Down
 

次の例では、show link state group detail コマンドの出力を示します。

Switch> show link state group detail
(Up):Interface up (Dwn):Interface Down (Dis):Interface disabled
Link State Group: 1 Status: Enabled, Down
Upstream Interfaces : Gi3/5(Dwn) Gi3/6(Dwn)
Downstream Interfaces : Gi3/1(Dis) Gi3/2(Dis) Gi3/3(Dis) Gi3/4(Dis)
Link State Group: 2 Status: Enabled, Down
Upstream Interfaces : Gi3/15(Dwn) Gi3/16(Dwn) Gi3/17(Dwn)
Downstream Interfaces : Gi3/11(Dis) Gi3/12(Dis) Gi3/13(Dis) Gi3/14(Dis)
(Up):Interface up (Dwn):Interface Down (Dis):Interface disabled