IP ルーティング:BGP コマンド リファレンス、Cisco IOS XE Release 3SE(Catalyst 3850 スイッチ)
BGP コマンド:O ~ show bgp
BGP コマンド:O ~ show bgp
発行日;2013/08/07   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

BGP コマンド:O ~ show bgp

redistribute(BGP から ISO IS-IS)

ボーダー ゲートウェイ プロトコル(BGP)自律システムから国際標準化機構(ISO)の Intermediate System-to-Intermediate System(IS-IS)ルーティング プロセスにルートを再配布するには、ルータ コンフィギュレーション モードで redistribute コマンドを使用します。 コンフィギュレーション ファイルから redistribute コマンドを削除し、BGP ルートを IS-IS に再配布しないデフォルトの状態にシステムを戻すには、このコマンドの no 形式を使用します。

redistribute protocol autonomous-system-number [route-type] [ route-map map-tag ]

no redistribute protocol autonomous-system-number [route-type] [ route-map map-tag ]

構文の説明

protocol

ルートの再配布元であるソース プロトコルです。 これは、bgp キーワードである必要があります。

bgp キーワードは、ダイナミック ルートを再配布する場合に使用します。

autonomous-system-number

BGP ルートを IS-IS に再配布する再配布元の BGP ルーティング プロセスの自律システム番号。 この引数の値の範囲は、1 ~ 65535 の有効な自律システム番号です。

  • Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、4 バイトの自律システム番号は、asplain 表記で 65536 ~ 4294967295 の範囲、asdot 表記で 1.0 ~ 65535.65535 の範囲でサポートされています。
  • Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、4 バイトの自律システム番号は、asdot 表記の 1.0 ~ 65535.65535 の範囲でのみサポートされています。

自律システムの番号形式の詳細については、router bgp コマンドの説明を参照してください。

route-type

(任意)再配布されるルートのタイプ。 次のキーワードのいずれかを指定できます。clns または ip。 デフォルトは ip です。

  • clns キーワードは、Network Service Access Point(NSAP)アドレスを持つ BGP ルートを IS-IS に再配布するために使用します。
  • ip キーワードは、IP アドレスを持つ BGP ルートを IS-IS に再配布するために使用します。

route-map map-tag

(任意)設定済みルート マップの ID。 ルート マップは、このソース ルーティング プロトコルから IS-IS へのルートのインポートをフィルタするために検証されます。 指定しない場合は、すべてのルートが再配布されます。 キーワードは指定されているが、ルート マップ タグがリストされていない場合、ルートはインポートされません。

コマンド デフォルト

BGP から ISO IS-IS へのルートの再配布はディセーブルになっています。

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.2(8)T

このコマンドが変更されました。 clns キーワードが追加されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

12.0(32)S12

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.0(32)SY8

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.4(24)T

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 2.3

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.2(33)SXI1

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.0(33)S3

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

Cisco IOS XE Release 2.4

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

12.2(33)SRE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。 BGP ルーティング プロセスの自律システム番号の変更に対するサポートが削除されました。

12.2(33)XNE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

使用上のガイドライン

BGP から ISO IS-IS ルーティング プロセスに NSAP プレフィックス ルートを再配布するには、clns キーワードを指定する必要があります。 redistribute コマンドのこのバージョンは、IS-IS プロセスのルータ コンフィギュレーション モードだけで使用されます。


(注)  


router isis ルータ コンフィギュレーション コマンドで no redistribute bgp autonomous-system route-map map-name コマンドを設定した場合、IS-IS はルート マップだけでなく、redistribute コマンド全体を削除することに注意してください。 この動作は、router bgp ルータ コンフィギュレーション コマンドで設定される no redistribute isis コマンドとは異なります。このコマンドはキーワードを削除します。


次の例では、BGP 自律システム 64500 の NSAP プレフィックス ルートが osi-proc-17 という IS-IS ルーティング プロセスに再配布されるように設定します。

router isis osi-proc-17
 redistribute bgp 64500 clns

関連コマンド

コマンド

説明

network(BGP およびマルチプロトコル BGP)

BGP ルーティング プロセスのネットワークのリストを指定します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

router bgp

BGP ルーティング プロセスを設定します。

show route-map

設定されたすべてのルート マップ、または指定した 1 つのルート マップだけを表示します。

redistribute(IP)

あるルーティング ドメインから別のルーティング ドメインにルートを再配布するには、適切なコンフィギュレーション モードで redistribute コマンドを使用します。 (プロトコルに応じて)再配布のすべてまたは一部をディセーブルにするには、このコマンドの no 形式を使用します。 詳細なプロトコル固有の動作については、「使用上のガイドライン」のセクションを参照してください。

redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ autonomous-system-number ] [ metric { metric-value | transparent } ] [ metric-type type-value ] [ match { internal | external 1 | external 2 } ] [ tag tag-value ] [ route-map map-tag ] [subnets] [nssa-only]

no redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ autonomous-system-number ] [ metric { metric-value | transparent } ] [ metric-type type-value ] [ match { internal | external 1 | external 2 } ] [ tag tag-value ] [ route-map map-tag ] [subnets] [nssa-only]

構文の説明

protocol

ルートの再配布元であるソース プロトコルです。 次のキーワードのいずれかを指定できます。bgpconnectedeigrpisismobileospfripまたは static [ip]。

static [ip] キーワードは、IP スタティック ルートを再配布する場合に使用します。 オプションの ip キーワードは、Intermediate System-to-Intermediate System(IS-IS)プロトコルに再配布するときに使用します。

connected キーワードは、インターフェイス上で IP をイネーブルにすることによって自動的に確立されるルートを示します。 Open Shortest Path First(OSPF)や IS-IS などのルーティング プロトコルの場合、これらのルートは自律システムに対して外部として再配布されます。

process-id

(任意)bgp または eigrp キーワードの場合、これは 16 ビット 10 進数値である自律システム番号です。

isis キーワードの場合は、ルーティング プロセスに意味のある名前を定義するオプションの tag 値です。 ルータごとに指定できる IS-IS プロセスは 1 つだけです。 ルーティング プロセスの名前を作成することは、ルーティングを設定するときに名前を使用することを意味します。

ospf キーワードの場合は、ルートの再配布元となる適切な OSPF プロセス ID です。 これは、ルーティング プロセスを識別します。 この値をゼロ以外の 10 進数値の形式を取ります。

rip キーワードの場合、process-id 値は必要ではありません。

デフォルトでは、プロセス ID は定義されていません。

level-1

IS-IS の場合、レベル 1 ルートが他の IP ルーティング プロトコルに個別に再配布されることを指定します。

level-1-2

IS-IS の場合、レベル 1 とレベル 2 ルートが他の IP ルーティング プロトコルに再配布されることを指定します。

level-2

IS-IS の場合、レベル 2 ルートが他の IP ルーティング プロトコルに個別に再配布されることを指定します。

autonomous-system-number

(任意)再配布ルートの自律システム番号。 指定できる範囲は 1 ~ 65535 です。

  • Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、4 バイトの自律システム番号は、asplain 表記で 65536 ~ 4294967295 の範囲、asdot 表記で 1.0 ~ 65535.65535 の範囲でサポートされています。
  • Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、4 バイトの自律システム番号は、asdot 表記の 1.0 ~ 65535.65535 の範囲でのみサポートされています。

自律システムの番号形式の詳細については、router bgp コマンドの説明を参照してください。

metric metric-value

(任意)同じルータ上で 1 つの OSPF プロセスから別の OSPF プロセスに再配布する場合、メトリック値を指定しないと、メトリックは 1 つのプロセスから他のプロセスへ存続します。 他のプロセスを OSPF プロセスに再配布するときに、メトリック値を指定しない場合、デフォルトのメトリックは 20 です。 デフォルト値は 0 です

metric transparent

(任意)Routing Information Protocol(RIP)で RIP メトリックとして再配布ルートのルーティング テーブル メトリックを使用するようにします。

metric-type type value

(任意)OSPF の場合、OSPF ルーティング ドメインにアドバタイズされるデフォルト ルートに関連付けられた外部リンク タイプを指定します。 次の 2 つの値のいずれかにすることができます。

  • 1:タイプ 1 外部ルート
  • 2:タイプ 2 外部ルート

metric-type を指定しない場合、Cisco IOS ソフトウェアはタイプ 2 外部ルートを採用します。

IS-IS の場合、次の 2 つの値のいずれかにすることができます。

  • internal:63 よりも小さい IS-IS メトリック。
  • external:64 よりも大きく 128 よりも小さい IS-IS メトリック。

デフォルトは、internal です。

match {internal | external1 | external2}

(任意)OSPF ルートを他のルーティング ドメインに再配布する条件を指定します。 次のいずれかを指定できます。

  • internal:特定の自律システムの内部にあるルート。
  • external 1:自律システムの外部にあるが、OSPF にタイプ 1 外部ルートとしてインポートされるルート。
  • external 2:自律システムの外部にあるが、OSPF にタイプ 2 外部ルートとしてインポートされるルート。

デフォルトは、internal です。

tag tag-value

(任意)各外部ルートに付加する 32 ビットの 10 進値を指定します。 これは OSPF 自体には使用されません。 自律システム境界ルータ(ASBR)間で情報を通信するために使用できます。 何も指定しないと、リモート自律システム番号が、ボーダー ゲートウェイ プロトコル(BGP)と Exterior Gateway Protocol(EGP)からのルートに使用され、その他のプロトコルでは、ゼロ(0)が使用されます。

route-map

(任意)このソース ルーティング プロトコルから現在のルーティング プロトコルへのルートのインポートをフィルタするために問い合わせる必要があるルート マップを指定します。 指定しない場合は、すべてのルートが再配布されます。 このキーワードは指定されているが、ルート マップ タグがリストされていない場合、ルートはインポートされません。

map-tag

(任意)設定済みルート マップの ID。

subnets

(任意)OSPF へのルートの再配布において、指定したプロトコルの再配布の範囲を指定します。 デフォルトでは、サブネットは定義されません。

nssa-only

(任意)OSPF に再配布されるすべてのルートに nssa-only 属性を設定します。

コマンド デフォルト

ルートの再配布はディセーブルです。

コマンド モード

ルータ コンフィギュレーション(config-router)

アドレス ファミリ コンフィギュレーション(config-af)

アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.0(5)T

このコマンドが変更されました。 アドレス ファミリ コンフィギュレーション モードが追加されました。

12.0(22)S

このコマンドが変更されました。 EIGRP でのアドレス ファミリのサポートが追加されました。

12.2(15)T

このコマンドが変更されました。 EIGRP でのアドレス ファミリのサポートが追加されました。

12.2(18)S

このコマンドが変更されました。 EIGRP でのアドレス ファミリのサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが変更されました。 EIGRP でのアドレス ファミリ トポロジのサポートが追加されました。

12.2(14)SX

このコマンドが Cisco IOS Release 12.2(14)SX に組み込まれました。

12.0(32)S12

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.0(32)SY8

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.4(24)T

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 2.3

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.2(33)SXI1

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.0(33)S3

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルト形式が asplain になりました。

Cisco IOS XE Release 2.4

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルト形式が asplain になりました。

15.0(1)M

このコマンドが変更されました。 キーワード nssa-only が追加されました。

12.2(33)SRE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

15.1(1)SG

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 3.3SG

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

15.1(2)SNG

このコマンドが、Cisco ASR 901 シリーズの集約サービス ルータに実装されました

使用上のガイドライン

redistribute コマンドの no 形式の使用方法


注意    


redistribute コマンドに設定したオプションを削除するには、期待する結果が得られるように redistribute コマンドの no 形式を慎重に使用する必要があります。 キーワードを変更またはディセーブルにした場合、プロトコルによって他のキーワードの状態に影響を与える場合とそうではない場合があります。


それぞれのプロトコルによって redistribute コマンドの no バージョンの実行が異なることを理解することが重要です。

  • BGP、OSPF、および RIP 設定では、no redistribute コマンドは、実行コンフィギュレーションの redistribute コマンドから指定したキーワードのみを削除します。 その他のプロトコルからの再配布の場合は、キーワードの引き算方式が使用されます。 たとえば、BGP の場合、no redistribute static route-map interior を設定すると、ルート マップだけが再配布から削除され、redistribute static はフィルタなしでそのまま残されます。
  • no redistribute isis コマンドは、実行コンフィギュレーションから IS-IS の再配布を削除します。 IS-IS では、IS-IS が再配布されるプロトコルか、再配布するプロトコルかに関係なく、コマンド全体が削除されます。
  • EIGRP では、EIGRP コンポーネント バージョン リリース 5 よりも前のリリースでキーワードの引き算方式が使用されていました。 バージョン リリース 5 以降の EIGRP コンポーネントでは、他のプロトコルからの再配布の場合、no redistribute コマンドで redistribute コマンド全体が削除されます。

redistribute コマンドのその他の使用上のガイドライン

内部メトリックが指定されたリンクステート プロトコルを受信するルータの場合、ルートのコストには、そのルータから再配布するルータまでのコストと宛先に達するまでのアドバタイズされたコストの合計が考慮されます。 外部メトリックでは、宛先に達するまでのアドバタイズされたメトリックだけが考慮されます。

IP ルーティング プロトコルから学習したルートは、接続されたエリアにレベル 1 で再配布するかまたはレベル 2 で再配布できます。 level-1-2 キーワードはレベル 1 とレベル 2 の両方のルートを 1 つのコマンドで指定できます。

再配布ルーティング情報は、distribute-list out ルータ コンフィギュレーション コマンドでフィルタする必要があります。 このガイドラインにより、管理者が意図するルートだけが、受信側のルーティング プロトコルに転送されるようになります。

redistribute コマンドまたは default-information ルータ コンフィギュレーション コマンドを使用して、OSPF ルーティング ドメインにルートを再配布した場合は、必ずルータは自動で ASBR になります。 ただし、デフォルトでは、ASBR はデフォルト ルートを OSPF ルーティング ドメインに生成しません。

ルートが OSPF や BGP 以外のプロトコルから OSPF に再配布され、メトリックが metric-type キーワードと type-value 引数で指定されていない場合、OSPF はデフォルト メトリックとして 20 を使用します。 ルートが BGP から OSPF に再配布される場合、OSPF はデフォルト メトリックとして 1 を使用します。 ルートが 1 つの OSPF プロセスから別の OSPF プロセスに再配布される場合、自律システムの外部および Not-So-Stubby-Area(NSSA)のルートはデフォルト メトリックとして 20 を使用します。 エリア内およびエリア間ルートが OSPF プロセス間で再配布される場合、再配布元プロセスからの内部 OSPF メトリックは再配布先プロセスの外部メトリックとしてアドバタイズされます。 (これは、ルートを OSPF に再配布するときにルーティング テーブルのメトリックが保持される場合のみです)。

ルートが OSPF に再配布されるときに、subnets キーワードが指定されていない場合は、サブネット化されていないルートだけが再配布されます。

NSSA エリアの内部ルータでは、キーワード nssa-only により、構築されたタイプ 7 NSSA LSA の伝播(P)ビットがゼロに設定され、エリア境界ルータはこれらの LSA をタイプ 5 外部 LSA に変換しなくなります。 NSSA および通常のエリアに接続されているエリア境界ルータでは、キーワード nssa-only により、ルートが NSSA エリアにのみ再配布されます。

この redistribute コマンドの影響を受ける connected キーワードで設定されたルートは、network ルータ コンフィギュレーション コマンドで指定されていないルートです。

default-metric コマンドを使用して、接続ルートのアドバタイズに使用するメトリックに影響を与えることはできません。


(注)  


redistribute コマンドで指定された metric の値は、default-metric コマンドで指定された metric の値よりも優先されます。


BGP への Interior Gateway Protocol(IGP)または Exterior Gateway Protocol(EGP)のデフォルトの再配布は、default-information originate ルータ コンフィギュレーション コマンドが指定されていない場合は許可されません。

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を設定予定の場合、この OSPF ルータ コンフィギュレーション コマンドをトポロジ認識にするには、アドレス ファミリ トポロジ コンフィギュレーション モードで redistribute コマンドを入力する必要があります。

4 バイト自律システム番号のサポート

Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、シスコが採用している 4 バイト自律システム番号は、自律システム番号の正規表現のマッチングおよび出力表示形式のデフォルトとして asplain(たとえば、65538)を使用していますが、RFC 5396 に記載されているとおり、4 バイト自律システム番号を asplain 形式および asdot 形式の両方で設定できます。 4 バイト自律システム番号の正規表現マッチングと出力表示のデフォルトを asdot 形式に変更するには、bgp asnotation dot コマンドを使用します。

Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、シスコが採用している 4 バイト自律システム番号は、設定形式、正規表現とのマッチング、および出力表示として asdot(たとえば、1.2)のみを使用します。asplain はサポートしていません。

次の例では、OSPF ルートを BGP ドメインに再配布する方法を示します。

Router(config)# router bgp 109
Router(config-router)# redistribute ospf

次の例では、EIGRP ルートを OSPF ドメインに再配布する方法を示します。

Router(config)# router ospf 110
Router(config-router)# redistribute eigrp

次の例では、指定された EIGRP プロセス ルートを OSPF ドメインに再配布する方法を示しています。 EIGRP 派生メトリックは 100 に再マッピングされ、RIP ルートは 200 に再マッピングされます。

Router(config)# router ospf 109
Router(config-router)# redistribute eigrp 108 metric 100 subnets
Router(config-router)# redistribute rip metric 200 subnets

次の例では、IS-IS に再配布されるように BGP ルートを設定する方法を示します。 リンク ステート コストは 5 に指定され、メトリック タイプは外部に設定されます。これにより、内部メトリックより優先順位が低いことが示されます。

Router(config)# router isis
Router(config-router)# redistribute bgp 120 metric 5 metric-type external

次の例では、ネットワーク 172.16.0.0 は、コストが 100 の OSPF 1 の外部 LSA として表示されます(コストは維持されます)。

Router(config)# interface ethernet 0
Router(config-if)# ip address 172.16.0.1 255.0.0.0
Router(config-if)# exit
Router(config)# ip ospf cost 100
Router(config)# interface ethernet 1
Router(config-if)# ip address 10.0.0.1 255.0.0.0
!
Router(config)# router ospf 1
Router(config-router)# network 10.0.0.0 0.255.255.255 area 0
Router(config-if)# exit
Router(config-router)# redistribute ospf 2 subnet
Router(config)# router ospf 2
Router(config-router)# network 172.16.0.0 0.255.255.255 area 0

次の例では、BGP ルートを OSPF に再配布し、asplain 形式のローカルの 4 バイト自律システム番号を割り当てる方法を示します。 この例では、Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)SXI1、Cisco IOS XE Release 2.4、またはそれ以降のリリースが必要です。

Router(config)# router ospf 2
Router(config-router)# redistribute bgp 65538

次の例では、redistribute connected metric 1000 subnets コマンドから connected metric 1000 subnets オプションを削除し、設定に redistribute connected コマンドを残す方法を示します。

Router(config-router)# no redistribute connected metric 1000 subnets

次の例では、redistribute connected metric 1000 subnets コマンドから metric 1000 オプションを削除し、設定に redistribute connected subnets コマンドを残す方法を示します。

Router(config-router)# no redistribute connected metric 1000

次の例では、redistribute connected metric 1000 subnets コマンドから subnets オプションを削除し、設定に redistribute connected metric 1000 コマンドを残す方法を示します。

Router(config-router)# no redistribute connected subnets

次の例では、設定から、redistribute connected コマンドと redistribute connected コマンドに設定されたすべてのオプションを削除する方法を示します。

Router(config-router)# no redistribute connected

次の例では、指定された EIGRP 設定の EIGRP プロセスに EIGRP ルートを再配布する方法を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# topology base
Router(config-router-af-topology)# redistribute eigrp 6473 metric 1 1 1 1 1

次の例では、EIGRP 設定で再配布を設定またはディセーブルにする方法を示します。 EIGRP の場合、コマンドの no 形式で redistribute コマンドのセット全体が実行コンフィギュレーションから削除されることに注意してください。

Router(config)# router eigrp 1
Router(config-router)# network 0.0.0.0
Router(config-router)# redistribute eigrp 2 route-map x
Router(config-router)# redistribute ospf 1 route-map x
Router(config-router)# redistribute bgp 1 route-map x
Router(config-router)# redistribute isis level-2 route-map x
Router(config-router)# redistribute rip route-map x

Router(config)# router eigrp 1
Router(config-router)# no redistribute eigrp 2 route-map x
Router(config-router)# no redistribute ospf 1 route-map x
Router(config-router)# no redistribute bgp 1 route-map x
Router(config-router)# no redistribute isis level-2 route-map x
Router(config-router)# no redistribute rip route-map x
Router(config-router)# end

Router# show running-config | section router eigrp 1

router eigrp 1
 network 0.0.0.0

次の例では、OSPF 設定で再配布を設定およびディセーブルにする方法を示します。 コマンドの no 形式により、実行コンフィギュレーションの redistribute コマンドから指定キーワードだけが削除されることに注意してください。

Router(config)# router ospf 1
Router(config-router)# network 0.0.0.0
Router(config-router)# redistribute eigrp 2 route-map x
Router(config-router)# redistribute ospf 1 route-map x
Router(config-router)# redistribute bgp 1 route-map x
Router(config-router)# redistribute isis level-2 route-map x
Router(config-router)# redistribute rip route-map x

Router(config)# router ospf 1
Router(config-router)# no redistribute eigrp 2 route-map x
Router(config-router)# no redistribute ospf 1 route-map x
Router(config-router)# no redistribute bgp 1 route-map x
Router(config-router)# no redistribute isis level-2 route-map x
Router(config-router)# no redistribute rip route-map x
Router(config-router)# end

Router# show running-config | section router ospf 1

router ospf 1
 redistribute eigrp 2
 redistribute ospf 1
 redistribute bgp 1
 redistribute rip 
 network 0.0.0.0 

次の例では、BGP の再配布からルート マップ フィルタだけを削除する方法を示します。再配布自体はフィルタなしで有効なままになります。

Router(config)# router bgp 65000
Router(config-router)# no redistribute eigrp 2 route-map x

次の例では、BGP への EIGRP 再配布を削除する方法を示します。

Router(config)# router bgp 65000
Router(config-router)# no redistribute eigrp 2 

関連コマンド

コマンド

説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

bgp asnotation dot

デフォルトの表示を変更し、BGP 4 バイト自律システム番号の正規表現一致形式を、asplain(10 進数の値)からドット付き表記にします。

default-information originate(BGP)

ネットワーク 0.0.0.0 の BGP への再配布を可能にします。

default-information originate(IS-IS)

IS-IS ルーティング ドメインへのデフォルト ルートを生成します。

default-information originate(OSPF)

OSPF ルーティング ドメインへのデフォルト ルートを生成します。

distribute-list out (IP)

ネットワークがアップデート時にアドバタイズされないようにします。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

router bgp

BGP ルーティング プロセスを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

show route-map

設定されたすべてのルート マップ、または指定した 1 つのルート マップだけを表示します。

topology(EIGRP)

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

redistribute(ISO IS-IS から BGP)

国際標準化機構(ISO)の Intermediate System-to-Intermediate System(IS-IS)ルーティング プロセスからボーダー ゲートウェイ プロトコル(BGP)の自律システムにルートを再配布するには、アドレス ファミリまたはルータ コンフィギュレーション モードで redistribute コマンドを使用します。 コンフィギュレーション ファイルから redistribute コマンドを削除し、IS-IS ルートを BGP に再配布しないデフォルトの状態にシステムを戻すには、このコマンドの no 形式を使用します。

redistribute protocol [process-id] [route-type] [ route-map [map-tag] ]

no redistribute protocol [process-id] [route-type] [ route-map [map-tag] ]

構文の説明

protocol

ルートの再配布元であるソース プロトコルです。 次のキーワードのいずれかを指定できます。isis または static

  • isis キーワードは、ダイナミック ルートを再配布する場合に使用します。
  • static キーワードは、スタティック ルートを再配布する場合に使用します。

process-id

(任意)IS-IS がソース プロトコルとして使用されている場合、この引数では、ルーティング プロセスの意味のある名前を定義します。 process-id 引数は、どの IS-IS ルーティング プロセスからルートが再配布されるかを指定します。

  • ルートは、IS-IS レベル 1-2 やレベル 2 ルーティング プロセスなど、レベル 2 ルートを含む IS-IS ルーティング プロセスからのみ再配布できます。
  • static キーワードを protocol として使用する場合は、process-id 引数は使用しません。

route-type

(任意)再配布されるルートのタイプ。 次のキーワードのいずれかを指定できます。clns または ip。 デフォルトは ip です。

  • clns キーワードは、Network Service Access Point(NSAP)アドレスを持つコネクションレス型ネットワーク サービス(CLNS)ルートを BGP に再配布するために使用します。
  • ip キーワードは、IP アドレスを持つ IS-IS ルートを BGP に再配布するために使用します。

route-map map-tag

(任意)設定済みルート マップの ID。 ルート マップは、このソース ルーティング プロトコルから BGP へのルートのインポートをフィルタするために検証されます。 ルート マップが指定されない場合は、すべてのルートが再配布されます。 route-map キーワードが指定されているが、map-tag の値が入力されていない場合、ルートはインポートされません。

コマンド デフォルト

ISO IS-IS から BGP へのルートの再配布はディセーブルになっています。

route-typeip

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)(Cisco IOS 12.3(8)T 以降のリリース)

ルータ コンフィギュレーション(config-router)(Cisco IOS 12.3(8)T よりも後の T リリース)

コマンド履歴

リリース

変更内容

12.2(8)T

clns キーワードが追加されました。

12.3(8)T

Cisco IOS Release 12.3(8)T 以降、redistribute コマンドのこのバージョンは、ルータ コンフィギュレーション モードではなく、アドレス ファミリ モードで入力する必要があります。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

Cisco IOS XE 2.6

このコマンドが Cisco IOS XE Release 2.6 に統合されました。

使用上のガイドライン

clns キーワードは、BGP に ISO IS-IS ルーティング プロセスの NSAP プレフィックス ルートを再配布するために指定する必要があります。 Cisco IOS Release 12.3(8)T 以降、redistribute コマンドのこのバージョンは、BGP プロセスのアドレス ファミリ コンフィギュレーション モードでのみ入力する必要があります。

次に、osi-proc-6 という名前の IS-IS ルーティング プロセスの CLNS NSAP ルートを BGP に再配布するように設定する例を示します。

Router(config)# router bgp 64352
Router(config-router)# redistribute isis osi-proc-6 clns

次に、osi-proc-15 という名前の IS-IS ルーティング プロセスの CLNS NSAP ルートを BGP に再配布するように設定する例を示します。

Router(config)# router bgp 404
Router(config-router)# address-family nsap
Router(config-router-af)# redistribute isis osi-proc-15 clns

関連コマンド

コマンド

説明

network(BGP およびマルチプロトコル BGP)

BGP ルーティング プロセスのネットワークのリストを指定します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

show route-map

設定されたすべてのルート マップ、または指定した 1 つのルート マップだけを表示します。

router bgp

ボーダー ゲートウェイ プロトコル(BGP)ルーティング プロセスを設定するには、グローバル コンフィギュレーション モードで router bgp コマンドを使用します。 BGP ルーティング プロセスを削除するには、このコマンドの no 形式を使用します。

router bgp autonomous-system-number

no router bgp autonomous-system-number

構文の説明

autonomous-system-number

他の BGP ルータに対するルータを指定し、同時に渡されるルーティング情報のタギングをする、自律システムの番号。 番号の範囲は 1 ~ 65535 です。

  • Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、4 バイトの自律システム番号は、asplain 表記で 65536 ~ 4294967295 の範囲、asdot 表記で 1.0 ~ 65535.65535 の範囲でサポートされています。
  • Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、4 バイトの自律システム番号は、asdot 表記の 1.0 ~ 65535.65535 の範囲でのみサポートされています。

自律システムの番号形式の詳細については、「使用上のガイドライン」のセクションを参照してください。

コマンド デフォルト

デフォルトでは BGP ルーティング プロセスはイネーブルではありません。

コマンド モード


グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドは、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SRB

このコマンドが変更されました。 IPv6 のサポートが追加されました。

12.2(14)SX

このコマンドが Cisco IOS Release 12.2(14)SX に組み込まれました。

12.2(33)SB

このコマンドが変更されました。 IPv6 のサポートが追加されました。

12.0(32)S12

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.0(32)SY8

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.4(24)T

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 2.3

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.2(33)SXI1

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.0(33)S3

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

Cisco IOS XE Release 2.4

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

12.2(33)SRE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.2(33)XNE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

15.1(1)SG

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

Cisco IOS XE Release 3.3SG

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

15.1(2)SNG

このコマンドが、Cisco ASR 901 シリーズの集約サービス ルータに実装されました。

使用上のガイドライン

このコマンドを使用すると、自律システム間でのルーティング情報のループなしのやり取りが自動的に保証される、分散ルーティング コアを設定できます。

2009 年 1 月まで、企業に割り当てられていた BGP 自律システム番号は、RFC 4271『A Border Gateway Protocol 4 (BGP-4)』に記述された、1 ~ 65535 の範囲の 2 オクテットの数値でした。 自律システム番号の要求の増加に伴い、インターネット割り当て番号局(IANA)により割り当てられる自律システム番号は 2009 年 1 月から 65536 ~ 4294967295 の範囲の 4 オクテットの番号になります。 RFC 5396『Textual Representation of Autonomous System (AS) Numbers』には、自律システム番号を表す 3 つの方式が記述されています。 シスコでは、次の 2 つの方式を実装しています。

  • asplain:10 進表記方式。2 バイトおよび 4 バイト自律システム番号をその 10 進数値で表します。 たとえば、65526 は 2 バイト自律システム番号、234567 は 4 バイト自律システム番号になります。
  • asdot:自律システム ドット付き表記。2 バイト自律システム番号は 10 進数で、4 バイト自律システム番号はドット付き表記で表されます。 たとえば、65526 は 2 バイト自律システム番号、1.169031(10 進表記の 234567 をドット付き表記にしたもの)は 4 バイト自律システム番号になります。

自律システム番号を表す 3 つ目の方法については、RFC 5396 を参照してください。


(注)  


4 バイト ASN のサポートを含む Cisco IOS リリースでは、4 バイト ASN 番号を含むコマンド アカウンティングおよびコマンド許可が、コマンドライン インターフェイスで使用されている形式に関係なく、asplain 表記で送信されます。


asdot だけを使用する自律システム番号形式

Cisco IOS Release 12.0(32)S12、12.4(24)T、Cisco IOS XE Release 2.3、およびそれ以降のリリースでは、1.10 または 45000.64000 など、4 オクテット(4 バイト)の自律システム番号が、asdot 表記だけで入力され、表示されます。 4 バイト自律システム番号を正規表現一致する場合、正規表現では特殊文字であるピリオドが asdot 形式で使用されます。 正規表現でのマッチングに失敗しないよう、1\.14 のようにピリオドの前にバックスラッシュを入力する必要があります。 次の表は、asdot 形式だけを使用できる Cisco IOS イメージで、2 バイトおよび 4 バイト自律システム番号の設定、正規表現とのマッチング、および show コマンド出力での表示に使用される形式をまとめたものです。

表 1 asdot だけを使用する 4 バイト自律システム番号形式

形式

設定形式

show コマンド出力および正規表現のマッチング形式

asdot

2 バイト:1 ~ 65535、4 バイト:1.0 ~ 65535.65535

2 バイト:1 ~ 65535、4 バイト:1.0 ~ 65535.65535

asplain をデフォルトとする自律システム番号形式

Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、シスコ実装の 4 バイト自律システム番号で asplain がデフォルトの自律システム番号表示形式として使用されていますが、4 バイト自律システム番号は asplain および asdot 形式のどちらにも設定できます。 また、正規表現で 4 バイト自律システム番号とマッチングするためのデフォルト形式は asplain であるため、4 バイト自律システム番号とマッチングする正規表現はすべて、asplain 形式で記述する必要があります。 デフォルトの show コマンド出力で、4 バイト自律システム番号が asdot 形式で表示されるように変更する場合は、ルータ コンフィギュレーション モードで bgp asnotation dot コマンドを使用します。 デフォルトで asdot 形式がイネーブルにされている場合、正規表現の 4 バイト自律システム番号のマッチングには、すべて asdot 形式を使用する必要があり、使用しない場合正規表現によるマッチングは失敗します。 次の表に示すように、4 バイト自律システム番号は asplain と asdot のどちらにも設定できるとはいえ、show コマンド出力と正規表現を用いた 4 バイト自律システム番号のマッチング制御には 1 つの形式だけが使用されます。デフォルトは asplain 形式です。 show コマンド出力の表示と正規表現のマッチング制御で asdot 形式の 4 バイト自律システム番号を使用する場合、bgp asnotation dot コマンドを設定する必要があります。 bgp asnotation dot コマンドをイネーブルにした後で、clear ip bgp * コマンドを入力し、すべての BGP セッションについて、ハード リセットを開始する必要があります。


(注)  


4 バイト自律システム番号をサポートしているイメージにアップグレードしている場合でも、2 バイト自律システム番号を使用できます。 4 バイト自律システム番号に設定された形式にかかわらず、2 バイト自律システムの show コマンド出力と正規表現のマッチングは変更されず、asplain(10 進数)形式のままになります。


表 2 asplain をデフォルトとする 4 バイト自律システム番号形式

形式

設定形式

show コマンド出力および正規表現のマッチング形式

asplain

2 バイト:1 ~ 65535、4 バイト:65536 ~ 4294967295

2 バイト:1 ~ 65535、4 バイト:65536 ~ 4294967295

asdot

2 バイト:1 ~ 65535、4 バイト:1.0 ~ 65535.65535

2 バイト:1 ~ 65535、4 バイト:65536 ~ 4294967295

表 3 asdot を使用する 4 バイト自律システム番号形式

形式

設定形式

show コマンド出力および正規表現のマッチング形式

asplain

2 バイト:1 ~ 65535、4 バイト:65536 ~ 4294967295

2 バイト:1 ~ 65535、4 バイト:1.0 ~ 65535.65535

asdot

2 バイト:1 ~ 65535、4 バイト:1.0 ~ 65535.65535

2 バイト:1 ~ 65535、4 バイト:1.0 ~ 65535.65535

予約済みおよびプライベートの自律システム番号

Cisco IOS Release 12.0(32)S12、12.0(32)SY8、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、12.4(24)T、Cisco IOS XE Release 2.3 以降のリリースでは、シスコによる BGP の実装で RFC 4893 がサポートされています。 RFC 4893 は、2 バイト自律システム番号から 4 バイト自律システム番号への段階的移行を BGP がサポートできるように開発されました。 新しい予約済み(プライベート)自律システム番号(23456)は RFC 4893 により作成された番号で、Cisco IOS CLI ではこの番号を自律システム番号として設定できません。

RFC 5398『Autonomous System (AS) Number Reservation for Documentation Use』では、文書化を目的として新たに予約された自律システム番号について説明されています。 予約済み番号を使用することで、設定例を正確に文書化しつつ、その設定がそのままコピーされた場合でも製品ネットワークに競合が発生することを防止できます。 予約済み番号は IANA 自律システム番号レジストリに記載されています。 予約済み 2 バイト自律システム番号は 64496 ~ 64511 の連続したブロック、予約済み 4 バイト自律システム番号は 65536 ~ 65551 をその範囲としています。

64512 ~ 65534 を範囲とするプライベートの 2 バイト自律システム番号は依然有効で、65535 は特殊な目的のために予約されています。 プライベート自律システム番号は内部ルーティング ドメインで使用できますが、インターネットにルーティングされるトラフィックについては変換が必要です。 プライベート自律システム番号を外部ネットワークへアドバタイズするように BGP を設定しないでください。 Cisco IOS ソフトウェアは、デフォルトではルーティング アップデートからプライベート自律システム番号を削除しません。 ISP がプライベート自律システム番号をフィルタリングすることを推奨します。


(注)  


パブリック ネットワークおよびプライベート ネットワークに対する自律システム番号の割り当ては、IANA が管理しています。 予約済み番号の割り当てや自律システム番号の登録申込など、自律システム番号についての情報については、http://www.iana.org/ を参照してください。


次に、自律システム 45000 に BGP プロセスを設定し、2 バイト自律システム番号を使用して異なる自律システムで 2 つの外部 BGP ネイバーを設定する例を示します。

router bgp 45000
 neighbor 192.168.1.2 remote-as 40000
 neighbor 192.168.3.2 remote-as 50000
 neighbor 192.168.3.2 description finance
 !
 address-family ipv4
  neighbor 192.168.1.2 activate
  neighbor 192.168.3.2 activate
  no auto-summary
  no synchronization
  network 172.17.1.0 mask 255.255.255.0
  exit-address-family

次に、自律システム 65538 に BGP プロセスを設定し、asplain 表記の 4 バイト自律システム番号を使用して異なる自律システムで 2 つの外部 BGP ネイバーを設定する例を示します。 この例は、Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでサポートされています。

router bgp 65538
 neighbor 192.168.1.2 remote-as 65536
 neighbor 192.168.3.2 remote-as 65550
 neighbor 192.168.3.2 description finance
 !
 address-family ipv4
  neighbor 192.168.1.2 activate
  neighbor 192.168.3.2 activate
  no auto-summary
  no synchronization
  network 172.17.1.0 mask 255.255.255.0
  exit-address-family

次に、自律システム 1.2 に BGP プロセスを設定し、asdot 表記の 4 バイト自律システム番号を使用して異なる自律システムで 2 つの外部 BGP ネイバーを設定する例を示します。 この例は、Cisco IOS Release 12.0(32)SY8、12.0(32)S12、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、12.4(24)T、Cisco IOS XE Release 2.3、およびそれ以降のリリースでサポートされています。

router bgp 1.2
 neighbor 192.168.1.2 remote-as 1.0
 neighbor 192.168.3.2 remote-as 1.14
 neighbor 192.168.3.2 description finance
 !
 address-family ipv4
  neighbor 192.168.1.2 activate
  neighbor 192.168.3.2 activate
  no auto-summary
  no synchronization
  network 172.17.1.0 mask 255.255.255.0
  exit-address-family

関連コマンド

コマンド

説明

bgp asnotation dot

デフォルトの表示を変更し、BGP 4 バイト自律システム番号の正規表現一致形式を、asplain(10 進数の値)からドット付き表記にします。

neighbor remote-as

BGP ネイバー テーブルまたはマルチプロトコル BGP ネイバー テーブルにエントリを追加します。

network(BGP およびマルチプロトコル BGP)

BGP ルーティング プロセスのネットワークのリストを指定します。

set as-path

BGP ルートの自律システム パスを変更するには、ルートマップ コンフィギュレーション モードで set as-path コマンドを使用します。 自律システム パスを変更しないようにするには、このコマンドの no 形式を使用します。

set as-path { tag | prepend as-path-string }

no set as-path { tag | prepend as-path-string }

構文の説明

tag

ルートのタグを自律システム パスに変換します。 BGP にルートを再配布するときのみ適用されます。

prepend

キーワード prepend の後の文字列を、ルート マップと一致するルートの自律システム パスに付加します。 インバウンドおよびアウトバウンドの BGP ルート マップに適用されます。

as-path-string

AS_PATH 属性の先頭に付加する自律システム番号。 この引数の値の範囲は、1 ~ 65535 の有効な自律システム番号です。 複数の値を入力できます。最大で 10 個の AS 番号を入力できます。

  • Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、4 バイトの自律システム番号は、asplain 表記で 65536 ~ 4294967295 の範囲、asdot 表記で 1.0 ~ 65535.65535 の範囲でサポートされています。
  • Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、4 バイトの自律システム番号は、asdot 表記の 1.0 ~ 65535.65535 の範囲でのみサポートされています。

自律システムの番号形式の詳細については、router bgp コマンドの説明を参照してください。

コマンド デフォルト

自律システム パスは変更されません。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

11.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(14)SX

このコマンドが Cisco IOS Release 12.2(14)SX に組み込まれました。

12.0(32)S12

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.0(32)SY8

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.4(24)T

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 2.3

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.2(33)SXI1

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.0(33)S3

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

Cisco IOS XE Release 2.4

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

12.2(33)SRE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.2(33)XNE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

15.1(1)SG

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 3.3SG

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

使用上のガイドライン

最適なパス選択に影響を与える唯一のグローバル BGP メトリックは、自律システム パス長です。 自律システム パスの長さを変えることで、BGP スピーカーは遠くのピアによる最適なパス選択に影響を与えます。

タグを自律システム パスに変換できるため、このコマンドの set as-path tag バリエーションで自律システム長を変更できます。 set as-path prepend バリエーションを使用すれば、任意の自律システム パス文字列を BGP ルートの先頭に「付加」できます。 通常、ローカルな自律システム番号は複数回追加され、AS パス長が増します。

Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、シスコが採用している 4 バイト自律システム番号は、自律システム番号の正規表現のマッチングおよび出力表示形式のデフォルトとして asplain(たとえば、65538)を使用していますが、RFC 5396 に記載されているとおり、4 バイト自律システム番号を asplain 形式および asdot 形式の両方で設定できます。 4 バイト自律システム番号の正規表現マッチングと出力表示のデフォルトを asdot 形式に変更するには、bgp asnotation dot コマンドに続けて、clear ip bgp * コマンドを実行し、現在の BGP セッションをすべてハード リセットします。

Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、シスコが採用している 4 バイト自律システム番号は、設定形式、正規表現とのマッチング、および出力表示として asdot(たとえば、1.2)のみを使用します。asplain はサポートしていません。

次に、再配布されたルートのタグを自律システム パスに変換する例を示します。

route-map set-as-path-from-tag
 set as-path tag
!
router bgp 100
 redistribute ospf 109 route-map set-as-path-from-tag

次に、10.108.1.1 にアドバタイズされるすべてのルートの先頭に 100 100 100 を付加する例を示します。

route-map set-as-path
 match as-path 1
 set as-path prepend 100 100 100
!
router bgp 100
 neighbor 10.108.1.1 route-map set-as-path out

次に、192.168.1.2 にアドバタイズされるすべてのルートの先頭に 65538 65538 65538 を付加する例を示します。 この例では、Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、またはそれ以降のリリースが必要です。

route-map set-as-path
 match as-path 1.1
 set as-path prepend 65538 65538 65538
 exit
router bgp 65538
 neighbor 192.168.1.2 route-map set-as-path out

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

router bgp

BGP ルーティング プロセスを設定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set community

BGP コミュニティ属性を設定するには、set community ルート マップ コンフィギュレーション コマンドを使用します。 エントリを削除するには、このコマンドの no 形式を使用します。

set community { community-number [additive] [well-known-community] | none }

no set community

構文の説明

community-number

そのコミュニティ番号を指定します。 有効な値は、1 ~ 4294967200、no-export、または no-advertise です。

additive

(任意)既存のコミュニティにコミュニティを追加します。

well-known-community

(任意)既知のコミュニティは次のキーワードを使用して指定できます。

  • internet
  • local-as
  • no-advertise
  • no-export

none

(任意)ルート マップを通過するプレフィックスからコミュニティ属性を削除します。

コマンド デフォルト

BGP コミュニティ属性は存在しません。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.3

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

タグを設定する場合は、match 句を使用する必要があります(「permit everything」リストを指している場合でも)。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set ルート マップ コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、設定アクションmatch コマンドで指定した基準を満たしている場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドにより、ルート マップが削除されます。

set route-map コンフィギュレーション コマンドを使用すると、ルート マップのすべての一致基準を満たした場合に実行する再配布 set 処理を指定します。 すべての一致基準を満たすと、すべての set 処理が実行されます。

次の例では、自律システム パス アクセス リスト 1 を通過するルートのコミュニティが 109 に設定されます。 自律システム パス アクセス リスト 2 を通過するルートのコミュニティは、no-export(これらのルートがどの eBGP ピアにもアドバタイズされない)に設定されます。

route-map set_community 10 permit
 match as-path 1
 set community 109
route-map set_community 20 permit
 match as-path 2
 set community no-export

次の同様の例では、自律システム パス アクセス リスト 1 を通過するルートのコミュニティが 109 に設定されます。 自律システム パス アクセス リスト 2 を通過するルートのコミュニティは、local-as(ルータがローカル自律システムの外部のピアにこのルートをアドバタイズしない)に設定されます。

route-map set_community 10 permit
 match as-path 1
 set community 109
route-map set_community 20 permit
 match as-path 2
 set community local-as

関連コマンド

コマンド

説明

ip community-list

BGP 用のコミュニティ リストを作成し、このリストへのコントロール アクセスを作成します。

match community

BGP コミュニティを照合します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set comm-list delete

インバウンドまたはアウトバウンド アップデートのコミュニティ属性からコミュニティを削除します。

show ip bgp community

指定された BGP コミュニティに属するルートを示します。

set dampening

BGP ルート ダンプニング係数を設定するには、set dampening ルート マップ コンフィギュレーション コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

set dampening half-life reuse suppress max-suppress-time

no set dampening

構文の説明

half-life

ペナルティが小さくなるまでの時間(分単位)。 ルートにペナルティが割り当てられると、ペナルティは半減期で半分まで小さくなります(デフォルトでは 15 分です)。 ペナルティを小さくするプロセスは 5 秒ごとに発生します。 半減期の範囲は 1 ~ 45 分です。 デフォルト値は、15 分です。

reuse

フラッピング ルートがこの値を下回るまで減少すると、ルートの抑制を中止します。 ルートの抑制中止プロセスは、10 秒経過ごとに発生します。 再使用値の範囲は 1 ~ 20000 です。デフォルトは 750 です。

suppress

ペナルティがこの制限を超えると、ルートが抑制されます。 指定できる範囲は 1 ~ 20000 で、デフォルトは 2000 です。

max-suppress-time

ルートを抑制できる最大時間(分単位)。 範囲は 1 ~ 20000 で、デフォルトは half-life 値の 4 倍です。 half-life の値がデフォルトに設定されている場合、最大抑制時間はデフォルトの 60 分になります。

コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

11.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set ルートマップ コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、設定アクションmatch コマンドで指定した基準を満たしている場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドにより、ルート マップが削除されます。

BGP ピアがリセットされた場合、ルートは廃止され、フラップ統計情報は消去されます。 この場合、ルート フラップ ダンプニングがイネーブルの場合でも、withdrawal(取り消し)によるペナルティが生じません。

次に、半減期を 30 分に、再使用値を 1500 に、抑制値を 10000 に、最大抑制時間を 120 分に設定する例を示します。

route-map tag
 match as path 10
 set dampening 30 1500 10000 120
!
router bgp 100
 neighbor 172.16.233.52 route-map tag in

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定のインターフェイスの 1 つのネクスト ホップを持つルートを配布します。

match ip address

標準または拡張アクセス リストで許可された宛先ネットワーク番号アドレスを持つルートを配布し、パケットのポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set ip next-hop

ネクスト ホップのアドレスを指定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set origin(BGP)

BGP 送信元コードを設定します。

set tag(IP)

宛先ルーティング プロトコルの値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

show route-map

設定されたすべてのルート マップ、または指定した 1 つのルート マップだけを表示します。

set ip next-hop(BGP)

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの出力先を示すには、ルート マップ コンフィギュレーション モードで set ip next-hop コマンドを使用します。 エントリを削除するには、このコマンドの no 形式を使用します。

set ip next-hop ip-address [ ...ip-address ] [ peer-address ]

no set ip next-hop ip-address [ ...ip-address ] [ peer-address ]

構文の説明

ip-address

パケットが出力される出力先ネクスト ホップの IP アドレス。 隣接ルータである必要はありません。

peer-address

(任意)ネクスト ホップを BGP ピアリング アドレスに設定します。

コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

11.0

このコマンドが導入されました。

12.0

peer-address キーワードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドは、Cisco ASR 1000 シリーズ ルータで追加されました。

使用上のガイドライン

コマンド構文の省略記号(...)は、コマンド入力で ip-address 引数に複数の値を含められることを示します。

パケットのポリシー ルーティングに関する条件を定義するには、ip policy route-map インターフェイス コンフィギュレーション コマンド、route-map グローバル コンフィギュレーション コマンド、match および set ルートマップ コンフィギュレーション コマンドを使用します。 ip policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、設定アクションmatch コマンドで指定した基準を満たしている場合に実行される特定のルーティング アクション)を指定します。

set ip next-hop コマンドで指定された最初のネクスト ホップがダウン状態になると、任意で指定された IP アドレスが順に使用されます。

BGP ピアのインバウンド ルート マップで peer-address キーワードを指定し、set ip next-hop コマンドを使用すると、受信された一致するルートのネクスト ホップをネイバー ピアリング アドレスに設定し、サードパーティのネクスト ホップを上書きします。 したがって、同じルート マップを複数の BGP ピアに適用すると、サードパーティのネクストホップを上書きできます。

BGP ピアのアウトバウンド ルート マップで peer-address キーワードを指定し、set ip next-hop コマンドを使用すると、アドバタイズされた一致するルートのネクスト ホップをローカル ルータのピアリング アドレスに設定し、ネクスト ホップ計算をディセーブルにします。 一部のルートだけにネクスト ホップを設定できるので、set ip next-hop コマンドは、(ネイバー単位の)neighbor next-hop-self コマンドよりも詳細に設定できます。 neighbor next-hop-self コマンドを使用すると、そのネイバーに送信されたすべてのルートにネクスト ホップが設定されます。

set 句は互いに組み合わせて使用できます。 set 句は次の順で評価されます。

  1. set ip next-hop
  2. set interface
  3. set ip default next-hop
  4. set default interface

(注)  


反映されたルートの一般的な設定エラーを回避するには、BGP ルート リフレクタ クライアントに適用されるルート マップで set ip next-hop コマンドを使用しないでください。


VRF インターフェイスで set ip next-hop ...ip-address コマンドを設定すると、指定した VRF アドレス ファミリ内でネクスト ホップを検索できます。 この場合、...ip-address 引数は、指定された VRF インスタンスのそれと照合されます。

次の例では、3 台のルータが同じ FDDI LAN 上にあります(IP アドレス 10.1.1.1、10.1.1.2、および 10.1.1.3)。 それぞれが異なる自律システム(AS)です。 set ip next-hop peer-address コマンドは、ルート マップと一致する、リモート自律システム 300 内のルータ(10.1.1.3)からリモート自律システム 100 内のルータ(10.1.1.1)へのトラフィックが、LAN への相互接続で自律システム 100 内のルータ(10.1.1.1)に直接送信されるのではなく、ルータ bgp 200 を通過するように指定します。

router bgp 200
 neighbor 10.1.1.3 remote-as 300
 neighbor 10.1.1.3 route-map set-peer-address out
 neighbor 10.1.1.1 remote-as 100
route-map set-peer-address permit 10
 set ip next-hop peer-address

関連コマンド

コマンド

説明

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match ip address

標準または拡張アクセス リストで許可された宛先ネットワーク番号アドレスを持つルートを配布し、パケットのポリシー ルーティングを実行します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

neighbor next-hop-self

ルータ上で BGP アップデートのネクスト ホップ処理をディセーブルにします。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set default interface

ポリシー ルーティングでルート マップの match 句を満たしたパケットのうち、宛先への明示ルートを持っていないパケットの出力先を指定します。

set interface

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco IOS ソフトウェアが持たない場合の出力先を示します。

set ipv6 next-hop(BGP)

ポリシー ルーティングでルート マップの match 句を満たした IPv6 パケットの出力先を示すには、ルートマップ コンフィギュレーション モードで set ipv6 next-hop コマンドを使用します。 エントリを削除するには、このコマンドの no 形式を使用します。

set ipv6 next-hop { ipv6-address [link-local-address] | encapsulate l3vpn profile name | peer-address }

no set ipv6 next-hop { ipv6-address [link-local-address] | encapsulate l3vpn profile name | peer-address }

構文の説明

ipv6-address

パケットが出力されるネクスト ホップの IPv6 グローバル アドレス。 隣接ルータである必要はありません。

この引数は、RFC 2373 に記述されている形式にする必要があります。コロン区切りの 16 ビット値を使用して、アドレスを 16 進数で指定します。

link-local-address

(任意)パケットが出力されるネクスト ホップの IPv6 リンクローカル アドレス。 隣接ルータである必要があります。

この引数は、RFC 2373 に記述されている形式にする必要があります。コロン区切りの 16 ビット値を使用して、アドレスを 16 進数で指定します。

encapsulate l3vpn

VPN ネクスト ホップのカプセル化のプロファイルを設定します。

profile name

レイヤ 3 カプセル化プロファイルの名前。

peer-address

(任意)ネクスト ホップを BGP ピアリング アドレスに設定します。

コマンド デフォルト

IPv6 パケットはルーティング テーブルのネクスト ホップ ルータに転送されます。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

12.2(4)T

このコマンドが導入されました。

12.0(21)ST

このコマンドが Cisco IOS Release 12.0(21)ST に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

Cisco IOS XE Release 2.1

このコマンドは、Cisco ASR 1000 シリーズ ルータで追加されました。

12.2(33)SRE

このコマンドが変更されました。 encapsulate l3vpn キーワードが追加されました。

使用上のガイドライン

set ipv6 next-hop コマンドは、set ip next-hop コマンドと類似していますが、これは IPv6 専用です。

set コマンドは、設定アクションmatch コマンドで指定した基準を満たしている場合に実行される特定のルーティング アクション)を指定します。

BGP ピアのインバウンド ルート マップで peer-address キーワードを指定し、set ipv6 next-hop コマンドを使用すると、受信された一致するルートのネクスト ホップをネイバー ピアリング アドレスに設定し、サードパーティのネクスト ホップを上書きします。 したがって、同じルート マップを複数の BGP ピアに適用すると、サードパーティのネクストホップを上書きできます。

BGP ピアのアウトバウンド ルート マップで peer-address キーワードを指定し、set ipv6 next-hop コマンドを使用すると、アドバタイズされた一致するルートのネクスト ホップをローカル ルータのピアリング アドレスに設定し、ネクスト ホップ計算をディセーブルにします。 一部のルートだけにネクスト ホップを設定できるので、set ipv6 next-hop コマンドは、ネイバー単位の neighbor next-hop-self コマンドよりも詳細に設定できます。 neighbor next-hop-self コマンドを使用すると、そのネイバーに送信されたすべてのルートにネクスト ホップが設定されます。

set 句は互いに組み合わせて使用できます。 set 句は次の順で評価されます。

  1. set ipv6 next-hop
  2. set interface
  3. set ipv6 default next-hop
  4. set default interface

VRF インターフェイスで set ipv6 next-hop ipv6-address コマンドを設定すると、指定した VRF アドレス ファミリ内でネクスト ホップを検索できます。 この場合、ipv6-address 引数は、指定された VRF インスタンスのそれと照合されます。

次の例では、IPv6 マルチプロトコル BGP ピア FE80::250:BFF:FE0E:A471 を設定し、ネイバーのファスト イーサネット インターフェイス 0 の IPv6 ネクスト ホップ グローバル アドレスを BGP アップデートに含めるように nh6 という名前のルート マップを設定します。 nh6 ルート マップで、または neighbor update-source ルータ コンフィギュレーション コマンドで指定したインターフェイスから、IPv6 ネクスト ホップのリンクローカル アドレスをネイバーに送信できます。

router bgp 170
 neighbor FE80::250:BFF:FE0E:A471 remote-as 150
 neighbor FE80::250:BFF:FE0E:A471 update-source fastether 0
address-family ipv6
  neighbor FE80::250:BFF:FE0E:A471 activate
  neighbor FE80::250:BFF:FE0E:A471 route-map nh6 out
route-map nh6
 set ipv6 next-hop 3FFE:506::1

(注)  


neighbor update-source コマンドでネイバー インターフェイス(interface-type 引数)を指定した後に、set ipv6 next-hop コマンドでグローバル IPv6 ネクスト ホップ アドレス(ipv6-address 引数)だけを指定している場合は、ネイバー インターフェイスのリンクローカル アドレスが、ネクスト ホップとして BGP アップデートに含まれます。 したがって、リンクローカル アドレスを使用する複数の BGP ピアに必要となるのは、BGP アップデートにグローバル IPv6 ネクスト ホップ アドレスを設定する 1 つのルート マップだけとなります。


関連コマンド

コマンド

説明

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match ipv6 address

プレフィックス リストによって許可されたプレフィックスを持つ IPv6 ルートを配布します。

match ipv6 next-hop

プレフィックス リストによって許可されたネクスト ホップ プレフィックスを持つ IPv6 ルートを配布します。

match ipv6 route-source

プレフィックス リストで指定されているアドレスのルータによってアドバタイズされた IPv6 ルートを配布します。

neighbor next-hop-self

ルータ上で BGP アップデートのネクスト ホップ処理をディセーブルにします。

neighbor update-source

BGP セッションで、TCP 接続の動作インターフェイスを使用できるよう、Cisco IOS ソフトウェアを設定します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set metric(BGP-OSPF-RIP)

ルーティング プロトコルのメトリック値を設定するには、ルートマップ コンフィギュレーション モードで set metric コマンドを使用します。 デフォルトのメトリック値に戻すには、このコマンドの no 形式を使用します。

set metric metric-value

no set metric metric-value

構文の説明

metric-value

メトリック値。-294967295 ~ 294967295 の整数。 この引数は、Enhanced Interior Gateway Routing Protocol(EIGRP)を除くすべてのルーティング プロトコルに適用されます。

コマンド デフォルト

動的に学習したメトリック値。

コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

デフォルト値を変更する前に、シスコのテクニカル サポート担当者に問い合わせてください。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、設定アクションmatch コマンドで指定した基準を満たしている場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドはルート マップを削除します。

set ルート マップ コンフィギュレーション コマンドは、ルート マップのすべての一致基準が満たされたときに実行される再配布 set 処理を指定します。 すべての一致基準を満たすと、すべての set 処理が実行されます。

次の例では、ルーティング プロトコルのメトリック値を 100 に設定します。

route-map set-metric
 set metric 100

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定のインターフェイスの 1 つのネクスト ホップを持つルートを配布します。

match ip address

標準または拡張アクセス リストで許可された宛先ネットワーク番号アドレスを持つルートを配布し、パケットのポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set ip next-hop

ネクスト ホップのアドレスを指定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set origin(BGP)

BGP 送信元コードを設定します。

set tag(IP)

宛先ルーティング プロトコルの値を設定します。

set origin(BGP)

BGP 送信元コードを設定するには、ルートマップ コンフィギュレーション モードで set origin コマンドを使用します。 エントリを削除するには、このコマンドの no 形式を使用します。

set origin { igp | egp autonomous-system-number | incomplete }

no set origin { igp | egp autonomous-system-number | incomplete }

構文の説明

igp

Interior Gateway Protocol(IGP)のリモート システム。

egp

Exterior Gateway Protocol(EGP)のローカル システム。

autonomous-system-number

リモート自律システム番号。 この引数の値の範囲は、1 ~ 65535 の有効な自律システム番号です。

incomplete

未知の継承。

コマンド デフォルト

ルートの始点はメイン IP ルーティング テーブルのルートのパス情報に基づきます。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(14)SX

このコマンドが Cisco IOS Release 12.2(14)SX に組み込まれました。

12.4(2)T

このコマンドが変更されました。 egp キーワードおよび autonomous-system-number 引数が削除されました。

12.0(33)S3

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

Cisco IOS XE Release 2.4

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

12.2(33)SRE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.2(33)XNE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

使用上のガイドライン

ルートの始点を設定する場合は、match 句を設定する必要があります(「permit everything」リストを指している場合でも)。 ルートが BGP に再配布される場合は、このコマンドを使用して特定の始点を設定します。 ルートが再配布される場合、始点は通常、不完全として記録され、BGP テーブルでは ? で識別されます。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドは、設定アクションmatch コマンドで指定した基準を満たしている場合に実行される特定の再配布アクション)を指定します。 no route-map コマンドはルート マップを削除します。

set ルート マップ コンフィギュレーション コマンドは、ルート マップのすべての一致基準が満たされたときに実行される再配布 set 処理を指定します。 すべての一致基準を満たすと、すべての set 処理が実行されます。

次に、ルート マップを IGP に送信するルートの発信を設定する例を示します。

route-map set_origin
 match as-path 10
 set origin igp

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

router bgp

BGP ルーティング プロセスを設定します。

set as-path

BGP ルートの自律システム パスを変更します。

set weight

ルーティング テーブルの BGP 重みを指定するには、ルートマップ コンフィギュレーション モードで set weight コマンドを使用します。 エントリを削除するには、このコマンドの no 形式を使用します。

set weight number

no set weight number

構文の説明

number

重み値。 0 ~ 65535 の整数に設定できます。

コマンド デフォルト

重みは指定のルート マップによって変更されません。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

実行された重みは、最初に一致した自律システム(AS)パスに基づいています。 自律システム パスが一致したときに表示された重みは、グローバルな neighbor コマンドによって割り当てられた重みを無効にします。 つまり、set weight ルートマップ コンフィギュレーション コマンドで割り当てられた重みは、neighbor weight コマンドを使用して割り当てられた重みを無効にします。

次に、自律システム パス アクセス リストと一致するルートの BGP 重みを 200 に設定する例を示します。

route-map set-weight
 match as-path 10
 set weight 200

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定のインターフェイスの 1 つのネクスト ホップを持つルートを配布します。

match ip address

標準または拡張アクセス リストで許可された宛先ネットワーク番号アドレスを持つルートを配布し、パケットのポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set ip next-hop

ネクスト ホップのアドレスを指定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set origin(BGP)

BGP 送信元コードを設定します。

set tag(IP)

宛先ルーティング プロトコルの値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。