IP ルーティング:BGP コマンド リファレンス、Cisco IOS XE Release 3SE(Catalyst 3850 スイッチ)
BGP コマンド:M ~ N
BGP コマンド:M ~ N
発行日;2013/08/07   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

BGP コマンド:M ~ N

match as-path

アクセス リストで指定された BGP 自律システム パスを照合するには、ルート マップ コンフィギュレーション モードで match as-path コマンドを使用します。 パス リスト エントリを削除するには、このコマンドの no形式を使用します。

match as-path path-list-number

no match as-path path-list-number

構文の説明

path-list-number

自律システム パスを指定するアクセス リスト。 1 ~ 199 の整数。

コマンド デフォルト

アクセス リストで指定された自律システム パスでは照合は実行されません。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

ip as-path access-list コマンドを使用して、指定されている AS パスを特定するアクセス リストを作成します。 その後、match as-path コマンドを使用して、AS パスを特定したアクセス リストの照合に基づいてルート マップを作成します。

match as-pathset weight コマンドの組み合わせで設定された値は、グローバル値を上書きします。 たとえば、match as-pathset weight ルート マップ コンフィギュレーション コマンドで割り当てられた重みは、neighbor weight コマンドを使用して割り当てられた重みを上書きします。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。 一部のデータのみを変更したい場合は、別のルートマップ セクションに明示的に match を指定する必要があります。

次に、アクセス リスト 20 で指定された自律システム パスで照合を行うルート マップの設定例を示します。

route-map IGP2BGP
 match as-path 20

関連コマンド

コマンド

説明

ip as-path access-list

正規表現を使用して AS パス フィルタを設定します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定のインターフェイスの 1 つのネクスト ホップを持つルートを配布します。

match ip address

標準または拡張アクセス リストで許可された宛先ネットワーク番号アドレスを持つルートを配布し、パケットのポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

neighbor weight

ネイバー接続に重みを割り当てます。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

ルート マップの設定におけるタグ値を自動計算します。

set community

BGP コミュニティ属性を設定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set origin(BGP)

BGP 送信元コードを設定します。

set tag(IP)

宛先ルーティング プロトコルの値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match community

ボーダー ゲートウェイ プロトコル(BGP)コミュニティを照合するには、ルート マップ コンフィギュレーション モードで match community コマンドを使用します。 コンフィギュレーション ファイルから match community コマンドを削除し、システムをデフォルトの条件(BGP コミュニティ リスト エントリを削除)に戻すには、このコマンドの no 形式を使用します。

match community { standard-list-number | expanded-list-number | community-list-name [exact] }

no match community { standard-list-number | expanded-list-number | community-list-name [exact] }

構文の説明

standard-list-number

コミュニティの 1 つまたは複数の許可グループまたは拒否グループを識別する 1 ~ 99 までの標準コミュニティ リスト番号を指定します。

expanded-list-number

コミュニティの 1 つまたは複数の許可グループまたは拒否グループを識別する 100 ~ 500 までの拡張コミュニティ リスト番号を指定します。

community-list-name

コミュニティ リストの名前。

exact

(任意)完全一致が必要であることを示します。 指定されたすべてのコミュニティのみが存在する必要があります。

コマンド デフォルト

ルート マップではコミュニティ リストの照合は行われません。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

12.1

このコマンドが導入されました。

12.1(9)E

名前付きコミュニティ リストのサポートが、Cisco IOS Release 12.1(9)E に統合されました。

12.2(8)T

名前付きコミュニティ リストのサポートが、Cisco IOS Release 12.2(8)T に統合されました。

12.0(22)S

Cisco IOS Release 12.0(22)S で、詳細拡張コミュニティ リスト番号の最大数が 199 から 500 に変更されました。

12.2(14)S

拡張コミュニティ リストの最大数が 199 から 500 に変更され、名前付きコミュニティ リストのサポートが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(15)T

Cisco IOS Release 12.2(15)T で、詳細拡張コミュニティ リスト番号の最大数が 199 から 500 に変更されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連した match コマンドと 1 つも一致しないルートは無視されます。そのため、このようなルートは、アウトバウンド ルート マップではアドバタイズされず、インバウンド ルート マップでは受け入れられません。 一部のデータのみを変更したい場合は、別のルートマップ セクションに明示的に match を指定する必要があります。

コミュニティ リスト番号に基づく照合は、BGP に適用できる match コマンドのタイプの 1 つです。

次の例では、コミュニティ リスト 1 と一致するルートの重みが 100 に設定されます。 コミュニティ 109 を含むすべてのルートの重みが 100 に設定されます。

Router(config)# ip community-list 1 permit 109
Router(config)# route-map set_weight
Router(config-route-map)#  match community 1
Router(config-route-map)# set weight 100

次の例では、コミュニティ リスト 1 と一致するルートの重みを 200 に設定します。 コミュニティ 109 を含むすべてのルートの重みが 200 に設定されます。

Router(config)# ip community-list 1 permit 109
Router(config)# route-map set_weight
Router(config-route-map)# match community
 1 exact
Router(config-route-map)# set weight 200

次の例では、コミュニティ リスト LIST_NAME と一致するルートの重みが 100 に設定されます。 コミュニティ 101 を含むすべてのルートの重みが 100 に設定されます。

Router(config)# ip community-list LIST_NAME permit 101
Router(config)# route-map set_weight
Router(config-route-map)# match community LIST_NAME 
Router(config-route-map)# set weight 100

次の例は、拡張コミュニティ リスト 500 と一致するルートを示しています。 拡張コミュニティ 1 を含むすべてのルートの重みが 150 に設定されます。

Router(config)# ip community-list 500 permit [0-9]*
Router(config)# route-map MAP_NAME permit 10
Router(config-route-map)# match extcommunity 500
Router(config-route-map)# set weight 150

関連コマンド

コマンド

説明

ip community-list

BGP のコミュニティ リストを作成し、アクセスを制御します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

neighbor activate

ボーダー ゲートウェイ プロトコル(BGP)ネイバーとの情報交換をイネーブルにするには、アドレス ファミリ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで neighbor activate コマンドを使用します。 BGP ネイバーとのアドレス交換をディセーブルにするには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name | ipv6-address% } activate

no neighbor { ip-address | peer-group-name | ipv6-address% } activate

構文の説明

ip-address

隣接ルータの IP アドレス。

peer-group-name

BGP ピア グループの名前。

ipv6-address

BGP ネイバーの IPv6 アドレス。

%

(任意)IPv6 リンクローカル アドレス ID。 このキーワードは、リンクローカル IPv6 アドレスがそのインターフェイスのコンテキスト外で使用される場合は、追加する必要があります。

コマンド デフォルト

BGP ネイバーとのアドレス交換は、IPv4 アドレス ファミリに対してイネーブルになっています。 その他すべてのアドレス ファミリのアドレス交換はディセーブルになっています。


(注)  


neighbor remote-as コマンドを設定する前に no bgp default ipv4 activate コマンドを設定している場合、または no neighbor activate コマンドを使用して、特定のネイバーとのアドレス ファミリ IPv4 のアドレス交換をディセーブルにしてある場合を除いて、アドレス ファミリ IPv4 のアドレス交換は、neighbor remote-as コマンドで設定された各 BGP ルーティング セッションに対してデフォルトでイネーブルになっています。


コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

11.0

このコマンドが導入されました。

12.0(5)T

アドレス ファミリ コンフィギュレーション モードと IPv4 アドレス ファミリのサポートが追加されました。

12.2(2)T

ipv6-address 引数と IPv6 アドレス ファミリのサポートが追加されました。

12.0(21)ST

このコマンドが Cisco IOS Release 12.0(21)ST に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

% キーワードが追加されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

Cisco IOS XE Release 2.1

このコマンドは、Cisco ASR 1000 シリーズ ルータで追加されました。

15.1(2)SNG

このコマンドが、Cisco ASR 901 シリーズの集約サービス ルータに実装されました。

使用上のガイドライン

このコマンドを使用して、IP または IPv6 プレフィックスの形式でアドレス情報をアドバタイズします。 アドレス プレフィックス情報は、BGP ではネットワーク層到達可能性情報(NLRI)と呼ばれます。

% キーワードは、リンクローカル IPv6 アドレスがインターフェイスのコンテキスト外で使用されている場合に常に使用します。 このキーワードは、非リンクローカル IPv6 アドレスに使用する必要はありません。

次に、PEPEER という名前の BGP ピア グループのすべてのネイバーとネイバー 10.0.0.44 で、アドレス ファミリ vpnv4 のアドレス交換をイネーブルにする例を示します。

Router(config)# address-family vpnv4
Router(config-router-af)# neighbor PEPEER activate
Router(config-router-af)# neighbor 10.0.0.44 activate
Router(config-router-af)# exit-address-family

次に、group1 という名前の BGP ピア グループのすべてのネイバーと BGP ネイバー 172.16.1.1 で、アドレス ファミリ IPv4 ユニキャストのアドレス交換をイネーブルにする例を示します。

Router(config)# address-family ipv4 unicast
Router(config-router-af)# neighbor group1 activate
Router(config-router-af)# neighbor 172.16.1.1 activate

次に、group2 という名前の BGP ピア グループのすべてのネイバーと BGP ネイバー 7000::2 で、アドレス ファミリ IPv6 のアドレス交換をイネーブルにする例を示します。

Router(config)# address-family ipv6
Router(config-router-af)# neighbor group2 activate
Router(config-router-af)# neighbor 7000::2 activate

関連コマンド

コマンド

説明

address-family ipv4

標準 IPv4 アドレス プレフィックスを使用する BGP などのルーティング セッションを設定するために、ルータをアドレス ファミリ コンフィギュレーション モードにします。

address-family ipv6

標準 IPv6 アドレス プレフィックスを使用する BGP などのルーティング セッションを設定するために、ルータをアドレス ファミリ コンフィギュレーション モードにします。

address-family vpnv4

標準 VPNv4 アドレス プレフィックスを使用する BGP などのルーティング セッションを設定するために、ルータをアドレス ファミリ コンフィギュレーション モードにします。

address-family vpnv6

標準 VPNv6 アドレス プレフィックスを使用する BGP などのルーティング セッションを設定するために、ルータをアドレス ファミリ コンフィギュレーション モードにします。

exit-address-family

アドレス ファミリ サブモードを終了します。

neighbor remote-as

BGP ネイバー テーブルまたはマルチプロトコル BGP ネイバー テーブルにエントリを追加します。

neighbor advertise-map

条件付きアドバタイズメントの BGP ルーティング テーブルに、ボーダー ゲートウェイ プロトコル(BGP)のルートをローカル起点のルートとしてインストールするには、ルータ コンフィギュレーション モードで neighbor advertise-map コマンドを使用します。 条件付きアドバタイズメントをディセーブルにするには、このコマンドの no 形式を使用します。

neighbor ip-address advertise-map map-name { exist-map map-name | non-exist-map map-name }

no neighbor ip-address advertise-map map-name { exist-map map-name | non-exist-map map-name }

構文の説明

ip-address

条件付きアドバタイズメントを受信する必要があるルータの IP アドレスを指定します。

advertise-map map-name

存在マップまたは非存在マップの条件を満たした場合にアドバタイズされるルート マップの名前を指定します。

exist-map map-name

アドバタイズ マップと比較されるルート マップの名前を指定します。 条件を満たしていて、アドバタイズ マップと存在マップで一致が出現している場合は、ルートがアドバタイズされます。 一致が出現していない場合は、条件が満たされず、ルートは取り消されます。

non-exist-map map-name

アドバタイズ マップと比較されるルート マップの名前を指定します。 条件を満たしていて、一致が出現していない場合は、ルートがアドバタイズされます。 一致が出現している場合は、条件が満たされず、ルートは取り消されます。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

11.1CC

このコマンドが導入されました。

11.2

このコマンドが Cisco IOS Release 11.2 に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

neighbor advertise-map コマンドは、選択されたルートを条件付きでアドバタイズするために使用します。 条件付きでアドバタイズされるルート(プレフィックス)は、アドバタイズ マップと存在マップまたは非存在マップの 2 つのルート マップで定義されます。

  • 存在マップまたは不在マップと関連付けられているルート マップは、BGP スピーカーが追跡するプレフィックスを指定します。
  • アドバタイズ マップと関連付けられているルート マップは、条件が満たされたときに、指定されたネイバーにアドバタイズされるプレフィックスを指定します。

存在マップが設定されている場合、プレフィックスがアドバタイズ マップと存在マップの両方に存在するときに条件が満たされます。

非存在マップが設定されている場合、プレフィックスがアドバタイズ マップには存在するが、非存在マップには存在しないときに条件が満たされます。

条件が満たされない場合、ルートは取り消され、条件付きアドバタイズメントは行われません。 条件付きアドバタイズメントを行うには、ダイナミックにアドバタイズされるルート、またはアドバタイズされないルートがすべて BGP ルーティング テーブルに存在する必要があります。

次のルータの設定例では、存在マップを使用して、条件付きで 10.2.1.1 ネイバーにプレフィックスをアドバタイズするように BGP を設定します。 プレフィックスが MAP1 と MAP2 に存在する場合、条件が満たされ、プレフィックスがアドバタイズされます。

router bgp 5
 neighbor 10.2.1.1 advertise-map MAP1 exist-map MAP2

次のアドレス ファミリの設定例では、非存在マップを使用して、条件付きで 10.1.1.1 ネイバーにプレフィックスをアドバタイズするように BGP を設定します。 プレフィックスが MAP3 に存在するが MAP4 には存在しない場合、条件が満たされ、プレフィックスがアドバタイズされます。

router bgp 5
 address-family ipv4 multicast
 neighbor 10.1.1.1 advertise-map MAP3 non-exist-map MAP4

関連コマンド

コマンド

説明

address-family ipv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

neighbor advertisement-interval

BGP ルーティング アップデートの送信に最小ルート アドバタイズメント インターバル(MRAI)を設定するには、アドレス ファミリまたはルータ コンフィギュレーション モードで neighbor advertisement-interval コマンドを使用します。 デフォルト値に戻すには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } advertisement-interval seconds

no neighbor { ip-address | peer-group-name } advertisement-interval seconds

構文の説明

ip-address

ネイバーの IP アドレス。

peer-group-name

BGP ピア グループの名前。

seconds

時間(秒)は、0 ~ 600 の整数で指定します。

コマンド デフォルト

VRF 以外の eBGP セッション:30 秒

VRF の eBGP セッション:0 秒

iBGP セッション:0 秒

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.3

このコマンドが導入されました。

12.0(7)T

アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

12.4T、12.2SB、12.2SE、12.2SG、12.2SR、12.2SX、Cisco IOS XE 2.1

このコマンドが変更されました。 VRF の eBGP セッションと iBGP セッションのデフォルト値が、0.5 秒から 0 秒に変更されました。

使用上のガイドライン

MRAI が 0 秒に等しい場合、BGP ルーティング アップデートは BGP ルーティング テーブルが変更されるとすぐに送信されます。

peer-group-name 引数を使用して BGP ピア グループを指定する場合、このコマンドで設定される特性が、ピア グループのすべてのメンバーで引き継がれます。

次のルータ コンフィギュレーション モードの例では、BGP ルーティング アップデートの送信の最小間隔を 10 秒に設定します。

router bgp 5
 neighbor 10.4.4.4 advertisement-interval 10

次のアドレス ファミリ コンフィギュレーション モードの例では、BGP ルーティング アップデートの送信の最小間隔を 10 秒に設定します。

router bgp 5
address-family ipv4 unicast
 neighbor 10.4.4.4 advertisement-interval 10

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

neighbor peer-group(作成)

BGP ピア グループを作成します。

neighbor capability orf prefix-list

ピア ルータにアウトバウンド ルート フィルタ(ORF)機能をアドバタイズするには、アドレス ファミリまたはルータ コンフィギュレーション モードで neighbor capability orf prefix-list コマンドを使用します。 ORF 機能をディセーブルにするには、このコマンドの no 形式を使用します。

neighbor ip-address capability orf prefix-list [ receive | send | both ]

no neighbor ip-address capability orf prefix-list [ receive | send | both ]

構文の説明

ip-address

隣接ルータの IP アドレス。

receive

(任意)受信モードの ORF プレフィックス リスト機能をイネーブルにします。

send

(任意)送信モードの ORF プレフィックス リスト機能をイネーブルにします。

both

(任意)受信と送信の両方のモードの ORF プレフィックス リスト機能をイネーブルにします。

コマンド デフォルト

ORF 機能はピア ルータにアドバタイズされません。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.0(11)ST

このコマンドが導入されました。

12.2(4)T

このコマンドが、Cisco IOS Release 12.2(4)T に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

neighbor capability orf prefix-list コマンドは、BGP スピーカーがプレフィックス フィルタリングに基づいてピア ルータと送受信する BGP プレフィックスの数を減らすために使用します。

通常の設定では、このコマンドは、both キーワードを使用して送信と受信の両方の ORF 機能をアドバタイズするために使用します。 ただし、この機能は、2 台のルータ間の 1 方向で、片方のルータを ORF 機能を送信するように設定し、もう片方のルータを最初のルータからの ORF 機能を受信するように設定することで、設定できます。

次の例では、ORF 送受信機能を BGP ネイバーにアドバタイズするようにルータを設定します。

次の例では、アウトバウンド ルート フィルタを作成し、ルータ A(10.1.1.1)がルータ B(172.16.1.2)にフィルタをアドバタイズするよう設定します。 FILTER という名前の IP プレフィックスが作成され、サブネット 192.168.1.0/24 をアウトバウンド ルート フィルタリングに指定します。 ルータ A がアウトバウンド ルート フィルタをルータ B にアドバタイズできるよう、ORF 送信機能がルータ A で設定されます。

ip prefix-list FILTER seq 10 permit 192.168.1.0/24 
!
router bgp 100
 address-family ipv4 unicast 
 neighbor 172.16.1.2 remote-as 200
 neighbor 172.16.1.2 ebgp-multihop 
 neighbor 172.16.1.2 capability orf prefix-list send
 neighbor 172.16.1.2 prefix-list FILTER in
 exit 

次の例では、ORF 受信機能をルータ A にアドバタイズするようにルータ B を設定します。 ORF 機能が交換された後、ルータ B は FILTER プレフィックス リストで定義されたアウトバウンド ルート フィルタをインストールします。 アウトバウンド ルート フィルタをアクティブ化するため、この設定の最後にルータ B でインバウンド ソフト リセットが開始されます。

router bgp 200
 address-family ipv4 unicast 
 neighbor 10.1.1.1 remote-as 100
 neighbor 10.1.1.1 ebgp-multihop 255
 neighbor 10.1.1.1 capability orf prefix-list receive
 end 
clear ip bgp 10.1.1.1 in prefix-filter

(注)  


BGP ORF 機能が正しく動作するために、clear ip bgp コマンドでインバウンド ソフト リセットを開始する必要があります。


関連コマンド

コマンド

説明

neighbor prefix-list

プレフィックス リストで指定された BGP ネイバー情報を配布します。

neighbor default-originate

BGP スピーカー(ローカル ルータ)でデフォルト ルート 0.0.0.0 をネイバーに送信してデフォルト ルートとして使用できるようにするには、アドレス ファミリまたはルータ コンフィギュレーション モードで neighbor default-originate コマンドを使用します。 デフォルトとして使用するルートを送信しないようにするには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } default-originate [ route-map map-name ]

no neighbor { ip-address | peer-group-name } default-originate [ route-map map-name ]

構文の説明

ip-address

ネイバーの IP アドレス。

peer-group-name

BGP ピア グループの名前。

route-map map-name

(任意)ルート マップ名。 ルート マップでは、条件に応じてルート 0.0.0.0 を注入できます。

コマンド デフォルト

デフォルト ルートはネイバーに送信されません。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

11.0

このコマンドが導入されました。

12.0

拡張アクセス リストを許可するように変更が追加されました。

12.0(7)T

アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

このコマンドでは、ローカル ルータに 0.0.0.0 が存在する必要はありません。 ルート マップとともに使用すると、ルート マップに match ip address 句が含まれ、IP アクセス リストに正確に一致するルートがある場合、デフォルト ルート 0.0.0.0 が注入されます。 ルート マップには、他の match 句を含めることができます。

neighbor default-originate コマンドでは、標準または拡張アクセス リストを使用できます。

次のルータの設定例では、ローカル ルータはネイバー 172.16.2.3 にルート 0.0.0.0 を無条件に注入します。

router bgp 109
 network 172.16.0.0
 neighbor 172.16.2.3 remote-as 200
 neighbor 172.16.2.3 default-originate

次の例では、ローカル ルータは、192.168.68.0 へのルートがある場合だけ、ネイバー 172.16.2.3 にルート 0.0.0.0 を注入します(つまり、255.255.255.0 または 255.255.0.0 など任意のマスクを持つルートがある場合)。

router bgp 109
 network 172.16.0.0
 neighbor 172.16.2.3 remote-as 200
 neighbor 172.16.2.3 default-originate route-map default-map
!
route-map default-map 10 permit
 match ip address 1
!
access-list 1 permit 192.168.68.0

次の例では、拡張アクセス リストの使用を示すように、コンフィギュレーションの最後の行が変更されています。 ローカル ルータは、マスク 255.255.0.0 を持つ 192.168.68.0 へのルートがある場合だけ、ネイバー 172.16.2.3 にルート 0.0.0.0 を注入します。

router bgp 109
 network 172.16.0.0
 neighbor 172.16.2.3 remote-as 200
 neighbor 172.16.2.3 default-originate route-map default-map
!
route-map default-map 10 permit
 match ip address 100
!
access-list 100 permit ip host 192.168.68.0 host 255.255.0.0

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

neighbor ebgp-multihop

直接接続されていないネットワーク上の外部ピアからの BGP 接続を受け入れ、またそのピアへの BGP 接続を試みます。

neighbor description

説明をネイバーに関連付けるには、ルータ コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで neighbor description コマンドを使用します。 説明を削除するには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } description text

no neighbor { ip-address | peer-group-name } description [text]

構文の説明

ip-address

ネイバーの IP アドレス。

peer-group-name

EIGRP ピア グループ名。 この引数は、アドレス ファミリ コンフィギュレーション モードでは利用できません。

text

ネイバーを説明するテキスト(最大 80 文字)。

コマンド デフォルト

ネイバーの説明はありません。

コマンド モード

ルータ コンフィギュレーション(config-router)、アドレス ファミリ コンフィギュレーション(config-router-af)

コマンド履歴

リリース

変更内容

11.3

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。 アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

Cisco IOS XE Release 2.6

このコマンドが Cisco IOS XE Release 2.6 に統合されました。

次の例では、ネイバーの説明を「peer with example.com」としてします。

Router(config)# router bgp 109
Router(config-router)# network 172.16.0.0
Router(config-router)# neighbor 172.16.2.3 description peer with example.com

次の例では、アドレス ファミリ ネイバーの説明を「address-family-peer」としています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# 
network 172.16.0.0
Router(config-router-af)# 
neighbor 172.16.2.3 description address-family-peer

関連コマンド

コマンド

説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

network(EIGRP)

EIGRP ルーティング プロセスのネットワークを指定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

neighbor ebgp-multihop

直接接続されていないネットワーク上の外部ピアへの BGP 接続を受け入れ、試行するには、ルータ コンフィギュレーション モードで neighbor ebgp-multihop コマンドを使用します。 デフォルトに戻るには、no 形式のコマンドを使用します。

neighbor { ip-address | ipv6-address | peer-group-name } ebgp-multihop [ttl]

no neighbor { ip-address | ipv6-address | peer-group-name } ebgp-multihop

構文の説明

ip-address

BGP スピーキング ネイバーの IP アドレス。

ipv6-address

BGP スピーキング ネイバーの IPv6 アドレス。

peer-group-name

BGP ピア グループの名前。

ttl

(任意)1 ~ 255 ホップの範囲の存続可能時間。

コマンド デフォルト

直接接続されたネイバーのみ許可されています。

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

11.0

peer-group-name 引数が追加されました。

12.2(33)SRA

ipv6-address 引数と IPv6 アドレス ファミリのサポートが追加されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合されました。

12.2(33)SXI

このコマンドが、Cisco IOS Release 12.2(33)SXI に統合されました。

Cisco IOS XE Release 3.1S

このコマンドが Cisco IOS XE Release 3.1S に統合されました。

使用上のガイドライン

この機能は、シスコ テクニカル サポート担当者の指導の下でのみ使用する必要があります。

peer-group-name 引数を使用して BGP ピア グループを指定する場合、このコマンドで設定される特性が、ピア グループのすべてのメンバーで引き継がれます。

ルーティングの反復によるループの発生を防ぐために、マルチ ホップ ピアへの唯一のルートがデフォルト ルート(0.0.0.0)の場合、マルチ ホップは確立されません。

次の例では、直接接続されていないネットワークに存在するネイバー 10.108.1.1 との接続が許可されます。

router bgp 109
 neighbor 10.108.1.1 ebgp-multihop

関連コマンド

コマンド

説明

neighbor advertise-map non-exist-map

BGP スピーカー(ローカル ルータ)にネイバーへのデフォルト ルート 0.0.0.0 の送信を許可して、このルートがデフォルト ルートとして使用されるようにします。

neighbor peer-group(作成)

BGP ピア グループを作成します。

network(BGP およびマルチプロトコル BGP)

BGP ルーティング プロセスのネットワークのリストを指定します。

neighbor ha-mode graceful-restart

ボーダー ゲートウェイ プロトコル(BGP)ネイバーまたはピア グループの BGP グレースフル リスタート機能をイネーブルまたはディセーブルにするには、ルータ コンフィギュレーション モードで neighbor ha-mode graceful-restart コマンドを使用します。 設定からネイバーの BGP グレースフル リスタート機能を削除するには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } ha-mode graceful-restart [disable]

no neighbor { ip-address | peer-group-name } ha-mode graceful-restart [disable]

構文の説明

ip-address

ネイバーの IP アドレス。

peer-group-name

BGP ピア グループの名前。

disable

(任意)ネイバーの BGP グレースフル リスタート機能をディセーブルにします。

コマンド デフォルト

BGP グレースフル リスタート機能はディセーブルになっています。

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.2(33)SRC

このコマンドが導入されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合されました。

15.1(1)SG

このコマンドが、Cisco IOS Release 15.1(1)SG に統合されました。

Cisco IOS XE 3.3SG

このコマンドが Cisco IOS XE Release 3.3SG に統合されました。

使用上のガイドライン

neighbor ha-mode graceful-restart コマンドは、BGP ネットワークの個別の BGP ネイバーまたはピア グループのグレースフル リスタート機能をイネーブルまたはディセーブルにするために使用します。 BGP ピアに対してグレースフル リスタートを以前にイネーブルにしている場合に、グレースフル リスタート機能をディセーブルにするには、disable キーワードを使用します。

グレースフル リスタート機能は、セッション確立時の OPEN メッセージで、ノンストップ フォワーディング(NSF)対応および NSF 認識のピア間でネゴシエートされます。 BGP セッションの確立後にグレースフル リスタート機能をイネーブルにした場合、ソフトまたはハード リセットでセッションを再起動する必要があります。

グレースフル リスタート機能は、NSF 対応および NSF 認識のルータでサポートされます。 NSF 対応ルータは、ステートフル スイッチオーバー(SSO)の動作(グレースフル リスタート)を実行し、SSO の動作中にルーティング テーブル情報を保持することによって、ピアの再起動を支援することができます。 NSF 認識ルータは NSF 対応ルータと同様に機能しますが、SSO の動作を実行することはできません。

すべての BGP ネイバーの BGP グレースフル リスタート機能を全体的にイネーブルにするには、bgp graceful-restart コマンドを使用します。 個別のネイバーで BGP グレースフル リスタート機能が設定されている場合は、グレースフル リスタートを設定するためのそれぞれの方法のプライオリティは同じであり、最後の設定インスタンスがネイバーに適用されます。

BGP ネイバーの BGP グレースフル リスタートの設定を確認するには、show ip bgp neighbors コマンドを使用します。

次の例は、BGP ネイバー 172.21.1.2 の BGP グレースフル リスタート機能をイネーブルにします。

router bgp 45000
 bgp log-neighbor-changes
 address-family ipv4 unicast
 neighbor 172.21.1.2 remote-as 45000
 neighbor 172.21.1.2 activate
 neighbor 172.21.1.2 ha-mode graceful-restart
 end

次の例は、すべての BGP ネイバーの BGP グレースフル リスタート機能を全体的にイネーブルにしてから、BGP ピア グループ PG1 の BGP グレースフル リスタート機能をディセーブルにします。 BGP ネイバー 172.16.1.2 は、ピア グループ PG1 のメンバーとして設定され、BGP グレースフル リスタート機能のディセーブル化を継承します。

router bgp 45000
 bgp log-neighbor-changes
 bgp graceful-restart
 address-family ipv4 unicast
 neighbor PG1 peer-group
 neighbor PG1 remote-as 45000
 neighbor PG1 ha-mode graceful-restart disable
 neighbor 172.16.1.2 peer-group PG1
 end

関連コマンド

コマンド

説明

bgp graceful-restart

すべての BGP ネイバーで BGP グレースフル リスタート機能をグローバルでイネーブルにします。

ha-mode graceful-restart

BGP ピア セッション テンプレートの BGP グレースフル リスタート機能をイネーブルまたはディセーブルにします。

show ip bgp neighbors

ネイバーへの TCP 接続および BGP 接続についての情報を表示します。

neighbor inherit peer-session

ネイバーがコンフィギュレーションを継承できるように、ピア セッション テンプレートをネイバーに送信するには、アドレス ファミリまたはルータ コンフィギュレーション モードで neighbor inherit peer-session コマンドを使用します。 ピア セッション テンプレートの送信を停止するには、このコマンドの no 形式を使用します。

neighbor ip-address inherit peer-session session-template-name

no neighbor ip-address inherit peer-session session-template-name

構文の説明

ip-address

ネイバーの IP アドレス。

session-template-name

ピア セッション テンプレートの名前またはタグ。

コマンド デフォルト

デフォルトの動作または値はありません。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.0(24)S

このコマンドが導入されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.3(4)T

このコマンドが Cisco IOS Release 12.3(4)T に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

このコマンドは、指定されたネイバーにローカルに設定されたセッション テンプレートを送信するために使用されます。 他のセッション テンプレートからのコンフィギュレーションを継承するようにセッション テンプレートが設定されている場合、指定されたネイバーは、他のセッション テンプレートのコンフィギュレーションも間接的に継承します。 ネイバーは、1 つのピア セッション テンプレートだけを直接継承でき、7 つまでのピア セッション テンプレートを間接的に継承できます。


(注)  


ボーダー ゲートウェイ プロトコル(BGP)ネイバーを、ピア グループとピア テンプレートの両方と連動するようには設定できません。 BGP ネイバーは、1 つのピア グループだけに属するように設定するか、またはピア テンプレートだけからポリシーを継承するように設定できます。


次の例は、CORE1 ピア セッション テンプレートを継承するように、172.16.0.1 ネイバーを設定します。 172.16.0.1 ネイバーは、ピア セッション テンプレート INTERNAL-BGP からも間接的にコンフィギュレーションを継承します。 ネイバー継承文を動作させるには、remote-as 文を明示的に使用する必要があります。 ピアリングが設定されていない場合、指定されたネイバーはセッション テンプレートを受け付けません。

Router(config)# router bgp 101
Router(config)# neighbor 172.16.0.1 remote-as 202
Router(config-router)# neighbor 172.16.0.1 inherit peer-session CORE1

関連コマンド

コマンド

説明

exit peer-session

セッション テンプレート コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードを開始します。

inherit peer-session

別のピア セッション テンプレートのコンフィギュレーションを継承するように、ピア セッション テンプレートを設定します。

show ip bgp neighbors

ネイバーへの TCP 接続および BGP 接続についての情報を表示します。

show ip bgp template peer-session

ローカルに設定されたピア セッション テンプレートを表示します。

template peer-session

ピア セッション テンプレートを作成し、セッション テンプレート コンフィギュレーション モードを開始します。

neighbor maximum-prefix(BGP)

ネイバーから受信できるプレフィックスの数を制御するには、ルータ コンフィギュレーション モードで neighbor maximum-prefix コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } maximum-prefix maximum [threshold] [ restart restart-interval ] [warning-only]

no neighbor { ip-address | peer-group-name } maximum-prefix maximum

構文の説明

ip-address

ネイバーの IP アドレス。

peer-group-name

ボーダー ゲートウェイ プロトコル(BGP)ピア グループの名前。

maximum

指定ネイバーから受信できるプレフィックスの最大数。 設定可能なプレフィックス数は、ルータ上の使用可能なシステム リソースのみによって制限されます。

threshold

(任意)最大プレフィックス数の制限値の何パーセントになったらルータが警告メッセージを生成するかを示すパーセンテージ。 指定できる範囲は 1 ~ 100 で、デフォルトは 75 です。

restart

(任意)最大プレフィックス制限を超えたためにディセーブルになったピアリング セッションを自動的に再確立するように、BGP を実行しているルータを設定します。 再起動タイマーは restart-interval 引数で設定されます。

restart-interval

(任意)ピアリング セッションが再確立される時間間隔(分単位)。 範囲は 1 ~ 65535 分です。

warning-only

(任意)最大プレフィックス数の制限値を超えた場合、ピアリング セッションを終了せずに、ルータで syslog メッセージを生成できるようにします。

コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。 最大プレフィックス数を超えると、ピアリング セッションはディセーブルになります。 restart-interval 引数が設定されていないと、最大プレフィックス制限を超えた後もディセーブルになったセッションはダウン状態のままになります。

threshold:75%

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

11.3

このコマンドが導入されました。

12.0(22)S

restart キーワードが導入されました。

12.2(15)T

restart キーワードが、Cisco IOS リリース 12.2(15)T に統合されました。

12.2(18)S

restart キーワードが、Cisco IOS リリース 12.2(18)S に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.2(4)S

このコマンドが Cisco IOS Release 15.2(4)S に統合されました。

使用上のガイドライン

neighbor maximum-prefix コマンドを使用すると、ボーダー ゲートウェイ プロトコル(BGP)ルーティング プロセスが指定ピアから受け入れるプレフィックスの最大数を設定できます。 この機能は、ピアから受信されるプレフィックスの制御メカニズムを提供します(配布リスト、フィルタ リスト、ルート マップに加えて)。

受信プレフィックスの数が設定されている最大数を超えると、BGP はピアリング セッションをディセーブルにします(デフォルト)。 restart キーワードが設定されている場合、BGP は設定されている時間間隔でピアリング セッションを自動的に再確立します。 restart キーワードが設定されていないと、最大プレフィックス数の制限値を超えたためにピアリング セッションが終了した場合、そのピアリング セッションは clear ip bgp コマンドが入力されるまで再確立されません。 warning-only キーワードが設定されていれば、BGP はログ メッセージだけを送信し、送信側とピアを保ちます。

このコマンドで設定できるプレフィックス数には、デフォルトの制限値はありません。 設定可能なプレフィックス数の制限は、システム リソースの容量によって決まります。

次の例では、192.168.1.1 ネイバーから受け入れられる最大プレフィックス数が 1000 に設定されます。

Router(config)# router bgp 40000
 
Router(config-router)# network 192.168.0.0
 
Router(config-router)# neighbor 192.168.1.1 maximum-prefix 1000

次の例では、192.168.2.2 ネイバーから受け入れられる最大プレフィックス数が 5000 に設定されます。 ルータは、最大プレフィックス リミット(2500 プレフィックス)の 50% に到達した段階で警告メッセージを表示するようにも設定されます。

Router(config)# router bgp 40000 
Router(config-router)# network 192.168.0.0
 
Router(config-router)# neighbor 192.168.2.2 maximum-prefix 5000 50

次の例では、192.168.3.3 ネイバーから受け入れられる最大プレフィックス数が 2000 に設定されます。 ルータは、30 分後にディセーブルにされたピアリング セッションを再確立するようにも設定されます。

Router(config)# router bgp 40000
 
Router(config-router) network 192.168.0.0
 
Router(config-router)# neighbor 192.168.3.3 maximum-prefix 2000 restart 30

次の例では、192.168.4.4 ネイバーの最大プレフィックス数の制限値(500 x 0.75 = 375)を超えると警告メッセージが表示されます。

Router(config)# router bgp 40000
 
Router(config-router)# network 192.168.0.0
 
Router(config-router)# neighbor 192.168.4.4 maximum-prefix 500 warning-only
 

関連コマンド

コマンド

説明

clear ip bgp

BGP ソフト再設定を使用して BGP 接続をリセットします。

neighbor peer-group(メンバーの割り当て)

BGP ネイバーをピア グループのメンバーとして設定するには、アドレス ファミリまたはルータ コンフィギュレーション モードで neighbor peer-group コマンドを使用します。 ピア グループからネイバーを削除するには、このコマンドの no 形式を使用します。

neighbor { ip-address | ipv6-address } peer-group peer-group-name

no neighbor { ip-address | ipv6-address } peer-group peer-group-name

構文の説明

ip-address

peer-group-name 引数で指定されたピア グループに属する BGP ネイバーの IP アドレス。

ipv6-address

peer-group-name 引数で指定されたピア グループに属する BGP ネイバーの IPv6 アドレス。

peer-group-name

このネイバーが属する BGP ピア グループの名前。

コマンド デフォルト

ピア グループに BGP ネイバーはありません。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

11.0

このコマンドが導入されました。

12.0(7)T

アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(2)T

IPv6 のサポートが追加されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドは、Cisco ASR 1000 シリーズ ルータで追加されました。

使用上のガイドライン

指定された IP アドレスのネイバーは、ピア グループのすべての設定済みオプションを継承します。


(注)  


neighbor peer-group コマンドの no 形式を使用すると、ピア グループの関連付けだけでなく、そのネイバーのすべての BGP 設定が削除されます。


次のルータ コンフィギュレーション モードの例では、internal という名前のピア グループに 3 つのネイバーを割り当てます。

router bgp 100
 neighbor internal peer-group
 neighbor internal remote-as 100
 neighbor internal update-source loopback 0
 neighbor internal route-map set-med out
 neighbor internal filter-list 1 out
 neighbor internal filter-list 2 in
 neighbor 172.16.232.53 peer-group internal
 neighbor 172.16.232.54 peer-group internal
 neighbor 172.16.232.55 peer-group internal
 neighbor 172.16.232.55 filter-list 3 in

次のアドレス ファミリ コンフィギュレーション モードの例では、internal という名前のピア グループに 3 つのネイバーを割り当てます。

router bgp 100
address-family ipv4 unicast
 neighbor internal peer-group
 neighbor internal remote-as 100
 neighbor internal update-source loopback 0
 neighbor internal route-map set-med out
 neighbor internal filter-list 1 out
 neighbor internal filter-list 2 in
 neighbor 172.16.232.53 peer-group internal
 neighbor 172.16.232.54 peer-group internal
 neighbor 172.16.232.55 peer-group internal
 neighbor 172.16.232.55 filter-list 3 in

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

neighbor peer-group(作成)

BGP ピア グループを作成します。

neighbor shutdown

ネイバーまたはピア グループをディセーブルにします。

neighbor peer-group(作成)

BGP またはマルチプロトコル BGP ピア グループを作成するには、アドレス ファミリまたはルータ コンフィギュレーション モードで neighbor peer-group コマンドを使用します。 ピア グループとそのメンバーのすべてを削除するには、このコマンドの no 形式を使用します。

neighbor p eer-group-name peer-group

no neighbor peer-group-name peer-group

構文の説明

peer-group-name

BGP ピア グループの名前。

コマンド デフォルト

BGP ピア グループはありません。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

11.0

このコマンドが導入されました。

11.1(20)CC

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが追加されました。

12.0(2)S

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが追加されました。

12.0(7)T

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが削除されました。

アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

多くの場合、BGP またはマルチプロトコル BGP スピーカーでは、多数のネイバーが同じアップデート ポリシー(つまり、同じアウトバウンド ルート マップ、配布リスト、フィルタ リスト、アップデート ソースなど)を使用して設定されます。 アップデート ポリシーが同じネイバーをピア グループにまとめると設定が簡単になり、アップデートの計算がより効率的になります。


(注)  


ピア グループ メンバーは、複数の論理 IP サブネットにまたがることができ、1 つのピア グループ メンバーから別のピア グループ メンバーにルートを転送、つまり渡すことができます。


neighbor peer-group コマンドでピア グループを作成した後は、そのピア グループを neighbor コマンドで設定できます。 デフォルトでは、ピア グループのメンバーは、ピア グループのすべての設定オプションを継承します。 また、アウトバウンド アップデートに影響しないオプションを無効にするように、メンバーを設定することもできます。

すべてのピア グループ メンバーが、現在の設定とピア グループに対する変更を継承します。 ピア グループ メンバーは常にデフォルトで次の設定オプションを継承します。

  • remote-as(設定されている場合)
  • version
  • update-source
  • outbound route-maps
  • outbound filter-lists
  • outbound distribute-lists
  • minimum-advertisement-interval
  • next-hop-self

ピア グループが remote-as オプションで設定されていない場合は、neighbor {ip-address | peer-group-name} remote-as コマンドでメンバーを設定できます。 このコマンドでは、外部 BGP(eBGP)ネイバーを含むピア グループを作成できます。

次の例では、次のタイプのネイバー ピア グループの作成方法を示します。

  • 内部ボーダー ゲートウェイ プロトコル(iBGP)ピア グループ
  • eBGP ピア グループ
  • マルチプロトコル BGP ピア グループ

次の例では、internal という名前のピア グループで iBGP ネイバーとなるピア グループのメンバーを設定します。 router bgp コマンドと neighbor remote-as コマンドが同じ自律システム(この場合は自律システム 100)を示しているため、定義上、これは iBGP グループになります。 すべてのピア グループ メンバーが、アップデート ソースとしてループバック 0 を使用し、アウトバウンド ルート マップとして set-med を使用します。 neighbor internal filter-list 2 in コマンドにより、172.16.232.55 を除くすべてのネイバーに、インバウンド フィルタ リストとしてフィルタ リスト 2 が設定されていることが示されます。

router bgp 100
 neighbor internal peer-group
 neighbor internal remote-as 100
 neighbor internal update-source loopback 0
 neighbor internal route-map set-med out
 neighbor internal filter-list 1 out
 neighbor internal filter-list 2 in
 neighbor 172.16.232.53 peer-group internal
 neighbor 172.16.232.54 peer-group internal
 neighbor 172.16.232.55 peer-group internal
 neighbor 172.16.232.55 filter-list 3 in

次の例では、neighbor remote-as コマンドを使用しないで、external-peers という名前のピア グループを定義します。 ピア グループの個々のメンバーがそれぞれの自律システム番号で別々に設定されているため、定義上、これは eBGP ピア グループになります。 したがって、ピア グループは自律システム 200、300、および 400 のメンバーで構成されます。 すべてのピア グループ メンバーに、アウトバウンド ルート マップとして set-metric ルート マップ、アウトバウンド フィルタ リストとしてフィルタ リスト 99 が設定されます。 ネイバー 172.16.232.110 を除いて、これらのすべてにインバウンド フィルタ リストとして 101 が設定されます。

router bgp 100
 neighbor external-peers peer-group
 neighbor external-peers route-map set-metric out
 neighbor external-peers filter-list 99 out
 neighbor external-peers filter-list 101 in
 neighbor 172.16.232.90 remote-as 200
 neighbor 172.16.232.90 peer-group external-peers
 neighbor 172.16.232.100 remote-as 300
 neighbor 172.16.232.100 peer-group external-peers
 neighbor 172.16.232.110 remote-as 400
 neighbor 172.16.232.110 peer-group external-peers
 neighbor 172.16.232.110 filter-list 400 in

次の例では、ピア グループのすべてのメンバーがマルチキャスト対応になります。

router bgp 100
neighbor 10.1.1.1 remote-as 1
neighbor 172.16.2.2 remote-as 2
address-family ipv4 multicast
 neighbor mygroup peer-group
 neighbor 10.1.1.1 peer-group mygroup
 neighbor 172.16.2.2 peer-group mygroup
 neighbor 10.1.1.1 activate
 neighbor 172.16.2.2 activate

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

clear ip bgp peer-group

BGP ピア グループのすべてのメンバーを削除します。

show ip bgp peer-group

BGP ピア グループに関する情報を表示します。

neighbor prefix-list

プレフィックス リスト、コネクションレス型ネットワーク サービス(CLNS)フィルタ式、または CLNS フィルタ セットで指定されたボーダー ゲートウェイ プロトコル(BGP)のネイバー情報の配布を防ぐには、アドレス ファミリまたはルータ コンフィギュレーション モードで neighbor prefix-list コマンドを使用します。 フィルタ リストを削除するには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } prefix-list { prefix-list-name | clns-filter-expr-name | clns-filter-set-name } { in | out }

no neighbor { ip-address | peer-group-name } prefix-list { prefix-list-name | clns-filter-expr-name | clns-filter-set-name } { in | out }

構文の説明

ip-address

ネイバーの IP アドレス。

peer-group-name

BGP ピア グループの名前。

prefix-list-name

プレフィックス リストの名前。 この引数は、ルータ コンフィギュレーション モードだけで使用されます。

clns-filter-expr-name

CLNS フィルタ式の名前。 この引数は、ネットワーク サービス アクセス ポイント(NSAP)のアドレス ファミリ コンフィギュレーション モードだけで使用されます。

clns-filter-set-name

CLNS フィルタ セットの名前。 この引数は、NSAP アドレス ファミリ コンフィギュレーション モードだけで使用されます。

in

フィルタ リストはそのネイバーからの入力アドバタイズメントに適用されます。

out

フィルタ リストはそのネイバーへの出力アドバタイズメントに適用されます。

コマンド デフォルト

すべての外部およびアドバタイズされたアドレス プレフィックスが、BGP ネイバーに配布されます。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.0

このコマンドが導入されました。

12.0(7)T

アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(8)T

アドレス ファミリ コンフィギュレーション モードで、CLNS フィルタ式または CLNS フィルタ セットの名前を指定するように prefix-list-name 引数が修正されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE 2.6

このコマンドが Cisco IOS XE Release 2.6 に統合されました。

使用上のガイドライン

プレフィックス リストの使用は、BGP アドバタイズメントをフィルタする 3 種類の方法の 1 つです。 AS-path フィルタを使用することもできます。これは、ip as-path access-list グローバル コンフィギュレーション コマンドで定義され、BGP アドバタイズメントをフィルタするために neighbor filter-list コマンドで使用されます。 BGP アドバタイズメントをフィルタする 3 番目の方法では、neighbor distribute-list コマンドでアクセス リストまたはプレフィックス リストを使用します。

peer-group-name 引数を使用して BGP ピア グループを指定する場合、このコマンドで設定される特性が、ピア グループのすべてのメンバーで引き継がれます。 IP アドレスとともにこのコマンドを指定すると、ピア グループから継承された値が上書きされます。

アドレス ファミリ コンフィギュレーション モードで neighbor prefix-list コマンドを使用して、NSAP BGP アドバタイズメントをフィルタします。


(注)  


特定の方向(インバウンドまたはアウトバウンド)のネイバーに neighbor distribute-listneighbor prefix-list の両方のコマンドを適用しないでください。 これら 2 つのコマンドは相互に排他的であり、インバウンドまたはアウトバウンドのそれぞれの方向に 1 つのコマンドのみ(neighbor distribute-list または neighbor prefix-list)適用できます。


次のルータ コンフィギュレーション モードの例では、ネイバー 10.23.4.1 からの入力アドバタイズメントに abc という名前のプレフィックス リストが適用されます。

router bgp 65200
 network 192.168.1.2
 neighbor 10.23.4.1 prefix-list abc in 

次のアドレス ファミリ コンフィギュレーション モードの例では、ネイバー 10.23.4.2 からの入力アドバタイズメントに abc という名前のプレフィックス リストが適用されます。

router bgp 65001
address-family ipv4 unicast
 network 192.168.2.4
 neighbor 10.23.4.2 prefix-list abc in 

次のルータ コンフィギュレーション モードの例では、ネイバー 10.23.4.3 への出力アドバタイズメントに CustomerA という名前のプレフィックス リストが適用されます。

router bgp 64800
 network 192.168.3.6
 neighbor 10.23.4.3 prefix-list CustomerA out

次のアドレス ファミリ コンフィギュレーション モードの例では、ネイバー 10.1.2.1 へのアウトバウンド アドバタイズメントに default-prefix-only という名前の CLNS フィルタ リストが適用されます。

clns filter-set default-prefix-only deny 49...
clns filter-set default-prefix-only permit default
!
router bgp 65202
 address-family nsap
  neighbor 10.1.2.1 activate
  neighbor 10.1.2.1 default-originate
  neighbor 10.1.2.1 prefix-list default-prefix-only out 

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータでアドレス ファミリ コンフィギュレーション モードを開始して、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータでアドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

clear ip prefix-list

プレフィックス リスト エントリのヒット カウントをリセットします。

clns filter-expr

CLNS フィルタ式にエントリを作成します。

clns filter-set

CLNS フィルタ セットにエントリを作成します。

ip as-path access-list

BGP-related アクセス リストを定義します。

ip prefix-list

プレフィックス リストにエントリを作成します。

ip prefix-list description

プレフィックス リストの説明テキストを追加します。

ip prefix-list sequence-number

プレフィックス リストのエントリのシーケンス番号生成をイネーブルにします。

neighbor filter-list

BGP フィルタを設定します。

show bgp nsap filter-list

フィルタ リストまたはフィルタ リスト エントリに関する情報を表示します。

show ip bgp peer-group

BGP ピア グループに関する情報を表示します。

show ip prefix-list

プレフィックス リストまたはプレフィックス リスト エントリに関する情報を表示します。

neighbor remote-as

BGP またはマルチプロトコル BGP ネイバー テーブルにエントリを追加するには、ルータ コンフィギュレーション モードで neighbor remote-as コマンドを使用します。 テーブルからエントリを削除するには、このコマンドの no 形式を使用します。

neighbor { ip-address | ipv6-address% | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ... ]

no neighbor { ip-address | ipv6-address% | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ... ]

構文の説明

ip-address

ネイバーの IP アドレス。

ipv6-address

ネイバーの IPv6 アドレス。

%

(任意)IPv6 リンクローカル アドレス ID。 このキーワードは、リンクローカル IPv6 アドレスがそのインターフェイスのコンテキスト外で使用される場合は、追加する必要があります。

peer-group-name

BGP ピア グループの名前。

autonomous-system-number

ネイバーが属する自律システムの 1 ~ 65535 の範囲内の番号。

  • Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、4 バイトの自律システム番号は、asplain 表記で 65536 ~ 4294967295 の範囲、asdot 表記で 1.0 ~ 65535.65535 の範囲でサポートされています。
  • Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、4 バイトの自律システム番号は、asdot 表記の 1.0 ~ 65535.65535 の範囲でのみサポートされています。

自律システムの番号形式の詳細については、router bgp コマンドの説明を参照してください。

alternate-as キーワードと一緒に使用した場合は、5 つまでの自律システム番号を入力できます。

alternate-as

(任意)ダイナミック ネイバーの可能性を識別できる代替自律システムを指定します。 このキーワードを指定した場合、最大で 5 つの自律システム番号を入力できます。

コマンド デフォルト

BGP ネイバー ピアもマルチプロトコル BGP ネイバー ピアもありません。

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

11.0

peer-group-name 引数が追加されました。

11.1(20)CC

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが追加されました。

12.0(7)T

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが削除されました。

12.2(4)T

IPv6 アドレス ファミリのサポートが追加されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが変更されました。 % キーワードが追加されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。 BGP ダイナミック ネイバーをサポートするため、alternate-as キーワードが追加されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合されました。

Cisco IOS XE Release 2.1

このコマンドは、Cisco ASR 1000 シリーズ ルータで追加されました。

12.0(32)S12

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.0(32)SY8

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.4(24)T

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 2.3

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.2(33)SXI1

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.0(33)S3

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

Cisco IOS XE Release 2.4

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルトが asplain になりました。

12.2(33)SRE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.2(33)XNE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

15.0(1)S

このコマンドが Cisco IOS Release 15.0(1)S に統合されました。

15.1(1)SG

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 3.3SG

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

15.1(2)SNG

このコマンドが、Cisco ASR 901 シリーズの集約サービス ルータに実装されました。

使用上のガイドライン

router bgp グローバル コンフィギュレーション コマンドで指定されている自律システム番号に一致する自律システム番号を持つネイバーを指定することにより、ネイバーがローカル自律システムの内部にあるとして指定されます。 それ以外の場合は、ネイバーは外部にあると認識されます。

peer-group-name 引数を使用して BGP ピア グループを指定する場合、このコマンドで設定される特性が、ピア グループのすべてのメンバーで引き継がれます。

デフォルトでは、ルータ コンフィギュレーション モードで neighbor remote-as コマンドを使用して定義したネイバーは、ユニキャスト アドレス プレフィックスだけを交換します。 マルチキャストやバーチャル プライベート ネットワーク(VPN)バージョン 4 などの、他のアドレス プレフィックス タイプをやり取りするには、適切なアドレス ファミリ コンフィギュレーション モードで、ネイバーもアクティブにする必要があります。

Cisco IOS Release 12.2(33)SXH で導入された alternate-as キーワードを使用して、ダイナミックな BGP ネイバーが識別される代替自律システムを最大で 5 台指定します。 BGP ダイナミック ネイバーのサポートは、IP アドレスの範囲で定義されたリモート ネイバーのグループへの BGP ピアリングを可能にします。 BGP ダイナミック ネイバーは、IP アドレスおよび BGP ピア グループの範囲を使用して設定されます。 サブネットの範囲が設定され、bgp listen コマンドで BGP ピア グループに関連付けられた後、そのサブネットの範囲の IP アドレスに対して TCP セッションを開始すると、新しい BGP ネイバーがそのグループのメンバーとしてダイナミックに作成されます。 新しい BGP ネイバーはグループの設定またはテンプレートのすべてを継承します。

% キーワードは、リンクローカル IPv6 アドレスがインターフェイスのコンテキスト外で使用されている場合に常に使用します。 このキーワードは、非リンクローカル IPv6 アドレスに使用する必要はありません。

Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、シスコが採用している 4 バイト自律システム番号は、自律システム番号の正規表現のマッチングおよび出力表示形式のデフォルトとして asplain(たとえば、65538)を使用していますが、RFC 5396 に記載されているとおり、4 バイト自律システム番号を asplain 形式および asdot 形式の両方で設定できます。 4 バイト自律システム番号の正規表現マッチングと出力表示のデフォルトを asdot 形式に変更するには、bgp asnotation dot コマンドに続けて、clear ip bgp * コマンドを実行し、現在の BGP セッションをすべてハード リセットします。

Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、シスコが採用している 4 バイト自律システム番号は、設定形式、正規表現とのマッチング、および出力表示として asdot(たとえば、1.2)のみを使用します。asplain はサポートしていません。


(注)  


4 バイト ASN のサポートを含む Cisco IOS リリースでは、4 バイト ASN 番号を含むコマンド アカウンティングおよびコマンド許可が、コマンドライン インターフェイスで使用されている形式に関係なく、asplain 表記で送信されます。


円滑に移行するには、4 バイト自律システム番号を使用して指定されている自律システム内にあるすべての BGP スピーカーで、4 バイト自律システム番号をサポートするようアップグレードすることを推奨します。

次に、アドレス 10.108.1.2 にあるルータが、自律システム番号 65200 にある内部 BGP(iBGP)ネイバーになるよう指定する例を示します。

router bgp 65200
 network 10.108.0.0
 neighbor 10.108.1.2 remote-as 65200

次に、IPv6 アドレス 2001:0DB8:1:1000::72a にあるルータが自律システム番号 65001 の外部 BGP(eBGP)ネイバーであることを指定する例を示します。

router bgp 65300
 address-family ipv6 vrf site1
 neighbor 2001:0DB8:1:1000::72a remote-as 65001

次に、BGP ルータを自律システム 65400 に割り当て、自律システムの送信元として 2 つのネットワークのリストが表示される例を示します。 3 つのリモート ルータ(とその自律システム)のアドレスのリストが表示されます。 設定中のルータでは、ネットワーク 10.108.0.0 とネットワーク 192.168.7.0 の情報が、隣接ルータと共有されます。 1 つ目のルータは、この設定が入力されたルータ(eBGP ネイバー)とは異なる自律システムにあるリモート ルータです。2 つ目の neighbor remote-as コマンドにより、アドレス 10.108.234.2 の(自律システムの番号が同じの)内部 BGP ネイバーが表示されます。最後の neighbor remote-as コマンドにより、この設定が入力されたルータとは異なるネットワークにあるネイバー(これも eBGP ネイバー)が指定されます。

router bgp 65400
 network 10.108.0.0
 network 192.168.7.0
 neighbor 10.108.200.1 remote-as 65200
 neighbor 10.108.234.2 remote-as 65400
 neighbor 172.29.64.19 remote-as 65300

次に、マルチキャスト ルータだけでやり取りするため、自律システム番号 65001 にあるネイバー 10.108.1.1 を設定する例を示します。

router bgp 65001
 neighbor 10.108.1.1 remote-as 65001
 neighbor 172.31 1.2 remote-as 65001
 neighbor 172.16.2.2 remote-as 65002
 address-family ipv4 multicast
  neighbor 10.108.1.1 activate
  neighbor 172.31 1.2 activate
  neighbor 172.16.2.2 activate
  exit-address-family

次に、ユニキャスト ルータだけでやり取りするため、自律システム番号 65001 にあるネイバー 10.108.1.1 を設定する例を示します。

router bgp 65001
 neighbor 10.108.1.1 remote-as 65001
 neighbor 172.31 1.2 remote-as 65001
 neighbor 172.16.2.2 remote-as 65002

Cisco IOS Release 12.2(33)SXH 以降のリリースでのみ設定可能な次の例では、192.168.0.0/16 のサブネット範囲を設定し、このリッスン範囲を BGP ピア グループに関連付けます。 BGP ダイナミック ネイバー機能用に設定されたリッスン範囲ピア グループは、neighbor activate コマンドを使用して IPv4 アドレス ファミリでアクティブ化できることに注意してください。 ルータ 1 の初期設定後に、ルータ 2 が BGP ルータ セッションを開始し、BGP ネイバー テーブルにルータ 1 を追加すると、TCP セッションが開始され、新規ネイバーの IP アドレスがリッスン範囲サブネット内にあるため、ルータ 1 によって新しい BGP ネイバーがダイナミックに作成されます。

enable
configure terminal
router bgp 45000
 bgp log-neighbor-changes
 neighbor group192 peer-group 
 bgp listen range 192.168.0.0/16 peer-group group192   
 neighbor group192 remote-as 40000 alternate-as 50000
 address-family ipv4 unicast 
 neighbor group192 activate
 end

enable
configure terminal
router bgp 50000
 neighbor 192.168.3.1 remote-as 45000
 exit

show ip bgp summary コマンドをルータ 1 で入力すると、ダイナミックに作成された BGP ネイバー 192.168.3.2 が出力に示されます。

Router1# show ip bgp summary
BGP router identifier 192.168.3.1, local AS number 45000
BGP table version is 1, main routing table version 1
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
*192.168.3.2    4 50000       2       2        0    0    0 00:00:37        0
* Dynamically created based on a listen range command
Dynamically created neighbors: 1/(200 max), Subnet ranges: 1
BGP peergroup group192 listen range group members: 
  192.168.0.0/16 

次に、自律システム 65538 に BGP プロセスを設定し、asplain 形式の 4 バイト自律システム番号を使用して、2 つの外部 BGP ネイバーをそれぞれ異なる自律システムで設定する例を示します。 この例は、Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、またはそれ以降のリリースでのみサポートされます。

router bgp 65538
 neighbor 192.168.1.2 remote-as 65536
 neighbor 192.168.3.2 remote-as 65550
 neighbor 192.168.3.2 description finance
 !
 address-family ipv4
  neighbor 192.168.1.2 activate
  neighbor 192.168.3.2 activate
  no auto-summary
  no synchronization
  network 172.17.1.0 mask 255.255.255.0
  exit-address-family

次に、自律システム 1.2 に BGP プロセスを設定し、asdot 形式の 4 バイト自律システム番号を使用して、2 つの外部 BGP ネイバーをそれぞれ異なる自律システムで設定する例を示します。 この例では、Cisco IOS Release 12.0(32)SY8、12.0(32)S12、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、12.4(24)T、Cisco IOS XE Release 2.3、またはそれ以降のリリースが必要です。

router bgp 1.2
 neighbor 192.168.1.2 remote-as 1.0
 neighbor 192.168.3.2 remote-as 1.14
 neighbor 192.168.3.2 description finance
 !
 address-family ipv4
  neighbor 192.168.1.2 activate
  neighbor 192.168.3.2 activate
  no auto-summary
  no synchronization
  network 172.17.1.0 mask 255.255.255.0
  exit-address-family

関連コマンド

コマンド

説明

bgp asnotation dot

デフォルトの表示を変更し、BGP 4 バイト自律システム番号の正規表現一致形式を、asplain(10 進数の値)からドット付き表記にします。

bgp listen

サブネット範囲を BGP ピア グループと関連付け、BGP ダイナミック ネイバー機能をアクティブにします。

neighbor peer-group

BGP ピア グループを作成します。

router bgp

BGP ルーティング プロセスを設定します。

neighbor route-map

着信ルートまたは発信ルートにルート マップを適用するには、アドレス ファミリまたはルータ コンフィギュレーション モードで neighbor route-map コマンドを使用します。 ルート マップを削除するには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name | ipv6-address [ % ] } route-map map-name { in | out }

no neighbor { ip-address | peer-group-name | ipv6-address [ % ] } route-map map-name { in | out }

構文の説明

ip-address

ネイバーの IP アドレス。

peer-group-name

BGP またはマルチプロトコル BGP ピア グループの名前。

ipv6-address

ネイバーの IPv6 アドレス。

%

(任意)IPv6 リンクローカル アドレス ID。 このキーワードは、リンクローカル IPv6 アドレスがそのインターフェイスのコンテキスト外で使用される場合は、追加する必要があります。

map-name

ルート マップの名前。

in

着信ルートにルート マップを適用します。

out

発信ルートにルート マップを適用します。

コマンド デフォルト

ルート マップは、ピアに適用されません。

コマンド モード

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.0(7)T

アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(4)T

IPv6 のサポートが追加されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

% キーワードが追加されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合されました。

Cisco IOS XE Release 2.1

このコマンドは、Cisco ASR 1000 シリーズ ルータで追加されました。

12.2(33)SXI

このコマンドが、Cisco IOS Release 12.2(33)SXI に統合されました。

使用上のガイドライン

アドレス ファミリ コンフィギュレーション モードで指定する場合、このコマンドはそのアドレス ファミリだけにルート マップを適用します。 ルータ コンフィギュレーション モードで指定する場合、このコマンドは IPv4 または IPv6 ユニキャスト ルートだけにルート マップを適用します。

アウトバウンド ルート マップが指定されている場合、ルート マップの少なくとも 1 つのセクションと一致するルートしかアドバタイズしないのは適切な動作です。

peer-group-name 引数を使用して BGP またはマルチキャスト BGP ピアグループを指定する場合、このコマンドで設定される特性が、ピア グループのすべてのメンバーに引き継がれます。 ネイバーに対してコマンドを指定すると、ピア グループから継承されたインバウンド ポリシーが上書きされます。

% キーワードは、リンクローカル IPv6 アドレスがインターフェイスのコンテキスト外で使用されている場合に常に使用します。 このキーワードは、非リンクローカル IPv6 アドレスに使用する必要はありません。

次のルータ コンフィギュレーション モードの例では、172.16.70.24 からの BGP 着信ルートに internal-map という名前のルート マップが適用されます。

router bgp 5
 neighbor 172.16.70.24 route-map internal-map in
route-map internal-map
 match as-path 1
 set local-preference 100

次のアドレス ファミリ コンフィギュレーション モードの例では、172.16.70.24 からのマルチプロトコル BGP 着信ルートに internal-map という名前のルート マップが適用されます。

router bgp 5
address-family ipv4 multicast
 neighbor 172.16.70.24 route-map internal-map in
route-map internal-map
 match as-path 1
 set local-preference 100

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IP バージョン 4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family ipv6

標準 IPv6 アドレス プレフィックスを使用する BGP などのルーティング セッションを設定するために、アドレス ファミリ コンフィギュレーション モードを開始します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPN バージョン 4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv6

標準 VPNv6 アドレス プレフィックスを使用するルーティング セッションを設定するために、ルータをアドレス ファミリ コンフィギュレーション モードにします。

neighbor remote-as

BGP ピア グループを作成します。

neighbor shutdown

ネイバーまたはピア グループをディセーブルにしたり、メンテナンスのためにリンクを正常にシャットダウンするには、ルータ コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで neighbor shutdown コマンドを使用します。 ネイバーまたはピア グループを再びイネーブルにするには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } shutdown graceful seconds [ community value] [ local-preference value ] [ community value ] [ local-preference value]

no neighbor { ip-address | peer-group-name } shutdown graceful seconds [ community value] [ local-preference value ] [ community value ] [ local-preference value]

構文の説明

ip-address

ネイバーの IP アドレス。

peer-group-name

BGP ピア グループの名前。

graceful

(任意)指定されている場合は、BGP グレースフル シャットダウンを設定し、GSHUT コミュニティや他のコミュニティを使用してルートをアドバタイズします。

seconds

(任意)BGP グレースフル シャットダウンが発生する秒数。

  • 範囲は 30 ~ 65535 秒です。
  • iBGP ピアが収束し、最良パスである代替パスを選択できるように、十分な時間を設定します。

community

別のコミュニティ値を追加する必要があるかどうかを指定します。

value

値を追加する必要があるかどうかを指定します。

  • GSHUT コミュニティがデフォルトで設定されます。 ルーティング ポリシーを適用するために受信ルータで使用できる、GSHUT コミュニティ以外のコミュニティを指定できます。 1 ~ 4294967295 の数。

local-preference

GSHUT コミュニティと指定したローカル プリファレンス値を使用してルートをアドバタイズします。

value

ネイバーへのルートに割り当てられるローカル プリファレンスの値。

  • 指定できる範囲は 1 ~ 4294967295 です。

コマンド デフォルト

BGP ネイバーまたはピア グループの状態は何も変更されません。

コマンド モード

ルータ コンフィギュレーション(config-router)

アドレス ファミリ コンフィギュレーション(config-router-af)

コマンド履歴

リリース

変更内容

12.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.2(2)S

このコマンドが変更されました。 graceful seconds キーワードと引数、community value キーワードと引数、および local-preference value キーワードと引数が追加されました。

Cisco IOS XE 3.6S

このコマンドが変更されました。 graceful seconds キーワードと引数、community value キーワードと引数、および local-preference value キーワードと引数が追加されました。

Cisco IOS XE 3.7S

このコマンドが Cisco ASR 903 ルータに実装されました。

15.2(4)M

このコマンドが、Cisco IOS Release 15.2(4)M に統合されました。

15.2(4)S

このコマンドが Cisco 7200 シリーズ ルータに実装されました。

使用上のガイドライン

neighbor shutdown コマンドは、指定されたネイバーまたはピア グループのアクティブ セッションを終了し、すべての関連するルーティング情報を削除します。 ピア グループの場合、多数のピアリング セッションが突然終了される可能性があります。

BGP ネイバーおよびピア グループ接続の概要を表示するには、show ip bgp summary コマンドを使用します。 アイドル状態のネイバーおよび Admin エントリは neighbor shutdown コマンドによってディセーブルにされています。

「State/PfxRcd」は、BGP セッションの状態や、ルータがネイバーまたはピア グループから受信したプレフィックスの数を示します。 最大数(neighbor maximum-prefix コマンドで設定)に達すると、文字列「PfxRcd」がエントリに表示され、ネイバーがシャットダウンされて、接続がアイドルになります。

BGP グレースフル シャットダウン

手動による、または計画的なメンテナンス作業のためにリンクをシャット ダウンし、それによるパケット損失を軽減または排除するために BGP グレースフル シャット ダウン機能を使用します。 この機能は、(すべてのアドレス ファミリに対して)全体的に、または IPv4 VRF や IPv6 VRF アドレス ファミリに対して設定できます。

iBGP ピアが収束し、最良パスである代替パスを選択できるように、十分な時間を設定する必要があることに注意してください。 ネットワーク管理者が短すぎる秒数を指定することを BGP では禁止していません。この場合、グレースフル シャットダウンのための十分な時間が取れなくなります。

また、graceful キーワードを使用する場合は、community または local-preference キーワードのうち少なくとも 1 つを設定する必要があります。 communitylocal-preference の両方のキーワードを使用できます。

グレースフル シャットダウン タイマーの実行中に、nvgen に格納されるものはありません。 シャットダウンした後でのみ、neighbor shutdown コマンドの nvgen が格納されます。

neighbor ip-address shutdown graceful seconds local-pref value community value

グレースフル シャットダウン タイマーの期限が切れた場合、コマンドは次のように nvgen に格納されます。

neighbor ip-address shutdown

clear ip bgp コマンドを使用してセッションをリセットすると、すべてのタイマーがリセットされます。 したがって、グレースフル シャットダウンは行われません。

次の例では、ネイバー 172.16.70.23 のすべてのアクティブ セッションをディセーブルにします。

neighbor 172.16.70.23 shutdown

次の例では、internal という名前のピア グループのすべてのピアリング セッションをディセーブルにします。

neighbor internal shutdown

次の例では、1200 秒で正常にシャットダウンし、既知の GSHUT コミュニティと 400 のローカル プリファレンスを使用してルートをアドバタイズするように、指定されたネイバーを設定します。

neighbor 2001:db8:a::1 shutdown graceful 1200 local-preference 400

関連コマンド

コマンド

説明

ip community-list

BGP コミュニティ リストを作成します。

neighbor maximum-prefix

ネイバーから受信できるプレフィックスの数を制御します。

show ip bgp community

さまざまなコミュニティに属するネイバーを表示します。

show ip bgp summary

BGP 接続すべての状況を表示します。

neighbor soft-reconfiguration

アップデートの格納を開始するように Cisco IOS ソフトウェア設定するには、ルータ コンフィギュレーション モードで neighbor soft-reconfiguration コマンドを使用します。 受信したアップデートを格納しないようにするには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } soft-reconfiguration inbound

no neighbor { ip-address | peer-group-name } soft-reconfiguration inbound

構文の説明

ip-address

BGP スピーキング ネイバーの IP アドレス。

peer-group-name

BGP ピア グループの名前。

inbound

保存するアップデートが着信したアップデートであることを示します。

コマンド デフォルト

ソフト再設定がイネーブルではありません。

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

11.2

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

このコマンドを入力すると、アップデートの格納が開始されます。これは着信ソフト再設定を行うために必要です。 BGP 発信ソフト再設定では、着信ソフト再設定をイネーブルにする必要はありません。

事前設定ではなく、ソフト再設定(ソフト リセット)を使用するには、両方の BGP ピアがソフト ルート リフレッシュ機能をサポートしている必要があります。この機能は、ピアが TCP セッションを確立する際に送信する OPEN メッセージに格納され、アドバタイズされます。 リリース 12.1 よりも前の Cisco IOS ソフトウェア リリースが実行されているルータでは、ルート リフレッシュ機能がサポートされていないため、neighbor soft-reconfiguration コマンドを使用して、BGP セッションをクリアする必要があります。 neighbor soft-reconfiguration コマンドを使用して BGP セッションをクリアするとネットワーク動作に悪影響が及ぶため、最終手段としてのみ使用してください。 Cisco IOS ソフトウェア リリース 12.1 以降のリリースが実行されているルータでは、ルート リフレッシュ機能およびダイナミック ソフト リセットがサポートされているため、clear ip bgp{*| address| peer-group name} in コマンドを使用して BGP セッションをクリアできます。

BGP ルータがこの機能をサポートしているかどうかを確認するには、show ip bgp neighbors コマンドを使用します。 ルータがルータ リフレッシュ機能をサポートしている場合は、次のメッセージが表示されます。

Received route refresh capability from peer.

peer-group-name 引数を使用して BGP ピア グループを指定する場合、このコマンドで設定される特性が、ピア グループのすべてのメンバーで引き継がれます。

次に、ネイバー 10.108.1.1 の着信ソフト再設定をイネーブルにする例を示します。 このネイバーから受信されるすべてのアップデートは、着信ポリシーを無視してそのまま格納されます。 後になって着信ソフト再設定が行われるときは、格納されている情報を使用して新しい着信アップデートのセットが生成されます。

router bgp 100
 neighbor 10.108.1.1 remote-as 200
 neighbor 10.108.1.1 soft-reconfiguration inbound

関連コマンド

コマンド

説明

clear ip bgp

BGP ソフト再設定を使用して BGP 接続をリセットします。

neighbor remote-as

BGP ピア グループを作成します。

show ip bgp neighbors

ネイバーへの TCP 接続および BGP 接続についての情報を表示します。

neighbor unsuppress-map

aggregate-address ですでに抑制されているルートを選択的にアドバタイズするには、アドレス ファミリまたはルータ コンフィギュレーション モードで neighbor unsuppress-map コマンドを使用します。 システムをデフォルトの状態に戻すには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } unsuppress-map route-map-name

no neighbor { ip-address | peer-group-name } unsuppress-map route-map-name

構文の説明

ip-address

BGP スピーキング ネイバーの IP アドレス。

peer-group-name

BGP ピア グループの名前。

route-map-name

ルート マップの名前。

コマンド デフォルト

ルートは抑制されていません。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.0(5)T

このコマンドが導入されました。

12.0(5)T

アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

neighbor unsuppress-map コマンドを使用すると、抑制された特定のルートをアドバタイズできるようになります。

次の BGP ルータのコンフィギュレーションでは、map1 という名前のルート マップで指定されているルートが抑制されます。

access-list 3 deny 172.16.16.6
access-list 3 permit any
route-map map1 permit 10
match ip address 3
!
router bgp 65000 
network 172.16.0.0
neighbor 192.168.1.2 remote-as 40000
aggregate-address 172.0.0.0 255.0.0.0 suppress-map map1
neighbor 192.168.1.2 unsuppress-map map1
neighbor 192.168.1.2 activate

次に、internal-map で指定されているルートのネイバー 172.16.16.6 に対する抑制が解除される例を示します。

router bgp 100
address-family ipv4 multicast
 network 172.16.0.0
 neighbor 172.16.16.6 unsuppress-map internal-map

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルーティングをアドレス ファミリ コンフィギュレーション モードにして、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

aggregate-address

BGP ルーティング テーブルに集約エントリを作成します。

neighbor route-map

インバウンドまたはアウトバウンドのルートにルート マップを適用します。

neighbor update-source

ボーダー ゲートウェイ プロトコル(BGP)セッションで TCP 接続の動作インターフェイスを使用できるようにシスコのソフトウェアを設定するには、ルータ コンフィギュレーション モードで neighbor update-source コマンドを使用します。 インターフェイスの割り当てを最も近いインターフェイス(最適ローカル アドレス)に復元するには、このコマンドの no 形式を使用します。

neighbor { ip-address | ipv6-address [ % ] | peer-group-name } update-source interface-type interface-number

neighbor { ip-address | ipv6-address [ % ] | peer-group-name } update-source interface-type interface-number

構文の説明

ip-address

BGP スピーキング ネイバーの IPv4 アドレス。

ipv6-address

BGP スピーキング ネイバーの IPv6 アドレス。

%

(任意)IPv6 リンクローカル アドレス ID。 このキーワードは、リンクローカル IPv6 アドレスがそのインターフェイスのコンテキスト外で使用される場合は、追加する必要があります。

peer-group-name

BGP ピア グループの名前。

interface-type

インターフェイス タイプ。

interface-number

インターフェイス番号を指定します。

コマンド デフォルト

最良ローカル アドレス

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(4)T

引数 ipv6-address が追加されました。

12.0(21)ST

このコマンドが Cisco IOS Release 12.0(21)ST に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

% キーワードが追加されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco ASR 1000 シリーズ ルータで導入されました。

15.1(2)SNG

このコマンドが、Cisco ASR 901 シリーズの集約サービス ルータに実装されました。

使用上のガイドライン

このコマンドは、『Cisco IOS Interface and Hardware Component Configuration Guide』の「Interface Configuration Overview」の章で説明されているループバック インターフェイス機能とともに動作できます。

peer-group-name 引数を使用して BGP ピア グループを指定する場合、このコマンドで設定される特性が、ピア グループのすべてのメンバーで引き継がれます。

内部または外部 BGP セッションの IPv6 リンクローカル ピアリングをイネーブルにするには、neighbor update-source コマンドを使用する必要があります。

リンク ローカル IPv6 アドレスをインターフェイスのコンテキスト外で使用する場合には常に % キーワードを使用し、これらのリンク ローカル IPv6 アドレスについて、それらが存在するインターフェイスを指定する必要があります。 構文は <IPv6 local-link address>%<interface name>(例:FE80::1%Ethernet1/0)のようになります。 インターフェイスのタイプと番号にスペースを含めることはできません。また、この場合の名前の短縮はサポートされていないため、省略なしで使用する必要があります。 % キーワードと後続のインターフェイスの構文は、非リンクローカル IPv6 アドレスには使用しません。

次に、指定されたネイバーの BGP TCP 接続に、ベスト ローカル アドレスではなく、ループバック インターフェイスの IP アドレスを提供する例を示します。

router bgp 65000
 network 172.16.0.0
 neighbor 172.16.2.3 remote-as 110
 neighbor 172.16.2.3 update-source Loopback0

次に、自律システム 65000 内の指定されたネイバーの IPv6 BGP TCP 接続にループバック インターフェイス 0 のグローバル IPv6 アドレスを指定し、自律システム 65400 内の指定されたネイバーにファスト イーサネット インターフェイス 0/0 のリンクローカル IPv6 アドレスを提供する例を示します。 FE80::2 のリンク ローカル IPv6 アドレスはイーサネット インターフェイス 1/0 上にあることに注意してください。

router bgp 65000
 neighbor 3ffe::3 remote-as 65000 
 neighbor 3ffe::3 update-source Loopback0 
 neighbor fe80::2%Ethernet1/0 remote-as 65400 
 neighbor fe80::2%Ethernet1/0 update-source FastEthernet 0/0 
 address-family ipv6 
  neighbor 3ffe::3 activate 
  neighbor fe80::2%Ethernet1/0 activate 
  exit-address-family 

関連コマンド

コマンド

説明

neighbor activate

BGP 隣接ルータとの情報交換をイネーブルにします。

neighbor remote-as

BGP ネイバー テーブルまたはマルチプロトコル BGP ネイバー テーブルにエントリを追加します。

network(BGP およびマルチプロトコル BGP)

ボーダー ゲートウェイ プロトコル(BGP)およびマルチプロトコル BGP ルーティング プロセスによってアドバタイズされるネットワークを指定するには、アドレス ファミリまたはルータ コンフィギュレーション モードで network コマンドを使用します。 ルーティング テーブルからエントリを削除するには、このコマンドの no 形式を使用します。

network { network-number [ mask network-mask ] | nsap-prefix } [ route-map map-tag ]

no network { network-number [ mask network-mask ] | nsap-prefix } [ route-map map-tag ]

構文の説明

network-number

BGP またはマルチプロトコル BGP がアドバタイズするネットワーク。

mask network-mask

(任意)マスク アドレスを持つネットワークまたはサブネットワーク マスク。

nsap-prefix

BGP またはマルチプロトコル BGP がアドバタイズするコネクションレス型ネットワーク サービス(CLNS)ネットワークのネットワーク サービス アクセス ポイント(NSAP)プレフィックス。 この引数は、NSAP アドレス ファミリ コンフィギュレーション モードだけで使用されます。

route-map map-tag

(任意)設定済みルート マップの ID。 ルート マップを検証してアドバタイズされるネットワークをフィルタする必要があります。 指定されていない場合、すべてのネットワークがアドバタイズされます。 キーワードが指定されているが、ルート マップ タグがリストされていない場合、ネットワークはアドバタイズされません。

コマンド デフォルト

ネットワークは指定されていません。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.0

BGP ルータ 1 台あたり 200 network コマンドという制限が廃止されました。

11.1(20)CC

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが追加されました。

12.0(7)T

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが削除されました。

アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(8)T

nsap prefix 引数が、アドレス ファミリ コンフィギュレーション モードに追加されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

Cisco IOS XE 2.6

このコマンドが Cisco IOS XE Release 2.6 に統合されました。

使用上のガイドライン

BGP およびマルチプロトコル BGP ネットワークは、接続されたルート、ダイナミック ルーティング、およびスタティック ルート ソースから認識可能です。

使用できる network コマンドの最大数は、設定されている NVRAM または RAM などのルータのリソースによって決まります。

次に、BGP アップデートに含めるネットワーク 10.108.0.0 の設定例を示します。

router bgp 65100
 network 10.108.0.0

次に、マルチプロトコル BGP アップデートに含めるネットワーク 10.108.0.0 の設定例を示します。

router bgp 64800
address family ipv4 multicast
 network 10.108.0.0

次に、マルチプロトコル BGP アップデートの NSAP プレフィックス 49.6001 をアドバタイズする例を示します。

router bgp 64500
 address-family nsap
  network 49.6001

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータでアドレス ファミリ コンフィギュレーション モードを開始して、標準 IP バージョン 4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータでアドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

default-information originate(BGP)

ネットワーク 0.0.0.0 の BGP への再配布を可能にします。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

router bgp

BGP ルーティング プロセスを設定します。

network backdoor

BGP で学習された、より詳細なネットワーク情報を提供するプレフィックスに、バック ドア ルートを指定するには、アドレス ファミリまたはルータ コンフィギュレーション モードで network backdoor コマンドを使用します。 リストからアドレスを削除するには、このコマンドの no 形式を使用します。

network ip-address backdoor

no network ip-address backdoor

構文の説明

ip-address

バック ドア ルートを必要とするネットワークの IP アドレス。

コマンド デフォルト

どのネットワークにもバック ドアがあるというマークは付けられません。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.0(7)T

アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

バックドア ネットワークには 200 のアドミニストレーティブ ディスタンスが割り当てられます。 目的は、Interior Gateway Protocol(IGP)で学習されたルートを優先するようにすることです。 バックドア ネットワークはローカル ネットワークとして扱われますが、アドバタイズされません。 バック ドアとしてマークされたネットワークは、ローカル ルータでは提供されないため、外部ネイバーから認識する必要があります。 ネットワークをバックドアとして設定しても、BGP 最適パス選択アルゴリズムは変わりません。

次のアドレス ファミリ コンフィギュレーションの例では、ローカル ネットワークとしてネットワーク 10.108.0.0、バックドア ネットワークとしてネットワーク 192.168.7.0 を設定します。

router bgp 109
address-family ipv4 multicast
 network 10.108.0.0
 network 192.168.7.0 backdoor

次のルータ コンフィギュレーションの例では、ローカル ネットワークとしてネットワーク 10.108.0.0、バック ドア ネットワークとしてネットワーク 192.168.7.0 を設定します。

router bgp 109
 network 10.108.0.0
 network 192.168.7.0 backdoor

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IP バージョン 4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPN バージョン 4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

distance bgp

ノードへの最適なルートとなる可能性のある外部、内部、およびローカル アドミニストレーティブ ディスタンスの使用を許可します。

network(BGP およびマルチプロトコル BGP)

BGP およびマルチプロトコル BGP ルーティング プロセスによってアドバタイズされるネットワークを指定します。

router bgp

BGP ネットワークに絶対重みを割り当てます。