IP ルーティング:BGP コマンド リファレンス、Cisco IOS XE Release 3SE(Catalyst 3850 スイッチ)
BGP コマンド:A ~ B
BGP コマンド:A ~ B
発行日;2013/08/07   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

BGP コマンド:A ~ B

address-family ipv4(BGP)

アドレス ファミリまたはルータ スコープ アドレス ファミリ コンフィギュレーション モードを開始して、標準の IP Version 4(IPv4)アドレス プレフィックスを使用するルーティング セッションを設定するには、ルータ コンフィギュレーション モードまたはルータ スコープ コンフィギュレーション モードで address-family ipv4 コマンドを使用します。 アドレス ファミリ コンフィギュレーション モードを終了し、実行コンフィギュレーションから IPv4 アドレス ファミリ コンフィギュレーションを削除するには、このコマンドの no 形式を使用します。

Syntax Available Under Router Configuration Mode

address-family ipv4 [ mdt | tunnel | { multicast | unicast} [ vrf vrf-name ] | vrf vrf-name ]

no address-family ipv4 [ mdt | tunnel | { multicast | unicast} [ vrf vrf-name ] | vrf vrf-name ]

Syntax Available Under Router Scope Configuration Mode

address-family ipv4 [ mdt | multicast | unicast ]

no address-family ipv4 [ mdt | multicast | unicast ]

構文の説明

mdt

(任意)IPv4 マルチキャスト配信ツリー(MDT)アドレス ファミリ セッションを指定します。

tunnel

(任意)マルチポイント トンネリングの IPv4 ルーティング セッションを指定します。

multicast

(任意)IPv4 マルチキャスト アドレス プレフィックスを指定します。

unicast

(任意)IPv4 ユニキャスト アドレス プレフィックスを指定します。 これはデフォルトです。

vrf vrf-name

(任意)後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VPN ルーティングおよび転送(VRF)インスタンスの名前を指定します。

コマンド デフォルト

IPv4 アドレス プレフィックスはイネーブルではありません。

コマンド モード

ルータ コンフィギュレーション(config-router)

ルータ スコープ コンフィギュレーション(config-router-scope)

コマンド履歴

リリース

変更内容

12.0(5)T

このコマンドが導入されました。 このコマンドが、match nlri コマンドと set nlri コマンドに置き換わりました。

12.0(28)S

このコマンドが変更されました。 tunnel キーワードが追加されました。

12.0(29)S

このコマンドが変更されました。 mdt キーワードが追加されました。

12.0(30)S

このコマンドが変更されました。 Cisco 12000 シリーズ インターネット ルータのサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドは、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SRB

このコマンドが変更されました。 ルータ スコープ コンフィギュレーション モードのサポートが追加されました。 tunnel キーワードが廃止されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合されました。

Cisco IOS XE Release 2.1

このコマンドが、Cisco ASR 1000 シリーズの集約サービス ルータで導入されました。

12.4(20)T

このコマンドが変更されました。 mdt キーワードが追加されました。

Cisco IOS XE Release 3.6S

このコマンドが変更されました。 VRF ベースのマルチキャスト サポートが追加されました。

15.2(4)S

このコマンドが Cisco 7200 シリーズ ルータに実装されました。

15.1(2)SNG

このコマンドが、Cisco ASR 901 シリーズの集約サービス ルータに実装されました。

使用上のガイドライン

address-family ipv4 コマンドが、match nlri コマンドと set nlri コマンドに置き換わりました。 address-family ipv4 コマンドは、デバイスをアドレス ファミリ コンフィギュレーション モード(プロンプト:config-router-af)に配置します。ここから、標準 IPv4 アドレス プレフィックスを使用するルーティング セッションを設定できます。 アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードに戻るには、exit を入力します。


(注)  


アドレス ファミリ IPv4 のルーティング情報は、neighbor remote-as コマンドを使用して設定した各ボーダー ゲートウェイ プロトコル(BGP)ルーティング セッションにデフォルトでアドバタイズされます。ただし、neighbor remote-as コマンドを設定する前に no bgp default ipv4-unicast コマンドを入力している場合は除きます。


tunnel キーワードは、IPv4 アドレス ファミリ識別子の下でトンネル サブアドレス ファミリ識別子(SAFI)をイネーブルにするために使用されます。 この SAFI は、トンネル エンドポイントと(トンネル タイプとトンネル機能を含む)SAFI 固有属性をアドバタイズするために使用されます。 トンネル アドレス ファミリが設定されたときに、トンネル エンドポイントが BGP IPv4 トンネル SAFI テーブルへ自動的に再配布されます。 ただし、トンネル情報がセッションで交換されるようにするには、トンネル アドレス ファミリでピアをアクティブ化する必要があります。

mdt キーワードは、IPv4 アドレス ファミリ識別子の下で MDT SAFI をイネーブルにするために使用されます。 この SAFI は、相互 AS のマルチキャスト VPN ピアリング セッションのトンネル エンドポイントをアドバタイズするために使用されます。

address-family ipv4 multicast コマンドを指定する場合は、network network-number [mask network-mask] コマンドを指定します。 network コマンドは、指定したネットワーク番号とマスクをマルチキャスト BGP データベースにアドバタイズ(注入)します。 このルートは、BGP ではなく、Interior Gateway Protocol(IGP)によって(つまり、EIGRP、OSPF、RIP、IGRP、スタティック、または IS-IS によって)インストールされた転送テーブルに存在している必要があります。

Cisco IOS Release 12.2(33)SRB 以降のリリースでは、ルータ スコープ コンフィギュレーション モードでアドレス ファミリ コンフィギュレーションを使用できるようになりました。 スコープ階層は BGP ルーティング セッションに対して定義可能で、マルチトポロジ ルーティング(MTR)をサポートするために必要です。 ルータ スコープ コンフィギュレーション モードを開始するには、全体的に、または特定の VRF に適用できる scope コマンドを使用します。 特定の VRF に対してスコープを使用する場合は、unicast キーワードのみ使用可能です。

次の例では、デバイスを IPv4 アドレス ファミリのアドレス ファミリ コンフィギュレーション モードに配置します。

Device(config)# router bgp 50000
Device(config-router)# address-family ipv4
Device(config-router-af)#

次の例では、デバイスを IPv4 アドレス ファミリのアドレス ファミリ コンフィギュレーション モードに配置し、マルチキャスト アドレス プレフィックスのみを指定します。

Device(config)# router bgp 50000
Device(config-router)# address-family ipv4 multicast
Device(config-router-af)#

次の例では、デバイスを IPv4 アドレス ファミリのアドレス ファミリ コンフィギュレーション モードに配置し、ユニキャスト アドレス プレフィックスを指定します。

Device(config)# router bgp 50000
Device(config-router)# address-family ipv4 unicast
Device(config-router-af)#

次の例では、デバイスをアドレス ファミリ コンフィギュレーション モードに配置し、後続の IPv4 ネイバー アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF インスタンスの名前として cisco を指定します。

Device(config)# router bgp 50000
Device(config-router)# address-family ipv4 vrf cisco
Device(config-router-af)#

(注)  


VRF を指定するこの形式のコマンドを使用すると、プロバイダー エッジ(PE)デバイスとカスタマー エッジ(CE)デバイス間のルーティング交換のみが設定されます。


次の例では、デバイスをトンネル アドレス ファミリ コンフィギュレーション モードに配置します。

Device(config)# router bgp 100
Device(config-router)# address-family ipv4 tunnel
Device(config-router-af)#

次の例では、IPv4 MDT アドレス ファミリ セッションをサポートするようにデバイスを設定します。

Device(config)# router bgp 45000
Device(config-router)# address-family ipv4 mdt
Device(config-router-af)#

次の例では、ルータ スコープ コンフィギュレーション モードで IPv4 アドレス ファミリを設定します。 この例では、スコープ階層が全体的にイネーブルになります。 デバイスは、ルータ スコープ アドレス ファミリ コンフィギュレーション モードを開始し、IPv4 アドレス ファミリのマルチキャスト アドレス プレフィックスだけが指定されます。

Device(config)# router bgp 50000
Device(config-router)# scope global
Device(config-router-scope)# address-family ipv4 multicast
Device(config-router-scope-af)#

関連コマンド

コマンド

説明

address-family ipv6

標準 IPv6 アドレス プレフィックスを使用する BGP などのルーティング セッションを設定するために、デバイスをアドレス ファミリ コンフィギュレーション モードにします。

address-family vpn4

デバイスをアドレス ファミリ コンフィギュレーション モードにして、標準 VPN バージョン 4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

bgp default ipv4-unicast

IPv4 ユニキャスト アドレス ファミリをすべてのネイバーでイネーブルにします。

neighbor activate

BGP 隣接デバイスとの情報交換をイネーブルにします。

neighbor remote-as

BGP ネイバー テーブルまたはマルチプロトコル BGP ネイバー テーブルにエントリを追加します。

scope

BGP ルーティング セッションのスコープを定義して、ルータ スコープ コンフィギュレーション モードを開始します。

aggregate-address

ボーダー ゲートウェイ プロトコル(BGP)データベースに集約エントリを作成するには、アドレス ファミリまたはルータ コンフィギュレーション モードで aggregate-address コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

aggregate-address address mask [as-set] [as-confed-set] [summary-only] [ suppress-map map-name ] [ advertise-map map-name ] [ attribute-map map-name ]

no aggregate-address address mask [as-set] [as-confed-set] [summary-only] [ suppress-map map-name ] [ advertise-map map-name ] [ attribute-map map-name ]

構文の説明

address

集約アドレス。

mask

集約マスク。

as-set

(任意)自律システム設定パス情報を生成します。

as-confed-set

(任意)自律連合設定パス情報を生成します。

summary-only

(任意)アップデートからのすべてのより具体的なルートをフィルタ処理します。

suppress-map map-name

(任意)抑制するルートを選択するために使用するルート マップの名前を指定します。

advertise-map map-name

(任意)AS_SET 送信元コミュニティを作成するルートを選択するために使用するルート マップの名前を指定します。

attribute-map map-name

(任意)集約ルートの属性を設定するために使用するルート マップの名前を指定します。

コマンド デフォルト

アトミック集約属性は、as-set キーワードが指定されない限り、このコマンドによって集約ルートが作成されるときに自動的に設定されます。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

11.1(20)CC

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが追加されました。

12.0(2)S

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが追加されました。

12.0(7)T

nlri unicast キーワード、nlri multicast キーワード、および nlri unicast multicast キーワードが削除されました。

アドレス ファミリ コンフィギュレーション モードのサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

IPv6 のサポートが追加されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合されました。

12.2(33)SXI

このコマンドが、Cisco IOS Release 12.2(33)SXI に統合されました。

12.2(33)SRE

as-confed-set キーワードが追加されました。

Cisco IOS XE Release 3.1S

このコマンドが、Cisco ASR 1000 シリーズ ルータで導入されました。

使用上のガイドライン

集約ルートを BGP またはマルチプロトコル BGP(mBGP)に再配布するか、条件付きの集約ルーティング機能を使用することにより、BGP および mBGP に集約ルーティングを実装できます。

キーワードなしで aggregate-address コマンドを使用すると、指定された範囲内にあるより具体的な BGP または mBGP ルートを使用できる場合、BGP または mBGP ルーティング テーブルに集約エントリが作成されます。 (集約と一致するより長いプレフィックスがルーティング情報ベース(RIB)内に存在する必要があります)。集約ルートは、自律システムからのルートとしてアドバタイズされ、情報が消失している可能性があることを示すアトミック集約属性が設定されます。 (アトミック集約属性は、as-set キーワードを指定しない限りデフォルトで設定されます)。

as-set キーワードを使用すると、このキーワードを指定していない場合にコマンドが従うルールと同じルールを使用して集約エントリが作成されますが、このルートにアドバタイズされるパスは、集約されているすべてのパス内に含まれるすべての要素で構成される AS_SET になります。 このルートは集約されたルート変更に関する自律システム パス到着可能性情報として継続的に削除およびアップデートされる必要があるため、多くのパスを集約する際に aggregate-address コマンドのこの形式を使用しないでください。

as-confed-set キーワードを使用すると、このキーワードを指定していない場合にコマンドが従うルールと同じルールを使用して集約エントリが作成されます。 このキーワードは、自律連合設定パス情報を生成する点を除いて、as-set キーワードと同じ機能を実行します。

summary-only キーワードを使用すると、集約ルート(192.*.*.* など)が作成されるだけでなく、すべてのネイバーへのより具体的なルートのアドバタイズメントが抑制されます。 特定のネイバーへのアドバタイズメントのみを抑制したい場合、neighbor distribute-list コマンドを使用できますが、慎重に使用すべきです。 より具体的なルートがリークした場合、すべての BGP または mBGP ルータは、生成中の具体的でない集約よりもこのルートを優先します(最長一致ルーティングによる)。

suppress-map キーワードを使用すると、集約ルートは作成されますが、指定されたルートのアドバタイズメントが抑制されます。 ルート マップの match 句を使用して、集約ルートのうち、より具体的なものを選択的に抑制し、その他のルートを抑制せずにそのまま残すことができます。 IP アクセス リストと自律システム パス アクセス リストの match がサポートされています。

advertise-map キーワードを使用すると、集約ルートの個々のコンポーネント(AS_SET やコミュニティなど)を構築するために使用する特定のルートが選択されます。 集約のコンポーネントが別々の自律システムにあり、AS_SET で集約を作成して同じ自律システムの一部にアドバタイズしたい場合、aggregate-address コマンドのこの形式が役に立ちます。 AS_SET から特定の自律システム番号を省略し、集約が受信ルータの BGP ループ検出メカニズムによってドロップされるのを防ぐことを忘れてはなりません。 IP アクセス リスト、および自律システム パス アクセス リストの match 句がサポートされています。

attribute-map キーワードを使用すると、集約ルートの属性を変更できます。 AS_SET を構成するルートの 1 つが community no-export 属性(集約ルートがエクスポートされるのを防ぐ)などの属性で設定されている場合、aggregate-address コマンドのこの形式が役に立ちます。 属性マップ ルート マップを作成し、集約の属性を変更することができます。

次に、集約 BGP アドレスがルータ コンフィギュレーション モードで作成される例を示します。 このルートにアドバタイズされるパスは、集約中のすべてのパス内に含まれるすべての要素で構成される AS_SET になります。

Router(config)# router bgp 50000 
Router(config-router)# aggregate-address 10.0.0.0 255.0.0.0 as-set 

次に、集約 BGP アドレスがアドレス ファミリ コンフィギュレーション モードで作成され、IP バージョン 4 アドレス ファミリのマルチキャスト データベースに適用される例を示します。 summary-only キーワードが設定されているため、アップデートからより具体的なルートがフィルタ処理されます。

Router(config)# router bgp 50000 
Router(config-router)# address-family ipv4 multicast 
Router(config-router-af)# aggregate-address 10.0.0.0 255.0.0.0 summary-only 

次に、AS-path アクセス リストで照合される MAP-ONE というルート マップを作成する例を示します。 このルートにアドバタイズされるパスは、ルート マップで照合されるパスに含まれる要素で構成される AS_SET になります。

Router(config)# ip as-path access-list 1 deny ^1234_ 
Router(config)# ip as-path access-list 1 permit .* 
Router(config)# ! 
Router(config)# route-map MAP-ONE 
Router(config-route-map)# match ip as-path 1 
Router(config-route-map)# exit 
Router(config)# router bgp 50000 
Router(config-router)# address-family ipv4 
Router(config-router-af)# aggregate-address 10.0.0.0 255.0.0.0 as-set advertise-map
MAP-ONE 
Router(config-router-af)# end
 

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

ip as-path access-list

BGP 自律システム パス アクセス リストを定義します。

match ip address

標準または拡張アクセス リストで許可された宛先ネットワーク番号アドレスを持つルートを配布し、パケットのポリシー ルーティングを実行します。

neighbor distribute-list

アクセス リストの BGP ネイバー情報を配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

auto-summary(BGP)

ネットワーク レベル ルートへのサブネット ルートの自動集約を設定するには、アドレス ファミリまたはルータ コンフィギュレーション モードで auto-summary コマンドを使用します。 自動集約をディセーブルにし、クラスフル ネットワーク境界を越えてサブプレフィックス ルーティング情報を送信するには、このコマンドの no 形式を使用します。

auto-summary

no auto-summary

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

自動集約はデフォルトでディセーブルです(ソフトウェアはクラスフル ネットワーク境界を越えてサブプレフィックス ルーティング情報を送信します)。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.0(7)T

アドレス ファミリ コンフィギュレーション モードのサポートが追加されました。

12.2(8)T

コマンドのデフォルトの動作が、ディセーブルに変更されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

15.0M、12.2SRE

このコマンドが変更されました。 集約範囲内にあるアドレスでアドレス指定されたインターフェイスがシャット ダウンされると、そのルートは BGP ルーティング テーブルに表示されなくなります。

使用上のガイドライン

このコマンドがイネーブルの場合、BGP は自動的にクラスフル ネットワーク境界へのルートを集約します。 ルート集約は、ルーティング テーブル内のルーティング情報の量を減らすために使用されます。 自動集約は、接続されているスタティックな再配布ルートに適用されます。


(注)  


MPLS VPN の VRF 単位ラベル機能は、自動集約をサポートしていません。


デフォルトでは、自動集約はディセーブルになり、BGP は Interior Gateway Protocol(IGP)から再配布されるサブネットを受け入れます。 クラスフル ネットワーク境界を通過するときに、サブネットをブロックしてクラスフル ネットワーク境界に対する集約サブプレフィックスを作成するには、auto-summary コマンドを使用します。

自動集約をイネーブルにしている場合に BGP のサブネット ルートをアドバタイズし、伝送するには、サブネットをアドバタイズする明示的な network コマンドを使用します。 auto-summary コマンドは、network コマンドによって、または iBGP や eBGP によって BGP に注入されたルートには適用されません。

BGP の自動要約がデフォルトでディセーブルになっている理由

auto-summary がイネーブルの場合、再配布によって BGP に注入されたルートはクラスフル境界で集約されます。 32 ビット IP アドレスはネットワーク アドレスとホスト アドレスで構成されることに注意してください。 サブネット マスクは、ネットワーク アドレスに使用されるビット数およびホスト アドレスに使用されるビット数を指定します。 次の表に示すように、IP アドレス クラスにはナチュラルまたは標準サブネット マスクがあります。

表 1 IP アドレス クラス

クラス

アドレス範囲

標準マスク

A

1.0.0.0 ~ 126.0.0.0

255.0.0.0 または /8

B

128.1.0.0 ~ 191.254.0.0

255.255.0.0 または /16

C

192.0.1.0 ~ 223.255.254.0

255.255.255.0 または /24

予約済みアドレスには 128.0.0.0、191.255.0.0、192.0.0.0、および 223.255.255.0 があります。

標準サブネット マスクを使用する場合、クラス A アドレスはネットワーク用に 1 つのオクテット、クラス B アドレスはネットワーク用に 2 つのオクテット、クラス C アドレスはネットワーク用に 3 つのオクテットを使用します。

たとえば、24 ビット サブネット マスクを持つクラス B アドレス 156.26.32.1 について考えてみます。 24 ビット サブネット マスクではネットワーク用に 3 つのオクテット、156.26.32、が選択されます。 最後のオクテットはホスト アドレスです。 ネットワーク 156.26.32.1/24 が IGP によって学習され、BGP に再配布されると、auto-summary がイネーブルの場合には、ネットワークがクラス B ネットワークのナチュラル マスクに自動的に集約されます。 BGP がアドバタイズするネットワークは 156.26.0.0/16 です。 BGP は 156.26.0.0 ~ 156.26.255.255 のすべてのクラス B アドレス空間に到達できることをアドバタイズします。 BGP ルータで到達できる唯一のネットワークが 156.26.32.0/24 の場合、BGP は、このルータで到達できない 254 のネットワークをアドバタイズします。 このため、auto-summary(BGP)コマンドが、デフォルトでディセーブルになっています。

次の例では、自動集約が IPv4 アドレス ファミリのプレフィックスでイネーブルになります。

Router(config)# router bgp 50000
 
Router(config-router)# address-family ipv4 unicast
 
Router(config-router-af)# auto-summary
 
Router(config-router-af)# network 7.7.7.7 255.255.255.255

例では、ループバック インターフェイス 6 とループバック インターフェイス 7 に 7.7.7.6 と 7.7.7.7 など、それぞれに異なるサブネットがあります。 auto-summarynetwork コマンドの両方が設定されています。

Router# show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            100.0.1.7       YES NVRAM  up                    up      
Ethernet0/1            unassigned      YES NVRAM  administratively down down    
Ethernet0/2            unassigned      YES NVRAM  administratively down down    
Ethernet0/3            unassigned      YES NVRAM  administratively down down    
Ethernet1/0            108.7.9.7       YES NVRAM  up                    up      
Ethernet1/1            unassigned      YES NVRAM  administratively down down    
Ethernet1/2            unassigned      YES NVRAM  administratively down down    
Ethernet1/3            unassigned      YES NVRAM  administratively down down    
Loopback6              7.7.7.6         YES NVRAM  up                    up      
Loopback7              7.7.7.7         YES NVRAM  up                    up      

次の出力では、auto-summary コマンドのために、BGP ルーティング テーブルに 7.7.7.6 ではなく集約ルート 7.0.0.0 が表示されていることに注意してください。 7.7.7.7/32 ネットワークは、auto-summary コマンドによって影響されない network コマンドで設定されているために表示されています。

Router# show ip bgp
BGP table version is 10, local router ID is 7.7.7.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network          Next Hop            Metric LocPrf Weight Path
*> 6.6.6.6/32       100.0.1.6                0             0 6 i
*> 7.0.0.0          0.0.0.0                  0         32768 ?   <-- summarization
*> 7.7.7.7/32       0.0.0.0                  0         32768 i   <-- network command
r>i9.9.9.9/32       108.7.9.9                0    100      0 i
*> 100.0.0.0        0.0.0.0                  0         32768 ?
r> 100.0.1.0/24     100.0.1.6                0             0 6 ?
*> 108.0.0.0        0.0.0.0                  0         32768 ?
r>i108.7.9.0/24     108.7.9.9                0    100      0 ?
*>i200.0.1.0        108.7.9.9 

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

network(BGP およびマルチプロトコル BGP)

BGP およびマルチプロトコル BGP によってアドバタイズされるネットワークを指定します。

bgp default ipv4-unicast

BGP ピアリング セッション確立のデフォルトとして IP Version 4(IPv4)ユニキャスト アドレス ファミリを設定するには、ルータ コンフィギュレーション モードで bgp default ipv4-unicast コマンドを使用します。 ピアリング セッションの確立のためのデフォルトの IPv4 ユニキャスト アドレス ファミリをディセーブルにするには、このコマンドの no 形式を使用します。

bgp default ipv4-unicast

no bgp default ipv4-unicast

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

デフォルトでは、IPv4 アドレス ファミリのルーティング情報は、neighbor remote-as コマンドを設定する前に、no bgp default ipv4-unicast コマンドを設定している場合を除いて、neighbor remote-as コマンドで設定された BGP ルーティング セッションごとにアドバタイズされます。

コマンド モード

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.0(5)T

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.7S

このコマンドが Cisco IOS XE Release 3.7S に統合されました。

15.2(2)SNG

このコマンドが、Cisco ASR 901 シリーズの集約サービス ルータに実装されました。

使用上のガイドライン

bgp default ipv4-unicast コマンドは IPv4 アドレス ファミリ プレフィックスの自動交換をイネーブルにするために使用します。 neighbor activate アドレス ファミリ コンフィギュレーション コマンドは、各 IPv4 アドレス ファミリ セッションで、プレフィックス交換が発生する前に入力する必要があります。

次の例では、IP Version 4 ユニキャスト アドレス ファミリのルーティング情報の自動交換がディセーブルになります。

Device(config)# router bgp 50000
Device(config-router)# no bgp default ipv4-unicast

関連コマンド

コマンド

説明

neighbor activate

隣接ルータとの情報交換をイネーブルにします。

bgp fast-external-fallover

ピアにアクセスするためのリンクがダウンした場合に、ただちに外部 BGP ピアリング セッションをリセットするようにボーダー ゲートウェイ プロトコル(BGP)ルーティング プロセスを設定するには、ルータ コンフィギュレーション モードで bgp fast-external-fallover コマンドを使用します。 BGP 高速外部フォールオーバーをディセーブルにするには、このコマンドの no 形式を使用します。

bgp fast-external-fallover

no bgp fast-external-fallover

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

BGP 高速外部フォールオーバーは Cisco IOS ソフトウェアではデフォルトでイネーブルです。

コマンド モード


ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.0(7)T

アドレス ファミリ コンフィギュレーション モードのサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

bgp fast-external-fallover コマンドは、直接接続されている外部ピアとの BGP ピアリング セッションにおける高速外部フォールオーバーをディセーブルまたはイネーブルにするために使用します。 リンクがダウンするとセッションは即座にリセットされます。 直接接続されているピアのみサポートされます。

BGP 高速外部フォールオーバーがディセーブルの場合、BGP ルーティング プロセスはデフォルトのホールド タイマーの期限(3 回のキープアライブ)が切れるまで待ってピアリング セッションをリセットします。 BGP 高速外部フォールオーバーは、ip bgp fast-external-fallover インターフェイス コンフィギュレーション コマンドを使用して、インターフェイス単位で設定することもできます。

次に、BGP 高速外部フォールオーバー機能をディセーブルにする例を示します。 このセッションを伝送するリンクがフラップしても、接続はリセットされません。

Router(config)# router bgp 50000
 
Router(config-router)# no bgp fast-external-fallover
 

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

ip bgp fast-external-fallover

インターフェイスごとに BGP 高速外部フォールオーバーを設定します。

bgp graceful-restart

すべての BGP ネイバーのボーダー ゲートウェイ プロトコル(BGP)グレースフル リスタート機能を全体的にイネーブルにするには、アドレス ファミリまたはルータ コンフィギュレーション モードで bgp graceful-restart コマンドを使用します。 すべての BGP ネイバーの BGP グレースフル リスタート機能を全体的にディセーブルにするには、このコマンドの no 形式を使用します。

bgp graceful-restart [ restart-time seconds | stalepath-time seconds ] [all]

no bgp graceful-restart

構文の説明

restart-time seconds

(任意)再起動イベント発生後にグレースフル リスタート対応ネイバーが正常な動作に戻るのをローカル ルータが待つ最大時間を設定します。 この引数のデフォルト値は 120 秒です。 値の設定可能範囲は 1 ~ 3600 秒です。

stalepath-time seconds

(任意)ローカル ルータが再起動するピアの古くなったパスを保持する最大時間を設定します。 すべての古いパスは、このタイマーが期限切れになった後に削除されます。 この引数のデフォルト値は 360 秒です。 値の設定可能範囲は 1 ~ 3600 秒です

all

(任意)すべてのアドレス ファミリ モードの BGP グレースフル リスタート機能をイネーブルにします。

コマンド デフォルト

このコマンドがキーワードまたは引数なしで入力された場合、次のデフォルト値が使用されます。

restart-time:120 秒、stalepath-time:360 秒


(注)  


BGP グレースフル リスタート機能をイネーブルにするために、restart と stalepath のタイマー値を変更する必要はありません。 デフォルト値はほとんどのネットワーク構成にとって最適な値であり、これらの値は経験豊富なネットワーク オペレータのみが調整すべきです。


コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.0(22)S

このコマンドが導入されました。

12.2(15)T

このコマンドが、Cisco IOS Release 12.2(15)T に統合されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(28)SB

このコマンドのサポートが Cisco IOS Release 12.2(28)SB に追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

IPv6 のサポートが追加されました。 オプションの all キーワードが追加されました。

12.2(33)SRE

このコマンドが変更されました。 Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが変更されました。 Cisco IOS Release 12.2(33)XNE に統合されました。

使用上のガイドライン

bgp graceful-restart コマンドは、BGP ネットワークのすべての BGP ネイバーでグレースフル リスタート機能を全体的にイネーブルまたはディセーブルにするために使用されます。 グレースフル リスタート機能は、セッション確立時の OPEN メッセージで、ノンストップ フォワーディング(NSF)対応および NSF 認識のピア間でネゴシエートされます。 BGP セッションの確立後にグレースフル リスタート機能をイネーブルにした場合、ソフトまたはハード リセットでセッションを再起動する必要があります。

グレースフル リスタート機能は、NSF 対応および NSF 認識のルータでサポートされます。 NSF 対応ルータは、ステートフル スイッチオーバー(SSO)の動作(グレースフル リスタート)を実行し、SSO の動作中にルーティング テーブル情報を保持することによって、ピアの再起動を支援することができます。 NSF 認識ルータは NSF 対応ルータと同様に機能しますが、SSO の動作を実行することはできません。

BGP グレースフル リスタート機能は、Cisco IOS ソフトウェアのサポート バージョンがインストールされている場合はデフォルトでイネーブルになります。 この機能のデフォルトのタイマー値は、ほとんどのネットワーク構成にとって最適です。 これらの値は、経験豊富なネットワーク オペレータのみが調整することを推奨します。 タイマー値を調整する場合、再起動タイマーは、OPEN メッセージ内にある保持時間を超える値に設定してはなりません。 連続した再起動動作が発生する場合、以前に古くなったとしてマークされたルート(再起動するルータからのルート)が削除されます。


(注)  


BGP グレースフル リスタート機能をイネーブルにするために、restart と stalepath のタイマー値を変更する必要はありません。 デフォルト値はほとんどのネットワーク構成にとって最適な値であり、これらの値は経験豊富なネットワーク オペレータのみが調整すべきです。


次の例では、BGP グレースフル リスタート機能がイネーブルになります。

Router# configure terminal
Router(config)# router bgp 65000
Router(config-router)# bgp graceful-restart

次の例では、restart タイマーが 130 秒に設定されます。

Router# configure terminal
Router(config)# router bgp 65000
Router(config-router)# bgp graceful-restart restart-time 130 

次の例では、stalepath タイマーが 350 秒に設定されます。

Router# configure terminal
Router(config)# router bgp 65000
Router(config-router)# bgp graceful-restart stalepath-time 350

関連コマンド

コマンド

説明

show ip bgp

BGP ルーティング テーブル内のエントリを表示します。

show ip bgp neighbors

ネイバーへの TCP 接続および BGP 接続についての情報を表示します。

bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにするには、ルータ コンフィギュレーション モードで bgp log-neighbor-changes コマンドを使用します。 BGP ネイバールータとの隣接関係の変化に関するロギングをディセーブルにするには、このコマンドの no 形式を使用します。

bgp log-neighbor-changes

no bgp log-neighbor-changes

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

BGP ネイバー リセットのロギングはイネーブルになっていません。

コマンド モード

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

11.1CC

このコマンドが導入されました。

12.0

このコマンドが Cisco IOS Release 12.0 に統合されました。

12.0(7)T

アドレス ファミリ コンフィギュレーション モードのサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

IPv6 のサポートが追加されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合されました。

12.2(33)SXI

このコマンドが、Cisco IOS Release 12.2(33)SXI に統合されました。

Cisco IOS XE Release 3.7S

このコマンドが Cisco IOS XE Release 3.7S に統合されました。

15.1(2)SNG

このコマンドが、Cisco ASR 901 シリーズの集約サービス ルータに実装されました。

使用上のガイドライン

bgp log-neighbor-changes コマンドは、BGP ネイバー ステータスの変化(アップまたはダウン)およびリセットに関するロギングをイネーブルにします。ログはネットワークの接続問題のトラブルシューティングおよびネットワークの安定性の評価に使用します。 ネイバーが突然リセットする場合は、ネットワークのエラー率の高いことやパケット損失の多いことが考えられるので、調査するようにしてください。

ステータスの変化に関するメッセージをロギングするために bgp log-neighbor-changes コマンドを使用しても、BGP アップデート デバッグをイネーブルにする場合などと異なり、パフォーマンスに大きな影響を与えることはありません。 UNIX の syslog ファシリティがイネーブルの場合、メッセージは syslog デーモンを実行している UNIX ホストに送信され、保存およびアーカイブされます。 UNIX の syslog ファシリティがイネーブルでない場合、ステータスの変化に関するメッセージはディスクではなくルータの内部バッファに保持されます。 このバッファのサイズは logging buffered コマンドで設定できますが、利用可能な RAM に依存します。

bgp log-neighbor-changes コマンドがイネーブルでない場合、ネイバー ステータスの変化に関するメッセージはリセットの理由に関するものを除いて記録されません。リセットの理由は show ip bgp neighbors および show bgp ipv6 neighbors コマンドの出力として常に利用可能です。

eigrp log-neighbor-changes コマンドは、Enhanced Interior Gateway Routing Protocol(EIGRP)隣接ルータとの隣接関係のロギングをイネーブルにしますが、BGP ネイバーに関するメッセージは、bgp log-neighbor-changes コマンドで明確にイネーブルにされた場合にのみ記録されます。

BGP ネイバーの変化に関するログを表示するには、show logging コマンドを使用します。

次に、ルータ コンフィギュレーション モードで BGP のネイバーの変化をログする例を示します。

Device(config)# bgp router 40000
Device(config-router)# bgp log-neighbor-changes

関連コマンド

コマンド

説明

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

eigrp log-neighbor-changes

ルーティング システムの安定性をモニタして問題の検出に役立てるために、隣接ルータとの隣接関係の変更のロギングをイネーブルにします。

logging buffered

メッセージを内部バッファにロギングします。

show ip bgp ipv4

ネイバーへの TCP 接続および BGP 接続についての情報を表示します。

show ip bgp neighbors

BGP ネイバーに関する情報を表示します。

show logging

ロギング(syslog)の状態を表示します。

bgp router-id

ボーダー ゲートウェイ プロトコル(BGP)のローカル ルーティング プロセスの固定ルータ ID を設定するには、ルータ コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで bgp router-id コマンドを使用します。 固定ルータ ID を実行コンフィギュレーション ファイルから削除し、デフォルトのルータ ID 選択に戻すには、このコマンドの no 形式を使用します。

Router Configuration

bgp router-id { ip-address | vrf auto-assign }

no bgp router-id [ vrf auto-assign ]

Address Family Configuration

bgp router-id { ip-address | auto-assign }

no bgp router-id

構文の説明

ip-address

IP アドレス形式のルータ ID。

vrf

Virtual Routing and Forwarding(VRF)インスタンスのルータ ID を設定します。

auto-assign

自動的に各 VRF にルータ ID を割り当てます。

コマンド デフォルト

このコマンドがイネーブルでない場合、次の動作によってローカル ルータ ID の選択が決定します。

  • ループバック インターフェイスが設定されている場合、ルータ ID はループバック インターフェイスの IP アドレスに設定されます。 複数のループバック インターフェイスが設定されている場合、ルータ ID は最も高い IP アドレスを持つループバック インターフェイスの IP アドレスに設定されます。
  • ループバック インターフェイスが設定されていない場合、ルータ ID は物理インターフェイスの最上位の IP アドレスに設定されます。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

vrf および auto-assign キーワードが追加され、このコマンドが Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

vrf および auto-assign キーワードを含めて、このコマンドが Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SXH

vrf および auto-assign キーワードを含めて、このコマンドが Cisco IOS Release 12.2(33)SXH に統合されました。

12.4(20)T

vrf および auto-assign キーワードが追加されました。

使用上のガイドライン

bgp router-id コマンドを使用して、ローカル BGP ルーティング プロセスの固定ルータ ID を設定します。 ルータ ID は IP アドレス形式で入力します。 すべての有効な IP アドレスを使用できます。ルータにローカルに設定されていないアドレスも使用できます。 ローカル インターフェイスの IP アドレスを使用する場合は、物理インターフェイスのアドレスよりも、ループバック インターフェイスのアドレスを使用することを推奨します。 (ダウンする物理リンクがないため、ループバック インターフェイスは固定インターフェイスより ID として有効です)。ピアリング セッションは、ルータ ID が変更されると自動的にリセットされます。

Cisco IOS Release 12.2(33)SRA、12.2(31)SB2、12.2(33)SXH、12.4(20)T、およびそれ以降のリリースでは、BGP ルータ ID の VRF 単位割り当て機能によって、同じルータの BGP に VRF 間ピアリングが導入されました。 BGP は、ルータ ID チェックのため、BGP 自身でセッションを拒否するように設計されています。 VRF 単位割り当て機能により、VRF ごとに異なるルータ ID を使用できます。 ルータ ID は、各 VRF に手動で設定できます。または、アドレス ファミリ コンフィギュレーション モードで各 VRF または全体的に自動で割り当てることができます。

次に、192.168.254.254 という固定の BGP ルータ ID を使用して、ローカル ルータを設定する例を示します。

router bgp 50000
 bgp router-id 192.168.254.254 

次に、VRF1 という名前の VRF に BGP ルータ ID を設定する例を示します。 この設定は、アドレス ファミリ IPv4 VRF コンフィギュレーション モードで行われます。

router bgp 45000
 address-family ipv4 vrf VRF1
  bgp router-id 10.1.1.99

次に、すべての VRF について、自動割り当ての VRF BGP ルータ ID を設定する例を示します。 この設定は、BGP ルータ コンフィギュレーション モードで行われます。

router bgp 45000
 bgp router-id vrf auto-assign

次に、単一の VRF について、自動割り当ての VRF BGP ルータ ID を設定する例を示します。 この設定は、アドレス ファミリ IPv4 VRF コンフィギュレーション モードで行われます。

router bgp 45000
 address-family ipv4 vrf VRF2
  bgp router-id auto-assign

関連コマンド

コマンド

説明

show ip bgp

BGP ルーティング テーブル内のエントリを表示します。

show ip bgp vpnv4

VPNv4 アドレス情報を BGP ルーティング テーブルから表示します。

bgp soft-reconfig-backup

ルート リフレッシュ機能をサポートしていないピアに対してインバウンド ソフト再構成を実行するようにボーダー ゲートウェイ プロトコル(BGP)スピーカーを設定するには、アドレス ファミリまたはルータ コンフィギュレーション モードで bgp soft-reconfig-backup コマンドを使用します。 この機能をディセーブルにするには、このコマンドの no 形式を使用します。

bgp soft-reconfig-backup

no bgp soft-reconfig-backup

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

ルート リフレッシュ機能をサポートしていないピアに対してインバウンド ソフト再構成は実行されません。

コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.3(14)T

このコマンドが導入されました。

使用上のガイドライン

bgp soft-reconfig-backup コマンドは、ルート リフレッシュ機能をサポートしていないピアに対して、インバウンド ソフトウェア再構成を実行するように、BGP スピーカーを設定するために使用します。 このコマンドの設定により、必要な場合にだけ、アップデート(ソフト再構成)を格納するように、BGP を設定することができます。 このコマンドを設定しても、ルート リフレッシュ機能をサポートしているピアは影響されません。

ピアがルート リフレッシュ機能をサポートしているかどうかを判断するには、show ip bgp neighbors コマンドを使用します。 サポートされている場合、次のように出力に表示されます。

Route refresh: advertised and received(new)

BGP スピーカーがルート リフレッシュ機能をサポートしていないピアのインバウンド アップデートを格納しているかどうかを判断するには、show ip bgp コマンドを使用します。 アップデートが保存されている場合、次のように出力に表示されます。

(received-only) 

グローバル コンフィギュレーション モードで開始する次の例では、ピアがルート リフレッシュ機能をサポートしていない場合に限り、ルータがインバウンド ソフト再構成を実行するように設定します。

Router(config)# router bgp 50000 
Router(config-router)# bgp soft-reconfig-backup
 
Router(config-router)# neighbor 10.1.1.1 remote-as 40000
 
Router(config-router)# neighbor 192.168.1.1 remote-as 60000
 

関連コマンド

コマンド

説明

show ip bgp

ボーダー ゲートウェイ プロトコル(BGP)のルーティング テーブルのエントリを表示します。

show ip bgp neighbors

ネイバーへの TCP 接続およびボーダー ゲートウェイ プロトコル(BGP)接続についての情報を表示します。