IP ルーティング:プロトコル非依存コマンド リファレンス、Cisco IOS XE Release 3SE(Catalyst 3850 スイッチ)
IP ルーティング プロトコル非依存コマンド:A ~ R
IP ルーティング プロトコル非依存コマンド:A ~ R
発行日;2013/07/24   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

IP ルーティング プロトコル非依存コマンド:A ~ R

accept-lifetime

キー チェーンの認証キーが有効なキーとして受信される期間を設定するには、キー チェーン キー コンフィギュレーション モードで accept-lifetime コマンドを使用します。 デフォルト値に戻すには、このコマンドの no 形式を使用します。

accept-lifetime commandaccept-lifetime start-time { infinite | end-time | duration seconds }

no accept-lifetime [ start-time { infinite | end-time | duration seconds } ]

構文の説明

start-time

key コマンドで指定されたキーの受信が有効になる開始時間。 構文は次のいずれかにすることができます。

hh : mm : ss Month date year

hh : mm : ss date Month year

  • hh -- 時間
  • mm -- 分
  • ss --
  • Month -- 月の最初の 3 文字
  • date -- 日(1 ~ 31)
  • year -- 年(4 桁)

デフォルトの開始時刻と、指定できる最初の日付は、1993 年 1 月 1 日です。

infinite

キーは start-time 値から受信できます。

end-time

キーは start-time 値から end-time 値まで受信できます。 構文は、start-time 値と同じです。 end-time 値は start-time 値の後にする必要があります。 デフォルトの終了時間は無期限です。

duration seconds

キーの受信が有効である期間(秒単位)。 値の範囲は 1 ~ 2147483646 です。

コマンド デフォルト

キー チェーンの認証キーは無制限に有効として受信されます(開始時間は 1993 年 1 月 1 日、終了時間は無期限)。

コマンド モード

キー チェーン キー コンフィギュレーション(config-keychain-key)

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.4(6)T

IPv6 のサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

DRP Agent、Enhanced Interior Gateway Routing Protocol(EIGRP)、および Routing Information Protocol(RIP)Version 2 でのみキー チェーンが使用されます。

start-time 値と、infiniteend-time、または duration seconds のいずれかの値を指定します。

キーにライフタイムを割り当てる場合は、ネットワーク タイム プロトコル(NTP)または他の時刻同期方式を実行することを推奨します。

最後のキーの有効期限が切れると、認証が続行され、エラー メッセージが生成されます。 認証をディセーブルにするには、手動で有効な最後のキーを削除する必要があります。

次の例では、chain1 という名前のキー チェーンが設定されます。 キー「key1」は午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー「key2」は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# interface ethernet 0
Router(config-if)# ip rip authentication key-chain chain1
Router(config-if)# ip rip authentication mode md5
!
Router(config)# router rip
Router(config-router)# network 172.19.0.0
Router(config-router)# version 2
!
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain)# key-string key2
Router(config-keychain)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

次の例では、EIGRP アドレスファミリに chain1 という名前のキー チェーンが設定されます。 キー「key1」は午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー「key2」は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# router
 eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# authentication key-chain trees
Router(config-router-af-interface)# authentication mode md5
Router(config-router-af-interface)# exit
Router(config-router-af)# exit
Router(config-router)# exit
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

関連コマンド

コマンド

説明

key

キー チェーンの認証キーを識別します。

key chain

ルーティング プロトコルの認証をイネーブルにするために必要な認証キー チェーンを定義します。

key-string(認証)

キーの認証文字列を指定します。

send-lifetime

キー チェーンの認証キーが有効に送信される期間を設定します。

show key chain

認証キーの情報を表示します。

bfd all-interfaces

ルーティング プロセスに参加しているすべてのインターフェイスの双方向フォワーディング検出(BFD)をイネーブルにするには、ルータ コンフィギュレーション モードまたはアドレス ファミリ インターフェイス コンフィギュレーション モードで bfd all-interfaces コマンドを使用します。 1 つのインターフェイスですべてのネイバーの BFD をディセーブルにするには、このコマンドの no 形式を使用します。

bfd all-interfaces

no bfd all-interfaces

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

BFD は、ルーティング プロセスに参加するインターフェイスでディセーブルです。

コマンド モード

ルータ コンフィギュレーション(config-router)

アドレス ファミリ インターフェイス コンフィギュレーション(config-router-af)

コマンド履歴

リリース

変更内容

12.2(18)SXE

このコマンドが導入されました。

12.0(31)S

このコマンドが Cisco IOS Release 12.0(31)S に統合されました。

12.4(4)T

このコマンドが Cisco IOS Release 12.4(4)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

Cisco IOS XE Release 2.1

このコマンドが Cisco IOS Release XE 2.1 に統合され、Cisco ASR 1000 シリーズの集約サービス ルータに実装されました。

12.2(33)SRE

このコマンドが変更されました。 IPv6 のサポートが追加されました。

15.0(1)M

このコマンドが変更されました。 名前付きルータ コンフィギュレーション モードの bfd all-interfaces コマンドがアドレス ファミリ インターフェイス モードの bfd コマンドに置き換えられました。

15.1(2)T

このコマンドが変更されました。 IPv6 のサポートが追加されました。

Cisco IOS XE Release 3.3

このコマンドが変更されました。 Routing Information Protocol(RIP)のサポートが追加されました。

15.2(4)S

このコマンドが変更されました。 IPv6 のサポートが追加されました。

Cisco IOS XE Release 3.7S

このコマンドが変更されました。 IPv6 のサポートが追加されました。

使用上のガイドライン

障害検出のために BFD を使用するようにルーティング プロトコルを設定する方法は 2 通りあります。 すべてのインターフェイスの BFD をイネーブルにするには、ルータ コンフィギュレーション モードで bfd all-interfaces コマンドを使用します。 Cisco IOS Release 12.4(24)T、Cisco IOS 12.2(33)SRA、およびそれ以前のリリースでは、bfd all-interfaces コマンドはルータ コンフィギュレーション モードとアドレス ファミリ インターフェイス モードで機能します。

Cisco IOS Release 15.0(1)M 以降のリリースで、名前付きルータ コンフィギュレーション モードの bfd all-interfaces コマンドはアドレス ファミリ インターフェイス コンフィギュレーション モードの bfd コマンドに置き換えられました。 ルータ コンフィギュレーション モードの bfd all-interfaces コマンドと同じ機能を実行するには、アドレス ファミリ インターフェイス コンフィギュレーション モードで bfd コマンドを使用します。

次に、すべての Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバーの BFD をイネーブルにする例を示します。

Router> enable
Router# configure terminal
Router(config)# router eigrp 123
Router(config-router)# bfd all-interfaces
Router(config-router)# end

次に、すべての Intermediate System-to-Intermediate System(IS-IS)ネイバーの BFD をイネーブルにする例を示します。

Router> enable
Router# configure terminal
Router(config)# router isis tag1
Router(config-router)# bfd all-interfaces
Router(config-router)# end

次に、すべての Open Shortest Path First(OSPF)ネイバーの BFD をイネーブルにする例を示します。

Router> enable
Router# configure terminal
Router(config)# router ospf 123
Router(config-router)# bfd all-interfaces
Router(config-router)# end

次に、アドレス ファミリ インターフェイス コンフィギュレーション モードで bfd コマンドを使用して、すべての EIGRP ネイバーの BFD をイネーブルにする例を示します。

Router> enable
Router# configure terminal
Router(config)# router eigrp my_eigrp
Router(config-router)# address family ipv4 autonomous-system 100
Router(config-router-af)# af-interface FastEthernet 0/0
Router(config-router-af)# bfd

次に、すべての Routing Information Protocol(RIP)ネイバーの BFD をイネーブルにする例を示します。

Router> enable
Router# configure terminal
Router(config)# router rip
Router(config-router)# bfd all-interfaces
Router(config-router)# end

次に、アドレス ファミリ インターフェイス コンフィギュレーション モードですべての IS-IS ネイバーの IPv6 BFD をイネーブルにする例を示します。

Router> enable
Router# configure terminal
Router(config)# router isis
Router(config-router)# address family ipv6
Router(config-router-af)# bfd all-interfaces
Router(config-router-af)# end

関連コマンド

コマンド

説明

bfd

インターフェイスのベースライン BFD セッション パラメータを設定します。

dampening

フラッピング セッションを自動的にダンプニングするようにデバイスを設定するには、インターフェイス コンフィギュレーション モードで dampening コマンドを使用します。 自動ダンプニングをディセーブルにするには、このコマンドの no 形式を使用します。

dampening [ half-life-period reuse-threshold suppress-threshold max-suppress-time ] [ restart-penalty ]

no dampening

構文の説明

half-life-period

(任意)ペナルティが小さくなるまでの時間(秒単位)。 ルートにペナルティを割り当てると、half-life 期間の経過後にペナルティが半分まで減少します。 half-life 期間の範囲は 1 ~ 30 秒です。 デフォルトの時間は 5 秒です。

reuse-threshold

(任意)ペナルティの数に基づいて値を再利用します。 累積ペナルティがこの値を下回るまで減少すると、ルートは抑制されなくなります。 再利用値の範囲は 1 ~ 20000 です。デフォルトは 1000 です。

suppress-threshold

(任意)フラッピングが発生しているインターフェイスのダンプニングをルータでトリガーする、累積ペナルティの値。 ペナルティがこの制限を超えるとルートが抑制されます。 指定できる範囲は 1 ~ 20000 で、デフォルトは 2000 です。

max-suppress-time

(任意)ルートの最長抑制時間(秒単位)。 範囲は 1 ~ 20000 で、デフォルトは half-life-period の 4 倍です。 half-life-period の値がデフォルトに設定されている場合、最大抑制時間はデフォルトの 20 秒になります。

restart-penalty

(任意)ルータのリロード後に初めて起動したときにインターフェイスに適用されるペナルティ。 設定できる範囲は 1 ~ 18000 ペナルティです。 デフォルトは 2000 ペナルティです。 この引数は、他の設定には必須ではありません。

コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。 手動で restart-penalty 引数のタイマーを設定するには、すべての引数の値を手動で入力する必要があります。

コマンド モード

インターフェイス コンフィギュレーション(config-if)

コマンド履歴

リリース

変更内容

12.0(22)S

このコマンドが導入されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(18)SXD

このコマンドが、Cisco IOS Release 12.2(18)SXD に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドは、Cisco IOS Release 12.2(31)SB2 に統合されました。

使用上のガイドライン

IP イベント ダンプニング機能は、サブインターフェイスで機能しますが、サブインターフェイスのみで設定できません。 この機能を設定できるのは、プライマリ インターフェイスのみです。 プライマリ インターフェイスの設定は、すべてのサブインターフェイスに対しデフォルトで適用されます。

インターフェイスがダンプニングされると、インターフェイスが IP ルーティングとコネクションレス型ネットワーク サービス(CLNS)ルーティングの両方で等しくダンプニングします。 Intermediate System-to-Intermediate System(IS-IS)などの統合型ルーティング プロトコル、IP、ルーティング プロトコル、および CLNS ルーティング プロトコルは緊密に相互接続されるため、インターフェイスは IP と CLNS の両方にダンプニングします。ダンプニングを別々に適用することはできません。

仮想テンプレートから仮想アクセス インターフェイスへのダンプニング設定のコピーはサポートされません。これは、仮想テンプレートを使用する既存のアプリケーションでは、ダンプニングの有用性が限定的であるためです。 インターフェイスでフラップが発生すると仮想アクセス インターフェイスはリリースされ、インターフェイスがアップしてネットワークに対して使用可能になると、新しい接続と仮想アクセス インターフェイスが取得されます。 ダンプニング状態はインターフェイスに対して設定されるため、インターフェイスのフラップより長く続くことはありません。

すでにダンプニングが設定されているインターフェイスに対して dampening コマンドを適用すると、ダンプニング状態はすべてリセットされ、累積ペナルティが 0 に設定されます。 インターフェイスが減衰されている場合、累積ペナルティは再使用しきい値まで低下し、減衰しているインターフェイスはネットワークに対して使用可能になります。 ただし、フラップ カウントは保持されます。

次に、半減期を 30 秒に、再使用しきい値を 1500 に、抑制しきい値を 10000 に、最大抑制時間を 120 秒に設定する例を示します。

interface Ethernet 0/0
 dampening 30 1500 10000 120

次に、ルータがリロードされた後、最初にインターフェイスがアップしたときに、イーサネット インターフェイス 0/0 で 500 のペナルティを適用するようにルータを設定する例を示します。

interface Ethernet 0/0
 dampening 5 500 1000 20 500 

関連コマンド

コマンド

説明

clear counters

インターフェイス カウンタをクリアします。

show dampening interface

インターフェイス ダンプニングのサマリーを表示します。

show interface dampening

ダンプニング パラメータおよびステータスのサマリーを表示します。

ip policy route-map

インターフェイスでのポリシー ルーティングに使用するルート マップを特定するには、インターフェイス コンフィギュレーション モードで ip policy route-map コマンドを使用します。 インターフェイスでポリシー ルーティングをディセーブルにするには、このコマンドの no 形式を使用します。

ip policy route-map commandip policy route-map map-tag

no ip policy route-map

構文の説明

map-tag

ポリシー ルーティングに使用するルート マップの名前。 名前は、route-map コマンドで指定された map-tag 値に一致させる必要があります。

コマンド デフォルト

インターフェイスでポリシー ルーティングは行われません。

コマンド モード

インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更内容

11.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.2

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

明らかな最短パス以外のルートを選択するようにパケットを設定する場合は、ポリシー ルーティングをイネーブルにする場合があります。

ip policy route-map コマンドは、ポリシー ルーティングに使用するルート マップを特定します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドでは、パケットの宛先 IP アドレスに基づいて、一致基準(そのインターフェイスにポリシー ルーティングが許可される条件)を指定します。 set コマンドでは、set 処理match コマンドによる基準が満たされた場合に実行する特定のポリシー ルーティング処理)を指定します。 no ip policy route-map コマンドは、ルート マップへのポインタを削除します。

match ip address コマンドを使用し、拡張 IP アクセス リストを参照する場合、拡張 IP アクセス リストに定義可能なあらゆる一致基準でポリシーベース ルーティングを実行できます。

次に、IP アドレス 172.30.3.20 のルータに 172.21.16.18 の宛先 IP アドレスのパケットを送信する例を示します。

interface serial 0
 ip policy route-map wethersfield
!
route-map wethersfield
 match ip address 172.21.16.18
 set ip next-hop 172.30.3.20

関連コマンド

コマンド

説明

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set default interface

ポリシー ルーティングにおいてルート マップの match 句を満たし、宛先への明示ルートがないパケットの出力先を示します。

set interface

ポリシー ルーティング用のルート マップの match 句に合格したパケットの出力先を示します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco IOS ソフトウェアが持たない場合の出力先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

key

キー チェーンの認証キーを指定するには、キーチェーン コンフィギュレーション モードで key コマンドを使用します。 キー チェーンからキーを削除するには、このコマンドの no 形式を使用します。

key commandkey key-id

no key key-id

構文の説明

key-id

キー チェーンの認証キーの識別番号。 キーの範囲は、0 ~ 2147483647 です。 キー識別番号は連続している必要はありません。

コマンド デフォルト

キーはキー チェーンに存在しません。

コマンド モード

キーチェーン コンフィギュレーション(config-keychain)

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.4(6)T

IPv6 のサポートが追加されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

DRP Agent、Enhanced Interior Gateway Routing Protocol(EIGRP)、および Routing Information Protocol(RIP)Version 2 でのみキー チェーンが使用されます。

キー チェーンに複数のキーを含めると便利です。これにより、ソフトウェアは、accept-lifetime および send-lifetime キー チェーン キー コマンド設定に基づいてキーが後で無効になったときにキーを順序付けることができます。

各キーには、ローカルに格納される独自のキー識別子があります。 キー ID、およびメッセージに関連付けられたインターフェイスの組み合わせにより、使用中の認証アルゴリズムおよび Message Digest 5(MD5)認証キーが一意に識別されます。 有効なキーの数にかかわらず、送信される認証パケットは 1 つだけです。 ソフトウェアは、まず最小のキー ID 番号を確認し、最初の有効なキーを使用します。

最後のキーの有効期限が切れると、認証が続行され、エラー メッセージが生成されます。 認証をディセーブルにするには、手動で有効な最後のキーを削除する必要があります。

すべてのキーを削除するには、no key chain コマンドを使用して、キー チェーンを削除します。

次の例では、chain1 という名前のキー チェーンが設定されます。 キー「key1」は午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー「key2」は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# interface ethernet 0
Router(config-if)# ip rip authentication key-chain chain1
Router(config-if)# ip rip authentication mode md5
!
Router(config)# router rip
Router(config-router)# network 172.19.0.0
Router(config-router)# version 2
!
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

次の名前付き設定の例では、EIGRP アドレスファミリに chain1 という名前のキー チェーンが設定されます。 キー「key1」は午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー「key2」は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# router 
eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# authentication key-chain trees
Router(config-router-af-interface)# authentication mode md5
Router(config-router-af-interface)# exit
Router(config-router-af)# exit
Router(config-router)# exit
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

次の名前付き設定の例では、EIGRP サービスファミリに chain1 という名前のキー チェーンが設定されます。 キー「key1」は午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー「key2」は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4453
Router(config-router-sf)# network 10.0.0.0
Router(config-router-sf)# sf-interface ethernet0/0
Router(config-router-sf-interface)# authentication key-chain trees
Router(config-router-sf-interface)# authentication mode md5
Router(config-router-sf-interface)# exit
Router(config-router-sf)# exit
Router(config-router)# exit
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

関連コマンド

コマンド

説明

accept-lifetime

キー チェーンの認証キーが有効として受信される期間を設定します。

ip authentication key-chain eigrp

EIGRP パケットの認証をイネーブルにします。

key chain

ルーティング プロトコルの認証をイネーブルにするために必要な認証キー チェーンを定義します。

key-string(認証)

キーの認証文字列を指定します。

send-lifetime

キー チェーンの認証キーが有効に送信される期間を設定します。

show key chain

認証キーの情報を表示します。

key chain

ルーティング プロトコルの認証をイネーブルにするために必要な認証キー チェーンを定義し、キーチェーン コンフィギュレーション モードを開始するには、グローバル コンフィギュレーション モードで key chain コマンドを使用します。 キー チェーンを削除するには、このコマンドの no 形式を使用します。

key chain commandkey chain name-of-chain

no key chain name-of-chain

構文の説明

name-of-chain

キー チェーンの名前。 キー チェーンには少なくとも 1 つのキーが必要で、最大 2147483647 のキーを含めることができます。

コマンド デフォルト

キー チェーンは存在しません。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.4(6)T

IPv6 のサポートが追加されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

DRP Agent、Enhanced Interior Gateway Routing Protocol(EIGRP)、および Routing Information Protocol(RIP)Version 2 でのみキー チェーンが使用されます。

認証をイネーブルにするには、キー チェーンにキーを設定する必要があります。

複数のキー チェーンを指定できますが、ルーティング プロトコルごとにインターフェイスあたり 1 つのキー チェーンを使用することを推奨します。 key chain コマンドを指定すると、キー チェーン コンフィギュレーション モードが開始されます。

次の例では、chain1 という名前のキー チェーンが設定されます。 キー「key1」は午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー「key2」は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# interface ethernet 0
Router(config-if)# ip rip authentication key-chain chain1
Router(config-if)# ip rip authentication mode md5
!
Router(config)# router rip
Router(config-router)# network 172.19.0.0
Router(config-router)# version 2
!
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

次の名前付き設定の例では、EIGRP アドレスファミリに chain1 という名前のキー チェーンが設定されます。 キー「key1」は午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー「key2」は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# authentication key-chain trees
Router(config-router-af-interface)# authentication mode md5
Router(config-router-af-interface)# exit
Router(config-router-af)# exit
Router(config-router)# exit
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

次の名前付き設定の例では、サービスファミリに trees という名前のキー チェーンが設定されます。 chestnut という名前のキーは午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー birch は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4453
Router(config-router-sf)# sf-interface ethernet
Router(config-router-sf-interface)# authentication key chain trees
Router(config-router-sf-interface)# authentication mode md5
Router(config-router-sf-interface)# exit
Router(config-router-sf)# exit
Router(config-router)# exit
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string chestnut
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string birch
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

関連コマンド

コマンド

説明

accept-lifetime

キー チェーンの認証キーが有効として受信される期間を設定します。

ip rip authentication key-chain

RIP Version 2 パケットの認証をイネーブルにして、インターフェイスに使用可能なキー セットを指定します。

ip authentication key-chain eigrp

EIGRP パケットの認証をイネーブルにします。

key

キー チェーンの認証キーを識別します。

key-string(認証)

キーの認証文字列を指定します。

send-lifetime

キー チェーンの認証キーが有効に送信される期間を設定します。

show key chain

認証キーの情報を表示します。

key-string(認証)

キーの認証文字列を指定するには、キー チェーン キー コンフィギュレーション モードで key-string(認証)コマンドを使用します。 認証文字列を削除するには、このコマンドの no 形式を使用します。

key-string commandkey-string text

no key-string text

構文の説明

text

認証するルーティング プロトコルを使用してパケットで送受信する必要がある認証文字列。 文字列には、大文字小文字の英数字 1 ~ 80 文字を含めることができます。

コマンド デフォルト

キーの認証文字列は存在しません。

コマンド モード

キー チェーン キー コンフィギュレーション(config-keychain-key)

コマンド履歴

リリース

変更内容

11.1

このコマンドが導入されました。

12.4(6)T

IPv6 のサポートが追加されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

DRP Agent、Enhanced Interior Gateway Routing Protocol(EIGRP)、および Routing Information Protocol(RIP)Version 2 でのみキー チェーンが使用されます。 各キーに 1 つのキー文字列のみを設定できます。

service password-encryption コマンドを使用して)パスワードの暗号化を設定した場合、ソフトウェアは暗号化テキストとしてキー文字列を保存します。 more system:running-config コマンドを使用して端末に書き込むと、key-string 7 は暗号化テキストで表示されます。

次の例では、chain1 という名前のキー チェーンが設定されます。 キー「key1」は午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー「key2」は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# interface ethernet 0
Router(config-if)# ip rip authentication key-chain chain1
Router(config-if)# ip rip authentication mode md5
!
Router(config)# router rip
Router(config-router)# network 172.19.0.0
Router(config-router)# version 2
!
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

次の例では、EIGRP アドレスファミリに chain1 という名前のキー チェーンが設定されます。 キー「key1」は午後 1 時 30 分から午後 3 時 30 分まで受け入れられ、午後 2 時から午後 3 時まで送信されます。 キー「key2」は午後 2 時 30 分から午後 4 時 30 分まで受け入れられ、午後 3 時から午後 4 時まで送信されます。 重複により、キーの移行またはルータの設定時間の相違に対処できます。 時間の相違に対処するために両側に 30 分の余裕があります。

Router(config)# eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# authentication key-chain trees
Router(config-router-af-interface)# authentication mode md5
Router(config-router-af-interface)# exit
Router(config-router-af)# exit
Router(config-router)# exit
Router(config)# key chain chain1
Router(config-keychain)# key 1
Router(config-keychain-key)# key-string key1
Router(config-keychain-key)# accept-lifetime 13:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 14:00:00 Jan 25 1996 duration 3600
Router(config-keychain-key)# exit
Router(config-keychain)# key 2
Router(config-keychain-key)# key-string key2
Router(config-keychain-key)# accept-lifetime 14:30:00 Jan 25 1996 duration 7200
Router(config-keychain-key)# send-lifetime 15:00:00 Jan 25 1996 duration 3600

関連コマンド

コマンド

説明

accept-lifetime

キー チェーンの認証キーが有効として受信される期間を設定します。

ip authentication key-chain eigrp

EIGRP パケットの認証をイネーブルにします。

key

キー チェーンの認証キーを識別します。

key chain

ルーティング プロトコルの認証をイネーブルにするために必要な認証キー チェーンを定義します。

send-lifetime

キー チェーンの認証キーが有効に送信される期間を設定します。

service password-encryption

パスワードを暗号化します。

show key chain

認証キーの情報を表示します。

match interface(IP)

指定されたインターフェイスのいずれかを起点とするネクスト ホップが存在するルートを配布するには、ルートマップ コンフィギュレーション モードで match interface コマンドを使用します。 match interface エントリを削除するには、このコマンドの no 形式を使用します。

match interface interface-type interface-number [ . .. interface-type interface-number ]

no match interface interface-type interface-number [ . .. interface-type interface-number ]

構文の説明

interface- type

インターフェイス タイプ。

interface- number

インターフェイス番号を指定します。

コマンド デフォルト

一致インターフェイスは定義されません。

コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.1(2)S

このコマンドが Cisco IOS Release 15.1(2)S に統合されました。

使用上のガイドライン

コマンド構文内の省略記号(...)は、コマンドを入力するときに、interface-type interface-number 引数に対応する値を複数指定できることを意味します。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、set 処理match コマンドによる基準が満たされた場合に実行する特定の再配布アクション)を指定します。 no route-map コマンドはルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。 一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

次の例では、イーサネット インターフェイス 0 を起点とするネクスト ホップがあるルートが配布されます。

route-map name
 match interface ethernet 0

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ip address

宛先ネットワーク番号アドレスが標準アクセス リスト、拡張アクセス リスト、またはプレフィックス リストで許可されているルートを配布する場合、またはパケットでポリシー ルーティングを実行する場合は、ルートマップ コンフィギュレーション モードで match ip address コマンドを使用します。 match ip address エントリを削除するには、このコマンドの no 形式を使用します。

match ip address { access-list-number [ access-list-number . .. | access-list-name . .. ] | access-list-name [ access-list-number . .. | access-list-name ] | prefix-list prefix-list-name [ prefix-list-name . .. ] }

no match ip address { access-list-number [ access-list-number . .. | access-list-name . .. ] | access-list-name [ access-list-number . .. | access-list-name ] | prefix-list prefix-list-name [ prefix-list-name . .. ] }

構文の説明

access-list-number...

標準アクセス リストまたは拡張アクセス リストの番号。 1 ~ 199 の整数を指定できます。 省略符号は、複数の値を入力可能であることを示します。

access-list-name...

標準アクセス リストまたは拡張アクセス リストの名前。 1 ~ 199 の整数を指定できます。 省略符号は、複数の値を入力可能であることを示します。

prefix-list

プレフィックス リストに基づいてルートを配布します。

prefix-list-name...

特定のプレフィックス リストの名前。 省略符号は、複数の値を入力可能であることを示します。

コマンド デフォルト

アクセス リスト番号もプレフィックス リストも指定されません。

コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.1(2)S

このコマンドが Cisco IOS Release 15.1(2)S に統合されました。

使用上のガイドライン

このコマンド構文内の省略符号(...)は、access-list-number、access-list-name、または prefix-list-name 引数に複数の値を入力できることを示します。

同じルート マップ サブブロック内の類似 match は、「OR」(論理和)でフィルタリングされます。 ルート マップ サブブロック全体の中に一致する match 節が 1 つあれば、照合の成功として処理されます。 非類似 match 句は、「AND」(論理積)でフィルタリングされます。 したがって、非類似照合は論理的にフィルタリングされます。 最初の条件セットが満たされない場合、2 つ目の match 節がフィルタリングされます。 このプロセスは一致するものが見つかるまで、または match 節がなくなるまで続きます。

ルートの再配布またはパケットのポリシー ルーティングを実行するには、ルート マップを使用します。 両方の用途について、ここで説明します。

再分配

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、set 処理match コマンドによる基準が満たされた場合に実行する特定の再配布アクション)を指定します。 no route-map コマンドはルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップを使用してルートを渡す場合、ルート マップの複数のセクションに特定の match節を入力できます。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。 一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

ポリシー ルーティング

ルート マップには、ポリシー ルーティングをイネーブルにするというもう 1 つの用途があります。 match ip address コマンドは、拡張アクセス リスト(プロトコル、プロトコル サービス、送信元または宛先の IP アドレスなど)による一致基準に基づいたパケットのポリシー ルーティングを可能にします。 パケットのポリシー ルーティング条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドに加えて、ip policy route-map インターフェイス コンフィギュレーション コマンドも使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(ポリシー ルーティングが発生する条件)を指定します。 set コマンドでは、set 処理match コマンドによる基準が満たされた場合に実行する特定のルーティング アクション)を指定します。 送信元に基づくパケットのポリシー ルーティングを、たとえばアクセス リストを使用して実行できます。

次の例では、アクセス リスト番号 5 または 80 で指定されたアドレスを持つルートが一致と見なされます。

Router(config)# route-map name
Router(config-route-map)#  match ip address 5 80

プレフィックス リストを使用するルート マップは、他のルーティング プロトコルでルート フィルタリング、デフォルト発信元、および再配布に使用できます。 次の例では、プレフィックス 10.1.1.0/24 がルーティング テーブルに存在する場合にデフォルト ルート 0.0.0.0/0 が条件付きで発信されます。

Router(config)# ip prefix-list cond permit 10.1.1.0/24
!
Router(config)# route-map default-condition permit 10
Router(config-route-map)# match ip address prefix-list cond
!
Router(config)# router rip
Router(config-router)# default-information originate route-map default-condition

次のポリシー ルーティングの例では、アクセス リスト番号 6 または 25 で指定されたアドレスを持つパケットがイーサネット インターフェイス 0 にルーティングされます。

Router(config)# interface serial 0
Router(config-if)# ip policy route-map chicago
!
Router(config)# route-map chicago
Router(config-route-map)# match ip address 6 25 
Router(config-route-map)# set interface ethernet 0

関連コマンド

コマンド

説明

ip local policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set default interface

ポリシー ルーティングにおいてルート マップの match 句を満たし、宛先への明示ルートがないパケットの出力先を示します。

set interface

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco IOS ソフトウェアが持たない場合の出力先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ip next-hop

指定されたいずれかのアクセス リストによって渡されるネクストホップ ルータ アドレスがあるルートを再配布するには、ルートマップ コンフィギュレーション モードで match ip next-hop コマンドを使用します。 ネクスト ホップ エントリを削除するには、このコマンドの no形式を使用します。

match ip next-hop { access-list-number | access-list-name } [ . .. access-list-number | . .. access-list-name ]

no match ip next-hop { access-list-number | access-list-name } [ . .. access-list-number | . .. access-list-name ]

構文の説明

access-list-number access-list-name

標準アクセス リストまたは拡張アクセス リストの番号または名前。 1 ~ 199 の整数を指定できます。

コマンド デフォルト

ネクスト ホップ アドレスの一致を必要とせず、自由にルートが再配布されます。

コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.1(2)S

このコマンドが Cisco IOS Release 15.1(2)S に統合されました。

使用上のガイドライン

コマンド構文に含まれる省略符号(...)は、コマンド入力に access-list-number または access-list-name 引数の値を複数含めることができることを示します。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、set 処理match コマンドによる基準が満たされた場合に実行する特定の再配布アクション)を指定します。 no route-map コマンドはルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルートがルート マップを通過するようにするときには、ルート マップに複数の要素を持たせることができます。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。 一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

次の例では、ネクスト ホップ ルータ アドレスがアクセス リスト 5 または 80 で一致したルートが再配布されます。

Router(config)# route-map name
Router(config-route-map)# match ip next-hop 5 80

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ip route-source

アクセス リストに指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを照合するには、ルートマップ コンフィギュレーション モードで、match ip route-source コマンドを使用します。 ルート ソース エントリを削除するには、このコマンドの no形式を使用します。

match ip route-source [ access-list-number [ . .. access-list-number ] ] [ expanded-access-list [ . .. expanded-access-list ] ] [ access-list-name [ . .. access-list-name ] ] [ prefix-list name [ . . .prefix-list name ] ] [redistribution-source]

no match ip route-source [ access-list-number [ . .. access-list-number ] ] [ expanded-access-list [ . .. expanded-access-list ] ] [ access-list-name [ . .. access-list-name ] ] [ prefix-list name [ . . .prefix-list name ] ] [redistribution-source]

構文の説明

access-list-number

(任意)標準アクセス リストの番号。 範囲は 1 ~ 199 です。

expanded-access-list

(任意)拡張アクセス リストの番号。 指定できる範囲は 1300 ~ 1999 です。

access-list-name

(任意)標準アクセス リストの名前。

prefix-list name

(任意)指定したプレフィックス リストの一致エントリを設定します。

redistribution-source

(任意)Enhanced Interior Gateway Routing Protocol(EIGRP)のルート再配布ソースを指定します。

コマンド デフォルト

ルートのフィルタリングはルート ソースで適用されません。

コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが Cisco IOS XE Release 2.1 に統合され、Cisco ASR 1000 シリーズの集約サービス ルータに実装されました。

使用上のガイドライン

コマンド構文に含まれる省略符号(...)は、コマンド入力に access-list-number 引数、expanded-access-list 引数、access-list-name 引数、および prefix-list name キーワードと引数のペアの値を複数含めることができることを示します。

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準、つまり現在の route-map コマンドについて再配布を許可する条件を指定します。 set コマンドでは、set 処理(match コマンドによる基準が満たされた場合に実行する特定の再配布アクション)を指定します。 no route-map コマンドはルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。 一部のデータのみ修正する場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

次に、アクセス リスト 5 および拡張アクセス リスト 1335 で指定されているアドレスのルータおよびアクセス サーバによってアドバタイズされたルートを照合する方法を示します。

Router(config)# route-map R1
Router(config-route-map)# match ip route-source 5 1335

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定されたインターフェイスのいずれかからのネクスト ホップを持つルートを再配布します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip redistribution-source

アクセス リストによって指定されたアドレスのルータおよびアクセス サーバによってアドバタイズされた外部 EIGRP ルートをフィルタリングします。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match ipv6 address

プレフィックス リストで許可されたプレフィックスを持つ IPv6 ルートを配布したり、IPv6 向けポリシーベース ルーティング(PBR)のパケットを照合するために使用する IPv6 アクセス リストを指定したりするには、ルートマップ コンフィギュレーション モードで match ipv6 address コマンドを使用します。 match ipv6 address エントリを削除するには、このコマンドの no 形式を使用します。

match ipv6 address { prefix-list prefix-list-name | access-list-name }

no match ipv6 address

構文の説明

prefix-list prefix-list-name

IPv6 プレフィックス リストの名前を指定します。

access-list-name

IPv6 アクセス リスト名。 名前にはスペースまたは引用符を含めることはできません。また、数字で始めることはできません。

コマンド デフォルト

ルートは、宛先ネットワーク番号またはアクセス リストに基づいて配布されません。

コマンド モード


ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

12.2(2)T

このコマンドが導入されました。

12.0(21)ST

このコマンドが Cisco IOS Release 12.0(21)ST に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.3(7)T

このコマンドが変更されました。 引数 access-list-name が追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SXI4

このコマンドが変更されました。 prefix-list prefix-list-name キーワードと引数のペアの引数は、Cisco IOS Release 12.2(33)SXI4 ではサポートされません。

Cisco IOS XE Release 3.2S

このコマンドが Cisco IOS XE Release 3.2S に統合されました。

15.1(1)SY

このコマンドが、Cisco IOS Release 15.1(1)SY に統合されました。

Cisco IOS XE Release 3.2SE

このコマンドが Cisco IOS XE Release 3.2SE に統合されました。

使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map コマンドと、match および set コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準、つまり現在の route-map コマンドについて再配布を許可する条件を指定します。 set コマンドでは、set 処理(match コマンドによる基準が満たされた場合に実行する特定の再配布アクション)を指定します。

match ipv6 address コマンドは、アクセス リストまたはプレフィックス リストを指定するために使用できます。 PBR を使用する場合は、access-list-name 引数を指定する必要があります。prefix-list prefix-list-name キーワードと引数のペアの引数は機能しません。

次の例では、marketing という名前のプレフィックス リストで指定されたアドレスを持つ IPv6 ルートが照合されます。

Device(config)# route-map name
Device(config-route-map)# match ipv6 address prefix-list marketing

次の例では、marketing という名前のアクセス リストで指定されたアドレスを持つ IPv6 ルートが照合されます。

Device(config)# route-map
Device(config-route-map)# match ipv6 address marketing

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match ipv6 address

IPv6 の PBR でパケットの照合に使用する IPv6 アクセス リストを指定します。

match ipv6 next-hop

プレフィックス リストによって許可されているネクスト ホップ プレフィックスを持つ IPv6 ルートを配布します。

match ipv6 route-source

プレフィックス リストで指定されているアドレスのルータによってアドバタイズされた IPv6 ルートを配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match metric

指定したメトリックを持つルートを再配布します。

match route-type

指定されたタイプのルートを再配布します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義します。

set as-path

BGP ルートの自律システム パスを変更します。

set community

BGP コミュニティ属性を設定します。

set default interface

ポリシー ルーティングにおいてルート マップの match 句を満たし、宛先への明示ルートがないパケットの出力先のデフォルト インターフェイスを指定します。

set interface

ポリシー ルーティング用のルート マップの match 句を通過したパケットの送出先のデフォルト インターフェイスを指定します。

set ipv6 default next-hop

一致パケットが転送されるデフォルトの IPv6 ネクスト ホップを指定します。

set ipv6 next-hop(PBR)

ポリシー ルーティング用のルート マップの match 句を通過した IPv6 パケットの送出先を示します。

set ipv6 precedence

IPv6 パケット ヘッダーのプリファレンス値を設定します。

set level

ルートのインポート先を示します。

set local preference

自律システム パスのプリファレンス値を指定します。

set metric

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set tag

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match length

レベル 3 パケット長に基づくポリシー ルーティングを実行するには、ルートマップ コンフィギュレーション モードで、match length コマンドを使用します。 エントリを削除するには、このコマンドの no 形式を使用します。

match length minimum-length maximum-length

no match length minimum-length maximum-length

構文の説明

minimum-length

一致として許容されるレベル 3 パケット長の最小値。 範囲は 0 ~ 0x7FFFFFFF です。

maximum-length

一致として許容されるレベル 3 パケット長の最大値。 範囲は 0 ~ 0x7FFFFFFF です。

コマンド デフォルト

パケット長に基づくポリシー ルーティングは実行されません。

コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.3(7)T

このコマンドが変更されました。 このコマンドが IPv6 ポリシーベース ルーティング(PBR)の設定で使用するために更新されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

このコマンドが Cisco IOS XE Release 3.2S に統合されました。

15.1(1)SY

このコマンドが、Cisco IOS Release 15.1(1)SY に統合されました。

使用上のガイドライン

IPv4 でパケットのポリシー ルーティング条件を定義するには、ip policy route-map インターフェイス コンフィギュレーション コマンド、route-map グローバル コンフィギュレーション コマンド、および matchset のルートマップ コンフィギュレーション コマンドを使用します。 ip policy route-map コマンドは、名前でルート マップを識別します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(ポリシー ルーティングが発生する条件)を指定します。 set コマンドは、set 処理match コマンドによって強制される基準が満たされた場合に実行される特定のルーティング アクション)を指定します。

PBR for IPv6 でパケットのポリシー ルーティング条件を定義するには、ipv6 policy route-map または ipv6 local policy route-map コマンドを使用します。

IPv4 の match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドは任意の順序で発行できます。set コマンドで指定された set 処理に基づいてパケットがルーティングされるようにするためには、すべての match コマンドを「通過」する必要があります。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

IPv4 では、パケット長に基づくポリシー ルーティングが可能なため、インタラクティブ トラフィックとバルク トラフィックを異なるルータに送信できます。

次の例では、3 ~ 200 バイトの長さのパケットが FDDI インターフェイス 0 にルーティングされます。

interface serial 0
 ip policy route-map interactive
!
route-map interactive
 match length 3 200
 set interface fddi 0

IPv6 に関する次の例では、3 ~ 200 バイトの長さのパケットが FDDI インターフェイス 0 にルーティングされます。

interface Ethernet0/0
  ipv6 policy-route-map interactive
!
route-map interactive
 match length 3 200
 set interface fddi 0

関連コマンド

コマンド

説明

ip local policy route-map

インターフェイスのポリシー ルーティングに使用するルート マップを指定します。

ipv6 local policy route-map

IPv6 により発生したパケットの IPv6 PBR を設定します。

ipv6 policy route-map

インターフェイスで IPv6 PBR を設定します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ipv6 address

IPv6 PBR のパケットを照合するために使用する IPv6 アクセス リストを指定します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set default interface

ポリシー ルーティングにおいてルート マップの match 句を満たし、宛先への明示ルートがないパケットの出力先を示します。

set interface

ポリシー ルーティング用のルート マップの match 句に合格したパケットの出力先を示します。

set ip default next-hop

ポリシー ルーティングにおいてルート マップの match 句を通過するパケットの宛先への明示ルートを Cisco ソフトウェアが持たない場合の出力先を示します。

set ipv6 default next-hop

一致パケットが転送されるデフォルトの IPv6 ネクスト ホップを指定します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set ipv6 next-hop(PBR)

ポリシー ルーティング用のルート マップの match 句を通過した IPv6 パケットの送出先を示します。

set ipv6 precedence

IPv6 パケット ヘッダーのプリファレンス値を設定します。

match metric(IP)

メトリックが指定されたルートを再配布するには、ルートマップ コンフィギュレーション モードで match metric コマンドを使用します。 ルーティング テーブルから再配布されたルートに関するエントリを削除するには、このコマンドの no 形式を使用します。

match metric { metric-value | external metric-value } [+-deviation-number]

no match metric { metric-value | external metric-value } [+-deviation-number]

構文の説明

metric-value

Enhanced Interior Gateway Routing Protocol(EIGRP)の 5 つの部分からなるメトリックとなる内部ルート メトリック。 指定できる範囲は 1 ~ 4294967295 です。

external

ルートに関連付けられ、ソース プロトコルによって解釈される外部プロトコル。

+- deviation-number

(任意)metric-value 引数に対して設定された数値をオフセットする標準偏差値。 deviation-number 引数は任意の数値にできます。 デフォルトはありません。

(注)     

+ および - のキーワードでメトリックの偏差を指定すると、ルータは、その値の範囲にある任意のメトリックと照合します。

コマンド デフォルト

メトリック値に関するフィルタリングを行いません。

コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

11.2

このコマンドが導入されました。

12.3(8)T

external+- キーワードおよび deviation-number 引数が追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、set 処理match コマンドによる基準が満たされた場合に実行する特定の再配布アクション)を指定します。 no route-map コマンドはルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連する少なくとも 1 つの match 句に一致しないルートは、すべて無視されます。つまり、発信ルート マップではルートはアドバタイズされず、着信ルート マップではルートは受け入れられません。 一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。


(注)  


外部プロトコル ルート メトリックは、EIGRP で割り当てられたルート メトリックと同じではありません。割り当てられたルート メトリックは、EIGRP のベクトル化されたメトリック コンポーネント(遅延、帯域幅、信頼性、負荷、および MTU)を使用して算出された値です。


次の例では、メトリックが 5 のルートが再配布されます。

Router(config)# route-map name
Router(config-route-map)# match metric 5

次の例では、400 ~ 600 の範囲のメトリックが照合されます。

Router(config)# route-map name
Router(config-route-map)# match metric 500 +- 100

次の例は、EIGRP の外部プロトコル メトリック ルートを、有効な偏差の 100、BGP のソース プロトコル、および自律システム 45000 と照合するための、ルート マップの設定方法を示しています。 2 つの match 句が true の場合、対象のルーティング プロトコルのタグ値が 5 に設定されます。 ルート マップを使用して、着信パケットを EIGRP プロセスへ配布します。

Router(config)# route-map metric_range
Router(config-route-map)# match metric external 500 +- 100
Router(config-route-map)# match source-protocol bgp 45000
Router(config-route-map)# set tag 5
!
Router(config)# router eigrp 45000 
Router(config-router)# network 172.16.0.0
Router(config-router)# distribute-list route-map metric_range in

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

match route-type(IP)

指定されたタイプのルートを再配布するには、ルートマップ コンフィギュレーション モードで match route-type コマンドを使用します。 ルート タイプ エントリを削除するには、このコマンドの no 形式を使用します。

match route-type { local | internal | external [ type-1 | type-2 ] | level-1 | level-2 }

no match route-type { local | internal | external [ type-1 | type-2 ] | level-1 | level-2 }

構文の説明

local

ローカルに生成された Border Gateway Protocol(BGP)ルート。

internal

Open Shortest Path First(OSPF)のエリア内およびエリア間ルート、または Enhanced Interior Gateway Routing Protocol(EIGRP)の内部ルート。

external [type-1|type-2

OSPF 外部ルートまたは EIGRP 外部ルート。 OSPF の場合、external type-1 キーワードはタイプ 1 外部ルートにのみ一致し、external type-2 キーワードはタイプ 2 外部ルートにのみ一致します。

level-1

Intermediate System-to-Intermediate System(IS-IS)レベル 1 ルート。

level-2

IS-IS レベル 2 ルート。

コマンド デフォルト

このコマンドは、デフォルトでディセーブルになっています。

コマンド モード

ルート マップ コンフィギュレーション

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

11.2

local および external [type-1 | type-2] キーワードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、set 処理match コマンドによる基準が満たされた場合に実行する特定の再配布アクション)を指定します。 no route-map コマンドはルート マップを削除します。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルート マップは、いくつかの部分にわかれている可能性があります。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。 一部のデータのみを変更したい場合は、2 番目のルート マップ セクションに明示的に match を指定する必要があります。

内部ルートを再配布する例を示します。

route-map name
 match route-type internal

関連コマンド

コマンド

説明

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定されたインターフェイスのいずれかがネクスト ホップであるルートを再配布します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ip next-hop

指定のアクセス リストのいずれかが通過する、ネクスト ホップ ルータ アドレスを持ったルートをすべて再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set level(IP)

ルートのインポート先を示します。

set local-preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

match tag

特定のルート タグに一致するルートをフィルタリングするには、ルートマップ コンフィギュレーション モードで match tag コマンドを使用します。 タグ エントリを削除するには、このコマンドの no形式を使用します。

match tag { tag-value | tag-value-dotted-decimal } [ ... tag-value | ... tag-value-dotted-decimal ]

no match tag { tag-value | tag-value-dotted-decimal } [ ... tag-value | ... tag-value-dotted-decimal ]

構文の説明

tag-value

10 進数のルート タグ値。 有効範囲は 0 ~ 4294967295 です。

tag-value-dotted-decimal

ドット付き 10 進数のルート タグ値。 有効範囲は 0.0.0.0 ~ 255.255.255.255 です。

コマンド デフォルト

match tag の値は定義されません。

コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco ASR 1000 シリーズの集約サービス ルータに実装されました。

15.1(2)S

このコマンドが Cisco IOS Release 15.1(2)S に統合されました。

15.2(2)S

このコマンドが変更されました。 ドット付き 10 進表記のタグ値をサポートするために、tag-value-dotted-decimal 引数が追加されました。

Cisco IOS XE Release 3.6S

このコマンドが変更されました。 ドット付き 10 進表記のタグ値をサポートするために、tag-value-dotted-decimal 引数が追加されました。

使用上のガイドライン

コマンド構文内の省略符号(...)は、tag-value および tag-value-dotted-decimal 引数に複数の値を入力できることを示します。

次の例では、タグ値 5 を持つルートを照合する方法を示します。

Device(config)# route-map name
Device(config-route-map)# match tag 5

次の例では、タグ値 10.10.10.10 を持つルートを照合する方法を示します。

Device(config)# route-map name
Device(config-route-map)# match tag 10.10.10.10

関連コマンド

コマンド

説明

match as-path

アクセス リストで指定された BGP 自律システム パスを照合します。

match community

BGP コミュニティを照合します。

match ip address

パケットのポリシー ルーティングを実行し、標準または拡張アクセス リストで許可された宛先アドレスを含むすべてのルートを配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

set automatic-tag

自動的にタグ値を計算します。

set level(IP)

ルートのインポート先を示します。

set local-preference

ルート マップに合格した自律システム パスのプリファレンス値を指定します。

set metric(BGP-OSPF-RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric-type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag(IP)

ルートのタグ値を設定します。

maximum-paths

IP ルーティング プロトコルがサポートできる最大パラレル ルート数を制御するには、ルータ アドレス ファミリ トポロジまたはルータ コンフィギュレーション モードで maximum-paths コマンドを使用します。 デフォルトのパラレル ルート数に戻すには、このコマンドの no形式を使用します。

maximum-paths number-of-paths

no maximum-paths number-of-paths

構文の説明

number-of-paths

IP ルーティング プロトコルがルーティング テーブルにインストールするパラレル ルートの最大数。 有効な値は、Cisco IOS のリリースとプラットフォームによって異なります。 有効な値の詳細については、疑問符(?)オンライン ヘルプ機能を使用してください。

コマンド デフォルト

デフォルトのパラレル ルート数は Cisco IOS のリリースとプラットフォームによって異なります。

コマンド モード

ルータ アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

12.2(8)T

このコマンドが導入されました。

12.2(14)SX

このコマンドがスーパーバイザ エンジン 720 に実装されました。

12.2(17d)SXB

スーパーバイザ エンジン 2 上のこのコマンドのサポートが Cisco IOS Release 12.2(17d)SXB に拡張されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが変更されました。 このコマンドが、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで使用できるようになりました。

12.2(33)SXH

このコマンドが変更されました。 Cisco IOS Release 12.2(33) SXH のパスの最大数が 8 から 16 に変更されました。

Cisco IOS XE Release 3.5S

Cisco IOS XE Release 3.5S では、Cisco ASR 903 ルータのサポートが追加されました。

使用上のガイドライン

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を設定予定の場合、この Open Shortest Path First(OSPF)ルータ コンフィギュレーション コマンドがトポロジを認識するために、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードで maximum-paths コマンドを入力する必要があります。

OSPF ルーティング プロセスで、1 つの宛先に最大 16 のパスを許容する例を示します。

Router(config)# router ospf 3
Router(config-router)# maximum-paths 16

nsf

Cisco NSF をイネーブルにし、設定するには、ルータ コンフィギュレーション モードで nsf コマンドを使用します。 NSF をディセーブルにするには、このコマンドの no 形式を使用します。

nsf [ enforce global ]

nsf [ { cisco | ietf } | interface wait seconds | interval minutes | t3 [ adjacency | manual seconds ] ]

no nsf

構文の説明

enforce global

(任意)NSF 非対応ネイバーが検出された場合、OSPF NSF の再開をキャンセルします。

cisco

アクティブな RP のフェールオーバーの場合に、シスコ独自の IS-IS NSF 方式を指定します。

ietf

アクティブな RP のフェールオーバーの場合に、IETF IS-IS NSF プロトコル変更方式を指定します。

interface wait seconds

(任意)フェールオーバーのあと Cisco NSF プロセスを実行するまで、インターフェイスが動作するのを待機する時間を指定します。有効値は、1 ~ 60 秒です。

interval minutes

(任意)ルート プロセッサが安定したあと、再開するまで待機する時間を指定します。有効値は、0 ~ 1440 分です。

t3 adjacency

(任意)ラベル スイッチド パス(LSP)データベースが同期化するのを IETF NSF が待機する時間が、スイッチオーバーの前に、指定された RP のネイバーにアドバタイズされる隣接の保持時間により決定されるよう指定します。

t3 manual seconds

(任意)NSF データベースの同期化のあと、再開ノードを中継として見なさないようその他のノードに知らせるまでの待機時間を指定します。有効値は、5 ~ 3600 秒です。

コマンド デフォルト

デフォルト設定は、次のとおりです。

  • NSF はディセーブルです。
  • enforce global -- イネーブル。
  • interval minutes -- 5 分。
  • interface waitseconds -- 10 秒.
  • t3 manual seconds -- 30 秒。

コマンド モード

ルータ コンフィギュレーション

コマンド履歴

リリース

変更内容

12.2(18)SXD

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

nsf コマンドは、Supervisor Engine 2 が設定された Cisco 7600 シリーズ ルータではサポートされません。

nsf t3 マニュアル コマンドを使用して、シスコ独自の IS-IS NSF が設定されているかまたは Internet Engineering Task Force(IETF)IS-IS NSF がイネーブルの場合、nsf interface wait コマンドを使用できます。 インターフェイスが動作するまで時間がかかる場合、このコマンドを使用できます。


(注)  


Cisco NSF は、Cisco 7600 シリーズ ルータが再開時に Cisco NSF の実行が予想される場合だけ必要です。 Cisco 7600 シリーズ ルータが、Cisco NSF の再開だけを実行するネイバーと協力すると予想される場合、スイッチはデフォルト(Cisco NSF をサポートするバージョンのコードを実行)で NSF 対応である必要があります。


nsf コマンドは、router コマンドのサブセットで、指定されたプロセスの対象となるすべてのインターフェイスに影響します。 Cisco NSF は、BGP、OSPF、IS-IS、および EIGRP プロトコルをサポートします。 NSF 処理をイネーブルにするコンフィギュレーション コマンドは、次のとおりです。

  • router ospf コマンドの下の nsf
  • router isis コマンドの下の nsf ietf
  • router bgp コマンドの下の bgp graceful-restart

これらのコマンドは、ルータの実行コンフィギュレーションの一部として発行される必要があります。 再開時にこれらのコマンドは、NSF 処理を作動させるよう復元されます。

[{cisco | ietf} | interface waitseconds | interval minutes | t3 [adjacency | manual seconds]] キーワードおよび引数は、IS-IS だけに適応されます。

{enforce global} キーワードは、OSPF だけに適応されます。

BGP NSF に関するガイドライン

NSF の BGP サポートでは、ネイバー ネットワークのデバイスが NSF 対応デバイスである必要があります。つまり、これらのデバイスにはグレースフル リスタート機能があり、セッション確立中に OPEN メッセージでこの機能をアドバタイズする必要があります。 NSF 対応ルータが、特定の BGP ネイバーでグレースフル リスタート機能がイネーブルでないことを検出した場合、このネイバーを使用した NSF 対応セッションは確立されません。 他のすべてのネイバーに、グレースフル リスタート機能が備わっている場合は、この NSF 対応ネットワーキング デバイスを使用して NSF 対応セッションを引き続き維持します。 グレースフル リスタート機能をイネーブルにするには、bgp graceful-restart ルータ コンフィギュレーション コマンドを入力します。

EIRGP NSF に関するガイドライン

ルータは NSF 対応のルータである可能性がありますが、コールド スタートから動作するため、NSF 再開のネイバーの援助には参加しない場合があります。

IS-IS NSF に関するガイドライン

ネットワーキング デバイス上で IETF は設定されていても、隣接ルータが IETF と互換性がない場合、NSF はスイッチオーバーのあとで打ち切られます。

IS-IS NSF を設定する場合、次の 2 つのキーワードを使用します。

  • ietf:Internet Engineering Task Force IS-IS。スーパーバイザ エンジンのスイッチオーバー後に、NSF 対応のルータが隣接する NSF 対応デバイスに IS-IS NSF 再開要求を送信します。
  • cisco:Cisco IS-IS。 すべての隣接情報および LSP 情報が、スタンバイ スーパーバイザ エンジンに対して保存(チェックポイント)されます。 スイッチオーバー後、新しいアクティブ スーパーバイザ エンジンは、迅速にそのルーティング テーブルを再確立するために、チェックポイントされたデータを使用してその隣接を維持します。

OSPF NSF に関するガイドライン

OSPF NSF では、すべてのネイバー ネットワーキング デバイスが NSF 対応デバイスである必要があります。 NSF 対応ルータが、特定のネットワーク セグメントに非 NSF アウェアのネイバーが存在することを検出すると、このセグメントに対する NSF 機能はディセーブルになります。 完全に NSF 可能または NSF 対応のルータだけで構成されているその他のネットワーク セグメントは、引き続き NSF 機能を提供します。

OSPF NSF は、IPv4 トラフィックの NSF/SSO のみをサポートします。 OSPFv3 は、NSF/SSO ではサポートされていません。 NSF/SSO では、OSPFv2 のみがサポートされています。

次に、すべての OSPF プロセス インターフェイスに関して NSF をイネーブルにする例を示します。

Router(config)# router ospf 109
Router(config-router)# nsf

次に、すべての OSPF プロセス インターフェイスに関して NSF をディセーブルにする例を示します。

Router(config)# router ospf 109
Router(config-router)# no nsf

関連コマンド

コマンド

説明

router

ルーティング プロセスをイネーブルにします。

passive-interface

インターフェイス上のルーティング アップデートの送信をディセーブルにするには、ルータ コンフィギュレーション モードで passive-interface コマンドを使用します。 ルーティング アップデートの送信を再びイネーブルにするには、このコマンドの no 形式を使用します。

passive-interface commandpassive-interface [default] i nterface-type interface-number

no passive-interface interface-type interface-number

構文の説明

default

(任意)すべてのインターフェイスがパッシブとなります。

interface-type

インターフェイス タイプ。

interface-number

インターフェイス番号を指定します。

コマンド デフォルト

インターフェイス上でルーティング アップデートが送信されます。

コマンド モード

ルータ コンフィギュレーション(config-router)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.0

このコマンドが変更されました。 default キーワードが追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

15.1(2)S

このコマンドが Cisco IOS Release 15.1(2)S に統合されました。

使用上のガイドライン

インターフェイス上でルーティング アップデートの送信をディセーブルにした場合でも、特定のサブネットは引き続き他のインターフェイスにアドバタイズされ、このインターフェイス上の他のルータからのアップデートは引き続き受信および処理されます。

default キーワードを指定すると、すべてのインターフェイスがデフォルトでパッシブに設定されます。 この場合、隣接情報を必要とする個別のインターフェイスを設定するには、no passive-interface コマンドを使用します。 default キーワードは、インターネット サービス プロバイダー(ISP)や大規模な企業ネットワークなど、多数のディストリビューション ルータに 200 以上ものインターフェイスが搭載されるような環境で役立ちます。

Open Shortest Path First(OSPF)プロトコルの場合、指定したルータ インターフェイスでは、OSPF ルーティング情報の送信も受信も行われません。 指定したインターフェイス アドレスは、OSPF ドメイン内のスタブ ネットワークとして表示されます。

Intermediate System-to-Intermediate System(IS-IS)プロトコルの場合、このコマンドでは IS-IS に対し、指定したインターフェイスでは実際に IS-IS を実行せずに、このインターフェイスの IP アドレスをアドバタイズするように指示します。 IS-IS に対してこのコマンドの no 形式を使用すると、指定したアドレスの IP アドレスのアドバタイズがディセーブルになります。


(注)  


IS-IS の場合は、1 つ以上のアクティブ インターフェイスを維持する必要があり、このインターフェイスを ip router isis コマンドを使用して設定します。


Enhanced Interior Gateway Routing Protocol(EIGRP)の passive-interface コマンドを使用すると、インターフェイスの hello パケットの交換が抑制されるため、ルーティング アップデートがアドバタイズされなくなり、着信ルーティング アップデートも抑制されます。 パッシブ インターフェイスの詳細については、http:/​/​www.cisco.com/​en/​US/​tech/​tk365/​technologies_​tech_​note09186a0080093f0a.shtml を参照してください。

次に、イーサネット インターフェイス 1 を除く、ネットワーク 10.108.0.0 上のすべてのインターフェイスに対して EIGRP アップデートを送信する例を示します。

router eigrp 109
 network 10.108.0.0
 passive-interface ethernet 1

次のコンフィギュレーションでは、インターフェイス Ethernet 1 およびインターフェイス serial 0 上で IS-IS をイネーブルにし、リンクステート プロトコル データ ユニット(PDU)でインターフェイス Ethernet 0 の IP アドレスをアドバタイズしています。

router isis Finance
 passive-interface Ethernet 0
interface Ethernet 1
 ip router isis Finance
interface serial 0
 ip router isis Finance

次の例では、すべてのインターフェイスをパッシブに設定してから、インターフェイス ethernet0 をアクティブにする方法を示します。

router ospf 100
 passive-interface default
 no passive-interface ethernet0
 network 10.108.0.1 0.0.0.255 area 0

redistribute(IP)

あるルーティング ドメインから別のルーティング ドメインにルートを再配布するには、適切なコンフィギュレーション モードで redistribute コマンドを使用します。 再配布のすべてまたは一部をディセーブルにするには(プロトコルに応じて)、このコマンドの no 形式を使用します。 詳細なプロトコル固有の動作については、「使用上のガイドライン」の項を参照してください。

redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ autonomous-system-number ] [ metric { metric-value | transparent } ] [ metric-type type-value ] [ match { internal | external 1 | external 2 } ] [ tag tag-value ] [ route-map map-tag ] [subnets] [nssa-only]

no redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ autonomous-system-number ] [ metric { metric-value | transparent } ] [ metric-type type-value ] [ match { internal | external 1 | external 2 } ] [ tag tag-value ] [ route-map map-tag ] [subnets] [nssa-only]

構文の説明

protocol

ルートの再配布元であるソース プロトコルです。 次のキーワードのいずれかを指定できます。bgpconnectedeigrpisismobileospfripまたは static [ip]。

static [ip] キーワードは、IP スタティック ルートを再配布する場合に使用します。 オプションの ip キーワードは、Intermediate System-to-Intermediate System(IS-IS)プロトコルに再配布するときに使用します。

connected キーワードは、インターフェイスでイネーブルになっている IP によって自動的に確立されるルートを示します。 Open Shortest Path First(OSPF)や IS-IS などのルーティング プロトコルの場合、これらのルートは自律システムに対して外部として再配布されます。

process-id

(任意)bgp または eigrp キーワードの場合、これは 16 ビット 10 進数値である自律システム番号。

isis キーワードの場合、これはルーティング プロセスの意味のある名前を定義するオプションの tag 値です。 各ルータに指定できる IS-IS プロセスは 1 つだけです。 ルーティング プロセスの名前を作成することは、ルーティングを設定するときに名前を使用することを意味します。

ospf キーワードの場合、これはルートの再配布元である適切な OSPF プロセス ID です。 これは、ルーティング プロセスを示します。 この値はゼロ以外の 10 進数の形式です。

rip キーワードの場合、process-id 値は必要ではありません。

デフォルトでは、プロセス ID は定義されていません。

level-1

IS-IS 用に、レベル 1 ルートが他の IP ルーティング プロトコルに個別に再配布されることを指定します。

level-1-2

IS-IS 用に、レベル 1 とレベル 2 の両方のルートが他の IP ルーティング プロトコルに再配布されることを指定します。

level-2

IS-IS 用に、レベル 2 ルートが他の IP ルーティング プロトコルに個別に再配布されることを指定します。

autonomous-system-number

(任意)再配布ルートの自律システム番号。 指定できる範囲は 1 ~ 65535 です。

  • Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、4 バイト自律システム番号は 65536 ~ 4294967295(asplain 表記)および 1.0 ~ 65535.65535(asdot 表記)の範囲でサポートされます。
  • Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、4 バイト自律システム番号は asdot 表記だけの 1.0 ~ 65535.65535 の範囲でサポートされます。

自律システムの番号形式の詳細については、router bgp コマンドの説明を参照してください。

metric metric-value

(任意)同じルータ上で 1 つの OSPF プロセスから別の OSPF プロセスに再配布する場合、メトリック値を指定しないと、メトリックは 1 つのプロセスから他のプロセスへ存続します。 他のプロセスを OSPF プロセスに再配布するときに、メトリック値を指定しない場合、デフォルトのメトリックは 20 です。 デフォルト値は 0 です

metric transparent

(任意)Routing Information Protocol(RIP)が RIP メトリックとして再配布ルートにルーティング テーブル メトリックを使用するようにします。

metric-type type value

(任意)OSPF の場合、OSPF ルーティング ドメインにアドバタイズされるデフォルトのルートに関連付けられる外部リンク タイプを指定します。 次の 2 つの値のいずれかにすることができます。

  • 1:タイプ 1 外部ルート
  • 2:タイプ 2 外部ルート

metric-type を指定しない場合、Cisco IOS ソフトウェアはタイプ 2 外部ルートを採用します。

IS-IS の場合、次の 2 つの値のいずれかにすることができます。

  • internal:63 以下の IS-IS メトリック。
  • external:64 以上、128 以下の IS-IS メトリック。

デフォルトは、internal です。

match {internal | external1 | external2}

(任意)OSPF ルートを他のルーティング ドメインに再配布する条件を指定します。 次のいずれかを指定できます。

  • internal:特定の自律システムの内部のルート。
  • external 1:自律システムの外部だが、OSPF にタイプ 1 外部ルートとしてインポートされるルート。
  • external 2:自律システムの外部だが、OSPF にタイプ 2 外部ルートとしてインポートされるルート。

デフォルトは、internal です。

tag tag-value

(任意)各外部ルートに付加する 32 ビットの 10 進値を指定します。 これは OSPF 自体には使用されません。 自律システム境界ルータ(ASBR)間で情報を通信するために使用できます。 何も指定しないと、リモート自律システム番号が Border Gateway Protocol(BGP)と Exterior Gateway Protocol(EGP)からのルートに使用されます。他のプロトコルでは、ゼロ(0)が使用されます。

route-map

(任意)このソース ルーティング プロトコルから現在のルーティング プロトコルへのルートのインポートをフィルタリングするために調べる必要があるルート マップを指定します。 指定しない場合は、すべてのルートが再配布されます。 このキーワードを指定し、ルート マップ タグが表示されていない場合、ルートはインポートされません。

map-tag

(任意)設定されたルート マップの ID。

subnets

(任意)OSPF へのルートの再配布において、指定したプロトコルの再配布の範囲。 デフォルトでは、サブネットは定義されません。

nssa-only

(任意)OSPF に再配布されるすべてのルートの nssa-only 属性を設定します。

コマンド デフォルト

ルートの再配布はディセーブルです。

コマンド モード

ルータ コンフィギュレーション(config-router)

アドレス ファミリ コンフィギュレーション(config-af)

アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.0(5)T

このコマンドが変更されました。 アドレス ファミリ コンフィギュレーション モードが追加されました。

12.0(22)S

このコマンドが変更されました。 EIGRP の下でのアドレス ファミリのサポートが追加されました。

12.2(15)T

このコマンドが変更されました。 EIGRP の下でのアドレス ファミリのサポートが追加されました。

12.2(18)S

このコマンドが変更されました。 EIGRP の下でのアドレス ファミリのサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

このコマンドが変更されました。 EIGRP の下でのアドレス ファミリ トポロジのサポートが追加されました。

12.2(14)SX

このコマンドが Cisco IOS Release 12.2(14)SX に組み込まれました。

12.0(32)S12

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.0(32)SY8

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.4(24)T

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 2.3

このコマンドが変更されました。 asdot 表記だけの 4 バイト自律システム番号のサポートが追加されました。

12.2(33)SXI1

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

12.0(33)S3

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルト表記が asplain になりました。

Cisco IOS XE Release 2.4

このコマンドが変更されました。 asplain 表記のサポートが追加され、4 バイト自律システム番号のデフォルト表記が asplain になりました。

15.0(1)M

このコマンドが変更されました。 キーワード nssa-only が追加されました。

12.2(33)SRE

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

15.1(1)SG

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

Cisco IOS XE Release 3.3SG

このコマンドが変更されました。 asplain 表記と asdot 表記の 4 バイト自律システム番号のサポートが追加されました。

15.1(2)SNG

このコマンドが、Cisco ASR 901 シリーズの集約サービス ルータに実装されました。

使用上のガイドライン

redistribute コマンドの no 形式の使用


注意    


redistribute コマンドに設定したオプションを削除するには、期待する結果が得られるように redistribute コマンドの no 形式を慎重に使用する必要があります。 キーワードを変更またはディセーブルにすると、プロトコルによって他のキーワードの状態に影響を与える場合と与えない場合があります。


プロトコルによって redistribute コマンドの no バージョンの実装が異なることを理解することが重要です。

  • BGP、OSPF、RIP 設定では、no redistribute コマンドは、実行コンフィギュレーションの redistribute コマンドから指定キーワードを削除するだけです。 その他のプロトコルから再配布するときは、減法キーワード方式が使用されます。 たとえば、BGP の場合、no redistribute static route-map interior を設定した場合、ルート マップだけが再配布から除外され、redistribute static はフィルタなしのままです。
  • no redistribute isis コマンドでは、実行コンフィギュレーションから IS-IS 再配布は削除されません。 IS-IS は、IS-IS が再配布されたプロトコルであるか、または再配布するプロトコルであるかにかかわらず、コマンド全体を削除します。
  • EIGRP では、EIGRP コンポーネント バージョン rel5 よりも前は減法キーワード方式が使用されていました。 EIGRP コンポーネント バージョン rel5 以降、no redistribute コマンドは、他のプロトコルから再配布するときに、redistribute コマンド全体を削除します。

redistribute コマンドのその他の使用上のガイドライン

内部メトリックが指定されたリンクステート プロトコルを受信するルータの場合、ルートのコストには、そのルータから再配布するルータまでのコストと宛先に達するまでのアドバタイズされたコストの合計が考慮されます。 外部メトリックでは、宛先に達するまでのアドバタイズされたメトリックだけを考慮します。

IP ルーティング プロトコルから学習したルートは、接続されたエリアへのレベル 1 またはレベル 2 に再配布できます。 level-1-2 キーワードは、レベル 1 とレベル 2 の両方のルートを 1 つのコマンドで許可します。

再配布ルーティング情報は、distribute-list out ルータ コンフィギュレーション コマンドによってフィルタリングされる必要があります。 このガイドラインでは、管理者が意図するルートだけが、受信側のルーティング プロトコルに転送されることを保証しています。

redistribute コマンドまたは default-information ルータ コンフィギュレーション コマンドを使用して、OSPF ルーティング ドメインにルートを再配布した場合は、必ずルータは自動で ASBR になります。 ただし、デフォルトでは、ASBR はデフォルト ルートを OSPF ルーティング ドメインに生成しません。

ルートが OSPF や BGP 以外のプロトコルから OSPF に再配布され、メトリックが metric-type キーワードと type-value 引数で指定されていない場合、OSPF はデフォルト メトリックとして 20 を使用します。 ルートが BGP から OSPF に再配布される場合、OSPF はデフォルト メトリックとして 1 を使用します。 ルートがある OSPF プロセスから別の OSPF プロセスに再配布される場合、自律システムの外部ルートおよび Not-So-Stubby-Area(NSSA)ルートはデフォルト メトリックとして 20 を使用します。 エリア内およびエリア間ルートが OSPF プロセス間で再配信される場合、再配布ソース プロセスからの内部 OSPF メトリックは、再配布先のプロセスの外部メトリックとしてアドバタイズされます。 (これは、ルートを OSPF に再配布する場合にルーティング テーブル メトリックが維持されている場合のみです)。

ルートが OSPF に再配布されるときに、subnets キーワードが指定されていない場合、サブネット化されていないルートだけが再配布されます。

NSSA エリアの内部ルータ上では、nssa-only キーワードを指定すると、発信されたタイプ 7 NSSA LSA の伝播(P)ビットがゼロに設定され、エリア境界ルータはタイプ 5 外部 LSA にこれらの LSA を変換できなくなります。 NSSA および通常のエリアに接続されているエリア境界ルータでは、nssa-only キーワードにより、ルートが NSSA エリアにのみ再配布されます。

この redistribute コマンドによって影響される connected キーワードが設定されたルートは、network ルータ コンフィギュレーション コマンドによって指定されていないルートです。

接続ルートをアドバタイズするために使用するメトリックに影響を与える default-metric コマンドは使用できません。


(注)  


redistribute コマンドで指定された metric 値は、default-metric コマンドを使用して指定された metric 値より優先されます。


Interior Gateway Protocol(IGP)または Exterior Gateway Protocol(EGP)の BGP へのデフォルト再配布は、default-information originate ルータ コンフィギュレーション コマンドが指定されていない場合は許可されません。

Release 12.2(33)SRB

Multi-Topology Routing(MTR)機能を設定予定の場合、この OSPF コンフィギュレーション コマンドがトポロジを認識するために、アドレス ファミリ トポロジ コンフィギュレーション モードで redistribute コマンドを入力する必要があります。

4 バイト自律システム番号のサポート

Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)XNE、12.2(33)SXI1、Cisco IOS XE Release 2.4、およびそれ以降のリリースでは、シスコが採用している 4 バイト自律システム番号は、自律システム番号の正規表現のマッチングおよび出力表示形式のデフォルトとして asplain(たとえば、65538)を使用していますが、RFC 5396 に記載されているとおり、4 バイト自律システム番号を asplain 形式および asdot 形式の両方で設定できます。 4 バイト自律システム番号の正規表現マッチングと出力表示のデフォルトを asdot 形式に変更するには、bgp asnotation dot コマンドを使用します。

Cisco IOS Release 12.0(32)S12、12.4(24)T、および Cisco IOS XE Release 2.3 では、シスコが採用している 4 バイト自律システム番号は、設定形式、正規表現とのマッチング、および出力表示として、asdot(たとえば、1.2)だけを使用しています。asplain はサポートしていません。

次に、OSPF ルートが BGP ドメインに再配布される例を示します。

Router(config)# router bgp 109
Router(config-router)# redistribute ospf

次に、OSPF ドメインに EIGRP ルートを再配布する例を示します。

Router(config)# router ospf 110
Router(config-router)# redistribute eigrp

次の例では、指定された EIGRP プロセス ルートを OSPF ドメインに再配布する方法を示しています。 EIGRP 派生メトリックは 100 に、RIP ルートは 200 に再マッピングされます。

Router(config)# router ospf 109
Router(config-router)# redistribute eigrp 108 metric 100 subnets
Router(config-router)# redistribute rip metric 200 subnets

次に、BGP ルートを IS-IS に再配布されるように設定する例を示します。 リンクステート コストが 5、メトリック タイプが外部に設定されています。この場合、内部メトリックよりもプライオリティが下がります。

Router(config)# router isis
Router(config-router)# redistribute bgp 120 metric 5 metric-type external

次の例では、ネットワーク 172.16.0.0 はコスト 100 で OSPF 1 の外部 LSA として表示されます(コストは維持されます)。

Router(config)# interface ethernet 0
Router(config-if)# ip address 172.16.0.1 255.0.0.0
Router(config-if)# exit
Router(config)# ip ospf cost 100
Router(config)# interface ethernet 1
Router(config-if)# ip address 10.0.0.1 255.0.0.0
!
Router(config)# router ospf 1
Router(config-router)# network 10.0.0.0 0.255.255.255 area 0
Router(config-if)# exit
Router(config-router)# redistribute ospf 2 subnet
Router(config)# router ospf 2
Router(config-router)# network 172.16.0.0 0.255.255.255 area 0

次に、BGP ルートを OSPF に再配布し、ローカルの asplain 形式の 4 バイト自律システム番号を割り当てる例を示します。 この例では、Cisco IOS Release 12.0(32)SY8、12.0(33)S3、12.2(33)SRE、12.2(33)SXI1、Cisco IOS XE Release 2.4、またはそれ以降のリリースが必要です。

Router(config)# router ospf 2
Router(config-router)# redistribute bgp 65538

次に、connected metric 1000 subnets オプションを redistribute connected metric 1000 subnets コマンドから削除し、redistribute connected コマンドを設定に残す例を示します。

Router(config-router)# no redistribute connected metric 1000 subnets

次に、metric 1000 オプションを redistribute connected metric 1000 subnets コマンドから削除し、redistribute connected subnets コマンドを設定に残す例を示します。

Router(config-router)# no redistribute connected metric 1000

次に、subnets オプションを redistribute connected metric 1000 subnets コマンドから削除し、redistribute connected metric 1000 コマンドを設定に残す例を示します。

Router(config-router)# no redistribute connected subnets

次に、redistribute connected コマンドと、redistribute connected コマンドに設定されているオプションを設定から削除する例を示します。

Router(config-router)# no redistribute connected

次に、指定した EIGRP 設定で EIGRP ルートを EIGRP プロセスに再配布する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# topology base
Router(config-router-af-topology)# redistribute eigrp 6473 metric 1 1 1 1 1

次に、EIGRP 設定で再配布を設定したりディセーブルにしたりする例を示します。 EIGRP の場合、コマンドの no 形式は、redistribute コマンド セット全体を実行コンフィギュレーションから削除します。

Router(config)# router eigrp 1
Router(config-router)# network 0.0.0.0
Router(config-router)# redistribute eigrp 2 route-map x
Router(config-router)# redistribute ospf 1 route-map x
Router(config-router)# redistribute bgp 1 route-map x
Router(config-router)# redistribute isis level-2 route-map x
Router(config-router)# redistribute rip route-map x

Router(config)# router eigrp 1
Router(config-router)# no redistribute eigrp 2 route-map x
Router(config-router)# no redistribute ospf 1 route-map x
Router(config-router)# no redistribute bgp 1 route-map x
Router(config-router)# no redistribute isis level-2 route-map x
Router(config-router)# no redistribute rip route-map x
Router(config-router)# end

Router# show running-config | section router eigrp 1

router eigrp 1
 network 0.0.0.0

次に、OSPF 設定で再配布を設定したりディセーブルにしたりする例を示します。 コマンドの no 形式は、実行コンフィギュレーションの redistribute コマンドから指定したキーワードのみを削除します。

Router(config)# router ospf 1
Router(config-router)# network 0.0.0.0
Router(config-router)# redistribute eigrp 2 route-map x
Router(config-router)# redistribute ospf 1 route-map x
Router(config-router)# redistribute bgp 1 route-map x
Router(config-router)# redistribute isis level-2 route-map x
Router(config-router)# redistribute rip route-map x

Router(config)# router ospf 1
Router(config-router)# no redistribute eigrp 2 route-map x
Router(config-router)# no redistribute ospf 1 route-map x
Router(config-router)# no redistribute bgp 1 route-map x
Router(config-router)# no redistribute isis level-2 route-map x
Router(config-router)# no redistribute rip route-map x
Router(config-router)# end

Router# show running-config | section router ospf 1

router ospf 1
 redistribute eigrp 2
 redistribute ospf 1
 redistribute bgp 1
 redistribute rip 
 network 0.0.0.0 

次に、BGP で再配布からルート マップ フィルタだけを排除する例を示します。再配布自体はフィルタなしで有効なままです。

Router(config)# router bgp 65000
Router(config-router)# no redistribute eigrp 2 route-map x

次に、BGP への EIGRP 再配布を削除する例を示します。

Router(config)# router bgp 65000
Router(config-router)# no redistribute eigrp 2 

関連コマンド

コマンド

説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

address-family ipv4(BGP)

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 IPv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

address-family vpnv4

ルータをアドレス ファミリ コンフィギュレーション モードにして、標準 VPNv4 アドレス プレフィックスを使用する、BGP、RIP、スタティック ルーティング セッションなどのルーティング セッションを設定します。

bgp asnotation dot

デフォルトの表示を変更し、BGP 4 バイト自律システム番号の正規表現一致形式を、asplain(10 進数の値)からドット付き表記にします。

default-information originate(BGP)

ネットワーク 0.0.0.0 の BGP への再配布を可能にします。

default-information originate(IS-IS)

IS-IS ルーティング ドメインへのデフォルト ルートを生成します。

default-information originate(OSPF)

OSPF ルーティング ドメインへのデフォルト ルートを生成します。

distribute-list out(IP)

ネットワークがアップデート時にアドバタイズされないようにします。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、ポリシー ルーティングをイネーブルにします。

router bgp

BGP ルーティング プロセスを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

show route-map

設定されたすべてのルート マップ、または指定した 1 つのルート マップだけを表示します。

topology(EIGRP)

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

route-map

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布したり、ポリシー ルーティングをイネーブルにしたりするには、グローバル コンフィギュレーション モードで route-map コマンドを使用します。 エントリを削除するには、このコマンドの no 形式を使用します。

route-map map-tag [ permit | deny ] [sequence-number]

no route-map map-tag [ permit | deny ] [sequence-number]

構文の説明

map-tag

ルート マップの名前。

permit

(任意)ルート マップに一致するルートのみの転送または再配布を許可します。

deny

(任意)ルート マップに一致するルートの転送または再配布をブロックします。

sequence-number

(任意)すでに同じ名前で設定されているルート マップ リスト内の新しいルート マップの位置を指定する番号。

コマンド デフォルト

ポリシー ルーティングはイネーブルではなく、あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件は設定されません。

コマンド モード

グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

10.0

このコマンドが導入されました。

12.3(7)T

このコマンドが IPv6 ポリシーベース ルーティング(PBR)の設定で使用するために更新されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

Cisco IOS XE Release 2.1

このコマンドが、Cisco ASR 1000 シリーズの集約サービス ルータに実装されました。

12.2(33)SXI4

このコマンドが変更されました。 Cisco IOS Release 12.2(33)SXI4 に統合されました。

15.1(1)SY

このコマンドが、Cisco IOS Release 15.1(1)SY に統合されました。

使用上のガイドライン

route-map コマンドを使用して、ルート マップ コンフィギュレーション モードを開始します。

ルートの再配布またはパケットのポリシー ルーティングを実行するには、ルート マップを使用します。 両方の用途について、ここで説明します。

再分配

あるルーティング プロトコルから別のルーティング プロトコルにルートを再配布する条件を定義するには、route-map グローバル コンフィギュレーション コマンドと、match および set route-map コンフィギュレーション コマンドを使用します。 route-map コマンドごとに、それに関連した match および set コマンドのリストがあります。 match コマンドは、一致基準(現在の route-map コマンドで再配布が許可される条件)を指定します。 set コマンドでは、set 処理match コマンドによる基準が満たされた場合に実行する特定の再配布アクション)を指定します。 no route-map コマンドにより、ルート マップが削除されます。

match route-map コンフィギュレーション コマンドには複数の形式があります。 match コマンドの順序は任意に指定できます。すべての match コマンドが満たされないと、set コマンドで指定した set 処理に従ってルートの再配布が行われません。 match コマンドの no 形式を使用すると、指定した一致基準が削除されます。

ルーティング プロセス間でルートを再配布する方法を詳細に制御する必要がある場合にルート マップを使用します。 宛先ルーティング プロトコルは router グローバル コンフィギュレーション コマンドを使用して指定します。 ソース ルーティング プロトコルは redistribute ルータ コンフィギュレーション コマンドを使用して指定します。 ルート マップの設定方法の例については、「例」の項を参照してください。

ルートがルート マップを通過するようにするときには、ルート マップに複数の要素を持たせることができます。 route-map コマンドに関連付けられているどの match ステートメントとも一致しないルートは無視されます。したがって、そのルートは発信ルート マップ用にアドバタイズされることも、着信ルート マップ用に受け入れられることもありません。 一部のデータのみ修正したい場合は、別にルート マップ セクションを設定して明示的に一致基準を指定する必要があります。

redistribute ルータ コンフィギュレーション コマンドでは、map-tag 引数で指定された名前を使用してルート マップを参照します。 複数のルート マップで同じマップ タグ名を共有できます。

このルート マップの一致基準が満たされた場合、permit キーワードが指定されていると、設定アクションに従ってルートが再配布されます。 ポリシー ルーティングの場合、パケットはポリシーに従ってルーティングされます。 一致基準が満たされなかった場合、permit キーワードが指定されていると、同じマップ タグを持つ次のルート マップがテストされます。 あるルートが、同じ名前を共有するルート マップ セットの一致基準のいずれをも満たさない場合、そのセットによる再配布は行われません。

ルート マップの一致基準が満たされた場合でも、deny キーワードが指定されているとルートは再配布されません。 ポリシー ルーティングの場合、パケットはポリシーに従ってルーティングされません。また、同じマップ タグ名を共有するルート マップは、これ以上検証されません。 パケットがポリシー ルーティングの対象にならない場合、通常の転送アルゴリズムが使用されます。

ポリシー ルーティング

ルート マップには、ポリシー ルーティングをイネーブルにするというもう 1 つの用途があります。 ポリシー ルーティング パケットの条件を定義するには、route-map コマンド、match および set コマンドに加えて、ip policy route-map または ipv6 policy route-map コマンドを使用します。 match コマンドは、ポリシー ルーティングが行われる条件を指定します。 set コマンドは、match コマンドで指定した基準を満たしている場合に実行するルーティング動作を指定します。 自明の最短パスと異なる方法でルート パケットにポリシーを適用することができます。

sequence-number 引数は次のように動作します。

  1. 提供されたタグでエントリが定義されていない場合、sequence-number 引数を 10 にしたエントリが作成されます。
  2. 提供されたタグでエントリが 1 つしか定義されていない場合、そのエントリが後続の route-map コマンドのデフォルト エントリになります。 このエントリの sequence-number 引数は変わりません。
  3. 提供されたタグで複数のエントリが定義されている場合、sequence-number 引数が必要であることを伝えるエラー メッセージが表示されます。

no route-map map-tag コマンドが指定されると(sequence-number 引数なし)、ルート マップ全体が削除されます。

次に、ホップ カウントが 1 の Routing Information Protocol(RIP)ルートを Open Shortest Path First(OSPF)に再配布する例を示します。 これらのルートはメトリック 5、メトリック タイプがタイプ 1、タグが 1 の外部リンクステート アドバタイズメント(LSA)として OSPF に再配布されます。

Device(config)# router ospf 109
Device(config-router)# redistribute rip route-map rip-to-ospf
Device(config-router)# exit
Device(config)# route-map rip-to-ospf permit
Device(config-route-map)# match metric 1
Device(config-route-map)# set metric 5
Device(config-route-map)# set metric-type type1
Device(config-route-map)# set tag 1

次に、ホップ カウントが 1 の RIP ルートを OSPF に再分配する IPv6 の例を示します。 これらのルートは、タグが 42、メトリック タイプがタイプ 1 の外部 LSA として OSPF に再配布されます。

Device(config)# ipv6 router ospf 1
Device(config-router)# redistribute rip one route-map rip-to-ospfv3
Device(config-router)# exit
Device(config)# route-map rip-to-ospfv3
Device(config-route-map)# match tag 42
Device(config-route-map)# set metric-type type1

次の名前付き設定の例では、ホップ カウントが 1 の Enhanced Interior Gateway Routing Protocol(EIGRP)アドレスを再配布する方法を示します。 これらのアドレスは、メトリックが 5、タグが 1 の外部として EIGRP に再配布されます。

Device(config)# router eigrp virtual-name1
Device(config-router)# address-family ipv4 autonomous-system 4453
Device(config-router-af)# topology base
Device(config-router-af-topology)# redistribute eigrp 6473 route-map virtual-name1-to-virtual-name2
Device(config-router-af-topology)# exit-address-topology
Device(config-router-af)# exit-address-family
Device(config-router)# router eigrp virtual-name2
Device(config-router)# address-family ipv4 autonomous-system 6473
Device(config-router-af)# topology base
Device(config-router-af-topology)# exit-af-topology
Device(config-router-af)# exit-address-family
Device(config)# route-map virtual-name1-to-virtual-name2
Device(config-route-map)# match tag 42
Device(config-route-map)# set metric 5
Device(config-route-map)# set tag 1

関連コマンド

コマンド

説明

ip policy route-map

インターフェイスでポリシー ルーティングに使用するルート マップを特定します。

ipv6 policy route-map

インターフェイスで IPv6 PBR を設定します。

match as-path

BGP 自律システム パス アクセス リストを照合します。

match community

BGP コミュニティを照合します。

match interface(IP)

指定したいずれかのインターフェイスにネクスト ホップを持つ、すべてのルートを配布します。

match ip address

標準または拡張アクセス リストが許可した宛先ネットワーク番号アドレスが含まれるルートを配布し、パケットでポリシー ルーティングを実行します。

match ipv6 address

プレフィックス リストで許可されたプレフィックスがある IPv6 ルートを配布するか、IPv6 の PBR でパケットを照合するために使用する IPv6 アクセス リストを指定します。

match ip next-hop

指定されたアクセス リストのいずれかによって渡されたネクストホップ ルータ アドレスを含むすべてのルートを再配布します。

match ip route-source

アクセス リストによって指定されたアドレスで、ルータおよびアクセス サーバによってアドバタイズされたルートを再配布します。

match length

パケットのレベル 3 長に基づいてポリシー ルーティングを実行します。

match metric(IP)

指定したメトリックを持つルートを再配布します。

match route-type(IP)

指定されたタイプのルートを再配布します。

match tag

指定されたタグと一致するルーティング テーブルのルートを再配布します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

set as-path

BGP ルートの自律システム パスを変更します。

set automatic-tag

自動的にタグ値を計算します。

set community

BGP コミュニティ属性を設定します。

set default interface

ポリシー ルーティングにおいてルート マップの match 句を満たし、宛先への明示ルートがないパケットの出力先を示します。

set interface

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set ipv6 default next-hop

一致パケットが転送されるデフォルトの IPv6 ネクスト ホップを指定します。

set ip default next-hop verify-availability

ポリシー ルーティングにおいてルート マップの match 句を満たしたパケットの宛先への明示ルートを Cisco IOS ソフトウェアが持たない場合の出力先を示します。

set ip next-hop

ポリシー ルーティング用のルート マップの match 節を通過したパケットの送出先を示します。

set ipv6 next-hop(PBR)

IPv6 の PBR のルート マップの match 句を通過した IPv6 パケットの送出先を示します。

set level(IP)

ルートのインポート先を示します。

set local preference

自律システム パスのプリファレンス値を指定します。

set metric(BGP、OSPF、RIP)

ルーティング プロトコルのメトリック値を設定します。

set metric type

宛先ルーティング プロトコルのメトリック タイプを設定します。

set next-hop

ネクスト ホップのアドレスを指定します。

set tag(IP)

宛先ルーティング プロトコルのタグ値を設定します。

set weight

ルーティング プロトコルの BGP 重みを指定します。

show route-map

設定されたすべてのルート マップ、または指定した 1 つのルート マップだけを表示します。