A から M
A から M
発行日;2013/07/17   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

A から M

auto discovery qos

AutoQoS for the Enterprise 機能を設定するためのデータの検出と収集を開始するには、インターフェイス コンフィギュレーション モードで autodiscoveryqos コマンドを使用します。 データの検出と収集を停止するには、このコマンドの no 形式を使用します。

auto discovery qos [trust]

no auto discovery qos

構文の説明

trust

(任意)パケットの Diffserv コード ポイント(DSCP)マーキングが、音声、ビデオ、データ トラフィックの分類で trust である(信頼できる)ことを示します。

オプションの trust キーワードが指定されていない場合、音声、ビデオ、データ トラフィックは Network-Based Application Recognition(NBAR)を使用して分類され、パケットは、適切な DSCP 値でマーキングされます。

コマンド デフォルト

データ収集は実行されません。

コマンド モード


インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更内容

12.3(7)T

このコマンドが導入されました。

12.3(11)T

trust モードは、プロトコル タイプではなく、DSCP 値でパケットを分類するように変更されました。

使用上のガイドライン

autodiscoveryqos コマンドは、AutoQoS for the Enterprise 機能の自動検出(データ収集)フェーズを開始します。 このコマンドは、データを収集し、インターフェイスの出力方向でトラフィックを分析するように NBAR プロトコル ディスカバリを呼び出します。

noautodiscoveryqos コマンドは、自動検出フェーズを終了し、生成されたすべてのデータ収集レポートを削除します。

trust キーワードは、指定された DSCP のマーキングに基づいた信頼モデルで使用されます。 詳細については、Cisco IOS Release 12.3(7)T の『AutoQoS for the Enterprise』フィーチャ モジュールの「Trusted Boundary」の項を参照してください。

次は serial2/1/1 サブインターフェイスでイネーブルな AutoQoS for the Enterprise 機能の自動検出(データ収集)フェーズを示す設定例を示します。

Router> enable
Router# configure terminal
Router(config)# interface serial2/1.1
Router(config-if)# frame-relay interface-dlci 58
Router(config-if)# auto discovery qos
Router(config-if)# end

関連コマンド

コマンド

説明

auto qos

AutoQoS for the Enterprise 機能によって作成される QoS クラス マップとポリシー マップをインストールします。

service policy

入力インターフェイスまたは VC、あるいは出力インターフェイスまたは VC に、そのインターフェイスまたは VC のサービス ポリシーとして使用するポリシー マップを対応付けます。

show auto qos

特定のインターフェイスまたはすべてのインターフェイス上で AutoQoS により作成されたインターフェイス設定、ポリシー マップ、クラス マップを表示します。

auto qos

AutoQoS for the Enterprise 機能によって作成された Quality-Of-Service(QoS)のクラス マップとポリシー マップをインストールするには、インターフェイス コンフィギュレーション モードで autoqos コマンドを使用します。 QoS ポリシーを削除するには、このコマンドの no 形式を使用します。

auto qos

no auto qos

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

QoS ポリシーがインストールされていません。

コマンド モード


インターフェイス コンフィギュレーション(config-if)

コマンド履歴

リリース

変更内容

12.3(7)T

このコマンドが導入されました。

使用上のガイドライン

クラス マップとポリシー マップは、AutoQoS for the Enterprise 機能によって自動的に生成されたテンプレートから作成されます。 これらのテンプレート(およびそのクラス マップとポリシー マップ)は、AutoQoS for the Enterprise 機能の自動検出フェーズで収集されたデータに基づいて生成されます。 自動検出フェーズの詳細については、Cisco IOS Release 12.3(7)T の『AutoQoS for the Enterprise』フィーチャ モジュールの「Configuration Phases」の項を参照してください。

noautoqos コマンドにより、インターフェイスにインストールされた AutoQoS が生成したクラス マップとポリシー マップがすべて削除されます。

autoqos コマンドはギガビット インターフェイスでサポートされません。

次は serial2/1/1 サブインターフェイスでイネーブルな AutoQoS for the Enterprise 機能を示す設定例を示します。 この設定では、AutoQoS のクラス マップとポリシー マップは serial2/1 インターフェイスにインストールされます。

Router> enable
Router# configure terminal
Router(config)# interface serial2/1
Router(config-if)# frame-relay interface-dlci 58
Router(config-if)# auto qos
Router(config-if)# end

関連コマンド

コマンド

説明

service policy

入力インターフェイスまたは VC、あるいは出力インターフェイスまたは VC に、そのインターフェイスまたは VC のサービス ポリシーとして使用するポリシー マップを対応付けます。

show auto qos

特定のインターフェイスまたはすべてのインターフェイス上で AutoQoS により作成されたインターフェイス設定、ポリシー マップ、クラス マップを表示します。

auto qos voip

AutoQoS--VoIP 機能をインターフェイス上に設定するには、インターフェイス コンフィギュレーション モードまたはフレーム リレー DLCI コンフィギュレーション モードで、autoqosvoip コマンドを使用します。 インターフェイスから AutoQoS--VoIP 機能を削除するには、このコマンドの no 形式を使用します。

auto qos voip [trust] [fr-atm]

no auto qos voip [trust] [fr-atm]

構文の説明

trust

(任意)パケットの Diffserv コード ポイント(DSCP)マーキングが、音声トラフィックの分類で信頼できることを示します。 オプションの trust キーワードが指定されていない場合、音声トラフィックは Network-Based Application Recognition(NBAR)を使用して分類され、パケットは、適切な DSCP 値でマーキングされます。

fr-atm

(任意)フレームリレー/ATM リンクで AutoQoS--Voip 機能をイネーブルにします。 このオプションは、フレームリレー/ATM インターワーキング用のフレーム リレー データ リンク接続識別子(DLCI)のみで使用できます。

コマンド デフォルト

デフォルト モードはディセーブルです。

コマンド モード


インターフェイス コンフィギュレーション(config-if)フレーム リレー DLCI コンフィギュレーション(フレーム リレー DLCI での使用)(config-fr-dlci)

コマンド履歴

リリース

変更内容

12.2(15)T

このコマンドが導入されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

フレームリレー/ATM インターワーキングで AutoQoS--VoIP 機能をイネーブルにするには、fr-atm キーワードを明示的に設定する必要があります。 ただし、fr-atm キーワードは低速 DLCI だけに影響します。 これは、高速 DLCI には影響しません。


(注)  


リンク速度が 768 kbps 以下の DLCI は、低速 DLCI と見なされ、リンク速度が 768 kbps よりも速い DLCI は高速 DLCI と見なされます。


trust キーワードがこのコマンドに設定されているかどうかに応じて、AutoQoS--VoIP 機能は次の 2 つのポリシー マップのいずれか 1 つを自動的に作成します。

  • 「AutoQoS-Policy-Trust」(trust キーワードが設定されている場合に作成)
  • 「AutoQoS-Policy-UnTrust」(trust キーワードが設定されていない場合に作成)

この 2 つのポリシー マップは、両方ともインターフェイスまたは相手先固定接続(PVC)での Voice over IP(VoIP)トラフィックを処理できるように設計されており、ネットワークの Quality of Service(QoS)の要件に合わせて変更できます。 これらのポリシー マップを変更するには、適切な Cisco IOS コマンドを使用します。

service-policy コマンドを使用して、これらのポリシー マップをインターフェイスまたは PVC に付加しないようにしてください。 ポリシー マップがこのように付加されている場合、AutoQoS--VoIP 機能(つまり、ポリシー マップ、クラス マップ、およびアクセス コントロール リスト (ACL))は noautoqosvoip コマンドが設定された場合に適切に削除されません。

同じネットワークの ATM PVC と相互接続している低速フレームリレー DLCI では、fr-atm キーワードを autoqosvoip コマンドで明示的に設定して、AutoQoS--VoIP 機能を適切に設定する必要があります。 つまり、コマンドは autoqosvoipfr-atm として設定する必要があります。

フレームリレー/ATM で設定された低速フレーム リレー DLCI では、Multilink PPP(MLP)over Frame Relay(MLPoFR)が自動的に設定されます。 サブインターフェイスには IP アドレスが必要です。 MLPoFR の設定時、この IP アドレスは削除され、MLP バンドルに置かれます。 AutoQoS--VoIP 機能も、ATM 側で autoqosvoip コマンドを使用して設定する必要があります。

autoqosvoip コマンドは、サブインターフェイスまたはギガビット インターフェイスでサポートされません。

autoqosvoip コマンドは、フレーム リレー DLCI で利用可能です。

AutoQoS--VoIP のディセーブル化

noautoqosvoip コマンドは、AutoQoS--VoIP 機能をディセーブルにし、この機能に関連付けられている設定を削除します。

noautoqosvoip コマンドを使用すると、AutoQoS--VoIP 機能によって最初に生成された個々のコマンドの no 形式が設定されます。 コマンドの個々の no 形式の使用で、システムのデフォルトが復元されます。 コマンドの no 形式は、ユーザがコマンドを個別に入力したかのように適用されます。 デフォルトに戻す設定が適用されると、コマンドの処理によって生じたメッセージが表示されます。


(注)  


noautoqosvoip コマンドを設定しないでサブインターフェイスまたは PVC(ATM やフレーム リレー PVC)を削除すると、AutoQoS--VoIP 機能は正しく削除されません。


次に、シリアル ポイントツーポイント サブインターフェイス 4/1.2 で設定された AutoQoS--VoIP 機能を示します。 この例では、trust キーワードと fr-atm キーワードの両方が設定されます。

Router> enable
Router# configure terminal
Router(config)# interface serial4/1.2 point-to-point
Router(config-if)# bandwidth 100
Router(config-if)# ip address 192.168.0.0 255.255.255.0
Router(config-if)# frame-relay interface-dlci 102
Router(config-fr-dlci)# auto qos voip trust fr-atm
Router(config-fr-dlci)# end
Router(config-if#
 
exit

関連コマンド

コマンド

説明

service-policy

入力インターフェイスまたは VC、あるいは出力インターフェイスまたは VC に、そのインターフェイスまたは VC のサービス ポリシーとして使用するポリシー マップを対応付けます。

show auto qos

特定のインターフェイスまたはすべてのインターフェイスの AutoQoS--VoIP 機能で作成された設定が表示されます。

bandwidth(ポリシーマップ クラス)

ポリシー マップに属するクラスに割り当てられる帯域幅を指定または変更する、あるいは ATM オーバーヘッド アカウンティングをイネーブルにするには、QoS ポリシー マップ クラス コンフィギュレーション モードで bandwidth コマンドを使用します。 クラスに指定されている帯域幅を削除するには、または ATM オーバーヘッド アカウンティングをディセーブルにするには、このコマンドの no 形式を使用します。

bandwidth { kbps | [ remaining ] percent percentage } [ account { qinq | dot1q } aal5 subscriber-encapsulation ]

no bandwidth

Cisco 10000 Series Router (PRE3)

bandwidth { kbps | [ remaining ] percent percentage } account { qinq | dot1q } { aal5 | aal3 } subscriber-encapsulation user-defined offset [atm]

no bandwidth

構文の説明

kbps

クラスに割り当てる帯域幅の量(kbps)。 帯域幅の量は、使用中のインターフェイスとプラットフォームに応じて変わります。 値は 1~2,000,000 kbps であることが必要です。

remaining

(任意)保証帯域幅の割合は、使用可能な帯域幅の相対割合に基づいていること を指定します。

percent percentage

プライオリティ クラスの場合に除外される使用可能な帯域幅の絶対割合、または使用可能な帯域幅の相対割合に基づく保証帯域幅の割合を指定します。 有効な範囲は、1~100 です。

account

(任意)ATM オーバーヘッド アカウンティングをイネーブルにします。

qinq

(任意)ATM オーバーヘッド アカウンティングのデジタル加入者線アクセス マルチプレクサ(DSLAM)カプセル化タイプにブロードバンド集約システム(BRAS)として queue-in-queue カプセル化を指定します。

dot1q

(任意)ATM オーバーヘッド アカウンティングの BRAS-DSLAM カプセル化タイプとして IEEE 802.1Q VLAN カプセル化を指定します。

aal5

(任意)ATM オーバーヘッド アカウンティングの加入者線に ATM アダプテーション層 5 およびカプセル化タイプを指定します。 AAL5 はコネクション型可変ビット レート(VBR)サービスをサポートします。 有効なカプセル化タイプについては、「使用上のガイドライン」の項を参照してください。

subscriber-encapsulation

加入者線カプセル化タイプ。 有効なカプセル化タイプについては、「使用上のガイドライン」の項を参照してください。

aal3

コネクションレス型リンクとコネクション型リンクの両方をサポートする ATM アダプテーション層 5 を指定します。 aal3 または aal5 のいずれかを指定する必要があります。

user-defined offset

ATM オーバーヘッドを計算するときにルータが使用するオフセット サイズを指定します。

有効値は– 127 バイト~127 バイトで、0 は有効な値ではありません。
(注)     

user-defined offset オプションを指定しなかった場合、ルータがオフセット サイズを設定します。

atm

ATM オーバーヘッドの計算に ATM セル タックスを適用します。

(注)     

offset オプションと atm オプションの両方を設定すると、オフセット サイズに対するパケット サイズの調整が行われてから、ATM セル タックスが追加されます。

コマンド デフォルト

帯域幅は指定されていません。

ATM オーバーヘッド アカウンティングはディセーブルです。

コマンド モード

QoS ポリシーマップ クラス コンフィギュレーション(config-pmap-c)

コマンド履歴

リリース

変更内容

12.0(5)T

このコマンドが導入されました。

12.0(5)XE

このコマンドが Cisco IOS Release 12.0(5)XE に統合され、Versatile Interface Processor(VIP)対応型 Cisco 7500 シリーズ ルータに実装されました。

12.0(7)T

このコマンドが変更されました。 percent キーワードが追加されました。

12.0(17)SL

このコマンドは、Cisco IOS Release 12.0(17)SL に統合され、Cisco 10000 シリーズ ルータに実装されました。

12.0(22)S

このコマンドが変更されました。 percent キーワードのサポートが Cisco 10000 シリーズ ルータに追加されました。

12.0(23)SX

このコマンドが変更されました。 remaining percent キーワードのサポートが Cisco 10000 シリーズ ルータに追加されました。

12.1(5)T

このコマンドが Cisco IOS Release 12.1(5)T に統合され、VIP 対応型 Cisco 7500 シリーズ ルータに実装されました。

12.2(2)T

このコマンドが変更されました。 remaining percent キーワードが追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(31)SB

このコマンドは、Cisco IOS Release 12.2(31)SB に統合され、Cisco 10000 シリーズ ルータに実装されました。

12.2(31)SB2

このコマンドが Cisco IOS Release 12.0(17) SL に統合され、Cisco 10000 シリーズ ルータの PRE3 に実装され、さらに PRE3 の Cisco 10000 シリーズ ルータでの ATM オーバーヘッドに対応して機能強化されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

12.2(31)SB6

このコマンドが ATM オーバーヘッドを計算する際のオフセット サイズを指定するように変更され、PRE3 向け Cisco 10000 シリーズ ルータに実装されました。

12.2(33)SRC

このコマンドは、Cisco IOS Release 12.2(33)SRC に統合され、Cisco 7600 シリーズ ルータに実装されました。

12.2(33)SB

このコマンドは、Cisco IOS Release 12.2(33)SB に統合され、Cisco 7300 シリーズ ルータに実装されました。

12.4(20)T

このコマンドが変更されました。 モジュラ Quality of Service(QoS)CLI(MQC)を使用した階層型キューイング フレームワーク(HQF)のサポートが追加されました。

15.1(1)T

このコマンドが変更されました。 kbps 引数の許容値が変更されました。 値は 8~2000000 である必要があります。

15.2(1)T

このコマンドが変更されました。 offset 引数および kbps 引数の許容値が変更されました。

使用上のガイドライン

ポリシー マップの設定

class-map コマンドで定義されたクラスのポリシー マップを設定する際に、bandwidth コマンドを使用します。 bandwidth コマンドは、そのクラス内のトラフィックの帯域幅を指定します。 クラス ベース均等化キューイング(CBWFQ)は、クラスに属するパケットのウェイトを、クラスに割り当てられた帯域幅から導出します。 次に、CBWFQ はこのウェイトを使用して、このクラスのキューを適正に処理します。

帯域幅を持つ完全プライオリティの設定

完全プライオリティで設定できるクラスは 1 つだけです。 その他のクラスは、プライオリティの設定も帯域幅の設定も持てません。 他のクラスの最小帯域幅を設定するには、bandwidthremainingpercent コマンドを使用します。

Cisco 10000 シリーズ ルータ以外のすべてのサポート対象プラットフォームのパーセント比率として帯域幅を指定します。

kbps 単位で帯域幅の量を指定する以外に、使用可能な帯域幅または総帯域幅に対するパーセント比率で帯域幅を指定することもできます。 輻輳の発生中には、そのクラスは、設定されている帯域幅比率に比例した帯域幅で処理されます。 帯域幅の割合は、インターフェイスの帯域幅に基づきます。 使用可能な帯域幅とは、インターフェイスの帯域幅からリソース予約プロトコル(RSVP)機能、IP RTP プライオリティ機能、低遅延キューイング(LLQ)機能に予約されているすべての帯域幅の合計を差し引いた帯域幅です。


(注)  


bandwidth remaining percent コマンドが設定されていると、確実な保証帯域幅が提供されない場合があり、相対的な帯域幅しか確保されないことを念頭に置いておいてください。 つまり、クラスの帯域幅は、常にインターフェイスの帯域幅に対する指定されたパーセント比率に比例します。 リンク帯域幅が固定されている場合、クラス帯域幅の保証は、設定されているパーセンテージに比例します。 リンク帯域幅がわからないか変動する場合、ルータは、kbps でのクラス保証帯域幅を計算することができません。


Cisco 10000 シリーズ ルータのパーセント比率として帯域幅を指定できます。

kbps 単位で帯域幅の量を指定する以外に、使用可能な帯域幅または総帯域幅に対するパーセント比率で帯域幅を指定することもできます。 輻輳の発生中には、そのクラスは、設定されている帯域幅比率に比例した帯域幅で処理されます。 最小帯域幅のパーセント比率は、最も近い親シェーピング レートに基づいています。


(注)  


bandwidth remaining percent コマンドが設定されていると、確実な保証帯域幅が提供されない場合があり、相対的な帯域幅しか確保されないことを念頭に置いておいてください。 つまり、クラスの帯域幅は、常にインターフェイスの帯域幅に対する指定されたパーセント比率に比例します。 リンク帯域幅が固定されている場合、クラス帯域幅の保証は、設定されているパーセンテージに比例します。 リンク帯域幅がわからないか変動する場合、ルータは、kbps でのクラス保証帯域幅を計算することができません。


ルータは、指定された帯域幅をインターフェイス速度の 1/255(ESR-PRE1)または 1/65535(ESR-PRE2)の最も近い倍数に変換します。 実際の帯域幅を表示するには、show policy-map interface コマンドを使用します。

サポートされているすべてのプラットフォームに関する制限事項

bandwidth コマンドには、次の制限事項があります。

  • 設定する帯域幅の量は、レイヤ 2 オーバーヘッドも十分処理できる量にする必要があります。
  • ポリシー マップは kbps またはパーセント比率のいずれか一方で、同一クラス内にすべてのクラス帯域幅を指定できます。 ただし、プライオリティ クラスでの priority コマンドの単位は、非プライオリティ クラスの帯域幅単位とは異なっていてもかまいません。
  • そのインターフェイスのサービス ポリシーを定めるために、クラス ポリシー設定を含むポリシー マップがインターフェイスに付加されている場合は、bandwidth percent コマンドを設定すると、利用可能な帯域幅が評価されます。 インターフェイスの帯域幅が不十分なことが原因で、特定のインターフェイスにポリシー マップがアタッチできない場合、そのポリシーは、正常にアタッチされていたすべてのインターフェイスから削除されます。 この制限事項は、bandwidth remaining percent コマンドには適用されません。

(注)  


CSCsy73939 で bandwidth percent コマンドから有効な範囲よりも低い帯域幅が得られた場合、この値を指定するポリシー マップをインターフェイスに付加することはできません。ルータから「service-policy output parent Configured Percent results in out of range kbps. Allowed range is min-valuemax-value. The present CIR value is n.」というエラー メッセージが表示されます。


帯域割り当ての詳細については、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Congestion Management Overview」モジュールを参照してください。

クラス ポリシー コンフィギュレーションが含まれているポリシー マップがインターフェイスに付加されて、そのインターフェイスのサービス ポリシーが決定される場合、使用可能な帯域幅が評価されることに注意してください。 インターフェイスの帯域幅が不十分なことが原因で、特定のインターフェイスにポリシー マップを付加できない場合、そのポリシーは、正常に付加されていたすべてのインターフェイスから削除されます。

モジュラ QoS CLI キュー制限

bandwidth コマンドは、特定のクラスに対する帯域幅を指定するため、MQC で使用できます。 MQC で使用される場合、bandwidth コマンドは、クラスに設定されているデフォルトのキュー制限を使用します。 このキュー制限は、queue-limit コマンドを使用して変更でき、bandwidth コマンドによって設定されたデフォルトが上書きされます。


(注)  


インターフェイスで必要な最小帯域幅保証を満たすためには、queue-limit コマンドを使用して高速インターフェイスのデフォルトのキュー制限を変更します。


Cisco 10000 シリーズ ルータ

Cisco 10000 シリーズ ルータは、発信インターフェイスのみで bandwidth コマンドをサポートします。 これらは、着信インターフェイスではこのコマンドをサポートしません。

PRE2 で、帯域幅値と帯域幅値の単位を指定します。 帯域幅の有効な値は 1~2488320000 です。 単位は bps、kbps、mbps、gbps です。 デフォルトの単位は kbps です。 たとえば、次のコマンドは、PRE2 に 10000 bps と 10000 kbps の帯域幅を設定します。

bandwidth 10000 bps
bandwidth 10000

PRE3 で指定できるのは帯域幅のみです。 単位は常に kbps であるため、PRE3 は unit 引数をサポートしません。 有効な値の範囲は 1~2000000 です。 たとえば、次のコマンドは、PRE3 に 128,000 kbps の帯域幅を設定します。

bandwidth 128000

PRE3 は、PRE2 bandwidth コマンドが unit 引数なしで使用される場合に限り、このコマンドを受け入れます。 指定された帯域幅が PRE3 の有効な帯域幅値の範囲(1~2000000)外にある場合、PRE3 は PRE2 bandwidth コマンドを拒否します。

kbps 単位で帯域幅の量を指定する以外に、使用可能な帯域幅または総帯域幅に対するパーセント比率で帯域幅を指定することもできます。 輻輳の発生中には、そのクラスは、設定されている帯域幅比率に比例した帯域幅で処理されます。 帯域幅の割合は、インターフェイスの帯域幅に基づきます。 ただし、階層型ポリシーでは、帯域幅の最小割合は、最も近い親シェーピング レートに基づいています。


(注)  


bandwidth remaining percent コマンドが設定されている場合、絶対帯域幅が保証されないことがあり、相対的な帯域幅のみが保証されます。 クラスの帯域幅は、常にインターフェイスの帯域幅に対する指定されたパーセント比率に比例します。 リンク帯域幅が固定されている場合、クラス帯域幅の保証は、設定されているパーセンテージに比例します。 リンク帯域幅がわからないか変動する場合、ルータは、kbps でのクラス保証帯域幅を計算することができません。


ルータは、指定された帯域幅をインターフェイス速度の 1/255(PRE1)または 1/65535(PRE2、PRE3)の最も近い倍数に変換します。 実際の帯域幅を表示するには、show policy-map interface コマンドを使用します。

ATM のオーバーヘッド アカウンティング(Cisco 10000 シリーズ ルータ)

ATM オーバーヘッド アカウンティングを設定する場合、BRAS-DSLAM、DSLAM-CPE、加入者線カプセル化タイプを指定する必要があります。 ルータは、次の加入者線カプセル化タイプをサポートします。

  • mux-1483routed
  • mux-dot1q-rbe
  • snap-pppoa
  • mux-rbe
  • snap-1483routed
  • snap-dot1q-rbe
  • mux-pppoa
  • snap-rbe

ルータは user-defined offset オプションを指定しなかった場合のオフセット サイズを計算します。

階層型ポリシーでは、次の方法で ATM オーバーヘッド アカウンティングを設定します。

  • 親でイネーブル:親ポリシーで ATM オーバーヘッド アカウンティングをイネーブルにすると子ポリシーでアカウンティングをイネーブルにする必要がありません。
  • 子と親でイネーブル:子ポリシーで ATM オーバーヘッド アカウンティングをイネーブルにした場合は、親ポリシーでも ATM オーバーヘッド アカウンティングをイネーブルにする必要があります。

カプセル化タイプは子ポリシーと親ポリシーに一致する必要があります。

user-defined offset 値は子ポリシーと親ポリシーに一致する必要があります。

次の例では、VLAN という名前のポリシー マップは Customer1 という名前のクラスに帯域幅の 30% を保証し、Customer2 という名前のクラスに帯域幅の 60% を保証します。 VLAN ポリシー マップを 1-Mbps リンクに適用すると、300 kbps(1 Mbps の 30%)が Customer1 に保証され、600 kbps(1 Mbps の 60%)が Customer2 に保証されます。100 kbps は class-default クラス用に残ります。 class-default クラスが、追加の帯域幅を必要としない場合、未使用の 100 kbps は Customer1 クラスおよび Customer2 クラスで使用できます。 両方のクラスで帯域幅が必要な場合は、設定された速度に比例して共有します。 この例では、共有率は 30:60 または 1:2 です。

router(config)# policy-map VLAN
router(config-pmap)# class Customer1
router(config-pmap-c)# bandwidth percent 30
router(config-pmap-c)# exit
router(config-pmap)# class Customer2
router(config-pmap-c)# bandwidth percent 60

次に、2 つのクラスを持つポリシー マップを作成する方法、CBWFQ のみが設定されている場合に帯域幅を保証する方法、ポリシーをシリアル インターフェイス 3/2/1 に付加する方法を示します。

Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth percent 50
Router(config-pmap-c)# exit
Router(config-pmap)# class class2
Router(config-pmap-c)# bandwidth percent 25
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# interface serial3/2/1
Router(config-if)# service output policy1
Router(config-if)# end

show policy-map コマンドからの次の出力は、policy1 という名前のポリシー マップの設定を示します。

Router# show policy-map policy1
 
Policy Map policy1
 Class class1
  Weighted Fair Queuing
   Bandwidth 50 (%) Max Threshold 64 (packets)
 Class class2
  Weighted Fair Queuing
   Bandwidth 25 (%) Max Threshold 64 (packets)

show policy-map interface コマンドからの出力は、インターフェイス帯域幅の 50% が class1 という名前のクラスに対して保証され、25% が class2 という名前のクラスに対して保証されることを示しています。 この出力では、割合と kbps の数の両方で帯域幅の量を表示しています。

Router# show policy-map interface serial3/2
 
Serial3/2
Service-policy output:policy1
Class-map:class1 (match-all)
 0 packets, 0 bytes
 5 minute offered rate 0 bps, drop rate 0 bps
 Match:none
 Weighted Fair Queuing
  Output Queue:Conversation 265
  Bandwidth 50 (%)
  Bandwidth 772 (kbps) Max Threshold 64 (packets)
  (pkts matched/bytes matched) 0/0
  (depth/total drops/no-buffer drops) 0/0/0
Class-map:class2 (match-all)
 0 packets, 0 bytes
 5 minute offered rate 0 bps, drop rate 0 bps
 Match:none
 Weighted Fair Queuing
  Output Queue:Conversation 266
  Bandwidth 25 (%)
  Bandwidth 386 (kbps) Max Threshold 64 (packets)
  (pkts matched/bytes matched) 0/0
  (depth/total drops/no-buffer drops) 0/0/0
Class-map:class-default (match-any)
 0 packets, 0 bytes
 5 minute offered rate 0 bps, drop rate 0 bps
 Match:any

この例では、シリアル インターフェイス 3/2 に合計 1544 kbps の帯域幅があります。 輻輳時に、帯域幅の 50%(772 kbps)が class1 という名前のクラスに保証され、リンク帯域幅の 25%(386 kbps)が class2 という名前のクラスに保証されます。

次の例では、インターフェイスに合計 1544 kbps の帯域幅があります。 輻輳時に、帯域幅の 50%(772 kbps)が class1 という名前のクラスに保証され、リンク帯域幅の 25%(386 kbps)が class2 という名前のクラスに保証されます。

show policy-map コマンドからの次の出力は、p1 という名前のポリシー マップの設定を示します。

Router# show policy-map p1
Policy Map p1
 Class voice
  Weighted Fair Queuing
   Strict Priority
   Bandwidth 500 (kbps) Burst 12500 (Bytes)
 Class class1
  Weighted Fair Queuing
   Bandwidth remaining 50 (%) Max Threshold 64 (packets)
 Class class2
  Weighted Fair Queuing
   Bandwidth remaining 25 (%) Max Threshold 64 (packets)

シリアル インターフェイス 3/2 での show policy-map interface コマンドからの次の出力は、500 kbps の帯域幅が voice1 という名前のクラスに対して保証されることを示します。 class1 と class2 という名前のクラスが、残りの帯域幅の 50% と 25% をそれぞれ受け取ります。 割り当てられていない帯域幅は、class1、class2、ベスト エフォート型のトラフィック クラス間に均等に分割されます。


(注)  


この出力例は(この項で先に記述されているの他の多くのものとは異なり)、帯域幅は、クラス 1 とクラス 2 の割合としてのみ表示されます。 kbps の数で表現される帯域幅は、percent キーワードが bandwidth remaining コマンドで使用されるため、表示されません。 bandwidth remaining percent コマンドは、インターフェイスで使用可能な合計帯域幅の相対割合として帯域幅を割り当てることができます。


Router# show policy-map interface serial3/2
 
Serial3/2
Service-policy output:p1
 Class-map:voice (match-all)
  0 packets, 0 bytes
  5 minute offered rate 0 bps, drop rate 0 bps
  Match:ip precedence 5
  Weighted Fair Queuing
   Strict Priority
   Output Queue:Conversation 264
   Bandwidth 500 (kbps) Burst 12500 (Bytes)
   (pkts matched/bytes matched) 0/0
   (total drops/bytes drops) 0/0
 Class-map:class1 (match-all)
  0 packets, 0 bytes
  5 minute offered rate 0 bps, drop rate 0 bps
  Match:none
  Weighted Fair Queuing
   Output Queue:Conversation 265
   Bandwidth remaining 50 (%) Max Threshold 64 (packets)
   (pkts matched/bytes matched) 0/0
   (depth/total drops/no-buffer drops) 0/0/0
 Class-map:class2 (match-all)
  0 packets, 0 bytes
  5 minute offered rate 0 bps, drop rate 0 bps
  Match:none
  Weighted Fair Queuing
   Output Queue:Conversation 266
   Bandwidth remaining 25 (%) Max Threshold 64 (packets)
   (pkts matched/bytes matched) 0/0
   (depth/total drops/no-buffer drops) 0/0/0
 Class-map:class-default (match-any)
  0 packets, 0 bytes
  5 minute offered rate 0 bps, drop rate 0 bps
  Match:any	

親ポリシーで ATM オーバーヘッド アカウンティングがイネーブルにされている場合は、bandwidth コマンドまたは shape コマンドを含まない子トラフィック クラス上で ATM オーバーヘッド アカウンティングをイネーブルにする必要がありません。 次に、subscriber_classes という名前の子ポリシー マップの gaming クラスと class-default クラス、および、subscriber_line という名前の親ポリシー マップの class-default クラスで ATM オーバーヘッド アカウンティングが帯域幅に対してイネーブルである設定例を示します。 voip および video クラスでは、ATM オーバーヘッド アカウンティングが明示的にイネーブルにされていません。ATM オーバーヘッド アカウンティングが親ポリシーでイネーブルになっているため、これらのプライオリティ キューではオーバーヘッド アカウンティングが暗黙的にイネーブルになっています。 親ポリシーと子ポリシーの機能で同じカプセル化タイプが使用されていることに注意してください。

Router(config)# policy-map subscriber_classes
Router(config-pmap)# class voip
Router(config-pmap-c)# priority level 1
Router(config-pmap-c)# police 8000
Router(config-pmap-c)# exit
Router(config-pmap)# class video
Router(config-pmap-c)# priority level 2
Router(config-pmap-c)# police 20
Router(config-pmap-c)# exit
Router(config-pmap)# class gaming
Router(config-pmap-c)# bandwidth remaining percent 80 account aal5 snap-rbe-dot1q
Router(config-pmap-c)# exit
Router(config-pmap)# class class-default
Router(config-pmap-c)# bandwidth remaining percent 20 account aal5 snap-rbe-dot1q
Router(config-pmap-c)# policy-map subscriber_line
Router(config-pmap-c)# exit
Router(config-pmap)# class class-default
Router(config-pmap-c)# bandwidth remaining ratio 10 account aal5 snap-rbe-dot1q
Router(config-pmap-c)# shape average 512 account aal5 snap-rbe-dot1q
Router(config-pmap-c)# service policy subscriber_classes

次の例では、ルータは ATM オーバーヘッドの計算に 20 のオーバーヘッド バイトと ATM セル タックスを使用します。 子ポリシーと親ポリシーには必須の一致のオフセット値が含まれます。 親ポリシーは、仮想テンプレート 1 に付加されます。

Router(config)# policy-map child
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 500 account user-defined 20 atm
Router(config-pmap-c)# exit
Router(config-pmap)# class class2 
Router(config-pmap-c)# shape average 30000 account user-defined 20 atm
Router(config-pmap)# exit
Router(config)# exit
Router(config)#

関連コマンド

コマンド

説明

class(ポリシーマップ)

クラスのポリシーを設定する前に、ポリシーを作成または変更するクラスの名前、およびデフォルト クラス(一般に class-default クラスとして知られるクラス)を指定します。

class-map

指定したクラスへのパケットのマッチングに使用するクラス マップを作成します。

max-reserved-bandwidth

CBWFQ、LLQ、および IP RTP プライオリティに割り当てるインターフェイス帯域幅のパーセント比率を変更します。

policy-map

1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または修正し、サービス ポリシーを指定します。

priority

ポリシー マップに属するトラフィックのクラスのプライオリティを指定します。

queue-limit

キューが保持できる、ポリシー マップ内に設定されるクラス ポリシーのパケットの最大数を指定または変更します。

random-detect(インターフェイス)

WRED または DWRED をイネーブルにします。

random-detect exponential-weighting- constant

キューの平均サイズ計算のための WRED および DWRED 指数加重係数を設定します。

random-detect precedence

特定の IP precedence に対する WRED パラメータと DWRED パラメータを設定します。

show policy-map

指定されたサービス ポリシー マップに対するすべてのクラスの設定、または、すべての既存ポリシー マップに対するすべてのクラスの設定を表示します。

show policy-map interface

指定したインターフェイスまたはサブインターフェイス上か、インターフェイス上の特定の PVC に対し、すべてのサービス ポリシーに対して設定されているすべてのクラスのパケット統計情報を表示します。

bandwidth remaining ratio

非プライオリティ キューに割り当てる超過帯域幅の量(プライオリティ トラフィックで未使用)を指示するため、輻輳中に使用するクラス レベル キューまたはサブインターフェイス レベル キューの帯域幅余剰比率を指定するには、ポリシー マップ クラス コンフィギュレーション モードで bandwidthremainingratio コマンドを使用します。 帯域幅余剰比率を削除するには、このコマンドの no 形式を使用します。

bandwidth remaining ratio ratio

no bandwidth remaining ratio ratio

bandwidth remaining ratio ratio [ account { qinq | dot1q } [aal5] { subscriber-encapsulation | user-defined offset } ]

no bandwidth remaining ratio ratio [ account { qinq | dot1q } [aal5] { subscriber-encapsulation | user-defined offset } ]

bandwidth remaining ratio ratio

no bandwidth remaining ratio ratio

構文の説明

ratio

他のサブインターフェイスまたはクラス キューに関するこのサブインターフェイスまたはクラス キューの相対的重み。 有効な値の範囲は 1~1000 です。 サブインターフェイス レベルでは、デフォルト値はプラットフォームによって異なります。 クラス キュー レベルのデフォルトは 1 です。

Cisco 7300 シリーズ ルータ、Cisco 7600 シリーズ ルータおよび Cisco 10000 シリーズ ルータ

ratio

他のサブインターフェイスまたはクラス キューに関するこのサブインターフェイスまたはクラス キューの相対的重み。

(注)     

Cisco 7300 シリーズ ルータ、および 7600 シリーズ ルータでは、有効な値の範囲は 1~10000 で、デフォルト値は 1 です。

(注)     

Cisco 10000 シリーズ ルータでは、有効な値の範囲は 1~1000 で、デフォルトは 1 です。

account

(任意)ATM オーバーヘッド アカウンティングをイネーブルにします。

qinq

(任意)ブロードバンド リモート アクセス サーバ - デジタル加入者線アクセス マルチプレクサ(BRAS-DSLAM)カプセル化タイプとして queue-in-queue カプセル化を指定します。

dot1q

(任意)BRAS-DSLAM カプセル化タイプとして IEEE 802.1Q VLAN カプセル化を指定します。

aal5

(任意)コネクション型可変ビット(VBR)サービスをサポートする ATM アダプテーション層 5 を指定します。

subscriber-encapsulation

(任意)加入者線でのカプセル化タイプを指定します。 カプセル化タイプは加入者線によって異なります。

user-defined offset

(任意)ATM オーバーヘッドの計算時にルータが使用するオフセット サイズをバイト単位で指定します。

(注)     

Cisco 7300 シリーズ ルータ、および 7600 シリーズ ルータでは、有効な値の範囲は -48~+48 です。

(注)     

Cisco 10000 シリーズ ルータの有効値は -63~+63 です。

Cisco ASR 1000 シリーズ ルータ

ratio

他のサブインターフェイスまたはクラス キューに関するこのサブインターフェイスまたはクラス キューの相対的重み。 有効な値の範囲は 1~1000 です。 サブインターフェイス レベルおよびクラス キューのデフォルトは 1 です。

Cisco 10000 シリーズ ルータ

ほとんどのプラットフォームでは、デフォルトの帯域幅の比率は 1 です。

サブインターフェイス レベルでデフォルトの帯域幅残量割合を使用すると、Cisco 10000 シリーズ ルータは、インターフェイス タイプを区別します。 サブインターフェイス レベルでのデフォルトの帯域幅余剰比率は、VLAN サブインターフェイス、フレーム リレー データ リンク接続識別子(DLCI)では 1 です。 ATM サブインターフェイスの場合、ルータはサブインターフェイス速度に基づいてデフォルトの帯域幅余剰比率を計算します。

クラス レベルでデフォルトの帯域幅余剰比率を使用すると、Cisco 10000 シリーズ ルータは、インターフェイス タイプを区別しません。 クラス レベルのデフォルトの帯域幅余剰比率は 1 です。

コマンド モード


ポリシー マップ クラス(config-pmap-c)

コマンド履歴

リリース

変更内容

12.2(31)SB2

このコマンドが導入されました。 このコマンドは、PRE3 用の Cisco 10000 シリーズ ルータに実装されました。

12.2(33)SRC

このコマンドが変更されました。 Cisco 7600 シリーズ ルータに実装されました。 PRE3 用の Cisco 7600 シリーズ ルータおよび Cisco 10000 シリーズ ルータでの ATM オーバーヘッド アカウンティングをサポートするため(任意)、追加のキーワードと引数が追加されました。

12.2(33)SB

このコマンドが変更されました。 Cisco 7300 シリーズ ルータのサポートが追加されました。 ATM オーバーヘッド アカウンティングに関連する追加のキーワードと引数もサポートされています。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

使用上のガイドライン

Cisco 10000 シリーズ ルータ

スケジューラは、bandwidthremainingratio コマンドで指定される比率を使用して、輻輳時にクラス レベル キューまたはサブインターフェイス レベルのキューに割り当てる超過帯域幅の量(プライオリティ トラフィックで未使用)を指定することができます。 スケジューラは、他のキューまたはサブインターフェイスを基準にした未使用の帯域幅を割り当てます。

bandwidthremainingratio コマンドは、同じポリシー マップの別のトラフィック クラスで、別の bandwidth コマンドと共存することはできません。 たとえば、次の設定は無効で、エラー メッセージが表示されます。

policy-map Prec1
 class precedence_0
  bandwidth remaining ratio 10
 class precedence_2
  bandwidth 1000

PRE2 では、bandwidthremainingratio コマンドは、ポリシー マップ内の同一のクラスで、別の bandwidth コマンドと共存することができます。 PRE3 では、bandwidthremainingratio コマンドは同じクラス内の bandwidth コマンドと共存することはできません。 たとえば、次の設定は PRE3 では無効で、エラー メッセージが表示されます。

policy-map Prec1
 class precedence_0
  bandwidth 1000
  bandwidth remaining ratio 10

親ポリシーが class-default クラスのみを定義している階層ポリシー マップに、子のキューイング ポリシーが適用されていると、ルータは class-default クラスで bandwidth コマンドの bandwidthremainingratio 形式のみを受け入れます。

bandwidthremainingratio コマンドは、同じクラスで priority コマンドと共存することはできません。 たとえば、次の設定は無効で、エラー メッセージが表示されます。

policy-map Prec1
 class precedence_1
  priority
  police percent 30
  bandwidth remaining ratio 10

bandwidthremainingratio コマンドが指定されていないすべてのキューは、プラットフォームで指定された最小帯域幅余剰比率を受け取ります。 ルータは設定に基づいて最小認定情報レート(CIR)を決定します。

ATM オーバーヘッド アカウンティング(任意)

bandwidthremainingratio コマンドを使用して ATM オーバーヘッド アカウンティングをイネーブルにすることもできます。 ATM オーバーヘッド アカウンティングをイネーブルにするには、構文の説明表に記載されている account キーワードとそれに続くキーワードおよび引数を使用します。

Cisco 7200 シリーズ ルータ

bandwidthremainingratio コマンドは、Cisco 7200 シリーズ ルータではサポートされていません。 Cisco IOS Release 12.2(33) SRD から Cisco IOS Release 12.2(33) SRE にアップグレードした場合、このコマンドを実行する際にパーサー エラーが表示される場合もあります。 Cisco 7200 シリーズ ルータでは、bandwidthremainingratio コマンドの代わりに同じ機能を実行する bandwidthremainingpercent コマンドを使用できます。

次に、ATM サブインターフェイスに帯域幅余剰比率を設定する例を示します。 この例では、ルータは可変ビット レート非リアルタイム(VBR-nrt)PVC 0/200 用に 50 Mbps のピーク セル レートを保証します。 輻輳時に、サブインターフェイスは物理インターフェイスに設定された他のサブインターフェイスを基準に、10 の帯域幅余剰比率に基づいて、超過帯域幅の共有(プライオリティ トラフィックで未使用)を受信します。

policy-map Child
 class precedence_0
  bandwidth 10000
 class precedence_1
  shape average 100000
  bandwidth 100
!
policy-map Parent
 class class-default
  bandwidth remaining ratio 10
  shape average 20000000
  service-policy Child
!
interface ATM2/0/3.200 point-to-point
 ip address 10.20.1.1 255.255.255.0
 pvc 0/200
 protocol ip 10.20.1.2
 vbr-nrt 50000
 encapsulation aal5snap
 service-policy output Parent

次に、個々のクラス キューの帯域幅残余比率を設定する例を示します。 設定されたクラスの一部に帯域幅保証および明示的に指定された帯域幅余剰比率があります。 輻輳がサブインターフェイス レベル内で発生すると、このクラス キューはクラス レベル帯域幅余剰比率(precedence_0、precedence_1、precedence_2、precedence_5 クラスに対して、それぞれ 20、30、120、100)に基づいて、超過帯域幅(プライオリティ トラフィックで未使用)を受信します。 通常、precedence_3 クラス(定義されている比率なし)は、子ポリシーで定義された class-default クラスの帯域幅余剰比率に基づいて帯域幅を受信します。 ただし、この例では、子ポリシーは class-default の帯域幅残余比率を定義しません。 したがって、ルータは 1 の比率を使用して、precedence_3 トラフィックに超過帯域幅を割り当てます。

policy-map Child
 class precedence_0
  shape average 100000
  bandwidth remaining ratio 20
 class precedence_1
  shape 10000
  bandwidth remaining ratio 30
 class precedence_2
  shape average 200000
  bandwidth remaining ratio 120
 class precedence_3
  set ip precedence 3
 class precedence_5
  set ip precedence 5
  bandwidth remaining ratio 100
policy-map Parent
 class class-default
  bandwidth remaining ratio 10
  service-policy Child
!
interface GigabitEthernet 2/0/1.10
 encapsulation dot1q 10
 service-policy output Parent

次に、オプションの account キーワードおよび関連するキーワードと引数を使用してオーバーヘッド アカウンティングを設定する例を示します。

policy-map subscriber_line
 class class-default
  bandwidth remaining ratio 10 account dot1q aal5 snap-rbe-dot1q
  shape average 512 account dot1q 
aal5 snap-rbe-dot1q
  service policy subscriber_classes

関連コマンド

コマンド

説明

bandwidth remaining percent

クラス レベルまたはサブインターフェイス レベルのキューの帯域幅残余割合を指定します。この帯域幅残余割合は、プライオリティ トラフィックによって使用されていない余分な帯域幅を判断し、非プライオリティ キューに割り当てるために輻輳時に使用します。

show policy-map

指定されたサービス ポリシー マップに対するすべてのクラスの設定、または、すべての既存ポリシー マップに対するすべてのクラスの設定を表示します。

show policy-map interface

指定したインターフェイスまたはサブインターフェイス上か、インターフェイス上の特定の PVC に対し、すべてのサービス ポリシーに対して設定されているすべてのクラスのパケット統計情報を表示します。

class(ポリシーマップ)

ポリシーを作成または変更するクラスの名前を指定する、またはクラスのポリシーを設定する前にデフォルト クラス(一般に class-default クラスとして知られるクラス)を指定するには、ポリシーマップ コンフィギュレーション モードで class コマンドを使用します。 ポリシー マップからクラスを削除するには、このコマンドの no 形式を使用します。

class { class-name | class-default [ fragment fragment-class-name ] } [ insert-before class-name ] [ service-fragment fragment-class-name ]

no class { class-name | class-default }

構文の説明

class-name

設定するクラス、またはポリシーを編集するクラスの名前を指定します。 クラス名は、クラス マップに使用するとともに、ポリシー マップのクラスにポリシーを設定する場合にも使用します。

class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

fragment f ragment-class-name

(任意)デフォルト トラフィック クラスをフラグメントに指定し、フラグメント トラフィック クラスに名前を付けます。

insert-before class-name

(任意)既存の任意の 2 つのクラス マップ間にクラス マップを追加します。

既存の 2 つのクラス マップ間に新しいクラス マップを挿入すると、既存のポリシー マップ コンフィギュレーションの柔軟性が向上します。 このオプションを指定しないと、クラス マップはポリシー マップの末尾に追加されます。

このキーワードは、Flexible Packet Matching(FPM)ポリシーでだけサポートされています。

service-fragment fragment-class-name

(任意)クラスがフラグメントのコレクションを分類するように指定します。 このクラスにより分類されるフラグメントは、すべて同じ fragment-class-name を共有している必要があります。

コマンド デフォルト

クラスの指定はありません。

コマンド モード


ポリシー マップ コンフィギュレーション(config-pmap)

コマンド履歴

リリース

変更内容

12.0(5)T

このコマンドが導入されました。

12.0(5)XE

このコマンドが Cisco IOS Release 12.0(5)XE に統合されました。

12.0(7)S

このコマンドが Cisco IOS Release 12.0(7)S に統合されました。

12.1(1)E

このコマンドが Cisco IOS Release 12.1(1)E に統合されました。

12.2(14)SX

このコマンドのサポートが、Cisco 7600 ルータに追加されました。

12.2(17d)SXB

このコマンドが、Cisco 7600 ルータに実装され、Cisco IOS Release 12.2(17d)SXB に統合されました。

12.2(18)SXE

class-default キーワードが Cisco 7600 ルータに追加されました。

12.4(4)T

insert-beforeclass-name オプションが追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(31)SB2

このコマンドが、Cisco 10000 シリーズ ルータの PRE3 に追加されました。

12.2(18)ZY

insert-beforeclass-name オプションが、Catalyst 6500 シリーズの Programmable Intelligent Services Accelerator(PISA)が搭載されているスイッチの Cisco IOS Release 12.2(18)ZY に統合されました。

Cisco IOS XE Release 2.1

このコマンドが Cisco ASR 1000 シリーズ ルータに実装されました。 fragmentfragment-class-name および service-fragmentfragment-class-name オプションが導入されました。

使用上のガイドライン

ポリシー マップ コンフィギュレーション モード

ポリシー マップ内で、class(ポリシーマップ) コマンドを使用すれば、ポリシーを作成または変更するクラスの名前を指定できます。 まず、ポリシー マップを指定する必要があります。

ポリシー マップを指定する(および、必要なポリシー マップ コンフィギュレーション モードに入る)には、policy-map コマンドを使用してから class(ポリシーマップ) コマンドを使用します。 ポリシー マップを指定した後は、新しいクラスのポリシーを設定したり、そのポリシー マップ内の任意の既存クラスのポリシーを変更したりできます。

クラス特性

ポリシー マップで指定したクラス名は、class-map コマンドを使用して設定されたように、そのクラスの特性、つまりそのポリシーをクラス マップとその一致基準に連結します。

クラスのポリシーを設定し、その帯域幅を指定し、ポリシー マップをインターフェイスに割り当てると、クラス ベース Weighted Fair Queueing(CBWFQ)によって、そのクラスの帯域幅要件が満たされているかどうかが判断されます。 満たされていれば、CBWFQ がその帯域幅要件のキューを割り当てます。

クラスが削除されると、インターフェイスに使用できる帯域幅が、そのクラスにそれまで割り当てられていた量だけ増加します。

ルータに(つまり 1 つのポリシー マップ内で)設定できるクラスの最大数は、64 個です。

定義済みのデフォルト クラス

class-default と呼ばれる定義済みのデフォルト クラスを指定するには、class-default キーワードを使用します。 class-default クラスは、トラフィックがクラス マップ内で設定されているどの一致基準とも一致しない場合に、そのトラフィックが送られるクラスです。

テール ドロップまたは WRED

クラス ポリシーを定義するには、テール ドロップを使用するか(queue-limit コマンドを実行)、または Weighted Random Early Detection(WRED)を使用(random-detect コマンドを実行)することができます。 テール ドロップまたは WRED を使用する場合は、次の点に注意してください。

  • queue-limit コマンドと random-detect コマンドの両方を同じクラス ポリシー内で使用することはできませんが、同じポリシー マップ内の 2 つのクラス ポリシー内で使用することは可能です。
  • クラス ポリシー内で queue-limit コマンドまたは random-detect コマンドのいずれかが設定されている場合は、bandwidth コマンドを設定できます。 bandwidth コマンドは、クラスに割り当てられる帯域幅の量を指定します。
  • 定義済みのデフォルト クラスでは、fair-queue(class-default)コマンドを設定できます。 fair-queue コマンドは、デフォルト クラスのダイナミック キューの数を指定します。 fair-queue コマンドは、queue-limit コマンドまたは random-detect コマンドと同じクラス ポリシー内で使用できます。 bandwidth コマンドと一緒に使用することはできません。

Fragments

デフォルト トラフィック クラスは、ポリシー マップ クラス ステートメントで fragment キーワードを使用して、フラグメントとしてマークされています。 これにより、フラグメントを分類して、複数のフラグメントをまとめて service-fragment キーワードを使用して作成した別のポリシー マップに入れることができます。 フラグメントが使用されると、フラグメントとしてマークされているデフォルト トラフィック クラスに、デフォルト以外のトラフィック クラスとは別に、QoS が適用されます。

フラグメントを使用する場合は、次のガイドラインに従ってください。

  • フラグメントとしてマークできるのは、デフォルト トラフィック クラスだけです。
  • デフォルト クラス ステートメントでの fragmentfragment-class-name オプションが、デフォルト クラスをフラグメントとしてマークします。
  • ポリシー マップ内でクラスを定義しているときに service-fragmentfragment-class-name オプションを使用すると、同じ fragment-class-name を共有するすべてのフラグメントを含むモジュール式 QoS CLI でのトラフィックのクラスを指定できます。
  • フラグメントは、同一物理インターフェイス内でしか使用できません。 同じ fragment-class-name を共有し、異なるインターフェイス上にあるフラグメントを持つポリシー マップを、service-fragmentfragment-class-name オプションを持つクラスを使用してひとまとめに分類することはできません。

Cisco 10000 シリーズ ルータ

PRE2 によって、ポリシー マップ 31 クラス キューを設定することができます。

PRE3 により、プライオリティ レベル 1 の 1 個のキュー、プライオリティ レベル 2 の 1 個のキュー、12 個のクラス キューと、1 個のデフォルト キューをポリシー マップに設定することができます。

Cisco ASR 1000 シリーズ ルータ

したがって、Cisco ASR 1000 シリーズ ルータにポリシー マップ内で設定できるクラスの最大数は、8 個です。

次に、policy1 というポリシー マップに含まれる 3 個のクラス ポリシーを設定する例を示します。 Class1 は、アクセス コントロール リスト 136 に一致するトラフィックのポリシーを指定します。 Class2 はインターフェイス ethernet101 のトラフィックのポリシーを指定します。 3 つ目のクラスは、設定済みの一致基準を満たさないパケットが送られるデフォルト クラスです。

! The following commands create class-maps class1 and class2 
! and define their match criteria:
class-map class1
 match access-group 136
class-map class2
 match input-interface ethernet101
! The following commands create the policy map, which is defined to contain policy
! specification for class1, class2, and the default class:
policy-map policy1
Router(config)# policy-map policy1
Router(config-pmap)# class class1
Router(config-pmap-c)# bandwidth 2000
Router(config-pmap-c)# queue-limit 40
Router(config-pmap)# class class2
Router(config-pmap-c)# bandwidth 3000
Router(config-pmap-c)# random-detect
Router(config-pmap-c)# random-detect exponential-weighting-constant 10
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue 16
Router(config-pmap-c)# queue-limit 20
  • Class1:輻輳が発生すると、最低 2000 Kbps の帯域幅がこのクラスに提供されると予測され、このクラス用に確保されたキューは、追加パケットを処理するためにテール ドロップが適用される前に 40 個のパケットをキューに入れることができます。
  • Class2:輻輳が発生すると、最低 3000 Kbps の帯域幅がこのクラスに提供されると予測され、平均キュー サイズの計算に 10 の重み係数が使用されます。 輻輳回避のために、テール ドロップではなく WRED パケットのドロップが使用されます。
  • デフォルト クラス:ポリシーが、policy1 と呼ばれるポリシー マップで定義されている、他のクラスの一致基準を満たさないトラフィック用に 16 個のダイナミック キューが確保されています。追加パケットを処理するためにテール ドロップが適用される前に 1 個のキューあたり最大 20 個のパケットがキューに入れられます。

(注)  


これらのクラスを含むポリシー マップが、そのインターフェイスのサービス ポリシーを規定するインターフェイスに付加された場合、すべてのクラス ポリシーおよびリソース予約プロトコル(RSVP)(設定されている場合)を考慮に入れて、使用可能な帯域幅が評価されます。


次に、policy8 というポリシー マップに含まれるデフォルト クラスのポリシーを設定する例を示します。 デフォルト クラスには、次のような特性があります。ポリシーが、policy8 というポリシー マップによって定義される、他のクラスの一致基準を満たさないトラフィック用に 20 個のダイナミック キューが確保され、平均キュー サイズの計算に 14 の重み係数が使用されます。 輻輳回避のために、テール ドロップではなく WRED パケットのドロップが使用されます。

Router(config)# policy-map policy8
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue 20
Router(config-pmap-c)# random-detect exponential-weighting-constant 14

次の例では、policy1 というポリシー マップに含まれる acl136 というクラスのためのポリシーを設定する方法を示します。 クラス acl136 には、次のような特性があります。輻輳が発生すると、最低 2000 Kbps の帯域幅がこのクラスに提供されると予測され、このクラス用に確保されたキューは、追加パケットを処理するためにテール ドロップが適用される前に 40 個のパケットをキューに入れることができます。 このクラスを含むポリシー マップが、そのインターフェイスのサービス ポリシーを規定するポリシー マップがインターフェイスに付加された場合、すべてのクラス ポリシーおよび RSVP(設定されている場合)を考慮に入れて、使用可能な帯域幅が評価されることに注意してください。

Router(config)# policy-map policy1
Router(config-pmap)# class acl136
Router(config-pmap-c)# bandwidth 2000
Router(config-pmap-c)# queue-limit 40

次の例では、policy8 というポリシー マップに含まれる int101 というクラスのためのポリシーを設定する方法を示します。 クラス int101 には、次のような特性があります。輻輳の発生時にこのクラスに最低 3000 Kbps の帯域幅が提供され、平均キュー サイズの計算に重み係数 10 が使用されます。 輻輳回避のために、テール ドロップではなく WRED パケットのドロップが使用されます。 このクラスを含むポリシー マップがインターフェイスに付加されて、そのインターフェイスのサービス ポリシーが決定される場合、使用可能な帯域幅が評価されることに注意してください。

Router(config)# policy-map policy8
Router(config-pmap)# class int101
Router(config-pmap-c)# bandwidth 3000
Router(config-pmap-c)# random-detect exponential-weighting-constant 10

次に、policy1 というポリシー マップに組み込まれるデフォルト クラス class-default のポリシーを設定する例を示します。 デフォルト クラス class-default には、次のような特性があります。policy1 と呼ばれるポリシー マップで定義されている、他のクラスの一致基準を満たさないトラフィック用の 10 個のハッシュ キューと、キューに入れられた追加パケットを処理するためにテール ドロップが適用される前に 1 個のキューあたり最大 20 個のパケット。

Router(config)# policy-map policy1
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue
Router(config-pmap-c)# queue-limit 20

次に、policy8 というポリシー マップに組み込まれるデフォルト クラス class-default のポリシーを設定する例を示します。 デフォルト クラス class-default には、次のような特性があります。ポリシーが、policy8 というポリシー マップによって定義される、他のクラスの一致基準を満たさないトラフィック用に 20 個のハッシュ キューと、平均キュー サイズの計算に 14 の重み係数が使用されます。 輻輳回避のために、テール ドロップではなく WRED パケットのドロップが使用されます。

Router(config)# policy-map policy8
Router(config-pmap)# class class-default
Router(config-pmap-c)# fair-queue 20
Router(config-pmap-c)# random-detect exponential-weighting-constant 14

次に、ブラスタ パケットに対する FPM を設定する例を示します。 クラス マップには、TCP ポート 135、4444 または UDP ポート 69 と IP ヘッダーの開始から 3 バイトのパターンが 0x0030 という一致基準が含まれます。

load protocol disk2:ip.phdf
load protocol disk2:tcp.phdf
load protocol disk2:udp.phdf 
class-map type stack match-all ip-tcp
 match field ip protocol eq 0x6 next tcp
class-map type stack match-all ip-udp
 match field ip protocol eq 0x11 next udp
class-map type access-control match-all blaster1
 match field tcp dest-port eq 135
 match start 13-start offset 3 size 2 eq 0x0030
class-map type access-control match-all blaster2
 match field tcp dest-port eq 4444
Router(config-cmap)# match start 13-start offset 3 size 2 eq 0x0030
class-map type access-control match-all blaster3
 match field udp dest-port eq 69
 match start 13-start offset 3 size 2 eq 0x0030
policy-map type access-control fpm-tcp-policy
 class blaster1
 drop
 class blaster2
 drop
policy-map type access-control fpm-udp-policy
 class blaster3
 drop
policy-map type access-control fpm-policy
 class ip-tcp
 service-policy fpm-tcp-policy
 class ip-udp
 service-policy fpm-udp-policy
interface gigabitEthernet 0/1
 service-policy type access-control input fpm-policy

次に、BestEffort というデフォルト トラフィック クラスを分類するためにフラグメント トラフィック クラスの作成方法を示しています。 ポリシー マップからのすべてのデフォルト トラフィックは、subscriber1 という名前で、subscriber2 は、BestEffort という名前のフラグメントのデフォルト トラフィック クラスの一部です。 このデフォルト トラフィックは、service-fragment キーワードおよび shape コマンドを使用する data というクラスの作成によって集合的に整形されます。

この例では、次の点に注意してください。

  • 各フラグメントのデフォルト トラフィック クラスの class-name は「BestEffort」です。
  • 「BestEffort」の class-name は、service-fragment キーワードが入力されるクラスを定義するためにも使用されます。 このクラスは、「BestEffort」というフラグメントのデフォルト トラフィック クラスを使用して、転送されるすべてのトラフィックにシェーピング ポリシーを適用します。
policy-map subscriber1
class voice
set cos 5
priority level 1
class video
set cos 4
priority level 2
class class-default fragment BestEffort
shape average 200
bandwidth remaining ratio 10
policy-map subscriber 2
class voice
set cos 5
priority level 1
class video
set cos 4
priority level 2
class class-default fragment BestEffort
shape average 200
bandwidth remaining ratio 10
policy-map input_policy
class class-default
set dscp default
policy-map main-interface
class data service-fragment BestEffort
shape average 400
interface portchannel1.1001
encapsulation dot1q 1001service-policy output subscriber1
service-policy input input_policy
interface portchannel1.1002
encapsulation dot1q 1002
service-policy output subscriber2
service-policy input input_policy
interface gigabitethernet 0/1
description member-link1
port channel 1
service-policy output main-interface
interface gigabitethernet 0/2
description member-link2
port channel 1

service-policy output main-interface

関連コマンド

コマンド

説明

bandwidth(ポリシーマップ クラス)

ポリシー マップに属するクラスに割り当てる帯域幅を指定または変更します。

class-map

指定したクラスへのパケットのマッチングに使用するクラス マップを作成します。

fair-queue(class-default)

デフォルト クラス ポリシーの一部として class-default クラスで使用するために予約するダイナミック キューの数を指定します。

policy-map

1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または修正し、サービス ポリシーを指定します。

queue-limit

キューが保持できる、ポリシー マップ内に設定されるクラス ポリシーのパケットの最大数を指定または変更します。

random-detect(インターフェイス)

WRED または DWRED をイネーブルにします。

random-detect exponential-weighting-constant

キューの平均サイズ計算のための WRED および DWRED 指数加重係数を設定します。

random-detect precedence

特定の IP Precedence の WRED パラメータと DWRED パラメータを設定します。

class-map

指定したクラスとパケットの照合に使用するクラス マップを作成し、QoS クラス マップ コンフィギュレーション モードを開始するには、グローバル コンフィギュレーション モードで class-map コマンドを使用します。 デバイスから既存のクラス マップを削除するには、このコマンドの no 形式を使用します。

Cisco 2600, 3660, 3845, 6500, 7200, 7401, and 7500 Series Routers

class-map [ type { stack | access-control | port-filter | queue-threshold | logging log-class } ] [ match-all | match-any ] class-map-name

no class-map [ type { stack | access-control | port-filter | queue-threshold | logging log-class } ] [ match-all | match-any ] class-map-name

Cisco 7600 Series Routers

class-map class-map-name [ match-all | match-any ]

no class-map class-map-name [ match-all | match-any ]

Cisco Performance Monitor in Cisco IOS Release 15.1(3)T and 12.2(58)SE

class-map class-map-name

no class-map class-map-name

構文の説明

type

(任意)クラス マップ タイプを指定します。

stack

(任意)フレキシブル パケット マッチング(FPM)機能をイネーブルにして、プロトコル スタックを検査するように指示します。

load protocol コマンドを使用してデバイスにプロトコル ヘッダーの説明ファイル(PHDF)をロードすると、プロトコル ヘッダーのスタックが定義され、フィルタにより、どのヘッダーがどの順番で存在しているか、特定することができます。

access-control

(任意)設定されたプロトコル スタック内を検索するパターンを指定します。

(注)     

type access-control キーワードを使用して)access-control クラス マップを指定する前に、(type stack キーワードを使用して)スタックのクラス マップを指定する必要があります。

port-filter

(任意)コントロール プレーン パケットの TCP または UDP ポート ポリシングをイネーブルにする port-filter クラス マップを作成します。 このキーワードがイネーブルの場合、コマンドは、コントロール プレーン ホスト サブインターフェイス上の特定のポートに向かうトラフィックをフィルタに掛けます。

queue-threshold

(任意)指定されたプロトコルでコントロール プレーン IP 入力キューに入ることができるパケットの総数を制限するキューしきい値をイネーブルにします。 キューしきい値は、コントロールプレーン ホスト サブインターフェイスにだけ適用されます。

logging log-class

(任意)コントロール プレーン上のパケット トラフィックのロギングをイネーブルにします。 log-class 引数の値は、ログ クラスの名前です。

match-all

(任意)複数の一致基準が存在する場合に、どのようにしてパケットを評価するかを決定します。 このクラス マップの下のステートメントが、論理 AND 関数に基づいて一致します。 パケットは、受け入れるすべてのステートメントに一致させる必要があります。 match-all キーワードも match-any キーワードも指定しなかった場合に使用されるデフォルト キーワードは、match-all です。

match-any

(任意)複数の一致基準が存在する場合に、どのようにしてパケットを評価するかを決定します。 このクラス マップの下のステートメントが、論理 OR 関数に基づいて一致します。 パケットは、受け入れるすべての照合ステートメントに一致させる必要があります。 match-any キーワードも match-all キーワードも指定しなかった場合に使用されるデフォルト キーワードは、match-all です。

class-map-name

クラス マップのクラスの名前です。 クラス名は、クラス マップに使用するとともに、ポリシー マップのクラスにポリシーを設定する場合にも使用します。

(注)     

class-map-name 引数の値は引用符内に入力できます。 ソフトウェアでは、引用符なしで入力されたクラス マップ名にはスペースを入力できません。

コマンド デフォルト

クラス マップは設定されません。

コマンド モード


グローバル コンフィギュレーション(config)

コマンド履歴

リリース

変更内容

12.0(5)T

このコマンドが導入されました。

12.0(5)XE

このコマンドが Cisco IOS Release 12.0(5)XE に統合されました。

12.0(7)S

このコマンドが Cisco IOS Release 12.0(7)S に統合されました。

12.1(1)E

このコマンドが Cisco IOS Release 12.1(1)E に統合されました。

12.2(14)SX

このコマンドは、Cisco IOS Release 12.2(14)SX に統合され、Cisco 7600 シリーズ ルータに実装されました。

12.2(17d)SXB

このコマンドは、Cisco IOS Release 12.2(17d)SXB に統合され、Cisco 7600 シリーズ ルータに実装されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.4(4)T

このコマンドが変更されました。 FPM をサポートするため、stack キーワードと access-control キーワードが追加されました。 コントロール プレーン保護をサポートするため、port-filter キーワードと queue-threshold キーワードが追加されました。

12.4(6)T

このコマンドが変更されました。 コントロール プレーン パケット ロギングをサポートするため、logging log-class キーワードと引数のペアが追加されました。

12.2(18)ZY

このコマンドが変更されました。 stack キーワードおよび access-control キーワードが、プログラマブル インテリジェント サービス アクセラレータ(PISA)を搭載した Catalyst 6500 シリーズ スイッチの Cisco IOS Release 12.2(18) ZY に統合されました。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合され、Cisco ASR 1000 シリーズの集約サービス ルータに実装されました。

15.1(3)T

このコマンドは、使用可能な唯一の構文要素としての class-map-name 引数を使用して Cisco Performance Monitor 用の Cisco IOS Release 15.1(3)T に統合されました。

12.2(58)SE

このコマンドは、class-map-name 引数を使用して Cisco Performance Monitor 用の Cisco IOS Release 12.2(58) SE に統合されました。

12.2(33)SCF

このコマンドが、Cisco IOS Release 12.2(33)SCF に統合されました。

15.2(3)T

このコマンドが変更されました。 ソフトウェアでは、引用符なしで入力されたクラス マップ名にはスペースを入力できません。

15.1(2)SNG

このコマンドは Cisco ASR 901 シリーズの集約サービス ルータに統合されました。

使用上のガイドライン

Cisco IOS Release 15.1(3)T および 12.2(58)SE の Cisco Performance Monitor

class-map-name 引数だけ使用できます。

Cisco 2600、3660、3845、6500、7200、7401、7500、および ASR 1000 シリーズ ルータ

class-map コマンドを使用して、クラス マップの一致基準に一致させるために作成または変更するクラスを指定します。 このコマンドは、このクラスの一致基準を設定する 1 つまたは複数の match コマンドを入力できる QoS クラスマップ コンフィギュレーション モードを開始します。 入力インターフェイスまたは出力インターフェイスのいずれか(service-policy コマンドの設定により決まります)に到達したパケットが、クラス マップに設定されている一致基準に対して照合され、パケットがそのクラスに属するかどうかが判断されます。

クラス マップを設定する際には、1 つまたは複数の match コマンドを使用して一致基準を指定できます。 たとえば、match access-group コマンド、match protocol コマンド、または match input-interface コマンドを使用できます。 match コマンドは、Cisco ソフトウェア リリースごとに異なります。 一致基準および match コマンドの詳細については、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Modular Quality of Service Command-Line Interface(CLI)(MQC)」の章を参照してください。

Cisco 7600 シリーズ ルータ

class-map コマンドおよびインターフェイス単位の QoS クラス マップ コンフィギュレーション モードで使用できるコマンドを適用して、パケット分類、マーキング、集約、およびグローバルに指定したサービス ポリシーの一部としてのフロー ポリシングを定義します。

サービス ポリシーは EtherChannel に付加できます。 EtherChannel のメンバーであるポートに、サービス ポリシーを付加しないでください。

デバイスが QoS クラスマップ コンフィギュレーション モードの場合、次のコンフィギュレーション コマンドが利用可能です。

  • description:クラス マップ設定の説明を指定します。
  • exit:QoS クラス マップ コンフィギュレーション モードを終了します。
  • match:分類基準を設定します。
  • no:クラス マップから照合ステートメントを削除します。

次のコマンドは、CLI ヘルプに表示されますが、オプティカル サービス モジュール(OSM)の LAN インターフェイスまたは WAN インターフェイスではサポートされていません。

  • destination-address mac mac-address
  • input-interface {interface-type interface-number | null number | vlan vlan-id}
  • protocol link-type
  • source-address mac mac-address

OSM は、Supervisor Engine32 が搭載された Catalyst 7600 シリーズ ルータではサポートされません。

ポリシー フィーチャ カード(PFC)QoS は次のコマンドをサポートしていません。

  • destination-address mac mac-address
  • input-interface {interface-type interface-number | null number | vlan vlan-id}
  • protocol link-type
  • qos-group group-value
  • source-address mac mac-address

これらのコマンドを入力した場合、インターフェイスにポリシー マップが付加されないと、PFC QoS はサポートされていないキーワードを検出しません。 インターフェイスにポリシー マップを付加しようとすると、エラー メッセージが生成されます。 詳細については、『Cisco 7600 Series Router Cisco IOS Software Configuration Guide』および Cisco IOS コマンド リファレンスを参照してください。

クラス マップ名とデバイスを設定すると、QoS クラス マップ コンフィギュレーション モードで match access-group コマンドと match ip dscp コマンドを入力できます。 これらのコマンドの構文は次のとおりです。

match [access-group {acl-index | acl-name} | ip dscp | precedence} value]

match コマンドのキーワードの説明については、次の表を参照してください。

表 1 match コマンドの構文の説明

オプション コマンド

説明

access-group acl-index | acl-name

(任意)アクセス リスト インデックスまたはアクセス リスト名を指定します。 有効なアクセス リスト インデックスの値は 1~2699 です。

access-group acl-name

(任意)名前付きアクセス リストを指定します。

ip dscp value1 value2 ... value8

(任意)照合する IP DiffServ コード ポイント(DSCP)値を指定します。 有効値の範囲は 0 ~ 63 です。 最大 8 つの DSCP 値をスペースで区切って入力できます。

ip precedence value1 value2 ... value8

(任意)照合する IP precedence 値を指定します。 有効な値の範囲は 0 ~ 7 です。 最大 8 つの precedence 値をスペースで区切って入力できます。

次に、クラスの名前として class101 を指定し、そのクラスに対してクラス マップを定義する方法の例を示します。 class101 という名前のクラスは、ACL 101 と一致するトラフィックのポリシーを指定します。

Device(config)# class-map class101
Device(config-cmap)# match access-group 101
Device(config-cmap)# end

次に、slammer および UDP パケットに対する FPM トラフィック クラスを定義する例を示します。 クラス マップ内で定義されている一致基準は、IP の長さが 404(0x194)以下、UDP ポートが 1434(0x59A)、IP ヘッダーの開始から 224 バイトのパターンが 0x4011010 の slammer および UPD パケット用です。

Device(config)# load protocol disk2:ip.phdf
Device(config)# load protocol disk2:udp.phdf
Device(config)# class-map type stack match-all ip-udp
Device(config-cmap)# description “match UDP over IP packets”
Device(config-cmap)# match field ip protocol eq 0x11 next udp
Device(config-cmap)#exit
Device(config)# class-map type access-control match-all slammer
Device(config-cmap)# description “match on slammer packets”
Device(config-cmap)# match field udp dest-port eq 0x59A
Device(config-cmap)# match field ip length eq 0x194
Device(config-cmap)# match start 13-start offset 224 size 4 eq 0x 4011010
Device(config-cmap)# end

次に、port-filter ポリシーが簡易ネットワーク管理プロトコル(SNMP)以外の閉鎖状態または「非待ち受け状態」ポートに向かうすべてのトラフィックをドロップするように設定する例を示します。

Device(config)# class-map type port-filter pf-class
Device(config-cmap)# match not port udp 123
Device(config-cmap)# match closed-ports
Device(config-cmap)# exit
Device(config)# policy-map type port-filter pf-policy
Device(config-pmap)# class pf-class
Device(config-pmap-c)# drop
Device(config-pmap-c)# end

次の例は、ipp5 というクラス マップを設定して、IP precedence 5 の照合ステートメントを入力する方法を示しています。

Device(config)# class-map ipp5
Device(config-cmap)# match ip precedence 5

次に、クラス マップを設定し、パケットのサービス クラス(CoS)値に 802.1p ドメインのトラフィック クラスを照合する例を示します。

Device> enable
Device# configure terminal
Device(config)# class-map cos1
Device(config-cmap)# match cos 0
Device(config-pmap-c)# end

次に、クラス マップを設定し、パケットの Experimental(EXP)値にマルチ プロトコル ラベル スイッチング(MPLS)ドメインのトラフィック クラスを照合する例を示します。

Device> enable
Device# configure terminal
Device(config)# class-map exp7
Device(config-cmap)# match mpls experimental topmost 2
Device(config-pmap-c)# end

関連コマンド

コマンド

説明

description

クラス マップまたはポリシー マップ コンフィギュレーションの説明を指定します。

drop

特定のクラス マップに属するパケットを廃棄するようにトラフィック クラスを設定します。

class(ポリシーマップ)

ポリシーを作成または変更するクラスの名前と、ポリシーを設定する前のデフォルト クラスを指定します。

load protocol

PHDF をルータにロードします。

matchクラス マップ

ポート フィルタまたはプロトコル キュー ポリシーに基づいて、クラス マップの一致基準を設定します。

match access-group

指定した ACL をベースにクラス マップに対して一致基準を設定します。

match input-interface

指定された入力インターフェイスを一致基準として使用するクラス マップを設定します。

match ip dscp

1 つまたは複数の DSCP 値、AF 値、および CS 値を一致基準として指定します。

match mpls experimental

指定した EXP フィールド値を一致基準として使用するクラス マップを設定します。

match protocol

指定されたプロトコルに基づいて、クラス マップの一致基準を設定します。

policy-map

1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または修正し、サービス ポリシーを指定します。

protocol

制御インターフェイスのタイマーと認証方式を設定します。

qos-group

クラス マップの QoS グループ値を関連付けます。

service-policy

入力インターフェイスまたは VC、あるいは出力インターフェイスまたは VC に、そのインターフェイスまたは VC のサービス ポリシーとして使用するポリシー マップを対応付けます。

show class-map

クラス マップ情報を表示します。

show policy-map interface

インターフェイスに適用された入力および出力ポリシーの統計情報および設定を表示します。

source-address

ポートに送信元アドレス制御を設定します。

dscp

Diffserv コード ポイント(DSCP)値の最小および最大パケットしきい値を変更するには、random-detect-group コンフィギュレーション モードで dscp コマンドを使用します。 最小および最大パケットしきい値を DSCP 値のデフォルトに戻すには、このコマンドの no 形式を使用します。

dscp dscp-value min-threshold max-threshold [mark-probability-denominator]

no dscp dscp-value min-threshold max-threshold [mark-probability-denominator]

構文の説明

dscp-value

DSCP 値を指定します。 DSCP 値には、0~63 の数字、または、efaf11af12af13af21af22af23af31af32af33af41af42af43cs1cs2cs3cs4cs5cs7 のいずれかのキーワードを指定できます。

min-threshold

パケット数での最小しきい値。 この引数に指定できる値の範囲は、1 ~ 4096 です。 キューの平均の長さが最小しきい値に達すると、重み付けランダム早期検出(WRED)は指定した DSCP 値の一部のパケットをランダムにドロップします。

max-threshold

パケット数での最大しきい値。 この引数に指定できる値の範囲は、min-threshold の値 ~ 4096 です。 キューの平均の長さが最大しきい値を超えると、WRED は指定した DSCP 値のすべてのパケットをドロップします。

mark-probability-denominator

(任意)キューの平均の深さが最大しきい値にあるときにドロップされたパケットの割合の分母。 たとえば、分母が 512 の場合、512 パケットごとに 1 つのパケットが、平均キューが最大しきい値にあるときにドロップします。 指定できる値の範囲は、1 ~ 65536 です。 デフォルトは 10 で、最大しきい値では 10 パケットごとに 1 つのパケットがドロップされます。

コマンド デフォルト

パケットのドロップ確率の計算に WRED で DSCP 値を使用する場合、DSCP テーブルのすべてのエントリは「使用上のガイドライン」の項の表に示されているデフォルト設定で初期化されます。

コマンド モード


Random-detect-group コンフィギュレーション

コマンド履歴

リリース

変更内容

12.1(5)T

このコマンドが導入されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

使用上のガイドライン

このコマンドは、random-detect-group コマンドと組み合わせて使用する必要があります。

さらに、dscp コマンドが使用できるのは、random-detect-group コマンドを使用するときに dscp-based 引数を指定した場合だけです。

次の表に、dscp コマンドで使用される DSCP のデフォルト設定を示します。 次の表に、DSCP 値と対応する最小しきい値、最大しきい値、およびマーク確率を示します。 表の最後の行(「デフォルト」というラベルが付いている行)は、この表には登場しない DSCP 値すべてで使用されるデフォルト設定を表します。

表 2 DSCP デフォルト設定

DSCP

(優先順位)

最小しきい値

最大しきい値

マーク確率

af11

32

40

1/10

af12

28

40

1/10

af13

24

40

1/10

af21

32

40

1/10

af22

28

40

1/10

af23

24

40

1/10

af31

32

40

1/10

af32

28

40

1/10

af33

24

40

1/10

af41

32

40

1/10

af42

28

40

1/10

af43

24

40

1/10

cs1

22

40

1/10

cs2

24

40

1/10

cs3

26

40

1/10

cs4

28

40

1/10

cs5

30

40

1/10

cs6

32

40

1/10

cs7

34

40

1/10

ef

36

40

1/10

rsvp

36

40

1/10

デフォルト

20

40

1/10

次に、DSCP 値 af22 を使用するように WRED をイネーブル化する例を示します。 DSCP 値 af22 の最小しきい値は 28、最大しきい値は 40、マーク確率は 10 です。

Router> enable
Router# configure terminal
Router(config)# random-detect-group class1 dscp-based
Router(cfg-red-group)# dscp af22 28 40 10
Router(cfg-red-group)# end

関連コマンド

コマンド

説明

random-detect-group

per-VC WRED または per-VC DWRED をイネーブルにします。

show queueing

すべてまたは選択した設定済みキューイング戦略を表示します。

show queueing interface

インターフェイスまたは VC のキューイングの統計情報を表示します。

match class-map

分類ポリシーとしてトラフィック クラスを使用するには、クラス マップまたはポリシー インライン コンフィギュレーション モードで match class-map コマンドを使用します。 一致基準として特定のトラフィック クラスを削除するには、このコマンドの no 形式を使用します。

match class-map class-map-nam e

no match class-map class-map-name

構文の説明

class-map-name

一致基準として使用するトラフィック クラスの名前。

コマンド デフォルト

一致基準が指定されていません。

コマンド モード


クラス マップ コンフィギュレーション(config-cmap)

コマンド履歴

リリース

変更内容

12.0(5)XE

このコマンドが導入されました。

12.1(1)E

このコマンドが Cisco IOS Release 12.1(1)E に統合されました。

12.1(5)T

このコマンドが、Cisco IOS Release 12.1(5)T に統合されました。

12.4(6)T

このコマンドは、ゾーン ベースのポリシー ファイアウォールをサポートするように拡張されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB

このコマンドは、Cisco 10000 シリーズに実装されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 3.2S

このコマンドが Cisco IOS XE Release 3.2S に統合されました。

使用上のガイドライン

1 つのトラフィック クラスで match-any 特性と match-all 特性を使用するための唯一の方法は、match class-map コマンドを使用することです。 1 つのクラスに match-any 特性と match-all 特性を組み合わせるには、次のいずれかを実行します。

  • match-any 手順を使用してトラフィック クラスを作成し、一致基準として(match class-map コマンドを使用して)match-all 手順で設定されたクラスを使用します。
  • match-all 手順を使用してトラフィック クラスを作成し、一致基準として(match class-map コマンドを使用して)match-any 手順で設定されたクラスを使用します。

match class-map コマンドを使用して、トラフィック クラスを相互にネストすることもできます。これで、情報の大半がすでに設定済みのトラフィック クラスに存在している場合、トラフィック クラスを新たに再作成するオーバーヘッドをユーザが回避することができます。

パケットがクラス マップに一致すると、トラフィック レートがこれらのパケットに対して生成されます。 ゾーン ベースのファイアウォール ポリシーでは、セッションを作成する最初のパケットのみがポリシーに一致します。 このフローの後続のパケットは、設定済みのポリシーのフィルタに一致しませんが、その代わりにセッションを直接照合します。 後続のパケットに関連する統計情報は、「検査」アクションの一部として表示されます。

次の例で、トラフィック クラス class1 の特性は、トラフィック クラス class2 の特性とほぼ同じですが、トラフィック クラス class1 では、一致条件として宛先アドレスが追加されています。 トラフィック クラス class1 を行単位で設定する代わりに、match class-map class2 コマンドを入力できます。 このコマンドを使用すると、トラフィック クラス class2 のすべての特性をトラフィック クラス class1 に取り込み、トラフィック クラスを再設定することなく、新しい宛先アドレスの一致条件を追加できます。

Router(config)# class-map match-any class2
Router(config-cmap)# match protocol ip
Router(config-cmap)# match qos-group 3
Router(config-cmap)# match access-group 2
Router(config-cmap)# exit
Router(config)# class-map match-all class1
Router(config-cmap)# match class-map class2
Router(config-cmap)# match destination-address mac 1.1.1
Router(config-cmap)# exit

次に、2 つのトラフィック クラスの特性を組み合わせる例を示します。1 つは match-any 特性を使用し、1 つは match-all 特性を使用しています。これを、match class-map コマンドで 1 つのトラフィック クラスとして設定します。 class4 というトラフィック クラスの結果には、class4 というトラフィック クラスのメンバーと見なされる、次の 3 個の一致基準(IP プロトコルおよび QoS group 4、宛先 MAC アドレス 1.1.1、またはアクセス グループ 2)のいずれか 1 つに一致するパケットが必要です。 class3 というトラフィック クラスの定義には、一致基準の IP プロトコルおよび QoS group 4 が必要で、match class-map class3 コマンドを使用して、一致する可能性があるものとして class4 というトラフィック クラスの定義に含まれます。

この例では、トラフィック クラス class4 だけがサービス ポリシー policy1 で使用されています。

Router(config)# class-map match-all class3
Router(config-cmap)# match protocol ip
Router(config-cmap)# match qos-group 4
Router(config-cmap)# exit
Router(config)# class-map match-any class4
Router(config-cmap)# match class-map class3
Router(config-cmap)# match destination-address mac 1.1.1
Router(config-cmap)# match access-group 2
Router(config-cmap)# exit
Router(config)# policy-map policy1
Router(config-pmap)# class class4
Router(config-pmap-c)# police 8100 1500 2504 conform-action transmit exceed-action set-qos-transmit 4
Router(config-pmap-c)# exit

関連コマンド

コマンド

説明

class-map

指定したクラスへのパケットのマッチングに使用するクラス マップを作成します。

match cos

レイヤ 2 サービス クラス(CoS)/スイッチ間リンク(ISL)マーキングに基づいてパケットを照合するには、クラス マップ コンフィギュレーションまたはポリシー インライン コンフィギュレーション モードで matchcos コマンドを使用します。 一致基準としての特定のレイヤ 2 CoS/ISL マーキングを削除するには、このコマンドの no 形式を使用します。

match cos cos-value [ cos-value [ cos-value [cos-value] ] ]

no match cos cos-value [ cos-value [ cos-value [cos-value] ] ]

構文の説明

Cisco 10000 シリーズ ルータ以外のサポートされているプラットフォーム

cos-value

具体的な IEEE 802.1Q/ISL CoS 値。 cos-value は 0~7 です。1 つの matchcos 文に最大 4 つの CoS 値をスペースで区切って指定できます。

Cisco 10000 シリーズ ルータ

cos-value

特定のパケット CoS ビット値。 パケットの CoS ビット値が指定した CoS 値に一致する必要があることを指定します。 cos-value は 0~7 です。1 つの matchcos 文に最大 4 つの CoS 値をスペースで区切って指定できます。

コマンド デフォルト

パケットのレイヤ 2 CoS/ISL マーキングに基づいた照合は行われません。

コマンド モード


クラス マップ コンフィギュレーション(config-cmap)ポリシー インライン コンフィギュレーション(config-if-spolicy-inline)

コマンド履歴

リリース

変更内容

12.1(5)T

このコマンドが導入されました。

12.0(25)S

このコマンドが Cisco IOS Release 12.0(25)S に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB

このコマンドは、Cisco IOS Release 12.2(31)SB に統合され、Cisco 10000 シリーズ ルータに実装されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

12.2(33)SRC

このコマンドが、Cisco IOS Release 12.2(33)SRC に統合され、Cisco 7600 シリーズ ルータのサポートが追加されました。

12.4(15)T2

このコマンドが Cisco IOS Release 12.4(15)T2 に統合されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合され、Cisco 7300 シリーズ ルータのサポートが追加されました。

15.1(3)T

このコマンドは、Cisco Performance Monitor 用の Cisco IOS Release 15.1(3)T に統合されました。 ポリシー インライン コンフィギュレーション モードのサポートが追加されました。

12.2(58)SE

このコマンドは、Cisco Performance Monitor 用の Cisco IOS Release 12.2(58)SE に統合されました。

12.2(33)SCF

このコマンドが、Cisco IOS Release 12.2(33)SCF に統合されました。

3.2SE

このコマンドが Cisco IOS XE Release 3.2SE に統合されました。

15.1(2)SNG

このコマンドは Cisco ASR 901 シリーズの集約サービス ルータに統合されました。

使用上のガイドライン

このコマンドは、Flexible NetFlow および Performance Monitor の両方で使用できます。 これらの製品は、このコマンドを発行するコンフィギュレーション モードを開始する際に異なるコマンドを使用します。

Cisco IOS Release 15.1(3)T および 12.2(58)SE の Cisco Performance Monitor

最初に service-policytypeperformance-monitorinline コマンドを入力する必要があります。

次に、1、2、および 3 の CoS 値を、cos という分類ポリシーを含むインターフェイスの成功一致基準とする例を示します。

Router(config)# class-map cos
Router(config-cmap)# match cos 1 2 3

次の例では、CoS 値に基づいてトラフィックを分類するために、voice および video-n-data というクラスを作成しています。 その後、cos-based-treatment ポリシー マップ内で該当パケットへの QoS 処理を指定しています(この例では、QoS 処理は priority が 64、bandwidth が 512)。 この例で設定したサービス ポリシーは、ファスト イーサネット インターフェイス 0/0.1 から出て行くすべてのパケットに付加されます。 サービス ポリシーは、サービス ポリシーをサポートする任意のインターフェイスにアタッチできます。

Router(config)# class-map voice
Router(config-cmap)# match cos 7
Router(config)# class-map video-n-data
Router(config-cmap)# match cos 5
Router(config)# policy-map cos-based-treatment
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 64
Router(config-pmap-c)# exit
Router(config-pmap)# class video-n-data
Router(config-pmap-c)# bandwidth 512
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# interface fastethernet0/0.1
Router(config-if)# service-policy output cos-based-treatment

次に、Performance Monitor のサービス ポリシーを設定するために、ポリシー インライン コンフィギュレーション モードを使用する例を示します。 このポリシーは、CoS 値 2 の基準に一致するイーサネット インターフェイス 0/0 を通過するパケットが、fm-2 という名前のフロー モニタの設定で指定されたパラメータに基づいてモニタされることを指定します。

Router(config)# interface ethernet 0/0
Router(config-if)# service-policy type performance-monitor inline input
Router(config-if-spolicy-inline)# match cos 2
Router(config-if-spolicy-inline)# flow monitor fm-2
Router(config-if-spolicy-inline)# exit

次に、802.1p ドメインのトラフィック クラスをパケットの CoS 値と照合する例を示します。

Router> enable
Router# config terminal
Router(config)# class-map cos7
Router(config-cmap)# match cos 2
Router(config-cmap)# exit

関連コマンド

コマンド

説明

class-map

指定したクラスへのパケットのマッチングに使用するクラス マップを作成します。

service-policy type performance-monitor

Performance Monitor ポリシーとインターフェイスを関連付けます。

policy-map

1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または修正し、サービス ポリシーを指定します。

service-policy

入力インターフェイスまたは VC、あるいは出力インターフェイスまたは VC に、そのインターフェイスまたは VC のサービス ポリシーとして使用するポリシー マップを対応付けます。

set cos

発信パケットのレイヤ 2 CoS 値を設定します。

show class-map

すべてのクラス マップおよびその一致基準を表示します。

match protocol

指定したプロトコルに基づいてクラス マップの一致基準を設定するには、クラス マップ コンフィギュレーションまたはポリシー インライン コンフィギュレーション モードで matchprotocol コマンドを使用します。 クラス マップからプロトコル ベースの一致基準を削除するには、このコマンドの no 形式を使用します。

match protocol protocol-name

no match protocol protocol-name

構文の説明

protocol-name

一致基準として使用するプロトコルの名前(bgp など)。 大部分のルータでサポートされるプロトコルのリストについては、「使用上のガイドライン」を参照してください。

コマンド デフォルト

一致基準は設定されていません。

コマンド モード


クラス マップ コンフィギュレーション(config-cmap)ポリシー インライン コンフィギュレーション(config-if-spolicy-inline)

コマンド履歴

リリース

変更内容

12.0(5)T

このコマンドが導入されました。

12.0(5)XE

このコマンドが Cisco IOS Release 12.0(5)XE に統合されました。

12.0(7)S

このコマンドが Cisco IOS Release 12.0(7)S に統合されました。

12.1(1)E

このコマンドが Cisco IOS Release 12.1(1)E に統合されました。

12.1(13)E

このコマンドが Cisco IOS Release 12.1(13)E に統合され、Catalyst 6000 ファミリ スイッチで FlexWAN モジュールなしで実装されました。

12.2(8)T

このコマンドが Cisco IOS Release 12.2(8)T に統合されました。

12.2(13)T

このコマンドは、一致基準として使用するプロトコルのリストから、apollovinesxns を除外するように変更されました。 これらのプロトコルは、Apollo Domain、Banyan VINES、Xerox Network Systems(XNS)がこのリリースで廃止されたため、削除されました。 IPv6 プロトコルは IPv6 パケットのマッチングをサポートするために追加されました。

12.0(28)S

このコマンドが、IPv6 用の Cisco IOS Release 12.0(28)S に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(17a)SX1

このコマンドが、Cisco IOS Release 12.2(17a)SX1 に統合されました。

12.2(18)SXE

このコマンドが Cisco IOS Release 12.2(18)SXE に統合され、Supervisor Engine 720 に実装されました。

12.4(6)T

このコマンドが変更されました。 Napster プロトコルは、現在サポートされていないため、削除されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドは、Cisco IOS Release 12.2(31)SB2 に統合され、Cisco 10000 シリーズ ルータに実装されました。

12.2(18)ZY

このコマンドが、Cisco IOS Release 12.2(18)ZY に統合されました。 このコマンドは、Supervisor 32/プログラマブル インテリジェント サービス アクセラレータ(PISA)エンジンに搭載されている Catalyst 6500 シリーズ スイッチの Network-Based Application Recognition(NBAR)機能を拡張するため、変更されました。

12.4(15)XZ

このコマンドが、Cisco IOS Release 12.4(15)XZ に統合されました。

12.4(20)T

このコマンドが Cisco IOS Release 12.4(20)T に統合され、Cisco 1700、Cisco 1800、Cisco 2600、Cisco 2800、Cisco 3700、Cisco 3800、Cisco 7200、および Cisco 7300 シリーズ ルータに実装されました。

Cisco IOS XE Release 2.2

このコマンドが Cisco IOS XE Release 2.2 に統合され、Cisco ASR 1000 シリーズ ルータに実装されました。

Cisco IOS XE Release 3.1S

このコマンドが変更されました。 より多くのプロトコルのサポートが追加されました。

15.1(3)T

このコマンドは、Cisco Performance Monitor 用の Cisco IOS Release 15.1(3)T に統合されました。 ポリシー インライン コンフィギュレーション モードのサポートが追加されました。

12.2(58)SE

このコマンドは、Cisco Performance Monitor 用の Cisco IOS Release 12.2(58)SE に統合されました。

使用上のガイドライン

このコマンドは、Flexible NetFlow および Performance Monitor の両方で使用できます。 これらの製品は、このコマンドを発行するコンフィギュレーション モードを開始する際に異なるコマンドを使用します。

Cisco IOS Release 15.1(3)T および 12.2(58)SE の Cisco Performance Monitor

最初に service-policytypeperformance-monitorinline コマンドを入力する必要があります。

Cisco 7600 ルータおよび Cisco 10000 シリーズ ルータ以外のサポートされているプラットフォーム

クラスベース重み付け均等化キューイング(CBWFQ)では、一致基準にプロトコル、アクセス コントロール リスト(ACL)、入力インターフェイス、Quality of Service(QoS)ラベル、Experimental(EXP)フィールド値に基づいてトラフィック クラスを定義します。 クラスの一致基準を満たすパケットは、そのクラスのトラフィックの一部となります。

matchprotocol コマンドは、パケットがクラス マップで指定されたクラスに属するかどうか判別するのに照合される一致基準として使用されるプロトコル名を指定します。

matchprotocolipx コマンドは、出力方向のみのパケットに一致します。

matchprotocol コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するクラスの名前を指定する必要があります。 クラスを指定したら、次のいずれかのコマンドを使用してそのクラスの一致基準を設定できます。

  • match access-group
  • match input-interface
  • match mpls experimental

クラス マップで複数のコマンドを指定する場合、最後に入力されたコマンドだけが適用されます。 最後のコマンドは、それ以前に入力されたコマンドを無効にします。

NBAR を NBAR トラフィックでサポートされるプロトコル タイプに一致するように設定するには、matchprotocol(NBAR)コマンドを使用します。

Cisco 7600 シリーズ ルータ

QoS クラス マップ コンフィギュレーションの matchprotocol コマンドは、NBAR を設定し、マルチレイヤ スイッチ フィーチャ カード 2(MSFC2)のソフトウェアで処理される入出力ポート上のすべてのトラフィックを送信します。

CBWFQ では、プロトコル、ACL、入力インターフェイス、QoS ラベル、マルチ プロトコル ラベル スイッチング(MPLS)EXP フィールド値などの一致基準に基づいてトラフィック クラスを定義します。 クラスの一致基準を満たすパケットは、そのクラスのトラフィックの一部となります。

matchprotocol コマンドは、パケットがクラス マップで指定されたクラスに属するかどうか判別するのに照合される一致基準として使用されるプロトコル名を指定します。

matchprotocoll コマンドを使用する場合は、まず class-map コマンドを入力して一致基準を確立するクラス名を指定する必要があります。

クラス マップで複数のコマンドを指定する場合、最後に入力されたコマンドだけが適用されます。 最後のコマンドは、それ以前に入力されたコマンドを無効にします。

このコマンドは、NBAR 機能が認知するプロトコルを照合するのに使用されます。 NBAR が現在サポートするプロトコルの一覧については、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Classification」部を参照してください。

Cisco 10000 シリーズ ルータ

CBWFQ の場合、一致基準(プロトコル、ACL、入力インターフェイス、QoS ラベル、および EXP フィールド値など)に基づいてトラフィック クラスを定義します。 クラスの一致基準を満たすパケットは、そのクラスのトラフィックの一部となります。

matchprotocol コマンドは、パケットがクラス マップで指定されたクラスに属するかどうか判別するのに照合される一致基準として使用されるプロトコル名を指定します。

matchprotocolipx コマンドは、出力方向のみのパケットに一致します。

matchprotocol コマンドを使用するには、先に class-map コマンドを入力して、一致基準を確立するクラスの名前を指定する必要があります。

NBAR プロトコルに一致している場合は、matchprotocol(NBAR)コマンドを使用します。

Match Protocol コマンドの制限(Catalyst 6500 シリーズ スイッチのみ)

ポリシー マップには、トラフィック クラスが含まれます。 トラフィック クラスには、プロトコル タイプまたはアプリケーションに基づいてパケットを照合する(およびこれらをグループに編成する)ために使用できる 1 つまたは複数の match コマンドを含めることができます。 必要に応じて任意の数のトラフィック クラスを作成できます。

Cisco IOS Release 12.2(18)ZY には、Supervisor 32/PISA エンジンに搭載されている Catalyst 6500 シリーズ スイッチ用に設計されたソフトウェアが含まれます。 このリリースとプラットフォームでは、ポリシー マップと matchprotocol コマンドを使用する場合は、次の制限事項に注意してください。

  • 1 つのトラフィック クラスは、最大 8 個のプロトコルまたはアプリケーションに一致するように設定できます。
  • 複数のトラフィック クラスは累積最大 95 個のプロトコルまたはアプリケーションに一致するように設定できます。

サポートされるプロトコル

次の表に、大部分のルータがサポートするプロトコルを示します。 一部のルータは、追加プロトコルをサポートします。 たとえば、Cisco 7600 ルータは、AARP および DECnet プロトコルをサポートし、Cisco 7200 ルータは直接接続および PPPOE プロトコルをサポートします。 サポートされているプロトコルの完全なリストについては、使用しているルータの matchprotocol コマンドのオンライン ヘルプを参照してください。

表 3 サポートされるプロトコル

プロトコル名

説明

802-11-iapp

IEEE 802.11 無線ローカル エリア ネットワーク Working Group の Internet Access Point Protocol

ace-svr

ACE サーバ/伝播

aol

America-Online Instant Messenger

appleqtc

Apple QuickTime

arp *

IP アドレス解決プロトコル(ARP)

bgp

Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)

biff

Biff のメール通知

bootpc

Bootstrap Protocol Client(ブートストラップ プロトコル クライアント)

bootps

Bootstrap Protocol Server(ブートストラップ プロトコル サーバ)

bridge *

bridging

cddbp

CD データベース プロトコル

cdp *

Cisco Discovery Protocol

cifs

CIFS

cisco-fna

Cisco FNATIVE

cisco-net-mgmt

cisco-net-mgmt

cisco-svcs

Cisco license/perf/GDP/X.25/ident svcs

cisco-sys

Cisco SYSMAINT

cisco-tdp

cisco-tdp

cisco-tna

Cisco TNATIVE

citrix

Citrix Systems Metaframe

citriximaclient

Citrix IMA Client

clns *

ISO コネクションレス型ネットワーク サービス

clns_es *

ISO CLNS エンド システム

clns_is *

ISO CLNS 中継システム

clp

シスコの回線プロトコル

cmns *

ISO コネクションモード ネットワーク サービス

cmp

Cluster Membership Protocol

compressedtcp *

Compressed TCP

creativepartnr

クリエイティブ パートナー

creativeserver

クリエイティブ サーバ

cuseeme

CU-SeeMe デスクトップ ビデオ会議

daytime

日時(RFC 867)

dbase

dBASE Unix

dbcontrol_agent

Oracle Database Control Agent

ddns-v3

ダイナミック DNS バージョン 3

dhcp

ダイナミック ホスト コンフィギュレーション

dhcp-failover

DHCP フェールオーバー

directconnect

Direct Connect

discard

ポートの廃棄

dns

Domain Name Server lookup(ドメイン ネーム サーバ ルックアップ)

dnsix

DNSIX セキュリティ属性のトークン マップ

echo

ポートのエコー

edonkey

eDonkey

egp

Exterior Gateway Protocol(エクステリア ゲートウェイ プロトコル)

eigrp

Enhanced Interior Gateway Routing Protocol(拡張内部ゲートウェイ ルーティング プロトコル)

entrust-svc-handler

KM/Admin サービス ハンドラの委任

entrust-svcs

sps/aaas/aams の委任

exec

リモート プロセスの実行

exchange

Microsoft RPC for Exchange

fasttrack

FastTrack トラフィック(KaZaA、Morpheus、Grokster など)

fcip-port

FCIP

finger

Finger

ftp

File Transfer Protocol

ftps

TLS/SSL を介した FTP

gdoi

グループ ドメイン オブ インタープリテーション

giop

Oracle GIOP/SSL

gnutella

Gnutella バージョン 2 トラフィック(BearShare、Shareeza、Morpheus など)

gopher

Gopher

gre

Generic Routing Encapsulation(総称ルーティング カプセル化)

gtpv0

GPRS トンネリング プロトコル バージョン 0

gtpv1

GPRS トンネリング プロトコル バージョン 1

h225ras

ユニキャストを介した H225 RAS

h323

H323 プロトコル

h323callsigalt

H323 コール信号の代替

hp-alarm-mgr

HP Performance data alarm manager

hp-collector

HP Performance data collector

hp-managed-node

HP Performance data managed node

hsrp

Hot Standby Router Protocol(ホット スタンバイ ルータ プロトコル)

http

Hypertext Transfer Protocol

https

セキュア ハイパーテキスト転送プロトコル

ica

ica(Citrix)

icabrowser

icabrowser(Citrix)

icmp

Internet Control Message Protocol(インターネット制御メッセージ プロトコル)

ident

認証サービス

igmpv3lite

SSM 用の UDP を介した IGMP

imap

Internet Message Access Protocol

imap3

インタラクティブ メール アクセス プロトコル 3

imaps

TLS/SSL を介した IMAP

ip *

IP(バージョン 4)

ipass

IPASS

ipinip

IP in IP(カプセル化)

ipsec

IP セキュリティ プロトコル(ESP/AH)

ipsec-msft

Microsoft IPsec NAT-T

ipv6 *

IP(バージョン 6)

ipx

IPX

irc

Internet Relay Chat

irc-serv

IRC-SERV

ircs

TLS/SSL を介した IRC

ircu

IRCU

isakmp

ISAKMP

iscsi

iSCSI

iscsi-target

iSCSI ポート

kazaa2

Kazaa バージョン 2

kerberos

Kerberos

l2tp

Layer 2 Tunnel Protocol(レイヤ 2 トンネル プロトコル)

ldap

Lightweight Directory Access Protocol。

ldap-admin

LDAP 管理サーバ ポート

ldaps

LDAP over TLS/SSL

llc2 *

llc2

login

Remote login(リモート ログイン)

lotusmtap

Lotus Mail Tracking Agent Protocol

lotusnote

Lotus Notes

mgcp

Media Gateway Control Protocol

microsoft-ds

Microsoft-DS

msexch-routing

Microsoft Exchange Routing

msnmsgr

MSN Instant Messenger

msrpc

Microsoft Remote Procedure Call

msrpc-smb-netbios

TCP ポート 445 を介した MSRPC

ms-cluster-net

MS Cluster Net

ms-dotnetster

Microsoft .NETster Port

ms-sna

Microsoft SNA Server/Base

ms-sql

Microsoft SQL

ms-sql-m

Microsoft SQL Monitor

mysql

MySQL

n2h2server

N2H2 フィルタ サービス ポート

ncp

NCP(Novell)

net8-cman

Oracle Net8 Cman/Admin

netbios

Network Basic Input/Output System

netbios-dgm

NETBIOS Datagram Service

netbios-ns

NETBIOS Name Service

netbios-ssn

NETBIOS Session Service

netshow

Microsoft Netshow

netstat

systat のバリアント

nfs

Network File System

nntp

Network News Transfer Protocol

novadigm

Novadigm Enterprise Desktop Manager(EDM)

ntp

Network Time Protocol(ネットワーク タイム プロトコル)

oem-agent

OEM エージェント(Oracle)

oracle

Oracle

oracle-em-vp

Oracle EM/VP

oraclenames

Oracle Names

orasrv

Oracle SQL*Net v1/v2

ospf

Open Shortest Path First(オープン ショーテスト パス ファースト)

pad *

パケット アセンブラ/ディスアセンブラ(PAD)リンク

pcanywhere

Symantec pcANYWHERE

pcanywheredata

pcANYWHEREdata

pcanywherestat

pcANYWHEREstat

pop3

Post Office Protocol

pop3s

TLS/SSL を介した POP3

pppoe

Point-to-Point Protocol over Ethernet(PPPoE)

pptp

Point-to-Point Tunneling Protocol(ポイントツーポイント トンネリング プロトコル)

printer

印刷スプーラ/ldp

pwdgen

パスワード ジェネレータ プロトコル

qmtp

クイック メール転送プロトコル

radius

RADIUS & Accounting

rcmd

Berkeley Software Distribution(BSD)r- コマンド(rsh、rlogin、rexec)

rdb-dbs-disp

Oracle RDB

realmedia

RealNetwork’s Realmedia Protocol

realsecure

ISS Real Secure Console Service Port

rip

Routing Information Protocol(ルーティング情報プロトコル)

router

ローカル ルーティング プロセス

rsrb *

リモート ソース ルート ブリッジング

rsvd

RSVD

rsvp

Resource Reservation Protocol(リソース予約プロトコル)

rsvp-encap

RSVP ENCAPSULATION-1/2

rsvp_tunnel

RSVP トンネル

rtc-pm-port

Oracle RTC-PM ポート

rtelnet

Remote Telnet Service

rtp

Real-Time Protocol(リアルタイム プロトコル)

rtsp

Real Time Streaming Protocol

r-winsock

remote-winsock

secure-ftp

Transport Layer Security/Secure Sockets Layer(TLS/SSL)を介した FTP

secure-http

セキュリティ保護されている HTTP

secure-imap

TLS/SSL を介したインターネット メッセージ アクセス プロトコル

secure-irc

TLS/SSL を介したインターネット リレー チャット

secure-ldap

TLS/SSL を介した Lightweight Directory Access Protocol

secure-nntp

TLS/SSL を介した Network News Transfer Protocol

secure-pop3

TLS/SSL を介した Post Office Protocol

secure-telnet

TLS/SSL を介した Telnet

send

SEND

shell

リモート コマンド

sip

Session Initiation Protocol

sip-tls

Session Initiation Protocol-Transport Layer Security

skinny

Skinny Client Control Protocol

sms

SMS RCINFO/XFER/CHAT

smtp

Simple Mail Transfer Protocol

snapshot

スナップショット ルーティングのサポート

snmp

単純なネットワーク プロトコル

snmptrap

SNMP トラップ

socks

ソケットのネットワーク プロトコル(SOCKS)

sqlnet

Structured Query Language(SQL)*NET for Oracle

sqlserv

SQL サービス

sqlsrv

SQL サービス

sqlserver

Microsoft SQL Server

ssh

セキュア シェル

sshell

SSLshell

ssp

状態同期プロトコル

streamwork

Xing Technology StreamWorks プレーヤー

stun

cisco Serial Tunnel

sunrpc

Sun リモート プロシージャ コール(RPC)

syslog

System Logging Utility

syslog-conn

信頼できる Syslog サービス

tacacs

ログイン ホスト プロトコル(TACACS)

tacacs-ds

TACACS-Database サービス

tarantella

Tarantella

tcp

Transport Control Protocol

Telnet

Telnet

telnets

TLS/SSL を介した Telnet

tftp

Trivial File Transfer Protocol

time

Time

timed

タイム サーバ

tr-rsrb

cisco RSRB

tto

Oracle TTC/SSL

udp

User Datagram Protocol(ユーザ データグラム プロトコル)

uucp

UUCPD/UUCP-RLOGIN

vdolive

VDOLive ストリーミング ビデオ

vofr *

Voice over Frame Relay

vqp

VLAN Query Protocol

webster

Network Dictionary

who

Who のサービス

wins

Microsoft WINS

x11

X Window システム

xdmcp

XDM 制御プロトコル

xwindows *

X-Windows リモート アクセス

ymsgr

Yahoo! Instant Messenger

* このプロトコルは、Supervisor 32/PISA エンジンに搭載されている Catalyst 6500 シリーズ スイッチではサポートされません。

次に、ftp という名前のクラス マップを指定し、一致条件として FTP プロトコルを設定する例を示します

Router(config)# class-map ftp
Router(config-cmap)
#
 match protocol ftp

Cisco IOS Release 15.1(3)T および 12.2(58)SE の Cisco Performance Monitor

次に、Performance Monitor のサービス ポリシーを設定するために、ポリシー インライン コンフィギュレーション モードを使用する例を示します。 このポリシーは、IP プロトコルのイーサネット インターフェイス 0/0 を通過するパケットが、fm-2 という名前のフロー モニタの設定で指定されたパラメータに基づいてモニタされることを指定します。

Router(config)# interface ethernet 0/0
Router(config-if)# service-policy type performance-monitor inline input
Router(config-if-spolicy-inline)# match protocol ip
Router(config-if-spolicy-inline)# flow monitor fm-2
Router(config-if-spolicy-inline)# exit

関連コマンド

コマンド

説明

class-map

指定したクラスへのパケットのマッチングに使用するクラス マップを作成します。

service-policy type performance-monitor

Performance Monitor ポリシーとインターフェイスを関連付けます。

match access-group

指定した ACL に基づいてクラス マップの一致基準を設定します。

match input-interface

指定された入力インターフェイスを一致基準として使用するクラス マップを設定します。

match mpls experimental

指定された experimental フィールドの値を一致基準として使用するクラス マップを設定します。

match precedence

IP precedence 値を一致基準として識別します。

match protocol(NBAR)

NBAR に認識されるプロトコル タイプごとのトラフィックと照合するよう NBAR を設定します。

match qos-group

指定した EXP フィールド値を一致基準として使用するクラス マップを設定します。

match qos-group

特定の Quality of Service(QoS)グループ値を一致基準として指定するには、クラス マップ コンフィギュレーション モードで matchqos-group コマンドを使用します。 クラス マップから特定の QoS グループ値を削除するには、このコマンドの no 形式を使用します。

match qos-group qos-group-value

no match qos-group qos-group-value

構文の説明

qos-group-value

QoS グループ値の識別に使用される、0 ~ 99 からの正確な値。

コマンド デフォルト

一致基準は指定されていません。

コマンド モード


クラス マップ コンフィギュレーション(config-cmap)ポリシー インライン コンフィギュレーション(config-if-spolicy-inline)

コマンド履歴

リリース

変更内容

11.1CC

このコマンドが導入されました。

12.0(5)XE

このコマンドが Cisco IOS Release 12.0(5)XE に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB

このコマンドは、Cisco IOS Release 12.2(31)SB に統合され、Cisco 10000 シリーズ ルータに実装されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。 このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合され、Cisco ASR 1000 シリーズ ルータに実装されました。

15.1(3)T

このコマンドは、Cisco Performance Monitor 用の Cisco IOS Release 15.1(3)T に統合されました。 ポリシー インライン コンフィギュレーション モードのサポートが追加されました。

12.2(58)SE

このコマンドは、Cisco Performance Monitor 用の Cisco IOS Release 12.2(58)SE に統合されました。

使用上のガイドライン

このコマンドは、Flexible NetFlow および Performance Monitor の両方で使用できます。 これらの製品は、このコマンドを発行するコンフィギュレーション モードを開始する際に異なるコマンドを使用します。

matchqos-group コマンドは、特定の QoS グループ値でのパケットのマーキングを識別するために、クラス マップで使用します。 このコマンドは、受信したマルチプロトコル ラベル スイッチング(MPLS)の Experimental(EXP)フィールド値を出力インターフェイスに搬送するのにも使用できます。

qos-group-value 引数は、マーキングにだけ使用します。 QoS グループ値に数学的な意味はありません。 たとえば、2 という qos-group-value は 1 より大きいわけではありません。 値は単に 2 という qos-group-value でマーキングされているパケットが 1 という qos-group-value でマーキングされているパケットとは異なるということを示しているに過ぎません。 これらのパケットの処理は、ユーザが、QoS ポリシー マップ クラス コンフィギュレーション モードでの QoS ポリシーの設定を通じて定義します。

QoS グループ値は、ルータにローカルです。つまり、パケットにマーキングされている QoS グループ値は、パケットがそのルータを離れてもルータから離れません。 パケット内に存在するマーキングが必要な場合は、IP 優先順位設定、IP Diffserv コード ポイント(DSCP)値、またはその他のパケット マーキング手法を使用してください。

このコマンドは、random-detectdiscard-class-based コマンドと一緒に使用できます。

Cisco IOS Release 15.1(3)T および 12.2(58)SE の Cisco Performance Monitor

最初に service-policytypeperformance-monitorinline コマンドを入力する必要があります。

次に、priority50 という名前のサービス ポリシーを設定してインターフェイスに対応付ける例を示します。 この例では、qosgroup5 というクラス マップで、ファスト イーサネット インターフェイス 1/0/0 に入ってきたすべてのパケットについて、QoS グループ値が 5 かどうかを評価します。 受信パケットが QoS グループ値 5 でマーキングされていれば、そのパケットはプライオリティ レベル 50 で処理されます。

Router(config)#
 
class-map qosgroup5
Router(config-cmap)
#
 match qos-group 5
Router(config)#
 
exit
Router(config)#
 
policy-map priority50
Router(config-pmap)#
 
class qosgroup5
Router(config-pmap-c)#
 
priority 50
Router(config-pmap-c)#
 
exit
Router(config-pmap)#
 
exit
Router(config)#
 
interface fastethernet1/0/0
Router(config-if)#
 
service-policy output priority50

次に、Performance Monitor のサービス ポリシーを設定するために、ポリシー インライン コンフィギュレーション モードを使用する例を示します。 このポリシーは、QoS 値 4 の基準に一致するイーサネット インターフェイス 0/0 を通過するパケットが、fm-2 という名前のフロー モニタの設定で指定されたパラメータに基づいてモニタされることを指定します。

Router(config)# interface ethernet 0/0
Router(config-if)# service-policy type performance-monitor inline input
Router(config-if-spolicy-inline)# match qosgroup 4
Router(config-if-spolicy-inline)# flow monitor fm-2
Router(config-if-spolicy-inline)# exit

関連コマンド

コマンド

説明

class-map

指定したクラスへのパケットのマッチングに使用するクラス マップを作成します。

service-policy type performance-monitor

Performance Monitor ポリシーとインターフェイスを関連付けます。

policy-map

1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または修正し、サービス ポリシーを指定します。

random-detect discard-class-based

WRED の基礎をパケットのクラス廃棄値にします。

service-policy

入力インターフェイスまたは VC、あるいは出力インターフェイスまたは VC に、そのインターフェイスまたは VC のサービス ポリシーとして使用するポリシー マップを対応付けます。

set precedence

トラフィック クラス内のパケットの IP 優先順位値を指定します。

set qos-group

後からパケットの分類に使用できるグループ ID を設定します。

mls qos(グローバル コンフィギュレーション モード)

Quality of Service(QoS)機能を全体的にイネーブルにするには、グローバル コンフィギュレーション モードで mlsqos コマンドを使用します。 QoS 機能をグローバルにディセーブルにするには、このコマンドの no 形式を使用します。

mls qos

no mls qos

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

QoS はグローバルにディセーブルです。

コマンド モード


グローバル コンフィギュレーション

コマンド履歴

リリース

変更内容

12.2(14)SX

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(17d)SXB

このコマンドは Supervisor Engine 2 に実装され、Cisco IOS Release 12.2(17d)SXB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

QoS がグローバルにイネーブルの場合は、QoS がディセーブル化されているインターフェイスを除いて、すべてのインターフェイスで QoS がイネーブルになります。 QoS がグローバルにディセーブルの場合は、すべてのトラフィックが QoS パススルー モードで渡されます。

ポート キューイング モードでは、ポリシー フィーチャ カード(PFC)の QoS(マーキングおよびポリシング)がディセーブルで、パケットのタイプ オブ サービス(ToS)およびサービス クラス(CoS)は PFC によって変更されません。 受信および送信に関するすべてのキューイングは、着信パケットの QoS タグに基づいて行われます。この QoS タグは、着信 CoS に基づきます。

802.1Q またはスイッチ間リンク(ISL)でカプセル化したポート リンクでは、キューイングはパケット 802.1Q または ISL CoS に基づきます。

ルータのメイン インターフェイスまたはアクセス ポートでは、キューイングは設定されたポート単位の CoS(デフォルト CoS は 0)に基づいて行われます。

このコマンドは、オフの状態のすべてのインターフェイス上で Ternary Content Addressable Memory(TCAM)QoS をイネーブルまたはディセーブルにできます。

次に、QoS をグローバルにイネーブルにする例を示します。

Router(config)# mls qos
Router(config)#

次に、Cisco 7600 シリーズ ルータで QoS を全体的にディセーブルにする例を示します。

Router(config)# no mls qos
Router(config)#

関連コマンド

コマンド

説明

mls qos(インターフェイス コンフィギュレーション モード)

インターフェイスでの QoS 機能をイネーブルにします。

show mls qos

MLS QoS 情報を表示します。

mls qos(インターフェイス コンフィギュレーション モード)

インターフェイスの Quality of Service(QoS)機能をイネーブルにするには、インターフェイス コンフィギュレーション コマンド モードで mlsqos コマンドを使用します。 インターフェイスで QoS 機能をディセーブルにするには、このコマンドの no 形式を使用します。

mls qos

no mls qos

構文の説明

このコマンドには引数またはキーワードはありません。

コマンド デフォルト

イネーブル

コマンド モード


インターフェイス コンフィギュレーション

コマンド履歴

リリース

変更内容

12.2(14)SX

このコマンドのサポートが Supervisor Engine 720 に追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

使用上のガイドライン

このコマンドは、Supervisor Engine 2 が搭載された Cisco 7600 シリーズ ルータではサポートされません。

CLI を使用すると、OC-12 ATM OSM の WAN ポートおよびチャネライズド OSM の WAN ポートに PFC ベースの QoS を設定できますが、PFC ベースの QoS はこれらの OSM の WAN ポートではサポートされていません。

QoS をグローバルにディセーブルにすると、すべてのインターフェイスでディセーブルになります。

このコマンドは、インターフェイスの TCAM QoS(分類、マーキング、およびポリシング)をイネーブルまたはディセーブルにします。

次に、インターフェイス上で QoS をイネーブルにする例を示します。

Router(config-if)# mls qos

関連コマンド

コマンド

説明

mls qos(グローバル コンフィギュレーション モード)

QoS 機能をグローバルにイネーブルにします。

show mls qos

MLS QoS 情報を表示します。