ネットワーク管理コンフィギュレーション ガイド、Cisco IOS XE Release 3.6E(Catalyst 3850 スイッチ)
Web Cache Communication Protocol を使用したキャッシュ サービスの設定
Web Cache Communication Protocol を使用したキャッシュ サービスの設定

Web Cache Communication Protocol を使用したキャッシュ サービスの設定

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、http:/​/​www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

WCCP の前提条件

スイッチで WCCP を設定する前に、次の設定要件に従ってください。

  • 同じサービス グループ内のアプリケーション エンジンおよびスイッチは、WCCP 対応のスイッチに直接接続された同一サブネットワーク内に存在する必要があります。

  • クライアント、アプリケーション エンジン、およびレイヤ 3 インターフェイスとしてのサーバ(ルーテッド ポートおよびスイッチ仮想インターフェイス(SVI))に接続されたスイッチ インターフェイスを設定します。 WCCP パケットのリダイレクトが機能するためには、サーバ、アプリケーション エンジン、およびクライアントが、異なるサブネット上に存在する必要があります。

  • 各アプリケーション エンジンに 1 つのマルチキャスト アドレスを設定するときは、予約されていないマルチキャスト アドレスだけを使用します。

  • WCCP エントリおよび PBR エントリは、同じ TCAM リージョンを使用します。 WCCP は、PBR(アクセス、ルーティング、デュアル IPv4/v6 ルーティング)をサポートするテンプレート上でだけサポートされます。

  • TCAM エントリを WCCP エントリの追加に使用できない場合、パケットはリダイレクトされず、標準ルーティング テーブルを使用して転送されます。

  • 使用可能な PBR ラベルの数は、WCCP 入力方法でイネーブルになるインターフェイスが増えるにつれて減っていきます。 サービス グループをサポートする各インターフェイスでは、ラベルが 1 つ消費されます。 WCCP ラベルは PBR ラベルから取得されます。 PBR と WCCP 間で使用可能なラベルを監視および管理する必要があります。 ラベルが使用できないと、スイッチはサービス グループを追加できなくなります。 ただし、別のインターフェイスに同じ一連のサービス グループがある場合、新しいラベルは必要にならず、グループをインターフェイスに追加できます。

  • スタック メンバー スイッチで設定されたルーティング最大伝送単位(MTU)サイズは、クライアント MTU サイズより長い必要があります。 アプリケーション エンジンに接続されたポートで設定された MAC レイヤ MTU サイズは、GRE トンネル ヘッダー バイトを考慮する必要があります。

WCCP に関する制約事項

サポートしない WCCP 機能

次の WCCP 機能は、このソフトウェア リリースでサポートされていません。

  • ip wccp redirect out インターフェイス コンフィギュレーション コマンドを使用して設定された発信インターフェイスでのパケットのリダイレクト

  • パケット リダイレクトの GRE 転送方式

  • GRE リダイレクトおよび GRE リターン

  • ロードバランシング用のハッシュ割り当て方式

  • WCCP の SNMP サポート

  • ハードウェアでのハッシュ割り当て マスク割り当てのみを使用したロード バランスの実行

  • フラグメント化されたパケットのリダイレクト これは、セキュリティ機能です。

全般的な制約事項

  • サービス グループの最大数:8 入力および 8 出力。

  • 同じスイッチ インターフェイス上では、WCCP と VPN ルーティングおよび転送(VRF)を設定できません。

  • 同じスイッチ インターフェイス上では、WCCP および PBR を設定できません。

  • 同じスイッチ インターフェイス上では、WCCP およびプライベート VLAN(PVLAN)を設定できません。

  • ip wccp redirect exclude in コマンドは、出力 WCCP 方式から入力パケットを除外できるようにします。 これは、CE へのインターフェイスでは必要ではありません。

  • キャッシュ エンジンが使用できない場合は、一致するパケットはドロップされます。 これは、クローズ グループのサポートです。 VRF 認識 WCCP のサポート、IPv6 WCCP のサポートはありません。

  • デバイスを ip wccp check services all コマンドで設定すると、リダイレクト ACL がパケットと一致しなかった場合、次のプライオリティのサービス グループと照合されます。

WCCP に関する情報

WCCP の概要


(注)  


この機能を使用するには、デバイス上で IP Services フィーチャー セットが稼働している必要があります。


WCCP はシスコが開発したコンテンツ ルーティング技術です。WCCP を使用すると広域アプリケーション エンジン(以降、アプリケーション エンジンと呼ぶ)をネットワーク インフラストラクチャに統合できます。 アプリケーション エンジンは、頻繁にアクセスのあるコンテンツを透過的に格納し、その同じコンテンツへの要求を満たし、サーバから繰り返し伝送されることを防ぎます。 アプリケーション エンジンは、コンテンツ配信を加速させ、最大限のスケーラビリティとコンテンツの可用性を実現します。 サービスプロバイダー ネットワークのアクセス ポイント(POP)で、WCCP およびアプリケーション エンジン ソリューションを展開できます。 エンタープライズ ネットワークでは、地域サイトまたは小規模ブランチ オフィスで WCCP およびアプリケーション エンジン ソリューションを展開できます。

WCCP およびシスコのキャッシュ エンジン(または WCCP が稼働している他のアプリケーション エンジン)は、ネットワークでのトラフィック パターンをローカライズし、コンテンツ要求がローカルで実現されるようにします。

WCCP により、サポート対象のシスコ ルータおよびswitchesは、コンテンツ要求を透過的にリダイレクトできます。 透過リダイレクトを使用すると、ユーザは使用しているブラウザが Web プロキシを使用するように設定する必要がありません。 代わりに、ターゲット URL を使用してコンテンツを要求でき、その要求は自動的にアプリケーション エンジンにリダイレクトされます。 透過という用語は、エンド ユーザが、自分の要求したファイル(Web ページなど)が、もとの指定したサーバからではなくアプリケーション エンジンから送信されるのを知らないという意味です。

アプリケーション エンジンが要求を受け取ると、自身のローカル キャッシュからサービスしようとします。 要求された情報が存在しない場合、アプリケーション エンジンは別個の要求をエンド サーバに送信し、要求された情報を取得します。 取得した情報は、アプリケーション エンジンが要求元のクライアントに転送するとともに、その後の要求に応えるため、情報をキャッシュします。

WCCP では、アプリケーションエンジン クラスタ(一連のアプリケーション エンジン)は、、複数のルータまたはswitchesにサービスできます。

WCCP メッセージ交換

次の一連のイベントは、WCCP メッセージ交換について説明します。

  1. アプリケーション エンジンは、WCCP を使用して IP アドレスを WCCP 対応switchに送信し、Here I am メッセージを通して自己の存在を伝えます。 switchおよびアプリケーション エンジンは、UDP ポート 2048 に基づき、制御チャネルを介して互いに通信します。

  2. WCCP 対応switchは、アプリケーション エンジンの IP 情報を使用してクラスタ ビュー(クラスタ内のアプリケーション エンジンのリスト)を作成します。 このビューが、I see you メッセージでクラスタ内の各アプリケーション エンジンに送信すると、本質的にすべてのアプリケーション エンジンが互いの存在を認識するようになります。 クラスタのメンバーシップが一定時間同じままになった後で、安定したビューが確立されます。

  3. 安定したビューが確立されると、クラスタ内の低い IP アドレスを持つアプリケーション エンジンが指定アプリケーション エンジンとして選択されます。

WCCP ネゴシエーション

WCCP プロトコル メッセージを交換する際、指定アプリケーション エンジンおよび WCCP 対応switchは次の項目をネゴシエートします。

  • 転送方式(switchがパケットをアプリケーション エンジンに転送するときに使用される方式)。 switchは、パケット宛先 MAC アドレスをターゲット アプリケーション エンジン MAC アドレスに置き換えて、レイヤ 2 ヘッダーを書き換えます。 次にスイッチは、パケットをアプリケーション エンジンに転送します。 この転送方式では、ターゲット アプリケーション エンジンがレイヤ 2 でswitchに直接接続されている必要があります。

  • 割り当て方式(パケットをクラスタ内のアプリケーション エンジン間に配信するときに使用される方式)。 switchは宛先 IP アドレス、送信元 IP アドレス、宛先レイヤ 4 ポート、および送信元レイヤ 4 ポートの一部のビットを使用して、リダイレクトされたパケットを受け取るアプリケーション エンジンを判別します。

  • パケット戻し方式(パケットをアプリケーション エンジンから通常の転送用switchに戻すときに使用される方式)。 アプリケーション エンジンがパケットを拒否し、パケット戻し機能を起動するのには以下の理由があります。

    • アプリケーション エンジンが過負荷となり、パケットにサービスする余裕がない。

    • アプリケーション エンジンがサーバからエラー メッセージ(プロトコル エラーや認証エラーなど)を受け取り、ダイナミック クライアント バイパス機能を使用している。 バイパスは、クライアントがアプリケーション エンジンをバイパスし、サーバに直接接続できるようにします。

アプリケーション エンジンはパケットを WCCP 対応switchに戻し、アプリケーション エンジンが存在しないかのようにサーバに転送します。 アプリケーション エンジンは、再接続試行を代行受信しません。 このようにして、アプリケーション エンジンは効率的にアプリケーション エンジンへのパケットのリダイレクトをキャンセルし、バイパス フローを作成します。 戻し方式がレイヤ 2 書き換えである場合、パケットはハードウェア内でターゲット サーバに転送されます。 サーバが情報に応答しているとき、switchは通常のレイヤ 3 転送を使用して、情報を要求しているクライアントに戻します。

MD5 セキュリティ

WCCP は各プロトコル メッセージでオプションのセキュリティ コンポーネントを提供し、switchとアプリケーション エンジン間のメッセージで MD5 認証をswitchが使用できるようにします。 (switchの認証がイネーブルになっているとき)MD5 で認証されないメッセージは、switchによって廃棄されます。 パスワード文字列は、MD5 値と組み合され、switchとアプリケーション エンジン間の接続のセキュリティを確立します。 各アプリケーション エンジンで同じパスワードを設定する必要があります。

パケットのリダイレクトおよびサービス グループ

WCCP を設定して、FTP、プロキシ Web キャッシュ処理、音声およびビデオアプリケーションなど、リダイレクト用トラフィックを分類できます。 この分類はサービス グループと呼ばれ、プロトコル タイプ(TCP または UDP)およびレイヤ 4 送信元ポート番号と宛先ポート番号に基づきます。 サービス グループは、TCP ポート 80 を意味する、Web キャッシュなどの Well-known 名または 0 ~ 99 のサービス番号のいずれかで識別されます。 サービス グループは、プロトコルおよびレイヤ 4 ポート番号にマッピングするように設定され、独立して確立および維持されます。 WCCP は、アプリケーション エンジンに加入して分類基準を動的に提供するダイナミック サービス グループを許可します。

スイッチswitchたはスイッチswitchスタックでは最大 8 つまでのサービス グループを、サービス グループにつき 32 までのキャッシュ エンジンを設定できます。 WCCP のグループ定義には、サービス グループのプライオリティがあります。 WCCP は、プライオリティを使用して、switch ハードウェアのサービス グループを設定します。 たとえば、サービス グループ 1 はプライオリティ 100 で、宛先ポート 80 を探していて、サービス グループ 2 はプライオリティ 50 で、送信元ポート 80 を探している場合、送信元および宛先ポート 80 の着信パケットは、サービス グループ 1 を使用して転送されます。これは、サービス グループ 1 の方がプライオリティが高いためです。

WCCP は各サービス グループのアプリケーション エンジンのクラスタをサポートします。 リダイレクトされたトラフィックは、アプリケーション エンジンの 1 つに送信可能です。 switchは、サービス グループのクラスタ内のアプリケーション エンジン間で、トラフィックのロードバランシングのマスク割り当て方式をサポートします。

WCCP がswitch上で設定された後、switchはクライアントから受信したすべてのサービス グループ パケットをアプリケーション エンジンに転送します。 ただし、次のパケットはリダイレクトされません。

  • アプリケーションエンジンから発信され、サーバに宛てられたパケット

  • アプリケーション エンジンから発信され、クライアントに宛てられたパケット

  • アプリケーション エンジンにより返送または拒否されたパケット。 これらのパケットはサーバに送信されます。

プロトコル メッセージの送受信用に、サービス グループにつき 1 つのマルチキャスト アドレスを設定できます。 マルチキャスト アドレスが 1 つの場合、アプリケーション エンジンは通知を 1 つのアドレスに送信することになり、たとえば 225.0.0.0 など、サービス グループのすべてのルータにカバレッジを提供します。 ルータを動的に追加および削除する場合、1 つのマルチキャスト アドレスを使用することで、コンフィギュレーションが簡単になります。これは、特に WCCP ネットワークのすべてのデバイスのアドレスを入力する必要がないためです。

ルータ グループ リストを使用すれば、アプリケーション エンジンから受け取ったプロトコル パケットを検証できます。 グループ リストのアドレスに一致するパケットは処理され、グループ リスト アドレスに一致しないパケットはドロップされます。

特定クライアント、サーバ、またはクライアントとサーバのペアのキャッシングをディセーブルにするには、WCCP リダイレクト アクセス コントロール リスト(ACL)を使用します。 リダイレクト ACL に一致しないパケットはキャッシュをバイパスし、通常通りに転送されます。

WCCP パケットがリダイレクトされる前、switchはインターフェイス上に設定されているすべての着信機能に関連した ACL をテストし、パケットが ACL 内のエントリと一致するかどうかによって、パケットの転送を許可または拒否します。


(注)  


WCCP リダイレクト リストでは、許可と拒否の両方の ACL エントリがサポートされます。

パケットがリダイレクトされると、リダイレクトされたインターフェイスに関連付けられた出力 ACL がパケットに適用されます。 元のポートに関連付けられた ACL は、リダイレクトされたインターフェイス上で必須出力 ACL を特に設定しない限り適用されません。

WCCP およびスイッチ スタック

switch スタックの WCCP サポート機能は、スタンドアロン switchの場合と同じです。 WCCP の設定情報は、スタック内のすべてのswitchesに伝播されます。 スタック マスターを含むスタック内のすべてのswitchesでは、情報が処理され、ハードウェアがプログラムされます

スタック マスターは、次の WCCP 機能を実行します。

  • WCCP 対応インターフェイスからのプロトコル パケットを受信し、そのパケットをスタックの WCCP 対応インターフェイスに送信します。

  • WCCP 設定を処理し、情報をすべてのスタック メンバに伝播します。

  • WCCP 情報を、スタックに加入しているすべてのswitchに配信します。

  • 処理する WCCP 情報を使用して、ハードウェアをプログラミングします。

スタック メンバーはマスター switchから WCCP 情報を受け取り、ハードウェアをプログラミングします。

WCCP の設定方法

WCCP のデフォルト設定

機能 デフォルト設定
WCCP イネーブル ステート WCCP サービスはディセーブルです。
プロトコル バージョン WCCPv2
インターフェイス上で受信したトラフィックのリダイレクト ディセーブル

キャッシュ サービスのイネーブル化

WCCP パケット リダイレクトが機能するために、クライアントに接続されたswitch インターフェイスが着信パケットをリダイレクトするように設定する必要があります。

この手順では、ルーテッド ポートでこれらの機能を設定する方法を示します。 これらの機能を SVI で設定するには、手順に従った設定例を参照してください。

キャッシュ サービスをイネーブルにしたり、マルチキャスト グループ アドレスまたはグループ リストを設定したり、ルーテッド インターフェイスを設定したり、クライアントから受信した着信パケットをアプリケーション エンジンにリダイレクトしたり、マルチキャスト アドレスを受信するようにインターフェイスをイネーブルにしたり、パスワードを設定したりするには、次の手順を実行します。 この手順は必須です。

はじめる前に

SDM テンプレートを設定し、デバイスをリブートします。

手順の概要

    1.    enable

    2.    configure terminal

    3.    ip wccp {web-cache | service-number} [group-address groupaddress] [group-list access-list] [redirect-list access-list] [password encryption-number password]

    4.    interface interface-id

    5.    no switchport

    6.    ip address ip-address subnet-mask

    7.    no shutdown

    8.    exit

    9.    interface interface-id

    10.    no switchport

    11.    ip address ip-address subnet-mask

    12.    no shutdown

    13.    ip wccp {web-cache | service-number} redirect in

    14.    ip wccp {web-cache | service-number} group-listen

    15.    exit

    16.    end

    17.    show running-config

    18.    copy running-config startup-config


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Switch> enable
    
    
     

    特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

     

    ステップ 2configure terminal


    例:
    
    Switch# configure terminal
    
    
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3ip wccp {web-cache | service-number} [group-address groupaddress] [group-list access-list] [redirect-list access-list] [password encryption-number password]


    例:
    
    Switch(config)# ip wccp web-cache
    
     

    キャッシュ サービスをイネーブルにし、アプリケーション エンジンで定義されたダイナミック サービスに対応するサービス番号を指定します。 デフォルトでは、この機能はディセーブルになっています。

    (任意)group-address groupaddress には、switchesおよびアプリケーション エンジンがサービス グループに加入するときに使用するマルチキャスト グループ アドレスを指定します。

    (任意)group-list access-list には、マルチキャスト グループ アドレスが使用されない場合、サービス グループに加入しているアプリケーション エンジンに対応する有効な IP アドレスのリストを指定します。

    (任意)redirect-list access-list には、特定ホストのリダイレクト サービスまたはホストから特定パケットを指定します。

    (任意)password encryption-number password には、暗号化番号を指定します。 指定できる範囲は 0 ~ 7 です。 暗号化しない場合は 0、独自の場合は 7 を使用します。 7 文字以内でパスワード名を指定します。 switchは、パスワードと MD5 認証値を組み合わせて、switchとアプリケーション エンジンとの接続にセキュリティを確保します。 デフォルトでは、パスワードは設定されておらず、認証も実行されていません。

    各アプリケーション エンジンで同じパスワードを設定する必要があります。

    認証がイネーブルになっている場合、switchは認証されないメッセージを廃棄します。

     
    ステップ 4interface interface-id


    例:
    Switch(config)# interface gigabitethernet1/0/1
    
     

    アプリケーション エンジンまたはサーバに接続されたインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 5no switchport


    例:
    Switch(config-if)# no switchport
    
     

    レイヤ 3 モードを開始します。

     
    ステップ 6ip address ip-address subnet-mask


    例:
    Switch(config-if)# ip address 172.20.10.30 255.255.255.0
    
     

    IP アドレスとサブネット マスクを設定します。

     
    ステップ 7no shutdown


    例:
    Switch(config-if)# no shutdown
    
     

    インターフェイスをイネーブルにします。

     
    ステップ 8exit


    例:
    Switch(config-if)# exit
    
     

    グローバル コンフィギュレーション モードに戻ります。 アプリケーション エンジンとサーバごとにステップ 4 ~ 8 を繰り返します。

     
    ステップ 9interface interface-id


    例:
    Switch(config)# interface gigabitethernet1/0/2
    
     

    クライアントに接続するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 10no switchport


    例:
    Switch(config-if)# no switchport
    
     

    レイヤ 3 モードを開始します。

     
    ステップ 11ip address ip-address subnet-mask


    例:
    Switch(config-if)# ip address 175.20.20.10 255.255.255.0
    
     

    IP アドレスとサブネット マスクを設定します。

     
    ステップ 12no shutdown


    例:
    Switch(config-if)# no shutdown
    
     

    インターフェイスをイネーブルにします。

     
    ステップ 13ip wccp {web-cache | service-number} redirect in


    例:
    Switch(config-if)# ip wccp web-cache redirect in
    
     

    クライアントから受信したパケットをアプリケーション エンジンにリダイレクトします。 クライアントに接続されているインターフェイス上でイネーブルにします。

     
    ステップ 14ip wccp {web-cache | service-number} group-listen


    例:
    Switch(config-if)# ip wccp web-cache group-listen
    
     

    (任意)マルチキャスト グループ アドレスを使用するとき、group-listen キーワードはインターフェイスをイネーブルにしてマルチキャスト アドレスをリッスンします。 アプリケーション エンジンに接続されているインターフェイス上でイネーブルにします。

     
    ステップ 15exit


    例:
    Switch(config-if)# exit
    
     

    グローバル コンフィギュレーション モードに戻ります。 クライアントごとにステップ 9 ~ 15 を繰り返します。

     
    ステップ 16end


    例:
    
    Switch(config)# end
    
    
     

    特権 EXEC モードに戻ります。

     
    ステップ 17show running-config


    例:
    
    Switch# show running-config 
    
    
     

    入力を確認します。

     
    ステップ 18copy running-config startup-config


    例:
    Switch# copy running-config startup-config 
    
    
     

    (任意)コンフィギュレーション ファイルに設定を保存します。

     

    設定例

    次に、ルーテッド インターフェイスを設定し、マルチキャスト グループ アドレスとリダイレクト アクセス リストでキャッシュ サービスをイネーブルにする例を示します。 ギガビット イーサネット ポート 1 はアプリケーション エンジンに接続され、IP アドレス 172.20.10.30 のルーテッド ポートとして設定され、再イネーブル化されています。 ギガビット イーサネット ポート 2 はインターネット経由でサーバに接続され、IP アドレス 175.20.20.10 のルーテッド ポートとして設定され、再イネーブル化されています。 ギガビット イーサネット ポート 3 ~ 6 はクライアントに接続され、IP アドレス 175.20.30.20、175.20.40.30、175.20.50.40、および 175.20.60.50 のルーテッド ポートとして設定されています。 switchはマルチキャスト トラフィックを受信し、クライアント インターフェイスから受信したパケットをアプリケーション エンジンにリダイレクトします。

    Switch# configure terminal
    Switch(config)# ip wccp web-cache group-address 224.1.1.100 redirect list 12
    Switch(config)# access-list 12 permit host 10.1.1.1
    Switch(config)# interface gigabitethernet1/0/1
    Switch(config-if)# no switchport
    Switch(config-if)# ip address 172.20.10.30 255.255.255.0
    Switch(config-if)# no shutdown
    Switch(config-if)# ip wccp web-cache group-listen
    Switch(config-if)# exit
    Switch(config)# interface gigabitethernet1/0/2
    Switch(config-if)# no switchport
    Switch(config-if)# ip address 175.20.20.10 255.255.255.0
    Switch(config-if)# no shutdown
    Switch(config-if)# exit
    Switch(config)# interface gigabitethernet1/0/3
    Switch(config-if)# no switchport
    Switch(config-if)# ip address 175.20.30.20 255.255.255.0
    Switch(config-if)# no shutdown
    Switch(config-if)# ip wccp web-cache redirect in
    Switch(config-if)# exit
    Switch(config)# interface gigabitethernet1/0/4
    Switch(config-if)# no switchport
    Switch(config-if)# ip address 175.20.40.30 255.255.255.0
    Switch(config-if)# no shutdown
    Switch(config-if)# ip wccp web-cache redirect in
    Switch(config-if)# exit
    Switch(config)# interface gigabitethernet1/0/5
    Switch(config-if)# no switchport
    Switch(config-if)# ip address 175.20.50.40 255.255.255.0
    Switch(config-if)# no shutdown
    Switch(config-if)# ip wccp web-cache redirect in
    Switch(config-if)# exit
    Switch(config)# interface gigabitethernet1/0/6
    Switch(config-if)# no switchport
    Switch(config-if)# ip address 175.20.60.50 255.255.255.0
    Switch(config-if)# no shutdown
    Switch(config-if)# ip wccp web-cache redirect in
    Switch(config-if)# exit
    

    次に、SVI を設定し、マルチキャスト グループ リストでキャッシュ サービスをイネーブルにする例を示します。 VLAN 299 は、IP アドレス 175.20.20.10 で作成および設定されています。 ギガビット イーサネットのポート 1 をインターネット経由でサーバに接続し、VLAN 299 のアクセス ポートとして設定します。 VLAN 300 は、IP アドレス 172.20.10.30 で作成および設定されています。 ギガビット イーサネット ポート 2 はアプリケーション エンジンに接続され、VLAN 300 のアクセス ポートとして設定されています。 VLAN 301 は、IP アドレス 175.20.30.50 で作成および設定されています。 クライアントに接続されているファスト イーサネット ポート 3 ~ 6 は、VLAN 301 のアクセス ポートとして設定されています。 switchは、クライアント インターフェイスから受信したパケットをアプリケーション エンジンにリダイレクトします。


    (注)  


    WCCP リダイレクト リストでは、許可と拒否の両方の ACL エントリがサポートされます。
    Switch# configure terminal
    Switch(config)# ip wccp web-cache group-list 15
    Switch(config)# access-list 15 permit host 171.69.198.102
    Switch(config)# access-list 15 permit host 171.69.198.104
    Switch(config)# access-list 15 permit host 171.69.198.106
    Switch(config)# vlan 299
    Switch(config-vlan)# exit
    Switch(config)# interface vlan 299
    Switch(config-if)# ip address 175.20.20.10 255.255.255.0
    Switch(config-if)# exit
    Switch(config)# interface gigabitethernet1/0/1
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport access vlan 299
    Switch(config)# vlan 300
    Switch(config-vlan)# exit
    Switch(config)# interface vlan 300
    Switch(config-if)# ip address 171.69.198.100 255.255.255.0
    Switch(config-if)# exit
    Switch(config)# interface gigabitethernet1/0/2
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport access vlan 300
    Switch(config-if)# exit
    Switch(config)# vlan 301
    Switch(config-vlan)# exit
    Switch(config)# interface vlan 301
    Switch(config-if)# ip address 175.20.30.20 255.255.255.0
    Switch(config-if)# ip wccp web-cache redirect in
    Switch(config-if)# exit
    Switch(config)# interface range gigabitethernet1/0/3 - 6
    Switch(config-if-range)# switchport mode access
    Switch(config-if-range)# switchport access vlan 301
    Switch(config-if-range)# exit
    
    次の作業

    キャッシュ サービスをディセーブルにするには、no ip wccp web-cache グローバル コンフィギュレーション コマンドを使用します。 着信パケット リダイレクトをディセーブルにするには、no ip wccp web-cache redirect in インターフェイス コンフィギュレーション コマンドを使用します。 この手順を完了した後、ネットワークでアプリケーション エンジンを設定します。

    関連コンセプト

    その他の関連資料

    関連資料

    関連項目 マニュアル タイトル

    SNMP コマンド

    Network Management Command Reference, Cisco IOS XE Release 3E

    エラー メッセージ デコーダ

    説明 Link

    このリリースのシステム エラー メッセージを調査し解決するために、エラー メッセージ デコーダ ツールを使用します。

    https:/​/​www.cisco.com/​cgi-bin/​Support/​Errordecoder/​index.cgi

    標準および RFC

    標準/RFC タイトル

    なし

    -

       

    MIB

    MIB MIB のリンク

    本リリースでサポートするすべての MIB

    選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

    http:/​/​www.cisco.com/​go/​mibs

    テクニカル サポート

    説明 リンク

    シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

    お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

    シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​support

    Web Cache Communication Protocol の機能の履歴と情報

    リリース

    変更内容

    Cisco IOS XE 3.2SECisco IOS XE 3.2SE

    この機能が導入されました。