VLAN コンフィギュレーション ガイド Cisco IOS リリース 15.2(2) E(Catalyst 2960-XR スイッチ)
IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングの設定
IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングの設定

目次

IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングの設定

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、http:/​/​www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

トンネリング設定の前提条件

ここでは、IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングを設定するための前提条件と考慮事項について説明します。

IEEE 802.1Q トンネリング

IEEE 802.1Q トンネリングはレイヤ 2 パケット スイッチングで適切に動作しますが、一部のレイヤ 2 機能およびレイヤ 3 スイッチングの間には非互換性があります。

  • トンネル ポートはルーテッド ポートにできません。

  • IEEE 802.1Q ポートを含む VLAN では IP ルーティングがサポートされません。 トンネル ポートから受信したパケットは、レイヤ 2 情報だけに基づいて転送されます。 トンネル ポートを含むswitch仮想インターフェイス(SVI)でルーティングがイネーブルになっている場合、トンネル ポートから受信したタグなし IP パケットは、switchに認識されてルーティングされます。 カスタマーは、ネイティブ VLAN を介してインターネットにアクセスできます。 このアクセスが必要ない場合は、トンネル ポートを含む VLAN で SVI を設定しないでください。

  • フォールバック ブリッジングは、トンネル ポートでサポートされません。 トンネル ポートから受信したすべての IEEE 802.1Q タグ付きパケットは IP 以外のパケットとして扱われるので、トンネル ポートが設定されている VLAN でフォールバック ブリッジングがイネーブルである場合、IP パケットは VLAN を越えて不適切にブリッジングされます。 このため、トンネル ポートを含む VLAN ではフォールバック ブリッジングをイネーブルにしないでください。

  • トンネル ポートでは IP アクセス コントロール リスト(ACL)がサポートされません。

  • レイヤ 3 の Quality of Service(QoS)ACL およびレイヤ 3 情報に関連する他の QoS 機能は、トンネル ポートではサポートされていません。 MAC ベース QoS はトンネル ポートでサポートされます。

  • IEEE 802.1Q 設定が EtherChannel ポート グループ内で矛盾しない場合、EtherChannel ポート グループにはトンネル ポートとの互換性があります。

  • ポート集約プロトコル(PAgP)、Link Aggregation Control Protocol(LACP)、単一方向リンク検出(UDLD)は、IEEE 802.1Q トンネル ポートでサポートされます。

  • トンネル ポートとトランク ポートで非対称リンクを手動で設定する必要があるので、ダイナミック トランキング プロトコル(DTP)には IEEE 802.1Q トンネリングとの互換性がありません。

  • VLAN トランキング プロトコル(VTP)は、非対称リンクで接続されているデバイス間、またはトンネルを通して通信を行うデバイス間で動作しません。

  • IEEE 802.1Q トンネル ポートでは、ループバック検出がサポートされます。

  • IEEE 802.1Q トンネル ポートとしてポートを設定すると、スパニングツリー ブリッジ プロトコル データ ユニット(BPDU)フィルタリングがインターフェイスで自動的にイネーブルになります。 Cisco Discovery Protocol(CDP)および Layer Link Discovery Protocol(LLDP)は、インターフェイスで自動的にディセーブルになります。

レイヤ 2 プロトコル トンネリング

  • switchでは、CDP、STP(Multiple STP(MSTP)を含む)、VTP のトンネリングがサポートされます。 プロトコル トンネリングはデフォルトでディセーブルになっていますが、IEEE 802.1Q トンネル ポート、またはアクセス ポートでプロトコルごとにイネーブルにできます。

  • switchでは、switchport モードが dynamic auto または dynamic desirable に設定されているポートにおいて、レイヤ 2 プロトコル トンネリングがサポートされません。

  • DTP はレイヤ 2 プロトコル トンネリングと互換性がありません。

  • サービスプロバイダー ネットワークのアウトバウンド側のエッジ switchesでは、適切なレイヤ 2 プロトコル情報および MAC アドレス情報が復元され、同じメトロ VLAN のすべてのトンネル ポートおよびアクセス ポートにパケットが転送されます。

  • サードパーティ ベンダー switchesとの相互運用性のため、switchではレイヤ 2 プロトコルトンネル バイパス機能がサポートされます。 バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー switchesに制御 PDU が透過的に転送されます。 switchの入力ポートでレイヤ 2 プロトコル トンネリングがイネーブルになっている場合、出力トランク ポートは特殊なカプセル化を使用してトンネリング パケットを転送します。 出力トランク ポートでもレイヤ 2 プロトコル トンネリングをイネーブルにすると、この動作がバイパスされて、switchは加工や変更を行わずに制御 PDU を転送します。

  • switchでは、ポイントツーポイント ネットワーク トポロジのエミュレートに関して PAgP、LACP、UDLD のトンネリングがサポートされます。 プロトコル トンネリングはデフォルトでディセーブルになっていますが、IEEE 802.1Q トンネル ポート、またはアクセス ポートでプロトコルごとにイネーブルにできます。

  • PAgP トンネリングまたは LACP トンネリングの場合は、リンク障害検出を高速にするため、インターフェイスで UDLD もイネーブルにすることを推奨します。

  • PAgP パケット、LACP パケット、UDLD パケットのレイヤ 2 プロトコル トンネリングでは、ループバック検出はサポートされません。

  • IEEE 802.1Q 設定が EtherChannel ポート グループ内で矛盾しない場合、EtherChannel ポート グループにはトンネル ポートとの互換性があります。

  • 独自の宛先 MAC アドレスでカプセル化された PDU が、レイヤ 2 トンネリングがイネーブルになっているトンネル ポートまたはアクセス ポートから受信される場合、トンネル ポートは、ループを防止するためにシャットダウンされます。 このポートは、プロトコル用に設定されたシャットダウンしきい値に達した場合にもシャットダウンされます。 shutdown コマンドに続けて no shutdown コマンドを入力すると、ポートを手動で再びイネーブルにできます。 errdisable recovery がイネーブルである場合は、指定された時間間隔で動作が再試行されます。

  • カプセル化が解除された PDU だけがカスタマー ネットワークに転送されます。 サービスプロバイダー ネットワーク上で動作しているスパニングツリー インスタンスでは、BPDU がトンネル ポートに転送されません。 CDP パケットはトンネル ポートから転送されません。

  • インターフェイスでプロトコル トンネリングがイネーブルである場合は、カスタマー ネットワークによって生成された PDU 用に、プロトコルごとのシャットダウンしきい値やポートごとのシャットダウンしきい値を設定できます。 制限を超えると、ポートはシャットダウンされます。 QoS ACL およびポリシー マップをトンネル ポートで使用すると、BPDU レートを制限することもできます。

  • インターフェイスでプロトコル トンネリングがイネーブルである場合は、カスタマー ネットワークによって生成された PDU 用に、プロトコルごとのドロップしきい値やポートごとのドロップしきい値を設定できます。 制限を超えると、ポートが PDU を受信するレートがドロップしきい値未満になるまで、ポートで PDU がドロップされます。

  • トンネリングされた PDU(特に STP BPDU)は、カスタマーの仮想ネットワークが正しく動作するためにすべてのリモート サイトに配信される必要があるので、同じトンネル ポートから受信されるデータ パケットよりも PDU のプライオリティをサービスプロバイダー ネットワーク内で高くできます。 デフォルトの場合、PDU ではデータ パケットと同じ CoS 値が使用されます。

EtherChannel のレイヤ 2 トンネリング

EtherChannel の自動作成を容易にするためにレイヤ 2 ポイントツーポイント トンネリングを設定するには、サービスプロバイダー(SP)エッジ スイッチおよびカスタマー switchの両方を設定する必要があります。

トンネリングについて

IEEE 802.1Q およびレイヤ 2 プロトコルの概要

バーチャル プライベート ネットワーク(VPN)では、多くの場合にイーサネットベースの共有インフラストラクチャである企業規模の接続に、プライベート ネットワークと同じセキュリティ、プライオリティ、信頼性、管理の容易さが提供されます。 トンネリングは、サービス プロバイダーのネットワークを越えて複数のカスタマーのトラフィックを運び、その他のカスタマーのトラフィックに影響を与えずに、それぞれのカスタマーの VLAN およびレイヤ 2 プロトコルの設定を維持する必要があるサービス プロバイダー用に設計された機能です。


(注)  



この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。

IEEE 802.1Q トンネリング

サービス プロバイダーのビジネス カスタマーには、多くの場合、サポートする VLAN ID および VLAN の数に固有の要件があります。 同一サービスプロバイダー ネットワークのさまざまなカスタマーが必要とする VLAN 範囲は重複し、インフラストラクチャを通るカスタマーのトラフィックは混合してしまうことがあります。 それぞれのカスタマーに VLAN ID の固有の範囲を割り当てると、カスタマーの設定が制限され、IEEE 802.1Q 仕様の VLAN 制限(4096)を簡単に超えてしまうことがあります。

サービス プロバイダーは、IEEE 802.1Q トンネリング機能を使用すると、単一の VLAN を使用して、複数の VLAN を含むカスタマーをサポートできます。 カスタマーの VLAN ID は、同一 VLAN にあるように見えても保護され、さまざまなカスタマーのトラフィックは、サービスプロバイダー ネットワーク内で区別されます。 IEEE 802.1Q トンネリングを使用する場合、VLAN-in-VLAN 階層構造およびタグ付きパケットへの再タグ付けによって、VLAN スペースを拡張できます。 IEEE 802.1Q トンネリングをサポートするように設定したポートは、トンネル ポートと呼ばれます。 トンネリングを設定する場合は、トンネリング専用の VLAN ID にトンネル ポートを割り当てます。 それぞれのカスタマーには別個のサービスプロバイダー VLAN ID が必要ですが、その VLAN ID ではすべてのカスタマーの VLAN がサポートされます。

適切な VLAN ID で通常どおりにタグ付けされたカスタマーのトラフィックは、カスタマー デバイスの IEEE 802.1Q トランク ポートからサービスプロバイダーのエッジ switchのトンネル ポートに発信されます。 カスタマー デバイスとエッジ switch間のリンクは、片方が IEEE 802.1Q トランク ポートとして設定され、もう一方がトンネル ポートとして設定されるため、非対称です。 それぞれのカスタマーに固有のアクセス VLAN ID には、トンネル ポート インターフェイスを割り当てます。

図 1. サービス プロバイダー ネットワークにおける IEEE 802.1Q トンネル ポート

カスタマーのトランク ポートからサービス プロバイダーのエッジ switchのトンネル ポートに発信されるパケットには、通常、適切な VLAN ID とともに IEEE 802.1Q タグが付いています。 これらのタグ付きパケットは、switch内部ではそのまま保持され、トランク ポートを出てサービスプロバイダー ネットワークに入る時点で、カスタマーに固有の VLAN ID を含む、IEEE 802.1Q タグのもう 1 つのレイヤ(メトロ タグと呼ばれる)でカプセル化されます。 カスタマーの元の IEEE 802.1Q タグは、カプセル化されたパケット内で保護されます。 このため、サービスプロバイダー ネットワークに入るパケットには、カスタマーのアクセス VLAN ID を含む外部(メトロ)タグ、および着信トラフィックのものである内部 VLAN ID という、二重のタグが付きます。

二重タグ パケットがサービスプロバイダー コア switchの別のトランク ポートに入ると、switchがパケットを処理するときに外部タグが外されます。 パケットがその同じコア switchの別のトランク ポートを出るとき、同じメトロ タグがパケットに再び追加されます。

図 2. 元の(通常)イーサネット パケット、IEEE 802.1Q イーサネット パケット、二重タグ イーサネット パケットの形式. この図は、二重タグ付きパケットのタグ構造を示しています。

パケットがサービス プロバイダー出力switchのトランク ポートに入ると、switchがパケットを内部処理する間に外部タグが再び外されます。 ただし、パケットがエッジ switchのトンネル ポートからカスタマー ネットワークに送信されるとき、メトロ タグは追加されません。 パケットは通常の IEEE 802.1Q タグ フレームとして送信され、カスタマー ネットワーク内で元の VLAN 番号は保護されます。

上記のネットワークの図では、カスタマー A に VLAN 30、カスタマー B に VLAN 40 が割り当てられています。 エッジ switchのトンネル ポートに入る、IEEE 802.1Q タグが付いたパケットは、サービスプロバイダー ネットワークに入るとき、VLAN ID 30 または 40 を適切に含む外部タグ、および VLAN 100 などの元の VLAN 番号を含む内部タグが付いて二重タグになります。 カスタマー A とカスタマー B の両方が、それぞれのネットワーク内で VLAN 100 を含んでいても、外部タグが異なるので、サービスプロバイダー ネットワーク内で区別されます。 それぞれのカスタマーは、その他のカスタマーが使用する VLAN 番号スペース、およびサービスプロバイダー ネットワークが使用する VLAN 番号スペースから独立した、独自の VLAN 番号スペースを制御します。

アウトバウンド トンネル ポートでは、カスタマーのネットワーク上の元の VLAN 番号が回復されます。 トンネリングとタグ付けを複数レベルにすることもできますが、このリリースのswitchでは 1 レベルだけがサポートされます。

カスタマー ネットワークから発信されるトラフィックにタグ(ネイティブ VLAN フレーム)が付いていない場合、そのパケットのブリッジングまたはルーティングは通常パケットとして行われます。 エッジ switchのトンネル ポートを通ってサービスプロバイダー ネットワークに入るすべてのパケットは、タグが付いていないか、IEEE 802.1Q ヘッダーですでにタグが付いているかに関係なく、タグなしパケットとして扱われます。 パケットは、IEEE 802.1Q トランク ポートでサービスプロバイダー ネットワークを通じて送信される場合、メトロ タグ VLAN ID(トンネル ポートのアクセス VLAN に設定)でカプセル化されます。 メトロ タグのプライオリティ フィールドは、トンネル ポートで設定されているインターフェイス サービス クラス(CoS)プライオリティに設定されます (設定されていない場合、デフォルトはゼロです)。

switchesでは、802.1Q トンネリングがポート単位で設定されるため、switchはスタンドアロン switchまたはスタック メンバのいずれでもかまいません。 すべての設定はスタック マスターで実行されます。

IEEE 802.1Q トンネリング設定時の注意事項

IEEE 802.1Q トンネリングを設定する場合は、カスタマー デバイスおよびエッジ switchの間で非対称リンクを常に使用する必要があります。カスタマー デバイスのポートを IEEE 802.1Q トランク ポートに、エッジ switchのポートをトンネル ポートとして設定してください。

トンネリングに使用する VLAN だけにトンネル ポートを割り当ててください。

ネイティブ VLAN および最大伝送単位(MTU)の設定要件については、次の項で説明します。

ネイティブ VLAN

エッジ switchで IEEE 802.1Q トンネリングを設定する場合、サービスプロバイダー ネットワークにパケットを送信するために、IEEE 802.1Q トランク ポートを使用する必要があります。 ただし、サービスプロバイダー ネットワークのコアを通過するパケットは、IEEE 802.1Q トランク、ISL トランク、非トランキング リンクのいずれかで送信できます。 コア switchesで IEEE 802.1Q トランクを使用する場合、IEEE 802.1Q トランクのネイティブ VLAN は、同一switchの非トランキング(トンネリング)ポートのネイティブ VLAN と同じであってはなりません。これは、ネイティブ VLAN のトラフィックは、IEEE 802.1Q 送信トランク ポートではタグ付けされないためです。

次のネットワーク図で、VLAN 40 は、サービスプロバイダー ネットワークの入力エッジswitchSwitch B)にある、カスタマー X からの IEEE 802.1Q トランク ポートのネイティブ VLAN として設定されています。カスタマー X の Switch A は、VLAN 30 のタグ付きパケットを、アクセス VLAN 40 に属する、サービスプロバイダー ネットワークのSwitch B の入力トンネル ポートに送信します。 トンネル ポートのアクセス VLAN(VLAN 40)は、エッジ switchのトランク ポートのネイティブ VLAN(VLAN 40)と同じであるため、トンネル ポートから受信したタグ付きパケットにメトロ タグが追加されません。 パケットには VLAN 30 タグだけが付いて、サービスプロバイダー ネットワークで出力エッジ switchSwitch C)のトランク ポートに送信され、出力switch トンネルによってカスタマー Y に間違って送信されます。

図 3. IEEE 802.1Q トンネリングおよびネイティブ VLAN に潜在する問題

この問題の解決方法は次のとおりです。
  • vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用することで、(ネイティブ VLAN を含む)IEEE 802.1Q トランクから発信されるすべてのパケットがタグ付けされるようにエッジ switchesを設定します。 すべての IEEE 802.1Q トランクでネイティブ VLAN パケットにタグを付けるようにswitchesを設定した場合、switchesはタグなしパケットを受れ入れますが、タグ付きパケットだけを送信します。

  • エッジ switchesのトランク ポートのネイティブ VLAN ID が、カスタマー VLAN 範囲に含まれないようにしてください。 たとえばトランク ポートが VLAN100 ~ 200 のトラフィックを運ぶ場合は、この範囲以外の番号をネイティブ VLAN に割り当てます。

システム MTU

switch上のトラフィックに関するデフォルトのシステム MTU は、1500 バイトです。 system mtu グローバル コンフィギュレーション コマンドを使用すると、混合ハードウェア switch スタック内のswitch メンバーでファスト イーサネット ポートを設定して、1500 バイトより大きいフレームをサポートさせることができます。

system mtu jumbo グローバル コンフィギュレーション コマンドを使用すると、10 ギガビット イーサネット ポートおよびギガビット イーサネット ポートで 1500 バイトを超えるフレームをサポートするように設定できます。

システム MTU 値とシステム ジャンボ MTU 値には、IEEE 802.1Q ヘッダーは含まれていません。 IEEE 802.1Q トンネリング機能では、メトロ タグが追加されるとフレーム サイズが 4 バイト増加するため、システム最大伝送単位サイズとシステム ジャンボ最大伝送単位サイズに最低 4 バイトを追加することによって、サービスプロバイダー ネットワークのすべてのswitchesが最大フレームを処理できるように設定する必要があります。

たとえば、switchは、次のいずれかの設定で、1496 バイトの最大フレーム サイズをサポートします。

  • switchのシステム ジャンボ最大伝送単位値が 1500 バイトで、switchport mode dot1q tunnel インターフェイス コンフィギュレーション コマンドを使って 10 ギガビット イーサネットまたはギガビット イーサネット switch ポートが設定されている。

  • switch メンバのシステム最大伝送単位値が 1500 バイトで、switchport mode dot1q tunnel インターフェイス コンフィギュレーション コマンドを使ってメンバのファスト イーサネット ポートが設定されている。

IEEE 802.1Q トンネリングのデフォルト設定

デフォルトでは、デフォルト switchport モードが dynamic auto であるため、IEEE 802.1Q トンネルはディセーブルです。 すべての IEEE 802.1Q トランク ポートにおける IEEE 802.1Q ネイティブ VLAN パケットのタグ付けもディセーブルです。

レイヤ 2 プロトコル トンネリングの概要

サービスプロバイダー ネットワークを越えて接続されている、さまざまなサイトに散在するカスタマーは、さまざまなレイヤ 2 プロトコルを使用してトポロジをスケールし、すべてのリモート サイトおよびローカル サイトを含める必要があります。 STP を適切に動作させる必要があり、サービスプロバイダー ネットワークを越えたローカル サイトおよびすべてのリモート サイトを含む、適切なスパニングツリーをすべての VLAN で構築する必要があります。 Cisco Discovery Protocol(CDP)では、隣接するシスコ デバイスをローカル サイトおよびリモート サイトから検出する必要があります。 VLAN トランキング プロトコル(VTP)では、カスタマー ネットワークのすべてのサイトで一貫した VLAN 設定を提供する必要があります。

プロトコル トンネリングがイネーブルである場合、サービスプロバイダー ネットワークのインバウンド側エッジ switchesでは、特殊 MAC アドレスでレイヤ 2 プロトコルパケットがカプセル化され、サービスプロバイダー ネットワークに送信されます。 ネットワークのコア switchesでは、このパケットが処理されずに通常のパケットとして転送されます。 CDP、STP、VTP のレイヤ 2 プロトコル データ ユニット(PDU)は、サービスプロバイダー ネットワークをまたがり、サービスプロバイダー ネットワークのアウトバウンド側のカスタマー switchesに配信されます。 同一パケットは同じ VLAN のすべてのカスタマー ポートで受信され、次のような結果になります。

  • それぞれのカスタマー サイトのユーザは STP を適切に実行でき、すべての VLAN では(ローカル サイトだけではなく)すべてのサイトからのパラメータに基づいて、正しいスパニングツリーが構築されます。

  • CDP では、サービスプロバイダー ネットワークによって接続されているその他のシスコ デバイスに関する情報が検出されて表示されます。

  • VTP ではカスタマー ネットワーク全体で一貫した VLAN 設定が提供され、サービス プロバイダーを通してすべてのswitchesに伝播されます。


(注)  


サードパーティ ベンダーとの相互運用性を提供するには、レイヤ 2 プロトコルトンネル バイパス機能を使用します。 バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー switchesに、制御 PDU が透過的に転送されます。 バイパス モードを実装するには、出力トランク ポートでレイヤ 2 プロトコル トンネリングをイネーブルにします。 レイヤ 2 プロトコル トンネリングがトランク ポートでイネーブルの場合、カプセル化された MAC アドレスが削除されて、プロトコル パケットに通常の MAC アドレスを持つようになります。


レイヤ 2 プロトコル トンネリングは個別に使用できます。レイヤ 2 プロトコル トンネリングでは、IEEE 802.1Q トンネリングを向上させることができます。 IEEE 802.1Q トンネリング ポートでプロトコル トンネリングがイネーブルになっていない場合、サービスプロバイダー ネットワークの受信側のリモート switchesでは PDU が受信されず、STP、CDP、VTP を適切に実行できません。 プロトコルのトンネリングがイネーブルである場合、それぞれのカスタマー ネットワークのレイヤ 2 プロトコルは、サービスプロバイダー ネットワーク内で動作しているものから完全に区別されます。 IEEE 802.1Q トンネリングでサービスプロバイダー ネットワークを通してトラフィックを送信する、さまざまなサイトのカスタマー switchesでは、カスタマー VLAN が完全に認識されます。 IEEE 802.1Q トンネリングを使用しない場合は、アクセス ポートでカスタマー switchに接続し、サービスプロバイダーのアクセス ポートでトンネリングをイネーブルにすることで、レイヤ 2 プロトコル トンネリングをイネーブルにできます。

たとえば、次の図(レイヤ 2 プロトコル トンネリング)では、カスタマー X の 4 つのswitchesが同じ VLAN 上にあり、サービスプロバイダー ネットワークを通して互いに接続されています。 ネットワークで PDU がトンネリングされない場合、ネットワークの遠端側のswitchesでは、STP、CDP、VTP を適切に実行できません。 たとえば、カスタマー X のサイト 1 のswitchでは、VLAN の STP は、カスタマー X のサイト 2 のswitchesに基づくコンバージェンス パラメータを考慮せずに、サイト 1 のswitch上にスパニングツリーを構築します。 これにより、「適切なコンバージェンスを含まないレイヤ 2 ネットワーク トポロジ」の図に示されているようなトポロジになる可能性があります。

図 4. レイヤ 2 プロトコル トンネリング

図 5. 適切なコンバージェンスを含まないレイヤ 2 ネットワーク トポロジ

サービスプロバイダー ネットワークでは、レイヤ 2 プロトコル トンネリングを使用し、ポイントツーポイント ネットワーク トポロジをエミュレートして、EtherChannel の作成を向上させることができます。 サービスプロバイダー switchでプロトコル トンネリング(PAgP または LACP)をイネーブルにすると、リモート カスタマー switchesでは PDU が受信され、EtherChannel の自動作成をネゴシエーションできるようになります。

たとえば、次の図(EtherChannels のレイヤ 2 プロトコル トンネリング)では、カスタマー A の 2 つのswitchesが同じ VLAN 上にあり、サービスプロバイダー ネットワークを介して接続されています。 ネットワークで PDU がトンネリングされると、ネットワークの遠端側のswitchesでは、専用回線を必要とせずに EtherChannel の自動作成をネゴシエーションできます。

図 6. EtherChannel のレイヤ 2 プロトコル トンネリング

ポートでのレイヤ 2 プロトコル トンネリング

サービスプロバイダー ネットワークのエッジ switchesで、カスタマーに接続されているポートにおいて、レイヤ 2 プロトコル トンネリングを(プロトコルごとに)イネーブルにできます。 カスタマー switchesに接続されているサービス プロバイダー エッジ switchでは、トンネリング処理が実行されます。 エッジ switch トンネル ポートは、カスタマーの IEEE 802.1Q トランク ポートに接続されます。 エッジ switch アクセス ポートは、カスタマー アクセス ポートに接続されます。 カスタマー switchesに接続されるエッジ switchでは、トンネリング処理が実行されます。

アクセス ポートまたはトンネル ポートのいずれかとして設定されているポートでは、レイヤ 2 プロトコル トンネリングをイネーブルにできます。 switchport mode dynamic auto モード(デフォルト モード)または switchport mode dynamic desirable モードに設定されているポートでは、レイヤ 2 プロトコル トンネリングをイネーブルにできません。

switchでは、CDP、STP、VTP のレイヤ 2 プロトコル トンネリングがサポートされます。 ポイントツーポイント ネットワーク トポロジのエミュレートの場合は、PAgP、LACP、UDLD のプロトコルもサポートされます。 switchは、LLDP のレイヤ 2 プロトコル トンネリングをサポートしません。


(注)  


PAgP、LACP、UDLD プロトコル トンネリングでは、ポイントツーポイント トポロジのエミュレートだけが目的です。 設定を間違えたことによりトンネリング パケットが多くのポートに送信されると、ネットワーク障害が発生する可能性があります。


レイヤ 2 プロトコルがイネーブルになっているポート経由でサービスプロバイダーのインバウンド エッジ switchに入ったレイヤ 2 PDU が、トランク ポートからサービスプロバイダー ネットワークに出て行くとき、switchでは、カスタマー PDU 宛先 MAC アドレスが、周知のシスコ固有のマルチキャスト アドレス(01-00-0c-cd-cd-d0)で上書きされます。 IEEE 802.1Q トンネリングがイネーブルである場合、パケットにはタグが二重に付きます。このうち外部タグはカスタマーのメトロ タグ、内部タグはカスタマーの VLAN タグです。 コア switchesでは内部タグが無視され、同じメトロ VLAN のすべてのトランク ポートにパケットが転送されます。 アウトバウンド側のエッジ switchesでは、適切なレイヤ 2 プロトコル情報および MAC アドレス情報が復元され、同じメトロ VLAN のすべてのトンネル ポートまたはすべてのアクセス ポートにパケットが転送されます。 このため、レイヤ 2 PDU はそのまま残り、サービスプロバイダー インフラストラクチャを越えてカスタマー ネットワークの反対側に配信されます。

レイヤ 2 プロトコル トンネリングの概要のレイヤ 2 プロトコル トンネリングの図を参照してください(それぞれアクセス VLAN 30、40 のカスタマー X とカスタマー Y)。 非対称リンクにより、サイト 1 のカスタマーは、サービスプロバイダー ネットワークのエッジ switchesに接続されています。 サイト 1 のカスタマー Y からSwitch B に発信されたレイヤ 2 PDU(たとえば BPDU)は、周知の MAC アドレスが宛先 MAC アドレスになっている二重タグ パケットとしてインフラストラクチャに転送されます。 この二重タグ パケットには、40 というメトロ VLAN タグ、および VLAN 100 などの内部 VLAN タグが付いています。 二重タグ パケットがSwitch D に入ると、外部 VLAN タグ 40 が外されて、周知の MAC アドレスがそれぞれのレイヤ 2 プロトコル MAC アドレスで置き換わり、パケットは、VLAN 100 の 1 重タグ フレームとしてサイト 2 のカスタマー Y に送信されます。

また、カスタマー switchのアクセス ポートまたはトランク ポートに接続されているエッジ switchのアクセス ポートでも、レイヤ 2 プロトコル トンネリングをイネーブルにできます。 この場合は、カプセル化プロセスとカプセル開放プロセスが、前の段落で説明したものと同じですが、パケットはサービスプロバイダー ネットワークで二重タグになりません。 カスタマー固有のアクセス VLAN タグの 1 重タグになります。

switch スタックでは、レイヤ 2 プロトコル トンネリング設定がすべてのスタック メンバーに配信されます。 ローカル ポート上で入力パケットを受信する各スタック メンバーは、パケットをカプセル化またはカプセル化解除して、該当する宛先ポートに転送します。 単一のswitch上では、レイヤ 2 プロトコル トンネリング処理された入力トラフィックは、レイヤ 2 プロトコル トンネリングがイネーブルになっている同一 VLAN 上のすべてのローカル ポートに送信されます。 スタックでは、レイヤ 2 プロトコル トンネリングの設定が行われたポートで受信したパケットを、スタック内のレイヤ 2 プロトコル トンネリングが設定され、同じ VLAN 内にあるすべてのポートに配信します。 レイヤ 2 プロトコル トンネリング設定は、すべてスタック マスターにより取り扱われ、すべてのスタック メンバーに配信されます。

レイヤ 2 プロトコル トンネリングのデフォルト設定

次の表に、レイヤ 2 プロトコル トンネリングのデフォルト設定を記載します。

表 1 レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

機能

デフォルト設定

レイヤ 2 プロトコル トンネリング

ディセーブル

シャットダウンしきい値

未設定。

ドロップしきい値

未設定。

CoS 値

インターフェイスで CoS 値が設定されている場合は、その値がレイヤ 2 プロトコル トンネリングの BPDU CoS 値を設定するために使用されます。 インターフェイス レベルで CoS 値が設定されてない場合は、L2 プロトコル トンネリング BPDU の CoS マーキングのデフォルト値は 5 になります。 これはデータ トラフィックに適用されません。

トンネリングの設定方法

IEEE 802.1Q トンネリング ポートの設定

手順の概要

    1.    enable

    2.    configure terminal

    3.    interface interface-id

    4.    switchport access vlan vlan-id

    5.    switchport mode dot1q-tunnel

    6.    exit

    7.    vlan dot1q tag native

    8.    end

    9.    次のいずれかを使用します。

    • show dot1q-tunnel
    • show running-config interface

    10.    show vlan dot1q tag native

    11.    copy running-config startup-config


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Switch> enable
    
    
     

    特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

     

    ステップ 2configure terminal


    例:
    
    Switch# configure terminal
    
    
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3interface interface-id


    例:
    Switch(config)# interface gigabitethernet2/0/1
    
    
     

    トンネル ポートとして設定するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。 これは、カスタマー switchに接続するサービスプロバイダー ネットワーク内のエッジ ポートである必要があります。 有効なインターフェイスには、物理インターフェイスおよびポートチャネル論理インターフェイス(ポート チャネル 1 ~ 48)が含まれます。

     
    ステップ 4switchport access vlan vlan-id


    例:
    Switch(config-if)# switchport access vlan 2
    
    
     

    インターフェイスがトランキングを停止した場合に使用されるデフォルト VLAN を指定します。 この VLAN ID は特定カスタマーに固有です。

     
    ステップ 5switchport mode dot1q-tunnel


    例:
    Switch(config-if)# switchport mode dot1q-tunnel
    
    
     

    IEEE 802.1Q トンネル ポートとしてインターフェイスを設定します。

    (注)     

    ポートを dynamic desirable デフォルト状態に戻すには、no switchport mode dot1q-tunnel インターフェイス コンフィギュレーション コマンドを使用します。

     

    ステップ 6exit


    例:
    Switch(config-if)# exit
    
    
     

    特権 EXEC モードに戻ります。

     

    ステップ 7vlan dot1q tag native


    例:
    Switch(config)# vlan dot1q tag native
    
    
     

    (任意)すべての IEEE 802.1Q トランク ポートでネイティブ VLAN パケットのタギングがイネーブルになるようにswitchを設定します。 これを設定せず、カスタマー VLAN ID がネイティブ VLAN と同じである場合、トランク ポートはメトロ タグを適用せず、パケットは誤った宛先に送信される可能性があります。

    (注)     

    ネイティブ VLAN パケットのタグ付けをディセーブルにするには、no vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用します。

     

    ステップ 8end


    例:
    Switch(config)# end
    
    
     

    特権 EXEC モードに戻ります。

     
    ステップ 9次のいずれかを使用します。
    • show dot1q-tunnel
    • show running-config interface


    例:
    
    Switch# show dot1q-tunnel
    
    

    または

    
    Switch# show running-config interface
    
    
     

    IEEE 802.1Q トンネリング用に設定されたポートを表示します。

    トンネリング モードになっているポートを表示します。

     
    ステップ 10show vlan dot1q tag native


    例:
    Switch# show vlan dot1q native
    
    
     

    IEEE 802.1Q ネイティブ VLAN タギング ステータスを表示します。

     

    ステップ 11copy running-config startup-config


    例:
    Switch# copy running-config startup-config 
    
    
     

    (任意)コンフィギュレーション ファイルに設定を保存します。

     

    レイヤ 2 プロトコル トンネリングの設定

    手順の概要

      1.    enable

      2.    configure terminal

      3.    interface interface-id

      4.    次のいずれかを使用します。

      • switchport mode access
      • switchport mode dot1q-tunnel

      5.    l2protocol-tunnel [cdp | lldp | point-to-point | stp | vtp]

      6.    l2protocol-tunnel shutdown-threshold [ packet_second_rate_value | cdp | lldp point-to-point | stp | vtp]

      7.    l2protocol-tunnel drop-threshold [ packet_second_rate_value | cdp | lldp | point-to-point | stp | vtp]

      8.    exit

      9.    errdisable recovery cause l2ptguard

      10.    l2protocol-tunnel cos value

      11.    end

      12.    show l2protocol

      13.    copy running-config startup-config


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Switch> enable
      
      
       

      特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

       

      ステップ 2configure terminal


      例:
      
      Switch# configure terminal
      
      
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3interface interface-id


      例:
      
      Switch(config)# interface gigabitethernet1/0/1
      
      
       

      IP Phone に接続するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 4次のいずれかを使用します。
      • switchport mode access
      • switchport mode dot1q-tunnel


      例:
      
      Switch# switchport mode access
      
      

      または

      
      Switch# switchport mode dot1q-tunnel
      
      
       

      アクセス ポートまたは IEEE 802.1Q トンネル ポートとしてインターフェイスを設定します。

       
      ステップ 5l2protocol-tunnel [cdp | lldp | point-to-point | stp | vtp]


      例:
      Switch# l2protocol-tunnel cdp
      
      
       

      目的のプロトコルに対してプロトコル トンネリングをイネーブルにします。 キーワードを入力しない場合、トンネリングは、3 つのすべてのレイヤ 2 プロトコルでイネーブルになります。

      (注)     

      レイヤ 2 プロトコルのいずれか 1 つ、または 3 つすべてのプロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [cdp | lldp | point-to-point | stp | vtp] インターフェイス コンフィギュレーション コマンドを使用します。

       

      ステップ 6l2protocol-tunnel shutdown-threshold [ packet_second_rate_value | cdp | lldp point-to-point | stp | vtp]


      例:
      Switch# l2protocol-tunnel shutdown-threshold 100 cdp
      
       

      (任意)1 秒間にカプセル化可能なパケット数を表すしきい値を設定します。 設定したしきい値を超えると、インターフェイスはディセーブルになります。 プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。 範囲は 1 ~ 4096 です。 デフォルトでは、しきい値は設定されません。

      (注)     

      このインターフェイスでドロップしきい値も設定する場合は、shutdown-threshold 値を drop-threshold の値以上にする必要があります。

      (注)     

      シャットダウンしきい値およびドロップしきい値をデフォルト設定に戻すには、no l2protocol-tunnel shutdown-threshold [ packet_second_rate_value | cdp | lldp| point-to-point | stp | vtp] および no l2protocol-tunnel drop-threshold [ packet_second_rate_value | cdp | lldp| point-to-point |stp | vtp] コマンドを使用します。

       

      ステップ 7l2protocol-tunnel drop-threshold [ packet_second_rate_value | cdp | lldp | point-to-point | stp | vtp]


      例:
      Switch# l2protocol-tunnel drop-threshold 100 cdp
      
      
       

      (任意)1 秒間にカプセル化可能なパケット数を表すしきい値を設定します。 設定したしきい値を超えると、インターフェイスによってパケットがドロップされます。 プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。 範囲は 1 ~ 4096 です。 デフォルトでは、しきい値は設定されません。

      (注)     

      このインターフェイスでシャットダウンしきい値も設定する場合、drop-threshold 値は shutdown-threshold の値以下である必要があります。

      (注)     

      シャットダウンしきい値およびドロップしきい値をデフォルト設定に戻すには、no l2protocol-tunnel shutdown-threshold [cdp | lldp| point-to-point | stp | vtp] および no l2protocol-tunnel drop-threshold [cdp | stp | vtp] コマンドを使用します。

       

      ステップ 8exit


      例:
      Switch# exit
      
      
       

      グローバル コンフィギュレーション モードに戻ります。

       

      ステップ 9errdisable recovery cause l2ptguard


      例:
      Switch(config)# errdisable recovery cause l2ptguard
      
      
       

      (任意)インターフェイスが再びイネーブルになって再試行できるように、レイヤ 2 最大レート エラーからの復旧メカニズムを設定します。 errdisable recovery はデフォルトでディセーブルになっています。イネーブルにした場合、デフォルトの間隔は 300 秒です。

       

      ステップ 10l2protocol-tunnel cos value


      例:
      Switch(config)# l2protocol-tunnel cos value 7
      
      
       

      (任意)トンネリングされたすべてのレイヤ 2 PDU に対して CoS 値を設定します。 範囲は 0 ~ 7 です。デフォルトは、インターフェイスのデフォルト CoS 値です。 設定されていない場合、デフォルトは 5 です。

       

      ステップ 11end


      例:
      
      Switch(config)# end
      
      
       

      特権 EXEC モードに戻ります。

       
      ステップ 12show l2protocol


      例:
      Switch# show l2protocol
      
       

      switchのレイヤ 2 トンネル ポートを表示します(設定されているプロトコル、しきい値、カウンタを含む)。

       

      ステップ 13copy running-config startup-config


      例:
      Switch# copy running-config startup-config 
      
      
       

      (任意)コンフィギュレーション ファイルに設定を保存します。

       

      サービスプロバイダー エッジ スイッチの設定

      はじめる前にEtherChannels の場合は、SP(サービス プロバイダー)エッジ switchesおよびカスタマー switchesをレイヤ 2 プロトコル トンネリング用に設定する必要があります。
      手順の概要

        1.    enable

        2.    configure terminal

        3.    interface interface-id

        4.    switchport mode dot1q-tunnel

        5.    l2protocol-tunnel point-to-point [pagp | lacp | udld]

        6.    l2protocol-tunnel shutdown-threshold [point-to-point [pagp | lacp | udld]] value

        7.    l2protocol-tunnel drop-threshold [point-to-point [pagp | lacp | udld]] value

        8.    no cdp enable

        9.    spanning-tree bpdu filter enable

        10.    exit

        11.    errdisable recovery cause l2ptguard

        12.    l2protocol-tunnel cos value

        13.    end

        14.    show l2protocol

        15.    copy running-config startup-config


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Switch> enable
        
        
         

        特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

         

        ステップ 2configure terminal


        例:
        
        Switch# configure terminal
        
        
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3interface interface-id


        例:
        
        Switch(config)# interface gigabitethernet1/0/1
        
        
         

        IP Phone に接続するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

         
        ステップ 4switchport mode dot1q-tunnel


        例:
        Switch(config-if)# switchport mode dot1q-tunnel
        
        
         

        IEEE 802.1Q トンネル ポートとしてインターフェイスを設定します。

         

        ステップ 5l2protocol-tunnel point-to-point [pagp | lacp | udld]


        例:
        Switch(config-if)# l2protocol-tunnel point-to-point pagp
        
        
         

        (任意)目的のプロトコルに関するポイントツーポイント プロトコル トンネリングをイネーブルにします。 キーワードを入力しない場合、トンネリングは、3 つすべてのプロトコルでイネーブルになります。

        (注)     

        ネットワーク障害を避けるため、ネットワークがポイントツーポイント トポロジになっていることを確認してから、PAgP パケット、LACP パケット、UDLD パケットのうちいずれかのトンネリングをイネーブルにしてください。

        (注)     

        いずれかのレイヤ 2 プロトコルまたは 3 つのすべてのレイヤ 2 プロトコルのポイントツーポイント プロトコル トンネリングをディセーブルにするには、no l2protocol-tunnel [point-to-point [pagp | lacp | udld]] インターフェイス コンフィギュレーション コマンドを使用します。

         

        ステップ 6l2protocol-tunnel shutdown-threshold [point-to-point [pagp | lacp | udld]] value


        例:
        Switch(config-if)# l2protocol-tunnel shutdown-threshold point-to-point pagp 100
        
        
         

        (任意)1 秒間にカプセル化可能なパケット数を表すしきい値を設定します。 設定したしきい値を超えると、インターフェイスはディセーブルになります。 プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。 範囲は 1 ~ 4096 です。 デフォルトでは、しきい値は設定されません。

        (注)     

        このインターフェイスでドロップしきい値も設定する場合は、shutdown-threshold 値を drop-threshold の値以上にする必要があります。

        (注)     

        シャットダウンしきい値およびドロップしきい値をデフォルト設定に戻すには、no l2protocol-tunnel shutdown-threshold [point-to-point [pagp | lacp | udld]] および no l2protocol-tunnel drop-threshold [[point-to-point [pagp | lacp | udld]] コマンドを使用します。

         

        ステップ 7l2protocol-tunnel drop-threshold [point-to-point [pagp | lacp | udld]] value


        例:
        Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 500
        
        
         

        (任意)1 秒間にカプセル化可能なパケット数を表すしきい値を設定します。 設定したしきい値を超えると、インターフェイスによってパケットがドロップされます。 プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。 範囲は 1 ~ 4096 です。 デフォルトでは、しきい値は設定されません。

        (注)     

        このインターフェイスでシャットダウンしきい値も設定する場合、drop-threshold 値は shutdown-threshold の値以下である必要があります。

         

        ステップ 8no cdp enable


        例:
        Switch(config-if)# no cdp enable
        
        
         

        インターフェイス上で CDP をディセーブルにします。

         

        ステップ 9spanning-tree bpdu filter enable


        例:
        Switch(config-if)# spanning-tree bpdu filter enable
        
        
         

        インターフェイス上で BPDU フィルタリングをイネーブルにします。

         

        ステップ 10exit


        例:
        Switch(config-if)# exit
        
        
         

        グローバル コンフィギュレーション モードに戻ります。

         

        ステップ 11errdisable recovery cause l2ptguard


        例:
        Switch(config)# errdisable recovery cause l2ptguard
        
        
         

        (任意)インターフェイスが再びイネーブルになって再試行できるように、レイヤ 2 最大レート エラーからの復旧メカニズムを設定します。 errdisable recovery はデフォルトでディセーブルになっています。イネーブルにした場合、デフォルトの間隔は 300 秒です。

         

        ステップ 12l2protocol-tunnel cos value


        例:
        Switch(config)# l2protocol-tunnel cos 2
        
        
         

        (任意)トンネリングされたすべてのレイヤ 2 PDU に対して CoS 値を設定します。 範囲は 0 ~ 7 です。デフォルトは、インターフェイスのデフォルト CoS 値です。 設定されていない場合、デフォルトは 5 です。

         

        ステップ 13end


        例:
        
        Switch(config)# end
        
        
         

        特権 EXEC モードに戻ります。

         
        ステップ 14show l2protocol


        例:
        Switch)# show l2protocol
        
        
         

        switchのレイヤ 2 トンネル ポートを表示します(設定されているプロトコル、しきい値、カウンタを含む)。

         

        ステップ 15copy running-config startup-config


        例:
        Switch# copy running-config startup-config 
        
        
         

        (任意)コンフィギュレーション ファイルに設定を保存します。

         

        カスタマー Switchの設定

        はじめる前に

        EtherChannel の場合は、サービスプロバイダー エッジ switchおよびカスタマー switchesをレイヤ 2 プロトコル トンネリング用に設定する必要があります

        手順の概要

          1.    enable

          2.    configure terminal

          3.    interface interface-id

          4.    switchport trunk encapsulation dot1q

          5.    switchport mode trunk

          6.    udld port

          7.    channel-group channel-group-number mode desirable

          8.    exit

          9.    interface port-channel port-channel number

          10.    shutdown

          11.    no shutdown

          12.    end

          13.    show l2protocol

          14.    copy running-config startup-config


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Switch> enable
          
          
           

          特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

           

          ステップ 2configure terminal


          例:
          
          Switch# configure terminal
          
          
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3interface interface-id


          例:
          
          Switch(config)# interface gigabitethernet1/0/1
          
          
           

          IP Phone に接続するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

           
          ステップ 4switchport trunk encapsulation dot1q


          例:
          Switch(config)# switchport trunk encapsulation dot1q
          
          
           

          トランキング カプセル化形式を IEEE 802.1Q に設定します。

           
          ステップ 5switchport mode trunk


          例:
          Switch(config-if)# switchport mode trunk
          
          
           

          インターフェイスでトランキングをイネーブルにします。

           

          ステップ 6udld port


          例:
          Switch(config-if)# udld port
          
          
           

          インターフェイス上で UDLD を通常モードでイネーブルにします。

           

          ステップ 7channel-group channel-group-number mode desirable


          例:
          Switch(config-if)# channel-group 25 mode desirable
          
          
           

          チャネル グループにインターフェイスを割り当て、PAgP モードに desirable を指定します。

           

          ステップ 8exit


          例:
          Switch(config-if)# exit
          
          
           

          グローバル コンフィギュレーション モードに戻ります。

           

          ステップ 9interface port-channel port-channel number


          例:
          Switch(config)# interface port-channel port-channel 25
          
          
           

          ポートチャネル インターフェイス モードを開始します。

           

          ステップ 10shutdown


          例:
          Switch(config)# shutdown
          
          
           

          インターフェイスをシャットダウンします。

           

          ステップ 11no shutdown


          例:
          Switch(config)# no shutdown
          
          
           

          インターフェイスをイネーブルにします。

           

          ステップ 12end


          例:
          
          Switch(config)# end
          
          
           

          特権 EXEC モードに戻ります。

           
          ステップ 13show l2protocol


          例:
          Switch# show l2protocol
          
           

          switchのレイヤ 2 トンネル ポートを表示します(設定されているプロトコル、しきい値、カウンタを含む)。

           

          ステップ 14copy running-config startup-config


          例:
          
          Switch# copy running-config startup-config
          
          
           

          (任意)コンフィギュレーション ファイルに設定を保存します。

          (注)     

          インターフェイスをデフォルト設定に戻すには、no switchport mode trunkno udld enable、および no channel group channel-group-number mode desirable インターフェイス コンフィギュレーション コマンドを使用します。

           

          IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定例

          例:IEEE 802.1Q トンネリング ポートの設定

          以下の例では、トンネル ポートとしてインターフェイスを設定してネイティブ VLAN パケットのタグ付けをイネーブルにし、設定を確認する方法を示します。 この設定では、スタック メンバー 1 のインターフェイス Gigabit Ethernet 7 に接続するカスタマーの VLAN ID は、VLAN 22 になります。

          Switch(config)# interface gigabitethernet1/0/7
          Switch(config-if)# switchport access vlan 22
          % Access VLAN does not exist. Creating vlan 22
          Switch(config-if)# switchport mode dot1q-tunnel
          Switch(config-if)# exit
          Switch(config)# vlan dot1q tag native
          Switch(config)# end
          Switch# show dot1q-tunnel interface gigabitethernet1/0/7
          Port
          -----
          Gi1/0/1Port
          -----
          Switch# show vlan dot1q tag native
          dot1q native vlan tagging is enabled
          
          

          例:レイヤ 2 プロトコル トンネリングの設定

          以下の例では、CDP、STP、VTP のレイヤ 2 プロトコル トンネリングを設定し、設定を確認する方法を示します。

          
          Switch(config)# interface gigabitethernet1/0/11
          Switch(config-if)# l2protocol-tunnel cdp
          Switch(config-if)# l2protocol-tunnel stp
          Switch(config-if)# l2protocol-tunnel vtp
          Switch(config-if)# l2protocol-tunnel shutdown-threshold 1500
          Switch(config-if)# l2protocol-tunnel drop-threshold 1000
          Switch(config-if)# exit
          Switch(config)# l2protocol-tunnel cos 7
          Switch(config)# end
          Switch# show l2protocol
          
          COS for Encapsulated Packets: 7
          Port Protocol Shutdown Drop Encapsulation Decapsulation Drop
          Threshold Threshold Counter Counter Counter
          ------- -------- --------- --------- ------------- ------------- -------------
          Gi0/11 cdp 1500 1000 2288 2282 0
          stp 1500 1000 116 13 0
          vtp 1500 1000 3 67 0
          pagp ---- ---- 0 0 0
          lacp ---- ---- 0 0 0
          udld ---- ---- 0 0 0
          
          

          例:サービスプロバイダー エッジ スイッチとカスタマー スイッチの設定

          以下は、サービス プロバイダーのエッジ スイッチ 1 およびエッジ スイッチ 2 を設定する方法の例です。 VLAN 17、18、19、20 はアクセス VLAN、ファスト イーサネット インターフェイス 1 および 2 は PAgP および UDLD がイネーブルになっているポイントツーポイント トンネル ポート、ドロップしきい値は 1000、ファスト イーサネット インターフェイス 3 はトランク ポートです。

          サービスプロバイダー エッジ スイッチ 1 の設定は次のとおりです。

          Switch(config)# interface gigabitethernet1/0/1
          Switch(config-if)# switchport access vlan 17
          Switch(config-if)# switchport mode dot1q-tunnel
          Switch(config-if)# l2protocol-tunnel point-to-point pagp
          Switch(config-if)# l2protocol-tunnel point-to-point udld
          Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
          Switch(config-if)# exit
          Switch(config)# interface gigabitethernet1/0/2
          Switch(config-if)# switchport access vlan 18
          Switch(config-if)# switchport mode dot1q-tunnel
          Switch(config-if)# l2protocol-tunnel point-to-point pagp
          Switch(config-if)# l2protocol-tunnel point-to-point udld
          Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
          Switch(config-if)# exit
          Switch(config)# interface gigabitethernet1/0/3
          Switch(config-if)# switchport trunk encapsulation isl
          Switch(config-if)# switchport mode trunk
          
          

          サービスプロバイダー エッジ スイッチ 2 の設定は次のとおりです。

          Switch(config)# interface gigabitethernet1/0/1
          Switch(config-if)# switchport access vlan 19
          Switch(config-if)# switchport mode dot1q-tunnel
          Switch(config-if)# l2protocol-tunnel point-to-point pagp
          Switch(config-if)# l2protocol-tunnel point-to-point udld
          Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
          Switch(config-if)# exit
          Switch(config)# interface gigabitethernet1/0/2
          Switch(config-if)# switchport access vlan 20
          Switch(config-if)# switchport mode dot1q-tunnel
          Switch(config-if)# l2protocol-tunnel point-to-point pagp
          Switch(config-if)# l2protocol-tunnel point-to-point udld
          Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
          Switch(config-if)# exit
          Switch(config)# interface gigabitethernet1/0/3
          Switch(config-if)# switchport trunk encapsulation isl
          Switch(config-if)# switchport mode trunk
          
          

          次は、サイト 1 のカスタマー スイッチを設定する方法の例です。 ファスト イーサネット インターフェイス 1、2、3、4 は IEEE 802.1Q トランキング用に設定されており、UDLD はイネーブル、EtherChannel グループ 1 はイネーブル、ポート チャネルはシャットダウンされた後でイネーブルになり EtherChannel 設定がアクティブになります。

          Switch(config)# interface gigabitethernet1/0/1
          Switch(config-if)# switchport trunk encapsulation dot1q
          Switch(config-if)# switchport mode trunk
          Switch(config-if)# udld enable
          Switch(config-if)# channel-group 1 mode desirable
          Switch(config-if)# exit
          Switch(config)# interface gigabitethernet1/0/2
          Switch(config-if)# switchport trunk encapsulation dot1q
          Switch(config-if)# switchport mode trunk
          Switch(config-if)# udld enable
          Switch(config-if)# channel-group 1 mode desirable
          Switch(config-if)# exit
          Switch(config)# interface gigabitethernet1/0/3
          Switch(config-if)# switchport trunk encapsulation dot1q
          Switch(config-if)# switchport mode trunk
          Switch(config-if)# udld enable
          Switch(config-if)# channel-group 1 mode desirable
          Switch(config-if)# exit
          Switch(config)# interface gigabitethernet1/0/4
          Switch(config-if)# switchport trunk encapsulation dot1q
          Switch(config-if)# switchport mode trunk
          Switch(config-if)# udld enable
          Switch(config-if)# channel-group 1 mode desirable
          Switch(config-if)# exit
          Switch(config)# interface port-channel 1
          Switch(config-if)# shutdown
          Switch(config-if)# no shutdown
          Switch(config-if)# exit
          
          

          トンネリング ステータスのモニタリング

          次の表では、トンネリング ステータスをモニタするために使用するコマンドについて説明します。

          表 2 トンネリングのモニタリング コマンド

          コマンド

          目的

          clear l2protocol-tunnel counters

          レイヤ 2 プロトコル トンネリング ポートのプロトコル カウンタをクリアします。

          show dot1q-tunnel

          switchの IEEE 802.1Q トンネル ポートを表示します。

          show dot1q-tunnel interface interface-id

          特定のインターフェイスがトンネル ポートであるかどうかを確認します。

          show l2protocol-tunnel

          レイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

          show errdisable recovery

          レイヤ 2 プロトコル トンネル エラーディセーブル ステートの回復タイマーがイネーブルかどうかを確認します。

          show l2protocol-tunnel interface interface-id

          特定のレイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

          show l2protocol-tunnel summary

          レイヤ 2 プロトコルのサマリー情報だけを表示します。

          show vlan dot1q tag native

          switchのネイティブ VLAN タギングのステータスを表示します。

          次の作業

          次の設定を行えます。

          • VTP

          • VLAN

          • VLAN トランキング

          • プライベート VLAN

          • VLAN メンバーシップ ポリシー サーバ(VMPS)

          • 音声 VLAN

          その他の関連資料

          関連資料

          関連項目 マニュアル タイトル

          この章で使用するコマンドの完全な構文および使用方法の詳細。

          Catalyst 2960-XR Switch VLAN Management Command Reference

          標準および RFC

          標準/RFC タイトル

          MIB

          MIB MIB のリンク

          本リリースでサポートするすべての MIB

          選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

          http:/​/​www.cisco.com/​go/​mibs

          テクニカル サポート

          説明 リンク

          シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

          お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

          シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

          http:/​/​www.cisco.com/​support

          トンネリングの機能履歴と情報

          リリース 変更内容

          Cisco IOS 15.0(2)EX1

          この機能が導入されました。