VLAN コンフィギュレーション ガイド Cisco IOS リリース 15.2(2) E(Catalyst 2960-XR スイッチ)
VLAN トランクの設定
VLAN トランクの設定

目次

VLAN トランクの設定

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、使用するプラットフォームおよびソフトウェア リリースの Bug Search Tool およびリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator には、http:/​/​www.cisco.com/​go/​cfn からアクセスします。 Cisco.com のアカウントは必要ありません。

VLAN トランクの前提条件

IEEE 802.1Q トランクは、ネットワークのトランキング方式について次の制約があります。

  • IEEE 802.1Q トランクを使って接続される Cisco switchesのネットワークにおいて、switchesはトランク上で許容される VLAN ごとに 1 つのスパニングツリー インスタンスを維持します。 他社製のデバイスは、すべての VLAN でスパニングツリー インスタンスを 1 つサポートする場合があります。

    IEEE 802.1Q トランクを使用して Cisco switchを他社製のデバイスに接続する場合、Cisco switchは、トランクの VLAN のスパニングツリー インスタンスを、他社製の IEEE 802.1Q switchのスパニングツリー インスタンスと結合します。 ただし、各 VLAN のスパニングツリー情報は、他社製の IEEE 802.1Q switchesからなるクラウドにより分離された Cisco switchesによって維持されます。 Cisco switchesを分離する他社製の IEEE 802.1Q クラウドは、switches間の単一トランク リンクとして扱われます。

  • IEEE 802.1Q トランクに対応するネイティブ VLAN が、トランク リンクの両側で一致していなければなりません。 トランクの片側のネイティブ VLAN と反対側のネイティブ VLAN が異なっていると、スパニングツリー ループが発生する可能性があります。

  • ネットワーク上のすべてのネイティブ VLAN についてスパニングツリーをディセーブルにせずに、IEEE 802.1Q トランクのネイティブ VLAN 上のスパニングツリーをディセーブルにすると、スパニングツリー ループが発生することがあります。 IEEE 802.1Q トランクのネイティブ VLAN 上でスパニングツリーをイネーブルのままにしておくか、またはネットワーク上のすべての VLAN でスパニングツリーをディセーブルにすることを推奨します。 また、ネットワークにループがないことを確認してから、スパニングツリーをディセーブルにしてください。

VLAN トランクの制約事項

次に、VLAN トランクの制約事項を示します。
  • トランク ポートをセキュア ポートにすることはできません。

  • トランク ポートは、トンネル ポートにできません。

  • トランク ポートをまとめて EtherChannel ポート グループにすることはできますが、グループ内のすべてのトランクに同じ設定をする必要があります。 グループを初めて作成したときには、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。 次に示すパラメータのいずれかの設定を変更すると、switchは、入力された設定をグループ内のすべてのポートに伝播します。
    • 許可 VLAN リスト。

    • 各 VLAN の STP ポート プライオリティ。

    • STP PortFast の設定値。

    • トランク ステータス。

      ポート グループ内の 1 つのポートがもはやトランクでなくなった場合、すべてのポートがトランクでなくなります。

  • 構成するトランク ポートの数は、VLAN 単位のスパニングツリー(PVST)モードでは 24 以下、マルチ スパニングツリー(MST)モードでは 40 以下に抑えることを推奨します。

  • トランク ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。 IEEE 802.1x 対応ポートのモードをトランクに変更しようとしても、ポート モードは変更されません。

  • ダイナミック モードのポートは、ネイバーとトランク ポートへの変更をネゴシエートする場合があります。 ダイナミック ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。 IEEE 802.1x 対応ポートをダイナミックに変更しようとしても、ポート モードは変更されません。

  • ダイナミック トランキング プロトコル(DTP)は、プライベート VLAN ポートやトンネル ポートではサポートされません。

VLAN トランクについて

トランキングの概要

トランクとは、1 つまたは複数のイーサネット switch インターフェイスと他のネットワーキング デバイス(ルータ、switchなど)の間のポイントツーポイント リンクです。 イーサネット トランクは 1 つのリンクを介して複数の VLAN トラフィックを伝送するので、VLAN をネットワーク全体に拡張できます。

すべてのイーサネット インターフェイス上で、次のトランキング カプセル化方式を使用できます。

  • IEEE 802.1Q:業界標準のトランキング カプセル化方式です。

トランキング モード

イーサネット トランク インターフェイスは、さまざまなトランキング モードをサポートします。 インターフェイスをトランキングまたは非トランキングとして設定したり、ネイバー インターフェイスとトランキングのネゴシエーションを行ったりするように設定できます。 トランキングを自動ネゴシエーションするには、インターフェイスが同じ VTP ドメインに存在する必要があります。

トランク ネゴシエーションは、ポイントツーポイント プロトコル(PPP)であるダイナミック トランキング プロトコル(DTP)によって管理されます。 ただし、一部のインターネットワーキング デバイスによって DTP フレームが不正に転送されて、矛盾した設定となる場合があります。

この事態を避けるには、DTP をサポートしないデバイスに接続されたインターフェイスが DTP フレームを転送しないように、つまり DTP をオフにするように設定する必要があります。

  • これらのリンク上でトランキングを行わない場合は、switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、トランキングをディセーブルにします。

レイヤ 2 インターフェイス モード

表 1 レイヤ 2 インターフェイス モード

モード

機能

switchport mode access

インターフェイス(アクセス ポート)を永続的な非トランキング モードにして、リンクの非トランク リンクへの変換をネゴシエートします。 インターフェイスは、ネイバー インターフェイスがトランク インターフェイスかどうかに関係なく、非トランク インターフェイスになります。

switchport mode dynamic auto

インターフェイスがリンクをトランク リンクに変換できるようにします。 インターフェイスは、ネイバー インターフェイスが trunk または desirable モードに設定されている場合、トランク インターフェイスになります。 すべてのイーサネット インターフェイスのデフォルトのスイッチポート モードは、dynamic auto です。

switchport mode dynamic desirable

インターフェイスがリンクのトランク リンクへの変換をアクティブに実行するようにします。 隣接インターフェイスが trunk desirable、または auto モードに設定されている場合、インターフェイスはトランク インターフェイスになります。

switchport mode trunk

インターフェイスを永続的なトランキング モードにして、ネイバー リンクのトランク リンクへの変換をネゴシエートします。 インターフェイスは、ネイバー インターフェイスがトランク インターフェイスでない場合でも、トランク インターフェイスになります。

switchport nonegotiate

インターフェイスが DTP フレームを生成しないようにします。 このコマンドは、インターフェイス スイッチポート モードが access または trunk の場合だけ使用できます。 トランク リンクを確立するには、手動でネイバー インターフェイスをトランク インターフェイスとして設定する必要があります。

switchport mode dot1q-tunnel

インターフェイスをトンネル(非トランキング)ポートとして設定し、IEEE 802.1Q トランク ポートと非対称リンクで接続されるようにします。 IEEE 802.1Q トンネリングは、サービス プロバイダー ネットワーク全体でカスタマー VLAN の整合性を維持するのに使用されます。

switchport mode private-vlan

プライベート VLAN モードを設定します。

(注)     

switchport mode private-vlan コマンド オプションはサポートされていません。

トランクでの許可 VLAN

デフォルトでは、トランク ポートはすべての VLAN に対してトラフィックを送受信します。 各トランクですべての VLAN ID(1 ~ 4094)が許可されます。 ただし、許可リストから VLAN を削除することにより、それらの VLAN からのトラフィックがトランク上を流れないようにすることができます。

スパニングツリー ループまたはストームのリスクを減らすには、許可リストから VLAN 1 を削除して個々の VLAN トランク ポートの VLAN 1 をディセーブルにできます。 トランク ポートから VLAN 1 を削除した場合、インターフェイスは引き続き VLAN 1 内で Cisco Discovery Protocol(CDP)、ポート集約プロトコル(PAgP)、Link Aggregation Control Protocol(LACP)、DTP、および VTP などの管理トラフィックを送受信します。

VLAN 1 をディセーブルにしたトランク ポートが非トランク ポートになると、そのポートはアクセス VLAN に追加されます。 アクセス VLAN が 1 に設定されると、switchport trunk allowed の設定には関係なく、ポートは VLAN 1 に追加されます。 ポート上でディセーブルになっている任意の VLAN について同様のことが当てはまります。

トランク ポートは、VLAN がイネーブルになっており、VTP が VLAN を認識し、なおかつポートの許可リストにその VLAN が登録されている場合に、VLAN のメンバになることができます。 VTP が新しくイネーブルにされた VLAN を認識し、その VLAN がトランク ポートの許可リストに登録されている場合、トランク ポートは自動的にその VLAN のメンバになります。 VTP が新しい VLAN を認識し、その VLAN がトランク ポートの許可リストに登録されていない場合には、トランク ポートはその VLAN のメンバにはなりません。

トランク ポートでの負荷分散

負荷分散を行うと、switchesに接続するパラレル トランクによって提供される帯域幅が分割されます。 ループを防止するために、STP は通常、switches間で 1 つのパラレル リンク以外のすべてのリンクをブロックします。 負荷分散を行うと、トラフィックの所属する VLAN に基づいて、リンク間でトラフィックが分散されます。

トランク ポートで負荷分散を設定するには、STP ポート プライオリティまたは STP パス コストを使用します。 STP ポート プライオリティを使って負荷分散を行うには、両方の負荷分散リンクを同じswitchに接続する必要があります。 STP パス コストを使って負荷分散を行う場合には、それぞれの負荷分散リンクを同一のswitchに接続することも、2 台の異なるswitchesスイッチに接続することもできます。

STP プライオリティによるネットワークの負荷分散

同一switch上の 2 つのポートがループを形成する場合、switchは STP ポート プライオリティを使用して、どのポートをイネーブルにし、どのポートをブロッキング ステートにするかを決定します。 パラレル トランク ポートにプライオリティを設定することにより、そのポートに、特定の VLAN のすべてのトラフィックを伝送させることができます。 VLAN に対するプライオリティの高い(値の小さい)トランク ポートがその VLAN のトラフィックを転送します。 同じ VLAN に対してプライオリティの低い(値の大きい)トランク ポートは、その VLAN に対してブロッキング ステートのままです。 1 つのトランク ポートが特定の VLAN に関するすべてのトラフィックを送受信することになります。

STP パス コストによるネットワークの負荷分散

トランクにそれぞれ異なるパス コストを設定し、各パス コストをそれぞれ異なる VLAN 群に対応付け、各 VLAN でポートをブロックすることによって、VLAN トラフィックを分散するパラレル トランクを設定できます。 VLAN はトラフィックを分離し、リンクが失われた場合に備えて冗長性を維持します。

機能の相互作用

トランキングは他の機能と次のように相互作用します。

  • トランク ポートをセキュア ポートにすることはできません。

  • トランク ポートは、トンネル ポートにできません。

  • トランク ポートをまとめて EtherChannel ポート グループにすることはできますが、グループ内のすべてのトランクに同じ設定をする必要があります。 グループを初めて作成したときには、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。 次に示すパラメータのいずれかの設定を変更すると、switchは、入力された設定をグループ内のすべてのポートに伝播します。
    • 許可 VLAN リスト。

    • 各 VLAN の STP ポート プライオリティ。

    • STP PortFast の設定値。

    • トランク ステータス。

      ポート グループ内の 1 つのポートがトランクではなくなると、すべてのポートがトランクでなくなります。

  • 構成するトランク ポートの数を、VLAN 単位のスパニングツリー(PVST)モードでは 24 以下、マルチ スパニングツリー(MST)モードでは 40 以下に抑えることを推奨します。

  • トランク ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。 IEEE 802.1x 対応ポートのモードをトランクに変更しようとしても、ポート モードは変更されません。

  • ダイナミック モードのポートは、ネイバーとトランク ポートへの変更をネゴシエートする場合があります。 ダイナミック ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。 IEEE 802.1x 対応ポートをダイナミックに変更しようとしても、ポート モードは変更されません。

レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

次の表に、レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定を記載します。

表 2 レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

機能

デフォルト設定

インターフェイス モード

switchport mode dynamic auto

トランク カプセル化

switchport trunk encapsulation negotiate

VLAN 許容範囲

VLAN 1 ~ 4094

プルーニングに適格な VLAN 範囲

VLAN 2 ~ 1001

デフォルト VLAN(アクセス ポート用)

VLAN 1

ネイティブ VLAN(IEEE 802.1Q トランク用)

VLAN 1

VLAN トランクの設定方法

トランキングの設定ミスを防ぐには、DTP をサポートしないデバイスに接続されるインターフェイスが DTP フレームを転送しないように設定する(つまり DTP をオフにする)必要があります。

  • これらのリンク上でトランキングを行わない場合は、switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、トランキングをディセーブルにします。

  • DTP をサポートしていないデバイスへのトランキングをイネーブルにするには、switchport mode trunk および switchport nonegotiate インターフェイス コンフィギュレーション コマンドを使用して、インターフェイスがトランクになっても DTP フレームを生成しないように設定します。

トランク ポートとしてのイーサネット インターフェイスの設定

トランク ポートの設定

トランク ポートは VTP アドバタイズを送受信するため、VTP を使用するためには、switch上で少なくとも 1 つのトランク ポートを設定し、そのトランク ポートを別のswitchのトランク ポートに接続する必要があります。 こうしないと、switchは VTP アドバタイズを受信できません。

はじめる前に
手順の概要

    1.    enable

    2.    configure terminal

    3.    interface interface-id

    4.    switchport mode {dynamic {auto | desirable} | trunk}

    5.    switchport access vlan vlan-id

    6.    switchport trunk native vlan vlan-id

    7.    end

    8.    show interfaces interface-id switchport

    9.    show interfaces interface-id trunk

    10.    copy running-config startup-config


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Switch> enable
    
    
     

    特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

     

    ステップ 2configure terminal


    例:
    
    Switch# configure terminal
    
    
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3interface interface-id


    例:
    Switch(config)# interface gigabitethernet1/0/2
    
    
     

    トランクに設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 4switchport mode {dynamic {auto | desirable} | trunk}


    例:
    Switch(config-if)# switchport mode dynamic desirable
    
    
     

    インターフェイスをレイヤ 2 トランクとして設定します(インターフェイスがレイヤ 2 アクセス ポートまたはトンネル ポートである場合、あるいはトランキング モードを設定する場合に限り必要となります)。

    • dynamic auto:隣接インターフェイスが trunk または desirable モードに設定されている場合に、インターフェイスをトランク リンクに設定します。 これはデフォルトです。

    • dynamic desirable:隣接インターフェイスが trunk、desirable、または auto モードに設定されている場合に、インターフェイスをトランク リンクに設定します。

    • trunk:隣接インターフェイスがトランク インターフェイスでない場合でも、インターフェイスを永続的なトランキング モードに設定して、リンクをトランク リンクに変換するようにネゴシエートします。

     
    ステップ 5switchport access vlan vlan-id


    例:
    Switch(config-if)# switchport access vlan 200
    
    
     

    (任意)インターフェイスがトランキングを停止した場合に使用するデフォルト VLAN を指定します。

     
    ステップ 6switchport trunk native vlan vlan-id


    例:
    Switch(config-if)# switchport trunk native vlan 200
    
    
     

    IEEE 802.1Q トランク用のネイティブ VLAN を指定します。

     
    ステップ 7end


    例:
    
    Switch(config)# end
    
    
     

    特権 EXEC モードに戻ります。

     
    ステップ 8show interfaces interface-id switchport


    例:
    Switch# show interfaces gigabitethernet1/0/2 switchport
    
    
     

    インターフェイスのスイッチポート設定を [Administrative Mode] フィールドおよび [Administrative Trunking Encapsulation] フィールドに表示します。

     
    ステップ 9show interfaces interface-id trunk


    例:
    Switch# show interfaces gigabitethernet1/0/2 trunk
    
    
     

    インターフェイスのトランクの設定を表示します。

     
    ステップ 10copy running-config startup-config


    例:
    Switch# copy running-config startup-config
    
    
     

    (任意)コンフィギュレーション ファイルに設定を保存します。

    (注)     

    インターフェイスをデフォルト設定に戻すには、default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。 トランキング インターフェイスのすべてのトランキング特性をデフォルトにリセットするには、no switchport trunk インターフェイス コンフィギュレーション コマンドを使用します。 トランキングをディセーブルにするには、switchport mode access インターフェイス コンフィギュレーション コマンドを使用して、ポートをスタティック アクセス ポートとして設定します。

     
    関連コンセプト

    トランクでの許可 VLAN の定義

    VLAN 1 は、すべての Cisco switchesのすべてのトランク ポート上のデフォルト VLAN です。以前は、すべてのトランク リンクで VLAN 1 を常にイネーブルにする必要がありました。 VLAN 1 の最小化機能を使用して、個々の VLAN トランク リンクで VLAN 1 をディセーブルに設定できます。これにより、ユーザ トラフィック(スパニングツリー アドバタイズなど)は VLAN 1 で送受信されなくなります。

    手順の概要

      1.    configure terminal

      2.    interface interface-id

      3.    switchport mode trunk

      4.    switchport trunk allowed vlan {add | all | except | none | remove} vlan-list

      5.    end

      6.    show interfaces interface-id switchport

      7.    copy running-config startup-config


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1configure terminal


      例:
      
      Switch# configure terminal
      
      
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2interface interface-id


      例:
      Switch(config)# interface gigabitethernet1/0/1
      
      
       

      設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 3switchport mode trunk


      例:
      Switch(config-if)# switchport mode trunk
      
      
       

      インターフェイスを VLAN トランク ポートとして設定します。

       
      ステップ 4switchport trunk allowed vlan {add | all | except | none | remove} vlan-list


      例:
      Switch(config-if)# switchport trunk allowed vlan remove 2
      
      
       

      (任意)トランク上で許容される VLAN のリストを設定します。

      vlan-list パラメータは、1 ~ 4094 の単一の VLAN 番号、または 2 つの VLAN 番号(小さい方が先、ハイフンで区切る)で指定された VLAN 範囲です。 カンマで区切った VLAN パラメータの間、またはハイフンで指定した範囲の間には、スペースを入れないでください。

      デフォルトでは、すべての VLAN が許可されます。

       
      ステップ 5end


      例:
      
      Switch(config)# end
      
      
       

      特権 EXEC モードに戻ります。

       
      ステップ 6show interfaces interface-id switchport


      例:
      Switch# show interfaces gigabitethernet1/0/1 switchport
      
      
       

      表示された [Trunking VLANs Enabled] フィールドの設定を確認します。

       
      ステップ 7copy running-config startup-config


      例:
      Switch# copy running-config startup-config
      
      
       

      (任意)コンフィギュレーション ファイルに設定を保存します。

      (注)     

      すべての VLAN からなるデフォルト許可 VLAN リストに戻るには、no switchport trunk allowed vlan インターフェイス コンフィギュレーション コマンドを使用します。

       

      プルーニング適格リストの変更

      プルーニング適格リストは、トランク ポートだけに適用されます。 トランク ポートごとに独自の適格リストがあります。 この手順を有効にするには、VTP プルーニングがイネーブルに設定されている必要があります。

      手順の概要

        1.    enable

        2.    configure terminal

        3.    interface interface-id

        4.    switchport trunk pruning vlan {add | except | none | remove} vlan-list [,vlan [,vlan [,,,]]

        5.    end

        6.    show interfaces interface-id switchport

        7.    copy running-config startup-config


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Switch> enable
        
        
         

        特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

         

        ステップ 2configure terminal


        例:
        
        Switch# configure terminal
        
        
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3interface interface-id


        例:
        Switch(config)# interface gigabitethernet2/0/1
        
        
         

        VLAN プルーニングを適用するトランク ポートを選択し、インターフェイス コンフィギュレーション モードを開始します。

         
        ステップ 4switchport trunk pruning vlan {add | except | none | remove} vlan-list [,vlan [,vlan [,,,]]
         

        トランクからのプルーニングを許可する VLAN のリストを設定します。

        addexceptnone、および remove キーワードの使用方法については、このリリースに対応するコマンド リファレンスを参照してください。

        連続していない複数の VLAN ID は、カンマ(スペースなし)で区切ります。ID の範囲はハイフンで指定します。 有効な ID 範囲は 2 ~ 1001 です。 拡張範囲 VLAN(VLAN ID 1006 ~ 4094)はプルーニングできません。

        プルーニング不適格の VLAN は、フラッディング トラフィックを受信します。

        デフォルトでは、プルーニングが許可される VLAN のリストには、VLAN 2 ~ 1001 が含まれます。

        (注)     

        すべての VLAN のプルーニング適格リストをデフォルトに戻すには、no switchport trunk pruning vlan インターフェイス コンフィギュレーション コマンドを使用します。

         
        ステップ 5end


        例:
        
        Switch(config)# end
        
        
         

        特権 EXEC モードに戻ります。

         
        ステップ 6show interfaces interface-id switchport


        例:
        Switch# show interfaces gigabitethernet2/0/1 switchport
        
        
         

        表示された [Pruning VLANs Enabled] フィールドの設定を確認します。

         
        ステップ 7copy running-config startup-config


        例:
        Switch# copy running-config startup-config
        
        
         

        (任意)コンフィギュレーション ファイルに設定を保存します。

         

        タグなしトラフィック用ネイティブ VLAN の設定

        IEEE 802.1Q タギングが設定されたトランク ポートは、タグ付きトラフィックおよびタグなしトラフィックの両方を受信できます。 デフォルトで、switchは、ポートに設定されたネイティブ VLAN でタグなしトラフィックを転送します。 ネイティブ VLAN は、デフォルトでは VLAN 1 です。

        ネイティブ VLAN には任意の VLAN ID を割り当てることができます。

        パケットの VLAN ID が出力ポートのネイティブ VLAN ID と同じであれば、そのパケットはタグなしで送信されます。ネイティブ VLAN ID と異なる場合、switchはそのパケットをタグ付きで送信します。

        手順の概要

          1.    enable

          2.    configure terminal

          3.    interface interface-id

          4.    switchport trunk native vlan vlan-id

          5.    end

          6.    show interfaces interface-id switchport

          7.    copy running-config startup-config


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Switch> enable
          
          
           

          特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

           

          ステップ 2configure terminal


          例:
          
          Switch# configure terminal
          
          
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3interface interface-id


          例:
          Switch(config)# interface gigabitethernet1/0/2
          
          
           

          IEEE 802.1Q トランクとして設定するインターフェイスを定義して、インターフェイス コンフィギュレーション モードを開始します。

           
          ステップ 4switchport trunk native vlan vlan-id


          例:
          Switch(config-if)# switchport trunk native vlan 12
          
          
           

          トランク ポート上でタグなしトラフィックを送受信する VLAN を設定します。

          vlan-id に指定できる範囲は 1 ~ 4094 です。

           
          ステップ 5end


          例:
          Switch(config-if)# end
          
          
           

          特権 EXEC モードに戻ります。

           
          ステップ 6show interfaces interface-id switchport


          例:
          Switch# show interfaces gigabitethernet1/0/2 switchport
          
          
           

          [Trunking Native Mode VLAN] フィールドの設定を確認します。

           
          ステップ 7copy running-config startup-config


          例:
          Switch# copy running-config startup-config
          
          
           

          (任意)コンフィギュレーション ファイルに設定を保存します。

           

          トランク ポートの負荷分散の設定

          STP ポート プライオリティによる負荷分散の設定

          switchswitch スタックのメンバである場合、spanning-tree [vlan vlan-id] port-priority priority インターフェイス コンフィギュレーション コマンドの代わりに、spanning-tree [vlan vlan-id] cost cost インターフェイス コンフィギュレーション コマンドを使用して、フォワーディング ステートにするインターフェイスを選択する必要があります。 最初に選択させるインターフェイスには、低いコスト値を割り当て、最後に選択させるインターフェイスには高いコスト値を割り当てます。

          次の手順では、STP ポート プライオリティを使って負荷分散を行うネットワークの設定方法について説明しています。

          手順の概要

            1.    enable

            2.    configure terminal

            3.    vtp domain domain-name

            4.    vtp mode server

            5.    end

            6.    show vtp status

            7.    show vlan

            8.    configure terminal

            9.    interface interface-id

            10.    switchport mode trunk

            11.    end

            12.    show interfaces interface-id switchport

            13.    Switch またはswitchスタック内の別のポートのswitch A で上記の手順を繰り返します。

            14.    Switch B で上記の手順を繰り返し、Switch A に設定されたトランク ポートに接続するトランク ポートを設定します。

            15.    show vlan

            16.    configure terminal

            17.    interface interface-id

            18.    spanning-tree vlan vlan-range port-priority priority-value

            19.    exit

            20.    interface interface-id

            21.    spanning-tree vlan vlan-range port-priority priority-value

            22.    end

            23.    show running-config

            24.    copy running-config startup-config


          手順の詳細
             コマンドまたはアクション目的
            ステップ 1 enable


            例:
            Switch> enable
            
            
             

            特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

             

            ステップ 2configure terminal


            例:
            Switch# configure terminal
            
            
             

            Switch A で、グローバル コンフィギュレーション モードを開始します。

             
            ステップ 3vtp domain domain-name


            例:
            Switch(config)# vtp domain workdomain
            
            
             

            VTP 管理ドメインを設定します。

            1 ~ 32 文字のドメイン名を使用できます。

             
            ステップ 4vtp mode server


            例:
            Switch(config)# vtp mode server
            
            
             

            Switch A を VTP サーバとして設定します。

             
            ステップ 5end


            例:
            
            Switch(config)# end
            
            
             

            特権 EXEC モードに戻ります。

             
            ステップ 6show vtp status


            例:
            Switch# show vtp status
            
            
             

            Switch A およびSwitch B の両方で、VTP 設定を確認します。

            表示された [VTP Operating Mode] フィールドおよび [VTP Domain Name] フィールドをチェックします。

             
            ステップ 7show vlan


            例:
            Switch# show vlan
            
            
             

            Switch A のデータベースに VLAN が存在していることを確認します。

             
            ステップ 8configure terminal


            例:
            Switch# configure terminal
            
            
             

            グローバル コンフィギュレーション モードを開始します。

             
            ステップ 9interface interface-id


            例:
            Switch(config)# interface gigabitethernet1/0/1
            
            
             

            トランクとして設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

             
            ステップ 10switchport mode trunk


            例:
            Switch(config-if)# switchport mode trunk
            
            
             

            ポートをトランク ポートとして設定します。

             
            ステップ 11end


            例:
            Switch(config-if)# end
            
            
             

            特権 EXEC モードに戻ります。

             
            ステップ 12show interfaces interface-id switchport


            例:
            Switch# show interfaces gigabitethernet1/0/1 switchport
            
            
             

            VLAN の設定を確認します。

             
            ステップ 13 Switch またはswitchスタック内の別のポートのswitch A で上記の手順を繰り返します。    
            ステップ 14Switch B で上記の手順を繰り返し、Switch A に設定されたトランク ポートに接続するトランク ポートを設定します。    
            ステップ 15show vlan


            例:
            Switch# show vlan
            
            
             

            トランク リンクがアクティブになると、VTP はSwitch B に VTP および VLAN 情報を渡します。 このコマンドは、Switch B が VLAN 設定を学習したことを確認します。

             
            ステップ 16configure terminal


            例:
            Switch# configure terminal
            
            
             

            Switch A でグローバル コンフィギュレーション モードを開始します。

             
            ステップ 17interface interface-id


            例:
            Switch(config)# interface gigabitethernet1/0/1
            
            
             

            STP ポート プライオリティを設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

             
            ステップ 18spanning-tree vlan vlan-range port-priority priority-value


            例:
            Switch(config-if)# spanning-tree vlan 8-10 port-priority 16
            
             

            指定した VLAN 範囲のポート プライオリティを割り当てます。 0 ~ 240 のポート プライオリティ値を入力します。 ポート プライオリティの増分値は 16 です。

             
            ステップ 19exit


            例:
            Switch(config-if)# exit
            
            
             

            グローバル コンフィギュレーション モードに戻ります。

             
            ステップ 20interface interface-id


            例:
            Switch(config)# interface gigabitethernet1/0/2
            
            
             

            STP ポート プライオリティを設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

             
            ステップ 21spanning-tree vlan vlan-range port-priority priority-value


            例:
            Switch(config-if)# spanning-tree vlan 3-6 port-priority 16
            
            
             

            指定した VLAN 範囲のポート プライオリティを割り当てます。 0 ~ 240 のポート プライオリティ値を入力します。 ポート プライオリティの増分値は 16 です。

             
            ステップ 22end


            例:
            Switch(config-if)# end
            
            
             

            特権 EXEC モードに戻ります。

             
            ステップ 23show running-config


            例:
            Switch# show running-config
            
            
             

            入力を確認します。

             
            ステップ 24copy running-config startup-config


            例:
            Switch# copy running-config startup-config
            
            
             

            (任意)コンフィギュレーション ファイルに設定を保存します。

             

            STP パス コストによる負荷分散の設定

            次の手順では、STP パス コストを使って負荷分散を行うネットワークの設定方法について説明します。

            手順の概要

              1.    enable

              2.    configure terminal

              3.    interface interface-id

              4.    switchport mode trunk

              5.    exit

              6.    Switch A またはSwitch A スタック内の別のインターフェイスでステップ 2 ~ 4 を繰り返します。

              7.    end

              8.    show running-config

              9.    show vlan

              10.    configure terminal

              11.    interface interface-id

              12.    spanning-tree vlan vlan-range cost cost-value

              13.    end

              14.    Switch A で設定したもう一方のトランク インターフェイスでステップ 9 ~ 13 を繰り返し、VLAN 8、9、および 10 のスパニングツリー パス コストを 30 に設定します。

              15.    exit

              16.    show running-config

              17.    copy running-config startup-config


            手順の詳細
               コマンドまたはアクション目的
              ステップ 1 enable


              例:
              Switch> enable
              
              
               

              特権 EXEC モードをイネーブルにします。 パスワードを入力します(要求された場合)。

               

              ステップ 2configure terminal


              例:
              Switch# configure terminal
              
              
               

              Switch A でグローバル コンフィギュレーション モードを開始します。

               
              ステップ 3interface interface-id


              例:
              Switch(config)# interface gigabitethernet1/0/1
              
              
               

              トランクとして設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

               
              ステップ 4switchport mode trunk


              例:
              Switch(config-if)# switchport mode trunk
              
              
               

              ポートをトランク ポートとして設定します。

               
              ステップ 5exit


              例:
              Switch(config-if)# exit
              
              
               

              グローバル コンフィギュレーション モードに戻ります。

               
              ステップ 6Switch A またはSwitch A スタック内の別のインターフェイスでステップ 2 ~ 4 を繰り返します。    
              ステップ 7end


              例:
              
              Switch(config)# end
              
              
               

              特権 EXEC モードに戻ります。

               
              ステップ 8show running-config


              例:
              Switch# show running-config
              
              
               

              入力を確認します。 画面で、インターフェイスがトランク ポートとして設定されていることを確認してください。

               
              ステップ 9show vlan


              例:
              Switch# show vlan
              
              
               

              トランク リンクがアクティブになると、Switch A が他のswitchesから VTP 情報を受信します。 このコマンドは、Switch A が VLAN 設定を学習したことを確認します。

               
              ステップ 10configure terminal


              例:
              Switch# configure terminal
              
              
               

              グローバル コンフィギュレーション モードを開始します。

               
              ステップ 11interface interface-id


              例:
              Switch(config)# interface gigabitethernet1/0/1
              
              
               

              STP コストを設定するインターフェイスを定義し、インターフェイス コンフィギュレーション モードを開始します。

               
              ステップ 12spanning-tree vlan vlan-range cost cost-value


              例:
              Switch(config-if)# spanning-tree vlan 2-4 cost 30
              
              
               

              VLAN 2 ~ 4 のスパニングツリー パス コストを 30 に設定します。

               
              ステップ 13end


              例:
              Switch(config-if)# end
              
              
               

              グローバル コンフィギュレーション モードに戻ります。

               
              ステップ 14Switch A で設定したもう一方のトランク インターフェイスでステップ 9 ~ 13 を繰り返し、VLAN 8、9、および 10 のスパニングツリー パス コストを 30 に設定します。    
              ステップ 15exit


              例:
              Switch(config)# exit
              
              
               

              特権 EXEC モードに戻ります。

               
              ステップ 16show running-config


              例:
              Switch# show running-config
              
              
               

              入力を確認します。 両方のトランク インターフェイスに対してパス コストが正しく設定されていることを表示で確認します。

               
              ステップ 17copy running-config startup-config


              例:
              Switch# copy running-config startup-config
              
              
               

              (任意)コンフィギュレーション ファイルに設定を保存します。

               

              VLAN トランキングの設定例

              例:IEEE 802.1Q トランクの設定

              次に、IEEE 802.1Q トランクとしてポートを設定する例を示します。 この例では、ネイバー インターフェイスが IEEE 802.1Q トランキングをサポートするように設定されていることを前提としています。

              Switch# configure terminal
              Enter configuration commands, one per line. End with CNTL/Z.
              Switch(config)# interface gigabitethernet0/2
              Switch(config-if)# switchport mode dynamic desirable
              Switch(config-if)# switchport trunk encapsulation dot1q
              Switch(config-if)# end
              
              
              関連コンセプト

              例:VLAN の削除

              次に、ポートの許可 VLAN リストから VLAN 2 を削除する例を示します。

              Switch(config)# interface gigabitethernet0/1
              Switch(config-if)# switchport trunk allowed vlan remove 2
              Switch(config-if)# end
              
              

              次の作業

              VLAN トランクを設定した後は、次の設定を行うことができます。

              • VTP

              • VLAN

              • プライベート VLAN

              • VLAN メンバーシップ ポリシー サーバ(VMPS)

              • トンネリング

              • 音声 VLAN

              その他の関連資料

              関連資料

              関連項目 マニュアル タイトル

              この章で使用するコマンドの完全な構文および使用方法の詳細。

              Catalyst 2960-XR Switch VLAN Management Command Reference

              標準および RFC

              標準/RFC タイトル

              MIB

              MIB MIB のリンク
              本リリースでサポートするすべての MIB

              選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに関する MIB を探してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

              http:/​/​www.cisco.com/​go/​mibs

              テクニカル サポート

              説明 リンク

              シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

              お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

              シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

              http:/​/​www.cisco.com/​support

              VLAN トランクの機能履歴と情報

              リリース 変更内容

              Cisco IOS 15.0(2)EX1

              この機能が導入されました。