Cisco Catalyst Blade Switch 3130 および 3032 for Dell Software コンフィギュレーション ガイド
IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定
IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定
発行日;2012/01/31 | 英語版ドキュメント(2011/05/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定

IEEE 802.1Q トンネリングの概要

IEEE 802.1Q トンネリングの設定

IEEE 802.1Q トンネリングのデフォルト設定

IEEE 802.1Q トンネリング設定時の注意事項

ネイティブ VLAN

システム最大伝送ユニット

IEEE 802.1Q トンネリングおよびその他の機能

IEEE 802.1Q トンネリング ポートの設定

レイヤ 2 プロトコル トンネリングの概要

レイヤ 2 プロトコル トンネリングの設定

レイヤ 2 プロトコル トンネリングのデフォルト設定

レイヤ 2 プロトコル トンネリング設定時の注意事項

レイヤ 2 プロトコル トンネリングの設定

EtherChannel のレイヤ 2 トンネリングの設定

SP エッジ スイッチの設定

カスタマー スイッチの設定

トンネリング ステータスのモニタリングおよびメンテナンス

IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)では、多くの場合にイーサネットベースの共有インフラストラクチャである企業規模の接続に、プライベート ネットワークと同じセキュリティ、プライオリティ、信頼性、管理の容易さが提供されます。トンネリングは、サービス プロバイダーのネットワーク経由で複数のカスタマーのトラフィックを運び、その他のカスタマーのトラフィックに影響を与えずに、それぞれのカスタマーの VLAN およびレイヤ 2 プロトコルの設定を維持する必要があるサービス プロバイダー用に設計された機能です。スイッチは、IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングをサポートします。特に記述がない限り、 スイッチ という用語はスタンドアロン スイッチとスイッチ スタックを意味しています。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章の内容は次のとおりです。

「IEEE 802.1Q トンネリングの概要」

「IEEE 802.1Q トンネリングの設定」

「レイヤ 2 プロトコル トンネリングの概要」

「レイヤ 2 プロトコル トンネリングの設定」

「トンネリング ステータスのモニタリングおよびメンテナンス」

IEEE 802.1Q トンネリングの概要

サービス プロバイダーのビジネス カスタマーには、VLAN ID およびサポートされる VLAN 数について固有の要件がある場合が多くあります。同一サービス プロバイダー ネットワークのさまざまなカスタマーが必要とする VLAN 範囲は重複し、インフラストラクチャを通るカスタマーのトラフィックは混在することがあります。それぞれのカスタマーに VLAN ID の固有の範囲を割り当てると、カスタマーの設定が制限され、IEEE 802.1Q 仕様の VLAN 制限(4096)を簡単に超えてしまうことがあります。

サービス プロバイダーは、IEEE 802.1Q トンネリング機能を使用すると、単一の VLAN を使用して、複数の VLAN を含むカスタマーをサポートできます。サービス プロバイダー ネットワーク内でカスタマー VLAN ID が保持され、同じ VLAN 上に存在するように見える、異なるカスタマーからのトラフィックが分離されます。IEEE 802.1Q トンネリングを使用する場合、VLAN-in-VLAN 階層構造およびタグ付きパケットへの再タグ付けによって、VLAN スペースを拡張できます。IEEE 802.1Q トンネリングをサポートするように設定したポートは、 トンネル ポート と呼ばれます。トンネリングを設定する場合、トンネリング専用の VLAN ID にトンネル ポートを割り当てます。それぞれのカスタマーには別個のサービス プロバイダー VLAN ID が必要ですが、その VLAN ID ではすべてのカスタマーの VLAN がサポートされます。

カスタマー デバイスの IEEE 802.1Q トランク ポートから、通常どおりに適切な VLAN ID でタグ付けされたカスタマー トラフィックが、サービス プロバイダー エッジ スイッチのトンネル ポートに着信します。カスタマー デバイスとエッジ スイッチの間のリンクは、一方の端が IEEE802.1Q トランク ポート、反対側がトンネル ポートとして設定されているため、非対称です。それぞれのカスタマーに固有のアクセス VLAN ID には、トンネル ポート インターフェイスを割り当てます。図 17-1 を参照してください。

図 17-1 サービス プロバイダー ネットワークの IEEE 802.1Q トンネル ポート

 

カスタマー トランク ポートからサービス プロバイダー エッジ スイッチのトランク ポートに着信するパケットは、通常、適切な VLAN ID で IEEE 802.1Q タグ付けされています。これらのタグ付きパケットは、スイッチ内部でそのまま保持され、トランク ポートを出てサービス プロバイダー ネットワークに入る時点で、カスタマーに固有の VLAN ID を含む、IEEE 802.1Q タグのもう 1 つのレイヤ( メトロ タグ と呼ばれる)でカプセル化されます。このカプセル化されたパケットの中に、カスタマーの元の IEEE 802.1Q タグが残されます。したがって、パケットはサービス プロバイダー ネットワークに入る時点で、二重のタグが付いていることになります。外側の(メトロ)タグはカスタマーのアクセス VLAN ID を含み、内側の VLAN ID は着信トラフィックの VLAN です。

二重タグ付きパケットがサービス プロバイダー コア スイッチ上の別のトランク ポートに着信すると、スイッチでパケットが処理されるときに、外側のタグが削除されます。パケットが同じコア スイッチ上の別のトランク ポートから発信される時点で、同じメトロ タグが再びパケットに追加されます。図 17-2 に、二重タグ付きパケットのタグ構造を示します。

図 17-2 元の(標準)、IEEE 802.1Q、および二重タグ付きイーサネット パケットのフォーマット

 

パケットがサービス プロバイダー出力スイッチ上のトランク ポートに着信すると、スイッチ内部でパケットが処理されるときに、外側のタグが再び削除されます。ただし、エッジ スイッチ上のトンネル ポートからカスタマー ネットワークに送出される時点では、メトロ タグは追加されません。パケットは通常の IEEE 802.1Q タグ付きフレームとして送信され、カスタマー ネットワーク内の元の VLAN 番号が保持されます。

図 17-1 の場合、カスタマー A には VLAN 30、カスタマー B には VLAN 40 が割り当てられています。エッジ スイッチのトンネル ポートに IEEE 802.1Q タグ付きで着信するパケットは、サービス プロバイダー ネットワークに入る時点で二重にタグ付けされます。外側のタグにはそれぞれ VLAN ID 30 または 40 が含まれ、内側のタグには元の VLAN 番号(たとえば、VLAN 100)が含まれます。カスタマー A および B の両方のネットワークに VLAN 100 があっても、外側のタグが異なるため、サービス プロバイダー ネットワーク内ではトラフィックが分離されています。各カスタマーはそれぞれ独自の VLAN 番号スペースを管理します。この VLAN 番号スペースは、他のカスタマーが使用する VLAN 番号スペースや、サービス プロバイダー ネットワークで使用される VLAN 番号スペースとは無関係です。

アウトバウンド トンネル ポートでは、カスタマーのネットワーク上の元の VLAN 番号が回復されます。トンネリングおよびタグ付けを複数のレベルにすることもできますが、このリリースのスイッチでは 1 レベルだけがサポートされます。

カスタマー ネットワークから着信するトラフィックにタグが付いていない場合(ネイティブ VLAN フレーム)、これらのパケットは通常のパケットと同じようにブリッジングまたはルーティングされます。エッジ スイッチのトンネル ポートを通ってサービス プロバイダー ネットワークに入るすべてのパケットは、タグが付いていないか、IEEE 802.1Q ヘッダーですでにタグが付いているかに関係なく、タグなしパケットとして扱われます。パケットは、IEEE 802.1Q トランク ポートでサービス プロバイダー ネットワークを通じて送信される場合、メトロ タグ VLAN ID(トンネル ポートのアクセス VLAN に設定)でカプセル化されます。メトロ タグのプライオリティ フィールドは、トンネル ポートに設定されているインターフェイスの Class of Service(CoS; サービス クラス)プライオリティに設定されます(プライオリティが設定されていない場合、デフォルトは 0 です)。

802.1Q トンネリングは、ポート単位で設定されるため、スイッチがスタンドアロン スイッチまたはスタック メンバーのいずれでもかまいません。すべての設定はスタック マスターで実行されます。

IEEE 802.1Q トンネリングの設定

ここでは、次の設定情報について説明します。

「IEEE 802.1Q トンネリングのデフォルト設定」

「IEEE 802.1Q トンネリング設定時の注意事項」

「IEEE 802.1Q トンネリングおよびその他の機能」

「IEEE 802.1Q トンネリング ポートの設定」

IEEE 802.1Q トンネリングのデフォルト設定

デフォルトの場合、デフォルト switchport モードが dynamic auto であるため、IEEE 802.1Q トンネルはディセーブルです。すべての IEEE 802.1Q トランク ポートにおける IEEE 802.1Q ネイティブ VLAN パケットのタグ付けもディセーブルです。

IEEE 802.1Q トンネリング設定時の注意事項

IEEE 802.1Q トンネリングを設定する場合は、カスタマー デバイスおよびエッジ スイッチの間で非対称リンクを常に使用する必要があります。カスタマー デバイスのポートを IEEE 802.1Q トランク ポートに、エッジ スイッチのポートをトンネル ポートとして設定してください。

トンネリングに使用する VLAN だけにトンネル ポートを割り当ててください。

ネイティブ VLAN および Maximum Transmission Unit(MTU; 最大伝送ユニット)の設定上の要件について、次に説明します。

ネイティブ VLAN

エッジ スイッチに IEEE 802.1Q トンネリングを設定する場合、IEEE 802.1Q トランク ポートを使用してサービス プロバイダー ネットワークにパケットを送信する必要があります。ただし、サービス プロバイダー ネットワークのコアを通過するパケットは、IEEE 802.1Q トランクまたは非トランキング リンクで伝送される場合があります。これらのコア スイッチで IEEE 802.1Q トランクを使用する場合、IEEE 802.1Q トランクのネイティブ VLAN は、同じスイッチ上の非トランキング(トンネリング)ポートのネイティブ VLAN と同じであってはなりません。ネイティブ VLAN 上のトラフィックは、IEEE 802.1Q 送信側トランク ポートでタグ付けされていない場合があるためです。

図 17-3 を参照してください。VLAN 40 は、サービス プロバイダー ネットワークの入力エッジ スイッチ(スイッチ B)において、カスタマー X からの IEEE 802.1Q トランク ポートのネイティブ VLAN として設定されています。カスタマー X のスイッチ A は、VLAN 30 でタグ付きパケットをサービス プロバイダー ネットワークのスイッチ B の入力トンネル ポート(アクセス VLAN 40 に所属)に送信します。トンネル ポートのアクセス VLAN(VLAN 40)は、エッジ スイッチのトランク ポートのネイティブ VLAN(VLAN 40)と同じであるため、トンネル ポートから受信したタグ付きパケットには、メトロ タグが追加されません。パケットはサービス プロバイダー ネットワーク経由で出力エッジ スイッチ(スイッチ C)のトランク ポートまで VLAN 30 タグだけで伝送され、この出力スイッチのトンネル ポートを通じて、不正にカスタマー Y へ送信されます。

この問題の解決方法は次のとおりです。

vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用し、ネイティブ VLAN を含む、IEEE 802.1Q トランクから発信されるすべてのパケットがタグ付けされるようにエッジ スイッチを設定します。すべての IEEE 802.1Q トランクでネイティブ VLAN パケットにタグを付けるようにスイッチを設定した場合、スイッチはタグなしパケットを受信しますが、タグ付きパケットだけを送信します。

エッジ スイッチのトランク ポートのネイティブ VLAN ID が、カスタマー VLAN 範囲に属さないようにします。たとえばトランク ポートが VLAN 100 ~ 200 のトラフィックを運ぶ場合は、この範囲以外の番号をネイティブ VLAN に割り当てます。

図 17-3 IEEE 802.1Q トンネリングおよびネイティブ VLAN に潜在する問題

 

システム最大伝送ユニット

スイッチでは、トラフィックのデフォルトのシステム最大伝送ユニットは、1500 バイトです。

system mtu jumbo グローバル コンフィギュレーション コマンドを使用すると、1500 バイトより大きいフレームをサポートするように、10 ギガビット イーサネット ポートおよびギガビットイーサネットを設定できます。

system jumbo MTU の値には、IEEE 802.1Q ヘッダーは含まれません。IEEE 802.1Q トンネリング機能では、メトロ タグが追加されると、フレーム サイズが 4 バイト増加するため、システム MTU サイズおよび system jumbo MTU サイズを 4 バイト増加して最大フレームを処理できるように、サービス プロバイダー ネットワークのすべてのスイッチを設定する必要があります。

たとえば、この設定でスイッチは、1496 バイトの最大フレーム サイズをサポートします。

スイッチのシステム ジャンボ MTU には 1500 バイトの値が設定されて、10 ギガビットまたはギガビット イーサネット スイッチ ポートには switchport mode dot1q tunnel インターフェイス コンフィギュレーション コマンドが設定されています。

IEEE 802.1Q トンネリングおよびその他の機能

IEEE 802.1Q トンネリングは、レイヤ 2 パケット スイッチングに関しては適切に動作しますが、一部のレイヤ 2 機能およびレイヤ 3 スイッチングとは非互換です。

トンネル ポートはルーテッド ポートにできません。

IEEE 802.1Q ポートを含む VLAN では IP ルーティングがサポートされません。トンネル ポートから受信したパケットは、レイヤ 2 情報だけに基づいて転送されます。トンネル ポートを含む Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)上でルーティングがイネーブルの場合、トンネル ポートから受信したタグなし IP パケットはスイッチによって認識され、ルーティングされます。カスタマーはネイティブ VLAN 経由でインターネットにアクセスできます。このアクセスが不要な場合には、トンネル ポートを含む VLAN 上に SVI を設定すべきではありません。

フォールバック ブリッジングは、トンネル ポートでサポートされません。トンネル ポートから受信したすべての IEEE 802.1Q タグ付きパケットは IP 以外のパケットとして扱われるため、トンネル ポートが設定されている VLAN でフォールバック ブリッジングがイネーブルである場合、IP パケットは VLAN を超えて不適切にブリッジングされます。このため、トンネル ポートを含む VLAN ではフォールバック ブリッジングをイネーブルに しないでください

トンネル ポートでは IP Access Control List(ACL; アクセス コントロール リスト)がサポートされません。

レイヤ 3 QoS(Quality of Service)ACL およびレイヤ 3 に関連するその他の QoS 機能の情報は、トンネル ポートでサポートされません。MAC ベースの QoS は、トンネル ポート上でサポートされます。

IEEE 802.1Q 設定が EtherChannel ポート グループ内で矛盾しない場合、EtherChannel ポート グループにはトンネル ポートとの互換性があります。

Port Aggregation Protocol(PAgP; ポート集約プロトコル)、Link Aggregation Control Protocol(LACP)、UniDirectional Link Detection(UDLD; 単一方向リンク検出)は、IEEE 802.1Q トンネリング ポートでサポートされます。

トンネル ポートとトランク ポートで非対称リンクを手動で設定する必要があるため、Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)には IEEE 802.1Q トンネリングとの互換性がありません。

VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)は、非対称リンクで接続されているデバイス間、またはトンネルを通して通信をおこなうデバイス間で動作しません。

IEEE 802.1Q トンネル ポートでは、ループバック検出がサポートされます。

IEEE 802.1Q トンネル ポートとしてポートを設定すると、スパニング ツリー Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)フィルタリングがインターフェイスで自動的にイネーブルになります。Cisco Discovery Protocol(CDP; シスコ検出プロトコル)および Layer Link Discovery Protocol(LLDP)は、インターフェイスで自動的にディセーブルになります。

IEEE 802.1Q トンネリング ポートの設定

IEEE 802.1Q トンネル ポートとしてポート設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始して、インターフェイスをトンネル ポートとして設定します。これは、カスタマー スイッチに接続するサービス プロバイダー ネットワークのエッジ ポートである必要があります。有効なインターフェイスには、物理インターフェイスおよびポート チャネル論理インターフェイス(ポート チャネル 1 ~ 64)が含まれます。

ステップ 3

switchport access vlan vlan-id

デフォルト VLAN を指定します。これは、インターフェイスがトランキングを停止した場合に使用されます。この VLAN ID は特定カスタマーに固有です。

ステップ 4

switchport mode dot1q-tunnel

IEEE 802.1Q トンネル ポートとしてインターフェイスを設定します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

vlan dot1q tag native

(任意)すべての IEEE 802.1Q トランク ポートでネイティブ VLAN パケットのタグ付けをイネーブルにするようにスイッチを設定します。設定しない場合、カスタマー VLAN ID がネイティブ VLAN と同じであれば、トランク ポートはメトロ タグを適用せず、パケットが不正な宛先に送信される可能性があります。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show running-config

show dot1q-tunnel

IEEE 802.1Q トンネリングが設定されたポートを表示します。

トンネル モードのポートを表示します。

ステップ 9

show vlan dot1q tag native

IEEE 802.1Q ネイティブ VLAN タグ付けステータスを表示します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ポートをデフォルトの状態(dynamic desirable)に戻すには、 no switchport mode dot1q-tunnel インターフェイス コンフィギュレーション コマンドを使用します。ネイティブ VLAN パケットのタグ付けをディセーブルにするには、 no vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用します。

次に、インターフェイスをトンネル ポートとして設定し、ネイティブ VLAN パケットのタグ付けをイネーブルにして、設定を確認する例を示します。この設定では、スタック メンバー 1 上のギガビット イーサネット インターフェイス 7 に接続するカスタマーの VLAN ID は VLAN 22 です。

Switch(config)# interface gigabitethernet1/0/7
Switch(config-if)# switchport access vlan 22
% Access VLAN does not exist. Creating vlan 22
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# exit
Switch(config)# vlan dot1q tag native
Switch(config)# end
Switch# show dot1q-tunnel interface gigabitethernet1/0/7
Port
-----
Gi1/0/1Port
-----
Switch# show vlan dot1q tag native
dot1q native vlan tagging is enabled

レイヤ 2 プロトコル トンネリングの概要

サービス プロバイダー ネットワーク経由で接続される複数のサイトのカスタマーは、さまざまなレイヤ 2 プロトコルを使用して、すべてのリモート サイトおよびローカル サイトを含むようにトポロジを拡大する必要があります。Spanning Tree Protocol(STP; スパニング ツリー プロトコル)が適切に稼動している必要があり、すべての VLAN が、ローカル サイトおよびサービス プロバイダー ネットワーク経由ですべてのリモート サイトを含む、適切なスパニング ツリーを構築する必要があります。シスコ検出プロトコル(CDP)では、ネイバー シスコ デバイスをローカル サイトおよびリモート サイトから検出する必要があります。VLAN トランキング プロトコル(VTP)では、カスタマー ネットワークのすべてのサイトで矛盾しない VLAN 設定を提供する必要があります。

プロトコル トンネリングをイネーブルにした場合、サービス プロバイダー ネットワークの着信側にあるエッジ スイッチは、レイヤ 2 プロトコル パケットを特殊な MAC アドレスでカプセル化し、それらをサービス プロバイダー ネットワーク経由で送信します。ネットワークのコア スイッチでは、このパケットが処理されずに通常のパケットとして転送されます。CDP、STP、または VTP のレイヤ 2 Protocol Data Unit(PDU; プロトコル データ ユニット)は、サービス プロバイダー ネットワークを通過し、サービス プロバイダー ネットワークの発信側にあるカスタマー スイッチまで配信されます。同一パケットは同じ VLAN のすべてのカスタマー ポートで受信され、次のような結果になります。

カスタマーの各サイトのユーザは適切に STP を実行でき、すべての VLAN が、ローカル サイトだけでなく全サイトからのパラメータに基づく適正なスパニング ツリーを構築できます。

CDP では、サービス プロバイダー ネットワークによって接続されているその他のシスコ デバイスに関する情報が検出されて表示されます。

VTP は、カスタマー ネットワーク全体で一貫性のある VLAN 設定を提供し、サービス プロバイダーを通じてすべてのスイッチに伝播します。


) サードパーティ ベンダーとの相互運用性を提供するには、レイヤ 2 プロトコルトンネル バイパス機能を使用します。バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー スイッチに制御 PDU が透過的に転送されます。バイパス モードを実装するには、出力トランク ポートでレイヤ 2 プロトコル トンネリングをイネーブルにします。レイヤ 2 プロトコル トンネリングがトランク ポートでイネーブルの場合、カプセル化された MAC アドレスが削除されて、プロトコル パケットに通常の MAC アドレスを持つようになります。


レイヤ 2 プロトコル トンネリングは個別に使用できます。レイヤ 2 プロトコル トンネリングでは、IEEE 802.1Q トンネリングを向上させることができます。IEEE 802.1Q トンネリング ポートでプロトコル トンネリングをイネーブルにしていない場合、サービス プロバイダー ネットワークの受信側のリモート スイッチでは PDU が受信させず、STP、CDP、VTP を適切に実行できません。プロトコル トンネリングがイネーブル である 場合、それぞれのカスタマー ネットワークのレイヤ 2 プロトコルは、サービス プロバイダー ネットワーク内で動作しているものから完全に区別されます。IEEE 802.1Q トンネリングでサービス プロバイダー ネットワークを通してトラフィックを送信する、さまざまなサイトのカスタマー スイッチでは、カスタマー VLAN が完全に認識されます。IEEE 802.1Q トンネリングを使用しない場合でも、アクセス ポート経由でカスタマー スイッチに接続し、サービス プロバイダーのアクセス ポート上でトンネリングをイネーブルにすることによって、レイヤ 2 プロトコル トンネリングをイネーブルにできます。

たとえば図 17-4の場合、カスタマー X には、サービス プロバイダー ネットワーク経由で接続された同じ VLAN 上の 4 台のスイッチがあります。ネットワークで PDU がトンネルされない場合、ネットワークの向こう側のスイッチでは、STP、CDP、VTP を適切に実行できません。たとえば、カスタマー X、サイト 1 のスイッチ上の VLAN で動作する STP は、カスタマー X、サイト 2 のスイッチに基づくコンバージェンス パラメータを考慮せずに、このサイトのスイッチのスパニング ツリーを構築します。その結果、図 17-5に示すトポロジになる可能性があります。

図 17-4 レイヤ 2 プロトコル トンネリング

 

図 17-5 適切なコンバージェンスがないレイヤ 2 ネットワーク トポロジ

 

SP ネットワークでは、ポイントツーポイント ネットワーク トポロジをエミュレートして EtherChannel の作成を強化するのに、レイヤ 2 プロトコル トンネルを使用できます。プロトコル トンネリング(PAgP または LACP)を SP スイッチでイネーブルにすると、リモート カスタマー スイッチが PDU を受信し、EtherChannel の自動作成をネゴシエーションします。

たとえば図 17-6の場合、カスタマー A には同一 VLAN に 2 つのスイッチがあり、サービス プロバイダー ネットワークで接続されています。ネットワークで PDU がトンネリングされると、ネットワークの向こう側のスイッチでは、専用回線を必要とせずに、EtherChannel の自動作成をネゴシエーションできます。手順については、「EtherChannel のレイヤ 2 トンネリングの設定」を参照してください。

図 17-6 EtherChannel のレイヤ 2 プロトコル トンネリング

 

レイヤ 2 プロトコル トンネリングの設定

サービス プロバイダー ネットワークのエッジ スイッチ上のカスタマーに接続されたポート上で、(プロトコル別の)レイヤ 2 プロトコル トンネリングをイネーブルにできます。カスタマー スイッチに接続されているサービス プロバイダー エッジ スイッチでは、トンネリング処理が実行されます。エッジ スイッチのトンネル ポートは、カスタマーの IEEE 802.1Q トランク ポートに接続されています。エッジ スイッチのアクセス ポートは、カスタマーのアクセス ポートに接続されています。カスタマー スイッチに接続されているエッジ スイッチでは、トンネリング処理が実行されます。

レイヤ 2 プロトコル トンネリングは、アクセス ポートまたはトンネル ポートとして設定されたポート上でイネーブルにできます。 switchport mode dynamic auto(デフォルト モード) または switchport mode dynamic desirable のいずれかに設定されたポート上でレイヤ 2 プロトコル トンネリングをイネーブルにできません。

スイッチでは、CDP、STP、VTP のレイヤ 2 プロトコル トンネリングがサポートされます。ポイントツーポイント ネットワーク トポロジのエミュレートの場合は、PAgP、LACP、UDLD のプロトコルもサポートされます。スイッチでは、LLDP のレイヤ 2 プロトコル トンネリングはサポートされません。


注意 PAgP、LACP、UDLD プロトコル トンネリングでは、ポイントツーポイント トポロジのエミュレートだけが目的です。設定を間違えたことによりトンネリング パケットが多くのポートに送信されると、ネットワーク障害が発生する可能性があります。

サービス プロバイダーの入力エッジ スイッチのレイヤ 2 プロトコル対応ポートに着信したレイヤ 2 PDU がトランク ポート経由でサービス プロバイダー ネットワークに送信されるとき、スイッチはカスタマー PDU 宛先 MAC アドレスを、シスコ独自の既知のマルチキャスト アドレス(01-00-0c-cd-cd-d0)で上書きします。IEEE 802.1Q トンネリングがイネーブルに設定されていなければ、パケットには二重タグも付けられます(外側のタグはカスタマー メトロ タグ、内側のタグはカスタマー VLAN タグ)。コア スイッチでは内部タグが無視され、同じメトロ VLAN のすべてのトランク ポートにパケットが転送されます。出力側のエッジ スイッチは適切なレイヤ 2 プロトコルおよび MAC アドレス情報を復元し、同じメトロ VLAN 上のすべてのトンネル ポートまたはアクセス ポートにパケットを転送します。したがって、レイヤ 2 PDU はそのまま維持され、サービス プロバイダー インフラストラクチャ経由でカスタマー ネットワークの反対側まで配信されます。

図 17-4を参照してください。カスタマー X およびカスタマー Y が、それぞれアクセス VLAN 30 および 40 になっています。非対称リンクにより、サイト 1 のカスタマーは、サービス プロバイダー ネットワークのエッジ スイッチに接続されています。サイト 1 のカスタマー Y のスイッチ B に着信するレイヤ 2 PDU(たとえば、BPDU など)は、宛先 MAC アドレスとして既知の MAC アドレスを使用した二重タグ付きパケットとしてインフラストラクチャに転送されます。これらの二重タグ付きパケットには、メトロ VLAN タグ 40、および内側 VLAN タグ(たとえば、VLAN 100 など)があります。二重タグ付きパケットがスイッチ D に着信すると、外側 VLAN タグ 40 が削除され、既知の MAC アドレスが該当するレイヤ 2 プロトコル MAC アドレスに置き換えられ、パケットは VLAN 100 上で一重のタグ付きパケットとしてサイト 2 のカスタマー Y に送信されます。

カスタマー スイッチのアクセス ポートまたはトランク ポートに接続されたエッジ スイッチのアクセス ポート上で、レイヤ 2 プロトコル トンネリングをイネーブルにすることもできます。この場合、カプセル化およびカプセル化解除のプロセスは、パケットがサービス プロバイダー ネットワーク上で二重にタグ付けされない点を除いて、上記と同様です。カスタマー固有のアクセス VLAN タグの 一重タグになります。

スイッチ スタックでは、レイヤ 2 プロトコル トンネリング設定はすべてのスタック メンバー間で配信されます。ローカル ポートで入力パケットを受信した各スタック メンバーは、パケットをカプセル化またはカプセル化の解除をおこない、そのパケットを適切な宛先ポートに転送します。1 台のスイッチ上で、入力レイヤ 2 プロトコル トンネリング トラフィックは、レイヤ 2 プロトコル トンネリングがイネーブルにされた同じ VLAN のすべてのローカル ポートに送信されます。スタックでは、同じ VLAN 内にある、レイヤ 2 プロトコル トンネリングに対して設定されているスタック内のすべてのポートに、レイヤ 2 プロトコル トンネリング ポートによって受信されたパケットが配信されます。すべてのレイヤ 2 プロトコル トンネリング設定は、スタック マスターによって処理されて、すべてのスタック メンバーに配信されます。

ここでは、次の設定情報について説明します。

「レイヤ 2 プロトコル トンネリングのデフォルト設定」

「レイヤ 2 プロトコル トンネリング設定時の注意事項」

「レイヤ 2 プロトコル トンネリングの設定」

「EtherChannel のレイヤ 2 トンネリングの設定」

レイヤ 2 プロトコル トンネリングのデフォルト設定

表 17-1 に、レイヤ 2 プロトコル トンネリングのデフォルト設定を示します。

 

表 17-1 レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

機能
デフォルト設定

レイヤ 2 プロトコル トンネリング

ディセーブル。

シャットダウンしきい値

設定なし。

ドロップしきい値

設定なし。

CoS 値

インターフェイスで CoS 値が設定されている場合は、その値を使用して、レイヤ 2 PDU プロトコル トンネリングの BPDU CoS 値を設定します。インターフェイス レベルで CoS 値が設定されてない場合は、L2 プロトコル トンネリング BPDU の CoS マーキングのデフォルト値は 5 になります。これはデータ トラフィックに適用されません。

レイヤ 2 プロトコル トンネリング設定時の注意事項

次に、レイヤ 2 プロトコル トンネリング設定時の注意事項および動作特性を示します。

スイッチでは、CDP、STP(Multiple STP(MSTP)を含む)、VTP のトンネリングがサポートされます。プロトコル トンネリングはデフォルトでディセーブルですが、IEEE 802.1Q トンネル ポートまたはアクセス ポート上で個々のプロトコルについてイネーブルに設定できます。

スイッチは、 switchport mode dynamic auto または switchport mode dynamic desirable のポート上でのレイヤ 2 プロトコル トンネリングはサポートしません。

DTP にはレイヤ 2 プロトコル トンネリングとの互換性はありません。

サービス プロバイダー ネットワークの出力側のエッジ スイッチは適切なレイヤ 2 プロトコルおよび MAC アドレス情報を復元し、同じメトロ VLAN 上のすべてのトンネル ポートおよびアクセス ポートにパケットを転送します。

サードパーティ ベンダー スイッチとの相互運用性のため、スイッチではレイヤ 2 プロトコルトンネル バイパス機能がサポートされます。バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー スイッチに制御 PDU が透過的に転送されます。スイッチの入力ポートでレイヤ 2 プロトコル トンネルがイネーブルである場合は、出力トランク ポートにより、トンネリングされたパケットが特殊なカプセル化で転送されます。出力トランク ポート上でもレイヤ 2 プロトコル トンネリングをイネーブルに設定すると、この動作はバイパスされ、スイッチは制御 PDU を処理または変更することなく転送します。

スイッチでは、ポイントツーポイント ネットワーク トポロジのエミュレートの場合、PAgP、LACP、UDLD のトンネリングがサポートされます。プロトコル トンネリングはデフォルトでディセーブルですが、IEEE 802.1Q トンネル ポートまたはアクセス ポート上で個々のプロトコルについてイネーブルに設定できます。

PAgP トンネリングまたは LACP トンネリングの場合は、リンク障害検出を高速にするため、インターフェイスで UDLD もイネーブルにするよう推奨します。

PAgP パケット、LACP パケット、UDLD パケットのうちいずれかのレイヤ 2 プロトコル トンネリングでは、ループバック検出がサポートされません。

IEEE 802.1Q 設定が EtherChannel ポート グループ内で矛盾しない場合、EtherChannel ポート グループにはトンネル ポートとの互換性があります。

トンネル ポートまたはレイヤ 2 トンネリングがイネーブルに設定されているアクセス ポートから(独自の宛先 MAC アドレスを使用して)カプセル化された PDU を受信した場合、ループを防ぐために、そのトンネル ポートはシャットダウンされます。このポートは、プロトコル用に設定されたシャットダウンしきい値に達した場合にもシャットダウンされます。ポートを手動で再びイネーブルにする( shutdown および no shutdown コマンド シーケンスを入力する)ことができます。errdisable 回復機能をイネーブルに設定している場合、所定のタイム インターバルが経過した後に動作が再試行されます。

カプセル化が解除された PDU だけがカスタマー ネットワークに転送されます。サービス プロバイダー ネットワーク上で動作しているスパニング ツリー インスタンスでは、BPDU がトンネル ポートに転送されません。トンネル ポートから CDP パケットが転送されることはありません。

インターフェイスでプロトコル トンネリングがイネーブルである場合は、カスタマー ネットワークによって生成された PDU 用に、プロトコルごとのシャットダウンしきい値やポートごとのシャットダウンしきい値を設定できます。制限を超えると、ポートはシャットダウンされます。また、トンネル ポート上で QoS ACL およびポリシー マップを使用して BPDU の速度制限もできます。

インターフェイスでプロトコル トンネリングがイネーブルである場合は、カスタマー ネットワークによって生成された PDU 用に、プロトコルごとのドロップしきい値やポートごとのドロップしきい値を設定できます。この限界を超過すると、ポートは PDU を受信する速度がドロップしきい値より下になるまで、PDU をドロップします。

カスタマーの仮想ネットワークが正常に動作するように、トンネリングされる PDU(特に STP BPDU)をすべてのリモート サイトに配信する必要があるため、サービス プロバイダー ネットワーク上で同じトンネル ポートから受信するデータ パケットより高いプライオリティを PDU に与えることができます。デフォルトの場合、PDU ではデータ パケットと同じ CoS 値が使用されます。

レイヤ 2 プロトコル トンネリングの設定

レイヤ 2 プロトコル トンネリング用にポートを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トンネル ポートとして設定するインターフェイスを入力します。これは、カスタマー スイッチに接続するサービス プロバイダー ネットワークのエッジ ポートである必要があります。有効なインターフェイスには、物理インターフェイスおよびポート チャネル論理インターフェイス(ポート チャネル 1 ~ 64)に設定できます。

ステップ 3

switchport mode access
または
switchport mode dot1q-tunnel

インターフェイスを、アクセス ポートまたは IEEE 802.1Q トンネル ポートとして設定します。

ステップ 4

l2protocol-tunnel [ cdp | stp | vtp ]

目的のプロトコルのプロトコル トンネリングをイネーブルにします。キーワードを入力しない場合、トンネリングは、3 つすべてのレイヤ 2 プロトコルでイネーブルになります。

ステップ 5

l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスはディセーブルになります。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値が設定されていません。

(注) このインターフェイスでドロップしきい値も設定する場合、シャットダウンしきい値は、ドロップしきい値以上とする必要があります。

ステップ 6

l2protocol-tunnel drop-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスによってパケットがドロップされます。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値が設定されていません。

このインターフェイスでシャットダウンしきい値も設定する場合、ドロップしきい値は、シャットダウンしきい値以下である必要があります。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

errdisable recovery cause l2ptguard

(任意)インターフェイスを再びイネーブルにして再試行できるようにするため、レイヤ 2 最大レート エラーからの回復メカニズムを設定します。errdisable recovery はデフォルトでディセーブルになっています。イネーブルにした場合、デフォルトの間隔は 300 秒です。

ステップ 9

l2protocol-tunnel cos value

(任意)トンネリングされたすべてのレイヤ 2 PDU の CoS 値を設定します。範囲は 0 ~ 7 です。デフォルトは、インターフェイスのデフォルト CoS 値です。設定されていない場合、デフォルトは 5 です。

ステップ 10

end

特権 EXEC モードに戻ります。

ステップ 11

show l2protocol

設定されているプロトコル、しきい値、カウンタを含めた、スイッチのレイヤ 2 トンネル ポートを表示します。

ステップ 12

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ 2 プロトコル、または 3 つのプロトコル全部について、プロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ cdp | stp | vtp ] インターフェイス コンフィギュレーション コマンドを使用します。シャットダウンしきい値およびドロップしきい値をデフォルト設定に戻すには、 no l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ] コマンドおよび no l2protocol-tunnel drop-threshold [ cdp | stp | vtp ] コマンドを使用します。

以下は、CDP、STP、VTP のレイヤ 2 プロトコル トンネリングを設定し、設定を確認する方法の例です。

Switch(config)# interface gigabitethernet1/0/11
Switch(config-if)# l2protocol-tunnel cdp
Switch(config-if)# l2protocol-tunnel stp
Switch(config-if)# l2protocol-tunnel vtp
Switch(config-if)# l2protocol-tunnel shutdown-threshold 1500
Switch(config-if)# l2protocol-tunnel drop-threshold 1000
Switch(config-if)# exit
Switch(config)# l2protocol-tunnel cos 7
Switch(config)# end
Switch# show l2protocol
COS for Encapsulated Packets: 7
Port Protocol Shutdown Drop Encapsulation Decapsulation Drop
Threshold Threshold Counter Counter Counter
------- -------- --------- --------- ------------- ------------- -------------
Gi1/0/11 cdp 1500 1000 2288 2282 0
stp 1500 1000 116 13 0
vtp 1500 1000 3 67 0
pagp ---- ---- 0 0 0
lacp ---- ---- 0 0 0
udld ---- ---- 0 0 0

EtherChannel のレイヤ 2 トンネリングの設定

レイヤ 2 ポイントツーポイント トンネリングを設定して EtherChannel の自動作成を容易にするには、SP エッジ スイッチおよびカスタマー スイッチの両方を設定する必要があります。

SP エッジ スイッチの設定

EtherChannel のレイヤ 2 プロトコル トンネリング用に SP エッジ スイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トンネル ポートとして設定するインターフェイスを入力します。これは、カスタマー スイッチに接続する SP ネットワークのエッジ ポートである必要があります。有効なインターフェイスは物理インターフェイスです。

ステップ 3

switchport mode dot1q-tunnel

IEEE 802.1Q トンネル ポートとしてインターフェイスを設定します。

ステップ 4

l2protocol-tunnel point-to-point [ pagp | lacp | udld ]

(任意)希望するプロトコルのポイントツーポイント プロトコル トンネリングをイネーブルにします。キーワードを入力しない場合、トンネリングは、3 つすべてのプロトコルでイネーブルになります。


注意 ネットワーク障害を避けるため、ネットワークがポイントツーポイント トポロジになっていることを確認してから、PAgP パケット、LACP パケット、UDLD パケットのうちいずれかのトンネリングをイネーブルにしてください。

ステップ 5

l2protocol-tunnel shutdown-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスはディセーブルになります。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値が設定されていません。

(注) このインターフェイスでドロップしきい値も設定する場合、シャットダウンしきい値は、ドロップしきい値以上とする必要があります。

ステップ 6

l2protocol-tunnel drop-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスによってパケットがドロップされます。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値が設定されていません。

(注) このインターフェイスでシャットダウンしきい値も設定する場合、ドロップしきい値は、シャットダウンしきい値以下である必要があります。

ステップ 7

no cdp enable

インターフェイス上で CDP をディセーブルにします。

ステップ 8

spanning-tree bpdufilter enable

インターフェイス上で BPDU フィルタリングをイネーブルにします。

ステップ 9

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 10

errdisable recovery cause l2ptguard

(任意)インターフェイスを再びイネーブルにして再試行できるようにするため、レイヤ 2 最大レート エラーからの回復メカニズムを設定します。errdisable recovery はデフォルトでディセーブルになっています。イネーブルにした場合、デフォルトの間隔は 300 秒です。

ステップ 11

l2protocol-tunnel cos value

(任意)トンネリングされたすべてのレイヤ 2 PDU の CoS 値を設定します。範囲は 0 ~ 7 です。デフォルトは、インターフェイスのデフォルト CoS 値です。設定されていない場合、デフォルトは 5 です。

ステップ 12

end

特権 EXEC モードに戻ります。

ステップ 13

show l2protocol

設定されているプロトコル、しきい値、カウンタを含めた、スイッチのレイヤ 2 トンネル ポートを表示します。

ステップ 14

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ 2 プロトコルまたは 3 つすべてのレイヤ 2 プロトコルのポイントツーポイント プロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ point-to-point [ pagp | lacp | udld ]] インターフェイス コンフィギュレーション コマンドを使用します。シャットダウンしきい値およびドロップしきい値をデフォルト設定に戻すには、 no l2protocol-tunnel shutdown-threshold [ point-to-point [ pagp | lacp | udld ]] コマンドおよび no l2protocol-tunnel drop-threshold [ [ point-to-point [ pagp | lacp | udld ]] コマンドを使用します。

カスタマー スイッチの設定

SP エッジ スイッチを設定したら、特権 EXEC モードで次の手順を実行し、EtherChannel のレイヤ 2 プロトコル トンネリング用にカスタマー スイッチを設定します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始します。これは、カスタマー スイッチ ポートにする必要があります。

ステップ 3

switchport trunk encapsulation dot1q

トランキング カプセル化形式を IEEE 802.1Q に設定します。

ステップ 4

switchport mode trunk

インターフェイス上でトランキングをイネーブルにします。

ステップ 5

udld enable

インターフェイスの 標準 モードで UDLD をイネーブルにします。

ステップ 6

channel-group channel-group-number mode desirable

チャネル グループにインターフェイスを割り当て、PAgP モードに desirable を指定します。EtherChannel の設定の詳細については、 第 38 章「EtherChannel およびリンクステート トラッキングの設定」 を参照してください。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface port-channe l port-channel number

ポート チャネル インターフェイス モードに入ります。

ステップ 9

shutdown

インターフェイスをシャットダウンします。

ステップ 10

no shutdown

インターフェイスをイネーブルにします。

ステップ 11

end

特権 EXEC モードに戻ります。

ステップ 12

show l2protocol

設定されているプロトコル、しきい値、カウンタを含めた、スイッチのレイヤ 2 トンネル ポートを表示します。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 no switchport mode trunk no udld enable 、および no channel group channel-group-number mode desirable インターフェイス コンフィギュレーション コマンドを使用します。

EtherChannel の場合は、SP エッジ スイッチおよびカスタマー スイッチをレイヤ 2 プロトコル トンネリング用に設定する必要があります(図 17-6 を参照)。

次に、SP エッジ スイッチ 1 および SP エッジ スイッチ 2 を設定する例を示します。VLAN 17、18、19、20 はアクセス VLAN、ファスト イーサネット インターフェイス 1 および 2 は PAgP および UDLD がイネーブルになっているポイントツーポイント トンネル ポート、ドロップしきい値は 1000、ファスト イーサネット インターフェイス 3 はトランク ポートです。

SP エッジ スイッチ 1 の設定

Switch(config)# interface gigabitethernet1/0/1
Switch(config-if)# switchport access vlan 17
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface gigabitethernet1/0/2
Switch(config-if)# switchport access vlan 18
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface gigabitethernet1/0/3
Switch(config-if)# switchport trunk encapsulation negotiate
Switch(config-if)# switchport mode trunk
 

SP エッジ スイッチ 2 の設定

Switch(config)# interface gigabitethernet1/0/1
Switch(config-if)# switchport access vlan 19
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface gigabitethernet1/0/2
Switch(config-if)# switchport access vlan 20
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface gigabitethernet1/0/3
Switch(config-if)# switchport trunk encapsulation negotiate
Switch(config-if)# switchport mode trunk
 

次に、サイト 1 でカスタマー スイッチを設定する例を示します。ファスト イーサネット インターフェイス 1、2、3、4 は IEEE 802.1Q トランキング用に設定されており、UDLD はイネーブル、EtherChannel グループ 1 はイネーブル、ポート チャネルはシャットダウンされた後でイネーブルになって EtherChannel 設定がアクティブになります。

Switch(config)# interface gigabitethernet1/0/1
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface gigabitethernet1/0/2
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface gigabitethernet1/0/3
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface gigabitethernet1/0/4
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface port-channel 1
Switch(config-if)# shutdown
Switch(config-if)# no shutdown
Switch(config-if)# exit

トンネリング ステータスのモニタリングおよびメンテナンス

表 17-2 に、IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングのモニタリングおよびメンテナンスに使用する特権 EXEC コマンドを示します。

 

表 17-2 トンネリングのモニタリングおよびメンテナンスのためのコマンド

コマンド
目的

clear l2protocol-tunnel counters

レイヤ 2 プロトコル トンネリング ポートのプロトコル カウンタをクリアします。

show dot1q-tunnel

スイッチの IEEE 802.1Q トンネル ポートを表示します。

show dot1q-tunnel interface interface-id

特定インターフェイスがトンネル ポートであるかどうかを確認します。

show l2protocol-tunnel

レイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

show errdisable recovery

レイヤ 2 プロトコル トンネル エラー ディセーブル状態からの回復タイマーがイネーブルかどうかを確認します。

show l2protocol-tunnel interface interface-id

特定レイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

show l2protocol-tunnel summary

レイヤ 2 プロトコルのサマリー情報だけを表示します。

show vlan dot1q tag native

スイッチのネイティブ VLAN タグのステータスを表示します。

この表示の詳細については、このリリースのコマンド リファレンスを参照してください。