Cisco Catalyst Blade Switch 3130 および 3032 for Dell Software コンフィギュレーション ガイド
スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て
スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て
発行日;2012/01/31 | 英語版ドキュメント(2011/05/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て

ブート プロセスの概要

スイッチ情報の割り当て

デフォルトのスイッチ情報

DHCP ベースの自動設定の概要

DHCP クライアントの要求プロセス

DHCP ベースの自動設定およびイメージ アップデートの概要

DHCP 自動設定

DHCP の自動イメージ アップデート

制限事項および制約事項

DHCP ベースの自動設定の設定

DHCP サーバ設定時の注意事項

TFTP サーバの設定

DNS の設定

リレー デバイスの設定

コンフィギュレーション ファイルの入手方法

構成例

DHCP ベースの自動設定およびイメージ アップデートの概要

DHCP 自動設定

DHCP の自動イメージ アップデート

制限事項および制約事項

DHCP の自動設定およびイメージ アップデート機能の設定

DHCP 自動設定の設定(コンフィギュレーション ファイルだけ)

DHCP 自動イメージ アップデートの設定(コンフィギュレーション ファイルおよびイメージ)

クライアントの設定

手動での IP 情報の割り当て

保護モードの設定

保護モードについて

設定時の注意事項と制限事項

保護モードのイネーブル化

実行コンフィギュレーションの確認および保存

NVRAM バッファ サイズの設定

スタートアップ コンフィギュレーションの変更

デフォルトのブート設定

コンフィギュレーション ファイルの自動ダウンロード

システム コンフィギュレーションを読み書きするためのファイル名の指定

手動でブートする場合

特定のソフトウェア イメージを起動する場合

環境変数の制御

ソフトウェア イメージ リロードのスケジュール設定

リロードのスケジュール設定

リロード スケジュール情報の表示

スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て

この章では、自動および手動による各種方法で、スイッチの初期設定(たとえば、IP アドレスの割り当てやデフォルト ゲートウェイ情報)を作成する方法について説明しています。スイッチのスタートアップ コンフィギュレーションを変更する方法についても説明します。特に記述がない限り、 スイッチ という用語はスタンドアロン スイッチとスイッチ スタックを意味しています。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスおよび『Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2』を参照してください。


この章で説明する内容は、次のとおりです。

「ブート プロセスの概要」

「スイッチ情報の割り当て」

「保護モードの設定」

「実行コンフィギュレーションの確認および保存」

「スタートアップ コンフィギュレーションの変更」

「ソフトウェア イメージ リロードのスケジュール設定」


) IP アドレスおよび DHCP の設定に関するこの章の情報については、IP Version 4(IPv4)固有のものです。IP Version 6(IPv6)転送をスイッチでイネーブルにしている場合、IPv6 アドレス形式および設定固有の情報について、第 40 章「IPv6 ホスト機能およびユニキャスト ルーティングの設定」を参照してください。IPv6 をイネーブルにするには、スタックまたはスイッチが IP サービス フィーチャ セットを実行している必要があります。


ブート プロセスの概要

スイッチを起動するには、まず、ハードウェア インストレーション ガイドに記載された手順に従い、スイッチを設置し、電源を投入して、スイッチの初期設定(IP アドレス、サブネット マスク、デフォルト ゲートウェイ、シークレットおよび Telnet パスワードなど)を行う必要があります。

通常のブート プロセスにはブート ローダ ソフトウェアの動作が含まれます。ブート ローダは次のアクティビティを実行します。

下位レベルの CPU 初期化を行います。CPU レジスタを初期化することにより、物理メモリがマッピングされる場所、容量、速度などを制御します。

CPU サブシステムの Power-on Self-Test(POST; 電源投入時自己診断テスト)を行います。CPU DRAM と、フラッシュ ファイル システムを構成するフラッシュ デバイスの部分をテストします。

システム ボード上のフラッシュ ファイル システムを初期化します。

デフォルトのオペレーティング システム ソフトウェア イメージをメモリにロードし、スイッチを起動します。

ブート ローダによってフラッシュ ファイル システムにアクセスしてから、オペレーティング システムをロードします。ブート ローダの使用目的は通常、オペレーティング システムのロード、圧縮解除、および起動に限定されます。オペレーティング システムが CPU を制御できるようになると、ブート ローダは、次にシステムがリセットされるか電源が投入されるまでは非アクティブになります。

また、オペレーティング システムが使用不可能になるほどの重大な障害が発生した場合は、ブート ローダはシステムにトラップドアからアクセスします。トラップドア メカニズムによるシステムへのアクセス機能を使用することで、必要に応じて、フラッシュ ファイル システムをフォーマットし、Xmodem プロトコルを使用してオペレーティング システムのソフトウェア イメージを再インストールし、失ったパスワードを回復し、最終的にオペレーティング システムを再起動できます。詳細については、「ソフトウェアで障害が発生した場合の回復」および「パスワードを忘れた場合の回復」を参照してください。


) パスワードの回復をディセーブルにできます。詳細については、「パスワード回復のディセーブル化」を参照してください。


スイッチ情報を割り当てるには、PC または端末をコンソール ポートに接続するか、PC をイーサネット管理ポートし、PC またはターミナル エミュレーション ソフトウェアのボー レートおよびキャラクタ フォーマットをスイッチのコンソール ポートの設定と一致させておく必要があります。

デフォルトのボー レートは 9600 です。

デフォルトのデータ ビットは 8 です。


) データ ビット オプションを 8 に設定した場合、パリティ オプションは「なし」に設定します。


デフォルトのストップ ビットは 1 です。

デフォルトのパリティ設定は「なし」です。

スイッチ情報の割り当て

IP 情報は、Advanced Management Module(AMM)GUI または手動で割り当てることができます。

スイッチがリブートする場合、保存済みのコンフィギュレーション ファイルにある IP アドレス、サブネット マスク、およびゲートウェイが使用されます。

スイッチ スタックは、単一 IP アドレスを通じて管理されます。IP アドレスは、システム レベルの設定であり、スタック マスターや他のスタック メンバー固有の設定ではありません。スタックからスタック マスターや他のスタック メンバーを削除しても、IP 接続が存続していれば、引き続き同じ IP アドレスを使用してスタックを管理できます。


) スイッチ スタックからスタック メンバーを削除する際、スタック メンバーは IP アドレスを維持します。ネットワーク内で 2 つのデバイスが同一 IP アドレスを持つことによる競合を回避するため、スイッチ スタックから削除したスイッチの IP アドレスを変更します。


サーバの設定後は DHCP サーバを使用して、IP 情報の集中管理と自動割り当てを行います。


) DHCP を使用している場合は、ダイナミックに割り当てられた IP アドレスをスイッチが受信してコンフィギュレーション ファイルを読み込むまでは、セットアップ プログラムの質問に応答しないでください。


スイッチの設定手順を熟知している経験豊富なユーザの場合は、スイッチを手動で設定してください。それ以外のユーザは、前述のセットアップ プログラムを使用してください。

ここでは、次の設定情報について説明します。

「デフォルトのスイッチ情報」

「DHCP ベースの自動設定の概要」

「DHCP ベースの自動設定の設定」

「DHCP ベースの自動設定およびイメージ アップデートの概要」

「DHCP の自動設定およびイメージ アップデート機能の設定」

「手動での IP 情報の割り当て」

デフォルトのスイッチ情報

表 3-1 に、デフォルトのスイッチ情報を示します。

 

表 3-1 デフォルトのスイッチ情報

機能
デフォルト設定

DCHP クライアント

ディセーブル。

IP アドレスおよびサブネット マスク

IP アドレスまたはサブネット マスクは定義されていません。

デフォルト ゲートウェイ

デフォルト ゲートウェイは定義されていません。

イネーブル シークレット パスワード

パスワードは定義されていません。

ホスト名

出荷時に割り当てられたデフォルトのホスト名は Switch です。

Telnet パスワード

パスワードは定義されていません。

DHCP ベースの自動設定の概要

DHCP は、インターネット ホストおよびインターネットワーキング デバイスに設定情報を提供します。このプロトコルは 2 つのコンポーネントで構成されていて、1 つは DHCP サーバからデバイスにコンフィギュレーション パラメータを提供するコンポーネント、もう 1 つはデバイスにネットワーク アドレスを割り当てるコンポーネントです。DHCP はクライアント/サーバ モデルに基づいています。指定された DHCP サーバが、ダイナミックに設定されるデバイスに対して、ネットワーク アドレスを割り当て、コンフィギュレーション パラメータを提供します。スイッチは、DHCP クライアントおよび DHCP サーバとして機能できます。

DHCP ベースの自動設定では、スイッチ(DHCP クライアント)は起動時に、IP アドレス情報およびコンフィギュレーション ファイルを使用して自動的に設定されます。

DHCP ベースの自動設定を使用すると、スイッチ上で DHCP クライアント側の設定を行う必要はありません。ただし、DHCP サーバで、IP アドレスに関連した各種リース オプションを設定する必要があります。DHCP を使用してネットワーク上でコンフィギュレーション ファイルをリレーする場合は、Trivial File Transfer Protocol(TFTP; 簡易ファイル転送プロトコル)サーバおよび Domain Name System(DNS; ドメイン ネーム システム)サーバの設定が必要なこともあります。


) スイッチ スタックと、DHCP、DNS、および TFTP サーバとの間で冗長接続を行うことを推奨しています。これにより、接続されているスタック メンバーがスイッチ スタックから削除された場合であっても、引き続き、これらのサーバを確実にアクセス可能なままにできます。


スイッチの DHCP サーバは、スイッチと同じ LAN 上に配置することも、そのスイッチとは別の LAN 上に配置することもできます。DHCP サーバが異なる LAN 上で動作している場合、スイッチと DHCP サーバ間に、DHCP のリレー デバイスを設定する必要があります。リレー デバイスは、直接接続されている 2 つの LAN 間でブロードキャスト トラフィックを転送します。ルータはブロードキャスト パケットを転送しませんが、受信したパケットの宛先 IP アドレスに基づいてパケットを転送します。

DHCP ベースの自動設定は、スイッチの BOOTP クライアント機能に代わるものです。

DHCP クライアントの要求プロセス

スイッチを起動したときに、スイッチにコンフィギュレーション ファイルがない場合は、DHCP クライアントが起動され、DHCP サーバに対して設定情報を要求します。コンフィギュレーション ファイルが存在し、その設定に特定のルーテッド インターフェイスの ip address dhcp インターフェイス コンフィギュレーション コマンドが含まれる場合、DHCP クライアントが呼び出され、DHCP クライアントがインターフェイスに IP アドレス情報を要求します。

図 3-1 に、DHCP クライアントと DHCP サーバ間で交換される一連のメッセージを示します。

図 3-1 DHCP クライアントおよびサーバ間のメッセージ交換

 

クライアントであるスイッチ A は、DHCP サーバの場所を特定するために、DHCPDISCOVER メッセージをブロードキャストします。DHCP サーバは、DHCPOFFER ユニキャスト メッセージによって、使用可能なコンフィギュレーション パラメータ(IP アドレス、サブネット マスク、ゲートウェイ IP アドレス、DNS IP アドレス、IP アドレス用のリースなど)をクライアントに提示します。

DHCPREQUEST ブロードキャスト メッセージでは、クライアントは、提示された設定情報に対して、DHCP サーバに正式な要求を戻します。この正式な要求はブロードキャストされるため、クライアントから DHCPDISCOVER ブロードキャスト メッセージを受信した他のすべての DHCP サーバは、クライアントに提示した IP アドレスを再利用できます。

DHCP サーバは、DHCPACK ユニキャスト メッセージをクライアントに戻すことで、IP アドレスがクライアントに割り当てられたことを確認します。このメッセージによって、クライアントとサーバはバインドされ、クライアントはサーバから受信した設定情報を使用します。スイッチの受信する情報量は、DHCP サーバの設定方法によって異なります。詳細については、「TFTP サーバの設定」を参照してください。

DHCPOFFER ユニキャスト メッセージによって送信されたコンフィギュレーション パラメータが無効である(コンフィギュレーション エラーがある)場合、クライアントは DHCP サーバに、DHCPDECLINE ブロードキャスト メッセージを戻します。

DHCP サーバはクライアントに、提示されたコンフィギュレーション パラメータが割り当てられていない、パラメータのネゴシエーション中にエラーが発生した、または DHCPOFFER メッセージに対するクライアントの応答が遅れている(DHCP サーバがパラメータを別のクライアントに割り当てた)という意味の DHCPNAK 拒否ブロードキャスト メッセージを送信します。

DHCP クライアントは、複数の DHCP サーバまたは BOOTP サーバから提示を受け取り、そのうちの任意の 1 つを受け入れることができますが、通常は最初に受け取った提示を受け入れます。DHCP サーバから提示された IP アドレスが必ずしもクライアントに割り当てられるわけではありません。ただし、サーバは通常、クライアントが正式にアドレスを要求するまではアドレスを確保しておきます。スイッチが BOOTP サーバからの応答を受け入れて、自身を設定する場合、スイッチはスイッチ コンフィギュレーション ファイルを入手するために、TFTP 要求をユニキャストするのではなくブロードキャストします。

DHCP ホスト名オプションにより、中央の管理 DHCP サーバからスイッチ グループでホスト名および標準設定を取得できます。クライアント(スイッチ)には、DHCP サーバからホスト名およびその他の設定パラメータを要求するのに使用するオプション 12 フィールドが、DCHPDISCOVER メッセージに含まれています。すべてのクライアントのコンフィギュレーション ファイルは、DHCP 取得ホスト名を除き、同一です。

クライアントにデフォルトのホスト名がある場合( hostname name グローバル コンフィギュレーション コマンドが設定されていないか、 no hostname グローバル コンフィギュレーション コマンドが入力されてホスト名が削除された場合)、 ip address dhcp インターフェイス コンフィギュレーション コマンド入力時に DHCP ホスト名オプションがパケットに含まれません。この場合、インターフェイスの IP アドレスを取得中にクライアントが DHCP との相互作用で DCHP ホスト名オプションを受信した場合、クライアントは DHCP ホスト名オプションを受け入れて、システムに設定済みのホスト名があることを示すフラグが設定されます。

DHCP ベースの自動設定およびイメージ アップデートの概要

DHCP のイメージ アップグレード機能を使用すると、新しいイメージおよび新しいコンフィギュレーション ファイルの両方をネットワーク内の 1 つ以上のスイッチにダウンロードするように DHCP サーバを設定できます。これにより、ネットワークに追加された新しいスイッチはそれぞれ同じイメージおよびコンフィギュレーションを受け取ることができます。

DHCP イメージのアップグレードには、DHCP 自動設定および DHCP 自動イメージ アップデートの 2 種類があります。

DHCP 自動設定

DHCP 自動設定により、コンフィギュレーション ファイルは DHCP サーバからネットワーク内の 1 つ以上のスイッチにダウンロードされます。ダウンロードされたコンフィギュレーション ファイルは、スイッチの実行コンフィギュレーションとなります。フラッシュに保存されている起動コンフィギュレーションは、スイッチをリロードするまで上書きされません。

DHCP の自動イメージ アップデート

DHCP 自動イメージ アップグレード機能を DHCP 自動設定と併用することにより、コンフィギュレーションおよび新しいイメージの両方をネットワーク内の 1 つ以上のスイッチにダウンロードできます。新しいコンフィギュレーションおよび新しいイメージがダウンロードされるスイッチ(または複数のスイッチ)は、ブランク(または、工場出荷時のデフォルト設定だけがロードされた状態)である場合があります。

すでにコンフィギュレーションを持っているスイッチに新しいコンフィギュレーションがダウンロードされる場合、ダウンロードされたコンフィギュレーションはスイッチにストアされているコンフィギュレーション ファイルに追加されます(既存のコンフィギュレーションはいずれも、ダウンロードされたコンフィギュレーションにより上書きされません)。


) スイッチ上で DHCP 自動イメージ アップデートをイネーブルにするには、イメージおよびコンフィギュレーション ファイルが配置されている TFTP サーバを Option 67(コンフィギュレーション ファイル名)、Option 66(DHCP サーバのホスト名)、Option 150(TFTP サーバのアドレス)、および Option 125(ファイルの説明)により適切に設定する必要があります。

スイッチを DHCP サーバとして設定する場合の手順については、「DHCP ベースの自動設定の設定」および『Cisco IOS IP Configuration Guide, Release 12.2』の「IP Addressing and Services」の章にある「Configuring DHCP」を参照してください。


ネットワークにスイッチを設置した後、自動イメージ アップデート機能が開始されます。ダウンロードされたコンフィギュレーション ファイルは、スイッチの実行コンフィギュレーションに保存され、新しいイメージはスイッチにダウンロードされ、インストールされます。スイッチをリブートすると、このコンフィギュレーションはスイッチに保存されたコンフィギュレーションにストアされます。

制限事項および制約事項

次に、制限事項ついて説明します。

保存コンフィギュレーション付き DHCP ベースの自動設定プロセスを実行するには、ネットワーク内に IP アドレスが割り当てられていないアップ ステートのレイヤ 3 インターフェイスが最低 1 つは存在している必要があります。

タイムアウトが設定されない限り、保存コンフィギュレーション付き DHCP ベースの自動設定機能では無限に IP アドレスをダウンロードしようとします。

コンフィギュレーション ファイルをダウンロードできない場合、またはコンフィギュレーション ファイルが破損している場合、自動インストール プロセスは停止します。

TFTP からダウンロードされるコンフィギュレーション ファイルは、実行コンフィギュレーション中の既存のコンフィギュレーションと統合されます。ただし、NVRAM に保存するには、 write memory または copy running-configuration startup-configuration 特権 EXEC コマンドを入力する必要があります。ダウンロードされたコンフィギュレーションがスタートアップ コンフィギュレーションに保存された場合、その後のシステム再起動時にこの機能はトリガされないことに注意してください。

DHCP ベースの自動設定の設定

ここでは、次の設定情報について説明します。

「DHCP サーバ設定時の注意事項」

「TFTP サーバの設定」

「DNS の設定」

「リレー デバイスの設定」

「コンフィギュレーション ファイルの入手方法」

「構成例」

DHCP サーバがシスコ デバイスである場合、DHCP 設定に関する詳細は、『 Cisco IOS IP Configuration Guide, Release 12.2 』の「IP Addressing and Services」の章にある「Configuring DHCP」の部分を参照してください。

DHCP サーバ設定時の注意事項

デバイスを DHCP サーバとして設定する場合、次の注意事項に従ってください。

DHCP サーバには、スイッチのハードウェア アドレスによって各スイッチとバインドされている予約済みのリースを設定する必要があります。

スイッチに IP アドレス情報を受信させるには、DHCP サーバに次のリース オプションを設定する必要があります。

クライアントの IP アドレス(必須)

クライアントのサブネット マスク(必須)

DNS サーバの IP アドレス(任意)

ルータの IP アドレス(スイッチで使用するデフォルト ゲートウェイ アドレス)(必須)

スイッチに TFTP サーバからコンフィギュレーション ファイルを受信させる場合は、DHCP サーバに次のリース オプションを設定する必要があります。

TFTP サーバ名(必須)

ブート ファイル名(クライアントが必要とするコンフィギュレーション ファイル名)(推奨)

ホスト名(任意)

DHCP サーバの設定によっては、スイッチは IP アドレス情報またはコンフィギュレーション ファイル、あるいはその両方を受信できます。

前述のリース オプションを設定しなかった場合、DHCP サーバは、設定されたパラメータだけを使用してクライアントの要求に応答します。IP アドレスおよびサブネット マスクが応答に含まれていないと、スイッチは設定されません。ルータの IP アドレスまたは TFTP サーバ名が見つからなかった場合、スイッチは TFTP 要求をユニキャストしないでブロードキャストする場合があります。その他のリース オプションは、使用できなくても自動設定には影響しません。

スイッチは DHCP サーバとして機能します。デフォルトでは、Cisco IOS DHCP サーバおよびリレー エージェント機能はスイッチ上でイネーブルですが、設定されていません。これらの機能は動作しません。DHCP サーバがシスコ デバイスである場合、DHCP 設定に関する詳細については、Cisco.com のホームページから [Documentation] > [Cisco IOS Software] > [12.2 Mainline] > [Configuration Guides] を選択し、『 Cisco IOS IP Configuration Guide 』の「IP Addressing and Services」の章にある「Configuring DHCP」の部分を参照してください。

TFTP サーバの設定

DHCP サーバの設定に基づいて、スイッチは TFTP サーバから 1 つ以上のコンフィギュレーション ファイルをダウンロードしようとします。TFTP サーバへの IP 接続に必要なすべてのオプションについてスイッチに応答するよう DHCP を設定している場合で、なおかつ、TFTP サーバ名、アドレス、およびコンフィギュレーション ファイル名を指定して DHCP サーバを設定している場合、スイッチは指定された TFTP サーバから指定されたコンフィギュレーション ファイルをダウンロードしようとします。

コンフィギュレーション ファイル名、および TFTP サーバを指定しなかった場合、またはコンフィギュレーション ファイルをダウンロードできなかった場合は、スイッチはファイル名と TFTP サーバアドレスをさまざまに組み合わせてコンフィギュレーション ファイルをダウンロードしようとします。ファイルには、(存在する場合)指定されたコンフィギュレーション ファイル名とそのファイルが含まれています。具体的には、network-config、cisconet.cfg、 hostname .config、または hostname .cfg ファイルで、ここで hostname はスイッチの現在のホスト名です。使用される TFTP サーバアドレスには、(存在する場合)指定された TFTP サーバのアドレス、およびブロードキャスト アドレス(255.255.255.255)が含まれています。

スイッチが正常にコンフィギュレーション ファイルをダウンロードするには、TFTP サーバのベース ディレクトリに 1 つ以上のコンフィギュレーション ファイルが含まれていなければなりません。含めることのできるファイルは、次のとおりです。

DHCP 応答で指定されているコンフィギュレーション ファイル(実際のスイッチ コンフィギュレーション ファイル)

network-confg または cisconet.cfg ファイル(デフォルトのコンフィギュレーション ファイル)

router-confg または ciscortr.cfg ファイル(これらのファイルには、すべてのスイッチに共通のコマンドが含まれています。通常、DHCP および TFTP サーバが適切に設定されていれば、これらのファイルはアクセスされません)

DHCP サーバ リース データベースに TFTP サーバ名を指定する場合は、DNS サーバのデータベースに TFTP サーバ名と IP アドレスのマッピングを設定することも必要です。

使用する TFTP サーバが、スイッチとは異なる LAN 上にある場合、またはスイッチがブロードキャスト アドレスを使用してアクセスした場合(前述のすべての必須情報が DHCP サーバの応答に含まれていない場合に発生)は、リレーを設定して TFTP サーバに TFTP パケットを転送する必要があります。詳細については、「リレー デバイスの設定」を参照してください。適切な解決方法は、必要なすべての情報を使用して DHCP サーバを設定することです。

DNS の設定

DHCP サーバは、DNS サーバを使用して TFTP サーバ名を IP アドレスに変換します。DNS サーバ上で、TFTP サーバ名から IP アドレスへのマッピングを設定する必要があります。TFTP サーバには、スイッチのコンフィギュレーション ファイルが存在します。

DHCP の応答時に IP アドレスを取得する DHCP サーバのリース データベースに、DNS サーバの IP アドレスを設定できます。リース データベースには、DNS サーバの IP アドレスを 2 つまで入力できます。

DNS サーバは、スイッチと同じ LAN 上に配置することも、そのスイッチとは別の LAN 上に配置することもできます。DHCP サーバが別の LAN 上に存在する場合、スイッチはルータを介して DHCP サーバにアクセスできなければなりません。

リレー デバイスの設定

異なる LAN 上にあるホストからの応答が必要なブロードキャスト パケットをスイッチが送信する場合は、リレー デバイス( リレー エージェント )を設定する必要があります。スイッチが送信する可能性のあるブロードキャスト パケットの例として DHCP パケット、DNS パケット、場合によっては TFTP パケットが挙げられます。リレー デバイスは、インターフェイス上の受信ブロードキャスト パケットを宛先ホストに転送するように設定しなければなりません。

リレー デバイスが Cisco ルータである場合、IP ルーティングをイネーブルにし( ip routing グローバル コンフィギュレーション コマンド)、 ip helper-address インターフェイス コンフィギュレーション コマンドを使用して、ヘルパー アドレスを設定します。

図 3-2では、ルータ インターフェイスを次のように設定しています。

インターフェイス 10.0.0.2 では、

router(config-if)# ip helper-address 20.0.0.2
router(config-if)# ip helper-address 20.0.0.3
router(config-if)# ip helper-address 20.0.0.4
 

インターフェイス 20.0.0.1 では、

router(config-if)# ip helper-address 10.0.0.1

) スイッチがリレー装置として機能している場合、インターフェイスをルーテッド ポートとして設定します詳細については、「ルーテッド ポート」および「レイヤ 3 インターフェイスの設定」を参照してください。


図 3-2 自動設定でのリレー デバイスの使用

 

コンフィギュレーション ファイルの入手方法

IP アドレスおよびコンフィギュレーション ファイル名が DHCP で予約済みのリースとして取得できるかどうかに応じて、スイッチは次の方法で設定情報を入手します。

IP アドレスおよびコンフィギュレーション ファイル名が、スイッチ用に予約され、DHCP 応答(1 ファイル読み込み方式)で提供されている場合

スイッチは DHCP サーバから、IP アドレス、サブネット マスク、TFTP サーバ アドレス、およびコンフィギュレーション ファイル名を受信します。さらにスイッチは、TFTP サーバのベース ディレクトリから指定のコンフィギュレーション ファイルを検索するために、TFTP サーバにユニキャスト メッセージを送信します。指定されたコンフィギュレーション ファイルを受信すると、スイッチの起動プロセスは完了します。

スイッチの IP アドレスおよびコンフィギュレーション ファイル名が予約されているが、DHCP 応答に TFTP サーバ アドレスが含まれていない場合(1 ファイル読み込み方式)

スイッチは DHCP サーバから、IP アドレス、サブネット マスク、およびコンフィギュレーション ファイル名を受信します。さらにスイッチは、TFTP サーバにブロードキャスト メッセージを送信してサーバのベース ディレクトリから指定のコンフィギュレーション ファイルを検索します。指定されたコンフィギュレーション ファイルを受信すると、スイッチのブート プロセスは完了します。

IP アドレスだけがスイッチ用に予約され、DHCP 応答で提供されており、コンフィギュレーション ファイル名は提供されない場合(2 ファイル読み込み方式)

スイッチは DHCP サーバから、IP アドレス、サブネット マスク、および TFTP サーバ アドレスを受信します。スイッチは、TFTP サーバにユニキャスト メッセージを送信し、network-confg または cisconet.cfg のデフォルト コンフィギュレーション ファイルを取得します(network-confg ファイルが読み込めない場合、スイッチは cisconet.cfg ファイルを読み込みます)。

デフォルト コンフィギュレーション ファイルには、スイッチのホスト名から IP アドレスへのマッピングが含まれています。スイッチは、ファイルの情報をホスト テーブルに書き込み、ホスト名を入手します。ファイルにホスト名がない場合、スイッチは DHCP 応答で指定されたホスト名を使用します。DHCP 応答でホスト名が指定されていない場合、スイッチはデフォルトの Switch をホスト名として使用します。

デフォルトのコンフィギュレーション ファイルまたは DHCP 応答からホスト名を入手した後、スイッチはホスト名と同じ名前のコンフィギュレーション ファイル(network-confg または cisconet.cfg のどちらが先に読み込まれたかに応じて、 hostname -confg または hostname .cfg)を TFTP サーバから読み込みます。cisconet.cfg ファイルが読み込まれている場合は、ホストのファイル名は 8 文字に切り捨てられます。

network-confg、cisconet.cfg、またはホスト名と同じ名前のファイルを読み込むことができない場合、スイッチは router-confg ファイルを読み込みます。router-confg ファイルを読み込むことができない場合、スイッチは ciscortr.cfg ファイルを読み込みます。


) DHCP 応答から TFTP サーバを入手できなかった場合、ユニキャスト伝送によるコンフィギュレーション ファイルの読み込みに失敗した場合、または TFTP サーバ名を IP アドレスに変換できない場合には、スイッチは TFTP サーバ要求をブロードキャストします。


構成例

図 3-3 に、DHCP ベースの自動設定を使用して IP 情報を検索するネットワークの構成例を示します。

図 3-3 DHCP ベースの自動設定を使用するネットワークの構成例

 

表 3-2 は、DHCP サーバ上の予約済みリースの設定例です。

 

表 3-2 DHCP サーバ コンフィギュレーション

スイッチ A
スイッチ B
スイッチ C
スイッチ D

バインディング キー(ハードウェア アドレス)

00e0.9f1e.2001

00e0.9f1e.2002

00e0.9f1e.2003

00e0.9f1e.2004

IP アドレス

10.0.0.21

10.0.0.22

10.0.0.23

10.0.0.24

サブネット マスク

255.255.255.0

255.255.255.0

255.255.255.0

255.255.255.0

ルータ アドレス

10.0.0.10

10.0.0.10

10.0.0.10

10.0.0.10

DNS サーバ アドレス

10.0.0.2

10.0.0.2

10.0.0.2

10.0.0.2

TFTP サーバ名

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

ブート ファイル名(コンフィギュレーション ファイル)(任意)

switcha-confg

switchb-confg

switchc-confg

switchd-confg

ホスト名(任意)

switcha

switchb

switchc

switchd

DNS サーバ コンフィギュレーション

DNS サーバは、TFTP サーバ名の maritsu を IP アドレス 10.0.0.3 にマッピングします。

TFTP サーバ コンフィギュレーション(UNIX)

TFTP サーバのベース ディレクトリは、/tftpserver/work/ に設定されています。このディレクトリには、2 ファイル読み込み方式で使用される network-confg ファイルがあります。このファイルには、IP アドレスに基づいてスイッチに割り当てられるホスト名が含まれています。ベース ディレクトリには、次に示すように、各スイッチのコンフィギュレーション ファイル( switcha-confg switchb-confg など)も含まれています。

prompt> cd /tftpserver/work/
prompt> ls
network-confg
switcha-confg
switchb-confg
switchc-confg
switchd-confg
prompt> cat network-confg
ip host switcha 10.0.0.21
ip host switchb 10.0.0.22
ip host switchc 10.0.0.23
ip host switchd 10.0.0.24
 

DHCP クライアント コンフィギュレーション

スイッチ A ~ D には、コンフィギュレーション ファイルは存在しません。

コンフィギュレーションの説明

図 3-3の場合、スイッチ A はコンフィギュレーション ファイルを次のようにして読み込みます。

DHCP サーバから IP アドレス 10.0.0.21 を入手します。

DHCP サーバの応答でコンフィギュレーション ファイル名が提供されない場合、スイッチ A は TFTP サーバのベース ディレクトリから network-confg ファイルを読み込みます。

ホスト テーブルに network-confg ファイルの内容を追加します。

IP アドレス 10.0.0.21 をもとにホスト テーブルを検索し、ホスト名(switcha)を取得します。

ホスト名に対応するコンフィギュレーション ファイルを読み取ります。たとえば、TFTP サーバから switch1-confg ファイルを読み取ります。

スイッチ B ~ D も、同様にコンフィギュレーション ファイルおよび IP アドレスを取得します。

DHCP ベースの自動設定およびイメージ アップデートの概要

DHCP のイメージ アップグレード機能を使用すると、新しいイメージおよび新しいコンフィギュレーション ファイルの両方をネットワーク内の 1 つ以上のスイッチにダウンロードするように DHCP サーバを設定できます。これにより、ネットワークに追加された新しいスイッチはそれぞれ同じイメージおよびコンフィギュレーションを受け取ることができます。

DHCP イメージのアップグレードには、DHCP 自動設定および DHCP 自動イメージ アップデートの 2 種類があります。

DHCP 自動設定

DHCP 自動設定により、コンフィギュレーション ファイルは DHCP サーバからネットワーク内の 1 つ以上のスイッチにダウンロードされます。ダウンロードされたコンフィギュレーション ファイルは、スイッチの実行コンフィギュレーションとなります。フラッシュに保存されている起動コンフィギュレーションは、スイッチをリロードするまで上書きされません。

DHCP の自動イメージ アップデート

DHCP 自動イメージ アップグレード機能を DHCP 自動設定と併用することにより、コンフィギュレーションおよび新しいイメージの両方をネットワーク内の 1 つ以上のスイッチにダウンロードできます。新しいコンフィギュレーションおよび新しいイメージがダウンロードされるスイッチ(または複数のスイッチ)は、ブランク(または、工場出荷時のデフォルト設定だけがロードされた状態)である場合があります。

すでにコンフィギュレーションを持っているスイッチに新しいコンフィギュレーションがダウンロードされる場合、ダウンロードされたコンフィギュレーションはスイッチにストアされているコンフィギュレーション ファイルに追加されます(既存のコンフィギュレーションはいずれも、ダウンロードされたコンフィギュレーションにより上書きされません)。


) スイッチ上で DHCP 自動イメージ アップデートをイネーブルにするには、イメージおよびコンフィギュレーション ファイルが配置されている TFTP サーバを Option 67(コンフィギュレーション ファイル名)、Option 66(DHCP サーバのホスト名)、Option 150(TFTP サーバのアドレス)、および Option 125(ファイルの説明)により適切に設定する必要があります。

スイッチを DHCP サーバとして設定する場合の手順については、「DHCP ベースの自動設定の設定」および『Cisco IOS IP Configuration Guide, Release 12.2』の「IP Addressing and Services」の章にある「Configuring DHCP」を参照してください。


ネットワークにスイッチを設置した後、自動イメージ アップデート機能が開始されます。ダウンロードされたコンフィギュレーション ファイルは、スイッチの実行コンフィギュレーションに保存され、新しいイメージはスイッチにダウンロードされ、インストールされます。スイッチをリブートすると、このコンフィギュレーションはスイッチに保存されたコンフィギュレーションにストアされます。

制限事項および制約事項

次に、制限事項ついて説明します。

保存コンフィギュレーション付き DHCP ベースの自動設定プロセスを実行するには、ネットワーク内に IP アドレスが割り当てられていないアップ ステートのレイヤ 3 インターフェイスが最低 1 つは存在している必要があります。

タイムアウトが設定されない限り、保存コンフィギュレーション付き DHCP ベースの自動設定機能では無限に IP アドレスをダウンロードしようとします。

コンフィギュレーション ファイルをダウンロードできない場合、またはコンフィギュレーション ファイルが破損している場合、自動インストール プロセスは停止します。


) TFTP からダウンロードされるコンフィギュレーション ファイルは、実行コンフィギュレーション中の既存のコンフィギュレーションと統合されます。ただし、NVRAM に保存するには、write memory または copy running-configuration startup-configuration 特権 EXEC コマンドを入力する必要があります。ダウンロードされたコンフィギュレーションがスタートアップ コンフィギュレーションに保存された場合、その後のシステム再起動時にこの機能はトリガされないことに注意してください。


DHCP の自動設定およびイメージ アップデート機能の設定

DHCP を使用して、新しいイメージおよび新しいコンフィギュレーションをスイッチにダウンロードするには、少なくとも 2 つのスイッチ(DHCP サーバおよび TFTP サーバとして動作する 1 つのスイッチ)を設定する必要があります。クライアント スイッチは、新しいコンフィギュレーションまたは新しいコンフィギュレーション ファイル、および 新しいイメージ ファイルをダウンロードするように設定されます。

DHCP 自動設定の設定(コンフィギュレーション ファイルだけ)

新しいスイッチで TFTP 設定および DHCP 設定の DHCP 自動設定を設定して、新しいコンフィギュレーション ファイルをダウンロードするには、特権 EXEC モードを開始して、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip dhcp poolname

DHCP サーバ アドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 3

bootfile filename

ブート イメージとして使用されるコンフィギュレーション ファイルの名前を指定します。

ステップ 4

network network-number mask prefix-length

DHCP アドレス プールのサブネット ネットワーク番号およびマスクを指定します。

(注) プレフィクス長により、アドレス プレフィクスを構成するビット数が指定されます。プレフィクスは、クライアントのネットワーク マスクを指定する代替方法です。プレフィクス長は、フォワード スラッシュ(/)が前に付く必要があります。

ステップ 5

default-router address

DHCP クライアントのデフォルト ルータの IP アドレスを指定します。

ステップ 6

option 150 address

TFTP サーバの IP アドレスを指定します。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

tftp-server flash:filename.text

TFTP サーバ上のコンフィギュレーション ファイルを指定します。

ステップ 9

interface interface-id

コンフィギュレーション ファイルを受信するクライアントのアドレスを指定します。

ステップ 10

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 11

ip address address mask

インターフェイスの IP アドレスおよびマスクを指定します。

ステップ 12

end

特権 EXEC モードに戻ります。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次に、DHCP サーバとして設定されたスイッチがコンフィグレーション ファイルをダウンロードする例を示します。

Switch# configure terminal
Switch(config)# ip dhcp pool pool1
Switch(dhcp-config)# network 10.10.10.0 255.255.255.0
Switch(dhcp-config)# bootfile config-boot.text
Switch(dhcp-config)# default-router 10.10.10.1
Switch(dhcp-config)# option 150 10.10.10.1
Switch(dhcp-config)# exit
Switch(config)# tftp-server flash:config-boot.text
Switch(config)# interface gigabitethernet1/0/4
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.10.10.1 255.255.255.0
Switch(config-if)# end

DHCP 自動イメージ アップデートの設定(コンフィギュレーション ファイルおよびイメージ)

新しいスイッチで TFTP および DHCP の設定を行う DHCP 自動設定を設定して、新しいイメージおよび新しいコンフィギュレーション ファイルをダウンロードするには、特権 EXEC モードを開始して、次の手順を実行します。


) このテーブルの次の手順を実行する前に、スイッチにアップロードされるテキスト ファイル(autoinstall_dhcp など)を作成する必要があります。テキスト ファイルには、ダウンロードするイメージの名前をつけます。このイメージは、tar ファイルであり、bin ファイルではありません。


 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip dhcp pool name

DHCP サーバ アドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 3

bootfile filename

ブート イメージとして使用されるファイルの名前を指定します。

ステップ 4

network network-number mask prefix-length

DHCP アドレス プールのサブネット ネットワーク番号およびマスクを指定します。

(注) プレフィクス長により、アドレス プレフィクスを構成するビット数が指定されます。プレフィクスは、クライアントのネットワーク マスクを指定する代替方法です。プレフィクス長は、フォワード スラッシュ(/)が前に付く必要があります。

ステップ 5

default-router address

DHCP クライアントのデフォルト ルータの IP アドレスを指定します。

ステップ 6

option 150 address

TFTP サーバの IP アドレスを指定します。

ステップ 7

option 125 hex

イメージ ファイルへのパスを説明するテキスト ファイルへのパスを指定します。

ステップ 8

copy tftp flash filename.txt

テキスト ファイルをスイッチにアップロードします。

ステップ 9

copy tftp flash imagename.tar

スイッチに新しいイメージの tar ファイルをアップロードします。

ステップ 10

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

tftp-server flash:config.text

TFTP サーバ上の Cisco IOS コンフィギュレーション ファイルを指定します。

ステップ 12

tftp-server flash:imagename.tar

TFTP サーバ上のイメージ名を指定します。

ステップ 13

tftp-server flash:filename.txt

ダウンロードするイメージ ファイルの名前を含むテキスト ファイルを指定します。

ステップ 14

interface interface-id

コンフィギュレーション ファイルを受信するクライアントのアドレスを指定します。

ステップ 15

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 16

ip address address mask

インターフェイスの IP アドレスおよびマスクを指定します。

ステップ 17

end

特権 EXEC モードに戻ります。

ステップ 18

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次に、DHCP サーバとして設定されたスイッチがコンフィグレーション ファイルをダウンロードする例を示します。

Switch# configure terminal
Switch(config)# ip dhcp pool pool1
Switch(dhcp-config)# network 10.10.10.0 255.255.255.0
Switch(dhcp-config)# bootfile config-boot.text
Switch(dhcp-config)# default-router 10.10.10.1
Switch(dhcp-config)# option 150 10.10.10.1
Switch(dhcp-config)# option 125 hex 0000.0009.0a05.08661.7574.6f69.6e73.7461.6c6c.5f64.686370
Switch(dhcp-config)# exit
Switch(config)# tftp-server flash:config-boot.text
Switch(config)# tftp-server flash:cbs31x0-ipservices-mz.122-44.3.SE.tar
Switch(config)# tftp-server flash:boot-config.text
Switch(config)# tftp-server flash: autoinstall_dhcp
Switch(config)# interface gigabitethernet1/0/4
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.10.10.1 255.255.255.0
Switch(config-if)# end

クライアントの設定

DHCP サーバからコンフィギュレーション ファイルおよび新しいイメージをダウンロードするように、スイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot host dhcp

保存コンフィギュレーション付き自動設定をイネーブルにします。

ステップ 3

boot host retry timeout timeout-value

(任意)システムがコンフィギュレーション ファイルのダウンロードを試行する時間を設定します。

(注) タイムアウトを設定しなければ、システムは無限に DHCP サーバから IP アドレスを取得しようとします。

ステップ 4

banner config-save ^C warning-message ^C

(任意)コンフィギュレーション ファイルを NVRAM に保存しようとした場合に表示される、警告メッセージを作成します。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show boot

設定を確認します。

次に、VLAN 99 のレイヤ 3 SVI インターフェイスを使用して、保存コンフィギュレーション付き DHCP ベースの自動設定をイネーブルにする例を示します。

Switch# configure terminal
Switch(conf)# boot host dhcp
Switch(conf)# boot host retry timeout 300
Switch(conf)# banner config-save ^C Caution - Saving Configuration File to NVRAM May Cause You to Nolonger Automatically Download Configuration Files at Reboot^C
Switch(config)# vlan 99
Switch(config-vlan)# interface vlan 99
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch# show boot
BOOT path-list:
Config file: flash:/config.text
Private Config file: flash:/private-config.text
Enable Break: no
Manual Boot: no
HELPER path-list:
NVRAM/Config file
buffer size: 32768
Timeout for Config
Download: 300 seconds
Config Download
via DHCP: enabled (next boot: enabled)
Switch#

) レイヤ 3 インターフェイスだけを設定し、イネーブルにする必要があります。IP アドレスまたは保存コンフィギュレーション付き DHCP ベースの自動設定を割り当てないでください。


手動での IP 情報の割り当て

IP アドレスを手動で割り当てるには、スイッチの IP アドレスと内部イーサネット管理ポートが AMM と同じサブネットに属している場合、AMM がスイッチの IP プロキシとして動作することに注意する必要があります。AMM は管理トラフィックを処理します。

複数の Switched Virtual Interface(SVI; スイッチ仮想インターフェイス)に手動で IP 情報を割り当てるには、特権 EXEC モードで次の手順を実行します。


) スイッチが IP サービス フィーチャ セットを実行している場合、まず no switchport インターフェイス コンフィギュレーション コマンドを使用してポートをレイヤ 3 モードにすると、手動で IP 情報をポートに割り当てることができます。


 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vlan-id

インターフェイス コンフィギュレーション モードを開始し、IP 情報を割り当てる VLAN を入力します。指定できる範囲は 1 ~ 4094 です。

ステップ 3

ip address dhcp [ client-id interface-name ] [ hostname host-name ]

DHCP サーバから VLAN インターフェイスの IP アドレスを取得します。

ステップ 4

ip address ip-address subnet-mask

IP アドレスおよびサブネット マスクを入力します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

ip default-gateway ip-address

スイッチに直接接続しているネクスト ホップのルータ インターフェイスの IP アドレスを入力します。このスイッチにはデフォルト ゲートウェイが設定されています。デフォルト ゲートウェイは、スイッチから宛先 IP アドレスを取得していない IP パケットを受信します。

デフォルト ゲートウェイが設定されると、スイッチは、ホストが接続する必要のあるリモート ネットワークに接続できます。

(注) IP でルーティングするようにスイッチを設定した場合、デフォルト ゲートウェイの設定は不要です。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show interfaces vlan vlan-id

設定された IP アドレスを確認します。

ステップ 9

show ip redirects

設定されたデフォルト ゲートウェイを確認します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチの IP アドレスを削除するには、 no ip address インターフェイス コンフィギュレーション コマンドを使用します。Telnet セッションからアドレスを削除すると、スイッチの接続は切断されます。デフォルト ゲートウェイのアドレスを削除するには、 no ip default-gateway グローバル コンフィギュレーション コマンドを使用します。

すべての VLAN インターフェイスは、ベース MAC アドレスから派生した MAC アドレスが割り当てられています。ベース MAC アドレスは、スイッチ ラベルにあるハードウェア アドレスです。また、 show version 特権 EXEC コマンド入力時にも表示されます。

最初の VLAN インターフェイス(VLAN 1)では、MAC アドレスはベース MAC アドレス + 0 x 40 です。設定する次の VLAN インターフェイスでは、MAC アドレスはベース MAC アドレス + 0 x 40 +1 となり、同様に後続の VLAN インターフェイスに続きます。

MAC アドレスおよび IP アドレスを表示するために、 show interfaces vlan vlan-id 特権 EXEC コマンドを入力できます。 show interfaces vlan vlan-id コマンド出力に表示される MAC アドレスは、スイッチ ラベルに印刷されている MAC アドレス(ベース MAC アドレス)と同一ではありません。

デフォルトで、VLAN 1 は管理ネットワークに接続するインターフェイスです。スイッチの起動時に、DHCP クライアント(スイッチ)が VLAN 1 の MAC アドレスを使用することによって DHCP サーバから IP アドレスを要求します。

スイッチのシステム名の設定、特権 EXEC コマンドへのアクセスの保護、時刻および日付の設定については、 第 5 章「スイッチの管理」 を参照してください。

保護モードの設定

ここでは、次の情報について説明します。

「保護モードについて」

「設定時の注意事項と制限事項」

「保護モードのイネーブル化」

保護モードについて

保護モード機能を使用すると、Advanced Management Module(AMM)モジュールがスタンドアロン スイッチを制御することを防止できます。デフォルトではこの機能はディセーブルになり、AMM がスイッチを制御します。

保護モードをイネーブルにすると、サーバ管理者が AMM を使用してスイッチを管理または設定できなくなり、AMM が次の特性および機能の設定を管理できなくなります。

IP アドレス

外部ポートの管理

外部ポートで受信したトラフィックの管理

製造時のデフォルト設定への復元防止

スタック メンバーでは保護モードをイネーブルにできませんが、スタック マスターで保護モードをイネーブルにすると、すべてのスタック メンバーでこの機能がイネーブルになります。スイッチ スタックで保護モードを使用する前に、機能間の関係に注意してください。


注意 スイッチの物理的損傷を防ぐため、AMM が過熱または過電流状態を検出した場合は、保護モードがイネーブルになっていても、AMM はスイッチをリブートまたは電源を切断できます。

設定時の注意事項と制限事項

保護モードをイネーブルまたはディセーブルにするときは、次の注意事項および制限事項に従ってください。

スイッチで platform chassis-management protected-mode グローバル コンフィギュレーション コマンドを入力する前に、AMM で保護モードをイネーブルにする必要があります。AMM で保護モードをイネーブルにする方法の詳細については、次の URL にある AMM のマニュアルを参照してください。

http://www-304.ibm.com/jct01004c/systems/support/supportsite.wss/brandmain?brandind=5000020

スイッチで platform chassis-management protected-mode グローバル コンフィギュレーション コマンドを入力後は、スイッチをリブートし、保護モードを動作状態にする必要があります。

スイッチを別のエンクロージャに移動しても、保護モードはスイッチでイネーブルのままになります。

パスワードを忘れた場合の回復では、外部シリアル ポートからスイッチに直接アクセスする必要があります。

保護モードのイネーブル化

スイッチ上で保護モードをイネーブルにするには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

platform chassis-management protected-mode

スイッチを AMM が制御できないようにします。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show platform summary

保護モードがイネーブルになっていることを確認します。

スイッチをリブートすると、スイッチで保護モードが動作状態になります。

ステップ 5

copy running-config startup-config

コンフィギュレーション ファイルに設定を保存します。

ステップ 6

(任意)スイッチをリブートします。

ステップ 7

show platform summary

または

show platform chassis { manager { registers | version | vpd mac-address length } | summary }

(任意)保護モードが動作状態になっていることを確認します。

または

(任意)AMM 情報を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

保護モードをディセーブルにするには、 no platform chassis-management protected-mode global コンフィギュレーション コマンドを入力します。

実行コンフィギュレーションの確認および保存

入力または変更した設定内容を確認するには、特権 EXEC コマンドを使用します。

Switch# show running-config
Building configuration...
 
Current configuration: 1363 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Stack1
!
enable secret 5 $1$ej9.$DMUvAUnZOAmvmgqBEzIxE0
!
.
<output truncated>
.
interface gigabitethernet6/0/17
no switchport
ip address 172.20.137.50 255.255.255.0
!
interface gigabitethernet6/0/18
mvr type source
 
<output truncated>
 
...!
interface VLAN1
ip address 172.20.137.50 255.255.255.0
no ip directed-broadcast
!
ip default-gateway 172.20.137.1 !
!
snmp-server community private RW
snmp-server community public RO
snmp-server community private@es0 RW
snmp-server community public@es0 RO
snmp-server chassis-id 0x12
!
end
 

スタートアップ コンフィギュレーションに対して行った設定や変更をフラッシュ メモリに保存するには、次の特権 EXEC コマンドを入力します。

Switch# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
 

このコマンドにより、入力した設定値が保存されます。保存できなかった場合、設定は次のシステム リロード時に失われます。フラッシュ メモリの NVRAM セクションに保存されている情報を表示するには、 show startup-config または more startup-config 特権 EXEC コマンドを使用します。

コンフィギュレーション ファイルのコピーの代替保存場所については、 付録 B「Cisco IOS File System、コンフィギュレーション ファイル、およびソフトウェア イメージの操作」 を参照してください。

NVRAM バッファ サイズの設定

デフォルトの NVRAM バッファ サイズは 512 KB です。場合によっては、コンフィギュレーション ファイルが大きすぎて NVRAM に保存できないことがあります。通常このようになるのは、スイッチ スタックに多数のスイッチがある場合です。NVRAM バッファのサイズを設定すると、大きなコンフィギュレーション ファイルをサポートできます。新しい NVRAM バッファ サイズは、すべての現行および新規メンバー スイッチで同期されます。


) NVRAM バッファ サイズの設定後は、スイッチまたはスイッチ スタックをリロードしてください。

スイッチをスタックに追加し、NVRAM サイズが異なる場合、新しいスイッチはスタックと同期し、自動的にリロードされます。


NVRAM バッファ サイズを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot buffersize size

NVRAM バッファ サイズを KB 単位で設定します。 size に指定できる範囲は、4096 ~ 1048576 です。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

設定を確認します。

次に、NVRAM バッファ サイズの設定例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# boot buffersize 524288
Switch(config)# end
Switch# show boot
BOOT path-list :
Config file : flash:/config.text
Private Config file : flash:/private-config.text
Enable Break : no
Manual Boot : no
HELPER path-list :
Auto upgrade : yes
Auto upgrade path :
NVRAM/Config file
buffer size: 524288
Timeout for Config
Download: 300 seconds
Config Download
via DHCP: enabled (next boot: enabled)
Switch#

スタートアップ コンフィギュレーションの変更

ここでは、スイッチのスタートアップ コンフィギュレーションの変更方法について説明します。

「デフォルトのブート設定」

「コンフィギュレーション ファイルの自動ダウンロード」

「手動でブートする場合」

「特定のソフトウェア イメージを起動する場合」

「環境変数の制御」

スイッチ コンフィギュレーション ファイルに関する詳細については、 付録 B「Cisco IOS File System、コンフィギュレーション ファイル、およびソフトウェア イメージの操作」 も参照してください。スイッチ スタック コンフィギュレーション ファイルに関する詳細については、「スイッチ スタックのコンフィギュレーション ファイル」を参照してください。

デフォルトのブート設定

表 3-3 に、デフォルトのブート設定を示します。

 

表 3-3 デフォルトのブート設定

機能
デフォルト設定

オペレーティング システム ソフトウェア イメージ

スイッチは、BOOT 環境変数内の情報を使用して、自動的にシステムの起動を試みます。この変数が設定されていない場合、スイッチはフラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初に検出した実行可能イメージをロードして実行しようとします。

Cisco IOS イメージは、イメージ ファイル(拡張子 .bin を除く)と同じ名前のディレクトリに保存されています。

ディレクトリの縦型検索では、検出した各サブディレクトリを完全に検索してから元のディレクトリでの検索を続けます。

コンフィギュレーション ファイル

設定されているスイッチは、システム ボードのフラッシュ メモリに保存されている config.text ファイルを使用します。

新しいスイッチの場合、コンフィギュレーション ファイルはありません。

コンフィギュレーション ファイルの自動ダウンロード

DHCP ベースの自動設定機能を使用することによって、スイッチにコンフィギュレーション ファイルを自動的にダウンロードできます。詳細については、「DHCP ベースの自動設定の概要」を参照してください。

システム コンフィギュレーションを読み書きするためのファイル名の指定

デフォルトでは、Cisco IOS ソフトウェアは、 config.text ファイルを使用して、システム コンフィギュレーションの不揮発性コピーを読み書きします。ただし、別のファイル名を指定することもでき、これは次のブート時にロードされます。


) このコマンドは、スタンドアロン スイッチから使用した場合にだけ正常に動作します。


別のコンフィギュレーション ファイル名を指定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot config-file flash:/ file-url

次回のブート時に読み込むコンフィギュレーション ファイルを指定します。

file-url に、パス(ディレクトリ)およびコンフィギュレーション ファイル名を指定します。

ファイル名およびディレクトリ名では、大文字と小文字が区別されます。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

設定を確認します。

boot config-file グローバル コンフィギュレーション コマンドによって、CONFIG_FILE 環境変数の設定が変更されます。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

デフォルトの設定に戻すには、 no boot config-file グローバル コンフィギュレーション コマンドを使用します。

手動でブートする場合

デフォルトでは、スイッチは自動的に起動しますが、手動で起動するように設定できます。


) このコマンドは、スタンドアロン スイッチから使用した場合にだけ正常に動作します。


次のブート時に手動で起動するようにスイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot manual

次回の起動時にスイッチを手動で起動できるようにします。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

設定を確認します。

boot manual グローバル コンフィギュレーション コマンドによって、MANUAL_BOOT 環境変数の設定が変更されます。

次回、システムを再起動したときには、スイッチはブート ローダ モードになり、ブート ローダ モードであることが switch: プロンプトで確認できます。システムを起動するには、 boot filesystem :/ file-url ブート ローダ コマンドを使用します。

filesystem : に対して、システム ボード上のフラッシュ デバイスの flash: を使用します。

file-url には、パス(ディレクトリ)およびブート可能なイメージの名前を指定します。

ファイル名およびディレクトリ名では、大文字と小文字が区別されます。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

手動でのブーティングをディセーブルにするには、 no boot manual グローバル コンフィギュレーション コマンドを使用します。

特定のソフトウェア イメージを起動する場合

デフォルトでは、スイッチは、BOOT 環境変数内の情報を使用して自動的にシステムを起動しようとします。この変数が設定されていない場合、スイッチは、フラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初の実行可能イメージをロードして実行しようとします。ディレクトリの縦型検索では、検出した各サブディレクトリを完全に検索してから元のディレクトリでの検索を続けます。ただし、起動する特定のイメージを指定できます。

次回の起動時に特定のイメージを起動するようにスイッチを設定するには、特権 EXEC モードで、次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot system filesystem :/ file-url

次回の起動時に、フラッシュ メモリ内の特定のイメージを起動するようにスイッチを設定します。

filesystem : に対して、システム ボード上のフラッシュ デバイスの flash: を使用します。

file-url には、パス(ディレクトリ)およびブート可能なイメージの名前を指定します。

このコマンドをスタック マスターで入力する場合、次回の起動時に指定されたソフトウェア イメージがスタック マスターだけにロードされます。

ファイル名およびディレクトリ名では、大文字と小文字が区別されます。

ステップ 3

boot system switch { number | all }

(任意)次の起動時にシステム イメージがロードされるスイッチ メンバーを指定します。

スタック メンバーを指定するには number を使用します(スタック メンバーは 1 つだけ指定します)。

すべてのスタック メンバーを指定するには all を使用します。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show boot

設定を確認します。

boot system グローバル コンフィギュレーション コマンドによって、BOOT 環境変数の設定が変更されます。

次回起動時、スイッチは、BOOT 環境変数内の情報を使用して自動的にシステムを起動しようとします。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

デフォルトの設定に戻すには、 no boot system グローバル コンフィギュレーション コマンドを使用します。

環境変数の制御

正常に動作しているスイッチでは、次のタスクを実行することにより、9600 bps 対応で設定されたスイッチ コンソール接続だけでブート ローダ モードが開始されます。

1. Advanced Management Module(AMM)GUI を使用するか、またはエンクロージャからスイッチを取り外すことにより、スイッチの電源をオフにします。

2. GUI を使用するか、エンクロージャにスイッチを再挿入することにより、スイッチの電源をオンにします。

3. スイッチの電源投入中にスイッチの Mode ボタンを押します。

ポート 1 の上の LED が消灯してから 1 ~ 2 秒後に、Mode ボタンを放します。次に、ブート ローダの switch: プロンプトが表示されます。

スイッチのブート ローダ ソフトウェアは不揮発性の環境変数をサポートするため、これらの環境変数を使用して、ブート ローダまたはシステムで稼動する他のソフトウェアの動作を制御できます。ブート ローダの環境変数は、UNIX または DOS システムで設定できる環境変数と類似しています。

値が設定された環境変数は、フラッシュ ファイル システム外のフラッシュ メモリに保存されています。

ファイルの各行には、環境変数名と等号に続いて、その変数の値が指定されます。このファイルに表示されていない変数には値がありません。表示されていればヌル ストリングであっても値があります。ヌル ストリング(たとえば " ")に設定されている変数は、値が設定された変数です。多くの環境変数は事前に定義されており、デフォルト値が設定されています。

環境変数には 2 種類のデータが保存されます。

コードを制御するデータ。Cisco IOS コンフィギュレーション ファイルを読み取りません。たとえば、ブート ローダの機能を拡張したり、パッチを適用したりするブート ローダ ヘルパー ファイルの名前は、環境変数として保存できます。

コードを制御するデータ。Cisco IOS コンフィギュレーション ファイルを読み取る役割があります。たとえば、環境変数として保存できる Cisco IOS コンフィギュレーション ファイルの名前

ブート ローダにアクセスするか、Cisco IOS コマンドを使用して、環境変数の設定を変更できます。通常の環境では、環境変数の設定を変更する必要はありません。


) ブート ローダ コマンドおよび環境変数の構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


表 3-4 で、代表的な環境変数の機能について説明します。

 

表 3-4 環境変数

変数
ブート ローダ コマンド
Cisco IOS グローバル コンフィギュレーション コマンド

BOOT

set BOOT filesystem :/ file-url ...

自動ブーティング時にロードして実行を試みる、セミコロンで区切られた実行可能ファイルのリスト。BOOT 環境変数が設定されていない場合、システムは、フラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初に検出された実行可能イメージをロードして実行を試みます。BOOT 環境変数が設定されていても指定されたイメージをロードできない場合は、システムはフラッシュ ファイル システムで最初に見つかったブート ファイルを起動しようとします。

boot system {f ilesystem:/file-url ... | switch { number | all }}

次回起動時にロードする Cisco IOS イメージと、イメージがロードされるスタック メンバーを指定します。このコマンドは、BOOT 環境変数の設定を変更します。

MANUAL_BOOT

set MANUAL_BOOT yes

スイッチが自動または手動で起動するかどうかを決定します。

有効値は 1、yes、0、および no です。no または 0 に設定されている場合、ブートローダはシステムを自動的に起動しようとします。他の値に設定されている場合は、ブート ローダ モードから手動でスイッチを起動する必要があります。

boot manual

次回起動時にスイッチを手動で起動できるようにします。MANUAL_BOOT 環境変数の設定が変更されます。

次回のシステムの再起動時には、スイッチはブート ローダ モードになります。システムを起動するには、 boot flash: filesystem :/ file-url コマンドを使用し、ブート イメージの名前を指定します。

CONFIG_FILE

set CONFIG_FILE flash:/ file-url

Cisco IOS がシステム設定の不揮発性コピーの読み書きに使用するファイル名を変更します。

boot config-file flash: / file-url

Cisco IOS がシステム設定の不揮発性コピーの読み書きに使用するファイル名を指定します。このコマンドによって、CONFIG_FILE 環境変数が変更されます。

SWITCH_NUMBER

set SWITCH_NUMBER stack-member-number

スタック メンバーのメンバー番号を変更します。

switch current-stack-member-number renumber new-stack-member-number

(注) スタック メンバーのメンバー番号を変更します。

SWITCH_PRIORITY

set SWITCH_PRIORITY stack-member-number

スタック メンバーのプライオリティ値を変更します。

switch stack-member-number priority priority-number

(注) スタック メンバーのプライオリティ値を変更します。

スイッチが内部イーサネット管理ポートを介して PC に接続されている場合、TFTP を使用してコンフィギュレーション ファイルをブート ローダにダウンロードまたはアップロードすることができます。 表 3-5 にある環境変数が設定されていることを確認してください。

 

表 3-5 TFTP の環境変数

変数
説明

MAC_ADDR

スイッチの MAC アドレスを指定します。

(注) この変数は変更しないことを推奨します。

ただし、ブート ローダ起動後にこの変数を変更するかこの値が保存されている値と異なる場合、TFTP を使用する前にこのコマンドを入力します。

IP_ADDR

スイッチの関連 IP サブネットの IP アドレスとサブネット マスクを指定します。

DEFAULT_ROUTER

デフォルト ゲートウェイの IP アドレスおよびサブネット マスクを指定します。

ソフトウェア イメージ リロードのスケジュール設定

スイッチ上でソフトウェア イメージのリロードを後で(深夜、週末などスイッチをあまり使用しないときに)行うように、スケジュールを設定できます。または(ネットワーク内のすべてのスイッチでソフトウェアをアップグレードする場合など)ネットワーク全体でリロードを同時に行うことができます。


) リロードのスケジュールは、約 24 日以内に設定する必要があります。


リロードのスケジュール設定

ソフトウェア イメージを後でリロードするようにスイッチを設定するには、特権 EXEC モードで次のいずれかのコマンドを使用します。

reload in [ hh : ] mm [ text ]

指定した分数、または時間および分数が経過したときに、ソフトウェアがリロードされるようにスケジュールを設定します。リロードは、約 24 日以内に実行する必要があります。最大 255 文字で、リロードの理由を指定できます。

スイッチ スタック内の固有のスイッチをリロードするには、 reload slot stack-member-number 特権 EXEC コマンドを使用します。

reload at hh : mm [ month day | day month ] [ text ]

指定した時刻(24 時間形式を使用)にソフトウェアがリロードされるように、スケジュールを設定します。月日を指定すると、指定された日時にリロードが行われるようにスケジュールが設定されます。月日を指定しなかった場合、リロードは当日の指定時刻に行われます(指定時刻が現時刻よりも後の場合)。または翌日の指定時刻に行われます(指定時刻が現在時刻よりも前の場合)。00:00 を指定すると、深夜 0 時のリロードが設定されます。


at キーワードを使用するのは、スイッチのシステム クロックが(Network Time Protocol(NTP; ネットワーク タイム プロトコル)、ハードウェア カレンダ、または手動で)設定されている場合だけです。時刻は、スイッチに設定された時間帯に基づきます。複数のスイッチで同時にリロードが行われるように設定する場合は、各スイッチの時刻を NTP によって同期させる必要があります。


reload コマンドはシステムを停止させます。手動で起動するように設定されていない場合、システムは自動的にリロードします。 reload コマンドは、スタートアップ コンフィギュレーションにスイッチの設定情報を保存( copy running-config startup-config )した後で使用します。

手動で起動するようにスイッチが設定されている場合、仮想端末からリロードを実行しないでください。これは、スイッチがブート ローダ モードになり、その結果、リモート ユーザが制御を失うことを防止するためです。

コンフィギュレーション ファイルを変更すると、リロードの前にコンフィギュレーションを保存するように指示するプロンプトが表示されます。保存操作時に、CONFIG_FILE 環境変数がすでに存在しないスタートアップ コンフィギュレーション ファイルを示していた場合、保存を続行するかどうかという問い合せがシステムから出されます。その状況のまま続けると、リロード時にセットアップ モードが開始されます。

次に、当日の午後 7 時 30 分にソフトウェアをスイッチにリロードする例を示します。

Switch# reload at 19:30
Reload scheduled for 19:30:00 UTC Wed Jun 5 1996 (in 2 hours and 25 minutes)
Proceed with reload? [confirm]
 

次に、先の日時を指定して、ソフトウェアをスイッチにリロードする例を示します。

Switch# reload at 02:00 jun 20
Reload scheduled for 02:00:00 UTC Thu Jun 20 1996 (in 344 hours and 53 minutes)
Proceed with reload? [confirm]
 

スケジュールがすでに設定されたリロードを取り消すには、 reload cancel 特権 EXEC コマンドを使用します。

リロード スケジュール情報の表示

リロードのスケジューリングに関する情報を表示してスイッチにリロードがスケジューリングされているかどうかを判別するには、 show reload 特権 EXEC コマンドを使用します。

リロードが予定されている時刻、リロードの理由を含め(リロードのスケジュール設定時に指定されている場合)、リロード情報が表示されます。