Cisco Catalyst Blade Switch 3130 および 3032 for Dell Software コンフィギュレーション ガイド
EtherChannel およびリンクステート トラッ キングの設定
EtherChannel およびリンクステート トラッキングの設定
発行日;2012/01/31 | 英語版ドキュメント(2011/05/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

EtherChannel およびリンクステート トラッキングの設定

EtherChannel の概要

EtherChannel の概要

ポート チャネル インターフェイス

ポート集約プロトコル

PAgP モード

PAgP と、仮想スイッチおよびデュアル アクティブ検出の相互作用

PAgP と他の機能との相互作用

Link Aggregation Control Protocol

LACP モード

LACP と他の機能との相互作用

EtherChannel の On モード

ロードバランシングおよび転送方式

EtherChannel とスイッチ スタック

EtherChannel の設定

EtherChannel のデフォルト設定

EtherChannel 設定時の注意事項

レイヤ 2 EtherChannel の設定

レイヤ 3 EtherChannel の設定

ポート チャネル論理インターフェイスの作成

物理インターフェイスの設定

EtherChannel ロードバランシングの設定

PAgP 学習方式およびプライオリティの設定

LACP ホット スタンバイ ポートの設定

LACP システム プライオリティの設定

LACP ポート プライオリティの設定

EtherChannel、PAgP、および LACP ステータスの表示

リンクステート トラッキングの概要

リンクステート トラッキングの設定

デフォルトのリンクステート トラッキングの設定

リンクステート トラッキングの設定時の注意事項

リンクステート トラッキングの設定

リンクステート トラッキング ステータスの表示

EtherChannel およびリンクステート トラッキングの設定

この章では、スイッチのレイヤ 2 およびレイヤ 3 ポートに EtherChannel を設定する方法について説明します。EtherChannel は、スイッチ、ルータ、およびサーバ間にフォールトトレラントな高速リンクを提供します。EtherChannel を使用すると、ワイヤリング クローゼットおよびデータ センタ間の帯域幅を拡張できます。EtherChannel はネットワーク上でボトルネックの発生が見込まれるところに、任意の場所に配置できます。EtherChannel は、他のリンクに負荷を再分散させることによって、リンク切断から自動的に回復します。リンク障害が発生した場合、EtherChannel は自動的に障害リンクからチャネル内の他のリンクにトラフィックをリダイレクトします。この章では、リンクステート トラッキングを設定する方法についても説明します。特に記述がない限り、 スイッチ という用語はスタンドアロン スイッチとスイッチ スタックを意味しています。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「EtherChannel の概要」

「EtherChannel の設定」

「EtherChannel、PAgP、および LACP ステータスの表示」

「リンクステート トラッキングの概要」

「リンクステート トラッキングの設定」

EtherChannel の概要

ここでは、EtherChannel の仕組みについて説明します。

「EtherChannel の概要」

「ポート チャネル インターフェイス」

「ポート集約プロトコル」

「Link Aggregation Control Protocol」

「EtherChannel の On モード」

「ロードバランシングおよび転送方式」

「EtherChannel とスイッチ スタック」

EtherChannel の概要

EtherChannel は単一の論理リンクにバンドルされた個々のギガビット イーサネット リンクで構成されます(図 38-1を参照)。

図 38-1 一般的な EtherChannel 構成

 

EtherChannel は、スイッチと別のスイッチまたはホストの間に、最大 8 Gb/s(Gigabit EtherChannel)または 80 Gb/s(10 Gigabit EtherChannel)の全二重帯域を提供します。

各 EtherChannel は、互換性のある設定のイーサネット ポートを 8 つまで使用して構成できます。各 EtherChannel 内のすべてのポートは、レイヤ 2 またはレイヤ 3 ポートのいずれかとして設定する必要があります。EtherChannel の最大数は 64 です。詳細については、「EtherChannel 設定時の注意事項」を参照してください。EtherChannel レイヤ 3 ポートは、ルーテッド ポートで構成されます。ルーテッド ポートは、 no switchport インターフェイス コンフィギュレーション コマンドを使用してレイヤ 3 モードに設定された物理ポートです。詳細については、 第 11 章「インターフェイス特性の設定」 を参照してください。

Port Aggregation Protocol(PAgP; ポート集約プロトコル)、Link Aggregation Control Protocol(LACP)、あるいは On のいずれかのモードで、EtherChannel を設定できます。EtherChannel の両端は同じモードで設定します。

EtherChannel の一方の端を PAgP または LACP モードに設定すると、システムはもう一方の端とネゴシエーションし、アクティブにするポートを決定します。リモート ポートで EtherChannel をネゴシエーションできない場合は、ローカル ポートが独立の状態になり、他の単一リンクのようにデータ トラフィックを伝送し続けます。ポート設定は変更されませんが、ポートは EtherChannel に参加しません。

EtherChannel を on モードに設定すると、ネゴシエーションは実行されません。スイッチは EtherChannel 内で互換性のあるすべてのポートを強制的にアクティブにします。EtherChannel のもう一方の端(他のスイッチ上)も、同じように on モードに設定する必要があります。それ以外を設定した場合、パケットの損失が発生します。

スタンドアロン スイッチ、スタック内の単一スイッチ、あるいはスタック内の複数のスイッチ(クロススタック EtherChannel)で、EtherChannel を作成できます。図 38-2 および図 38-3 を参照してください。

EtherChannel 内のリンクで障害が発生すると、それまでその障害リンクで伝送されていたトラフィックが EtherChannel 内の残りのリンクに切り替えられます。スイッチでトラップがイネーブルになっている場合、スイッチ、EtherChannel、および失敗したリンクを区別したトラップが送信されます。EtherChannel の 1 つのリンク上の着信ブロードキャストおよびマルチキャスト パケットは、EtherChannel の他のリンクに戻らないようにブロックされます。

図 38-2 単一スイッチ EtherChannel

 

図 38-3 クロススタック EtherChannel

 

ポート チャネル インターフェイス

EtherChannel の作成は、ポート チャネル論理インターフェイスにも関係します

レイヤ 2 ポートの場合は、 channel-group インターフェイス コンフィギュレーション コマンドを使用して、ポート チャネル論理インターフェイスを動的に作成します。

また、 interface port-channel port-channel-number グローバル コンフィギュレーション コマンドを使用して、ポート チャネル論理インターフェイスを手動で作成することもできます。ただし、その場合、論理インターフェイスを物理ポートにバインドするには、 channel-group channel-group-number コマンドを使用する必要があります。 channel-group-number port - channel-number と同じ値に設定することも、違う値を使用することもできます。新しい番号を使用した場合、 channel-group コマンドは動的に新しいポート チャネルを作成します。

レイヤ 3 ポートの場合は、 interface port-channel グローバル コンフィギュレーション コマンド、およびそのあとに no switchport インターフェイス コンフィギュレーション コマンドを使用して、論理インターフェイスを手動で作成する必要があります。その後、 channel-group インターフェイス コンフィギュレーション コマンドを使用して、手動で EtherChannel にインターフェイスを割り当てます。

レイヤ 2 およびレイヤ 3 ポートのいずれの場合も、 channel-group コマンドを実行すると、物理ポートと論理インターフェイスがバインドされます(図 38-4を参照)。

各 EtherChannel には、1 ~ 64 までの番号が付いたポート チャネル論理インターフェイスがあります。このポート チャネル インターフェイス番号は、 channel-group インターフェイス コンフィギュレーション コマンドで指定された番号に対応します。

図 38-4 物理ポート、論理ポート チャネル、およびチャネル グループの関係

 

EtherChannel を設定したあとに、ポート チャネルの設定を変更すると、そのポート チャネル インターフェイスに割り当てられたすべての物理ポートの設定も変更されます。物理ポートに適用された設定の変更は、設定を適用したポートのみに有効です。EtherChannel のすべてのポートのパラメータを変更するには、コンフィギュレーション コマンド(スパニング ツリー コマンド、またはレイヤ 2 EtherChannel をトランクとして設定するコマンドなど)をポートチャネル インターフェイスに適用します。

ポート集約プロトコル

ポート集約プロトコル(PAgP)はシスコ独自のプロトコルで、Cisco スイッチおよび PAgP をサポートするベンダーによってライセンス供与されたスイッチでだけ稼動します。PAgP を使用すると、イーサネット ポート間で PAgP パケットを交換することにより、EtherChannel を自動的に作成できます。単一スイッチの EtherChannel 設定内の PAgP だけを使用できます。クロススタック EtherChannel では PAgP をイネーブルにできません。詳細については、「EtherChannel 設定時の注意事項」を参照してください。

スイッチまたはスイッチ スタックは PAgP を使用することによって、PAgP をサポートできるパートナーの識別情報、および各ポートの機能を学習します。次に、同様に、スタック内の単一スイッチで設定されたポートを単一論理リンク(チャネルまたは集約ポート)に動的にグループ化します。設定が類似しているポートをグループ化する場合の基準は、ハードウェア、管理、およびポート パラメータ制約です。たとえば、PAgP は速度、デュプレックス モード、ネイティブ VLAN、VLAN 範囲、トランキング ステータス、およびトランキング タイプが同じポートをグループとしてまとめます。リンクをまとめて EtherChannel を形成したあとで、PAgP は単一スイッチ ポートとして、スパニング ツリーにそのグループを追加します。

PAgP モード

表 38-1 に、 channel-group インターフェイス コンフィギュレーション コマンドでユーザが設定できる EtherChannel PAgP モードを示します。

 

表 38-1 EtherChannel PAgP モード

モード
説明

auto

ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する PAgP パケットに応答しますが、PAgP パケット ネゴシエーションを開始することはありません。この設定では、PAgP パケットの伝送が最小化されます。EtherChannel メンバーがスイッチ スタックの異なるスイッチにある場合(クロススタック EtherChannel)は、このモードはサポートされていません。

desirable

ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは PAgP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。EtherChannel メンバーがスイッチ スタックの異なるスイッチにある場合(クロススタック EtherChannel)は、このモードはサポートされていません。

スイッチ ポートは、 auto モードまたは desirable モードに設定された相手ポートとだけ PAgP パケットを交換します。 on モードに設定されたポートは、PAgP パケットを交換しません。

auto モードおよび desirable モードでは、どちらの場合も、ポートは相手ポートとのネゴシエーションにより、ポート速度、レイヤ 2 EtherChannel の場合はトランキング ステートおよび VLAN 番号などの条件に基づいて、EtherChannel を形成できるかどうかを判別できます。

PAgP モードが異なっていても、モード間で互換性がある限り、ポートは EtherChannel を形成できます。次に例を示します。

desirable モードのポートは、 desirable モードまたは auto モードの別のポートとともに EtherChannel を形成できます。

auto モードのポートは、 desirable モードの別のポートとともに EtherChannel を形成できます。

どのポートも PAgP ネゴシエーションを開始しないため、 auto モードのポートは、 auto モードの別のポートとは EtherChannel を形成できません。

PAgP 対応のデバイスにスイッチを接続する場合、 non-silent キーワードを使用すると、非サイレント動作としてスイッチ ポートを設定できます。 auto モードまたは desirable モードとともに non-silent を指定しなかった場合は、サイレント モードが指定されていると見なされます。

サイレント モードを使用するのは、PAgP 非対応で、かつほとんどパケットを送信しないデバイスにスイッチを接続する場合です。サイレント パートナーの例は、トラフィックを生成しないファイル サーバ、またはパケット アナライザなどです。この場合、サイレント パートナーに接続された物理ポート上で PAgP を稼動させると、このスイッチ ポートが動作しなくなります。ただし、サイレントを設定すると、PAgP が動作してチャネル グループにポートを結合し、このポートが伝送に使用されます。

PAgP と、仮想スイッチおよびデュアル アクティブ検出の相互作用

スイッチ間のコントロールおよびデータ トラフィックを伝送する Virtual Switch Link(VSL; 仮想スイッチ リンク)によって接続される 2 つ以上の Catalyst 6500 コア スイッチを、仮想スイッチにすることができます。いずれかのスイッチがアクティブ モードです。他のスイッチはスタンバイ モードです。冗長性のため、リモート スイッチは Remote Satellite Link(RSL; リモート サテライト リンク)によって仮想スイッチに接続されます。

2 つのスイッチ間の VSL で障害が発生すると、一方のスイッチには他のスイッチのステータスがわかりません。両方のスイッチがアクティブ モードになり、設定が重複(IP アドレスとブリッジ識別子の重複を含む)したネットワークで デュアル アクティブ状態 になる可能性があります。ネットワークがダウンする可能性があります。

デュアル アクティブ状態を回避するために、コア スイッチは RSL 経由でリモート スイッチに PAgP Protocol Data Unit(PDU; プロトコル データ ユニット)を送信します。PAgP PDU はアクティブなスイッチを特定します。リモート スイッチはコア スイッチに PDU を転送するため、コア スイッチは同期化状態になります。アクティブなスイッチで障害が発生したり、リセットされたりすると、スタンバイ スイッチがアクティブなスイッチとなります。VSL がダウンした場合、あるコア スイッチは他のスイッチのステータスがわかるため、状態を変更しません。

PAgP と他の機能との相互作用

Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)および Cisco Discovery Protocol(CDP; シスコ検出プロトコル)は、EtherChannel の物理ポートを使用してパケットを送受信します。トランク ポートは、番号が最も小さい VLAN 上で PAgP プロトコル データ ユニット(PDU)を送受信します。

レイヤ 2 EtherChannel では、チャネル内で最初に起動するポートが EtherChannel に MAC アドレスを提供します。このポートがバンドルから削除されると、バンドル内の他のポートの 1 つが EtherChannel に MAC アドレスを提供します。レイヤ 3 EtherChannel の場合、インターフェイスが作成されるとすぐに、 interface port-channel グローバル コンフィギュレーション コマンド経由で、スタック マスターによって MAC アドレスが割り当てられます。

PAgP が PAgP PDU を送受信するのは、PAgP が auto モードまたは desirable モードでイネーブルになっている、稼動状態のポート上だけです。

Link Aggregation Control Protocol

LACP は IEEE 802.3ad で定義されていて、Cisco スイッチは 802.3ad プロトコルに準拠するスイッチ間のイーサネット チャネルを管理できます。LACP を使用すると、イーサネット ポート間で LACP パケットを交換することにより、EtherChannel を自動的に作成できます。

スイッチは LACP またはスイッチ スタックを使用することによって、LACP をサポートできるパートナーの識別情報、および各ポートの機能を学習します。次に、設定が類似している ポート を単一の倫理リンク(チャネルまたは集約ポート)に動的にグループ化します。設定が類似しているポートをグループ化する場合の基準は、ハードウェア、管理、およびポート パラメータ制約です。たとえば、LACP は速度、デュプレックス モード、ネイティブ VLAN、VLAN 範囲、トランキング ステータス、およびトランキング タイプが同じポートをグループとしてまとめます。リンクをまとめて EtherChannel を形成したあとで、LACP は単一スイッチ ポートとして、スパニング ツリーにそのグループを追加します。

LACP モード

表 38-2 に、 channel-group インターフェイス コンフィギュレーション コマンドでユーザが設定できる EtherChannel LACP モードを示します。

 

表 38-2 EtherChannel LACP モード

モード
説明

active

ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは LACP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。

passive

ポートはパッシブ ネゴシエーション ステートになります。この場合、ポートは受信する LACP パケットに応答しますが、LACP パケット ネゴシエーションを開始することはありません。これにより、LACP パケットの送信を最小限に抑えます。

active モードおよび passive LACP モードでは、どちらの場合も、ポートは相手ポートとのネゴシエーションにより、ポート速度、レイヤ 2 EtherChannel の場合はトランキング ステートおよび VLAN 番号などの条件に基づいて、EtherChannel を形成できるかどうかを判別できます。

LACP モードが異なっていても、モード間で互換性がある限り、ポートは EtherChannel を形成できます。次に例を示します。

active モードのポートは、 active モードまたは passive モードの別のポートとともに EtherChannel を形成できます。

どのポートも LACP ネゴシエーションを開始しないため、 passive モードのポートは、 passive モードの別のポートとは EtherChannel を形成できません。

LACP と他の機能との相互作用

DTP および CDP は、EtherChannel の物理ポートを介してパケットを送受信します。トランク ポートは、番号が最も小さい VLAN 上で LACP PDU を送受信します。

レイヤ 2 EtherChannel では、チャネル内で最初に起動するポートが EtherChannel に MAC アドレスを提供します。このポートがバンドルから削除されると、バンドル内の他のポートの 1 つが EtherChannel に MAC アドレスを提供します。レイヤ 3 EtherChannel の場合、インターフェイスが作成されるとすぐに、 interface port-channel グローバル コンフィギュレーション コマンド経由で、スタック マスターによって MAC アドレスが割り当てられます。

LACP が LACP PDU を送受信するのは、LACP が active モードまたは passive モードでイネーブルになっている稼動状態のポートとの間だけです。

EtherChannel の On モード

EtherChannel の on モードは、EtherChannel の手動設定に使用します。on モードを使用すると、ポートはネゴシエーションせずに強制的に EtherChannel に参加します。リモート デバイスが PAgP や LACP をサポートしていない場合にこの on モードが役立ちます。on モードでは、リンクの両端のスイッチが on モードに設定されている場合にだけ EtherChannel を使用できます。

同じチャネル グループの on モードで設定されたポートは、速度やデュプレックスのようなポート特性に互換性を持たせる必要があります。on モードで設定されていたとしても、互換性のないポートは suspended ステートになります。


注意 on モードの使用には注意が必要です。これは手動の設定であり、EtherChannel の両端にあるポートで同じ設定になっている必要があります。グループの設定を誤ると、パケット損失またはスパニングツリーのループが発生することがあります。

ロードバランシングおよび転送方式

EtherChannel は、フレーム内のアドレスに基づいて形成されたバイナリ パターンの一部を、チャネル内の 1 つのリンクを選択する数値に縮小することによって、チャネル内のリンク間でトラフィックのロードバランシングを行います。EtherChannel のロードバランシングには、MAC アドレスまたは IP アドレス、送信元アドレスや宛先アドレスのどちらか一方、またはその両方のアドレスを使用できます。選択したモードは、スイッチ上で設定されているすべての EtherChannel に適用されます。ロードバランシングおよび転送方式を設定するには、 port-channel load-balance グローバル コンフィギュレーション コマンドを使用します。

送信元 MAC アドレス転送の場合、EtherChannel に転送されたパケットは、着信パケットの送信元 MAC アドレスに基づいてチャネル ポート間で分配されます。したがって、ロードバランシングを行うために、送信元ホストが異なるパケットはそれぞれ異なるチャネル ポートを使用しますが、送信元ホストが同じパケットは同じチャネル ポートを使用します。

宛先 MAC アドレス転送の場合、EtherChannel に転送されたパケットは、着信パケットに指定されている宛先ホストの MAC アドレスに基づいてチャネル ポート間で分配されます。したがって、宛先が同じパケットは同じポートに転送され、宛先の異なるパケットはそれぞれ異なるチャネル ポートに転送されます。

送信元および宛先 MAC アドレス転送の場合、EtherChannel に転送されたパケットは、送信元および宛先の両方の MAC アドレスに基づいてチャネル ポート間で分配されます。この転送方式は、負荷分散の送信元 MAC アドレス転送方式と宛先 MAC アドレス転送方式を組み合わせたものです。特定のスイッチに対して送信元 MAC アドレス転送と宛先 MAC アドレス転送のどちらが適切であるかが不明な場合に使用できます。送信元および宛先 MAC アドレス転送の場合、ホスト A からホスト B、ホスト A からホスト C、およびホスト C からホスト B に送信されるパケットは、それぞれ異なるチャネル ポートを使用できます。

送信元 IP アドレスベース転送の場合、EtherChannel に転送されたパケットは、着信パケットの送信元 IP アドレスに基づいて EtherChannel ポート間で分配されます。したがって、ロードバランシングを行うために、IP アドレスが異なるパケットはそれぞれ異なるチャネル ポートを使用しますが、IP アドレスが同じパケットは同じチャネル ポートを使用します。

宛先 IP アドレスベース転送の場合、EtherChannel に転送されたパケットは、着信パケットの宛先 IP アドレスに基づいて EtherChannel ポート間で分配されます。したがって、ロードバランシングを行うために、同じ送信元 IP アドレスから異なる宛先 IP アドレスに送信されるパケットは、異なるチャネル ポートに送信できます。ただし、異なる送信元 IP アドレスから同じ宛先 IP アドレスに送信されるパケットは、常に同じチャネル ポートで送信されます。

送信元/宛先 IP アドレスベース転送の場合、EtherChannel に転送されたパケットは、着信パケットの送信元および宛先の両方の IP アドレスに基づいて EtherChannel ポート間で分配されます。この転送方式は、送信元 IP アドレスベース転送方式と宛先 IP アドレスベース転送方式を組み合わせたものです。特定のスイッチに対して送信元 IP アドレスベース転送と宛先 IP アドレスベース転送のどちらが適切であるかが不明な場合に使用できます。この方式では、IP アドレス A から IP アドレス B に、IP アドレス A から IP アドレス C に、および IP アドレス C から IP アドレス B に送信されるパケットは、それぞれ異なるチャネル ポートを使用できます。

ロードバランシング方式ごとに利点が異なります。ロードバランシング方式は、ネットワーク内のスイッチの位置、および負荷分散が必要なトラフィックの種類に基づいて選択する必要があります。図 38-5では、16 台のブレード サーバの EtherChannel がルータと通信します。ルータは単一 MAC アドレス デバイスであるため、スイッチ EtherChannel で送信元ベース転送を行うことにより、スイッチがルータの使用可能なすべての帯域幅を使用することが保証されます。ルータは、宛先アドレスベース転送を行うように設定されます。これは、多数のワークステーションで、トラフィックがルータ EtherChannel から均等に分配されることになっているためです。

設定で一番種類が多くなるオプションを使用してください。たとえば、チャネル上のトラフィックが単一 MAC アドレスだけを宛先とする場合、宛先 MAC アドレスを使用すると、チャネル内の同じリンクが常に選択されます。ただし、送信元アドレスまたは IP アドレスを使用した方が、ロードバランシングの効率がよくなる場合があります。

図 38-5 負荷の分散および転送方式

 

EtherChannel とスイッチ スタック

EtherChannel に参加しているポートを持つスタック メンバーで障害が発生した場合またはスタックを離れた場合は、スタック マスターは障害状態のスタック メンバー スイッチ ポートを EtherChannel から削除します。EtherChannel の残りのポートがある場合は、引き続き接続が維持されます。

スイッチが既存のスタックに追加されると、新しいスイッチがスタック マスターから実行コンフィギュレーションを受信し、EtherChannel 関連のスタック コンフィギュレーションで更新されます。また、スタック メンバーは動作情報(アップ状態でチャネルのメンバーであるポートのリスト)も受信します。

2 つのスタック間で EtherChannel が設定されているときに、そのスタックが統合されると、セルフループ ポートになります。スパニング ツリーはこの状態を検出し、状態に応じて動作します。ウィニング スイッチ スタックの任意の PAgP または LACP 設定は影響を受けませんが、ルージング スイッチ スタックの PAgP または LACP 設定はスタックの再起動後に失われます。

PAgP を使用すると、スタック マスターで障害が発生した場合あるいはスタックを離れた場合は、新しいスタック マスターが選択されます。EtherChannel 帯域幅に変更がない場合は、スパニング ツリーの再コンバージェンスはトリガされません。新しいスタック マスターは、スタック メンバーの設定をスタック マスターの設定に合わせて同期化します。EtherChannel のポートが古いスタック マスターにない場合は、スタック マスターの変更後に、PAgP 設定は影響を受けません。

LACP を使用すると、システム ID はスタック マスターのスタック MAC アドレスを使用します。スタック マスターが変更されると、LACP システム ID も変更される可能性があります。LACP システム ID が変更されると、EtherChannel 全体がフラップし、STP 再コンバージェンスが発生します。マスターのフェールオーバー中にスタック MAC アドレスを変更するかどうかを制御する場合は、 stack-mac persistent timer コマンドを使用します。

スイッチ スタックの詳細については、 第 7 章「スイッチ スタックの管理」 を参照してください。

EtherChannel の設定

ここでは、次の設定情報について説明します。

「EtherChannel のデフォルト設定」

「EtherChannel 設定時の注意事項」

「レイヤ 2 EtherChannel の設定」(必須)

「レイヤ 3 EtherChannel の設定」(必須)

「EtherChannel ロードバランシングの設定」(任意)

「PAgP 学習方式およびプライオリティの設定」(任意)

「LACP ホット スタンバイ ポートの設定」(任意)


) 必ず、ポートを正しく設定してください。詳細については、「EtherChannel 設定時の注意事項」を参照してください。



) EtherChannel の設定後、ポート チャネル インターフェイスに適用した設定変更は、そのポート チャネル インターフェイスに割り当てられたすべての物理ポートに適用されます。また、物理ポートに適用した設定変更は、設定を適用したポートだけに作用します。


EtherChannel のデフォルト設定

表 38-3 に、EtherChannel のデフォルト設定を示します。

 

表 38-3 EtherChannel のデフォルト設定

機能
デフォルト設定

チャネル グループ

割り当てなし。

ポート チャネル論理インターフェイス

未定義。

PAgP モード

デフォルトなし。

PAgP 学習方式

すべてのポートで集約ポート ラーニング。

PAgP プライオリティ

すべてのポートで 128。

LACP モード

デフォルトなし。

LACP 学習方式

すべてのポートで集約ポート ラーニング。

LACP ポート プライオリティ

すべてのポートで 32768。

LACP システム プライオリティ

32768

LACP システム ID

LACP システム プライオリティおよびスイッチの MAC アドレス。

Load-balancing

着信パケットの送信元 MAC アドレスに基づいてスイッチ上で負荷を分散。

EtherChannel 設定時の注意事項

EtherChannel ポートを正しく設定していない場合は、ネットワーク ループおよびその他の問題を回避するために、一部の EtherChannel インターフェイスが自動的にディセーブルになります。設定上の問題を回避するために、次の注意事項に従ってください。

スイッチ上には 48 を超える EtherChannel を設定しないでください。

PAgP EtherChannel は、同じタイプのイーサネット ポートを 8 つまで使用して設定します。

同じタイプのイーサネット ポートを最大で 16 備えた LACP EtherChannel を設定してください。最大 8 個のポートをアクティブにして、最大 8 個のポートをスタンバイ モードにすることができます。

EtherChannel 内のすべてのポートを同じ速度および同じデュプレックス モードで動作するように設定します。

EtherChannel 内のすべてのポートをイネーブルにします。 shutdown インターフェイス コンフィギュレーション コマンドによってディセーブルにされた EtherChannel 内のポートは、リンク障害として扱われます。そのポートのトラフィックは、EtherChannel 内の他のポートの 1 つに転送されます。

グループを初めて作成したときには、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。次のパラメータのいずれかで設定を変更した場合は、グループ内のすべてのポートでも変更する必要があります。

許可 VLAN リスト

各 VLAN のスパニング ツリー パス コスト

各 VLAN のスパニング ツリー ポート プライオリティ

スパニング ツリー PortFast の設定

1 つのポートが複数の EtherChannel グループのメンバーになるように設定しないでください。

EtherChannel は、PAgP と LACP の両方のモードには設定しないでください。PAgP および LACP を実行する EtherChannel グループは、同じスイッチまたはスタック内の異なるスイッチで共存できます。個々の EtherChannel グループは PAgP または LACP のどちらかを実行できますが、相互運用することはできません。

EtherChannel の一部として Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)宛先ポートを設定しないでください。

EtherChannel の一部としてセキュア ポートを設定したり、セキュア ポートの一部として EtherChannel を設定したりしないでください。

プライベート VLAN ポートを EtherChannel の一部として設定しないでください。

アクティブまたはアクティブでない EtherChannel メンバーを IEEE 802.1x ポートとして設定しないでください。EtherChannel ポートで IEEE 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、IEEE 802.1x はイネーブルになりません。

EtherChannel がスイッチ インターフェイスで設定されている場合は、インターフェイスから EtherChannel 設定を削除してから、 dot1x system-auth-control グローバル コンフィギュレーション コマンドを使用して、スイッチの IEEE 802.1x をグローバルにイネーブルにします。

ダウンストリーム Etherchannel インターフェイスに属すインターフェイスでは、リンクステート トラッキングを個別にイネーブルにしないでください。

レイヤ 2 EtherChannel の場合

EtherChannel 内のすべてのポートを同じ VLAN に割り当てるか、またはトランクとして設定してください。複数のネイティブ VLAN に接続されるポートは、EtherChannel を形成できません。

トランク ポートから EtherChannel を設定する場合は、すべてのトランクでトランキング モードが同じであることを確認してください。EtherChannel ポートのトランクのモードが一致していないと、予想外の結果になる可能性があります。

EtherChannel は、トランキング レイヤ 2 EtherChannel 内のすべてのポート上で同じ VLAN 許容範囲をサポートしています。VLAN 許容範囲が一致していないと、PAgP が auto モードまたは desirable モードに設定されていても、ポートは EtherChannel を形成しません。

スパニング ツリー パス コストが異なるポートは、設定上の矛盾がない限り、EtherChannel を形成できます。異なるスパニング ツリー パス コストを設定すること自体は、EtherChannel を形成するポートの矛盾にはなりません。

レイヤ3 EtherChannel の場合は、レイヤ 3 アドレスをチャネル内の物理ポートでなく、ポート チャネル論理インターフェイスに割り当ててください。

クロススタック EtherChannel 設定の場合は、必ず EtherChannel に向けられたすべてのポートを LACP 用に設定するか、 channel-group channel-group-number mode on インターフェイス コンフィギュレーション コマンドを使用して、このポートがチャネル グループになるように手動で設定します。PAgP はクロススタック EtherChannel ではサポートされていません。

クロススタック EtherChannel とスイッチ スタック パーティションが設定されている場合は、ループと転送誤動作が発生する可能性があります。

レイヤ 2 EtherChannel の設定

レイヤ 2 EtherChannel を設定するには、 channel-group インターフェイス コンフィギュレーション コマンドを使用して、チャネル グループにポートを割り当てます。このコマンドにより、ポート チャネル論理インターフェイスが自動的に作成されます。

auto または desirable モードでポートの PAgP をイネーブルにした場合は、 on モードまたは LACP モード用に再設定してから、このポートを EtherChannel に追加します。PAgP はクロススタック EtherChannel をサポートしません。

レイヤ 2 EtherChannel にレイヤ 2 イーサネット ポートを割り当てるには、特権 EXEC モードで次の手順を実行します。この手順は必須です。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

物理ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

指定できるインターフェイスとして、物理ポートも含まれます。

PAgP EtherChannel の場合、同じタイプおよび速度のポートを 8 つまで同じグループに設定できます。

LACP EtherChannel の場合、同じタイプのイーサネット ポートを 16 まで設定できます。最大 8 個のポートをアクティブにして、最大 8 個のポートをスタンバイ モードにすることができます。

ステップ 3

switchport mode { access | trunk }

switchport access vlan vlan-id

すべてのポートをスタティックアクセス ポートとして同じ VLAN に割り当てるか、またはトランクとして設定します。

ポートをスタティックアクセス ポートとして設定する場合は、ポートを 1 つの VLAN だけに割り当ててください。指定できる範囲は 1 ~ 4094 です。

ステップ 4

channel-group channel -group-number mode { auto [ non-silent ] | desirable [ non-silent ] | on } | { active | passive }

チャネル グループにポートを割り当て、PAgP モードまたは LACP モードを指定します。

channel-group-number の範囲は 1 ~ 64 です。

mode には、次のキーワードのいずれか 1 つを選択します。

auto PAgP デバイスが検出された場合にだけ、PAgP をイネーブルにします。ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する PAgP パケットに応答しますが、PAgP パケット ネゴシエーションを開始することはありません。EtherChannel メンバーがスイッチ スタックの異なるスイッチにある場合は、このキーワードはサポートされません。

desirable PAgP を無条件でイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは PAgP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。EtherChannel メンバーがスイッチ スタックの異なるスイッチにある場合は、このキーワードはサポートされません。

on PAgP や LACP を使用せずに、ポートを強制的にチャネル化します。 on モードでは、使用可能な EtherChannel が存在するのは、 on モードのポート グループが、 on モードの別のポート グループに接続する場合だけです。

non-silent :(任意) PAgP 対応のデバイスに接続されたスイッチのポートが auto または desirable モードの場合に、非サイレント動作を行うようにこのポートを設定します。 non-silent を指定しなかった場合は、サイレントが指定されたものと見なされます。サイレント設定は、ファイル サーバまたはパケット アナライザとの接続に適しています。サイレントを設定すると、PAgP が動作してチャネル グループにポートを結合し、このポートが伝送に使用されます。

active :LACP デバイスが検出された場合にだけ、LACP をイネーブルにします。これにより、ポートはアクティブ ネゴシエーション ステートになります。このステートの場合、ポートは LACP パケットを送信し、他のポートとのネゴシエーションを開始します。

passive ポート上で LACP をイネーブルにして、ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する LACP パケットに応答しますが、LACP パケット ネゴシエーションを開始することはありません。

スイッチおよびデバイスのモードの互換性に関する情報については、「PAgP モード」および「LACP モード」を参照してください。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show running-config

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

EtherChannel グループからポートを削除するには、 no channel-group インターフェイス コンフィギュレーション コマンドを使用します。

次に、スタックのシングル スイッチで EtherChannel を設定する例を示します。2 つのポートを VLAN 10 のスタティック アクセス ポートとして、PAgP モードが desirable であるチャネル 5 に割り当てます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode desirable non-silent
Switch(config-if-range)# end
 

次に、スタックのシングル スイッチで EtherChannel を設定する例を示します。2 つのポートは VLAN 10 のスタティックアクセス ポートとして、LACP モードが active であるチャネル 5 に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode active
Switch(config-if-range)# end
 

次に、クロススタック EtherChannel を設定する例を示します。LACP パッシブ モードを使用して、VLAN 10 のスタティック アクセス ポートとして、スタック メンバー 2 の 2 つのポートとスタック メンバー 3 の 1 つのポートをチャネル 5 に割り当てます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/4 -5
Switch(config-if-range)# switchport mode access
Switch(config-if-range)# switchport access vlan 10
Switch(config-if-range)# channel-group 5 mode active
Switch(config-if-range)# exit
Switch(config)# interface gigabitethernet3/0/3
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10
Switch(config-if)# channel-group 5 mode active
Switch(config-if)# exit

レイヤ 3 EtherChannel の設定

レイヤ 3 EtherChannel を設定するには、ポート チャネル論理インターフェイスを作成し、そのポート チャネルにイーサネット ポートを組み込みます。次に設定方法を説明します。

ポート チャネル論理インターフェイスの作成

レイヤ 3 EtherChannel を設定する場合、まず interface port-channel グローバル コンフィギュレーション コマンドを使用し、ポート チャネル論理インターフェイスを手動で作成する必要があります。次に、 channel-group インターフェイス コンフィギュレーション コマンドを使用して論理インターフェイスをチャネル グループに配置します。


) 物理ポートから EtherChannel に IP アドレスを移動するには、物理ポートから IP アドレスを削除してから、その IP アドレスをポート チャネル インターフェイス上で設定する必要があります。


レイヤ 3 EtherChannel 用のポート チャネル インターフェイスを作成するには、特権 EXEC モードで次の手順を実行します。この手順は必須です。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface port-channel port- channel-number

ポート チャネル論理インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

port - channel-number の範囲は 1 ~ 64です。

ステップ 3

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 4

ip address ip-address mask

EtherChannel に IP アドレスおよびサブネット マスクを割り当てます。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show etherchannel channel-group-number detail

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ステップ 8

レイヤ 3 EtherChannel にイーサネット ポートを割り当てます。詳細については、「物理インターフェイスの設定」を参照してください。

ポート チャネルを削除するには、 no interface port-channel port-channel-number グローバル コンフィギュレーション コマンドを使用します。

次に、論理ポート チャネル 5 を作成し、IP アドレスとして 172.10.20.10 を割り当てる例を示します。

Switch# configure terminal
Switch(config)# interface port-channel 5
Switch(config-if)# no switchport
Switch(config-if)# ip address 172.10.20.10 255.255.255.0
Switch(config-if)# end

物理インターフェイスの設定

レイヤ 3 EtherChannel にイーサネット ポートを割り当てるには、特権 EXEC モードで次の手順を実行します。この手順は必須です。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

物理ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

指定できるインターフェイスとして、物理ポートも含まれます。

PAgP EtherChannel の場合、同じタイプおよび速度のポートを 8 つまで同じグループに設定できます。

LACP EtherChannel の場合、同じタイプのイーサネット ポートを 16 まで設定できます。最大 8 個のポートをアクティブにして、最大 8 個のポートをスタンバイ モードにすることができます。

ステップ 3

no ip address

この物理ポートに割り当てられている IP アドレスをすべて削除します。

ステップ 4

no switchport

ポートをレイヤ 3 モードにします。

ステップ 5

channel-group channel -group-number mode { auto [ non-silent ] | desirable [ non-silent ] | on } | { active | passive }

チャネル グループにポートを割り当て、PAgP モードまたは LACP モードを指定します。

channel-group-number の範囲は 1 ~ 64 です。この番号は、「ポート チャネル論理インターフェイスの作成」で設定される port-channel-number (論理ポート)と同じでなければなりません。

mode には、次のキーワードのいずれか 1 つを選択します。

auto :PAgP デバイスが検出された場合にだけ、PAgP をイネーブルにします。ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する PAgP パケットに応答しますが、PAgP パケット ネゴシエーションを開始することはありません。EtherChannel メンバーがスイッチ スタックの異なるスイッチにある場合は、このキーワードはサポートされません。

desirable :PAgP を無条件でイネーブルにします。ポートをアクティブ ネゴシエーション ステートにします。この場合、ポートは PAgP パケットを送信することによって、相手ポートとのネゴシエーションを開始します。EtherChannel メンバーがスイッチ スタックの異なるスイッチにある場合は、このキーワードはサポートされません。

on :PAgP や LACP を使用せずに、ポートを強制的にチャネル化します。 on モードでは、使用可能な EtherChannel が存在するのは、 on モードのポート グループが、 on モードの別のポート グループに接続する場合だけです。

non-silent :(任意)PAgP 対応のパートナーに接続されたスイッチのポートが auto または desirable モードの場合に、非サイレント動作を行うようにこのポートを設定します。 non-silent を指定しなかった場合は、サイレントが指定されたものと見なされます。サイレント設定は、ファイル サーバまたはパケット アナライザとの接続に適しています。サイレントを設定すると、PAgP が動作してチャネル グループにポートを結合し、このポートが伝送に使用されます。

active :LACP デバイスが検出された場合にだけ、LACP をイネーブルにします。これにより、ポートはアクティブ ネゴシエーション ステートになります。このステートの場合、ポートは LACP パケットを送信し、他のポートとのネゴシエーションを開始します。

passive ポート上で LACP をイネーブルにして、ポートをパッシブ ネゴシエーション ステートにします。この場合、ポートは受信する LACP パケットに応答しますが、LACP パケット ネゴシエーションを開始することはありません。

スイッチおよびデバイスのモードの互換性に関する情報については、「PAgP モード」および「LACP モード」を参照してください。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show running-config

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次の例では、EtherChannel を設定する方法を示します。2 つのポートは、LACP モードが active であるチャネル 5 に割り当てられます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/1 -2
Switch(config-if-range)# no ip address
Switch(config-if-range)# no switchport
Switch(config-if-range)# channel-group 5 mode active
Switch(config-if-range)# end
 

次に、クロススタック EtherChannel を設定する例を示します。LACP アクティブ モードを使用して、スタック メンバー 2 の 2 つのポートとスタック メンバー 3 の 1 つのポートをチャネル 7 に割り当てます。

Switch# configure terminal
Switch(config)# interface range gigabitethernet2/0/4 -5
Switch(config-if-range)# no ip address
Switch(config-if-range)# no switchport
Switch(config-if-range)# channel-group 7 mode active
Switch(config-if-range)# exit
Switch(config)# interface gigabitethernet3/0/3
Switch(config-if)# no ip address
Switch(config-if)# no switchport
Switch(config-if)# channel-group 7 mode active
Switch(config-if)# exit

EtherChannel ロードバランシングの設定

ここでは、送信元ベースまたは宛先ベースの転送方式を使用することによって、EtherChannel のロードバランシングを設定する手順について説明します。詳細については、「ロードバランシングおよび転送方式」を参照してください。

EtherChannel のロードバランシングを設定するには、特権 EXEC モードで次の手順を実行します。この手順は任意です。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

port-channel load-balance { dst-ip | dst-mac | src-dst-ip | src-dst-mac | src-ip | src-mac }

EtherChannel のロードバランシング方式を設定します。

デフォルトは src-mac です。

次のいずれかの負荷分散方式を選択します。

dst-ip :宛先ホスト IP アドレスに基づいて負荷を分散します。

dst-mac :着信パケットの宛先ホスト MAC アドレスに基づいて負荷を分散します。

src-dst-ip :送信元および宛先ホスト IP アドレスに基づいて負荷を分散します。

src-dst-mac :送信元および宛先ホスト MAC アドレスに基づいて負荷を分散します。

src-ip :送信元ホスト IP アドレスに基づいて負荷を分散します。

src-mac :着信パケットの送信元 MAC アドレスに基づいて負荷を分散します。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show etherchannel load-balance

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

EtherChannel のロードバランシングをデフォルトの設定に戻す場合は、 no port-channel load-balance グローバル コンフィギュレーション コマンドを使用します。

PAgP 学習方式およびプライオリティの設定

ネットワーク デバイスは、PAgP 物理ラーナーまたは集約ポート ラーナーに分類されます。物理ポートによってアドレスを学習し、その知識に基づいて送信を指示するデバイスは物理ラーナーです。集約(論理)ポートによってアドレスを学習するデバイスは、集約ポート ラーナーです。学習方式は、リンクの両端で同一の設定にする必要があります。

デバイスとそのパートナーが両方とも集約ポート ラーナーの場合、論理ポート チャネル上のアドレスを学習します。デバイスは EtherChannel のいずれかのポートを使用することによって、送信元にパケットを送信します。集約ポート ラーニングを使用している場合、どの物理ポートにパケットが届くかは重要ではありません。

PAgP は、パートナー デバイスが物理ラーナーの場合およびローカル デバイスが集約ポート ラーナーの場合には自動検出できません。したがって、物理ポートでアドレスを学習するには、ローカル デバイスに手動で学習方式を設定する必要があります。また、負荷の分散方式を送信元ベース分散に設定して、指定された送信元 MAC アドレスが常に同じ物理ポートに送信されるようにする必要もあります。

グループ内の 1 つのポートですべての伝送を行うように設定して、他のポートをホット スタンバイに使用することもできます。選択された 1 つのポートでハードウェア信号が検出されなくなった場合は、数秒以内に、グループ内の未使用のポートに切り替えて動作させることができます。パケット伝送用に常に選択されるように、ポートを設定するには、 pagp port-priority インターフェイス コンフィギュレーション コマンドを使用してプライオリティを変更します。プライオリティが高いほど、そのポートが選択される可能性が高まります。


) CLI(コマンドライン インターフェイス)で physical-port キーワードを指定した場合でも、スイッチがサポートするのは、集約ポート上でのアドレス学習だけです。pagp learn-method コマンドおよび pagp port-priority コマンドは、スイッチ ハードウェアに影響を与えませんが、Catalyst 1900 シリーズ スイッチなど、物理ポートによるアドレス学習だけをサポートするデバイスとの PAgP 相互運用性のためには必須です。

スイッチのリンク パートナーが(Catalyst 1900 シリーズ スイッチなどのように)物理ラーナーである場合、pagp learn-method physical-port インターフェイス コンフィギュレーション コマンドを使用してスイッチを物理ポート ラーナーに設定することを推奨します。送信元 MAC アドレスに基づいて負荷の分散方式を設定するには、port-channel load-balance src-mac グローバル コンフィギュレーション コマンドを使用します。この設定により、送信元アドレスの学習元である EtherChannel 内の同じポートを使用して、パケットが Catalyst 1900 スイッチに送信されます。この場合には、pagp learn-method コマンドだけを使用してください。


スイッチを PAgP 物理ポート ラーナーとして設定し、バンドル内の同じポートがパケット送信用として選択されるようにプライオリティを調整するには、特権 EXEC モードで次の手順を実行します。この手順は任意です。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

伝送ポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

pagp learn-method physical-port

PAgP 学習方式を選択します。

デフォルトでは、 aggregation-port learning が選択されています。つまり、EtherChannel 内のポートのいずれかを使用して、パケットが送信元に送信されます。集約ポート ラーニングを使用している場合、どの物理ポートにパケットが届くかは重要ではありません。

物理ラーナー である 別のスイッチに接続するには、 physical-port を選択します。 port-channel load-balance グローバル コンフィギュレーション コマンドは、必ず src-mac に設定してください(「EtherChannel ロードバランシングの設定」を参照)。

学習方式はリンクの両端で同じ方式に設定する必要があります。

ステップ 4

pagp port-priority priority

選択したポートがパケット伝送用として選択されるように、プライオリティを割り当てます。

priority の範囲は、0 ~ 255 です。デフォルト値は 128 です。プライオリティが高いほど、PAgP 送信でポートが使用される可能性が高くなります。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show running-config

または

show pagp channel-group-number internal

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

プライオリティをデフォルト設定に戻すには、 no pagp port-priority インターフェイス コンフィギュレーション コマンドを使用します。学習方式をデフォルト設定に戻すには、 no pagp learn-method インターフェイス コンフィギュレーション コマンドを使用します。

LACP ホット スタンバイ ポートの設定

イネーブルの場合、LACP はチャネル内の LACP 互換ポート数を最大に設定しようとします(最大 16 ポート)。同時にアクティブになれる LACP リンクは 8 つだけです。リンクが追加されるとソフトウェアによってホット スタンバイモードになります。アクティブ リンクの 1 つが非アクティブになると、ホット スタンバイ モードのリンクが代わりにアクティブになります。

9 つ以上のリンクが EtherChannel グループとして設定された場合、ソフトウェアは LACP プライオリティに基づいてアクティブにするホット スタンバイ ポートを決定します。ソフトウェアは LACP が動作するシステム間のリンクごとに、次の要素(プライオリティ順)からなる一意のプライオリティを割り当てます。

LACP システム プライオリティ

システム ID(スイッチの MAC アドレス)

LACP ポート プライオリティ

ポート番号

プライオリティの比較においては、数値が小さいほどプライオリティが高くなります。プライオリティは、ハードウェア上の制約がある場合に、すべての互換ポートが集約されないように、スタンバイ モードにするポートを決定します。

アクティブであるポートとホット スタンバイ状態であるポートを決定するには、2 つの段階があります。まず、数値的に下位のシステム プライオリティのシステムとシステム ID が決定で配置されます。次に、システムによって、ポート プライオリティ値とポート番号値に基づいて、アクティブであるポートとホット スタンバイ状態であるポートが決定されます。他のシステムのポート プライオリティとポート番号値は使用されません。

ソフトウェアのアクティブおよびスタンバイ リンクの選択方法に影響を与えるように、LACP システム プライオリティおよび LACP ポート プライオリティのデフォルト値を変更できます。詳細については、「LACP システム プライオリティの設定」および「LACP ポート プライオリティの設定」を参照してください。

LACP システム プライオリティの設定

lacp system-priority グローバル コンフィギュレーション コマンドを使用して、LACP で使用可能なすべての EtherChannel にシステム プライオリティを設定できます。LACP を設定済みの各チャネルに対しては、システム プライオリティを設定できません。デフォルト値を変更すると、ソフトウェアのアクティブおよびスタンバイ リンクの選択方法に影響します。

show etherchannel summary 特権 EXEC コマンドを使用して、ホット スタンバイ モードのポートを確認できます(ポートステート フラグが H になっています)。

LACP システム プライオリティを設定するには、特権 EXEC モードで次の手順を実行します。この手順は任意です。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

lacp system-priority priority

LACP システム プライオリティを設定します。

priority の範囲は、1 ~ 65535 です。デフォルト値は 32768 です。

値が小さいほど、システム プライオリティは高くなります。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show running-config

または

show lacp sys-id

設定を確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

LACP システム プライオリティをデフォルトの値に戻すには、 no lacp system-priority グローバル コンフィギュレーション コマンドを使用します。

LACP ポート プライオリティの設定

デフォルトでは、すべてのポートは同一のポート プライオリティです。ローカル システムのシステム プライオリティおよびシステム ID の値がリモート システムよりも小さい場合は、LACP EtherChannel ポートのポート プライオリティをデフォルトよりも小さい値に変更して、最初にアクティブになるホット スタンバイ リンクを変更することができます。ポート番号が小さいホット スタンバイ ポートほど、先にチャネル内でアクティブになります。 show etherchannel summary 特権 EXEC コマンドを使用して、ホット スタンバイ モードのポートを確認できます(ポートステート フラグが H になっています)。


) LACP がすべての互換ポートを集約できない場合(たとえば、ハードウェアの制約が大きいリモート システム)、EtherChannel 中でアクティブにならないポートはすべてホット スタンバイ ステートになり、チャネル化されたポートのいずれかが機能しない場合に限り使用されます。


LACP ポート プライオリティを設定するには、特権 EXEC モードで次の手順を実行します。この手順は任意です。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

lacp port-priority priority

LACP ポート プライオリティを設定します。

priority の範囲は、1 ~ 65535 です。デフォルト値は 32768 です。値が小さいほど、ポートが LACP 送信で使用される可能性が高くなります。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show running-config

または

show lacp [ channel-group-number ] internal

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

LACP ポート プライオリティをデフォルト値に戻すには、 no lacp port-priority インターフェイス コンフィギュレーション コマンドを使用します。

EtherChannel、PAgP、および LACP ステータスの表示

EtherChannel、PAgP、および LACP ステータス情報を表示するには、 表 38-4 に記載された特権 EXEC コマンドを使用します。

 

表 38-4 EtherChannel、PAgP、および LACP ステータスを表示するためのコマンド

コマンド
説明

show etherchannel [ channel-group-number { detail | port | port-channel | protocol | summary }] { detail | load-balance | port | port-channel | protocol | summary }

EtherChannel 情報が簡潔、詳細に、1 行のサマリー形式で表示されます。ロードバランシング方式またはフレーム配布方式、ポート、ポート チャネル、プロトコルの情報も表示されます。

show pagp [ channel-group-number ] { counters | internal | neighbor }

トラフィック情報、内部 PAgP 設定、ネイバー情報などの PAgP 情報が表示されます。

show pagp [ channel-group-number ] dual-active

デュアル アクティブ検出ステータスを表示します。

show lacp [channel-group-number] {counters | internal | neighbor}

トラフィック情報、内部 LACP 設定、ネイバー情報などの LACP 情報が表示されます。

PAgP チャネルグループ情報およびトラフィック カウンタをクリアするには、 clear pagp { channel-group-number counters | counters }特権 EXEC コマンドを使用します。

LACP チャネルグループ情報およびトラフィック カウンタをクリアするには、 clear lacp { channel-group-number counters | counters } 特権 EXEC コマンドを使用します。

出力内の各フィールドについては、 このリリースのコマンド リファレンス を参照してください。

リンクステート トラッキングの概要

リンクステート トラッキングは、トランク フェールオーバーとも呼ばれ、複数のインターフェイスのリンクステートをバインドする機能です。リンクステート トラッキングがサーバ Network Interface Card(NIC; ネットワーク インターフェイス カード)アダプタ チーミングと使用されると、ネットワークが冗長化されます。サーバ ネットワーク アダプタが チーミング と呼ばれるプライマリまたはセカンダリ関係で構成され、プライマリ インターフェイスでリンクが失われると、接続は透過的にセカンダリ インターフェイスに変更されます。

図 38-6には、リンクステート トラッキング設定されたネットワークを示します。リンクステート トラッキングをイネーブルにするには、 link-state group を作成し、リンクステート グループに割り当てるインターフェイスを指定します。ポートの集合(EtherChannel)、アクセス モードまたはトランク モードの単一の物理ポート、またはルーテッド ポートをインターフェイスに指定できます。リンクステート グループでは、これらのインターフェイスはまとめてバンドルされます。 ダウンストリーム インターフェイス は、 アップストリーム インターフェイス にバインドされます。サーバに接続されたインターフェイスはダウンストリーム インターフェイスと呼ばれ、ディストリビューション スイッチおよびネットワーク装置に接続されたインターフェイスはアップストリーム インターフェイスと呼ばれます。

図 38-6 一般的なリンクステート トラッキングの設定

 

図 38-6の設定によって、サーバ NIC アダプタ チーミングが使用されるときに、ディストリビューション スイッチへのアップリンク接続が失われた場合でも、トラフィック フローが中断されないことが保証されます。

エンクロージャのブレード スイッチはポート チャネル経由で、ディストリビューション スイッチ 1 とディストリビューション スイッチ 2 に接続されます。

リンクステート グループ 1 は、ポート チャネル 1 経由のエンクロージャ(ブレード サーバ 1 ~ ブレード サーバ n)のすべてのブレード サーバからディストリビューション スイッチまでのプライマリ リンクです。

リンクステート グループ 2 は、ポート チャネル 2 経由のすべてのブレード サーバからディストリビューション スイッチまでのセカンダリ リンクです。

ブレード サーバはアクティブであるイーサネット サーバ インターフェイスを選択できます。ネットワーク トラフィック フローのバランスを保つために、リンクステート グループ 1 の一部のイーサネット インターフェイスとリンクステート グループ 2 の一部のイーサネット インターフェイスがアクティブになります。たとえば、ブレード スイッチ 1 に接続しているイーサネット インターフェイスの半分がアクティブで、ブレード サーバ 2 に接続している残りのインターフェイスがアクティブである場合、次のようにトラフィック フローを分割できます。

アクティブなイーサネット インターフェイスの半分からのトラフィックがブレード スイッチ 1 からディストリビューション スイッチ 1 までフローします。

残りのアクティブなイーサネット インターフェイスからのトラフィックがブレード スイッチ 2 からディストリビューション スイッチ 2 までフローします。

リンクステート グループでは、ディストリビューション スイッチまたはルータでの障害発生、ケーブル切断、あるいはリンク喪失のため、アップストリーム ポートが利用できないか接続が失われる可能性があります。次に、リンクステート トラッキングがイネーブルの場合のダウンストリーム インターフェイスとアップストリーム インターフェイス間の相互作用を示します。

アップストリーム インターフェイスのいずれかが link-up ステートである場合は、ダウンストリーム インターフェイスは link-up ステートに変更されるか、link-up ステートを維持できます。

アップストリーム インターフェイスのすべてが利用できなくなった場合、リンクステート トラッキングは自動的にダウンストリーム インターフェイスを errdisable ステートにします。サーバとの接続は自動的にプライマリ サーバ インターフェイスからセカンダリ サーバ インターフェイスに変更されます。

リンクステート グループ 1 からリンクステート グループ 2 への接続変更の例としては、ブレード スイッチ 1 からディストリビューション スイッチ 1 へのプライマリ リンクが失われるときに、ブレード サーバ 1 はセカンダリ イーサネット サーバ インターフェイス経由でリンクステート グループ 2 のブレード スイッチに接続します。

リンクステート グループが設定され、リンクステート トラッキングがディセーブルであるときに、アップストリーム インターフェイスが接続を失うと、ダウンストリーム インターフェイスのリンク ステートは変化しません。サーバはアップストリームの接続が切断されたことを認識しないため、セカンダリ インターフェイスへのフェールオーバーは実行されません。

障害のあるダウンストリーム ポートをリンクステート グループから削除することで、ダウンストリーム インターフェイスのリンクダウン状態から復旧できます。複数のダウンストリーム インターフェイスを復旧させるには、リンクステート グループをディセーブルにします。

リンクステート トラッキングの設定

ここでは、リンクステート トラッキング ポートの設定について説明します。

「デフォルトのリンクステート トラッキングの設定」

「リンクステート トラッキングの設定時の注意事項」

「リンクステート トラッキングの設定」

「リンクステート トラッキング ステータスの表示」

デフォルトのリンクステート トラッキングの設定

リンクステート グループは定義されておらず、リンクステート トラッキングはどのグループでもイネーブルではありません。

リンクステート トラッキングの設定時の注意事項

設定上の問題を回避するために、次の注意事項に従ってください。

アップストリーム インターフェイスとして定義されているインターフェイスを、同じまたは異なるリンクステート グループ内でダウンストリーム インターフェイスとして定義することはできません。その逆も同様です。

インターフェイスは、複数のリンクステート グループのメンバーにはなれません。

スタッキング非対応スイッチごとに設定できるのは、2 個のリンクステート グループだけです。

スタッキング対応スイッチごとに設定できるのは、10 個のリンクステート グループだけです。

ダウンストリーム Etherchannel インターフェイスに属すインターフェイスでは、リンクステート トラッキングを個別にイネーブルにしないでください。

gigabitethernet n/ 0/1 ~ gigabitethernet n / 0/14 のインターフェイスだけを特定のリンクステート グループのダウンストリーム ポートとして設定できます。ここでは、 n は 1 ~ 9 の範囲のスタック メンバー番号です。

次のインターフェイスだけを特定のリンクステート グループのアップストリーム ポートとして設定できます。

gigabitethernet n/ 0/15 ~ gigabitethernet n/ 0/18。ここでは、 n は 1 ~ 9 の範囲のスタック メンバー番号です。

tengigabitethernet n/ 0/1。ここでは、 n は 1 ~ 9 の範囲のスタック メンバー番号です。

リンクステート トラッキングの設定

リンクステート グループを設定し、そのグループにインターフェイスを割り当てるには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

link state track number

リンクステート グループを作成して、リンクステート トラッキングをイネーブルにします。グループ番号は、1 ~ 10 です。デフォルトは 1 です。

ステップ 3

interface interface-id

物理インターフェイスまたはインターフェイスの範囲を設定して、インターフェイス コンフィギュレーション モードを開始します。

有効なインターフェイスには、アクセス モードまたはトランク モード(IEEE 802.1q)のスイッチ ポート、ルーテッド ポート、アップストリーム EtherChannel インターフェイス(スタティック、PAgP、または LACP)にバンドルされた、トランク モードの複数ポートが含まれます。

(注) ダウンストリーム Etherchannel インターフェイスに属すインターフェイスでは、リンクステート トラッキングを個別にイネーブルにしないでください。

ステップ 4

link state group [ number ] { upstream | downstream }

リンクステート グループを指定して、グループの upstream または downstream インターフェイスとしてインターフェイスを設定します。グループ番号は、1 ~ 10 です。デフォルトは 1 です。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show running-config

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

次に、リンクステート グループを作成してインターフェイスを設定する例を示します。

Switch# configure terminal
Switch(config)# link state track 1
Switch(config)# interface port-channel 1
Switch(config-if)# link state group 1 upstream
Switch(config-if)# end

) インターフェイスが EtherChannel の一部である場合は、個々のポート メンバーではなくリンクステート グループの一部として、ポート チャネル名を指定する必要があります。


リンクステート グループをディセーブルにするには、 no link state track number グローバル コンフィギュレーション コマンドを使用します。

リンクステート トラッキング ステータスの表示

show link state group コマンドを使用してリンクステート グループの情報を表示します。キーワードを指定しないでこのコマンドを使用すると、すべてのリンクステート グループの情報が表示されます。特定のグループの情報を表示するには、グループ番号を入力します。グループの詳細情報を表示するには、detail キーワードを使用します。

次の例では、 show link state group 1 コマンドの出力を示します。

Switch> show link state group 1
 
Link State Group: 1 Status: Enabled, Down
 

次の例では、 show link state group detail コマンドの出力を示します。

Switch> show link state group detail
(Up):Interface up (Dwn):Interface Down (Dis):Interface disabled
 
Link State Group: 1 Status: Enabled, Up
Upstream Interfaces : Po1(Up)
Downstream Interfaces : Gi0/3(Up) Gi0/4(Up)
 
(Up):Interface up (Dwn):Interface Down (Dis):Interface disabled
 

出力フィールドの詳細については、このリリースに対応するコマンド リファレンスを参照してください。