Cisco IE 2000 スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.0(2)EB
SmartPort マクロの設定
SmartPort マクロの設定
発行日;2013/10/29 | 英語版ドキュメント(2013/08/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

SmartPort マクロの設定

機能情報の確認

SmartPort マクロの設定に関する情報

SmartPort マクロの設定方法

SmartPort のデフォルト設定

SmartPort 設定時の注意事項

SmartPort マクロの適用

SmartPort マクロのモニタリングおよびメンテナンス

SmartPort マクロの設定例

SmartPort マクロの適用:例

その他の関連資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

SmartPort マクロの設定

機能情報の確認

ご使用のソフトウェア リリースでは、この章で説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

SmartPort マクロの設定に関する情報

SmartPort マクロは、共通の設定を保存および共有するのに便利です。SmartPort マクロを使用すると、ネットワークでのスイッチの場所に基づいて機能および設定をイネーブルにしたり、ネットワークを通じて大規模な設定を配置したりできます。

各 SmartPort マクロは、定義する一連の CLI コマンドです。SmartPort マクロは、既存の CLI コマンドの集まりであり、新しい CLI コマンドは含まれていません。

SmartPort マクロをインターフェイスに適用すると、マクロ内の CLI コマンドがインターフェイスに設定されます。インターフェイスに SmartPort マクロを適用しても、インターフェイスの既存の設定は失われません。新しいコマンドがインターフェイスに追加され、実行コンフィギュレーション ファイルに保存されます。

SmartPort マクロの設定方法

SmartPort のデフォルト設定

スイッチで SmartPort マクロはイネーブルになっていません。

 

表 16-1 デフォルト SmartPort マクロ

マクロ名1
説明

cisco-ie-global

このグローバル コンフィギュレーション マクロを使用して、スイッチの設定を工業用イーサネットの環境に合わせてスイッチの設定を行います。このマクロは、Express Setup を使用してスイッチを初期設定するときに自動的に適用されます。

マクロを適用する必要があります。

cisco-desktop

PC のようなデスクトップ デバイスをスイッチ ポートに接続する場合、ネットワーク セキュリティと信頼性を高めるために、このインターフェイス コンフィギュレーション マクロを使用します。このマクロは、工業オートメーション トラフィック用に最適化されています。

cisco-phone

Cisco IP Phone を搭載した PC などのデスクトップ デバイスをスイッチ ポートに接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。このマクロは、 cisco-ie-desktop マクロの拡張で、同じセキュリティと復元力機能を備えていますが、遅延に影響されやすい音声トラフィックを正しく処理できるように専用の音声 VLAN が追加されています。このマクロは、工業オートメーション トラフィック用に最適化されています。

cisco-ie-switch

このインターフェイス コンフィギュレーション マクロは、アクセス スイッチとディストリビューション スイッチを接続している場合や、Small Form-Factor Pluggable(SFP)モジュールを使用して接続されているアクセス スイッチ間で接続している場合に使用します。このマクロは、工業オートメーション トラフィック用に最適化されています。

cisco-router

スイッチと WAN ルータを接続する場合、このインターフェイス コンフィギュレーション マクロを使用します。このマクロは、工業オートメーション トラフィック用に最適化されています。

cisco-ethernetip

このインターフェイス コンフィギュレーション マクロは、スイッチを EtherNet IP 装置に接続しているときに使用します。

マクロを適用する必要があります。

cisco-ie-qos-map-setup

このグローバル コンフィギュレーション マクロを使用して、QoS ポリシー マップを産業用イーサネットの環境に合わせてスイッチの設定を行います。

cisco-ie-qos-queue-setup

このグローバル コンフィギュレーション マクロを使用して、QoS ポリシー マップを産業用イーサネットの環境に合わせてスイッチの設定を行います。

1.シスコ デフォルト SmartPort マクロは、スイッチで実行されているソフトウェア バージョンによって異なります。

SmartPort 設定時の注意事項

マクロがスイッチまたはスイッチ インターフェイスにグローバルに適用されている場合、インターフェイス上の既存のすべての設定が保持されます。これは、差分設定に適用する場合に役立ちます。

構文エラーまたは設定エラーのためにコマンドが失敗した場合、マクロは引き続き残りのコマンドを適用します。マクロを適用およびデバッグして、構文エラーまたは設定エラーを検出するには、 macro global trace macro-name グローバル コンフィギュレーション コマンド、または macro trace macro-name インターフェイス コンフィギュレーション コマンドを使用できます。

特定のインターフェイス タイプ固有の CLI コマンドもあります。設定を受け入れないインターフェイスにマクロを適用すると、マクロが構文または設定のチェックに失敗し、スイッチはエラー メッセージを返します。

インターフェイス範囲へのマクロの適用は、単一インターフェイスへのマクロの適用と同じです。インターフェイスの範囲を使用する場合、マクロはその範囲内の各インターフェイスに順番に適用されます。1 つのインターフェイスでマクロ コマンドの実行に失敗しても、マクロは残りのインターフェイス上に適用されます。

スイッチまたはスイッチ インターフェイスにマクロを適用すると、マクロ名が自動的にスイッチまたはインターフェイスに追加されます。 show running-config ユーザ EXEC コマンドを使用して、適用されたコマンドおよびマクロ名を表示できます。

SmartPort マクロの適用

 

コマンド
目的

ステップ 1

show parser macro

スイッチ ソフトウェアに埋め込まれているシスコ デフォルト SmartPort マクロを表示します。

ステップ 2

show parser macro name macro-name

適用する特定のマクロを表示します。

ステップ 3

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

macro global { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

マクロで定義された各コマンドをスイッチに適用するには、 macro global apply macro-name を入力します。 macro global trace macro-name を指定して、構文または設定エラーを判別するためにマクロを適用およびデバッグします。

parameter value キーワードを使用して、必要な値をマクロに追加します。 $ で始まるキーワードには、一意のパラメータ値が必要です。

macro global apply macro-name ? コマンドを使用すると、マクロに必要な値を一覧表示できます。キーワード値を入力せずにマクロを適用した場合、コマンドは無効となり、マクロは適用されません。

(任意)そのスイッチに限定された一意のパラメータ値を指定します。最高 3 つのキーワードと値の組み合わせを入力できます。パラメータ キーワードの照合では、大文字と小文字が区別されます。キーワードで一致が見られると、すべて対応する値に置き換えられます。

ステップ 5

interface interface-id

(任意)インターフェイス コンフィギュレーション モードを開始して、マクロを適用するインターフェイスを指定します。

ステップ 6

default interface interface-id

(任意)指定したインターフェイスからすべての設定を消去します。

ステップ 7

macro { apply | trace } macro-name [ parameter { value }] [ parameter { value }] [ parameter { value }]

マクロで定義された各コマンドをポートに適用するには、 macro global apply macro-name を入力します。 macro global trace macro-name を指定して、構文または設定エラーを判別するためにマクロを適用およびデバッグします。

parameter value キーワードを使用して、必要な値をマクロに追加します。 $ で始まるキーワードには、一意のパラメータ値が必要です。

macro global apply macro-name ? コマンドを使用すると、マクロに必要な値を一覧表示できます。キーワード値を入力せずにマクロを適用した場合、コマンドは無効となり、マクロは適用されません。

(任意)そのスイッチに限定された一意のパラメータ値を指定します。最高 3 つのキーワードと値の組み合わせを入力できます。パラメータ キーワードの照合では、大文字と小文字が区別されます。キーワードで一致が見られると、すべて対応する値に置き換えられます。

ステップ 8

end

特権 EXEC モードに戻ります。

ステップ 9

show running-config interface interface-id

マクロがインターフェイスに適用されたことを確認します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

SmartPort マクロのモニタリングおよびメンテナンス

 

表 16-2 SmartPort マクロを表示するコマンド

コマンド
目的

show parser macro

すべての SmartPort マクロを表示します。

show parser macro name macro-name

特定の SmartPort マクロを表示します。

show parser macro brief

SmartPort マクロの名前を表示します。

show parser macro description [ interface interface-id ]

すべてのインターフェイスまたは特定のインターフェイスに関する SmartPort マクロの説明を表示します。

SmartPort マクロの設定例

SmartPort マクロの適用:例

次に、 cisco-ie-desktop マクロを表示する例、およびインターフェイス上でマクロを適用し、アクセス VLAN ID を 25 に設定する例を示します。

Switch# show parser macro name cisco-ie-desktop
--------------------------------------------------------------
Macro name : cisco-ie-desktop
Macro type : default interface
# macro keywords ACCESS_VLAN
#macro name cisco-ie-desktop
switchport mode access
switchport access vlan ACCESS_VLAN
switchport port-security
switchport port-security maximum 1
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
spanning-tree portfast
spanning-tree bpduguard enable
no macro description
macro description cisco-ie-desktop
--------------------------------------------------------------
Switch#
Switch# configure terminal
Switch(config)# interface gigabitethernet1/4
Switch(config-if)# macro apply cisco-ie-desktop $AVID 25
 

次に、cisco-ethernetip マクロを表示する例と、このマクロをインターフェイスに適用する例を示します。

Switch# show parser macro name cisco-ethernetip
Macro name : cisco-ie-global
Macro type : default interface
#macro name cisco-ethernetip
#macro keywords ACCESS_VLAN
#macro description cisco-ethernetip
switchport host
switchport access vlan ACCESS-VLAN
storm-control broadcast level 3.00 1.00
service-policy input CIP-Traffic
#service-policy input 1588
 
Switch# configure terminal
Switch(config)# interface fastethernet 1/1
Switch(config-if)# macro apply cisco-ethernetip ACCESS_VLAN 1
switchport mode will be set to access
spanning-tree portfast will be enabled
channel group will be disabled

その他の関連資料

ここでは、スイッチ管理に関する参考資料について説明します。

関連資料

関連項目
マニュアル タイトル

Cisco IE 2000 コマンド

Cisco IE 2000 Switch Command Reference , Release 15.0(1)EY』

Cisco IOS 基本コマンド

『Cisco IOS Configuration Fundamentals Command Reference』

標準

標準
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--

MIB

MIB
MIB のリンク

--

Cisco IOS XR ソフトウェアを使用して MIB を検索およびダウンロードするには、 http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml にある Cisco MIB Locator を使用し、[Cisco Access Products] メニューからプラットフォームを選択します。

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクなどの、数千ページに及ぶ技術情報が検索可能です。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/en/US/support/index.html