Cisco IE 2000 スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 15.0(2)EB
スイッチ セットアップの設定
スイッチ セットアップの設定
発行日;2013/10/29 | 英語版ドキュメント(2013/08/22 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

スイッチ セットアップの設定

スイッチ セットアップの設定の制約事項

スイッチのセットアップの実行に関する情報

スイッチ ブート プロセス

スイッチのデフォルト ブート設定

スイッチ ブートの最適化

スイッチ情報の割り当て

スイッチのデフォルト設定

DHCP ベースの自動設定の概要

DHCP クライアント要求プロセス

DHCP ベースの自動設定およびイメージ アップデート

DHCP 自動設定

DHCP 自動イメージ アップデート

DHCP サーバ設定時の注意事項

TFTP サーバ

DNS サーバ

リレー デバイス

コンフィギュレーション ファイルの入手方法

環境変数の制御方法

代表的な環境変数

ソフトウェア イメージのリロードのスケジューリング

スイッチのセットアップの設定方法

DHCP 自動設定(コンフィギュレーション ファイルだけ)の設定

DHCP 自動イメージ アップデート(コンフィギュレーション ファイルおよびイメージ)の設定

クライアントの設定

手動でのルーテッド ポートの IP 情報の割り当て

手動での SVI への IP 情報の割り当て

スタートアップ コンフィギュレーションの変更

システム コンフィギュレーションを読み書きするためのファイル名の指定

手動でのスイッチ起動

特定のソフトウェア イメージを起動する場合

スイッチ セットアップの設定のモニタリング

スイッチ実行コンフィギュレーションの確認

スイッチのセットアップの設定例

DHCP ベースの自動設定を使用して IP 情報を取得:例

ソフトウェア イメージのリロードのスケジューリング:例

DHCP 自動イメージ アップデートの設定:例

DHCP サーバとしてスイッチを設定:例

DHCP サーバからファイルをダウンロードするクライアントの設定

その他の関連資料

関連資料

標準

MIB

RFC

シスコのテクニカル サポート

スイッチ セットアップの設定

スイッチ セットアップの設定の制約事項

ネットワーク内に割り当てられた IP アドレスがなく、1 つ以上のレイヤ 3 インターフェイスが起動してない場合は、設定プロセスが保存された DHCP ベースの自動設定は停止します。

タイムアウトを設定しない限り、設定機能を備えている DHCP ベースの自動設定は IP アドレスのダウンロードを無期限に繰り返します。

コンフィギュレーション ファイルをダウンロードできないか破損している場合は、自動インストールプロセスが停止します。


) TFTP からダウンロードされたコンフィギュレーション ファイルは、実行コンフィギュレーション内の既存コンフィギュレーションとマージされますが、write memory または copy running-configuration startup-configuration 特権 EXEC コマンドを入力しない限り、NVRAM に保存されません。ダウンロードされたコンフィギュレーションがスタートアップ コンフィギュレーションに保存されると、後続のシステムシステム再起動中に、この機能が実行されないことに注意してください。


スイッチのセットアップの実行に関する情報

この章では、IP アドレスの割り当てと DHCP 自動設定を含む、スイッチの初期設定作業の実行方法について説明します。

スイッチ ブート プロセス

スイッチを起動するには、 ハードウェア インストレーション ガイド の手順に従って、スイッチを設置して電源をオンにし、スイッチの初期設定(IP アドレス、サブネット マスク、デフォルト ゲートウェイ、シークレット、Telnet パスワードなど)を行う必要があります。

通常の起動プロセスにはブートローダ ソフトウェアの動作が含まれます。ブートローダは次の処理を実行します。

下位レベルの CPU 初期化を行います。CPU レジスタを初期化することにより、物理メモリがマッピングされる場所、容量、速度などを制御します。

CPU サブシステムの電源投入時自己診断テスト (POST) を実行します。CPU DRAM とフラッシュ ファイル システムを構成するフラッシュ デバイスの部分をテストします。

システム ボードのフラッシュ メモリ カード上のファイル システムを初期化します。

デフォルトの OS(オペレーティング システム)ソフトウェアをメモリにロードし、スイッチを起動します。

ブートローダによってフラッシュ ファイル システムにアクセスしてから、オペレーティング システムをロードします。ブートローダの使用目的は通常、オペレーティング システムのロード、圧縮解除、および起動に限定されます。オペレーティング システムが CPU を制御できるようになると、ブートローダは、次にシステムがリセットされるか電源が投入されるまでは非アクティブになります。

このスイッチは、フラッシュ メモリ カードをサポートしています。フラッシュ メモリ カードを使えば、再設定を行わずに障害が発生したスイッチを新しいスイッチと交換できます。フラッシュ メモリ カードのスロットは、ホット スワップおよび前面アクセスされます。フラッシュ カードはカバーによって保護および保持されます。カバーは非脱落型ネジで蝶番が付けられ、閉じられます。これによってカードが固定され、衝撃および振動から保護されます。

フラッシュ メモリ カード ファイルの設定を表示するには、 show flash 特権 EXEC コマンドを使用します。スイッチのフラッシュ メモリ カードの取り外しまたは交換方法については、 ハードウェア インストレーション ガイド を参照してください。

また、オペレーティング システムが使用不可能になるほどの重大な障害が発生した場合は、ブートローダはシステムにトラップドアからアクセスします。トラップドアからシステムへアクセスして、必要があれば、フラッシュ ファイル システムをフォーマットし、XMODEM プロトコルを使用して OS のソフトウェアイメージを再インストールし、失われたパスワードを回復し、最終的に OS を再起動できます。詳細については、「ソフトウェア障害からの回復」および「パスワードを忘れた場合の回復」を参照してください。


) パスワードの回復をディセーブルにできます。詳細については、「「パスワード回復のディセーブル化」」を参照してください。


スイッチ情報を割り当てるには、PC または端末をコンソール ポートに接続し、PC または端末エミュレーション ソフトウェアのボーレートおよびキャラクタ フォーマットをスイッチのコンソール ポートの設定と一致させておく必要があります。

デフォルトのボーレートは 9600 です。

デフォルトのデータ ビットは 8 です。


) データ ビット オプションを 8 に設定した場合、パリティ オプションは「なし」に設定します。


デフォルトのストップ ビットは 1 です。

デフォルトのパリティ設定は「なし」です。

スイッチのデフォルト ブート設定

 

機能
デフォルト設定

オペレーティング システム ソフトウェア イメージ

スイッチは BOOT 環境変数の情報を使用して、システムを自動的に起動しようとします。この変数が設定されていない場合、スイッチはフラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初に検出した実行可能イメージをロードして実行しようとします。

Cisco IOS イメージは、イメージ ファイルと(.bin 拡張子を除いて)同名のディレクトリに保存されます。

ディレクトリの縦型検索では、検出した各サブディレクトリを完全に検索してから元のディレクトリでの検索を続けます。

コンフィギュレーション ファイル

設定されているスイッチは、システムボードのフラッシュ メモリに保存されている config.text ファイルを使用します。

新しいスイッチの場合、コンフィギュレーション ファイルはありません。

スイッチ ブートの最適化

通常のスイッチのブート プロセスには、メモリ テスト、ファイル システム チェック(FSCK)、および電源投入時自己診断テスト(POST)が含まれます。

グローバル コンフィギュレーション モードの boot fast コマンドはデフォルトでスイッチのブート最適化を可能にし、このためこれらのテストをディセーブルにして起動時間を最小化します。ただし、システム障害の発生後は、この機能は自動的にディセーブルになります。

スイッチが BOOT 環境変数内の情報を使用して、自動的にシステムを起動するように設定している場合、すぐにリロード シーケンスが実行されます。他の方法では、ブートローダ コンフィギュレーション モードで手動で boot コマンドを入力してもリロード シーケンスが実行されます。

初回リロード

スイッチは高速起動機能をディセーブルにし、次の警告メッセージを表示します。

“Reloading with boot fast feature disabled”
 

システム メッセージが表示された後、システムはクラッシュ情報を保存し、自動的に次のリロード サイクルのためにリセットします。

2 回目リロード

ブートローダは通常のフル メモリ テストおよび FSCK のチェックを実施し、LED ステータスは進行状況を表示します。メモリおよび FSCK テストが成功すると、システムは追加 POST テストを実行し、その結果がコンソールに表示されます。

高速起動機能は、システムが正常に起動した後に再びイネーブルになります。

スイッチ情報の割り当て

IP 情報を割り当てるには、スイッチのセットアップ プログラムを使用する方法、Dynamic Host Configuration Protocol(DHCP)サーバを使用する方法、または手動で実行する方法があります。

特定の IP 情報の設定が必要な場合、スイッチのセットアップ プログラムを使用してください。このプログラムを使用すると、ホスト名とイネーブル シークレット パスワードを設定することもできます。また、プログラムでは任意で、Telnet パスワードを割り当てたり(リモート管理中のセキュリティ確保のため)、スイッチをクラスタのコマンドまたはメンバ スイッチとして、あるいはスタンドアロン スイッチとして設定したりできます。セットアップ プログラムの詳細については、 ハードウェア インストレーション ガイド を参照してください。

サーバの設定後は DHCP サーバを使用して、IP 情報の集中管理と自動割り当てを行います。


) DHCP を使用している場合は、スイッチが動的に割り当てられた IP アドレスを受信してコンフィギュレーション ファイルを読み込むまでは、セットアップ プログラムからの質問に応答しないでください。


スイッチの設定手順を熟知している経験豊富なユーザの場合は、スイッチを手動で設定してください。それ以外のユーザは、セットアップ プログラムを使用してください。

スイッチのデフォルト設定

 

表 4-1 スイッチのデフォルト設定

機能
デフォルト設定

IP アドレスおよびサブネット マスク

IP アドレスまたはサブネット マスクは定義されていません。

デフォルト ゲートウェイ

デフォルト ゲートウェイは定義されていません。

イネーブル シークレット パスワード

パスワードは定義されていません。

ホスト名

出荷時に設定されたホスト名は Switch です。

Telnet パスワード

パスワードは定義されていません。

クラスタ コマンド スイッチ機能

ディセーブル

クラスタ名

クラスタ名は定義されません。

手動ブート

なし

ブート最適化

イネーブル

DHCP ベースの自動設定の概要

DHCP は、インターネットホストおよびインターネットワーキング デバイスに設定情報を提供します。このプロトコルには、2 つのコンポーネントがあります。1 つは DHCP サーバからデバイスにコンフィギュレーション パラメータを提供するコンポーネント、もう 1 つはデバイスにネットワーク アドレスを割り当てるコンポーネントです。DHCP はクライアント/サーバ モデルに基づいています。指定された DHCP サーバが、動的に設定されるデバイスに対して、ネットワーク アドレスを割り当て、コンフィギュレーション パラメータを提供します。スイッチは、DHCP クライアントおよび DHCP サーバとして機能できます。

DHCP ベースの自動設定では、スイッチ(DHCP クライアント)は起動時に、IP アドレス情報およびコンフィギュレーション ファイルを使用して自動的に設定されます。

DHCP ベースの自動設定を使用すると、スイッチ上で DHCP クライアント側の設定を行う必要はありません。ただし、DHCP サーバで、IP アドレスに関連した各種リース オプションを設定する必要があります。DHCP を使用してネットワーク上でコンフィギュレーション ファイルをリレーする場合は、TFTP サーバおよびドメイン ネーム システム(DNS)サーバの設定が必要なこともあります。

スイッチの DHCP サーバは、スイッチと同じ LAN 上に配置することも、そのスイッチとは別の LAN 上に配置することもできます。DHCP サーバが異なる LAN 上で動作している場合、スイッチと DHCP サーバ間に、DHCP のリレー デバイスを設定する必要があります。リレー デバイスは、直接接続されている 2 つの LAN 間でブロードキャスト トラフィックを転送します。ルータはブロードキャスト パケットを転送しませんが、受信したパケットの宛先 IP アドレスに基づいてパケットを転送します。

DHCP ベースの自動設定は、スイッチの BOOTP クライアント機能に代わるものです。

DHCP クライアント要求プロセス

スイッチを起動したときに、スイッチにコンフィギュレーション ファイルがない場合、DHCP クライアントが呼び出され、DHCP クライアントが DHCP サーバに設定情報を要求します。コンフィギュレーション ファイルが存在し、その設定に特定のルーテッド インターフェイスの ip address dhcp インターフェイス コンフィギュレーション コマンドが含まれる場合、DHCP クライアントが呼び出され、DHCP クライアントがインターフェイスに IP アドレス情報を要求します。

図 4-1 に、DHCP クライアントと DHCP サーバ間で交換される一連のメッセージを示します。

図 4-1 DHCP クライアント/サーバ間のメッセージ交換

 

クライアントであるスイッチ A は、DHCP サーバの場所を特定するために、DHCPDISCOVER メッセージをブロードキャストします。DHCP サーバは、DHCPOFFER ユニキャスト メッセージによって、使用可能なコンフィギュレーション パラメータ(IP アドレス、サブネット マスク、ゲートウェイ IP アドレス、DNS IP アドレス、IP アドレス用のリースなど)をクライアントに提示します。

DHCPREQUEST ブロードキャスト メッセージでは、クライアントは、提示された設定情報に対して、DHCP サーバに正式な要求を戻します。この正式な要求はブロードキャストされるため、クライアントから DHCPDISCOVER ブロードキャスト メッセージを受信した他のすべての DHCP サーバは、クライアントに提示した IP アドレスを再利用できます。

DHCP サーバは、DHCPACK ユニキャスト メッセージをクライアントに戻すことで、IP アドレスがクライアントに割り当てられたことを確認します。このメッセージによって、クライアントとサーバはバウンドされ、クライアントはサーバから受信した設定情報を使用します。スイッチが受信する情報量は、TFTP サーバと関連して提供される DHCP の設定方法によって異なります。詳細については、「TFTP サーバ」を参照してください。

DHCPOFFER ユニキャスト メッセージによって送信されたコンフィギュレーション パラメータが無効である(コンフィギュレーション エラーがある)場合、クライアントは DHCP サーバに、DHCPDECLINE ブロードキャスト メッセージを戻します。

DHCP サーバはクライアントに、提示されたコンフィギュレーション パラメータが割り当てられていない、パラメータのネゴシエーション中にエラーが発生した、または DHCPOFFER メッセージに対するクライアントの応答が遅れているという意味の DHCPNAK 拒否ブロードキャスト メッセージを送信します (DHCP サーバはパラメータをクライアントに割り当てました)。

DHCP クライアントは、複数の DHCP サーバまたは BOOTP サーバから提示を受け取り、そのうちの任意の 1 つを受け入れることができますが、通常は最初に受け取った提示を受け入れます。DHCP サーバから提示された IP アドレスが必ずしもスイッチに割り当てられるわけではありません。ただし、サーバは通常、クライアントが正式にアドレスを要求するまではアドレスを確保しておきます。スイッチが BOOTP サーバからの応答を受け入れて、自身を設定する場合、スイッチはスイッチ コンフィギュレーション ファイルを入手するために、TFTP 要求をユニキャストするのではなくブロードキャストします。

DHCP ホスト名オプションにより、スイッチのグループはホスト名および標準コンフィギュレーションを集中管理型 DHCP サーバから取得できます。クライアント(スイッチ)は DCHPDISCOVER メッセージ内に、DHCP サーバからのホスト名および他のコンフィギュレーション パラメータの要求に使用される Option 12 フィールドを加えます。すべてのクライアントのコンフィギュレーション ファイルは、DHCP から取得したホスト名を除き、まったく同じです。

クライアントにデフォルトのホスト名がある場合( hostname name グローバル コンフィギュレーション コマンドを設定していないか、 no hostname グローバル コンフィギュレーション コマンドを使用してホスト名を削除していない場合)は、 ip address dhcp インターフェイス コンフィギュレーション コマンドを入力すると、DHCP のホスト名オプションがパケットに含まれません。この場合、インターフェイスの IP アドレスを取得中にクライアントが DHCP との相互作用で DHCP ホスト名オプションを受信した場合、クライアントは DHCP ホスト名オプションを受け入れて、システムに設定済みのホスト名があることを示すフラグが設定されます。

DHCP ベースの自動設定およびイメージ アップデート

DHCP イメージ アップグレード機能を使用すると、ネットワーク内の 1 つ以上のスイッチに新しいイメージ ファイルおよび新しいコンフィギュレーション ファイルをダウンロードするように DHCP サーバを設定できます。これにより、ネットワークに加えられた新しいスイッチが、同じイメージとコンフィギュレーションを確実に受信するようになります。

DHCP イメージ アップグレードには、自動設定およびイメージ アップデートの 2 つのタイプがあります。

DHCP 自動設定

DHCP 自動設定は、コンフィギュレーション ファイルを DHCP サーバからネットワーク内の 1 つ以上のスイッチにダウンロードします。ダウンロードされたコンフィギュレーション ファイルは、スイッチの実行コンフィギュレーション ファイルになります。このファイルは、スイッチがリロードされるまで、フラッシュ メモリに保存された起動コンフィギュレーションを上書きしません。

DHCP 自動イメージ アップデート

DHCP 自動設定とともに DHCP 自動イメージ アップグレードを使用すると、コンフィギュレーションおよび新しいイメージをネットワーク内の 1 つ以上のスイッチにダウンロードできます。新しいコンフィギュレーションおよび新しいイメージをダウンロードしている 1 つ以上のスイッチは、ブランク(つまり、出荷時のデフォルト設定がロードされている状態)にできます。

コンフィギュレーションをすでに持っているスイッチに新しいコンフィギュレーションをダウンロードすると、ダウンロードされたコンフィギュレーションは、スイッチに保存されているコンフィギュレーション ファイルに追加されます (どの既存のコンフィギュレーション ファイルも、ダウンロードされたファイルに上書きされません)。


) スイッチの DHCP 自動イメージ アップデートをイネーブルにするには、イメージ ファイルおよびコンフィギュレーション ファイルがある TFTP サーバを、正しいオプション 67(コンフィギュレーション ファイル名)、オプション 66(DHCP サーバ ホスト名)、オプション 150(TFTP サーバ アドレス)、およびオプション 125(ファイルの説明)の設定で設定する必要があります。

スイッチを DHCP サーバとして設定する場合の手順については、「DHCP サーバ設定時の注意事項」および『Cisco IOS IP DHCP Configuration Guide, Release 15.0』の「IP Addressing and Services」の章にある「Configuring DHCP」を参照してください。


スイッチをネットワークに設置すると、自動イメージ アップデート機能が開始します。ダウンロードされたコンフィギュレーション ファイルはスイッチの実行コンフィギュレーションに保存され、新しいイメージがダウンロードされてスイッチにインストールされます。スイッチを再起動すると、このコンフィギュレーションがスイッチのコンフィギュレーションに保存されます。

DHCP サーバ設定時の注意事項

デバイスを DHCP サーバとして設定する場合、次の注意事項に従ってください。

DHCP サーバには、スイッチのハードウェア アドレスによって各スイッチと結び付けられている予約済みのリースを設定します。

スイッチに IP アドレス情報を受信させるには、DHCP サーバに次のリース オプションを設定する必要があります

クライアントの IP アドレス(必須)

クライアントのサブネット マスク(必須)

ルータの IP アドレス(スイッチで使用するデフォルト ゲートウェイ アドレス)(必須)

DNS サーバの IP アドレス(任意)

スイッチに TFTP サーバからコンフィギュレーション ファイルを受信させる場合は、DHCP サーバに次のリース オプションを設定する必要があります。

TFTP サーバ名(必須)

ブート ファイル名(クライアントが必要とするコンフィギュレーション ファイル名)(推奨)

ホスト名(任意)

DHCP サーバの設定によっては、スイッチは IP アドレス情報またはコンフィギュレーション ファイル、あるいはその両方を受信できます。

前述のリース オプションを設定しなかった場合、DHCP サーバは、設定されたパラメータのみを使用してクライアントの要求に応答します。

IP アドレスおよびサブネット マスクが応答に含まれていないと、スイッチは設定されません。ルータの IP アドレスまたは TFTP サーバ名が見つからなかった場合、スイッチは TFTP 要求をユニキャストしないでブロードキャストする場合があります。その他のリース オプションは、使用できなくても自動設定には影響しません。

スイッチは、DHCP サーバとして機能できます。デフォルトでは、Cisco IOS DHCP サーバおよび DHCP リレー エージェント機能はスイッチ上でイネーブルにされていますが、設定されていません。これらの機能は動作しません。DHCP サーバがシスコ デバイスの場合、DHCP 設定に関する詳細については、Cisco.com で『 Cisco IOS IP Configuration Guide 』の「IP Addressing and Services」の章にある「Configuring DHCP」の部分を参照してください。

TFTP サーバ

DHCP サーバの設定に基づいて、スイッチは TFTP サーバから 1 つまたは複数のコンフィギュレーション ファイルをダウンロードしようとします。TFTP サーバへの IP 接続に必要なすべてのオプションについてスイッチに応答するよう DHCP を設定している場合で、なおかつ、TFTP サーバ名、アドレス、およびコンフィギュレーション ファイル名を指定して DHCP サーバを設定している場合、スイッチは指定された TFTP サーバから指定されたコンフィギュレーション ファイルをダウンロードしようとします。

コンフィギュレーション ファイル名、および TFTP サーバを指定しなかった場合、またはコンフィギュレーション ファイルをダウンロードできなかった場合は、スイッチはファイル名と TFTP サーバアドレスをさまざまに組み合わせてコンフィギュレーション ファイルをダウンロードしようとします。ファイルには、(存在する場合)特定のコンフィギュレーション ファイル名と次のファイルが指定されています。network-config、cisconet.cfg、 hostname.config 、または hostname.cfg です。この場合、 hostname はスイッチの現在のホスト名です。使用される TFTP サーバアドレスには、(存在する場合)指定された TFTP サーバのアドレス、およびブロードキャスト アドレス(255.255.255.255)が含まれています。

スイッチが正常にコンフィギュレーション ファイルをダウンロードするには、TFTP サーバのベース ディレクトリに 1 つまたは複数のコンフィギュレーション ファイルが含まれていなければなりません。含めることのできるファイルは、次のとおりです。

DHCP 応答で指定されているコンフィギュレーション ファイル(実際のスイッチ コンフィギュレーション ファイル)

network-confg または cisconet.cfg ファイル(デフォルトのコンフィギュレーション ファイル)

router-confg または ciscortr.cfg ファイル(これらのファイルには、すべてのスイッチに共通のコマンドが含まれています。通常、DHCP および TFTP サーバが適切に設定されていれば、これらのファイルはアクセスされません)

DHCP サーバ リース データベースに TFTP サーバ名を指定する場合は、DNS サーバのデータベースに TFTP サーバ名と IP アドレスのマッピングを設定することも必要です。

使用する TFTP サーバが、スイッチとは異なる LAN 上にある場合、またはスイッチがブロードキャスト アドレスを使用してアクセスした場合(前述のすべての必須情報が DHCP サーバの応答に含まれていない場合に発生)は、リレーを設定して TFTP サーバに TFTP パケットを転送する必要があります。詳細については、「リレー デバイス」を参照してください。適切な解決方法は、必要なすべての情報を使用して DHCP サーバを設定することです。

DNS サーバ

DHCP サーバは、DNS サーバを使用して TFTP サーバ名を IP アドレスに変換します。DNS サーバ上で、TFTP サーバ名から IP アドレスへのマッピングを設定する必要があります。TFTP サーバには、スイッチのコンフィギュレーション ファイルが存在します。

DHCP の応答時に IP アドレスを取得する DHCP サーバのリース データベースに、DNS サーバの IP アドレスを設定できます。リース データベースには、DNS サーバの IP アドレスを 2 つまで入力できます。

DNS サーバは、スイッチと同じ LAN 上に配置することも、そのスイッチとは別の LAN 上に配置することもできます。DHCP サーバが別の LAN 上に存在する場合、スイッチはルータを介して DHCP サーバにアクセスできなければなりません。

リレー デバイス

異なる LAN 上にあるホストからの応答が必要なブロードキャスト パケットをスイッチが送信する場合は、リレー デバイス( リレー エージェント )を設定する必要があります。スイッチが送信する可能性のあるブロードキャスト パケットの例として DHCP パケット、DNS パケット、場合によっては TFTP パケットが挙げられます。リレー デバイスは、インターフェイス上の受信ブロードキャスト パケットを宛先ホストに転送するように設定する必要があります。

リレー デバイスが Cisco ルータである場合、IP ルーティングをイネーブルにし( ip routing グローバル コンフィギュレーション コマンド)、 ip helper-address インターフェイス コンフィギュレーション コマンドを使用して、ヘルパー アドレスを設定します。

図 4-2 では、ルータ インターフェイスを次のように設定しています。

インターフェイス 10.0.0.2 の場合:

router(config-if)# ip helper-address 20.0.0.2
router(config-if)# ip helper-address 20.0.0.3
router(config-if)# ip helper-address 20.0.0.4
 

インターフェイス 20.0.0.1 の場合:

router(config-if)# ip helper-address 10.0.0.1

図 4-2 自動設定でのリレー デバイスの使用

 

コンフィギュレーション ファイルの入手方法

IP アドレスおよびコンフィギュレーション ファイル名が DHCP で専用のリースとして取得できるかどうかに応じて、スイッチは次の方法で設定情報を入手します。

IP アドレスおよびコンフィギュレーション ファイル名が、スイッチ用に予約され、DHCP 応答(1 ファイル読み込み方式)で提供されている場合

スイッチは DHCP サーバから、IP アドレス、サブネット マスク、TFTP サーバ アドレス、およびコンフィギュレーション ファイル名を受信します。スイッチは、TFTP サーバにユニキャスト メッセージを送信し、指定されたコンフィギュレーション ファイルをサーバのベース ディレクトリから取得して、ブートアップ プロセスを完了します。

スイッチの IP アドレスおよびコンフィギュレーション ファイル名が予約されているが、DHCP 応答に TFTP サーバ アドレスが含まれていない場合(1 ファイル読み込み方式)

スイッチは DHCP サーバから、IP アドレス、サブネット マスク、およびコンフィギュレーション ファイル名を受信します。スイッチは、TFTP サーバにブロードキャスト メッセージを送信し、指定されたコンフィギュレーション ファイルをサーバのベース ディレクトリから取得して、ブートアップ プロセスを完了します。

IP アドレスだけがスイッチ用に予約され、DHCP 応答で提供されており、 コンフィギュレーション ファイル名は提供されない場合(2 ファイル読み込み方式)

スイッチは DHCP サーバから、IP アドレス、サブネット マスク、および TFTP サーバ アドレスを受信します。スイッチは、TFTP サーバにユニキャストメッセージを送信し、network-confg または cisconet.cfg のデフォルト コンフィギュレーション ファイルを取得します (network-confg ファイルが読み込めない場合、スイッチは cisconet.cfg ファイルを読み込みます)。

デフォルト コンフィギュレーション ファイルには、スイッチのホスト名から IP アドレスへのマッピングが含まれています。スイッチは、ファイルの情報をホスト テーブルに書き込み、ホスト名を入手します。ファイルにホスト名がない場合、スイッチは DHCP 応答で指定されたホスト名を使用します。DHCP 応答でホスト名が指定されていない場合、スイッチはデフォルトの Switch をホスト名として使用します。

デフォルトのコンフィギュレーション ファイルまたは DHCP 応答からホスト名を入手した後、スイッチはホスト名と同じ名前のコンフィギュレーション ファイル(network-confg または cisconet.cfg のどちらが先に読み込まれたかに応じて、 hostname -confg または hostname .cfg)を TFTP サーバから読み込みます。cisconet.cfg ファイルが読み込まれている場合は、ホストのファイル名は 8 文字に切り捨てられます。

network-confg、cisconet.cfg、またはホスト名と同じ名前のファイルを読み込むことができない場合、スイッチは router-confg ファイルを読み込みます。router-confg ファイルを読み込むことができない場合、スイッチは ciscortr.cfg ファイルを読み込みます。


) DHCP 応答から TFTP サーバを入手できなかった場合、ユニキャスト伝送によるコンフィギュレーション ファイルの読み込みに失敗した場合、または TFTP サーバ名を IP アドレスに変換できない場合には、スイッチは TFTP サーバ要求をブロードキャストします。


環境変数の制御方法

正常に動作しているスイッチでは、9600 bps 対応に設定されたスイッチ コンソール接続でのみブートローダ モードが開始されます。スイッチの電源コードを取り外し、電源コードの再接続中に Mode ボタンを押します。ポート 1 の上の LED が消灯してから 1 ~ 2 秒後に、Mode ボタンを離します。これにより、ブートローダの switch: プロンプトが表示されます。

スイッチのブートローダ ソフトウェアは不揮発性の環境変数をサポートするので、これらの環境変数を使用して、ブートローダまたはシステムで稼働する他のソフトウェアの動作を制御できます。ブートローダの環境変数は、UNIX または DOS システムで設定できる環境変数と類似しています。

値を持つ環境変数は、フラッシュ ファイル システムの外にあるフラッシュ メモリに保存されます。

ファイルの各行には、環境変数名と等号に続いて、その変数の値が指定されます。このファイルに表示されていない変数には値がありません。表示されていればヌル ストリングであっても値があります。ヌル ストリング(たとえば " ")に設定されている変数は、値が設定された変数です。多くの環境変数は事前に定義されており、デフォルト値が設定されています。

環境変数には 2 種類のデータが保存されます。

Cisco IOS コンフィギュレーション ファイルを読み取らないコードを制御するデータ。たとえば、ブートローダの機能を拡張したり、パッチを適用したりするブートローダ ヘルパー ファイルの名前は、環境変数として保存できます。

Cisco IOS コンフィギュレーション ファイルを読み取るコードを制御するデータ。たとえば、Cisco IOS コンフィギュレーション ファイル名は環境変数として保存できます。

環境変数の設定を変更するには、ブートローダにアクセスするか、Cisco IOS コマンドを使用します。通常の環境では、環境変数の設定を変更する必要はありません。


) ブートローダ コマンドおよび環境変数の構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


代表的な環境変数

表 4-2 で、代表的な環境変数の機能について説明します。

 

表 4-2 環境変数

変数
ブートローダ コマンド
Cisco IOS グローバル コンフィギュレーション コマンド

BOOT

set BOOT filesystem :/ file-url ...

自動起動時にロードして実行を試みる、セミコロンで区切られた実行可能ファイルのリスト。BOOT 環境変数が設定されていない場合、システムは、フラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初に検出された実行可能イメージをロードして実行を試みます。BOOT 変数が設定されていても、指定されたイメージをロードできなかった場合、システムはフラッシュ ファイル システムで最初に検出した起動可能なファイルを起動しようとします。

boot system filesystem:/file-url ...

次回の起動時に読み込む Cisco IOS イメージを指定します。このコマンドは、BOOT 環境変数の設定を変更します。

MANUAL_BOOT

set MANUAL_BOOT yes

スイッチの起動を自動で行うか手動で行うかを決定します。

有効値は 1、yes、0、および no です。no または 0 に設定されている場合、ブートローダはシステムの自動起動を試みます。それ以外の値に設定されている場合は、ブートローダ モードから手動でスイッチを起動する必要があります。

boot manual

次回の起動時にスイッチを手動で起動できるようにします。MANUAL_BOOT 環境変数の設定が変更されます。

次回のシステム再起動時には、スイッチはブートローダ モードになります。システムを起動するには、 boot flash: filesystem :/ file-url ブートローダ コマンドを使用し、起動可能イメージの名前を指定します。

CONFIG_FILE

set CONFIG_FILE flash:/ file-url

Cisco IOS がシステム コンフィギュレーションの不揮発性コピーの読み書きに使用するファイル名を変更します。

boot config-file flash: / file-url

Cisco IOS がシステム設定の不揮発性コピーの読み書きに使用するファイル名を指定します。このコマンドによって、CONFIG_FILE 環境変数が変更されます。

ソフトウェア イメージのリロードのスケジューリング

スイッチ上でソフトウェア イメージのリロードを後で(深夜、週末などスイッチをあまり使用しないときに)行うように、スケジュールを設定できます。または(ネットワーク内のすべてのスイッチでソフトウェアをアップグレードする場合など)ネットワーク全体でリロードを同時に行うことができます。


) リロードのスケジュールは、約 24 日以内に設定する必要があります。


次のリロード オプションがあります。

指定した分数、または時間および分数が経過したときに実施するソフトウェアがリロード。リロードは、約 24 日以内に実行する必要があります。最大 255 文字で、リロードの理由を指定できます。

(24 時間制で)指定された時刻に実施するソフトウェアのリロード。月日を指定すると、指定された日時にリロードが行われるようにスケジュールが設定されます。月日を指定しなかった場合、リロードは当日の指定時刻に行われます(指定時刻が現時刻より後の場合)。または翌日の指定時刻に行われます(指定時刻が現在時刻よりも前の場合)。00:00 を指定すると、深夜 0 時のリロードが設定されます。

reload コマンドはシステムを停止させます。手動で起動することが設定されていない限り、システムは自動的に再起動します。

手動で起動するようにスイッチが設定されている場合、仮想端末からリロードを実行しないでください。これは、スイッチがブートローダ モードになり、その結果、リモート ユーザが制御を失うことを防止するためです。

コンフィギュレーション ファイルを変更すると、リロードの前にコンフィギュレーションを保存するように指示するプロンプトが表示されます。保存操作時に、CONFIG_FILE 環境変数がすでに存在しないスタートアップ コンフィギュレーション ファイルを示していた場合、保存を続行するかどうかという問い合わせがシステムから出されます。その状況のまま続けると、リロード時にセットアップ モードが開始されます。

スケジュールがすでに設定されたリロードを取り消すには、 reload cancel 特権 EXEC コマンドを使用します。

スイッチのセットアップの設定方法

DHCP を使用して新しいイメージおよび新しいコンフィギュレーションをスイッチにダウンロードするには、少なくとも 2 つのスイッチを設定する必要があります。1 つのスイッチは DHCP および TFTP サーバとして動作します。もう 1 台のスイッチ(クライアント)は新しいコンフィギュレーション ファイル、または新しいコンフィギュレーション ファイルおよび新しいイメージ ファイルをダウンロードするように設定されます。

DHCP 自動設定(コンフィギュレーション ファイルだけ)の設定

この作業では、新しいスイッチに TFTP および DHCP 設定の DHCP 自動設定を設定して新しいコンフィギュレーション ファイルをダウンロードする方法について説明します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip dhcp pool name

DHCP サーバ アドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 3

bootfile filename

ブート イメージとして使用されるコンフィギュレーション ファイルの名前を指定します。

ステップ 4

network network-number mask prefix-length

DHCP アドレス プールのサブネット ネットワーク番号およびマスクを指定します。

(注) プレフィックス長は、アドレス プレフィックスを構成するビット数を指定します。プレフィックスは、クライアントのネットワーク マスクを指定する二者択一の方法です。プレフィックス長は、スラッシュ(/)で開始する必要があります。

ステップ 5

default-router address

DHCP クライアントのデフォルト ルータの IP アドレスを指定します。

ステップ 6

option 150 address

TFTP サーバの IP アドレスを指定します。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

tftp-server flash :filename.text

TFTP サーバ上のコンフィギュレーション ファイルを指定します。

ステップ 9

interface interface-id

コンフィギュレーション ファイルを受信するクライアントのアドレスを指定します。

ステップ 10

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 11

ip address address mask

インターフェイスの IP アドレスおよびマスクを指定します。

ステップ 12

end

特権 EXEC モードに戻ります。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

DHCP 自動イメージ アップデート(コンフィギュレーション ファイルおよびイメージ)の設定

この作業では、DHCP 自動設定の設定により新しいスイッチに TFTP および DHCP を設定して、新しいイメージおよび新しいコンフィギュレーション ファイルをダウンロードする方法について説明します。

はじめる前に

スイッチにアップロードされるテキスト ファイル(たとえば、autoinstall_dhcp)を作成する必要があります。このテキスト ファイル内に、ダウンロードするイメージの名前を含めます。このイメージは、bin ファイルでなく、tar ファイルである必要があります。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip dhcp poo l name

DHCP サーバ アドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 3

bootfile filename

ブート イメージとして使用されるファイルの名前を指定します。

ステップ 4

network network-number mask prefix-length

DHCP アドレス プールのサブネット ネットワーク番号およびマスクを指定します。

(注) プレフィックス長は、アドレス プレフィックスを構成するビット数を指定します。プレフィックスは、クライアントのネットワーク マスクを指定する二者択一の方法です。プレフィックス長は、スラッシュ(/)で開始する必要があります。

ステップ 5

default-router address

DHCP クライアントのデフォルト ルータの IP アドレスを指定します。

ステップ 6

option 150 address

TFTP サーバの IP アドレスを指定します。

ステップ 7

option 125 hex

イメージ ファイルへのパスを記述するテキスト ファイルへのパスを指定します。

ステップ 8

copy tftp flash filename.txt

テキスト ファイルをスイッチにアップロードします。

ステップ 9

copy tftp flash imagename.tar

新しいイメージの tar ファイルをスイッチにアップロードします。

ステップ 10

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

tftp-server flash:config.text

TFTP サーバの Cisco IOS コンフィギュレーション ファイルを指定します。

ステップ 12

tftp-server flash:imagename.tar

TFTP サーバ上のイメージ名を指定します。

ステップ 13

tftp-server flash:filename.txt

ダウンロードするイメージ ファイルの名前を含んでいるテキスト ファイルを指定します。

ステップ 14

interface interface-id

コンフィギュレーション ファイルを受信するクライアントのアドレスを指定します。

ステップ 15

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 16

ip address address mask

インターフェイスの IP アドレスおよびマスクを指定します。

ステップ 17

end

特権 EXEC モードに戻ります。

ステップ 18

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

クライアントの設定

レイヤ 3 インターフェイスだけを設定してイネーブルにする必要があります。保存されているコンフィギュレーションの DHCP ベースの自動設定に IP アドレスを割り当てないでください。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot host dhcp

保存されているコンフィギュレーションで自動設定をイネーブルにします。

ステップ 3

boot host retry timeout timeout-value

(任意)システムがコンフィギュレーション ファイルをダウンロードしようとする時間を設定します。

(注) タイムアウトを設定しないと、システムは無期限に DHCP サーバから IP アドレスを取得しようとします。

ステップ 4

banner config-save ^C warning-message ^C

(任意)コンフィギュレーション ファイルを NVRAM に保存しようとするときに表示される警告メッセージを作成します。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show boot

設定を確認します。

手動でのルーテッド ポートの IP 情報の割り当て

この作業は、手動でレイヤ 3 ルーテッド ポートに IP 情報を割り当てる方法について説明します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface type id

インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

no switchport

インターフェイスをレイヤ 3 モード に設定します。

ステップ 4

ip address address mask

インターフェイスの IP アドレスおよびマスクを指定します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

ip default-gateway ip-address

スイッチに直接接続しているネクスト ホップのルータ インターフェイスの IP アドレスを入力します。このスイッチにはデフォルト ゲートウェイが設定されています。デフォルト ゲートウェイは、スイッチから宛先 IP アドレスを取得していない IP パケットを受信します。

デフォルト ゲートウェイが設定されると、スイッチは、ホストが接続する必要のあるリモート ネットワークに接続できます。

(注) IP でルーティングするようにスイッチを設定した場合、デフォルト ゲートウェイの設定は不要です。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show ip redirects

設定されたデフォルト ゲートウェイを確認します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

手動での SVI への IP 情報の割り当て

この作業は、手動で複数のスイッチ仮想インタフェース(SVI)に IP 情報を割り当てる方法について説明します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vlan-id

インターフェイス コンフィギュレーション モードを開始して、IP 情報が割り当てられている VLAN を指定します。指定できる VLAN 範囲は 1 ~ 4096 です。

ステップ 3

ip address ip-address subnet-mask

IP アドレスとサブネット マスクを入力します。

ステップ 4

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 5

ip default-gateway ip-address

スイッチに直接接続しているネクスト ホップのルータ インターフェイスの IP アドレスを入力します。このスイッチにはデフォルト ゲートウェイが設定されています。デフォルト ゲートウェイは、スイッチから宛先 IP アドレスを取得していない IP パケットを受信します。

デフォルト ゲートウェイが設定されると、スイッチは、ホストが接続する必要のあるリモート ネットワークに接続できます。

(注) IP でルーティングするようにスイッチを設定した場合、デフォルト ゲートウェイの設定は不要です。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show interfaces vlan vlan-id

設定された IP アドレスを確認します。

ステップ 8

show ip redirects

設定されたデフォルト ゲートウェイを確認します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スタートアップ コンフィギュレーションの変更

システム コンフィギュレーションを読み書きするためのファイル名の指定

Cisco IOS ソフトウェアは、デフォルトで config.text ファイルを使用して、システム コンフィギュレーションの不揮発性コピーを読み書きします。別のファイル名を指定することもできます。次回の起動時には、その名前のファイルが読み込まれます。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot config-file flash:/ file-url

次回の起動時に読み込むコンフィギュレーション ファイルを指定します。

file-url に、パス(ディレクトリ)およびコンフィギュレーション ファイル名を指定します。

ファイル名およびディレクトリ名は、大文字と小文字を区別します。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

入力を確認します。

boot config-file グローバル コンフィギュレーション コマンドによって、CONFIG_FILE 環境変数の設定が変更されます。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

手動でのスイッチ起動

スイッチはデフォルトで自動的に起動しますが、手動で起動するように設定することもできます。

はじめる前に

この作業では、スタンドアロン スイッチを使用します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot manual

次回の起動時に、スイッチを手動で起動できるようにします。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

入力を確認します。

boot manual グローバル コンフィギュレーション コマンドによって、MANUAL_BOOT 環境変数の設定が変更されます。

次回、システムを再起動したときには、スイッチはブートローダ モードになり、ブートローダ モードであることが switch: プロンプトによって示されます。システムを起動するには、 boot filesystem :/ file-url ブートローダ コマンドを使用します。

filesystem : には、システム ボードのフラッシュ デバイスを指定する場合は flash: を使用します。

file-url には、パス(ディレクトリ)および起動可能なイメージの名前を指定します。

ファイル名およびディレクトリ名は、大文字と小文字を区別します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

特定のソフトウェア イメージを起動する場合

スイッチはデフォルトで、BOOT 環境変数の情報を使用して、システムを自動的に起動しようとします。この変数が設定されていない場合、スイッチは、フラッシュ ファイル システム全体に再帰的に縦型検索し、最初の実行可能イメージをロードして実行しようとします。ディレクトリの縦型検索では、検出した各サブディレクトリを完全に検索してから元のディレクトリでの検索を続けます。起動する具体的なイメージを指定することもできます。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot system filesystem :/ file-url

次回の起動時に、フラッシュ メモリ内の特定のイメージを起動するようにスイッチを設定します。

filesystem : には、システム ボードのフラッシュ デバイスを指定する場合は flash: を使用します。

file-url には、パス(ディレクトリ)および起動可能なイメージの名前を指定します。

ファイル名およびディレクトリ名は、大文字と小文字を区別します。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

入力を確認します。

boot system グローバル コンフィギュレーション コマンドによって、BOOT 環境変数の設定が変更されます。

次回の起動時に、スイッチは BOOT 環境変数の情報を使用して、システムを自動的に起動しようとします。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチ セットアップの設定のモニタリング

スイッチ実行コンフィギュレーションの確認

次の特権 EXEC コマンドを使用すると、入力した設定や変更を確認できます。

Switch# show running-config
Building configuration...
 
Current configuration: 1363 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch A
!
enable secret 5 $1$ej9.$DMUvAUnZOAmvmgqBEzIxE0
!
.
<output truncated>
.
interface gigabitethernet1/1
no switchport
ip address 172.20.137.50 255.255.255.0
!
interface gigabitethernet1/2
mvr type source
 
<output truncated>
 
...!
interface VLAN1
ip address 172.20.137.50 255.255.255.0
no ip directed-broadcast
!
ip default-gateway 172.20.137.1 !
!
snmp-server community private RW
snmp-server community public RO
snmp-server community private@es0 RW
snmp-server community public@es0 RO
snmp-server chassis-id 0x12
!
end
 

スタートアップ コンフィギュレーションに対して行った設定や変更をフラッシュ メモリに保存するには、次の特権 EXEC コマンドを使用します。

Switch# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
 

このコマンドにより、入力した設定値が保存されます。保存できなかった場合、設定は次のシステム リロード時に失われます。フラッシュ メモリの NVRAM(不揮発性 RAM)セクションに保存されている情報を表示するには、 show startup-config または more startup-config 特権 EXEC コマンドを使用します。

コンフィギュレーション ファイルの他のコピー元については、 付録 A「Cisco IOS ファイル システム、コンフィギュレーション ファイル、およびソフトウェア イメージの操作」 を参照してください。

スイッチのセットアップの設定例

DHCP ベースの自動設定を使用して IP 情報を取得:例

スイッチ A はコンフィギュレーション ファイルを次のようにして読み込みます。

DHCP サーバから IP アドレス 10.0.0.21 を入手します。

DHCP サーバの応答でコンフィギュレーション ファイル名が提供されない場合、スイッチ A は TFTP サーバのベース ディレクトリから network-confg ファイルを読み込みます。

ホスト テーブルに network-confg ファイルの内容を追加します。

IP アドレス 10.0.0.21 をもとにホスト テーブルを検索し、ホスト名(switcha)を取得します。

ホスト名に対応するコンフィギュレーション ファイルを読み込みます。たとえば、TFTP サーバから switch1-confg を読み込みます。

スイッチ B ~ D も、同様にコンフィギュレーション ファイルおよび IP アドレスを取得します。

図 4-3 に、DHCP ベースの自動設定を使用して IP 情報を検索するネットワークの構成例を示します。

図 4-3 DHCP ベースの自動設定を使用するネットワークの構成例

 

表 4-3 は、DHCP サーバ上の予約リースの設定例です。

 

表 4-3 DHCP サーバ コンフィギュレーション

スイッチ A
スイッチ B
スイッチ C
スイッチ D

バインディング キー(ハードウェア アドレス)

00e0.9f1e.2001

00e0.9f1e.2002

00e0.9f1e.2003

00e0.9f1e.2004

IP アドレス

10.0.0.21

10.0.0.22

10.0.0.23

10.0.0.24

サブネット マスク

255.255.255.0

255.255.255.0

255.255.255.0

255.255.255.0

ルータ アドレス

10.0.0.10

10.0.0.10

10.0.0.10

10.0.0.10

DNS サーバ アドレス

10.0.0.2

10.0.0.2

10.0.0.2

10.0.0.2

TFTP サーバ名

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

ブート ファイル名(コンフィギュレーション ファイル)(任意)

switcha-confg

switchb-confg

switchc-confg

switchd-confg

ホスト名(任意)

switcha

switchb

switchc

switchd

DNS サーバの設定

DNS サーバは、TFTP サーバ名 tftpserver を IP アドレス 10.0.0.3 にマッピングします。

TFTP サーバ コンフィギュレーション(UNIX)

TFTP サーバのベース ディレクトリは、/tftpserver/work/ に設定されています。このディレクトリには、2 ファイル読み込み方式で使用される network-confg ファイルがあります。このファイルには、IP アドレスに基づいてスイッチに割り当てられるホスト名が含まれています。ベース ディレクトリには、次に示すように、各スイッチのコンフィギュレーション ファイル( switcha-confg switchb-confg など)も含まれています。

prompt> cd /tftpserver/work/
prompt> ls
network-confg
switcha-confg
switchb-confg
switchc-confg
switchd-confg
prompt> cat network-confg
ip host switcha 10.0.0.21
ip host switchb 10.0.0.22
ip host switchc 10.0.0.23
ip host switchd 10.0.0.24
 

DHCP クライアント コンフィギュレーション

スイッチ A ~ D には、コンフィギュレーション ファイルは存在しません。

ソフトウェア イメージのリロードのスケジューリング:例

次に、当日の午後 7 時 30 分にソフトウェアをスイッチにリロードする例を示します。

Switch# reload at 19:30
Reload scheduled for 19:30:00 UTC Wed Jun 5 1996 (in 2 hours and 25 minutes)
Proceed with reload? [confirm]
 

次に、先の日時を指定して、ソフトウェアをスイッチにリロードする例を示します。

Switch# reload at 02:00 jun 20
Reload scheduled for 02:00:00 UTC Thu Jun 20 1996 (in 344 hours and 53 minutes)
Proceed with reload? [confirm]
 

スケジュールがすでに設定されたリロードを取り消すには、 reload cancel 特権 EXEC コマンドを使用します。

DHCP 自動イメージ アップデートの設定:例

Switch# configure terminal
Switch(config)# ip dhcp pool pool1
Switch(dhcp-config)# network 10.10.10.0 255.255.255.0
Switch(dhcp-config)# bootfile config-boot.text
Switch(dhcp-config)# default-router 10.10.10.1
Switch(dhcp-config)# option 150 10.10.10.1
Switch(dhcp-config)# exit
Switch(config)# tftp-server flash:config-boot.text
Switch(config)# interface gigabitethernet1/2
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.10.10.1 255.255.255.0
Switch(config-if)# end

DHCP サーバとしてスイッチを設定:例

次に、スイッチを DHCP サーバとして設定し、それがコンフィギュレーション ファイルをダウンロードするようにさせる例を示します。

Switch# config terminal
Switch(config)# ip dhcp pool pool1
Switch(dhcp-config)# network 10.10.10.0 255.255.255.0
Switch(dhcp-config)# bootfile config-boot.text
Switch(dhcp-config)# default-router 10.10.10.1
Switch(dhcp-config)# option 150 10.10.10.1
Switch(dhcp-config)# option 125 hex 0000.0009.0a05.08661.7574.6f69.6e73.7461.6c6c.5f64.686370
Switch(dhcp-config)# exit
Switch(config)# tftp-server flash:config-boot.text
Switch(config)# tftp-server flash:c-ipservices-mz.122-44.3.SE.tar
Switch(config)# tftp-server flash:ies-lanbase-tar.122-44.EX.tar
Switch(config)# tftp-server flash:boot-config.text
Switch(config)# tftp-server flash: autoinstall_dhcp
Switch(config)# interface gigabitethernet1/2
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.10.10.1 255.255.255.0
Switch(config-if)# end

DHCP サーバからファイルをダウンロードするクライアントの設定

次に、VLAN 99 上のレイヤ 3 SVI インターフェイスを使用し、保存されているコンフィギュレーションで DHCP ベースの自動設定をイネーブルにする例を示します。

Switch# configure terminal
Switch(conf)# boot host dhcp
Switch(conf)# boot host retry timeout 300
Switch(conf)# banner config-save ^C Caution - Saving Configuration File to NVRAM May Cause You to Nolonger Automatically Download Configuration Files at Reboot^C
Switch(config)# vlan 99
Switch(config-vlan)# interface vlan 99
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch# show boot
BOOT path-list:
Config file: flash:/config.text
Private Config file: flash:/private-config.text
Enable Break: no
Manual Boot: no
HELPER path-list:
NVRAM/Config file
buffer size: 32768
Timeout for Config
Download: 300 seconds
Config Download
via DHCP: enabled (next boot: enabled)
Switch#

その他の関連資料

ここでは、スイッチ管理に関する参考資料について説明します。

関連資料

関連項目
マニュアル タイトル

Cisco IE 2000 コマンド

Cisco IE 2000 Switch Command Reference , Release 15.0(1)EY』

Cisco IOS 基本コマンド

『Cisco IOS Configuration Fundamentals Command Reference』

標準

標準
タイトル

この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

--

MIB

MIB
MIB のリンク

--

Cisco IOS XR ソフトウェアを使用して MIB を検索およびダウンロードするには、 http://cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml にある Cisco MIB Locator を使用し、[Cisco Access Products] メニューからプラットフォームを選択します。

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクなどの、数千ページに及ぶ技術情報が検索可能です。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/en/US/support/index.html