Cisco MDS 9000 ファミリ CLI コンフィギュレーション ガイド リリース 3.x Cisco MDS SAN-OS for Release 3.0(1) ~ 3.3(3)
SPAN を使用したネットワーク トラフィックのモニタリング
SPAN を使用したネットワーク トラフィックのモニタリング
発行日;2013/09/03 | 英語版ドキュメント(2011/01/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

SPAN を使用したネットワーク トラフィックのモニタリング

SPAN の概要

SPAN 送信元

IPS 送信元ポート

使用可能な送信元インターフェイス タイプ

送信元としての VSAN

VSAN を送信元として設定する場合の注意事項

SPAN セッション

フィルタの指定

フィルタを指定する場合の注意事項

SD ポートの特性

SPAN を設定する場合の注意事項

SPAN の設定

SPAN の設定

第 2 世代ファブリック スイッチ用の SPAN の設定

SPAN セッションの一時停止および再開

フレームのカプセル化

SPAN 変換動作

ファイバ チャネル アナライザによるトラフィックのモニタリング

SPAN を使用しない場合

SPAN を使用する場合

SPAN を使用したファイバ チャネル アナライザの設定

単一 SD ポートによるトラフィックのモニタ

SPAN 情報の表示

リモート SPAN

RSPAN の使用の利点

FC トンネルと RSPAN トンネル

RSPAN を設定する場合の注意事項

ST ポートの特性

RSPAN の設定

RSPAN の設定例

送信元スイッチの設定

すべての中間スイッチの設定

宛先スイッチの設定

明示的パス

RSPAN トラフィックのモニタリング

サンプル シナリオ

単一の送信元と 1 本の RSPAN トンネル

単一の送信元と複数の RSPAN トンネル

複数の送信元と複数の RSPAN トンネル

RSPAN 情報の表示

SPAN および RSPAN のデフォルト設定

SPAN を使用したネットワーク トラフィックのモニタリング

この章では、Cisco MDS 9000 ファミリ スイッチに提供されるスイッチド ポート アナライザ(SPAN)機能について説明します。内容は次のとおりです。

「SPAN の概要」

「SPAN 送信元」

「SPAN セッション」

「フィルタの指定」

「SD ポートの特性」

「SPAN の設定」

「ファイバ チャネル アナライザによるトラフィックのモニタリング」

「SPAN 情報の表示」

「リモート SPAN」

「SPAN および RSPAN のデフォルト設定」

SPAN の概要

スイッチド ポート アナライザ(SPAN)機能は、Cisco MDS 9000 ファミリ スイッチ特有のものです。SPAN は、ファイバ チャネル インターフェイスを通じてネットワーク トラフィックをモニタします。任意のファイバ チャネル インターフェイスを通るトラフィックは、SPAN 宛先ポート(SD ポート)という専用ポートに複製することができます。スイッチの任意のファイバ チャネル ポートを SD ポートとして設定できます。SD ポート モードに設定したインターフェイスは、標準データ トラフィックには使用できません。ファイバ チャネル アナライザを SD ポートに接続すると、SPAN トラフィックをモニタすることができます(「Cisco Fabric Analyzer」を参照)。

SD ポートはフレームを受信しませんが、SPAN 送信元トラフィックのコピーを送信します。SPAN 機能は他の機能に割り込むことがなく、SPAN 送信元ポートのネットワーク トラフィックのスイッチングにも影響しません(図 53-1 を参照)。

図 53-1 SPAN の送信

 

SPAN 送信元

SPAN 送信元とは、トラフィックをモニタリングできるインターフェイスを表します。VSAN を SPAN 送信元として指定することもできます。この場合は、指定された VSAN でサポートされているすべてのインターフェイスが、SPAN 送信元に含まれます。任意の送信元インターフェイスで、入力方向、出力方向、または両方向の SPAN トラフィックを選択できます。

入力送信元(Rx):この送信元インターフェイスを介してスイッチ ファブリックに入るトラフィックは、SD ポートに スパン (コピー)されます(図 53-2 を参照)。

図 53-2 入力方向からの SPAN トラフィック

 

入力送信元(Tx):この送信元インターフェイスを介してスイッチ ファブリックから送信されるトラフィックは、SD ポートにスパン(コピー)されます(図 53-3 を参照)。

図 53-3 出力方向からの SPAN トラフィック

 

 

IPS 送信元ポート

SPAN 機能は、IP Storage Service(IPS)モジュールで利用できます。この SPAN 機能を実装できるのは、物理ギガビット イーサネット ポートでなく、FCIP および iSCSI 仮想ファイバ チャネル ポート インターフェイス上だけです。IPS モジュールで使用可能なすべてのインターフェイス(8 個の iSCSI インターフェイスおよび 24 個の FCIP インターフェイス)では、入力トラフィック、出力トラフィック、または両方向のトラフィックに SPAN を設定できます。


) イーサネット トラフィックに SPAN を設定するには、Cisco MDS 9000 ファミリ IPS モジュールに接続されたシスコ製スイッチまたはルータを使用します。


使用可能な送信元インターフェイス タイプ

SPAN 機能を使用できるインターフェイス タイプは、次のとおりです。

物理ポート(F ポート、FL ポート、TE ポート、E ポート、および TL ポート)。

インターフェイス sup-fc0(スーパーバイザに対するトラフィック)

sup-fc0 インターフェイスを介してスーパーバイザ モジュールからスイッチ ファブリックに送信されるファイバ チャネル トラフィックを、入力トラフィックと言います。入力送信元ポートとして sup-fc0 が選択されている場合は、このトラフィックがスパンされます。

sup-fc0 インターフェイスを介してスイッチ ファブリックからスーパーバイザ モジュールに送信されるファイバ チャネルトラフィックを、出力トラフィックと言います。出力送信元ポートとして sup-fc0 が選択されている場合は、このトラフィックがスパンされます。

PortChannel

PortChannel 内のすべてのポートが含まれ、送信元としてスパンされます。

PortChannel 内のポートを SPAN 送信元として個別に指定できません。設定済みの SPAN 固有のインターフェイス情報は廃棄されます。

IPS モジュール固有のファイバ チャネル インターフェイス

iSCSI インターフェイス

FCIP インターフェイス

送信元としての VSAN

送信元として VSAN が指定されている場合は、この VSAN 内のすべての物理ポートおよび PortChannel が SPAN 送信元として含まれます。TE ポートが含まれるのは、TE ポートのポート VSAN が送信元 VSAN と一致する場合だけです。設定済みの許可 VSAN リストに送信元 VSAN が含まれている場合でも、ポート VSAN が異なっていれば、TE ポートは除外されます。

同じ SPAN セッション内では、送信元インターフェイス(物理インターフェイス、PortChannel、または sup-fc インターフェイス)と送信元 VSAN を設定できません。

VSAN を送信元として設定する場合の注意事項

VSAN を送信元として設定する場合は、次の注意事項に従ってください。

送信元 VSAN に含まれるすべてのインターフェイスのトラフィックは、入力方向の場合にだけスパンされます。

VSAN が送信元として指定されている場合は、VSAN に含まれるインターフェイス上でインターフェイスレベルの SPAN 設定を実行することができません。設定済みの SPAN 固有のインターフェイス情報は廃棄されます。

VSAN 内のインターフェイスが送信元として設定されている場合は、この VSAN を送信元として設定できません。VSAN を送信元として設定する前に、まずこのようなインターフェイス上の既存の SPAN 設定を削除する必要があります。

インターフェイスが送信元として含まれるのは、ポート VSAN が送信元 VSAN と一致する場合だけです。図 53-4 に、VSAN 2 を送信元として使用した場合の設定を示します。

スイッチ内のすべてのポートは、fc1/1 を除いて、VSAN 1 内にあります。

インターフェイス fc1/1 は、ポート VSAN 2 を含む TE ポートです。VSAN 1、2、および 3 は許可リスト内で設定されます。

VSAN 1 および VSAN 2 は、SPAN 送信元として設定されています。

図 53-4 送信元としての VSAN

 

 

この設定では、次のようになります。

送信元としての VSAN 2 には、ポート VSAN 2 を持つ TE ポート fc1/1 だけが含まれます。

ポート VSAN が VSAN 1 と一致しないため、送信元としての VSAN 1 には TE ポート fc1/1 が含まれません。

「VSAN の許可アクティブ リストの設定」または「ポート VSAN メンバーシップの概要」を参照してください。

SPAN セッション

各 SPAN セッションは、1 つの宛先と複数の送信元の対応関係、およびネットワーク トラフィックをモニタするために指定されたその他のパラメータを表します。1 つの宛先を 1 つ以上の SPAN セッションで使用することができます。スイッチには最大 16 個の SPAN セッションを設定できます。各セッションには複数の送信元ポートおよび 1 つの宛先ポートを設定できます。

SPAN セッションをアクティブにするには、少なくとも 1 つの送信元および SD ポートを起動して、機能させる必要があります。このようにしないと、トラフィックが SD ポートに転送されません。


ヒント 1 つの送信元を 2 つのセッションで共有することは可能です。ただし、各セッションはそれぞれ異なる方向(1 つは入力、1 つは出力)でなければなりません。

SPAN セッションを一時的に非アクティブ(一時停止)にできます。この期間中、トラフィック モニタリングは停止します。

フィルタの指定

VSAN ベースのフィルタリングを実行すると、指定された VSAN 上でネットワーク トラフィックを選択的にモニタできます。この VSAN フィルタは、セッション内のすべての送信元に適用できます(図 53-4 を参照)。スパンされるのは、このフィルタ内の VSAN だけです。

指定されたセッション内のすべての送信元に適用されるセッション VSAN フィルタを指定できます。これらのフィルタは双方向であり、セッションに設定されたすべての送信元に適用されます。

フィルタを指定する場合の注意事項

SPAN フィルタには、次の注意事項が適用されます。

PortChannel 設定は、PortChannel 内にあるすべてのポートに適用されます。

フィルタが指定されていない場合は、該当するインターフェイスのすべてのアクティブ VSAN からのトラフィックがデフォルトでスパンされます。

セッションでは任意の VSAN フィルタを指定できますが、トラフィックをモニタできるのは、該当するポート VSAN 上、または該当するインターフェイスで許可されているアクティブ VSAN 上だけです。

SD ポートの特性

SD ポートには、次の特性があります。

BB_credits を無視します。

出力(Tx)方向のデータ トラフィックだけを許可します。

デバイスまたはアナライザを物理的に接続する必要はありません。

1 Gbps または 2 Gbps の速度だけをサポートします。自動速度オプションは使用できません。

複数のセッションで同じ宛先ポートを共有できます。

SD ポートがシャットダウンされると、共有されたすべてのセッションが SPAN トラフィックの生成を停止します。

発信フレームは、Extended Inter-Switch Link(EISL)フォーマットでカプセル化することができます。

SD ポートにはポート VSAN がありません。

Storage Services Module(SSM)を使用した SD ポートの設定はできません。

SPAN セッションで使用中のポート モードは、変更できません。


) SD ポート モードを別のポート モードに変更する必要がある場合は、最初に SD ポートをすべてのセッションから削除し、次に switchport mode コマンドを使用してポート モードを変更します。


SPAN を設定する場合の注意事項

SPAN を設定する場合は、次の注意事項が適用されます。

複数の入力(Rx)送信元には、最大 16 個の SPAN セッションを設定できます。

1 つの出力(Tx)ポートには、最大 3 個の SPAN セッションを設定できます。

32 ポート スイッチング モジュールでは、1 つのポート グループ(ユニット)内の 4 つのすべてのポートに、同じセッションを設定する必要があります。必要に応じて、このユニットの 2 つまたは 3 つのポートだけに設定することもできます(「第 1 世代インターフェイス設定の注意事項」を参照)。

送信元の合計帯域幅が宛先ポートの速度を超えると、SPAN フレームは廃棄されます。

送信元ポートで廃棄されたフレームは、スパンされません。

SPAN の設定

SD ポートを使用してネットワーク トラフィックをモニタするには、次の手順を実行します。


ステップ 1 SD ポートを設定します。

ステップ 2 指定した SPAN セッションに SD ポートを接続します。

ステップ 3 セッションに送信元インターフェイスを追加して、ネットワーク トラフィックをモニタします。


 

SPAN の設定

SPAN モニタリングの SD ポートを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc9/1

指定されたインターフェイスを設定します。

ステップ 3

switch(config-if)# switchport mode SD

インターフェイス fc9/1 の SD ポート モードを設定します。

ステップ 4

switch(config-if)# switchport speed 1000

SD ポート速度を 1000 Mbps に設定します。

ステップ 5

switch(config-if)# no shutdown

このインターフェイスを通過するトラフィック フローをイネーブルにします。

SPAN セッションを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# span session 1

switch(config-span)#

指定した SPAN セッション(1)を設定します。セッションが存在しない場合は、作成されます。

switch(config)# no span session 1

指定した SPAN セッション(1)を削除します。

ステップ 3

switch(config-span)# destination interface fc9/1

セッションの指定した宛先インターフェイス(fc 9/1)を設定します。

switch(config-span)# no destination interface fc9/1

指定した宛先インターフェイス(fc 9/1)を削除します。

ステップ 4

switch(config-span)# source interface fc7/1

 

両方向の送信元(fc 7/1)インターフェイスを設定します。

(注) Cisco MDS 9124 ファブリック スイッチは双方向の SPAN セッションをサポートしません(Rx および Tx)

switch(config-span)# no source interface fc7/1

指定した宛先インターフェイス(fc 7/1)をこのセッションから削除します。

ステップ 5

switch(config-span)# source interface sup-fc0

セッションの送信元インターフェイス(sup-fc0)を設定します。

switch(config-span)# source interface fc1/5 - 6, fc2/1 -3

セッションの指定したインターフェイス範囲を設定します。

switch(config-span)# source vsan 1-2

セッションの送信元 VSAN 1 および 2 を設定します。

switch(config-span)# source interface port-channel 1

送信元 PortChannel(port-channel 1)を設定します。

switch(config-span)# source interface fcip 51

セッションの送信元 FCIP インターフェイスを設定します。

switch(config-span)# source interface iscsi 4/1

セッションの送信元 iSCSI インターフェイスを設定します。

switch(config-span)# source interface svc1/1 tx traffic-type initiator

発信側トラフィック タイプの Tx 方向の送信元 SVC インターフェイスを設定します。

switch(config-span)# no source interface port-channel 1

指定した送信元インターフェイス(port-channel 1)を削除します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc9/1

指定されたインターフェイスを設定します。

ステップ 3

switch(config-if)# switchport mode SD

インターフェイス fc9/1 の SD ポート モードを設定します。

ステップ 4

switch(config-if)# switchport speed 1000

SD ポート速度を 1000 Mbps に設定します。

ステップ 5

switch(config-if)# no shutdown

このインターフェイスを通過するトラフィック フローをイネーブルにします。

SPAN モニタリングの SD ポートを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc9/1

指定されたインターフェイスを設定します。

ステップ 3

switch(config-if)# switchport mode SD

インターフェイス fc9/1 の SD ポート モードを設定します。

ステップ 4

switch(config-if)# switchport speed 1000

SD ポート速度を 1000 Mbps に設定します。

ステップ 5

switch(config-if)# no shutdown

このインターフェイスを通過するトラフィック フローをイネーブルにします。

SPAN セッションを設定する手順は、次のとおりです。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# span session 1

switch(config-span)#

指定した SPAN セッション(1)を設定します。セッションが存在しない場合は、作成されます。

switch(config)# no span session 1

指定した SPAN セッション(1)を削除します。

ステップ 3

switch(config-span)# destination interface fc9/1

セッションの指定した宛先インターフェイス(fc 9/1)を設定します。

switch(config-span)# no destination interface fc9/1

指定した宛先インターフェイス(fc 9/1)を削除します。

ステップ 4

switch(config-span)# source interface fc7/1

 

両方向の送信元(fc 7/1)インターフェイスを設定します。

(注) Cisco MDS 9124 ファブリック スイッチは双方向の SPAN セッションをサポートしません(Rx および Tx)

switch(config-span)# no source interface fc7/1

指定した宛先インターフェイス(fc 7/1)をこのセッションから削除します。

ステップ 5

switch(config-span)# source interface sup-fc0

セッションの送信元インターフェイス(sup-fc0)を設定します。

switch(config-span)# source interface fc1/5 - 6, fc2/1 -3

セッションの指定したインターフェイス範囲を設定します。

switch(config-span)# source vsan 1-2

セッションの送信元 VSAN 1 および 2 を設定します。

switch(config-span)# source interface port-channel 1

送信元 PortChannel(port-channel 1)を設定します。

switch(config-span)# source interface fcip 51

セッションの送信元 FCIP インターフェイスを設定します。

switch(config-span)# source interface iscsi 4/1

セッションの送信元 iSCSI インターフェイスを設定します。

switch(config-span)# source interface svc1/1 tx traffic-type initiator

発信側トラフィック タイプの Tx 方向の送信元 SVC インターフェイスを設定します。

switch(config-span)# no source interface port-channel 1

指定した送信元インターフェイス(port-channel 1)を削除します。

SPAN セッションを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# span session 1

switch(config-span)#

指定したセッション(1)を設定します。

ステップ 3

switch(config-span)# source interface fc9/1 tx

送信元(fc 9/1)インターフェイスを出力(Tx)方向に設定します。

switch(config-span)# source filter vsan 1-2

VSAN 1 および 2 をセッション フィルタとして設定します。

switch(config-span)# source interface fc7/1 rx

送信元(fc 7/1)インターフェイスを入力(Rx)方向に設定します。

SPAN セッションの SPAN ドロップしきい値を設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# span drop-threshold 15

switch(config-span)#

SPAN ドロップしきい値を設定します。


注意 デフォルトでは、送信元インターフェイスの帯域幅の合計が宛先ポートの帯域幅を超えると、SPAN フレームはドロップされます。値が大きいほど、SPAN トラフィックがデータ トラフィック スループットと引き換えに廃棄されるのではなく、SPAN 宛先に到達する可能性が高くなります。


注意 SPAN ドロップしきい値は、スイッチで現在 SPAN セッションがアクティブでない場合にだけ変更できます。


注意 デフォルトでは、送信元インターフェイスの帯域幅の合計が宛先ポートの帯域幅を超えると、SPAN フレームはドロップされます。値が大きいほど、SPAN トラフィックがデータ トラフィック スループットと引き換えに廃棄されるのではなく、SPAN 宛先に到達する可能性が高くなります。


注意 SPAN ドロップしきい値は、スイッチで現在 SPAN セッションがアクティブでない場合にだけ変更できます。

第 2 世代ファブリック スイッチ用の SPAN の設定

シスコの第 2 世代ファブリック スイッチ(MDS 9124 など)では、SPAN セッションが両方向(Rx と Tx)でサポートされます。


) 第 2 世代ファブリック スイッチを使用する場合、アクティブな SPAN セッションは 1 つしか作成できません。


次に、このスイッチの入力方向に SPAN セッションを設定する例を示します。

例 53-1 入力 SPAN セッションへの第 2 世代ファブリック スイッチの設定

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# span session 1

switch(config-span)#

指定したセッション(1)を設定します。

ステップ 3

switch(config-span)# destination interface fc1/1

宛先としてインターフェイス fc1/1 を設定します。

ステップ 4

switch(config-span)# source interface fc1/2 rx

送信元インターフェイス fc1/2 を入力方向に設定します。

例 53-2 出力 SPAN セッションへの第 2 世代ファブリック スイッチの設定

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# span session 1

switch(config-span)#

指定したセッション(1)を設定します。

ステップ 3

switch(config-span)# destination interface fc1/1

宛先としてインターフェイス fc1/1 を設定します。

ステップ 4

switch(config-span)# source interface fc1/2 tx

送信元インターフェイス fc1/2 を出力方向に設定します。

複数の SPAN 送信元インターフェイスを Rx 方向と Tx 方向で指定できます。

同じ SPAN セッション内に入力インターフェイスと出力インターフェイスを混在させることはできません。SPAN は、Rx 方向と Tx 方向が混在する設定をすべて拒否します。一方、単一方向で複数の SPAN 送信元インターフェイスを指定することはできます。

例 53-3 複数の SPAN インターフェイス用の Cisco MDS 9124 の設定

switch(config-span)# span session 1
switch(config-span)# destination interface fc1/1
switch(config-span)# source interface fc1/2 rx
switch(config-span)# source interface fc1/3 rx
 

第 2 世代ファブリック スイッチでは、出力方向において 1 つの VSAN に対してのみ VSAN フィルタがサポートされます。この制限は、入力方向には適用されません。たとえば、TE ポートのインターフェイスで 1 ~ 5 のアクティブな VSAN が存在する場合、VSAN 2 に対して VSAN フィルタを指定すると、VSAN 2 上のトラフィックのみがフィルタリングされます。

switch(config-span)# span session 1
switch(config-span)# source filter vsan 2
switch(config-span)# destination interface fc1/1
switch(config-span)# source interface fc1/2 tx
 

ただし、VSAN 1 ~ 2 の VSAN フィルタを指定する場合、すべての VSAN(1~5)からのトラフィックはフィルタリングされ、基本的に使用しないフィルタはレンダリングされます。

switch(config-span)# span session 1
switch(config-span)# source filter vsan 1-2
switch(config-span)# destination interface fc1/1
switch(config-span)# source interface fc1/2 tx
 

SPAN セッションの一時停止および再開

SPAN セッションを一時的に非アクティブ(一時停止)にできます。この期間中、トラフィック モニタリングは停止します。

SPAN セッション フィルタを一時的に停止または再開するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# span session 1

switch(config-span)#

指定したセッション(1)を設定します。

ステップ 3

switch(config-span)# suspend

一時的にセッションを中断します。

switch(config-span)# no suspend

セッションを再度アクティブにします。

フレームのカプセル化

フレームのカプセル化機能は、デフォルトではディセーブルになっています。カプセル化機能をイネーブルにすると、すべての発信フレームがカプセル化されます。

switchport encap eisl コマンドは、SD ポート インターフェイスにだけ適用されます。カプセル化がイネーブルの場合、 show interface SD_port_interface コマンド出力に新しい行( Encapsulation is eisl )が表示されます。

発信フレームをカプセル化するには(任意)、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc9/32

指定されたインターフェイスを設定します。

ステップ 3

switch(config-if)# switchport mode SD

インターフェイス fc9/32 の SD ポート モードを設定します。

ステップ 4

switch(config-if)# switchport encap eisl

この SD ポートのカプセル化オプションをイネーブルにします。

switch(config-if)# no switchport encap eisl

カプセル化オプションをディセーブルにします(デフォルト)。

SPAN 変換動作

(古い任意のリリースで設定された)SPAN 機能は次のように変換されます。

指定されたセッションにおいて送信元インターフェイスおよび送信元 VSAN が設定されている場合は、このセッションからすべての送信元 VSAN が削除されます。

例:Cisco MDS SAN-OS Release 1.0(4) よりも古いリリース

Session 1 (active)
Destination is fc1/9
No session filters configured
Ingress (rx) sources are
vsans 10-11
fc1/3,
Egress (tx) sources are
fc1/3,
 

Cisco MDS SAN-OS Release 1.1(1) にアップグレードした後

Session 1 (active)
Destination is fc1/9
No session filters configured
Ingress (rx) sources are
fc1/3,
Egress (tx) sources are
fc1/3,
 

アップグレード前は、セッション 1 に送信元インターフェイスと送信元 VSAN が両方とも設定されていました。アップグレード後は、送信元 VSAN が削除されました(法則 1)。

送信元インターフェイスにインターフェイス レベルの VSAN フィルタが設定されている場合、送信元インターフェイスもセッションから削除されます。このインターフェイスが双方向に設定されている場合、このインターフェイスは双方向で削除されます。

例:Cisco MDS SAN-OS Release 1.0(4) よりも古いリリース

Session 2 (active)
Destination is fc1/9
No session filters configured
Ingress (rx) sources are
vsans 12
fc1/6 (vsan 1-20),
Egress (tx) sources are
fc1/6 (vsan 1-20),
 

Cisco MDS SAN-OS Release 1.1(1) にアップグレードした後

Session 2 (inactive as no active sources)
Destination is fc1/9
No session filters configured
No ingress (rx) sources
No egress (tx) sources
 

) スイッチオーバーまたは新しいスタートアップ コンフィギュレーションを実装すると、推奨されない設定が固定メモリから削除されます。


セッション 2 には、送信元 VSAN 12 と送信元インターフェイス fc1/6、および Cisco MDS SAN-OS Release 1.0(4) で指定された VSAN フィルタが設定されていました。Cisco MDS SAN-OS Release 1.1(1) にアップグレードすると、次のように変更されます。

送信元 VSAN(VSAN 12)が削除されます(法則 1)。

送信元インターフェイス fc1/6 には VSAN フィルタが指定されていましたが、これも削除されます(法則 2)。

ファイバ チャネル アナライザによるトラフィックのモニタリング

SPAN を使用すると、トラフィックを中断することなく、インターフェイス上でトラフィックをモニタできます。この機能は、トラブルシューティングを行うときに特に役立ちます。トラブルシューティングの場では、トラフィックの中断により問題の環境が変更されたり、問題を再現するのが困難になるからです。

SPAN を使用しない場合

別のスイッチまたはホストに接続された Cisco MDS 9000 ファミリ スイッチのインターフェイス fc1/1 を使用して、トラフィックをモニタできます。インターフェイス fc1/1 を通るトラフィックを分析するには、スイッチとストレージ デバイスをファイバ チャネル アナライザで物理的に接続する必要があります(図 53-5 を参照)。

図 53-5 SPAN を使用しない場合のファイバ チャネル アナライザの使用方法

 

この接続タイプには、次のような制約があります。

2 つのネットワーク デバイス間にファイバ チャネル アナライザを物理的に挿入する必要があります。

ファイバ チャネル アナライザが物理的に接続されている場合は、トラフィックが中断されます。

アナライザはポート 1 およびポート 2 の Rx リンクのデータだけをキャプチャします。ポート 1 はインターフェイス fc1/1 からの出力トラフィックを、ポート 2 はインターフェイス fc1/1 への入力トラフィックをキャプチャします。

SPAN を使用する場合

SPAN を使用すると、トラフィックを中断しなくても、図 53-5 と同じトラフィックをキャプチャすることができます。ファイバ チャネルアナライザはポート 1 の入力(Rx)リンクを使用して、インターフェイス fc1/1 から送信されるすべてのフレームをキャプチャします。また、ポート 2 の入力リンクを使用して、インターフェイス fc1/1 へのすべての入力トラフィックをキャプチャします。

SPAN を使用すると、SD ポート fc2/2 で fc1/1 の入力トラフィックをモニタしたり、SD ポート fc2/1 の出力トラフィックをモニタすることができます。このトラフィックは、ファイバ チャネル アナライザでシームレスにキャプチャされます(図 53-6 を参照)。

図 53-6 SPAN を使用した場合のファイバ チャネル アナライザの使用方法

 

 

SPAN を使用したファイバ チャネル アナライザの設定

SPAN を使用してファイバ チャネル アナライザを設定するには(図 53-6 の例を使用)、次の手順を実行します。


ステップ 1 セッション 1 を使用して SD ポート fc2/1 上でトラフィックを送信するように、インターフェイス fc1/1 の入力(Rx)方向に SPAN を設定します。

ステップ 2 セッション 2 を使用して SD ポート fc2/2 上でトラフィックを送信するように、インターフェイス fc1/1 の出力(Tx)方向に SPAN を設定します。

ステップ 3 ファイバ チャネル アナライザのポート 1 に fc2/1 を物理的に接続します。

ステップ 4 ファイバ チャネル アナライザのポート 2 に fc2/2 を物理的に接続します。


 

送信元および宛先インターフェイスに SPAN を設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# span session 1

switch(config-span)#

SPAN セッション 1 を作成します。

ステップ 3

switch(config-span)## destination interface fc2/1

宛先インターフェイス fc2/1 を設定します。

ステップ 4

switch(config-span)# source interface fc1/1 rx

送信元インターフェイス fc1/1 を入力方向に設定します。

ステップ 5

switch(config)# span session 2

switch(config-span)#

SPAN セッション 2 を作成します。

ステップ 6

switch(config-span)## destination interface fc2/2

宛先インターフェイス fc2/2 を設定します。

ステップ 7

switch(config-span)# source interface fc1/1 tx

送信元インターフェイス fc1/1 を出力方向に設定します。

単一 SD ポートによるトラフィックのモニタ

任意のインターフェイス上で双方向トラフィックを監視する場合、SD ポートを 2 つ使用する必要はありません(図 53-6 を参照)。同じ SD ポート fc2/1 でこのインターフェイスのトラフィックをモニタすることにより、SD ポートおよびファイバ チャネル アナライザ ポートを 1 つずつ使用することができます。

図 53-7 に、宛先ポート fc2/1 および送信元インターフェイス fc1/1 を含む 1 つのセッションを使用して、入力および出力方向のトラフィックをキャプチャする SPAN 設定を示します。この設定では 2 ポートアナライザのポートをすべて使用せずに、SD ポートおよびアナライザのポートを 1 つずつ使用するため、図 53-6 の設定よりも便利かつ低コストです。

図 53-7 単一 SD ポートを使用した場合のファイバ チャネル アナライザ

 

 

この設定を使用するには、キャプチャされたすべてのフレームの入出力トラフィックを区別する機能がアナライザに必要です。

単一 SD ポートに SPAN を設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# span session 1

switch(config-span)#

SPAN セッション 1 を作成します。

ステップ 3

switch(config-span)## destination interface fc2/1

宛先インターフェイス fc2/1 を設定します。

ステップ 4

switch(config-span)# source interface fc1/1

同じ SD ポートに送信元インターフェイス fc1/1 を設定します。

SPAN 情報の表示

設定された SPAN 情報を表示するには、 show span コマンド セットを使用します。例 53-4 53-9 を参照してください。

例 53-4 要約形式での SPAN セッションの表示

switch# show span session brief
--------------------------------------------------------
Session Admin Oper Destination
State State Interface
--------------------------------------------------------
7 no suspend active fc2/7
1 suspend inactive not configured
2 no suspend inactive fc3/1

例 53-5 特定の SPAN セッションの詳細表示

switch# show span session 7
Session 7 (active)
Destination is fc2/7
No session filters configured
No ingress (rx) sources
Egress (tx) sources are
port-channel 7,
 

例 53-6 すべての SPAN セッションの表示

switch# show span session
Session 1 (inactive as no destination)
Destination is not specified
Session filter vsans are 1
No ingress (rx) sources
No egress (tx) sources
Session 2 (active)
Destination is fc9/5
No session filters configured
Ingress (rx) sources are
vsans 1
No egress (tx) sources
Session 3 (admin suspended)
Destination is not configured
Session filter vsans are 1-20
Ingress (rx) sources are
fc3/2, fc3/3, fc3/4, fcip 51,
port-channel 2, sup-fc0,
Egress (tx) sources are
fc3/2, fc3/3, fc3/4, sup-fc0,
 

例 53-7 SPAN セッションの SPAN ドロップカウンタの表示

switch# show span drop-counters
SPAN Drop-Counters for module 3 is: 0x0
SPAN Drop-Counters for module 7 is: 0x0
 

) show span drop-counters では、ドロップされたカウンタが表示されます。ドロップされたカウンタ値がゼロより大きい場合だけ、show span drop-threshold を設定できます。


例 53-8 SPAN セッションの SPAN ドロップしきい値の表示

switch# show span drop-threshold
Drop-Threshold for SPAN sessions: 15

) すべての SPAN セッションのデフォルト値は 15 です。span drop-threshold は、セッションが非アクティブの場合だけ発行できます。


例 53-9 カプセル化がイネーブルな場合の SD ポート インターフェイスの表示

switch# show int fc9/32
fc9/32 is up
Hardware is Fibre Channel
Port WWN is 22:20:00:05:30:00:49:5e
Admin port mode is SD
Port mode is SD
Port vsan is 1
Speed is 1 Gbps
Receive Buffer Size is 2112
Encapsulation is eisl <---------------- イネーブルなカプセル化のステータスを表示
Beacon is turned off
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
0 frames input, 0 bytes, 0 discards
0 CRC, 0 unknown class
0 too long, 0 too short
0 frames output, 0 bytes, 0 discards
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
0 output OLS, 0 LRR, 0 NOS, 0 loop inits
 

リモート SPAN


) HP c-Class BladeSystem 対応 Cisco Fabric Switch および IBM BladeSystem 対応 Cisco Fabric Switch は、リモート SPAN をサポートしていません。


リモート SPAN(RSPAN)機能により、ファイバ チャネル ファブリック内の 1 台以上の送信元スイッチで配信される 1 つ以上の SPAN 送信元のトラフィックをリモートでモニタできるようになります。SPAN 宛先(SD)ポートは、宛先スイッチ内でリモート モニタリング用に使用されます。宛先スイッチは、一般に送信元スイッチとは別に用意されますが、同じファイバ チャネル ファブリックに接続されます。Cisco MDS 送信元スイッチでトラフィックをモニタするのと同様に、任意のリモートの Cisco MDS 9000 ファミリ スイッチまたはディレクタでトラフィックを複製し、モニタすることができます。

RSPAN 機能は他の機能に割り込むことなく、SPAN 送信元ポートのネットワーク トラフィックのスイッチングに影響しません。リモート スイッチ上でキャプチャされたトラフィックは、送信元スイッチから宛先スイッチに至るまでの経路上にあるすべてのスイッチ上でトランキングがイネーブルにされているファイバ チャネル ファブリック上をトンネリングされます。ファイバ チャネル トンネルは、トランク化された ISL(TE)ポートを使用して構造化されます。TE ポート以外にも、RSPAN 機能では他に 2 つのインターフェイス タイプが使用されます(図 53-8 を参照)。

SD ポート:FC アナライザがリモート SPAN トラフィックを取得するために使用できるパッシブ ポート。

ST ポート:SPAN トンネル(ST)ポートは、RSPAN ファイバ チャネル トンネル用の送信元スイッチ内の入口ポートです。ST ポートは、特別な RSPAN ポートであり、通常のファイバ チャネル トラフィックに使用することはできません。

図 53-8 RSPAN の送信

 

 

RSPAN の使用の利点

RSPAN 機能には、次の利点があります。

遠隔地での中断のないトラフィック モニタリングが可能になります。

複数のスイッチ上でリモート トラフィックをモニタするために 1 つの SD ポートを使用することにより、費用対効果に優れたソリューションを提供します。

任意のファイバ チャネル アナライザで動作します。

Cisco MDS 9000 ポート アナライザ アダプタと互換性があります。

送信元スイッチ内のトラフィックに影響を与えません。ただし、ファブリック内の他のポートと ISL 帯域幅を共有します。

FC トンネルと RSPAN トンネル

FC トンネルは、送信元スイッチと宛先スイッチの間の論理的なデータ パスです。FC トンネルは、送信元スイッチから開始し、離れた場所にある宛先スイッチで終端します。

RSPAN では、送信元スイッチ内の ST ポートから開始し、宛先スイッチ内の SD ポートで終端する特別なファイバ チャネル トンネル(FC トンネル)が使用されます。FC トンネルを送信元スイッチ内の ST ポートにバインドし、それと同じ FC トンネルを宛先スイッチ内の SD ポートにマッピングする必要があります。マッピングとバインディングが設定されると、その FC トンネルは RSPAN トンネルと呼ばれます(図 53-9 を参照)。

図 53-9 FC トンネルと RSPAN トンネル

 

 

RSPAN を設定する場合の注意事項

SPAN を設定する場合は、次の注意事項が適用されます。

RSPAN トンネルのエンドツーエンドのパス上にあるすべてのスイッチは、Cisco MDS 9000 ファミリに属している必要があります。

RSPAN トラフィックが含まれるすべての VSAN がイネーブルになっている必要があります。RSPAN トラフィックが含まれる VSAN がイネーブルになっていないと、そのトラフィックはドロップされます。

RSPAN が実装されるファイバ チャネル トンネルのエンドツーエンドのパス内にある スイッチ上で次の設定を実行する必要があります。

トランキングをイネーブルにする必要があります(デフォルトではイネーブル)。

VSAN インターフェイスを設定する必要があります。

ファイバ チャネル トンネル機能をイネーブルにする必要があります(デフォルトではディセーブル)。

IP ルーティングが必要な特定のトポロジがある場合は、IP ルーティングをイネーブルにする必要があります(デフォルトではディセーブル)。


) トンネルの送信元と宛先が同じサブネットにある場合は、パスの各スイッチに対して VSAN インターフェイスを設定する必要はありません。


単一のファイバ チャネル スイッチ ポートを ST ポート機能専用にする必要があります。

モニタ対象のポートを ST ポートとして設定してはなりません。

FC トンネルの IP アドレスは、VSAN インターフェイスと同じサブネット内に存在する必要があります

「IP サービスの設定」を参照してください。

ST ポートの特性

ST ポートには、次の特性があります。

ST ポートは、FC フレームの RSPAN カプセル化を実行します。

ST ポートは、BB_credit を使用しません。

1 つの ST ポートは、1 つの FC トンネルにしかバインドできません。

ST ポートは、RSPAN トラフィックの伝送以外には使用できません。

ST ポートは、Storage Services Module(SSM)を使用して設定することはできません。

RSPAN の設定

RSPAN トンネルは、送信元スイッチ内で開始し、宛先スイッチ内で終端します。ここでは、スイッチ S が送信元となり、スイッチ D が宛先になると仮定しています。


) 送信元スイッチと宛先スイッチに加え、ファイバ チャネル ファブリック内に Cisco MDS スイッチが存在する場合はそれらにも VSAN を設定する必要があります。


RSPAN 機能を使用してネットワーク トラフィックをモニタするには、次の手順を実行します。


ステップ 1 ファイバ チャネル トンネル(FC トンネル)の作成に利用する VSAN インターフェイスを宛先スイッチ(スイッチ D)と送信元スイッチ(スイッチ S)に作成します。

ステップ 2 トンネルのエンドツーエンドのパス内にある各スイッチで FC トンネルをイネーブルにします。

ステップ 3 FC トンネルを開始し(スイッチ S)、そのトンネルを VSAN インターフェイスの IP アドレスにマッピングします(スイッチ D)。それにより、トンネルからのすべての RSPAN トラフィックが SD ポートに誘導されるようにします。

ステップ 4 宛先スイッチ(スイッチ D)で SPAN モニタリング用の SD ポートを設定します。

ステップ 5 送信元スイッチ(スイッチ S)で ST ポートを設定し、その ST ポートを FC トンネルにバインドします。

ステップ 6 送信元スイッチ(スイッチ S)でネットワーク トラフィックをモニタする RSPAN セッションを作成します。


 

RSPAN の設定例

ここでは、前の項で定義した手順を使用して RSPAN 設定の例を示します。

VSAN インターフェイスの作成

図 53-10 に、基本的な FC トンネル設定を示します。

図 53-10 FC トンネル設定

 


) この例では、VSAN 5 が VSAN データベースですでに設定されているものとします。


図 53-10 のシナリオで送信元スイッチの VSAN インターフェイスを作成するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchS# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchS(config)# interface vsan 5

switchS(config-if)#

送信元スイッチ(スイッチ S)の指定した VSAN インターフェイス(VSAN 5)を設定します。

ステップ 3

switchS(config-if)# ip address 10.10.10.1 255.255.255.0

送信元スイッチ(スイッチ S)の VSAN インターフェイス 5 の IPv4 アドレスとサブネットを設定します。

ステップ 4

switchS(config-if)# no shutdown

このインターフェイスを通過するトラフィック フローをイネーブルにします。

FC トンネルのイネーブル化

FC トンネル機能をイネーブルにするには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchS# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchS(config)# fc-tunnel enable

FC トンネル機能をイネーブルにします(デフォルトではディセーブル)。


) ファブリック内のエンドツーエンドのパス内にある各スイッチにおいてこの機能をイネーブルにする必要があります。


FC トンネルの開始

図 53-10 のシナリオで送信元スイッチの FC トンネルを開始するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchS# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchS(config)# interface fc-tunnel 100

switchS(config-if)#

送信元スイッチ(スイッチ S)の FC トンネル(100)を開始します。トンネル ID の範囲は 1 ~ 255 です。

ステップ 3

switchS(config-if)# source 10.10.10.1

送信元スイッチ(スイッチ S)の IPv4 アドレスを FC トンネル(100)にマッピングします。

ステップ 4

switchS(config-if)# destination 10.10.10.2

宛先スイッチ(スイッチ D)の IPv4 アドレスを FC トンネル(100)にマッピングします。

ステップ 5

switchS(config-if)# no shutdown

このインターフェイスを通過するトラフィック フローをイネーブルにします。


ヒント 宛先スイッチに FC トンネル マッピングが設定されるまで、インターフェイスを動作上のアップ状態にすることはできません。

ST ポートの設定

FC トンネルを作成した後、送信元スイッチにおいて、その FC トンネルにバインドされるように ST ポートを設定する必要があります。バインディングとマッピングが完了すると、その FC トンネルは RSPAN トンネルになります。

図 53-11 に、基本的な FC トンネル設定を示します。

図 53-11 FC トンネルのバインディング

 


) ST ポートは、Storage Services Module(SSM)を使用して設定することはできません。


図 53-11 のシナリオで ST ポートを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchS# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchS(config)# interface fc2/1

指定されたインターフェイスを設定します。

ステップ 3

switchS(config-if)# switchport mode ST

インターフェイス fc2/1 の ST ポート モードを設定します。

ステップ 4

switchS(config-if)# switchport speed 2000

ST ポート速度を 2000 Mbps に設定します。

ステップ 5

switchS(config-if)# rspan-tunnel interface fc-tunnel 100

ST ポートに RSPAN トンネル(100)を関連付けて、バインドします。

ステップ 6

switchS(config-if)# no shutdown

このインターフェイスを通過するトラフィック フローをイネーブルにします。

RSPAN セッションの設定

RSPAN セッションでは、SPAN セッションと同様に、宛先インターフェイスが RSPAN トンネルになります。

図 53-11 のシナリオで送信元スイッチに RSPAN セッションを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchS# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchS(config)# span session 2

switchS(config-span)#

指定した SPAN セッション(2)を設定します。セッションが存在しない場合は、作成されます。セッション ID の範囲は、1 ~ 16 です。

ステップ 3

switchS(config-span)# destination interface fc-tunnel 100

指定された RSPAN トンネル(100)をセッション内で設定します。

ステップ 4

switchS(config-span)# source interface fc1/1

このセッションの送信元インターフェイス(fc1/1)を設定し、インターフェイス fc1/1 から RSPAN トンネル 100 にトラフィックをスパンします。

すべての中間スイッチの設定

ここでは、RSPAN トンネルのエンドツーエンドのパス内にあるすべての中間スイッチで実行する必要のある作業を示します。

「VSAN インターフェイスの設定」

「FC トンネルのイネーブル化」

「IP ルーティングのイネーブル化」

VSAN インターフェイスの設定

図 53-12 に、宛先スイッチ(スイッチ D)で終端している RSPAN トンネル設定を示します。


) この例では、VSAN 5 が VSAN データベースですでに設定されているものとします。


図 53-12 のシナリオでの宛先スイッチの VSAN インターフェイスを作成するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchD# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchD(config)# interface vsan 5

switchD(config-if)#

宛先スイッチ(スイッチ D)の指定した VSAN インターフェイス(VSAN 5)を設定します。

ステップ 3

switchD(config-if)# ip address 10.10.10.2 255.255.255.0

宛先スイッチ(スイッチ D)の VSAN インターフェイスの IPv4 アドレスとサブネットを設定します。

ステップ 4

switchD(config-if)# no shutdown

(動作ステートは up の場合)管理上トラフィックを許可するようにトラフィック フローをイネーブルにします。

FC トンネルのイネーブル化

FC トンネル機能をイネーブルにするには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchS# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchS(config)# fc-tunnel enable

送信元スイッチ(スイッチ S)の FC トンネル(100)を開始します。トンネル ID の範囲は 1 ~ 255 です。


) ファブリック内のエンドツーエンドのパス内にある各スイッチにおいてこの機能をイネーブルにする必要があります。


IP ルーティングのイネーブル化

IP ルーティング機能は、デフォルトではディセーブルになっています。ファブリック内のエンドツーエンドのパス内にある各スイッチ(送信元スイッチと宛先スイッチを含む)において IP ルーティングをイネーブルにする必要があります(「IPv4 ルーティングのイネーブル化」を参照)。この手順は、FC トンネルを設定するために必要です。

宛先スイッチの設定

ここでは、宛先スイッチ(スイッチ D)で実行する必要のある作業を示します。

「VSAN インターフェイスの設定」

「SD ポートの設定」

「FC トンネルのマッピング」

VSAN インターフェイスの設定

図 53-12 に、宛先スイッチ(スイッチ D)で終端している RSPAN トンネル設定を示します。


) この例では、VSAN 5 が VSAN データベースですでに設定されているものとします。


図 53-12 のシナリオでの宛先スイッチの VSAN インターフェイスを作成するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchD# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchD(config)# interface vsan 5

switchD(config-if)#

宛先スイッチ(スイッチ D)の指定した VSAN インターフェイス(VSAN 5)を設定します。

ステップ 3

switchD(config-if)# ip address 10.10.10.2 255.255.255.0

宛先スイッチ(スイッチ D)の VSAN インターフェイスの IPv4 アドレスとサブネットを設定します。

ステップ 4

switchD(config-if)# no shutdown

(動作ステートは up の場合)管理上トラフィックを許可するようにトラフィック フローをイネーブルにします。

FC トンネルのイネーブル化

FC トンネル機能をイネーブルにするには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchS# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchS(config)# fc-tunnel enable

送信元スイッチ(スイッチ S)の FC トンネル(100)を開始します。トンネル ID の範囲は 1 ~ 255 です。


) トンネル内のエンドツーエンドのパス内にある各スイッチにおいてこの機能をイネーブルにする必要があります。


SD ポートの設定

宛先スイッチ内の SD ポートにより、FC アナライザは、ファイバ チャネル トンネルからの RSPAN トラフィックを受信できるようになります。図 53-12 に、RSPAN トンネル設定を示します。トンネル宛先もすでに設定されています。

図 53-12 RSPAN トンネル設定

 


) Storage Services Module(SSM)を使用した SD ポートの設定はできません。


図 53-12 のシナリオで SD ポートを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchD# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchD(config)# interface fc2/1

指定されたインターフェイスを設定します。

ステップ 3

switchD(config-if)# switchport mode SD

インターフェイス fc2/1 の SD ポート モードを設定します。

ステップ 4

switchD(config-if)# switchport speed 2000

SD ポート速度を 2000 Mbps に設定します。

ステップ 5

switchD(config-if)# no shutdown

このインターフェイスを通過するトラフィック フローをイネーブルにします。

FC トンネルのマッピング

tunnel-id-map オプションにより、宛先スイッチでのトンネルの出力インターフェイスが指定されます(図 53-13 を参照)。

図 53-13 FC トンネル設定

図 53-13 のシナリオで宛先スイッチの FC トンネルを終端させるには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchD# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchD(config)# fc-tunnel tunnel-id-map 100 interface fc2/1

宛先スイッチ(スイッチ D)の FC トンネル(100)を終端させます。トンネル ID の範囲は 1 ~ 255 です。

明示的パス

explicit-path オプションを使用して、Cisco MDS ファイバ チャネル ファブリックを通過する明示的なパスを指定できます(送信元ベース ルーティング)。たとえば、トンネル宛先に対して複数のパスがある場合、このオプションを使用して、FC トンネルが宛先スイッチまで常に 1 つのパスを使用するように指定できます。この場合、ソフトウェアは、他のパスが使用可能であっても、この指定されたパスを使用します。

このオプションが特に役立つのは、使用可能なパスが他にあるときでも特定のパスにトラフィックを誘導したい場合です。RSPAN の場合、RSPAN トラフィックが既存のユーザ トラフィックの妨げにならないように、明示的なパスを指定できます。1 台のスイッチ内で作成できる明示的なパスの数に制限はありません(図 53-14 を参照)。

図 53-14 明示的なパスの設定

 

明示的なパスは送信元スイッチに作成する必要があります。明示的なパスを設定するには、最初にパスを作成し、次にいずれか 1 つのパスを使用するように設定します。明示的なパスが設定されていない場合は、最小コスト パスがデフォルトで使用されます。明示的なパスが設定されていて、機能している場合は、指定されたパスが使用されます。

図 53-14 のシナリオで明示的なパスを作成するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchS# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchS(config)# fc-tunnel explicit-path Path1

switch(config-explicit-path)#

パス Path 1 に関する明示的なパスのプロンプトが表示されます。

ステップ 3

switchS(config-explicit-path)# next-address 10.10.10.2 strict

switchS(config-explicit-path)# next-address 10.10.10.3 strict

switchS(config-explicit-path)# next-address 10.10.10.4 strict

明示的なパスで指定されたネクスト ホップ VSAN インターフェイスの IPv4 アドレスと前のホップが直接接続を必要としないことを指定します。

ステップ 4

switchS(config)# fc-tunnel explicit-path Path2

switch(config-explicit-path)#

Path 2 に関する明示的なパスのプロンプトが表示されます。

ステップ 5

switchS(config-explicit-path)# next-address 10.10.10.5 strict

switchS(config-explicit-path)# next-address 10.10.10.4 strict

明示的なパスで指定されたネクスト ホップ VSAN インターフェイスの IPv4 アドレスと前のホップが直接接続を必要としないことを指定します。

ステップ 6

switchS(config)# fc-tunnel explicit-path Path3

switch(config-explicit-path)#

Path 3 に関する明示的なパスのプロンプトが表示されます。

ステップ 7

switchS(config-explicit-path)# next-address 10.10.10.3 loose

IPv4 アドレス 10.10.10.3 が存在する最小コスト パスを設定します。

オプションを使用)を発行しなくても、1 のコマンドで同じ結果を達成できます。

明示的なパスを参照するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switchS# config t

コンフィギュレーション モードに入ります。

ステップ 2

switchS(config)# interface fc-tunnel 100

Path1 のトンネル ID を参照します。

ステップ 3

switchS(config)# explicit-path Path1

Path1 をトンネル ID にリンクします。

この設定は、RSPAN トラフィックで使用される Path1 を明示的に指定します。明示的なパスおよび送信元ベース ルーティングの詳細については、RFC 3209 を参照してください。

RSPAN トラフィックのモニタリング

セッションを設定した後、必要に応じてこのセッションに対する他の SPAN 送信元を設定することもできます。図 53-15 に、宛先ポート fc2/1 および送信元インターフェイス fc1/1 を含む 1 つのセッションを使用して、入力および出力方向のトラフィックをキャプチャする RSPAN 設定を示します。

図 53-15 単一の SD ポートを使用して RSPAN トラフィックをモニタするファイバ チャネル アナライザ

 

 

この設定を使用するには、キャプチャされたすべてのフレームの入出力トラフィックを区別する機能がアナライザに必要です。

サンプル シナリオ


) RSPAN は、SD ポートがローカル SPAN トラフィックをリモート SPAN トラフィックと一緒に転送するように、ローカル SPAN 機能と組み合わせることができます。ここでは、さまざまな SPAN 送信元とトンネルのシナリオが説明されます。


単一の送信元と 1 本の RSPAN トンネル

送信元のスイッチ S と宛先のスイッチ D がファイバ チャネル ファブリックを介して相互接続されます。RSPAN トンネルは SPAN セッションの宛先インターフェイスとして設定され、ST ポートは SPAN トラフィックを RSPAN トンネル経由で転送します(図 53-16 を参照)。

図 53-16 送信元スイッチが 1 台、宛先スイッチが 1 台、トンネルが 1 本の場合の RSPAN シナリオ

 

 

単一の送信元と複数の RSPAN トンネル

図 53-17 に、スイッチ S とスイッチ N の間に設定された 2 本の独立した RSPAN トンネルを示します。各トンネルの関連 ST ポートは送信元スイッチ内に存在し、独立 SD ポートは宛先スイッチ内に存在します。この設定は、トラブルシューティングの場合に役立ちます。

図 53-17 送信元スイッチが 1 台、宛先スイッチが 1 台、トンネルが複数の場合の RSPAN シナリオ

 

複数の送信元と複数の RSPAN トンネル

図 53-18 に、スイッチ S1 とスイッチ S2 の間に設定された 2 本の独立した RSPAN トンネルを示します。これらのトンネルは、関連 ST ポートがそれぞれ別々の送信元スイッチ内に存在し、両方とも宛先スイッチ内にある同じ SD ポートで終端します。

図 53-18 送信元スイッチが 2 台、宛先スイッチが 1 台、トンネルが複数の場合の RSPAN シナリオ

 

 

この設定は、リモート モニタリングの場合に役立ちます。たとえば、管理者は宛先スイッチからリモートで 2 台の送信元スイッチをモニタできます。

RSPAN 情報の表示

設定された RSPAN 情報を表示するには、 show コマンド セットを使用します。例 53-10 53-16 を参照してください。

例 53-10 ST ポート インターフェイス情報の表示

switch# show interface brief
 
-------------------------------------------------------------------------------
Interface Vsan Admin Admin Status Oper Oper Port-channel
Mode Trunk Mode Speed
Mode (Gbps)
-------------------------------------------------------------------------------
fc1/1 1 auto on trunking TE 2 --
...
fc1/14 1 auto on trunking TE 2 --
fc1/15 1 ST on up ST 2 --
...
fc2/9 1 auto on trunking TE 2 port-channel 21
fc2/10 1 auto on trunking TE 2 port-channel 21
...
fc2/13 999 auto on up F 1 --
fc2/14 999 auto on up FL 1 --
fc2/15 1 SD -- up SD 2 --
fc2/16 1 auto on trunking TE 2 --
--------------------------------------------------------------------------------------
Interface Status Speed
(Gbps)
--------------------------------------------------------------------------------------
sup-fc0 up 1
 
--------------------------------------------------------------------------------------
Interface Status IP Address Speed MTU
--------------------------------------------------------------------------------------
mgmt0 up 172.22.36.175/22 100 Mbps 1500
 
--------------------------------------------------------------------------------------
Interface Status IP Address Speed MTU--
--------------------------------------------------------------------------------------
vsan5 up 10.10.10.1/24 1 Gbps 1500
--------------------------------------------------------------------------------------
Interface Vsan Admin Status Oper Oper
Trunk Mode Speed
Mode (Gbps)
--------------------------------------------------------------------------------------
port-channel 21 1 on trunking TE 4
--------------------------------------------------------------------------------------
Interface Status Dest IP Addr Src IP Addr TID Explicit Path
--------------------------------------------------------------------------------------
fc-tunnel 100 up 10.10.10.2 10.10.10.1 100

例 53-11 ST ポートインターフェイスの詳細情報の表示

switch# show interface fc1/11
fc1/11 is up
Hardware is Fibre Channel
Port WWN is 20:0b:00:05:30:00:59:de
Admin port mode is ST
Port mode is ST
Port vsan is 1
Speed is 1 Gbps
Rspan tunnel is fc-tunnel 100
Beacon is turned off
5 minutes input rate 248 bits/sec, 31 bytes/sec, 0 frames/sec
5 minutes output rate 176 bits/sec, 22 bytes/sec, 0 frames/sec
6862 frames input, 444232 bytes
0 discards, 0 errors
0 CRC, 0 unknown class
0 too long, 0 too short
6862 frames output, 307072 bytes
0 discards, 0 errors
0 input OLS, 0 LRR, 0 NOS, 0 loop inits
0 output OLS, 0 LRR, 0 NOS, 0 loop inits
 

例 53-12 FC トンネル ステータスの表示

switch# show fc-tunnel
fc-tunnel is enabled
 

例 53-13 FC トンネル出力マッピング情報の表示

switch# show fc-tunnel tunnel-id-map
tunnel id egress interface
150 fc3/1
100 fc3/1
 

) 複数のトンネル ID を同じインターフェイスで終端させることができます。


例 53-14 FC トンネルの明示的なマッピング情報の表示

switch# show fc-tunnel explicit-path
Explicit path name: Alternate1
10.20.1.2 loose
10.20.1.3 strict
Explicit path name: User2
10.20.50.1 strict
10.20.50.4 loose
 

例 53-15 SPAN マッピング情報の表示

switch# show span session
Session 2 (active)
Destination is fc-tunnel 100
No session filters configured
Ingress (rx) sources are
fc2/16,
Egress (tx) sources are
fc2/16,
 

例 53-16 FC トンネル インターフェイスの表示

switch# show interface fc-tunnel 200
fc-tunnel 200 is up
Dest IP Addr: 200.200.200.7 Tunnel ID: 200
Source IP Addr: 200.200.200.4 LSP ID: 1
Explicit Path Name:

SPAN および RSPAN のデフォルト設定

表 53-1 に、SPAN パラメータのデフォルト設定値を示します。

 

表 53-1 SPAN パラメータのデフォルト設定値

パラメータ
デフォルト

SPAN セッション

アクティブ

フィルタが指定されていない場合

SPAN トラフィックには、すべてのアクティブ VSAN から特定のインターフェイスを経由するトラフィックが含まれます。

カプセル化

ディセーブル

SD ポート

出力フレーム形式はファイバ チャネルです。

表 53-2 に、RSPAN パラメータのデフォルト設定を示します。

 

表 53-2 RSPAN パラメータのデフォルト設定値

パラメータ
デフォルト

FC トンネル

ディセーブル

明示パス

設定されていません。

最小コスト パス

明示パスが設定されていない場合に使用されます。