Cisco MDS 9000 ファミリ CLI コンフィギュレーション ガイド リリース 3.x Cisco MDS SAN-OS for Release 3.0(1) ~ 3.3(3)
オンデマンド ポート アクティベーション ライセンス
オンデマンド ポート アクティベーション ライセンス
発行日;2013/09/03 | 英語版ドキュメント(2011/01/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

オンデマンド ポート アクティベーション ライセンス

オンデマンド ポート アクティベーション ライセンスの概要

ポート命名規則

ポート ライセンス

デフォルト設定

ライセンス ステータスの定義

ポート アクティベーション ライセンスの設定

ライセンスを受信するためのポートの設定

ポートのライセンスの取得

ポート間のライセンスの移動

オンデマンド ポート アクティベーション ライセンスの例

オンデマンド ポート アクティベーション ライセンス

この章では、Cisco MDS 9124 ファブリック スイッチ、Cisco MDS 9134 ファブリック スイッチ、HP c-Class BladeSystem 用シスコ ファブリック スイッチ、および IBM BladeCenter 用シスコ ファブリック スイッチのオンデマンド ポート アクティベーション ライセンス機能の使用方法について説明します。この章の内容は、次のとおりです。

「オンデマンド ポート アクティベーション ライセンスの概要」

「ポート アクティベーション ライセンスの設定」

「オンデマンド ポート アクティベーション ライセンスの例」

オンデマンド ポート アクティベーション ライセンスの概要

Cisco MDS SAN-OS Release 3.1(1) では、必要に応じて追加のポート ライセンスをユーザが購入してインストールできるようにすることによって、SAN 接続を拡張できます。デフォルトでは、すべてのポートでライセンスをアクティブにできます。Cisco MDS 9124 ファブリック スイッチでは、ライセンスは順次割り当てられます。ただし、スイッチでライセンスを受信できるポートにライセンスを移動したり、再度割り当てたりできます。

Cisco MDS 9134 ファブリック スイッチでは、最初の 32 ポートが 1 Gbps、2 Gbps、または 4 Gbps で動作します。スイッチには、10 Gbps で動作する 2 つのポートがあります。ライセンスは順次割り当てられます。

HP c-Class BladeSystem 用のシスコ ファブリック スイッチおよび IBM BladeCenter 用のシスコ ファブリック スイッチでは、ポートが起動するときに内部ポートのライセンスが割り当てられます。外部ポートのライセンスは、順次割り当てられます。

ポート命名規則

表 4-1 に、4 機種のシスコ ファブリック スイッチのポート命名規則を示します。

 

表 4-1 シスコ ファブリック スイッチのポート命名規則

Cisco MDS 9124 スイッチ
Cisco MDS 9134 スイッチ
HP c-Class BladeSystem 用の Cisco ファブリック スイッチ
IBM BladeCenter 用のシスコ ファブリック スイッチ

fc1/1 ~ fc1/24

fc1/1 ~ fc1/34

内部ポート:bay1 ~ bay16

内部ポート:bay1 ~ bay14

外部ポート:ext1 ~ ext8

外部ポート:ext0、ext15 ~ ext19

ポート ライセンス

Cisco MDS 9124 スイッチでは、最初の 8 つのポートがデフォルトでライセンスされています。すぐに追加のポートをアクティブにしたり、ライセンスを受け取れないようにポートを設定したり、ポート ライセンスを移動したりする場合を除いて、デフォルト設定以外に行う必要がある作業はありません。

図 4-1 に、Cisco MDS 9124 スイッチのデフォルトでライセンスされているポートを示します。

図 4-1 Cisco MDS 9124 スイッチのデフォルト ポート ライセンス(fc1/1 ~ fc1/8)

 

追加の接続が必要な場合、それぞれにオンデマンド ポート アクティベーション ライセンスが付いた追加のポートを 8 ポート単位でアクティブにします(最大合計 24 ポート)。

Cisco MDS 9134 スイッチでは、1 Gbps、2 Gbps、または 4 Gbps で動作する最初の 24 ポートがデフォルトでライセンスされています。追加の接続が必要な場合、1 つのオンデマンド ポート アクティベーション ライセンスが付いた残りの 8 つのポートをアクティブにできます。別個の 10G ライセンス ファイルは、残りの 2 つの 10-Gbps ポートをアクティブにするのに必要です。

図 4-2 に、Cisco MDS 9134 スイッチのデフォルトでライセンスされているポートを示します。

図 4-2 Cisco MDS 9134 スイッチのデフォルト ポート ライセンス(fc1/1 ~ fc1/24)

 

図 4-3 に、HP c-Class BladeSystem 用シスコ ファブリック スイッチのデフォルトでライセンスされている外部ポートを示します。

図 4-3 HP c-Class BladeSystem 用シスコ ファブリック スイッチのデフォルト ポート ライセンス(ext1 ~ ext4)

 

HP c-Class BladeSystem 用シスコ ファブリック スイッチの場合、8 つの内部ポートと外部ポート(ext1 ~ ext4)がデフォルトでライセンスされています。残りの 8 つの内部ポートおよび 4 つの外部ポートを使用するのに、単一のオンデマンド ポート アクティベーション ライセンスが必要です。

IBM BladeCenter 用シスコ ファブリック スイッチの場合、7 つの内部ポートと外部ポート(ext0、ext15、および ext16)がデフォルトでライセンスされています。残りの 7 つの内部ポートおよび 3 つの外部ポートを使用するのに、単一のオンデマンド ポート アクティベーション ライセンスが必要です。

図 4-4 に、IBM BladeCenter 用シスコ ファブリック スイッチのデフォルトでライセンスされている外部ポートを示します。

図 4-4 IBM BladeCenter 用シスコ ファブリック スイッチのデフォルト ポート ライセンス(ext0、ext15 ~ ext16)

 

デフォルトの動作を受け入れず、特定のポートにライセンスを割り当てる場合、ライセンスを受信しないようにポートを設定する場合、またはポート間でライセンスを移動する場合は、「ポート アクティベーション ライセンスの設定」を参照してください。

デフォルト設定

図 4-1例 4-1 に、Cisco MDS 9124 スイッチのデフォルトのポート ライセンス設定を示します。

例 4-1 Cisco MDS 9124 スイッチのデフォルトのポート ライセンス設定

switch# show port-license
Available port activation licenses are 0
----------------------------------------------------
Interface Cookie Port Activation License
----------------------------------------------------
fc1/1 16777216 acquired
fc1/2 16781312 acquired
fc1/3 16785408 acquired
fc1/4 16789504 acquired
fc1/5 16793600 acquired
fc1/6 16797696 acquired
fc1/7 16801792 acquired
fc1/8 16805888 acquired
fc1/9 16809984 eligible
fc1/10 16814080 eligible
fc1/11 16818176 eligible
fc1/12 16822272 eligible
fc1/13 16826368 eligible
fc1/14 16830464 eligible
fc1/15 16834560 eligible
fc1/16 16838656 eligible
fc1/17 16842752 eligible
fc1/18 16846848 eligible
fc1/19 16850944 eligible
fc1/20 16855040 eligible
fc1/21 16859136 eligible
fc1/22 16863232 eligible
fc1/23 16867328 eligible
fc1/24 16871424 eligible
 

) ライセンスを取得するために Cookie が使用されます。取得したライセンスの Cookie を表示するには、show license usage PORT_ACTIVATION_PKG コマンドを使用します。


switch# show license usage PORT_ACTIVATION_PKG
Application
-----------
16777216
16797696
16781312
16793600
16785408
16805888
16789504
16801792
-----------
 

図 4-1例 4-2 に、Cisco MDS 9134 スイッチのデフォルトのポート ライセンス設定を示します。

例 4-2 Cisco MDS 9134 スイッチのデフォルトのポート ライセンス設定

switch# show port-license
Available port activation licenses are 0
Available 10G port activation licenses are 0
---------------------------------------------------
Interface Cookie Port Activation License
---------------------------------------------------
fc1/1 16777216 acquired
fc1/2 16781312 acquired
fc1/3 16785408 acquired
fc1/4 16789504 acquired
fc1/5 16793600 acquired
fc1/6 16797696 acquired
fc1/7 16801792 acquired
fc1/8 16805888 acquired
fc1/9 16809984 acquired
fc1/10 16814080 acquired
fc1/11 16818176 acquired
fc1/12 16822272 acquired
fc1/13 16826368 acquired
fc1/14 16830464 acquired
fc1/15 16834560 acquired
fc1/16 16838656 acquired
fc1/17 16842752 acquired
fc1/18 16846848 acquired
fc1/19 16850944 acquired
fc1/20 16855040 acquired
fc1/21 16859136 acquired
fc1/22 16863232 acquired
fc1/23 16867328 acquired
fc1/24 16871424 acquired
fc1/25 16875520 eligible
fc1/26 16879616 eligible
fc1/27 16883712 eligible
fc1/28 16887808 eligible
fc1/29 16891904 eligible
fc1/30 16896000 eligible
fc1/31 16900096 eligible
fc1/32 16904192 eligible
fc1/33 16908288 eligible
fc1/34 16912384 eligible
 

) ライセンスを取得するために Cookie が使用されます。取得したライセンスの Cookie を表示するには、show license usage PORT_ACTIVATION_PKG コマンドを使用します。


switch# show license usage PORT_ACTIVATION_PKG
Application
-----------
16777216
16797696
16781312
16793600
16785408
16805888
16789504
16801792
16809984
16859136
16814080
16826368
16838656
16834560
16842752
16818176
16822272
16830464
16855040
16850944
16846848
16867328
16871424
16863232
-----------
 

例 4-3 に、HP c-Class BladeSystem 用シスコ ファブリック スイッチのデフォルトのポート ライセンス設定を示します。


) 起動する最初の 8 個の内部ポートがライセンスを取得します。


例 4-3 HP c-Class BladeSystem 用シスコ ファブリック スイッチのデフォルトのポート ライセンス設定

switch# show port-license
Available ext port activation licenses are 0
Available bay port activation licenses are 0
---------------------------------------------------
Interface Cookie Port Activation License
---------------------------------------------------
bay1 16838656 acquired
bay2 16834560 eligible
bay3 16818176 acquired
bay4 16809984 eligible
bay5 16789504 acquired
bay6 16781312 eligible
bay7 16805888 eligible
bay8 16863232 acquired
bay9 16850944 acquired
bay10 16842752 acquired
bay11 16822272 acquired
bay12 16826368 eligible
bay13 16785408 acquired
bay14 16797696 eligible
bay15 16801792 eligible
bay16 16859136 eligible
ext1 16814080 acquired
ext2 16830464 acquired
ext3 16846848 acquired
ext4 16855040 acquired
ext5 16871424 eligible
ext6 16867328 eligible
ext7 16793600 eligible
ext8 16777216 eligible
 

) ライセンスを取得するために Cookie が使用されます。取得したライセンスの Cookie を表示するには、show license usage PORT_ACTIVATION_PKG コマンドを使用します。


switch# show license usage PORT_ACTIVATION_PKG
Application
-----------
16785408
16789504
16793600
16814080
16818176
16822272
16838656
16842752
16850944
16863232
16867328
16855040
-----------
 

例 4-4 に、IBM BladeCenter 用シスコ ファブリック スイッチのデフォルトのポート ライセンス設定を示します。


) 起動する最初の 7 個の内部ポートがライセンスを取得します。


例 4-4 IBM BladeCenter 用シスコ ファブリック スイッチのデフォルトのライセンス設定

switch# show port-license
Available ext port activation licenses are 0
Available bay port activation licenses are 0
---------------------------------------------------
Interface Cookie Port Activation License
---------------------------------------------------
bay1 16850944 eligible
bay2 16838656 eligible
bay3 16842752 acquired
bay4 16834560 eligible
bay5 16822272 acquired
bay6 16818176 eligible
bay7 16826368 acquired
bay8 16809984 eligible
bay9 16797696 acquired
bay10 16781312 eligible
bay11 16785408 acquired
bay12 16789504 eligible
bay13 16801792 acquired
bay14 16805888 acquired
ext0 16846848 acquired
ext15 16855040 acquired
ext16 16830464 acquired
ext17 16814080 eligible
ext18 16793600 eligible
ext19 16777216 eligible
 

) ライセンスを取得するために Cookie が使用されます。取得したライセンスの Cookie を表示するには、show license usage PORT_ACTIVATION_PKG コマンドを使用します。


switch# show license usage PORT_ACTIVATION_PKG
Application
-----------
16830464
16826368
16818176
16822272
16834560
16838656
16846848
16850944
16855040
16842752
-----------

ライセンス ステータスの定義

表 4-2 に、ポート アクティベーション ライセンス ステータスの用語を定義します。

 

表 4-2 ポート アクティベーション ライセンス ステータスの定義

ポート アクティベーション ライセンス ステータス
定義

acquired

ポートがライセンスされており、アクティブな状態です。

eligible

ポートはライセンスを受信できますが、まだ受信していません。

PORT_ACTIVATION_PKG およびライセンス キー ファイルを取得およびインストールする方法については、「ライセンスの入手とインストール」を参照してください。

ineligible

ポートはライセンスを受信できません。

デフォルトでは、追加のポート ライセンス アクティベーション パッケージをインストールすると、ポートのアクティベーション ステータスが「eligible」から「acquired」に変化します。デフォルトの動作を受け入れる場合、それ以上の動作は必要ありません。


) 使用中でないポートのライセンスはアンインストールできますが、デフォルトのラインセンスはアンインストールできません。


表 4-3 に、Cisco MDS 9124 スイッチのポート ライセンス割り当てを示します。

 

表 4-3 Cisco MDS 9124 スイッチのデフォルトのポート ライセンス割り当て

ライセンス パッケージ(PORT_ACTIVATION_PKG)
Cisco MDS 9124 スイッチのポートへの割り当て

デフォルト

1 ~ 8

最初の PORT_ACTIVATION_PKG

9 ~ 16

2 番目の PORT_ACTIVATION_PKG

17 ~ 24

show license usage コマンドを使用して、スイッチに割り当てられているライセンスを表示できます。ライセンスが使用中の場合、表示される状態は「In use」です。ライセンスがインストールされ、ライセンスを取得しているポートがない場合、表示される状態は「Unused」です。

Cisco MDS 9124 スイッチのデフォルト ライセンス パッケージは次のとおりです。

 
switch# show license usage
 
Feature Ins Lic Status Expiry Date Comments
Count
--------------------------------------------------------------------------------
FM_SERVER_PKG Yes - Unused never -
ENTERPRISE_PKG Yes - In use never -
PORT_ACTIVATION_PKG No 8 In use never -
10G_PORT_ACTIVATION_PKG No 0 Unused -
--------------------------------------------------------------------------------
 

) デフォルト ライセンスだけがインストールされている場合、PORT_ACTIVATION_PKG はインストール済みとして表示されません。


表 4-4 に、Cisco MDS 9134 スイッチのポート ライセンス割り当てを示します。

 

表 4-4 Cisco MDS 9134 スイッチのデフォルトのポート ライセンス割り当て

ライセンス パッケージ(PORT_ACTIVATION_PKG)
Cisco MDS 9134 スイッチのポートへの割り当て

デフォルト

1-24

PORT_ACTIVATION_PKG

25 ~ 32

10G_PORT_ACTIVATION_PKG

33 ~ 34

show license usage コマンドを使用して、スイッチに割り当てられているライセンスを表示できます。ライセンスが使用中の場合、表示される状態は「In use」です。ライセンスがインストールされ、ライセンスを取得しているポートがない場合、表示される状態は「Unused」です。

Cisco MDS 9134 スイッチのデフォルト ライセンス パッケージは次のとおりです。

 
switch# show license usage
 
Feature Ins Lic Status Expiry Date Comments
Count
--------------------------------------------------------------------------------
FM_SERVER_PKG Yes - Unused never -
ENTERPRISE_PKG Yes - In use never -
PORT_ACTIVATION_PKG No 24 In use never -
10G_PORT_ACTIVATION_PKG yes 2 Unused never -
--------------------------------------------------------------------------------
 

) デフォルト ライセンスだけがインストールされている場合、PORT_ACTIVATION_PKG はインストール済みとして表示されません。


表 4-5 に、HP c-Class BladeSystem 用シスコ ファブリック スイッチのポート ライセンス割り当てを示します。

 

表 4-5 HP c-Class BladeSystem 用シスコ ファブリック スイッチのデフォルトのポート ライセンス割り当て

ライセンス パッケージ(PORT_ACTIVATION_PKG)
HP c-Class BladeSystem 用シスコ ファブリック スイッチのポートへの割り当て

デフォルト

任意の 8 つの内部ポートと 4 つの外部ポート ext1 ~ ext4。

PORT_ACTIVATION_PKG

残りの 8 つの内部ポートおよび 4 つの外部ポートに 1 つのライセンスが必要です。

show license usage コマンドを使用して、スイッチに割り当てられているライセンスを表示できます。HP c-Class BladeSystem 用シスコ ファブリック スイッチのデフォルトのライセンス パッケージは、次のとおりです。
 
switch# show license usage
 
Feature Ins Lic Status Expiry Date Comments
Count
--------------------------------------------------------------------------------
FM_SERVER_PKG No - Unused -
ENTERPRISE_PKG No - Unused -
PORT_ACTIVATION_PKG No 12 In use never -
10G_PORT_ACTIVATION_PKG No 0 Unused -
--------------------------------------------------------------------------------
 

) デフォルト ライセンスだけがインストールされている場合、PORT_ACTIVATION_PKG はインストール済みとして表示されません。


表 4-6 に、IBM BladeCenter 用シスコ ファブリック スイッチのポート ライセンス割り当てを示します。

 

表 4-6 IBM BladeCenter 用シスコ ファブリック スイッチのデフォルトのポート ライセンス割り当て

ライセンス パッケージ(PORT_ACTIVATION_PKG)
IBM BladeCenter 用シスコ ファブリック スイッチのポートへの割り当て

デフォルト

任意の 7 つの内部ポートと 3 つの外部ポート ext0、ext15、および ext16。

PORT_ACTIVATION_PKG

残りの 7 つの内部ポートおよび 3 つの外部ポートに 1 つのライセンスが必要です。

show license usage コマンドを使用して、スイッチに割り当てられているライセンスを表示できます。IBM BladeCenter 用シスコ ファブリック スイッチのデフォルトのライセンス パッケージは、次のとおりです。
 
switch# show license usage
 
Feature Ins Lic Status Expiry Date Comments
Count
--------------------------------------------------------------------------------
FM_SERVER_PKG No - Unused -
ENTERPRISE_PKG No - Unused -
PORT_ACTIVATION_PKG No 10 In use never -
10G_PORT_ACTIVATION_PKG No 0 Unused -
--------------------------------------------------------------------------------
 

) デフォルト ライセンスだけがインストールされている場合、PORT_ACTIVATION_PKG はインストール済みとして表示されません。


ポート アクティベーション ライセンスの設定

ここでは、次の内容について説明します。

「ライセンスを受信するためのポートの設定」

「ポートのライセンスの取得」

「ポート間のライセンスの移動」

ライセンスを受信するためのポートの設定

デフォルトでは、すべてのポートがライセンスを受信できます。ただし、ライセンスを受信できないように設定されているポートをアクティブにする場合は、port-license コマンドを使用して、そのポートでライセンスを受信できるように設定する必要があります。

ライセンスを取得できるようにポートを設定するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ライセンスを取得できるように設定するポート インターフェイスを指定します。

(注) ポートの名前は、使用しているスイッチによって異なります。ポート名については、「ポート命名規則」を参照してください。

ステップ 3

switch(config-if)# port-license

ライセンスを取得できるようにポートを設定します。

 

switch(config-if)# no port-license

ライセンスがすでに割り当てられている場合はポートからライセンスを削除し、ライセンスを取得できないようにポートを設定します。

(注) 管理上のシャットダウン状態にないポートだけからライセンスを削除できます。

ポートのライセンスの取得

デフォルトのオンデマンド ポート ライセンスの割り当てを受け入れない場合は、まずライセンスを移動するポートのライセンスを取得する必要があります。

ポートのライセンスを取得するには、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t
switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ライセンスを取得できるように設定するポート インターフェイスを指定します。

(注) ポートの名前は、使用しているスイッチによって異なります。ポート名については、「ポート命名規則」を参照してください。

ステップ 3

switch(config-if)# port-license acquire

ポートまたはポート範囲にライセンスを付与します。

 

switch(config-if)# no port-license

ポートまたはポート範囲からライセンスを削除します。

ポート間のライセンスの移動


) HP c-Class BladeSystem 用のシスコ ファブリック スイッチおよび IBM BladeCenter 用のシスコ ファブリック スイッチでは、内部ポートのライセンスを内部ポート間でのみ移動できます。内部ポートのライセンスを外部ポートに移動したり、その逆に移動することはできません。外部ポートのライセンスは外部ポート間でのみ移動できます。


ポート(またはポート範囲)からライセンスをいつでも移動できます。ポートにライセンスを移動しようとし、ライセンスが使用可能でない場合、スイッチはメッセージ「port activation license not available」を返します。


) 内部ポートは、HP c-Class BladeSystem 用のシスコ ファブリック スイッチまたは IBM BladeCenter 用のシスコ ファブリック スイッチでライセンスされると、ユーザが copy running-config startup-config コマンドを入力した場合に、次のリロード時に、これらのポートでライセンスを保持します。


1 個のポートから別のポートにライセンスを移動するには(この例では、fc1/1 ~ fc1/24)、次の手順を実行します。

 
コマンド
目的

ステップ 1

switch# config t

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

ライセンスの移動元のポート インターフェイスを指定します。

(注) ポートの名前は、使用しているスイッチによって異なります。ポート名の詳細については、「ポート命名規則」を参照してください。

ステップ 3

switch(config-if)# no port-license

ライセンスをポート fc1/1 から削除し、ライセンスを取得できないようにポートを設定します。

(注) このコマンドを有効にするには、ポートをシャットダウンする必要があります。

ステップ 4

switch(config-if)# exit

switch(config)#

fc1/1 のインターフェイス モードを終了します。

ステップ 5

switch(config)# interface fc1/24

switch(config-if)#

ライセンスの移動先のポート インターフェイスを指定します。

(注) ポートの名前は、使用しているスイッチによって異なります。ポート名については、「ポート命名規則」を参照してください。

ステップ 6

switch(config-if)# port-license acquire

ポート fc1/24 にライセンスを許可します。

(注) このコマンドを有効にするには、ポートをシャットダウンする必要があります。

ステップ 7

switch(config-if)# end

EXEC モードに戻ります。

オンデマンド ポート アクティベーション ライセンスの例

次に、次のタスクを実行する例を示します。

ポートを不適格にします

ポート アクティベーション ライセンスをインストールします

1 個のポートから別のポートにライセンスを移動します

デフォルトの動作を受け入れない場合、またはライセンスを取得するポートについて柔軟性が必要な場合は、ポートを不適格にする必要がある場合があります。たとえば、最初の 8 ポートにライセンスがあり、ポート 7 からポート 9 にライセンスを移動する場合は、そのポートを不適格にする必要があります。または、ライセンスを取得しないポートがある場合、そのポートを不適格にすることができ、そのポートは追加ライセンスのインストール時にライセンスの候補になりません。

この例は、Cisco MDS 9124 スイッチのデフォルト設定に基づいています。


ステップ 1 デフォルトのポート ライセンス設定を表示します。

switch# show port-license
Available port activation licenses are 0
----------------------------------------------------
Interface Cookie Port Activation License
----------------------------------------------------
fc1/1 16777216 acquired
fc1/2 16781312 acquired
fc1/3 16785408 acquired
fc1/4 16789504 acquired
fc1/5 16793600 acquired
fc1/6 16797696 acquired
fc1/7 16801792 acquired
fc1/8 16805888 acquired
fc1/9 16809984 eligible
fc1/10 16814080 eligible
fc1/11 16818176 eligible
fc1/12 16822272 eligible
fc1/13 16826368 eligible
fc1/14 16830464 eligible
fc1/15 16834560 eligible
fc1/16 16838656 eligible
fc1/17 16842752 eligible
fc1/18 16846848 eligible
fc1/19 16850944 eligible
fc1/20 16855040 eligible
fc1/21 16859136 eligible
fc1/22 16863232 eligible
fc1/23 16867328 eligible
fc1/24 16871424 eligible

 

ステップ 2 追加ライセンス パッケージをインストールします。PORT_ACTIVATION_PKG およびライセンス キー ファイルを取得およびインストールする方法については、「ライセンスの入手とインストール」を参照してください。

switch# install license bootflash:license_file.lic
Installing license ..done
 

) ライセンス キー ファイルにターゲット名を指定する場合、ファイルは指定された名前でインストールされます。そうしない場合、ライセンス キー ファイルに指定されたファイル名がライセンスのインストールに使用されます。


ステップ 3 ライセンスを取得できないようにポート fc1/8 を設定します。


) ポートを不適格にすると、ライセンスは別のポートに自動的に転送されません。


switch# config t
Enter configuration commands, one per line.End with CNTL/Z.
switch(config)# interface fc1/8
switch(config-if)# no port-license
switch(config-if)# end
switch# show port-license
Available port activation licenses are 1
----------------------------------------------------
Interface Cookie Port Activation License
----------------------------------------------------
fc1/1 16777216 acquired
fc1/2 16781312 acquired
fc1/3 16785408 acquired
fc1/4 16789504 acquired
fc1/5 16793600 acquired
fc1/6 16797696 acquired
fc1/7 16801792 acquired
fc1/8 16805888 ineligible
fc1/9 16809984 eligible
fc1/10 16814080 eligible
 

ステップ 4 ライセンス付き機能を表示して、正常に PORT_ACTIVATION_PKG をインストールしたことを確認します。

switch# show license default
Feature Default License Count
-----------------------------------------------------------------------------
FM_SERVER_PKG -
ENTERPRISE_PKG -
PORT_ACTIVATION_PKG 8
10G_PORT_ACTIVATION_PKG 0
switch# ---------------------------------------------------------------------
 

ステップ 5 ポート ライセンス設定を表示して、追加ポートがライセンスを取得していることを確認します。


ポート fc1/8 は不適格のままで、1 ライセンスは使用可能です。ポート fc1/9 ~ fc1/16、追加ライセンスを取得しました。


switch# show port-license
Available port activation licenses are 1
----------------------------------------------------
Interface Cookie Port Activation License
----------------------------------------------------
fc1/1 16777216 acquired
fc1/2 16781312 acquired
fc1/3 16785408 acquired
fc1/4 16789504 acquired
fc1/5 16793600 acquired
fc1/6 16797696 acquired
fc1/7 16801792 acquired
fc1/8 16805888 ineligible
fc1/9 16809984 acquired
fc1/10 16814080 acquired
fc1/11 16818176 acquired
fc1/12 16822272 acquired
fc1/13 16826368 acquired
fc1/14 16830464 acquired
fc1/15 16834560 acquired
fc1/16 16838656 acquired
fc1/17 16842752 eligible
fc1/18 16846848 eligible
fc1/19 16850944 eligible
fc1/20 16855040 eligible
fc1/21 16859136 eligible
fc1/22 16863232 eligible
fc1/23 16867328 eligible
fc1/24 16871424 eligible
 

ステップ 6 ポート fc1/17 に残りのライセンスを移動します。

switch# config t
switch(config)# interface fc1/17
switch(config-int)# port-license acquire
 

ステップ 7 ポート ライセンス設定を表示して、ポート fc1/17 がライセンスを取得していることを確認します。

switch# show port-license
Available port activation licenses are 0
----------------------------------------------------
Interface Cookie Port Activation License
----------------------------------------------------
fc1/1 16777216 acquired
fc1/2 16781312 acquired
fc1/3 16785408 acquired
fc1/4 16789504 acquired
fc1/5 16793600 acquired
fc1/6 16797696 acquired
fc1/7 16801792 acquired
fc1/8 16805888 ineligible
fc1/9 16809984 acquired
fc1/10 16814080 acquired
fc1/11 16818176 acquired
fc1/12 16822272 acquired
fc1/13 16826368 acquired
fc1/14 16830464 acquired
fc1/15 16834560 acquired
fc1/16 16838656 acquired
fc1/17 16842752 acquired
fc1/18 16846848 eligible
fc1/19 16850944 eligible
fc1/20 16855040 eligible
fc1/21 16859136 eligible
fc1/22 16863232 eligible
fc1/23 16867328 eligible
fc1/24 16871424 eligible
 

ステップ 8 不揮発性ストレージに新しいポート ライセンス設定を保存して、この設定をスタートアップ コンフィギュレーションにします。この手順を完了すると、実行コンフィギュレーションとスタートアップ コンフィギュレーションのコピーは同一になります。

switch# copy running-config startup-config
 

ステップ 9 show running config コマンドを入力して、実行コンフィギュレーションのライセンスを表示または確認します。

switch# show running config
...
interface fc1/1
switchport trunk mode auto
port-license acquire
channel-group 122 force
no shutdown
 
interface fc1/2
switchport trunk mode auto
port-license acquire
channel-group 122 force
no shutdown
 
interface fc1/3
switchport trunk mode auto
port-license acquire
no shutdown
 
interface fc1/4
port-license acquire
no shutdown
 
interface fc1/5
switchport trunk mode auto
port-license acquire
port-track interface fc1/13
port-track interface fc1/21
port-track interface fc1/24
port-track interface port-channel 122
no shutdown
 
interface fc1/6
switchport trunk mode off
port-license acquire
fcsp auto-active
no shutdown