Cisco MDS 9000 ファミリ CLI コンフィギュレーション ガイド リリース 3.x Cisco MDS SAN-OS for Release 3.0(1) ~ 3.3(3)
ギガビット イーサネット インターフェイスでの IPv4 の設定
ギガビット イーサネット インターフェイスでの IPv4 の設定
発行日;2013/09/03 | 英語版ドキュメント(2011/01/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

ギガビット イーサネット インターフェイスでの IPv4 の設定

IPv4 の概要

ギガビット イーサネット インターフェイスでの IPv4 の基本設定

インターフェイスの説明の設定

標識モードの設定

自動ネゴシエーションの設定

MTU フレーム サイズの設定

無差別モードの設定

ギガビット イーサネット接続の確認

VLAN

ギガビット イーサネットの VLAN の概要

VLAN サブインターフェイスの設定

インターフェイス サブネットの要件

スタティック IPv4 ルーティングの設定

IPv4 ルート テーブルの表示

IPv4-ACL

ギガビット イーサネットの IPv4-ACL に関する注意事項

ギガビット イーサネット インターフェイスへの IPv4-ACL の適用

ARP キャッシュ

ARP キャッシュの表示

ARP キャッシュのクリア

IPv4 統計情報の表示

デフォルト設定

ギガビット イーサネット インターフェイスでの IPv4 の設定

Cisco MDS 9000 ファミリはギガビット イーサネット インターフェイス上で IP バージョン 4(IPv4)をサポートしています。この章では、IPv4 アドレスおよびその他の IPv4 機能の設定方法について説明します。

この章では、次の事項について説明します。

「IPv4 の概要」

「ギガビット イーサネット インターフェイスでの IPv4 の基本設定」

「ギガビット イーサネット接続の確認」

「VLAN」

「スタティック IPv4 ルーティングの設定」

「IPv4-ACL」

「ARP キャッシュ」

「IPv4 統計情報の表示」

「デフォルト設定」

IPv4 の概要

FCIP と iSCSI は両方とも TCP/IP を使用してネットワーク接続を行います。各 IPS モジュールまたは MPS-14/2 モジュールでは、ギガビット イーサネット インターフェイスを適切に設定することにより、接続を行います。ここでは、FCIP および iSCSI で IP を使用するように設定するための手順について説明します。


) FCIP の設定については、「FCIP の設定」を参照してください。iSCSI の設定については、「iSCSI の設定」を参照してください。


IPS モジュールまたは MPS-14/2 モジュールのギガビット イーサネット ポート用に、IPS という新しいポート モードが定義されています。IPS ポートは、暗黙的に IPS モードに設定されているため、iSCSI および FCIP ストレージ機能を実行する場合だけ使用できます。IPS ポートでは、イーサネット フレームのブリッジングや、他の IP パケットのルーティングは行われません。

各 IPS ポートはファイバ チャネル SAN 内の 1 つの仮想ファイバ チャネル ホストを表します。この IPS ポートに接続されているすべての iSCSI ホストは、この 1 つのファイバ チャネル ホストを介して統合および多重化されます。

ファイバ チャネル ストレージ サブシステムですべてのホスト デバイスの明示的な LUN アクセス コントロールが必要ない大規模な iSCSI 導入では、プロキシ イニシエータ モードを使用すると設定が簡単になります。


) MPS-14/2 モジュールのギガビット イーサネット インターフェイスは EtherChannel をサポートしていません。



) ギガビット イーサネット インターフェイスで IPv6 を設定する場合は、「IPv6 アドレッシングの設定および IPv6 ルーティングのイネーブル化」を参照してください。



ヒント IPS モジュールまたは MPS-14/2 モジュールのギガビット イーサネット ポートは、管理イーサネット ポートと同じイーサネット ブロードキャスト ドメイン内に設定しないでください。異なるスタンドアロン ハブまたはスイッチを使用するか、または異なる VLAN を使用して、異なるブロードキャスト ドメインに設定する必要があります。

ギガビット イーサネット インターフェイスでの IPv4 の基本設定

図 46-1 に、IP バージョン 4(IPv4)でのギガビット イーサネットの設定例を示します。

図 46-1 IPv4 でのギガビット イーサネットの設定例

 

 


) MDS ギガビット イーサネット インターフェイスが接続されているイーサネット スイッチ上のポートは、スイッチ ポートの代わりにホスト ポート(アクセス ポートともいう)として設定する必要があります。(イーサネット スイッチ上の)そのポートのスパニングツリー設定をディセーブルにする必要があります。これにより、(スパニングツリー設定がイネーブルであればイーサネット スイッチが実行する)イーサネット スパニングツリー処理の待ち時間による管理ポートの起動待ち時間を回避できます。シスコ製イーサネット スイッチの場合は、IOS の switchport host コマンドまたは Catalyst OS の set port host を使用します。イーサネット スイッチのコンフィギュレーション ガイドを参照してください。


図 46-1 の例において、ギガビット イーサネット インターフェイスを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface gigabitethernet 2/2

switch(config-if)#

ギガビット イーサネット インターフェイス(スロット 2、ポート 2)のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# ip address 10.1.1.100 255.255.255.0

ギガビット イーサネット インターフェイスの IPv4 アドレス(10.1.1.100)およびサブネット マスク(255.255.255.0)を入力します。

ステップ 4

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

この項では、次のトピックについて取り上げます。

「インターフェイスの説明の設定」

「標識モードの設定」

「自動ネゴシエーションの設定」

「MTU フレーム サイズの設定」

「無差別モードの設定」

インターフェイスの説明の設定

インターフェイスでスイッチ ポートの説明を設定する方法については、「インターフェイスの説明の概要」 を参照してください。

標識モードの設定

インターフェイスで標識モードを設定する方法については、「標識モードの概要」を参照してください。

自動ネゴシエーションの設定

デフォルトで、自動ネゴシエーションはすべてのギガビット イーサネット インターフェイスでイネーブルになっています。指定したギガビット イーサネット インターフェイスに対して、自動ネゴシエーションをイネーブルまたはディセーブルに設定できます。自動ネゴシエーションをイネーブルに設定すると、ポートはリンクの相手方に基づいて速度やポーズの方式、および着信信号のデュプレックスを自動的に検出します。また、自動ネゴシエーション機能を使用して、リンク アップの状態も検出できます。

自動ネゴシエーションを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface gigabitethernet 2/2

switch(config-if)#

ギガビット イーサネット インターフェイス(スロット 2、ポート 2)のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport auto-negotiate

このギガビット イーサネット インターフェイスの自動ネゴシエーションをイネーブルにします(デフォルト)。

switch(config-if)# no switchport auto-negotiate

このギガビット イーサネット インターフェイスの自動ネゴシエーションをディセーブルにします。

MTU フレーム サイズの設定

ポートで大きな(ジャンボ)フレームを伝送するようにスイッチのインターフェイスを設定できます。デフォルトの IP 最大伝送単位(MTU)フレーム サイズは、すべてのイーサネット ポートで 1500 バイトです。ポートにジャンボ フレームを設定すると、MTU サイズを最大 9000 バイトに拡張できます。


) MTU の最小サイズは 576 バイトです。



ヒント MTU の変更は中断を伴うため、ソフトウェアが MTU サイズの変更を検出すると、すべての FCIP リンクと iSCSI セッションにフラップが発生します。

shutdown コマンドと no shutdown コマンドを明示的に発行する必要はありません。

MTU フレーム サイズを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface gigabitethernet 2/2

switch(config-if)#

ギガビット イーサネット インターフェイス(スロット 2、ポート 2)のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport mtu 3000

MTU サイズを 3000 バイトに変更します。デフォルトは 1500 バイトです。

無差別モードの設定

無差別モードは、特定のギガビット イーサネット インターフェイスでイネーブルまたはディセーブルに設定できます。無差別モードをイネーブルに設定すると、ギガビット イーサネット インターフェイスはすべてのパケットを受信します。その後、ソフトウェアによってギガビット イーサネット インターフェイス宛てではないパケットがフィルタリングされて廃棄されます。

無差別モードを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface gigabitethernet 2/2

switch(config-if)#

ギガビット イーサネット インターフェイス(スロット 2、ポート 2)のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# switchport promiscuous-mode on

このギガビット イーサネット インターフェイスの無差別モードをイネーブルにします。デフォルトは オフ です。

switch(config-if)# switchport promiscuous-mode off

このギガビット イーサネット インターフェイスの無差別モードをディセーブルにします(デフォルト)。

switch(config-if)# no switchport promiscuous-mode

このギガビット イーサネット インターフェイスの無差別モードをディセーブルにします(デフォルト)。

ギガビット イーサネット接続の確認

有効な IP アドレスを使用してギガビット イーサネット インターフェイスを接続したら、各スイッチのインターフェイス接続を確認します。IP ホストの IP アドレスを使用してこのホストに対して ping を実行し、スタティック IP ルートが正しく設定されていることを確認します。


) 接続に失敗した場合は、次のことを確認してから、IP ホストに再び ping を実行してください。
- 説明(IP ホスト)の IP アドレスが正しく設定されている。
- ホストがアクティブ状態である(電源が投入されている)。
- IP ルートが正しく設定されている
- IP ホストからギガビット イーサネット インターフェイス サブネットに至るルートが存在する
- ギガビット イーサネット インターフェイスが up 状態である


ギガビット イーサネット接続を確認するには、 ping コマンドを使用します(例 46-1 を参照)。ping コマンドは、指定した IP アドレスのリモート デバイスに対してエコー要求パケットを送信します(「ping および ping ipv6 コマンドの使用」を参照)。

ギガビットイーサネット インターフェイスが起動しているかどうかを確認するには、 show interface gigabitethernet コマンドを使用します。

例 46-1 ギガビット イーサネット接続の確認

switch# ping 10.100.1.25
PING 10.100.1.25 (10.100.1.25): 56 data bytes
64 bytes from 10.100.1.25: icmp_seq=0 ttl=255 time=0.1 ms
64 bytes from 10.100.1.25: icmp_seq=1 ttl=255 time=0.1 ms
64 bytes from 10.100.1.25: icmp_seq=2 ttl=255 time=0.1 ms
--- 10.100.1.25 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.1/0.1/0.1 ms
 

VLAN

ここでは、Cisco MDS SAN-OS での仮想 LAN(VLAN)のサポートについて説明します。内容は次のとおりです。

「ギガビット イーサネットの VLAN の概要」

「VLAN サブインターフェイスの設定」

「インターフェイス サブネットの要件」

ギガビット イーサネットの VLAN の概要

仮想 LAN(VLAN)は、1 つの物理 LAN ネットワーク上で複数の仮想レイヤ 2 ネットワークを構成します。VLAN を使用すると、トラフィックの隔離、セキュリティの確保、およびブロードキャストの制御が可能になります。

ギガビット イーサネット ポートは、IEEE 802.1Q VLAN によってカプセル化されたイーサネット フレームを自動的に認識します。複数の VLAN から送信されたトラフィックを単一のギガビット イーサネット ポート上で終端させる必要がある場合は、VLAN ごとに 1 つずつサブインターフェイスを設定します。


) IPS モジュールまたは MPS-14/2 モジュールがシスコ製イーサネット スイッチに接続されていて、複数の VLAN からのトラフィックを単一の IPS ポートに送信する必要がある場合は、イーサネット スイッチで次の要件を確認します。
- IPS モジュールまたは MPS-14/2 モジュールに接続されたイーサネット スイッチ ポートがトランキング ポートとして設定されている。
- カプセル化がデフォルトの ISL でなく、802.1Q に設定されている


VLAN ID をギガビット イーサネット インターフェイス名の後ろに使用して、サブインターフェイス名( <スロット番号>/<ポート番号>.<VLAN-ID> )を作成します。

VLAN サブインターフェイスの設定

VLAN サブインターフェイス(VLAN ID)を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface gigabitethernet 2/2.100

switch(config-if)#

802.1Q を使用するサブインターフェイスを指定します(スロット 2、ポート 2、VLAN ID 100)。

(注) この例のサブインターフェイス番号 100 は、VLAN ID です。VLAN ID の範囲は 1 ~ 4093 です。

ステップ 3

switch(config-if)# ip address 10.1.1.101 255.255.255.0

ギガビット イーサネット インターフェイスの IPv4 アドレス(10.1.1.100)およびサブネット マスク(255.255.255.0)を入力します。

ステップ 4

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

インターフェイス サブネットの要件

ギガビット イーサネット インターフェイス(メジャー)、サブインターフェイス(VLAN ID)、および管理インターフェイス(mgmt 0)は、設定に応じて、同じサブネットまたは異なるサブネット上に設定できます( 表 46-1 を参照)。

 

表 46-1 インターフェイスのサブネット要件

インターフェイス 1
インターフェイス 2
同じサブネット内での
許可
注意事項

ギガビット イーサネット 1/1

ギガビット イーサネット 1/2

Yes

2 つのメジャー インターフェイスは同じサブネットまたは異なるサブネット内に設定できます。

ギガビット イーサネット 1/1.100

ギガビット イーサネット 1/2.100

Yes

VLAN ID が同じ 2 つのサブインターフェイスは、同じサブネットまたは異なるサブネット内に設定できます。

ギガビット イーサネット 1/1.100

ギガビット イーサネット 1/2.200

No

VLAN ID が異なる 2 つのサブインターフェイスは、同じサブネットに設定できません。

ギガビット イーサネット 1/1

ギガビット イーサネット 1/1.100

No

サブインターフェイスは、メジャー インターフェイスと同じサブネットに設定できません。

mgmt0

ギガビット イーサネット 1/1.100

No

mgmt0 インターフェイスは、ギガビット イーサネット インターフェイスまたはサブインターフェイスと同じサブネットに設定できません。

mgmt0

ギガビット イーサネット 1/1

No


表 46-1 の設定要件は、イーサネット PortChannel にも適用されます。


スタティック IPv4 ルーティングの設定

ギガビット イーサネット インターフェイスを介してスタティック IPv4 ルーティング(図 46-1 を参照)を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# ip route 10.100.1.0 255.255.255.0 10.1.1.1

switch(config-if)#

IP ホストの IP サブネット(10.100.1.0 255.255.255.0)を入力し、ギガビット イーサネット インターフェイスに接続されているルータの IPv4 アドレスであるネクスト ホップ 10.1.1.1 を設定します。

IPv4 ルート テーブルの表示

ip route interface コマンドは、パラメータとしてギガビット イーサネット インターフェイスを受け取り、そのインターフェイスのルート テーブルを返します。例 46-2 を参照してください。

例 46-2 IP ルート テーブルの表示

switch# show ips ip route interface gig 8/1
Codes: C - connected, S - static
No default gateway
C 10.1.3.0/24 is directly connected, GigabitEthernet8/1
 

Connected(C)はインターフェイスが設定されている(インターフェイスに直接接続されている)サブネットを示します。Static(S)はルータ経由のスタティック ルートを示します。

IPv4-ACL

ここでは、IPv4 アクセス コントロール リスト(IPv4-ACL)に関する注意事項と、ギガビット イーサネット インターフェイスに IPv4-ACL を適用する方法について説明します。

この項では、次のトピックについて取り上げます。

「ギガビット イーサネットの IPv4-ACL に関する注意事項」

「ギガビット イーサネット インターフェイスへの IPv4-ACL の適用」


) IPv4-ACL の作成については、「IPv4 および IPv6 のアクセス コントロール リストの設定」を参照してください。


ギガビット イーサネットの IPv4-ACL に関する注意事項

ギガビット イーサネット インターフェイスで IPv4-ACL を設定する際には、次の注意事項に従ってください。

Transmission Control Protocol(TCP)または Internet Control Message Protocol(ICMP)だけを使用します。


) ユーザ データグラム プロトコル(UDP)や HTTP などの他のプロトコルは、ギガビット イーサネット インターフェイスではサポートされていません。これらのプロトコルに関するルールを含む ACL をギガビット イーサネット インターフェイスに適用することは可能ですが、これらのルールは無効になります。


インターフェイスをイネーブルにする前に、インターフェイスに IPv4-ACL を適用します。このようにすれば、トラフィックが流れ始める前にフィルタを適用できます。

次の条件を確認します。

log-deny オプションを使用する場合、1 秒ごとに記録されるメッセージ数は最大 50 です。

established オプションを含む IPv4-ACL をギガビット イーサネット インターフェイスに適用すると、このオプションは無視されます。

前から存在している TCP 接続に IPv4-ACL のルールを適用しても、このルールは無視されます。たとえば、A と B の間に既存の TCP 接続がある場合に、送信元が A で送信先が B のパケットをすべて廃棄する IPv4-ACL を適用しても、このルールは無効になります。


ヒント ギガビット イーサネット インターフェイスに IPv4-ACL がすでに設定されている場合、このインターフェイスをイーサネット PortChannel グループに追加できません。IPv4-ACL の設定手順については、を参照してください。「IPv4 および IPv6 のアクセス コントロール リストの設定」

ギガビット イーサネット インターフェイスへの IPv4-ACL の適用

ギガビット イーサネット インターフェイスに IPv4-ACL を適用するには、次の手順を実行してください。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface gigabitethernet 3/1

switch(config-if)#

ギガビット イーサネット インターフェイス(3/1)を設定します。

ステップ 3

switch(config-if)# ip access-group SampleName

入力トラフィックと出力トラフィックの両方について、ギガビット イーサネット 3/1 の IPv4-ACL SampleName を適用します(アソシエーションがまだ存在しない場合)。

ステップ 4

switch(config-if)# ip access-group SampleName1 in

入力トラフィックについて、ギガビット イーサネット 3/1 の IPv4-ACL SampleName を適用します。

switch(config-if)# ip access-group SampleName2 out

出力トラフィックについて、ギガビット イーサネット 3/1 の IPv4-ACL SampleName を適用します(アソシエーションがまだ存在しない場合)。

ARP キャッシュ

Cisco MDS SAN-OS は IPv4 に設定されたギガビット イーサネット インターフェイスの ARP キャッシュをサポートします。この項では、次のトピックについて取り上げます。

「ARP キャッシュの表示」

「ARP キャッシュのクリア」

ARP キャッシュの表示

ギガビット イーサネット インターフェイスの ARP キャッシュを表示できます。


) すべての ARP キャッシュ コマンドに、サブインターフェイスではなくを物理インターフェイスを使用します。


ギガビットイーサネット インターフェイスの ARP キャッシュを表示するには、 show ips arp interface gigabitethernet コマンドを使用します。このコマンドは、イーサネット インターフェイスをパラメータとして受け取り、そのインターフェイスの ARP キャッシュを返します。例 46-3 を参照してください。

例 46-3 ARP キャッシュの表示

switch# show ips arp interface gigabitethernet 7/1
Protocol Address Age (min) Hardware Addr Type Interface
Internet 20.1.1.5 3 0005.3000.9db6 ARPA GigabitEthernet7/1
Internet 20.1.1.10 7 0004.76eb.2ff5 ARPA GigabitEthernet7/1
Internet 20.1.1.11 16 0003.47ad.21c4 ARPA GigabitEthernet7/1
Internet 20.1.1.12 6 0003.4723.c4a6 ARPA GigabitEthernet7/1
Internet 20.1.1.13 13 0004.76f0.ef81 ARPA GigabitEthernet7/1
Internet 20.1.1.14 0 0004.76e0.2f68 ARPA GigabitEthernet7/1
Internet 20.1.1.15 6 0003.47b2.494b ARPA GigabitEthernet7/1
Internet 20.1.1.17 2 0003.479a.b7a3 ARPA GigabitEthernet7/1
...
 

ARP キャッシュのクリア

ARP キャッシュは、2 つの方法でクリアできます。1 つのエントリだけをクリアするか、または ARP キャッシュ内のすべてのエントリをクリアできます。

ARP キャッシュをクリアするには、 clear ips arp コマンドを使用します。例 46-4 および例 46-5 を参照してください。

例 46-4 1 つの ARP キャッシュ エントリのクリア

switch# clear ips arp address 10.2.2.2 interface gigabitethernet 8/7
arp clear successful
 

例 46-5 すべての ARP キャッシュ エントリのクリア

switch# clear ips arp interface gigabitethernet 8/7
arp clear successful
 

IPv4 統計情報の表示

IP v4 統計情報を表示して確認するには、 show ips stats ip interface gigabitethernet コマンドを使用します。このコマンドは、メイン イーサネット インターフェイスをパラメータとして受け取り、そのインターフェイスの IPv4 統計情報を返します。例 46-6 を参照してください。


) IPv4 統計情報を表示するには、サブインターフェイスではなく物理インターフェイスを使用します。


例 46-6 IPv4 統計情報の表示

switch# show ips stats ip interface gigabitethernet 4/1
Internet Protocol Statistics for port GigabitEthernet4/1
168 total received, 168 good, 0 error
0 reassembly required, 0 reassembled ok, 0 dropped after timeout
371 packets sent, 0 outgoing dropped, 0 dropped no route
0 fragments created, 0 cannot fragment
 

デフォルト設定

表 46-2 に、IPv4 パラメータのデフォルト設定を示します。

 

表 46-2 IPv4 のデフォルト パラメータ

パラメータ
デフォルト

IPv4 MTU フレーム サイズ

すべてのイーサネット ポートで 1500 バイト

自動ネゴシエーション

イネーブル

無差別モード

ディセーブル