Cisco MDS 9000 ファミリ CLI コンフィギュレーション ガイド リリース 3.x Cisco MDS SAN-OS for Release 3.0(1) ~ 3.3(3)
IP ストレージの設定
IP ストレージの設定
発行日;2013/09/03 | 英語版ドキュメント(2011/01/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

IP ストレージの設定

サービス モジュール

モジュール ステータスの確認

IPS モジュールのアップグレード

MPS-14/2 モジュールのアップグレード

サポートされているハードウェア

IPS モジュールのコア ダンプ

ギガビット イーサネットのハイ アベイラビリティの設定

iSCSI および FCIP サービスの VRRP

ギガビット イーサネット インターフェイスに対する VRRP の設定

イーサネット PortChannel の集約の概要

イーサネット PortChannel の設定

Cisco Discovery Protocol(CDP)の設定

統計情報の表示

ギガビット イーサネット インターフェイスの統計情報の表示

イーサネット MAC 統計情報の表示

DMA-Bridge 統計情報の表示

TCP 統計情報の表示

デフォルト設定

IP ストレージの設定

Cisco MDS 9000 ファミリの IP ストレージ(IPS)サービスは、オープン規格の IP ベース テクノロジーを使用することによって、ファイバ チャネル SAN の到達距離を延長します。このスイッチは Fibre Channel over IP(FCIP)を使用して異なる SAN アイランド間を接続し、iSCSI プロトコルを使用して IP ホストからファイバ チャネル ストレージにアクセスできるようにします。


) FCIP 機能と iSCSI 機能は IPS モジュールに固有のものであり、Cisco MDS 9200 スイッチまたは Cisco MDS 9500 ディレクタで使用可能です。

Cisco MDS 9216I スイッチおよび 14/2 マルチプロトコル サービス(MPS-14/2)モジュールでは、ファイバ チャネル、FCIP、および iSCSI 機能も使用できます。MPS-14/2 モジュールは、Cisco MDS 9200 シリーズまたは Cisco MDS 9500 シリーズのすべてのスイッチで使用できます。


この章は、次の項で構成されています。

「サービス モジュール」

「サポートされているハードウェア」

「IPS モジュールのコア ダンプ」

「ギガビット イーサネットのハイ アベイラビリティの設定」

「Cisco Discovery Protocol(CDP)の設定」

「デフォルト設定」

サービス モジュール

IP ストレージ サービス モジュール(IPS モジュール)および MPS-14/2 モジュールを使用すると、FCIP および iSCSI の機能が利用できるようになります。これらのモジュールは Cisco MDS 9000 ファミリとシームレスに統合され、VSAN、セキュリティ、トラフィック管理など、他のスイッチング モジュールで使用可能な機能をすべてサポートします。現在、次のタイプのストレージ サービス モジュールが、Cisco MDS 9200 シリーズまたは Cisco MDS 9500 シリーズのすべてのスイッチで使用できます。

4 ポートのホットスワップ可能な IPS モジュール(IPS-4)は、4 つのギガビット イーサネット ポートを備えています。

8 ポートのホットスワップ可能な IPS モジュール(IPS-8)は、8 つのギガビット イーサネット ポートを備えています。

MPS-14/2 モジュールは、14 のファイバ チャネル ポート(ポート番号 1 ~ 14)と 2 つのギガビット イーサネット ポート(ポート番号 1 および 2)を備えています。

これらのモジュールのギガビット イーサネット ポートは、FCIP プロトコルまたは iSCSI プロトコル、あるいは両方のプロトコルを同時にサポートするように設定できます。

FCIP:IP ネットワークを介して、2 台の Cisco MDS 9000 ファミリ スイッチ間で、またはその他の FCIP 標準準拠のデバイス間で、ファイバ チャネル フレームを透過的に伝送します。図 45-1 に IPS モジュールを使用する FCIP のさまざまな例を示します。

図 45-1 FCIP の例

 

iSCSI:IPS モジュールは、IP ホストからファイバ チャネル ストレージ デバイスへのアクセスを提供します。IP ホストは SCSI コマンドを iSCSI プロトコル データ ユニット(PDU)にカプセル化し、TCP/IP 接続を介して Cisco MDS 9000 ファミリ スイッチの IPS ポートに送信します。この時点で、コマンドは IP ネットワークからファイバ チャネル ネットワークにルーティングされて、宛先に転送されます。図 45-2 に、IPS モジュールを使用する iSCSI の例を示します。

図 45-2 iSCSI の例

 

モジュール ステータスの確認

モジュールを挿入したら、 show module コマンドを使用してモジュールの状態を確認します。

switch# show module
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ------------------ ------------
1 0 Caching Services Module DS-X9560-SMAP ok
2 8 IP Storage Services Module DS-X9308-SMIP ok <-------IPS-8 モジュール
4 16 2x1GE IPS, 14x1/2Gbps FC Module DS-X9216i-K9-SUP ok <-------MPS-14/2 モジュール
5 0 Supervisor/Fabric-1 DS-X9530-SF1-K9 active *
6 0 Supervisor/Fabric-1 DS-X9530-SF1-K9 ha-standby
9 4 IP Storage Services Module DS-X9304-SMIP ok <---------IPS-4 モジュール
 
Mod Sw Hw World-Wide-Name(s) (WWN)
--- ----------- ------ --------------------------------------------------
1 2.0(1) 0.201 20:41:00:0b:fd:44:68:c0 to 20:48:00:0b:fd:44:68:c0
2 2.0(1) 0.201 20:41:00:0b:fd:44:68:c0 to 20:48:00:0b:fd:44:68:c0
4 2.0(1) 0.201 20:c1:00:05:30:00:07:1e to 20:d0:00:05:30:00:07:1e
5 2.0(1) 0.0 --
6 2.0(1) 0.0 --
9 2.0(1) 0.1 22:01:00:05:30:00:07:1e to 22:04:00:05:30:00:07:1e
 
Mod Application Image Description Application Image Version
-------- ----------------------------- -------------------------
1 svc-node1 1.3(5M)
1 svc-node2 1.3(5M)
 
Mod MAC-Address(es) Serial-Num
--- -------------------------------------- ----------
1 00-05-30-01-49-c2 to 00-05-30-01-4a-46 JAB073907EP
2 00-05-30-00-9d-d2 to 00-05-30-00-9d-de JAB064605a2
4 00-05-30-01-7f-32 to 00-05-30-01-7f-38 JAB081405AM
5 00-05-30-00-2c-4e to 00-05-30-00-2c-52 JAB06350B1M
6 00-05-30-00-19-66 to 00-05-30-00-19-6a JAB073705GL
9 00-0d-bc-2f-d6-00 to 00-0d-bc-2f-d6-08 JAB080804TN
 
* this terminal session

IPS モジュールのアップグレード


注意 IPS モジュールのソフトウェア アップグレードは中断を伴います。スイッチに搭載されたファイバ チャネル モジュールおよびスイッチ自体のソフトウェアをアップグレードする場合、SAN-OS ソフトウェアのアップグレードに中断は発生しません。

IPS モジュールはローリング アップグレード インストール メカニズムを使用するので、特定のスイッチ内の各モジュールは順番にアップグレードする必要があります。安定した状態を確保するために、スイッチ内の IPS モジュールをアップグレードしてから次の IPS モジュールをアップグレードするまでに 5 分間の間隔をあける必要があります。

MPS-14/2 モジュールのアップグレード


注意 MPS-14/2 モジュールのソフトウェア アップグレードは、部分的な中断を伴います。スイッチに搭載されたファイバ チャネル モジュールおよびスイッチ自体のソフトウェアをアップグレードする場合、SAN-OS ソフトウェアのアップグレードに中断は発生しません。

MPS-14/2 モジュールは、14 のファイバ チャネル ポート(アップグレード時に中断しない)と 2 つのギガビット イーサネット ポート(アップグレード時に中断する)を備えています。MPS-14/2 モジュールは、2 つのギガビット イーサネット ポートに対してローリング アップグレード インストール メカニズムを使用するので、特定のスイッチ内の各モジュールは順番にアップグレードする必要があります。安定した状態を確保するために、スイッチ内の MPS-14/2 モジュールをアップグレードしてから次のモジュールをアップグレードするまでに 5 分間の間隔をあける必要があります。

サポートされているハードウェア

次のハードウェアを 1 つまたは複数使用して、FCIP および iSCSI 機能を設定できます。

IPS-4 または IPS-8 モジュール(詳細については、『 Cisco MDS 9200 Series Hardware Installation Guide 』または『 Cisco MDS 9500 Series Hardware Installation Guide 』を参照してください)

MPS-14/2 モジュール(詳細については、『 Cisco MDS 9200 Series Hardware Installation Guide 』または『 Cisco MDS 9500 Series Hardware Installation Guide 』を参照してください)


) MPS-14/2 モジュールおよび Cisco MDS 9216i 内蔵スーパーバイザ モジュールの両方で、ファイバ チャネル ポートとギガビット イーサネット ポートのポート番号が異なります。ファイバ チャネル ポート番号は 1 ~ 14、ギガビット イーサネット ポート番号は 1 および 2 です。


Cisco MDS 9216i スイッチ(『 Cisco MDS 9200 Series Hardware Installation Guide 』を参照)

IPS モジュールのコア ダンプ

IPS のコア ダンプは、他のモジュールに対するシステムのカーネル コア ダンプとは異なります。IPS モジュールのオペレーティング システム(OS)が予期せずリセットされた場合、メモリ イメージのコピー(IPS コア ダンプ)を取得すると、リセットの原因の確認に役立ちます。その状況では、IPS モジュールからスーパーバーザ モジュールにコア ダンプが送られ、格納されます。シスコ製 MDS スイッチには、次の 2 つのレベルの IPS コア ダンプがあります。

部分コア ダンプ(デフォルト):部分コア ダンプはそれぞれ 4 つの部分(4 つのファイル)で構成されます。4 つのファイルはすべて、アクティブなスーパーバイザ モジュールに保存されます。

これらのファイルを表示するには show cores コマンドを使用します。

完全コア ダンプ:完全コア ダンプはそれぞれ 75 の部分(75 のファイル)で構成されます。MPS-14/2 モジュールおよび Cisco MDS 9216i スイッチの IPS コア ダンプには、38 の部分だけが含まれます。このコア ダンプの保存には大きな容量が必要となるため、このコア ダンプはスーパーバイザ モジュールに保存されません。外部 TFTP サーバに直接コピーされます。

IPS コア ダンプ(およびその他のコア ダンプ)のコピー先となる外部 TFTP サーバの設定には、 system cores tftp: コマンドを使用します。

IPS モジュールの IPS コア ダンプを設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# ips core dump full

 

スイッチのすべての IPS モジュールの完全コア ダンプの生成を設定します。

switch(config)# no ips core dump full

 

スイッチのすべての IPS モジュールの完全コア ダンプの生成の設定をディセーブルにします。

ステップ 3

switch(config)# ips core dump partial

 

スイッチの IPS モジュールの部分コア ダンプ(デフォルト)の生成を設定します。

switch(config)# no ips core dump partial

 

スイッチのすべての IPS モジュールの部分コア ダンプの生成の設定をディセーブルにします。

ギガビット イーサネットのハイ アベイラビリティの設定

Virtual Router Redundancy Protocol(VRRP)およびイーサネット PortChannel は、iSCSI および FCIP サービスにハイ アベイラビリティを提供する 2 つのギガビット イーサネット機能です。

iSCSI および FCIP サービスの VRRP

VRRP は iSCSI および FCIP サービスに対して、ギガビット イーサネット ポートへの冗長代替パスを提供します。VRRP を利用すると、IP アドレスを代替ギガビット イーサネット インターフェイスにフェールオーバーして保護できます。これにより、IP アドレスが常に使用可能な状態になります(図 45-3 を参照)。

図 45-3 VRRP の例

 

図 45-3 では、VRRP グループのメンバーは、すべて IPS ギガビット イーサネット ポートでなければなりません。VRRP グループ メンバーには、次のインターフェイスを 1 つまたは複数設定できます。

同じ IPS モジュールまたは MPS-14/2 モジュールの 1 つまたは複数のインターフェイス

1 台のスイッチの IPS モジュールまたは MPS-14/2 モジュールのインターフェイス

複数のスイッチの IPS モジュールまたは MPS-14/2 モジュールのインターフェイス

ギガビット イーサネット サブインターフェイス

イーサネット PortChannel および PortChannel サブインターフェイス

「仮想ルータ冗長プロトコル」を参照してください。


) メイン インターフェイスとすべてのサブインターフェイスを含めて、1 つのギガビット イーサネット インターフェイスには、IPv4 と IPv6 の両方で最大 7 つの VRRP グループを設定できます。


ギガビット イーサネット インターフェイスに対する VRRP の設定

IPv4 を使用してギガビット イーサネット インターフェイスの VRRP を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch1# config terminal

switch1(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface gigabitethernet 2/2

switch(config-if)#

ギガビット イーサネット インターフェイス(スロット 2、ポート 2)のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# ip address 10.1.1.10 255.255.255.0

ギガビット イーサネット インターフェイスに IPv4 アドレス(10.1.1.10)およびサブネット マスク(255.255.255.0)を割り当てます。

ステップ 4

switch(config-if)# no shutdown

選択したインターフェイスをイネーブルにします。

ステップ 5

switch(config-if)# vrrp 100

switch(config-if-vrrp)

VR ID 100 を作成します。

ステップ 6

switch(config-if-vrrp) # address 10.1.1.100

選択した VRRP グループ(VR ID で識別される)の仮想 IPv4 アドレス(10.1.1.100)を設定します。

(注) 仮想 IPv4 アドレスは、ギガビット イーサネット インターフェイスの IPv4 アドレスと同じサブネットにある必要があります。VRRP グループのメンバーはすべて同じ仮想 IPv4 アドレスを設定する必要があります。

ステップ 7

switch(config-if-vrrp) # priority 10

この VRRP グループ内の選択したインターフェイスのプライオリティを設定します。

(注) プライオリティが最も高いインターフェイスがマスターとして選択されます。

ステップ 8

switch(config-if-vrrp) # no shutdown

選択したインターフェイスの VRRP プロトコルをイネーブルにします。

IPv6 を使用してギガビット イーサネット インターフェイスの VRRP を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch1# config terminal

switch1(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface gigabitethernet 2/2

switch(config-if)#

ギガビット イーサネット インターフェイス(スロット 2、ポート 2)のインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switch(config-if)# ipv6 address 2001:0db8:800:200c::417a/64

ギガビット イーサネット インターフェイスに IPv6 アドレスを割り当てます。

ステップ 4

switch(config-if)# no shutdown

選択したインターフェイスをイネーブルにします。

ステップ 5

switch(config-if)# vrrp ipv6 100

switch(config-if-vrrp-ipv6)

VR ID 100 を作成します。

ステップ 6

switch(config-if-vrrp-ipv6) # address 2001:0db8:800:200c::417a

単一のプライマリ リンクローカル IPv6 アドレスまたは複数のセカンダリ IPv6 アドレスのいずれかを割り当てます。

(注) この IPv6 アドレスが物理 IPv6 アドレスと同じである場合、このスイッチは自動的にこの IPv6 アドレスの所有者になります。

ステップ 7

switch(config-if-vrrp-ipv6) # priority 10

この VRRP グループ内の選択したインターフェイスのプライオリティを設定します。

(注) プライオリティが最も高いインターフェイスがマスターとして選択されます。

ステップ 8

switch(config-if-vrrp-ipv6) # no shutdown

選択したインターフェイスの VRRP プロトコルをイネーブルにします。


) IPFC VSAN インターフェイスにセカンダリ VRRP IPv6 アドレスを設定する場合、Cisco Release 3.0(1) 以前のリリースにダウングレードする前に、セカンダリ VRRP IPv6 アドレスを削除する必要があります。これは IPv6 アドレスを設定する場合にだけ必要となります。



) VRRP の preempt オプションは、IPS のギガビット イーサネット インターフェイスではサポートされません。ただし、仮想 IP アドレスがインターフェイスの IP アドレスでもある場合、プリエンプションは暗黙的に適用されます。


イーサネット PortChannel の集約の概要

イーサネット PortChannel は、複数の物理ギガビット イーサネット インターフェイスを単一の論理イーサネット インターフェイスに集約したものです。これにより、リンク冗長性が確保され、場合によっては集約帯域幅およびロード バランシング効率が高まります。

MDS スイッチのギガビット イーサネット ポートに接続されたイーサネット スイッチでは、IP アドレス、IP アドレスと UDP/TCP ポート番号、または MAC アドレスに基づいてロード バランシングを実行できます。このロード バランシング方式では、1 つの TCP 接続からのデータ トラフィックは、必ずイーサネット PortChannel の同じ物理ギガビット イーサネット ポート上で伝送されます。MDS に着信するトラフィックに対して、イーサネット スイッチは、IP アドレス、送信元/宛先 MAC アドレス、または IP アドレスとポートに基づいてロード バランシングを実行できます。1 つの TCP 接続からのデータ トラフィックは、常に同じ物理リンク上で伝送されます。両方のポートを発信方向で使用するには、複数の TCP 接続が必要です。

1 つの FCIP リンクのすべての FCIP データ トラフィックは、1 つの TCP 接続上で伝送されます。したがって、この FCIP リンクの集約帯域幅は 1 Gbps になります。


) シスコ製イーサネット スイッチの PortChannel は、デフォルトの 802.3ad プロトコルとしてではなく、スタティック PortChannel として設定する必要があります。


イーサネット PortChannel が集約できるのは、指定された IPS モジュール上で相互に隣接する 2 つの物理インターフェイスだけです(図 45-4 を参照)。


PortChannel メンバーは、ポート 1 と 2、ポート 3 と 4、ポート 5 と 6、またはポート 7 と 8 のいずれかの組み合わせでなければなりません。


図 45-4 イーサネット PortChannel の例

 

図 45-4 で、スロット 9 のギガビット イーサネット ポート 3 および 4 は、イーサネット PortChannel に集約されます。イーサネット PortChannel は、MPS-14/2 モジュールおよび 9216i IPS モジュールではサポートされていません。


) PortChannel インターフェイスは、ギガビット イーサネットおよびファイバ チャネル用に設定できます。ただし、PortChannel メンバーシップに基づいて、ギガビット イーサネット パラメータまたはファイバ チャネル パラメータだけが適用できます。


イーサネット PortChannel の設定

「PortChannel の設定」で指定された PortChannel 設定は、イーサネット PortChannel 設定にも適用されます。

イーサネット PortChannel を設定するには、次の手順を実行します。

コマンド
目的

ステップ 1

switch1# config terminal

switch1(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# interface port-channel 10

switch(config-if)#

指定した PortChannel(10)を設定します。

ステップ 3

switch(config-if)# ip address 10.1.1.1 255.255.255.0

PortChannel の IPv4 アドレス(10.1.1.1)およびサブネット マスク(255.255.255.0)を入力します。

(注) 最初に作成する場合、PortChannel にメンバーはありません。

ステップ 4

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

switch(config)# interface gigabitethernet 9/3

switch(config-if)#

指定したギガビット イーサネット インターフェイス(スロット 9、ポート 3)を設定します。

ステップ 6

switch(config-if)# channel-group 10

gigabitethernet 9/3 added to port-channel 10 and disabled

please do the same operation on the switch at the other end of the port-channel, then do “no shutdown” at both ends to bring them up

switch(config-if)#

チャネル グループ 10 にギガビット イーサネット インターフェイス 9/3 を追加します。チャネル グループ 10 が存在しない場合は、作成されます。ポートがシャットダウンします。

ステップ 7

switch(config-if) # no shutdown

選択したインターフェイスをイネーブルにします。

ステップ 8

switch(config)# interface gigabitethernet 9/4

switch(config-if)#

指定したギガビット イーサネット インターフェイス(スロット 9、ポート 4)を設定します。

ステップ 9

switch(config-if)# channel-group 10

gigabitethernet 9/4 added to port-channel 10 and disabled

please do the same operation on the switch at the other end of the port-channel, then do “no shutdown” at both ends to bring them up

チャネル グループ 10 にギガビット イーサネット インターフェイス 9/4 を追加します。ポートがシャットダウンします。

ステップ 10

switch(config-if) # no shutdown

選択したインターフェイスをイネーブルにします。


) 次のいずれかの場合は、ギガビット イーサネット インターフェイスを PortChannel に追加できません。
- インターフェイスにすでに IP アドレスが割り当てられている場合。
- このインターフェイスにサブインターフェイスが設定されている場合
- インターフェイスに IPv4-ACL のルールが適用されていて、PortChannel には IPv4-ACL のルールが適用されていない場合


Cisco Discovery Protocol(CDP)の設定

Cisco Discovery Protocol(CDP)はスーパーバイザ モジュールの管理イーサネット インターフェイス、および IPS モジュールまたは MPS-14/2 モジュールのギガビット イーサネット インターフェイスでサポートされています。

「CDP の設定」を参照してください。

統計情報の表示

ここでは、IP ストレージ ポートのギガビット イーサネットおよび TCP/IP の統計情報を確認する例を示します。

ギガビット イーサネット インターフェイスの統計情報の表示

インターフェイスが起動して期待どおりに機能していることを確認するには、各スイッチに対して show interface gigabitethernet コマンドを使用します。例 45-1 および例 45-2 を参照してください。

例 45-1 ギガビット イーサネット インターフェイスの表示

switch# show interface gigabitethernet 8/1
GigabitEthernet8/1 is up <-----------インターフェイスは up 状態です。
Hardware is GigabitEthernet, address is 0005.3000.a98e
Internet address is 10.1.3.1/24
MTU 1500 bytes, BW 1000000 Kbit
Port mode is IPS
Speed is 1 Gbps
Beacon is turned off
5 minutes input rate 744 bits/sec, 93 bytes/sec, 1 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
3343 packets input, 406582 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
8 packets output, 336 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
 

例 45-2 ギガビット イーサネット サブインターフェイスの表示

switch# show interface gigabitethernet 4/2.100
GigabitEthernet4/2.100 is up
Hardware is GigabitEthernet, address is 0005.3000.abcb
Internet address is 10.1.2.100/24
MTU 1500 bytes
5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
5 minutes output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
0 packets input, 0 bytes
0 multicast frames, 0 compressed
0 input errors, 0 frame, 0 overrun 0 fifo
1 packets output, 46 bytes, 0 underruns
0 output errors, 0 collisions, 0 fifo
0 carrier errors
 

イーサネット MAC 統計情報の表示

show ips stats mac interface gigabitethernet コマンドは、パラメータとしてメイン ギガビットイーサネット インターフェイスを受け取り、そのインターフェイスのイーサネット統計情報を返します。例 45-3 を参照してください。


) イーサネット MAC の統計情報を表示するには、サブインターフェイスではなく物理インターフェイスを使用します。


例 45-3 イーサネット MAC 統計情報の表示

switch# show ips stats mac interface gigabitethernet 8/1
Ethernet MAC statistics for port GigabitEthernet8/1
Hardware Transmit Counters
237 frame 43564 bytes
0 collisions, 0 late collisions, 0 excess collisions
0 bad frames, 0 FCS error, 0 abort, 0 runt, 0 oversize
Hardware Receive Counters
427916 bytes, 3464 frames, 0 multicasts, 3275 broadcasts
0 bad, 0 runt, 0 CRC error, 0 length error
0 code error, 0 align error, 0 oversize error
Software Counters
3429 received frames, 237 transmit frames
0 frames soft queued, 0 current queue, 0 max queue
0 dropped, 0 low memory
 

DMA-Bridge 統計情報の表示

show ips stats dma-bridge interface gigabitethernet コマンドを使用して、ダイレクト メモリ アクセス(DMA)デバイス統計情報を表示できます。このコマンドは、メイン ギガビット イーサネット インターフェイスをパラメータとして受け取り、そのインターフェイスの DMA-Bridge 統計情報を返します。例 45-4 を参照してください。


) DMA-Bridge 統計情報を表示するには、サブインターフェイスではなく物理インターフェイスを使用します。


例 45-4 DMA-Bridge 統計情報の表示

switch# show ips stats dma-bridge interface gigabitethernet 7/1
Dma-bridge ASIC Statistics for port GigabitEthernet7/1
Hardware Egress Counters
231117 Good, 0 bad protocol, 0 bad header cksum, 0 bad FC CRC
Hardware Ingress Counters
218255 Good, 0 protocol error, 0 header checksum error
0 FC CRC error, 0 iSCSI CRC error, 0 parity error
Software Egress Counters
231117 good frames, 0 bad header cksum, 0 bad FIFO SOP
0 parity error, 0 FC CRC error, 0 timestamp expired error
0 unregistered port index, 0 unknown internal type
0 RDL ok, 0 RDL drop (too big), 0 RDL ttl_1
3656368645 idle poll count, 0 loopback, 0 FCC PQ, 0 FCC EQ
Flow Control: 0 [0], 0 [1], 0 [2], 0 [3]
Software Ingress Counters
218255 Good frames, 0 header cksum error, 0 FC CRC error
0 iSCSI CRC error, 0 descriptor SOP error, 0 parity error
0 frames soft queued, 0 current Q, 0 max Q, 0 low memory
0 out of memory drop, 0 queue full drop
0 RDL ok, 0 RDL drop (too big)
Flow Control: 0 [0], 0 [1], 0 [2], 0 [3]
 

この出力は、ギガビット イーサネット ポートから入出力されるすべてのファイバ チャネル フレームを示しています。

TCP 統計情報の表示

TCP 統計情報を表示および確認するには、 show ips stats tcp interface gigabitethernet を使用します。このコマンドは、メイン イーサネット インターフェイスをパラメータとして受け取り、接続リストおよび TCP 状態とともに TCP 統計情報を表示します。 detail オプションは、インターフェイスで維持されているすべての情報を表示します。例 45-5 および例 45-6 を参照してください。

例 45-5 TCP 統計情報の表示

switch# show ips stats tcp interface gigabitethernet 4/1
TCP Statistics for port GigabitEthernet4/1
Connection Stats
0 active openings, 3 accepts
0 failed attempts, 12 reset received, 3 established
Segment stats
163 received, 355 sent, 0 retransmitted
0 bad segments received, 0 reset sent
TCP Active Connections
Local Address Remote Address State Send-Q Recv-Q
0.0.0.0:3260 0.0.0.0:0 LISTEN 0 0
 

例 45-6 詳細な TCP 統計情報の表示

switch# show ips stats tcp interface gigabitethernet 4/1 detail
TCP Statistics for port GigabitEthernet4/1
TCP send stats
355 segments, 37760 bytes
222 data, 130 ack only packets
3 control (SYN/FIN/RST), 0 probes, 0 window updates
0 segments retransmitted, 0 bytes
0 retransmitted while on ethernet send queue, 0 packets split
0 delayed acks sent
TCP receive stats
163 segments, 114 data packets in sequence, 6512 bytes in sequence
0 predicted ack, 10 predicted data
0 bad checksum, 0 multi/broadcast, 0 bad offset
0 no memory drops, 0 short segments
0 duplicate bytes, 0 duplicate packets
0 partial duplicate bytes, 0 partial duplicate packets
0 out-of-order bytes, 1 out-of-order packets
0 packet after window, 0 bytes after window
0 packets after close
121 acks, 37764 ack bytes, 0 ack toomuch, 4 duplicate acks
0 ack packets left of snd_una, 0 non-4 byte aligned packets
8 window updates, 0 window probe
30 pcb hash miss, 0 no port, 0 bad SYN, 0 paws drops
TCP Connection Stats
0 attempts, 3 accepts, 3 established
3 closed, 2 drops, 0 conn drops
0 drop in retransmit timeout, 1 drop in keepalive timeout
0 drop in persist drops, 0 connections drained
TCP Miscellaneous Stats
115 segments timed, 121 rtt updated
0 retransmit timeout, 0 persist timeout
12 keepalive timeout, 11 keepalive probes
TCP SACK Stats
0 recovery episodes, 0 data packets, 0 data bytes
0 data packets retransmitted, 0 data bytes retransmitted
0 connections closed, 0 retransmit timeouts
TCP SYN Cache Stats
15 entries, 3 connections completed, 0 entries timed out
0 dropped due to overflow, 12 dropped due to RST
0 dropped due to ICMP unreach, 0 dropped due to bucket overflow
0 abort due to no memory, 0 duplicate SYN, 0 no-route SYN drop
0 hash collisions, 0 retransmitted
TCP Active Connections
Local Address Remote Address State Send-Q Recv-Q
0.0.0.0:3260 0.0.0.0:0 LISTEN 0 0

 

IP 統計情報を表示および確認するには、 show ips stats icmp interface gigabitethernet を使用します。このコマンドは、メイン イーサネット インターフェイスをパラメータとして受け取り、そのインターフェイスの ICMP 統計情報を返します。例 45-7 を参照してください。

例 45-7 ICMP 統計情報の表示

switch# show ips stats icmp interface gigabitethernet 2/1
ICMP Statistics for port GigabitEthernet2/1
0 ICMP messages received
0 ICMP messages dropped due to errors
ICMP input histogram
0 destination unreachable
0 time exceeded
0 parameter problem
0 source quench
0 redirect
0 echo request
0 echo reply
0 timestamp request
0 timestamp reply
0 address mask request
0 address mask reply
ICMP output histogram
0 destination unreachable
0 time exceeded
0 parameter problem
0 source quench
0 redirect
0 echo request
0 echo reply
0 timestamp request
0 timestamp reply
0 address mask request
0 address mask reply
 

デフォルト設定

表 45-1 に、IP ストレージ サービス パラメータのデフォルト設定を示します。

 

表 45-1 ギガビット イーサネットのデフォルト パラメータ

パラメータ
デフォルト

IPS コア サイズ

Partial