Cisco MDS 9000 ファミリ CLI コンフィギュレーション ガイド リリース 3.x Cisco MDS SAN-OS for Release 3.0(1) ~ 3.3(3)
高度な機能および概念
高度な機能および概念
発行日;2013/09/03 | 英語版ドキュメント(2011/01/05 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

高度な機能および概念

Common Information Model

CIM について

CIM サーバのセキュリティの強化

CIM 情報の表示

ファイバ チャネルの Time Out Value

すべての VSAN のタイマー設定

VSAN 単位のタイマー設定

fctimer 配信の概要

fctimer の配布のイネーブル化とディセーブル化

fctimer 設定変更のコミット

fctimer 設定変更の廃棄

ファブリックのロックの上書き

データベース マージの注意事項

設定された fctimer 値の表示

World Wide Names(WWN)

WWN 情報の表示

リンク初期化 WWN の使用法

セカンダリ MAC アドレスの設定

HBA の FC ID 割り当て

デフォルトの企業 ID リスト

企業 ID の設定の確認

スイッチの相互運用性

Interop モードの概要

interop モード 1 の設定

相互運用性ステータスの確認

デフォルト設定

高度な機能および概念

この章では、Cisco MDS 9000 ファミリのスイッチが提供する高度な機能について説明します。内容は次のとおりです。

「Common Information Model」

「ファイバ チャネルの Time Out Value」

「World Wide Names(WWN)」

「HBA の FC ID 割り当て」

「スイッチの相互運用性」

「デフォルト設定」

Common Information Model

共通情報モデル(CIM)は、既存の規格を拡張してネットワークやエンタープライズ環境の管理情報を記述するオブジェクト指向の情報モデルです。

ここでは、次の項目について説明します。

「CIM について」

「CIM サーバのセキュリティの強化」

「CIM 情報の表示」

CIM について

CIM メッセージは、N Extensible Markup Language(XML)で符号化されるため、プラットフォームおよび実装に依存しません。CIM は仕様とスキーマで構成されます。仕様には、管理データの記述および他の管理モデルとの統合に用いられる、構文とルールが定義されています。スキーマは、システム、アプリケーション、ネットワーク、およびデバイスの実際のモデルの説明を提供します。

CIM の詳細については、次の URL にある Distributed Management Task Force(DMTF)の Web サイトから入手可能な仕様を参照してください。 http://www.dmtf.org/

Cisco MDS 9000 ファミリでの CIM サーバのサポートの詳細については、『 Cisco MDS 9000 Family CIM Programming Reference Guide 』を参照してください。

CIM サーバにアクセスするには、CIM クライアントが必要です。CIM をサポートするクライアントであれば、どのようなクライアントでも利用できます。

CIM サーバのセキュリティの強化

セキュリティを向上させるために、SSL 証明書をインストールして、ログイン情報を暗号化し、CIM サーバをイネーブルにする前に、HTTPS サーバをイネーブルにすることができます。デフォルトでは CIM サーバはディセーブルになっています。HTTPS サーバをイネーブルにしない場合、標準 HTTP サーバがイネーブルになります(デフォルト)。

HTTPS プロトコルを使用して CIM サーバを設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# cimserver certificate bootflash:simserver.pem

.pem 拡張子を持つファイルで指定されている Secure Socket Layer(SSL)証明書をインストールします。

switch(config)# cimserver clearcertificate Certificate1

任意。指定された SSL 証明書(Certificate1)をクリアします。

ステップ 3

switch(config)# cimserver enableHttps

HTTPS をイネーブルにします(セキュアなプロトコル)。

switch(config)# no cimserver enableHttps

任意。HTTPS をディセーブルにします(デフォルト)。

ステップ 4

switch(config)# cimserver enable

CIM サーバをイネーブルにします。

switch(config)# no cimserver enable

任意。CIM サーバをディセーブルにします(デフォルト)。

HTTP プロトコルを使用して CIM サーバを設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# cimserver enable

デフォルトの HTTP(非セキュア)プロトコルを使用して CIM サーバをイネーブルにします。

switch(config)# no cimserver enable

任意。CIM サーバをディセーブルにします(デフォルト)。

switch(config)# no cimserver enableHttp

任意。HTTP をディセーブルにします。

switch(config)# cimserver enableHttp

任意。HTTP をディセーブルにし、スイッチのデフォルトに戻します。

CIM 情報の表示

CIM 情報を表示するには、 show cimserver コマンドを使用します(例 30-1 から例 30-12 を参照)。

例 30-1 CIM サーバ ステータスの表示

switch# show cimserver status
cimserver is enabled
 

例 30-2 CIM サーバの HTTPS ステータスの表示

switch# show cimserver httpsstatus
cimserver Https is enabled
 

例 30-3 CIM サーバの HTTP ステータスの表示

switch# show cimserver httpstatus
cimserver Http is not enabled
 

例 30-4 CIM サーバ表示の表示

switch# show cimserver indication
Filter: root/cimv2:Feb 7, 2008 2:32:11 PM
Query: "SELECT * FROM CISCO_LinkUp"
Query Language: WQL
-----------------------------------------
Handler: root/cimv2:CIM_ListenerDestinationCIMXML.Thu Feb 07 14:32:44 IST 20081202374964083
Destination: http://10.77.91.110:59901
PersistenceType: Transient
-----------------------------------------
Namespace: root/cimv2
Filter: root/cimv2:Feb 7, 2008 2:32:11 PM
Handler: root/cimv2:CIM_ListenerDestinationCIMXML.Thu Feb 07 14:32:44 IST 20081202374964083
Query: "SELECT * FROM CISCO_LinkUp"
Destination: http://10.77.91.110:59901
SubscriptionState: Enabled
-----------------------------------------
 

例 30-5 CIM サーバ表示のフィルタの表示

switch# show cimserver indication filters
Filter: root/cimv2:Feb 7, 2008 2:32:11 PM
Query: "SELECT * FROM CISCO_LinkUp"
Query Language: WQL
 

例 30-6 CIM サーバ表示の受信者の表示

switch# show cimserver indication recipients
Handler: root/cimv2:CIM_ListenerDestinationCIMXML.Thu Feb 07 14:32:44 IST 20081202374964083
Destination: http://10.77.91.110:59901
PersistenceType: Transient
 

例 30-7 CIM サーバ表示のサブスクリプションの表示

switch# show cimserver indication subscriptions
Namespace: root/cimv2
Filter: root/cimv2:Feb 7, 2008 2:32:11 PM
Handler: root/cimv2:CIM_ListenerDestinationCIMXML.Thu Feb 07 14:32:44 IST 20081202374964083
Query: "SELECT * FROM CISCO_LinkUp"
Destination: http://10.77.91.110:59901
SubscriptionState: Enabled
cimserver certificate file name is servcert.pem
 

例 30-8 CIM サーバの設定の表示

switch# show cimserver
cimserver is enabled
cimserver Http is not enabled
cimserver Https is enabled
cimserver certificate file name is servcert.pem
 

例 30-9 CIM サーバのログの表示

switch# show cimserver logshttpsstatus
02/07/2008-16:38:14 INFO cimserver: Sent response to: localhost
02/07/2008-16:38:26 INFO cimserver: Received request from: 10.77.91.110
02/07/2008-16:38:27 INFO cimserver: Sent response to: 10.77.91.110
 

例 30-10 CIM サーバのログレベルの設定

switch# conf t
Enter configuration commands, one per line.End with CNTL/Z.
switch(config)# cimserver logLevel ?
<1-5> 1-trace;2-information;3-warning;4-severe;5-fatal
switch(config)# cimserver logLevel 2
Current value for the property logLevel is set to "INFORMATION" in CIMServer.
cimserver Https is enabled
 

例 30-11 CIM サーバの証明書ファイルの表示

switch# show cimserver certificateName
cimserver certificate file name is servcert.pem
 

例 30-12 CIM サーバの証明書ファイルをクリアする場合

switch(config)# cimserver clearcertificate
 

ファイバ チャネルの Time Out Value

ファイバ チャネル プロトコルに関連するスイッチ タイマー値を変更するには、次の Time Out Value(TOV)を設定します。

Distributed Services TOV(D_S_TOV):有効範囲は 5,000 ~ 10,000 ミリ秒です。デフォルトは 5,000 ミリ秒です。

Error Detect TOV(E_D_TOV):有効範囲は 1,000 ~ 10,000 ミリ秒です。デフォルトは 2,000 ミリ秒です。この値は、ポート初期化中に他端と比較されます。

Resource Allocation TOV(R_A_TOV):有効範囲は 5,000 ~ 10,000 ミリ秒です。デフォルトは 10,000 ミリ秒です。この値は、ポート初期化中に他端と比較されます。


) Fabric Stability TOV(F_S_TOV)定数は設定できません。


この項では、次のトピックについて取り上げます。

「すべての VSAN のタイマー設定」

「VSAN 単位のタイマー設定」

「fctimer 配信の概要」

「fctimer の配布のイネーブル化とディセーブル化」

「fctimer 設定変更のコミット」

「fctimer 設定変更の廃棄」

「ファブリックのロックの上書き」

「データベース マージの注意事項」

「設定された fctimer 値の表示」

すべての VSAN のタイマー設定

ファイバ チャネル プロトコルに関連するスイッチのタイマー値を変更できます。


注意 D_S_TOV、E_D_TOV、および R_A_TOV 値は、スイッチ内のすべての VSAN を一時停止しないかぎり、グローバルに変更できません。


) タイマー値を変更するときに VSAN を指定しない場合は、変更された値がスイッチ内のすべての VSAN に適用されます。


すべての VSAN にファイバ チャネル タイマーを設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# config t

switch(config)

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# fctimer R_A_TOV 6000

すべての VSAN の R_A_TOV 値を 6000 ミリ秒に設定します。このタイプの設定は、すべての VSAN が一時停止されていないかぎり、許可されません。

VSAN 単位のタイマー設定

VSAN を指定して fctimer を発行し、VSAN に異なる TOV 値を設定して FC や IP トンネルなどに特別にリンクさせることができます。VSAN ごとに異なる E_D_TOV、R_A_TOV、および D_S_TOV 値を設定できます。アクティブ VSAN のタイマー値を変更すると、VSAN は一時停止されてからアクティブになります。


注意 以前のバージョンでは VSAN ごとの FC タイマーをサポートしておらず、中断のないダウングレードは実行できません。


) この設定はファブリックのすべてのスイッチに伝播する必要があります。ファブリックのすべてのスイッチが同じ値に設定されていることを確認してください。


タイマーを VSAN 用に設定した後にスイッチが Cisco MDS SAN-OS Release 1.2 または 1.1 にダウングレードされると、厳密に互換性がないことを警告するエラー メッセージが表示されます。『 Cisco MDS 9000 Family Troubleshooting Guide 』を参照してください。

VSAN 単位のファイバ チャネル タイマーを設定する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# config t

switch(config)

コンフィギュレーション モードに入ります。

ステップ 2

switch(config#)# fctimer D_S_TOV 6000 vsan 2

Warning: The vsan will be temporarily suspended when updating the timer value This configuration would impact whole fabric. Do you want to continue? (y/n) y

Since this configuration is not propagated to other switches, please configure the same value in all the switches

VSAN 2 の D_S_TOV 値を 6000 ミリ秒に設定します。VSAN が一時的に停止します。必要に応じて、このコマンドを終了することもできます。

fctimer 配信の概要

ファブリック内のすべての Cisco MDS スイッチで、VSAN 単位の fctimer ファブリック配信をイネーブルにできます。fctimer の設定を実行して、配布をイネーブルにすると、ファブリック内のすべてのスイッチにその設定が配布されます。

スイッチでの配信をイネーブルにした後で最初のコンフィギュレーション コマンドを発行すると、ファブリック全体が自動的にロックされます。fctimer アプリケーションは、有効データベースと保留データベース モデルを使用し、使用中のコンフィギュレーションに基づいてコマンドを格納またはコミットします。

CFS アプリケーションの詳細については、「CFS インフラストラクチャの使用」を参照してください。

fctimer の配布のイネーブル化とディセーブル化

fctimer ファブリック配信をイネーブルまたはディセーブルにする手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# fctimer distribute

ファブリック内のすべてのスイッチに対する fctimer 設定の配布をイネーブルにします。ファブリックのロックを取得して、その後の設定変更をすべて保留データベースに格納します。

switch(config)# no fctimer distribute

ファブリック内のすべてのスイッチに対する fctimer 設定の配布をディセーブル(デフォルト)にします。

fctimer 設定変更のコミット

fctimer の設定変更をコミットすると、有効データベースは保留データベースの設定変更によって上書きされ、ファブリック内のすべてのスイッチが同じ設定を受け取ります。セッション機能を実行せずに fctimer の設定変更をコミットすると、fctimer 設定は物理ファブリック内のすべてのスイッチに配布されます。

fctimer の設定変更をコミットする手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# fctimer commit

ファブリック内のすべてのスイッチに対して fctimer の設定変更を配布し、ロックを解除します。保留データベースに対する変更を有効データベースに上書きします。

fctimer 設定変更の廃棄

設定変更を加えたあと、変更内容をコミットする代わりに廃棄すると、この変更内容を廃棄できます。いずれの場合でも、ロックは解除されます。

fctimer の設定変更を廃棄する手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# fctimer abort

保留データベースの fctimer の設定変更を廃棄して、ファブリックのロックを解除します。

ファブリックのロックの上書き

ユーザが fctimer を設定して、変更のコミットや廃棄を行ってロックを解除するのを忘れていた場合、管理者はファブリック内の任意のスイッチからロックを解除できます。管理者がこの操作を行うと、ユーザによる保留データベースの変更は廃棄され、ファブリックのロックは解除されます。


ヒント 変更は volatile ディレクトリだけで使用でき、スイッチを再起動すると廃棄されます。

管理者特権を使用して、ロックされた fctimer セッションを解除するには、 clear fctimer session コマンドを使用します。

switch# clear fctimer session
 

データベース マージの注意事項

概念の詳細については、「CFS マージのサポート」を参照してください。

2 つのファブリックを結合する場合は、次の注意事項に従ってください。

次の結合条件を確認します。

マージ プロトコルが実装済みでも fctimer 値は配信されるとはかぎりません。ファブリックをマージするときは、fctimer 値を手動でマージする必要があります。VSAN 単位の fctimer 設定は、物理ファブリック内に配信されます。

fctimer 設定は、変更された fctimer 値を持つ VSAN が含まれるスイッチだけに適用される。

グローバルな fctimer 値は配布されない。

配布がイネーブルになっている場合は、グローバル タイマーの値を設定しないでください。


) 保留できる fctimer 設定操作の回数は 15 回以内です。この数に達した時点で、さらに処理を実行するには、保留中の設定をコミットするか、打ち切る必要があります。


設定された fctimer 値の表示

設定された fctimer 値を表示するには、 show fctimer コマンドを使用します(例 30-13 30-14 を参照)。

例 30-13 設定されたグローバル TOV の表示

switch# show fctimer
F_S_TOV D_S_TOV E_D_TOV R_A_TOV
----------------------------------------
5000 ms 5000 ms 2000 ms 10000 ms
 

show fctimer コマンドの出力には、(設定されていない場合でも)F_S_TOV 定数が表示されます。


例 30-14 指定した VSAN の設定された TOV の表示

switch# show fctimer vsan 10
vsan no.F_S_TOV D_S_TOV E_D_TOV R_A_TOV
-------------------------------------------------
10 5000 ms 5000 ms 3000 ms 10000 ms
 

World Wide Names(WWN)

スイッチの WWN は、イーサネット MAC アドレスと同等です。MAC アドレスと同様に、デバイスごとに WWN を一意に対応付ける必要があります。主要スイッチを選択するとき、およびドメイン ID を割り当てるときは、WWN を使用します。WWN は、スイッチのスーパーバイザ モジュールのプロセスレベル マネージャである WWN マネージャによって、各スイッチに割り当てられます。

Cisco MDS 9000 ファミリのスイッチは、3 つの Network Address Authority(NAA)アドレス フォーマットをサポートしています( 表 30-1 を参照)。

 

表 30-1 標準化された NAA WWN フォーマット

NAA アドレス
NAA タイプ
WWN フォーマット

IEEE 48 ビット アドレス

タイプ 1 = 0001b

000 0000 0000b

48 ビット MAC アドレス

IEEE 拡張

タイプ 2 = 0010b

ローカルに割り当て

48 ビット MAC アドレス

IEEE 登録

タイプ 5 = 0101b

IEEE 企業 ID:24 ビット

VSID:36 ビット


注意 WWN の変更は、管理者または、スイッチの操作に精通した担当者が実行してください。

この項では、次のトピックについて取り上げます。

「WWN 情報の表示」

「リンク初期化 WWN の使用法」

「セカンダリ MAC アドレスの設定」

WWN 情報の表示

WWN 設定のステータスを表示するには、 show wwn コマンドを使用します。例 30-15 30-17 を参照してください。

例 30-15 すべての WWN のステータスの表示

switch# show wwn status
Type 1 WWNs: Configured: 64 Available: 48 (75%) Resvd.: 16
Types 2 & 5 WWNs: Configured: 524288 Available: 450560 (85%) Resvd.: 73728
NKAU & NKCR WWN Blks: Configured: 1760 Available: 1760 (100%)
Alarm Status: Type1: NONE Types 2&5: NONE
 

例 30-16 指定したブロック ID 情報の表示

switch# show wwn status block-id 51
WWNs in this block: 21:00:ac:16:5e:52:00:03 to 21:ff:ac:16:5e:52:00:03
Num.of WWNs:: Configured: 256 Allocated: 0 Available: 256
Block Allocation Status: FREE
 

例 30-17 指定したスイッチの WWN の表示

switch# show wwn switch
Switch WWN is 20:00:ac:16:5e:52:00:00
 

リンク初期化 WWN の使用法

Exchange Link Protocol(ELP)および Exchange Fabric Protocol(EFP)は、リンク初期化の際に WWN を使用します。使用方法の詳細は、Cisco SAN-OS ソフトウェア リリースごとに異なります。

ELP と EFP のどちらも、リンク初期化中にデフォルトで VSAN WWN を使用します。ただし、ELP の使用方法はピア スイッチの使用方法に応じて変わります。

ピア スイッチの ELP がスイッチの WWN を使用する場合、ローカル スイッチもスイッチの WWN を使用します。

ピア スイッチの ELP が VSAN の WWN を使用する場合、ローカル スイッチも VSAN の WWN を使用します。


) Cisco SAN-OS Release 2.0(2b) 時点で、ELP は FC-SW-3 に準拠するように機能拡張されました。


セカンダリ MAC アドレスの設定

セカンダリ MAC アドレスを割り当てる手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# config t

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# wwn secondary-mac 00:99:55:77:55:55 range 64

This command CANNOT be undone.

Please enter the BASE MAC ADDRESS again: 00:99:55:77:55:55

Please enter the mac address RANGE again: 64

From now on WWN allocation would be based on new MACs.

Are you sure? (yes/no) no

You entered: no. Secondary MAC NOT programmed

セカンダリ MAC アドレスを設定します。このコマンドは元に戻せません。

HBA の FC ID 割り当て

ファイバ チャネル標準では、任意のスイッチの Fx ポートに接続された N ポートに、一意の FC ID を割り当てる必要があります。使用する FC ID 数を節約するために、Cisco MDS 9000 ファミリ スイッチは特殊な割り当て方式を使用します。

一部の Host Bus Adapter(HBA)は、ドメインとエリアが同じ FC ID を持つターゲットを検出しません。Cisco SAN-OS Release 2.0(1b) よりも前の Cisco SAN-OS ソフトウェアでは、この動作をサポートしないテスト済みの企業 ID のリストを保持していました。これらの HBA には、単一の FCID が割り当てられ、残りにはエリア全体が割り当てられます。

Release 1.3 以前で使用可能な FC ID 割り当て方式では、これらの HBA に領域全体を割り当てます。このように割り当てることによって、これらの HBA が該当領域から分離され、ファブリック ログイン時に pWWN とともにリストされるようになります。割り当てられた FC ID は常にキャッシュされ、Cisco SAN-OS Release 2.0(1b) でも使用できます(「HBA の FC ID 割り当て」 を参照)。

多数のポートを備えたスイッチの拡張性を高めるために、Cisco SAN-OS ソフトウェアはこの動作をサポートする HBA のリストを保持します。ファブリック ログインの間、pWWN で使用される企業 ID(組織固有識別子(OUI)としても知られる)によってそれぞれの HBA が識別されます。したがって、リストされた企業 ID を持つ N ポートにはエリア全体が割り当てられ、その他のポートには単一の FC ID が割り当てられます。割り当てられた FC ID の種類(エリア全体か単独か)に関わりなく、FC ID エントリは永続的です。

この項では、次のトピックについて取り上げます。

「デフォルトの企業 ID リスト」

「企業 ID の設定の確認」

デフォルトの企業 ID リスト

Cisco SAN-OS Release 2.0(1b) 以降に付属の Cisco MDS 9000 ファミリ内のすべてのスイッチには、エリア割り当てが必要な企業 ID のデフォルト リストが格納されています。この企業 ID を使用すると、設定する永続的 FC ID エントリの数が少なくなります。これらのエントリは、CLI を使用して設定または変更できます。


注意 永続的エントリは、企業 ID の設定よりも優先されます。HBA がターゲットを検出しない場合は、HBA とターゲットが同じスイッチに接続され、FC ID のエリアが同じであることを確認してから、次の手順を実行します。

1.HBA に接続されているポートをシャットダウンします。
2.永続的 FC ID エントリをクリアします。
3.ポート WWN から企業 ID を取得します。
4.エリア割り当てを必要とするリストに企業 ID を追加します。
5.ポートをアップにします。

企業 ID のリストには、次の特性があります。

永続的 FC ID の設定は常に企業 ID リストよりも優先されます。このため、エリアを受け取るように企業 ID が設定されている場合でも、永続的 FC ID の設定によって単一の FC ID が割り当てられます。

後続のリリースに追加される新規の企業 ID は、既存の企業 ID に自動的に追加されます。

企業 ID のリストは、実行コンフィギュレーションおよび保存されたコンフィギュレーションの一部として保存されます。

企業 ID のリストが使用されるのは、fcinterop の FC ID 割り当て方式が auto モードの場合だけです。変更されないかぎり、interop の FC ID 割り当ては、デフォルトで auto に設定されています。


ヒント fcinterop の FC ID 割り当て方式を auto に設定し、企業 ID リストと永続的 FC ID 設定を使用して、FC ID のデバイス割り当てを行うことをお勧めします。


FC ID の割り当てを変更するには、 fcinterop FCID allocation auto コマンドを使用し、現在割り当てられているモードを表示するには、 show running-config コマンドを使用します。

write erase を発行すると、リストは該当するリリースに付属している企業 ID のデフォルト リストを継承します。

企業 ID を割り当てる手順は、次のとおりです。

コマンド
目的

ステップ 1

switch# config t

switch(config)#

コンフィギュレーション モードに入ります。

ステップ 2

switch(config)# fcid-allocation area company-id 0x003223

デフォルト リストに新しい企業 ID を追加します。

switch(config)# no fcid-allocation area company-id 0x00E069

デフォルト リストから企業 ID を削除します。

switch(config)# fcid-allocation area company-id 0x003223

デフォルト リストに新しい企業 ID を追加します。

企業 ID の設定の確認

設定された企業 ID を表示するには、 show fcid-allocation area コマンドを発行します(例 30-18 を参照)。最初にデフォルト エントリが表示され、次にユーザによって追加されたエントリが表示されます。エントリがデフォルト リストの一部で、あとで削除された場合でも、エントリは表示されます。

例 30-18 デフォルトおよび設定された企業 ID のリストの表示

switch# show fcid-allocation area
FCID area allocation company id info:
00:50:2E <-------------------- デフォルト エントリ
00:50:8B
00:60:B0
00:A0:B8
00:E0:69
00:30:AE + <------------------ ユーザが追加したエントリ
00:32:23 +
 
00:E0:8B * <------------- (オリジナルのデフォルト リストから)明示的に削除されたエントリ
Total company ids: 7
+ - Additional user configured company ids.
* - Explicitly deleted company ids from default list.
 

削除済みエントリの印が付いていない企業 ID のリストを組み合わせると、特定のリリースに付属するデフォルト エントリを暗黙的に導き出すことができます。

また、 show fcid-allocation company-id-from-wwn コマンドを発行すると、特定の WWN の企業 ID を表示または取得することもできます(例 30-19 を参照)。一部の WWN 形式では、企業 ID がサポートされていません。この場合、FC ID の永続的エントリを設定する必要があります。

例 30-19 指定した WWN の企業 ID の表示

switch# show fcid-allocation company-id-from-wwn 20:00:00:05:30:00:21:60
Extracted Company ID: 0x000530
 

スイッチの相互運用性

相互運用性により、複数ベンダー製品間の相互接続が可能になっています。ファイバ チャネル標準規格では、ベンダーに対して共通の外部ファイバ チャネル インターフェイスを使用することを推奨しています。

すべてのベンダーが同じ方法で標準に従っていれば、異なる製品の相互接続が問題になることはありません。ただし、同じ方法で標準に従っていないベンダーもあるため、interop モードが開発されました。ここでは、これらのモードの基本的な概念について簡単に説明します。

各ベンダーには標準モード、および同等の相互運用性モードがあります。相互運用性モードでは拡張機能または独自の機能が無効になり、より使いやすい、標準に準拠した実装が可能になります。


) Cisco MDS 9000 ファミリ スイッチの相互運用性の設定の詳細については、『Cisco MDS Family Switch-to-Switch Interoperability Configuration Guide』を参照してください。


この項では、次のトピックについて取り上げます。

「Interop モードの概要」

「interop モード 1 の設定」

「相互運用性ステータスの確認」

Interop モードの概要

Cisco SAN-OS ソフトウェアは、次の 4 つの interop モードをサポートします。

モード 1:ファブリック内のその他のすべてのベンダーを interop モードにする必要がある、標準ベースの interop モード

モード 2:Brocade ネイティブ モード(Core PID 0)

モード 3:Brocade ネイティブ モード(Core PID 1)

モード 4:McData ネイティブ モード

interop モード 2、3、および 4 の設定方法については、『 Cisco MDS 9000 Family Switch-to-Switch Interoperability Configuration Guide 』を参照してください。

表 30-2 に、interop モードをイネーブルにした場合のスイッチ動作の変更点を示します。これらは、interop モードになっている Cisco MDS 9000 ファミリのスイッチに固有の変更点です。

 

表 30-2 相互運用性がイネーブルの場合のスイッチ動作の変更点

スイッチ機能
相互運用モードがイネーブルの場合の変更点

ドメイン ID

一部のベンダーは、ファブリック内の 239 のドメインを完全には使用できません。

ドメイン ID は 97 ~ 127 の範囲に制限されています。これは、McData の通常の制限をこの範囲に収めるためです。ドメイン ID の設定方法には、静的に設定する(Cisco MDS スイッチは 1 つのドメイン ID だけを受け入れ、そのドメイン ID を取得できない場合はファブリックから隔離する)方法と、優先設定を使用する (スイッチが要求したドメイン ID を取得できない場合、割り当てられた任意のドメイン ID を受け入れる)方法があります。

タイマー

ISL(スイッチ間リンク)を確立するときにファイバ チャネル タイマー値が E ポートで交換されるので、すべてのスイッチでこれらのタイマーをすべて同じにする必要があります。タイマーには、F_S_TOV、D_S_TOV、E_D_TOV、および R_A_TOV があります。

F_S_TOV

Fabric Stability TOV タイマーが正確に一致するかどうかを確認してください。

D_S_TOV

Distributed Services TOV タイマーが正確に一致するかどうかを確認してください。

E_D_TOV

Error Detect TOV タイマーが正確に一致するかどうかを確認してください。

R_A_TOV

Resource Allocation TOV タイマーが正確に一致するかどうかを確認してください。

トランキング

2 つの異なるベンダー製のスイッチ間では、トランキングはサポートされません。この機能はポート単位、またはスイッチ単位でディセーブルに設定できます。

デフォルト ゾーン

ゾーンのデフォルトの許可動作(すべてのノードから他のすべてのノードを認識可能)または拒否動作(明示的にゾーンに配置されていないすべてのノードが隔離される)は、変更できます。

ゾーン分割属性

ゾーンを pWWN に制限したり、その他の独自のゾーン分割方式(物理ポート番号)を除去することができます。

コマンドを使用して、ファブリック全体のゾーン分割設定を保存します。このコマンドは、同じファブリックに属す Cisco MDS 9000 ファミリ スイッチには影響しません。Cisco MDS 9000 ファミリの各スイッチに、設定を明示的に保存する必要があります。

ゾーンの伝播

一部のベンダーは、他のスイッチに完全なゾーン設定を受け渡さないで、アクティブ ゾーン セットだけを受け渡します。

ファブリック内の他のスイッチにアクティブ ゾーンセットまたはゾーン設定が正しく伝播されたかどうかを確認してください。

VSAN

interop モードは、指定された VSAN にだけ有効です。

(注) interop モードは、FICON 対応の VSAN でイネーブルにできません。

TE ポートと PortChannel

TE ポートと PortChannel を使用して、Cisco MDS を Cisco 以外の MDS スイッチに接続することはできません。Cisco MDS 以外のスイッチに接続できるのは、E ポートだけです。TE ポートと PortChannel を使用すると、interop モードの場合でも、Cisco MDS をその他の Cisco MDS スイッチに接続できます。

FSPF

interop モードにしても、ファブリック内のフレームのルーティングは変更されません。スイッチは引き続き src-id、dst-id、および ox-id を使用して、複数の ISL リンク間でロード バランスします。

ドメインの中断再設定

これは、スイッチ全体に影響するイベントです。Brocade および McData では、ドメイン ID を変更するときにスイッチ全体をオフライン モードにしたり、再起動したりする必要があります。

ドメインの非中断再設定

これは、関連する VSAN に限定されるイベントです。スイッチ全体ではなく、関連する VSAN の Domain Manager プロセスだけが再起動される機能は、Cisco MDS 9000 ファミリのスイッチだけに組み込まれています。

ネーム サーバ

すべてのベンダーのネーム サーバ データベースに正しい値が格納されているかを確認してください。

IVRivr

IVR 対応の VSAN は、 no interop (デフォルト)モード、または interop モードのいずれかで設定できます。

interop モード 1 の設定

Cisco MDS 9000 ファミリ スイッチの interop モード 1 のイネーブル化は、中断を伴うかまたは中断を伴わずに行うことができます。


) Brocade スイッチから Cisco MDS 9000 ファミリ スイッチまたは McData スイッチに接続する前に、Brocade の msplmgmtdeactivate コマンドを確実に実行する必要があります。このコマンドでは、Brocade 独自のフレームを使用して、Cisco MDS 9000 スイッチまたは McData スイッチが認識しないプラットフォーム情報を交換します。これらのフレームを拒否すると、一般的な E ポートが隔離されます。


Cisco MDS 9000 ファミリの任意のスイッチに interop モード 1 を設定する手順は、次のとおりです。


ステップ 1 他ベンダー製スイッチに接続する E ポートの VSAN を相互運用モードにします。

switch# config t
switch(config)# vsan database
switch(config-vsan-db)# vsan 1 interop 1
switch(config-vsan-db)# exit
switch(config)#
 

) FICON 対応 VSAN では、INTEROP モードをイネーブルにできません。


ステップ 2 97(0x61)~ 127(0x7F)の範囲でドメイン ID を割り当てます。


) これは、McData スイッチに適用される制限です。


switch(config)# fcdomain domain 100 preferred vsan 1
 

Cisco MDS 9000 スイッチの場合、デフォルトでは、主要スイッチから ID が要求されます。Preferred オプションを使用した場合、Cisco MDS 9000 スイッチは固有の ID を要求しますが、主要スイッチから別の ID が割り当てられた場合もファブリックに加入します。Static オプションを使用した場合、要求された ID を主要スイッチが承認して、これを割り当てない限り、Cisco MDS 9000 スイッチはファブリックに参加しません。


) ドメイン ID を変更すると、N ポートに割り当てられた FC ID も変更されます。


ステップ 3 FC タイマーを変更します(システム デフォルトから変更された場合)。


) Cisco MDS 9000、Brocade、McData FC Error Detect(ED_TOV)、および Resource Allocation(RA_TOV)の各タイマーは、同じ値にデフォルト設定されています。これらの値は、必要に応じて変更できます。RA_TOV のデフォルト値は 10 秒、ED_TOV のデフォルト値は 2 秒です。FC-SW2 標準に基づく場合、これらの値は、ファブリック内の各スイッチで一致している必要があります。


switch(config)# fctimer e_d_tov ?
<1000-100000> E_D_TOV in milliseconds(1000-100000)
switch(config)# fctimer r_a_tov ?
<5000-100000> R_A_TOV in milliseconds(5000-100000)
 

ステップ 4 ドメインを変更するときに、変更された VSAN の Cisco MDS ドメイン マネージャ機能の再起動が必要な場合と、不要な場合があります。

disruptive オプションを使用して、ファブリックを強制的に再設定する場合は次のようになります。

switch(config)# fcdomain restart disruptive vsan 1
 

または

ファブリックを強制的に再設定しない場合は次のようになります。

switch(config# fcdomain restart vsan 1
 


 

相互運用性ステータスの確認

ここでは、ファブリックが起動していて、相互運用性モードで稼働していることを確認するためのコマンドについて説明します。

Cisco MDS 9000 ファミリのスイッチで相互運用性コマンドを発行した結果のステータスを確認するには、次の手順を実行します。


ステップ 1 show version コマンドを使用して、バージョンを確認します。

switch# show version
Cisco Storage Area Networking Operating System (SAN-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2003, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
Cisco Systems, Inc. and/or other third parties and are used and
distributed under license.Some parts of this software are covered
under the GNU Public License.A copy of the license is available
http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 1.0.8
loader: version 1.1(2)
kickstart: version 2.0(1) [build 2.0(0.6)] [gdb]
system: version 2.0(1) [build 2.0(0.6)] [gdb]
 
BIOS compile time: 08/07/03
kickstart image file is: bootflash:///m9500-sf1ek9-kickstart-mzg.2.0.0.6.bin
kickstart compile time: 10/25/2010 12:00:00
system image file is: bootflash:///m9500-sf1ek9-mzg.2.0.0.6.bin
system compile time: 10/25/2020 12:00:00
 
 
Hardware
RAM 1024584 kB
 
bootflash: 1000944 blocks (block size 512b)
slot0: 0 blocks (block size 512b)
 
172.22.92.181 uptime is 0 days 2 hours 18 minute(s) 1 second(s)
 
Last reset at 970069 usecs after Tue Sep 16 22:31:25 1980
Reason: Reset Requested by CLI command reload
System version: 2.0(0.6)
Service:
 

ステップ 2 show interface brief コマンドを使用して、インターフェイスの状態が設定に必要な状態になっているかどうかを確認します。

switch# show int brief
Interface Vsan Admin Admin Status Oper Oper Port-channel
Mode Trunk Mode Speed
Mode (Gbps)
--------------------------------------------------------------------
fc2/1 1 auto on up E 2 --
fc2/2 1 auto on up E 2 --
fc2/3 1 auto on fcotAbsent -- -- --
fc2/4 1 auto on down -- -- --
fc2/5 1 auto on down -- -- --
fc2/6 1 auto on down -- -- --
fc2/7 1 auto on up E 1 --
fc2/8 1 auto on fcotAbsent -- -- --
fc2/9 1 auto on down -- -- --
fc2/10 1 auto on down -- -- --
 

ステップ 3 show run コマンドを使用して、必要な設定を実行しているかどうかを確認します。

switch# show run
Building Configuration...
 
interface fc2/1
no shutdown
 
interface fc2/2
no shutdown
 
interface fc2/3
interface fc2/4
interface fc2/5
interface fc2/6
interface fc2/7
no shutdown
 
interface fc2/8
interface fc2/9
interface fc2/10
 
<省略>
 
interface fc2/32
 
interface mgmt0
ip address 6.1.1.96 255.255.255.0
switchport encap default
no shutdown
 
vsan database
vsan 1 interop
 
boot system bootflash:/m9500-system-253e.bin sup-1
boot kickstart bootflash:/m9500-kickstart-253e.bin sup-1
boot system bootflash:/m9500-system-253e.bin sup-2
boot kickstart bootflash:/m9500-kickstart-253e.bin sup-2
callhome
 
fcdomain domain 100 preferred vsan 1
 
ip route 6.1.1.0 255.255.255.0 6.1.1.1
ip routing
line console
databits 5
speed 110
logging linecard
ssh key rsa 512 force
ssh server enable
switchname MDS9509
username admin password 5 $1$Li8/fBYX$SNc72.xt4nTXpSnR9OUFB/ role network-admin
 

ステップ 4 show vsan コマンドを使用して、相互運用性モードがアクティブかどうかを確認します。

switch# show vsan 1
vsan 1 information
name:VSAN0001 stalactites
interoperability mode:yes <-------------------- モードの確認
loadbalancing:src-id/dst-id/oxid
operational state:up
 

ステップ 5 show fcdomain vsan コマンドを使用して、ドメイン ID を確認します。

switch# show fcdomain vsan 1
The local switch is a Subordinated Switch.
 
Local switch run time information:
State: Stable
Local switch WWN: 20:01:00:05:30:00:51:1f
Running fabric name: 10:00:00:60:69:22:32:91
Running priority: 128
Current domain ID: 0x64(100) <---------------ドメイン ID の確認
 
Local switch configuration information:
State: Enabled
Auto-reconfiguration: Disabled
Contiguous-allocation: Disabled
Configured fabric name: 41:6e:64:69:61:6d:6f:21
Configured priority: 128
Configured domain ID: 0x64(100) (preferred)
 
Principal switch run time information:
Running priority: 2
 
Interface Role RCF-reject
---------------- ------------- ------------
fc2/1 Downstream Disabled
fc2/2 Downstream Disabled
fc2/7 Upstream Disabled
---------------- ------------- ------------
 

ステップ 6 show fcdomain domain-list vsan コマンドを使用して、ローカル主要スイッチのステータスを確認します。

switch# show fcdomain domain-list vsan 1
 
Number of domains: 5
Domain ID WWN
--------- -----------------------
0x61(97) 10:00:00:60:69:50:0c:fe
0x62(98) 20:01:00:05:30:00:47:9f
0x63(99) 10:00:00:60:69:c0:0c:1d
0x64(100) 20:01:00:05:30:00:51:1f [Local]
0x65(101) 10:00:00:60:69:22:32:91 [Principal]
--------- -----------------------
 

ステップ 7 show fspf internal route vsan コマンドを使用して、スイッチのネクスト ホップと宛先を確認します。

switch# show fspf internal route vsan 1
 
FSPF Unicast Routes
---------------------------
VSAN Number Dest Domain Route Cost Next hops
-----------------------------------------------
1 0x61(97) 500 fc2/2
1 0x62(98) 1000 fc2/1
fc2/2
1 0x63(99) 500 fc2/1
1 0x65(101) 1000 fc2/7
 

ステップ 8 show fcns data vsan コマンドを使用して、ネーム サーバ情報を確認します。

switch# show fcns data vsan 1
VSAN 1:
------------------------------------------------------------------
FCID TYPE PWWN (VENDOR) FC4-TYPE:FEATURE
------------------------------------------------------------------
0x610400 N 10:00:00:00:c9:24:3d:90 (Emulex) scsi-fcp
0x6105dc NL 21:00:00:20:37:28:31:6d (Seagate) scsi-fcp
0x6105e0 NL 21:00:00:20:37:28:24:7b (Seagate) scsi-fcp
0x6105e1 NL 21:00:00:20:37:28:22:ea (Seagate) scsi-fcp
0x6105e2 NL 21:00:00:20:37:28:2e:65 (Seagate) scsi-fcp
0x6105e4 NL 21:00:00:20:37:28:26:0d (Seagate) scsi-fcp
0x630400 N 10:00:00:00:c9:24:3f:75 (Emulex) scsi-fcp
0x630500 N 50:06:01:60:88:02:90:cb scsi-fcp
0x6514e2 NL 21:00:00:20:37:a7:ca:b7 (Seagate) scsi-fcp
0x6514e4 NL 21:00:00:20:37:a7:c7:e0 (Seagate) scsi-fcp
0x6514e8 NL 21:00:00:20:37:a7:c7:df (Seagate) scsi-fcp
0x651500 N 10:00:00:e0:69:f0:43:9f (JNI)
 
Total number of entries = 12
 

) Cisco MDS ネーム サーバには、ローカル エントリとリモート エントリの両方が表示され、エントリはタイムアウトしません。


デフォルト設定

表 30-4 に、この章で説明した機能のデフォルト設定を示します。

 

表 30-3 拡張機能のデフォルト設定値

パラメータ
デフォルト

CIM サーバ

ディセーブル

CIM サーバ セキュリティ プロトコル

HTTP

D_S_TOV

5,000 ミリ秒

E_D_TOV

2,000 ミリ秒

R_A_TOV

10,000 ミリ秒

fctrace を呼び出すタイムアウト時間

5 秒

fcping 機能によって送信されるフレーム数

5 フレーム

リモート キャプチャ接続プロトコル

TCP

リモート キャプチャ接続モード

パッシブ

ローカル キャプチャ フレームの制限

10 フレーム

FC ID の割り当てモード

auto モード

ループ モニタリング

ディセーブル

表 30-4 拡張機能のデフォルト設定値

パラメータ
デフォルト

D_S_TOV

5,000 ミリ秒

E_D_TOV

2,000 ミリ秒

R_A_TOV

10,000 ミリ秒

interop モード

ディセーブル