Cisco MDS 9000 ファミリー CLI クイック コンフィギュレーション ガイド
VSAN とインターフェイスの設定
VSAN とインターフェイスの設定
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 944KB) | フィードバック

目次

VSAN とインターフェイスの設定

VSAN の作成

デフォルト VSAN

VSAN の作成と設定

VSAN メンバーシップの割り当て

VSAN 情報の表示

インターフェイスの設定

ファイバ チャネル インターフェイスの設定

各種インターフェイスの設定

インターフェイスの有効化

インターフェイス モードの設定

管理インターフェイスの設定

VSAN インターフェイスの作成

インターフェイス情報の表示

VSAN とインターフェイスの設定

ファイバ チャネル ファブリックでは、Virtual Storage Area Network(VSAN; 仮想ストレージ エリア ネットワーク)を使用することによって、より高度なセキュリティと安定性を得ることができます。VSAN は、物理的に同一のファブリックに接続された装置間で分離構成を提供します。

インターフェイスは VSAN のメンバーです。 インターフェイスを使用することにより、同じ VSAN に属しているスイッチ間で通信できるようになります。 同じ VSAN のメンバーであるインターフェイスは互いに通信できますが、別々の VSAN のメンバーであるインターフェイスは互いに通信できません。

VSAN とインターフェイスを設定するのに必要な各手順を図3-1 に示しました。

図3-1 VSAN とインターフェイス

 

この章の具体的な内容は、次のとおりです。

「VSAN の作成」

「インターフェイスの設定」

「インターフェイスの有効化」

「インターフェイス情報の表示」

VSAN の作成

VSAN では、共通の物理インフラストラクチャ上に、複数の論理 SAN を作成することができます。 各 VSAN に最大 239 のスイッチを含めることができ、各 VSAN は、別の VSAN でも同時に同じ Fibre Channel ID(FC ID; ファイバ チャネル ID)を使用することが可能な独立したアドレス領域を持ちます。

デフォルト VSAN

VSAN 1(「デフォルト VSAN」ともいう)は、多くの場合、通信、管理、テストの各用途に使用されます。 ただし、VSAN 1 は、実稼働環境の VSAN としては使用しないことをお勧めします。 これは、VSAN 1 でのトラフィックを中断する機能がいくつかあるためです。 これらの機能を設定すると、実稼働環境の VSAN として VSAN 1 を使用した場合にトラフィックが中断されるリスクが生じます。


) デフォルトでは、Cisco MDS 9000 ファミリー スイッチはすべて VSAN 1 に属します。 実稼働環境の VSAN を作成し、その VSAN を使用するように各スイッチを設定することを推奨します。


VSAN を作成する前に、VSAN に対してアプリケーション特有のパラメータを設定することはできません。

VSAN の作成と設定

VSAN を作成して設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# vsan database

switch(config-vsan-db)#

VSAN に対するデータベースを設定します。アプリケーション特有の VSAN パラメータをこのプロンプトから設定することはできません。

ステップ 3

switch(config-vsan-db)# vsan 2

switch(config-vsan-db)#

VSAN が存在しない場合は、指定された ID(2)で VSAN を作成します。

switch(config-vsan-db)# vsan 2 name TechDoc

updated vsan 2

switch(config-vsan-db)#

割り当てられた名前(TechDoc)で VSAN を更新します。

ステップ 4

switch(config-vsan-db)# vsan 2 loadbalancing src-dst-id

switch(config-vsan-db)#

選択された VSAN に対してロードバランシングの保証を有効にし、スイッチがパス選択プロセスで送信元/宛先 ID を使用するようにします。

switch(config-vsan-db)# no vsan 2 loadbalancing src-dst-id

switch(config-vsan-db)#

前のステップで入力したコマンドを無効にし、ロードバランシング パラメータのデフォルト値に戻します。

switch(config-vsan-db)# vsan 2 loadbalancing src-dst-ox-id

switch(config-vsan-db)#

送信元 ID、宛先ID、OX ID(デフォルト)を使用するようにパス選択設定を変更します。

ステップ 5

switch(config-vsan-db)# vsan 2 suspend

switch(config-vsan-db)#

選択された VSAN を中断します。

switch(config-vsan-db)# no vsan 2 suspend

vs.-config-vsan-db#

前のステップで入力した suspend コマンドを無効にします。

ステップ 6

switch(config-vsan-db)# end

switch#

EXEC モードに戻ります。

詳しくは、 付録A「スタティック ドメイン ID と永続 FC ID の設定」 を参照してください。

警告 HP-UX と AIX の各オペレーティングシステムでは、ストレージへのデバイス パスに FC ID が利用されます。 スイッチが必ず同じデバイスに同じ FC ID を割り当てるようにするためには、永続 FC ID とスタティック ドメイン ID とをその VSAN に設定しなければなりません。

VSAN メンバーシップの割り当て

VSAN メンバーシップを割り当てる手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# vsan database

switch(config-vsan-db)#

VSAN に対するデータベースを設定します。

ステップ 3

switch(config-vsan-db)# vsan 2

switch(config-vsan-db)#

VSAN が存在しない場合は、指定された ID(2)で VSAN を作成します。

ステップ 4

switch(config-vsan-db)# vsan 2 interface fc1/8

switch(config-vsan-db)#

fc1/8 インターフェイスのメンバーシップを指定された VSAN(VSAN 2)に割り当てます。

ステップ 5

switch(config-vsan-db)# vsan 7

switch(config-vsan-db)#

VSAN が存在しない場合は、指定された ID(7)で別の VSAN を作成します。

ステップ 6

switch(config-vsan-db)# vsan 7 interface fc1/8

switch(config-vsan-db)#

変更された VSAN を反映させるために、インターフェイスのメンバーシップ情報を更新します。

VSAN 情報の表示

show vsan コマンドは、EXEC モードから呼び出すコマンドです。実行すると、VSAN の構成を表示します。 表3-1 に、各種の show コマンドと、表示される情報を列挙しました。

 

表3-1 show vsan コマンド

show コマンド
内容

show vsan

すべての VSAN に関する情報を表示する。

show vsan 100

指定した VSAN に関する情報を表示する。

show vsan usage

VSAN の使用状況に関する情報を表示する。

show vsan 100 membership

指定した VSAN の VSAN メンバーシップ情報を表示する。

show vsan membership

すべての VSAN を対象に、スタティック メンバーシップ情報を表示する。

show vsan membership interface fc1/1

指定したインターフェイスのスタティック メンバーシップ情報を表示する。

インターフェイスの設定

スイッチの主な機能は、1つのデータ リンクから別のリンクへとフレームをリレーすることです。 フレーム リレーを行うには、フレームが送受信されるインターフェイスの特性を定義する必要があります。インターフェイスをファイバ チャネル インターフェイス、管理インターフェイス(mgmt0)、または VSAN(仮想SAN)インターフェイスに設定できます。

ファイバ チャネル インターフェイスの設定

同じスイッチに含まれている各物理ファイバ チャネル インターフェイスは、E ポート、F ポート、FL ポート、TL ポート、TE ポート、SD ポート、ST ポート、B ポートという各モードのいずれか 1 つのモードで機能することができます。 これらのモードに加えて、各インターフェイスを auto ポート モードまたは Fx ポート モードに設定することができます。これら2つのモードは、インターフェイスの初期化でポート タイプを判別します。

ファイバ チャネル インターフェイスを設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface fc1/1

指定されたインターフェイスを設定します。


) ファイバ チャネル インターフェイスが設定された場合、自動的に一意の World Wide Name(WWN)が割り当てられます。 インターフェイスの動作ステートが up の場合、ファイバ チャネル ID(FC ID)も割り当てられます。


各種インターフェイスの設定

インターフェイスの範囲を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface fc1/1 - 4, fc2/1 - 3

指定されたインターフェイスの範囲を設定します。


) このコマンドでは、カンマの前後にスペースを入れます。


インターフェイスの有効化

ポート上のインターフェイスは、デフォルトでシャットダウンされています(初期設定を変更した場合を除いて)。

トラフィック フローをイネーブルにする手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface fc1/1

指定されたインターフェイスを設定します。

ステップ 3

switch(config-if)# no shutdown

no プレフィクスが使用された場合(動作ステートはup)、管理上トラフィックを許可するようにトラフィック フローをイネーブルにします。

switch(config-if)# shutdown

インターフェイスの機能を停止し、管理手段としてトラフィック フローを停止する(デフォルト)。

インターフェイスを有効にしたあとは必ずケーブルを差し込んでください。 ケーブルが差し込まれていないと、ホストとストレージ デバイスとの間で通信ができなくなります。

インターフェイス モードの設定

インターフェイス モードを設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface fc1/1

switch(config-if)#

指定されたインターフェイスを設定します。

ステップ 3

switch(config-if)# switchport mode F

switch(config-if)#

ポートの管理モードを設定します。 動作ステートは、auto、E、F、FL、Fx、TL、SD のいずれのポート モードにも設定できます。


Fx ポートは、F ポートまたは FL ポート(ホスト接続のみ)を指します。E ポートは含まれません。


switch(config-if)# switchport mode auto

switch(config-if)#

E、F、FL、または TE ポート モード動作(TL または SD ポート モードは含まない)を自動ネゴシエーションするようにインターフェイス モードを設定する。


) TLポートとSDポートを自動設定することはできません。この2つのポートは、管理上設定する必要があります。


管理インターフェイスの設定

管理インターフェイス(mgmt0)を介してリモートからスイッチを設定できます。 遠隔からの接続を設定するには、スイッチにアクセスできるようにするために CLI(コマンドライン インターフェイス)から IP パラメータ(IP アドレス、サブネット マスクおよびデフォルト ゲートウェイ)を設定する必要があります。


) 手動による管理インターフェイスの設定を始める前に、スイッチの IP アドレスと IP サブネット マスクを取得します。


Ethernet mgmt0 インターフェイスを設定する手順は次のとおりです。

 

コマンド
目的

ステップ 1

switch# config terminal

switch(config)#

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface mgmt0

switch(config-if)#

スイッチに付いている Ethernet 管理インターフェイスを設定して管理インターフェイスを設定する。

ステップ 3

switch(config-if)# ip address 172.16.1.2 255 255.255.0

ステップ 2 で指定されたインターフェイスの IP アドレスと IP サブネット マスクを入力します。

ステップ 4

switch(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

switch(config-if)# exit

switch(config)#

コンフィギュレーション モードに戻ります。

ステップ 6

switch(config)# ip default-gateway 1.1.1.4 switch(config)#

デフォルトのゲートウェイ IP アドレスを設定します。

ステップ 7

switch(config)# exit

switch#

EXEC モードに戻ります。

ステップ 8

switch# copy running-config startup-config

(任意)ファイル システムに設定の変更内容を保存します。


) 設定を保存する場合、このコマンドをいつでも入力できます。



) デフォルト ゲートウェイがスイッチに接続され、IP パケットを送信、または各サブネットのルートを追加するように明示的に設定する必要があります。


VSAN インターフェイスの作成

VSAN は、ファイバ チャネル ファブリックに適用し、同一の物理インフラストラクチャで複数の分離 SAN トポロジーを設定することを可能にします。VSAN の上に IP インターフェイスを作成して、このインターフェイスを使用してこの VSAN にフレームを送信できます。この機能を使用するには、この VSAN の IP アドレスを設定する必要があります。VSAN インターフェイスを存在しない VSAN に作成することはできません。

VSAN インターフェイスを作成または削除するときは、次の注意事項に従ってください。

VSAN にインターフェイスを作成する前に VSAN を作成します。VSAN が存在しない場合は、インターフェイスを作成できません。

interface vsan コマンドを使用してインターフェイスを作成します。 この操作は自動的には実行されません。

VSANを削除すると、接続されたインターフェイスが自動的に削除されます。

各インターフェイスを 1 つの VSAN だけに設定します。


ヒント VSAN インターフェイスを設定したあと、IP アドレスまたは Virtual Router Redundancy Protocol(VRRP)機能を設定できます


VSAN インターフェイスを作成する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

switch# config t

コンフィギュレーション モードを開始します。

ステップ 2

switch(config)# interface vsan 5

switch(config-if)#

VSAN を ID 5 に設定します。

インターフェイス情報の表示

show interface コマンドを EXEC モードから呼び出して、インターフェイス設定を表示します。 引数を入力しないと、このコマンドはスイッチ内に設定されたすべてのインターフェイスの情報を表示します。 表3-2 に、各種の show コマンドと、表示される情報を列挙しました。

 

表3-2 show interface コマンド

show コマンド
内容

show interface

すべてのインターフェイスを表示する。

show interface fc2/2

指定したインターフェイスを表示する。

show interface fc3/13, fc3/16

指定した複数のインターフェイスを表示する。

show interface vsan 2

指定した VSAN インターフェイスを表示する。

show cimserver certificateName

CIM サーバの認証ファイルを表示する。

show cimserver

CIM サーバの設定を表示する。

show cimserver httpsstatus

CIM サーバの HTTPS のステータスを表示する。

show interface description

ポートに関する説明を表示する。

show interface brief

インターフェイス情報の要点のみを表示する。

show interface counters

インターフェイス カウンタを表示する。

show interface counters brief

インターフェイス カウンタの要点のみを表示する。

show interface bbcredit

BB_credit 情報を表示する。

show interface fc2/31 bbcredit

指定したファイバ チャネル インターフェイスの BB_credit 情報を表示する。

show interface transceiver

トランシーバ情報を表示する。

show running-config interface fc1/1

特定のインターフェイスの実行コンフィギュレーションを表示する。