Cisco MDS 9000 ファミリー コンフィギュレーション ガイド Release 2.x
設定作業を開始する前に
設定作業を開始する前に
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

設定作業を開始する前に

スイッチ プロンプトの概要

デフォルトのスイッチの役割

CLIコマンド モードの概要

CLIコマンド階層構造

EXECモード オプション

コンフィギュレーション モード

コンフィギュレーション モードのコマンドおよびサブモード

CLIコマンドのナビゲート

ヘルプの表示

コマンドの完成

ファイル システムの完成

コマンドのno形式およびデフォルト形式

CLIコマンド設定のオプション

スイッチ コンフィギュレーションの表示

コンフィギュレーションの保存

コンフィギュレーションのクリア

ユーザの表示

ユーザへのメッセージの送信

pingコマンドの使用

拡張pingコマンドの使用

tracerouteの使用

シェル タイムアウトの設定

VTYセッションの表示

VTYセッションのクリア

端末タイムアウトの設定

端末タイプの設定

端末の長さの設定

端末の幅の設定

端末設定の表示

スイッチのバナー メッセージの設定

フラッシュ デバイスの概要

内蔵bootflash:

外付けCompactFlash(Slot0:)

フラッシュ デバイスおよびファイル システムのフォーマット

内蔵bootflash:の初期化

外付けCompactFlashのフォーマット

ファイル システムの使用

現在のディレクトリの設定

現在のディレクトリの表示

ファイル チェックサムの表示

ディレクトリ内のファイルの一覧表示

ディレクトリの作成

既存のディレクトリの削除

ファイルの移動

ファイルのコピー

ファイルの削除

ファイル内容の表示

コマンド出力のファイルへの保存

ファイルの圧縮および圧縮解除

ファイルの末尾の表示

スクリプトで指定されたコマンドの実行

遅延時間の設定

設定作業を開始する前に

この章では、CLI(コマンドライン インターフェイス)を使用してスイッチを設定するために、あらかじめ知っておくべき事項について説明します。作業を開始する前に必要な情報を示すとともに、各種のCLIコマンド モードについても説明します。

この章の内容は、次のとおりです。

「スイッチ プロンプトの概要」

「デフォルトのスイッチの役割」

「CLIコマンド モードの概要」

「CLIコマンド階層構造」

「CLIコマンドのナビゲート」

「フラッシュ デバイスの概要」

「フラッシュ デバイスおよびファイル システムのフォーマット」

「ファイル システムの使用」

スイッチ プロンプトの概要


) インストレーション手順および接続手順については、『Cisco MDS 9200 Series Hardware Installation Guide』または『Cisco MDS 9500 Series Hardware Installation Guide』を参照してください。


スイッチが正常に起動された場合、デフォルトのスイッチ プロンプト( switch# )が表示されます(例2-1を参照)。

例2-1 スイッチ起動時の出力

Auto booting bootflash:/boot-279 bootflash:/system_image;...
Booting kickstart image:bootflash:/boot-279....
............................................Image verification OK
 
Starting kernel...
INIT: version 2.78 booting
Checking all filesystems..... done.
Loading system software
Uncompressing system image: bootflash:/system_image
CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
INIT: Entering runlevel: 3
 
<<<<<<SAN OS bootup log messages>>>>>>
 
---- Basic System Configuration Dialog ----
 
This setup utility will guide you through the basic configuration of
the system. Use ctrl-c to abort configuration dialog at any prompt.
 
Basic management setup configures only enough connectivity for
management of the system.
 
Would you like to enter the basic configuration dialog (yes/no): yes
 
<<<<<<after configuration>>>>>>
 
switch login:admin101
Password:*******
Cisco Storage Area Networking Operating System (SAN-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2004, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
Cisco Systems, Inc. and/or other third parties and are used and
distributed under license. Some parts of this software are covered
under the GNU Public License. A copy of the license is available
at http://www.gnu.org/licenses/gpl.html.
switch#
 

このプロンプトで、組み込みのCLI動作を実行したり、コマンド ヒストリにアクセスしたり、コマンド解析機能を使用したりできます。Enter(CR)キーを押すと、スイッチはコマンド ストリングを回収し、端末からコマンドを受け入れます。

デフォルトのスイッチの役割

デフォルトでは、すべてのスイッチに次の2つの役割が存在します。

network operator ― コンフィギュレーションを表示する権限があります。

network administrator ― すべての機能を実行し、ユーザの役割およびグループに基づいて最大64の権限レベルを設定する権限があります。

ユーザがコマンドを実行したり、コマンドを完成させたり、コンテキスト センシティブ ヘルプを表示するとき、スイッチ ソフトウェアは、ユーザがそのコマンドの説明に記載されている正しい権限を持っている場合に限り、動作を続行します(「スイッチ セキュリティの設定」を参照)。

CLIコマンド モードの概要

Cisco MDS 9000ファミリー スイッチには、2つの主要なコマンド モード(ユーザEXECモードおよびコンフィギュレーション モード)があります。どのコマンドを使用できるかは、その時点で有効になっているモードによって決まります。システム プロンプトに疑問符(?)を入力することによって、そのモードで使用可能なコマンドの一覧を表示できます。

表 2-1 に、代表的な2つのモード、各モードの開始方法、および表示されるシステム プロンプトを示します。現在どのモードが有効になっていて、どのコマンドが使用可能であるかは、システム プロンプトから判断することができます。

 

表 2-1 よく使用するスイッチ コマンド モード

モード
用途の説明
アクセス方法
プロンプト

EXEC

端末設定を一時的に変更したり、基本的なテストを実行したり、システム情報を表示できます。


) 通常このモードで行った変更は、システムのリセット時には保存されません。


スイッチ プロンプトに、必要なEXECモード コマンドを入力します。

switch#

コンフィギュレーション モード

システム全体に影響する機能の設定を行うことができます。


) このモードで行った変更は、コンフィギュレーションを保存するとシステムをリセットしても保持されます。「コンフィギュレーションの保存」を参照してください。


EXECモードから、
config terminal コマンドを入力します。

switch(config)#

特定のコマンドを他のコマンドから区別できる最低限の文字数だけを入力して、コマンドおよびキーワードを簡略化することができます。たとえば、 config terminal コマンドは、 conf t に簡略化できます。


) コマンドラインでは、パーセント( % )、ポンド( # )、省略記号( ...)、縦線( | )、かぎカッコ
( < > )、角カッコ( [ ] )、または波カッコ( { } )は使用しないでください。これらの文字には、Cisco SAN OSテキスト ストリング内では特殊な意味があります。


CLIコマンド階層構造

CLIコマンドは、同じような機能を実行するコマンドを同じレベルに集めた階層構造に編成されています。たとえば、システム、コンフィギュレーション、またはハードウェアに関する情報を表示するコマンドは、すべて show コマンドのグループに属し、スイッチを設定するコマンドは config terminal コマンドのグループに属します。図 2-1に、 config terminal コマンド階層構造の一部分を示します。

図 2-1 CLIコマンド階層構造の例

 

コマンドを実行するには、そのコマンドを階層構造のトップ レベルから順に入力します。たとえば、インターフェイス ファイバ チャネルを設定するには、まず config terminal コマンドを使用します。コンフィギュレーション モードを開始してから、 interface コマンドを発行します。インターフェイス サブモードに入った段階で、そのサブモードで使用できるコマンドを調べることができます。

次に、インターフェイス サブモードで使用できるコマンドを確認する例を示します。

switch# config t
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)# interface fc1/1
switch(config-if)# ?
Interface configuration commands:
channel-group Add to/remove from a port-channel
exit Exit from this submode
fcdomain Enter the interface submode
fspf To configure FSPF related parameters
no Negate a command or set its defaults
shutdown Enable/disable an interface
switchport Configure switchport parameters
 

EXECモード オプション

スイッチ上でセッションを開始する場合、最初はEXECモードから始めます。ユーザに割り当てられている役割またはグループに応じて、一部のコマンドしかアクセスできない場合もあれば、すべてのコマンドにアクセスできる場合もあります( 役割ベースの許可を参照)。このEXECモードから、コンフィギュレーション モードを開始できます。大部分のEXECコマンドは、 show コマンド(現在のコンフィギュレーション ステータスを表示する)のように、1回限りのコマンドです。次に、EXECモード コマンドの一覧を示します。

switch# ?
Exec Commands:
attach Connect to a specific linecard
callhome Callhome commands
cd Change current directory
clear Reset functions
clock Manage the system clock
config Enter configuration mode
copy Copy from one file to another
debug Debugging functions
delete Remove files
dir Directory listing for files
discover Discover information
exit Exit from the EXEC
fcping Ping an N-Port
fctrace Trace the route for an N-Port.
find Find a file below the current directory
format Format disks
install Upgrade software
load Load system image
mkdir Create new directory
move Move files
no Disable debugging functions
ping Send echo messages
purge Deletes unused data
pwd View current directory
reload Reboot the entire box
rmdir Remove existing directory
run-script Run shell scripts
send Send message to all the open sessions
setup Run the basic SETUP command facility
show Show running system information
sleep Sleep for the specified number of seconds
system System management commands
tail Display the last part of a file
telnet Telnet to another system
terminal Set terminal line parameters
test Test command
traceroute Trace route to destination
undebug Disable Debugging functions (See also debug)
write Write current configuration
zone Execute Zone Server commands
 

コンフィギュレーション モード

コンフィギュレーション モードでは、既存のコンフィギュレーションを変更できます。コンフィギュレーションを保存する場合、これらのコマンドはスイッチを再起動しても保持されます。コンフィギュレーション モードから、インターフェイス コンフィギュレーション モード、ゾーン コンフィギュレーション モード、および各種のプロトコル固有モードを開始できます。コンフィギュレーション モードは、あらゆるコンフィギュレーション コマンドの起点です。コンフィギュレーション モードでは、スイッチはユーザからのコンフィギュレーション コマンドを受け付けます。

次に、 config terminal コマンドの出力例を示します。

switch# config terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#

コンフィギュレーション モードのコマンドおよびサブモード

次に、コンフィギュレーション モード コマンドの一覧を示します。

switch# config t
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)# ?
Configure commands:
aaa Configure AAA
arp [no] remove an entry from the ARP cache
boot Configure boot variables
callhome Enter the callhome configuration mode
clock Configure time-of-day clock
end Exit from configure mode
exit Exit from configure mode
fcalias Fcalias configuration commands
fcanalyzer Configure cisco fabric analyzer
fcc Configure FC Congestion Control
fcdomain Enter the fcdomain configuration mode
fcdroplatency Configure switch or network latency
fcflow Configure fcflow
fcinterop Interop commands.
fcns Name server configuration
fcroute Configure FC routes
fcs Configure Fabric Config Server
fctimer Configure fibre channel timers
fspf Configure fspf
in-order-guarantee Set in-order delivery guarantee
interface Select an interface to configure
ip Configure IP features
line Configure a terminal line
logging Modify message logging facilities
no Negate a command or set its defaults
ntp NTP Configuration
power Configure power supply
poweroff Poweroff a module in the switch
qos Configure priority of FC control frames
radius-server Configure RADIUS related parameters
role Configure roles
rscn Config commands for RSCN
snmp-server Configure snmp server
span Enter SPAN configuration mode
ssh Configure SSH parameters
switchname Configure system's network name
system System config command
telnet Enable telnet
trunk Configure Switch wide trunk protocol
username Configure user information.
vsan Enter the vsan configuration mode
wwn Set secondary base MAC addr and range for additional WWNs
zone Zone configuration commands
zoneset Zoneset configuration commands
 

コンフィギュレーション モード(別名、端末コンフィギュレーション モード)には、いくつかのサブモードがあります。これらのサブモードはそれぞれ、プロンプト階層構造におけるその次のレベルに相当します。 exit を入力すると、1つ前のレベルに戻ることができます。 end を入力すると、ユーザEXECレベルに戻ります。また、コンフィギュレーション モードで end と入力する代わりに、 Ctrl-Z を入力することもできます。


) コンフィギュレーション モードでは、次の入力ができます。
endコマンドの代わりにCtrl-Zコマンド
exitコマンドの代わりにCtrl-Gコマンド


コンフィギュレーション モードまたはサブモードのプロンプトから、EXECモードのコマンドを実行することができます。このコマンドは、コンフィギュレーション モードのすべてのサブモードから発行できます。コンフィギュレーション モード(またはいずれかのサブモード)で、 do コマンドと一緒に必要なEXECモード コマンドを入力します。入力したコマンドがEXECレベルで実行され、現在のモード レベルのプロンプトが再び表示されます。

switch(config)# do terminal session-timeout 0
switch(config)#
 

この例では、 terminal session-timeout はEXECモード コマンドです。コンフィギュレーション モードの do コマンドを使用して、EXECモード コマンドを発行しています。

do コマンドは、 end および exit コマンドを除くすべてのEXECモード コマンドに適用できます。また、 do コマンドと一緒にEXECコマンドを使用するとき、EXECコマンドのヘルプ( ? )およびコマンド完成( Tab )機能を利用することもできます。

表 2-2 に、EXECモードおよびコンフィギュレーション モードの両方で使用できる便利なコマンド キーを示します。

 

表 2-2 便利なコマンド キー

コマンド
説明

Ctrl-P

ヒストリを上へ

Ctrl-N

ヒストリを下へ

Ctrl-R

現在の行をリフレッシュし、再表示します。

Ctrl-X-H

ヒストリの一覧表示

Alt-P

ヒストリを後方へ検索


Tabキーによるコマンドの完成機能とAlt-PまたはAlt-Nの違いは、Tabが現在のワードを完成させるのに対し、Alt-PおよびAlt-Nは前に入力したコマンドを完成させる点です。


Alt-N

ヒストリを前方へ検索

Ctrl-G

Exit

Ctrl-Z

End

Ctrl-L

スクリーンをクリア

CLIコマンドのナビゲート

前に入力したコマンドを再表示するには、 上矢印 キーを押します。 上矢印 キーを続けて押すと、さらに前のコマンドを表示できます。同様に、 下矢印 右矢印 左矢印 、および Delete キーを押して、コマンド ヒストリをナビゲートし、既存のコマンド ストリングを変更することができます。

ヘルプの表示

どのコマンド モードでも疑問符(?)を入力することによって、使用可能なコマンドの一覧を表示できます。

switch# ?
 

特定の文字シーケンスで始まるコマンドの一覧を表示するには、それらの文字を入力した直後に疑問符(?)を入力します。スペースは入れないでください。

switch# co?
configure copy
 

キーワードまたは引数の一覧を表示するには、キーワードまたは引数の位置に疑問符を入力します。疑問符の前にスペースを入れます。すでに入力したコマンド、キーワード、および引数に基づいて適切なキーワードまたは引数を知らせるので、この形式のヘルプをコマンド構文ヘルプといいます。

switch# config ?
terminal Configure the system from the terminal

ヒント コマンドを入力してエラーになる場合は、システム プロンプトをチェックし、疑問符(?)を入力して使用可能なコマンドの一覧を表示してください。ほとんどの場合、コマンド モードが間違っているか、不正な構文を使用していることが原因です。


コマンドの完成

どのコマンド モードでも、特定のコマンド シーケンスを先頭から入力し、途中で Tab キーを押すことによって、そのコマンドを最後まで完成させることができます。

switch(config)# ro <Tab>
switch(config)# role <Tab>
switch(config)# role name
 

ユーザに代わって単語を完成させるので、この形式のヘルプをコマンド完成といいます。入力した文字に対していくつかの選択肢がある場合、それらの文字に対応するすべての選択肢が表示されます。

switch(config)# fc <Tab>
fcalias fcdomain fcs
fcanalyzer fcdroplatency fcns fctimer
fcc fcinterop fcroute
switch(config)# fcd <Tab>
fcdomain fcdroplatency
switch(config)# fcdo <Tab>
switch(config)# fcdomain
 

ファイル システムの完成

SAN OS Release 2.0(1b)では、 Tab キーを使用することによって、ファイル システムで利用可能なスキーム、サーバ、およびファイル名を完成させることができます。

たとえば、次のようになります。

switch# cd bootflash:<Tab>
bootflash: bootflash://sup-1/ bootflash://sup-remote/
bootflash:/// bootflash://sup-2/ bootflash://sup-standby/
bootflash://module-5/ bootflash://sup-active/
bootflash://module-6/ bootflash://sup-local/
 
switch# bootflash://mo<Tab>
switch# bootflash://module-6/
 

コマンドのno形式およびデフォルト形式

コマンドの no 形式を使用して、次の動作を実行できます。

誤って発行したコマンドを取り消す

zone member コマンドを発行した場合、このコマンドの結果を次のようにして取り消すことができます。

switch(config)# zone name test vsan 1
switch(config-zone)# member pwwn 12:12:12:12:12:12:12:12
switch(config-zone)# no member pwwn 12:12:12:12:12:12:12:12
WARNING: Zone is empty. Deleting zone test. Exit the submode.
switch(config-zone)#
 

作成したファシリティを削除する

作成したゾーンを削除する例を示します。

switch(config)# zone name test vsan 1
switch(config-zone)# exit
switch(config)# no zone name test vsan 1
switch(config)#
 

ゾーン ファシリティtestのモードが有効なときは、このファシリティを削除することはできません。最初にゾーン サブモードを終了し、コンフィギュレーション モードに戻る必要があります。

CLIコマンド設定のオプション

ソフトウェアの設定は、次の2通りの方法で行うことができます。

CLIプロンプトに対してコマンドを発行することにより、対話形式でスイッチのコンフィギュレーションを作成できます。

スイッチ コンフィギュレーションを含むASCIIファイルを作成し、必要なシステムにそのファイルをロードします。次に、CLIを使用してファイルを編集し、アクティブにします( コンフィギュレーション ファイルの使用を参照)。

スイッチ コンフィギュレーションの表示

必要に応じて、コンフィギュレーション ファイルをASCII形式で表示できます。EXECプロンプトから現在のコンフィギュレーション ツリーを表示するには、 show running-config コマンドを使用します。実行コンフィギュレーションがスタートアップ コンフィギュレーションと異なり、再起動後に copy run start コマンドを入力していない場合に限り、 show startup-config コマンドを入力して、スイッチの起動に使用された現在のスタートアップ コンフィギュレーションのASCIIバージョンを表示します。現在のスタートアップ コンフィギュレーションの内容を表示するには、 show startup コマンドを使用します。

また、全体的なスイッチ コンフィギュレーションの中で特定の情報を収集するには、該当する show コマンドを使用します。指定した機能、インターフェイス、モジュール、またはVSAN(仮想SAN)に基づいてコンフィギュレーションが表示されます。各機能に対応して使用できる show コマンドについては、ここでも簡単に説明しますが、各章の最後にリストします。

2-2 2-8 に、 show コマンドの例を示します。

例2-2 特定のインターフェイスの詳細を表示

switch# show interface fc1/1
fc1/1 is up
Hardware is Fibre Channel, 20:01:ac:16:5e:4a:00:00
vsan is 1
Port mode is E
Speed is 1 Gbps
Beacon is turned off
FCID is 0x0b0100
0 frames input, 0 bytes, 0 discards
0 runts, 0 jabber, 0 too long, 0 too short
0 input errors, 0 CRC, 0 invalid transmission words
0 address id, 0 delimiter
0 EOF abort, 0 fragmented, 0 unknown class
0 frames output, 0 bytes, 0 discards
Received 0 OLS, 0 LRR, 0 NOS, 0 loop inits
Transmitted 0 OLS, 0 LRR, 0 NOS, 0 loop inits
 

例2-3 ソフトウェアおよびハードウェアのバージョンを表示

switch# show version
Cisco Storage Area Networking Operating System (SAN-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2003, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained herein are owned by
Cisco Systems, Inc. and/or other third parties and are used and
distributed under license. Some parts of this software are covered
under the GNU Public License. A copy of the license is available
at http://www.gnu.org/licenses/gpl.html.
 
Software
BIOS: version 1.0.8
loader: version 1.1(2)
kickstart: version 2.0(1) [build 2.0(0.6)] [gdb]
system: version 2.0(1) [build 2.0(0.6)] [gdb]
 
BIOS compile time: 08/07/03
kickstart image file is: bootflash:///m9500-sf1ek9-kickstart-mzg.2.0.0.6.bin
kickstart compile time: 10/25/2010 12:00:00
system image file is: bootflash:///m9500-sf1ek9-mzg.2.0.0.6.bin
system compile time: 10/25/2020 12:00:00
 
Hardware
RAM 1024584 kB
 
bootflash: 1000944 blocks (block size 512b)
slot0: 0 blocks (block size 512b)
 
172.22.92.181 uptime is 0 days 2 hours 18 minute(s) 1 second(s)
 
Last reset at 970069 usecs after Tue Sep 16 22:31:25 1980
Reason: Reset Requested by CLI command reload
System version: 2.0(0.6)
Service:
 

例2-4 実行コンフィギュレーションを表示

switch# show running
Building Configuration ...
interface fc1/1
interface fc1/2
interface fc1/3
interface fc1/4
interface mgmt0
ip address 172.22.95.112 255.255.255.0
no shutdown
vsan database
boot system bootflash:system-237; sup-1
boot kickstart bootflash:boot-237 sup-1
callhome
ip default-gateway 172.22.95.1
switchname switch
trunk protocol enable
username admin password 5 /AFDAMD4B2xK2 role network-admin

例2-5 実行コンフィギュレーションとスタートアップ コンフィギュレーションの違いを表示

switch# show running diff
Building Configuration ...
*** Startup-config
--- Running-config
****************** 1,16 ****
fcip enable
ip default-gateway 172.22.91.1
iscsi authentication none
iscsi enable
! iscsi import target fc
iscsi virtual-target name vt
pWWN 21:00:00:04:cf:4c:52:c1
all-initiator-permit
--- 1,20 ----
fcip enable
+ aaa accounting logsize 500
+
+
+
ip default-gateway 172.22.91.1
iscsi authentication none
iscsi enable
! iscsi initiator name junk
iscsi virtual-target name vt
pWWN 21:00:00:04:cf:4c:52:c1
all-initiator-permit
 

例2-6 特定のインターフェイスのコンフィギュレーションを表示

switch# show running interface fc2/9
interface fc2/9
switchport mode E
no shutdown

show running interfaceコマンドは、show interface コマンドとは異なります。


例2-7 16ポート モジュール上の全インターフェイスのコンフィギュレーションを表示

switch# show running interface fc2/10 - 12
interface fc2/10
switchport mode E
no shutdown
 
interface fc2/11
switchport mode E
no shutdown
 
interface fc2/12
switchport mode FL
no shutdown
 

例2-8 VSAN単位でコンフィギュレーションを表示

switch# show runnning vsan 1
Building Configuration ...
zone name m vsan 1
member pwwn 21:00:00:20:37:60:42:5c
member pwwn 21:00:00:20:37:4b:00:a2
zoneset name m vsan 1
member m
zoneset activate name m vsan 1

コンフィギュレーションの保存

不揮発性ストレージに新しいコンフィギュレーションを保存するには、 copy running-config startup-config コマンドを使用します。このコマンドが入力されると、実行コンフィギュレーションおよびスタートアップ コンフィギュレーションのコピーは同一になります。

「ファイルのコピー」を参照してください。

コンフィギュレーションのクリア

スタートアップ コンフィギュレーションをクリアするには、 write erase コマンドを使用します。このコマンドを発行すると、スイッチのスタートアップ コンフィギュレーションは出荷時のデフォルトに戻ります。実行コンフィギュレーションには影響はありません。


注意 write eraseコマンドは、ローダ機能に影響する設定を例外として、スタートアップ コンフィギュレーション全体を消去します。

write erase boot コマンドは、ローダ機能に影響する設定だけを消去します。ローダ機能の設定には、boot変数およびmgmt0 IPコンフィギュレーション情報(IPアドレス、ネットマスク、およびデフォルト ゲートウェイ)が含まれます。

switch# write erase boot
This command will erase the boot variables and the ip configuration of interface mgmt 0

ユーザの表示

現在スイッチをアクセスしている全ユーザを表示するには、 show users コマンドを使用します。

switch# show users
admin pts/7 Jan 12 20:56 (10.77.202.149)
admin pts/9 Jan 12 23:29 (modena.cisco.com)
admin pts/11 Jan 13 01:53 (dhcp-171-71-49-49.cisco.com)

ユーザへのメッセージの送信

現在スイッチを使用しているアクティブなCLIユーザ全員にメッセージを送信するには、 send コマンドを使用します。このメッセージは、スペースを含めて最大80文字の英数字です。

次に、スイッチをシャットダウンするという警告メッセージをアクティブ ユーザ全員に送信する例を示します。

switch# send Shutting down the system in 2 minutes. Please log off.
 
Broadcast Message from admin@excal-112
(/dev/pts/3) at 16:50 ...
Shutting down the system in 2 minutes. Please log off.

pingコマンドの使用

エコー メッセージを送信してリモート ホストまたはサーバとの接続能力を確認するには、 ping コマンドを使用します。

このコマンドの構文は、 ping <hostまたはip address> です。

switch# ping 198.133.219.25
PING 198.133.219.25 (198.133.219.25) 56(84) bytes of data.
64 bytes from 198.133.219.25: icmp_seq=1 ttl=245 time=0.856 ms
64 bytes from 198.133.219.25: icmp_seq=2 ttl=245 time=1.02 ms
 
--- 198.133.219.25 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 0.856/0.941/1.027/0.090 ms
 

pingセッションを途中で終了するには、エスケープ シーケンス Ctrl-C を入力します。

拡張pingコマンドの使用

SAN OS Release 2.0(1b)では、 ping コマンドは、リモート ホストまたはサーバの接続能力を確認するための追加のオプションを提供します。このような追加パラメータを指定するには、CLIスイッチ プロンプトで ping を入力し、Enterキーを押します。

表 2-3 に、構文とデフォルト値をまとめます。

 

表 2-3 pingコマンドのオプションとデフォルト値

オプション
説明
デフォルト

Target IP address

pingを実行する宛先ノードのIPアドレスまたはホスト名

該当なし

Repeat count

宛先アドレスに送信されるpingパケット数

5パケット

Datagram size

各pingパケットのサイズ(バイト)

100バイト

Timeout in seconds

ping コマンドが終了するまでのタイムアウト インターバル

2秒

Extended commands

一連の追加コマンドを表示するかどうかを指定します。

使用しない

Sweep range of sizes

送信されるエコー パケットのサイズ。このオプションは、宛先アドレスへのパスと一緒にノードに設定されるMTUの最小サイズを決定します。これにより、パケット フラグメンテーション パフォーマンスの問題を軽減できます。「MTUサイズ」を参照してください。

使用しない

Source address or interface

送信元インターフェイスのIPアドレス値または名前

該当なし

Type of service

Internet Control Message Protocol(ICMP)データグラムのQuality of Service(QoS;サービス品質)。「QoS」を参照してください。

0

Set DF bit in IP header

Path MTU Discoveryストラテジー。「MTUサイズ」を参照してください。

使用しない

Data pattern

発信パケットをパディングするのに、最大16バイトまで指定できます。このパディングは、ネットワーク内のデータに関わる問題を診断するのに役立ちます。たとえば、 ff は、発信パケットをすべて1で埋めます。

0xABCD

このコマンドの構文は、次のとおりです。

switch# ping
Target IP address: 198.133.219.25
Target IP address: 198.133.219.25
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]:
Set DF bit in IP header [n]:
Data pattern [0xABCD]:
Sweep range of sizes [n]:
PATTERN: 0xabcd
PING 198.133.219.25 (198.133.219.25) 100(128) bytes of data.
108 bytes from 198.133.219.25: icmp_seq=1 ttl=245 time=0.600 ms
108 bytes from 198.133.219.25: icmp_seq=2 ttl=245 time=0.614 ms
108 bytes from 198.133.219.25: icmp_seq=3 ttl=245 time=0.872 ms
108 bytes from 198.133.219.25: icmp_seq=4 ttl=245 time=0.558 ms
108 bytes from 198.133.219.25: icmp_seq=5 ttl=245 time=0.570 ms
 
--- 198.133.219.25 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 7996ms
rtt min/avg/max/mdev = 0.558/0.642/0.872/0.120 ms
 

pingセッションを途中で終了するには、エスケープ シーケンス Ctrl-C を入力します。

tracerouteの使用

特定のホストまたはIPアドレスによって使用されるルートを出力するには、 traceroute コマンドを使用します。

このコマンドの構文は、 traceroute <hostまたはip address>です。

switch# traceroute www.cisco.com
Tracing route to www.cisco.com [198.133.219.25] 30 hops max, 38 byte packets
1 bras3-l0.pltnca.sbcglobal.net [151.164.184.79] 30 ms 30 ms 20 ms
2 dist2-vlan50.pltn13.pbi.net [64.164.97.67] 20 ms 20 ms 30 ms
3 bb2-g1-1.pltn13.pbi.net [67.116.251.194] 20 ms 20 ms 20 ms
4 bb1-p12-0.pltn13.pbi.net [151.164.40.17] 20 ms 21 ms 20 ms
5 bb2-p13-0.sntc01.pbi.net [151.164.191.65] 20 ms 20 ms 30 ms
6 ex1-p3-0.eqsjca.sbcglobal.net [64.161.1.54] 20 ms 20 ms 30 ms
7 sl-st20-sj-0-0.sprintlink.net [144.223.242.81] 20 ms 20 ms 30 ms
8 sl-bb25-sj-10-0.sprintlink.net [144.232.20.62] 20 ms 30 ms 20 ms
9 sl-gw11-sj-10-0.sprintlink.net [144.232.3.134] 70 ms 30 ms 30 ms
10 sl-ciscopsn2-11-0-0.sprintlink.net [144.228.44.14] 20 ms 30 ms 20 ms
11 sjce-dmzbb-gw1.cisco.com [128.107.239.89] 20 ms 30 ms 30 ms
12 sjck-dmzdc-gw1.cisco.com [128.107.224.69] 20 ms 30 ms 20 ms
13 www.cisco.com (198.133.219.25) 2.496 ms * 2.135 ms
 

tracerouteセッションを強制的に終了するには、 Ctrl-C を入力します。

シェル タイムアウトの設定

スイッチ上のすべての端末セッションのライフタイムを設定するには、コンフィギュレーション モードで exec-timeout コマンドを使用します。このコマンドで設定したタイム リミットに達すると、シェルが終了し、そのセッションが閉じられます。このコマンドの構文は、 exec-timeout minutes です。

デフォルトは30分です。コンソール セッションと仮想端末回線(VTY)セッションで、異なるタイムアウト値を設定できます。 exec-timeout 値を0に設定すると、この機能はディセーブルになり、スイッチを終了するまでセッションがアクティブな状態を続けます。この変更はコンフィギュレーション ファイルに保存されます。

コンソールの場合:

switch(config)# line console
switch(config-console)# exec-timeout 60

現在のコンソール シェル タイムアウトを60分に設定します。

VTYセッション(TelnetまたはSSH)の場合:

switch(config)# line vty
switch(config-line)# exec-timeout 60

現在のコンソール シェル タイムアウトを60分に設定します。

VTYセッションの表示

設定されているVTYセッションをすべて表示するには、 show line コマンドを使用します。

switch# show line
line Console:
Speed: 9600 bauds
Databits: 8 bits per byte
Stopbits: 1 bit(s)
Parity: none
Modem In: Disable
Modem Init-String -
default : ATE0Q1&D2&C1S0=1\015
Statistics: tx:5558511 rx:5033958 Register Bits:RTS|CTS|DTR|DSR|CD|RI
line Aux:
Speed: 9600 bauds
Databits: 8 bits per byte
Stopbits: 1 bit(s)
Parity: none
Modem In: Disable
Modem Init-String -
default : ATE0Q1&D2&C1S0=1\015
Hardware Flowcontrol: ON
Statistics: tx:35 rx:0 Register Bits:RTS|DTR
 

VTYセッションのクリア

特定のVTYセッションを閉じるには、 clear line コマンドを使用します。

switch# clear line Aux
 

端末タイムアウトの設定

スイッチ上の現在の端末セッションの自動ログアウト時間を設定するには、EXECモードで terminal session-timeout コマンドを使用します。このコマンドで設定したタイム リミットに達すると、スイッチはそのセッションを閉じて終了します。

このコマンドの構文は、 terminal session-timeout minutes です。

デフォルトは30分です。 terminal session-timeout 値を0に設定すると、この機能はディセーブルになり、スイッチを終了するまで端末がアクティブな状態を続けます。この変更はコンフィギュレーション ファイルに保存されません。

switch# terminal session-timeout 600
 

現在のセッションの端末タイムアウトを600分に設定します。

端末タイプの設定

スイッチに使用する端末タイプを指定するには、EXECモードで terminal terminal-type コマンドを使用します。

このコマンドの構文は、 terminal terminal-type terminal-type です。

switch# terminal terminal-type vt100
 

端末タイプを指定します。 terminal-type ストリングは最高80文字であり、有効なタイプを指定する必要があります(たとえば、vt100またはxterm)。TelnetまたはSSHセッションで不明の端末タイプを指定すると、スイッチはデフォルトでvt100端末を使用します。

端末の長さの設定

現在のセッションの端末スクリーン長を設定するには、EXECモードで terminal length コマンドを使用します。このコマンドは、コンソール ポートのみを対象とします。TelnetおよびSSHセッションでは、スクリーン長が自動的に設定されます。

このコマンドの構文は、 terminal length lines です。

switch# terminal length 20
 

現在の端末セッションのスクリーン長を20行に設定します。デフォルトは24行です。

端末の幅の設定

現在のセッションの端末スクリーン幅を設定するには、EXECモードで terminal width コマンドを使用します。このコマンドは、コンソール ポートのみを対象とします。TelnetおよびSSHセッションでは、スクリーン幅が自動的に設定されます。

このコマンドの構文は、 terminal width columns です。

switch# terminal width 86
 

現在の端末セッションのスクリーン幅を86カラムに設定します。デフォルトは80カラムです。

端末設定の表示

現在のセッションの端末設定を表示するには、 show terminal コマンドを使用します。

switch# show terminal
TTY: Type: “vt100”
Length: 24 lines, Width: 80 columns
Session Timeout: 525600 minutes
 

スイッチのバナー メッセージの設定

Cisco MDS SAN OS Release 1.3(4)では、コンフィギュレーション モードで banner motd コマンドを入力して、Message of the Day(MOTD;日付メッセージ)を設定できます。

このコマンドの構文は、banner motd [ delimiting-character message delimiting-character ]です。

次に、バナー メッセージに「Testing the MOTD Feature」のテキストを設定する例を示します。

switch# config t
switch(config)# banner motd # Testing the MOTD Feature. #
 

メッセージは、各行の文字数が最大80文字、行数は最大40行に制限されています。

設定されたバナー メッセージを表示するには、 show banner motd コマンドを使用します。

次の例は、設定されたバナー メッセージを表示します。

switch# show banner motd
Testing the MOTD Feature
 

ユーザがCisco MDS 9000ファミリー スイッチにログインすると常に、設定されたMOTDバナーがログイン プロンプトの前に表示されます。

Testing the MOTD Feature
switch login:
 

デリミタ文字を使用する場合は、次の注意事項に従ってください。

デリミタ文字 メッセージ ストリングには使用しないでください。

" および % をデリミタとして使用しないでください。

メッセージ テキストに$(トークン)形式のトークンを加えることができます。トークンは対応する設定変数によって置き換えられます。たとえば、次のようになります。

$(hostname) は、スイッチのホスト名を表示します。

$(line) は、vtyまたはtty回線または名前を表示します。

次の例は複数行にまたがり、トークンを使用して、バナー メッセージを設定します。

switch# config t
switch(config)# banner motd #
Enter TEXT message. End with the character '#'.
Welcome to switch $(hostname).
Your tty line is $(line).
#

フラッシュ デバイスの概要

Cisco MDS 9000ファミリーの全スイッチに、内蔵bootflashが1つ装備されています(図 2-2を参照)。Cisco MDS 9500シリーズでは、slot0という追加的な外付けCompactFlashが1つ装備されています(図 2-2および図 2-3を参照)。

図 2-2 Cisco MDS 9000スーパバイザ モジュールのフラッシュ デバイス

 

図 2-3 Cisco MDS 9000スーパバイザ モジュールの外付けCompactFlash

 

内蔵bootflash:

Cisco MDS 9000ファミリーの全スイッチに、内蔵bootflash:が1つ装備されています。bootflash:は、スーパバイザまたはスイッチング モジュールに組み込まれています。この内蔵bootflash:ファイル システム上の次の2つの場所にアクセスできます。

volatile:ファイル システムは、一時的なストレージを提供します。ファイル システム コマンドのデフォルト ロケーションでもあります。一時的ストレージ(volatile:)に保存されたファイルは、スイッチを再起動すると消去されます。

bootflash:(不揮発性ストレージ)ファイル システムは、永続的なストレージを提供します。bootflash:に保存したファイルは、スイッチの再起動時および停電時にも保存されます。

外付けCompactFlash(Slot0:)

Cisco MDS 9500シリーズ ディレクタには、slot0:ファイル システムという追加的な外付けCompactFlashが装備されています。

MDS 9500シリーズ ディレクタのオプションの装置である外付けCompactFlashは、ソフトウェア イメージ、ログ、およびコア ダンプの保存に使用できます。

フラッシュ デバイスおよびファイル システムのフォーマット

フラッシュ デバイスまたはファイル システムをフォーマットすると、そのデバイスまたはファイル システムの内容がクリアされ、出荷時の状態に戻されます。

「フラッシュ デバイスの概要」および「ファイル システムの使用」を参照してください。

内蔵bootflash:の初期化

スイッチの出荷時に init system コマンドがすでに実行されているので、このコマンドをもう一度発行する必要はありません。スイッチを初期化すると、内部フラッシュ デバイス全体がリセットされ、bootflash:ファイル システムの全データが消去されます。内部フラッシュ デバイスはいくつかのファイル システムで構成され、bootflash:はその中の1つです。bootflash:の全ファイルが消去されるので、システムをダウンロードして再びイメージを起動する必要があります。 init system コマンドを発行したあとで、bootflash:を再度フォーマットする必要はありません。bootflash:は自動的にフォーマットされています。


init systemコマンドは、また既存(稼働中の)キックスタート イメージから新しいローダをインストールします。このコマンドは、switch(boot)#プロンプトからアクセスできます(「ソフトウェア イメージ」を参照)。


起動シーケンスでbootflash:が壊れていることが判明した場合、次のメッセージが表示されます。

ERROR:bootflash: has unrecoverable error; please do “format bootflash:”
 

format bootflash: コマンドは、bootflash:ファイル システムをフォーマットする場合にのみ使用します。 format bootflash: コマンドは、 switch# または switch(boot)# プロンプトから発行できます。

format bootflash: コマンドを発行する場合、キックスタート イメージおよびシステム イメージを再びダウンロードする必要があります。

外付けCompactFlashのフォーマット

外付けCompactFlash装置を使用してファイルまたはイメージを保存する前に、この装置を必ずフォーマットしてください。

外付けCompactFlash装置がフォーマットされているかどうかを確認するには、slot0:に装置を挿入し、 dir slot0: コマンドを発行します。

外付けCompactFlash装置がすでにフォーマットされている場合、ファイル システムの使用状況に関する情報が(既存のファイルとともに)表示されます。

外付けCompactFlash装置がフォーマットされていない(壊れている)場合、次のメッセージが表示されます。

Device unavailable
 

この場合、 format slot0: コマンドを使用して、CompactFlash装置をフォーマットする必要があります。


) slot0:ファイル システムは、スイッチを起動したあとでディスクを挿入した場合には、スタンバイのloader>プロンプトまたはswitch(boot)#プロンプトからアクセスすることはできません。



注意 Cisco SAN OSソフトウェアは、Cisco MDSスイッチを使用してフォーマットされた、シスコシステムズが認定するCompactFlash装置のみをサポートします。認定されていないCompactFlash装置を使用すると、予測不可能な結果を引き起こす可能性があります。他のプラットフォームを使用してCompactFlash装置をフォーマットすると、エラーになる可能性があります。

ファイル システムの使用

スイッチのソフトウェア イメージ ファイルおよびコンフィギュレーション ファイルを管理するために、次に説明する便利な機能が提供されています。

「現在のディレクトリの設定」

「現在のディレクトリの表示」

「ディレクトリ内のファイルの一覧表示」

「ディレクトリの作成」

「既存のディレクトリの削除」

「ファイルの移動」

「ファイルのコピー」

「ファイルの削除」

「ファイル内容の表示」

「コマンド出力のファイルへの保存」

「ファイルの圧縮および圧縮解除」

「ファイルの末尾の表示」

「スクリプトで指定されたコマンドの実行」

「遅延時間の設定」

現在のディレクトリの設定

現在のディレクトリ レベルを指定するディレクトリに変更するには、 cd コマンドを使用します。CLIではデフォルトでvolatile:ファイルシステムが使用されています。このコマンドにはディレクトリ名を入力する必要があります。


ヒント volatile:ファイル システムに保存されたファイルは、スイッチを再起動すると消去されます。


このコマンドの構文は、 cd directory name です。

次に、slot0ファイル システムにあるmystorageディレクトリを現在のディレクトリにする例を示します。

switch# cd slot0:mystorage
 

次に、現在のディレクトリにあるmystorageディレクトリを現在のディレクトリにする例を示します。

switch# cd mystorage
 

現在のディレクトリがslot0:mydirの場合、このコマンドは現在のディレクトリをslot0:mydir/mystorageに変更します。

現在のディレクトリの表示

現在のディレクトリ位置を表示するには、 pwd コマンドを使用します。次に、ディレクトリを変更し、現在のディレクトリを表示する例を示します。

switch# cd bootflash:
switch# pwd
bootflash:

) Cisco MDS 9500シリーズのアクティブ スーパバイザ モジュールからこのコマンドを入力する場合(たとえば、module-5)、現在の作業ディレクトリをmodule-6のbootflash:に変更できません。「スーパバイザ モジュール」を参照してください。


ファイル チェックサムの表示

show file file md5sum コマンドは、ファイルのMD5チェックサムを提供します。MD5は、ファイルの電子指紋です。MD5は、RFC 1321に記述されているインターフェイス標準の最新版の実装であり、データのセキュリティおよび整合性を保つのに役立ちます。

show file file cksum コマンドは、ファイルのチェックサムを提供します。チェックサム値は、名前が付いた各ファイルのCyclic Redundancy Check(CRC)を計算します。このコマンドを使用して、データが壊れていないかどうかを確認します。元のファイルのチェックサム出力と受信したファイルのチェックサム出力を比較します。

次の例では、ファイルが指定された場合の show file コマンドの出力を表示します。

switch# show file bootflash://sup-1/ultimate_file.tar cksum
2569913991
 
switch# show file bootflash://sup-1/ultimate_file.tar md5sum
52479aae2dce1fd849b6f4916d750392
 

ディレクトリ内のファイルの一覧表示

現在のディレクトリまたは特定のディレクトリの内容を表示するには、 dir コマンドを使用します。このコマンドの構文は、 dir directory or file name です。

次に、デフォルトのvolatile:ファイル システムのファイルを一覧表示する例を示します。

switch# dir
Usage for volatile: filesystem
0 bytes total used
20971520 bytes free
20971520 bytes available

ディレクトリの作成

現在のディレクトリ レベルまたは特定のディレクトリ レベルでディレクトリを作成するには、 mkdir コマンドを使用します。

このコマンドの構文は、 mkdir directory name です。

次に、slot0ディレクトリに新しいディレクトリtestを作成する例を示します。

switch# mkdir slot0:test

次に、現在のディレクトリ レベルで新しいディレクトリtestを作成する例を示します。

switch# mkdir test
 
現在のディレクトリがslot0:mydirの場合、このコマンドはslot0:mydir/testというディレクトリを作成します。

既存のディレクトリの削除

現在のディレクトリ レベルまたは特定のディレクトリ レベルで既存のディレクトリを削除するには、 rmdir コマンドを使用します。削除するディレクトリは空でなければなりません。

このコマンドの構文は、 rmdir directory name です。

次に、slot0ディレクトリにあるディレクトリtestを削除する例を示します。

switch# rmdir slot0:test
This is a directory. Do you want to continue (y/n)? [y] y
 

Cisco SAN OS Release 2.0(1b)では、 delete コマンドは空のディレクトリ、またはそれ以外のディレクトリも削除できます。このコマンドを入力する場合、ディレクトリを削除するつもりかどうかを確認する警告が表示されます。

次に、現在のディレクトリ レベルでディレクトリtestを削除する例を示します。

switch# rmdir test
This is a directory. Do you want to continue (y/n)? [y] y
 

現在のディレクトリがslot0:mydirの場合、このコマンドはslot0:mydir/testディレクトリを削除します。

ファイルの移動

ファイルを元のディレクトリから削除して別のディレクトリに移動するには、 move コマンドを使用します。移動先のディレクトリに同じ名前のファイルが存在する場合、そのファイルは移動したファイルによって上書きされます。

次に、slot0:ファイル システムのルート ディレクトリからmystorageディレクトリにファイルsamplefileを移動する例を示します。

switch# move slot0:samplefile slot0:mystorage/samplefile
 

次に、現在のディレクトリ レベルからファイルを移動する例を示します。

 
switch# move samplefile mystorage/samplefile
 

現在のディレクトリがslot0:mydirの場合、このコマンドはslot0:mydir/samplefileをslot0:mydir/mystorage/samplefileに移動します。

ファイルのコピー

ファイルをコピーするには、 copy コマンドを使用します。

次に、slot0:ファイル システムのルート ディレクトリからmystorageディレクトリにファイルsamplefileをコピーする例を示します。

switch# copy slot0:samplefile slot0:mystorage/samplefile
 

次に、現在のディレクトリ レベルからファイルをコピーする例を示します。

switch# copy samplefile mystorage/samplefile
 

現在のディレクトリがslot0:mydirの場合、このコマンドはslot0:mydir/samplefileをslot0:mydir/mystorage/samplefileにコピーします。

また、 copy コマンドを使用して、ファイルをslot0:またはbootflash: ファイル システムとFTP、TFTP、SFTP、またはSCPサーバ間でアップロードおよびダウンロードすることもできます( ファイルのコピーを参照)。

ファイルの削除

delete コマンドは、指定したファイル、または指定したディレクトリとその内容を削除します( ファイルの削除を参照)。

次に、現在の作業ディレクトリからファイルを削除する例を示します。

switch# delete dns_config.cfg
 

次に、外付けCompactFlash(slot0)からファイルを削除する例を示します。

switch# delete slot0:dns_config.cfg
 

次の例は、 my-dir ディレクトリ全体とその内容を削除します。

switch# delete bootflash:my-dir

注意 ディレクトリを指定すると、deleteコマンドがディレクトリ全体とその内容を削除します。

ファイル内容の表示

ファイル システムの特定のファイルの内容を表示するには、 show file コマンドを使用します。

このコマンドの構文は、 show file file_name です。

次に、slot0ディレクトリにあるtestファイルの内容を表示する例を示します。

switch# show file slot0:test
config t
Int fc1/1
no shut
end
show int
 

次に、現在のディレクトリにあるファイルの内容を表示する例を示します。

switch# show file myfile
 

コマンド出力のファイルへの保存

スクリーンに表示される出力結果をすべてファイルに保存するには、コマンドの後ろに > filename を指定します。たとえば、EXECモードのスイッチ プロンプトで show interface > samplefile と入力すると、同じディレクトリ レベルに samplefile が作成され、このファイルにインターフェイス コンフィギュレーションが保存されます。EXECモードのスイッチ プロンプトで dir コマンドを発行すると、新しく保存した samplefile も含めて、このディレクトリのすべてのファイルが表示されます。コンフィギュレーション ファイルの保存およびコピーについては、「初期設定」を参照してください。ソフトウェア イメージの保存およびコピーについては、「ソフトウェア イメージ」を参照してください。


) 現在のディレクトリがvolatile:(デフォルト)またはslot0:ファイル システムにある場合にのみ、リダイレクションが可能です。現在のディレクトリがbootflash:ファイル システムにある場合には、リダイレクションは認められません。現在のディレクトリを表示するにはpwdコマンド、ディレクトリを変更するにはcdコマンドを使用します。


ファイルの圧縮および圧縮解除

gzip コマンドを使用すると、指定したファイルがLZ77コーディングを使用して圧縮(zip)されます。

次に、show tech-supportコマンドの出力を特定のファイル(Samplefile)にリダイレクトし、そのファイルを圧縮して、volatile:ディレクトリにおけるスペース使用量の差を確認する例を示します。

switch# show tech-support > Samplefile
Building Configuration ...
switch# dir
1525859 Jul 04 00:51:03 2003 Samplefile
Usage for volatile://
1527808 bytes used
19443712 bytes free
20971520 bytes total
switch# gzip volatile:Samplefile
switch# dir
266069 Jul 04 00:51:03 2003 Samplefile.gz
Usage for volatile://
266240 bytes used
20705280 bytes free
20971520 bytes total
 

LZ77でコーディングされたファイルを圧縮解除(unzip)するには、 gunzip コマンドを使用します。

次に、前出の例で圧縮したファイルを圧縮解除する例を示します。

switch# gunzip samplefile
switch# dir
1525859 Jul 04 00:51:03 2003 Samplefile
Usage for volatile://
1527808 bytes used
19443712 bytes free
20971520 bytes total

ファイルの末尾の表示

指定するファイルの最後の部分(テール エンド)を表示するには、 tail コマンドを使用します。

このコマンドの構文は、 tail <file name> [<number of lines> ]です。

switch# tail mylog 10
 

この場合、mylogファイルの最後の10行が表示されます。

スクリプトで指定されたコマンドの実行

ファイルで指定したコマンドを実行するには、 run-script コマンドを使用します。このコマンドを使用する場合、ファイルを作成し、その中にコマンドを必要な順序で指定しておきます。


) スイッチ プロンプトの位置でスクリプト ファイルを作成することはできません。外部のマシンでスクリプト ファイルを作成し、そのファイルをbootflash:ディレクトリにコピーします。ここでは、スクリプト ファイルがbootflash:ディレクトリにあると想定しています。


このコマンドの構文は、 run-script file_name です。

次に、slot0ディレクトリにあるtestfileに指定されているCLIコマンドを表示する例を示します。

switch# show file slot0:testfile
conf t
interface fc 1/1
no shutdown
end
sh interface fc1/1
 

次に、testfileファイルの内容を実行する run-script コマンドによって得られるファイル出力例を示します。

switch# run-script slot0:testfile
'conf t'
Enter configuration commands, one per line. End with CNTL/Z.
'interface fc1/1'
'no shutdown'
'end'
'sh interface fc1/1'
fc1/1 is down (Fcot not present)
Hardware is Fibre Channel
Port WWN is 20:01:00:05:30:00:48:9e
Admin port mode is auto, trunk mode is on
vsan is 1
Beacon is turned off
Counter Values (current):
0 frames input, 0 bytes, 0 discards
0 runts, 0 jabber, 0 too long, 0 too short
0 input errors, 0 CRC, 0 invalid transmission words
0 address id, 0 delimiter
0 EOF abort, 0 fragmented, 0 unknown class
0 frames output, 0 bytes, 0 discards
Received 0 OLS, 0 LRR, 0 NOS, 0 loop inits
Transmitted 0 OLS, 0 LRR, 0 NOS, 0 loop inits
Counter Values (5 minute averages):
...
 

遅延時間の設定

アクションを特定の秒数だけ遅延させるには、 sleep コマンドを使用します。

このコマンドの構文は、 sleep <seconds> です。

switch# sleep 30
 

この場合、30秒後にスイッチ プロンプトが再表示されます。

このコマンドは、スクリプトの内部で使用すると便利です。たとえば、次のようなスクリプトtest-scriptを作成します。

switch# show file slot0:test-script
discover scsi-target remote
sleep 10
show scsi-target disk
switch# run-script slot0:test-script
 

slot0:test-scriptを実行すると、スイッチ ソフトウェアは discover scsi-target remote コマンドを実行したあと、10秒待機してから、 show scsi-target disk コマンドを実行します。