Cisco Service Control Application Reporter ユーザ ガイド
使用する前に
使用する前に
発行日;2012/01/31 | 英語版ドキュメント(2011/03/23 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

使用する前に

概要

システム コンポーネント

システム要件

Windows 環境での SCA Reporter のインストール

Windows 環境での SCA Reporter のインストール

Windows 環境での SCA Reporter のアンインストール

Linux 環境での SCA Reporter のインストール

Linux 環境での SCA Reporter のインストール

Linux 環境での SCA Reporter のアンインストール

SCA Reporter の起動

SCA Reporter の設定

データベース接続の管理

データベース接続の追加

データベース接続のアクティブ化

SCE プラットフォームの IP アドレスの設定

グラフ カラーの設定

カラー セットの使用

1 つの凡例項目のカラーの変更

グラフの凡例の設定

[Hierarchy] ビューの設定

SCA Reporter の詳細オプションの設定

オンライン ヘルプの使用

オンライン ヘルプの利用方法

オンライン ヘルプの検索の使用

クイック スタート:SCA Reporter を使用する前に

最初のレポートの作成

最初のレポートの処理

使用する前に

概要

Cisco Service Control Application Reporter(SCA Reporter)は、SCE プラットフォーム上で実行されたトラフィック分析に基づいてレポートを生成可能な Cisco Service Control Application ツールです。情報は、SCE プラットフォームから送信されてデータベースに保存されます。SCA Reporter は、データベースに情報を照会して取得し、結果をグローバル モニタリング、加入者モニタリング、P2P、トラフィック ディスカバリ統計情報などのさまざまなレポートに出力できます。

「システム コンポーネント」

「システム要件」

「Windows 環境での SCA Reporter のインストール」

「Linux 環境での SCA Reporter のインストール」

「SCA Reporter の起動」

「SCA Reporter の設定」

「オンライン ヘルプの使用」

「クイック スタート:SCA Reporter を使用する前に」

システム コンポーネント

SCA Reporter は、ネットワークを使用しているアプリケーションとサブスクライバの傾向やリソース消費を把握するために有効なツールです。このツールは、さまざまなルールの有効性とそれらのネットワーク上の実装に対する影響を判断するためにも使用できます。

SCA Reporter は、データベースとともに展開するという形式に限り使用できます。次の方法のいずれかでレポートを生成できます。

スタンドアロン アプリケーション

CLI(コマンドライン インターフェイス):「SCA Reporter の CLI」を参照してください。

SCA BB Console ツール:「SCA BB Console のツールとしての SCA Reporter」を参照してください。

使用可能なレポートは、さまざまな図表現(積み重ね棒グラフや面グラフなど)または表形式で表示できます。図は、さまざまなプレゼンテーション オプション(3D など)で調整できます。表レポートおよびグラフ レポートの両方をファイルにエクスポートできます。また、レポートを印刷したり、E メールで送信したりできます。さらに、プロパティに割り当てられた値(時間境界など)を変更することによって、レポートを変更することもできます。レポートの複製、保存、お気に入りへの追加ができます。

GUI ではなく、SCA Reporter の CLI を使用して、レポートを生成することもできます。

SCA Reporter は、 ビュー というビジュアル コンポーネントから構成されます。ビュー、およびそれぞれのビューで実行できるタスクは次のとおりです。

[Templates] ビュー:レポート テンプレートの選択、新しいレポート インスタンスの作成、およびレポートの生成を行います。

[Properties] ビュー:フォーカスされているオブジェクトのプロパティとその値を表示します。フォーカスされるオブジェクトは、テンプレート グループ、レポート テンプレート、レポート インスタンス、レポートのグラフ表示などです。レポート インスタンス プロパティおよびグラフ表示プロパティの設定もできます。

レポート ビュー:レポートのデータをグラフや表形式で表示します。各レポートは、専用のレポート ビューで表示されます。

[Progress] ビュー:実行またはエクスポートを行ったレポートをモニタします。このビューでは経過詳細を表示でき、バックグラウンドでレポートを生成してその他のレポートでの作業を続けることを選択することもできます。

[Favorites] ビュー:よく使用するレポート テンプレートのリストを表示し、レポートを生成します。

[Hierarchy] ビュー:レポート メトリックを階層ツリー形式で表示します。メトリックを選択または選択解除して、レポートに追加したりレポートから削除したりできます。

レポートの生成は、主に 5 つのステップで構成されます。

1. New Report ウィザードを使用して、[Templates] ビューからレポート インスタンスを作成します。

a. レポート インスタンスのプロパティを設定します。

b. 新しいレポート インスタンスを実行します(オプション)。

c. 新しいレポート インスタンスを[Favorites] ビューに追加します(オプション)。

2. レポート ビューで表形式またはグラフ形式のレポートを表示します。

3. [Hierarchy] ビューでグラフ項目を選択および選択解除して、レポート データのサブセットを表示します。

4. [Hierarchy] ビューでグラフ項目の展開および折りたたみを行います。

5. [Properties] ビューでレポートのグラフ表示を調整します。

複数のレポートを同時に生成し、後でエクスポートできます。また、レポートを印刷したり、E メールで送信したりできます。レポートの実行中は、[Progress] ビューを使用してレポートをモニタし、バックグラウンドでレポートを生成できます。

システム要件

SCA Reporter GUI フロント エンドとコマンドライン アプリケーションは、Windows 2000 または Windows XP を実行している任意のコンピュータにインストールし、実行することができます。

SCA Reporter の Linux 用コマンドライン アプリケーションは、Red Hat Enterprise Linux 4 または 5 を実行している任意のコンピュータにインストールできます。

コンピュータには最低 512 MB のメモリが必要ですが、1024 MB のメモリを強く推奨します。

最低画面解像度は、1024 × 768 ピクセルです。

Windows 環境での SCA Reporter のインストール

「Windows 環境での SCA Reporter のインストール」

「Windows 環境での SCA Reporter のアンインストール」

Windows 環境での SCA Reporter のインストール


ステップ 1 SCA Reporter のインストール ファイル SCA Reporter 3.6.0 Setup.exe を選択してダブルクリックします。

[Welcome to the SCA Reporter 3.6.0 Setup Wizard] ウィンドウが表示されます。図 2-1 を参照してください。

図 2-1 SCA Reporter Setup ウィザードの [Welcome]

 

ステップ 2 [Next] をクリックします。SCA Reporter 3.6.0 Setup ウィザードの [Choose Install Location] ウィンドウが表示されます。図 2-2 を参照してください。

図 2-2 [Choose Install Location]

 

ステップ 3 (オプション)別のディレクトリにインストールするには、[Browse] をクリックします。

ステップ 4 [Next] をクリックします。SCA Reporter 3.6.0 Setup ウィザードの [Choose Start Menu Folder] ウィンドウが表示されます。図 2-3 を参照してください。

図 2-3 [Start] メニューの場所

 

ステップ 5 (オプション)別の場所にインストールするには、[Start Menu Folder] フィールドに別の [Start] メニュー フォルダを入力します。

ステップ 6 [Install] をクリックします。SCA Reporter 3.6.0 Setup ウィザードの [Installing] ウィンドウが表示されます。図 2-4 を参照してください。

図 2-4 [Installing]

 

ステップ 7 インストールが完了するまで待機します。[Completing the SCA Reporter 3.6.0 Setup Wizard] ウィンドウが表示されます。図 2-5 を参照してください。

図 2-5 インストールの完了

 

ステップ 8 [Finish] をクリックします。SCA Reporter 3.6.0 Setup ウィザードが閉じます。SCA Reporter がマシンにインストールされました。


 

Windows 環境での SCA Reporter のアンインストール


ステップ 1 [Start] > [All Programs] > [Cisco SCA] > [SCA Reporter 3.6.0] > [Uninstall] を選択します。[Welcome to the SCA Reporter 3.6.0 Uninstall Wizard] が表示されます。図 2-6 を参照してください。

図 2-6 Reporter のアンインストール ウィザード

 

ステップ 2 [Next] をクリックします。[Uninstall SCA Reporter 3.6.0] ウィンドウが表示されます。図 2-7 を参照してください。

図 2-7 [Start] メニュー フォルダ

 

ステップ 3 [Uninstall] をクリックします。[Uninstalling] ウィンドウが表示されます。図 2-8を参照してください。

図 2-8 アンインストール

 

ステップ 4 アンインストールが完了するまで待機します。[Completing the SCA Reporter 3.6.0 Uninstall Wizard] ウィンドウが表示されます。図 2-9 を参照してください。

図 2-9 アンインストールの完了

 

ステップ 5 [Finish] をクリックします。SCA Reporter がマシンからアンインストールされました。


 

Linux 環境での SCA Reporter のインストール

SCA Reporter は Linux 環境でインストールし、コマンドラインから実行できます(「SCA Reporter の CLI」を参照)。

「Linux 環境での SCA Reporter のインストール」

「Linux 環境での SCA Reporter のアンインストール」

Linux 環境での SCA Reporter のインストール


ステップ 1 SCA BB インストール パッケージ(reporter-cmd-linux.tgz)を CCO からダウンロードします。

ステップ 2 tar xpzf reporter-cmd-linux-3.6.0.tgz コマンドを使用して、選択したディレクトリでインストール パッケージを開きます。

ステップ 3 インストール ディレクトリで reportercmd.sh -setup コマンドを実行します。


 

Linux 環境での SCA Reporter のアンインストール

インストール ディレクトリを削除します。

SCA Reporter の起動

SCA Reporter には [Start] メニューからアクセスできます。


ステップ 1 [Start] > [All Programs] > [Cisco SCA] > [SCA Reporter 3.6.0] > [SCA Reporter 3.6.0] を選択します。

Cisco Service Control SCA Reporter のスプラッシュ ウィンドウが表示されます。図 2-10 を参照してください。

図 2-10 Cisco Service Control SCA Reporter

 

SCA Reporter がロードされたあと、SCA Reporter のメイン ウィンドウが表示され、[Welcome] ビューが表示されます。

ステップ 2 [Welcome] ペインを閉じます。[Template] ペインが表示されます。図 2-11 を参照してください。

図 2-11 テンプレート

 


 

SCA Reporter の設定

SCA Reporter を設定するには、SCA Reporter の基本設定を作成する必要があります。これには、データベース タイプの選択、データベースへの接続、データベースのアクティブ化、サービス コンフィギュレーション データが使用される Service Control Engine(SCE)プラットフォームの IP アドレスの設定が含まれます。

バンドル モードでは、Cisco Service Control Management Suite(SCMS)Collection Manager(CM)を Sybase Adaptive Server Enterprise(Sybase ASE)と併用します。Sybase データ管理プラットフォームでは、トランザクション中心のエンタープライズ アプリケーションがサポートされます。情報の保存および取得をオンラインで実行でき、必要に応じて情報をウェアハウスに保存できます 詳細については、『 Cisco Service Control Management Suite Collection Manager User Guide 』を参照してください。Oracle データベースおよび MySQL データベースと連動するように CM を設定することもできます。

データベースをアクティブにしたら、データベースで SCE プラットフォームの 1 つの IP アドレスを選択する必要があります。[Preferences (Filtered)] ウィンドウのタブで表示されるリポジトリごとに選択する必要があります。SCA Reporter の[Templates] ビューに表示されるすべてのオプション(使用可能パッケージ、サービス)は、設定済み SCE プラットフォームに現在適用されているサービス コンフィギュレーションによって決まります。各レポートは、それが設定されている SCE デバイスに従って生成されます。設定例では、1 つの SCE デバイスがデータベースに接続され、1 つのリポジトリ プリファレンスがあります。

「データベース接続の管理」

「SCE プラットフォームの IP アドレスの設定」

「グラフ カラーの設定」

「グラフの凡例の設定」

「SCA Reporter の詳細オプションの設定」

データベース接続の管理

SCA Reporter を使用するには、SCE プラットフォームから作成されたデータが格納されているデータベースへの接続を作成し、アクティブにする必要があります。

多数のデータベースへの接続を追加し、必要に応じてアクティブ データベースを変更することができます。

「データベース接続の追加」

「データベース接続のアクティブ化」

データベース接続の追加

データベース接続は Add Database ウィザードで追加できます。


ステップ 1 [Main] メニューで [Preferences (Filtered)] > [Reporter] を選択します。[Preferences (Filtered)] ウィンドウが表示されます。図 2-12 を参照してください。

ステップ 2 [Reporter] ツリーで [Reporter] > [Databases] を選択します。

図 2-12 [Preferences (Filtered)]([Databases])

 

 

ステップ 3 [Databases] ペインで [Add] をクリックします。[Add Database wizard] ウィンドウが表示されます。図 2-13 を参照してください。

図 2-13 Add Database ウィザード

 

ステップ 4 [Choose definition mode] オプション ボタンのうちいずれかを選択します。

[Simple]

[Advanced]

ステップ 5 [Next] をクリックします。

[Define new database connection] ウィンドウが表示されます。この表示は、ステップ 4 で選択した定義モードによって決まります。

[Simple] 定義モードを選択した場合、[Define new database connection] ウィンドウの表示は図 2-14 のようになります。

図 2-14 [Define new database connection]

 

[Advanced] 定義モードを選択した場合、[Define new database connection] ウィンドウの表示は図 2-15 のようになります。

図 2-15 [Advanced] 定義

 

 

ステップ 6 すべてのフィールドに必要な詳細を入力します。

ステップ 7 (オプション)[Activate this database] チェックボックスをオンにします。

ステップ 8 [Finish] をクリックします。Add Database ウィザードが閉じます。

データベースの定義が、[Preferences (Filtered)] ウィンドウのリストに追加されます。図 2-16 を参照してください。

図 2-16 [Preferences (Filtered)] - [Databases]

 

ステップ 9 [Test Active DB] をクリックします。

データベース接続がテストされます。

接続に成功すると、[Click OK] というメッセージが表示されます。

接続に失敗した場合は、データベース接続を再設定してください。

ステップ 10 [OK] をクリックします。[Preferences (Filtered)] ウィンドウが閉じます。


 

データベース接続のアクティブ化


ステップ 1 メイン メニューで [Preferences (Filtered)] > [Reporter] を選択します。[Preferences (Filtered)] ウィンドウが表示されます。

ステップ 2 [Reporter] ツリーで [Reporter] > [Databases] を選択します。定義されているすべてのデータベース接続が表に一覧表示されます。

現在アクティブになっているデータベースがあれば、チェック マークで示されます( )。

ステップ 3 アクティブ化するデータベース接続を選択します。

ステップ 4 [Activate] をクリックします。

ステップ 5 [OK] をクリックします。データベースがアクティブ化されます。

ポリシー データの IP アドレス リストから、最初の IP アドレスが SCE プラットフォームの IP アドレスとして選択され、この SCE プラットフォームのサービス コンフィギュレーション データがレポートで使用されます。[Preferences (Filtered)] ウィンドウが閉じます。


 

SCE プラットフォームの IP アドレスの設定

データベースがアクティブ化されると、IP アドレスは自動的に IP リストの最初のエントリに設定されます。IP アドレスを変更するには、次の手順を実行します。


) [Preferences (Filtered)] ウィンドウには、Reporter で利用できるリポジトリ(テンプレート セット)ごとに 1 つのタブがあります。それぞれのタブで 1 つの SCE プラットフォームを選択してください。複数のリポジトリがある場合は、[Templates] ビュー内に複数のテンプレート グループ セットがあります。



ステップ 1 メイン メニューで [Preferences (Filtered)] > [Reporter] を選択します。[Preferences (Filtered)] ウィンドウが表示されます。図 2-17 を参照してください。

ステップ 2 [Reporter] ツリーで [Reporter] > [Templates] を選択します。

図 2-17 [Preferences (Filtered)] - [Templates]

 

 

ステップ 3 [Templates] ペインで、[IP of SCE for policy data] ドロップダウン リストから、サービス コンフィギュレーション データがレポートで使用される SCE プラットフォームの IP アドレスを選択します。この IP アドレスは、SCA Reporter のテンプレート リポジトリに追加されます。

ステップ 4 [Apply] をクリックします。SCE プラットフォームの IP アドレスがサービス コンフィギュレーション データ用に設定されます。


) ダイアログボックスを閉じる前に、[Apply] をクリックする必要があります


ステップ 5 [OK] をクリックします。[Preferences (Filtered)] ウィンドウが閉じます。


 

グラフ カラーの設定

Reporter インストールの一部としてインストールされているグラフのデフォルトのカラー セットを使用せず(定義済みのカラーは SCA BB Templates パッケージ内にパッケージ化されている)、独自にカラー セットを定義できます。

これにより、次のような Reporter の異なるセッション間でカラーの永続性を確保できます。

同じ Reporter インストールにおける異なるセッション

同じ SCE プラットフォームのデータを使用する、異なる Reporter インストール(色ファイルをエクスポートおよびインポートする)

異なる SCE プラットフォームのデータを使用する、異なる Reporter

Reporter の異なるバージョン

カラー セットの詳細および項目のカラーの凡例を変更する方法については、「カラー セットの使用」および「1 つの凡例項目のカラーの変更」を参照してください。

カラー セットの使用

カラー セット ファイルの各行で、1 つの凡例項目のカラーを定義します。手動でカラー セット ファイルを編集することは避けてください。


ステップ 1 [Main] メニューで [Preferences (Filtered)] > [Reporter] を選択します。[Preferences (Filtered)] ダイアログボックスが表示されます。

ステップ 2 [Reporter] ツリーで [Reporter] > [Charts Colors] を選択します。[Charts Colors] ペインが表示されます。図 2-18 を参照してください。

図 2-18 [Chart Colors] プリファレンス

 

ステップ 3 実行する処理を選択します。

ファイルからカラー セットをインポートするには、[Import] をクリックします。

[Open] ダイアログボックスが表示されます。目的のファイルを参照して [Open] をクリックします。ファイルがインポートされ、既存のカラー セットが上書きされます。

現在のカラー セットをファイルにエクスポートするには、[Export] をクリックします。

[Save As] ダイアログボックスが表示されます。目的のディレクトリを参照し、[File name] フィールドにファイル名を入力して、[Save] をクリックします。カラー セットがエクスポートされます。

デフォルトのカラー セット(SCA BB Templates パッケージで提供されている設定済みのカラー)を復元するには、[Restore Defaults] をクリックします。

リリース 3.5.0 よりも前に使用されていたカラー割り当て方式をイネーブルにするには、[Enable legacy coloring mode] チェックボックスをオンにします。図 2-19 を参照してください。

図 2-19 [Chart Colors] - [Enable Legacy Coloring Mode]

 


) [Import]、[Restore Defaults]、または [Enable legacy color mode] を適用する前に、[Confirm discarding color settings] ダイアログボックスが表示されます。図 2-20 を参照してください。


図 2-20 [Confirm Discarding Color Settings]

 

ステップ 4 [OK] をクリックします。[Preferences (Filtered)] ウィンドウが閉じます。


 

1 つの凡例項目のカラーの変更


ステップ 1 [Main] メニューで [Preferences (Filtered)] > [Reporter] を選択します。[Preferences (Filtered)] ウィンドウが表示されます。

ステップ 2 [Reporter] ツリーで [Reporter] > [Charts Colors] を選択します。[Charts Colors preference] ペインが表示されます。

ステップ 3 カラー ツリーで凡例項目を 1 つ選択します(次のウィンドウでは、service)。

凡例項目の現在のカラーが、[Charts Colors] ペインの右上に表示されます。図 2-21 を参照してください。

図 2-21 現在のカラー

 

 


) 凡例項目で使用できるカテゴリは、Direction、Hostname、Host IP、Protocol、MOS、Range、Codec、Port Number、Newsgroup、Protocol、Service、Measure、および Subscriber です。

カラーが凡例項目に割り当てられた後、カテゴリと凡例項目は [Charts Colors] ペインだけに表示されます。レポート インスタンスを初めて実行したときに、カラーがグラフ内の凡例項目に割り当てられます。


ステップ 4 カラーをクリックします。カラー パレット ウィンドウが表示されます。図 2-22 を参照してください。

図 2-22 カラー パレット

 

ステップ 5 凡例項目の新しいカラーを選択し、[OK] をクリックします。

[Color] ウィンドウが閉じます。選択したカラーが凡例項目に適用されます。図 2-23 を参照してください。

[Reset] ボタンがイネーブルになります。

図 2-23 選択したカラーの適用

 


) [Reset] ボタンを使用すると、選択した 1 つの凡例項目のデフォルト カラーを復元できます。



 

グラフの凡例の設定

グラフ内の凡例の外観をグローバルに設定できます。


ステップ 1 [Main] メニューで [Preferences (Filtered)] > [Reporter] を選択します。[Preferences (Filtered)] ウィンドウが表示されます。図 2-24 を参照してください。

ステップ 2 [Reporter] ツリーで [Reporter] > [Configuration] を選択します。

図 2-24 [Preferences (Filtered)] - [Configuration]

 

ステップ 3 (オプション)[Show item check box in legend] チェックボックスをオフにします。

ステップ 4 (オプション)[Allow multi column in legend] チェックボックスをオフにします。

ステップ 5 (オプション)[Max legend percentage] フィールドで、新しい値を入力します。

ステップ 6 [OK] をクリックします。新しい設定値が保存されます。[Preferences (Filtered)] ウィンドウが閉じます。


 

[Hierarchy] ビューの設定

[Hierarchy] ビューの複数のアトリビュートを設定するには、次の手順を実行します。


ステップ 1 [Main] メニューで [Preferences (Filtered)] > [Reporter] を選択します。[Preferences (Filtered)] ウィンドウが表示されます。図 2-25 を参照してください。

ステップ 2 [Reporter] ツリーで [Reporter] > [Configuration] を選択します。

図 2-25 [Preferences (Filtered)] - [Configuration]

 

ステップ 3 (オプション)[open hierarchy view on start] チェックボックスをオンにします。

ステップ 4 (オプション)[services tree default level] フィールドで、新しいを入力します。

ステップ 5 (オプション)[sorted tree number of services on other group] フィールドで、階層の [Other group] 内に含めるサービスの数を示す新しい値を入力します。

ステップ 6 [OK] をクリックします。新しい設定値が保存されます。

[Preferences (Filtered)] ウィンドウが閉じます。


 

SCA Reporter の詳細オプションの設定

SCA Reporter では、次の詳細オプションを設定できます。

デバッグ メッセージのログ

データベース接続を待ち受ける時間の長さ

同時に実行できるレポート インスタンスの最大数


ステップ 1 [Main] メニューで [Preferences (Filtered)] > [Reporter] を選択します。[Preferences (Filtered)] ウィンドウが表示されます。図 2-26 を参照してください。

ステップ 2 [Reporter] ツリーで [Reporter] > [Configuration] を選択します。

図 2-26 [Preferences (Filtered)] - [Configuration]

 

ステップ 3 デバッグ メッセージをロギングするには、[Send debug messages to log] チェックボックスをオンにします。

デバッグ メッセージをロギングすると、ログ ファイルが急速に大きくなることがあります。

ステップ 4 [seconds to wait for a database connection] フィールドに新しい値を入力します。

ステップ 5 [maximum number of reports that can be executed simultaneously] フィールドに新しい値を入力します。

ステップ 6 [OK] をクリックします。新しい設定値が保存されます。[Preferences (Filtered)] ウィンドウが閉じます。


 

オンライン ヘルプの使用

「オンライン ヘルプの利用方法」

「オンライン ヘルプの検索の使用」

オンライン ヘルプの利用方法

このユーザ ガイドの関連部分に SCA Reporter からアクセスするには、次の手順を実行します。


ステップ 1 [Help] メニューから [Help Contents] を選択します。オンライン ヘルプが別のウィンドウで開きます。詳細については、「オンライン ヘルプの検索の使用」を参照してください。


 

オンライン ヘルプの検索の使用

SCA Reporter 内からオンライン ヘルプを検索することもできます。


ステップ 1 [Help] メニューから [Search] を選択します。[Reporter] ウィンドウで [Help] ビューが表示されます(図 2-27)。

図 2-27 Reporter のヘルプ

 

ステップ 2 単語、語句、式を [Search expression] フィールドに入力します。

[Go] ボタンがクリック可能になります。


) [>>](拡張)をクリックすると、検索式の作成方法が表示されます。


ステップ 3 [Go] をクリックします。検索式を含むヘルプ トピックが [Local Help] の下に表示されます。

ステップ 4 内容を表示するには、 ヘルプ トピックをクリックします。


) トピックにブックマークを付けて後で参照できます。


ステップ 5 [Help] ビュー下部の適切なリンクをクリックすると、以下に切り替えることができます。

すべてのトピック

関連トピック

ブックマーク


 

クイック スタート:SCA Reporter を使用する前に

このクイック スタートの項は、SCA Reporter を初めて使用する場合に役立ちます。SCA Reporter の設定、レポート インスタンスの作成、レポートの生成、およびレポートの処理を行います。

「最初のレポートの作成」

「最初のレポートの処理」

最初のレポートの作成


ステップ 1 SCA Reporter を起動します([Start] > [All Programs] > [Cisco SCA] > [SCA Reporter 3.6.0] > [SCA Reporter 3.6.0] を選択)(図 2-28)。

図 2-28 Reporter

 

ステップ 2 データベース接続を追加、設定、およびアクティブ化します(「データベース接続の管理」を参照)。

ステップ 3 アクティブなデータベースがあり、システムが正しく設定されていることを確認します。

a. [Main] メニューで [Preferences (Filtered)] > [Reporter] を選択します。[Preferences (Filtered)] ウィンドウが表示されます。

b. [Reporter] ツリーで [Reporter] > [Databases] を選択します。

c. [Databases] ペインで [Test Active DB] をクリックします。

ステップ 4 [Templates] ビューで、いずれかのテンプレート グループのノードを展開します。図 2-29 を参照してください。

図 2-29 テンプレート

 

ステップ 5 次のいずれかを実行します。

レポート テンプレートをダブルクリックします。

レポート テンプレートを右クリックします。

レポート テンプレートのポップアップ メニューが表示されます。図 2-30 を参照してください。

図 2-30 テンプレート ポップアップ メニュー

 

ステップ 6 メニューから [New] を選択します。[New Report Wizard] が表示されます。図 2-31 を参照してください。

図 2-31 [New Report Wizard]

 

レポート インスタンスの名前は、レポート テンプレートの名前に「#1」を付加したものになります。[Report name] フィールドに名前を入力し、任意でレポート インスタンスの名前を変更できます。

ステップ 7 レポート インスタンスのプロパティの設定

([not set])を持つプロパティがある場合は、それに値を割り当てる必要があります。

ステップ 8 [Next] をクリックします(図 2-32)。

図 2-32 レポート処理の選択

 

ステップ 9 [Finish] をクリックします。

レポート テンプレートの下にレポート インスタンスが追加されます(図 2-33 を参照)。

図 2-33 追加されたレポート インスタンス

 

レポート インスタンスが[Favorites] ビューに表示されます。図 2-34 を参照してください。

図 2-34 [Favorites]

 

[SCA Reporter] ウィンドウの右上にレポート インスタンスの名前を持つレポート ビューが表示され、レポートのグラフが表示されます。図 2-35 を参照してください。

図 2-35 レポート

 

レポートに含まれるすべてのサービスが[Hierarchy] ビューに含まれます。図 2-36 を参照してください。

図 2-36 [Hierarchy]

 

ステップ 10 レポートを表示します。グラフ表示プロパティは[Properties] ビューに表示されます。図 2-37 を参照してください。

図 2-37 [Properties]

 


 

最初のレポートの処理


ステップ 1 前述の手順に従ってレポートを作成します。

ステップ 2 [Properties] ビューでグラフ表示プロパティを修正することによって、グラフ表示を調整します (「グラフ表示の調整」 を参照)。

ステップ 3 [Hierarchy] ビューで、グラフ項目をいくつかオフにします。修正されたレポートがレポート ビューに表示されます。図 2-38 を参照してください。

ステップ 4 レポート ビューにおいて、ビューの上にあるドロップダウン メニューから [Go To Report] を選択します。

図 2-38 修正されたレポート

 

[Properties] ビューに、レポート インスタンス プロパティが表示されます。

ステップ 5 ([Show Advanced Properties])をクリックすることによって、すべてのレポート インスタンス プロパティを表示します(図 2-39)。

図 2-39 レポート プロパティ

 

ステップ 6 1 つまたは複数のプロパティを修正します (「既存のレポート インスタンスの修正」 を参照)。

ステップ 7 ([Execute])をクリックします レポートが再生成されます。

修正されたレポートがレポート ビューに表示されます。図 2-40 を参照してください。

図 2-40 修正されたレポート

 

(ここに示した例(図 2-40)では、[Traffic Direction] および [Units of results] の各プロパティが修正されています)