Cisco ASA シリーズ ファイアウォール ASDM コンフィギュレーション ガイド ソフトウェア バージョン 7.1 ASA 5505、ASA 5510、ASA 5520、ASA 5540、ASA 5550、ASA 5512-X、ASA 5515-X、ASA 5525-X、ASA 5545-X、ASA 5555-X、ASA 5580、ASA 5585-X、および ASA サービス モジュール用
接続のトラブルシューティングおよびリソース
接続のトラブルシューティングおよびリソース
発行日;2013/10/09 | 英語版ドキュメント(2013/09/18 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

接続のトラブルシューティングおよびリソース

コンフィギュレーションのテスト

のインターフェイスへの ping の実行

ping を使用した のコンフィギュレーションと動作の検証、およびインターフェイスのテストの実行

ping に関する情報

インターフェイスからの ping の送信

インターフェイスへの ping の送信

のインターフェイスを通過する ping

ping ツールのトラブルシューティング

ping ツールの使い方

トレースルートによるパケット ルーティングの決定

パケット トレーサによるパケットの追跡

パフォーマンスのモニタリング

システム リソースのモニタリング

Blocks

CPU

メモリ

接続のモニタリング

プロセスごとの CPU 使用率のモニタリング

接続のトラブルシューティングおよびリソース

この章では、ASA のトラブルシューティングの方法について説明します。次の項目を取り上げます。

「コンフィギュレーションのテスト」

「パフォーマンスのモニタリング」

「システム リソースのモニタリング」

「接続のモニタリング」

「プロセスごとの CPU 使用率のモニタリング」

コンフィギュレーションのテスト

この項では、シングル モード ASA または各セキュリティ コンテキストの接続性のテスト方法、ASA インターフェイスを ping する方法、およびあるインターフェイスにあるホストが他のインターフェイスのホストに ping できるようにする方法について説明します。

この項では、次のトピックについて取り上げます。

「ASA のインターフェイスへの ping の実行」

「ping を使用した ASA のコンフィギュレーションと動作の検証、およびインターフェイスのテストの実行」

「トレースルートによるパケット ルーティングの決定」

「パケット トレーサによるパケットの追跡」

ASA のインターフェイスへの ping の実行

ASA インターフェイスが起動して動作しているかどうか、およびASAと接続ルータが正しく動作しているかどうかをテストするには、ASA インターフェイスを ping します。

ASA インターフェイスを ping するには、次の手順を実行します。


ステップ 1 インターフェイス名、セキュリティ レベル、および IP アドレスを示すシングル モードのASAまたはセキュリティ コンテキストの図を作成します。


) この手順では IP アドレスを使用しますが、ping コマンドでは、DNS 名および name コマンドを使用してローカル IP アドレスに割り当てられた名前もサポートされます。


図には、直接接続されたすべてのルータ、および ASA を ping するルータの反対側にあるホストも含める必要があります。(図 23-1 を参照)。

図 23-1 インターフェイス、ルータ、およびホストを含むネットワーク図

 

ステップ 2 直接接続されたルータから各 ASA インターフェイスを ping します。トランスペアレント モードでは、管理 IP アドレスを ping します。このテストは、ASA インターフェイスがアクティブであること、およびインターフェイス コンフィギュレーションが正しいことを確認します。

ASA インターフェイスがアクティブではない場合、インターフェイス コンフィギュレーションが正しくない場合、またはASAとルータの間でスイッチがダウンしている場合、ping は失敗する可能性があります(図 23-2 を参照)。この場合は、パケットが ASA に到達しないので、デバッグ メッセージや syslog メッセージは表示されません。

図 23-2 のインターフェイスへの ping の失敗

 

ping がASAに到達し、応答があると、次のようなデバッグ メッセージが表示されます。

ICMP echo reply (len 32 id 1 seq 256) 209.165.201.1 > 209.165.201.2
ICMP echo request (len 32 id 1 seq 512) 209.165.201.2 > 209.165.201.1
 

ping 応答がルータに戻されない場合は、スイッチ ループまたは冗長 IP アドレスが存在する可能性があります(図 23-3 を参照)。

図 23-3 IP アドレッシングの問題による ping の失敗

 

ステップ 3 リモート ホストから各 ASA インターフェイスを ping します。トランスペアレント モードでは、管理 IP アドレスを ping します。このテストは、直接接続されたルータがホストとASAの間でパケットをルーティングできるかどうか、およびASAがパケットを正確にルーティングしてホストに戻せるかどうかを確認します。

中間ルータを通ってホストに戻るルートがASAにない場合、ping は失敗する可能性があります(図 23-4 を参照)。この場合は、デバッグ メッセージは ping が成功したことを示しますが、ルーティングの失敗を示す syslog メッセージ 110001 が表示されます。

図 23-4 に戻りルートがないことによる ping の失敗

 


 

ping を使用した ASA のコンフィギュレーションと動作の検証、およびインターフェイスのテストの実行

ping ツールは、ASAおよび関係する通信リンクのコンフィギュレーションおよび動作を検証する場合、また他のネットワーク デバイスをテストする場合に便利です。

この項では、次のトピックについて取り上げます。

「ping に関する情報」

「インターフェイスからの ping の送信」

「インターフェイスへの ping の送信」

「ASA のインターフェイスを通過する ping」

「ping ツールのトラブルシューティング」

「ping ツールの使い方」

ping に関する情報

ping が IP アドレスに送信されると、応答が返されます。このプロセスを使用して、ネットワーク デバイスは、相互に検出、識別、およびテストすることができます。

ping ツールでは、ICMP(RFC 777 および RFC 792 に記載)を使用して、2 つのネットワーク デバイス間でのエコー要求とエコー応答のトランザクションを定義します。エコー要求パケットは、ネットワーク デバイスの IP アドレスへ送信されます。受信側のデバイスは送信元と宛先のアドレスを逆にしてから、そのパケットをエコー応答として送り返します。

管理者は、次の方法で ASDM の ping インタラクティブ診断ツールを使用できます。

2 つのインターフェイス間のループバック テスト:同じ ASA で一方のインターフェイスから相手側のインターフェイスに ping を外部ループバック テストとして起動すると、双方のインターフェイスの基本的な「アップ」ステータスおよび動作を検証できます。

ASAへの ping 送信:ping ツールにより、別のASAのインターフェイスに ping を送信し、そのインターフェイスがアップしていて応答することを確認できます。

ASAを通過する ping 送信:ping ツールの送信 ping パケットがデバイスに到達する途中で、中間のASAを通過する場合があります。エコー パケットは、返されるときにそのインターフェイスを両方とも通過します。この手順によって、中間にある装置のインターフェイス、動作、応答時間についての基本的なテストができます。

ネットワーク デバイスの疑わしい動作をテストするための ping 送信:正常に機能していないと思われるネットワーク デバイスに対して、ASAのインターフェイスから ping を送信できます。インターフェイスが正しく設定されているにもかかわらずエコーを受信しない場合は、デバイスに問題があると考えられます。

中間の通信状態をテストする場合の ping 送信:正常に機能し、エコー要求を返すことがわかっているネットワーク デバイスに対して、ASAのインターフェイスから ping を送信できます。エコーを受信した場合、中間にあるデバイスがすべて正常に動作し、物理的に正しく接続されていることが確認されたことになります。

インターフェイスからの ping の送信

インターフェイスの基本的なテストを行う場合は、正常に機能し、中間通信パスを経由して応答を返すことがわかっているネットワーク デバイスに対して、ASA のインターフェイスから ping 送信を開始できます。基本的なテストの場合は、次の手順を必ず実行してください。

「既知の正常な」デバイスが、ASA のインターフェイスから送信された ping を受信することを確認します。ping を受信しない場合は、送信ハードウェアまたはインターフェイスのコンフィギュレーションに問題がある可能性があります。

ASA のインターフェイスが正しく設定されているにもかかわらず、「既知の正常な」デバイスからエコー応答を受信しない場合は、インターフェイス ハードウェアの受信機能に問題があると考えられます。「既知の正常な」受信機能を持つ別のインターフェイスで、同じ「既知の正常な」デバイスに対して ping を送信してエコーを受信できる場合、最初のインターフェイスのハードウェアの受信機能に問題があると確認されたことになります。

インターフェイスへの ping の送信

ASA のインターフェイスに ping を送信しようとする場合は、[Tools] > [Ping] の順に選択して、そのインターフェイスで ping 応答(ICMP エコー応答 がイネーブルになっていることを確認してください。ping 機能がディセーブルになっていると、ASA は他のデバイスやソフトウェア アプリケーションから検出されず、ASDM の ping ツールに応答しません。

ASA のインターフェイスを通過する ping

「既知の正常な」送信元からの他のタイプのネットワーク トラフィックが ASA を通過していることを確認するには、[Monitoring] > [Interfaces] > [Interface Graphs] または SNMP 管理ステーションを選択します。

内部ホストから外部ホストへの ping の送信をイネーブルにするには、ICMP インスペクションを設定します。[Configuration] > [Firewall] > [Service Policies] を選択します。

ping ツールのトラブルシューティング

ping を送信してエコーを受信しない場合は、ASA のコンフィギュレーションまたは動作にエラーがあることも原因として考えられます。必ずしも ping を送信した IP アドレスから応答がないことが原因であるとは限りません。ping ツールを使用して、ASAのインターフェイスから、インターフェイスに、またはインターフェイスを通過させて ping を送信する前に、次の基本的な確認を行ってください。

インターフェイスが設定されていることを確認します。[Configuration] > [Device Setup] > [Interfaces] を選択します。

スイッチやルータなど通信パスの中間デバイスで、他のタイプのネットワーク トラフィックが正常に配信されていることを確認します。

「既知の正常な」送信元からの他のタイプのトラフィックが通過することを確認します。[Monitoring] > [Interfaces] > [Interface Graphs] を選択します。

ping ツールの使い方

ping ツールを使用するには、次の手順を実行します。


ステップ 1 メイン ASDM アプリケーション ウィンドウで、[Tools] > [Ping] の順に選択します。

[Ping] ダイアログボックスが表示されます。

ステップ 2 [IP Address] フィールドに、ICMP エコー要求パケットの宛先 IP アドレスを入力します。

ping は、IPv6 アドレスもサポートします。


) [Configuration] > [Firewall] > [Objects] > [Objects/Groups Names] ペインでホスト名が割り当てられている場合は、IP アドレスの代わりにホスト名を使用できます。


ステップ 3 (任意)ドロップダウン リストから、エコー要求パケットを送信するASAのインターフェイスを選択します。指定しない場合、ASAはルーティング テーブルを調べ、宛先アドレスを見つけて必要なインターフェイスを使用します。

ステップ 4 [Ping] をクリックして、指定したインターフェイスまたはデフォルトのインターフェイスから、指定した IP アドレスに ICMP エコー要求パケットを送信し、応答タイマーを開始します。

応答は [Ping Output] 領域に表示されます。IP アドレスへの ping は 3 回送信され、結果は次のフィールドに表示されます。

ping が送信されたデバイスの IP アドレスまたはデバイス名(設定されている場合)。デバイス名が割り当てられている場合、結果が応答なしの場合でもそのデバイス名が表示される場合があります。

ping が送信されると、指定した最大値つまりタイムアウト値でミリ秒タイマーが作動します。このタイマーは、異なるルートやアクティビティ レベルの相対応答時間をテストするのに便利です。

ping の実行結果の例:

Sending 5, 100-byte ICMP Echos to out-pc, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
 

ping が失敗した場合、実行結果は次のようになります。

Sending 5, 100-byte ICMP Echos to 10.132.80.101, timeout is 2 seconds:
?????
Success rate is 0 percent (0/5)
 

ステップ 5 新しい IP アドレスを入力するには、[Clear Screen] をクリックして、[Ping output] 領域から前の応答を削除します。


 

トレースルートによるパケット ルーティングの決定

Traceroute ツールにより、パケットが宛先に到着するまでのルートを判断できます。このツールは、送信される各プローブの結果を出力します。出力の各行が 1 つの TTL 値に対応します(昇順)。次の表に、このツールによって出力される記号の一覧を示します。

 

出力記号
説明

*

タイムアウトの期間内にプローブへの応答を受信しませんでした。

nn msec

各ノードで、指定した数のプローブのラウンドトリップにかかる時間(ミリ秒)。

!N.

ICMP ネットワークに到達できません。

!H

ICMP ホストに到達できません。

!P

ICMP に到達できません。

!A

ICMP が設定によって禁止されています。

?

ICMP の原因不明のエラーが発生しました。

Traceroute ツールを使用するには、次の手順を実行します。


ステップ 1 メイン ASDM アプリケーション ウィンドウで、[Tools] > [Traceroute] の順に選択します。

[Traceroute] ダイアログボックスが表示されます。

ステップ 2 ルートをトレースするホスト名または IP アドレスを入力します。ホスト名が指定されている場合は、[Configuration] > [Firewall] > [Objects] > [Service Objects/Groups] の順に選択して名前を定義するか、またはこのツールをイネーブルにするように DNS サーバを設定して、ホスト名を IP アドレスに解決します。

ステップ 3 応答を待機しているときの接続タイムアウト時間を秒単位で入力します。デフォルトは 3 秒です。

ステップ 4 UDP プローブ メッセージで使用される宛先ポートを入力します。デフォルト値は 33434 です。

ステップ 5 各 TTL レベルで送信されるプローブ数を入力します。デフォルトは 3 です。

ステップ 6 最初のプローブの最小および最大 TTL 値を指定します。デフォルトの最小値は 1 です。値を大きくすると、始めに表示される既知のホップが少なくなります。デフォルトの最大値は 30 です。トレースルートは、パケットが宛先に到達するか、または最大値に達すると終了します。

ステップ 7 [Specify source interface or IP address] チェックボックスをオンにします。ドロップダウン リストから、パケット トレースの送信元インターフェイスまたは IP アドレスを選択します。この IP アドレスはいずれかのインターフェイスの IP アドレスにする必要があります。トランスペアレント モードの場合は、ASAの管理 IP アドレスにする必要があります。

ステップ 8 名前解決が設定されている場合、使用されたホップ名を出力結果に表示するには、[Reverse Resolve] チェックボックスをオンにします。出力結果に IP アドレスを表示するには、このチェックボックスをオフにします。

ステップ 9 UDP プローブ パケットの代わりに ICMP プローブ パケットを使用するよう指定するには、[Use ICMP] チェックボックスをオンにします。

ステップ 10 [Trace Route] をクリックしてトレースルートを開始します。

[Traceroute Output] 領域に、トレースルートの結果についての詳細なメッセージが表示されます。

ステップ 11 [Clear Output] をクリックして新しいトレースルートを開始します。


 

パケット トレーサによるパケットの追跡

パケット トレーサ ツールは、パケット スニフィングとネットワーク障害箇所特定のためのパケット追跡を実現するとともに、パケットに関する詳細情報とASAによるパケットの処理方法を示します。コンフィギュレーション コマンドがパケット ドロップの原因ではない場合は、パケット トレーサ ツールを実行すると、その原因に関する情報が読みやすい形式で表示されます。

また、パケットが正しく動作しているかどうかを確認するために、パケット トレーサ ツールを使用して、ASAを通過するパケットのライフスパンをトレースできます。このツールを使用して、次のことを行えます。

ネットワーク内にドロップするすべてのパケットをデバッグする。

コンフィギュレーションが意図したとおりに機能しているかを確認する。

パケットに適用可能なすべてのルール、およびルールが追加される原因となった CLI コマンドを表示する。

データ パス内でのパケット変化を時系列で表示する。

データ パスにトレーサ パケットを挿入する。

ユーザ アイデンティティおよび FQDN に基づいて IPv4 アドレスまたは IPv6 アドレスを検索する。

パケット トレーサを使用するには、次の手順を実行します。


ステップ 1 メイン ASDM アプリケーション ウィンドウで、 [Tools] > [Packet Tracer] の順に選択します。

[Cisco ASDM Packet Tracer] ダイアログボックスが表示されます。

ステップ 2 ドロップダウン リストからパケット トレースの送信元インターフェイスを選択します。

ステップ 3 パケット トレースのプロトコル タイプを指定します。指定できるプロトコル タイプは、ICMP、IP、TCP、および UDP です。

ステップ 4 [Source] ドロップダウン リストで、次のいずれかのオプションを選択します:

IP Address

User

FQDN

Security Tag

Security Name

Cisco TrustSec ソリューションに統合されたときに、ASA から送信されたパケットをトレースする場合は [Security Tag] または [Security Name] オプションを選択します。セキュリティ名は Cisco ISE 上で作成され、セキュリティ グループに対応するわかりやすい名前が付けられます。

セキュリティ ポリシーがそのセキュリティ タグまたはセキュリティ名付きで ASA に設定されると、ASA はそのポリシーを実行します。(セキュリティ タグまたはセキュリティ名を含む ASA にセキュリティ ポリシーを作成できます。セキュリティ グループの名前に基づいてポリシーを実行するには、ASA はセキュリティ名をセキュリティ タグにマッピングするためにセキュリティ グループ テーブルが必要です)。

ASA を Cisco TrustSec ソリューションに統合するための設定に関する詳細については、一般的な操作のコンフィギュレーション ガイドのを参照してください。

ステップ 5 ユーザが [Source] ドロップダウン リストで選択したオプションに基づいて、トレースする項目に対応するテキストを入力します。たとえば、[Source IP Address] フィールドに、パケット トレースの送信元 IP アドレスを入力します。

ステップ 6 TCP および UDP の場合のみ、ドロップダウン リストから、パケット トレースの送信元ポートを選択します。

ステップ 7 [Destination] ドロップダウン リストで、次のいずれかのオプションを選択します。

IP Address

FQDN

Security Tag

Security Name

ステップ 8 [Destination] ドロップダウン リストで選択したオプションに基づいて、トレースする項目に対応するテキストを入力します。たとえば、[Destination IP Address] フィールドに、パケット トレースの送信元 IP アドレスを入力します。

ステップ 9 TCP および UDP の場合のみ、ドロップダウン リストから、パケット トレースの宛先ポートを選択します。

ステップ 10 ICMP の場合のみ、[Type] ドロップダウン リストから、パケット トレースのタイプを選択します。次に、該当するフィールドにトレース コードとトレース ID を入力します。

ステップ 11 IP の場合のみ、[Protocol] フィールドにプロトコル番号を入力します。有効値の範囲は 0 ~ 255 です。

ステップ 12 [Start] をクリックして、パケットをトレースします。

[Information Display Area] に、パケット トレースの結果に関する詳細情報が表示されます。


) パケット トレースをグラフィカルに表現するには、[Show animation] チェックボックスをオンにします。


ステップ 13 [Clear] をクリックして新しいパケット トレースを開始します。


 

パフォーマンスのモニタリング

ASA のパフォーマンス情報をグラフ形式または表形式で表示するには、次の手順を実行します。


ステップ 1 ASDM メイン ウィンドウで、[Monitoring] > [Properties] > [Connection] > [Graphs] > [Perfmon] の順に選択します。

ステップ 2 [Available Graphs] リストからエントリを 1 つ以上選択し、[Add] をクリックして、それらのエントリを [Selected Graphs] リストに移動します。エントリを [Selected Graphs] リストから削除するには、[Remove] をクリックします。使用可能なオプションは次のとおりです。

[AAA Perfmon]:ASAの AAA パフォーマンス情報を表示します。

[Inspection Perfmon]:ASAの検査パフォーマンス情報を表示します。

[Web Perfmon]:URL アクセスおよび URL サーバ要求などのASAの Web パフォーマンス情報を表示します。

[Connections Perfmon]:ASAの接続パフォーマンス情報を表示します。

[Xlate Perfmon]:ASAの NAT パフォーマンス情報を表示します。

1 つのグラフ ウィンドウに表示する統計情報のタイプは 4 つまで選択できます。複数のグラフ ウィンドウを同時に開くことができます。

ステップ 3 既存のウィンドウ タイトルを使用するには、ドロップダウン リストからいずれかを選択します。新しいウィンドウにグラフを表示するには、[Graph Window Title] フィールドに新しいウィンドウ タイトルを入力します。

ステップ 4 [Show Graphs] をクリックして、新しいグラフ ウィンドウまたは更新したグラフ ウィンドウにパフォーマンス統計情報を表示します。

ステップ 5 [Table] タブをクリックして、同じパフォーマンス統計情報を表形式で表示します。

ステップ 6 いずれかのタブ上の [View] ドロップダウン リストから、情報を更新して表示する期間を [Real-time, data every 10 sec]、[Last 10 minutes, data every 10 sec]、[Last 60 minutes, data every 1 min]、[Last 12 hours, data every 12 minutes]、または [Last 5 days, data every two hours] から選択します。

ステップ 7 (任意)[Export] をクリックして、[Export Graph Data] ダイアログボックスを表示します。エクスポートするよう選択されたパフォーマンス統計情報は、すでにオンになっています。

ステップ 8 (任意)[Export] を再度クリックして、[Save] ダイアログボックスを表示します。

ステップ 9 (任意)[Save] をクリックして、パフォーマンス統計情報をローカル ドライブ上のテキスト ファイル(.txt)に保存し、後で参照できるようにします。

ステップ 10 (任意)[Print] をクリックして、[Print Graph] ダイアログボックスを表示します。

ステップ 11 (任意)ドロップダウン リストからグラフまたはテーブル名を選択し、[Print] をクリックして、[Print] ダイアログボックスを表示します。

ステップ 12 (任意)[OK] をクリックして、選択したパフォーマンス統計情報を印刷します。


 

システム リソースのモニタリング

この項では、次のトピックについて取り上げます。

「Blocks」

「CPU」

「メモリ」

Blocks

空きメモリ ブロックおよび使用中のメモリ ブロックを表示するには、次の手順を実行します。


ステップ 1 ASDM メイン ウィンドウで、[Monitoring] > [Properties] > [System Resources Graphs] > [Blocks] の順に選択します。

ステップ 2 [Available Graphs] リストからエントリを 1 つ以上選択し、[Add] をクリックして、それらのエントリを [Selected Graphs] リストに移動します。エントリを [Selected Graphs] リストから削除するには、[Remove] をクリックします。使用可能なオプションは次のとおりです。

[Blocks Used]:ASAで使用中のメモリ ブロックを表示します。

[Blocks Free]:ASAの空きメモリ ブロックを表示します。

1 つのグラフ ウィンドウに表示する統計情報のタイプは 4 つまで選択できます。複数のグラフ ウィンドウを同時に開くことができます。

ステップ 3 既存のウィンドウ タイトルを使用するには、ドロップダウン リストからいずれかを選択します。新しいウィンドウにグラフを表示するには、[Graph Window Title] フィールドに新しいウィンドウ タイトルを入力します。

ステップ 4 [Show Graphs] をクリックして、新しいグラフ ウィンドウまたは更新したグラフ ウィンドウにシステム リソース統計情報を表示します。

ステップ 5 [Table] タブをクリックして、同じパフォーマンス統計情報を表形式で表示します。

ステップ 6 いずれかのタブ上の [View] ドロップダウン リストから、情報を更新して表示する期間を [Real-time, data every 10 sec]、[Last 10 minutes, data every 10 sec]、[Last 60 minutes, data every 1 min]、[Last 12 hours, data every 12 minutes]、または [Last 5 days, data every two hours] から選択します。

ステップ 7 (任意)[Export] をクリックして、[Export Graph Data] ダイアログボックスを表示します。エクスポートするよう選択されたメモリ ブロック統計情報は、すでにオンになっています。

ステップ 8 (任意)[Export] を再度クリックして、[Save] ダイアログボックスを表示します。

ステップ 9 (任意)[Save] をクリックして、メモリ ブロック統計情報をローカル ドライブ上のテキスト ファイル(.txt)に保存し、後で参照できるようにします。

ステップ 10 (任意)[Print] をクリックして、[Print Graph] ダイアログボックスを表示します。

ステップ 11 (任意)ドロップダウン リストからグラフまたはテーブル名を選択し、[Print] をクリックして、[Print] ダイアログボックスを表示します。

ステップ 12 (任意)[OK] をクリックして、選択したメモリ ブロック統計情報を印刷します。


 

CPU

CPU 使用率を表示するには、次の手順を実行します。


ステップ 1 ASDM メイン ウィンドウで、[Monitoring] > [Properties] > [System Resources Graphs] > [CPU] の順に選択します。

ステップ 2 [Available Graphs] リストからエントリを 1 つ以上選択し、[Add] をクリックして、それらのエントリを [Selected Graphs] リストに移動します。エントリを [Selected Graphs] リストから削除するには、[Remove] をクリックします。

1 つのグラフ ウィンドウに表示する統計情報のタイプは 4 つまで選択できます。複数のグラフ ウィンドウを同時に開くことができます。

ステップ 3 既存のウィンドウ タイトルを使用するには、ドロップダウン リストからいずれかを選択します。新しいウィンドウにグラフを表示するには、[Graph Window Title] フィールドに新しいウィンドウ タイトルを入力します。

ステップ 4 [Show Graphs] をクリックして、新しいグラフ ウィンドウまたは更新したグラフ ウィンドウにシステム リソース統計情報を表示します。

ステップ 5 [Table] タブをクリックして、同じパフォーマンス統計情報を表形式で表示します。

ステップ 6 いずれかのタブ上の [View] ドロップダウン リストから、情報を更新して表示する期間を [Real-time, data every 10 sec]、[Last 10 minutes, data every 10 sec]、[Last 60 minutes, data every 1 min]、[Last 12 hours, data every 12 minutes]、または [Last 5 days, data every two hours] から選択します。

ステップ 7 (任意)[Export] をクリックして、[Export Graph Data] ダイアログボックスを表示します。エクスポートするよう選択された CPU 使用率統計情報は、すでにオンになっています。

ステップ 8 (任意)[Export] を再度クリックして、[Save] ダイアログボックスを表示します。

ステップ 9 (任意)[Save] をクリックして、CPU 使用率統計情報をローカル ドライブ上のテキスト ファイル(.txt)に保存し、後で参照できるようにします。

ステップ 10 (任意)[Print] をクリックして、[Print Graph] ダイアログボックスを表示します。

ステップ 11 (任意)ドロップダウン リストからグラフまたはテーブル名を選択し、[Print] をクリックして、[Print] ダイアログボックスを表示します。

ステップ 12 (任意)[OK] をクリックして、選択した CPU 使用率統計情報を印刷します。


 

メモリ

メモリ使用率を表示するには、次の手順を実行します。


ステップ 1 ASDM メイン ウィンドウで、[Monitoring] > [Properties] > [System Resources Graphs] > [Blocks] の順に選択します。

ステップ 2 [Available Graphs] リストからエントリを 1 つ以上選択し、[Add] をクリックして、それらのエントリを [Selected Graphs] リストに移動します。エントリを [Selected Graphs] リストから削除するには、[Remove] をクリックします。使用可能なオプションは次のとおりです。

[Free Memory]:ASAの空きメモリを表示します。

[Used Memory]:ASAの使用中のメモリを表示します。

1 つのグラフ ウィンドウに表示する統計情報のタイプは 4 つまで選択できます。複数のグラフ ウィンドウを同時に開くことができます。

ステップ 3 既存のウィンドウ タイトルを使用するには、ドロップダウン リストからいずれかを選択します。新しいウィンドウにグラフを表示するには、[Graph Window Title] フィールドに新しいウィンドウ タイトルを入力します。

ステップ 4 [Show Graphs] をクリックして、新しいグラフ ウィンドウまたは更新したグラフ ウィンドウにシステム リソース統計情報を表示します。

ステップ 5 [Table] タブをクリックして、同じパフォーマンス統計情報を表形式で表示します。

ステップ 6 いずれかのタブ上の [View] ドロップダウン リストから、情報を更新して表示する期間を [Real-time, data every 10 sec]、[Last 10 minutes, data every 10 sec]、[Last 60 minutes, data every 1 min]、[Last 12 hours, data every 12 minutes]、または [Last 5 days, data every two hours] から選択します。

ステップ 7 (任意)[Export] をクリックして、[Export Graph Data] ダイアログボックスを表示します。エクスポートするよう選択されたメモリ使用率統計情報は、すでにオンになっています。

ステップ 8 (任意)[Export] を再度クリックして、[Save] ダイアログボックスを表示します。

ステップ 9 (任意)[Save] をクリックして、メモリ使用率統計情報をローカル ドライブ上のテキスト ファイル(.txt)に保存し、後で参照できるようにします。

ステップ 10 (任意)[Print] をクリックして、[Print Graph] ダイアログボックスを表示します。

ステップ 11 (任意)ドロップダウン リストからグラフまたはテーブル名を選択し、[Print] をクリックして、[Print] ダイアログボックスを表示します。

ステップ 12 (任意)[OK] をクリックして、選択したメモリ使用率統計情報を印刷します。


 

接続のモニタリング

現在の接続を表形式で表示するには、ASDM メイン ウィンドウで、[Monitoring] > [Properties] > [Connections] の順に選択します。各接続は、次のパラメータにより識別されます。

プロトコル

送信元:

セキュリティ ID

セキュリティ名

IP アドレス

ポート

宛先:

セキュリティ ID

セキュリティ名

IP アドレス

ポート

最後にパケットが送信または受信されてからのアイドル時間

その接続で送信および受信されたトラフィックの量

プロセスごとの CPU 使用率のモニタリング

CPU で実行されているプロセスをモニタできます。特定のプロセスで使用される CPU の使用率に関する情報を取得できます。CPU 使用率の統計情報は降順で並べられ、使用率の最も高いプロセスが先頭に表示されます。また、プロセスごとの CPU に対する負荷に関する情報(記録時間の 5 秒前、1 分前、および 5 分前の情報)も含まれています。この情報は 5 秒おきに自動的に更新され、リアルタイムの統計情報が表示されます。ASDM では、30 秒おきに更新されます。

CPU 使用率をプロセスごとに表示するには、次の手順を実行します。


ステップ 1 ASDM メイン ウィンドウで、[Monitoring] > [Properties] > [Per-Process CPU Usage] の順に選択します。

ステップ 2 画面の自動リフレッシュを停止するには、[Stop auto-refresh] をクリックします。

ステップ 3 画面上の情報をローカルのテキスト ファイルに保存するには、[Save log to local file] をクリックします。

[Save] ダイアログボックスが表示されます。

ステップ 4 テキスト ファイルの名前を入力し、[Save] をクリックします。

CPU 使用率の範囲に応じてプロセスを色分けするには、[Configure CPU usage] をクリックします。

[Color Settings] ダイアログボックスが表示されます。

ステップ 5 範囲のオプション(49% 以下、50 ~ 79%、および 80% 以上)の中からいずれかを選択します。

ステップ 6 前景または背景のセルをクリックして [Pick a Color] ダイアログボックスを表示し、指定した範囲の前景色および背景色を選択します。

ステップ 7 [Swatches]、[HSB]、または [RGB] のいずれかのタブをクリックして、カラー パレットを選択します。 完了したら、[OK] をクリックします。

ステップ 8 [OK] をクリックすると、色分けされたエントリが表示されます。

ステップ 9 [Refresh] をクリックすると、いつでも手動でデータをリフレッシュできます。