Cisco ASA 5500 シリーズ コマンド リファレンス ソフトウェア バージョン 8.3(2)
backup interface コマンド~ browse-networks コマンド
backup interface コマンド~ browse-networks コマンド
発行日;2012/05/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 27MB) | フィードバック

目次

backup interface コマンド~ browse-networks コマンド

backup interface

backup-servers

banner

banner(グループ ポリシー)

blocks

boot

border style

browse-networks

backup interface コマンド~ browse-networks コマンド

backup interface

ASA 5505 適応型セキュリティ アプライアンスなどスイッチ内蔵モデルの場合は、インターフェイス コンフィギュレーション モードで backup interface コマンドを使用して、たとえば ISP へのバックアップ インターフェイスとして、VLAN インターフェイスを指定できます。このコマンドは、インターフェイス コンフィギュレーション モードで VLAN インターフェイスに対してのみ入力できます。このコマンドは、プライマリ インターフェイス経由のデフォルト ルートがダウンしているのでなければ、指定されたバックアップ インターフェイスのすべての通過トラフィックをブロックします。通常の運用に戻すには、 no backup interface コマンドを使用します。

backup interface vlan number

no backup interface vlan number

 
構文の説明

vlan number

バックアップ インターフェイスの VLAN ID を指定します。

 
デフォルト

デフォルトでは、 backup interface コマンドはディセーブルです。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
トランスペアレント
シングル
マルチ
コンテキスト
システム

インターフェイス コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.2(1)

このコマンドが追加されました。

7.2(2)

Security Plus ライセンスで、通常のトラフィックについて 3 個、バックアップ インターフェイスについて 1 個、フェールオーバーについて 1 個という VLAN インターフェイスの個数制限がなくなりました。他の制限なしで、20 個までのインターフェイスを設定できるようになりました。したがって、3 個を超えるインターフェイスをイネーブルにするための backup interface コマンドは不要です。

 
使用上のガイドライン

backup interface コマンドを使用して Easy VPN を設定してあり、バックアップ インターフェイスがプライマリになる場合、適応型セキュリティ アプライアンスでは、VPN ルールをその新しいプライマリ インターフェイスに移動します。バックアップ インターフェイスの状態を表示する場合は、 show interface コマンドを参照してください。

必ずプライマリ インターフェイスとバックアップ インターフェイスの両方にデフォルト ルートを設定して、プライマリが故障したときにバックアップ インターフェイスを使用できるようにしてください。たとえば、低いアドミニストレーティブ ディスタンスを設定したプライマリ インターフェイス用のルート 1 つと、高いディスタンスを設定したバックアップ インターフェイス用のルート 1 つの、2 つのデフォルト ルートを設定できます。DHCP サーバから取得したデフォルト ルートのアドミニストレーティブ ディスタンスを上書きする場合は、 dhcp client route distance コマンドを参照してください。デュアル ISP サポートを設定する場合の詳細については、 sla monitor コマンドおよび track rtr コマンドを参照してください。

management-only コマンドがインターフェイスにすでに設定されている場合は、バックアップ インターフェイスを設定できません。

次に、4 つの VLAN インターフェイスを設定する例を示します。backup-isp インターフェイスでは、プライマリ インターフェイスがダウンしている場合にだけ、通過トラフィックが許可されます。 route コマンドは、バックアップ ルートのアドミニストレーティブ ディスタンスを小さくして、プライマリ インターフェイスおよびバックアップ インターフェイスのデフォルト ルートを作成します。

hostname(config)# interface vlan 100
hostname(config-if)# nameif outside
hostname(config-if)# security-level 0
hostname(config-if)# ip address 10.1.1.1 255.255.255.0
hostname(config-if)# backup interface vlan 400
hostname(config-if)# no shutdown
 
hostname(config-if)# interface vlan 200
hostname(config-if)# nameif inside
hostname(config-if)# security-level 100
hostname(config-if)# ip address 10.2.1.1 255.255.255.0
hostname(config-if)# no shutdown
 
hostname(config-if)# interface vlan 300
hostname(config-if)# nameif dmz
hostname(config-if)# security-level 50
hostname(config-if)# ip address 10.3.1.1 255.255.255.0
hostname(config-if)# no shutdown
 
hostname(config-if)# interface vlan 400
hostname(config-if)# nameif backup-isp
hostname(config-if)# security-level 50
hostname(config-if)# ip address 10.1.2.1 255.255.255.0
hostname(config-if)# no shutdown
 
hostname(config)# interface ethernet 0/0
hostname(config-if)# switchport access vlan 100
hostname(config-if)# no shutdown
 
hostname(config-if)# interface ethernet 0/1
hostname(config-if)# switchport access vlan 200
hostname(config-if)# no shutdown
 
hostname(config-if)# interface ethernet 0/2
hostname(config-if)# switchport access vlan 300
hostname(config-if)# no shutdown
 
hostname(config-if)# interface ethernet 0/3
hostname(config-if)# switchport access vlan 400
hostname(config-if)# no shutdown
 
hostname(config-if)# route outside 0 0 10.1.1.2 1
hostname(config)# route backup-isp 0 0 10.1.2.2 2
 

 
関連コマンド

コマンド
説明

forward interface

インターフェイスによる別のインターフェイスのトラフィックの開始を制限します。

interface vlan

VLAN インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

dhcp client route distance

DHCP サーバから取得したデフォルト ルートのアドミニストレーティブ ディスタンスを上書きします。

sla monitor

スタティック ルート トラッキングのための SLA モニタリング動作を作成します。

track rtr

SLA モニタリング動作の状態を追跡します。

backup-servers

バックアップ サーバを設定するには、グループ ポリシー コンフィギュレーション モードで backup-servers コマンドを使用します。バックアップ サーバを削除するには、このコマンドの no 形式を使用します。実行コンフィギュレーションから backup-servers アトリビュートを削除するには、引数なしで、このコマンドの no 形式を使用します。これにより、別のグループ ポリシーから backup-servers の値を継承できるようになります。

IPSec バックアップ サーバを使用すると、プライマリ適応型セキュリティ アプライアンスが利用できない場合に VPN クライアントが中央サイトに接続できます。バックアップ サーバを設定した場合、適応型セキュリティ アプライアンスでは、IPSec トンネルが確立された時点でサーバ リストをクライアントに配信します。

backup-servers { server1 server2 . . . . server10 | clear-client-config | keep-client-config}

no backup-servers [ server1 server2 . . . . server10 | clear-client-config | keep-client-config ]

 
構文の説明

clear-client-config

クライアントでバックアップ サーバを使用しないことを指定します。適応型セキュリティ アプライアンスは、ヌル サーバ リストを配信します。

keep-client-config

適応型セキュリティ アプライアンスでバックアップ サーバ情報をクライアントに配信しないことを指定します。クライアントでは、独自のバックアップ サーバ リストが設定されていれば、そのリストを使用します。

server1 server 2 .... server10

プライマリ 適応型セキュリティ アプライアンスを利用できない場合に VPN クライアントで使用する、スペースで区切られ、プライオリティで順序付けされたサーバのリストを規定します。IP アドレスまたはホスト名でサーバを識別します。このリストは、長さは 500 文字までですが、格納できるエントリは 10 個だけです。

 
デフォルト

クライアントまたはプライマリ適応型セキュリティ アプライアンスのいずれかでバックアップ サーバを設定しないうちは、バックアップ サーバは存在しません。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
トランスペアレント
シングル
マルチ
コンテキスト
システム

グループ ポリシー コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

クライアントまたはプライマリ適応型セキュリティ アプライアンスのいずれかでバックアップ サーバを設定します。バックアップ サーバを適応型セキュリティ アプライアンスに設定した場合は、バックアップ サーバ ポリシーがグループ内のクライアントに配信されて、クライアントにバックアップ サーバ リストが設定されていれば、そのリストが置換されます。


) ホスト名を使用する場合は、プライマリ DNS サーバおよび WINS サーバとは別のネットワークに、DNS サーバおよび WINS サーバをバックアップすることを推奨します。そのように構成していないと、ハードウェア クライアントの背後にあるクライアントが DHCP を介してハードウェア クライアントから DNS 情報および WINS 情報を取得しており、プライマリ サーバへの接続が失われた場合に、バックアップ サーバの DNS 情報および WINS 情報がプライマリ サーバと異なっていれば、DHCP リース期間が切れるまで該当するクライアントを更新できません。さらに、ホスト名を使用しているときに、DNS サーバを利用できない場合は、大幅な遅延が発生するおそれがあります。


次の例では、「FirstGroup」というグループ ポリシーに、IP アドレス 10.10.10.1 および 192.168.10.14 のバックアップ サーバを設定する方法を示します。

hostname(config)# group-policy FirstGroup attributes
hostname(config-group-policy)# backup-servers 10.10.10.1 192.168.10.14

 

banner

ASDM、セッション、ログイン、または Message-of-The-Day バナーを設定するには、グローバル コンフィギュレーション モードで banner コマンドを使用します。 no banner コマンドでは、指定されている banner キーワード( exec login 、または motd )からすべての行が削除されます。

banner { asdm | exec | login | motd text }

[no] banner { asdm | exec | login | motd [ text ] }

 
構文の説明

asdm

正常に ASDM にログインした後でバナーを表示するようにシステムを設定します。ログインを続行して完了するのか、切断するのかを指定するプロンプトがユーザに出されます。このオプションを使用すると、文書化されたポリシーの条件に同意してから接続することをユーザに要求できます。

exec

イネーブル プロンプトを表示する前にバナーを表示するよう、システムを設定します。

login

Telnet を使用して適応型セキュリティ アプライアンスにアクセスする場合に、パスワード ログイン プロンプトを出す前にバナーを表示するよう、システムを設定します。

motd

最初に接続したときに、Message-of-The-Day バナーを表示するよう、システムを設定します。

text

表示するメッセージ テキストの行。

 
デフォルト

デフォルトはバナーなしです。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
トランスペアレント
シングル
マルチ
コンテキスト
システム

グローバル コンフィギュレーション

 
コマンド履歴

リリース
変更内容

7.2(4)/8.0(3)

asdm キーワードが追加されました。

 
使用上のガイドライン

banner コマンドは、指定したキーワードに対して表示するバナーを設定します。 text 文字列は、先頭の空白スペース(スペース)を含み、これに続く行の末尾(復帰または Line Feed(LF; 改行))までのすべての文字で構成されます。テキストに含まれているスペースは保持されます。ただし、CLI からはタブを入力できません。

最初にバナーをクリアしていない場合、後続の text エントリは、既存のバナーの末尾に追加されます。


) トークン $(domain) および $(hostname) は、適応型セキュリティ アプライアンスのホスト名およびドメイン名で置換されます。コンテキスト コンフィギュレーションで $(system) トークンを入力した場合、そのコンテキストでは、システム コンフィギュレーションで設定したバナーが使用されます。


複数行のバナーの各行を操作するには、追加するバナーの行ごとに新しい banner コマンドを入力します。その場合、各行は既存のバナーの末尾に追加されます。バナーの長さには、メモリおよびフラッシュに起因する制限以外の制限はありません。

Telnet または SSH を介して適応型セキュリティ アプライアンスにアクセスしている場合に、バナー メッセージを処理するために十分な使用可能なシステム メモリがないか、TCP 書き込みエラーが発生すると、セッションが終了します。SSH を介した適応型セキュリティ アプライアンスへのアクセスをサポートするのは、exec バナーおよび motd バナーだけです。login バナーでは SSH をサポートしません。

バナーを置換する場合は、新しい行を追加する前に no banner コマンドを使用します。

指定した banner キーワードのすべての行を削除するには、no banner { exec | login | motd } コマンドを使用します。

no banner コマンドでは、テキスト文字列の選択的削除を行いません。したがって、no banner コマンドの末尾に入力した text はいずれも無視されます。

次の例では、 asdm バナー、 exec バナー、 login バナー、および motd バナーを設定する方法を示します。

hostname(config)# banner asdm You successfully logged in to ASDM
hostname(config)# banner motd Think on These Things
hostname(config)# banner exec Enter your password carefully
hostname(config)# banner login Enter your password to log in
hostname(config)# show running-config banner
asdm:
You successfully logged in to ASDM
 
exec:
Enter your password carefully
 
login:
Enter your password to log in
 
motd:
Think on These Things
 

次の例では、 motd バナーに別の行を追加する方法を示します。

hostname(config)# banner motd and Enjoy Today
hostname(config)# show running-config banner motd
Think on These Things and Enjoy Today

 
関連コマンド

コマンド
説明

clear configure banner

すべてのバナーを削除します。

show running-config banner

すべてのバナーを表示します。

banner(グループ ポリシー)

リモート クライアントが接続したときに、そのクライアントにバナー(ウェルカム テキスト)を表示するには、グループ ポリシー コンフィギュレーション モードで banner コマンドを使用します。バナーを削除するには、このコマンドの no 形式を使用します。このオプションを使用すると、他のグループ ポリシーからバナーを継承できます。バナーを継承しないようにするには、 banner none コマンドを使用します。

banner { value banner_string | none}

no banner


) VPN グループ ポリシーに複数のバナーを設定した後で、いずれかのバナーを削除すると、すべてのバナーが削除されます。


 
構文の説明

none

ヌル値のバナーが設定されるため、バナーは拒否されます。デフォルトまたは指定したグループ ポリシーからバナーが継承されません。

value banner_string

バナー テキストを指定します。最大文字列サイズは 500 文字です。復帰を挿入するには「\n」シーケンスを使用します。

 
デフォルト

デフォルト バナーはありません。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
トランスペアレント
シングル
マルチ
コンテキスト
システム

グループ ポリシー コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

IPsec VPN クライアントでは、バナーでフル HTML に対応しています。一方、クライアントレス ポータルおよび AnyConnect クライアントでは、部分 HTML に対応しています。リモート ユーザにバナーを必ず正しく表示させるには、次のガイドラインに従ってください。

IPsec クライアント ユーザに対しては、/n タグを使用します。

AnyConnect クライアント ユーザに対しては、<BR> タグを使用します。

クライアントレス ユーザに対しては、<BR> タグを使用します。

次の例では、「FirstGroup」というグループ ポリシーのバナーを作成する方法を示します。

hostname(config)# group-policy FirstGroup attributes
hostname(config-group-policy)# banner value Welcome to Cisco Systems 7.0.

blocks

ブロック診断( show blocks コマンドで表示)に追加のメモリを割り当てるには、特権 EXEC モードで blocks コマンドを使用します。値をデフォルトに戻すには、このコマンドの no 形式を使用します。割り当てるメモリの量は最大 150 KB ですが、空きメモリの 50 % を超えることはできません。オプションで、メモリ サイズを手動で指定できます。

blocks queue history enable [ memory_size ]

no blocks queue history enable [ memory_size ]

 
構文の説明

memory_size

(任意)ダイナミック値を適用する代わりに、ブロック診断用のメモリ サイズをバイト単位で設定します。この値が空きメモリを超えている場合は、エラー メッセージが表示され、値は受け入れられません。この値が空きメモリの 50 % を超えている場合は、警告メッセージが表示されますが、値は受け入れられます。

 
デフォルト

ブロック診断を追跡するために割り当てられるデフォルトのメモリは 2136 バイトです。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
トランスペアレント
シングル
マルチ
コンテキスト
システム

特権 EXEC

--

 
コマンド履歴

リリース
変更内容

7.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

現在割り当てられているメモリを表示するには、 show blocks queue history コマンドを入力します。

適応型セキュリティ アプライアンスをリロードすると、メモリ割り当てはデフォルトに戻ります。

次に、ブロック診断用のメモリ サイズを拡大する例を示します。

hostname# blocks queue history enable
 

次に、メモリ サイズを 3000 バイトに拡大する例を示します。

hostname# blocks queue history enable 3000
 

次に、メモリ サイズを 3000 バイトに拡大しようとしたときに、この値が空きメモリを超えている例を示します。

hostname# blocks queue history enable 3000
ERROR: memory size exceeds current free memory
 

次に、メモリ サイズを 3000 バイトに拡大する一方で、この値が空きメモリの 50 % を超えている例を示します。

hostname# blocks queue history enable 3000
WARNING: memory size exceeds 50% of current free memory
 

 
関連コマンド

コマンド
説明

clear blocks

システム バッファの統計情報をクリアします。

show blocks

システム バッファの使用状況を表示します。

boot

次回のリロードでシステムが使用するイメージおよび起動時にシステムが使用するコンフィギュレーション ファイルを指定するには、グローバル コンフィギュレーション モードで boot コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

boot { config | system } url

no boot { config | system } url

 
構文の説明

config

システムのロード時に使用されるコンフィギュレーション ファイルを指定します。

system

システムのロード時に使用されるイメージ ファイルを指定します。

url

イメージまたはコンフィギュレーションの場所を設定します。マルチ コンテキスト モードでは、管理コンテキストからすべてのリモート URL にアクセスできる必要があります。次の URL 構文を参照してください。

disk0:/ [ path / ] filename

ASA 5500 シリーズ適応型セキュリティ アプライアンスの場合、この URL は内部フラッシュ メモリを指します。 disk0 ではなく flash を使用することもできます。これらはエイリアスになっています。

disk1:/ [ path / ] filename

ASA 5500 シリーズ適応型セキュリティ アプライアンスの場合、この URL は外部フラッシュ メモリ カードを指します。

flash:/ [ path / ] filename

この URL は内部フラッシュ メモリを示します。

tftp:// [ user [ : password ] @ ] server [: port ] / [ path / ] filename [ ;int= interface_name ]

サーバ アドレスへのルートを上書きする場合は、インターフェイス名を指定します。

このオプションは、ASA 5500 シリーズ適応型セキュリティ アプライアンスの boot system コマンドだけで使用可能です。 boot config コマンドでは、スタートアップ コンフィギュレーションがフラッシュ メモリに格納されている必要があります。

設定できる boot system tftp: コマンドは 1 つだけであり、このコマンドが最初に設定されている必要があります。

 
デフォルト

boot config コマンドを指定しなかった場合、スタートアップ コンフィギュレーションは非表示の場所に保存され、 show startup-config コマンドや copy startup-config コマンドなど、そのコンフィギュレーションを利用するコマンドだけで使用されます。

boot system コマンドにはデフォルトはありません。場所を指定しなかった場合、適応型セキュリティ アプライアンスでは、起動する最初の有効なイメージを見つけるために、内部フラッシュ メモリだけを検索します。有効なイメージが見つからない場合、システム イメージはロードされず、ROMMON またはモニタ モードの割り込みまで、適応型セキュリティ アプライアンスの起動がループされます。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
トランスペアレント
シングル
マルチ
コンテキスト
システム

グローバル コンフィギュレーション

--

 
コマンド履歴

リリース
変更内容

7.0(1)

このコマンドが追加されました。

 
使用上のガイドライン

write memory コマンドを使用してこのコマンドをスタートアップ コンフィギュレーションに保存すると、設定は BOOT 環境変数および CONFIG_FILE 環境変数にも保存されます。この設定は、適応型セキュリティ アプライアンスが再起動するときに、スタートアップ コンフィギュレーションおよび起動するソフトウェア イメージを決めるために使用されます。

boot system コマンド エントリは 4 個まで入力して、起動する別々のイメージを順に指定できます。適応型セキュリティ アプライアンスでは、見つかった最初の有効なイメージから起動します。

現在の実行コンフィギュレーションと異なる新しい場所にあるスタートアップ コンフィギュレーション ファイルを使用する場合は、実行コンフィギュレーションを保存した後でスタートアップ コンフィギュレーション ファイルを必ずその新しい場所にコピーしてください。コピーしておかないと、実行コンフィギュレーションを保存するときに、実行コンフィギュレーションで新しいスタートアップ コンフィギュレーションが上書きされます。


ヒント ASDM イメージ ファイルは、asdm image コマンドで指定します。

次に、起動時に configuration.txt というコンフィギュレーション ファイルをロードするよう、適応型セキュリティ アプライアンスに指定する例を示します。

hostname(config)# boot config disk0:/configuration.txt

 
関連コマンド

コマンド
説明

asdm image

ASDM ソフトウェア イメージを指定します。

show bootvar

ブート ファイル環境変数およびコンフィギュレーション環境変数を表示します。

border style

認証された WebVPN ユーザに表示される WebVPN ホームページの境界線をカスタマイズするには、カスタマイゼーション コンフィギュレーション モードで border style コマンドを使用します。コンフィギュレーションからコマンドを削除して、値が継承されるようにするには、このコマンドの no 形式を使用します。

border style value

no border style value

 
構文の説明

value

Cascading Style Sheet(CSS)パラメータ(最大 256 文字)。

 
デフォルト

境界線のデフォルト スタイルは background-color:#669999;color:white です。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
トランスペアレント
シングル
マルチ
コンテキスト
システム

カスタマイゼーション コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.1(1)

このコマンドが追加されました。

 
使用上のガイドライン

style オプションは有効な Cascading Style Sheet(CSS)パラメータとして表されます。これらのパラメータについては、このマニュアルでは説明しません。CSS パラメータの詳細については、World Wide Web Consortium(W3C)の Web サイト(www.w3.org)の CSS 仕様を参照してください。『CSS 2.1 Specification』の「Appendix F」には、CSS パラメータの使いやすいリストがあります。この付録は www.w3.org/TR/CSS21/propidx.html で入手できます。

ここでは、WebVPN ページに対する変更で最もよく行われるページの配色を変更するためのヒントを紹介します。

カンマ区切りの RGB 値、HTML の色値、または色の名前(HTML で認識される場合)を使用できます。

RGB 形式は 0,0,0 で、各色(赤、緑、青)を 0 ~ 255 の範囲の 10 進値で入力します。このカンマ区切りのエントリは、他の 2 色と組み合わせる各色の明度レベルを示します。

HTML 形式は #000000 で、16 進形式の 6 桁の数値です。先頭と 2 番めは赤を、3 番めと 4 番めは緑を、5 番めと 6 番めは青を表しています。


) WebVPN ページを簡単にカスタマイズするには、ASDM を使用することを推奨します。ASDM には、色見本やプレビュー機能など、スタイルの要素を設定するための便利な機能があります。


次に、境界線の背景色を RGB カラー #66FFFF(緑の一種)にカスタマイズする例を示します。

hostname(config)# webvpn
hostname(config-webvpn)# customization cisco
hostname(config-webvpn-custom)# border style background-color:66FFFF

 
関連コマンド

コマンド
説明

application-access

WebVPN ホームページの [Application Access] ボックスをカスタマイズします。

browse-networks

WebVPN ホームページの [Browse Networks] ボックスをカスタマイズします。

web-bookmarks

WebVPN ホームページの [Web Bookmarks] タイトルまたはリンクをカスタマイズします。

file-bookmarks

WebVPN ホームページの [File Bookmarks] タイトルまたはリンクをカスタマイズします。

browse-networks

認証された WebVPN ユーザに表示される WebVPN ホームページの [Browse Networks] ボックスをカスタマイズするには、webvpn カスタマイゼーション コンフィギュレーション モードで browse-networks コマンドを使用します。コンフィギュレーションからコマンドを削除して、値が継承されるようにするには、このコマンドの no 形式を使用します。

browse-networks { title | message | dropdown } { text | style } value

no browse-networks [{ title | message | dropdown } { text | style } value ]

 
構文の説明

dropdown

ドロップダウン リストを変更することを指定します。

message

タイトルの下に表示されるメッセージを変更することを指定します。

style

スタイルを変更することを指定します。

text

テキストを変更することを指定します。

title

タイトルを変更することを指定します。

value

実際に表示するテキスト(最大 256 文字)、または Cascading Style Sheet(CSS)パラメータ(最大 256 文字)です。

 
デフォルト

デフォルトのタイトル テキストは「Browse Networks」です。

デフォルトのタイトル スタイルは、次のとおりです。

background-color:#99CCCC;color:black;font-weight:bold;text-transform:uppercase

デフォルトのメッセージ テキストは「Enter Network Path」です。

デフォルトのメッセージ スタイルは、次のとおりです。

background-color:#99CCCC;color:maroon;font-size:smaller.

デフォルトのドロップダウン テキストは「File Folder Bookmarks」です。

デフォルトのドロップダウン スタイルは、次のとおりです。

border:1px solid black;font-weight:bold;color:black;font-size:80%

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
トランスペアレント
シングル
マルチ
コンテキスト
システム

webvpn カスタマイゼーション コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.1(1)

このコマンドが追加されました。

 
使用上のガイドライン

style オプションは有効な Cascading Style Sheet(CSS)パラメータとして表されます。これらのパラメータについては、このマニュアルでは説明しません。CSS パラメータの詳細については、World Wide Web Consortium(W3C)の Web サイト(www.w3.org)の CSS 仕様を参照してください。『CSS 2.1 Specification』の「Appendix F」には、CSS パラメータの使いやすいリストがあります。この付録は www.w3.org/TR/CSS21/propidx.html で入手できます。

ここでは、WebVPN ページに対する変更で最もよく行われるページの配色を変更するためのヒントを紹介します。

カンマ区切りの RGB 値、HTML の色値、または色の名前(HTML で認識される場合)を使用できます。

RGB 形式は 0,0,0 で、各色(赤、緑、青)を 0 ~ 255 の範囲の 10 進値で入力します。このカンマ区切りのエントリは、他の 2 色と組み合わせる各色の明度レベルを示します。

HTML 形式は #000000 で、16 進形式の 6 桁の数値です。先頭と 2 番めは赤を、3 番めと 4 番めは緑を、5 番めと 6 番めは青を表しています。


) WebVPN ページを簡単にカスタマイズするには、ASDM を使用することを推奨します。ASDM には、色見本やプレビュー機能など、スタイルの要素を設定するための便利な機能があります。


次に、タイトルを「Browse Corporate Networks」に変更し、このスタイル内のテキストを青に変更する例を示します。

F1-asa1(config)# webvpn
F1-asa1(config-webvpn)# customization cisco
F1-asa1(config-webvpn-custom)# browse-networks title text Browse Corporate Networks
F1-asa1(config-webvpn-custom)# browse-networks title style color:blue

 
関連コマンド

コマンド
説明

application-access

WebVPN ホームページの [Application Access] ボックスをカスタマイズします。

file-bookmarks

WebVPN ホームページの [File Bookmarks] タイトルまたはリンクをカスタマイズします。

web-applications

WebVPN ホームページの [Web Application] ボックスをカスタマイズします。

web-bookmarks

WebVPN ホームページの [Web Bookmarks] タイトルまたはリンクをカスタマイズします。