Cisco ASA 5580 適応型セキュリティ アプライアン ス コマンド リファレンス
backup interface コマンド~ browse-networks コマンド
backup interface コマンド~ browse-networks コマンド
発行日;2012/02/24 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 24MB) | フィードバック

目次

backup interface コマンド~ browse-networks コマンド

backup interface

backup-servers

banner

banner(グループ ポリシー)

blocks

boot

border style

browse-networks

backup interface コマンド~ browse-networks コマンド

backup interface

組み込みスイッチを持つモデル(ASA 5505 適応型セキュリティ アプライアンスなど)では、インターフェイス コンフィギュレーション モードで backup interface コマンドを使用して、VLAN インターフェイスを ISP などのバックアップ用インターフェイスに指定します。このコマンドを入力できるのは、VLAN インターフェイスのインターフェイス コンフィギュレーション モードだけです。このコマンドは、プライマリ インターフェイスを通るデフォルトのルートがダウンしない限り、バックアップに指定したインターフェイスを通過しようとするトラフィックをすべてブロックします。通常の状態に戻すには、 no backup interface コマンドを使用します。

backup interface vlan number

no backup interface vlan number

 
シンタックスの説明

vlan number

バックアップ インターフェイスの VLAN の ID を指定します。

 
デフォルト

デフォルトでは、 backup interface コマンドはディセーブルになっています。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

インターフェイス コンフィギュレーション

--

--

--

 
コマンドの履歴

リリース
変更内容

7.2(1)

このコマンドが導入されました。

7.2(2)

Security Plus ライセンスでは、VLAN インターフェイスの数が通常のトラフィック用には 3 つ、バックアップ インターフェイス用には 1 つ、フェールオーバー用には 1 つと制限されていました。この制限がなくなり、最大 20 のインターフェイスを設定できるようになりました(これ以外の制限はありません)。したがって、 backup interface コマンドは、4 つ以上のインターフェイスをイネーブルにするためには不要です。

 
使用上のガイドライン

backup interface コマンドで Easy VPN を設定すると、バックアップ インターフェイスがプライマリになった場合に、セキュリティ アプライアンスは VPN 規則を新しいプライマリ インターフェイスに移動します。バックアップ インターフェイスの状態を表示するには、 show interface コマンドを参照してください。

プライマリ インターフェイスがダウンした場合にバックアップ インターフェイスを使用できるように、必ずプライマリとバックアップの両方のインターフェイスにデフォルト ルートを設定してください。たとえば、プライマリ インターフェイス用に管理ディスタンスの低いルート、バックアップ インターフェイス用に管理ディスタンスの高いルートの 2 つのデフォルト ルートを設定します。DHCP サーバから取得したデフォルト ルートの管理ディスタンスを上書きする方法については、 dhcp client route distance コマンドを参照してください。ISP のデュアル サポートの設定について詳しくは、 sla monitor コマンドと track rtr コマンドを参照してください。

management-only コマンドを設定しているインターフェイスをバックアップ インターフェイスに設定することはできません。

次の例では、4 つの LAN インターフェイスを設定しています。backup-ip インターフェイスでは、プライマリ インターフェイスがダウンしている場合に限り、通過トラフィックを許可します。 route コマンドは、プライマリ インターフェイスおよびバックアップ インターフェイスのデフォルト ルートを作成しています。バックアップ ルートに低い管理ディスタンスが設定されています。

hostname(config)# interface vlan 100
hostname(config-if)# nameif outside
hostname(config-if)# security-level 0
hostname(config-if)# ip address 10.1.1.1 255.255.255.0
hostname(config-if)# backup interface vlan 400
hostname(config-if)# no shutdown
 
hostname(config-if)# interface vlan 200
hostname(config-if)# nameif inside
hostname(config-if)# security-level 100
hostname(config-if)# ip address 10.2.1.1 255.255.255.0
hostname(config-if)# no shutdown
 
hostname(config-if)# interface vlan 300
hostname(config-if)# nameif dmz
hostname(config-if)# security-level 50
hostname(config-if)# ip address 10.3.1.1 255.255.255.0
hostname(config-if)# no shutdown
 
hostname(config-if)# interface vlan 400
hostname(config-if)# nameif backup-isp
hostname(config-if)# security-level 50
hostname(config-if)# ip address 10.1.2.1 255.255.255.0
hostname(config-if)# no shutdown
 
hostname(config)# interface ethernet 0/0
hostname(config-if)# switchport access vlan 100
hostname(config-if)# no shutdown
 
hostname(config-if)# interface ethernet 0/1
hostname(config-if)# switchport access vlan 200
hostname(config-if)# no shutdown
 
hostname(config-if)# interface ethernet 0/2
hostname(config-if)# switchport access vlan 300
hostname(config-if)# no shutdown
 
hostname(config-if)# interface ethernet 0/3
hostname(config-if)# switchport access vlan 400
hostname(config-if)# no shutdown
 
hostname(config-if)# route outside 0 0 10.1.1.2 1
hostname(config)# route backup-isp 0 0 10.1.2.2 2
 

 
関連コマンド

コマンド
説明

forward interface

あるインターフェイスで、別のインターフェイスへのトラフィックを開始できないようにします。

interface vlan

VLAN インターフェイスを作成し、インターフェイス コンフィギュレーション モードに入ります。

dhcp client route distance

DHCP サーバから取得したデフォルト ルートの管理ディスタンスを上書きします。

sla monitor

スタティック ルートのトラッキングの SLA 監視オペレーションを定義します。

track rtr

SLA 監視オペレーションの状況をトラッキングします。

backup-servers

バックアップ サーバを設定するには、グループ ポリシー コンフィギュレーション モードで backup-servers コマンドを使用します。バックアップ サーバを削除するには、このコマンドの no 形式を使用します。backup-servers アトリビュートを実行コンフィギュレーションから削除するには、引数を付けずにこのコマンドの no 形式を使用します。これで、backup-servers の値を別のグループ ポリシーから継承できます。

IPSec バックアップ サーバにより、VPN クライアントは、プライマリ セキュリティ アプライアンスが利用できない場合に中央のサイトに接続できます。バックアップ サーバを設定すると、IPSec トンネルが確立されるときにセキュリティ アプライアンスがクライアントにサーバ リストをプッシュします。

backup-servers { server1 server2 . . . . server10 | clear-client-config | keep-client-config}

no backup-servers [ server1 server2 . . . . server10 | clear-client-config | keep-client-config ]

 
シンタックスの説明

clear-client-config

クライアントがバックアップ サーバを使用しないように指定します。セキュリティ アプライアンスは、ヌルのサーバ リストをプッシュします。

keep-client-config

セキュリティ アプライアンスがバックアップ サーバ情報をクライアントに送信しないように指定します。クライアントは、独自のバックアップ サーバ リストを使用します(設定されている場合)。

server1 server 2 .... server10

プライマリ セキュリティ アプライアンスが利用できない場合に VPN クライアントが使用するサーバのリストを入力します。各サーバをスペースで区切って優先度の高い順に並べます。サーバは、IP アドレスまたはホスト名で指定します。リストには 500 文字入力できますが、10 個のエントリしか含めることができません。

 
デフォルト

クライアントまたはプライマリ セキュリティ アプライアンス上にバックアップ サーバを設定しない限り、バックアップ サーバは存在しません。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

グループ ポリシー コンフィギュレーション

--

--

--

 
コマンドの履歴

リリース
変更内容

7.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

バックアップ サーバは、クライアントまたはプライマリ セキュリティ アプライアンス上に設定します。セキュリティ アプライアンス上にバックアップ サーバを設定すると、セキュリティ アプライアンスはバックアップ サーバ ポリシーをグループ内のクライアントにプッシュし、クライアント上にバックアップ サーバ リストが設定されている場合、そのリストを置き換えます。


) ホスト名を使用する場合は、バックアップ DNS サーバとバックアップ WINS サーバを、プライマリ DNS サーバとプライマリ WINS サーバとは別のネットワーク上に置くことをお勧めします。同一ネットワーク上に置くと、ハードウェア クライアントの背後のクライアントが DHCP を介してハードウェア クライアントから DNS 情報および WINS 情報を取得し、プライマリ サーバとの接続が失われ、バックアップ サーバに異なる DNS 情報および WINS 情報がある場合、DHCP リースが期限切れになるまでクライアントをアップデートできません。さらに、ホスト名を使用するときに DNS サーバが利用できないと、重大な遅延が発生することがあります。


次の例は、「FirstGroup」という名前のグループ ポリシーに IP アドレス 10.10.10.1 および 192.168.10.14 のバックアップ サーバを設定する方法を示したものです。

hostname(config)# group-policy FirstGroup attributes
hostname(config-group-policy)# backup-servers 10.10.10.1 192.168.10.14

 

banner

ASDM バナー、セッション バナー、ログイン バナー、または「Message-of-The-Day」バナーを設定するには、グローバル コンフィギュレーション モードで banner コマンドを使用します。指定したバナー キーワード( exec login 、または motd )のすべての行を削除するには、 no banner コマンドを使用します。

banner { asdm | exec | login | motd text }

[no] banner { asdm | exec | login | motd [ text ] }

 
シンタックスの説明

asdm

ASDM へのログインが成功した後にバナーが表示されるようシステムを設定します。ユーザに対しては、接続してログインを完了するか、接続解除するかを選択するプロンプトが表示されます。このオプションを使用することで、ユーザに対し、表示されたポリシーのさまざまな条件に同意したうえで接続することを要求できます。

exec

イネーブル プロンプトを表示する前に、バナーを表示するようにシステムを設定します。

login

ユーザが Telnet を使用してセキュリティ アプライアンスにアクセスしたときに、パスワード ログイン プロンプトを表示する前にバナーを表示するようにシステムを設定します。

motd

初めて接続したときに「Message-of-The-Day」バナーを表示するようにシステムを設定します。

text

表示するメッセージ テキスト行。

 
デフォルト

デフォルトでは、バナーは表示されません。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

7.2(4)/8.0(3)

asdm キーワードが追加されました。

 
使用上のガイドライン

banner コマンドは、指定したキーワードに対応するバナーを表示するように設定します。 text 文字列は、最初の空白文字(スペース)の後に続く、行末(復帰または改行(LF))までのすべての文字で構成されます。テキスト内にあるスペースはそのまま表示されます。ただし、CLI ではタブを入力できません。

先に既存のバナーを消去しない限り、後続の text エントリはその末尾に追加されます。


) トークン $(domain) と $(hostname) を使用すると、それぞれセキュリティ アプライアンスのドメイン名とホスト名に置き換えられます。コンテキスト コンフィギュレーションで $(system) トークンを入力すると、コンテキストはシステム コンフィギュレーションに設定されているバナーを使用します。


バナーを複数行にする場合は、追加する行ごとに banner コマンドを新しく入力します。入力した行は、既存バナーの末尾に追加されていきます。RAM およびフラッシュ メモリの容量による限界を除いて、バナーの長さに制限はありません。

Telnet または SSH でセキュリティ アプライアンスにアクセスする場合、バナー メッセージの処理に必要なシステム メモリが十分にないときや、TCP 書き込みエラーが発生したときは、セッションが閉じます。exec バナーと motd バナーだけが、SSH を介したセキュリティ アプライアンスへのアクセスをサポートしています。login バナーは SSH をサポートしていません。

バナーを置き換えるには、no banner コマンドを使用してから、新しい行を追加します。

no banner { exec | login | motd } コマンドは、指定したバナー キーワードのすべての行を削除します。

no banner コマンドでは、テキスト文字列の一部だけを削除できません。そのため、no banner コマンドの末尾に入力した text はすべて無視されます。

次の例は、 asdm exec login 、および motd の各バナーを設定する方法を示しています。

hostname(config)# banner asdm You successfully logged in to ASDM
hostname(config)# banner motd Think on These Things
hostname(config)# banner exec Enter your password carefully
hostname(config)# banner login Enter your password to log in
hostname(config)# show running-config banner
asdm:
You successfully logged in to ASDM
 
exec:
Enter your password carefully
 
login:
Enter your password to log in
 
motd:
Think on These Things
 

次の例は、 motd バナーにもう 1 行を追加する方法を示しています。

hostname(config)# banner motd and Enjoy Today
hostname(config)# show running-config banner motd
Think on These Things and Enjoy Today

 
関連コマンド

コマンド
説明

clear configure banner

すべてのバナーを削除します。

show running-config banner

すべてのバナーを表示します。

banner(グループ ポリシー)

リモート クライアントの接続時にリモート クライアント上でバナー(ウェルカム テキスト)を表示するには、グループ ポリシー コンフィギュレーション モードで banner コマンドを使用します。バナーを削除するには、このコマンドの no 形式を使用します。このオプションを使用すると、バナーを別のグループ ポリシーから継承できます。バナーを継承しないようにするには、 banner none コマンドを使用します。

banner { value banner_string | none}

no banner


) VPN グループ ポリシーで複数のバナーを設定し、いずれかのバナーを削除すると、すべてのバナーが削除されます。


 
シンタックスの説明

none

バナーにヌル値を設定して、バナーを拒否します。デフォルトのグループ ポリシーまたは指定されているグループ ポリシーからバナーを継承しないようにします。

value banner_string

バナー テキストを設定します。文字列の最大サイズは 500 文字です。復帰を挿入する場合には、「\n」シーケンスを使用します。

 
デフォルト

デフォルトのバナーはありません。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

グループ ポリシー コンフィギュレーション

--

--

--

 
コマンドの履歴

リリース
変更内容

7.0(1)

このコマンドが導入されました。

次の例は、「FirstGroup」という名前のグループ ポリシーに対してバナーを作成する方法を示しています。

hostname(config)# group-policy FirstGroup attributes
hostname(config-group-policy)# banner value Welcome to Cisco Systems 7.0.

blocks

ブロック診断( show blocks コマンドで表示)に追加のメモリを割り当てるには、特権 EXEC モードで blocks コマンドを使用します。値をデフォルトに戻すには、このコマンドの no 形式を使用します。割り当てられるメモリ量は最大 150 KB ですが、空きメモリの 50% を超えることはありません。オプションで、メモリ サイズを手動で指定できます。

blocks queue history enable [ memory_size ]

no blocks queue history enable [ memory_size ]

 
シンタックスの説明

memory_size

(オプション)ダイナミックな値を適用するのではなく、ブロック診断用のメモリ サイズをバイト単位で設定します。この値が空きメモリよりも大きい場合は、エラー メッセージが表示され、値は受け入れられません。この値が空きメモリの 50% を超える場合は、警告メッセージが表示されますが、値は受け入れられます。

 
デフォルト

ブロック診断の追跡に割り当てられるデフォルト メモリは 2136 バイトです。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

特権 EXEC

--

 
コマンドの履歴

リリース
変更内容

7.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

現在割り当てられているメモリを表示するには、 show blocks queue history コマンドを入力します。

セキュリティ アプライアンスをリロードすると、メモリ割り当てがデフォルトに戻ります。

次の例では、ブロック診断用のメモリ サイズを増やしています。

hostname# blocks queue history enable
 

次の例では、ブロック診断用のメモリ サイズを 3000 バイトに増やしています。

hostname# blocks queue history enable 3000
 

次の例では、ブロック診断用のメモリ サイズを 3000 バイトに増やそうとしていますが、値が空きメモリを上回っています。

hostname# blocks queue history enable 3000
ERROR: memory size exceeds current free memory
 

次の例では、ブロック診断用のメモリ サイズを 3000 バイトに増やしていますが、値が空きメモリの 50% を超えています。

hostname# blocks queue history enable 3000
WARNING: memory size exceeds 50% of current free memory
 

 
関連コマンド

コマンド
説明

clear blocks

システム バッファの統計情報を消去します。

show blocks

システム バッファの使用状況を表示します。

boot

システムが次回のリロードで使用するシステム イメージ、およびシステムが起動時に使用するコンフィギュレーション ファイルを指定するには、グローバル コンフィギュレーション モードで boot コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

boot { config | system } url

no boot { config | system } url

 
シンタックスの説明

config

システムがロードされるときに使用するコンフィギュレーション ファイルを指定します。

system

システムがロードされるときに使用するシステム イメージ ファイルを指定します。

url

イメージまたはコンフィギュレーションの場所を設定します。マルチ コンテキスト モードでは、管理コンテキストですべてのリモート URL にアクセスできる必要があります。次の URL シンタックスを参照してください。

disk0:/ [ path / ] filename

ASA 5500 シリーズ適応型セキュリティ アプライアンスの場合、この URL は内部フラッシュ メモリを指します。 disk0 ではなく flash を使用することもできます。これらは、エイリアス関係にあります。

disk1:/ [ path / ] filename

ASA 5500 シリーズ適応型セキュリティ アプライアンスの場合、この URL は外部フラッシュ メモリ カードを指します。

flash:/ [ path / ] filename

この URL は内部フラッシュ メモリを指します。

tftp:// [ user [ : password ] @ ] server [: port ] / [ path / ] filename [ ;int= interface_name ]

サーバ アドレスへのルートを上書きする場合は、インターフェイス名を指定します。

このオプションは、ASA 5500 シリーズ適応型セキュリティ アプライアンスの boot system コマンドでしか使用できません。 boot config コマンドを使用するには、セットアップ コンフィギュレーションがフラッシュ メモリ上に保存されていることが必要です。

boot system tftp: コマンドは、1 つしか設定できず、最初に設定する必要があります。

 
デフォルト

boot config コマンドを指定しないと、スタートアップ コンフィギュレーションが非表示の場所に保存され、スタートアップ コンフィギュレーションを利用するコマンド( show startup-config コマンドや copy startup-config コマンド)だけで使用されます。

boot system コマンドにデフォルトはありません。場所を指定しない場合、セキュリティ アプライアンスでは、起動する有効なイメージの検索が、内蔵フラッシュ メモリ内から行われます。有効なイメージが見つからない場合は、システム イメージがロードされず、セキュリティ アプライアンスはブート ループ状態になります。この状態は、ROMmon モードまたは Monitor モードが開始されるまで解除されません。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

グローバル コンフィギュレーション

--

 
コマンドの履歴

リリース
変更内容

7.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドを、 write memory コマンドを使用してスタートアップ コンフィギュレーションに保存すると、BOOT と CONFIG_FILE という環境変数にも設定が保存されます。この環境変数は、セキュリティ アプライアンスが再起動するときにスタートアップ コンフィギュレーションと起動するソフトウェア イメージを決めるために使用します。

最大 4 つの boot system コマンド を入力し、異なるイメージを指定して、順番に起動を試みることができます。セキュリティ アプライアンスは、最初に見つけた有効なイメージを起動します。

現在の実行コンフィギュレーションとは別の場所のスタートアップ コンフィギュレーション ファイルを使用したい場合は、実行コンフィギュレーションを保存した後で、必ずスタートアップ コンフィギュレーション ファイルを新しい場所にコピーしてください。保存後にコピーしておかないと、新しいスタートアップ コンフィギュレーションが実行コンフィギュレーションで上書きされます。


ヒント ASDM イメージ ファイルは、asdm image コマンドで指定します。

次の例は、起動時にセキュリティ アプライアンスが configuration.txt という名前のコンフィギュレーション ファイルをロードするように指定しています。

hostname(config)# boot config disk0:/configuration.txt

 
関連コマンド

コマンド
説明

asdm image

ASDM ソフトウェア イメージを指定します。

show bootvar

ブート ファイルおよびコンフィギュレーションの環境変数を表示します。

border style

認証された WebVPN ユーザに表示される WebVPN ホームページの境界線をカスタマイズするには、カスタマイゼーション コンフィギュレーション モードで border style コマンドを使用します。このコマンドをコンフィギュレーションから削除し、値が継承されるようにするには、このコマンドの no 形式を使用します。

border style value

no border style value

 
シンタックスの説明

value

Cascading Style Sheet(CSS)パラメータ(最大 256 文字)です。

 
デフォルト

境界線のデフォルトのスタイルは background-color:#669999;color:white です。

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

カスタマイゼーション コンフィギュレーション

--

--

--

 
コマンドの履歴

リリース
変更内容

7.1(1)

このコマンドが導入されました。

 
使用上のガイドライン

style オプションは、有効な Cascading Style Sheet(CSS)パラメータとして表現されます。このパラメータの説明は、このマニュアルでは取り扱いません。CSS パラメータの詳細については、World Wide Web Consortium(W3C)の Web サイト www.w3.org の CSS 仕様を参照してください。『CSS 2.1 Specification』の「Appendix F」には、CSS パラメータの使いやすいリストがあります。この付録は www.w3.org/TR/CSS21/propidx.html で入手可能です。

ここでは、WebVPN ページに対する変更で最もよく行われるページの配色を変更するためのヒントを紹介します。

カンマ区切りの RGB 値、HTML の色値、または色の名前(HTML で認識される場合)を使用できます。

RGB 形式は 0,0,0 で、各色(赤、緑、青)について 0 ~ 255 の範囲で 10 進値を入力します。このカンマ区切りのエントリは、他の 2 色と混合する各色の輝度のレベルを示しています。

HTML 形式は #000000 で、16 進形式の 6 桁の数値です。先頭と 2 番目は赤を、3 番目と 4 番目は緑を、5 番目と 6 番目は青を表しています。


) WebVPN ページを簡単にカスタマイズするには、ASDM を使用することをお勧めします。ASDM には、色見本やプレビュー機能など、スタイルの要素を設定するのに便利な機能があります。


次の例では、境界線の背景色を RGB カラー #66FFFF(緑色の一種)にカスタマイズしています。

hostname(config)# webvpn
hostname(config-webvpn)# customization cisco
hostname(config-webvpn-custom)# border style background-color:66FFFF

 
関連コマンド

コマンド
説明

application-access

WebVPN ホームページの Application Access ボックスをカスタマイズします。

browse-networks

WebVPN ホームページの Browse Networks ボックスをカスタマイズします。

web-bookmarks

WebVPN ホームページの Web Bookmarks タイトルまたはリンクをカスタマイズします。

file-bookmarks

WebVPN ホームページの File Bookmarks タイトルまたはリンクをカスタマイズします。

browse-networks

認証された WebVPN ユーザに表示される WebVPN ホームページの Browse Networks ボックスをカスタマイズするには、webvpn カスタマイゼーション コンフィギュレーション モードで browse-networks コマンドを使用します。このコマンドをコンフィギュレーションから削除し、値が継承されるようにするには、このコマンドの no 形式を使用します。

browse-networks { title | message | dropdown } { text | style } value

no browse-networks [{ title | message | dropdown } { text | style } value ]

 
シンタックスの説明

dropdown

ドロップダウン リストを変更することを指定します。

message

タイトルの下に表示されるメッセージを変更することを指定します。

style

スタイルを変更することを指定します。

text

テキストを変更することを指定します。

title

タイトルを変更することを指定します。

value

実際に表示するテキスト(最大 256 文字)、または Cascading Style Sheet(CSS)パラメータ(最大 256 文字)です。

 
デフォルト

デフォルトのタイトルのテキストは「Browse Networks」です。

デフォルトのタイトルのスタイルは次のとおりです。

background-color:#99CCCC;color:black;font-weight:bold;text-transform:uppercase

デフォルトのメッセージのテキストは「Enter Network Path」です。

デフォルトのメッセージのスタイルは次のとおりです。

background-color:#99CCCC;color:maroon;font-size:smaller

デフォルトのドロップダウンのテキストは「File Folder Bookmarks」です。

デフォルトのドロップダウンのスタイルは次のとおりです。

border:1px solid black;font-weight:bold;color:black;font-size:80%

 
コマンド モード

次の表は、このコマンドを入力できるモードを示しています。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

Webvpn カスタマイゼーション コンフィギュレーション

--

--

--

 
コマンドの履歴

リリース
変更内容

7.1(1)

このコマンドが導入されました。

 
使用上のガイドライン

style オプションは、有効な Cascading Style Sheet(CSS)パラメータとして表現されます。このパラメータの説明は、このマニュアルでは取り扱いません。CSS パラメータの詳細については、World Wide Web Consortium(W3C)の Web サイト www.w3.org の CSS 仕様を参照してください。『CSS 2.1 Specification』の「Appendix F」には、CSS パラメータの使いやすいリストがあります。この付録は www.w3.org/TR/CSS21/propidx.html で入手可能です。

ここでは、WebVPN ページに対する変更で最もよく行われるページの配色を変更するためのヒントを紹介します。

カンマ区切りの RGB 値、HTML の色値、または色の名前(HTML で認識される場合)を使用できます。

RGB 形式は 0,0,0 で、各色(赤、緑、青)について 0 ~ 255 の範囲で 10 進値を入力します。このカンマ区切りのエントリは、他の 2 色と混合する各色の輝度のレベルを示しています。

HTML 形式は #000000 で、16 進形式の 6 桁の数値です。先頭と 2 番目は赤を、3 番目と 4 番目は緑を、5 番目と 6 番目は青を表しています。


) WebVPN ページを簡単にカスタマイズするには、ASDM を使用することをお勧めします。ASDM には、色見本やプレビュー機能など、スタイルの要素を設定するのに便利な機能があります。


次の例では、タイトルを「Browse Corporate Networks」に変更し、スタイル内のテキストの色を青に変更しています。

F1-asa1(config)# webvpn
F1-asa1(config-webvpn)# customization cisco
F1-asa1(config-webvpn-custom)# browse-networks title text Browse Corporate Networks
F1-asa1(config-webvpn-custom)# browse-networks title style color:blue

 
関連コマンド

コマンド
説明

application-access

WebVPN ホームページの Application Access ボックスをカスタマイズします。

file-bookmarks

WebVPN ホームページの File Bookmarks タイトルまたはリンクをカスタマイズします。

web-applications

WebVPN ホームページの Web Application ボックスをカスタマイズします。

web-bookmarks

WebVPN ホームページの Web Bookmarks タイトルまたはリンクをカスタマイズします。