Cisco Security Appliance コマンド ライン コンフィギュレーション ガイド Version 7.0(4)
フェールオーバーの設定
フェールオーバーの設定
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

フェールオーバーの設定

フェールオーバーの概要

フェールオーバーのシステム要件

ハードウェア要件

ソフトウェア要件

ライセンス要件

フェールオーバー リンクとステートフル フェールオーバー リンク

フェールオーバー リンク

ステートフル フェールオーバー リンク

Active/Active フェールオーバーと Active/Standby フェールオーバー

Active/Standby フェールオーバー

Active/Active フェールオーバー

使用するフェールオーバーのタイプの決定

標準フェールオーバーとステートフル フェールオーバー

標準フェールオーバー

ステートフル フェールオーバー

フェールオーバー ヘルスのモニタリング

装置ヘルスのモニタリング

インターフェイスのモニタリング

フェールオーバーの設定

Active/Standby フェールオーバーの設定

前提条件

ケーブルベースの Active/Standby フェールオーバーの設定(PIX セキュリティ アプライアンスのみ)

LAN ベースの Active/Standby フェールオーバーの設定

オプションの Active/Standby フェールオーバー設定値の設定

Active/Active フェールオーバーの設定

前提条件

ケーブルベースの Active/Active フェールオーバーの設定(PIX セキュリティ アプライアンスのみ)

LAN ベースの Active/ Active フェールオーバーの設定

オプションの Active/ Active フェールオーバー設定値の設定

フェールオーバー通信の認証/暗号化の設定

フェールオーバー コンフィギュレーションの確認

show failover コマンドの使用方法

監視対象インターフェイスの表示

実行コンフィギュレーション内のフェールオーバー コマンドの表示

フェールオーバー機能のテスト

フェールオーバーの制御およびモニタリング

強制フェールオーバー

フェールオーバーのディセーブル化

故障した装置またはフェールオーバー グループの復元

フェールオーバーのモニタリング

フェールオーバー システム メッセージ

デバッグ メッセージ

SNMP

フェールオーバー コンフィギュレーションの例

ケーブルベースの Active/Standby フェールオーバーの例

LAN ベースの Active/Standby フェールオーバーの例

LAN ベースの Active/ Active フェールオーバーの例

フェールオーバーの設定

この章では、セキュリティ アプライアンスのフェールオーバー機能について説明します。この機能を使用すると、2 つのセキュリティ アプライアンスを設定して、一方の装置が故障した場合に、もう一方の装置が動作を引き継ぐようにできます。

次の事項について説明します。

「フェールオーバーの概要」

「フェールオーバーの設定」

「フェールオーバーの制御およびモニタリング」

「フェールオーバー コンフィギュレーションの例」

フェールオーバーの概要

フェールオーバー設定には、同じセキュリティ アプライアンスが 2 台、専用のフェールオーバー リンク(オプションで、ステートフル フェールオーバー リンク)で相互に接続されている必要があります。アクティブ インターフェイスおよび装置のヘルスが監視されて、所定のフェールオーバー条件に一致しているかどうかが判断されます。所定の条件に一致すると、フェールオーバーが行われます。

セキュリティ アプライアンスは、Active/Active フェールオーバーと Active/Standby フェールオーバーの 2 つのフェールオーバーをサポートします。各フェールオーバー コンフィギュレーションには、フェールオーバーを判定および実行する独自の方式があります。

Active/Active フェールオーバーでは、両方の装置がネットワーク トラフィックを渡すことができます。これによって、ネットワークのロードバランシングを設定できます。Active/Active フェールオーバーは、マルチコンテキスト モードで実行中の装置でのみ使用できます。

Active/Standby フェールオーバーでは、1 つの装置だけがトラフィックを渡すことができ、もう 1 つの装置はスタンバイ状態で待機します。Active/Standby フェールオーバーは、シングルコンテキスト モードで実行中の装置とマルチコンテキスト モードで実行中の装置の両方で使用できます。

両フェールオーバー コンフィギュレーションとも、ステートフルまたはステートレス(通常)フェールオーバーをサポートします。


) VPN フェールオーバーは、マルチコンテキスト モードで動作中の装置ではサポートされません。VPN フェールオーバーは、Active/Standby フェールオーバー コンフィギュレーションに限り使用できます。


ここでは、次の項目について説明します。

「フェールオーバーのシステム要件」

「フェールオーバー リンクとステートフル フェールオーバー リンク」

「Active/Active フェールオーバーと Active/Standby フェールオーバー」

「標準フェールオーバーとステートフル フェールオーバー」

「フェールオーバー ヘルスのモニタリング」

フェールオーバーのシステム要件

ここでは、フェールオーバー コンフィギュレーションにあるセキュリティ アプライアンスのハードウェア要件、ソフトウェア要件、およびライセンス要件について説明します。ここでは、次の項目について説明します。

「ハードウェア要件」

「ソフトウェア要件」

「ライセンス要件」

ハードウェア要件

フェールオーバー コンフィギュレーションでは、2 台の装置が同じハードウェア コンフィギュレーションになっていなければなりません。つまり、同じモデル、同じ数およびタイプのインターフェイス、同じフラッシュ メモリ量、および同じ RAM 量でなければなりません。

ソフトウェア要件

フェールオーバー コンフィギュレーションの 2 台の装置は同じ動作モード(ルーテッドまたは透過、シングルコンテキストまたはマルチコンテキスト)でなければなりません。ソフトウェア バージョンは、メジャー(最初の番号)およびマイナー(2 番目の番号)ともに同じである必要があります。ただし、アップグレード プロセス中は、異なるバージョンのソフトウェアを使用できます。たとえば、ある装置をバージョン 7.0(1) からバージョン 7.0(2) にアップグレードし、フェールオーバーをアクティブ状態のままにできます。長期的に互換性を維持するために、両方の装置を同じバージョンにアップグレードすることをお勧めします。

ライセンス要件

PIX セキュリティ アプライアンス プラットフォームでは、少なくとも 1 台の装置に無制限(UR)ライセンスが必要です。もう一方の装置は、Failover Only(FO)ライセンス、Failover Only Active-Active(FO_AA)ライセンス、または別の UR ライセンスのどれでもかまいません。制限付きライセンスの装置はフェールオーバーには使用できません。FO または FO_AA ライセンスの装置 2 台をフェールオーバー ペアとして一緒に使用することはできません。


) FO ライセンスは、Active/Active フェールオーバーをサポートしません。


FO ライセンスおよび FO_AA ライセンスは、フェールオーバー コンフィギュレーションの装置にのみ使用することが予定されており、スタンドアロン モードの装置で使用することは考えられていません。このいずれかのライセンスのフェールオーバー装置をスタンドアロン モードで使用すると、フェールオーバー動作に戻るまで、少なくとも 24 時間に 1 回リブートされます。FO または FO_AA ライセンスの装置は、UR ライセンスのフェールオーバー ピアに接続されていない状態でブートされると、スタンドアロン モードで動作します。フェールオーバー ペアの UR ライセンスの装置が故障して、コンフィギュレーションから削除された場合、FO または FO_AA ライセンスの装置は、24 時間ごとに自動的にリブートすることはなくなります。手動でリブートされない限り、中断することなく動作します。

装置が自動的にリブートされると、次のメッセージがコンソールに表示されます。

=========================NOTICE=========================
This machine is running in secondary mode without
a connection to an active primary PIX. Please
check your connection to the primary system.
 
REBOOTING....
========================================================
 

ASA プラットフォームには、この制限はありません。

フェールオーバー リンクとステートフル フェールオーバー リンク

ここでは、フェールオーバー リンクおよびステートフル フェールオーバー リンクについて説明します。これらのリンクは、フェールオーバー コンフィギュレーションで 2 台の装置を接続する専用のリンクです。ここでは、次の項目について説明します。

「フェールオーバー リンク」

「ステートフル フェールオーバー リンク」

フェールオーバー リンク

フェールオーバー ペアの 2 台の装置は、フェールオーバー リンク経由で常に通信して、各装置の動作ステータスを確認しています。次の情報がフェールオーバー リンク経由で伝達されています。

装置の状態(アクティブまたはスタンバイ)

電源ステータス(ケーブルベースのフェールオーバーのみ:Cisco PIX セキュリティ アプライアンス プラットフォームに限り使用可能)

hello メッセージ(キープアライブ)

ネットワーク リンクの状態

MAC アドレス交換

コンフィギュレーションの複製および同期


注意 フェールオーバー リンクおよびステートフル フェールオーバー リンク経由で送信される情報は、フェールオーバー キーを使用して通信をセキュリティで保護しない限り、すべてクリア テキストで送信されます。VPN トンネルの終端にセキュリティ アプライアンスを使用する場合、この情報には、トンネルの確立に使用されたすべてのユーザ名、パスワード、および事前共有キーが含まれています。この機密データをクリア テキストで転送することは、非常に大きなセキュリティ リスクになる恐れがあります。セキュリティ アプライアンスを使用して VPN トンネルを終端する場合は、フェールオーバー通信をフェールオーバー キーによってセキュリティで保護することをお勧めします。

PIX セキュリティ アプライアンスの場合、フェールオーバー リンクは LAN ベースの接続または専用のシリアル フェールオーバー ケーブルです。ASA プラットフォームの場合、フェールオーバー リンクは LAN ベースの接続のみです。

ここでは、次の項目について説明します。

「LAN ベースのフェールオーバー リンク」

「シリアル ケーブル フェールオーバー リンク(PIX セキュリティ アプライアンスのみ)」

LAN ベースのフェールオーバー リンク

装置上のイーサネット インターフェイスは、使用されていなければどれでも、フェールオーバー リンクとして使用できます。現在名前が設定されているインターフェイスは指定できません。フェールオーバー リンク インターフェイスは、通常のネットワーク インターフェイスとしては設定されません。フェールオーバー通信のためにのみ存在します。このインターフェイスは、フェールオーバー リンク(および、オプションでステートフル フェールオーバー リンク)専用とする必要があります。LAN ベースのフェールオーバー リンクを接続するには、そのリンク上にホストもルータもない専用スイッチを使用することも、装置を直接リンクするクロスオーバー イーサネット ケーブルを使用することもできます。


) VLAN を使用する場合は、フェールオーバー リンク専用の VLAN を使用します。フェールオーバー リンク VLAN を他の VLAN と共有すると、トラフィックが途切れ途切れになるという問題、あるいは ping 障害や ARP 障害が発生することがあります。スイッチを使用してフェールオーバー リンクを接続する場合は、フェールオーバー リンクには、スイッチおよびセキュリティ アプライアンス上の専用インターフェイスを使用します。このインターフェイスは、通常のネットワーク トラフィックを転送するサブインターフェイスと共有しないでください。


マルチコンテキスト モードで動作中のシステムの場合、フェールオーバー リンクはシステム コンテキストに存在します。このインターフェイスとステートフル フェールオーバー リンク(使用される場合)のみが、システム コンテキストで設定できるインターフェイスです。他のインターフェイスは、すべてセキュリティ コンテキストに割り当てられ、セキュリティ コンテキスト内から設定されます。


) フェールオーバー リンクの IP アドレスおよび MAC アドレスは、フェールオーバー時に変更されません。


シリアル ケーブル フェールオーバー リンク(PIX セキュリティ アプライアンスのみ)

シリアル フェールオーバー ケーブル、つまり「ケーブルベースのフェールオーバー」、は PIX セキュリティ アプライアンス プラットフォームでのみ使用できます。2 台の装置の距離が約 1.8 m 以内の場合は、シリアル フェールオーバー ケーブルを使用することをお勧めします。

2 台の装置を接続するケーブルは、117,760 bps(115 Kbps)でデータを転送する修正 RS-232 シリアル リンク ケーブルです。ケーブルの一方の端には「Primary」のラベルが付いています。ケーブルのこの端に接続される装置は、自動的にプライマリ装置になります。ケーブルのもう一方の端には「Secondary」のラベルが付いています。ケーブルのこの端に接続される装置は、自動的にセカンダリ装置になります。PIX セキュリティ アプライアンス ソフトウェアでこれらの指定を上書きすることはできません。PIX セキュリティ アプライアンス フェールオーバー バンドルを購入すると、このケーブルが含まれています。予備を注文する場合は、部品番号 PIX-FO= を使用します。

ケーブルベースのフェールオーバーを使用する利点は次のとおりです。

PIX セキュリティ アプライアンスは、ピア装置の電源断を即時に検出でき、さらに電源断とケーブルが外れているのとを区別できます。

スタンバイ装置はアクティブ装置と通信でき、またフェールオーバーのブートストラップを行わなくても、コンフィギュレーション全体を受信できます。LAN ベースのフェールオーバーでは、スタンバイ装置がアクティブ装置と通信するには、事前にスタンバイ装置にフェールオーバー リンクを設定しておく必要があります。

LAN ベースのフェールオーバーで 2 台の装置間のスイッチが、別のハードウェア障害ポイントとなる場合があります。ケーブルベースのフェールオーバーでは、この潜在的な障害ポイントはなくなります。

イーサネット インターフェイス(およびスイッチ)をフェールオーバー リンク専用にする必要はありません。

ケーブルによってプライマリ装置とセカンダリ装置が判別されるため、装置コンフィギュレーションでその情報を手動で入力する必要がなくなります。

欠点は次のとおりです。

距離の制限:装置は約 1.8 m 以上離せません。

コンフィギュレーションの複製に時間がかかります。

ステートフル フェールオーバー リンク

ステートフル フェールオーバーを使用するには、ステートフル フェールオーバー リンクを設定してすべてのステート情報を渡す必要があります。ステートフル フェールオーバー リンクを設定する方法としては、次の 3 つのオプションがあります。

ステートフル フェールオーバー リンクに、専用のイーサネット インターフェイスを使用できます。

LAN ベースのフェールオーバーを使用している場合は、フェールオーバー リンクを共有できます。

内部インターフェイスなど、通常のデータ インターフェイスを共有できます。しかし、このオプションは推奨しません。

ステートフル フェールオーバー リンクに専用のイーサネット インターフェイスを使用している場合、スイッチまたはクロスオーバー ケーブルを使用して装置を直接接続できます。スイッチを使用している場合、他のホストまたはルータをこのリンクに配置しないでください。


) セキュリティ アプライアンスに直接接続されているシスコ スイッチ ポートの PortFast オプションをイネーブルにします。


フェールオーバー リンクをステートフル フェールオーバー リンクとして使用している場合は、使用可能な最も速いイーサネット インターフェイスを使用します。このインターフェイスでパフォーマンス上の問題が発生した場合は、別のインターフェイスをステートフル フェールオーバー インターフェイス専用にすることを検討してください。

データ インターフェイスをステートフル フェールオーバー リンクとして使用する場合、そのインターフェイスをステートフル フェールオーバー リンクと指定すると、次の警告が表示されます。

******* WARNING ***** WARNING ******* WARNING ****** WARNING *********
Sharing Stateful failover interface with regular data interface is not
a recommended configuration due to performance and security concerns.
******* WARNING ***** WARNING ******* WARNING ****** WARNING *********
 

データ インターフェイスとステートフル フェールオーバー インターフェイスを共有すると、リプレイ攻撃を受けやすくなる場合があります。さらに、大量のステートフル フェールオーバー トラフィックがインターフェイスで送信され、そのネットワーク セグメントでパフォーマンス上の問題が発生することがあります。


) データ インターフェイスをステートフル フェールオーバー インターフェイスとして使用するのは、シングルコンテキストのルーテッド モードでのみサポートされます。


マルチコンテキスト モードでは、ステートフル フェールオーバー リンクはシステム コンテキストに存在します。このインターフェイスとフェールオーバー インターフェイスが、システム コンテキスト内にある唯一のインターフェイスです。他のインターフェイスは、すべてセキュリティ コンテキストに割り当てられ、セキュリティ コンテキスト内から設定されます。


) ステートフル フェールオーバー リンクが通常のデータ インターフェイスに設定されていない限り、ステートフル フェールオーバー リンクの IP アドレスと MAC アドレスは、フェールオーバー時に変更されません。



注意 フェールオーバー リンクおよびステートフル フェールオーバー リンク経由で送信される情報は、フェールオーバー キーを使用して通信をセキュリティで保護しない限り、すべてクリア テキストで送信されます。VPN トンネルの終端にセキュリティ アプライアンスを使用する場合、この情報には、トンネルの確立に使用されたすべてのユーザ名、パスワード、および事前共有キーが含まれています。この機密データをクリア テキストで転送することは、非常に大きなセキュリティ リスクになる恐れがあります。セキュリティ アプライアンスを使用して VPN トンネルを終端する場合は、フェールオーバー通信をフェールオーバー キーによってセキュリティで保護することをお勧めします。

Active/Active フェールオーバーと Active/Standby フェールオーバー

ここでは、各フェールオーバー コンフィギュレーションについて詳細に説明します。ここでは、次の項目について説明します。

「Active/Standby フェールオーバー」

「Active/Active フェールオーバー」

「使用するフェールオーバーのタイプの決定」

Active/Standby フェールオーバーの概要

Active/Standby フェールオーバーでは、スタンバイ セキュリティ アプライアンスを使用して、障害の発生した装置の機能を引き継ぎます。アクティブ装置が故障すると、スタンバイ状態に変わり、そしてスタンバイ装置がアクティブ状態に変わります。アクティブになる装置が、障害の発生した装置の IP アドレス(または、透過ファイアウォールの場合は管理 IP アドレス)および MAC アドレスを引き継いで、トラフィックの転送を開始します。現在スタンバイになっている装置が、スタンバイの IP アドレスと MAC アドレスを引き継ぎます。ネットワーク装置は、MAC と IP アドレスの組み合せについて変更を認識しないため、ネットワーク上のどこにおいても ARP エントリが変更されたり、タイムアウトが生じたりすることはありません。


) マルチコンテキスト モードの場合、セキュリティ アプライアンスは装置全体(すべてのコンテキストを含む)をフェールオーバーできますが、個々のコンテキストを別々にフェールオーバーすることはできません。


Primary/Secondary ステータスと Active/Standby ステータス

フェールオーバー ペアの 2 台の装置の主な相違点は、どちらの装置がアクティブでどちらの装置がスタンバイであるか、つまりどちらの IP アドレスを使用するかおよびどちらの装置がアクティブにトラフィックを渡すかということに関連します。

しかし、プライマリである装置(コンフィギュレーションで指定)とセカンダリである装置との間で、いくつかの相違点があります。

両方の装置が同時にスタート アップした場合(さらに動作ヘルスが等しい場合)、プライマリ装置が常にアクティブ装置になります。

プライマリ装置の MAC アドレスは常に、アクティブ IP アドレスと結び付けられています。この規則の例外は、セカンダリ装置がアクティブであり、フェールオーバー リンク経由でプライマリ MAC アドレスを取得できない場合に発生します。この場合、セカンダリ MAC アドレスが使用されます。

装置の初期化とコンフィギュレーションの同期

コンフィギュレーションの同期は、フェールオーバー ペアの一方または両方の装置がブートされると行われます。コンフィギュレーションは常に、アクティブ装置からスタンバイ装置に同期化されます。スタンバイ装置は、その初期スタートアップを完了すると、自分の実行コンフィギュレーションを削除し(アクティブ装置との通信に必要なフェールオーバー コマンドを除く)、アクティブ装置は自分のコンフィギュレーション全体をスタンバイ装置に送信します。

アクティブ装置は、次の条件で判別されます。

装置がブートされ、ピアがすでにアクティブとして動作中であることを検出すると、その装置はスタンバイ装置になります。

装置がブートされてピアを検出できないと、その装置はアクティブ装置になります。

両方の装置が同時にブートされた場合は、プライマリ装置がアクティブ装置になり、セカンダリ装置がスタンバイ装置になります。


) セカンダリ装置がブートされてプライマリ装置を検出できないと、その装置はアクティブ装置になります。アクティブ IP アドレスには、セカンダリ装置自体の MAC アドレスを使用します。しかし、プライマリ装置が使用可能になると、セカンダリ装置は MAC アドレスをプライマリ装置の MAC アドレスに変更します。これによって、ネットワーク トラフィックが中断されることがあります。これを回避するには、フェールオーバー ペアを仮想 MAC アドレスで設定します。詳細については、「Active/Standby フェールオーバーの設定」を参照してください。


複製が開始されると、アクティブ装置のセキュリティ アプライアンス コンソールに「Beginning configuration replication: Sending to mate」というメッセージが表示され、複製が完了すると、セキュリティ アプライアンスに「End Configuration Replication to mate」というメッセージが表示されます。複製中、アクティブ装置に入力されたコマンドがスタンバイ装置に適切に複製されないことがあり、またスタンバイ装置に入力されたコマンドが、アクティブ装置から複製されているコンフィギュレーションによって上書きされることがあります。コンフィギュレーションの複製処理中には、フェールオーバー ペアのどちらの装置にもコマンドを入力しないでください。コンフィギュレーションのサイズによって、複製は数秒で済むことも数分かかることもあります。

スタンバイ装置の場合、コンフィギュレーションは実行メモリにのみ存在します。同期化後にコンフィギュレーションをフラッシュ メモリに保存するには、次のようにします。

シングルコンテキスト モードの場合は、アクティブ装置で copy running-config startup-config コマンドを使用します。コマンドはスタンバイ装置に複製され、コンフィギュレーションがフラッシュ メモリに書き込まれます。

マルチコンテキスト モードの場合は、システム実行スペースおよびディスク上の各コンテキスト内からアクティブ装置に copy running-config startup-config コマンドを入力します。コマンドはスタンバイ装置に複製され、コンフィギュレーションがフラッシュ メモリに書き込まれます。外部のサーバにスタートアップ コンフィギュレーションがあるコンテキストは、ネットワーク経由で両方の装置からアクセスできます。そのため、各装置で個別に保存する必要はありません。または、ディスク上のコンテキストを、アクティブ装置から外部サーバにコピーし、それからスタンバイ装置のディスクにコピーできます。スタンバイ装置で、装置がリロードされると、そのコンテキストが使用可能になります。

コマンドの複製

コマンドの複製は常に、アクティブ装置からスタンバイ装置の方向に行われます。アクティブ装置にコマンドを入力すると、そのコマンドがフェールオーバー リンクを通してスタンバイ装置に送信されます。コマンドを複製する場合、アクティブ コンフィギュレーションをフラッシュ メモリに保存する必要はありません。


) スタンバイ装置上で行った変更は、アクティブ装置に複製されません。スタンバイ装置にコマンドを入力すると、セキュリティ アプライアンスに **** WARNING **** Configuration Replication is NOT performed from Standby unit to Active unit. Configurations are no longer synchronized というメッセージが表示されます。このメッセージは、コンフィギュレーションに影響しない数多くのコマンドを入力したときにも表示されます。


アクティブ装置に write standby コマンドを入力すると、スタンバイ装置で実行コンフィギュレーションが削除され(アクティブ装置との通信に使用するフェールオーバー コマンドを除く)、アクティブ装置のコンフィギュレーション全体がスタンバイ装置に送信されます。

マルチコンテキスト モードの場合、システム実行スペースに write standby コマンドを入力すると、すべてのコンテキストが複製されます。あるコンテキスト内で write standby コマンドを入力すると、コマンドはそのコンテキスト コンフィギュレーションのみを複製します。

複製されたコマンドは、実行コンフィギュレーションに保存されます。スタンバイ装置のフラッシュ メモリに複製されたコマンドを保存するには、次のように行います。

シングルコンテキスト モードの場合は、アクティブ装置で copy running-config startup-config コマンドを使用します。コマンドはスタンバイ装置に複製され、コンフィギュレーションがフラッシュ メモリに書き込まれます。

マルチコンテキスト モードの場合は、システム実行スペースおよびディスク上の各コンテキスト内からアクティブ装置に copy running-config startup-config コマンドを入力します。コマンドはスタンバイ装置に複製され、コンフィギュレーションがフラッシュ メモリに書き込まれます。外部のサーバにスタートアップ コンフィギュレーションがあるコンテキストは、ネットワーク経由で両方の装置からアクセスできます。そのため、各装置で個別に保存する必要はありません。または、ディスク上のコンテキストを、アクティブ装置から外部サーバにコピーし、それからスタンバイ装置のディスクにコピーできます。

フェールオーバーのトリガー

次のいずれかのイベントが発生した場合、装置が故障する可能性があります。

装置でハードウェア障害または電源断が発生した。

装置でソフトウェア障害が発生した。

多くの監視対象インターフェイスが故障した。

no failover active コマンドがアクティブ装置に入力されたか、 failover active コマンドがスタンバイ装置に入力された。

フェールオーバーのアクション

Active/Standby フェールオーバーでは、フェールオーバーは装置ごとに行われます。マルチコンテキスト モードで動作中のシステムでも、個々のコンテキストまたはコンテキストのグループをフェールオーバーすることはできません。

表11-1 に、各障害イベントに対するフェールオーバー アクションを示します。この表には、各フェールオーバー イベントに対して、フェールオーバー ポリシー(フェールオーバーまたはフェールオーバーなし)、アクティブ装置が行うアクション、スタンバイ装置が行うアクション、およびフェールオーバー条件とアクションに関する特別な注意事項を示します。

 

表11-1 フェールオーバー動作

障害の状況
ポリシー
アクティブ
アクション
スタンバイ
アクション
注意

アクティブ装置が故障(電源またはハードウェア)

フェールオーバー

該当なし

アクティブになる

アクティブに故障とマークする

監視対象インターフェイスまたはフェールオーバー リンクで hello メッセージは受信されません。

以前にアクティブであった装置の復旧

フェールオーバーなし

スタンバイになる

動作なし

なし

スタンバイ装置が故障(電源またはハードウェア)

フェールオーバーなし

スタンバイに故障とマークする

該当なし

スタンバイ装置が故障とマークされている場合、インターフェイス障害しきい値を超えても、アクティブ装置はフェールオーバーを行いません。

動作中にフェールオーバー リンクに障害が発生した

フェールオーバーなし

フェールオーバー インターフェイスに故障とマークする

フェールオーバー インターフェイスに故障とマークする

フェールオーバー リンクがダウンしている間、装置はスタンバイ装置にフェールオーバーできないため、できるだけ早くフェールオーバー リンクを復元する必要があります。

スタートアップ時にフェールオーバー リンクに障害が発生した

フェールオーバーなし

フェールオーバー インターフェイスに故障とマークする

アクティブになる

スタートアップ時にフェールオーバー リンクがダウンしていると、両方の装置がアクティブになります。

ステートフル フェールオーバー リンクに障害が発生した

フェールオーバーなし

動作なし

動作なし

ステート情報が古くなり、フェールオーバーが発生するとセッションが終了します。

アクティブ装置におけるしきい値を超えたインターフェイス障害

フェールオーバー

アクティブに故障とマークする

アクティブになる

なし

スタンバイ装置におけるしきい値を超えたインターフェイス障害

フェールオーバーなし

動作なし

スタンバイに故障とマークする

スタンバイ装置が故障とマークされている場合、インターフェイス障害しきい値を超えても、アクティブ装置はフェールオーバーを行いません。

Active/Active フェールオーバー

ここでは、Active/Active フェールオーバーについて説明します。ここでは、次の項目について説明します。

「Active/Active フェールオーバーの概要」

「Primary/Secondary ステータスと Active/Standby ステータス」

「装置の初期化とコンフィギュレーションの同期」

「コマンドの複製」

「フェールオーバーのトリガー」

「フェールオーバー アクション」

Active/Active フェールオーバーの概要

Active/Active フェールオーバーは、マルチコンテキスト モードのセキュリティ アプライアンスでのみ使用できます。Active/Active フェールオーバー コンフィギュレーションでは、両方のセキュリティ アプライアンスがネットワーク トラフィックを渡すことができます。

Active/Active フェールオーバーでは、セキュリティ アプライアンスのセキュリティ コンテキストは、 フェールオーバー グループ に分割されます。フェールオーバー グループは、1 つまたは複数のセキュリティ コンテキストの論理グループにすぎません。セキュリティ アプライアンスには最大 2 つのフェールオーバー グループを作成できます。管理コンテキストは常にフェールオーバー グループ 1 のメンバーであり、未割り当てセキュリティ コンテキストもまた、デフォルトでフェールオーバー グループ 1 のメンバーです。

フェールオーバー グループは、Active/Active フェールオーバーにおいてフェールオーバーの基本単位を形成します。インターフェイス障害モニタリング、フェールオーバー、およびアクティブ/スタンバイ ステータスはすべて、フェールオーバー グループのアトリビュートであって、装置のアトリビュートではありません。アクティブ フェールオーバー グループが故障すると、スタンバイ状態に変化し、スタンバイ フェールオーバー グループがアクティブになります。アクティブになったフェールオーバー グループのインターフェイスが、故障したフェールオーバー グループのインターフェイスの MAC アドレスと IP アドレスを引き継ぎます。スタンバイ状態になったフェールオーバー グループのインターフェイスが、スタンバイ MAC アドレスと IP アドレスを引き継ぎます。


) あるフェールオーバー グループが装置上で故障したというのは、装置が故障したという意味ではありません。その装置では、別のフェールオーバー グループが依然としてトラフィックを渡している場合があります。


フェールオーバー グループを作成する場合は、フェールオーバー グループ 1 がアクティブ状態にある装置に作成する必要があります。


) Active/Active フェールオーバーでは、各フェールオーバー グループのインターフェイスに対して仮想 MAC アドレスが生成されます。同じネットワーク上に Active/Active フェールオーバー ペアが複数ある場合は、あるペアのインターフェイスに割り当てられているものと同じデフォルト仮想 MAC アドレスが、他のペアのインターフェイスに割り当てられることがあります。これは、デフォルト仮想 MAC アドレスの決定方法に基づいた動作です。ネットワーク上で MAC アドレスが重複することを回避するには、必ず各物理インターフェイスに仮想のアクティブおよびスタンバイ MAC アドレスを割り当てます。


Primary/Secondary ステータスと Active/Standby ステータス

Active/Standby フェールオーバーの場合のように、Active/Active フェールオーバー ペアの一方の装置がプライマリ装置に指定され、もう一方の装置がセカンダリ装置に指定されます。Active/Standby フェールオーバーの場合とは異なり、両方の装置が同時に起動された場合、この指定ではどちらの装置がアクティブになるか指示しません。代わりに、プライマリ/セカンダリ指定によって、ペアに実行コンフィギュレーションを提供する装置と、両方の装置が同時に起動された場合に各フェールオーバー グループがアクティブ状態で表示される装置が決定されます。

コンフィギュレーションの各フェールオーバー グループには、プライマリまたはセカンダリ装置プリファレンスが付与されます。このプリファレンスによって、両方の装置が同時に起動された場合に、フェールオーバー ペアのどちらの装置で、フェールオーバー グループのコンテキストがアクティブ状態で表示されるかが決定されます。両方のフェールオーバー グループをペアのある 1 つの装置でアクティブ状態にして、もう一方の装置にはスタンバイ状態のフェールオーバー グループが含まれるようにできます。しかし、さらに一般的なコンフィギュレーションでは、各フェールオーバー グループに異なる役割プリファレンスを割り当て、装置ごとにそれぞれ 1 つをアクティブにして、装置全体でトラフィックのバランスがとれるようにします。


) セキュリティ アプライアンスには、ロードバランシング サービスは用意されていません。ロードバランシングは、セキュリティ アプライアンスにトラフィックを渡すルータが処理する必要があります。


装置の初期化とコンフィギュレーションの同期

コンフィギュレーションの同期がとられるのは、フェールオーバー ペアの一方または両方の装置がブートされたときです。

ピア装置が使用できないときに装置がブートされると、フェールオーバー グループおよび装置のプライマリまたはセカンダリ指定には関係なく、両方のフェールオーバー グループがその装置でアクティブになります。コンフィギュレーションの同期はとられません。ピア装置が使用できない場合があるのは、ピア装置の電源が切断されている、ピア装置が故障状態である、または装置間のフェールオーバー リンクが確立されていない、などの理由が考えられます。

ピア装置がアクティブ(ピア装置で両方のフェールオーバー グループがアクティブ)の間に装置がブートされると、ブートされた装置はアクティブ装置にアクセスして実行コンフィギュレーションを取得します。デフォルトでは、フェールオーバー グループは、アクティブ装置でアクティブのままです。これは、各フェールオーバー グループのプライマリ プリファレンスまたはセカンダリ プリファレンス、および装置指定には関係ありません。フェールオーバー グループは、フェールオーバーが行われるか、または no failover active コマンドでもう一方の装置に手動で強制的にフェールオーバーされるまで、その装置でアクティブのままです。しかし、 preempt コマンドを使用すると、優先する装置が使用可能になったときに、その装置上でアクティブになるように、各フェールオーバー グループを設定できます。フェールオーバー グループは、 preempt コマンドで設定されている場合、優先する装置が使用可能になると、その装置上で自動的にアクティブになります。

両方の装置が同時にブートされる場合、プライマリ装置がアクティブ装置になります。セカンダリ装置は、実行コンフィギュレーションをプライマリ装置から取得します。コンフィギュレーションが同期化されると、各フェールオーバー グループが優先する装置上でアクティブになります。

コマンドの複製

両方の装置が動作中になった後で、次のように、コマンドが一方の装置からもう一方の装置に複製されます。

セキュリティ コンテキスト内で入力されたコマンドは、そのセキュリティ コンテキストがアクティブ状態で表示される装置からピア装置に複製されます。


) あるコンテキストがある装置でアクティブ状態と見なされるのは、そのコンテキストが属するフェールオーバー グループがその装置上でアクティブ状態である場合です。


システム実行スペースで入力されたコマンドは、フェールオーバー グループ 1 がアクティブ状態の装置から、フェールオーバー グループ 1 がスタンバイ状態の装置に複製されます。

管理コンテキストで入力されたコマンドは、フェールオーバー グループ 1 がアクティブ状態の装置から、フェールオーバー グループ 1 がスタンバイ状態の装置に複製されます。

コマンド複製を行うのに適切な装置上でコマンドを入力しなかった場合は、コンフィギュレーションは非同期になります。この変更内容は、次回に初期コンフィギュレーション同期が行われると失われることがあります。

write standby コマンドを使用すると、非同期になったコンフィギュレーションを再同期化できます。Active/Active フェールオーバーの場合、 write standby コマンドは次のように動作します。

システム実行スペースで write standby コマンドを入力すると、システム コンフィギュレーションおよびセキュリティ アプライアンス上のセキュリティ コンテキストすべてに対するコンフィギュレーションがピア装置に書き込まれます。これには、スタンバイ状態のセキュリティ コンテキストのコンフィギュレーション情報が含まれています。このコマンドの入力は、フェールオーバー グループ 1 がアクティブ状態の装置上のシステム実行スペースで行う必要があります。

セキュリティ コンテキストで write standby コマンドを入力すると、セキュリティ コンテキストのコンフィギュレーションのみがピア装置に書き込まれます。このコマンドの入力は、セキュリティ コンテキストがアクティブ状態で表示される装置のセキュリティ コンテキストで行う必要があります。

複製されたコマンドは、ピア装置に複製された場合、フラッシュ メモリに保存されません。実行コンフィギュレーションに追加されます。複製されたコマンドを両方の装置のフラッシュ メモリに保存するには、変更を行った装置で write memory または copy running-config startup-config コマンドを使用します。コマンドはピア装置に複製されて、コンフィギュレーションがピア装置のフラッシュ メモリに保存されます。

フェールオーバーのトリガー

Active/Active フェールオーバーでは、次のいずれかのイベントが発生すると、フェールオーバーが装置レベルでトリガーされます。

装置でハードウェア障害が発生した。

装置で電源障害が発生した。

装置でソフトウェア障害が発生した。

no failover active または failover active コマンドがシステム実行スペースで入力された。

フェールオーバーは、次のいずれかのイベントが発生すると、フェールオーバー グループ レベルでトリガーされます。

グループ内の多くの監視対象インターフェイスが故障した。

no failover active group group_id コマンドが入力された。

フェールオーバー グループ内のインターフェイスの数または割合を指定することで各フェールオーバー グループにフェールオーバーしきい値を設定し、故障したインターフェイスがこのしきい値(インターフェイスの数または割合)を超えた場合にそのグループは故障したと判断されます。フェールオーバー グループには複数のコンテキストを含めることができ、また各コンテキストには複数のインターフェイスを含めることができるので、1 つのコンテキストのインターフェイスがすべて故障しても、そのコンテキストに関連するフェールオーバー グループが故障と判断されない可能性があります。

インターフェイスと装置のモニタリングの詳細については、「フェールオーバー ヘルスのモニタリング」を参照してください。

フェールオーバー アクション

Active/Active フェールオーバー コンフィギュレーションでは、フェールオーバーは、システムごとに行うのではなく、フェールオーバー グループごとに行われます。たとえば、プライマリ装置で両方のフェールオーバー グループをアクティブと指定し、フェールオーバー グループ 1 が故障すると、フェールオーバー グループ 2 はプライマリ装置でアクティブのままですが、フェールオーバー グループ 1 はセカンダリ装置でアクティブになります。


) Active/Active フェールオーバーを構成する場合は、両方の装置の合計トラフィックが各装置の容量以内になるようにしてください。


表11-2 に、各障害イベントに対するフェールオーバー アクションを示します。各障害イベントに対して、ポリシー(フェールオーバーまたはフェールオーバーなし)、アクティブ フェールオーバー グループのアクション、およびスタンバイ フェールオーバー グループのアクションを示します。

 

表11-2 Active/Active フェールオーバーのフェールオーバー動作

障害の状況
ポリシー
アクティブ
グループの
アクション
スタンバイ
グループの
アクション
注意

装置で電源断またはソフトウェア障害が発生した

フェールオーバー

スタンバイになり、故障とマークする

アクティブになる

アクティブに故障とマークする

フェールオーバー ペアの装置が故障すると、その装置のアクティブ フェールオーバー グループはすべて故障とマークされ、ピア装置のフェールオーバー グループがアクティブになります。

アクティブ フェールオーバー グループにおけるしきい値を超えたインターフェイス障害

フェールオーバー

アクティブ グループに故障とマークする

アクティブになる

なし。

スタンバイ フェールオーバー グループにおけるしきい値を超えたインターフェイス障害

フェールオーバーなし

動作なし

スタンバイ グループに故障とマークする

スタンバイ フェールオーバー グループが故障とマークされている場合、インターフェイス フェールオーバー障害しきい値を超えても、アクティブ フェールオーバー グループはフェールオーバーを行いません。

以前にアクティブであったフェールオーバー グループの復旧

フェールオーバーなし

動作なし

動作なし

preempt コマンドで設定されていない場合、フェールオーバー グループは現在の装置でアクティブのままです。

スタートアップ時にフェールオーバー リンクに障害が発生した

フェールオーバーなし

アクティブになる

アクティブになる

スタートアップ時にフェールオーバー リンクがダウンしていると、両方の装置の両方のフェールオーバー グループがアクティブになります。

ステートフル フェールオーバー リンクに障害が発生した

フェールオーバーなし

動作なし

動作なし

ステート情報が古くなり、フェールオーバーが発生するとセッションが終了します。

動作中にフェールオーバー リンクに障害が発生した

フェールオーバーなし

該当なし

該当なし

各装置で、フェールオーバー インターフェイスが故障とマークされます。フェールオーバー リンクがダウンしている間、装置はスタンバイ装置にフェールオーバーできないため、できるだけ早くフェールオーバー リンクを復元する必要があります。

使用するフェールオーバーのタイプの決定

選択するフェールオーバーのタイプは、セキュリティ アプライアンスのコンフィギュレーションとセキュリティ アプライアンスの使用計画によって決定されます。

セキュリティ アプライアンスをシングルモードで動作させている場合、使用できるのは Active/Standby フェールオーバーのみです。Active/Active フェールオーバーは、マルチコンテキスト モードで動作しているセキュリティ アプライアンスでのみ使用できます。

セキュリティ アプライアンスをマルチコンテキスト モードで動作させている場合は、Active/Active フェールオーバーまたは Active/Standby フェールオーバーを設定できます。

ロードバランシングを提供するには、Active/Active フェールオーバーを使用します。

ロードバランシングを提供しない場合は、Active/Standby フェールオーバーまたは Active/Active フェールオーバーを使用します。

表11-3 に、各タイプのフェールオーバー コンフィギュレーションでサポートされる機能を比較して示します。

 

表11-3 フェールオーバー コンフィギュレーション機能のサポート

機能
Active/Active
Active/Standby

シングルコンテキスト モード

なし

あり

マルチコンテキスト モード

あり

あり

ロードバランシング ネットワーク コンフィギュレーション

あり

なし

装置フェールオーバー

あり

あり

コンテキスト グループのフェールオーバー

あり

なし

個別コンテキストのフェールオーバー

なし

なし

標準フェールオーバーとステートフル フェールオーバー

セキュリティ アプライアンスは、標準およびステートフルという 2 つのタイプのフェールオーバーをサポートします。ここでは、次の項目について説明します。

「標準フェールオーバー」

「ステートフル フェールオーバー」

標準フェールオーバー

フェールオーバーが行われると、アクティブ接続はすべてドロップされます。新しいアクティブ装置が引き継ぐ場合、クライアントは接続を再確立する必要があります。

ステートフル フェールオーバー

ステートフル フェールオーバーがイネーブルになっている場合、アクティブ装置は接続ごとのステート情報をスタンバイ装置に常に渡しています。フェールオーバーの発生後も、新しいアクティブ装置で同じ接続情報が利用できます。サポートされているエンドユーザのアプリケーションでは、同じ通信セッションを保持するために再接続する必要はありません。

スタンバイ装置に渡されるステート情報は、次のとおりです。

NAT 変換テーブル

TCP 接続状態

UDP 接続状態

ARP テーブル

レイヤ 2 ブリッジ テーブル(透過ファイアウォール モードで動作中の場合)

HTTP 接続状態(HTTP 複製がイネーブルの場合)

ISAKMP および IPSec SA テーブル

GTP PDP 接続データベース

ステートフル フェールオーバーがイネーブルになっている場合にスタンバイ装置に渡されない情報は、次のとおりです。

HTTP 接続テーブル(HTTP 複製がイネーブルでない場合)

ユーザ認証(uauth)テーブル

ルーティング テーブル

セキュリティ サービス カードのステート情報


) アクティブな Cisco IP SoftPhone セッション中にフェールオーバーが行われると、コール セッション ステート情報がスタンバイ装置に複製されているので、コールはアクティブのままになります。コールが終了すると、IP SoftPhone クライアントは CallManager との接続がなくなります。これは、CTIQBE ハングアップ メッセージのセッション情報がスタンバイ装置に存在しないために発生します。IP SoftPhone クライアントが一定の時間内に CallManager から返送される応答を受信しない場合、このクライアントは CallManager を到達不能と見なし、自分自身の登録を解除します。


フェールオーバー ヘルスのモニタリング

セキュリティ アプライアンスは、各装置について全体的なヘルスおよびインターフェイス ヘルスを監視します。セキュリティ アプライアンスがテストを実行して、各装置の状態を判断する方法の詳細については、次の項を参照してください。

「装置ヘルスのモニタリング」

「インターフェイスのモニタリング」

装置ヘルスのモニタリング

セキュリティ アプライアンスは、フェールオーバー リンクを監視して相手装置のヘルスを判断します。装置がフェールオーバー リンクで hello メッセージを受信しない場合、装置は、フェールオーバー インターフェイスを含むすべてのインターフェイスに ARP 要求を送信します。セキュリティ アプライアンスによる試行回数は、ユーザが設定できます。セキュリティ アプライアンスが行うアクションは、相手装置からの応答によって決まります。次の可能なアクションを参照してください。

セキュリティ アプライアンスがいずれかのインターフェイスで応答を受信した場合は、フェールオーバーを行いません。

セキュリティ アプライアンスがどのインターフェイスでも応答を受信しなかった場合、スタンバイ装置がアクティブ モードに切り替わり、相手装置を故障に分類します。

セキュリティ アプライアンスがフェールオーバー リンクで応答を受信しなかった場合、装置のフェールオーバーは行われません。フェールオーバー リンクが故障とマークされます。フェールオーバー リンクがダウンしている間、装置はスタンバイ装置にフェールオーバーできないため、できるだけ早くフェールオーバー リンクを復元する必要があります。


) 障害が発生した装置が回復せず、実際には障害は発生していないと考えられる場合は、failover reset コマンドを使用して状態をリセットできます。ただし、フェールオーバー条件が継続している場合、装置は再び障害状態になります。


インターフェイスのモニタリング

すべてのコンテキスト間に分割された最大 250 のインターフェイスを監視できます。重要なインターフェイスを監視する必要があります。たとえば、共有インターフェイスを監視するように 1 つのコンテキストを設定する場合があります(インターフェイスが共有されているため、すべてのコンテキストがそのモニタリングで監視されます)。

装置が監視対象のインターフェイスで hello メッセージを受信しない場合は、次のテストを実行します。

1. リンク アップ/ダウン テスト:インターフェイスのステータスのテスト。リンク アップ/ダウン テストでインターフェイスが動作していることが示された場合、セキュリティ アプライアンス はネットワーク テストを実行します。一連のテストでは、障害が発生している装置を判別するためのネットワーク トラフィックが生成されます。各テストの開始時に、各装置はインターフェイスの受信パケット カウントをリセットします。各テストの終了時には、各装置はトラフィックを受信したかどうかをチェックします。トラフィックを受信していれば、インターフェイスは正常に動作していると見なされます。いずれか一方の装置だけがテスト用のトラフィックを受信している場合は、トラフィックを受信しなかった装置が故障していると見なされます。どちらの装置もトラフィックを受信しなかった場合は、次のテストが使用されます。

2. ネットワーク アクティビティ テスト:受信ネットワーク アクティビティ テスト。装置は、最大 5 秒間、すべての受信パケット数をカウントします。この時間間隔の間にパケットが受信されると、インターフェイスが正常に動作しているものと見なされ、テストは停止します。トラフィックが受信されなかった場合、ARP テストが開始します。

3. ARP テスト:取得したエントリの最後の 2 つの装置 ARP キャッシュの読み取り。装置は、ネットワーク トラフィックを発生させるために、1 回に 1 つずつ、これらのマシンに ARP 要求を送信します。各要求後、装置は最大 5 秒間受信したトラフィックをすべてカウントします。トラフィックが受信されれば、インターフェイスは正常に動作していると見なされます。トラフィックが受信されなければ、ARP 要求が次のマシンに送信されます。リストの最後まで、まったくトラフィックが受信されなかった場合、ping テストが開始します。

4. ブロードキャスト Ping テスト:ブロードキャスト ping 要求の送信で構成される ping テスト。装置は、最大 5 秒間、すべての受信パケット数をカウントします。この時間間隔の間にパケットが受信されると、インターフェイスが正常に動作しているものと見なされ、テストは停止します。

1 つのインターフェイスに対するネットワーク テストがすべて失敗したが、相手装置のこのインターフェイスが正常にトラフィックを渡し続けている場合、そのインターフェイスは故障していると見なされます。故障したインターフェイスがしきい値を超えている場合は、フェールオーバーが行われます。相手装置のインターフェイスもすべてのネットワーク テストに失敗した場合、両方のインターフェイスが「未知」状態になり、フェールオーバー制限に向けてのカウントは行いません。

インターフェイスは、何らかのトラフィックを受信すると、再度動作状態になります。故障したセキュリティ アプライアンスは、インターフェイス障害しきい値が満たされなくなった場合、スタンバイ モードに戻ります。


) 障害が発生した装置が回復せず、実際には障害は発生していないと考えられる場合は、failover reset コマンドを使用して状態をリセットできます。ただし、フェールオーバー条件が継続している場合、装置は再び障害状態になります。


フェールオーバーの設定

この項では、フェールオーバーを設定する方法について説明します。次の項目を取り上げます。

「Active/Standby フェールオーバーの設定」

「Active/Active フェールオーバーの設定」

「フェールオーバー通信の認証/暗号化の設定」

「フェールオーバー コンフィギュレーションの確認」

Active/Standby フェールオーバーの設定

ここでは、Active/Standby フェールオーバーを設定する手順の詳細を説明します。ここでは、次の項目について説明します。

「前提条件」

「ケーブルベースの Active/Standby フェールオーバーの設定(PIX セキュリティ アプライアンスのみ)」

「LAN ベースの Active/Standby フェールオーバーの設定」

「オプションの Active/Standby フェールオーバー設定値の設定」

代表的なフェールオーバー コンフィギュレーションの例については、「フェールオーバー コンフィギュレーションの例」を参照してください。

前提条件

始める前に、次の事項を確認します。

両方の装置のハードウェア、ソフトウェア コンフィギュレーション、必要なライセンスが同じである。

両方の装置が同じモードである(シングルまたはマルチ、透過またはルーテッド)。

ケーブルベースの Active/Standby フェールオーバーの設定(PIX セキュリティ アプライアンスのみ)

次の手順に従って、シリアル ケーブルをフェールオーバー リンクとして使用して Active/Standby フェールオーバーを設定します。このタスクのコマンドは、フェールオーバー ペアの プライマリ 装置で入力します。プライマリ装置は、ケーブルの「Primary」と表記された側が接続されている装置です。マルチコンテキスト モードの装置では、特に注記がない限り、システム実行スペースでコマンドを入力します。

ケーブルベースのフェールオーバーを使用する場合、フェールオーバー ペアのセカンダリ装置をブートストラップする必要はありません。指示があるまで、セカンダリ装置の電源はオフのままにします。

ケーブルベースのフェールオーバーは、PIX セキュリティ アプライアンス プラットフォームでのみ使用できます。

ケーブルベースの Active/Standby フェールオーバーを設定するには、次の手順を実行します。


ステップ 1 フェールオーバー ケーブルを PIX セキュリティ アプライアンスに接続します。必ず「Primary」とマークされているケーブルの端をプライマリ装置として使用する装置に接続し、「Secondary」とマークされているケーブルの端をもう一方の装置に接続します。

ステップ 2 プライマリ装置の電源を投入します。

ステップ 3 まだ行っていない場合、各インターフェイス(ルーテッド モード)または管理インターフェイス(透過モード)のアクティブおよびスタンバイ IP アドレスを設定します。スタンバイ IP アドレスは、現在スタンバイ装置になっているセキュリティ アプライアンスで使用します。アクティブ IP アドレスと同じサブネットである必要があります。


) 専用インターフェイスでステートフル フェールオーバーを使用する場合は、ステートフル フェールオーバー リンクの IP アドレスは設定しないでください。


hostname(config-if)# ip address active_addr netmask standby standby_addr
 

) マルチコンテキスト モードでは、各コンテキストからインターフェイス アドレスを設定する必要があります。changeto context コマンドを使用して、コンテキストを切り替えます。コマンド プロンプトが hostname/context(config-if)# に変わります。ここで、context は、現在のコンテキスト名です。


ステップ 4 (オプション)ステートフル フェールオーバーをイネーブルにするには、ステートフル フェールオーバー リンクを設定します。

a. ステートフル フェールオーバー リンクとして使用するインターフェイスを指定します。

hostname(config)# failover link if_name phy_if
 

if_name 引数は、 phy_if 引数で指定されたインターフェイスに論理名を割り当てます。 phy_if 引数は、物理ポート名(Ethernet1 など)にすることも、すでに作成されているサブインターフェイス(Ethernet0/2.3 など)にすることもできます。このインターフェイスは、他の目的に使用しないでください。

b. アクティブおよびスタンバイ IP アドレスをステートフル フェールオーバー リンクに割り当てます。

hostname(config)# failover interface ip if_name ip_addr mask standby ip_addr
 

) ステートフル フェールオーバー リンクがデータ インターフェイスを使用する場合は、このステップをスキップします。インターフェイスのアクティブおよびスタンバイ IP アドレスは、すでに定義しています。


スタンバイ IP アドレスは、アクティブ IP アドレスと同じサブネットである必要があります。スタンバイ IP アドレスのサブネット マスクを指定する必要はありません。

ステートフル フェールオーバー リンク IP アドレスおよび MAC アドレスは、データ インターフェイスを使用しない限り、フェールオーバー時に変更されません。アクティブ IP アドレスは、常にプライマリ装置にあります。スタンバイ IP アドレスは、セカンダリ装置にあります。

c. インターフェイスをイネーブルにします。

hostname(config)# interface phy_if
hostname(config-if)# no shutdown
 

ステップ 5 フェールオーバーをイネーブルにします。

hostname(config)# failover
 

ステップ 6 セカンダリ装置の電源を投入し、まだイネーブルにしていない場合、装置でフェールオーバーをイネーブルにします。

hostname(config)# failover
 

実行メモリのコンフィギュレーションがアクティブ装置からスタンバイ装置に送信されます。コンフィギュレーションが同期すると、メッセージ「Beginning configuration replication: sending to mate」および「End Configuration Replication to mate」がプライマリ コンソールに表示されます。

ステップ 7 コンフィギュレーションをプライマリ装置のフラッシュ メモリに保存します。プライマリ装置で入力されたコマンドはセカンダリ装置に複製されるため、セカンダリ装置もコンフィギュレーションをフラッシュ メモリに保存します。

hostname(config)# copy running-config startup-config
 


 

LAN ベースの Active/Standby フェールオーバーの設定

ここでは、イーサネット フェールオーバー リンクを使用して Active/Standby フェールオーバーを設定する方法について説明します。LAN ベースのフェールオーバーを設定するときは、セカンダリ装置がプライマリ装置から実行コンフィギュレーションを取得する前に、セカンダリ装置をブートストラップしてフェールオーバー リンクを認識させる必要があります。


) ケーブルベースのフェールオーバーから LAN ベースのフェールオーバーに変更する場合、ケーブルベースのフェールオーバー コンフィギュレーションで完了しているステップ(各インターフェイスのアクティブ IP アドレスおよびスタンバイ IP アドレスの割り当てなど)はスキップできます。


ここでは、次の項目について説明します。

「プライマリ装置の設定」

「セカンダリ装置の設定」

プライマリ装置の設定

次の手順に従って、LAN ベースの Active/Standby フェールオーバー コンフィギュレーションのプライマリ装置を設定します。この手順では、プライマリ装置でフェールオーバーをイネーブルにするために必要な最小のコンフィギュレーションが用意されています。マルチコンテキスト モードでは、特に注記がない限り、手順はすべてシステム実行スペースで実行します。

Active/Standby フェールオーバー ペアのプライマリ装置を設定するには、次の手順を実行します。


ステップ 1 まだ行っていない場合、各インターフェイス(ルーテッド モード)または管理インターフェイス(透過モード)のアクティブおよびスタンバイ IP アドレスを設定します。スタンバイ IP アドレスは、現在スタンバイ装置になっているセキュリティ アプライアンスで使用します。アクティブ IP アドレスと同じサブネットである必要があります。


) 専用のステートフル フェールオーバー リンクを使用する場合は、フェールオーバー リンクの IP アドレスもステートフル フェールオーバー リンクの IP アドレスも設定しないでください。


hostname(config-if)# ip address active_addr netmask standby standby_addr
 

) マルチコンテキスト モードでは、各コンテキストからインターフェイス アドレスを設定する必要があります。changeto context コマンドを使用して、コンテキストを切り替えます。コマンド プロンプトが hostname/context(config-if)# に変わります。ここで、context は、現在のコンテキスト名です。


ステップ 2 (PIX セキュリティ アプライアンス プラットフォームのみ)LAN ベースのフェールオーバーをイネーブルにします。

hostname(config)# failover lan enable
 

ステップ 3 装置をプライマリ装置に指定します。

hostname(config)# failover lan unit primary
 

ステップ 4 フェールオーバー インターフェイスを定義します。

a. フェールオーバー インターフェイスとして使用するインターフェイスを指定します。

hostname(config)# failover lan interface if_name phy_if
 

if_name 引数は、 phy_if 引数で指定されたインターフェイスに名前を割り当てます。 phy_if 引数は、物理ポート名(Ethernet1 など)にすることも、すでに作成されているサブインターフェイス(Ethernet0/2.3 など)にすることもできます。

b. アクティブおよびスタンバイ IP アドレスをフェールオーバー リンクに割り当てます。

hostname(config)# failover interface ip if_name ip_addr mask standby ip_addr
 

スタンバイ IP アドレスは、アクティブ IP アドレスと同じサブネットである必要があります。スタンバイ アドレスのサブネット マスクを指定する必要はありません。

フェールオーバー リンクの IP アドレスおよび MAC アドレスは、フェールオーバー時に変更されません。フェールオーバー リンクのアクティブ IP アドレスは、常にプライマリ装置にあります。スタンバイ IP アドレスは、セカンダリ装置にあります。

c. インターフェイスをイネーブルにします。

hostname(config)# interface phy_if
hostname(config-if)# no shutdown
 

ステップ 5 (オプション)ステートフル フェールオーバーをイネーブルにするには、ステートフル フェールオーバー リンクを設定します。

a. ステートフル フェールオーバー リンクとして使用するインターフェイスを指定します。

hostname(config)# failover link if_name phy_if

) ステートフル フェールオーバー リンクがフェールオーバー リンクまたはデータ インターフェイスを使用する場合は、if_name 引数を指定することだけが必要です。


if_name 引数は、 phy_if 引数で指定されたインターフェイスに論理名を割り当てます。 phy_if 引数は、物理ポート名(Ethernet1 など)にすることも、すでに作成されているサブインターフェイス(Ethernet0/2.3 など)にすることもできます。このインターフェイスは、他の目的に使用しないでください(オプションのフェールオーバー リンクは除く)。

b. アクティブおよびスタンバイ IP アドレスをステートフル フェールオーバー リンクに割り当てます。


) ステートフル フェールオーバー リンクがフェールオーバー リンクまたはデータ インターフェイスを使用する場合は、このステップをスキップします。インターフェイスのアクティブおよびスタンバイ IP アドレスは、すでに定義しています。


hostname(config)# failover interface ip if_name ip_addr mask standby ip_addr
 

スタンバイ IP アドレスは、アクティブ IP アドレスと同じサブネットである必要があります。スタンバイ アドレスのサブネット マスクを指定する必要はありません。

ステートフル フェールオーバー リンク IP アドレスおよび MAC アドレスは、データ インターフェイスを使用しない限り、フェールオーバー時に変更されません。アクティブ IP アドレスは、常にプライマリ装置にあります。スタンバイ IP アドレスは、セカンダリ装置にあります。

c. インターフェイスをイネーブルにします。


) ステートフル フェールオーバー リンクがフェールオーバー リンクまたはデータ インターフェイスを使用する場合は、このステップをスキップします。インターフェイスは、すでにイネーブルです。


hostname(config)# interface phy_if
hostname(config-if)# no shutdown
 

ステップ 6 フェールオーバーをイネーブルにします。

hostname(config)# failover
 

ステップ 7 システム コンフィギュレーションをフラッシュ メモリに保存します。

hostname(config)# copy running-config startup-config
 


 

セカンダリ装置の設定

セカンダリ装置に必要なコンフィギュレーションは、フェールオーバー インターフェイス用のコンフィギュレーションのみです。セカンダリ装置には、プライマリ装置と初期に通信するために、これらのコマンドが必要です。プライマリ装置がセカンダリ装置にコンフィギュレーションを送信した後、2 つのコンフィギュレーション間で唯一、不変の相違点は failover lan unit コマンドです。このコマンドで各装置がプライマリかセカンダリかを識別します。

マルチコンテキスト モードでは、特に注記がない限り、手順はすべてシステム実行スペースで実行します。

セカンダリ装置を設定するには、次の手順を実行します。


ステップ 1 (PIX セキュリティ アプライアンス プラットフォームのみ)LAN ベースのフェールオーバーをイネーブルにします。

hostname(config)# failover lan enable
 

ステップ 2 フェールオーバー インターフェイスを定義します。プライマリ装置に使用している設定と同じ設定を使用します。

a. フェールオーバー インターフェイスとして使用するインターフェイスを指定します。

hostname(config)# failover lan interface if_name phy_if
 

if_name 引数は、 phy_if 引数で指定されたインターフェイスに名前を割り当てます。

b. アクティブおよびスタンバイ IP アドレスをフェールオーバー リンクに割り当てます。

hostname(config)# failover interface ip if_name ip_addr mask standby ip_addr

) プライマリ装置にフェールオーバー インターフェイスを設定する場合、プライマリ装置でこのコマンドを入力するときは、正確に入力してください。


c. インターフェイスをイネーブルにします。

hostname(config)# interface phy_if
hostname(config-if)# no shutdown
 

ステップ 3 (オプション)この装置をセカンダリ装置に指定します。

hostname(config)# failover lan unit secondary

) 以前に設定されていない場合、装置はデフォルトでセカンダリに指定されているので、このステップはオプションです。


ステップ 4 フェールオーバーをイネーブルにします。

hostname(config)# failover
 

フェールオーバーをイネーブルにすると、実行メモリのコンフィギュレーションがアクティブ装置からスタンバイ装置に送信されます。コンフィギュレーションが同期すると、メッセージ「Beginning configuration replication: Sending to mate」および「End Configuration Replication to mate」がアクティブ装置のコンソールに表示されます。

ステップ 5 実行コンフィギュレーションの複製が完了したら、そのコンフィギュレーションをフラッシュ メモリに保存します。

hostname(config)# copy running-config startup-config
 


 

オプションの Active/Standby フェールオーバー設定値の設定

次のオプションの Active/Standby フェールオーバー設定値は、最初にフェールオーバーを設定するときでも、フェールオーバーがすでに設定された後でも設定できます。特に注記がない限り、コマンドはアクティブ装置で入力する必要があります。

ここでは、次の項目について説明します。

「ステートフル フェールオーバーでの HTTP 複製のイネーブル化」

「インターフェイス モニタリングのディセーブル化とイネーブル化」

「インターフェイスと装置のポーリング時間の設定」

「フェールオーバー基準の設定」

「仮想 MAC アドレスの設定」

ステートフル フェールオーバーでの HTTP 複製のイネーブル化

HTTP 接続がステート情報複製に含まれるようにするには、HTTP 複製をイネーブルにする必要があります。HTTP 接続は通常は存続期間が短く、HTTP クライアントは接続試行が失敗すると通常は再試行するため、HTTP 接続は複製されるステート情報に自動的には含まれません。

次のコマンドをグローバル コンフィギュレーション モードで入力して、ステートフル フェールオーバーがイネーブル状態の場合に、HTTP ステート複製をイネーブルにします。

hostname(config)# failover replication http
 

インターフェイス モニタリングのディセーブル化とイネーブル化

デフォルトでは、物理インターフェイスのモニタリングはイネーブルに、サブインターフェイスのモニタリングはディセーブルになっています。1 台の装置で最大 250 のインターフェイスを監視できます。特定のインターフェイスのモニタリングをディセーブルにし、別のモニタリングをイネーブルにすることで、フェールオーバー ポリシーに影響を与えるインターフェイスを制御できます。これによって、重要度の低いネットワークに接続されているインターフェイスがフェールオーバー ポリシーに影響を与えないようにできます。

マルチコンフィギュレーション モードの装置の場合は、次のコマンドを使用して特定のインターフェイスのヘルス モニタリングをイネーブルまたはディセーブルにします。

インターフェイスのヘルス モニタリングをディセーブルにするには、コンテキスト内で次のコマンドを入力します。

hostname/context(config)# no monitor-interface if_name
 

インターフェイスのヘルス モニタリングをイネーブルにするには、コンテキスト内で次のコマンドを入力します。

hostname/context(config)# monitor-interface if_name
 

シングルコンフィギュレーション モードの装置の場合は、次のコマンドを使用して特定のインターフェイスのヘルス モニタリングをイネーブルまたはディセーブルにします。

インターフェイスのヘルス モニタリングをディセーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを入力します。

hostname(config)# no monitor-interface if_name
 

インターフェイスのヘルス モニタリングをイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを入力します。

hostname(config)# monitor-interface if_name
 

インターフェイスと装置のポーリング時間の設定

セキュリティ アプライアンスは、フェールオーバーについて装置とインターフェイス両方のヘルスを監視します。インターフェイスと装置のヘルスを監視する場合、hello メッセージの間の時間間隔を設定できます。ポーリング時間を短縮すると、インターフェイスまたは装置の障害をより迅速に検出できますが、多くのシステム リソースを消費します。

インターフェイスのポーリング時間を変更するには、グローバル コンフィギュレーション モードで次のコマンドを入力します。

hostname(config)# failover polltime interface seconds
 

装置のポーリング時間を変更するには、グローバル コンフィギュレーション モードで次のコマンドを入力します。

hostname(config)# failover polltime seconds
 

フェールオーバー基準の設定

デフォルトでは、1 つのインターフェイス障害でフェールオーバーが行われます。インターフェイス数または監視されているインターフェイスの割合を指定して、この数または割合を超えたインターフェイスに障害が発生した場合にフェールオーバーが発生するようにできます。

デフォルトのフェールオーバー基準を変更するには、グローバル コンフィギュレーション モードで次のコマンドを入力します。

hostname(config)# failover interface-policy num[%]
 

インターフェイス数を指定する場合、 num 引数は 1 ~ 250 です。インターフェイスの割合を指定する場合、 num 引数は 1 ~ 100 です。

仮想 MAC アドレスの設定

Active/Standby フェールオーバーでは、プライマリ装置の MAC アドレスは常にアクティブ IP アドレスに関連付けられています。セカンダリ装置は、最初にブートされてアクティブになると、そのインターフェイスの焼き付け済み MAC アドレスを使用します。プライマリ装置がオンラインになると、セカンダリ装置はプライマリ装置から MAC アドレスを取得します。この変更によって、ネットワーク トラフィックが中断することがあります。

各インターフェイスに仮想 MAC アドレスを設定して、セカンダリ装置がプライマリ装置より前にオンラインになっても、セカンダリ装置がアクティブ装置である場合、正しい MAC アドレスを使用するようにします。仮想 MAC アドレスを使用しない場合、フェールオーバー ペアは焼き付け済み NIC アドレスを MAC アドレスとして使用します。


) フェールオーバーまたはステートフル フェールオーバー リンクには、仮想 MAC アドレスは設定できません。これらのリンクの MAC アドレスおよび IP アドレスは、フェールオーバー中に変更されません。


アクティブ装置で次のコマンドを入力して、インターフェイスの仮想 MAC アドレスを設定します。

hostname(config)# failover mac address phy_if active_mac standby_mac
 

phy_if 引数は、インターフェイスの物理名(Ethernet1 など)です。 active_mac および standby_mac 引数は、H.H.H 形式(H は 16 ビットの 16 進数)の MAC アドレスです。たとえば、MAC アドレス 00-0C-F1-42-4C-DE は、000C.F142.4CDE と入力します。

active_mac アドレスはインターフェイスのアクティブ IP アドレスに関連付けられ、 standby_mac はインターフェイスのスタンバイ IP アドレスに関連付けられます。

Active/Active フェールオーバーの設定

ここでは、Active/Active フェールオーバーの設定方法について説明します。

ここでは、次の項目について説明します。

「前提条件」

「ケーブルベースの Active/Active フェールオーバーの設定(PIX セキュリティ アプライアンスのみ)」

「LAN ベースの Active/ Active フェールオーバーの設定」

「オプションの Active/ Active フェールオーバー設定値の設定」

代表的なフェールオーバー コンフィギュレーションの例については、「フェールオーバー コンフィギュレーションの例」を参照してください。

前提条件

始める前に、次の事項を確認してください。

両方の装置のハードウェア、ソフトウェア コンフィギュレーション、必要なライセンスが同じである。

両方の装置がマルチコンテキスト モードである。

ケーブルベースの Active/Active フェールオーバーの設定(PIX セキュリティ アプライアンスのみ)

次の手順に従って、シリアル ケーブルをフェールオーバー リンクとして使用して Active/ Active フェールオーバーを設定します。このタスクのコマンドは、フェールオーバー ペアの プライマリ 装置で入力します。プライマリ装置は、ケーブルの「Primary」と表記された側が接続されている装置です。マルチコンテキスト モードの装置では、特に注記がない限り、システム実行スペースでコマンドを入力します。

ケーブルベースのフェールオーバーを使用する場合、フェールオーバー ペアのセカンダリ装置をブートストラップする必要はありません。指示があるまで、セカンダリ装置の電源はオフのままにします。

ケーブルベースのフェールオーバーは、PIX セキュリティ アプライアンス プラットフォームでのみ使用できます。

ケーブルベースの Active/ Active フェールオーバーを設定するには、次の手順を実行します。


ステップ 1 フェールオーバー ケーブルを PIX セキュリティ アプライアンスに接続します。必ず「Primary」とマークされているケーブルの端をプライマリ装置として使用する装置に接続し、「Secondary」とマークされている端をセカンダリ装置として使用する装置に接続します。

ステップ 2 プライマリ装置の電源を投入します。

ステップ 3 まだ行っていない場合、各インターフェイス(ルーテッド モード)または管理インターフェイス(透過モード)のアクティブおよびスタンバイ IP アドレスを設定します。スタンバイ IP アドレスは、現在スタンバイ装置になっているセキュリティ アプライアンスで使用します。アクティブ IP アドレスと同じサブネットである必要があります。


) 専用のステートフル フェールオーバー インターフェイスを使用する場合は、ステートフル フェールオーバー リンクの IP アドレスは設定しないでください。


hostname(config-if)# ip address active_addr netmask standby standby_addr

) マルチコンテキスト モードでは、各コンテキストからインターフェイス アドレスを設定する必要があります。changeto context コマンドを使用して、コンテキストを切り替えます。コマンド プロンプトが hostname/context(config-if)# に変わります。ここで、context は、現在のコンテキスト名です。


ステップ 4 (オプション)ステートフル フェールオーバーをイネーブルにするには、ステートフル フェールオーバー リンクを設定します。

a. ステートフル フェールオーバー リンクとして使用するインターフェイスを指定します。

hostname(config)# failover link if_name phy_if
 

if_name 引数は、 phy_if 引数で指定されたインターフェイスに論理名を割り当てます。 phy_if 引数は、物理ポート名(Ethernet1 など)にすることも、すでに作成されているサブインターフェイス(Ethernet0/2.3 など)にすることもできます。このインターフェイスは、他の目的に使用しないでください(オプションのフェールオーバー リンクは除く)。

b. アクティブおよびスタンバイ IP アドレスをステートフル フェールオーバー リンクに割り当てます。

hostname(config)# failover interface ip if_name ip_addr mask standby ip_addr
 

スタンバイ IP アドレスは、アクティブ IP アドレスと同じサブネットである必要があります。スタンバイ IP アドレスのサブネット マスクを指定する必要はありません。

ステートフル フェールオーバー リンクの IP アドレスおよび MAC アドレスは、ステートフル フェールオーバーで標準データ インターフェイスを使用する場合を除き、フェールオーバー時に変更されません。アクティブ IP アドレスは、常にプライマリ装置にあります。スタンバイ IP アドレスは、セカンダリ装置にあります。

c. インターフェイスをイネーブルにします。

hostname(config)# interface phy_if
hostname(config-if)# no shutdown
 

ステップ 5 フェールオーバー グループを設定します。最大 2 つのフェールオーバー グループを使用できます。 failover group コマンドは、指定されたフェールオーバー グループが存在しない場合はこれを作成し、フェールオーバー グループ コンフィギュレーション モードに移行します。

フェールオーバー グループごとに primary または secondary コマンドを使用して、フェールオーバー グループがプライマリ プリファレンスとセカンダリ プリファレンスのどちらを持つかを指定する必要があります。同じプリファレンスを両方のフェールオーバー グループに割り当てることができます。ロードバランシング コンフィギュレーションの場合は、各フェールオーバー グループに異なる装置プリファレンスを割り当てる必要があります。

次の例では、フェールオーバー グループ 1 にプライマリ プリファレンスを、フェールオーバー グループ 2 にセカンダリ プリファレンスを割り当てます。

hostname(config)# failover group 1
hostname(config-fover-group)# primary
hostname(config-fover-group)# exit
hostname(config)# failover group 2
hostname(config-fover-group)# secondary
hostname(config-fover-group)# exit
 

ステップ 6 コンテキスト コンフィギュレーション モードで join-failover-group コマンドを使用して、各ユーザ コンテキストをフェールオーバー グループに割り当てます。

割り当てられていないコンテキストは、自動的にフェールオーバー グループ 1 に割り当てられます。管理コンテキストは、常にフェールオーバー グループ 1 のメンバです。

次のコマンドを入力して、各コンテキストをフェールオーバー グループに割り当てます。

hostname(config)# context context_name
hostname(config-context)# join-failover-group {1 | 2}
hostname(config-context)# exit
 

ステップ 7 フェールオーバーをイネーブルにします。

hostname(config)# failover
 

ステップ 8 セカンダリ装置の電源を投入し、まだイネーブルにしていない場合、装置でフェールオーバーをイネーブルにします。

hostname(config)# failover
 

実行メモリのコンフィギュレーションがアクティブ装置からスタンバイ装置に送信されます。コンフィギュレーションが同期すると、メッセージ「Beginning configuration replication: Sending to mate」および「End Configuration Replication to mate」がプライマリ コンソールに表示されます。

ステップ 9 コンフィギュレーションをプライマリ装置のフラッシュ メモリに保存します。プライマリ装置で入力されたコマンドはセカンダリ装置に複製されるため、セカンダリ装置もコンフィギュレーションをフラッシュ メモリに保存します。

hostname(config)# copy running-config startup-config
 

ステップ 10 必要に応じて、プライマリ装置でアクティブなフェールオーバー グループすべてを強制的にセカンダリ装置でアクティブ状態にします。フェールオーバー グループを強制的にセカンダリ装置でアクティブにするには、プライマリ装置のシステム実行スペースで次のコマンドを入力します。

hostname# no failover active group group_id
 

group_id 引数は、セカンダリ装置でアクティブにするグループを指定します。


 

LAN ベースの Active/ Active フェールオーバーの設定

ここでは、イーサネット フェールオーバー リンクを使用して Active/ Active フェールオーバーを設定する方法について説明します。LAN ベースのフェールオーバーを設定するときは、セカンダリ装置がプライマリ装置から実行コンフィギュレーションを取得する前に、セカンダリ装置をブートストラップしてフェールオーバー リンクを認識させる必要があります。

ここでは、次の項目について説明します。

「プライマリ装置の設定」

「セカンダリ装置の設定」

プライマリ装置の設定

Active/ Active フェールオーバー コンフィギュレーションのプライマリ装置を設定するには、次の手順を実行します。


ステップ 1 基本フェールオーバー パラメータをシステム実行スペースで設定します。

a. (PIX セキュリティ アプライアンス プラットフォームのみ)LAN ベースのフェールオーバーをイネーブルにします。

hostname(config)# hostname(config)# failover lan enable
 

b. 装置をプライマリ装置に指定します。

hostname(config)# failover lan unit primary
 

c. フェールオーバー リンクを指定します。

hostname(config)# failover lan interface if_name phy_if
 

if_name 引数は、 phy_if 引数で指定されたインターフェイスに論理名を割り当てます。 phy_if 引数は、物理ポート名(Ethernet1 など)にすることも、すでに作成されているサブインターフェイス(Ethernet0/2.3 など)にすることもできます。このインターフェイスは、他の目的に使用しないでください(オプションのステートフル フェールオーバー リンクは除く)。

d. フェールオーバー リンクのアクティブ IP アドレスおよびスタンバイ IP アドレスを指定します。

hostname(config)# failover interface ip if_name ip_addr mask standby ip_addr
 

スタンバイ IP アドレスは、アクティブ IP アドレスと同じサブネットである必要があります。スタンバイ IP アドレスのサブネット マスクを指定する必要はありません。フェールオーバー リンクの IP アドレスおよび MAC アドレスは、フェールオーバー時に変更されません。アクティブ IP アドレスは、常にプライマリ装置にあります。スタンバイ IP アドレスは、セカンダリ装置にあります。

ステップ 2 (オプション)ステートフル フェールオーバーをイネーブルにするには、ステートフル フェールオーバー リンクを設定します。

a. ステートフル フェールオーバー リンクとして使用するインターフェイスを指定します。

hostname(config)# failover link if_name phy_if
 

if_name 引数は、 phy_if 引数で指定されたインターフェイスに論理名を割り当てます。 phy_if 引数は、物理ポート名(Ethernet1 など)にすることも、すでに作成されているサブインターフェイス(Ethernet0/2.3 など)にすることもできます。このインターフェイスは、他の目的に使用しないでください(オプションのフェールオーバー リンクは除く)。


) ステートフル フェールオーバー リンクがフェールオーバー リンクまたは標準データ インターフェイスを使用する場合は、if_name 引数を指定することだけが必要です。


b. アクティブおよびスタンバイ IP アドレスをステートフル フェールオーバー リンクに割り当てます。


) ステートフル フェールオーバー リンクがフェールオーバー リンクまたは標準データ インターフェイスを使用する場合は、このステップをスキップします。インターフェイスのアクティブおよびスタンバイ IP アドレスは、すでに定義しています。


hostname(config)# failover interface ip if_name ip_addr mask standby ip_addr
 

スタンバイ IP アドレスは、アクティブ IP アドレスと同じサブネットである必要があります。スタンバイ アドレスのサブネット マスクを指定する必要はありません。

状態リンクの IP アドレスおよび MAC アドレスは、フェールオーバー時に変更されません。アクティブ IP アドレスは、常にプライマリ装置にあります。スタンバイ IP アドレスは、セカンダリ装置にあります。

c. インターフェイスをイネーブルにします。


) ステートフル フェールオーバー リンクがフェールオーバー リンクまたは標準データ インターフェイスを使用する場合は、このステップをスキップします。インターフェイスは、すでにイネーブルです。


hostname(config)# interface phy_if
hostname(config-if)# no shutdown
 

ステップ 3 フェールオーバー グループを設定します。最大 2 つのフェールオーバー グループを使用できます。 failover group コマンドは、指定されたフェールオーバー グループが存在しない場合はこれを作成し、フェールオーバー グループ コンフィギュレーション モードに移行します。

フェールオーバー グループごとに primary または secondary コマンドを使用して、フェールオーバー グループがプライマリ プリファレンスとセカンダリ プリファレンスのどちらを持つかを指定する必要があります。同じプリファレンスを両方のフェールオーバー グループに割り当てることができます。ロードバランシング コンフィギュレーションの場合は、各フェールオーバー グループに異なる装置プリファレンスを割り当てる必要があります。

次の例では、フェールオーバー グループ 1 にプライマリ プリファレンスを、フェールオーバー グループ 2 にセカンダリ プリファレンスを割り当てます。

hostname(config)# failover group 1
hostname(config-fover-group)# primary
hostname(config-fover-group)# exit
hostname(config)# failover group 2
hostname(config-fover-group)# secondary
hostname(config-fover-group)# exit
 

ステップ 4 コンテキスト コンフィギュレーション モードで join-failover-group コマンドを使用して、各ユーザ コンテキストをフェールオーバー グループに割り当てます。

割り当てられていないコンテキストは、自動的にフェールオーバー グループ 1 に割り当てられます。管理コンテキストは、常にフェールオーバー グループ 1 のメンバです。

次のコマンドを入力して、各コンテキストをフェールオーバー グループに割り当てます。

hostname(config)# context context_name
hostname(config-context)# join-failover-group {1 | 2}
hostname(config-context)# exit
 

ステップ 5 フェールオーバーをイネーブルにします。

hostname(config)# failover
 


 

セカンダリ装置の設定

LAN ベースの Active/Active フェールオーバーを設定するときは、セカンダリ装置をブートストラップしてフェールオーバー リンクを認識させる必要があります。その結果、セカンダリ装置は、プライマリ装置と通信して、実行コンフィギュレーションを受信できるようになります。

Active/ Active フェールオーバー コンフィギュレーションのセカンダリ装置をブートストラップするには、次の手順を実行します。


ステップ 1 (PIX セキュリティ アプライアンス プラットフォームのみ)LAN ベースのフェールオーバーをイネーブルにします。

hostname(config)# failover lan enable
 

ステップ 2 フェールオーバー インターフェイスを定義します。プライマリ装置に使用している設定と同じ設定を使用します。

a. フェールオーバー インターフェイスとして使用するインターフェイスを指定します。

hostname(config)# failover lan interface if_name phy_if
 

if_name 引数は、 phy_if 引数で指定されたインターフェイスに論理名を割り当てます。 phy_if 引数は、物理ポート名(Ethernet1 など)にすることも、すでに作成されているサブインターフェイス(Ethernet0/2.3 など)にすることもできます。

b. アクティブおよびスタンバイ IP アドレスをフェールオーバー リンクに割り当てます。

hostname(config)# failover interface ip if_name ip_addr mask standby ip_addr
 

) フェールオーバー インターフェイスを設定する場合、プライマリ装置でこのコマンドを入力するときは、正確に入力してください。


スタンバイ IP アドレスは、アクティブ IP アドレスと同じサブネットである必要があります。スタンバイ アドレスのサブネット マスクを指定する必要はありません。

c. インターフェイスをイネーブルにします。

hostname(config)# interface phy_if
hostname(config-if)# no shutdown
 

ステップ 3 (オプション)この装置をセカンダリ装置に指定します。

hostname(config)# failover lan unit secondary
 

) 前に別の設定がされていない限り、装置はデフォルトでセカンダリに指定されているので、このステップはオプションです。


ステップ 4 フェールオーバーをイネーブルにします。

hostname(config)# failover
 

フェールオーバーをイネーブルにすると、実行メモリのコンフィギュレーションがアクティブ装置からスタンバイ装置に送信されます。コンフィギュレーションが同期すると、メッセージ「 Beginning configuration replication: Sending to mate 」および「 End Configuration Replication to mate 」がアクティブ装置のコンソールに表示されます。

ステップ 5 実行コンフィギュレーションの複製が完了したら、次のコマンドを入力してそのコンフィギュレーションをフラッシュ メモリに保存します。

hostname(config)# copy running-config startup-config
 

ステップ 6 必要に応じて、プライマリ装置でアクティブなフェールオーバー グループすべてを強制的にセカンダリ装置でアクティブ状態にします。フェールオーバー グループを強制的にセカンダリ装置でアクティブにするには、プライマリ装置のシステム実行スペースで次のコマンドを入力します。

hostname# no failover active group group_id
 

group_id 引数は、セカンダリ装置でアクティブにするグループを指定します。


 

オプションの Active/ Active フェールオーバー設定値の設定

次のオプションの Active/Active フェールオーバー設定値は、最初にフェールオーバーを設定するときでも、フェールオーバーがすでに設定された後でも設定できます。特に注記がない限り、コマンドは、フェールオーバー グループ 1 がアクティブ状態の装置で入力する必要があります。

ここでは、次の項目について説明します。

「フェールオーバー グループのプリエンプションの設定」

「ステートフル フェールオーバーでの HTTP 複製のイネーブル化」

「インターフェイス モニタリングのディセーブル化とイネーブル化」

「インターフェイスと装置のポーリング時間の設定」

「フェールオーバー基準の設定」

「仮想 MAC アドレスの設定」

「非対称ルーティングのサポートの設定」

フェールオーバー グループのプリエンプションの設定

プライマリまたはセカンダリの優先順位をフェールオーバー グループに割り当てると、両方の装置が同時にブートされるときに、フェールオーバー グループがどの装置上でアクティブになるかが指定されます。しかし、ある装置がもう一方の装置よりも先にブートした場合、どちらのフェールオーバー グループもその装置上でアクティブになります。もう一方の装置がオンラインになると、その装置に優先度を認めているフェールオーバー グループはいずれも、その装置ではアクティブになりません。ただし、手動で強制された場合、フェールオーバーが行われた場合、またはそのフェールオーバー グループが preempt コマンドで設定されている場合は除きます。 preempt コマンドによって、フェールオーバー グループは、指定された装置が使用可能になると、その装置で自動的にアクティブになります。

指定されたフェールオーバー グループのプリエンプションを設定するには、次のコマンドを入力します。

hostname(config)# failover group {1 | 2}
hostname(config-fover-group)# preempt [delay]
 

オプションの delay 値に秒数を入力して、その時間フェールオーバー グループが現在の装置でアクティブ状態に維持され、その後に指定された装置で自動的にアクティブになるようにできます。

ステートフル フェールオーバーでの HTTP 複製のイネーブル化

HTTP 接続をステート情報に含めることができるようにするには、HTTP 複製をイネーブルにする必要があります。HTTP 接続は通常は存続期間が短く、HTTP クライアントは接続試行が失敗すると通常は再試行するため、HTTP 接続は複製されるステート情報に自動的には含まれません。 replication http コマンドを使用すると、ステートフル フェールオーバーがイネーブルになっている場合に、フェールオーバー グループに HTTP ステート情報を複製させることができます。

フェールオーバー グループの HTTP ステート複製をイネーブルにするには、次のコマンドを入力します。このコマンドは、設定されているフェールオーバー グループにのみ影響します。両方のフェールオーバー グループの HTTP ステート複製をイネーブルにするには、各グループで次のコマンドを入力する必要があります。次のコマンドは、システム実行スペースで入力する必要があります。

hostname(config)# failover group {1 | 2}
hostname(config-fover-group)# replication http
 

インターフェイス モニタリングのディセーブル化とイネーブル化

1 台の装置で最大 250 のインターフェイスを監視できます。デフォルトでは、物理インターフェイスのモニタリングはイネーブルに、サブインターフェイスのモニタリングはディセーブルになっています。特定のインターフェイスのモニタリングをディセーブルにし、別のモニタリングをイネーブルにすることで、フェールオーバー ポリシーに影響を与えるインターフェイスを制御できます。これによって、重要度の低いネットワークに接続されているインターフェイスがフェールオーバー ポリシーに影響を与えないようにできます。

インターフェイスのヘルス モニタリングをディセーブルにするには、コンテキスト内で次のコマンドを入力します。

hostname/context(config)# no monitor-interface if_name
 

インターフェイスのヘルス モニタリングをイネーブルにするには、コンテキスト内で次のコマンドを入力します。

hostname/context(config)# monitor-interface if_name
 

インターフェイスと装置のポーリング時間の設定

フェールオーバー グループ内のインターフェイスのヘルスを監視する場合、hello メッセージ間の時間間隔を設定できます。インターフェイスのポーリング時間を短縮すると、インターフェイスが故障した場合にフェールオーバーを迅速に行うことができますが、多くのシステム リソースを消費します。

インターフェイスのデフォルトのポーリング時間を変更するには、次のコマンドを入力します。

hostname(config)# failover group {1 | 2}
hostname(config-fover-group)# polltime interface seconds
 

装置のポーリング時間は、ピア装置のヘルスを判断するために、フェールオーバー リンク全体に送信される hello メッセージ間の時間間隔を指定します。装置のポーリング時間を短縮すると、障害の発生した装置をより迅速に検出できますが、多くのシステム リソースを消費します。装置のポーリング時間を変更するには、システム実行スペースのグローバル コンフィギュレーション モードで次のコマンドを入力します。

hostname(config)# failover polltime seconds
 

フェールオーバー基準の設定

デフォルトでは、1 つのインターフェイス障害でフェールオーバーが行われます。インターフェイス数または監視されているインターフェイスの割合を指定して、この数または割合を超えたインターフェイスに障害が発生した場合にフェールオーバーが発生するようにできます。フェールオーバー基準は、フェールオーバー グループごとに指定されます。

指定されたフェールオーバー グループのデフォルト フェールオーバー基準を変更するには、次のコマンドを入力します。

hostname(config)# failover group {1 | 2}
hostname(config-fover-group)# interface-policy num[%]
 

インターフェイス数を指定する場合、 num 引数は 1 ~ 250 です。インターフェイスの割合を指定する場合、 num 引数は 1 ~ 100 です。

仮想 MAC アドレスの設定

Active/Active フェールオーバーでは、すべてのインターフェイスで仮想 MAC アドレスを使用します。仮想 MAC アドレスを指定しない場合は、次のように計算されます。

アクティブ装置のデフォルト MAC アドレス:00a0.c9 physical_port_number . failover_group_id 01

スタンバイ装置のデフォルト MAC アドレス:00a0.c9 physical_port_number . failover_group_id 02


同じネットワーク上に Active/Active フェールオーバー ペアが複数ある場合は、あるペアのインターフェイスに割り当てられているものと同じデフォルト仮想 MAC アドレスが、他のペアのインターフェイスに割り当てられることがあります。これは、デフォルト仮想 MAC アドレスの決定方法に基づいた動作です。ネットワーク上で MAC アドレスが重複することを回避するには、すべてのフェールオーバー グループに対して、必ず各物理インターフェイスに仮想のアクティブおよびスタンバイ MAC アドレスを割り当てます。


インターフェイスの特定のアクティブおよびスタンバイ MAC アドレスを設定するには、次のコマンドを入力します。

hostname(config)# failover group {1 | 2}
hostname(config-fover-group)# mac address phy_if active_mac standby_mac
 

phy_if 引数は、インターフェイスの物理名(Ethernet1 など)です。 active_mac および standby_mac 引数は、H.H.H 形式(H は 16 ビットの 16 進数)の MAC アドレスです。たとえば、MAC アドレス 00-0C-F1-42-4C-DE は、000C.F142.4CDE と入力します。

active_mac アドレスはインターフェイスのアクティブ IP アドレスに関連付けられ、 standby_mac はインターフェイスのスタンバイ IP アドレスに関連付けられます。

非対称ルーティングのサポートの設定

Active/Active フェールオーバーで動作中の場合、装置は、ピア装置を経由して送信された接続用の返送パケットを受信することがあります。そのパケットを受信するセキュリティ アプライアンスにはそのパケットの接続情報がないために、パケットはドロップされます。これが最もよく発生するのは、Active/Active フェールオーバー ペアのセキュリティ アプライアンス 2 台が異なるサービス プロバイダーに接続されており、発信接続で NAT アドレスが使用されていない場合です。

返送パケットのドロップは、ドロップが発生する可能性のあるインターフェイスで asr-group コマンドを使用することで防止できます。インターフェイスに asr-group コマンドが設定されていると、インターフェイス接続情報がフェールオーバー ピアに送信されます。ピアは、アクティブ接続のないパケットを受信した場合、非同期ルーティング グループ内の他のインターフェイスで対応する接続を探します。受信したパケットのアクティブ接続がピアに存在する場合は、そのパケットおよびその接続向けに受信する他のすべてのものを、その接続がアクティブであるピア装置に、接続が終了するまで転送します。


) 非対称ルーティングのサポートを設定するために asr-group コマンドを使用する方法は、nailed オプションを指定して static コマンドを使用する方法よりも安全です。


次のコマンドを入力して、非対称ルーティングのサポートを設定します。 asr-group コマンドは、セキュリティ コンテキストでのみ使用できます。非対称ルーティングが正しく機能するには、ステートフル フェールオーバーがイネーブルになっている必要があります。

hostname/ctx1(config)# interface phy_if
hostname/ctx1(config-if)# asr-group num
 

num 範囲に有効な値は、1 ~ 32 です。非対称ルーティング グループに参加するインターフェイスそれぞれにコマンドを入力する必要があります。インターフェイスによって転送、受信、またはドロップされた ASR パケットの数を表示するには、 show interface detail コマンドを使用します。

図11-1 に、非対称ルーティングのサポートに対する asr-group コマンドの使用例を示します。

図11-1 ASR の例

 

コンテキスト A が一方の装置でアクティブであり、コンテキスト B がもう一方の装置でアクティブです。各コンテキストには、「外部」という名前のインターフェイスがあります。両方とも asr-group 1 の一部として設定されています。発信トラフィックは、コンテキスト A がアクティブの装置を経由してルーティングされます。しかし、リターン トラフィックは、コンテキスト B がアクティブの装置を経由してルーティングされます。通常、リターン トラフィックは、その装置上にリターン トラフィックに関するセッション情報がないので、ドロップされます。しかし、インターフェイスに asr-group 番号が設定されているので、その装置は、同じ asr-group が割り当てられている他のインターフェイスすべてのセッション情報を参照します。その装置は、コンテキスト A の外部インターフェイスにセッション情報を検出します。コンテキスト A はその装置ではスタンバイ状態であり、リターン トラフィックをコンテキスト A がアクティブである装置に転送します。

トラフィックは、コンテキスト A がスタンバイ状態である装置のコンテキスト A の外部インターフェイスを経由して転送され、コンテキスト A がアクティブ状態である装置のコンテキスト A の外部インターフェイスを経由して返送されます。この転送は、必要に応じて、セッションが終了するまで続行されます。

フェールオーバー通信の認証/暗号化の設定

フェールオーバー ピアの間の通信の暗号化および認証は、共有秘密または 16 進数のキーを指定することによって可能になります。


) PIX セキュリティ アプライアンス プラットフォームの場合、専用のシリアル フェールオーバー ケーブルを使用して装置を接続すると、フェールオーバー リンク経由の通信は、フェールオーバー キーが設定されていても、暗号化されません。フェールオーバー キーでは、LAN ベースのフェールオーバー通信のみが暗号化されます。



注意 フェールオーバー リンクおよびステートフル フェールオーバー リンク経由で送信される情報は、フェールオーバー キーを使用して通信をセキュリティで保護しない限り、すべてクリア テキストで送信されます。VPN トンネルの終端にセキュリティ アプライアンスを使用する場合、この情報には、トンネルの確立に使用されたすべてのユーザ名、パスワード、および事前共有キーが含まれています。この機密データをクリア テキストで転送することは、非常に大きなセキュリティ リスクになる恐れがあります。セキュリティ アプライアンスを使用して VPN トンネルを終端する場合は、フェールオーバー通信をフェールオーバー キーによってセキュリティで保護することをお勧めします。

Active/Standby フェールオーバー ペアのアクティブ装置、または Active/Active フェールオーバー ペアのフェールオーバー グループ 1 がアクティブ状態の装置で次のコマンドを入力します。

hostname(config)# failover key {secret | hex key}
 

secret 引数で、暗号キーの生成に使用される共有秘密を指定します。共有秘密には 1 ~ 63 文字が指定できます。文字としては、数字、英字、句読点のどのような組み合せでも使用できます。 hex key 引数で、16 進暗号キーを指定します。キーは、32 桁の 16 進数文字(0 ~ 9、a ~ f)でなければなりません。


) フェールオーバー キーが、ピア装置に既存のフェールオーバー コンフィギュレーション用のクリア テキストとして複製されるのを防止するには、アクティブ装置(またはフェールオーバー グループ 1 がアクティブ状態の装置のシステム実行スペース)でフェールオーバーをディセーブルにして、両方の装置でフェールオーバー キーを入力し、その後フェールオーバーを再度イネーブルにします。フェールオーバーが再度イネーブルにされると、フェールオーバー通信がそのキーで暗号化されます。


新しい LAN ベースのフェールオーバー コンフィギュレーションの場合、 failover key コマンドはフェールオーバー ペアのブートストラップ コンフィギュレーションの一部でなければなりません。

フェールオーバー コンフィギュレーションの確認

この項では、フェールオーバー コンフィギュレーションを確認する方法について説明します。ここでは、次の項目について説明します。

「show failover コマンドの使用方法」

「監視対象インターフェイスの表示」

「実行コンフィギュレーション内のフェールオーバー コマンドの表示」

「フェールオーバー機能のテスト」

show failover コマンドの使用方法

ここでは、 show failover コマンドの出力について説明します。各装置で、 show failover コマンドを入力してフェールオーバー ステータスを確認できます。表示される情報は、Active/Standby フェールオーバーと Active/Active フェールオーバーのどちらを使用しているかによって決まります。

ここでは、次の項目について説明します。

「show failover:Active/Standby」

「フェールオーバーの表示:Active/Active」

show failover:Active/Standby

次に、Active/Standby フェールオーバーの show failover コマンドの出力例を示します。 表11-4 に、表示される情報についての説明を示します。

hostname# show failover
 
Failover On
Cable status: N/A - LAN-based failover enabled
Failover unit Primary
Failover LAN Interface: fover Ethernet2 (up)
Unit Poll frequency 1 seconds, holdtime 3 seconds
Interface Poll frequency 15 seconds
Interface Policy 1
Monitored Interfaces 2 of 250 maximum
failover replication http
Last Failover at: 22:44:03 UTC Dec 8 2004
This host: Primary - Active
Active time: 13434 (sec)
Interface inside (10.130.9.3): Normal
Interface outside (10.132.9.3): Normal
Other host: Secondary - Standby Ready
Active time: 0 (sec)
Interface inside (10.130.9.4): Normal
Interface outside (10.132.9.4): Normal
 
Stateful Failover Logical Update Statistics
Link : fover Ethernet2 (up)
Stateful Obj xmit xerr rcv rerr
General 1950 0 1733 0
sys cmd 1733 0 1733 0
up time 0 0 0 0
RPC services 0 0 0 0
TCP conn 6 0 0 0
UDP conn 0 0 0 0
ARP tbl 106 0 0 0
Xlate_Timeout 0 0 0 0
VPN IKE upd 15 0 0 0
VPN IPSEC upd 90 0 0 0
VPN CTCP upd 0 0 0 0
VPN SDI upd 0 0 0 0
VPN DHCP upd 0 0 0 0
 
Logical Update Queue Information
Cur Max Total
Recv Q: 0 2 1733
Xmit Q: 0 2 15225
 

マルチコンテキスト モードでは、セキュリティ コンテキストで show failover コマンドを使用して、そのコンテキストのフェールオーバー情報を表示します。この情報は、シングルコンテキスト モードでコマンドを使用した場合に表示される情報に似ています。装置のアクティブ ステータスまたはスタンバイ ステータスを表示する代わりに、コンテキストのアクティブ ステータスまたはスタンバイ ステータスを表示します。 表11-4 に、表示された情報についての説明を示します。

 
Failover On
Last Failover at: 04:03:11 UTC Jan 4 2003
This context: Negotiation
Active time: 1222 (sec)
Interface outside (192.168.5.121): Normal
Interface inside (192.168.0.1): Normal
Peer context: Not Detected
Active time: 0 (sec)
Interface outside (192.168.5.131): Normal
Interface inside (192.168.0.11): Normal
 
Stateful Failover Logical Update Statistics
Status: Configured.
Stateful Obj xmit xerr rcv rerr
RPC services 0 0 0 0
TCP conn 99 0 0 0
UDP conn 0 0 0 0
ARP tbl 22 0 0 0
Xlate_Timeout 0 0 0 0
GTP PDP 0 0 0 0
GTP PDPMCB 0 0 0 0
 

 

表11-4 show failover の表示の説明

フィールド
オプション

Failover

On

Off

Cable status:

Normal:ケーブルは両方の装置に接続されており、両方の装置とも電源が入っています。

My side not connected:シリアル ケーブルがこの装置に接続されていません。ケーブルがもう一方の装置に接続されているかどうかは不明です。

Other side is not connected:シリアル ケーブルはこの装置に接続されていますが、もう一方の装置には接続されていません。

Other side powered off:相手装置の電源がオフになっています。

N/A:LAN ベースのフェールオーバーはイネーブルです。

Failover Unit

Primary または Secondary

Failover LAN Interface

フェールオーバー リンクの論理名または物理名が表示されます。

Unit Poll frequency

hello メッセージがピア装置に送信される間隔の秒数と、装置がフェールオーバー リンクで hello メッセージを受信する待機時間の秒数が表示されます。この秒数を超えて hello メッセージを受信しない場合、ピアに障害が発生したと宣言されます。

Interface Poll frequency

n seconds

failover polltime interface コマンドで設定した秒数です。デフォルトは、15 秒です。

Interface Policy

数または割合が表示されます。この数または割合を超えたインターフェイスが故障すると、フェールオーバーがトリガーされます。

Monitored Interfaces

監視中のインターフェイス数と、監視可能最大インターフェイス数が表示されます。

failover replication http

ステートフル フェールオーバーに対して HTTP ステート複製がイネーブルの場合に表示されます。

Last Failover at:

最後のフェールオーバーの日付と時刻。形式は次のとおりです。

hh : mm : ss UTC DayName Month Day yyyy

UTC(世界標準時)は、GMT(グリニッジ標準時)と同じです。

This host:

Other host:

ホストごとに、次の情報が表示されます。

Primary または Secondary

Active

Standby

Active time:

n (sec)

装置がアクティブ状態にあった時間。この時間は累積です。したがって、スタンバイ装置にも、過去にアクティブであった場合は値が表示されます。

slot x

スロットのモジュールに関する情報、または空。

Interface name ( n . n . n . n ):

インターフェイスごとに、各装置で現在使用している IP アドレス、および次の状態のいずれかが表示されます。

Failed:インターフェイスに障害が発生しました。

No Link:インターフェイスの回線プロトコルがダウンしています。

Normal:インターフェイスが正しく動作しています。

Link Down:インターフェイスは管理上シャットダウンされました。

Unknown:セキュリティ アプライアンスがインターフェイスのステータスを判別できません。

Waiting:相手装置のネットワーク インターフェイスの監視はまだ開始されていません。

Stateful Failover Logical Update Statistics

次のフィールドは、ステートフル フェールオーバー機能に関係します。Link フィールドにインターフェイス名が表示されている場合、ステートフル フェールオーバー統計情報が表示されます。

Link

interface_name :ステートフル フェールオーバー リンクに使用するインターフェイス。

Unconfigured:ステートフル フェールオーバーを使用していません。

up:インターフェイスは実行中で、機能しています。

down:インターフェイスは管理上シャットダウンされたか、物理的にダウンしています。

failed:インターフェイスに障害が発生し、ステートフル データが渡されていません。

Stateful Obj

各フィールド型で、次の統計情報が表示されます。これらは、2 台の装置の間で送信されたステート情報パケットのカウンタです。フィールドは必ずしも、装置を通過するアクティブな接続を示すわけではありません。

xmit:相手装置に送信されたパケットの数

xerr:相手装置にパケットを送信中に発生したエラーの数

rcv:受信されたパケットの数

rerr:相手装置からパケットを受信中に発生したエラーの数

General

ステートフル オブジェクトの総数。

sys cmd

論理更新システム コマンド(LOGIN、Stay Alive など)。

up time

アップタイム(アクティブ装置がスタンバイ装置に渡す値)。

RPC services

Remote Procedure Call(リモート プロシージャ コール)接続の情報。

TCP conn

TCP 接続の情報。

UDP conn

ダイナミック UDP 接続の情報。

ARP tbl

ダイナミック ARP テーブルの情報。

L2BRIDGE tbl

レイヤ 2 ブリッジ テーブルの情報(透過ファイアウォール モードのみ)。

Xlate_Timeout

接続変換タイムアウトの情報を示します。

VPN IKE upd

IKE 接続の情報。

VPN IPSEC upd

IPSec 接続の情報。

VPN CTCP upd

cTCP トンネル接続の情報。

VPN SDI upd

SDI AAA 接続の情報。

VPN DHCP upd

トンネル DHCP 接続の情報。

GTP PDP

GTP PDP アップデート情報。この情報は、inspect GTP がイネーブルの場合にのみ適用されます。

GTP PDPMCB

GTP PDPMCB アップデート情報。この情報は、inspect GTP がイネーブルの場合にのみ適用されます。

Logical Update Queue Information

各フィールド型で、次の統計情報が使用されます。

Cur:現在のパケット数

Max:最大パケット数

Total:合計パケット数

Recv Q

受信キューのステータス。

Xmit Q

送信キューのステータス。

フェールオーバーの表示:Active/Active

次に、Active/ Active フェールオーバーの show failover コマンドの出力例を示します。 表11-5 に、表示される情報についての説明を示します。

hostname# show failover
 
Failover On
Failover unit Primary
Failover LAN Interface: third GigabitEthernet0/2 (up)
Unit Poll frequency 1 seconds, holdtime 15 seconds
Interface Poll frequency 4 seconds
Interface Policy 1
Monitored Interfaces 8 of 250 maximum
failover replication http
Group 1 last failover at: 13:40:18 UTC Dec 9 2004
Group 2 last failover at: 13:40:06 UTC Dec 9 2004
 
This host: Primary
Group 1 State: Active
Active time: 2896 (sec)
Group 2 State: Standby Ready
Active time: 0 (sec)
 
slot 0: ASA-5530 hw/sw rev (1.0/7.0(0)79) status (Up Sys)
slot 1: SSM-IDS-20 hw/sw rev (1.0/5.0(0.11)S91(0.11)) status (Up)
admin Interface outside (10.132.8.5): Normal
admin Interface third (10.132.9.5): Normal
admin Interface inside (10.130.8.5): Normal
admin Interface fourth (10.130.9.5): Normal
ctx1 Interface outside (10.1.1.1): Normal
ctx1 Interface inside (10.2.2.1): Normal
ctx2 Interface outside (10.3.3.2): Normal
ctx2 Interface inside (10.4.4.2): Normal
 
Other host: Secondary
Group 1 State: Standby Ready
Active time: 190 (sec)
Group 2 State: Active
Active time: 3322 (sec)
 
slot 0: ASA-5530 hw/sw rev (1.0/7.0(0)79) status (Up Sys)
slot 1: SSM-IDS-20 hw/sw rev (1.0/5.0(0.1)S91(0.1)) status (Up)
admin Interface outside (10.132.8.6): Normal
admin Interface third (10.132.9.6): Normal
admin Interface inside (10.130.8.6): Normal
admin Interface fourth (10.130.9.6): Normal
ctx1 Interface outside (10.1.1.2): Normal
ctx1 Interface inside (10.2.2.2): Normal
ctx2 Interface outside (10.3.3.1): Normal
ctx2 Interface inside (10.4.4.1): Normal
 
Stateful Failover Logical Update Statistics
Link : third GigabitEthernet0/2 (up)
Stateful Obj xmit xerr rcv rerr
General 1973 0 1895 0
sys cmd 380 0 380 0
up time 0 0 0 0
RPC services 0 0 0 0
TCP conn 1435 0 1450 0
UDP conn 0 0 0 0
ARP tbl 124 0 65 0
Xlate_Timeout 0 0 0 0
VPN IKE upd 15 0 0 0
VPN IPSEC upd 90 0 0 0
VPN CTCP upd 0 0 0 0
VPN SDI upd 0 0 0 0
VPN DHCP upd 0 0 0 0
 
Logical Update Queue Information
Cur Max Total
Recv Q: 0 1 1895
Xmit Q: 0 0 1940
 

次に、Active/Active フェールオーバーの show failover group コマンドの出力例を示します。表示される情報は show failover コマンドの情報と似ていますが、指定されたグループの情報に限定されています。 表11-5 に、表示される情報についての説明を示します。

 
hostname# show failover group 1
 
Last Failover at: 04:09:59 UTC Jan 4 2005
 
This host: Secondary
State: Active
Active time: 186 (sec)
 
admin Interface outside (192.168.5.121): Normal
admin Interface inside (192.168.0.1): Normal
 
 
Other host: Primary
State: Standby
Active time: 0 (sec)
 
admin Interface outside (192.168.5.131): Normal
admin Interface inside (192.168.0.11): Normal
 
Stateful Failover Logical Update Statistics
Status: Configured.
RPC services 0 0 0 0
TCP conn 33 0 0 0
UDP conn 0 0 0 0
ARP tbl 12 0 0 0
Xlate_Timeout 0 0 0 0
GTP PDP 0 0 0 0
GTP PDPMCB 0 0 0 0
 

 

表11-5 show failover の表示の説明

フィールド
オプション

Failover

On

Off

Failover Unit

Primary または Secondary

Failover LAN Interface

フェールオーバー リンクの論理名または物理名が表示されます。

Unit Poll frequency

hello メッセージがピア装置に送信される間隔の秒数と、装置がフェールオーバー リンクで hello メッセージを受信する待機時間の秒数が表示されます。この秒数を超えて hello メッセージを受信しない場合、ピアに障害が発生したと宣言されます。

Interface Poll frequency

n seconds

failover polltime interface コマンドで設定した秒数です。デフォルトは、15 秒です。

Interface Policy

数または割合が表示されます。この数または割合を超えたインターフェイスが故障すると、フェールオーバーがトリガーされます。

Monitored Interfaces

監視中のインターフェイス数と、監視可能最大インターフェイス数が表示されます。

Group 1 Last Failover at:

Group 2 Last Failover at:

各グループの最後のフェールオーバーの日付と時刻。形式は次のとおりです。

hh : mm : ss UTC DayName Month Day yyyy

UTC(世界標準時)は、GMT(グリニッジ標準時)と同じです。

This host:

Other host:

ホストごとに、次の情報が表示されます。

Role

Primary または Secondary

System State

Active または Standby Ready

アクティブ時間(秒)

Group 1 State

Group 2 State

Active または Standby Ready

アクティブ時間(秒)

slot x

スロットのモジュールに関する情報、または空。

context Interface name ( n . n . n . n ):

インターフェイスごとに、各装置で現在使用している IP アドレス、および次の状態のいずれかが表示されます。

Failed:インターフェイスに障害が発生しました。

No Link:インターフェイスの回線プロトコルがダウンしています。

Normal:インターフェイスが正しく動作しています。

Link Down:インターフェイスは管理上シャットダウンされました。

Unknown:セキュリティ アプライアンスがインターフェイスのステータスを判別できません。

Waiting:相手装置のネットワーク インターフェイスの監視はまだ開始されていません。

Stateful Failover Logical Update Statistics

次のフィールドは、ステートフル フェールオーバー機能に関係します。Link フィールドにインターフェイス名が表示されている場合、ステートフル フェールオーバー統計情報が表示されます。

Link

interface_name :ステートフル フェールオーバー リンクに使用するインターフェイス。

Unconfigured:ステートフル フェールオーバーを使用していません。

up:インターフェイスは実行中で、機能しています。

down:インターフェイスは管理上シャットダウンされたか、物理的にダウンしています。

failed:インターフェイスに障害が発生し、ステートフル データが渡されていません。

Stateful Obj

各フィールド型で、次の統計情報が使用されます。これらは、2 台の装置の間で送信されたステート情報パケットのカウンタです。フィールドは必ずしも、装置を通過するアクティブな接続を示すわけではありません。

xmit:相手装置に送信されたパケットの数

xerr:相手装置にパケットを送信中に発生したエラーの数

rcv:受信されたパケットの数

rerr:相手装置からパケットを受信中に発生したエラーの数

General

ステートフル オブジェクトの総数。

sys cmd

論理更新システム コマンド(LOGIN、Stay Alive など)。

up time

アップタイム(アクティブ装置がスタンバイ装置に渡す値)。

RPC services

Remote Procedure Call(リモート プロシージャ コール)接続の情報。

TCP conn

TCP 接続の情報。

UDP conn

ダイナミック UDP 接続の情報。

ARP tbl

ダイナミック ARP テーブルの情報。

L2BRIDGE tbl

レイヤ 2 ブリッジ テーブルの情報(透過ファイアウォール モードのみ)。

Xlate_Timeout

接続変換タイムアウトの情報を示します。

VPN IKE upd

IKE 接続の情報。

VPN IPSEC upd

IPSec 接続の情報。

VPN CTCP upd

cTCP トンネル接続の情報。

VPN SDI upd

SDI AAA 接続の情報。

VPN DHCP upd

トンネル DHCP 接続の情報。

GTP PDP

GTP PDP アップデート情報。この情報は、inspect GTP がイネーブルの場合にのみ適用されます。

GTP PDPMCB

GTP PDPMCB アップデート情報。この情報は、inspect GTP がイネーブルの場合にのみ適用されます。

Logical Update Queue Information

各フィールド型で、次の統計情報が使用されます。

Cur:現在のパケット数

Max:最大パケット数

Total:合計パケット数

Recv Q

受信キューのステータス。

Xmit Q

送信キューのステータス。

監視対象インターフェイスの表示

監視対象インターフェイスのステータスを表示するには、次のコマンドを入力します。シングルコンテキスト モードの場合は、グローバル コンフィギュレーション モードでこのコマンドを入力します。マルチコンテキスト モードの場合は、コンテキスト内でこのコマンドを入力します。

primary/context(config)# show monitor-interface
 

次に例を示します。

hostname/context(config)# show monitor-interface
This host: Primary - Active
Interface outside (192.168.1.2): Normal
Interface inside (10.1.1.91): Normal
Other host: Secondary - Standby
Interface outside (192.168.1.3): Normal
Interface inside (10.1.1.100): Normal

実行コンフィギュレーション内のフェールオーバー コマンドの表示

実行コンフィギュレーション内のフェールオーバー コマンドを表示するには、次のコマンドを入力します。

hostname(config)# show running-config failover
 

すべてのフェールオーバー コマンドが表示されます。マルチコンテキスト モードで動作中の装置の場合は、システム実行スペースでこのコマンドを入力します。 show running-config all failover を入力すると、実行コンフィギュレーション内のフェールオーバー コマンドが表示され、デフォルト値を変更していないコマンドが含まれています。

フェールオーバー機能のテスト

フェールオーバーの機能をテストするには、次の手順を実行します。


ステップ 1 アクティブ装置またはフェールオーバー グループが、たとえば FTP を使用して予期したとおりにトラフィックを渡して、異なるインターフェイスのホスト間でファイルを送信することをテストします。

ステップ 2 次のコマンドを入力して、スタンバイ装置に強制的にフェールオーバーします。

Active/Standby フェールオーバーの場合は、アクティブ装置で次のコマンドを入力します。

hostname(config)# no failover active
 

Active/Active フェールオーバーの場合は、ホストを接続するインターフェイスを含むフェールオーバー グループがアクティブである装置で、次のコマンドを入力します。

hostname(config)# no failover active group group_id
 

ステップ 3 FTP を使用して、同じ 2 つのホスト間で別のファイルを送信します。

ステップ 4 テストに成功しなかった場合は、 show failover コマンドを入力して、フェールオーバー ステータスをチェックします。

ステップ 5 終了したら、次のコマンドを入力して、装置またはフェールオーバー グループをアクティブ状態に復元できます。

Active/Standby フェールオーバーの場合は、アクティブ装置で次のコマンドを入力します。

hostname(config)# failover active
 

Active/Active フェールオーバーの場合は、ホストを接続するインターフェイスを含むフェールオーバー グループがアクティブである装置で、次のコマンドを入力します。

hostname(config)# failover active group group_id
 


 

フェールオーバーの制御およびモニタリング

ここでは、フェールオーバーの制御方法および監視方法について説明します。ここでは、次の項目について説明します。

「強制フェールオーバー」

「フェールオーバーのディセーブル化」

「故障した装置またはフェールオーバー グループの復元」

「フェールオーバーのモニタリング」

強制フェールオーバー

スタンバイ装置またはフェールオーバー グループを強制的にアクティブにするには、次のいずれかのコマンドを入力します。

Active/Standby フェールオーバーの場合

スタンバイ装置で次のコマンドを入力します。

hostname# failover active
 

アクティブ装置で次のコマンドを入力します。

hostname# no failover active
 

Active/Active フェールオーバーの場合

フェールオーバー グループがスタンバイ状態の装置のシステム実行スペースで、次のコマンドを入力します。

hostname# failover active group group_id
 

または、フェールオーバー グループがアクティブ状態の装置のシステム実行スペースで、次のコマンドを入力します。

hostname# no failover active group group_id
 

システム実行スペースで次のコマンドを入力すると、すべてのフェールオーバー グループがアクティブになります。

hostname# failover active
 

フェールオーバーのディセーブル化

フェールオーバーをディセーブルにするには、次のコマンドを入力します。

hostname(config)# no failover
 

Active/Standby ペアのフェールオーバーをディセーブルにすると、各装置のアクティブおよびスタンバイ状態が、再起動するまで維持されます。たとえば、スタンバイ装置はスタンバイ モードのままなので、両方の装置はトラフィックを渡し始めません。スタンバイ装置をアクティブにするには(フェールオーバーがディセーブル状態でも)、「強制フェールオーバー」を参照してください。

Active/Active ペアのフェールオーバーをディセーブルにすると、どの装置が優先に設定されているかに関係なく、どちらの装置が現在アクティブであっても、アクティブ状態の装置においてフェールオーバー グループがアクティブ状態のままになります。システム実行スペースでは、フェールオーバー コマンドを入力しないでください。

故障した装置またはフェールオーバー グループの復元

故障した装置を故障していない状態に復元するには、次のコマンドを入力します。

hostname(config)# failover reset
 

故障した Active/Active フェールオーバー グループを故障していない状態に復元するには、次のコマンドを入力します。

hostname(config)# failover reset group group_id
 

故障した装置またはグループを故障していない状態にしても自動的にアクティブになりません。復元された装置またはグループは、フェールオーバーによってアクティブにされるまで(強制または通常)、スタンバイ状態のままになっています。例外は、 preempt コマンドで設定されたフェールオーバー グループです。前にアクティブであった場合、フェールオーバー グループは、 preempt コマンドで設定されていて、故障したときの装置が優先設定の装置であると、アクティブになります。

フェールオーバーのモニタリング

フェールオーバーが行われると、両方のセキュリティ アプライアンスからシステム メッセージが送信されます。ここでは、次の項目について説明します。

「フェールオーバー システム メッセージ」

「デバッグ メッセージ」

「SNMP」

フェールオーバー システム メッセージ

セキュリティ アプライアンスは、優先度 2 でフェールオーバーに関連したいくつかのシステム メッセージを発行します。優先度 2 は、クリティカルな状態を示します。これらのメッセージを表示するには、『 Cisco Security Appliance Logging Configuration and System Log Messages 』のロギングのイネーブル化、およびシステム メッセージの説明の表示を参照してください。


) 切り替え中に、フェールオーバーが論理的にシャットダウンされ、その後インターフェイスが起動されて、syslog 411001 および 411002 メッセージが生成されます。これは、正常なアクティビティです。


デバッグ メッセージ

デバッグ メッセージを表示するには、 debug fover コマンドを入力します。詳細については、『 Cisco Security Appliance Command Reference 』を参照してください。


) デバッグ出力は CPU プロセスで高優先順位が割り当てられているため、システム パフォーマンスに大幅に影響することがあります。このため、特定の問題のトラブルシューティングを行う場合や、シスコのテクニカル サポート スタッフとのトラブルシューティング セッションの間に限り debug fover コマンドを使用してください。


SNMP

フェールオーバー用の SNMP syslog トラップを受信するには、SNMP トラップを SNMP 管理ステーションに送信するように SNMP エージェントを設定し、syslog ホストを定義し、Cisco syslog MIB をコンパイルして SNMP 管理ステーションに組み込みます。詳細については、『 Cisco Security Appliance Command Reference 』の snmp-server コマンドおよび logging コマンドのページを参照してください。

フェールオーバー コンフィギュレーションの例

ここでは、コンフィギュレーションおよびネットワーク図のサンプルとして、次の 3 つの例を示します。

「ケーブルベースの Active/Standby フェールオーバーの例」

「LAN ベースの Active/Standby フェールオーバーの例」

「LAN ベースの Active/ Active フェールオーバーの例」

ケーブルベースの Active/Standby フェールオーバーの例

図11-2 に、シリアル フェールオーバー ケーブルを使用したフェールオーバー コンフィギュレーションのネットワーク図を示します。

図11-2 ケーブルベースのフェールオーバー コンフィギュレーション

 

例11-1 に、ケーブルベースのフェールオーバー コンフィギュレーションにおける代表的なコマンドのリストを示します。

例11-1 ケーブルベースのフェールオーバー コンフィギュレーション

interface Ethernet0
nameif outside
speed 100full
ip address 209.165.201.1 255.255.255.224 standby 209.165.201.2
interface Ethernet1
nameif inside
speed 100full
ip address 192.168.2.1 255.255.255.0 standby 192.168.2.2
interface Ethernet2
nameif interface2
security-level 4
no ip address
interface Ethernet3
description STATE Failover Interface
enable password BVKtebKhYT.3gsIp encrypted
passwd iyymOglaKJgF2fx6 encrypted
telnet 192.168.2.45 255.255.255.255
hostname pixfirewall
access-list acl_out permit tcp any host 209.165.201.5 eq 80
failover
failover link state Ethernet3
failover interface ip state 192.168.253.1 255.255.255.252 standby 192.168.253.2
global (outside) 1 209.165.201.3 netmask 255.255.255.224
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 209.165.201.5 192.168.2.5 netmask 255.255.255.255 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 209.165.201.4 1
 

LAN ベースの Active/Standby フェールオーバーの例

図11-3 に、イーサネット フェールオーバー リンクを使用したフェールオーバー コンフィギュレーションのネットワーク図を示します。

図11-3 LAN ベースのフェールオーバー コンフィギュレーション

 

例11-2(プライマリ装置)および 例11-3(セカンダリ装置)に、LAN ベースのフェールオーバー コンフィギュレーションにおける代表的なコマンドのリストを示します。


) フェールオーバー LAN ケーブル コマンドは、PIX セキュリティ アプライアンス でのみ必要です。


例11-2 LAN ベースのフェールオーバー コンフィギュレーション:プライマリ装置

interface Ethernet0
nameif outside
ip address 209.165.201.1 255.255.255.224 standby 209.165.201.2
interface Ethernet1
nameif inside
ip address 192.168.2.1 255.255.255.0 standby 192.168.2.2
interface Ethernet2
description LAN Failover Interface
interface ethernet3
description STATE Failover Interface
enable password BVKtebKhYT.3gsIp encrypted
passwd iyymOglaKJgF2fx6 encrypted
telnet 192.168.2.45 255.255.255.255
hostname pixfirewall
access-list acl_out permit tcp any host 209.165.201.5 eq 80
failover
failover lan unit primary
failover lan interface failover Ethernet2
failover lan enable
failover key ******
failover link state Ethernet3
failover interface ip failover 192.168.254.1 255.255.255.0 standby 192.168.254.2
failover interface ip state 192.168.253.1 255.255.255.0 standby 192.168.253.2
global (outside) 1 209.165.201.3 netmask 255.255.255.224
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 209.165.201.5 192.168.2.5 netmask 255.255.255.255 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 209.165.201.4 1
 
 

例11-3 に、セカンダリ装置のコンフィギュレーションを示します。

例11-3 LAN ベースのフェールオーバー コンフィギュレーション:セカンダリ装置

failover
failover lan unit secondary
failover lan interface failover ethernet2
failover lan enable
failover lan key ******
failover interface ip failover 192.168.254.1 255.255.255.0 standby 192.168.254.2

LAN ベースの Active/ Active フェールオーバーの例

次の例は、Active/Active フェールオーバーの設定方法を示します。この例では、admin と ctx1 という名前の 2 つのコンテキストがあります。図11-4 に、ネットワーク図の例を示します。

図11-4 Active/Active フェールオーバー コンフィギュレーション

 

例11-4 に、システム コンテキストのコンフィギュレーションを示します。例11-5 および 例11-6 に、各コンテキストのコンフィギュレーションを示します。

例11-4 システム コンテキストのコンフィギュレーション

interface Ethernet0
description LAN/STATE Failover Interface
interface Ethernet1
interface Ethernet2
interface Ethernet3
interface Ethernet4
interface Ethernet5
interface Ethernet6
interface Ethernet7
interface Ethernet8
interface Ethernet9
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname ciscopix
boot system flash:/cdisk.bin
ftp mode passive
no pager
failover
failover lan unit primary
failover lan interface folink Ethernet0
failover link folink Ethernet0
failover interface ip folink 10.0.4.1 255.255.255.0 standby 10.0.4.11
failover group 1
primary
preempt
failover group 2
secondary
preempt
no asdm history enable
arp timeout 14400
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02 rpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp
console timeout 0
terminal width 80
 
admin-context admin
context admin
description admin
allocate-interface Ethernet1
allocate-interface Ethernet2
config-url flash:admin.cfg
join-failover-group 1
 
context ctx1
description context 1
allocate-interface Ethernet3
allocate-interface Ethernet4
config-url flash:ctx1.cfg
join-failover-group 2
 
Cryptochecksum:e46a0587966b4c13bf59d7992f994e1e
: end
ciscopix(config)#
 
ciscopix(config)# changeto context admin
ciscopix/admin(config)#
ciscopix/admin(config)# show running-config
: Saved
:

例11-5 admin コンテキストのコンフィギュレーション

interface Ethernet1
nameif outside
security-level 0
ip address 192.168.5.101 255.255.255.0 standby 192.168.5.111
 
interface Ethernet2
nameif inside
security-level 100
ip address 192.168.0.1 255.255.255.0 standby 192.168.0.11
 
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname admin
pager lines 24
mtu outside 1500
mtu inside 1500
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
no vpn-addr-assign local
monitor-interface outside
monitor-interface inside
no asdm history enable
arp timeout 14400
route outside 0.0.0.0 0.0.0.0 192.168.5.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02 rpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp
fragment size 200 outside
fragment chain 24 outside
fragment timeout 5 outside
fragment size 200 inside
fragment chain 24 inside
fragment timeout 5 inside
telnet timeout 5
ssh timeout 5
console timeout 0
!
class-map inspection_default
match default-inspection-traffic
!
!

例11-6 ctx1 コンテキストのコンフィギュレーション

interface Ethernet3
nameif inside
security-level 100
ip address 192.168.20.1 255.255.255.0 standby 192.168.20.11
!
interface Ethernet4
nameif outside
security-level 0
ip address 192.168.10.31 255.255.255.0 standby 192.168.10.41
asr-group 1
!
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname ctx1
access-list 201 extended permit ip any any
pager lines 24
logging console informational
mtu inside 1500
mtu outside 1500
no vpn-addr-assign aaa
no vpn-addr-assign dhcp
no vpn-addr-assign local
monitor-interface inside
monitor-interface outside
no asdm history enable
arp timeout 14400
access-group 201 in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.10.71 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02 rpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp