Cisco ASA 5500 シリーズ コンフィギュレーション ガイド(CLI を使用)
OSPF の設定
OSPF の設定
発行日;2012/02/01 | 英語版ドキュメント(2011/07/15 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 15MB) | フィードバック

目次

OSPF の設定

OSPF に関する情報

OSPF のライセンス要件

ガイドラインと制限事項

OSPF の設定

OSPF のカスタマイズ

OSPF へのルートの再配布

OSPF にルートを再配布する場合のルート集約の設定

OSPF エリア間のルート集約の設定

OSPF インターフェイスのパラメータの設定

OSPF エリア パラメータの設定

OSPF NSSA の設定

スタティック OSPF ネイバーの定義

ルート計算タイマーの設定

ネイバーがアップ状態またはダウン状態になった時点でのロギング

OSPF プロセスの再起動

OSPF の設定例

OSPF のモニタリング

OSPF の機能履歴

OSPF の設定

この章では、Open Shortest Path First(OSPF)ルーティング プロトコルを使用してデータをルーティングし、認証を実行し、ルーティング情報を再配布するように適応型セキュリティ アプライアンスを設定する方法について説明します。

この章は、次の項目を取り上げます。

「OSPF に関する情報」

「OSPF のライセンス要件」

「ガイドラインと制限事項」

「OSPF の設定」

「OSPF のカスタマイズ」

「OSPF のモニタリング」

「OSPF の設定例」

「OSPF の機能履歴」

OSPF に関する情報

OSPF は、パスの選択に距離ベクトル型ではなくリンク ステートを使用する Interior Gateway Routing Protocol(IGRP)です。OSPF は、ルーティング テーブル アップデートではなく、リンクステート アドバタイズメントを伝搬します。ルーティング テーブル全体ではなく LSA だけが交換されるため、OSPF ネットワークは RIP ネットワークよりも迅速に収束します。

OSPF は、リンクステート アルゴリズムを使用して、すべての既知の宛先までの最短パスを構築および計算します。OSPF エリア内の各ルータには、ルータが使用可能なインターフェイスと到達可能なネイバーそれぞれのリストである同一のリンクステート データベースが置かれています。

RIP に比べると OSPF は次の点で有利です。

OSPF のリンクステート データベースのアップデート送信は RIP ほど頻繁ではありません。また、古くなった情報のタイムアウトで徐々にアップデートされるのではなく、リンクステート データベースは瞬時にアップデートされます。

ルーティング決定はコストに基づいて行われます。これは、特定のインターフェイスを介してパケットを送信するためにオーバーヘッドが必要であることを示しています。適応型セキュリティ アプライアンスは、インターフェイスのコストをリンク帯域幅に基づいて計算し、宛先までのホップ数は使用しません。コストは優先パスを指定するために設定できます。

最短パス優先アルゴリズムの欠点は、CPU サイクルとメモリが大量に必要になることです。

適応型セキュリティ アプライアンスは、OSPF プロトコルのプロセス 2 つを異なるインターフェイス セット上で同時に実行できます。同じ IP アドレスを使用する複数のインターフェイス(NAT ではこのようなインターフェイスは共存可能ですが、OSPF ではアドレスの重複は許しません)があるときに、2 つのプロセスを実行する場合があります。あるいは、一方のプロセスを内部で実行しながら別のプロセスを外部で実行し、ルートのサブセットをこの 2 つのプロセス間で再配布する場合もあります。同様に、プライベート アドレスをパブリック アドレスから分離する必要がある場合もあります。

OSPF ルーティング プロセスには、別の OSPF ルーティング プロセスや RIP ルーティング プロセスから、または OSPF 対応インターフェイスに設定されているスタティック ルートおよび接続されているルートから、ルートを再配布できます。

適応型セキュリティ アプライアンスでは、次の OSPF の機能がサポートされています。

エリア内ルート、エリア間ルート、および外部ルート(タイプ I とタイプ II)のサポート

仮想リンクのサポート

OSPF の LSA フラッディング

OSPF パケットの認証(パスワード認証と MD5 認証の両方)

適応型セキュリティ アプライアンスの代表ルータまたは代表バックアップ ルータとしての設定のサポート。適応型セキュリティ アプライアンスは、ABR として設定することもできます。

スタブ エリアと not so stubby エリア(NSSA)のサポート

エリア境界ルータのタイプ 3 LSA フィルタリング

OSPF は、MD5 とクリア テキスト ネイバー認証をサポートしています。OSPF と他のプロトコル(RIP など)の間のルートの再配布は、攻撃者によるルーティング情報の悪用に使用される可能性があるため、できる限りすべてのルーティング プロトコルで認証を使用する必要があります。

NAT が使用されている場合、OSPF がパブリック エリアおよびプライベート エリアで動作している場合、またアドレス フィルタリングが必要な場合は、2 つの OSPF プロセス(1 つはパブリック エリア用、1 つはプライベート エリア用)を実行する必要があります。

複数のエリアにインターフェイスを持つルータは、Area Border Router(ABR; エリア境界ルータ)と呼ばれます。ゲートウェイとして動作し、OSPF を使用しているルータと他のルーティング プロトコルを使用しているルータの間でトラフィックを再配布するルータは、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)と呼ばれます。

ABR は LSA を使用して、使用可能なルータに関する情報を他の OSPF ルータに送信します。ABR タイプ 3 LSA フィルタリングを使用すると、ABR として機能する適応型セキュリティ アプライアンスを使用して、プライベート エリアとパブリック エリアを分けることができます。タイプ 3 LSA(エリア間ルータ)は、1 つのエリアから別のエリアにフィルタリングできます。この結果、プライベート ネットワークをアドバタイズすることなく、NAT と OSPF を同時に使用できます。


) フィルタリングできるのはタイプ 3 LSA だけです。プライベート ネットワークで適応型セキュリティ アプライアンスを ASBR として設定している場合は、プライベート ネットワークを記述するタイプ 5 LSA が送信され、パブリック エリアを含む AS 全体に対してフラッディングされます。


NAT が採用されているが、OSPF がパブリック エリアだけで実行されている場合は、パブリック ネットワークに対するルートを、デフォルトまたはタイプ 5 AS 外部 LSA としてプライベート ネットワーク内で再配布できます。ただし、適応型セキュリティ アプライアンスにより保護されているプライベート ネットワークにはスタティック ルートを設定する必要があります。また、同一の適応型セキュリティ アプライアンス インターフェイス上で、パブリック ネットワークとプライベート ネットワークを混在させることはできません。

適応型セキュリティ アプライアンスでは、2 つの OSPF ルーティング プロセス(1 つの RIP ルーティング プロセスと 1 つの EIGRP ルーティング プロセス)を同時に実行できます。

OSPF のライセンス要件

 

モデル
ライセンス要件

すべてのモデル

基本ライセンス

ガイドラインと制限事項

この項では、この機能のガイドラインと制限事項について説明します。

コンテキスト モードのガイドライン

シングルコンテキスト モードでサポートされています。

ファイアウォール モードのガイドライン

ルーテッド ファイアウォール モードでだけサポートされています。トランスペアレント モードはサポートされていません。

IPv6 のガイドライン

IPv6 はサポートされません。

OSPF の設定

この項では、システムで OSPF プロセスをイネーブルにする方法について説明します。

OSPF をイネーブルにした後、ルートマップを定義する必要があります。詳細については、「ルートマップの定義」を参照してください。その後、デフォルト ルートを生成します。詳細については、「スタティック ルートおよびデフォルト ルートの設定」を参照してください。

OSPF プロセスのルートマップを定義した後、自分のニーズに合せて OSPF プロセスをカスタマイズできます。ご使用のシステム上で OSPF プロセスをカスタマイズする方法については、「OSPF のカスタマイズ」を参照してください。

OSPF をイネーブルにするには、OSPF ルーティング プロセスを作成し、このルーティング プロセスに関連付ける IP アドレスの範囲を指定し、さらにその IP アドレスの範囲にエリア ID を割り当てる必要があります。

最大 2 つの OSPF プロセス インスタンスをイネーブルにできます。各 OSPF プロセスには、独自のエリアとネットワークが関連付けられます。

OSPF をイネーブルにするには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、この OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

適応型セキュリティ アプライアンス上で OSPF プロセスが 1 つしかイネーブルになっていないと、そのプロセスがデフォルトで選択されます。既存のエリアを編集する場合、OSPF プロセス ID は変更できません。

ステップ 2

network ip_address mask area area_id
 
hostname(config)# router ospf 2
hostname(config-router)# network 10.0.0.0 255.0.0.0 area 0

この手順では、OSPF を実行する IP アドレスを定義し、そのインターフェイスのエリア ID を定義します。

新しいエリアを追加する場合、そのエリア ID を入力します。このエリア ID には、10 進数か IP アドレスを指定できます。有効な 10 進数値の範囲は 0 ~ 4294967295 です。既存のエリアを編集する場合、エリア ID は変更できません。

OSPF のカスタマイズ

この項では、OSPF プロセスをカスタマイズする方法について説明します。次の項目を取り上げます。

「OSPF へのルートの再配布」

「OSPF インターフェイスのパラメータの設定」

「OSPF エリア間のルート集約の設定」

「OSPF インターフェイスのパラメータの設定」

「OSPF エリア パラメータの設定」

「OSPF NSSA の設定」

「ルート計算タイマーの設定」

「スタティック OSPF ネイバーの定義」

「ネイバーがアップ状態またはダウン状態になった時点でのロギング」

「OSPF プロセスの再起動」

OSPF へのルートの再配布

適応型セキュリティ アプライアンスは、OSPF ルーティング プロセス間のルート再配布を制御できます。


) 指定されたルーティング プロトコルから、ターゲット ルーティング プロセスに再配布できるルートを定義することでルートを再配布する場合は、デフォルト ルートを最初に生成する必要があります。「スタティック ルートおよびデフォルト ルートの設定」を参照し、その後に「ルートマップの定義」に従ってルートマップを定義します。


スタティック ルート、接続されているルート、RIP ルート、または OSPF ルートを OSPF プロセスに再配布するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、再配布する OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

選択したルート タイプを OSPF ルーティング プロセスに再配布するには、次のいずれかの手順を実行します。

redistribute connected [ [ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name ]
 
hostname(config)# redistribute connected 5 type-1 route-map-practice

この手順では、接続されたルートを OSPF ルーティング プロセスに再配布します。

redistribute static [ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name
 
hostname(config)# redistribute static 5 type-1 route-map-practice

この手順では、スタティック ルートを OSPF ルーティング プロセスに再配布します。

redistribute ospf pid [match {internal | external [1 | 2] | nssa-external [1 | 2]}] [ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name ]
 
hostname(config)# route-map 1-to-2 permit
hostname(config-route-map)# match metric 1
hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1
hostname(config-route-map)# router ospf 2
hostname(config-router)# redistribute ospf 1 route-map 1-to-2

この手順では、OSPF ルーティング プロセスのルートを別の OSPF ルーティング プロセスに再配布できます。

このコマンドに match オプションを使用してルート プロパティを照合および設定することも、ルートマップを使用することもできます。 subnet オプションは、 route-map コマンドで使用する場合と同じではありません。 redistribute コマンドでルートマップと match オプションの両方を使用した場合、これらは一致している必要があります。

この例では、ルートをメトリック 1 に照合することによる、OSPF プロセス 1 から OSPF プロセス 2 へのルートの再配布を示しています。適応型セキュリティ アプライアンスは、これらのルートをメトリック 5、メトリック タイプ 1 で外部 LSA として再配布します。

redistribute rip [ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name ]
 
hostname(config)# redistribute rip 5
hostname(config-route-map)# match metric 1
hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1
hostname(config-router)# redistribute ospf 1 route-map 1-to-2

この手順では、RIP ルーティング プロセスのルートを OSPF ルーティング プロセスに再配布できます。

redistribute eigrp as-num [ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name ]
 
hostname(config)# redistribute eigrp 2
hostname(config-route-map)# match metric 1
hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1
hostname(config-router)# redistribute ospf 1 route-map 1-to-2

この手順では、EIGRP ルーティング プロセスのルートを OSPF ルーティング プロセスに再配布できます。

OSPF にルートを再配布する場合のルート集約の設定

他のプロトコルからのルートを OSPF に再配布する場合、各ルートは外部 LSA で個別にアドバタイズされます。その一方で、指定したネットワーク アドレスとマスクでカバーされる再配布ルートすべてに対して 1 つのルートをアドバタイズするように適応型セキュリティ アプライアンスを設定することができます。この設定によって OSPF リンクステート データベースのサイズが小さくなります。

指定した IP アドレス マスク ペアと一致するルートは廃止できます。ルートマップで再配布を制御するために、タグ値を一致値として使用できます。

ネットワーク アドレスとマスクでカバーされる再配布ルートすべてに対して 1 つのサマリー ルートをアドバタイズするようにソフトウェアを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 1

OSPF ルーティング プロセスを作成し、この OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

summary-address ip_address mask [ not-advertise ] [tag tag ]
 
hostname(config)# router ospf 1
hostname(config-router)# summary-address 10.1.0.0 255.255.0.0

この手順ではサマリー アドレスを設定します。

この例のサマリー アドレスの 10.1.0.0 には、10.1.1.0、10.1.2.0、10.1.3.0 などのアドレスが含まれます。外部のリンクステート アドバタイズメントでは、アドレス 10.1.0.0 だけがアドバタイズされます。

OSPF エリア間のルート集約の設定

ルート集約は、アドバタイズされるアドレスを統合することです。この機能を実行すると、1 つのサマリー ルートがエリア境界ルータを通して他のエリアにアドバタイズされます。OSPF のエリア境界ルータは、ネットワークをある 1 つのエリアから別のエリアへとアドバタイズしていきます。あるエリアにおいて連続する複数のネットワーク番号が割り当てられている場合、指定された範囲に含まれるエリア内の個別のネットワークをすべてカバーするサマリー ルートをアドバタイズするようにエリア境界ルータを設定することができます。

ルート集約のアドレス範囲を定義するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 1

OSPF ルーティング プロセスを作成し、この OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

area area-id range ip-address mask [ advertise | not-advertise ]
 
hostname(config)# router ospf 1
hostname(config-router)# area 17 range 12.1.0.0 255.255.0.0

この手順ではアドレス範囲を設定します。

この例では、アドレス範囲は OSPF エリア間で設定されます。

OSPF インターフェイスのパラメータの設定

インターフェイス固有の OSPF パラメータは、必要に応じて変更できます。

前提条件

これらのパラメータは必ずしも変更する必要はありませんが、 ospf hello-interval ospf dead-interval 、および ospf authentication-key というインターフェイス パラメータは、接続されているネットワーク内のすべてのルータで一致している必要があります。これらのパラメータのいずれかを設定する場合は、ネットワーク上のすべてのルータのコンフィギュレーションに適合する値にするようにしてください。

OSPF インターフェイス パラメータを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、再配布する OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

network ip_address mask area area_id
 
hostname(config)# router ospf 2
hostname(config-router)# network 10.0.0.0 255.0.0.0 area 0

この手順では、OSPF を実行する IP アドレスを定義し、そのインターフェイスのエリア ID を定義します。

ステップ 3

hostname(config)# interface interface_name
 
hostname(config)# interface my_interface

インターフェイス コンフィギュレーション モードに入ることができます。

ステップ 4

次のいずれかの手順を実行し、オプションの OSPF インターフェイス パラメータを設定します。

ospf authentication [message-digest | nul l ]

 
hostname(config-interface)# ospf authentication message-digest

インターフェイスの認証タイプを指定します。

ospf authentication-key key

 
hostname(config-interface)# ospf authentication-key cisco

OSPF 簡易パスワード認証を使用しているネットワーク セグメントに存在するネイバー OSPF ルータで使用するパスワードを割り当てることができます。

key には、最大 8 バイトの連続する文字列が指定できます。

このコマンドで作成するパスワードはキーとして使用され、このキーは適応型セキュリティ アプライアンスのソフトウェアによるルーティング プロトコル パケットの発信時に OSPF ヘッダーに直接挿入されます。各ネットワークにはインターフェイスごとに個別のパスワードを割り当てることができます。OSPF 情報が交換できるためには、同じネットワーク上のネイバー ルータはすべて、同じパスワードを持つ必要があります。

ospf cost cost

 

hostname(config-interface)# ospf cost 20

OSPF インターフェイスでパケットを送信するためのコストを明示的に指定できます。 cost は、1 ~ 65535 の整数です。

この例では、cost は 20 に設定されています。

ospf dead-interval seconds

 

hostname(config-interface)# ospf dead-interval 40

hello パケットが受信されなかったために、ネイバー OSPF ルータがダウンしているとデバイスが宣言する場合に必要な待機時間を秒単位で設定できます。この値はネットワーク上のすべてのノードで同じにする必要があります。

この例では、dead-interval は 40 に設定されています。

ospf hello-interval seconds

 

hostname(config-interface)# ospf hello-interval 10

適応型セキュリティ アプライアンスが OSPF インターフェイスから hello パケットを送信する時間間隔を指定できます。この値はネットワーク上のすべてのノードで同じにする必要があります。

この例では、hello-interval は 10 に設定されています。

ospf message-digest-key key_id md5 key

 
hostname(config-interface)# ospf message-digest-key 1 md5 cisco

OSPF MD5 認証をイネーブルにします。

次の値を設定できます。

key_id :範囲 1 ~ 255 の識別子

key :最大 16 バイトの英数字によるパスワード

通常は、インターフェイスあたり 1 つのキーを使用して、パケット送信時に認証情報を生成するとともに着信パケットを認証します。ネイバー ルータの同一キー識別子は、キー値を同一にする必要があります。

1 インターフェイスで 2 つ以上のキーを保持しないことをお勧めします。新しいキーを追加したらその都度古いキーを削除して、ローカル システムが古いキー情報を持つ悪意のあるシステムと通信を続けることのないようにしてください。古いキーを削除すると、ロールオーバー中のオーバーヘッドを減らすことにもなります。

ospf priority number_value

 
hostname(config-interface)# ospf priority 20

ネットワークの OSPF 代表ルータを決定するためのプライオリティを設定できます。

number_value は、0 ~ 255 です。

この例では、プライオリティ番号の値は 20 に設定されています。

ospf retransmit-interval seconds

 
hostname(config-interface)# ospf retransmit-interval seconds

OSPF インターフェイスに属する隣接ルータに LSA を再送信する間隔を秒単位で指定できます。

seconds の値は、接続されているネットワーク上の任意の 2 ルータ間で予想されるラウンドトリップ遅延よりも長い秒数でなければなりません。範囲は 1 ~ 65535 秒です。デフォルト値は 5 秒です。

この例では、retransmit-interval の値は 15 に設定されています。

ospf transmit-delay seconds

 
hostname(config-interface)# ospf transmit-delay 5

OSPF インターフェイスでリンクステート アップデート パケットを送信するために必要な予想時間を秒単位で設定できます。 seconds の値は、1 ~ 65535 秒です。デフォルト値は 1 秒です。

この例では、transmit-delay は 5 秒です。

ospf network point-to-point non-broadcast

 
hostname(config-interface)# ospf network point-to-point non-broadcast

インターフェイスをポイントツーポイントの非ブロードキャスト ネットワークとして指定します。

インターフェイスをポイントツーポイントの非ブロードキャストとして指定する場合、OSPF ネイバーを手動で設定する必要があります。ダイナミック近隣探索は使用できません。詳細については、「スタティック OSPF ネイバーの定義」を参照してください。さらに、そのインターフェイスに定義できる OSPF ネイバーは 1 つだけです。

OSPF エリア パラメータの設定

複数の OSPF エリア パラメータを設定できます。これらのエリア パラメータ(後述のタスク リストに表示)には、認証の設定、スタブ エリアの定義、デフォルト サマリー ルートへの特定のコストの割り当てがあります。認証では、エリアへの不正アクセスに対してパスワードベースで保護します。

スタブ エリアは、外部ルートの情報が送信されないエリアです。その代わりに、ABR で生成されるデフォルトの外部ルートがあり、このルートは自律システムの外部の宛先としてスタブ エリアに送信されます。OSPF スタブ エリアのサポートを活用するには、デフォルトのルーティングをスタブ エリアで使用する必要があります。スタブ エリアに送信される LSA の数をさらに減らすには、ABR で実行する area stub コマンドに no-summary キーワードを設定して、スタブ エリアにサマリー リンク アドバタイズメント(LSA タイプ 3)が送信されないようにします。

ネットワークにエリア パラメータを指定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、再配布する OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

次のいずれかの手順を実行し、オプションの OSPF エリア パラメータを設定します。

area area-id authentication
 
hostname(config-router)# area 0 authentication

この手順では、OSPF エリアの認証をイネーブルにします。

area area-id authentication message-digest

 
hostname(config-router)# area 0 authentication message-digest

この手順では、OSPF エリアの MD5 認証をイネーブルにします。

OSPF NSSA の設定

Not-So-Stubby Area(NSSA)の OSPF への実装は、OSPF のスタブ エリアに似ています。NSSA は、タイプ 5 の外部 LSA をコアからエリアにフラッディングすることはありませんが、自律システムの外部ルートをある限られた方法でエリア内にインポートできます。

NSSA は、再配布によって、タイプ 7 の自律システムの外部ルートを NSSA エリア内部にインポートします。これらのタイプ 7 の LSA は、NSSA の ABR によってタイプ 5 の LSA に変換され、ルーティング ドメイン全体にフラッディングされます。変換中は集約とフィルタリングがサポートされます。

OSPF を使用する中央サイトから異なるルーティング プロトコルを使用するリモート サイトに接続しなければならない ISP またはネットワーク管理者は、NSSA を使用することによって管理を簡略化できます。

NSSA が実装される前は、企業サイトの境界ルータとリモート ルータ間の接続では、OSPF スタブ エリアとしては実行されませんでした。これは、リモート サイト向けのルートは、スタブ エリアに再配布することができず、2 種類のルーティング プロトコルを維持する必要があったためです。RIP のようなシンプルなプロトコルを実行して再配布を処理する方法が一般的でした。NSSA が実装されたことで、企業ルータとリモート ルータ間のエリアを NSSA として定義することにより、NSSA で OSPF を拡張してリモート接続をカバーできます。

この機能を使用する前に、次のガイドラインを参考にしてください。

外部の宛先に到達するために使用可能なタイプ 7 のデフォルト ルートを設定できます。設定すると、NSSA または NSSA エリア境界ルータまでのタイプ 7 のデフォルトがルータによって生成されます。

同じエリア内にあるすべてのルータは、このエリアが NSSA であることに同意しなければなりません。同意しないと、ルータは通信できなくなります。

OSPF NSSA を設定するために必要なエリア パラメータをネットワークに指定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、再配布する OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

次のいずれかの手順を実行し、オプションの OSPF NSSA パラメータを設定します。

area area-id nssa [ no-redistribution ] [ default-information-originate ]
 
hostname(config-router)# area 0 nssa

この手順では NSSA エリアを定義します。

summary-address ip_address mask [ not-advertise ] [tag tag ]
 
hostname(config)# router ospf 1
hostname(config-router)# summary-address 10.1.0.0 255.255.0.0

この手順では、サマリー アドレスを設定します。これは、ルーティング テーブルのサイズを小さくするために役立ちます。OSPF でこのコマンドを使用すると、このアドレスでカバーされる再配布ルートすべての集約として、1 つの外部ルートが OSPF ASBR からアドバタイズされます。

この例のサマリー アドレスの 10.1.0.0 には、10.1.1.0、10.1.2.0、10.1.3.0 などのアドレスが含まれます。外部のリンクステート アドバタイズメントでは、アドレス 10.1.0.0 だけがアドバタイズされます。


) OSPF は summary-address 0.0.0.0 0.0.0.0 をサポートしません。


スタティック OSPF ネイバーの定義

ポイントツーポイントの非ブロードキャスト ネットワークを介して OSPF ルートをアドバタイズするには、スタティック OSPF ネイバーを定義する必要があります。これにより、OSPF アドバタイズメントを GRE トンネルにカプセル化しなくても、既存の VPN 接続でブロードキャストすることができます。

開始する前に、OSPF ネイバーに対するスタティック ルートを作成する必要があります。スタティック ルートの作成方法の詳細については、 「スタティック ルートおよびデフォルト ルートの設定」 を参照してください。

スタティック OSPF ネイバーを定義するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、この OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

neighbor addr [ interface if_name ]
 
hostname(config-router)# neighbor 255.255.0.0 [interface my_interface ]

この手順では OSPF ネイバーを定義します。

addr 引数には OSPF ネイバーの IP アドレスを指定します。 if_name は、ネイバーとの通信に使用するインターフェイスです。OSPF ネイバーが直接接続されているインターフェイスのいずれとも同じネットワーク上にない場合、 interface を指定する必要があります。

ルート計算タイマーの設定

OSPF によるトポロジ変更受信と最短パス優先(SPF)計算開始との間の遅延時間が設定できます。最初に SPF を計算してから次に計算するまでの保持時間も設定できます。

ルート計算タイマーを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、この OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

timers spf spf-delay spf-holdtime
 
hostname(config-router)# timers spf 10 120

この手順では、ルート計算時刻を設定します。

spf-delay は、OSPF によるトポロジ変更受信と SPF 計算開始との間の遅延時間(秒)です。0 ~ 65535 の整数に設定できます。デフォルトの時間は 5 秒です。値の 0 は遅延がないことを意味します。つまり、SPF 計算はただちに開始されます。

spf-holdtime は、2 つの連続する SPF 計算の間の最短時間(秒)です。0 ~ 65535 の整数に設定できます。デフォルトの時間は 10 秒です。値の 0 は遅延がないことを意味します。つまり、2 回の SPF 計算がすぐに続けて行われます。

ネイバーがアップ状態またはダウン状態になった時点でのロギング

デフォルトでは、OSPF ネイバーがアップ状態またはダウン状態になったときに、システム メッセージが生成されます。

アップ状態またはダウン状態になった OSPF ネイバーについて、 debug ospf adjacency コマンドを実行せずに確認する必要がある場合に、このコマンドを設定します。 log-adj-changes router コンフィギュレーション コマンドでは、少ない出力によってピアの関係が高いレベルで表示されます。それぞれの状態変化メッセージを確認する場合は、 log-adj-changes detail コマンドを設定します。

アップ状態またはダウン状態になったネイバーをログに記録するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 
hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、この OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

log-adj-changes [ detail ]
 
hostname(config-router)# log-adj-changes [detail]

この手順では、アップ状態またはダウン状態になったネイバーに対するロギングを設定します。

OSPF プロセスの再起動

イネーブルにした OSPF 設定全体を削除するには、次のコマンドを入力します。

 

コマンド
目的
clear ospf pid { process | redistribution | counters [ neighbor [ neighbor-interface ] [ neighbor-id ]]}
 
hostname(config)# clear ospf

イネーブルにした OSPF 設定全体を削除します。設定をクリアした後、 router ospf コマンドを使用して OSPF を再設定する必要があります。

OSPF の設定例

次の例に、さまざまなオプションのプロセスを使用して OSPF をイネーブルにし、設定する方法を示します。


ステップ 1 OSPF をイネーブルにします。

hostname(config)# router ospf 2
hostname(config-router)# network 10.0.0.0 255.0.0.0 area 0
 

ステップ 2 1 つの OSPF プロセスから別の OSPF プロセスにルートを再配布します(オプション)。

hostname(config)# route-map 1-to-2 permit
hostname(config-route-map)# match metric 1
hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1
hostname(config-route-map)# router ospf 2
hostname(config-router)# redistribute ospf 1 route-map 1-to-2
 

ステップ 3 OSPF インターフェイス パラメータを設定します(オプション)。

hostname(config)# router ospf 2
hostname(config-router)# network 2.0.0.0 255.0.0.0 area 0
hostname(config-router)# interface inside
hostname(config-interface)# ospf cost 20
hostname(config-interface)# ospf retransmit-interval 15
hostname(config-interface)# ospf transmit-delay 10
hostname(config-interface)# ospf priority 20
hostname(config-interface)# ospf hello-interval 10
hostname(config-interface)# ospf dead-interval 40
hostname(config-interface)# ospf authentication-key cisco
hostname(config-interface)# ospf message-digest-key 1 md5 cisco
hostname(config-interface)# ospf authentication message-digest
 

ステップ 4 OSPF エリア パラメータを設定します(オプション)。

hostname(config)# router ospf 2
hostname(config-router)# area 0 authentication
hostname(config-router)# area 0 authentication message-digest
hostname(config-router)# area 17 stub
hostname(config-router)# area 17 default-cost 20
 

ステップ 5 ルート計算タイマーを設定し、ログ ネイバーのアップまたはダウンのメッセージを表示します(オプション)。

hostname(config-router)# timers spf 10 120
hostname(config-router)# log-adj-changes [detail]
 

ステップ 6 OSPF プロセスを再起動します。

hostname(config)# clear ospf pid {process | redistribution | counters [neighbor [neighbor-interface] [neighbor-id]]}
 

ステップ 7 OSPF の設定の結果を表示します(オプション)。

次に、 show ospf コマンドの出力例を示します。

hostname(config)# show ospf
 
Routing Process “ospf 2” with ID 20.1.89.2 and Domain ID 0.0.0.2
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs.Minimum LSA arrival 1 secs
Number of external LSA 5.Checksum Sum 0x 26da6
Number of opaque AS LSA 0.Checksum Sum 0x 0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1.1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 2 times
Area ranges are
Number of LSA 5.Checksum Sum 0x 209a3
Number of opaque link LSA 0.Checksum Sum 0x 0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 


 

OSPF のモニタリング

IP ルーティング テーブルの内容、キャッシュの内容、およびデータベースの内容など、特定の統計情報を表示できます。提供される情報は、リソースの使用状況を判定してネットワークの問題を解決するために使用することもできます。また、ノードの到達可能性情報を表示して、デバイス パケットがネットワークを通過するときにとるルーティング パスを見つけることもできます。

さまざまな OSPF ルーティング統計情報をモニタまたは表示するには、次のいずれかのコマンドを入力します。

 

コマンド
目的
show ospf [ process-id [area-id] ]

OSPF ルーティング プロセスに関する一般情報を表示します。

show ospf border-routers

ABR および ASBR までの内部 OSPF ルーティング テーブル エントリを表示します。

show ospf [ process-id [ area-id ]] database

特定のルータの OSPF データベースに関連する情報のリストを表示します。

show ospf flood-list if-name

(OSPF パケット ペーシングの観察のため)インターフェイスへのフラッディングを待機している LSA のリストを表示します。

OSPF アップデート パケットは、自動的にペーシングされるため、各パケットの送信間隔が 33 ミリ秒未満になることはありません。ペーシングを行わないと、リンクが低速の状態でアップデート パケットの一部が失われたり、ネイバーがアップデートを十分すばやく受信できなくなったり、あるいは、ルータがバッファ スペースを使い切ってしまったりすることがあります。たとえば、ペーシングを行わないと、次のいずれかのトポロジが存在する場合にパケットがドロップされる可能性があります。

高速ルータがポイントツーポイント リンクを介して低速のルータと接続している。

フラッディング中に、複数のネイバーから 1 つのルータに同時にアップデートが送信される。

ペーシングは、再送信間でも、送信効率を高めて再送信パケットの損失を最小にするために利用されます。インターフェイスへの送信を待機している LSA を表示することもできます。ペーシングの利点は、OSPF アップデートおよび再送信パケットの送信の効率をよくすることです。

この機能を設定するタスクはありません。自動的に行われます。

show ospf interface [ if_name ]

OSPF に関連するインターフェイス情報を表示します。

show ospf neighbor [ interface-name ] [ neighbor-id ] [ detail ]

OSPF ネイバー情報をインターフェイスごとに表示します。

show ospf request-list neighbor if_name

ルータで要求されるすべての LSA のリストを表示します。

show ospf retransmission-list neighbor if_name

再送信を待機しているすべての LSA のリストを表示します。

show ospf [ process-id ] summary-address

OSPF プロセスで設定されているサマリー アドレスのすべての再配布情報のリストを表示します。

show ospf [ process-id ] virtual-links

OSPF に関連する仮想リンク情報を表示します。

OSPF の機能履歴

表 20-1 に、各機能変更と、それが実装されたプラットフォーム リリースを示します。

 

表 20-1 スタティック ルートおよびデフォルト ルートの機能履歴

機能名
プラットフォーム リリース
機能情報

OSPF サポート

7.0(1)

Open Shortest Path First(OSPF)ルーティング プロトコルを使用した、データのルーティング、認証の実行、およびルーティング情報の再配布とモニタについて、サポートが追加されました。

route ospf コマンドが、Open Shortest Path First(OSPF)ルーティング プロトコルを使用して、データのルーティング、認証の実行、およびルーティング情報の再配布とモニタを行うために導入されました。