Cisco ASA 5500 シリーズ コンフィギュレーション ガイド(CLI8.2 を使用)
RIP の設定
RIP の設定
発行日;2012/02/02 | 英語版ドキュメント(2011/09/19 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 21MB) | フィードバック

目次

RIP の設定

概要

ルーティング アップデート プロセス

RIP のルーティング メトリック

RIP 安定性機能

RIP タイマー

RIP のライセンス要件

ガイドラインと制限事項

RIP の設定

RIP のイネーブル化

RIP のカスタマイズ

デフォルト ルートの生成

RIP のインターフェイスの設定

ルート集約のディセーブル化

RIP でのネットワークのフィルタリング

RIP ルーティング プロセスへのルートの再配布

インターフェイス上の RIP 送受信バージョンの設定

RIP 認証のイネーブル化

RIP の監視

RIP の設定例

RIP の機能履歴

その他の参考資料

関連資料

RIP の設定

この章では、Routing Information Protocol(RIP)ルーティング プロトコルを使用してデータをルーティングし、認証を実行し、ルーティング情報を再配布するように適応型セキュリティ アプライアンスを設定する方法について説明します。

この章には、次の項があります。

「概要」

「RIP のライセンス要件」

「ガイドラインと制限事項」

「RIP の設定」

「RIP のカスタマイズ」

「RIP の監視」

「RIP の設定例」

「RIP の機能履歴」

「その他の参考資料」

概要

RIP と呼ばれることが多い Routing Information Protocol は、すべてのルーティング プロトコルの中で最も堅牢なものの 1 つです。RIP には、ルーティング アップデート プロセス、RIP ルーティング メトリック、ルーティング安定性、ルーティング タイマーの 4 つの基本的なコンポーネントがあります。RIP をサポートしているデバイスは、ネットワークのトポロジが変更されると、ルーティングアップデート メッセージを所定の間隔で送信します。これらの RIP パケットには、デバイスが到達可能なネットワークに関する情報、さらに宛先アドレスに到達するためにパケットが通過しなければならないルータやゲートウェイの数が含まれています。RIP では、生成されるトラフィックは OSPF より多くなりますが、設定は OSPF より容易です。

RIP は、初期コンフィギュレーションが簡単で、トポロジが変更されても設定をアップデートする必要がないため、スタティック ルーティングより有利です。RIP の欠点は、ネットワーク数や処理オーバーヘッドがスタティック ルーティングより大きいことです。

適応型セキュリティ アプライアンスは、RIP バージョン 1 および 2 をサポートしています。

ルーティング アップデート プロセス

RIP は、ルーティングアップデート メッセージを定期的に、またネットワーク トポロジが変更されたときに送信します。ルータは、エントリの変更が含まれるルーティング アップデートを受け取ると、新しいルートを反映するようにそのルーティング テーブルを更新します。パスのメトリック値は 1 ずつ大きくなり、送信者はネクストホップとして示されます。RIP ルータは、宛先に対する最適なルート(メトリック値が最も小さいルート)だけを保持します。ルータは、そのルーティング テーブルを更新した後、他のネットワーク ルータに変更を通知するために、ルーティング アップデートの送信をただちに開始します。これらのアップデートは、RIP ルータが送信する定期的にスケジュールされたアップデートとは独立して送信されます。

RIP のルーティング メトリック

RIP は、1 つのルーティング メトリック(ホップ カウント)を使用して発信元と宛先ネットワークとの距離を測定します。発信元から宛先までのパスの各ホップにはホップ カウント値(通常は 1)が割り当てられます。ルータが、新しいまたは変更された宛先ネットワーク エントリが含まれるルーティング アップデートを受け取ると、アップデートで示されたメトリック値に 1 を加算し、そのネットワークをルーティング テーブルに入れます。送信者の IP アドレスがネクストホップとして使用されます。

RIP 安定性機能

RIP は、送信元から宛先へのパスで許可されるホップ数に制限を導入することにより、ルーティング ループが無限に続くことを防止しています。パス内のホップの最大数は 15 です。新しいまたは変更されたエントリが含まれるルーティング アップデートをルータが受信し、メトリック値に 1 を加えた結果、メトリックが無限(つまり 16)になる場合は、ネットワークの宛先は到達不能と見なされます。この安定性機能の欠点は、この機能によって RIP ネットワークの直径の最大値が 16 ホップ未満に制限されることです。

RIP には、その他にも、多くのルーティング プロトコルに共通の安定性機能がいくつか含まれます。ネットワーク トポロジは急激に変化する可能性がありますが、これらの機能は、安定性を提供するように設計されています。たとえば、RIP では、スプリット ホライズンとホールドダウン メカニズムを実装して、間違ったルーティング情報が伝搬されることを防止しています。

RIP タイマー

RIP では、多数のタイマーを使用してそのパフォーマンスを調整しています。これらのタイマーには、ルーティングアップデート タイマー、ルートタイムアウト タイマー、ルートフラッシュ タイマーがあります。ルーティングアップデート タイマーは、定期的なルーティング アップデートの間隔を測ります。通常は 30 秒に設定されており、タイマーがリセットされたときにはランダムな時間がわずかに追加されます。これは、すべてのルータがそのネイバーを同時にアップデートしようとした結果発生する輻輳を防ぐためです。ルーティング テーブルの各エントリには、ルートタイムアウト タイマーが関連付けられています。ルートタイムアウト タイマーが期限切れになると、ルートには無効のマークが付きますが、ルートフラッシュ タイマーが期限切れになるまではテーブル内に保持されます。

RIP のライセンス要件

 

モデル
ライセンス要件

すべてのモデル

基本ライセンス

ガイドラインと制限事項

この項では、この機能のガイドラインと制限事項について説明します。

コンテキスト モードのガイドライン

シングルコンテキスト モードとマルチコンテキスト モードでサポートされています。

ファイアウォール モードのガイドライン

ルーテッド ファイアウォール モードと透過ファイアウォール モードでサポートされています。

IPv6 のガイドライン

IPv6 はサポートされません。

RIP の設定

この項では、システムで RIP プロセスをイネーブルにし、再起動する方法について説明します。

「RIP のイネーブル化」

イネーブルにした後に、システムで RIP プロセスをカスタマイズする方法を説明した項、「RIP のカスタマイズ」を参照してください。

RIP のイネーブル化

適応型セキュリティ アプライアンスでは、RIP ルーティング プロセスを 1 つだけイネーブルにできます。RIP ルーティング プロセスをイネーブルにした後に、 network コマンドを使用して、そのルーティング プロセスに参加するインターフェイスを定義する必要があります。デフォルトでは、適応型セキュリティ アプライアンスは RIP バージョン 1 アップデートを送信し、RIP バージョン 1 およびバージョン 2 アップデートを受け取ります。

RIP ルーティング プロセスをイネーブルにするには、次の手順を実行します。

詳細な手順

 

コマンド
目的
router rip
 
例:
hostname(config)# router rip

RIP ルーティング プロセスを開始し、ルータ コンフィギュレーション モードに入ります。

イネーブルにした RIP 設定全体を削除するには、 no router rip コマンドを使用します。削除されたら、 router rip コマンドを使用して RIP を再度設定する必要があります。

RIP のカスタマイズ

この項では、RIP を設定する方法について説明します。次の項目を取り上げます。

「デフォルト ルートの生成」

「RIP のインターフェイスの設定」

「ルート集約のディセーブル化」

「RIP でのネットワークのフィルタリング」

「RIP ルーティング プロセスへのルートの再配布」

「インターフェイス上の RIP 送受信バージョンの設定」

「RIP 認証のイネーブル化」

デフォルト ルートの生成

RIP でデフォルト ルートを生成するには、次の手順を実行します。

詳細な手順

 

コマンド
目的

ステップ 1

router rip
 
例:
hostname(config)# router rip

RIP ルーティング プロセスを開始し、ルータ コンフィギュレーション モードに入ります。

ステップ 2

default-information originate

 
例:

hostname(config-router):# default-information originate

この手順では、RIP にデフォルト ルートを生成します。

 

RIP のインターフェイスの設定

RIP ルーティングに参加させないインターフェースがアドバタイズするネットワークに接続されている場合は、そのインターフェイスが接続されているネットワークが対象に含まれる network コマンドを設定し、 passive-interface コマンドを使用して、そのインターフェイスによる RIP の送受信を防止できます。さらに、適応型セキュリティ アプライアンスがアップデートのために使用する RIP のバージョンを指定することもできます。

詳細な手順

 

コマンド
目的

ステップ 1

router rip
 
例:
hostname(config)# router rip

RIP ルーティング プロセスを開始し、ルータ コンフィギュレーション モードに入ります。

ステップ 2

network network_address
 
例:
hostname(config)# router rip
hostname(config-router)# network 10.0.0.0

この手順では、RIP ルーティング プロセスに参加するインターフェイスを指定します。

インターフェイスがこのコマンドで定義されるネットワークに属していれば、そのインターフェイスは RIP ルーティング プロセスに参加します。インターフェイスがこのコマンドで定義されるネットワークに属していなければ、そのインターフェイスは RIP アップデートを送受信しません。

ステップ 3

RIP ルーティングに参加するようにインターフェイスをカスタマイズするには、次のいずれかの手順を実行します。

version [1 | 2]
 
例:
hostname(config-router):# version [1]

 

適応型セキュリティ アプライアンスが使用する RIP のバージョンを指定します。

この設定はインターフェイスごとに上書きできます。

passive-interface [default | if_name ]

 
例:

hostname(config-router):# passive-interface [default]

この手順では、パッシブ モードで動作するインターフェイスを指定します。

default キーワードを使用すると、すべてのインターフェイスがパッシブ モードで動作するようになります。1 つのインターフェイス名を指定すると、そのインターフェイスだけがパッシブ RIP モードに設定されます。パッシブ モードでは、RIP ルーティング アップデートは、指定されたインターフェイスにより受信されますが、そこから送信されることはありません。パッシブ モードに設定するインターフェイスごとに、このコマンドを入力できます。

ルート集約のディセーブル化

RIP バージョン 1 では、常に自動ルート集約を使用します。RIP バージョン 1 ではこの機能をディセーブルにできません。RIP バージョン 2 では、デフォルトで自動ルート集約を使用します。RIP ルーティング プロセスは、ネットワーク番号の境界で集約を行います。ネットワークが連続していない場合、これによってルーティングの問題が発生する可能性があります。

たとえば、ネットワーク 192.168.1.0、192.168.2.0、192.168.3.0 が接続されているルータがあり、それらのネットワークがすべて RIP に参加しているとすると、RIP ルーティング プロセスはそれらのルートに対しサマリー アドレス 192.168.0.0 を作成します。さらにネットワーク 192.168.10.0 と 192.168.11.0 が接続されているルータがこのネットワークに追加され、それらのネットワークが RIP に参加すると、これらもまた 192.168.0.0 として集約されます。トラフィックが誤った場所にルーティングされる可能性をなくすために、競合するサマリー アドレスを作成するルータでの自動ルート集約をディセーブルにする必要があります。

自動ルータ集約をディセーブルにするには、RIP ルーティング プロセスのルータ コンフィギュレーション モードで次のコマンドを入力します。

詳細な手順

 

コマンド
目的

ステップ 1

router rip
 
例:
hostname(config)# router rip

RIP ルーティング プロセスを開始し、ルータ コンフィギュレーション モードに入ります。

ステップ 2

no auto-summarize
 
例:
hostname(config-router):# no auto-summarize

この手順では、自動ルート集約をディセーブルにします。

RIP でのネットワークのフィルタリング

アップデートで受信されるネットワークをフィルタリングするには、次の手順を実行します。


) 開始する前に、標準アクセスリストを作成し、ルーティング テーブルの中で RIP プロセスが許可しているネットワークを許可し、RIP プロセスが破棄するネットワークを拒否するように設定する必要があります。標準アクセスリストの作成の詳細については、「アクセスリストによるトラフィックの指定」の章を参照してください。


詳細な手順

 

コマンド
目的

ステップ 1

router rip
 
例:
hostname(config)# router rip

RIP ルーティング プロセスを開始し、ルータ コンフィギュレーション モードに入ります。

ステップ 2

distribute-list acl in [interface if_name ]
distribute-list acl out [connected | eigrp | interface if_name | ospf | rip | static ]
 
例:

hostname(config-router)# distribute-list acl2 in [interface interface1 ]

hostname(config-router): distribute-list acl3 out [connected]

この手順では、アップデートで送信されるネットワークをフィルタリングします。

インターフェイスを指定して、そのインターフェイスが送受信するアップデートだけにフィルタを適用することができます。このコマンドは、フィルタを適用するインターフェイスごとに入力できます。インターフェイス名を指定しない場合、フィルタは RIP アップデートに適用されます。

RIP ルーティング プロセスへのルートの再配布

OSPF ルーティング プロセス、EIGRP ルーティング プロセス、スタティック ルーティング プロセス、および接続されているルーティング プロセスからルートを RIP ルーティング プロセスに再配布できます。

ルートを RIP ルーティング プロセスに再配布するには、次の手順を実行します。


) この手順を開始する前に、ルートマップを作成し、指定されたルーティング プロトコルのうち RIP ルーティング プロセスに再配布されるルートを詳細に定義する必要があります。ルートマップの作成の詳細については、「ルートマップの定義」を参照してください。


詳細な手順

 

コマンド
目的

ステップ 1

選択したルート タイプを RIP ルーティング プロセスに再配布するには、次のいずれかの手順を実行します。RIP ルータ コンフィギュレーション内に default-metric コマンドが含まれていない場合、 redistribute コマンドに RIP メトリック値を指定する必要があります。

redistribute connected [ metric < metric-value > | transparent ] [route-map < route-map-name >]
 
例:
hostname(config-router): # redistribute connected [ metric <metric-value > | transparent ] [route-map < route-map-name >]

この手順を使用して、接続されているルートを RIP ルーティング プロセスに再配布します。

redistribute static [metric { metric_value | transparent}] [route-map map_name ]
 
例:
hostname(config-router):# redistribute static [metric { metric_value | transparent}] [route-map map_name ]

この手順を使用して、スタティック ルートを EIGRP ルーティング プロセスに再配布します。

redistribute ospf pid [match {internal | external [1 | 2] | nssa-external [1 | 2]}] [metric { metric_value | transparent}] [route-map map_name ]
 
例:
hostname(config-router):# redistribute ospf pid [match {internal | external [1 | 2] | nssa-external [1 | 2]}] [metric { metric_value | transparent}] [route-map map_name ]

この手順を使用して、OSPF ルーティング プロセスのルートを RIP ルーティング プロセスに再配布します。

redistribute eigrp as-num [metric { metric_value | transparent}] [route-map map_name ]
 
例:
hostname(config-router):# redistribute eigrp as-num [metric {metric_value | transparent}] [route-map map_name ]

この手順を使用して、EIGRP ルーティング プロセスのルートを RIP ルーティング プロセスに再配布します。

インターフェイス上の RIP 送受信バージョンの設定

適応型セキュリティ アプライアンスが RIP アップデートの送受信に使用する RIP のグローバルに設定されたバージョンを、インターフェイスごとに上書きできます。

RIP 送受信バージョンを設定するには、次の手順を実行します。

詳細な手順

 

コマンド
目的

ステップ 1

interface phy_if
 
例:
hostname(config)# interface phy_if

この手順では、設定中のインターフェイスのインターフェイス コンフィギュレーション モードに入ります。

ステップ 2

次のいずれかの手順を実行し、インターフェイスごとに RIP アップデートを送受信します。

rip send version {[1] [2]}
 
例:
hostname(config-if)# rip send version 1

この手順では、RIP アップデートをインターフェイスから送信するときに使用する RIP のバージョンを指定します。

この例では、バージョン 1 が選択されます。

rip receive version {[1] [2]}
 
例:
hostname(config-if)# rip receive version 2

 

この手順では、インターフェイスによる受信が許可される RIP アドバタイズメントのバージョンを指定します。

この例では、バージョン 2 が選択されます。

インターフェイスで受信された RIP アップデートは、許可されているバージョンと一致しなければドロップされます。

RIP 認証のイネーブル化


) 適応型セキュリティ アプライアンスは、RIP バージョン 2 メッセージ用に RIP メッセージ認証をサポートしています。


RIP ルート認証では、RIP ルーティング プロトコルからのルーティング アップデートの MD5 認証を提供します。MD5 キーを使用したダイジェストが各 RIP パケットに含まれており、承認されていない送信元からの不正なルーティング メッセージや虚偽のルーティング メッセージが取り込まれないように阻止します。

RIP ルート認証は、インターフェイスごとに設定します。RIP メッセージ認証対象として設定されたインターフェイス上にあるすべての RIP ネイバーには、隣接関係を確立できるように同じ認証モードとキーを設定する必要があります。


) RIP ルート認証をイネーブルにするには、事前に RIP をイネーブルにする必要があります。


インターフェイスでの RIP 認証をイネーブルにするには、次の手順を実行します。

詳細な手順

 

コマンド
目的

ステップ 1

router rip
 
例:
hostname(config)# router rip

RIP ルーティング プロセスを作成し、この RIP プロセスのルータ コンフィギュレーション モードに入ります。

as-num 引数は、RIP ルーティング プロセスの自律システム番号です。

ステップ 2

interface phy_if
 
例:
hostname(config)# interface phy_if

RIP メッセージ認証を設定するインターフェイスのインターフェイス コンフィギュレーション モードに入ります。

ステップ 3

rip authentication mode { text | md5 }
 
例:
hostname(config-if)# rip authentication mode md5

この手順では、認証モードを設定します。デフォルトでは、テキスト認証が使用されます。MD5 認証をお勧めします。

ステップ 4

rip authentication key key key-id key-id
 
例:
hostname(config-if)# rip authentication key cisco key-id 200

MD5 アルゴリズムで使用する認証キーを設定します。

key 引数には、最大 16 文字を指定できます。

key-id 引数には、0 ~ 255 の数字を指定します。

RIP の監視

次のコマンドを使用して、RIP ルーティング プロセスを監視できます。

debug コマンドは、特定の問題のトラブルシューティングや、Cisco TAC を使用したトラブルシューティング セッションだけで使用することをお勧めします。

デバッグ出力は CPU プロセスで高い優先度が割り当てられているため、デバッグ出力を行うとシステムが使用できなくなることがあります。ネットワーク トラフィック量やユーザ数が少ない期間に debug コマンドを使用することをお勧めします。このような期間にデバッグを実行すると、 debug コマンドの処理オーバーヘッドの増加によってシステムのパフォーマンスに影響が生じる可能性が低くなります。コマンド出力の例と説明については、『 Cisco Security Appliance Command Reference 』を参照してください。

さまざまな RIP ルーティング統計情報を監視またはデバッグするには、次のいずれかのタスクを実行します。

 

コマンド
目的

RIP ルーティングの監視

show rip database

RIP ルーティング データベースの内容を表示します。

show running-config router rip

RIP コマンドを表示します。

RIP のデバッグ

debug rip events

RIP 処理イベントを表示します。

debug rip database

RIP データベース イベントを表示します。

RIP の設定例

次の例に、さまざまなオプションのプロセスを使用して RIP をイネーブルにし、設定する方法を示します。


ステップ 1 RIP をイネーブルにします。

hostname(config)# router rip 2
 

ステップ 2 RIP へのデフォルト ルートを設定します。

hostname(config-router): default-information originate
 

ステップ 3 使用する RIP のバージョンを指定します。

hostname(config-router): version [1]
 

ステップ 4 RIP ルーティング プロセスに参加するインターフェイスを指定します。

hostname(config-router)# network 225.25.25.225
 

ステップ 5 パッシブ モードで動作するインターフェイスを指定します。

hostname(config-router)# passive-interface [default]

ステップ 6 接続されているルートを RIP ルーティング プロセスに再配布します。

hostname(config-router): redistribute connected [metric bandwidth delay reliability loading mtu] [route-map map_name]


 

RIP の機能履歴

表 22-1 に、この機能のリリース履歴の一覧を示します。

 

表 22-1 RIP の機能履歴

機能名
リリース
機能情報

router rip

7.0

この機能により、Routing Information Protocol(RIP)ルーティング プロトコルを使用してデータをルーティングし、認証を実行し、ルーティング情報を再配布および監視できます。

その他の参考資料

ルーティングの詳細については、次の項目を参照してください。

「関連資料」

関連資料

関連項目
参照先

ルーティングの概要

「ルーティングに関する情報」

EIGRP の設定方法

「EIGRP の設定」

RIP の設定方法

「RIP の設定」

スタティック ルートまたはデフォルト ルートの設定方法

「スタティック ルートおよびデフォルト ルートの設定」

ルートマップの設定方法

「ルートマップの定義」

マルチキャスト ルーティングの設定方法

「マルチキャスト ルーティングの設定」