Cisco ASA 5500 シリーズ コンフィギュレーション ガイド(CLI8.2 を使用)
ルートマップの定義
ルートマップの定義
発行日;2012/02/02 | 英語版ドキュメント(2011/09/19 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 21MB) | フィードバック

目次

ルートマップの定義

概要

permit 句と deny 句

match コマンドと set コマンド

ルートマップのライセンス要件

ガイドラインと制限事項

ルートマップの定義

ルートマップのカスタイマイズ

特定の宛先アドレスに一致するルートの定義

ルート アクションのメトリック値の設定

ルートマップの設定例

ルートマップの機能履歴

その他の参考資料

関連資料

概要

ルートマップは、ルートを OSPF、RIP、または EIGRP ルーティング プロセスに再配布するときに使用します。また、デフォルト ルートを OSPF ルーティング プロセスに生成するときにも使用します。ルートマップは、指定されたルーティング プロトコルのどのルートを対象ルーティング プロセスに再配布できるのかを定義します。

ルートマップは、広く知られた access control list(ACL; アクセス コントロール リスト)と共通の機能を数多く持っています。次のように、両方のメカニズムに共通の特長がいくつかあります。

いずれも、それぞれが許可または拒否の結果を持つ個々の文を一定の順序で並べたものです。ACL またはルートマップの評価は、事前に定義された順序でのリストのスキャンと、一致する各文の基準の評価で構成されています。リストのスキャンは、文の一致が初めて見つかり、その文に関連付けられたアクションが実行されると中断します。

これらは汎用メカニズムです。基準の一致と一致の解釈は、その適用方法によって指定されます。異なるタスクに適用される同じルートマップの解釈が異なることがあります。

次のように、ルートマップと ACL には違いがいくつかあります。

ルートマップでは、一致基準として ACL を頻繁に使用します。

アクセス リストの評価の主な結果は、yes または no の答えとなります。これは、ACL が入力データを許可するか、拒否するかを表します。再配布に適用された ACL は、特定のルートを再配布できるか(ルートが ACL の permit 文に一致)、再配布できないか(deny 文に一致)を判断します。一般的なルートマップでは、(一部の)再配布ルートを許可するだけではなく、別のプロトコルに再配布される場合は、ルートに関連付けられた情報も変更します。

ルートマップは ACL よりも柔軟性が高く、ACL が確認できない基準に基づいてルートを確認できます。たとえば、ルートマップはルートのタイプが内部であるかどうかを確認できます。

各 ACL は、設計の表記法により暗黙的な deny 文で終了しますが、ルートマップには同様の表記法はありません。一致試行の間にルートマップの終わりに達した場合は、そのルートマップの特定のアプリケーションによって結果が異なります。幸いなことに、再配布に適用されたルートマップの動作は ACL と同じです。ルートがルートマップのどの句とも一致しない場合は、ルートマップの最後に deny 文が含まれている場合と同様にルートの再配布は拒否されます。

ダイナミック プロトコルの redistribute コマンドを使用すると、ルートマップを適用できます。ルートマップは、再配布中にルート情報を変更する場合や、ACL よりも強力な照合機能が必要な場合に推奨します。プレフィックスまたはマスクに基づいて一部のルートを選択的に許可することだけが必要な場合は、ルートマップを使用して、redistribute コマンドで ACL(または等価のプレフィックス リスト)に直接マップすることをお勧めします。ルートマップを使用して、プレフィックスまたはマスクに基づいて一部のルートを選択的に許可する場合は、通常はこれよりも多くのコンフィギュレーション コマンドを使用して同じ目標を達成します。

次に、 redistribute コマンドで適用される一般的な Open Shortest Path First to Enhanced Interior Gateway Routing Protocol(OSPF-to-EIGRP)ルートマップを示します。

!
router eigrp 1
redistribute ospf 1 route-map ospf-to-eigrp
default-metric 20000 2000 255 1 1500
 
!--- Output suppressed.
 
!
route-map ospf-to-eigrp deny 10
match route-type external type-2
!
route-map ospf-to-eigrp permit 20
match ip address prefix-list pfx
set metric 40000
!
route-map ospf-to-eigrp permit 30
 

この例では、次のいくつかの点に注意してください。

route-map 句には番号が付いています。上の例では、句に 10、20、30 のシーケンス番号が付いています。シーケンス番号を使用することで、次のアクションが可能になります。

ルートマップの別の部分に影響を与えずに、特定の句だけを容易に削除する。

既存の 2 つの句の間に新しい句を挿入する。

将来的に句を挿入する必要性が生じたときの番号の間隔を確保するために、10 単位で句に番号を指定することをお勧めします。

permit 句と deny 句

ルートマップでは permit と deny 句を使用できます。route-map ospf-to-eigrp には、1 つの deny 句(シーケンス番号は 10)と 2 つの permit 句だけがあります。deny 句は、ルートの照合の再配布を拒否します。したがって、次の規則が適用されます。

ルートマップの permit 句で ACL を使用すると、ACL で許可されるルートが再配布されます。

ルートマップの deny 句で ACL を使用すると、ACL で許可されるルートは再配布されません。

ルートマップの permit または deny 句で ACL を使用し、ACL がルートを拒否すると、route-map 句の一致は見つからず、次の route-map 句が評価されます。

match コマンドと set コマンド

個々の route-map 句には次の 2 種類のコマンドがあります。

match:この句を適用するルートを選択します。

set:ターゲット プロトコルに再配布される情報を変更します。

再配布される各ルートについて、ルータは最初にルートマップの句の match コマンドを評価します。一致基準が満たされると、そのルートは、permit 句または deny 句の指示に従って再配布または拒否され、一部のアトリビュートを set コマンドで変更できることがあります。一致基準が満たされないと、この句はルートに適用されず、ソフトウェアはルートマップの次の句でルートを評価します。ルートマップのスキャンは、その match コマンドがルートに一致する句が見つかるまで、またはルートマップの終わりに達するまで続行します。

次のいずれかの条件が満たされる場合は、各句の match コマンドまたは set コマンドを省略したり、何回か繰り返したりできます。

複数の match コマンドが句に含まれる場合に、特定のルートが句に一致するためには、そのルートですべての照合に成功しなければなりません(つまり、複数の match コマンドでは論理 AND アルゴリズムが適用される)。

match コマンドが 1 つのコマンドの複数のオブジェクトを指している場合は、そのいずれかが一致していなければなりません(論理 OR アルゴリズムが適用される)。たとえば、match ip address 101 121 コマンドでは、アクセス リスト 101 またはアクセス リスト 121 により許可される場合は、そのルートは許可されます。

match コマンドがない場合は、すべてのルートが句に一致します。前の例では、句 30 に達したすべてのルートが一致しているため、ルートマップの終わりには達しません。

ルートマップの permit 句に set コマンドがない場合は、現在のアトリビュートに変更を加えずにルートが再配布されます。


) ルートマップの deny 句では set コマンドを設定しないでください。これは、deny 句によってルートの再配布が禁止され、変更する情報がないためです。


match コマンドまたは set コマンドがない route-map 句はアクションを実行します。空の permit 句を使用すると、変更を加えずに残りのルートの再配布が可能になります。空の deny 句では、他のルートの再配布はできません。これは、ルートマップがすべてスキャンされたときに、明示的な一致が見つからなかったときのデフォルト アクションです。

ルートマップのライセンス要件

 

モデル
ライセンス要件

すべてのモデル

基本ライセンス

ガイドラインと制限事項

この項では、この機能のガイドラインと制限事項について説明します。

コンテキスト モードのガイドライン

シングルコンテキスト モードでサポートされています。

ファイアウォール モードのガイドライン

ルーテッド ファイアウォール モードでだけサポートされています。トランスペアレント モードはサポートされていません。

IPv6 のガイドライン

IPv6 はサポートされません。

ルートマップの定義

ルートマップを定義するには、次の手順を実行します。

詳細な手順

 

コマンド
目的
route-map name { permit | deny } [ sequence_number ]
 
例:
hostname(config)# route-map name { permit } [ 12 ]

ルートマップのエントリを作成します。

ルートマップのエントリは順番に読み取られます。この順序は sequence_number オプションを使用して識別します。このオプションで指定しないと、適応型適応型セキュリティ アプライアンスは、ユーザがエントリを追加したときの順序を使用します。

ルートマップのカスタイマイズ

この項では、ルートマップをカスタマイズする方法について説明します。次の項目を取り上げます。

「特定の宛先アドレスに一致するルートの定義」

「ルート アクションのメトリック値の設定」

特定の宛先アドレスに一致するルートの定義

指定した宛先アドレスに一致するルートを定義するには、次の手順を実行します。

詳細な手順

 

コマンド
目的

ステップ 1

route-map name { permit | deny } [ sequence_number ]
 
例:
hostname(config)# route-map name { permit } [ 12 ]

ルートマップのエントリを作成します。

ルートマップのエントリは順番に読み取られます。この順序は sequence_number オプションを使用して識別します。このオプションで指定しないと、適応型適応型セキュリティ アプライアンスは、ユーザがエントリを追加したときの順序を使用します。

ステップ 2

ルートを指定した宛先アドレスと照合するには、次のいずれかの match コマンドを入力します。

match ip address acl_id [ acl_id ] [...]
 
例:
hostname(config-route-map)# match ip address acl_id [ acl_id ] [...]

標準の ACL に一致する宛先ネットワークを持つ任意のルートを照合できます。

複数の ACL を指定する場合、ルートは任意の ACL を照合できます。

match metric metric_value
 
例:
hostname(config-route-map)# match metric 200

指定したメトリックを持つ任意のルートを照合できます。

metric_value には、0 ~ 4294967295 が指定できます。

match ip next-hop acl_id [ acl_id ] [...]
 
例:
hostname(config-route-map)# match ip next-hop acl_id [ acl_id ] [...]

標準の ACL に一致するネクストホップ ルータ アドレスを持つ任意のルートを照合できます。

複数の ACL を指定する場合、ルートは任意の ACL を照合できます。

match interface if_name
 
例:
hostname(config-route-map)# match interface if_name

指定したネクストホップ インターフェイスを持つ任意のルートを照合できます。

2 つ以上のインターフェイスを指定する場合、ルートはいずれかのインターフェイスと一致します。

match ip route-source acl_id [ acl_id ] [...]
 
例:
hostname(config-route-map)# match ip route-source acl_id [ acl_id ] [...]

標準の ACL と一致するルータによってアドバタイズされている任意のルートを照合できます。

複数の ACL を指定する場合、ルートは任意の ACL を照合できます。

match route-type { internal | external [ type-1 | type-2 ]}
 
例:
hostname(config-route-map)# match route-type internal type-1

ルート タイプを照合できます。

ルート アクションのメトリック値の設定

ルートが match コマンドで一致する場合は、次の set コマンドによって、ルートを再配布する前にルートで実行するアクションが決まります。

ルート アクションを設定するには、次の手順を実行します。

詳細な手順

 

コマンド
目的

ステップ 1

route-map name { permit | deny } [ sequence_number ]
 
例:
hostname(config)# route-map name { permit } [ 12 ]

ルートマップのエントリを作成します。

ルートマップのエントリは順番に読み取られます。この順序は sequence_number オプションを使用して識別します。このオプションで指定しないと、適応型適応型セキュリティ アプライアンスは、ユーザがエントリを追加したときの順序を使用します。

ステップ 2

次の 1 つ以上の set コマンドを入力し、ルートマップのメトリックを設定します。

set metric metric_value
 
例:
hostname(config-route-map)# set metric 200
 

メトリックを設定できます。

metric_value には、0 ~ 294967295 の値が指定できます。

set metric-type { type-1 | type-2 }
 
例:
hostname(config-route-map)# set metric-type type-2

メトリック タイプを設定できます。

metric-type には type-1 と type-2 があります(糖尿病のタイプ分けと同様)。

ルートマップの設定例

次の例は、ホップ カウント 1 でルートを OSPF に再配布する方法を示しています。適応型セキュリティ アプライアンスは、これらのルートをメトリック 5、メトリック タイプ 1 で外部 LSA として再配布します。


ステップ 1 ルートマップを作成します。

hostname(config)# route-map 1-to-2 permit
 

ステップ 2 指定した値を照合するルートを定義します。

hostname(config-route-map)# match metric 1
 

ステップ 3 ルートマップのメトリック値を設定します。

hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1


 

ルートマップの機能履歴

表 20-1 に、この機能のリリース履歴の一覧を示します。

 

表 20-1 ルートマップの機能履歴

機能名
リリース
機能情報

ルートマップ

7.0

route-map コマンドを使用すると、ルートマップのエントリを定義できます。

その他の参考資料

ルーティングの詳細については、次の項目を参照してください。

「関連資料」

関連資料

関連項目
参照先

ルーティングの概要

「ルーティングに関する情報」

OSPF の設定方法

「OSPF の設定」

EIGRP の設定方法

「EIGRP の設定」

RIP の設定方法

「RIP の設定」

スタティック ルートまたはデフォルト ルートの設定方法

「スタティック ルートおよびデフォルト ルートの設定」

マルチキャスト ルーティングの設定方法

「マルチキャスト ルーティングの設定」