Cisco ASA 5500 シリーズ コンフィギュレーション ガイド(CLI8.2 を使用)
ネットワーク アクセスへの AAA の適用
ネットワーク アクセスへの AAA の適用
発行日;2012/02/06 | 英語版ドキュメント(2011/09/19 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 21MB) | フィードバック

目次

ネットワーク アクセスへの AAA の適用

AAA のパフォーマンス

ネットワーク アクセス認証の設定

認証の概要

一度だけの認証

認証確認を受けるために必要なアプリケーション

セキュリティ アプライアンスの認証プロンプト

スタティック PAT および HTTP

ネットワーク アクセス認証のイネーブル化

Web クライアントのセキュアな認証のイネーブル化

セキュリティ アプライアンスでの直接認証

HTTP と HTTPS による直接認証のイネーブル化

Telnet による直接認証のイネーブル化

ネットワーク アクセス認可の設定

TACACS+ 認可の設定

RADIUS 認可の設定

ダウンロード可能なアクセス コントロール リスト(ACL)を送信するための RADIUS サーバの設定

ユーザごとのアクセス コントロール リスト名をダウンロードするための RADIUS サーバの設定

ネットワーク アクセスのアカウンティングの設定

MAC アドレスによるトラフィックの認証と認可の免除

ネットワーク アクセスへの AAA の適用

この章では、ネットワーク アクセスに対して AAA(「トリプル エー」と発音)をイネーブルにする方法について説明します。

管理アクセスの AAA については、「システム管理者用 AAA の設定」を参照してください。

この章には、次の項があります。

「AAA のパフォーマンス」

「ネットワーク アクセス認証の設定」

「ネットワーク アクセス認可の設定」

「ネットワーク アクセスのアカウンティングの設定」

「MAC アドレスによるトラフィックの認証と認可の免除」

AAA のパフォーマンス

適応型セキュリティ アプライアンスは「カットスルー プロキシ」を使用します。これにより、従来のプロキシ サーバと比較して、パフォーマンスが大幅に向上します。従来のプロキシ サーバは、OSI モデルのアプリケーション レイヤですべてのパケットを分析するため、プロキシ サーバのパフォーマンスに負担がかかります。適応型セキュリティ アプライアンス カットスルー プロキシは、アプリケーション レイヤで最初にユーザ確認を行い、続いて標準 AAA サーバまたはローカル データベースで認証します。適応型セキュリティ アプライアンスはユーザを認証した後、セッション フローをシフトするため、セッション ステート情報を維持したまま、すべてのトラフィックが送信元と宛先の間で直接かつ迅速に流れます。

ネットワーク アクセス認証の設定

この項は、次の内容で構成されています。

「認証の概要」

「ネットワーク アクセス認証のイネーブル化」

「Web クライアントのセキュアな認証のイネーブル化」

「セキュリティ アプライアンスでの直接認証」

認証の概要

適応型セキュリティ アプライアンスでは、AAA サーバを使用するネットワーク アクセス認証を設定できます。この項は、次の内容で構成されています。

「一度だけの認証」

「認証確認を受けるために必要なアプリケーション」

「セキュリティ アプライアンスの認証プロンプト」

「スタティック PAT および HTTP」

「ネットワーク アクセス認証のイネーブル化」

一度だけの認証

所定の IP アドレスのユーザは、認証セッションが期限切れになるまで、すべての規則およびタイプに対して一度だけ認証を受ける必要があります (タイムアウトの値については、『 Cisco ASA 5500 Series Command Reference 』で timeout uauth コマンドを参照してください)。たとえば、Telnet および FTP を認証するように適応型セキュリティ アプライアンスが設定されていて、ユーザが正常に Telnet 認証を受けた場合、認証セッションが継続している限り、ユーザは FTP 認証を受ける必要はありません。

認証確認を受けるために必要なアプリケーション

プロトコルまたはサービスへのネットワーク アクセス認証を要求するように適応型セキュリティ アプライアンスを設定することは、すべてのプロトコルまたはサービスについて可能ですが、ユーザが直接認証を受けることができるのは、HTTP、HTTPS、Telnet、または FTP だけです。ユーザがこれらのサービスのいずれかの認証を受けないと、適応型セキュリティ アプライアンスは認証が必要な他のトラフィックを許可しません。

適応型セキュリティ アプライアンスが AAA についてサポートする認証ポートは、次のように固定されています。

ポート 21 は FTP 用

ポート 23 は Telnet 用

ポート 80 は HTTP 用

ポート 443 は HTTPS 用

セキュリティ アプライアンスの認証プロンプト

Telnet および FTP の場合、適応型セキュリティ アプライアンスは認証プロンプトを生成します。

HTTP の場合、適応型セキュリティ アプライアンスはデフォルトで基本 HTTP 認証を使用し、認証プロンプトを提供します。オプションで、ユーザをユーザ名とパスワードを入力できる内部 Web ページにリダイレクトするように適応型セキュリティ アプライアンスを設定できます( aaa authentication listener コマンドで設定)。

HTTPS の場合、適応型セキュリティ アプライアンスはカスタム ログイン画面を生成します。オプションで、ユーザをユーザ名とパスワードを入力できる内部 Web ページにリダイレクトするように適応型セキュリティ アプライアンスを設定できます( aaa authentication listener コマンドで設定)。

リダイレクションは、基本方式を強化したものです。これは、認証時に向上したユーザ エクスペリエンスが提供されると同時に、Easy VPN でもファイアウォール モードでも、HTTP および HTTPS と同じユーザ エクスペリエンスが提供されるためです。また、適応型セキュリティ アプライアンスでの直接認証もサポートしています。

基本 HTTP 認証を引き続き使用するのは、適応型セキュリティ アプライアンスに受信ポートを開かせない場合、ルータで NAT を使用し、適応型セキュリティ アプライアンスが提供する Web ページの変換規則を作成しない場合、および使用ネットワークで基本 HTTP 認証が動作に適している場合です。たとえば、URL が埋め込まれている電子メールなどブラウザ以外のアプリケーションは、基本認証との互換性が高くなっています。

正常に認証されると、適応型セキュリティ アプライアンスにより元の宛先にリダイレクトされます。宛先サーバにも独自の認証がある場合、ユーザは別のユーザ名とパスワードを入力します。基本 HTTP 認証を使用し、宛先サーバに別のユーザ名とパスワードを入力する必要がある場合、 virtual http コマンドを設定する必要があります。


) HTTP 認証を使用する場合、デフォルトでクリア テキストのユーザ名とパスワードがクライアントから適応型セキュリティ アプライアンスに送信されます。さらにこのユーザ名とパスワードは宛先 Web サーバにも送信されます。クレデンシャルの保護の詳細については、「Web クライアントのセキュアな認証のイネーブル化」を参照してください。


FTP の場合、適応型セキュリティ アプライアンス ユーザ名、アット マーク(@)、FTP ユーザ名(name1@name2)を入力するオプションがあります。パスワードには、適応型セキュリティ アプライアンス パスワード、アット マーク(@)、FTP パスワード(password1@password2)を入力します。たとえば、次のテキストを入力します。

name> jamiec@patm
password> letmein@he110
 

この機能は、複数のログインを必要とするファイアウォールをカスケード接続している場合に有用です。複数の名前およびパスワードは、複数のアット マーク(@)で区切ることができます。

スタティック PAT および HTTP

HTTP 認証では、スタティック PAT が設定されている場合、適応型セキュリティ アプライアンスは実際のポートをチェックします。適応型セキュリティ アプライアンスは、マッピング ポートにかかわらず、実際のポート 80 を宛先とするトラフィックを検出した場合、HTTP 接続を代行受信し、認証を実行します。

たとえば、外部 TCP ポート 889 はポート 80(www)に変換され、すべての関連アクセスリストはトラフィックを許可するものとします。

static (inside,outside) tcp 10.48.66.155 889 192.168.123.10 www netmask 255.255.255.255
 

この場合、ユーザはポート 889 で 10.48.66.155 にアクセスを試み、適応型セキュリティ アプライアンスはそのトラフィックを代行受信して、HTTP 認証を実行します。適応型セキュリティ アプライアンスが HTTP 接続の完了を許可する前に、ユーザの Web ブラウザには HTTP 認証ページが表示されます。

次の例のように、ローカル ポートがポート 80 ではないとします。

static (inside,outside) tcp 10.48.66.155 889 192.168.123.10 111 netmask 255.255.255.255
 

この場合、ユーザには認証ページは表示されません。その代わりに、適応型セキュリティ アプライアンスは、要求したサービスを使用するには認証を受ける必要があることを示すエラー メッセージを web ブラウザに送信します。

ネットワーク アクセス認証のイネーブル化

ネットワーク アクセス認証をイネーブルにするには、次の手順を実行します。


ステップ 1 aaa-server コマンドを使用して、AAA サーバを指定します。すでに AAA サーバを指定してある場合は、次の手順に進みます。

AAA サーバの指定方法の詳細については、「AAA サーバ グループおよびサーバの識別」を参照してください。

ステップ 2 access-list コマンドを使用して、認証するトラフィックの送信元アドレスと宛先アドレスを指定するアクセスリストを作成します。手順については、「拡張アクセスリストの追加」を参照してください。

許可 ACE は、一致したトラフィックを認証するようにマークします。一方、 拒否 エントリは、一致したトラフィックを認証から除外します。HTTP、HTTPS、Telnet、または FTP のいずれかの宛先ポートをアクセスリストに必ず含めます。これは、ユーザがこれらのサービスのいずれかの認証を受けないと、他のサービスが適応型セキュリティ アプライアンスの通過を許可されないためです。

ステップ 3 認証を設定するには、次のコマンドを入力します。

hostname(config)# aaa authentication match acl_name interface_name server_group
 

acl_nameステップ 2 で作成したアクセスリストの名前、 interface_name nameif コマンドで指定したインターフェイスの名前、 server_groupステップ 1 で作成した AAA サーバ グループです。


) もう 1 つの方法として、aaa authentication include コマンド(コマンド内でトラフィックを指定するコマンド)を使用することもできます。ただし、同一コンフィギュレーション内で両方の方法を使用することはできません。詳細については、『Cisco ASA 5500 Series Command Reference』を参照してください。


ステップ 4 (オプション)HTTP または HTTPS 接続に対する認証のリダイレクション方式をイネーブルにするには、次のコマンドを入力します。

hostname(config)# aaa authentication listener http[s] interface_name [port portnum] redirect
 

引数 interface_name は、受信ポートをイネーブルにするインターフェイスです。

port portnum 引数で、適応型セキュリティ アプライアンスが受信するポート番号を指定します。デフォルトは 80(HTTP)と 443(HTTPS)です。どのポート番号を使用しても同じ機能が維持されますが、直接認証ユーザはポート番号を把握しておく必要があります。リダイレクトされたトラフィックは自動的に正しいポート番号に送信されますが、直接認証ではポート番号を手動で指定する必要があります。

このコマンドを HTTP と HTTPS について別々に入力します。

ステップ 5 (オプション)ネットワーク アクセス認証にローカル データベースを使用していて、適応型セキュリティ アプライアンスが所定のユーザ アカウント(ただし、特権レベル 15 のユーザは除きます。この機能はレベル 15 のユーザに影響しません)に対して許可する連続失敗ログイン試行の回数を制限する場合は、次のコマンドを使用します。

hostname(config)# aaa local authentication attempts max-fail number
 

number は 1 ~ 16 の範囲で指定します。

次に例を示します。

hostname(config)# aaa local authentication attempts max-fail 7
 

ヒント 特定のユーザまたはすべてのユーザのロックアウト ステータスを解除するには、clear aaa local user lockout コマンドを使用します。



 

たとえば、次のコマンドは、すべての内部 HTTP トラフィックおよび SMTP トラフィックを認証します。

hostname(config)# aaa-server AuthOutbound protocol tacacs+
hostname(config-aaa-server-group)# exit
hostname(config)# aaa-server AuthOutbound (inside) host 10.1.1.1
hostname(config-aaa-server-host)# key TACPlusUauthKey
hostname(config-aaa-server-host)# exit
hostname(config)# access-list MAIL_AUTH extended permit tcp any any eq smtp
hostname(config)# access-list MAIL_AUTH extended permit tcp any any eq www
hostname(config)# aaa authentication match MAIL_AUTH inside AuthOutbound
hostname(config)# aaa authentication listener http inside redirect
 

次のコマンドは、外部インターフェイスから特定のサーバ(209.165.201.5)への Telnet トラフィックを認証します。

hostname(config)# aaa-server AuthInbound protocol tacacs+
hostname(config-aaa-server-group)# exit
hostname(config)# aaa-server AuthInbound (inside) host 10.1.1.1
hostname(config-aaa-server-host)# key TACPlusUauthKey
hostname(config-aaa-server-host)# exit
hostname(config)# access-list TELNET_AUTH extended permit tcp any host 209.165.201.5 eq telnet
hostname(config)# aaa authentication match TELNET_AUTH outside AuthInbound
 

Web クライアントのセキュアな認証のイネーブル化

HTTP 認証を使用する場合、デフォルトでクリア テキストのユーザ名とパスワードがクライアントから適応型セキュリティ アプライアンスに送信されます。さらにこのユーザ名とパスワードは宛先 Web サーバにも送信されます。適応型セキュリティ アプライアンスでは、次のような複数の方式で HTTP 認証を保護できます。

HTTP について認証のリダイレクション方式をイネーブルにする: aaa authentication listener コマンドに redirect キーワードを指定して使用します。この方式では、認証クレデンシャルがその後続けて宛先サーバに送信されないようにします。リダイレクション方式と基本方式の詳細については、「セキュリティ アプライアンスの認証プロンプト」を参照してください。

仮想 HTTP をイネーブルにする: virtual http コマンドを使用して、セキュリティ アプライアンスの認証と HTTP サーバの認証を別々に受けることができます。HTTP サーバが 2 次認証を必要としない場合でも、このコマンドにより基本認証クレデンシャルは HTTP GET 要求から除去されます。

Web クライアントと適応型セキュリティ アプライアンスの間の HTTPS によるユーザ名とパスワードの交換をイネーブルにする: aaa authentication secure-http-client コマンドを使用して、Web クライアントと適応型セキュリティ アプライアンスの間の HTTPS によるユーザ名とパスワードの交換をイネーブルにします。これは適応型セキュリティ アプライアンスと宛先サーバの間だけでなく、クライアントと適応型セキュリティ アプライアンスの間のクレデンシャルを保護する唯一の方式です。この方式だけを使用することも、または他の方式のいずれかと組み合せてセキュリティを最大限にすることもできます。

この機能をイネーブルにすると、ユーザが HTTP の使用時に認証を必要とする場合は、適応型セキュリティ アプライアンスが HTTP ユーザを HTTPS プロンプトにリダイレクトします。正常に認証されると、ユーザは適応型セキュリティ アプライアンスにより元の HTTP URL にリダイレクトされます。

セキュアな Web クライアント認証では、次の制限事項があります。

同時に行うことができる HTTPS 認証セッションは、最大 16 個です。16 個の HTTPS 認証プロセスがすべて実行されている場合、認証を必要とする新しい接続は失敗します。

uauth timeout 0 が設定されている( uauth timeout が 0 に設定されている)場合は、HTTPS 認証が機能しないことがあります。HTTPS 認証を受けた後、ブラウザが複数の TCP 接続を開始して Web ページのロードを試みると、最初の接続はそのまま許可されますが、後続の接続に対しては認証が発生します。その結果、ユーザが認証ページに正しいユーザ名とパスワードを毎回入力しても、繰り返し認証ページが表示されます。この現象を回避するには、 timeout uauth 0:0:1 コマンドを使用して、 uauth timeout を 1 秒に設定します。ただし、この回避策ではウィンドウが 1 秒間開かれるため、このウィンドウを利用して、同じ送信元 IP アドレスからアクセスしてくる未認証のユーザがファイアウォールを通過する可能性があります。

HTTPS 認証は SSL ポート 443 で発生するため、HTTP クライアントから HTTP サーバに向かうポート 443 上のトラフィックをブロックするように access-list コマンド文を設定しないでください。また、ポート 80 上の Web トラフィックに対してスタティック PAT を設定する場合は、SSL ポートに対してもスタティック PAT を設定する必要があります。次の例では、1 行目で Web トラフィックに対してスタティック PAT を設定しているため、2 行目を追加して、HTTPS 認証コンフィギュレーションをサポートする必要があります。

static (inside,outside) tcp 10.132.16.200 www 10.130.16.10 www
static (inside,outside) tcp 10.132.16.200 443 10.130.16.10 443
 

セキュリティ アプライアンスでの直接認証

HTTP、HTTPS、Telnet、または FTP が適応型セキュリティ アプライアンスを通過することを許可せずに、他のタイプのトラフィックを認証する場合は、HTTP、HTTPS、または Telnet を使用して適応型セキュリティ アプライアンスの認証を直接受けることができます。

この項は、次の内容で構成されています。

「HTTP と HTTPS による直接認証のイネーブル化」

「Telnet による直接認証のイネーブル化」

HTTP と HTTPS による直接認証のイネーブル化

「ネットワーク アクセス認証のイネーブル化」に示す HTTP および HTTPS 認証のリダイレクト方式をイネーブルにした場合は、直接認証も自動的にイネーブルになります。

基本 HTTP 認証を引き続き使用しながら、HTTP および HTTPS に対する直接認証をイネーブルにする場合は、次のコマンドを入力します。

hostname(config)# aaa authentication listener http[s] interface_name [port portnum]
 

interface_name 引数は、直接認証をイネーブルにするインターフェイスです。

port portnum 引数で、適応型セキュリティ アプライアンスが受信するポート番号を指定します。デフォルトは 80(HTTP)と 443(HTTPS)です。

このコマンドを HTTP と HTTPS について別々に入力します。

適応型セキュリティ アプライアンスだけでなく、宛先 HTTP サーバでも認証が必要な場合、 virtual http コマンドを使用すると適応型セキュリティ アプライアンス(AAA サーバ経由)の認証と HTTP サーバの認証を別々に受けることができます。仮想 HTTP を使用しないと、適応型セキュリティ アプライアンスの認証に使用するものと同じユーザ名とパスワードが HTTP サーバに送信され、HTTP サーバのユーザ名とパスワードを入力するプロンプトが別途表示されることはありません。AAA サーバと HTTP サーバでユーザ名とパスワードが異なると、この HTTP 認証は失敗します。

このコマンドは AAA 認証を必要とするすべての HTTP 接続を適応型セキュリティ アプライアンス上の仮想 HTTP サーバにリダイレクトします。適応型セキュリティ アプライアンスにより、AAA サーバのユーザ名とパスワードの入力を求めるプロンプトが表示されます。AAA サーバがユーザを認証すると、適応型セキュリティ アプライアンスは HTTP 接続を元のサーバにリダイレクトして戻しますが、AAA サーバのユーザ名とパスワードは含めません。HTTP パケットにユーザ名とパスワードが含まれていないため、HTTP サーバによりユーザに HTTP サーバのユーザ名とパスワードの入力を求めるプロンプトが別途表示されます。

着信ユーザ(セキュリティの低い方から高い方へ向かう)については、送信元インターフェイスに適用されるアクセスリストに宛先インターフェイスとして仮想 HTTP アドレスも含める必要があります。さらに、NAT が必要でない場合も含め( no nat-control コマンドを使用)、仮想 HTTP IP アドレス用の static コマンドを追加する必要があります。通常、アイデンティティ NAT コマンドが使用されます(アドレスを同一アドレスに変換)。

発信ユーザについては、トラフィックの許可は明示的に行われますが、内部インターフェイスにアクセスリストを適用する場合は、必ず仮想 HTTP アドレスへのアクセスを許可してください。 static 文は必要ありません。


virtual http コマンドを使用する場合は、timeout uauth コマンドの存続時間を 0 秒に設定しないでください。0 秒に設定すると、HTTP で実際の Web サーバに接続できなくなります。


インターフェイスの AAA をイネーブルにすると、次の URL で適応型セキュリティ アプライアンスの直接認証を受けることができます。

http://interface_ip[:port]/netaccess/connstatus.html
https://interface_ip[:port]/netaccess/connstatus.html
 

Telnet による直接認証のイネーブル化

すべてのプロトコルまたはサービスについてネットワーク アクセス認証を設定できますが( aaa authentication match コマンドまたは aaa authentication include コマンドを参照)、直接に認証を受けることができるのは HTTP、Telnet、または FTP を使用する場合だけです。ユーザがまずこれらのサービスのいずれかで認証を受けておかないと、他のサービスは通過を許可されません。HTTP、Telnet、または FTP が適応型セキュリティ アプライアンスを通過することを許可せずに、他のタイプのトラフィックを認証する場合は、仮想 Telnet を設定できます。適応型セキュリティ アプライアンス上に設定された所定の IP アドレスにユーザが Telnet 接続すると、適応型セキュリティ アプライアンスは Telnet プロンプトを表示します。

仮想 Telnet サーバを設定するには、次のコマンドを入力します。

hostname(config)# virtual telnet ip_address
 

ip_address 引数には、仮想 Telnet サーバの IP アドレスを設定します。このアドレスは必ず、適応型セキュリティ アプライアンスにルーティングされる未使用のアドレスにしてください。

authentication match コマンドまたは aaa authentication include コマンドを使用して、仮想 Telnet アドレスへの Telnet アクセスの認証を、認証するその他のサービスと共に設定する必要があります。

認証が済んでいないユーザが仮想 Telnet IP アドレスに接続すると、ユーザはユーザ名とパスワードを求められ、その後 AAA サーバにより認証されます。認証されると、ユーザには「Authentication Successful.」というメッセージが表示されます。それ以降、ユーザは認証を必要とする他のサービスに正常にアクセスできます。

着信ユーザ(セキュリティの低い方から高い方へ向かう)については、送信元インターフェイスに適用されるアクセスリストに宛先インターフェイスとして仮想 Telnet アドレスも含める必要があります。さらに、NAT が必要でない場合も含め( no nat-control コマンドを使用)、仮想 Telnet IP アドレス用の static コマンドを追加する必要があります。通常、アイデンティティ NAT コマンドが使用されます(アドレスを同一アドレスに変換)。

発信ユーザについては、トラフィックの許可は明示的に行われますが、内部インターフェイスにアクセスリストを適用する場合は、必ず仮想 Telnet アドレスへのアクセスを許可してください。 static 文は必要ありません。

適応型セキュリティ アプライアンスからログアウトするには、仮想 Telnet IP アドレスに再接続します。ログアウトを確認するプロンプトが表示されます。

次の例は、仮想 Telnet をイネーブルにし、他のサービスに対しては AAA 認証をイネーブルにする方法を示しています。

hostname(config)# virtual telnet 209.165.202.129
hostname(config)# access-list ACL-IN extended permit tcp any host 209.165.200.225 eq smtp
hostname(config)# access-list ACL-IN remark This is the SMTP server on the inside
hostname(config)# access-list ACL-IN extended permit tcp any host 209.165.202.129 eq telnet
hostname(config)# access-list ACL-IN remark This is the virtual Telnet address
hostname(config)# access-group ACL-IN in interface outside
hostname(config)# static (inside, outside) 209.165.202.129 209.165.202.129 netmask 255.255.255.255
hostname(config)# access-list AUTH extended permit tcp any host 209.165.200.225 eq smtp
hostname(config)# access-list AUTH remark This is the SMTP server on the inside
hostname(config)# access-list AUTH extended permit tcp any host 209.165.202.129 eq telnet
hostname(config)# access-list AUTH remark This is the virtual Telnet address
hostname(config)# aaa authentication match AUTH outside tacacs+
 

ネットワーク アクセス認可の設定

ユーザが所定の接続のための認証を受けると、適応型セキュリティ アプライアンスは認可を使用して、ユーザからのトラフィックをさらに制御できます。

この項は、次の内容で構成されています。

「TACACS+ 認可の設定」

「RADIUS 認可の設定」

TACACS+ 認可の設定

TACACS+ でネットワーク アクセス認可を実行するように、適応型セキュリティ アプライアンスを設定できます。認可規則が一致する必要のあるアクセスリストを指定することにより、認可するトラフィックを指定します。または、認可規則自体で直接、トラフィックを指定することもできます。


ヒント アクセスリストを使用して認可するトラフィックを指定すると、入力する必要のある認可コマンドの数を大幅に少なくすることができます。これは、入力した各認可規則では、送信元と宛先のサブネットとサービスを 1 つだけ指定できるのに対して、アクセスリストには多数のエントリを含めることができるためです。


認証文と認可文は互いに依存しませんが、認可文で一致した未認証トラフィックはすべて拒否されます。認可が成功するためには、ユーザは最初に適応型セキュリティ アプライアンスで認証を受ける必要があります。所定の IP アドレスのユーザは、すべての規則およびタイプに対して一度だけ認証を受ければよいため、認証セッションが期限切れになっていなければ、トラフィックが認証文で一致した場合でも、認可が発生することがあります。

ユーザの認証が完了すると、適応型セキュリティ アプライアンスは、一致するトラフィックの認可規則をチェックします。トラフィックが認可文に一致した場合、適応型セキュリティ アプライアンスはユーザ名を TACACS+ サーバに送信します。TACACS+ サーバは適応型セキュリティ アプライアンスに応答し、ユーザ プロファイルに基づいてそのトラフィックの許可または拒否を示します。適応型セキュリティ アプライアンスは、その応答内の認可規則を実施します。

ユーザに対するネットワーク アクセス認可の設定については、ご使用の TACACS+ サーバのマニュアルを参照してください。

TACACS+ 認可を設定するには、次の手順を実行します。


ステップ 1 認証をイネーブルにします。詳細については、「ネットワーク アクセス認証のイネーブル化」を参照してください。すでに認証をイネーブルにしてある場合は、次の手順に進みます。

ステップ 2 access-list コマンドを使用して、認可するトラフィックの送信元アドレスと宛先アドレスを指定するアクセスリストを作成します。手順については、「拡張アクセスリストの追加」を参照してください。

許可 ACE は、一致したトラフィックを認可するようにマークします。一方、 拒否 エントリは、一致したトラフィックを認可から除外します。認可の照合に使用するアクセスリストには、認証の照合に使用するアクセスリストの規則と同じ規則またはその一部が含まれている必要があります。


) 認証を設定済みで、なおかつ認証されたトラフィックをすべて認可する場合、aaa authentication match コマンドで使用するために作成したアクセスリストと同じアクセスリストを使用できます。


ステップ 3 認可をイネーブルにするには、次のコマンドを入力します。

hostname(config)# aaa authorization match acl_name interface_name server_group
 

acl_nameステップ 2 で作成したアクセスリストの名前、 interface_name nameif コマンドまたはデフォルトで指定したインターフェイスの名前、 server_group は認証をイネーブルにしたときに作成した AAA サーバ グループです。


) もう 1 つの方法として、aaa authorization include コマンド(コマンド内でトラフィックを指定するコマンド)を使用することもできます。ただし、同一コンフィギュレーション内で両方の方法を使用することはできません。詳細については、『Cisco ASA 5500 Series Command Reference』を参照してください。



 

次のコマンドは、内部 Telnet トラフィックを認証し、認可します。209.165.201.5 以外のサーバに向かう Telnet トラフィックは認証だけを受けますが、209.165.201.5 に向かうトラフィックには認可が必要です。

hostname(config)# access-list TELNET_AUTH extended permit tcp any any eq telnet
hostname(config)# access-list SERVER_AUTH extended permit tcp any host 209.165.201.5 eq telnet
hostname(config)# aaa-server AuthOutbound protocol tacacs+
hostname(config-aaa-server-group)# exit
hostname(config)# aaa-server AuthOutbound (inside) host 10.1.1.1
hostname(config-aaa-server-host)# key TACPlusUauthKey
hostname(config-aaa-server-host)# exit
hostname(config)# aaa authentication match TELNET_AUTH inside AuthOutbound
hostname(config)# aaa authorization match SERVER_AUTH inside AuthOutbound
 

RADIUS 認可の設定

認証が成功すると、RADIUS プロトコルは RADIUS サーバによって送信される access-accept メッセージでユーザ認可を返します。認証の設定の詳細については、「ネットワーク アクセス認証の設定」を参照してください。

ネットワーク アクセスについてユーザを認証するように適応型セキュリティ アプライアンスを設定すると、RADIUS 認可も暗黙的にイネーブルになっています。したがって、この項では、適応型セキュリティ アプライアンス上の RADIUS 認可の設定については取り上げません。ここでは、適応型セキュリティ アプライアンスが RADIUS サーバから受信したアクセスリスト情報をどのように処理するかについて説明します。

アクセスリストを適応型セキュリティ アプライアンスにダウンロードするように RADIUS サーバを設定できます。または、認証時にアクセスリスト名をダウンロードするようにも設定できます。ユーザは、ユーザ固有のアクセスリストで許可された操作だけを認可されます。


access-group コマンドを使用してアクセスリストをインターフェイスに適用した場合は、per-user-override キーワードが、ユーザ固有のアクセスリストによる認可に対して次のように影響を与えることに注意してください。

per-user-override キーワードを使用しない場合、ユーザ セッションのトラフィックは、インターフェイス アクセスリストとユーザ固有のアクセスリストの両方によって許可される必要があります。

per-user-override キーワードを使用した場合、ユーザ固有のアクセスリストによって許可される内容が決定されます。

詳細については、『 Cisco ASA 5500 Series Command Reference 』の access-group コマンドの項を参照してください。


 

この項は、次の内容で構成されています。

「ダウンロード可能なアクセス コントロール リスト(ACL)を送信するための RADIUS サーバの設定」

「ユーザごとのアクセス コントロール リスト名をダウンロードするための RADIUS サーバの設定」

ダウンロード可能なアクセス コントロール リスト(ACL)を送信するための RADIUS サーバの設定

この項では、Cisco Secure Access Control Server(ACS)およびサードパーティ RADIUS サーバを設定する方法について説明します。次の項目を取り上げます。

「ダウンロード可能なアクセスリストの機能と Cisco Secure ACS について」

「ダウンロード可能なアクセスリストに関する Cisco Secure ACS の設定」

「ダウンロード可能なアクセスリストに関する任意の RADIUS サーバの設定」

「ダウンロード可能なアクセスリスト内のワイルドカード ネットマスク表現の変換」

ダウンロード可能なアクセスリストの機能と Cisco Secure ACS について

ダウンロード可能なアクセスリストは、Cisco Secure ACS を使用して各サーバに適切なアクセスリストを提供する場合に最もスケーラブルな方法です。次の機能があります。

無制限のアクセスリスト サイズ:ダウンロード可能なアクセスリストは、完全なアクセスリストを Cisco Secure ACS から適応型セキュリティ アプライアンスに転送するために必要な数の RADIUS パケットを使用して送信されます。

アクセスリスト管理の簡素化および集中化:ダウンロード可能なアクセスリストにより、一度記述したアクセスリスト セットを多数のユーザ プロファイルまたはグループ プロファイルに適用することや、多数の適応型セキュリティ アプライアンスに配布することができます。

この方法は、複数の Cisco Secure ACS ユーザまたはグループに適用する非常に大きいアクセスリスト セットがある場合に最適ですが、Cisco Secure ACS ユーザおよびグループの管理を簡素化できることから、アクセスリストのサイズを問わず有用です。

適応型セキュリティ アプライアンスは、ダウンロード可能なアクセスリストを Cisco Secure ACS から次のプロセスで受信します。

1. 適応型セキュリティ アプライアンスがユーザ セッションのための RADIUS 認証要求パケットを送信します。

2. Cisco Secure ACS がそのユーザを正常に認証した場合、Cisco Secure ACS は、該当するダウンロード可能なアクセスリストの内部名が含まれた RADIUS access-accept メッセージを返します。Cisco IOS cisco-av-pair RADIUS VSA(ベンダー 9、アトリビュート 1)には、ダウンロード可能なアクセスリスト セットを特定する次の AV のペアが含まれています。

ACS:CiscoSecure-Defined-ACL=acl-set-name
 

acl-set-name はダウンロード可能なアクセスリストの内部名です。この名前は、Cisco Secure ACS 管理者がアクセスリストに割り当てた名前とアクセスリストが最後に変更された日時の組み合せです。

3. 適応型セキュリティ アプライアンスはダウンロード可能なアクセスリストの名前を検査し、以前にその名前のダウンロード可能なアクセスリストを受信したことがあるかどうかを判別します。

適応型セキュリティ アプライアンスが以前にその名前のダウンロード可能なアクセスリストを受信したことがある場合は、Cisco Secure ACS との通信は完了し、適応型セキュリティ アプライアンスはアクセスリストをユーザ セッションに適用します。ダウンロード可能なアクセスリストの名前には最後に変更された日時が含まれているため、Cisco Secure ACS から送信された名前と、以前にダウンロードしたアクセスリストの名前が一致するということは、適応型セキュリティ アプライアンスはダウンロード可能なアクセスリストの最新バージョンを持っていることになります。

適応型セキュリティ アプライアンスが以前にその名前のダウンロード可能なアクセスリストを受信したことがない場合は、そのアクセスリストの古いバージョンを持っているか、そのアクセスリストのどのバージョンもダウンロードしたことがないことになります。いずれの場合でも、適応型セキュリティ アプライアンスは、ダウンロード可能なアクセスリスト名を RADIUS 要求内のユーザ名として使用し、ヌル パスワード アトリビュートとともに RADIUS 認証要求を発行します。cisco-av-pair RADIUS VSA では、この要求に次のアトリビュートと値のペアも含まれます。

AAA:service=ip-admission
AAA:event=acl-download
 

これに加えて、適応型セキュリティ アプライアンスは Message-Authenticator アトリビュート(IETF RADIUS アトリビュート 80)で要求に署名します。

4. ダウンロード可能なアクセスリストの名前が含まれているユーザ名アトリビュートを持つ RADIUS 認証要求を受信すると、Cisco Secure ACS は Message-Authenticator アトリビュートをチェックして要求を認証します。Message-Authenticator アトリビュートがない場合、または正しくない場合、Cisco Secure ACS はその要求を無視します。Message-Authenticator アトリビュートの存在により、ダウンロード可能なアクセスリスト名がネットワーク アクセスの不正取得に悪用されることが防止されます。Message-Authenticator アトリビュートとその使用方法は、RFC 2869「RADIUS Extensions」で定義されています。この文書は、 http://www.ietf.org で入手できます。

5. 要求されたアクセスリストの長さが約 4 KB 未満の場合、Cisco Secure ACS はそのアクセスリストを含めた access-accept メッセージで応答します。メッセージには他の必須アトリビュートを含める必要があるので、1 つの access-accept メッセージに収まるアクセスリストの最大サイズは 4 KB よりわずかに小さくなります。

Cisco Secure ACS はダウンロード可能なアクセスリストを cisco-av-pair RADIUS VSA で送信します。アクセスリストは、一連のアトリビュートと値のペアという形式をとります。各ペアには ACE が 1 つ含まれ、シリアル番号が付けられます。

ip:inacl#1=ACE-1
ip:inacl#2=ACE-2
.
.
.
ip:inacl#n=ACE-n
 

アトリビュートと値のペアの例を次に示します。

ip:inacl#1=permit tcp 10.1.0.0 255.0.0.0 10.0.0.0 255.0.0.0
 

6. 要求されたアクセスリストの長さが約 4 KB を超える場合、Cisco Secure ACS は、上記の形式のアクセスリストの一部が含まれた access-challenge メッセージで応答します。メッセージには、State アトリビュート(IETF RADIUS アトリビュート 24)も含まれています。State アトリビュートには、Cisco Secure ACS がダウンロードの進捗を追跡するために使用する制御データが含まれています。Cisco Secure ACS は、RADIUS メッセージの最大サイズ以内で可能な限り多数の完全なアトリビュートと値のペアを cisco-av-pair RADIUS VSA に含めます。

適応型セキュリティ アプライアンスはアクセスリストの一部を受信すると、それを保存し、新しい access-request メッセージで応答します。これには、ダウンロード可能なアクセスリストを求める最初の要求と同じアトリビュートと、access-challenge メッセージで受信した State アトリビュートのコピーが含まれています。

これは、Cisco Secure ACS がアクセスリストの最後の部分を access-accept メッセージで送信するまで続行されます。

ダウンロード可能なアクセスリストに関する Cisco Secure ACS の設定

Cisco Secure ACS 上のダウンロード可能なアクセスリストを共有プロファイル コンポーネントとして設定し、そのアクセスリストをグループまたは個々のユーザに割り当てることができます。

アクセスリスト定義は、次のプレフィックスがない点を除いて拡張 access-list コマンド(「拡張アクセスリストの追加」を参照)に類似する、1 つまたは複数の適応型セキュリティ アプライアンスのコマンドで構成されます。

access-list acl_name extended
 

Cisco Secure ACS バージョン 3.3 上のダウンロード可能なアクセスリスト定義の例を次に示します。

+--------------------------------------------+
| Shared profile Components |
| |
| Downloadable IP ACLs Content |
| |
| Name: acs_ten_acl |
| |
| ACL Definitions |
| |
| permit tcp any host 10.0.0.254 |
| permit udp any host 10.0.0.254 |
| permit icmp any host 10.0.0.254 |
| permit tcp any host 10.0.0.253 |
| permit udp any host 10.0.0.253 |
| permit icmp any host 10.0.0.253 |
| permit tcp any host 10.0.0.252 |
| permit udp any host 10.0.0.252 |
| permit icmp any host 10.0.0.252 |
| permit ip any any |
+--------------------------------------------+
 

ダウンロード可能なアクセスリストを作成する方法、およびそれらをユーザと関連付ける方法の詳細については、ご使用のバージョンの Cisco Secure ACS のガイドを参照してください。

適応型セキュリティ アプライアンス上では、ダウンロードされたアクセスリストの名前は次のようになります。

#ACSACL#-ip-acl_name-number
 

acl_name 引数は Cisco Secure ACS で定義された名前(上記の例では acs_ten_acl)、 number は Cisco Secure ACS が生成した固有のバージョン ID です。

適応型セキュリティ アプライアンス上にダウンロードされたアクセスリストは、次の行で構成されます。

access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit tcp any host 10.0.0.254
access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit udp any host 10.0.0.254
access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit icmp any host 10.0.0.254
access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit tcp any host 10.0.0.253
access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit udp any host 10.0.0.253
access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit icmp any host 10.0.0.253
access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit tcp any host 10.0.0.252
access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit udp any host 10.0.0.252
access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit icmp any host 10.0.0.252
access-list #ACSACL#-ip-asa-acs_ten_acl-3b5385f7 permit ip any any
 

ダウンロード可能なアクセスリストに関する任意の RADIUS サーバの設定

ユーザ固有のアクセスリストを Cisco IOS RADIUS cisco-av-pair VSA(ベンダー 9、アトリビュート 1)で適応型セキュリティ アプライアンスに送信するように、Cisco IOS RADIUS VSA をサポートする任意の RADIUS サーバを設定できます。

cisco-av-pair VSA で、 access-list extended コマンド(「拡張アクセスリストの追加」を参照)と類似する 1 つまたは複数の ACE を設定します。ただし、次のコマンド プレフィックスを置き換える必要があります。

access-list acl_name extended
 

次のテキストに置き換えます。

ip:inacl#nnn=
 

nnn 引数は、0 ~ 999999999 の番号で、適応型セキュリティ アプライアンス上に設定するコマンド文の順序を指定します。このパラメータを省略すると、順番は 0 となり、cisco-av-pair RADIUS VSA 内部の ACE の順序が使用されます。

RADIUS サーバ上の cisco-av-pair VSA に対して設定されている必要のあるアクセスリスト定義の例を次に示します。

ip:inacl#1=permit tcp 10.1.0.0 255.0.0.0 10.0.0.0 255.0.0.0
ip:inacl#99=deny tcp any any
ip:inacl#2=permit udp 10.1.0.0 255.0.0.0 10.0.0.0 255.0.0.0
ip:inacl#100=deny udp any any
ip:inacl#3=permit icmp 10.1.0.0 255.0.0.0 10.0.0.0 255.0.0.0
 

cisco-av-pair アトリビュートで送信されるアクセスリストをユーザごとに固有にする方法については、ご使用の RADIUS サーバのマニュアルを参照してください。

適応型セキュリティ アプライアンス上では、ダウンロードされたアクセスリストの名前は次のようになります。

AAA-user-username
 

username 引数は、認証を受けるユーザの名前です。

適応型セキュリティ アプライアンス上にダウンロードされたアクセスリストは、次の行で構成されます。RADIUS サーバ上で指定された番号に基づいた順序になっています。

access-list AAA-user-bcham34-79AD4A08 permit tcp 10.1.0.0 255.0.0.0 10.0.0.0 255.0.0.0
access-list AAA-user-bcham34-79AD4A08 permit udp 10.1.0.0 255.0.0.0 10.0.0.0 255.0.0.0
access-list AAA-user-bcham34-79AD4A08 permit icmp 10.1.0.0 255.0.0.0 10.0.0.0 255.0.0.0
access-list AAA-user-bcham34-79AD4A08 deny tcp any any
access-list AAA-user-bcham34-79AD4A08 deny udp any any
 

ダウンロードされたアクセスリストの「access-list」という単語と名前の間には、2 個のスペースがあります。これらのスペースにより、ダウンロードされたアクセスリストとローカルのアクセスリストが区別されます。この例では、「79AD4A08」は適応型セキュリティ アプライアンスが作成したハッシュ値で、RADIUS サーバ上でアクセスリスト定義がいつ変更されたかを判別するために役立ちます。

ダウンロード可能なアクセスリスト内のワイルドカード ネットマスク表現の変換

RADIUS サーバを使用して、ダウンロード可能なアクセスリストを Cisco VPN 3000 Series Concentrator および適応型セキュリティ アプライアンスに提供する場合は、ワイルドカード ネットマスク表現を標準のネットマスク表現に変換するように適応型セキュリティ アプライアンスを設定しなければならない場合があります。これは、Cisco VPN 3000 Series Concentrator はワイルドカード ネットマスク表現をサポートしますが、適応型セキュリティ アプライアンスは標準のネットマスク表現しかサポートしないためです。これらの違いは、RADIUS サーバ上のダウンロード可能なアクセスリストを設定する方法に影響しますが、ワイルドカード ネットマスク表現を変換するように適応型セキュリティ アプライアンスを設定することで、その影響を最小限に抑えることができます。ワイルドカード ネットマスク表現の変換により、RADIUS サーバ上のダウンロード可能なアクセスリストのコンフィギュレーションを変更することなく、Cisco VPN 3000 Series Concentrator 用に記述されたダウンロード可能なアクセスリストを適応型セキュリティ アプライアンスで使用できます。

アクセスリスト ネットマスク変換は、 acl-netmask-convert コマンドを使用してサーバごとに設定できます。このコマンドは aaa サーバ コンフィギュレーション モードで使用できます。RADIUS サーバの設定方法の詳細については、「AAA サーバ グループおよびサーバの識別」を参照してください。 acl-netmask-convert コマンドの詳細については、『 Cisco ASA 5500 Series Command Reference 』を参照してください。

ユーザごとのアクセス コントロール リスト名をダウンロードするための RADIUS サーバの設定

ユーザ認証時に、適応型セキュリティ アプライアンスで作成済みのアクセスリストの名前を RADIUS サーバからダウンロードするには、IETF RADIUS filter-id アトリビュート(アトリビュート番号 11)を次のように設定します。

filter-id=acl_name
 

) Cisco Secure ACS では、filter-id アトリビュートの値は、HTML インターフェイスのボックスで、filter-id= を省略し、acl_name だけを入力して指定します。


filter-id アトリビュートの値をユーザごとに固有にする方法については、ご使用の RADIUS サーバのマニュアルを参照してください。

「拡張アクセスリストの追加」上にアクセスリストを作成する方法については、適応型セキュリティ アプライアンスを参照してください。

ネットワーク アクセスのアカウンティングの設定

適応型セキュリティ アプライアンスは、適応型セキュリティ アプライアンスを通過する任意の TCP トラフィックまたは UDP トラフィックについてのアカウンティング情報を RADIUS サーバまたは TACACS+ サーバに送信できます。そのトラフィックも認証されている場合、AAA サーバはユーザ名でアカウンティング情報を保持できます。そのトラフィックが認証されていない場合、AAA サーバは IP アドレスでアカウンティング情報を保持できます。アカウンティング情報には、セッションの開始時刻と終了時刻、ユーザ名、そのセッションで適応型セキュリティ アプライアンスを経由したバイト数、使用されたサービス、セッションの継続時間が含まれます。

アカウンティングを設定するには、次の手順を実行します。


ステップ 1 ユーザごとのアカウンティング データを提供するように適応型セキュリティ アプライアンスを設定する場合は、認証をイネーブルにする必要があります。詳細については、「ネットワーク アクセス認証のイネーブル化」を参照してください。IP アドレスごとのアカウンティング データを提供するように適応型セキュリティ アプライアンスを設定する場合は、認証をイネーブルにする必要はありません。次のステップに進みます。

ステップ 2 access-list コマンドを使用して、アカウンティング対象のトラフィックの送信元アドレスと宛先アドレスを指定するアクセスリストを作成します。手順については、「拡張アクセスリストの追加」を参照してください。

許可 ACE は、一致したトラフィックを認可するようにマークします。一方、 拒否 エントリは、一致したトラフィックを認可から除外します。


) 認証が設定済みで、なおかつ認証されたすべてのトラフィックのアカウンティング データが必要な場合、aaa authentication match コマンドで使用するために作成したアクセスリストと同じアクセスリストを使用できます。


ステップ 3 アカウンティングをイネーブルにするには、次のコマンドを入力します。

hostname(config)# aaa accounting match acl_name interface_name server_group
 

acl_name 引数は、 access-list コマンドで設定されたアクセスリスト名です。

interface_name 引数は、 nameif コマンドで設定されたインターフェイス名です。

server_group 引数は、 aaa-server コマンドで設定されたサーバ グループ名です。


) もう 1 つの方法として、aaa accounting include コマンド(コマンド内でトラフィックを指定するコマンド)を使用することもできます。ただし、同一コンフィギュレーション内で両方の方法を使用することはできません。詳細についてはCisco ASA 5500 Series Command Reference』を参照してください。



 

次のコマンドは、内部 Telnet トラフィックを認証、認可、アカウンティングします。209.165.201.5 以外のサーバに向かう Telnet トラフィックは認証だけを受けますが、209.165.201.5 に向かうトラフィックには認可およびアカウンティングが必要です。

hostname(config)# aaa-server AuthOutbound protocol tacacs+
hostname(config-aaa-server-group)# exit
hostname(config)# aaa-server AuthOutbound (inside) host 10.1.1.1
hostname(config-aaa-server-host)# key TACPlusUauthKey
hostname(config-aaa-server-host)# exit
hostname(config)# access-list TELNET_AUTH extended permit tcp any any eq telnet
hostname(config)# access-list SERVER_AUTH extended permit tcp any host 209.165.201.5 eq telnet
hostname(config)# aaa authentication match TELNET_AUTH inside AuthOutbound
hostname(config)# aaa authorization match SERVER_AUTH inside AuthOutbound
hostname(config)# aaa accounting match SERVER_AUTH inside AuthOutbound
 

MAC アドレスによるトラフィックの認証と認可の免除

適応型セキュリティ アプライアンスは、特定の MAC アドレスからのトラフィックの認証および認可を免除できます。たとえば、適応型セキュリティ アプライアンスが特定のネットワークから発信される TCP トラフィックを認証し、特定のサーバからの未認証の TCP 接続は許可する場合、MAC 免除規則を使用すると、この規則で指定したサーバからのすべてのトラフィックに対して認証および認可が免除されます。

この機能は、認証プロンプトに応答できない IP 電話などのデバイスを免除する場合に特に便利です。

MAC アドレスを使用してトラフィックの認証および認可を免除するには、次の手順を実行します。


ステップ 1 MAC リストを設定するには、次のコマンドを入力します。

hostname(config)# mac-list id {deny | permit} mac macmask
 

id 引数は、MAC リストに割り当てる 16 進数です。一連の MAC アドレスをグループ化するには、同じ ID 値で必要な回数の mac-list コマンドを入力します。AAA 免除に使用できる MAC リストは 1 つだけなので、MAC リストには免除するすべての MAC アドレスを含めてください。複数の MAC リストを作成できますが、一度に使用できるのは 1 つだけです。

ベスト マッチ シナリオと異なり、パケットは一致した最初のエントリを使用するので、エントリの順番が重要になります。許可エントリで許可されるアドレスのうち、拒否するアドレスがある場合は、許可エントリの前に拒否エントリを入力してください。

mac 引数には、12 桁の 16 進数の形式(nnnn.nnnn.nnnn)で送信元の MAC アドレスを指定します。

macmask 引数には、照合に使用される MAC アドレスの一部を指定します。たとえば、ffff.ffff.ffff は完全に MAC アドレスと一致します。ffff.ffff.0000 は最初の 8 桁だけ一致します。

ステップ 2 特定の MAC リストで指定されている MAC アドレスのトラフィックに対して免除するには、次のコマンドを入力します。

hostname(config)# aaa mac-exempt match id
 

id は、認証および認可を免除するトラフィックの MAC アドレスが含まれている MAC リストを指定する文字列です。 aaa mac-exempt コマンドのインスタンスを 1 つだけ入力できます。


 

次の例では、1 個の MAC アドレスに対する認証をバイパスします。

hostname(config)# mac-list abc permit 00a0.c95d.0282 ffff.ffff.ffff
hostname(config)# aaa mac-exempt match abc
 

次のエントリは、ハードウェア ID 0003.E3 を持つすべての Cisco IP Phone の認証をバイパスします。

hostname(config)# mac-list acd permit 0003.E300.0000 FFFF.FF00.0000
hostname(config)# aaa mac-exempt match acd
 

次の例では、00a0.c95d.02b2 以外の MAC アドレス グループの認証をバイパスします。00a0.c95d.02b2 は permit 文とも一致するので、permit 文の前に deny 文を入力します。permit 文が先に来ると、deny 文とは照合されません。

hostname(config)# mac-list 1 deny 00a0.c95d.0282 ffff.ffff.ffff
hostname(config)# mac-list 1 permit 00a0.c95d.0000 ffff.ffff.0000
hostname(config)# aaa mac-exempt match 1