Cisco Security Appliance コマンド リファレンス Cisco ASA 5500 シリーズ/Cisco PIX 500 シリーズ用 ソフトウェア バージョン 8.0(5)
backup interface コマンド~ browse-networks コマンド
backup interface コマンド~ browse-networks コマンド
発行日;2013/10/22 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 13MB) | フィードバック

目次

backup interface コマンド~ browse-networks コマンド

backup interface

backup-servers

banner

banner(グループ ポリシー)

blocks

boot

border style

browse-networks

backup interface コマンド~ browse-networks コマンド

backup interface

ASA 5505 適応型セキュリティ アプライアンスなど、組み込みスイッチを搭載したモデルの場合、インターフェイス コンフィギュレーション モードで backup interface コマンドを使用して、ISP などのバックアップ インターフェイスとして VLAN インターフェイスを指定します。このコマンドを入力できるのは、VLAN インターフェイスのインターフェイス コンフィギュレーション モードだけです。このコマンドは、プライマリ インターフェイスを経由するデフォルト ルートがダウンしない限り、指定したバックアップ インターフェイスを通過しようとするトラフィックをすべてブロックします。通常の動作に戻すには、 no backup interface コマンドを使用します。

backup interface vlan number

no backup interface vlan number

 
構文の説明

vlan number

バックアップ インターフェイスの VLAN ID を指定します。

 
デフォルト

デフォルトでは、 backup interface コマンドはディセーブルになっています。

 
コマンド モード

次の表に、コマンドを入力できるモードを示します。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

インターフェイス コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.2(1)

このコマンドが導入されました。

7.2(2)

Security Plus ライセンスでは、VLAN インターフェイス数の制限(通常のトラフィック用は 3 つ、バックアップ インターフェイス用は 1 つ、フェールオーバー用は 1 つ)がなくなり、最大 20 のインターフェイスを設定できるようになりました(最大数以外の制限はありません)。したがって、4 つ以上のインターフェイスをイネーブルにするために backup interface コマンドを使用する必要がなくなりました。

 
使用上のガイドライン

backup interface コマンドで Easy VPN を設定した場合は、バックアップ インターフェイスがプライマリになると、セキュリティ アプライアンスは VPN ルールを新しいプライマリ インターフェイスに移動します。バックアップ インターフェイスの状態を表示する方法については、 show interface コマンドを参照してください。

必ずプライマリ インターフェイスとバックアップ インターフェイスの両方にデフォルト ルートを設定して、プライマリ インターフェイスに障害が発生した場合にバックアップ インターフェイスを使用できるようにしてください。たとえば、2 つのデフォルト ルートを設定して、1 つはアドミニストレーティブ ディスタンスが低いプライマリ インターフェイス用とし、もう 1 つはアドミニストレーティブ ディスタンスが高いバックアップ インターフェイス用とすることができます。DHCP サーバから取得したデフォルト ルートのアドミニストレーティブ ディスタンスを上書きする方法については、 dhcp client route distance コマンドを参照してください。デュアル ISP サポートの設定の詳細については、 sla monitor コマンドおよび track rtr コマンドを参照してください。

management-only コマンドをすでに設定しているインターフェイスをバックアップ インターフェイスに設定することはできません。

次に、4 つの VLAN インターフェイスを設定する例を示します。backup-isp インターフェイスは、プライマリ インターフェイスがダウンしている場合に限り、通過トラフィックを許可します。 route コマンドでは、プライマリ インターフェイスとバックアップ インターフェイスのデフォルト ルートを作成し、バックアップ ルートには低いアドミニストレーティブ ディスタンスを設定しています。

hostname(config)# interface vlan 100
hostname(config-if)# nameif outside
hostname(config-if)# security-level 0
hostname(config-if)# ip address 10.1.1.1 255.255.255.0
hostname(config-if)# backup interface vlan 400
hostname(config-if)# no shutdown
 
hostname(config-if)# interface vlan 200
hostname(config-if)# nameif inside
hostname(config-if)# security-level 100
hostname(config-if)# ip address 10.2.1.1 255.255.255.0
hostname(config-if)# no shutdown
 
hostname(config-if)# interface vlan 300
hostname(config-if)# nameif dmz
hostname(config-if)# security-level 50
hostname(config-if)# ip address 10.3.1.1 255.255.255.0
hostname(config-if)# no shutdown
 
hostname(config-if)# interface vlan 400
hostname(config-if)# nameif backup-isp
hostname(config-if)# security-level 50
hostname(config-if)# ip address 10.1.2.1 255.255.255.0
hostname(config-if)# no shutdown
 
hostname(config)# interface ethernet 0/0
hostname(config-if)# switchport access vlan 100
hostname(config-if)# no shutdown
 
hostname(config-if)# interface ethernet 0/1
hostname(config-if)# switchport access vlan 200
hostname(config-if)# no shutdown
 
hostname(config-if)# interface ethernet 0/2
hostname(config-if)# switchport access vlan 300
hostname(config-if)# no shutdown
 
hostname(config-if)# interface ethernet 0/3
hostname(config-if)# switchport access vlan 400
hostname(config-if)# no shutdown
 
hostname(config-if)# route outside 0 0 10.1.1.2 1
hostname(config)# route backup-isp 0 0 10.1.2.2 2
 

 
関連コマンド

コマンド
説明

forward interface

インターフェイスが別のインターフェイスへのトラフィックを開始することを制限します。

interface vlan

VLAN インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

dhcp client route distance

DHCP サーバから取得したデフォルト ルートのアドミニストレーティブ ディスタンスを上書きします。

sla monitor

スタティック ルートのトラッキングの SLA モニタリング動作を作成します。

track rtr

SLA モニタリング動作の状態を追跡します。

backup-servers

バックアップ サーバを設定するには、グループ ポリシー コンフィギュレーション モードで backup-servers コマンドを使用します。バックアップ サーバを削除するには、このコマンドの no 形式を使用します。実行コンフィギュレーションから backup-servers 属性を削除するには、このコマンドの no 形式を引数なしで使用します。これにより、backup-servers の値を別のグループ ポリシーから継承できます。

IPSec バックアップ サーバにより、VPN クライアントは、プライマリセキュリティ アプライアンスが利用できない場合でも中央サイトに接続できます。バックアップ サーバを設定すると、IPSec トンネルが確立されるときにセキュリティ アプライアンスがクライアントにサーバ リストをプッシュします。

backup-servers { server1 server2 . . . . server10 | clear-client-config | keep-client-config}

no backup-servers [ server1 server2 . . . . server10 | clear-client-config | keep-client-config ]

 
構文の説明

clear-client-config

クライアントがバックアップ サーバを使用しないことを指定します。セキュリティ アプライアンスは、ヌルのサーバ リストをプッシュします。

keep-client-config

セキュリティ アプライアンスがバックアップ サーバ情報をクライアントに送信しないことを指定します。クライアントは、独自のバックアップ サーバ リストを使用します(設定されている場合)。

server1 server 2 .... server10

プライマリセキュリティ アプライアンスが利用できない場合に VPN クライアントが使用するサーバのリストを指定します。各サーバをスペースで区切り、プライオリティの高い順に並べます。サーバは、IP アドレスまたはホスト名で指定します。リストには 500 文字まで入力できますが、10 個のエントリのみを含めることができます。

 
デフォルト

クライアント上またはプライマリセキュリティ アプライアンス上にバックアップ サーバを設定しない限り、バックアップ サーバは存在しません。

 
コマンド モード

次の表に、コマンドを入力できるモードを示します。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

グループ ポリシー コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

バックアップ サーバは、クライアント上またはプライマリセキュリティ アプライアンス上に設定します。セキュリティ アプライアンス上にバックアップ サーバを設定すると、適応型セキュリティ アプライアンスは、バックアップ サーバ ポリシーをグループ内のクライアントにプッシュして、クライアント上にバックアップ サーバ リストが設定されている場合、そのリストを置き換えます。


) ホスト名を使用する場合は、バックアップ DNS サーバおよびバックアップ WINS サーバを、プライマリ DNS サーバおよびプライマリ WINS サーバとは別のネットワーク上に配置することを推奨します。このようにしないと、ハードウェア クライアントの背後のクライアントが DHCP を介してハードウェア クライアントから DNS 情報および WINS 情報を取得している場合、プライマリ サーバとの接続が失われ、バックアップ サーバに異なる DNS 情報と WINS 情報があると、DHCP リースが期限切れになるまでクライアントを更新できなくなります。さらに、ホスト名を使用するときに DNS サーバが利用できないと、重大な遅延が発生することがあります。


次に、「FirstGroup」という名前のグループ ポリシーに IP アドレス 10.10.10.1 および 192.168.10.14 のバックアップ サーバを設定する例を示します。

hostname(config)# group-policy FirstGroup attributes
hostname(config-group-policy)# backup-servers 10.10.10.1 192.168.10.14

 

banner

ASDM バナー、セッション バナー、ログイン バナー、または Message-of-The-Day バナーを設定するには、グローバル コンフィギュレーション モードで banner コマンドを使用します。 no banner コマンドは、指定したバナー キーワード( exec login 、または motd )のすべての行を削除します。

banner { asdm | exec | login | motd text }

[no] banner { asdm | exec | login | motd [ text ] }

 
構文の説明

asdm

ASDM へのログインに成功した後にバナーを表示するようにシステムを設定します。続行してログインを完了するか、または切断するかを確認するプロンプトがユーザに表示されます。このオプションを使用すると、接続の前に、書面によるポリシー条件の受け入れをユーザに求めることができます。

exec

イネーブル プロンプトを表示する前に、バナーを表示するようにシステムを設定します。

login

Telnet を使用してセキュリティ アプライアンスにアクセスする場合、パスワード ログイン プロンプトを表示する前にバナーを表示するようにシステムを設定します。

motd

初めて接続したときに Message-of-The-Day バナーを表示するようにシステムを設定します。

text

表示するメッセージ テキスト行。

 
デフォルト

デフォルトでは、バナーは表示されません。

 
コマンド モード

次の表に、コマンドを入力できるモードを示します。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

グローバル コンフィギュレーション

 
コマンド履歴

リリース
変更内容

7.2(4)/8.0(3)

asdm キーワードが追加されました。

 
使用上のガイドライン

banner コマンドは、指定したキーワードに対応して表示されるようにバナーを設定します。 text ストリングは、最初の空白(スペース)の後に続く、行末(復帰または改行(LF))までのすべての文字で構成されます。テキスト内のスペースは維持されます。ただし、CLI ではタブを入力できません。

最初に既存のバナーをクリアしない限り、後続の text エントリは既存のバナーの末尾に追加されていきます。


) $(domain) トークンと $(hostname) トークンは、セキュリティ アプライアンスのドメイン名とホスト名にそれぞれ置き換えられます。コンテキスト コンフィギュレーションで $(system) トークンを入力すると、このコンテキストでは、システム コンフィギュレーションで設定されているバナーが使用されます。


バナーを複数行にするには、追加する行ごとに banner コマンドを新たに入力します。各行は、既存のバナーの末尾に追加されていきます。RAM およびフラッシュでの制限を除き、バナーの長さに制限はありません。

Telnet または SSH を介してセキュリティ アプライアンスにアクセスする場合は、バナー メッセージの処理に必要なシステム メモリが十分ないか、または TCP 書き込みエラーが発生すると、セッションが閉じます。exec バナーと motd バナーだけが、SSH を介したセキュリティ アプライアンスへのアクセスをサポートしています。login バナーは SSH をサポートしていません。

バナーを置き換えるには、no banner コマンドを使用してから、新しい行を追加します。

指定したバナー キーワードのすべての行を削除するには、no banner { exec | login | motd } コマンドを使用します。

no banner コマンドでは、テキスト ストリングを選択して削除することはできません。そのため、no banner コマンドの末尾に入力した テキスト はすべて無視されます。

次に、 asdm exec login 、および motd の各バナーを設定する例を示します。

hostname(config)# banner asdm You successfully logged in to ASDM
hostname(config)# banner motd Think on These Things
hostname(config)# banner exec Enter your password carefully
hostname(config)# banner login Enter your password to log in
hostname(config)# show running-config banner
asdm:
You successfully logged in to ASDM
 
exec:
Enter your password carefully
 
login:
Enter your password to log in
 
motd:
Think on These Things
 

次に、 motd バナーに別の行を追加する例を示します。

hostname(config)# banner motd and Enjoy Today
hostname(config)# show running-config banner motd
Think on These Things and Enjoy Today

 
関連コマンド

コマンド
説明

clear configure banner

すべてのバナーを削除します。

show running-config banner

すべてのバナーを表示します。

banner(グループ ポリシー)

リモート クライアントの接続時にリモート クライアント上でバナー(ウェルカム テキスト)を表示するには、グループ ポリシー コンフィギュレーション モードで banner コマンドを使用します。バナーを削除するには、このコマンドの no 形式を使用します。このオプションを使用すると、別のグループ ポリシーのバナーを継承できます。バナーを継承しないようにするには、 banner none コマンドを使用します。

banner { value banner_string | none}

no banner


) VPN グループ ポリシーで複数のバナーを設定し、いずれかのバナーを削除すると、すべてのバナーが削除されます。


 
構文の説明

none

バナーにヌル値を設定して、バナーを禁止します。デフォルトまたは指定したグループ ポリシーのバナーを継承しません。

value banner_string

バナー テキストを設定します。最大ストリング サイズは 500 文字です。復帰を挿入するには、「\n」シーケンスを使用します。

 
デフォルト

デフォルトのバナーはありません。

 
コマンド モード

次の表に、コマンドを入力できるモードを示します。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

グループ ポリシー コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

IPsec VPN クライアントは、バナー用の完全な HTML をサポートしています。ただし、クライアントレス ポータルおよび AnyConnect クライアントは部分的な HTML をサポートしています。バナーがリモート ユーザに適切に表示されるようにするには、次のガイドラインに従います。

IPsec クライアント ユーザの場合は、/n タグを使用します。

AnyConnect クライアント ユーザの場合は、<BR> タグを使用します。

クライアントレス ユーザの場合は、<BR> タグを使用します。

次に、「FirstGroup」という名前のグループ ポリシー用のバナーを作成する例を示します。

hostname(config)# group-policy FirstGroup attributes
hostname(config-group-policy)# banner value Welcome to Cisco Systems 7.0.

blocks

ブロック診断( show blocks コマンドで表示)に追加のメモリを割り当てるには、特権 EXEC モードで blocks コマンドを使用します。値をデフォルトに戻すには、このコマンドの no 形式を使用します。割り当てられるメモリ量は最大 150 KB ですが、空きメモリの 50% を超えることはありません。必要に応じて、メモリ サイズを手動で指定できます。

blocks queue history enable [ memory_size ]

no blocks queue history enable [ memory_size ]

 
構文の説明

memory_size

(任意)ダイナミックな値を適用するのではなく、ブロック診断用のメモリ サイズをバイト単位で設定します。この値が空きメモリよりも大きい場合は、エラー メッセージが表示され、値は受け入れられません。この値が空きメモリの 50% を超える場合は、警告メッセージが表示されますが、値は受け入れられます。

 
デフォルト

ブロック診断の追跡に割り当てられるデフォルト メモリは、2136 バイトです。

 
コマンド モード

次の表に、コマンドを入力できるモードを示します。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

特権 EXEC

--

 
コマンド履歴

リリース
変更内容

7.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

現在割り当てられているメモリを表示するには、 show blocks queue history コマンドを入力します。

セキュリティ アプライアンスをリロードすると、メモリ割り当てがデフォルトに戻ります。

次に、ブロック診断用のメモリ サイズを増やす例を示します。

hostname# blocks queue history enable
 

次に、メモリ サイズを 3000 バイトに増やす例を示します。

hostname# blocks queue history enable 3000
 

次に、メモリ サイズを 3000 バイトに増やすことを試みるものの、この値が空きメモリを超えている例を示します。

hostname# blocks queue history enable 3000
ERROR: memory size exceeds current free memory
 

次に、メモリ サイズを 3000 バイトに増やすものの、この値が空きメモリの 50% を超えている例を示します。

hostname# blocks queue history enable 3000
WARNING: memory size exceeds 50% of current free memory
 

 
関連コマンド

コマンド
説明

clear blocks

システム バッファの統計情報をクリアします。

show blocks

システム バッファの使用状況を表示します。

boot

システムが次回のリロードで使用するシステム イメージ、およびシステムが起動時に使用するコンフィギュレーション ファイルを指定するには、グローバル コンフィギュレーション モードで boot コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

boot { config | system } url

no boot { config | system } url

 
構文の説明

config

システムがロードされるときに使用するコンフィギュレーション ファイルを指定します。

system

システムがロードされるときに使用するシステム イメージ ファイルを指定します。

url

イメージまたはコンフィギュレーションの場所を設定します。マルチ コンテキスト モードでは、管理コンテキストですべてのリモート URL にアクセスできる必要があります。次の URL 構文を参照してください。

disk0:/ [ path / ] filename

ASA 5500 シリーズ適応型セキュリティ アプライアンスの場合、この URL は内部フラッシュ メモリを指します。 disk0 ではなく flash を使用することもできます。これらはエイリアスになっています。

disk1:/ [ path / ] filename

ASA 5500 シリーズ適応型セキュリティ アプライアンスの場合、この URL は外部フラッシュ メモリ カードを指します。

flash:/ [ path / ] filename

この URL は内部フラッシュ メモリを示します。

tftp:// [ user [ : password ] @ ] server [: port ] / [ path / ] filename [ ;int= interface_name ]

サーバ アドレスへのルートを上書きする場合は、インターフェイス名を指定します。

このオプションは、ASA 5500 シリーズ適応型セキュリティ アプライアンスの boot system コマンドだけで使用できます。 boot config コマンドを使用するには、スタートアップ コンフィギュレーションがフラッシュ メモリに存在している必要があります。

boot system tftp: コマンドは、1 つのみ設定でき、かつ最初に設定する必要があります。

 
デフォルト

boot config コマンドを指定しないと、スタートアップ コンフィギュレーションが非表示の場所に保存され、スタートアップ コンフィギュレーションを利用するコマンド( show startup-config コマンドや copy startup-config コマンド)だけで使用されるようになります。

boot system コマンドにデフォルトはありません。場所を指定しないと、セキュリティ アプライアンスは、ブートする最初の有効なイメージを内部フラッシュ メモリでのみ探します。有効なイメージが見つからない場合は、システム イメージがロードされず、セキュリティ アプライアンスは、ROMMON モードまたはモニタ モードが開始されるまでブート ループ状態になります。

 
コマンド モード

次の表に、コマンドを入力できるモードを示します。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

グローバル コンフィギュレーション

--

 
コマンド履歴

リリース
変更内容

7.0(1)

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドを、 write memory コマンドを使用してスタートアップ コンフィギュレーションに保存すると、BOOT 環境変数と CONFIG_FILE 環境変数にも設定が保存されます。セキュリティ アプライアンスは、これらの環境変数を使用して、再起動時のスタートアップ コンフィギュレーションおよびブートするソフトウェア イメージを決定します。

最大 4 つの boot system コマンド エントリを入力して異なるイメージを指定し、順番にブートすることができます。セキュリティ アプライアンスは、最初に見つけた有効なイメージをブートします。

現在の実行コンフィギュレーションとは異なる、新しい場所にあるスタートアップ コンフィギュレーション ファイルを使用する場合は、実行コンフィギュレーションを保存した後に、必ず、スタートアップ コンフィギュレーション ファイルを新しい場所にコピーしてください。このようにしないと、実行コンフィギュレーションの保存時に、実行コンフィギュレーションによって新しいスタートアップ コンフィギュレーションが上書きされます。


ヒント ASDM イメージ ファイルは、asdm image コマンドで指定します。

次に、起動時にセキュリティ アプライアンスが configuration.txt という名前のコンフィギュレーション ファイルをロードするように指定する例を示します。

hostname(config)# boot config disk0:/configuration.txt

 
関連コマンド

コマンド
説明

asdm image

ASDM ソフトウェア イメージを指定します。

show bootvar

ブート ファイルおよびコンフィギュレーションの環境変数を表示します。

border style

認証された WebVPN ユーザに表示される WebVPN ホームページの境界線をカスタマイズするには、カスタマイゼーション コンフィギュレーション モードで border style コマンドを使用します。コンフィギュレーションからコマンドを削除して、値が継承されるようにするには、このコマンドの no 形式を使用します。

border style value

no border style value

 
構文の説明

value

Cascading Style Sheet(CSS; カスケーディング スタイル シート)パラメータ(最大 256 文字)。

 
デフォルト

境界線のデフォルト スタイルは background-color:#669999;color:white です。

 
コマンド モード

次の表に、コマンドを入力できるモードを示します。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

カスタマイゼーション コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.1(1)

このコマンドが導入されました。

 
使用上のガイドライン

style オプションは有効な Cascading Style Sheet(CSS)パラメータとして表されます。これらのパラメータについては、このマニュアルでは説明しません。CSS パラメータの詳細については、World Wide Web Consortium(W3C)の Web サイト(www.w3.org)の CSS 仕様を参照してください。『CSS 2.1 Specification』の「Appendix F」には、CSS パラメータの使いやすいリストがあります。この付録は www.w3.org/TR/CSS21/propidx.html で入手できます。

ここでは、WebVPN ページに対する変更で最もよく行われるページの配色を変更するためのヒントを紹介します。

カンマ区切りの RGB 値、HTML の色値、または色の名前(HTML で認識される場合)を使用できます。

RGB 形式は 0,0,0 で、各色(赤、緑、青)を 0 ~ 255 の範囲の 10 進値で入力します。このカンマ区切りのエントリは、他の 2 色と組み合わせる各色の明度レベルを示します。

HTML 形式は #000000 で、16 進形式の 6 桁の数値です。先頭と 2 番めは赤を、3 番めと 4 番めは緑を、5 番めと 6 番めは青を表しています。


) WebVPN ページを簡単にカスタマイズするには、ASDM を使用することを推奨します。ASDM には、色見本やプレビュー機能など、スタイルの要素を設定するための便利な機能があります。


次に、境界線の背景色を RGB カラー #66FFFF(緑色の一種)にカスタマイズする例を示します。

hostname(config)# webvpn
hostname(config-webvpn)# customization cisco
hostname(config-webvpn-custom)# border style background-color:66FFFF

 
関連コマンド

コマンド
説明

application-access

WebVPN ホームページの [Application Access] ボックスをカスタマイズします。

browse-networks

WebVPN ホームページの [Browse Networks] ボックスをカスタマイズします。

web-bookmarks

WebVPN ホームページの [Web Bookmarks] タイトルまたはリンクをカスタマイズします。

file-bookmarks

WebVPN ホームページの [File Bookmarks] タイトルまたはリンクをカスタマイズします。

browse-networks

認証された WebVPN ユーザに表示される WebVPN ホームページの [Browse Networks] ボックスをカスタマイズするには、webvpn カスタマイゼーション コンフィギュレーション モードで browse-networks コマンドを使用します。コンフィギュレーションからコマンドを削除して、値が継承されるようにするには、このコマンドの no 形式を使用します。

browse-networks { title | message | dropdown } { text | style } value

no browse-networks [{ title | message | dropdown } { text | style } value ]

 
構文の説明

dropdown

ドロップダウン リストを変更することを指定します。

message

タイトルの下に表示されるメッセージを変更することを指定します。

style

スタイルを変更することを指定します。

text

テキストを変更することを指定します。

title

タイトルを変更することを指定します。

value

実際に表示するテキスト(最大 256 文字)、または Cascading Style Sheet(CSS)パラメータ(最大 256 文字)です。

 
デフォルト

タイトルのデフォルト テキストは「Browse Networks」です。

デフォルトのタイトル スタイルは、次のとおりです。

background-color:#99CCCC;color:black;font-weight:bold;text-transform:uppercase

メッセージのデフォルト テキストは「Enter Network Path」です。

メッセージのデフォルト スタイルは次のとおりです。

background-color:#99CCCC;color:maroon;font-size:smaller.

ドロップダウンのデフォルト テキストは「File Folder Bookmarks」です。

ドロップダウンのデフォルト スタイルは次のとおりです。

border:1px solid black;font-weight:bold;color:black;font-size:80%.

 
コマンド モード

次の表に、コマンドを入力できるモードを示します。

 

コマンド モード
ファイアウォール モード
セキュリティ コンテキスト
ルーテッド
透過
シングル
マルチ
コンテキスト
システム

webvpn カスタマイゼーション コンフィギュレーション

--

--

--

 
コマンド履歴

リリース
変更内容

7.1(1)

このコマンドが導入されました。

 
使用上のガイドライン

style オプションは有効な Cascading Style Sheet(CSS)パラメータとして表されます。これらのパラメータについては、このマニュアルでは説明しません。CSS パラメータの詳細については、World Wide Web Consortium(W3C)の Web サイト(www.w3.org)の CSS 仕様を参照してください。『CSS 2.1 Specification』の「Appendix F」には、CSS パラメータの使いやすいリストがあります。この付録は www.w3.org/TR/CSS21/propidx.html で入手できます。

ここでは、WebVPN ページに対する変更で最もよく行われるページの配色を変更するためのヒントを紹介します。

カンマ区切りの RGB 値、HTML の色値、または色の名前(HTML で認識される場合)を使用できます。

RGB 形式は 0,0,0 で、各色(赤、緑、青)を 0 ~ 255 の範囲の 10 進値で入力します。このカンマ区切りのエントリは、他の 2 色と組み合わせる各色の明度レベルを示します。

HTML 形式は #000000 で、16 進形式の 6 桁の数値です。先頭と 2 番めは赤を、3 番めと 4 番めは緑を、5 番めと 6 番めは青を表しています。


) WebVPN ページを簡単にカスタマイズするには、ASDM を使用することを推奨します。ASDM には、色見本やプレビュー機能など、スタイルの要素を設定するための便利な機能があります。


次に、タイトルを「Browse Corporate Networks」に変更し、スタイル内のテキストを青色に変更する例を示します。

F1-asa1(config)# webvpn
F1-asa1(config-webvpn)# customization cisco
F1-asa1(config-webvpn-custom)# browse-networks title text Browse Corporate Networks
F1-asa1(config-webvpn-custom)# browse-networks title style color:blue

 
関連コマンド

コマンド
説明

application-access

WebVPN ホームページの [Application Access] ボックスをカスタマイズします。

file-bookmarks

WebVPN ホームページの [File Bookmarks] タイトルまたはリンクをカスタマイズします。

web-applications

WebVPN ホームページの [Web Application] ボックスをカスタマイズします。

web-bookmarks

WebVPN ホームページの [Web Bookmarks] タイトルまたはリンクをカスタマイズします。