マニュアル 1:Cisco ASA シリーズ CLI コンフィギュレーション ガイド(一般的な操作)バージョン 9.1
OSPF の設定
OSPF の設定
発行日;2013/05/30 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

OSPF の設定

OSPF に関する情報

OSPFv2 および OSPFv3 間の実装の差異

クラスタリングの使用

OSPF のライセンス要件

ガイドラインと制限事項

OSPFv2 の設定

OSPFv2 のカスタマイズ

OSPFv2 へのルートの再配布

OSPFv2 にルートを再配布する場合のルート集約の設定

OSPFv2 エリア間のルート集約の設定

OSPFv2 インターフェイスのパラメータの設定

OSPFv2 エリア パラメータの設定

OSPFv2 NSSA の設定

クラスタリングの IP アドレス プールの設定(OSPFv2 および OSPFv3)

スタティック OSPFv2 ネイバーの定義

ルート計算タイマーの設定

ネイバーがアップ状態またはダウン状態になった時点でのロギング

OSPFv3 の設定

OSPFv3 のイネーブル化

OSPFv3 インターフェイスのパラメータの設定

OSPFv3 ルータ パラメータの設定

OSPFv3 エリア パラメータの設定

OSPFv3 パッシブ インターフェイスの設定

OSPFv3 アドミニストレーティブ ディスタンスの設定

OSPFv3 タイマーの設定

スタティック OSPFv3 ネイバーの定義

OSPFv3 デフォルト パラメータのリセット

syslog メッセージの送信

syslog メッセージの抑止

サマリー ルート コストの計算

OSPFv3 ルーティング ドメインへのデフォルトの外部ルートの生成

IPv6 サマリー プレフィックスの設定

IPv6 ルートの再配布

OSPF 設定の削除

OSPFv2 の設定例

OSPFv3 の設定例

OSPF のモニタリング

その他の参考資料

RFC

OSPF の機能履歴

OSPF の設定

この章では、Open Shortest Path First(OSPF)ルーティング プロトコルを使用してデータをルーティングし、認証を実行し、ルーティング情報を再配布するように ASA を設定する方法について説明します。

この章は、次の項目を取り上げます。

「OSPF に関する情報」

「OSPF のライセンス要件」

「ガイドラインと制限事項」

「OSPFv2 の設定」

「OSPFv2 のカスタマイズ」

「OSPFv3 の設定」

「OSPF 設定の削除」

「OSPFv2 の設定例」

「OSPFv3 の設定例」

「OSPF のモニタリング」

「その他の参考資料」

「OSPF の機能履歴」

OSPF に関する情報

OSPF は、パスの選択に距離ベクトル型ではなくリンク ステートを使用する Interior Gateway Routing Protocol(IGRP)です。OSPF は、ルーティング テーブル アップデートではなく、リンクステート アドバタイズメントを伝搬します。ルーティング テーブル全体ではなく LSA だけが交換されるため、OSPF ネットワークは RIP ネットワークよりも迅速に収束します。

OSPF は、リンクステート アルゴリズムを使用して、すべての既知の宛先までの最短パスを構築および計算します。OSPF エリア内の各ルータには、ルータが使用可能なインターフェイスと到達可能なネイバーそれぞれのリストである同一のリンクステート データベースが置かれています。

RIP に比べると OSPF は次の点で有利です。

OSPF のリンクステート データベースのアップデート送信は RIP ほど頻繁ではありません。また、古くなった情報のタイムアウトで徐々にアップデートされるのではなく、リンクステート データベースは瞬時にアップデートされます。

ルーティング決定はコストに基づいて行われます。これは、特定のインターフェイスを介してパケットを送信するためにオーバーヘッドが必要であることを示しています。ASAは、インターフェイスのコストをリンク帯域幅に基づいて計算し、宛先までのホップ数は使用しません。コストは優先パスを指定するために設定できます。

最短パス優先アルゴリズムの欠点は、CPU サイクルとメモリが大量に必要になることです。

ASA は、OSPF プロトコルのプロセス 2 つを異なるインターフェイス セット上で同時に実行できます。同じ IP アドレスを使用する複数のインターフェイス(NAT ではこのようなインターフェイスは共存可能ですが、OSPF ではアドレスの重複は許しません)があるときに、2 つのプロセスを実行する場合があります。あるいは、一方のプロセスを内部で実行しながら別のプロセスを外部で実行し、ルートのサブセットをこの 2 つのプロセス間で再配布する場合もあります。同様に、プライベート アドレスをパブリック アドレスから分離する必要がある場合もあります。

OSPF ルーティング プロセスには、別の OSPF ルーティング プロセスや RIP ルーティング プロセスから、または OSPF 対応インターフェイスに設定されているスタティック ルートおよび接続されているルートから、ルートを再配布できます。

ASAでは、次の OSPF の機能がサポートされています。

エリア内ルート、エリア間ルート、および外部ルート(タイプ I とタイプ II)。

仮想リンク。

LSA フラッディング。

OSPF パケットの認証(パスワード認証と MD5 認証の両方)。

ASA の指定ルータまたは指定バックアップ ルータとしての設定。ASAは、ABR として設定することもできます。

スタブ エリアと not so stubby エリア。

エリア境界ルータのタイプ 3 LSA フィルタリング。

OSPF は、MD5 とクリア テキスト ネイバー認証をサポートしています。OSPF と他のプロトコル(RIP など)の間のルート再配布は、攻撃者によるルーティング情報の悪用に使用される可能性があるため、できる限りすべてのルーティング プロトコルで認証を使用する必要があります。

NAT が使用されている場合、OSPF がパブリック エリアおよびプライベート エリアで動作している場合、またアドレス フィルタリングが必要な場合は、2 つの OSPF プロセス(1 つはパブリック エリア用、1 つはプライベート エリア用)を実行する必要があります。

複数のエリアにインターフェイスを持つルータは、Area Border Router(ABR; エリア境界ルータ)と呼ばれます。ゲートウェイとして動作し、OSPF を使用しているルータと他のルーティング プロトコルを使用しているルータの間でトラフィックを再配布するルータは、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)と呼ばれます。

ABR は LSA を使用して、使用可能なルータに関する情報を他の OSPF ルータに送信します。ABR タイプ 3 LSA フィルタリングを使用すると、ABR として機能するASAを使用して、プライベート エリアとパブリック エリアを分けることができます。タイプ 3 LSA(エリア間ルート)は、プライベート ネットワークをアドバタイズしなくても NAT と OSPF を一緒に使用できるように、1 つのエリアから他のエリアにフィルタリングできます。


) フィルタリングできるのはタイプ 3 LSA だけです。プライベート ネットワークで ASA を ASBR として設定している場合は、プライベート ネットワークを記述するタイプ 5 LSA が送信され、パブリック エリアを含む AS 全体に対してフラッディングされます。


NAT が採用されているが、OSPF がパブリック エリアだけで実行されている場合は、パブリック ネットワークに対するルートを、デフォルトまたはタイプ 5 AS 外部 LSA としてプライベート ネットワーク内で再配布できます。ただし、ASAにより保護されているプライベート ネットワークにはスタティック ルートを設定する必要があります。また、同一のASA インターフェイス上で、パブリック ネットワークとプライベート ネットワークを混在させることはできません。

ASAでは、2 つの OSPF ルーティング プロセス(1 つの RIP ルーティング プロセスと 1 つの EIGRP ルーティング プロセス)を同時に実行できます。

OSPFv2 および OSPFv3 間の実装の差異

OSPFv3 には、OSPFv2 との下位互換性はありません。OSPF を使用して、IPv4 および IPv6 トラフィックの両方をルーティングするには、OSPFv2 および OSPFv3 の両方を同時に実行する必要があります。これらは互いに共存しますが、相互に連携していません。

OSPFv3 では、次の追加機能が提供されます。

リンクごとのプロトコル処理。

アドレッシング セマンティックの削除。

フラッディング スコープの追加。

リンクごとの複数インスタンスのサポート。

ネイバー探索およびその他の機能に対する IPv6 リンクローカル アドレスの使用。

プレフィックスおよびプレフィックス長として表される LSA。

2 つの LSA タイプの追加。

未知の LSA タイプの処理。

RFC-4552 で指定されている OSPFv3 ルーティング プロトコル トラフィックの IPsec ESP 標準を使用する認証サポート。

クラスタリングの使用

ダイナミック ルーティングおよびクラスタリングの詳細については、「ダイナミック ルーティングおよびクラスタリング」を参照してください。

クラスタリングの使用に関する詳細については、「ASA のクラスタの設定」を参照してください。

OSPF のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

モデル
ライセンス要件

すべてのモデル

基本ライセンス

ガイドラインと制限事項

この項では、この機能のガイドラインと制限事項について説明します。

コンテキスト モードのガイドライン

OSPFv2 は、シングル コンテキスト モードとマルチ コンテキスト モードをサポートしています。

OSPFv3 は、シングル モードのみをサポートしています。

ファイアウォール モードのガイドライン

OSPF は、ルーテッド ファイアウォール モードのみをサポートしています。OSPF は、トランスペアレント ファイアウォール モードをサポートしません。

フェールオーバーのガイドライン

OSPFv2 および OSPFv3 は、ステートフル フェールオーバーをサポートしています。

IPv6 のガイドライン

OSPFv2 は IPv6 をサポートしません。

OSPFv3 は IPv6 をサポートしています。

OSPFv3 は、IPv6 を使用して認証を行います。

ASA は、OSPFv3 ルートが最適なルートの場合、IPv6 RIB にこのルートをインストールします。

OSPFv3 パケットは、 capture コマンドの IPv6 ACL を使用してフィルタリングで除外できます。

クラスタリングのガイドライン

OSPFv2 および OSPFv3 は、クラスタリングをサポートします。

OSPFv3 暗号化はサポートされていません。クラスタリング環境で OSPFv3 暗号化を設定しようとすると、エラー メッセージが表示されます。

スパンド インターフェイス モードでは、ダイナミック ルーティングは管理専用インターフェイスでサポートされていません。

個別インターフェイス モードで、OSPFv2 または OSPFv3 ネイバーとしてマスター ユニットおよびスレーブ ユニットが確立されていることを確認します。

OSPFv2 と EIGRP の両方を設定すると、スパンド インターフェイス モードまたは個別インターフェイス モードのいずれかを使用できますが、2 つのモードを同時に使用することはできません。

個別インターフェイス モードでは、OSPFv2 との隣接関係は、マスター ユニットの共有インターフェイスの 2 つのコンテキスト間でのみ確立できます。スタティック ネイバーの設定は、ポイントツーポイン リンクでのみサポートされます。したがって、インターフェイスで許可されるのは 1 つのネイバー ステートメントだけです。

ルータ ID は、OSPFv2、OSPFv3、および EIGRP ルータ コンフィギュレーション モードでオプションです。ルータ ID を明示的に設定しない場合、ルータ ID は自動的に生成され、各クラスタ ユニットのデータ インターフェイスにおける最大の IPv4 アドレスに設定されます。

クラスタ インターフェイス モードが設定されていない場合は、ルータ ID として単一のドット付き 10 進数の IPv4 アドレスだけが許可され、 cluster pool オプションはディセーブルになります。

クラスタ インターフェイス モードがスパンド コンフィギュレーションに設定されている場合は、ルータ ID として単一のドット付き 10 進数の IPv4 アドレスだけが許可され、 cluster pool オプションはディセーブルになります。

クラスタ インターフェイス モードが個々のコンフィギュレーションに設定されている場合、 cluster pool オプションは必須となり、単一の、ドット付き 10 進数の IPv4 アドレスがルータ ID として許可されません

check-detail または nocheck オプションを指定せずに、クラスタ インターフェイス モードをスパンド コンフィギュレーションから個々のコンフィギュレーション(またはその逆)に変更すると、ルータ ID を含むコンフィギュレーション全体が削除されます。

新しいインターフェイス モードと互換性のないダイナミック ルーティング プロトコルのルータ ID がある場合は、コンソールにエラー メッセージが表示され、インターフェイス モード CLI は失敗します。エラー メッセージには、ダイナミック ルーティング プロトコル(OSPFv2、OSPFv3 および EIGRP)ごとに 1 行があり、互換性のない設定が発生した各コンテキストの名前がリストされます。

nocheck オプションが cluster interface mode コマンドに指定されている場合は、インターフェイス モードを変更できます。ただし、すべてのルータ ID の設定に新しいモードとの互換性があるとは限りません。

クラスタがイネーブルの場合、ルータ ID の互換性チェックが繰り返されます。非互換性が検出された場合、 cluster enable コマンドは失敗します。管理者は、クラスタをイネーブルにする前に互換性のないルータ ID コンフィギュレーションを修正する必要があります。

ユニットがスレーブとしてクラスタに参加する場合は、ルータ ID の互換性チェックが失敗しないように、 cluster interface mode コマンドの nocheck オプションを指定することを推奨します。スレーブ ユニットは、マスター ユニットのルータ コンフィギュレーションを継承します。

クラスタでマスターシップ ロールの変更が発生した場合、次の動作が発生します。

スパンド インターフェイス モードでは、ルータ プロセスはマスター ユニットでのみアクティブになり、スレーブ ユニットでは停止状態になります。コンフィギュレーションがマスター ユニットと同期されているため、各クラスタ ユニットには同じルータ ID があります。その結果、隣接ルータはロール変更時のクラスタのルータ ID の変更を認識しません。

個別インターフェイス モードでは、ルータ プロセスはすべての個別のクラスタ ユニットでアクティブになります。各クラスタ ユニットは設定されたクラスタ プールから独自の個別のルータ ID を選択します。クラスタでマスターシップ ロールが変更されても、ルーティング トポロジは変更されません。

その他のガイドライン

OSPFv2 および OSPFv3 は 1 つのインターフェイス上での複数インスタンスをサポートしています。

OSPFv3 は、非クラスタ環境での ESP ヘッダーを介した暗号化をサポートしています。

OSPFv3 は非ペイロード暗号化をサポートします。

OSPFv2 の設定

ここでは、ASA で OSPFv2 プロセスをイネーブルにする方法について説明します。

OSPFv2 をイネーブルにした後、ルート マップを定義する必要があります。詳細については、「ルート マップの定義」を参照してください。その後、デフォルト ルートを生成します。詳細については、「スタティック ルートおよびデフォルト ルートの設定」を参照してください。

OSPFv2 プロセスのルート マップを定義した後で、ニーズに合わせてカスタマイズできます。ASA 上で OSPFv2 プロセスをカスタマイズする方法については、「OSPFv2 のカスタマイズ」を参照してください。

OSPFv2 をイネーブルにするには、OSPFv2 ルーティング プロセスを作成し、このルーティング プロセスに関連付ける IP アドレスの範囲を指定し、さらにその IP アドレスの範囲にエリア ID を割り当てる必要があります。

最大 2 つの OSPFv2 プロセス インスタンスをイネーブルにできます。各 OSPFv2 プロセスには、独自のエリアとネットワークが関連付けられます。

OSPFv2 をイネーブルにするには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成して、この OSPF プロセスのルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ASA上で OSPF プロセスが 1 つしかイネーブルになっていないと、そのプロセスがデフォルトで選択されます。既存のエリアを編集する場合、OSPF プロセス ID を変更できません。

ステップ 2

network ip_address mask area area_id
 

hostname(config)# router ospf 2

hostname(config-rtr)# network 10.0.0.0 255.0.0.0 area 0

OSPF を実行する IP アドレスを定義し、そのインターフェイスのエリア ID を定義します。

新しいエリアを追加する場合、そのエリア ID を入力します。このエリア ID には、10 進数か IP アドレスを指定できます。有効な 10 進値の範囲は、0 ~ 4294967295 です。既存のエリアを編集する場合、エリア ID は変更できません。

OSPFv2 のカスタマイズ

この項では、OSPFv2 プロセスをカスタマイズする方法について説明します。次の項目を取り上げます。

「OSPFv2 へのルートの再配布」

「OSPFv2 にルートを再配布する場合のルート集約の設定」

「OSPFv2 エリア間のルート集約の設定」

「OSPFv2 インターフェイスのパラメータの設定」

「OSPFv2 エリア パラメータの設定」

「OSPFv2 NSSA の設定」

「クラスタリングの IP アドレス プールの設定(OSPFv2 および OSPFv3)」

「スタティック OSPFv2 ネイバーの定義」

「ルート計算タイマーの設定」

「ネイバーがアップ状態またはダウン状態になった時点でのロギング」

OSPFv2 へのルートの再配布

ASA は、OSPFv2 ルーティング プロセス間のルート再配布を制御できます。


) 指定されたルーティング プロトコルから、ターゲット ルーティング プロセスに再配布できるルートを定義することでルートを再配布する場合は、デフォルト ルートを最初に生成する必要があります。「スタティック ルートおよびデフォルト ルートの設定」を参照し、その後に「ルート マップの定義」に従ってルート マップを定義します。


スタティック ルート、接続されているルート、RIP ルート、または OSPFv2 ルートを OSPFv2 プロセスに再配布するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、再配布する OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

選択したルート タイプを OSPF ルーティング プロセスに再配布するには、次のいずれかの手順を実行します。

redistribute connected [[ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name ]
 

hostname(config)# redistribute connected 5 type-1 route-map-practice

接続済みルートを OSPF ルーティング プロセスに再配布します。

redistribute static [ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name
 

hostname(config)# redistribute static 5 type-1 route-map-practice

スタティック ルートを OSPF ルーティング プロセスに再配布します。

redistribute ospf pid [ match {internal | external [ 1 | 2] | nssa-external [ 1 | 2 ]}] [ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name ]
 

hostname(config)# route-map 1-to-2 permit

hostname(config-route-map)# match metric 1

hostname(config-route-map)# set metric 5

hostname(config-route-map)# set metric-type type-1

hostname(config-route-map)# router ospf 2

hostname(config-rtr)# redistribute ospf 1 route-map 1-to-2

OSPF ルーティング プロセスのルートを別の OSPF ルーティング プロセスに再配布できます。

このコマンドに match オプションを使用してルート プロパティを照合および設定することも、ルート マップを使用することもできます。 subnets オプションは、 route-map コマンドで使用する場合と同じではありません。 redistribute コマンドでルート マップと match オプションの両方を使用した場合、これらは一致している必要があります。

この例では、ルートをメトリック 1 に照合することによる、OSPF プロセス 1 から OSPF プロセス 2 へのルートの再配布を示しています。ASA は、これらのルートをメトリック 5、メトリック タイプ 1 で外部 LSA として再配布します。

redistribute rip [ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name ]
 

hostname(config)# redistribute rip 5

hostname(config-route-map)# match metric 1

hostname(config-route-map)# set metric 5

hostname(config-route-map)# set metric-type type-1

hostname(config-rtr)# redistribute ospf 1 route-map 1-to-2

RIP ルーティング プロセスのルートを OSPF ルーティング プロセスに再配布できます。

redistribute eigrp as-num [ metric metric-value ] [ metric-type { type-1 | type-2 }] [ tag tag_value ] [ subnets ] [ route-map map_name ]
 

hostname(config)# redistribute eigrp 2

hostname(config-route-map)# match metric 1

hostname(config-route-map)# set metric 5

hostname(config-route-map)# set metric-type type-1

hostname(config-rtr)# redistribute ospf 1 route-map 1-to-2

EIGRP ルーティング プロセスのルートを OSPF ルーティング プロセスに再配布できます。

OSPFv2 にルートを再配布する場合のルート集約の設定

他のプロトコルからのルートを OSPF に再配布する場合、各ルートは外部 LSA で個別にアドバタイズされます。その一方で、指定したネットワーク アドレスとマスクに含まれる再配布ルートすべてに対して 1 つのルートをアドバタイズするように ASA を設定することができます。この設定によって OSPF リンクステート データベースのサイズが小さくなります。

指定した IP アドレス マスク ペアと一致するルートは廃止できます。ルート マップで再配布を制御するために、タグ値を一致値として使用できます。

ネットワーク アドレスとマスクに含まれる再配布ルートすべてに対して 1 つのサマリー ルートをアドバタイズするようにソフトウェアを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 1

OSPF ルーティング プロセスを作成して、この OSPF プロセスのルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

summary-address ip_address mask [ not-advertise ] [tag tag ]
 

hostname(config)# router ospf 1

hostname(config-rtr)# summary-address 10.1.0.0 255.255.0.0

サマリー アドレスを設定します。

この例のサマリー アドレスの 10.1.0.0 には、10.1.1.0、10.1.2.0、10.1.3.0 などのアドレスが含まれます。外部のリンクステート アドバタイズメントでは、アドレス 10.1.0.0 だけがアドバタイズされます。

OSPFv2 エリア間のルート集約の設定

ルート集約は、アドバタイズされるアドレスを統合することです。この機能を実行すると、1 つのサマリー ルートがエリア境界ルータを通して他のエリアにアドバタイズされます。OSPF のエリア境界ルータは、ネットワークをある 1 つのエリアから別のエリアへとアドバタイズしていきます。あるエリアにおいて連続する複数のネットワーク番号が割り当てられている場合、指定された範囲に含まれるエリア内の個別のネットワークをすべて含むサマリー ルートをアドバタイズするようにエリア境界ルータを設定することができます。

ルート集約のアドレス範囲を定義するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 1

OSPF ルーティング プロセスを作成して、この OSPF プロセスのルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

area area-id range ip-address mask [ advertise | not-advertise ]
 
hostname(config)# router ospf 1
hostname(config-rtr)# area 17 range 12.1.0.0 255.255.0.0

アドレス範囲を設定します。

この例では、アドレス範囲は OSPF エリア間で設定されます。

OSPFv2 インターフェイスのパラメータの設定

必要に応じて一部のインターフェイス固有の OSPFv2 パラメータを変更できます。これらのパラメータは必ずしも変更する必要はありませんが、 ospf hello-interval ospf dead-interval 、および ospf authentication-key というインターフェイス パラメータは、接続されているネットワーク内のすべてのルータで一致している必要があります。これらのパラメータのいずれかを設定する場合は、ネットワーク上のすべてのルータのコンフィギュレーションに適合する値にするようにしてください。

OSPFv2 インターフェイス パラメータを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、再配布する OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

network ip_address mask area area_id
 

hostname(config)# router ospf 2

hostname(config-rtr)# network 10.0.0.0 255.0.0.0 area 0

OSPF を実行する IP アドレスを定義し、そのインターフェイスのエリア ID を定義します。

ステップ 3

interface interface_name
 

hostname(config)# interface my_interface

インターフェイス コンフィギュレーション モードに入ることができます。

ステップ 4

次のいずれかの手順を実行し、オプションの OSPF インターフェイス パラメータを設定します。

ospf authentication [message-digest | nul l ]

 

hostname(config-interface)# ospf authentication message-digest

インターフェイスの認証タイプを指定します。

ospf authentication-key key

 

hostname(config-interface)# ospf authentication-key cisco

OSPF 簡易パスワード認証を使用しているネットワーク セグメントに存在するネイバー OSPF ルータで使用するパスワードを割り当てることができます。

key 引数には、最大 8 バイトの連続する文字列が指定できます。

このコマンドで作成するパスワードはキーとして使用され、このキーはASAのソフトウェアによるルーティング プロトコル パケットの発信時に OSPF ヘッダーに直接挿入されます。各ネットワークにはインターフェイスごとに個別のパスワードを割り当てることができます。OSPF 情報を交換するには、同じネットワーク上のすべての隣接ルータが同じパスワードを持っている必要があります。

ospf cost cost

 

hostname(config-interface)# ospf cost 20

OSPF インターフェイスでパケットを送信するためのコストを明示的に指定できます。 cost は、1 ~ 65535 の整数です。

この例では、cost は 20 に設定されています。

ospf dead-interval seconds

 

hostname(config-interface)# ospf dead-interval 40

hello パケットが受信されなかったために、ネイバー OSPF ルータがダウンしているとデバイスが宣言する場合に必要な待機時間を秒単位で設定できます。この値はネットワーク上のすべてのノードで同じにする必要があります。

この例では、dead 間隔は 40 に設定されています。

ospf hello-interval seconds

 

hostname(config-interface)# ospf hello-interval 10

ASA が OSPF インターフェイスから hello パケットを送信する時間間隔を指定できます。この値はネットワーク上のすべてのノードで同じにする必要があります。

この例では、hello 間隔は 10 に設定されています。

ospf message-digest-key key_id md5 key

 

hostname(config-interface)# ospf message-digest-key 1 md5 cisco

OSPF MD5 認証をイネーブルにします。

次の引数を設定できます。

key_id :範囲 1 ~ 255 の識別子

key :最大 16 バイトの英数字パスワード。

通常は、インターフェイスあたり 1 つのキーを使用して、パケット送信時に認証情報を生成するとともに着信パケットを認証します。隣接ルータの同一キー識別子は、キー値を同一にする必要があります。

1 インターフェイスで 2 つ以上のキーを保持しないことをお勧めします。新しいキーを追加したらその都度古いキーを削除して、ローカル システムが古いキー情報を持つ悪意のあるシステムと通信を続けることのないようにしてください。古いキーを削除すると、ロールオーバー中のオーバーヘッドを減らすことにもなります。

ospf priority number_value

 

hostname(config-interface)# ospf priority 20

ネットワークの OSPF 指定ルータを決定するためのプライオリティを設定できます。

number_value の引数の範囲は 0 ~ 255 です。

この例では、プライオリティ番号の値は 20 に設定されています。

ospf retransmit-interval seconds

 

hostname(config-interface)# ospf retransmit-interval seconds

OSPF インターフェイスに属する隣接ルータに LSA を再送信する間隔を秒単位で指定できます。

seconds の値は、接続されているネットワーク上の任意の 2 ルータ間で予想されるラウンドトリップ遅延よりも長い秒数でなければなりません。範囲は 1 ~ 65535 秒です。デフォルト値は、5 秒です。

この例では、retransmit-interval の値は 15 に設定されています。

ospf transmit-delay seconds

 
hostname(config-interface)# ospf transmit-delay 5

OSPF インターフェイスでリンクステート アップデート パケットを送信するために必要な予想時間を秒単位で設定できます。 seconds の値は、1 ~ 65535 秒です。デフォルト値は 1 秒です。

この例では、transmit-delay は 5 秒です。

ospf network point-to-point non-broadcast

 

hostname(config-interface)# ospf network point-to-point non-broadcast

インターフェイスをポイントツーポイントの非ブロードキャスト ネットワークとして指定します。

インターフェイスをポイントツーポイントの非ブロードキャストとして指定するには、手動で OSPF ネイバーを定義する必要があります。ダイナミック ネイバー探索はできません。詳細については、「スタティック OSPFv2 ネイバーの定義」を参照してください。さらに、そのインターフェイスに定義できる OSPF ネイバーは 1 つだけです。

OSPFv2 エリア パラメータの設定

複数の OSPF エリア パラメータを設定できます。これらのエリア パラメータ(後述のタスク リストに表示)には、認証の設定、スタブ エリアの定義、デフォルト サマリー ルートへの特定のコストの割り当てがあります。認証では、エリアへの不正アクセスに対してパスワードベースで保護します。

スタブ エリアは、外部ルートの情報が送信されないエリアです。その代わりに、ABR で生成されるデフォルトの外部ルートがあり、このルートは自律システムの外部の宛先としてスタブ エリアに送信されます。OSPF スタブ エリアのサポートを活用するには、デフォルトのルーティングをスタブ エリアで使用する必要があります。スタブ エリアに送信される LSA の数をさらに減らすには、ABR で実行する area stub コマンドで no-summary キーワードを使用して、スタブ エリアにサマリー リンク アドバタイズメント(LSA タイプ 3)が送信されないようにします。

ネットワークに OSPFv2 エリア パラメータを指定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、再配布する OSPF プロセスのルータ コンフィギュレーション モードに入ります。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

次のいずれかの手順を実行し、オプションの OSPF エリア パラメータを設定します。

area area-id authentication
 

hostname(config-rtr)# area 0 authentication

OSPF エリアの認証をイネーブルにします。

area area-id authentication message-digest

 

hostname(config-rtr)# area 0 authentication message-digest

OSPF エリアの MD5 認証をイネーブルにします。

OSPFv2 NSSA の設定

NSSA の OSPFv2 への実装は、OSPFv2 のスタブ エリアに似ています。NSSA は、タイプ 5 の外部 LSA をコアからエリアにフラッディングすることはありませんが、自律システムの外部ルートをある限られた方法でエリア内にインポートできます。

NSSA は、再配布によって、タイプ 7 の自律システムの外部ルートを NSSA エリア内部にインポートします。これらのタイプ 7 の LSA は、NSSA の ABR によってタイプ 5 の LSA に変換され、ルーティング ドメイン全体にフラッディングされます。変換中は集約とフィルタリングがサポートされます。

OSPFv2 を使用する中央サイトから異なるルーティング プロトコルを使用するリモート サイトに接続しなければならない ISP またはネットワーク管理者は、NSSA を使用することによって管理を簡略化できます。

NSSA が実装される前は、企業サイトの境界ルータとリモート ルータ間の接続では、OSPFv2 スタブ エリアとしては実行されませんでした。これは、リモート サイト向けのルートは、スタブ エリアに再配布することができず、2 種類のルーティング プロトコルを維持する必要があったためです。RIP のようなシンプルなプロトコルを実行して再配布を処理する方法が一般的でした。NSSA が実装されたことで、企業ルータとリモート ルータ間のエリアを NSSA として定義することにより、NSSA で OSPFv2 を拡張してリモート接続をカバーできます。

この機能を使用する前に、次のガイドラインを参考にしてください。

外部の宛先に到達するために使用可能なタイプ 7 のデフォルト ルートを設定できます。設定すると、NSSA または NSSA エリア境界ルータまでのタイプ 7 のデフォルトがルータによって生成されます。

同じエリア内のすべてのルータは、エリアが NSSA であることを認識する必要があります。そうでない場合、ルータは互いに通信できません。

OSPFv2 NSSA を設定するためのエリア パラメータをネットワークに指定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 2

OSPF ルーティング プロセスを作成し、再配布する OSPF ルーティング プロセスのルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

次のいずれかの手順を実行し、オプションの OSPF NSSA パラメータを設定します。

area area-id nssa [ no-redistribution ] [ default-information-originate ]
 

hostname(config-rtr)# area 0 nssa

NSSA エリアを定義します。

summary-address ip_address mask [ not-advertise ] [tag tag ]
 

hostname(config-rtr)# summary-address 10.1.0.0 255.255.0.0

サマリー アドレスを設定します。これは、ルーティング テーブルのサイズを小さくするために役立ちます。OSPF でこのコマンドを使用すると、このアドレスでカバーされる再配布ルートすべての集約として、1 つの外部ルートが OSPF ASBR からアドバタイズされます。

この例のサマリー アドレスの 10.1.0.0 には、10.1.1.0、10.1.2.0、10.1.3.0 などのアドレスが含まれます。外部のリンクステート アドバタイズメントでは、アドレス 10.1.0.0 だけがアドバタイズされます。


) OSPF は summary-address 0.0.0.0 0.0.0.0 をサポートしません。


クラスタリングの IP アドレス プールの設定(OSPFv2 および OSPFv3)

レイヤ 3 クラスタリングを使用する場合は、ルータ ID のクラスタ プールの IPv4 アドレスの範囲を割り当てることができます。

OSPFv2 および OSPFv3 のレイヤ 3 クラスタリングのルータ ID のクラスタ プールの IPv4 アドレスの範囲を割り当てるには、次のコマンドを入力します。

 

コマンド
目的
router-id cluster-pool hostname | A.B.C.D ip_pool
 

hostname(config)# ip local pool rpool 1.1.1.1-1.1.1.4

hostname(config)# router ospf 1

hostname(config-rtr)# router-id cluster-pool rpool

hostname(config-rtr)# network 17.5.0.0 255.255.0.0 area 1

hostname(config-rtr)# log-adj-changes

レイヤ 3 クラスタリングのルータ ID のクラスタ プールを指定します。

cluster-pool キーワードは、レイヤ 3 クラスタリングが設定されている場合に、IP アドレス プールの設定をイネーブルにします。 hostname | A.B.C.D. キーワードは、この OSPF プロセスの OSPF ルータ ID を指定します。 ip_pool 引数には、IP アドレス プールの名前を指定します。

(注) クラスタリングを使用している場合は、ルータ ID の IP アドレス プールを指定する必要はありません。IP アドレス プールを設定しない場合、ASA は自動的に生成されたルータ ID を使用します。

スタティック OSPFv2 ネイバーの定義

ポイントツーポイントの非ブロードキャスト ネットワークを介して OSPFv2 ルートをアドバタイズするには、スタティック OSPFv2 ネイバーを定義する必要があります。この機能により、OSPFv2 アドバタイズメントを GRE トンネルにカプセル化しなくても、既存の VPN 接続でブロードキャストすることができます。

開始する前に、OSPFv2 ネイバーに対するスタティック ルートを作成する必要があります。スタティック ルートの作成方法の詳細については、 「スタティック ルートおよびデフォルト ルートの設定」 を参照してください。

スタティック OSPFv2 ネイバーを定義するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 2

OSPFv2 ルーティング プロセスを作成して、この OSPFv2 プロセスのルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

neighbor addr [ interface if_name ]
 

hostname(config-rtr)# neighbor 255.255.0.0 [interface my_interface]

OSPFv2 ネイバーフッドを定義します。

addr 引数には OSPFv2 ネイバーの IP アドレスを指定します。 if_name 引数は、ネイバーとの通信に使用するインターフェイスです。OSPFv2 ネイバーが直接接続されているインターフェイスのいずれとも同じネットワーク上にない場合、interface を指定する必要があります。

ルート計算タイマーの設定

OSPFv2 によるトポロジ変更受信と最短パス優先(SPF)計算開始との間の遅延時間が設定できます。最初に SPF を計算してから次に計算するまでの保持時間も設定できます。

ルート計算タイマーを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 2

OSPFv2 ルーティング プロセスを作成して、この OSPFv2 プロセスのルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

timers spf spf-delay spf-holdtime
 

hostname(config-rtr)# timers spf 10 120

ルート計算時間を設定します。

spf-delay 引数は、OSPF によるトポロジ変更受信と SPF 計算開始との間の遅延時間(秒)です。0 ~ 65535 の整数に設定できます。デフォルトの時間は 5 秒です。値の 0 は遅延がないことを意味します。つまり、SPF 計算はただちに開始されます。

spf-holdtime 引数は、2 つの連続する SPF 計算の間の最短時間(秒)です。0 ~ 65535 の整数に設定できます。デフォルトの時間は 10 秒です。値の 0 は遅延がないことを意味します。つまり、2 回の SPF 計算がすぐに続けて実行されます。

ネイバーがアップ状態またはダウン状態になった時点でのロギング

デフォルトでは、OSPFv2 ネイバーがアップ状態またはダウン状態になったときに、syslog メッセージが生成されます。

アップ状態またはダウン状態になった OSPFv2 ネイバーについて、 debug ospf adjacency コマンドを実行せずに確認する必要がある場合に、 log-adj-changes コマンドを設定します。 log-adj-changes コマンドでは、少ない出力によってピアの関係が高いレベルで表示されます。それぞれの状態変化メッセージを確認する場合は、 log-adj-changes detail コマンドを設定します。

アップ状態またはダウン状態になった OSPFv2 ネイバーをログに記録するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config)# router ospf 2

OSPFv2 ルーティング プロセスを作成して、この OSPFv2 プロセスのルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。任意の正の整数が使用できます。この ID は内部専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

log-adj-changes [ detail ]
 

hostname(config-rtr)# log-adj-changes [detail]

アップ状態またはダウン状態になったネイバーに対するロギングを設定します。

OSPFv3 の設定

ここでは、OSPFv3 ルーティング プロセスを設定する手順について説明します。内容は次のとおりです。

「OSPFv3 のイネーブル化」

「OSPFv3 インターフェイスのパラメータの設定」

「OSPFv3 ルータ パラメータの設定」

「OSPFv3 エリア パラメータの設定」

「OSPFv3 パッシブ インターフェイスの設定」

「OSPFv3 アドミニストレーティブ ディスタンスの設定」

「OSPFv3 タイマーの設定」

「スタティック OSPFv3 ネイバーの定義」

「OSPFv3 デフォルト パラメータのリセット」

「syslog メッセージの送信」

「syslog メッセージの抑止」

「サマリー ルート コストの計算」

「OSPFv3 ルーティング ドメインへのデフォルトの外部ルートの生成」

「IPv6 サマリー プレフィックスの設定」

「IPv6 ルートの再配布」

OSPFv3 のイネーブル化

OSPFv3 をイネーブルにするには、OSPFv3 ルーティング プロセスを作成し、OSPFv3 用のエリアを作成して、OSPFv3 のインターフェイスをイネーブルにする必要があります。その後、ターゲットの OSPFv3 ルーティング プロセスにルートを再配布する必要があります。

OSPFv3 をイネーブルにするには、次のコマンドを入力するか、次の手順を実行します。

 

コマンド
目的

ipv6 router ospf process-id

 

hostname(config)# ipv6 router ospf 10

OSPFv3 ルーティング プロセスを作成し、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用されるタグです。任意の正の整数が使用できます。このタグは内部専用のため、他のどのデバイス上のタグとも照合する必要はありません。最大 2 つのプロセスが使用できます。

 

コマンド
目的

ステップ 1

interface interface_name
 
hostname(config)# interface Gigabitethernet0/0

インターフェイスをイネーブルにします。

ステップ 2

ipv6 ospf process-id area area_id
 
hostname(config)# ipv6 ospf 200 area 100

特定のプロセス ID を持つ OSPFv3 ルーティング プロセスおよび指定したエリア ID を持つ OSPFv3 のエリアを作成します

OSPFv3 インターフェイスのパラメータの設定

必要に応じて特定のインターフェイス固有の OSPFv3 パラメータを変更できます。これらのパラメータは必ずしも変更する必要はありませんが、 ipv6 ospf hello-interval 、および ipv6 ospf dead-interval というインターフェイス パラメータは、接続されているネットワーク内のすべてのルータで一致している必要があります。これらのパラメータを設定する場合は、ネットワーク上のすべてのルータで、コンフィギュレーションの値が矛盾していないことを確認してください。

IPv6 の OSPFv3 インターフェイス パラメータを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id

 

hostname(config-if)# ipv6 router ospf 10

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用されるタグです。任意の正の整数が使用できます。このタグは内部専用のため、他のどのデバイス上のタグとも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

ipv6 ospf area [ area-num ] [ instance ]
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200

OSPFv3 エリアを作成します。

area-num 引数は、認証がイネーブルになるエリアであり、10 進数値または IP アドレスを指定できます。 instance キーワードは、インターフェイスに割り当てられるエリア インスタンス ID を指定します。インターフェイスは、OSPFv3 エリアを 1 つだけ保有できます。複数のインターフェイスで同じエリアを使用でき、各インターフェイスは異なるエリア インスタンス ID を使用できます。

ステップ 3

次のいずれかの手順を実行し、OSPFv3 インターフェイス パラメータを設定します。

ipv6 ospf cost interface-cost
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200

インターフェイス上でパケットを送信するコストを明示的に指定します。 interface-cost 引数は、リンクステート メトリックとして表される符号なし整数値を指定します。値の範囲は、1 ~ 65535 です。デフォルトのコストは帯域幅に基づきます。

ipv6 ospf database-filter all out
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200

ipv6 ospf database-filter all out

OSPFv3 インターフェイスへの発信 LSA をフィルタリングします。デフォルトでは、すべての発信 LSA がインターフェイスにフラッディングされます。

ipv6 ospf dead-interval seconds
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200
ipv6 ospf dead-interval 60

秒単位で設定する期間内に hello パケットが確認されないと、当該ルータがダウンしていることがネイバーによって示されます。この値はネットワーク上のすべてのノードで同じにする必要があります。値の範囲は、1 ~ 65535 です。デフォルト値は、 ipv6 ospf hello-interval コマンドで設定された間隔の 4 倍です。

ipv6 ospf encryption { ipsec spi spi esp encryption-algorithm [[ key-encryption-type ] key ] authentication-algorithm [[ key-encryption-type ] key | null }
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200
ipv6 ospf encryption ipsec spi 1001 esp null sha1 123456789A123456789B123456789C123456789D

インターフェイスに暗号化タイプを指定します。 ipsec キーワードは、IP セキュリティ プロトコルを指定します。 spi spi キーワード引数のペアは、セキュリティ ポリシー インデックスを指定します。値の範囲は 256 ~ 42949667295 である必要があり、10 進数で入力する必要があります。 esp キーワードは、カプセル化セキュリティ ペイロードを指定します。 encryption-algorithm 引数は、ESP で使用される暗号化アルゴリズムを指定します。有効な値は次のとおりです。

aes-cdc:AES-CDC 暗号化をイネーブルにします。

3des:トリプル DES 暗号化をイネーブルにします。

des:DES 暗号化をイネーブルにします。

null:暗号化なしの ESP を指定します。

key-encryption-type 引数に、次の 2 つのうちいずれかの値を指定します。

0:キーは暗号化されません。

7:キーは暗号化されます。

key 引数は、メッセージ ダイジェストの計算で使用される番号を指定します。この番号の長さは 32 桁の 16 進数(16 バイト)です。キーのサイズは、使用される暗号化アルゴリズムによって異なります。AES-CDC など、一部のアルゴリズムでは、キーのサイズを選択することができます。 authentication-algorithm 引数は、使用される次のいずれかの暗号化認証アルゴリズムを指定します。

md5:Message Digest 5(MD5)をイネーブルにします。

sha1:SHA-1 をイネーブルにします。

null キーワードはエリアの暗号化より優先されます。

(注) インターフェイスで OSPFv3 暗号化がイネーブルになっており、ネイバーが異なるエリア(たとえば、エリア 0)にあり、ASA がそのエリアとの隣接関係を形成する場合は、ASA のエリアを変更する必要があります。ASA のエリアを 0 に変更すると、OSPFv3 の隣接関係が確立される前に 2 分の遅延が発生します。

ipv6 ospf flood-reduction
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200
ipv6 ospf flood reduction

インターフェイスに LSA のフラッディング削減を指定します。

ipv6 ospf hello-interval seconds
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200

ipv6 ospf hello-interval 15

インターフェイス上で送信される hello パケット間の間隔(秒数)を指定します。この値は特定のネットワーク上のすべてのノードで同じにする必要があります。値の範囲は、1 ~ 65535 です。デフォルトの間隔は、イーサネット インターフェイスで 10 秒、非ブロードキャスト インターフェイスで 30 秒です。

ipv6 ospf mtu-ignore
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200
ipv6 ospf mtu-ignore

DBD パケットを受信した場合の OSPF MTU 不一致検出をディセーブルにします。OSPF MTU 不一致検出は、デフォルトでイネーブルになっています。

ipv6 ospf network { broadcast | point-to-point non-broadcast }
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200
ipv6 ospf network point-to-point non-broadcast

ネットワーク タイプに依存するデフォルト以外のタイプに OSPF ネットワーク タイプを設定します。 point-to-point non-broadcast キーワードは、ネットワーク タイプをポイントツーポイント、非ブロードキャストに設定します。 broadcast キーワードは、ネットワーク タイプをブロードキャストに設定します。

ipv6 ospf priority number-value
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200
ipv6 ospf priority 4

ルータ プライオリティを設定します。これは、ネットワークにおける指定ルータの特定に役立ちます。有効値の範囲は 0 ~ 255 です。

ipv6 ospf neighbor ipv6-address [ priority number ] [ poll-interval seconds ] [ cost number ] [ database-filter all out ]
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200
ipv6 ospf neighbor FE80::A8BB:CCFF:FE00:C01

非ブロードキャスト ネットワークへの OSPFv3 ルータの相互接続を設定します。

ipv6 ospf retransmit-interval seconds
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200
ipv6 ospf retransmit-interval 8

インターフェイスに属する隣接関係の LSA 再送信間の時間を秒単位で指定します。接続ネットワーク上の任意の 2 台のルータ間で想定される往復遅延より大きな値にする必要があります。有効値の範囲は、1 ~ 65535 秒です。デフォルトは 5 秒です。

ipv6 ospf transmit-delay seconds
 

hostname(config-if)# interface GigabitEthernet3/2.200

vlan 200

nameif outside

security-level 100

ip address 10.20.200.30 255.255.255.0 standby 10.20.200.31

ipv6 address 3001::1/64 standby 3001::8

ipv6 address 6001::1/64 standby 6001::8

ipv6 enable

ospf priority 255

ipv6 ospf cost 100

ipv6 ospf 100 area 10 instance 200
ipv6 ospf retransmit-delay 3

インターフェイス上でリンクステート更新パケットを送信する時間を秒単位で設定します。有効値の範囲は、1 ~ 65535 秒です。デフォルトは 1 秒です。

OSPFv3 ルータ パラメータの設定

IPv6 の OSPFv3 ルータ パラメータを設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config)# ipv6 router ospf 10

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

次のいずれかの手順を実行し、オプションの OSPFv3 ルータ パラメータを設定します。

area
 
hostname(config-rtr)# area 10

OSPFv3 エリア パラメータを設定します。サポートされているパラメータには、0 ~ 4294967295 の 10 進数値のエリア ID、 A.B.C.D の IP アドレス形式のエリア ID などがあります。

default
 

hostname(config-rtr)# default originate

コマンドをデフォルト値に設定します。 originate パラメータはデフォルト ルートを配布します。

default-information
 

hostname(config-rtr)# default-information

デフォルト情報の配布を制御します。

distance
 

hostname(config-rtr)# distance 200

ルート タイプに基づいて、OSPFv3 ルート アドミニストレーティブ ディスタンスを定義します。サポートされるパラメータには、1 ~ 254 の値のアドミニストレーティブ ディスタンス、OSPFv3 ディスタンスの ospf などがあります。

exit
 
hostname(config-rtr)# exit

IPv6 ルータ コンフィギュレーション モードを終了します。

ignore
 

hostname(config-rtr)# ignore lsa

ルータがタイプ 6 Multicast OSPF(MOSPF)パケットのリンクステート アドバタイズメント(LSA)を受信した場合に、 lsa パラメータが指定されている syslog メッセージの送信を抑止します。

log-adjacency-changes
 

hostname(config-rtr)# log-adjacency-changes detail

OSPFv3 ネイバーが起動または停止したときに、ルータが syslog メッセージを送信するように設定します。 detail パラメータによって、すべての状態変更がログに記録されます。

passive-interface [ interface_name ]
 

hostname(config-rtr)# passive-interface inside

インターフェイスでのルーティング アップデートの送受信を抑止します。 interface_name 引数は、OSPFv3 プロセスが実行されているインターフェイスの名前を指定します。

redistribute
 

hostname(config-rtr)# redistribute ospf

次のパラメータに基づいて 1 つのルーティング ドメインから別のルーティング ドメインへのルートの再配布を設定します。

connected :接続ルートを指定します。

ospf :OSPFv3 ルートを指定します。

static :スタティック ルートを指定します。

router-id
 
hostname(config-rtr)# router-id 10.1.1.1

次のパラメータを使用して、指定されたプロセスの固定ルータ ID を作成します。

A.B.C.D :IP アドレス形式の OSPF ルータ ID を指定します。

cluster-pool :キーワードは、レイヤ 3 クラスタリングが設定されている場合に、IP アドレス プールを設定します。クラスタリングで使用される IP アドレス プールの詳細については、「クラスタリングの IP アドレス プールの設定(OSPFv2 および OSPFv3)」を参照してください。

summary-prefix
 
hostname(config-if)# ipv6 router ospf 1
hostname(config-router)# router-id 192.168.3.3
hostname(config-router)# summary-prefix FECO::/24
hostname(config-router)# redistribute static

0 ~ 128 の有効な値で IPv6 アドレス サマリーを設定します。 X:X:X:X::X/ パラメータは、IPv6 プレフィックスを指定します。

timers
 
hostname(config)# ipv6 router ospf 10
hostname(config-rtr)# timers throttle spf 6000 12000 14000

ルーティング タイマーを調整します。ルーティング タイマー パラメータは次のとおりです。

lsa :OSPFv3 LSA タイマーを指定します。

pacing :OSPFv3 ペーシング タイマーを指定します。

throttle :OSPFv3 スロットル タイマーを指定します。

OSPFv3 エリア パラメータの設定

OSPFv3 エリア パラメータを設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

次のいずれかの手順を実行し、オプションの OSPFv3 エリア パラメータを設定します。

area area-id default-cost cost
 
hostname(config-rtr)# area 1 default-cost nssa

NSSA エリアまたはスタブ エリアのサマリー デフォルト コストを設定します。

area area-id range ipv6-prefix / prefix-length [ advertise | not advertise ] [ cost cost ]
 
hostname(config-rtr)# area 1 range FE01:1::1/64

アドレスおよび境界ルータ専用のマスクと一致するルートを集約します。

area-id 引数は、ルートが集約されているエリアを識別します。値には、10 進数または IPv6 プレフィックスを指定できます。 ipv6-prefix 引数は、IPv6 プレフィックスを指定します。 prefix-length 引数は、プレフィックス長を指定します。 advertise キーワードは、アドレス範囲ステータスをアドバタイズに設定し、Type 3 サマリー LSA を生成します。 not-advertise キーワードはアドレス範囲ステータスを DoNotAdvertise に設定します。Type 3 サマリー LSA は抑制され、コンポーネント ネットワークは他のネットワークから隠された状態のままです。 cost cost キーワード引数のペアは、宛先への最短パスを決定するために OSPF SPF 計算で使用されるサマリー ルートのメトリックまたはコストを指定します。有効な値の範囲は 0 ~ 16777215 です。

area area-id nssa
 

hostname(config-rtr)# area 1 nssa

NSSA エリアを指定します。

area area-id stub
 
hostname(config-rtr)# area 1 stub

スタブ エリアを指定します。

area area-id virtual-link router-id [ hello-interval seconds ] [ retransmit-interval seconds ] [ transmit-delay seconds ] [ dead-interval seconds ] [ ttl-security hops hop-count ]
 
hostname(config-rtr)# area 1 virtual-link 192.168.255.1 hello-interval 5

仮想リンクとそのパラメータを定義します。

area-id 引数は、ルートが集約されているエリアを識別します。 virtual link キーワードは、仮想リンク ネイバーの作成を指定します。 router-id 引数は、仮想リンク ネイバーに関連付けられたルータ ID を指定します。ルータ ID を表示するには、 show ip ospf コマンドまたは show ipv6 display コマンドを入力します。デフォルト値はありません。 hello-interval キーワードは、インターフェイス上で送信される hello パケット間の時間を秒単位で指定します。hello 間隔は、hello パケットでアドバタイズされる符号なし整数です。この値は、共通のネットワークに接続されているすべてのルータおよびアクセス サーバで同じであることが必要です。有効な値の範囲は 1 ~ 8192 です。デフォルトは 10 です。 retransmit-interval seconds キーワード引数のペアは、インターフェイスに属する隣接関係の LSA 再送信間の時間を秒単位で指定します。再送信間隔は、接続されているネットワーク上の任意の 2 台のルータ間の予想されるラウンドトリップ遅延です。この値は、予想されるラウンドトリップ遅延より大きくなり、1 ~ 8192 の範囲で指定できます。デフォルトは 5 です。 transmit-delay seconds キーワード引数のペアは、インターフェイス上でリンクステート更新パケットを送信するために必要とされる時間を秒単位で設定します。ゼロよりも大きい整数値を指定します。アップデート パケット内の LSA 自体の経過時間は、転送前にこの値の分だけ増分されます。値の範囲は 1 ~ 8192 です。デフォルトは 1 です。 dead-interval seconds キーワード引数のペアは、ルータがダウンしていることをネイバーが示す前に hello パケットを非表示にする時間を秒単位で指定します。デッド間隔は符号なし整数です。デフォルトは hello 間隔の 4 倍または 40 秒です。この値は、共通のネットワークに接続されているすべてのルータおよびアクセス サーバで同じであることが必要です。有効な値の範囲は 1 ~ 8192 です。 ttl-security hops キーワードは仮想リンクの存続可能時間(TTL)セキュリティを設定します。 hop-count 引数の値は 1 ~ 254 の範囲で指定できます。

OSPFv3 パッシブ インターフェイスの設定

OSPFv3 パッシブ インターフェイスを設定するには、次の手順を実行します。

 

コマンド
目的

ステップ 1

ipv6 router ospf process_id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

passive-interface [ interface_name ]
 

hostname(config-rtr)# passive-interface inside

インターフェイスでのルーティング アップデートの送受信を抑止します。 interface_name 引数は、OSPFv3 プロセスが実行されているインターフェイスの名前を指定します。 no interface_name 引数を指定すると、OSPFv3 プロセス process_id のすべてのインターフェイスがパッシブとなります。

OSPFv3 アドミニストレーティブ ディスタンスの設定

IPv6 ルートの OSPFv3 アドミニストレーティブ ディスタンスを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process_id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

distance [ ospf { external | inter-area | intra-area }] distance
 
hostname(config-rtr)# distance ospf external 200

OSPFv3 ルートのアドミニストレーティブ ディスタンスを設定します。

ospf キーワードは、OSPFv3 ルートを指定します。 external キーワードは、OSPFv3 の外部タイプ 5 およびタイプ 7 ルートを指定します。 inter-area キーワードは、OSPVv3 のエリア間ルートを指定します。 intra-area キーワードは、OSPFv3 のエリア内ルートを指定します。 distance 引数は、10 ~ 254 の整数であるアドミニストレーティブ ディスタンスを指定します。

OSPFv3 タイマーの設定

OSPFv3 の LSA 到着タイマー、LSA ペーシング タイマー、およびスロットリング タイマーを設定できます。

ASA が OSPFv3 ネイバーから同じ LSA を受け入れる最小間隔を設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

timers lsa arrival milliseconds
 
hostname(config-rtr)# timers lsa arrival 2000

ASA が OSPF ネイバーから同一の LSA を受け入れる最小間隔を設定します。

milliseconds 引数は、ネイバーから到着する同じ LSA の受け入れの間で経過する最小遅延をミリ秒単位で指定します。有効な範囲は 0 ~ 6,000,000 ミリ秒です。デフォルトは 1000 ミリ秒です。

LSA フラッド パケット ペーシングを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

timers pacing flood milliseconds
 
hostname(config-rtr)# timers lsa flood 20

LSA フラッド パケット ペーシングを設定します。

milliseconds 引数は、フラッディング キュー内の LSA が更新と更新の間にペーシングされる時間(ミリ秒)を指定します。設定できる範囲は 5 ~ 100 ミリ秒です。デフォルト値は 33 ミリ秒です。

OSPFv3 LSA を収集してグループ化し、リフレッシュ、チェックサム計算、またはエージングを行う間隔を変更するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

timers pacing lsa-group seconds
 
hostname(config-rtr)# timers pacing lsa-group 300

OSPFv3 LSA を収集してグループ化し、リフレッシュ、チェックサム、またはエージングを行う間隔を変更します。

seconds 引数は、LSA がグループ化、リフレッシュ、チェックサム計算、またはエージングされる間隔を秒単位で指定します。有効な範囲は 10 ~ 1800 秒です。デフォルト値は 240 秒です。

LSA 再送信パケット ペーシングを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

timers pacing retransmission milliseconds
 
hostname(config-rtr)# timers pacing retransmission 100

LSA 再送信パケット ペーシングを設定します。

milliseconds 引数は、再送信キュー内の LSA がペーシングされる時間(ミリ秒)を指定します。設定できる範囲は 5 ~ 200 ミリ秒です。デフォルト値は 66 ミリ秒です。

LSA および SPF スロットリングは、ネットワークが不安定になっている間に OSPFv3 の LSA 更新速度を低下し、ミリ秒単位の LSA レート制限を提供することにより、より高速な OSPFv3 コンバージェンスを許可するダイナミック メカニズムを提供します。

LSA および SPF スロットリング タイマーを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

次のいずれかのオプションを選択します。

timers throttle lsa milliseconds1 milliseconds2 milliseconds3
 
hostname(config-rtr)# timers throttle lsa 500 6000 8000

OSPFv3 LSA スロットリングを設定します。

milliseconds1 引数は、LSA の最初のオカレンスを生成する遅延をミリ秒単位で指定します。 milliseconds2 引数は、同じ LSA を送信する最大遅延をミリ秒単位で指定します。 milliseconds3 引数は、同じ LSA を送信する最小遅延をミリ秒単位で指定します。

LSA スロットリングでは、最小時間または最大時間が最初のオカレンスの値よりも小さい場合、OSPFv3 が自動的に最初のオカレンス値に修正します。同様に、指定された最遅延が最小遅延よりも小さい場合、OSPFv3 が自動的に最小遅延値に修正します。

LSA スロットリングのデフォルト値は次のとおりです。

milliseconds1 の場合、デフォルト値は 0 ミリ秒です。

milliseconds2 および milliseconds3 の場合、デフォルト値は 5000 ミリ秒です。

timers throttle spf milliseconds1 milliseconds2 milliseconds3
 
hostname(config-rtr)# timers throttle spf 5000 12000 16000

OSPFv3 SPF スロットリングを設定します。

milliseconds1 引数は、SPF 計算の変更を受信する遅延をミリ秒単位で指定します。 milliseconds2 引数は、最初と 2 番目の SPF 計算の間の遅延をミリ秒単位で指定します。 milliseconds3 引数は、SPF 計算の最大待機時間をミリ秒単位で指定します。

SPF スロットリングでは、 milliseconds2 または milliseconds3 milliseconds1 よりも小さい場合、OSPFv3 が自動的に milliseconds1 の値に修正します。同様に、 milliseconds3 milliseconds2 より小さい場合、OSPFv3 が自動的に milliseconds2 の値に修正します。

SPF スロットリングのデフォルト値は次のとおりです。

milliseconds1 の場合、デフォルト値は 5000 ミリ秒です。

milliseconds2 および milliseconds3 の場合、デフォルト値は 10000 ミリ秒です。

スタティック OSPFv3 ネイバーの定義

ポイントツーポイントの非ブロードキャスト ネットワークを介して OSPFv3 ルートをアドバタイズするには、スタティック OSPF ネイバーを定義する必要があります。この機能により、OSPFv3 アドバタイズメントを GRE トンネルにカプセル化しなくても、既存の VPN 接続でブロードキャストすることができます。

開始する前に、OSPFv3 ネイバーに対するスタティック ルートを作成する必要があります。スタティック ルートの作成方法の詳細については、 「スタティック ルートおよびデフォルト ルートの設定」 を参照してください。

スタティック OSPFv3 ネイバーを定義するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

ipv6 ospf neighbor ipv6-address [ priority number ] [ poll-interval seconds ] [ cost number ] [ database-filter all out ]
 
hostname(config-if)# interface ethernet0/0 ipv6 ospf neighbor FE80::A8BB:CCFF:FE00:C01

非ブロードキャスト ネットワークへの OSPFv3 ルータの相互接続を設定します。

OSPFv3 デフォルト パラメータのリセット

OSPFv3 パラメータをデフォルト値に戻すには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

default [ area | auto-cost | default-information | default-metric | discard-route | discard-route | distance | distribute-list | ignore | log-adjacency-changes | maximum-paths | passive-interface | redistribute | router-id | summary-prefix | timers ]
 
hostname(config-rtr)# default metric 5

オプションのパラメータをデフォルト値に戻します。

area キーワードは、OSPFv3 エリア パラメータを指定します。 auto-cost キーワードは、帯域幅に従って OSPFv3 インターフェイス コストを指定します。 default-information キーワードはデフォルト情報を配布します。 default-metric キーワードは再配布ルートのメトリックを指定します。 discard-route キーワードは、廃棄ルートのインストールをイネーブルまたはディセーブルにします。 distance キーワードはアドミニストレーティブ ディスタンスを指定します。 distribute-list キーワードは、ルーティング アップデートのネットワークをフィルタリングします。 Ignore キーワードは、特定のイベントを無視します。 log-adjacency-changes キーワードは、隣接状態の変更をログに記録します。 maximum-paths キーワードは、複数のパスを介して複数のパケットを転送します。 passive-interface キーワードは、インターフェイス上のルーティング アップデートを抑止します。 redistribute キーワードは、別のルーティング プロトコルからの IPv6 プレフィックスを再配布します。 router-id キーワードは、指定されたルーティング プロセスのルータ ID を指定します。 summary-prefix キーワードは、IPv6 サマリー プレフィックスを指定します。 timers キーワードは、OSPFv3 タイマーを指定します。

syslog メッセージの送信

OSPFv3 ネイバーが起動または停止したときに syslog メッセージを送信するようにルータを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

log-adjacency-changes [ detail ]
 
hostname(config-rtr)# log-adjacency-changes detail

OSPFv3 ネイバーが起動または停止したときに、ルータが syslog メッセージを送信するように設定します。

detail キーワードは、OSPFv3 ネイバーが起動または停止したときだけではなく、各状態の syslog メッセージを送信します。

syslog メッセージの抑止

ルータがサポートされていない LSA タイプ 6 Multicast OSPF(MOSPF)パケットを受信した場合の syslog メッセージの送信を抑止するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router ospf process_id
 

hostname(config-if)# router ospf 1

OSPFv2 ルーティング プロセスをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

ignore lsa mospf
 
hostname(config-rtr)# ignore lsa mospf

ルータが、サポートされていない LSA タイプ 6 MOSPF パケットを受信した場合の syslog メッセージの送信を抑止します。

サマリー ルート コストの計算

RFC 1583 に従ってサマリー ルート コストを計算するには、次のコマンドを入力します。

 

コマンド
目的
compatible rfc1583
 

hostname (config-rtr)# compatible rfc1583

RFC 1583 に従ってサマリー ルート コストの計算に使用される方式に復元します。

OSPFv3 ルーティング ドメインへのデフォルトの外部ルートの生成

OSPFv3 ルーティング ドメインへのデフォルト ルートを生成するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

default-information originate [ always ] metric metric-value [ metric-type type-value ] [ route-map map-name ]
 
hostname(config-rtr)# default-information originate always metric 3 metric-type 2

OSPFv3 ルーティング ドメインへのデフォルトの外部ルートを生成します。

always キーワードは、デフォルト ルートがあるかどうかにかかわらず、デフォルト ルートをアドバタイズします。 metric metric-value キーワード引数のペアは、デフォルト ルートの生成に使用するメトリックを指定します。 default-metric コマンドを使用して値を指定しない場合、デフォルト値は 10 です。有効なメトリック値の範囲は、0 ~ 16777214 です。 metric-type type-value キーワード引数のペアは、OSPFv3 ルーティング ドメインにアドバタイズされるデフォルト ルートに関連付けられる外部リンク タイプを指定します。有効な値は次のいずれかになります。

1:タイプ 1 外部ルート

2:タイプ 2 外部ルート

デフォルトはタイプ 2 外部ルートです。 route-map map-name キーワード引数のペアは、ルート マップが一致している場合にデフォルト ルートを生成するルーティング プロセスを指定します。

IPv6 サマリー プレフィックスの設定

IPv6 サマリー プレフィックスを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process_id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

summary-prefix prefix [ not-advertise | tag tag-value ]
 
hostname(config-if)# ipv6 router ospf 1
hostname(config-rtr)# router-id 192.168.3.3
hostname(config-rtr)# summary-prefix FECO::/24
hostname(config-rtr)# redistribute static

IPv6 サマリー プレフィックスを設定します。

prefix 引数は、宛先の IPv6 ルート プレフィックスです。 not-advertise キーワードは、指定したプレフィックスとマスク ペアと一致するルートを抑止します。このキーワードは OSPFv3 だけに適用されます。 tag tag-value キーワード引数のペアは、ルート マップで再配布を制御するために一致値として使用できるタグ値を指定します。このキーワードは OSPFv3 だけに適用されます。

IPv6 ルートの再配布

OSPFv3 に接続済みルートを再配布するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

ipv6 router ospf process-id
 

hostname(config-if)# ipv6 router ospf 1

OSPFv3 ルーティング プロセスをイネーブルにし、IPv6 ルータ コンフィギュレーション モードを開始します。

process-id 引数は、このルーティング プロセス内部で使用される識別子です。ローカルに割り当てられ、1 ~ 65535 の任意の正の整数を指定できます。この ID は内部管理専用のため、他のどのデバイス上の ID とも照合する必要はありません。最大 2 つのプロセスが使用できます。

ステップ 2

redistribute source-protocol [ process-id ] [ include-connected {[ level-1 | level-2 }] [ as-number ] [ metric [ metric-value | transparent }] [metric-type type-value ] [ match { external [ 1 | 2 ] | internal | nssa-external [ 1 | 2 ]}] [ tag tag-value ] [ route-map map-tag ]
 
hostname(config-rtr)# redistribute connected 5 type-1

ある OSPFv3 プロセスから別の OSPFv3 プロセスに IPv6 ルートを再配布します。

source-protocol 引数は、ルートの再配布元となるソース プロトコルを指定します。これは、スタティック、接続済み、または OSPFv3 にすることができます。 process-id 引数は、OSPFv3 ルーティング プロセスがイネーブルになったときに管理目的で割り当てられる番号です。 include-connected キーワードは、ソース プロトコルから学習したルートと、ソース プロトコルが動作しているインターフェイス上の接続先プレフィックスを、ターゲット プロトコルが再配布できるようにします。 level-1 キーワードは、Intermediate System-to-Intermediate System(IS-IS)用に、レベル 1 ルートが他の IP ルーティング プロトコルに個別に再配布されることを指定します。 level-1-2 キーワードは、IS-IS 用に、レベル 1 とレベル 2 の両方のルートが他の IP ルーティング プロトコルに再配布されることを指定します。 level-2 キーワードは、IS-IS 用に、レベル 2 ルートが他の IP ルーティング プロトコルに個別に再配布されることを指定します。 metric metric-value キーワード引数のペアでは、ある OSPFv3 プロセスのルートを同じルータ上の別の OSPFv3 プロセスに再配布する場合、メトリック値を指定しないと、メトリックは 1 つのプロセスから他のプロセスへ存続します。他のプロセスを OSPFv3 プロセスに再配布するときに、メトリック値を指定しない場合、デフォルトのメトリックは 20 です。 metric transparent キーワードにより、RIP は RIP メトリックとして再配布ルートのルーティング テーブル メトリックを使用します。 metric-type type-value キーワード引数のペアは、OSPFv3 ルーティング ドメインにアドバタイズされるデフォルト ルートに関連付けられる外部リンク タイプを指定します。有効な値は、タイプ 1 外部ルートの場合は 1、タイプ 2 外部ルートの場合は 2 です。 metric-type キーワードに値が指定されていない場合、ASA は、タイプ 2 外部ルートを受け入れます。IS-IS の場合、リンク タイプは、63 未満の IS-IS メトリックの場合は内部、64 を超えて 128 未満の IS-IS メトリックの場合は外部となります。デフォルトは、内部です。 match キーワードは、他のルーティング ドメインにルートを再配布し、次のいずれかのオプションとともに使用されます。自律システムの外部であり、タイプ 1 またはタイプ 2 の外部ルートとして OSPFv3 にインポートされるルートの場合は external [ 1 | 2 ]、特定の自律システムの内部にあるルートの場合は internal 、自律システムの外部であり、タイプ 1 またはタイプ 2 の外部ルートとして IPv6 の NSSA で OSPFv3 にインポートされるルートの場合は nssa-external [ 1 | 2 ]。 tag tag-value キーワード引数のペアは、ASBR 間で情報を通信するために使用できる、各外部ルートに付加される 32 ビットの 10 進数値を指定します。何も指定しない場合、BGP および EGP からのルートにはリモート自律システムの番号が使用されます。その他のプロトコルについては、ゼロが使用されます。有効値の範囲は、0 ~ 4294967295 です。 route-map キーワードは、送信元ルーティング プロトコルから現在のルーティング プロトコルへのルートのインポートのフィルタリングをチェックするルート マップを指定します。このキーワードを指定しない場合、すべてのルートが再配布されます。このキーワードを指定し、ルート マップ タグが表示されていない場合、ルートはインポートされません。 map-tag 引数は、設定されたルート マップを識別します。

OSPF 設定の削除

すでにイネーブルにした OSPFv2 設定全体を削除するには、次のコマンドを入力します。

 

コマンド
目的
clear configure router ospf pid
 

hostname(config)# clear configure router ospf 1000

イネーブルにした OSPFv2 設定全体を削除します。設定をクリアした後、 router ospf コマンドを使用して OSPF を再設定する必要があります。

すでにイネーブルにした OSPFv3 設定全体を削除するには、次のコマンドを入力します。

 

コマンド
目的
clear configure ipv6 router ospf process-id
 

hostname(config)# clear configure ipv6 router ospf 1000

イネーブルにした OSPFv3 設定全体を削除します。設定をクリアした後、 ipv6 router ospf コマンドを使用して OSPFv3 を再設定する必要があります。

OSPFv2 の設定例

次の例に、さまざまなオプションのプロセスを使用して OSPFv2 をイネーブルにし、設定する方法を示します。


ステップ 1 OSPFv2 をイネーブルにするには、次のコマンドを入力します。

hostname(config)# router ospf 2
hostname(config-rtr)# network 10.0.0.0 255.0.0.0 area 0
 

ステップ 2 (任意)1 つの OSPFv2 プロセスから別の OSPFv2 プロセスにルートを再配布するには、次のコマンドを入力します。

hostname(config)# route-map 1-to-2 permit
hostname(config-route-map)# match metric 1
hostname(config-route-map)# set metric 5
hostname(config-route-map)# set metric-type type-1
hostname(config-route-map)# router ospf 2
hostname(config-rtr)# redistribute ospf 1 route-map 1-to-2
 

ステップ 3 (任意)OSPFv2 インターフェイス パラメータを設定するには、次のコマンドを入力します。

hostname(config)# router ospf 2
hostname(config-rtr)# network 10.0.0.0 255.0.0.0 area 0
hostname(config-rtr)# interface inside
hostname(config-interface)# ospf cost 20
hostname(config-interface)# ospf retransmit-interval 15
hostname(config-interface)# ospf transmit-delay 10
hostname(config-interface)# ospf priority 20
hostname(config-interface)# ospf hello-interval 10
hostname(config-interface)# ospf dead-interval 40
hostname(config-interface)# ospf authentication-key cisco
hostname(config-interface)# ospf message-digest-key 1 md5 cisco
hostname(config-interface)# ospf authentication message-digest
 

ステップ 4 (任意)OSPFv2 エリア パラメータを設定するには、次のコマンドを入力します。

hostname(config)# router ospf 2
hostname(config-rtr)# area 0 authentication
hostname(config-rtr)# area 0 authentication message-digest
hostname(config-rtr)# area 17 stub
hostname(config-rtr)# area 17 default-cost 20
 

ステップ 5 (任意)ルート計算タイマーを設定し、ログ ネイバーのアップおよびダウンのメッセージを表示するには、次のコマンドを入力します。

hostname(config-rtr)# timers spf 10 120
hostname(config-rtr)# log-adj-changes [detail]
 

ステップ 6 (任意)現在の OSPFv2 の設定を表示するには、 show ospf コマンドを入力します。

次に、 show ospf コマンドの出力例を示します。

hostname(config)# show ospf
 
Routing Process "ospf 2" with ID 10.1.89.2 and Domain ID 0.0.0.2
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs.Minimum LSA arrival 1 secs
Number of external LSA 5.Checksum Sum 0x 26da6
Number of opaque AS LSA 0.Checksum Sum 0x 0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1.1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 2 times
Area ranges are
Number of LSA 5.Checksum Sum 0x 209a3
Number of opaque link LSA 0.Checksum Sum 0x 0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 

ステップ 7 OSPFv2 設定をクリアするには、次のコマンドを入力します。

hostname(config)# clear configure router ospf pid
 


 

OSPFv3 の設定例

次に、インターフェイス レベルで OSPFv3 をイネーブルにして設定する例を示します。

hostname (config)# interface GigabitEthernet3/1
hostname (config-if)# ipv6 enable
hostname (config-if)# ipv6 ospf 1 area 1
 

次に、 show running-config ipv6 コマンドの出力例を示します。

hostname (config)# show running-config ipv6
ipv6 router ospf 1
log-adjacency-changes
 

次に、 show running-config interface コマンドの出力例を示します。

hostname (config-if)# show running-config interface GigabitEthernet3/1
interface GigabitEthernet3/1
nameif fda
security-level 100
ip address 1.1.11.1 255.255.255.0 standby 1.1.11.2
ipv6 address 9098::10/64 standby 9098::11
ipv6 enable
ipv6 ospf 1 area 1
 

次に、OSPFv3-specific インターフェイスを設定する例を示します。

hostname (config)# interface GigabitEthernet3/1
hostname (config-if)# nameif fda
hostname (config-if)# security-level 100
hostname (config-if)# ip address 10.1.11.1 255.255.255.0 standby 10.1.11.2
hostname (config-if)# ipv6 address 9098::10/64 standby 9098::11
hostname (config-if)# ipv6 enable
hostname (config-if)# ipv6 ospf cost 900
hostname (config-if)# ipv6 ospf hello-interval 20
hostname (config-if)# ipv6 ospf network broadcast
hostname (config-if)# ipv6 ospf database-filter all out
hostname (config-if)# ipv6 ospf flood-reduction
hostname (config-if)# ipv6 ospf mtu-ignore
hostname (config-if)# ipv6 ospf 1 area 1 instance 100
hostname (config-if)# ipv6 ospf encryption ipsec spi 890 esp null md5 12345678901234567890123456789012
 
hostname (config)# ipv6 router ospf 1
hostname (config)# area 1 nssa
hostname (config)# distance ospf intra-area 190 inter-area 100 external 100
hostname (config)# timers lsa arrival 900
hostname (config)# timers pacing flood 100
hostname (config)# timers throttle lsa 900 900 900
hostname (config)# passive-interface fda
hostname (config)# log-adjacency-changes
hostname (config)# redistribute connected metric 100 metric-type 1 tag 700
 

OSPFv3 仮想リンクを設定する方法の例については、次の URL を参照してください:

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080b8fd06.shtml

OSPF のモニタリング

IP ルーティング テーブルの内容、キャッシュの内容、およびデータベースの内容など、特定の統計情報を表示できます。提供される情報は、リソースの使用状況を判定してネットワークの問題を解決するために使用することもできます。また、ノードの到達可能性情報を表示して、デバイス パケットがネットワークを通過するときにとるルーティング パスを見つけることもできます。

さまざまな OSPFv2 ルーティング統計情報をモニタまたは表示するには、次のいずれかのコマンドを入力します。

 

コマンド
目的
show ospf [ process-id [ area-id ]]

OSPFv2 ルーティング プロセスに関する一般情報を表示します。

show ospf border-routers

ABR および ASBR までの内部 OSPFv2 ルーティング テーブル エントリを表示します。

show ospf [ process-id [ area-id ]] database

特定のルータの OSPFv2 データベースに関係する情報のリストを表示します。

show ospf flood-list if-name

(OSPFv2 パケット ペーシングの観察のため)インターフェイスへのフラッディングを待機している LSA のリストを表示します。

OSPFv2 アップデート パケットは、自動的にペーシングされるため、各パケットの送信間隔が 33 ミリ秒未満になることはありません。ペーシングを行わないと、リンクが低速の状態でアップデート パケットの一部が失われたり、ネイバーがアップデートを十分すばやく受信できなくなったり、あるいは、ルータがバッファ スペースを使い切ってしまったりすることがあります。たとえば、ペーシングを行わないと、次のいずれかのトポロジが存在する場合にパケットがドロップされる可能性があります。

高速ルータがポイントツーポイント リンクを介して低速のルータと接続している。

フラッディング中に、複数のネイバーから 1 つのルータに同時にアップデートが送信される。

ペーシングは、再送信間でも、送信効率を高めて再送信パケットの損失を最小にするために利用されます。インターフェイスからの送信を待機している LSA を表示することもできます。ペーシングの利点は、OSPFv2 アップデートおよび再送信パケットの送信の効率をよくすることです。

この機能を設定するタスクはありません。自動的に行われます。

show ospf interface [ if_name ]

OSPFv2-related インターフェイスの情報を表示します。

show ospf neighbor [ interface-name ] [ neighbor-id ] [ detail ]

OSPFv2 ネイバー情報をインターフェイスごとに表示します。

show ospf request-list neighbor if_name

ルータで要求されるすべての LSA のリストを表示します。

show ospf retransmission-list neighbor if_name

再送信を待機しているすべての LSA のリストを表示します。

show ospf [ process-id ] summary-address

OSPFv2 プロセスで設定されているサマリー アドレスのすべての再配布情報のリストを表示します。

show ospf [ process-id ] traffic

特定の OSPFv2 インスタンスで送信または受信されたパケットのさまざまなタイプのリストを表示します。

show ospf [ process-id ] virtual-links

OSPFv2-related 仮想リンク情報を表示します。

show route cluster

クラスタリングの追加 OSPFv2 ルートの同期情報を表示します。

さまざまな OSPFv3 ルーティング統計情報をモニタまたは表示するには、次のいずれかのコマンドを入力します。

 

コマンド
目的
show ipv6 ospf [ process-id [ area-id ]]

OSPFv3 ルーティング プロセスに関する一般的な情報を表示します。

show ipv6 ospf [ process-id ] border-routers

ABR および ASBR までの内部 OSPFv3 ルーティング テーブル エントリを表示します。

show ipv6 ospf [ process-id [ area-id ]] database [ external | inter-area prefix | inter-area-router | network | nssa-external | router | area | as | ref-lsa | [ destination-router-id ] [ prefix ipv6-prefix ] [ link-state-id ]] [ link [ interface interface-name ] [ adv-router router-id ] | self-originate ] [ internal ] [ database-summary ]

特定のルータの OSPFv3 データベースに関する情報のリストを表示します。

show ipv6 ospf [ process-id [ area-id ]] events

OSPFv3 イベント情報を表示します。

show ipv6 ospf [ process-id ] [ area-id ] flood-list interface-type interface-number

(OSPFv3 パケット ペーシングの観察のため)インターフェイスへのフラッディングを待機している LSA のリストを表示します。

OSPFv3 アップデート パケットは、自動的にペーシングされるため、各パケットの送信間隔が 33 ミリ秒未満になることはありません。ペーシングを行わないと、リンクが低速の状態でアップデート パケットの一部が失われたり、ネイバーがアップデートを十分すばやく受信できなくなったり、あるいは、ルータがバッファ スペースを使い切ってしまったりすることがあります。たとえば、ペーシングを行わないと、次のいずれかのトポロジが存在する場合にパケットがドロップされる可能性があります。

高速ルータがポイントツーポイント リンクを介して低速のルータと接続している。

フラッディング中に、複数のネイバーから 1 つのルータに同時にアップデートが送信される。

ペーシングは、再送信間でも、送信効率を高めて再送信パケットの損失を最小にするために利用されます。インターフェイスからの送信を待機している LSA を表示することもできます。ペーシングの利点は、OSPFv3 アップデートおよび再送信パケットの送信の効率をよくすることです。

この機能を設定するタスクはありません。自動的に行われます。

show ipv6 ospf [ process-id ] [ area-id ] interface [ type number ] [ brief ]

OSPFv3 関連のインターフェイス情報を表示します。

show ipv6 ospf neighbor [ process-id ] [ area-id ] [ interface-type interface-number ] [ neighbor-id ] [ detail ]

OSPFv3 ネイバー情報をインターフェイスごとに表示します。

show ipv6 ospf [ process-id ] [ area-id ] request-list [ neighbor ] [ interface ] [ interface-neighbor ]

ルータで要求されるすべての LSA のリストを表示します。

show ipv6 ospf [ process-id ] [ area-id ] retransmission-list [ neighbor ] [ interface ] [ interface-neighbor ]

再送信を待機しているすべての LSA のリストを表示します。

show ipv6 ospf statistic [ process-id ] [ detail ]

さまざまな OSPFv3 統計情報を表示します。

show ipv6 ospf [ process-id ] summary-prefix

OSPFv3 プロセスで設定されているサマリー アドレスのすべての再配布情報のリストを表示します。

show ipv6 ospf [ process-id ] timers [ lsa-group | rate-limit ]

OSPFv3 タイマー情報を表示します。

show ipv6 ospf [ process-id ] traffic [ interface_name ]

OSPFv3 トラフィック関連の統計情報を表示します。

show ipv6 ospf virtual-links

OSPFv3-related 仮想リンク情報を表示します。

show ipv6 route cluster [ failover ] [ cluster ] [ interface ] [ ospf ] [ summary ]

クラスタ内の IPv6 ルーティング テーブルのシーケンス番号、IPv6 再コンバージェンス タイマーのステータス、および IPv6 ルーティング エントリのシーケンス番号表示します。

その他の参考資料

OSPF の実装に関する詳細情報については、次の項を参照してください。

RFC

RFC

 

RFC
タイトル

2328

『OSPFv2』

4552

『OSPFv3 Authentication』

5340

『OSPF for IPv6』

OSPF の機能履歴

表 27-1 に、各機能変更と、それが実装されたプラットフォーム リリースを示します。

 

表 27-1 OSPF の機能履歴

機能名
プラットフォーム リリース
機能情報

OSPF サポート

7.0(1)

Open Shortest Path First(OSPF)ルーティング プロトコルを使用した、データのルーティング、認証、およびルーティング情報の再配布とモニタについて、サポートが追加されました。

route ospf コマンドが導入されました。

マルチ コンテキスト モードのダイナミック ルーティング

9.0(1)

OSPFv2 ルーティングは、マルチ コンテキスト モードでサポートされます。

クラスタリング

OSPFv2 および OSPFv3 の場合、バルク同期、ルートの同期およびレイヤ 2 ロード バランシングは、クラスタリング環境でサポートされます。

show route cluster show ipv6 route cluster debug route cluster、router-id cluster-pool の各コマンドが導入または変更されました。

IPv6 の OSPFv3 サポート

OSPFv3 ルーティングが IPv6 に対してサポートされます。

ipv6 ospf ipv6 ospf area ipv6 ospf cost、ipv6 ospf database-filter all out、ipv6 ospf dead-interval、ipv6 ospf encryption、ipv6 ospf hello-interval、ipv6 ospf mtu-ignore、ipv6 ospf neighbor、ipv6 ospf network、ipv6 ospf flood-reduction、ipv6 ospf priority、ipv6 ospf retransmit-interval、ipv6 ospf transmit-delay、ipv6 router ospf、ipv6 router ospf area、ipv6 router ospf default、ipv6 router ospf default-information、ipv6 router ospf distance、ipv6 router ospf exit、ipv6 router ospf ignore、ipv6 router ospf log-adjacency-changes、ipv6 router ospf no、ipv6 router ospf passive-interface、ipv6 router ospf redistribute、ipv6 router ospf router-id、ipv6 router ospf summary-prefix、ipv6 router ospf timers、area encryption、area range、area stub、area nssa、area virtual-link、default、default-information originate、distance、ignore lsa mospf、log-adjacency-changes、redistribute、router-id、summary-prefix、timers lsa arrival、timers pacing flood、timers pacing lsa-group、timers pacing retransmission、timers throttle、show ipv6 ospf、show ipv6 ospf border-routers、show ipv6 ospf database、show ipv6 ospf events、show ipv6 ospf flood-list、show ipv6 ospf graceful-restart、show ipv6 ospf interface、show ipv6 ospf neighbor、show ipv6 ospf request-list、show ipv6 ospf retransmission-list、show ipv6 ospf statistic、show ipv6 ospf summary-prefix、show ipv6 ospf timers、show ipv6 ospf traffic、show ipv6 ospf virtual-links、show ospf、show running-config ipv6 router、clear ipv6 ospf、clear configure ipv6 router、debug ospfv3、ipv6 ospf neighbor の各コマンドが導入または変更されました。