Cisco ASA シリーズ CLI コンフィギュレーション ガイド ASA 5505、ASA 5510、ASA 5520、ASA 5540、ASA 5550、ASA 5512-X、ASA 5515-X、ASA 5525-X、ASA 5545-X、ASA 5555-X、ASA 5580、ASA5585-X、および ASA サービス モジュール用ソフトウェア バージョン 9.0
インターフェイス コンフィギュレーションの実行(トランスペアレント モード)
インターフェイス コンフィギュレーションの実行(トランスペアレント モード)
発行日;2013/04/17 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 27MB) | フィードバック

目次

インターフェイス コンフィギュレーションの実行(トランスペアレント モード)

トランスペアレント モードでのインターフェイス コンフィギュレーションの実行の概要

トランスペアレント モードのブリッジ グループ

セキュリティ レベル

トランスペアレント モードでインターフェイス コンフィギュレーションを実行するためのライセンス要件

ガイドラインと制限事項

デフォルト設定

トランスペアレント モードのインターフェイス コンフィギュレーションの実行

インターフェイス コンフィギュレーションを実行するためのタスク フロー

ブリッジ グループの設定

一般的なインターフェイス パラメータの設定

管理インターフェイスの設定(ASA 5510 以降)

MAC アドレスおよび MTU の設定

IPv6 アドレッシングの設定

IPv6 に関する情報

グローバル IPv6 アドレスの設定

IPv6 ネイバー探索の設定

同じセキュリティ レベルの通信の許可

インターフェイスのオン/オフ

インターフェイスのモニタリング

トランスペアレント モードのインターフェイス コンフィギュレーション例

トランスペアレント モードのインターフェイスの機能履歴

インターフェイス コンフィギュレーションの実行(トランスペアレント モード)

この章では、トランスペアレント ファイアウォール モードですべてのモデルのインターフェイス コンフィギュレーションを実行するためのタスクについて説明します。

この章は、次の項で構成されています。

「トランスペアレント モードでのインターフェイス コンフィギュレーションの実行の概要」

「トランスペアレント モードでインターフェイス コンフィギュレーションを実行するためのライセンス要件」

「ガイドラインと制限事項」

「デフォルト設定」

「トランスペアレント モードのインターフェイス コンフィギュレーションの実行」

「インターフェイスのオン/オフ」

「インターフェイスのモニタリング」

「トランスペアレント モードのインターフェイス コンフィギュレーション例」

「トランスペアレント モードのインターフェイスの機能履歴」


) マルチ コンテキスト モードでは、この項のタスクをコンテキスト実行スペースで実行してください。設定するコンテキストに切り替えるには、changeto context name コマンドを入力します。


トランスペアレント モードでのインターフェイス コンフィギュレーションの実行の概要

この項は、次の内容で構成されています。

「トランスペアレント モードのブリッジ グループ」

「セキュリティ レベル」

トランスペアレント モードのブリッジ グループ

セキュリティ コンテキストのオーバーヘッドを避けたい場合、またはセキュリティ コンテキストを最大限に使用したい場合、インターフェイスをブリッジ グループにグループ化し、各ネットワークに 1 つずつ複数のブリッジ グループを設定できます。ブリッジ グループのトラフィックは他のブリッジ グループから隔離され、トラフィックは ASA 内の他のブリッジ グループにはルーティングされません。また、トラフィックは外部ルータから ASA 内の他のブリッジ グループにルーティングされる前に、ASA から出る必要があります。ブリッジング機能はブリッジ グループごとに分かれていますが、その他の多くの機能はすべてのブリッジ グループ間で共有されます。たとえば、syslog サーバまたは AAA サーバの設定は、すべてのブリッジ グループで共有されます。セキュリティ ポリシーを完全に分離するには、各コンテキスト内に 1 つのブリッジ グループにして、セキュリティ コンテキストを使用します。コンテキストごとにまたはシングル モードに少なくとも 1 つのブリッジ グループが必要です。

各ブリッジ グループには、管理 IP アドレスが必要です。別の管理方法については、の項を参照してください。


) ASA では、セカンダリ ネットワーク上のトラフィックはサポートされていません。管理 IP アドレスと同じネットワーク上のトラフィックだけがサポートされています。


セキュリティ レベル

各インターフェイスには、0(最下位)~ 100(最上位)のセキュリティ レベルを設定する必要があります。たとえば、内部ホスト ネットワークなど、最もセキュアなネットワークにはレベル 100 を割り当てる必要があります。一方、インターネットなどに接続する外部ネットワークにはレベル 0 が割り当てられる場合があります。DMZ など、その他のネットワークはその中間に設定できます。複数のインターフェイスを同じセキュリティ レベルに割り当てることができます。詳細については、「同じセキュリティ レベルの通信の許可」を参照してください。

レベルによって、次の動作が制御されます。

ネットワーク アクセス:デフォルトで、高いセキュリティ レベルのインターフェイスから低いセキュリティ レベルのインターフェイスへの通信(発信)は暗黙的に許可されます。高いセキュリティ レベルのインターフェイス上のホストは、低いセキュリティ レベルのインターフェイス上の任意のホストにアクセスできます。インターフェイスにアクセス リストを適用することによって、アクセスを制限できます。

同じセキュリティ レベルのインターフェイスの通信をイネーブルにすると(「同じセキュリティ レベルの通信の許可」を参照)、同じセキュリティ レベルまたはそれより低いセキュリティ レベルの他のインターフェイスにアクセスするインターフェイスは、暗黙的に許可されます。

インスペクション エンジン:一部のアプリケーション インスペクション エンジンはセキュリティ レベルに依存します。同じセキュリティ レベルのインターフェイス間では、インスペクション エンジンは発信と着信のいずれのトラフィックに対しても適用されます。

NetBIOS インスペクション エンジン:発信接続に対してのみ適用されます。

SQL*Net インスペクション エンジン:SQL*Net(旧称 OraServ)ポートとの制御接続が一対のホスト間に存在する場合、着信データ接続だけがASAを通過することが許可されます。

フィルタリング:HTTP(S) および FTP フィルタリングは、(高いレベルから低いレベルへの)発信接続にのみ適用されます。

同じセキュリティ レベルのインターフェイス間の通信をイネーブルにすると、どちらの方向のトラフィックにもフィルタリングが適用できます。

established コマンド:このコマンドを使用すると、高いレベルのホストから低いレベルのホストへの接続がすでに確立されている場合、低いセキュリティ レベルのホストから高いセキュリティ レベルのホストへの戻り接続が許可されます。

セキュリティ レベルが同じインターフェイス間の通信をイネーブルにすると、両方向に対して established コマンドを設定できます。

トランスペアレント モードでインターフェイス コンフィギュレーションを実行するためのライセンス要件

 

モデル
ライセンス要件

ASA 5505

VLAN:

基本ライセンス:3(2 つの正規ゾーンともう 1 つの制限ゾーンだけが他の 1 つのゾーンと通信可能)

Security Plus ライセンス:20

VLAN トランク:

基本ライセンス:なし。

Security Plus ライセンス:8

すべての種類のインターフェイス1

基本ライセンス:52。

Security Plus ライセンス:120。

1.VLAN、物理、冗長、およびブリッジ グループ インターフェイスなど、すべてを合わせたインターフェイスの最大数。

 

モデル
ライセンス要件

ASA 5510

VLAN:

基本ライセンス:50

Security Plus ライセンス:100

インターフェイス速度:

基本ライセンス:すべてのインターフェイスがファスト イーサネット。

Security Plus ライセンス:Ethernet 0/0 および 0/1:ギガビット イーサネット、その他すべてはファスト イーサネット。

すべての種類のインターフェイス2

基本ライセンス:52

Security Plus ライセンス:120

ASA 5520

VLAN:

基本ライセンス:150

すべての種類のインターフェイス1

基本ライセンス:640

ASA 5540

VLAN:

基本ライセンス:200

すべての種類のインターフェイス1

基本ライセンス:840

ASA 5550

VLAN:

基本ライセンス:400

すべての種類のインターフェイス1

基本ライセンス:1640

ASA 5580

VLAN:

基本ライセンス:1024

すべての種類のインターフェイス1

基本ライセンス:4176

ASA 5512-X

VLAN:

基本ライセンス:50

すべての種類のインターフェイス1

基本ライセンス:328

ASA 5515-X

VLAN:

基本ライセンス:100

すべての種類のインターフェイス1

基本ライセンス:528

ASA 5525-X

VLAN:

基本ライセンス:200

すべての種類のインターフェイス1

基本ライセンス:928

ASA 5545-X

VLAN:

基本ライセンス:300

すべての種類のインターフェイス1

基本ライセンス:1328

ASA 5555-X

VLAN:

基本ライセンス:500

すべての種類のインターフェイス1

基本ライセンス:2128

ASA 5585-X

VLAN:

基本ライセンス:1024

SSP-10 および SSP-20 のインターフェイス速度:

基本ライセンス:ファイバ インターフェイスの場合 1 ギガビット イーサネット

10 GE I/O ライセンス(Security Plus):ファイバ インターフェイスの場合 10 ギガビット イーサネット

(SSP-40 および SSP-60 は 10 ギガビット イーサネットをデフォルトでサポートします)。

すべての種類のインターフェイス1

基本ライセンス:4176

2.VLAN、物理、冗長、ブリッジ グループ、および EtherChannel インターフェイスなど、すべてを合わせたインターフェイスの最大数。

 

モデル
ライセンス要件

ASASM

VLAN:

基本ライセンス:1000

ガイドラインと制限事項

この項では、この機能のガイドラインと制限事項について説明します。

コンテキスト モードのガイドライン

マルチ コンテキスト モードでの ASA 5510 以降の場合、に従って、システム実行スペースで物理インターフェイスを設定します。次に、この章に従って、コンテキスト実行スペースで論理インターフェイス パラメータを設定します。マルチ コンテキスト モードの ASASM の場合は、スイッチのスイッチ ポートおよび VLAN を設定し、に従って VLAN を ASASM に割り当てます。

ASA 5505 はマルチ コンテキスト モードをサポートしません。

設定できるのは、 allocate-interface コマンドを使用してシステム コンフィギュレーションでコンテキストにすでに割り当てられているコンテキスト インターフェイスだけです。

ファイアウォール モードのガイドライン

シングル モードまたはマルチ モードのコンテキストごとに、最大 8 個のブリッジ グループを設定できます。少なくとも 1 つのブリッジ グループを使用する必要があることに注意してください。データ インターフェイスはブリッジ グループに属している必要があります。


) ASA 5505 に複数のブリッジ グループを設定できますが、ASA 5505 のトランスペアレント モードのデータ インターフェイスは 2 つという制限は、実質的にブリッジ グループを 1 つだけ使用できることを意味します。


各ブリッジ グループには、最大 4 つのインターフェイスを含めることができます。

IPv4 の場合は、管理トラフィックと ASA を通過するトラフィック両方の各ブリッジ グループに対し、管理 IP アドレスが必要です。

各インターフェイスに IP アドレスが必要なルーテッド モードとは異なり、トランスペアレント ファイアウォールにはブリッジ グループ全体に割り当てられた IP アドレスがあります。ASAは、この IP アドレスを、システム メッセージや AAA 通信など、ASAで発信されるパケットの送信元アドレスとして使用します。ブリッジ グループ管理アドレスに加えて、一部のモデルの管理インターフェイスをオプションで設定できます。詳細については、を参照してください。

管理 IP アドレスは、接続されているネットワークと同じサブネット内にある必要があります。サブネットにホスト サブネット(255.255.255.255)を設定することはできません。ASA では、セカンダリ ネットワーク上のトラフィックはサポートされていません。管理 IP アドレスと同じネットワーク上のトラフィックだけがサポートされています。管理 IP サブネットの詳細については、「ブリッジ グループの設定」を参照してください。

IPv6 の場合は、少なくとも通過トラフィック用に各インターフェイスにリンクローカル アドレスを設定する必要があります。ASA の管理を含むすべての機能を使用するには、各ブリッジ グループのグローバルな IPv6 アドレスを設定する必要があります。

マルチ コンテキスト モードでは、各コンテキストが別個のインターフェイスを使用する必要があります。コンテキスト間でインターフェイスを共有することはできません。

マルチ コンテキスト モードでは、通常、各コンテキストが別個のサブネットを使用します。重複するサブネットを使用することもできますが、ルーティング スタンドポイントから可能にするため、ネットワーク トポロジにルータと NAT コンフィギュレーションが必要です。

フェールオーバーのガイドライン

フェールオーバー インターフェイスの設定は、この章の手順では完了しません。フェールオーバー リンクおよびステート リンクの設定については、またはを参照してください。マルチ コンテキスト モードでは、フェールオーバー インターフェイスがシステム コンフィギュレーションに設定されます。

IPv6 のガイドライン

IPv6 をサポートします。

トランスペアレント モードでは IPv6 エニーキャスト アドレスをサポートしません。

ASASM の VLAN ID に関するガイドライン

コンフィギュレーションにはあらゆる VLAN ID を追加できますが、トラフィックを転送できるのはスイッチによって ASA に割り当てられた VLAN だけです。ASA に割り当てられたすべての VLAN を表示するには、 show vlan コマンドを使用します。

スイッチによって ASA にまだ割り当てられていない VLAN にインターフェイスを追加した場合、そのインターフェイスはダウン ステートになります。ASA に VLAN を割り当てた時点で、インターフェイスはアップ ステートに変化します。インターフェイス ステートの詳細については、 show interface コマンドを参照してください。

デフォルト設定

この項では、工場出荷時のデフォルト コンフィギュレーションが設定されていない場合のインターフェイスのデフォルト設定を示します。工場出荷時のデフォルト コンフィギュレーションについては、を参照してください。

デフォルトのセキュリティ レベル

デフォルトのセキュリティ レベルは 0 です。インターフェイスに名前「inside」を付けて、明示的にセキュリティ レベルを設定しないと、ASA はセキュリティ レベルを 100 に設定します。


) インターフェイスのセキュリティ レベルを変更したときに、既存の接続がタイムアウトするまで待機せずに新しいセキュリティ情報を使用する必要がある場合は、clear local-host コマンドを使用して接続をクリアできます。


ASASM のインターフェイスのデフォルトの状態

シングル モードまたはシステム実行スペースでは、VLAN インターフェイスがデフォルトでイネーブルになります。

マルチ コンテキスト モードでは、システム実行スペース内でのインターフェイスの状態にかかわらず、すべての割り当て済みのインターフェイスがデフォルトでイネーブルになっています。ただし、トラフィックがインターフェイスを通過するためには、そのインターフェイスもシステム実行スペース内でイネーブルになっている必要があります。インターフェイスをシステム実行スペースでシャットダウンすると、そのインターフェイスは、それを共有しているすべてのコンテキストでダウンします。

ジャンボ フレーム サポート

デフォルトでは、ASASM はジャンボ フレームをサポートしています。「MAC アドレスおよび MTU の設定」に従って、目的のパケット サイズの MTU を設定します。

トランスペアレント モードのインターフェイス コンフィギュレーションの実行

この項は、次の内容で構成されています。

「インターフェイス コンフィギュレーションを実行するためのタスク フロー」

「ブリッジ グループの設定」

「一般的なインターフェイス パラメータの設定」

「管理インターフェイスの設定(ASA 5510 以降)」

「MAC アドレスおよび MTU の設定」

「IPv6 アドレッシングの設定」

「同じセキュリティ レベルの通信の許可」

インターフェイス コンフィギュレーションを実行するためのタスク フロー


ステップ 1 モデルに応じてインターフェイスを設定します。

ASA 5510 以降:

ASA 5505:

ASASM:

ステップ 2 (マルチ コンテキスト モード)に従って、コンテキストにインターフェイスを割り当てます。

ステップ 3 (マルチ コンテキスト モード) changeto context name コマンドを入力して、設定するコンテキストに切り替えます。IPv4 アドレスを含む 1 つまたは複数のブリッジ グループを設定します。「ブリッジ グループの設定」を参照してください。

ステップ 4 インターフェイス名、セキュリティ レベルなどの一般的なインターフェイス パラメータを設定します。「一般的なインターフェイス パラメータの設定」を参照してください。

ステップ 5 (任意。ASA 5505 ではサポートされていません)管理インターフェイスを設定します。「管理インターフェイスの設定(ASA 5510 以降)」を参照してください。

ステップ 6 (任意)MAC アドレスと MTU を設定します。「MAC アドレスおよび MTU の設定」を参照してください。

ステップ 7 (任意)IPv6 アドレッシングを設定します。「IPv6 アドレッシングの設定」を参照してください。

ステップ 8 (任意)2 つのインターフェイス間の通信を許可するか、トラフィックが同じインターフェイスに入って同じインターフェイスから出ることを許可することで、同じセキュリティ レベルの通信を許可します。「同じセキュリティ レベルの通信の許可」を参照してください。


 

ブリッジ グループの設定

各ブリッジ グループには、管理 IP アドレスが必要です。ASA はブリッジ グループが発信元になるパケットの送信元アドレスとして、この IP アドレスを使用します。管理 IP アドレスは、接続されているネットワークと同じサブネット内にある必要があります。IPv4 トラフィックの場合、すべてのトラフィックを通過させるには、管理 IP アドレスが必要です。IPv6 トラフィックの場合は、少なくとも、トラフィックを通過させるリンクローカル アドレスを設定する必要があります。リモート管理などの管理操作を含めたフル機能を実現するために、グローバル管理アドレスを設定することを推奨します。

ガイドラインと制限事項

シングル モードまたはマルチ モードのコンテキストごとに、最大 8 個のブリッジ グループを設定できます。少なくとも 1 つのブリッジ グループを使用しなければならないことに注意してください。データ インターフェイスはブリッジ グループに属している必要があります。


) 個別の管理インターフェイスでは(サポートされているモデルの場合)、設定できないブリッジ グループ(ID 101)は、設定に自動的に追加されます。このブリッジ グループはブリッジ グループの制限に含まれません。


手順の詳細

 

 
コマンド
目的

ステップ 1

interface bvi bridge_group_number

 

hostname(config)# interface bvi 1

ブリッジ グループを作成します。 bridge_group_number は 1~100 の整数です。

ステップ 2

ip address ip_address [ mask ] [ standby ip_address ]

 

hostname(config-if)# ip address 10.1.3.1 255.255.255.0 standby 10.1.3.2

ブリッジ グループの管理 IP アドレスを指定します。

ブリッジ グループにホスト アドレス(/32 または 255.255.255.255)を割り当てないでください。また、/30 サブネットなど(255.255.255.252)、ホスト アドレスが 3 つ未満(アップストリーム ルータ、ダウンストリーム ルータ、トランスペアレント ファイアウォールにそれぞれ 1 つずつ)の他のサブネットを使用しないでください。ASA は、サブネットの先頭アドレスと最終アドレスとの間で送受信されるすべての ARP パケットをドロップします。このため、/30 サブネットを使用し、このサブネットからアップストリーム ルータに予約済みアドレスを割り当てると、ASA はダウンストリーム ルータからアップストリーム ルータへの ARP 要求をドロップします。

ASA では、セカンダリ ネットワーク上のトラフィックはサポートされていません。管理 IP アドレスと同じネットワーク上のトラフィックだけがサポートされています。

フェールオーバーには、 standby キーワードおよびアドレスを使用します。

次に、ブリッジ グループ 1 の管理アドレスおよびスタンバイ アドレスを設定する例を示します。

hostname(config)# interface bvi 1
hostname(config-if)# ip address 10.1.3.1 255.255.255.0 standby 10.1.3.2
 

次の作業

一般的なインターフェイス パラメータを設定します。「一般的なインターフェイス パラメータの設定」を参照してください。

一般的なインターフェイス パラメータの設定

この手順は、トランスペアレント インターフェイスの名前、セキュリティ レベル、およびブリッジ グループを設定する方法について説明します。

個別の管理インターフェイスを設定するには、「管理インターフェイスの設定(ASA 5510 以降)」を参照してください。

ASA 5510 以降では、次のインターフェイス タイプのインターフェイス パラメータを設定する必要があります。

物理インターフェイス

VLAN サブインターフェイス

冗長インターフェイス

EtherChannel インターフェイス

ASA 5505 および ASASM では、次のインターフェイス タイプのインターフェイス パラメータを設定する必要があります。

VLAN インターフェイス

ガイドラインと制限事項

ブリッジ グループあたり最大 4 つのインターフェイスを設定できます。

ASA 5550 では、スループットを最大にするために、トラフィックを 2 つのインターフェイス スロットに分散してください。たとえば、内部インターフェイスをスロット 1 に、外部インターフェイスをスロット 0 に割り当てます。

セキュリティ レベルについては、「セキュリティ レベル」を参照してください。

フェールオーバーを使用している場合は、フェールオーバー通信およびステートフル フェールオーバー通信に予約されているインターフェイスには、この方法で名前を付けないでください。フェールオーバー リンクおよびステート リンクの設定については、またはを参照してください。

前提条件

モデルに応じてインターフェイスを設定します。

ASA 5510 以降:

ASA 5505:

ASASM:

マルチ コンテキスト モードで設定できるのは、に従ってシステム コンフィギュレーションでコンテキストにすでに割り当てられているコンテキスト インターフェイスだけです。

マルチ コンテキスト モードでは、コンテキスト実行スペースで次の手順を実行します。システム コンフィギュレーションからコンテキスト コンフィギュレーションに切り替えるには、 changeto context name コマンドを入力します。

手順の詳細

 

 
コマンド
目的

ステップ 1

ASA 5510 以降の場合:

interface {{ redundant number | port-channel number | physical_interface }[ . subinterface ] | mapped_name }

 

ASA 5505 の場合:

hostname(config)# interface { vlan number | mapped_name }

 

hostname(config)# interface vlan 100

まだインターフェイス コンフィギュレーション モードを開始していない場合は、インターフェイス コンフィギュレーション モードを開始します。

redundant number 引数には、冗長インターフェイス ID( redundant 1 など)を指定します。

port-channel number 引数は、 port-channel 1 などの EtherChannel インターフェイス ID です。

物理インターフェイス ID については、の説明を参照してください。管理インターフェイスにはこの手順を使用しないでください。管理インターフェイスを設定する場合は、「管理インターフェイスの設定(ASA 5510 以降)」を参照してください。

subinterface ID は、物理インターフェイス ID または冗長インターフェイス ID の後ろに、ピリオド(.)で区切って付加します。

マルチ コンテキスト モードで、マッピング名を allocate-interface コマンドを使用して割り当てた場合、その名前を mapped_name に入力します。

ステップ 2

bridge-group number

 

hostname(config-if)# bridge-group 1

インターフェイスをブリッジ グループに割り当てます。 number は 1 ~ 100 の範囲の整数です。ブリッジ グループには最大 4 個のインターフェイスを割り当てることができます。同一インターフェイスを複数のブリッジ グループに割り当てることはできません。

ステップ 3

nameif name

 

hostname(config-if)# nameif inside

インターフェイスに名前を付けます。

name は最大 48 文字のテキスト文字列です。大文字と小文字は区別されません。名前を変更するには、このコマンドで新しい値を再入力します。その名前を参照するすべてのコマンドが削除されるため、 no 形式は入力しないでください。

ステップ 4

security-level number

 

hostname(config-if)# security-level 50

セキュリティ レベルを設定します。 number には、0(最下位)~ 100(最上位)の整数を指定します。

次の作業

(任意)管理インターフェイスを設定します。「管理インターフェイスの設定(ASA 5510 以降)」を参照してください。

(任意)MAC アドレスと MTU を設定します。「MAC アドレスおよび MTU の設定」を参照してください。

(任意)IPv6 アドレッシングを設定します。「IPv6 アドレッシングの設定」を参照してください。

管理インターフェイスの設定(ASA 5510 以降)

1 つの管理インターフェイスをシングル モードで、またはコンテキストごとに、ブリッジ グループとは独立して設定できます。詳細については、を参照してください。

制約事項

を参照してください。

このインターフェイスをブリッジ グループに割り当てないでください。設定できないブリッジ グループ(ID 101)は、コンフィギュレーションに自動的に追加されます。このブリッジ グループはブリッジ グループの制限に含まれません。

モデルに管理インターフェイスが含まれていない場合、データ インターフェイスからトランスペアレント ファイアウォールを管理する必要があります。この手順はスキップします。(ASA 5505 上など)。

マルチ コンテキスト モードでは、どのインターフェイスも(これには管理インターフェイスも含まれます)、コンテキスト間で共有させることはできません。コンテキスト単位で管理を行うには、管理インターフェイスのサブインターフェイスを作成し、管理サブインターフェイスを各コンテキストに割り当てます。ASA 5512-X ~ ASA 5555-X では、管理インターフェイスのサブインターフェイスは許可されないので、コンテキスト単位で管理を行うには、データ インターフェイスに接続する必要があります。

前提条件

の手順を実行します。

マルチ コンテキスト モードで設定できるのは、に従ってシステム コンフィギュレーションでコンテキストにすでに割り当てられているコンテキスト インターフェイスだけです。

マルチ コンテキスト モードでは、コンテキスト実行スペースで次の手順を実行します。システム コンフィギュレーションからコンテキスト コンフィギュレーションに切り替えるには、 changeto context name コマンドを入力します。

手順の詳細

 

 
コマンド
目的

ステップ 1

interface {{ port-channel number | management slot / port }[ . subinterface ] | mapped_name }

 

hostname(config)# interface management 0/0.1

まだインターフェイス コンフィギュレーション モードを開始していない場合は、管理インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

port-channel number 引数は、 port-channel 1 などの EtherChannel インターフェイス ID です。EtherChannel インターフェイスには、管理メンバー インターフェイスのみが設定されている必要があります。

冗長インターフェイスは、管理 スロット / ポート インターフェイスをメンバとしてサポートしません。また、管理以外のインターフェイスで構成される冗長インターフェイスを、管理専用として設定することはできません。

マルチ コンテキスト モードで、マッピング名を allocate-interface コマンドを使用して割り当てた場合、その名前を mapped_name に入力します。

ステップ 2

nameif name

 

hostname(config-if)# nameif management

インターフェイスに名前を付けます。

name は最大 48 文字のテキスト文字列です。大文字と小文字は区別されません。名前を変更するには、このコマンドで新しい値を再入力します。その名前を参照するすべてのコマンドが削除されるため、 no 形式は入力しないでください。

ステップ 3

次のいずれかを実行します。

 

ip address ip_address [ mask ] [ standby ip_address ]

 

hostname(config-if)# ip address 10.1.1.1 255.255.255.0 standby 10.1.1.2

IP アドレスを手動で設定します。

(注) フェールオーバーとともに使用する場合は、IP アドレスとスタンバイ アドレスを手動で設定する必要があります。DHCP はサポートされません。

ip_address 引数および mask 引数には、インターフェイスの IP アドレスとサブネット マスクを設定します。

standby ip_address 引数は、フェールオーバーで使用します。詳細については、または を参照してください。

 

ip address dhcp [ setroute ]

 

hostname(config-if)# ip address dhcp

DHCP サーバから IP アドレスを取得します。

setroute キーワードを指定すると、ASA が DHCP サーバから渡されたデフォルト ルートを使用できるようになります。

DHCP リースをリセットし、新規リースを要求するには、このコマンドを再入力します。

ip address dhcp コマンドを入力する前に、 no shutdown コマンドを使用してインターフェイスをイネーブルにしなかった場合、DHCP 要求が送信されないことがあります。

ステップ 4

security-level number

 

hostname(config-if)# security-level 50

セキュリティ レベルを設定します。 number には、0(最下位)~ 100(最上位)の整数を指定します。

次の作業

(任意)MAC アドレスと MTU を設定します。「MAC アドレスおよび MTU の設定」を参照してください。

(任意)IPv6 アドレッシングを設定します。「IPv6 アドレッシングの設定」を参照してください。

MAC アドレスおよび MTU の設定

この項では、インターフェイスに MAC アドレスおよび MTU を設定する方法について説明します。

MAC アドレスに関する情報

デフォルトでは、物理インターフェイスはバーンドイン MAC アドレスを使用し、物理インターフェイスのすべてのサブインターフェイスは同じバーンドイン MAC アドレスを使用します。

ASASM では、すべての VLAN がバックプレーンから提供される同じ MAC アドレスを使用します。

冗長インターフェイスは、追加した最初の物理インターフェイスの MAC アドレスを使用します。コンフィギュレーションでメンバ インターフェイスの順序を変更すると、MAC アドレスは、リストの最初になったインターフェイスの MAC アドレスと一致するように変更されます。このコマンドを使用して冗長インターフェイスに MAC アドレスを割り当てると、メンバ インターフェイスの MAC アドレスに関係なく、割り当てた MAC アドレスが使用されます。

EtherChannel の場合は、そのチャネル グループに含まれるすべてのインターフェイスが同じ MAC アドレスを共有します。この機能によって、EtherChannel はネットワーク アプリケーションとユーザに対してトランスペアレントになります。ネットワーク アプリケーションやユーザから見えるのは 1 つの論理接続のみであり、個々のリンクのことは認識しないからです。ポート チャネル インターフェイスは、最も小さいチャネル グループ インターフェイスの MAC アドレスをポート チャネル MAC アドレスとして使用します。または、ポートチャネル インターフェイスの MAC アドレスを手動で設定することもできます。マルチ コンテキスト モードでは、EtherChannel ポート インターフェイスを含め、固有の MAC アドレスをインターフェイスに自動的に割り当てることができます。グループ チャネル インターフェイスのメンバーシップを変更する場合は、固有の MAC アドレスを手動で設定するか、またはマルチ コンテキスト モードで自動的に設定することを推奨します。ポートチャネル MAC アドレスを提供していたインターフェイスを削除すると、そのポートチャネルの MAC アドレスは次に番号が小さいインターフェイスに変わるため、トラフィックが分断されます。

マルチ コンテキスト モードでは、コンテキスト間でインターフェイスを共有している場合、固有の MAC アドレスをそれぞれのコンテキストのインターフェイスに割り当てることができます。この機能を使用すると、ASAはパケットを適切なコンテキストに容易に分類できます。固有の MAC アドレスがなくても共有インターフェイスを使用できますが、制限があります。詳細については、を参照してください。コンテキストの共有インターフェイスには、手動で各 MAC アドレスを割り当てることも、自動生成することもできます。MAC アドレスの自動生成については、を参照してください。MAC アドレスを自動生成する場合、この手順を使用して生成されたアドレスを上書きできます。

シングル コンテキスト モード、またはマルチ コンテキスト モードで共有されないインターフェイスの場合は、固有の MAC アドレスをサブインターフェイスに割り当てることを推奨します。たとえば、サービス プロバイダーによっては、MAC アドレスに基づいてアクセス コントロールを実行する場合があります。

MTU に関する情報

MTU は接続で送信される最大データグラム サイズです。MTU 値よりも大きいデータは、送信前にフラグメント化されます。

ASAは、IP パス MTU ディスカバリを(RFC 1191 での規定に従って)サポートします。これにより、ホストはパスに沿ったさまざまなリンクで許容される最大 MTU サイズをダイナミックに検出し、各サイズの差に対処できます。パケットがインターフェイスに対して設定されている MTU よりも大きくなっているものの、「Don't Fragment」(DF)ビットが設定されているために、ASA がデータグラムを転送できないことがあります。ネットワーク ソフトウェアは、メッセージを送信ホストに送信して、問題を警告します。送信ホストは、パスに沿ったすべてのリンクのうち最小のパケット サイズに適合するように、宛先へのパケットをフラグメント化する必要があります。

デフォルトの MTU は、イーサネット インターフェイスのブロックでは 1500 バイトです。ほとんどのアプリケーションではこの値で十分ですが、ネットワーク状況によってはこれよりも小さい値にすることもできます。

ジャンボ フレームはデフォルトで ASASM でサポートされます。ジャンボ フレームをイネーブルにするには、を参照してください。ジャンボ フレームとは、標準的な最大値 1518 バイト(レイヤ 2 ヘッダーおよび FCS を含む)より大きく、9216 バイトまでのイーサネット パケットのことです。ジャンボ フレームでは、処理を行うためにさらにメモリが必要となります。また、ジャンボ フレームに割り当てるメモリが多くなると、アクセス リストなどの他の機能が制限され最大限に利用できなくなる場合があります。ジャンボ フレームを使用するには、値を大きくします(たとえば 9000 バイト)。

前提条件

モデルに応じてインターフェイスを設定します。

ASA 5510 以降:

ASA 5505:

ASASM:

マルチ コンテキスト モードで設定できるのは、に従ってシステム コンフィギュレーションでコンテキストにすでに割り当てられているコンテキスト インターフェイスだけです。

マルチ コンテキスト モードでは、コンテキスト実行スペースで次の手順を実行します。システム コンフィギュレーションからコンテキスト コンフィギュレーションに切り替えるには、 changeto context name コマンドを入力します。

手順の詳細

 

 
コマンド
目的

ステップ 1

ASA 5510 以降の場合:

interface {{ redundant number | port-channel number | physical_interface }[ . subinterface ] | mapped_name }

 

ASA 5505 または ASASM の場合:

hostname(config)# interface { vlan number | mapped_name }

 

hostname(config)# interface vlan 100

まだインターフェイス コンフィギュレーション モードを開始していない場合は、インターフェイス コンフィギュレーション モードを開始します。

redundant number 引数には、冗長インターフェイス ID( redundant 1 など)を指定します。

port-channel number 引数は、 port-channel 1 などの EtherChannel インターフェイス ID です。

物理インターフェイス ID については、の説明を参照してください。

subinterface ID は、物理インターフェイス ID または冗長インターフェイス ID の後ろに、ピリオド(.)で区切って付加します。

マルチ コンテキスト モードで、マッピング名を allocate-interface コマンドを使用して割り当てた場合、その名前を mapped_name に入力します。

ステップ 2

mac-address m ac_address [ standby mac_address ]

 

hostname(config-if)# mac-address 000C.F142.4CDE

プライベート MAC アドレスをこのインターフェイスに割り当てます。 mac_address は、H.H.H 形式で指定します。H は 16 ビットの 16 進数です。たとえば、MAC アドレス 00-0C-F1-42-4C-DE は、000C.F142.4CDE と入力します。

自動生成された MAC アドレスも使用する場合、手動で割り当てる MAC アドレスの最初の 2 バイトには A2 を使用できません。

フェールオーバーで使用する場合は、 スタンバイ MAC アドレスを設定します。アクティブ装置がフェールオーバーし、スタンバイ装置がアクティブになると、新しいアクティブ装置はアクティブな MAC アドレスの使用を開始して、ネットワークの切断を最小限に抑えます。一方、古いアクティブ装置はスタンバイ アドレスを使用します。

ステップ 3

mtu interface_name bytes

 

hostname(config)# mtu inside 9200

MTU を 300 ~ 65,535 バイトの間で設定します。デフォルトは 1500 バイトです。

(注) 冗長インターフェイスまたはポートチャネル インターフェイスに MTU を設定すると、ASA は、この設定をすべてのメンバ インターフェイスに適用します。

ジャンボ フレームをサポートするモデルでは、インターフェイスに 1500 よりも大きな値を入力する場合、ジャンボ フレームのサポートをイネーブルにする必要があります。を参照してください。

次の作業

(任意)IPv6 アドレッシングを設定します。「IPv6 アドレッシングの設定」を参照してください。

IPv6 アドレッシングの設定

この項では、IPv6 アドレッシングを設定する方法について説明します。IPv6 の詳細については、を参照してください。

この項は、次の内容で構成されています。

「IPv6 に関する情報」

「グローバル IPv6 アドレスの設定」

「IPv6 ネイバー探索の設定」

IPv6 に関する情報

ここでは、IPv6 を設定する手順について説明します。内容は次のとおりです。

「IPv6 アドレス指定」

「Modified EUI-64 インターフェイス ID」

「サポート対象外のコマンド」

IPv6 アドレス指定

次の 2 種類の IPv6 のユニキャスト アドレスを設定できます。

グローバル:グローバル アドレスは、パブリック ネットワークで使用可能なパブリック アドレスです。このアドレスは、インターフェイスごとに設定するのではなく、ブリッジ グループごとに設定する必要があります。また、管理インターフェイスのグローバルな IPv6 アドレスを設定することもできます。

リンクローカル:リンクローカル アドレスは、直接接続されたネットワークだけで使用できるプライベート アドレスです。ルータは、リンクローカル アドレスを使用してパケットを転送するのではなく、特定の物理ネットワーク セグメント上で通信だけを行います。ルータは、アドレス設定またはアドレス解決およびネイバー探索などの ND 機能に使用できます。リンクローカル アドレスは 1 つのセグメント上だけで使用可能であり、インターフェイスの MAC アドレスに関連付けられているため、インターフェイスごとにリンクローカル アドレスを設定する必要があります。

最低限、IPv6 が動作するようにリンクローカル アドレスを設定する必要があります。グローバル アドレスを設定する場合、各インターフェイスにリンクローカル アドレスが自動的に設定されるため、特にリンクローカル アドレスを設定する必要はありません。グローバル アドレスを設定しない場合は、リンクローカル アドレスを自動的にするか、手動で設定する必要があります。


) リンクローカル アドレスの設定だけを行う場合は、コマンド リファレンスの ipv6 enable コマンド(自動設定)または ipv6 address link-local コマンド(手動設定)を参照してください。


Modified EUI-64 インターフェイス ID

RFC 3513「Internet Protocol Version 6 (IPv6) Addressing Architecture」(インターネット プロトコル バージョン 6 アドレッシング アーキテクチャ)では、バイナリ値 000 で始まるものを除き、すべてのユニキャスト IPv6 アドレスのインターフェイス識別子部分は長さが 64 ビットで、Modified EUI-64 形式で組み立てることが要求されています。ASAでは、ローカル リンクに接続されたホストにこの要件を適用できます。

この機能がインターフェイスでイネーブルになっていると、そのインターフェイス ID が Modified EUI-64 形式を採用していることを確認するために、インターフェイスで受信した IPv6 パケットの送信元アドレスが送信元 MAC アドレスに照らして確認されます。IPv6 パケットがインターフェイス ID に Modified EUI-64 形式を採用していない場合、パケットはドロップされ、次のシステム ログ メッセージが生成されます。

%ASA-3-325003: EUI-64 source address check failed.
 

アドレス形式の確認は、フローが作成される場合にのみ実行されます。既存のフローからのパケットは確認されません。また、アドレスの確認はローカル リンク上のホストに対してのみ実行できます。ルータの背後にあるホストから受信したパケットは、アドレス形式の検証に失敗してドロップされます。これは、その送信元 MAC アドレスがルータの MAC アドレスであり、ホストの MAC アドレスではないためです。

サポート対象外のコマンド

次の IPv6 コマンドにはルータ機能が必要であるため、トランスペアレント ファイアウォール モードではサポートされません。

ipv6 address autoconfig

ipv6 nd prefix

ipv6 nd ra-interval

ipv6 nd ra-lifetime

ipv6 nd suppress-ra

グローバル IPv6 アドレスの設定

ブリッジ グループまたは管理インターフェイスのグローバル IPv6 アドレスを設定するには、次の手順を実行します。


) グローバル アドレスを設定すると、リンクローカル アドレスは自動的に設定されるため、別々に設定する必要はありません。


制限事項

ASAは、IPv6 エニーキャスト アドレスはサポートしません。

前提条件

モデルに応じてインターフェイスを設定します。

ASA 5510 以降:

ASA 5505:

ASASM:

マルチ コンテキスト モードで設定できるのは、に従ってシステム コンフィギュレーションでコンテキストにすでに割り当てられているコンテキスト インターフェイスだけです。

マルチ コンテキスト モードでは、コンテキスト実行スペースで次の手順を実行します。システム コンフィギュレーションからコンテキスト コンフィギュレーションに切り替えるには、 changeto context name コマンドを入力します。

手順の詳細

 

 
コマンド
目的

ステップ 1

ブリッジ グループの場合:

interface bvi bridge_group_id

 

管理インターフェイスの場合:

interface management_interface_id

 

hostname(config)# interface bvi 1

まだインターフェイス コンフィギュレーション モードを開始していない場合は、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ipv6 address ipv6-address/prefix-length [ standby ipv6-address ]

 

hostname(config-if)# ipv6 address 2001:0DB8::BA98:0:3210/48

インターフェイスにグローバル アドレスを割り当てます。グローバル アドレスを割り当てると、(ブリッジ グループ、各メンバ インターフェイスの)インターフェイスに対してリンクローカル アドレスが自動的に作成されます。

standby は、フェールオーバー ペアのセカンダリ ユニットまたはフェールオーバー グループで使用されるインターフェイス アドレスを指定します。

キーワードは、トランスペアレント モードではサポートされません。

IPv6 アドレッシングの詳細については、を参照してください。

ステップ 3

(任意)

ipv6 enforce-eui64 if_name
 
hostname(config)# ipv6 enforce-eui64 inside

ローカル リンクの IPv6 アドレスに Modified EUI-64 形式のインターフェイス識別子の使用を適用します。

if_name 引数には、 nameif コマンドで指定したインターフェイスの名前を指定します。このインターフェイスに対してアドレス形式を適用できます。

詳細については、「Modified EUI-64 インターフェイス ID」を参照してください。

IPv6 ネイバー探索の設定

IPv6 ネイバー探索を設定するには、を参照してください。

同じセキュリティ レベルの通信の許可

デフォルトでは、同じセキュリティ レベルのインターフェイスは相互に通信することができません。また、パケットは同じインターフェイスを出入りすることができません。ここでは、複数のインターフェイスが同じセキュリティ レベルの場合にインターフェイス間通信をイネーブルにする方法について説明します。

インターフェイス間通信に関する情報

同じセキュリティ レベルのインターフェイスが互いに通信できるようにすると、アクセス リストがなくても同じセキュリティ レベルのインターフェイスすべての間で自由にトラフィックが流れるようにする場合に便利です。

同じセキュリティ インターフェイス通信をイネーブルにした場合でも、異なるセキュリティ レベルで通常どおりインターフェイスを設定できます。

手順の詳細

 

コマンド
目的

same-security-traffic permit inter-interface

相互通信を可能にするために同じセキュリティ レベルのインターフェイスをイネーブルにします。

インターフェイスのオン/オフ

ここでは、インターフェイスのオン/オフの方法について説明します。

デフォルトでは、すべてのインターフェイスがイネーブルです。マルチ コンテキスト モードでは、コンテキスト内でインターフェイスをディセーブルにした場合、または再度イネーブルにした場合は、そのコンテキスト インターフェイスだけが影響を受けます。ただし、システム実行スペースでインターフェイスをディセーブルにした場合、または再度イネーブルにした場合は、全コンテキストに対応するそのインターフェイスに影響します。

手順の詳細

 

 
コマンド
目的

ステップ 1

hostname(config)# interface { vlan number | mapped_name }

 

hostname(config)# interface vlan 100

まだインターフェイス コンフィギュレーション モードを開始していない場合は、インターフェイス コンフィギュレーション モードを開始します。

マルチ コンテキスト モードで、マッピング名を allocate-interface コマンドを使用して割り当てた場合、その名前を mapped_name に入力します。

ステップ 2

shutdown

 

hostname(config-if)# shutdown

インターフェイスをディセーブルにします。

ステップ 3

no shutdown

 

hostname(config-if)# no shutdown

インターフェイスを再びイネーブルにします。

インターフェイスのモニタリング

インターフェイスをモニタするには、次のいずれかのコマンドを入力します。

 

コマンド
目的

show interface

インターフェイス統計情報を表示します。

show interface ip brief

インターフェイスの IP アドレスとステータスを表示します。

show bridge-group

ブリッジ グループの情報を表示します。

トランスペアレント モードのインターフェイス コンフィギュレーション例

次の例では、3 つのインターフェイスそれぞれの 2 つのブリッジ グループと管理専用インターフェイスを示します。

interface gigabitethernet 0/0
nameif inside1
security-level 100
bridge-group 1
no shutdown
interface gigabitethernet 0/1
nameif outside1
security-level 0
bridge-group 1
no shutdown
interface gigabitethernet 0/2
nameif dmz1
security-level 50
bridge-group 1
no shutdown
interface bvi 1
ip address 10.1.3.1 255.255.255.0 standby 10.1.3.2
 
interface gigabitethernet 1/0
nameif inside2
security-level 100
bridge-group 2
no shutdown
interface gigabitethernet 1/1
nameif outside2
security-level 0
bridge-group 2
no shutdown
interface gigabitethernet 1/2
nameif dmz2
security-level 50
bridge-group 2
no shutdown
interface bvi 2
ip address 10.3.5.8 255.255.255.0 standby 10.3.5.9
 
interface management 0/0
nameif mgmt
security-level 100
ip address 10.2.1.1 255.255.255.0 standby 10.2.1.2
no shutdown

トランスペアレント モードのインターフェイスの機能履歴

表 14-1 に、各機能変更と、それが実装されたプラットフォーム リリースを示します。

 

表 14-1 トランスペアレント モードのインターフェイスの機能履歴

機能名
プラットフォーム リリース
機能情報

VLAN 数の増加

7.0(5)

次の制限値が増加されました。

ASA 5510 基本ライセンスの VLAN 数が 0 から 10 に増えました。

ASA 5510 Security Plus ライセンスの VLAN 数が 10 から 25 に増えました。

ASA 5520 の VLAN 数が 25 から 100 に増えました。

ASA 5540 の VLAN 数が 100 から 200 に増えました。

VLAN 数の増加

7.2(2)

ASA 5505 上の Security Plus ライセンスに対する VLAN 最大数が、5(3 つのフル機能インターフェイス、1 つのフェールオーバー インターフェイス、1 つのバックアップ インターフェイスに制限されるインターフェイス)から 20 のフル機能インターフェイスに増加されました。また、トランク ポート数も 1 から 8 に増加されました。フル機能のインターフェイスの数が 20 になり、バックアップ ISP インターフェイスを停止するために backup interface コマンドを使用する必要がなくなりました。つまり、バックアップ ISP インターフェイス用にフル機能のインターフェイスを使用できるようになりました。backup interface コマンドは、これまでどおり Easy VPN 設定用に使用できます。

VLAN の制限値も変更されました。ASA 5510 の基本ライセンスでは 10 から 50 に、Security Plus ライセンスでは 25 から 100 に、ASA 5520 では 100 から 150 に、ASA 5550 では 200 から 250 に増えています。

ASA 5510 Security Plus ライセンスに対するギガビット イーサネット サポート

7.2(3)

ASA 5510 は、GE(ギガビット イーサネット)を Security Plus ライセンスのあるポート 0 および 1 でサポートするようになりました。ライセンスを Base から Security Plus にアップグレードした場合、外部 Ethernet 0/0 および Ethernet 0/1 ポートの容量は、元の Fast Ethernet(FE; ファスト イーサネット)の 100 Mbps から GE の 1000 Mbps に増加します。インターフェイス名は Ethernet 0/0 および Ethernet 0/1 のままです。 speed コマンドを使用してインターフェイスの速度を変更します。また、 show interface コマンドを使用して各インターフェイスの現在の設定速度を確認します。

ASA 5505 に対するネイティブ VLAN サポート

7.2(4)/8.0(4)

ネイティブ VLAN を ASA 5505 トランク ポートに割り当てることができるようになりました。

switchport trunk native vlan コマンドが導入されました。

 

ASA 5580 に対するジャンボ パケット サポート

8.1(1)

Cisco ASA 5580 はジャンボ フレームをサポートしています。ジャンボ フレームとは、標準的な最大値 1518 バイト(レイヤ 2 ヘッダーおよび FCS を含む)より大きく、9216 バイトまでのイーサネット パケットのことです。イーサネット フレームを処理するためのメモリ容量を増やすことにより、すべてのインターフェイスに対してジャンボ フレームのサポートをイネーブルにできます。ジャンボ フレームに割り当てるメモリを増やすと、他の機能(アクセス リストなど)の最大使用量が制限される場合があります。

jumbo-frame reservation コマンドが導入されました。

 

ASA 5580 の VLAN 数の増加

8.1(2)

ASA 5580 上でサポートされる VLAN 数が 100 から 250 に増加されました。

トランスペアレント モードの IPv6 のサポート

8.2(1)

トランスペアレント ファイアウォール モードの IPv6 サポートが導入されました。

ASA 5580 10 ギガビット イーサネット インターフェイスでのフロー制御のポーズ フレームのサポート

8.2(2)

フロー制御のポーズ(XOFF)フレームをイネーブルにできるようになりました。

flowcontrol コマンドが導入されました。

 

トランスペアレント モードのブリッジ グループ

8.4(1)

セキュリティ コンテキストのオーバーヘッドを避けたい場合、またはセキュリティ コンテキストを最大限に使用したい場合、インターフェイスをブリッジ グループにグループ化し、各ネットワークに 1 つずつ複数のブリッジ グループを設定できます。ブリッジ グループのトラフィックは他のブリッジ グループから隔離されます。シングル モードまたはコンテキストごとに、それぞれ 4 つのインターフェイスからなる最大 8 個のブリッジ グループを設定できます。

interface bvi show bridge-group コマンドが導入されました。