LAN スイッチング コンフィギュレーション ガイド、Cisco IOS XE Release 3S(Cisco ASR 1000)
ギガビット EtherChannel メンバー リンクへの VLAN マッピング
ギガビット EtherChannel メンバー リンクへの VLAN マッピング
発行日;2013/06/17   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

ギガビット EtherChannel メンバー リンクへの VLAN マッピング

ギガビット EtherChannel(GEC)メンバー リンクへの VLAN マッピング機能を使用すると、GEC バンドル内の特定のメンバー リンクに VLAN ID で識別されるユーザ トラフィックのスタティックな割り当てを設定することができます。 プライマリおよびセカンダリ リンクに手動で仮想 LAN(VLAN)サブインターフェイスを割り当てることができます。 この機能は、ベンダー機器の能力に関係なく、ダウンストリーム機器へのロード バランシングを可能にし、プライマリ リンクに障害が発生すると、トラフィックをセカンダリ メンバー リンクにリダイレクトすることでフェールオーバー保護を提供します。 シャーシあたり最大 16 バンドルでメンバー リンクがサポートされます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、『Bug Search Tool』およびご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

GEC メンバー リンクへの VLAN マッピングの前提条件

  • 各 VLAN で IEEE 802.1Q カプセル化を設定する必要があります。
  • 各 VLAN に、プライマリ リンク 1 つとセカンダリ リンク 1 つを関連付ける必要があります。

GEC メンバー リンクへの VLAN マッピングの制約事項

次の制限は、ギガビット EtherChannel(GEC)リンクの IPv6 ロード バランシングに適用されます。

  • IPv6 トラフィック分散はフローのロード バランシングのポート チャネル上でのみイネーブルになります。
  • マルチプロトコル ラベル スイッチング(MPLS)トラフィック エンジニアリング(TE)は、ポート チャネルでサポートされていません。
  • ポートチャネルの QinQ サブインターフェイスはサポートされません。
  • Quality of Service(QoS)ポリシーは、次の条件が満たされた場合にポートチャネル サブインターフェイスに適用できます。
    • 手動仮想 LAN(VLAN)ロード バランシングがサポートされます。
    • ポリシー マップには、物理メンバー リンクで設定された適切なサービス フラグメントのポリシーがあります。

GEC メンバー リンクの VLAN マッピングに関する情報

手動 VLAN ロード バランシング

ロード バランシングが GEC リンクに設定されている場合、トラフィック フローはロード バランシング アルゴリズムによって示されるのとは異なるバケットにマッピングされます。 各 EtherChannel に、16 のバケットのセットが作成されます。 EtherChannel モジュールで、バケットがメンバー リンク間でどのように配分されるかが決定されます。 各バケットにアクティブ リンクが関連付けられ、同じバケットにマップされたすべてのフローに使用されるインターフェイスを表します。

同じ VLAN サブインターフェイスを介して転送されるすべてのパケットは、1 つのバケットにマッピングされているのと同じフローの一部であると見なされます。 各バケットにプライマリとセカンダリのペアが関連付けられ、バケットはペア内のアクティブ インターフェイスをポイントします。 アクティブなペアは、一度に 1 つだけです。 複数の VLAN のフローは、(プライマリおよびセカンダリの)マッピングが同じ場合は同じバケットにマッピングできます。

手動 VLAN ロード バランシングがイネーブルになっている場合に、バケットが作成されます。 VLAN ロード バランシングが削除されると、バケットは削除されます。 すべてのポート チャネルで、手動 VLAN ロード バランシングか動的フローベースのロード バランシングが使用されます。 フローベースのロード バランシングの詳細については、「フローベースのポートチャネルごとのロード バランシング」モジュールを参照してください。

特定の VLAN に、プライマリ リンク 1 つとセカンダリ リンク 1 つを関連付ける必要があります。 手動 VLAN ロード バランシングがイネーブルになっている場合にだけ、プライマリとセカンダリのオプションを使用できます。 次の条件を満たす場合、ロード バランシング情報がフォワーディング プレーンにダウンロードされます。 これらの条件が満たされない場合、ロード バランシング情報はフォワーディング プレーンから削除されます。

  • VLAN ロード バランシングはグローバルにイネーブルにする必要があります。
  • IEEE 802.1Q カプセル化を各 VLAN で設定する必要があります。
  • EtherChannel リンクに VLAN トラフィックを手動でマッピングするために、1 つのプライマリと 1 つのセカンダリ メンバー リンクをイネーブルにする必要があります。
  • プライマリおよびセカンダリ リンクは、これらのリンクを使用するために、トラフィックのポート チャネルの一部である必要があります。

プライマリ リンクだけが指定されている場合、セカンダリ リンクがデフォルトとして選択されます。 プライマリ リンクとセカンダリ リンクが明示的に設定されていない場合、プライマリ リンクとセカンダリ リンクはデフォルトで選択されます。 デフォルト リンクが選択されている場合は、リンク間で同等に VLAN 配布は行われません。

プライマリ リンクまたはセカンダリ リンクとして指定されたインターフェイスがポート チャネルの一部として設定されていない場合、またはグローバル VLAN ロード バランシングがイネーブルでない場合、警告メッセージが表示されます。

警告

VLAN 500's main interface is not the channel group of primary:プライマリ インターフェイスでチャンネルグループが設定されるまで、GigabitEthernet 4/0/1 の VLAN ごとの手動ロードバランシングは有効になりません。

VLAN 500's main interface is not the channel group of secondary:プライマリ インターフェイスでチャンネルグループが設定されるまで、GigabitEthernet 1/0/0 の VLAN ごとの手動ロードバランシングは有効になりません。

VLAN からポート チャネル メンバーへのリンク マッピング

次の図は、VLAN からポート チャネルへのマッピングのトラフィック フローを示します。

図 1. VLAN からポート チャネル メンバーへのリンク マッピング



黒い線は、レイヤ 2(L2)スイッチと MCP のルータを接続する物理 1 ギガビット イーサネット インターフェイスを表します。 これらのインターフェイスは、緑色で示されているポートチャネルと一緒にまとめられます。

次の図では、影付きのオレンジと赤で示される、加入者の VLAN サブインターフェイスは、EtherChannel インターフェイス上のレイヤ 3(L3)インターフェイスとして設定されます。 メンバー リンクへの VLAN のマッピング(黒い点線の矢印)が設定によって行われ、データプレーンにダウンロードされて、出力 VLA トラフィック(オレンジと赤の矢印)が関連するアクティブなプライマリまたはセカンダリ メンバー リンクを介して送信されます。 このモデルの QoS 設定は、VLAN サブインターフェイスとメンバー リンク インターフェイス レベルで適用され、QoS キューが両方のレベルで作成されたことを意味します。

図 2. VLAN からメンバー リンクへのマッピング



VLAN のプライマリ リンクおよびセカンダリ リンクの関連付け

ポートチャネルのトラフィック分散では、メンバー リンクのステートは、設定されたプライマリ ステートまたはセカンダリ ステート、および動作がアクティブなステートまたはスタンバイなステートになります。 インターフェイスがアップになると、プライマリ リンクはアクティブになります。 プライマリ リンクがダウンになった場合、インターフェイスは、プライマリでスタンバイ ステートになり、セカンダリ インターフェイスはセカンダリでアクティブ ステートになります。 プライマリ リンクがアップになると、インターフェイスの動作がアップの場合でも、セカンダリ リンクはセカンダリ スタンバイになります。

プライマリおよびセカンダリ メンバー リンクはそれぞれ、ポートチャネル メイン インターフェイスに設定されたルーテッド VLAN と関連付けられます。 この VLAN へのトラフィックを転送する場合、プライマリ インターフェイスがアップの場合は、このインターフェイスが発信インターフェイスとして使用され、セカンダリ インターフェイスが動作可能である場合、このインターフェイスはプライマリ インターフェイスがダウンになった場合に使用されます。

VLAN ごとのトラフィック分散のすべての条件が満たされていない場合、マッピングはフォワーディング プレーンにダウンロードされません。 すべての条件が満たされると、データプレーンはこのマッピングで更新されます。

次の表は、プライマリおよびセカンダリ リンクの設定ステータスとその設定の結果の機能について説明します。

表 1 VLAN のプライマリおよびセカンダリ リンクのマッピング ステータス

プライマリ ステータス

セカンダリ ステータス

説明

設定済み

設定済み

プライマリ リンクおよびセカンダリ リンクの両方が encapsulation dot1q コマンドで指定されます。

encapsulation dot1Q vlan-id primary

デフォルト設定

デフォルト設定

プライマリ リンクとセカンダリ リンクのいずれも指定されません。

encapsulation dot1Q vlan-id

安定したシステムでは、すべての VLAN と同様に、プライマリ リンクおよびセカンダリ リンクの両方にデフォルトが選択されます。 EC に追加される最初のアップしたリンクはプライマリとして選択され、2 番目のアップしたリンクはセカンダリとして選択されます。 アップしたリンクがない場合は、プライマリ リンクおよびセカンダリ リンクがダウンしたリンクから選択されます。

設定済み

デフォルト設定

プライマリ リンクだけが指定されます。

encapsulation dot1Q vlan-id primary

プライマリ リンクと異なるセカンダリ リンクが内部的に選択されます。

設定済み

プライマリ リンクだけが指定され、1 つのリンクだけが定義されます。

encapsulation dot1Q vlan-id primary

EC で 1 つのリンクしか定義されていない場合は、セカンダリ リンクはデフォルトとして選択されません。

デフォルト設定

プライマリ リンクとセカンダリ リンクのいずれも指定されておらず、1 つのリンクだけが定義されています。

encapsulation dot1Q vlan-id

プライマリ リンクのデフォルトが選択されます。 ただし、1 つのリンクだけが EC で定義されている場合は、セカンダリ リンクとしてデフォルト リンクは選択されません。

プライマリ リンクとセカンダリ リンクのいずれも指定されず、リンクは定義されません。

encapsulation dot1Q vlan-id

デフォルトは選択されず、リンクは EC で定義されません。


(注)  


デフォルト マッピングは、ユーザ設定のマッピングが誤って定義されても、ユーザ設定のマッピングを上書きしません。 関連付け(VLAN、プライマリ、セカンダリ)が実行されると(CLI、デフォルト、またはその両方の組み合わせで)、システムでマッピングが検証され、データプレーンにダウンロードされます。 設定された VLAN がない場合、ポート チャネルを介して転送されるすべてのトラフィックはドロップされます。


チャネル メンバー リンクの追加

新しいメンバー リンクが追加されると、新しいバケットが作成され、データプレーンにダウンロードされます。 プライマリまたはセカンダリのいずれかのインターフェイスを持つすべての VLAN で、新しい VLAN からバケットへのマッピングがデータプレーンにダウンロードされます。 プライマリおよびセカンダリのデフォルトを必要とするすべての VLAN で、デフォルト選択のアルゴリズムがトリガーされ、QoS 検証に合格すると、VLAN からバケットへのマッピングがダウンロードされます。 QoS ポリシーは、新しく追加されたリンクの VLAN キューを作成します。

メンバー リンクの削除

メンバー リンクが削除されると、警告メッセージが表示されます。 メンバー リンクからのすべての VLAN キュー、VLAN からバケットへのマッピング、影響を受けるすべてのバケットは削除されます。

ポート チャネル リンク ダウン通知

リンクがダウンすると、プライマリ リンクとして割り当てられたポート チャネルのリンクがある VLAN のすべてのトラフィックは、セカンダリ リンクが稼働中の場合はセカンダリ リンクに切り替える必要があります。 セカンダリとして割り当てられたポート チャネルのリンクを持つ VLAN のトラフィックは影響を受けません。 ポート チャネル リンク ダウン通知によって、プライマリとセカンダのペア(プライマリ リンクがダウンし、セカンダリ リンクが稼働している場合)に関連付けられたすべてのバケットが、セカンダリ リンクで更新されるようになります。 データプレーンにこの変更が伝えられます。

プライマリとセカンダリのペア(セカンダリ リンクがダウン リンクでプライマリ リンクが稼働中)に関連付けられたすべてのバケットが更新され、プライマリ リンクがアクティブ リンクになります。 データプレーンにこの変更が伝えられます。

ポート チャネル リンク アップ通知

リンクがアップすると、プライマリとしてこのリンクが割り当てられている VLAN のすべてのトラフィックは、このリンクに切り替えられます。 セカンダリとしてこのリンクが割り当てられている VLAN のトラフィックは影響を受けません。 ポート チャネル リンク アップ通知により、プライマリ リンクがアップになったリンクで、セカンダリ リンクがアップしていた、プライマリとセカンダリのペアに関連付けられたすべてのバケットに、プライマリ リンクがアップであることが通知されます。 データプレーンにこの変更が伝えられます。

セカンダリ リンクがアップになったリンクで、プライマリ リンクがダウンしている、プライマリとセカンダリのペアに関連付けられているすべてのバケットに、セカンダリ リンクがプライマリ リンクになったことが通知されます。 データプレーンにこの変更が伝えられます。

EtherChannel でのロード バランスのディセーブル化

EtherChannel のロードバランシングをディセーブルにするには、no port-channel load-balancing vlan-manual コマンドを使用します。 VLAN サブインターフェイスが見つかった場合、次の警告メッセージが表示されます。

Warning: Removing the Global VLAN LB command will affect traffic
c for all dot1Q VLANs

EtherChannel のメンバー リンクの削除

EtherChannel(EC)からメンバー リンクを削除するには、no channel-group コマンドを使用します。

VLAN マッピングに含まれているメンバー リンクが EC から削除されると、次の警告メッセージが表示されます。

Warning: Removing GigabitEthernet 4/0/0 from the port-channel will affect traffic for the dot1Q VLANs that include this link in their mapping.

GEC リンクへの VLAN マッピングの設定方法

VLAN ベースの手動ロード バランシングの設定

VLAN ポートチャネルをリンクし、ポートチャネルで VLAN ロード バランシングをイネーブルにするには、この作業を実行します。

手順の概要

    1.    enable

    2.    configure terminal

    3.    port-channel load-balancing vlan-manual

    4.    interface port-channel channel-number

    5.    ip address ip-address address-mask

    6.    exit

    7.    interface type subinterface-number

    8.    channel-group channel-number

    9.    exit

    10.    interface port-channel interface-number.subinterface-number

    11.    encapsulation dot1Q vlan-id primary interface-type slot/port secondary interface-type slot/port

    12.    ip address ip-address address-mask

    13.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 port-channel load-balancing vlan-manual


    例:
    Router(config)# port-channel load-balancing vlan-manual
     

    ルータ上で、ポートチャネル ロード バランシングをイネーブルにします。

     
    ステップ 4 interface port-channel channel-number


    例:
    Router(config)# interface port-channel 1
     

    インターフェイス コンフィギュレーション モードを開始し、ポート チャネルとしてインターフェイスを定義します。

     
    ステップ 5 ip address ip-address address-mask


    例:
    Router(config-if)# ip address 172.16.2.3 255.255.0.0
     

    IP アドレスおよびマスクを指定します。

     
    ステップ 6 exit


    例:
    Router(config-if)# exit 
     

    インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 7 interface type subinterface-number


    例:
    Router(config)# interface gigbabitethernet 1/1/0
     

    ギガビット イーサネット インターフェイスでインターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 8 channel-group channel-number


    例:
    Router(config-if)# channel-group 1
     

    指定したチャネル グループにギガビット インターフェイスを割り当てます。

    • チャネル番号は、ポートチャネル インターフェイスを作成したときに指定したチャネル番号と同じです。
     
    ステップ 9 exit


    例:
    Device(config-if)# exit 
     

    インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 10 interface port-channel interface-number.subinterface-number


    例:
    Device(config)# interface port-channel 1.100
     

    インターフェイス タイプ、インターフェイス番号、サブインターフェイス番号を指定します。

     
    ステップ 11 encapsulation dot1Q vlan-id primary interface-type slot/port secondary interface-type slot/port


    例:
    Device(config-if)# encapsulation dot1Q 100 primary GigabitEthernet 1/1/1 secondary GigabitEthernet 1/2/1
     

    インターフェイス上で IEEE 802.1Q カプセル化をイネーブルにします。

     
    ステップ 12 ip address ip-address address-mask


    例:
    Device(config-if)# ip address 172.16.2.100 255.255.255.0
     

    ポート チャネルの IP アドレスおよびマスクを指定します。

     
    ステップ 13 end


    例:
    Device(config-if)# end
     

    インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

     

    トラブルシューティングのヒント

    • 現在のポート チャネルのロードバランシング方式を表示するには、show etherchannel load-balancing コマンドを使用します。
    • 現在のトラフィック分散を表示するには、show interfaces port-channel etherchannel コマンドを使用します。

    GEC メンバー リンクへの VLAN マッピングの設定例

    例:VLAN 手動ロード バランシングの設定

    次に、port-channel load-balancing コマンドを使用して、トラフィックを処理するポリシーを定義するために、ロードバランシングの設定をグローバルに適用する例を示します。 IEEE 802.1Q カプセル化は、各ポートチャネル インターフェイスで設定される点に注意してください。 次の図は、次の設定例で使用される 3 つの VLAN とポート チャネル バンドルを示しています。

    図 3. ポート チャネル バンドル

    port-channel load-balancing vlan-manual
    !
    class-map match-all BestEffort
    !
    class-map match-all video
    !
    class-map match-all voice
    !
    policy-map subscriber
      class voice
        priority level 1
      class video
        priority level 2
      class class-default service-fragment BE
        shape average 10000
        bandwidth remaining percent 80
    policy-map aggregate-member-link
        class BestEffort service-fragment BE
        shape average 100000
    !
    interface Port-channel1
     ip address 172.16.2.3 255.255.0.0
    !
    interface Port-channel1.100
     encapsulation dot1Q 100 primary GigabitEthernet 1/1/1
    	             secondary GigabitEthernet 1/2/1
     ip address 172.16.2.100 255.255.255.0
     service-policy output subscriber
    !
    interface Port-channel1.200
     encapsulation dot1Q 200 primary GigabitEthernet 1/2/1
     ip address 172.16.2.200 255.255.255.0
     service-policy output subscriber
    !
    interface Port-channel1.300
     encapsulation dot1Q 300
     ip address 172.16.2.300 255.255.255.0
     service-policy output subscriber
    !
    interface GigabitEthernet 1/1/1
     no ip address
     channel-group 1 mode on
     service-policy output aggregate-member-link
    !
    interface GigabitEthernet 1/2/1
     no ip address
     channel-group 1 mode on
     service-policy output aggregate-member-link

    例:トラブルシューティング

    例 1:

    Device# show etherchannel load-balancing
    
    EtherChannel Load-Balancing Configuration: vlan-manual

    例 2:

    Device# show etherchannel load-balancing
    
    EtherChannel Load-Balancing Configuration: not configured
    

    現在使用中のトラフィック分散を表示するには、show interfaces port-channel コマンドを使用します。

    Device# show interfaces port-channel 1 etherchannel
     
    Active Member List contains 0 interfaces
     Passive Member List contains 2 interfaces
      Port: GigabitEthernet 4/0/0
        VLAN 1 (Pri, Ac, D, P)    VLAN 100 (Pri, Ac, C, P)    VLAN 200 (Sec, St, C, P)
      Port: GigabitEthernet 1/0/0
        VLAN 1 (Sec, St, D, P)    VLAN 100 (Sec, St, C, P)    VLAN 200 (Pri, Ac, C, P)
     Bucket Information for VLAN Manual LB:
        Bucket 0   (p=GigabitEthernet 4/0/0, s=GigabitEthernet 4/0/0) active GigabitEthernet 4/0/0
        Bucket 1   (p=Gigabitthernet 4/0/0, s=GigabitEthernet 1/0/0) active GigabitEthernet 4/0/0
        Bucket 4   (p=GigabitEthernet 1/0/0, s=GigabitEthernet 4/0/0) active GigabitEthernet 1/0/0
        Bucket 5   (p=GigabitEthernet 1/0/0, s=GigabitEthernet 1/0/0) active GigabitEthernet 1/0/0
    

    プライマリおよびセカンダリ リンクへの VLAN マッピングを表示するには、show vlans コマンドを使用します。

    Device# show vlans 100
    VLAN ID: 100 (IEEE 802.1Q Encapsulation)
       Protocols Configured:          Received:        Transmitted:
    VLAN trunk interfaces for VLAN ID 100:
    Port-channel1.1 (100)
          Mapping for traffic load-balancing using bucket 1:
              primary   = GigabitEthernet 4/0/0 (active, C, P)
              secondary = GigabitEthernet 1/0/0 (standby, C, P)
          Total 0 packets, 0 bytes input
          Total 0 packets, 0 bytes output
    No subinterface configured with ISL VLAN ID 100

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    Cisco IOS コマンド

    『Cisco IOS Master Commands List, All Releases』

    LAN スイッチング コマンド

    『Cisco IOS LAN Switching Command Reference』

    シスコのテクニカル サポート

    説明

    リンク

    シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    GEC メンバー リンクへの VLAN マッピングの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

    表 2 ギガビット EtherChannel メンバー リンクへの VLAN マッピングの機能情報

    機能名

    リリース

    機能情報

    ギガビット EtherChannel メンバー リンクへの VLAN マッピング

    Cisco IOS XE Release 2.1

    ギガビット EtherChannel メンバー リンクへの VLAN マッピング機能を使用すると、GEC バンドル内の特定のメンバー リンクに VLAN ID で識別されるユーザ トラフィックのスタティックな割り当てを設定することができます。 プライマリおよびセカンダリ リンクに手動で VLAN サブインターフェイスを割り当てることができます。 この機能は、ベンダー機器の能力に関係なく、ダウンストリーム機器へのロード バランシングを可能にし、プライマリ リンクに障害が発生すると、トラフィックをセカンダリ メンバー リンクにリダイレクトすることでフェールオーバー保護を提供します。 シャーシあたり最大 16 バンドルでメンバー リンクがサポートされます。

    次のコマンドが、この機能によって変更されました。encapsulation dot1qport-channel load-balancing vlan-manualshow etherchannel load-balancing、および show interfaces port-channel vlan mapping