LAN スイッチング コンフィギュレーション ガイド、Cisco IOS XE Release 3S(Cisco ASR 1000)
フローベースのポートチャネルごとのロード バランシング
フローベースのポートチャネルごとのロード バランシング
発行日;2013/06/17   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

フローベースのポートチャネルごとのロード バランシング

フローベースのポートチャネルごとのロード バランシング機能を使用すると、ギガビット EtherChannel(GEC)インターフェイス経由のトラフィックのさまざまなフローをパケット ヘッダーに基づいて識別し、ポート チャネルの異なるメンバー リンクにマッピングすることができます。 この機能により、フローベースのロード バランシングと手動 VLAN ロード バランシングを特定のポート チャネルに設定することができます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、『Bug Search Tool』およびご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

フローベースのポートチャネルごとのロード バランシングの制約事項

  • 最大で 64 の GEC インターフェイスをサポートします。
  • GEC インターフェイスあたり最大で 4 つのメンバー リンクをサポートします。

フローベースのポートチャネルごとのロード バランシングに関する情報

フローベースのロード バランシング

フローベースのロード バランシングは、データ パケットのキー フィールドに基づいてトラフィックのさまざまなフローを識別します。 フローを識別するために、たとえば、IPv4 送信元および宛先 IP アドレスを使用できます。 次に、さまざまなデータ トラフィックがポート チャネルの異なるメンバー リンクにマッピングされます。 マッピングが完了したら、フローのデータ トラフィックは、割り当てられたメンバー リンクを通じて送信されます。 フロー マッピングは動的で、フローが割り当てられたメンバー リンクの状態が変わったときに変更されます。 フローのマッピングは、メンバー リンクが GEC インターフェイスに追加または削除された場合にも変更されます。 複数のフローは、各メンバー リンクにマッピングできます。

フローベースのロード バランシング用のバケット

ロード バランシングは、バケットの概念によって、GEC インターフェイスのメンバー リンクへのトラフィック フローを動的にマッピングします。 多様な定義済みトラフィック フローがバケットにマップされ、バケットはメンバー リンク間で均等に配分されます。 各ポート チャネルで 16 のバケットが維持され、各バケットに 1 つのアクティブ メンバー リンクが関連付けられます。 バケットにマッピングされたすべてのトラフィック フローは、バケットが割り当てられたメンバー リンクを使用します。

ルータは、ポート チャネルにフローベースのロード バランシングを適用するときに、バケットからメンバーへのリンク マッピングを作成し、ポート チャネルには少なくとも 1 つのアクティブ メンバー リンクが作成されます。 マッピングは、最初のメンバー リンクが追加または起動されるときにも作成され、ロードバランシング方式がフローベースに設定されます。

メンバー リンクがダウンするか、またはポート チャネルから削除されると、そのメンバー リンクに関連付けられたバケットはラウンドロビン方式で他のアクティブ メンバー リンク間で再配布されます。 メンバー リンクが起動するまたはポート チャネルに追加されると、他のリンクに関連付けられたバケットの一部がこのリンクに割り当てられます。

次の図は、3 つのメンバー リンク間で配布された 16 のバケットの例を示します。 バケットに表示される番号はバケット ID です。 最初のメンバー リンクに追加のバケットがあることに注意してください。

図 1. 3 つのメンバー リンクにマッピングされた 16 のバケットの例

ロードバランシング方式を変更する場合、フローベースのロードバランシング用のバケットからメンバーへのリンク マッピングは削除されます。 マッピングは、ポート チャネルが削除されるか、またはポート チャネルの最後のメンバー リンクが削除されるまたはダウンした場合にも削除されます。

ポート チャネルのロード バランシング

GEC インターフェイスは、動的なフローベースのロード バランシングまたは手動 VLAN ロード バランシングを使用できます。 すべてのポート チャネルに対してグローバルにロードバランシング方式を設定するか、特定のポート チャネルに直接設定するかを設定できます。 グローバル コンフィギュレーションは、ロード バランシングが明示的には設定されていないポート チャネルだけに適用されます。 ポートチャネルの設定はグローバル コンフィギュレーションを上書きします。

フローベースのロード バランシングは、グローバル レベルでデフォルトでイネーブルになります。 VLAN ロード バランシングを明示的に設定しないと、ロードバランシング方式は、フローベースになります。

VLAN ロード バランシングの設定については、「ギガビット EtherChannel メンバー リンクへの VLAN マッピング」のモジュールを参照してください。

次の表は、設定に基づいてポート チャネルに適用されるロードバランシング方式をリストします。

表 1 フローベースのロード バランシングの設定オプション

グローバル設定

ポートチャネルの設定

適用されるロード バランシング

未設定

未設定

フローベース

フローベース

フローベース

手動 VLAN

手動 VLAN

手動 VLAN

未設定

手動 VLAN

フローベース

フローベース

手動 VLAN

手動 VLAN

次の表に、グローバル ロードバランシング方式を変更した場合の設定結果を示します。

表 2 グローバル コンフィギュレーションが変更された場合の結果

ポートチャネルの設定

グローバル設定

ポート チャネルで実行される処理

From

To

未設定

未設定

手動 VLAN

フローベースから手動 VLAN への変更

手動 VLAN

未設定

手動 VLAN からフローベースへの変更

設定済み

Any

Any

変更なし

次の表に、ポートチャネル ロードバランシング方式が変更された場合の設定結果を示します。

表 3 ポートチャネルの設定が変更された場合の結果

グローバル設定

ポートチャネルの設定

ポート チャネルで実行される処理

From

To

未設定

未設定

手動 VLAN

フローベースから手動 VLAN への変更

未設定

フローベース

アクションなし

手動 VLAN

フローベース

手動 VLAN からフローベースへの変更

手動 VLAN

未設定

手動 VLAN からフローベースへの変更

フローベース

手動 VLAN

フローベースから手動 VLAN への変更

フローベース

未設定

アクションなし

手動 VLAN

未設定

手動 VLAN

アクションなし

未設定

フローベース

手動 VLAN からフローベースへの変更

手動 VLAN

フローベース

手動 VLAN からフローベースへの変更

手動 VLAN

未設定

アクションなし

フローベース

手動 VLAN

フローベースから手動 VLAN への変更

フローベース

未設定

フローベースから手動 VLAN への変更

フローベースのポートチャネルごとのロード バランシングをイネーブルにする方法

ポート チャネルのロード バランシングの設定

ポート チャネルにロード バランシングを設定するには、次の手順を実行します。 各 GEC インターフェイスに対してこの手順を繰り返して行います。

はじめる前に

すでに目的のロードバランシング方式をグローバルに設定しており、その方式をすべてのポート チャネルに使用する場合は、この作業を行う必要はありません。 ロードバランシングをグローバルに設定するには、port-channel load-balancing vlan-manual コマンドを使用します。 グローバル コマンドを設定しない場合、フローベースのロード バランシングがすべてのポート チャネルに適用されます。

手順の概要

    1.    enable

    2.    configure terminal

    3.    interface port-channel channel-number

    4.    load-balancing {flow | vlan}

    5.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface port-channel channel-number


    例:
    Router(config)# interface port-channel 1
     

    インターフェイス コンフィギュレーション モードを開始し、ポート チャネルとしてインターフェイスを定義します。

     
    ステップ 4 load-balancing {flow | vlan}


    例:
    Router(config-if)# load-balancing flow
     

    特定のポート チャネルにロードバランシング方式を適用します。

    • このコマンドを設定しない場合、ポートチャネルは、port-channel load-balancing vlan-manual コマンドで設定されたグローバル ロードバランシング方式を使用します。 グローバル デフォルトはフローベースです。
     
    ステップ 5 end


    例:
    Router(config-if)# end
     

    コンフィギュレーション モードを終了します。

     

    GEC インターフェイスのロードバランシング設定の確認

    ロードバランシング設定を確認し、ポート チャネルのバケットの分散に関する情報を表示するには、これらの show コマンドを使用します。 任意の順序でこれらのコマンドを使用できます。

    手順の概要

      1.    show running-config interface port-channel channel-number

      2.    show etherchannel load-balancing

      3.    show interfaces port-channel channel-number etherchannel


    手順の詳細
      ステップ 1   show running-config interface port-channel channel-number

      ポート チャネルの設定を確認するには、このコマンドを使用します。



      例:
      Router# show running-config interface port-channel 1
      Building configuration...
       
      Current configuration : 88 bytes
      !
      interface Port-channel1
       ip address 10.1.1.1 255.0.0.0
       no negotiation auto
       load-balancing flow
      end
       
      ステップ 2   show etherchannel load-balancing

      各ポート チャネルに適用されるロードバランシング方式を表示するには、このコマンドを使用します。 次に、VLAN に手動でグローバルに、フローベースでポート チャネル 1 に設定されたロード バランシングの設定の出力例を示します。



      例:
      Router# show etherchannel load-balancing
       
       
      EtherChannel Load-Balancing Method: 
      Global LB Method: vlan-manual
       
        Port-Channel:                       LB Method
          Port-channel1                   :  flow-based
       
      ステップ 3   show interfaces port-channel channel-number etherchannel

      現在使用中のバケットの分散を表示するには、このコマンドを使用します。 次に、ロード バランシングがフローベースに設定されているインターフェイスの出力例を示します。



      例:
      Router(config)# show interface port-channel 2 etherchannel
       
       All IDBs List contains 3 configured interfaces
        Port: GigabitEthernet2/1/6 (index: 0)
        Port: GigabitEthernet2/1/7 (index: 1)
        Port: GigabitEthernet2/1/0 (index: 2)
       
       Active Member List contains 1 interfaces
        Port: GigabitEthernet2/1/0
       
       Passive Member List contains 2 interfaces
        Port: GigabitEthernet2/1/6
       
        Port: GigabitEthernet2/1/7
       
       Load-Balancing method applied: flow-based
       
       Bucket Information for Flow-Based LB:
       Interface:                                Buckets
          GigabitEthernet2/1/0:
                                 Bucket 0 , Bucket 1 , Bucket 2 , Bucket 3
                                 Bucket 4 , Bucket 5 , Bucket 6 , Bucket 7
                                 Bucket 8 , Bucket 9 , Bucket 10, Bucket 11
                                 Bucket 12, Bucket 13, Bucket 14, Bucket 15
      

      フローベースのポートチャネルごとのロード バランシングの設定例

      フローベースのロード バランシングの例

      次に、フローベースのロード バランシングがポートチャネル 2 で設定され、VLAN 手動方式がグローバルに設定されている設定の例を示します。

      !
      no aaa new-model
      port-channel load-balancing vlan-manual
      ip source-route
      .
      .
      .
      interface Port-channel2
       ip address 10.0.0.1 255.255.255.0
       no negotiation auto
       load-balancing flow
      !
      interface Port-channel2.10
       ip rsvp authentication key 11223344
       ip rsvp authentication
      !
      interface Port-channel2.50
       encapsulation dot1Q 50
      !
      interface GigabitEthernet2/1/0
       no ip address
       negotiation auto
       cdp enable
       channel-group 2
      !

      その他の関連資料

      ここでは、フローベースのポートチャネルごとのロード バランシング機能に関連する参考資料を示します。

      関連資料

      関連項目

      マニュアル タイトル

      Cisco IOS コマンド

      『Cisco IOS Master Commands List, All Releases』

      Cisco IOS LAN スイッチング コマンド

      『Cisco IOS LAN Switching Command Reference』

      標準

      標準

      タイトル

      この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

      --

      MIB

      MIB

      MIB のリンク

      この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

      選択したプラットフォーム、Cisco IOS XE ソフトウェア リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

      http:/​/​www.cisco.com/​go/​mibs

      RFC

      RFC

      タイトル

      この機能がサポートする新しい RFC または変更された RFC はありません。また、この機能は既存の規格に対するサポートに影響を及ぼしません。

      --

      シスコのテクニカル サポート

      説明

      リンク

      シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

      お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

      シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      フローベースのポートチャネルごとのロード バランシングの機能情報

      次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

      プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

      表 4 フローベースのポートチャネルごとのロード バランシングの機能情報

      機能名

      リリース

      機能情報

      フローベースのポートチャネルごとのロード バランシング

      Cisco IOS XE Release 2.5

      この機能を使用すると、GEC インターフェイスを経由するトラフィックのさまざまなフローを、異なるメンバー リンクに識別しマッピングすることができます。 また、特定のポート チャネルにロード バランシングを適用することもできます。

      次のコマンドが導入または変更されました。load-balancingport-channel load-balancing vlan-manualshow etherchannel load-balancingshow interfaces port-channel etherchannel

      GEC での IPv6 ロードバランシング

      Cisco IOS XE Release 3.4S

      GEC での IPv6 ロードバランシング機能は、Gigabit EtherChannel の IPv6 トラフィックにロードバランシングを提供します。