LAN スイッチング コンフィギュレーション ガイド、Cisco IOS XE Release 3S(Cisco ASR 1000)
EtherChannel フローベース限定 1:1 冗長性
EtherChannel フローベース限定 1:1 冗長性
発行日;2013/06/17   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

EtherChannel フローベース限定 1:1 冗長性

EtherChannel フローベース限定 1:1 冗長性は、上位層プロトコルが単一のリンク障害に対応して再コンバージェンスすることを防ぐために、MAC またはレイヤ 2 トラフィックを保護します。 EtherChannel フローベース限定 1:1 冗長性を使用するには、2 つのポート(アクティブ 1 つとスタンバイ 1 つ)で EtherChannel を設定します。 アクティブ リンクがダウンしても、EtherChannel はアップしたままで、システムはホットスタンバイ リンクへのファスト スイッチオーバーを実行します。 優先順位の設定に応じて、障害リンクが再度動作可能になるときに、EtherChannel は、元のアクティブ リンクに戻るために、別のファスト スイッチオーバーを実行します。 すべてのポート プライオリティが同じ場合は、戻らずに現在のアクティブ リンクが維持されます。

1:1 冗長性が設定されていると、特定の時間にアクティブになるリンクは 1 つだけになるため、すべてのフローがアクティブ リンクを介して方向付けられます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の警告および機能情報については、『Bug Search Tool』およびご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

EtherChannel フローベース限定 1:1 冗長性に関する情報

EtherChannel フローベース限定 1:1 冗長性

EtherChannel フローベース限定 1:1 冗長性によって、アクティブ リンク 1 つで EtherChannel を設定し、ホットスタンバイ リンクにファスト スイッチオーバーを提供します。 EtherChannel フローベース限定 1:1 冗長性を使用するには、2 つのポート(アクティブ 1 つとスタンバイ 1 つ)で Link Aggregation Control Protocol(LACP)EtherChannel を設定します。 アクティブ リンクがダウンしても、EtherChannel はアップしたままで、システムはホットスタンバイ リンクへのファスト スイッチオーバーを実行します。 リンクの優先順位の設定に応じて、障害リンクが再度動作可能になるときに、EtherChannel は元のアクティブ リンクまたはより優先順位の高いリンクに戻すために、ファスト スイッチオーバーをもう 1 回実行します。

EtherChannel フローベース限定 1:1 冗長性(特にファスト スイッチオーバー機能)が正しく機能するには、リンクの両端でこの機能がイネーブル化されている必要があります。

EtherChannel フローベース限定 1:1 冗長性の設定方法

EtherChannel フローベース限定 1:1 冗長性のファストスイッチオーバーとの設定

LACP EtherChannel を 2 つのポート(アクティブ 1 つとスタンバイ 1 つ)で設定するには、次の手順を実行します。 この機能は、リンクの両端でイネーブルにする必要があります。

冗長性に使用されるリンクのプライオリティを設定することによって、どのリンクをプライマリ アクティブ リンクにするかを制御できます。 プライマリ リンクを設定し、EtherChannel が元のリンクに戻ることを可能にするために、1 つのリンクのプライオリティを他のリンクより高くし、LACP の max-bundle を 1 に設定する必要があります。 この設定によって、リンク 1 がアクティブになり、リンク 2 がホットスタンバイ ステートになります。

スイッチオーバーが戻ることを防ぐために、両方のリンクに同じプライオリティを割り当てることができます。

手順の概要

    1.    enable

    2.    configure terminal

    3.    interface port-channel channel -number

    4.    lacp fast-switchover

    5.    lacp max-bundle 1

    6.    exit

    7.    interface tengigabitethernet slot / port / number

    8.    channel-group 1 mode mode

    9.    lacp port-priority priority

    10.    exit

    11.    interface tengigabitethernet slot / port / number

    12.    channel-group 1 mode mode

    13.    lacp port-priority priority

    14.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 interface port-channel channel -number


    例:
    Router(config)# interface port-channel 1
     

    LACP ポート チャネル インターフェイスを選択します。

     
    ステップ 4 lacp fast-switchover


    例:
    Router(config-if)# lacp fast-switchover
     

    この EtherChannel のファスト スイッチオーバー機能をイネーブルにします。

     
    ステップ 5 lacp max-bundle 1


    例:
    Router(config-if)# lacp max-bundle 1
     

    アクティブなメンバー ポートの最大数を 1 に設定します。

     
    ステップ 6 exit


    例:
    Router(config-if)# exit 
     

    インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 7 interface tengigabitethernet slot / port / number


    例:
    Router(config)# interface tengigabitethernet 0/0/0
     

    ポート チャネルに追加する最初のインターフェイスを選択します。

     
    ステップ 8 channel-group 1 mode mode


    例:
    Router(config-if)# channel-group 1 mode active
     

    メンバー リンクをポートチャネルに追加し、LACP ネゴシエーションにアクティブに参加します。

     
    ステップ 9 lacp port-priority priority


    例:
    Router(config-if)# lacp port-priority 32768
     

    ポートチャネルのプライオリティを設定します。 このプライオリティはデフォルト値に設定されます。

     
    ステップ 10 exit


    例:
    Router(config-if)# exit 
     

    インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

     
    ステップ 11 interface tengigabitethernet slot / port / number


    例:
    Router(config)# interface tengigabitethernet 1/0/0
     

    ポート チャネルに追加するインターフェイスを選択します。

     
    ステップ 12 channel-group 1 mode mode


    例:
    Router(config-if)# channel-group 1 mode active
     

    メンバー リンクをポートチャネルに追加し、LACP ネゴシエーションにアクティブに参加します。

     
    ステップ 13 lacp port-priority priority


    例:
    Router(config-if)# lacp port-priority 32767
     

    デフォルト値である 32768 より低い値を使用して、ポートのプライオリティを他のリンクより高く設定します。 これにより、トラフィックをやり取りするときは必ず、このリンクがアクティブ リンクになります。

     
    ステップ 14 end


    例:
    Router(config-if)# end
     

    インターフェイス コンフィギュレーション モードを終了します。

     

    キャリア遅延のスイッチオーバー レートの設定

    オプションで、各リンクのキャリア遅延を設定してアクティブとスタンバイ リンク間のスイッチオーバーの速度を制御できます。 carrier-delay コマンドは、他のモジュールにリンク状態に関する情報を Cisco IOS が伝播するためにどのくらいの時間がかかるかを制御します。

    手順の概要

      1.    enable

      2.    configure terminal

      3.    interface tengigabitethernet slot / port / number

      4.    carrier-delay msec msec

      5.    end


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Router> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Router# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 interface tengigabitethernet slot / port / number


      例:
      Router(config)# interface tengigabitethernet 0/1/0
       

      インターフェイス コンフィギュレーション モードを開始し、指定したインターフェイスの設定が表示されます。

       
      ステップ 4 carrier-delay msec msec


      例:
      Router(config-if)# carrier-delay msec 11
       

      他のモジュールにリンク ステータスを伝播するためにかかる時間を設定します。

       
      ステップ 5 end


      例:
      Router(config-if)# end
       

      インターフェイス コンフィギュレーション モードを終了します。

       

      EtherChannel フローベース限定 1:1 冗長性の確認

      これらの show コマンドを使用して、設定を確認し、ポート チャネルに関する情報を表示します。

      手順の概要

        1.    enable

        2.    show running-config interface type slot / port / number

        3.    show interfaces port-channel channel-number etherchannel

        4.    show etherchannel channel-number port-channel

        5.    end


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Router> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 show running-config interface type slot / port / number


        例:
        Router# show running-config interface tengigabitethernet 0/0/0
         

        設定を確認します。

        • typegigabitethernet または tengigabitethernet
         
        ステップ 3 show interfaces port-channel channel-number etherchannel


        例:
        Router# show interfaces port-channel 1 etherchannel
         

        現在使用中のバケットの分散が表示されます。

         
        ステップ 4 show etherchannel channel-number port-channel


        例:
        Router# show etherchannel 1 port-channel
         

        ポート チャネル ファスト スイッチオーバー機能を表示します。

         
        ステップ 5 end


        例:
        Router# end
         

        特権 EXEC モードを終了します。

         

        EtherChannel フローベース限定 1:1 冗長性の設定例

        EtherChannel 1:1 アクティブ スタンバイの例

        次に、どのポートがアクティブになるかが優先設定されないように、ポートのプライオリティが同じ 1:1 リンク冗長性用にポート チャネルを設定する例を示します。

        Router# enable
        Router# configure terminal
        Router(config)# interface port-channel 2
        Router(config-if)# ip address 10.1.1.1 255.255.0.0
        Router(config-if)# negotiation auto
        Router(config-if)# lacp max-bundle 1
        Router(config-if)# lacp fast-switchover
        Router(config)# interface Tengigabitethernet0/1/0
        Router(config-if)# channel-group 2 mode active
        Router(config-if)# negotiation auto
        Router(config)# interface Tengigabitethernet 2/1/0
        Router(config-if)# channel-group 2 mode active
        Router(config-if)# negotiation auto
        Router(config)# interface GigabitEthernet0/1/6
        Router(config-if)# negotiation auto
        Router(config-if)# channel-group 19 mode active
        Router(config)# interface GigabitEthernet0/1/7
        Router(config-if)# negotiation auto
        Router(config-if)# channel-group 19 mode active
        Router(config-if)# interface Port-channel19
        Router(config-if)# ip address 10.19.1.1 255.255.255.0
        Router(config-if)# no negotiation auto
        Router(config-if)# lacp fast-switchover
        Router(config-if)# lacp max-bundle 1
        Router(config-if)# end
        

        show コマンドで、プライオリティ値が同じであることが示されています。

        Router# show lacp internal 
        Flags: S - Device is requesting Slow LACPDUs 
        	F - Device is requesting Fast LACPDUs
        	A - Device is in Active mode P - Device is in Passive mode 
        Channel group 19
        LACP port Admin Oper Port Port
        Port Flags State Priority Key Key Number State
        Gi0/1/6 SA bndl 32768 0x13 0x13 0x47 0x3D 
        Gi0/1/7 FA hot-sby 32768 0x13 0x13 0x48 0x7 

        LACP を使用した 1:1 冗長性のプライオリティ設定の例

        この例は、1:1 冗長性機能を備えた LACP EtherChannel を設定する方法を示しています。 GigabitEthernet 0/1/7 は、高いプライオリティを与える低い値で設定されるため、アクティブなリンクになります。

        Router# configure terminal
        Router(config)# interface GigabitEthernet0/1/6
        Router(config-if)# lacp port-priority 32767
        Router(config-if)# exit
        Router(config)# interface GigabitEthernet0/1/7
        Router(config-if)# lacp fast-switchover
        Router(config-if)# lacp max-bundle 1
        Router(config-if)# negotiation auto
        Router(config-if)# channel-group 19 mode active
        

        この例では、バンドル リンクに高いプライオリティが設定されています。 これにより、スタンバイ設定でバンドル リンクが最初のアクティブ リンクとして使用されるようになります。

        Router# show lacp internal
         
        Flags: S - Device is requesting Slow LACPDUs 
        	F - Device is requesting Fast LACPDUs
        	A - Device is in Active mode P - Device is in Passive mode 
        Channel group 19
        LACP port Admin Oper Port Port
        Port Flags State Priority Key Key Number State
        Gi0/1/6 FA hot-sby 32768 0x13 0x13 0x47 0x7 
        Gi0/1/7 SA bndl 32767 0x13 0x13 0x48 0x3D

        その他の関連資料

        ここでは、EtherChannel フローベース限定 1:1 冗長性機能の関連資料を示します。

        関連資料

        関連項目

        マニュアル タイトル

        Cisco IOS コマンド

        『Cisco IOS Master Commands List, All Releases』

        LAN スイッチング コマンド

        『Cisco IOS LAN Switching Command Reference』

        標準

        標準

        タイトル

        この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

        --

        MIB

        MIB

        MIB のリンク

        この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

        選択したプラットフォーム、Cisco IOS XE ソフトウェア リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

        http:/​/​www.cisco.com/​go/​mibs

        RFC

        RFC

        タイトル

        この機能がサポートする新しい RFC または変更された RFC はありません。また、この機能は既存の規格に対するサポートに影響を及ぼしません。

        --

        シスコのテクニカル サポート

        説明

        リンク

        シスコのサポート Web サイトでは、シスコの製品やテクノロジーに関するトラブルシューティングにお役立ていただけるように、マニュアルやツールをはじめとする豊富なオンライン リソースを提供しています。

        お使いの製品のセキュリティ情報や技術情報を入手するために、Cisco Notification Service(Field Notice からアクセス)、Cisco Technical Services Newsletter、Really Simple Syndication(RSS)フィードなどの各種サービスに加入できます。

        シスコのサポート Web サイトのツールにアクセスする際は、Cisco.com のユーザ ID およびパスワードが必要です。

        http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

        EtherChannel フローベース限定 1:1 冗長性の機能情報

        次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

        プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

        表 1 EtherChannel フローベース限定 1:1 冗長性の機能情報

        機能名

        リリース

        機能情報

        EtherChannel フローベース限定 1:1 冗長性

        Cisco IOS XE Release 2.4

        EtherChannel フローベース限定 1:1 冗長性は、上位層プロトコルが単一のリンク障害に対応して再コンバージェンスすることを防ぐために、MAC またはレイヤ 2 トラフィックを保護します。 EtherChannel フローベース限定 1:1 冗長性を使用するには、2 つのポート(アクティブ 1 つとスタンバイ 1 つ)で EtherChannel を設定します。 アクティブ リンクがダウンしても、EtherChannel はアップしたままで、システムはホットスタンバイ リンクへのファスト スイッチオーバーを実行します。 優先順位の設定に応じて、障害リンクが再度動作可能になるときに、EtherChannel は、元のアクティブ リンクに戻るために、別のファスト スイッチオーバーを実行します。 すべてのポート プライオリティが同じ場合は、戻らずに現在のアクティブ リンクが維持されます。

        この機能をサポートするために変更または作成されたコマンドはありません。