QoS:ポリシングおよびシェーピング コンフィギュレーション ガイド、Cisco IOS XE Release 3S(Cisco ASR 1000)
ATM VC での PPP セッション キューイング
ATM VC での PPP セッション キューイング
発行日;2013/07/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

ATM VC での PPP セッション キューイング

ATM VC 機能での PPP セッション キューイングにより、ユーザが指定したレートに PPP over Ethernet over ATM(PPPoEoA)セッションをシェーピングし、キューに入れることができます。 複数のセッションが ATM VC に存在することがあり、Quality of Service(QoS)ポリシーを適用させることも、セッションの一部が QoS ポリシーを所有することもあります。 ルータは、VC での PPPoEoA トラフィックに使用するすべての帯域幅の合計をシェーピングします。これで、Digital Subscriber Line Access Multiplexer(DSLAM)への加入者接続が輻輳状態になりません。 キューイング関連機能は、PPPoEoA セッション全体で稼働するさまざまなアプリケーションに、異なるサービス レベルを提供します。

ネストされた、2 つのレベルの階層型サービス ポリシーは、Modular Quality of Service Command-Line Interface(MQC)を使用して、ルータに直接シェーピングするセッションを設定するために使用されます。 階層型ポリシーは次のコンポーネントから構成されます。

  • 子ポリシー:priority、bandwidth、police などの QoS コマンドを使用して QoS アクションを定義します。
  • 親ポリシー:shape コマンドまたは bandwidth remaining ratio コマンド、またはこの両方のコマンドが設定された class-default クラスのみが含まれます。
    • shape コマンド:特定のアルゴリズムに従って、指定されたビット レートにセッション トラフィックをシェーピングします。
    • bandwidth remaining ratio コマンド:輻輳中にセッションに割り当てる未使用帯域幅の量を決定するためにルータが使用する比率の値を指定します。

(注)  


ATM VC での PPP セッション キューイング機能は、PPP 終端集約(PTA)設定と L2TP アクセス コンセントレータ(LAC)設定の双方で動作します。


以下の図は、ATM VC での PPP セッション キューイングを示します。



機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、バグ検索ツールとプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

ATM VC での PPP セッション キューイングの前提条件

  • PPPoEoA セッションをイネーブルにする必要があります。
  • class-map コマンドを使用してトラフィック クラスを作成し、トラフィックの分類に使用される一致基準を指定します。
  • RADIUS を使用するダイナミックな PPPoEoA セッション キューイングの場合、次を実行する必要があります。
    • 認証、許可、アカウンティング(AAA)をルータでイネーブルにする
    • ダイナミックな QoS 用に RADIUS サーバを設定する
    • RADIUS サーバに加入者のユーザ プロファイルを作成する

ATM VC での PPP セッション キューイングに関する制約事項

  • 非整型 VC(指定されたピーク セル レート(PCR)または平均セル レート(SCR)のない VC)には、PPP セッション キューイングを設定できません。
  • セッション キューイング ポリシーを持つ VC は、整形仮想パス(VP)の一部にすることはできません。
  • 同じ ATM カテゴリ(整形未指定ビット レート(UBR)など)に低帯域幅 VC と高帯域幅 VC の両方が含まれる場合、SAR メカニズムにより高帯域幅 VC の低スループットを引き起こす可能性があります。 回避策は、低帯域幅 VC と高帯域幅 VC に異なる ATM クラスを使用することです。 たとえば、低帯域幅 VC を整形 UBR として、高帯域幅 VC を非リアルタイム可変ビット レート(VBR-rt nrt)または固定ビット レート(CBR)として設定します。
  • CLASS-BASED QOS MIB には、セッションに適用されるサービス ポリシーの統計情報は含まれません。
  • RADIUS アカウンティングには、キューイングの統計情報は含まれません。

ATM VC での PPP セッション キューイングの概要

ATM VC での PPP セッションに QoS ポリシーを動的に適用する

ルータによって、RADIUS を使用して PPPoEoA セッションに QoS ポリシー マップを動的に適用できるようになります。 QoS ポリシーの実際の設定がルータで発生しても、セッションに動的に適用するポリシー マップの名前を指定するように RADIUS に次の属性と値(AV)のペアを設定することができます。

"ip:sub-qos-policy-in=<name of the QoS policy in ingress direction>"
"ip:sub-qos-policy-out=<name of egress policy>"

AV ペアは、次の RADIUS プロファイルのいずれかに定義できます。

  • ユーザ プロファイル:RADIUS サーバ上のユーザ プロファイルには、ユーザに適用されるポリシー マップ名を識別するエントリが含まれます。 ポリシー マップ名は、セッションが承認されると RADIUS がルータにダウンロードするサービスです。
  • サービス プロファイル:RADIUS サーバ上のサービス プロファイルは、セッション ID と AV ペアを指定します。 セッション ID は、セッションの IP アドレスなどです。 AV ペアは、ユーザが属するサービス(ポリシー マップ名)を定義します。

ポリシー サーバからサービス ログイン要求を受け取った後、すでにログインしている加入者向けのサービスをアクティブにするため、RADIUS はルータに許可変更(CoA)要求を送信します。 許可に成功すると、ルータは ip:sub-qos-policy-in[out]= AV ペアを使用して RADIUS からポリシー マップ名をダウンロードし、PPPoEoA セッションに QoS ポリシーを適用します。 サービス ポリシーにはキューイング関連の操作が含まれるため、ルータは適切なクラス キューを設定します。


(注)  


ルータは RADIUS のベンダー固有属性(VSA)38、Cisco-Policy-Down および Cisco-Policy-Up もサポートしますが、QoS ポリシー定義には ip:sub-qos-policy-in[out]= AV ペアを使用することを推奨します。


PPP セッション キューイングの継承

PPP セッションは、そのユーザの親インターフェイスからキューを継承するか、セッション自身のキューを含みます。 セッション キューイングが設定されている PPPoEoA セッションにはそれぞれ独自のキューのセットがあります。

次の表に、ルータがセッション トラフィックを指示するキューを示します。

表 1 PPP セッション キューの継承

キューイング ポリシー

セッション トラフィックに使用されるキュー

ポリシーなし

VC のデフォルト キュー

VC に適用

VC キュー

セッションに適用

セッションのキュー

PPP セッション キューイングをサポートするインターフェイス

ルータはアウトバウンド トラフィック専用の整形 ATM VC に対して、PPP セッション キューイングをサポートします。

ルータはインバウンド ATM インターフェイスでの PPP セッション キューイングをサポートされません。

混合設定とキューイング

混合設定とは、QoS が適用されていないセッションが含まれる設定です。 一部の VC ではキューイング ポリシーは VC レベルで適用され、他の VC ではセッションにキューイング ポリシーが適用されます。 一部のセッションにはポリシーがまったく適用されません。 その結果、ルータはトラフィックを階層型キューイング フレームワーク(HQF)を使用して次のようにトラフィックを転送します。

  • VC レベルまたはセッション レベルでキューイング ポリシーが適用されていない場合、ルータは policing-only ポリシーが適用されている、またはポリシーが適用されていない VC 上のセッションからのトラフィックを含む、VC 上のすべてのトラフィックをデフォルト キューに送信します。
  • キューイング ポリシーがセッション レベルではなく VC レベルで適用されている場合、ルータは VC 上のキューイング ポリシーに関連付けられたキューにトラフィックを送信します。
  • キューイング ポリシーが他のセッションにではなく VC 上の一部のセッションに適用されている場合、ルータは policing-only ポリシーが付属したトラフィックまたは VC のデフォルト キューにポリシーが適用されていないトラフィックを送信します。 ルータは、キューイング ポリシーが付属したトラフィックを、セッションに適用されるキューイング ポリシーに関連付けられたキューに送信します。

帯域幅モードおよび ATM ポートのオーバーサブスクリプション

ATM ポートは予約帯域幅モードまたは共有帯域幅モードで動作します。

ポートがオーバーサブスクライブしていない(ポート上のすべての VC の帯域幅の合計がポート帯域幅未満である)場合、ポートは予約帯域幅モード(特定の量の帯域幅がポートの各 VC 用に予約されている)で動作します。 VC が割り当てられた帯域幅の一部だけを使用している場合は、未使用の帯域幅はポート上の VC 間で共有されません。

ATM ポートがオーバーサブスクライブしている(ポート上のすべての VC の帯域幅の合計がポート帯域幅よりも大きい)場合、ポートは共有帯域幅モードで動作します。 このモードでは、すべての未使用帯域幅が、VC の個々のシェーピング レートまで、ポート上の他の VC で再使用できます。VC 上のトラフィックは、その VC のシェーピング レートを超えることはできません。

セッション レベルでのオーバーサブスクリプション

セッション レベルのオーバーサブスクリプションは、セッションのトラフィックのシェーピング後、および集約セッション トラフィックがサブインターフェイスのシェーピング レートを超過した場合に発生します。 すべてのプライオリティ トラフィックが指定されると、ルータは、セッションに適用されるポリシーの親ポリシーに設定した bandwidth remaining ratio コマンドで指定された値に基づいて、VC 上の残りの帯域幅をセッションに分配します。 bandwidth remaining ratio コマンドが親ポリシーで指定されていない場合、ルータはデフォルトの比率である 1 を使用します。

ATM VC での PPP セッション キューイングの設定方法

仮想テンプレートを使用して PPP セッション キューイングを設定する

仮想テンプレートは、その設定が特定の目的に対応する汎用設定情報、ユーザ固有の設定情報とルータ依存情報を指定できる論理インターフェイスです。 インターフェイスに仮想テンプレートを設定し、仮想テンプレートに QoS ポリシー マップを適用します。 仮想テンプレートは、ポリシー マップで指定された QoS 機能を継承します。 ルータがインターフェイスにセッションを確立すると、ルータは仮想テンプレート設定で指定された QoS 機能を、仮想テンプレートに付加されたポリシー マップで指定された QoS 機能を含むセッションに作成された仮想アクセス インターフェイス(VAI)に適用します。

ATM インターフェイスに設定されたブロードバンド集約グループ(bba-group)は、セッションに QoS ポリシーを適用するためにルータが使用する仮想テンプレートを示します。 セッションが ATM インターフェイスに到達すると、ルータはセッションに仮想アクセス インターフェイス(VAI)を作成し、仮想テンプレートに関連付けられたポリシーをセッションに適用します。

仮想テンプレートを使用して PPPoEoA セッション キューイングを設定するには、次の設定作業を実行します。

階層型 QoS ポリシーの設定

手順の概要

    1.    enable

    2.    configure terminal

    3.    policy-map policy-map-name

    4.    class class-map-name

    5.    priority level level

    6.    police bps [burst-normal burst-max] [conform-action action] [exceed-action action] violate-action action

    7.    set cos value

    8.    bandwidth remaining ratio

    9.    exit

    10.    policy-map policy-map-name

    11.    class class-default

    12.    bandwidth remaining ratio

    13.    shape [average] mean-rate[burst-size] [excess-burst-size]

    14.    service-policy policy-map-name


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 policy-map policy-map-name


    例:
    Router(config)# policy-map policy-map-name
     

    子ポリシーを作成または変更します。 ポリシーマップ コンフィギュレーション モードを開始します。

    policy-map-name は子ポリシー マップの名前です。

     
    ステップ 4 class class-map-name


    例:
    Router(config-pmap)# class class-map-name
     

    指定するトラフィック クラスをポリシー マップに割り当てます。 ポリシーマップ クラス コンフィギュレーション モードを開始します。

    class-map-name は設定済みのクラス マップの名前で、QoS アクションを定義するトラフィック クラスです。

    子ポリシー マップに含めるトラフィック クラスごとにステップ 2~6 を繰り返して行ってください。

     
    ステップ 5 priority level level

    例:
    Router(config-pmap-c)# priority level level
     

    (任意)完全プライオリティ サービス モデルの複数レベルを定義します。 特定のプライオリティ レベルのサービスを持つトラフィック クラスをイネーブルにすると、指定されたプライオリティ サービスのレベルがイネーブルであるすべてのトラフィックに関連付けられた単一のプライオリティ キューに影響します。

    level は、特定のプライオリティ レベルを示す番号です。 有効な値は、1(高プライオリティ)~ 4(低プライオリティ)です。 デフォルト:1

     
    ステップ 6 police bps [burst-normal burst-max] [conform-action action] [exceed-action action] violate-action action


    例:
    Router(config-pmap-c)# police bps [burst-normal] [burst-max] [conform-action action] [exceed-action action] [violate-action  action]
     

    (任意)トラフィック ポリシングを設定します。

    bps はビット/秒の平均速度です。 有効値は 8000 ~ 200000000 です。

    (任意)burst-normal は標準バースト サイズ(バイト)です。 有効値は 1000 ~ 51200000 です。 デフォルトのノーマル バースト サイズは 1500 バイトです。

    (任意)burst-max は超過バースト サイズ(バイト)です。 有効値は 1000 ~ 51200000 です。

    (任意)conform-action action は、レート制限に適合するパケットで実行されるアクションを示します。

    (任意)exceed-action action は、レート制限を超過するパケットで実行されるアクションを示します。

    (任意)violate-action action は、ノーマルおよび超過バースト サイズに違反するパケットで実行するアクションです。

     
    ステップ 7 set cos value

    例:
    Router(config-pmap-c)# set cos value
     

    (任意)送信パケットのレイヤ 2 サービス クラス(CoS)値を設定します。

    値は 0~7 の、IEEE 802.1Q CoS 固有値です。

     
    ステップ 8 bandwidth remaining ratio

    例:
    Router(config-pmap-c)# bandwidth remaining ratio
     

    (任意)クラス レベルまたはサブインターフェイス レベルのキューの BRR を指定します。この BRR は、プライオリティ トラフィックによって使用されていない余分な帯域幅を判断し、非プライオリティ キューに割り当てるために輻輳時に使用します。

    比率は、他のサブインターフェイスまたはキューに関して、サブインターフェイスまたはキューに対する相対的重みを指定します。 有効な値は、1 ~ 1000 です。

     
    ステップ 9 exit

    例:
    Router(config-pmap-c)# exit
     

    ポリシーマップ クラス コンフィギュレーション モードを終了します。

     
    ステップ 10 policy-map policy-map-name


    例:
    Router(config-pmap)# policy-map policy-map-name
     

    親ポリシーを作成または変更します。

    policy-map-name は親ポリシー マップの名前です。

     
    ステップ 11 class class-default


    例:
    Router(config-pmap)# class class-default
     

    親 class-default クラスを設定または変更します。

    親ポリシーの class-default クラスは 1 つだけ設定できます。 他のトラフィック クラスは設定しないでください。

     
    ステップ 12 bandwidth remaining ratio

    例:
    Router(config-pmap-c)# bandwidth remaining ratio
     

    (任意)クラス レベルまたはサブインターフェイス レベルのキューの BRR を指定します。この BRR は、プライオリティ トラフィックによって使用されていない余分な帯域幅を判断し、非プライオリティ キューに割り当てるために輻輳時に使用します。

    比率は、他のサブインターフェイスまたはキューに関して、サブインターフェイスまたはキューに対する相対的重みを指定します。 有効な値は、1 ~ 1000 です。

     
    ステップ 13 shape [average] mean-rate[burst-size] [excess-burst-size]


    例:
                
                  Router(config-pmap-c)# shape [average] mean-rate [burst-size] [excess-burst-size]
     

    指示されたビット レートにトラフィックをシェーピングし、ATM オーバーヘッド アカウンティングをイネーブルにします。

    (任意)average は、各間隔で送信される最大ビット数を指定する認定バースト(Bc)です。 このオプションがサポートされるのは Performance Routing Engine 3(PRE3)だけです。

    mean-rate は、認定情報速度(CIR)とも呼ばれます。 トラフィックのシェーピングに使用されるビット レートを bps 単位で指定します。 このコマンドを逆方向明示的輻輳通知(BECN)の近似値と併用すると、ビット レートは許容ビット レート範囲の上限値になります。

    (任意)burst-size は測定インターバル内のビット数(Bc)です。

    (任意)excess-burst-size は Be の超過が許可される受け入れ可能なビット数です。

     
    ステップ 14 service-policy policy-map-name


    例:
    Router(config-pmap-c)# service-policy policy-map-name
     

    親の class-default クラスに子ポリシーを適用します。

    policy-map-name は、ステップ 1 で設定された子ポリシー マップの名前です。

     

    次に、階層型 QoS ポリシーを設定する例を示します。 この例では、child-policy は Premium と Silver という 2 種類のトラフィック クラスに QoS 機能を設定します。 Premium トラフィックが優先され、40 パーセントでポリシングされます。 ルータは Premium トラフィックの IP precedence をレベル 3 に設定します。 Silver トラフィックは 80000 bps でポリシングされ、IP Precedence レベル 3 が設定されます。 トラフィックを 200,000 Kbps にシェーピングする親ポリシーの class-default クラスに child-policy が適用されます。

    Router(config)# policy-map child-policy
    Router(config-pmap)# class Premium
    Router(config-pmap-c)# priority
    Router(config-pmap-c)# police percent 40
    Router(config-pmap-c)# set ip precedence 3
    Router(config-pmap-c)# class Silver
    Router(config-pmap-c)# police 80000 10000 conform-action transmit exceed-action drop
    Router(config-pmap-c)# set ip precedence 5
    Router(config-pmap-c)# exit
    Router(config-pmap)# policy-map Parent
    Router(config-pmap)# class class-default
    Router(config-pmap-c)# shape 200000
    Router(config-pmap-c)# service-policy output child-policy
    Router(config-pmap-c)# exit
    Router(config-pmap)# exit
    Router(config)#

    仮想テンプレートと階層型ポリシー マップの関連付け

    手順の概要

      1.    enable

      2.    configure terminal

      3.    interface virtual-template template- number

      4.    service-policy {input | output} policy-map-name

      5.    exit


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Router> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Router# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 interface virtual-template template- number


      例:
      Router(config)# interface virtual-template template-number
       

      仮想テンプレートを作成し、インターフェイス コンフィギュレーション モードを開始します。

      template-number は識別のために仮想テンプレート インターフェイスに割り当てられる番号です。 有効な値は 1~200 です。

      ルータ上に最大 200 個の仮想テンプレート インターフェイスを設定できます。

       
      ステップ 4 service-policy {input | output} policy-map-name


      例:
      Router(config-if)# service-policy {input | output} policy-map-name
       

      指定したポリシー マップを、指定の着信方向または発信方向で仮想テンプレート インターフェイスに対応付けます。

      input は着信トラフィックにポリシー マップを適用するように指定します。

      output は発信トラフィックにポリシー マップを適用するように指定します。

      policy-map-name は設定済みのポリシー マップの名前です。

       
      ステップ 5 exit

      例:
      Router(config-if)# exit
       

      インターフェイス コンフィギュレーション モードを終了します。

       

      次に、仮想テンプレートとポリシー マップを関連付ける例を示します。 この例では、Parent という名前のポリシー マップが VirtualTemplate1 という名前の仮想テンプレートに関連付けられます。

      Router(config)# interface virtual-template1
      Router(config-if)# service-policy output Parent
      Router(config-if)# exit
      Router(config)#

      ATM サブインターフェイスに仮想テンプレートを適用する

      手順の概要

        1.    enable

        2.    configure terminal

        3.    bba-group pppoe group-name

        4.    virtual-template template-number

        5.    exit

        6.    interface atm number.subinterface [point-to-point]

        7.    pvc [name] vpi/vci

        8.    protocol pppoe group group-name

        9.    exit

        10.    exit


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Router> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 configure terminal


        例:
        Router# configure terminal
         

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 bba-group pppoe group-name


        例:
        Router(config)# bba-group pppoe group-name
         

        PPP over Ethernet(PPPoE)プロファイルを作成します。 BBA グループ コンフィギュレーション モードを開始します。

        group-name は、PPPoE プロファイルの名前です。

         
        ステップ 4 virtual-template template-number


        例:
        Router(config-bba-grp)# virtual-template template-number
         

        仮想アクセス インターフェイスのクローンを作成する際に使用される仮想テンプレートに BBA グループを関連付けます。

        template-number は仮想テンプレートの識別番号です。

         
        ステップ 5 exit

        例:
        Router(config-bba-grp)# exit
         

        BBA グループ コンフィギュレーション モードを終了します。

         
        ステップ 6 interface atm number.subinterface [point-to-point]

        例:
        Router(config)# interface atm number.subinterface [point-to-point]
         

        サブインターフェイスを作成または変更します。 サブインターフェイス コンフィギュレーション モードを開始します。

        atm はインターフェイス タイプです。

        number は、インターフェイスのスロット、モジュール、およびポート番号です(1/0/0 など)。

        .subinterface はサブインターフェイスの番号です(1/0/0.1 など)です。

        (任意)point-to-point はサブインターフェイスが別のサブインターフェイスに直接接続することを示します。

         
        ステップ 7 pvc [name] vpi/vci

        例:
        Router(config-subif) pvc [name] vpi/vci 
         

        ATM 相手先固定接続(PVC)を作成または変更します。 ATM 仮想回線コンフィギュレーション モードを開始します。

        (任意)name は PVC を識別し、15 文字まで使用できます。

        vpi/ はこの PVC の ATM ネットワーク仮想パス識別子(VPI)を指定します。 スラッシュを指定する必要があります。 有効な値は、0 ~ 255 です。 ルータは、有効な値の範囲外にある値を接続 ID として処理します。 デフォルト値は 0 です

        (注)     

        vpi および vci 引数は両方を 0 に設定できません。一方が 0 の場合、もう一方は 0 にできません。

        vci はこの PVC の ATM ネットワーク仮想チャネル識別子(VCI)を指定します。 有効な値は 0~1 で、atm vc-per-vp コマンドによってこのインターフェイスに対して設定された最大値未満です。 値が範囲外の場合、「認識されないコマンド」のエラー メッセージが表示されます。

        VCI 値はローカルにだけ意味があるため、単一リンク上でだけ一意であり、ATM ネットワーク全体では一意ではありません。 通常、小さい値である 0~31 は特定のトラフィック(F4 OAM、SVC シグナリング、ILMI など)に予約されているため使用できません。

         
        ステップ 8 protocol pppoe group group-name

        例:
        Router(config-atm-vc)# protocol pppoe group group-name
         

        PPP over Ethernet(PPPoE)セッションを相手先固定接続(PVC)で確立できるようにします。

        group は、インターフェイス上の PPPoE セッションで使用される PPPoE プロファイル(bba-group)を示します。

        group-name は、インターフェイス上の PPPoE セッションで使用される PPPoE プロファイル(bba-group)の名前です。

        group group-name は、QoS ポリシー付きの仮想テンプレート インターフェイスをセッションに適用するために使用される、bba-group を指します。

         
        ステップ 9 exit

        例:
        Router(config-atm-vc)# exit
         

        ATM 仮想回線コンフィギュレーション モードを終了します。

         
        ステップ 10 exit

        例:
        Router(config-subif)# exit
         

        サブインターフェイス コンフィギュレーション モードを終了します。

         

        次に、ATM インターフェイスを仮想テンプレート インターフェイスを関連付ける方法と、インターフェイス上のセッションに仮想テンプレート内のポリシーを適用する方法の例を示します。 この例では、Parent という名前のサービス ポリシーが、pppoeoa-group という bba-group に関連付けられている Virtual-Template 8 に適用されます。 bba-group は ATM サブインターフェイス 4/0/1.10 上の PVC 101/210 に適用されます。

        bba-group pppoe pppoeoa-group
        Virtual-Template 8
        interface ATM4/0/1.10 point-to-point
        pvc 101/210
        vbr-nrt 4000 2000 50
        no dbs enable
        encapsulation aal5snap
        protocol pppoe group pppoeoa-group
        !
        interface Virtual-Template8
        ip unnumbered Loopback5555
        no logging event link-status
        peer default ip address pool pool-1
        ppp authentication chap
        service-policy output Parent

        RADIUS を使用して PPP セッション キューイングを設定する

        RADIUS を使用して PPPoEoA セッション キューイングを設定するには、次の設定作業を実行します。

        ポリシー マップの設定

        ルータによって、PPPoEoA セッションに RADIUS を使用して QoS ポリシー マップを動的に適用できるようになります。

        RADIUS プロファイルに Cisco QoS AV ペアを追加する

        シスコの属性と値(AV)のペアは、シスコなどのベンダーが独自の拡張属性をサポートできるようにするベンダー固有属性(VSA)です。 RADIUS 属性 26 は、ルータと RADIUS サーバ間でベンダー固有の情報をやり取りするために使用される Cisco VSA です。

        RADIUS ユーザ プロファイルには、RADIUS サーバが認証する各ユーザのエントリが含まれます。 エントリごとにユーザがアクセス可能な属性が設定されます。 RADIUS を使用して PPPoEoA セッション キューイングを設定する場合は、適切なユーザ プロファイルに次の Cisco AV ペアを入力してください。

        Cisco-AVPair = "ip:sub-qos-policy-out=<name of egress policy>"
        

        Cisco AV ペアは、QoS 機能を PPPoEoA セッションに適用する場合にルータが使用するポリシー マップを示します。 ポリシー サーバからサービス ログイン要求を受け取った後、すでにログインしているユーザ向けのサービスをアクティブにするため、RADIUS はルータに許可変更(CoA)要求を送信します。 認証に成功すると、ルータは Cisco AV ペアを使用して RADIUS からポリシー マップ名をダウンロードし、セッションに QoS ポリシーを適用します。


        (注)  


        ルータは RADIUS のベンダー固有属性(VSA)38、Cisco-Policy-Down および Cisco-Policy-Up もサポートしますが、QoS ポリシー定義には上記の属性を使用することを推奨します。


        ATM VC での PPP セッション キューイングの確認

        手順の概要

          1.    enable

          2.    configure terminal

          3.    show policy-map [interface interface]

          4.    show policy-map session [uid uid-number] [input | output [class class-name]]

          5.    show running-config


        手順の詳細
           コマンドまたはアクション目的
          ステップ 1 enable


          例:
          Router> enable
           

          特権 EXEC モードをイネーブルにします。

          • パスワードを入力します(要求された場合)。
           
          ステップ 2 configure terminal


          例:
          Router# configure terminal
           

          グローバル コンフィギュレーション モードを開始します。

           
          ステップ 3 show policy-map [interface interface]


          例:
          Router# show policy-map [interface interface]
           

          ユーザが指定したインターフェイスに付加されたポリシー マップに関する情報を表示します。 インターフェイスを指定しないと、ルータ上で設定されているすべてのポリシー マップに関する情報が表示されます。

          interface interface は、インターフェイスのタイプと番号です(atm 4/0/0 など)。

           
          ステップ 4 show policy-map session [uid uid-number] [input | output [class class-name]]

          例:
          Router# show policy-map session [uid uid-number] [input | output [class class-name]]
           

          加入者セッションに対して有効な QoS ポリシー マップを表示します。

          (任意)uid は一意のセッション ID を定義します。

          (任意)uid-number は一意のセッション ID です。 有効な値は 1 ~ 65535 です。

          (任意)input には一意のセッションのアップストリーム トラフィックが表示されます。

          (任意)output には一意のセッションのダウンストリーム トラフィックが表示されます。

          (任意)class は、QoS ポリシー マップ定義の一部であるクラスを識別します。

          (任意)class-name は QoS ポリシー マップ定義の一部であるクラス名を提供します。

           
          ステップ 5 show running-config


          例:
          Router# show running-config
           

          ルータ上の実行コンフィギュレーションを表示します。 出力には、AAA 設定、およびポリシー マップ、ATM VCs、PPPoEoA、ダイナミック帯域幅選択、仮想テンプレート、RADIUS サーバの設定が表示されます。

           

          ATM VC での PPP セッション キューイングの設定例

          ATM VC での PPP セッション キューイングの設定例

          次に、PPPoEoA セッション キューイングを設定する例を示します。 この例では、pppoeoa Group という名前のブロードバンド集約グループに適用される pm_hier2_0_2 という名前の階層型 QoS ポリシーが、Virtual-Template555 に関連付けられています。

          bba-group pppoe pppoeoa-group
          Virtual-Template 555
          !
          policy-map pm_hier2_child_0_2
          class cm_0
          priority level 1
          police percent 5 2 ms 0 ms conform-action transmit exceed-action drop violate-action drop
          queue-limit 77 packets
          class cm_1
          shape average percent 80
          bandwidth remaining ratio 80
          class class-default
          shape average percent 50
          bandwidth remaining ratio 20
          policy-map pm_hier2_0_2
          class class-default
          shape average percent 100
          bandwidth remaining ratio 100
          service-policy pm_hier_child_0_2
          interface ATM2/0/7.5555 point-to-point
          pvc 1/5555
          vbr-nrt 4000 2000 50
          no dbs enable
          encapsulation aal5snap
          protocol pppoe group pppoeoa-group
          !
          !
          interface Virtual-Template555
          ip unnumbered Loopback5555
          no logging event link-status
          peer default ip address pool pool-1
          ppp authentication chap
          service-policy output pm_hier2_0_2

          階層型ポリシー マップを設定および適用する例

          階層型ポリシー マップを設定および適用する例に、階層型ポリシーを設定し、仮想テンプレートに適用する例を示します。 この例には、child1 という名前の子ポリシー マップと、gold トラフィック クラスと bronze トラフィック クラス用に定義された QoS 機能が含まれます。 child1 ポリシーは 512000 bps にシェーピングされる、親ポリシー マップに適用されます。 階層型ポリシーは、virtual-template 1 という名前の仮想テンプレートに適用されます。

          Router(config)# policy-map child1
          Router(config-pmap)# class gold
          Router(config-pmap-c)# priority
          Router(config-pmap-c)# police percent 40
          Router(config-pmap-c)# class bronze
          Router(config-pmap-c)# police 8000
          Router(config-pmap-c)# exit
          Router(config-pmap)# policy-map parent
          Router(config-pmap)# class class-default
          Router(config-pmap-c)# shape 512000
          Router(config-pmap-c)# service-policy child1
          Router(config-pmap-c)# exit
          Router(config-pmap)# exit
          Router(config)# interface virtual-template 1
          Router(config-if)# service-policy output parent

          ATM VC での PPP セッション キューイング用 RADIUS の設定例

          ATM VC での PPP セッション キューイング用 RADIUS の設定例に、ポリシー マップ名をルータにダウンロードする際に使用される Cisco AV ペアを定義する方法を示します。 加入者のユーザ プロファイルの例の最初の 3 行には、ユーザ パスワード、サービス タイプ、プロトコル タイプが含まれます。 この情報は、ユーザ プロファイルが最初に作成されたときに、加入者のユーザ プロファイルに入力されます。 最後の行は、ユーザ プロファイルに追加された Cisco QoS AV ペアの例です。 ルータにダウンロードされたポリシー マップ名は p23 です。

          userid	Password = "cisco"
          Service-Type = Framed,
          Framed-Protocol = PPP,
          cisco-avpair = "sub-qos-policy-out=p23"

          ATM VC での PPP セッション キューイングの確認例

          PPP セッション情報の表示:show pxf cpu queue session コマンド

          ATM VC での PPP セッション キューイングの確認例は、show pppoe session コマンドを使用して、ルータに設定されたセッションを表示します。 この場合、セッション ID(SID)6 で 1 個のセッションがアクティブです。

          Router# show pppoe session
          1 session in LOCALLY_TERMINATED (PTA) State
          1 session total
          Uniq ID	PPPoE	RemMAC	Port	VT	VA	State
          	SID	LocMAC	VA-st	Type
          	14	6	0009.b68d.bb37	ATM2/0/7.5555	555	Vi3.1	PTA
          			0009.b68d.bc37	VC: 1/5555 			UP
          

          ATM VC での PPP セッション キューイングの確認例は、show policy-map session コマンドを使用して、ダウンストリーム方向のトラフィックの QoS ポリシー マップ統計情報を表示します。 ポリシー マップ コンフィギュレーションの例も示します。

          Router# show pppoe session
          1 session in LOCALLY_TERMINATED (PTA) State
          1 session total
          Uniq ID	PPPoE	RemMAC	Port	VT	VA	State
          	SID	LocMAC	VA-st	Type
          	14	6	0009.b68d.bb37	ATM2/0/7.5555	555	 Vi3.1 	PTA 
          	0009.b68d.bc37 VC: 1/5555	UP 
          Router#
          Router#
          Router# show policy-map session uid 14
          SSS session identifier 14 -
          	Service-policy output: pm_hier2_0_2
          Class-map: class-default (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: any 
          0 packets, 0 bytes
          30 second rate 0 bps
          Queueing
          queue limit 50 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 2000000, bc 8000, be 8000
          target shape rate 2000000
          bandwidth remaining ratio 100
          	Service-policy : pm_hier2_child_0_2
          queue stats for all priority classes:
          Queueing
          priority level 1
          queue limit 77 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          Class-map: cm_0 (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 0 
          0 packets, 0 bytes
          30 second rate 0 bps
          Priority: 0% (0 kbps), burst bytes 4470, b/w exceed drops: 0
          Priority Level: 1 
          Police:
          104000 bps, 1536 limit, 0 extended limit
          conformed 0 packets, 0 bytes; action: transmit
          exceeded 0 packets, 0 bytes; action: drop
          violated 0 packets, 0 bytes; action: drop
          Class-map: cm_1 (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: ip precedence 1 
          0 packets, 0 bytes
          30 second rate 0 bps
          Queueing
          queue limit 237 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 1600000, bc 6400, be 6400
          target shape rate 1600000
          bandwidth remaining ratio 80 
          Class-map: class-default (match-any)
          0 packets, 0 bytes
          30 second offered rate 0 bps, drop rate 0 bps
          Match: any 
          0 packets, 0 bytes
          30 second rate 0 bps
          Queueing
          queue limit 77 packets
          (queue depth/total drops/no-buffer drops) 0/0/0
          (pkts output/bytes output) 0/0
          shape (average) cir 1000000, bc 4000, be 4000
          target shape rate 1000000
          bandwidth remaining ratio 20 
          Router# show policy-map pm_hier2_0_2
          Policy Map pm_hier2_0_2
          Class class-default
          Average Rate Traffic Shaping
          cir 100%
          bandwidth remaining ratio 100 
          service-policy pm_hier2_child_0_2
          Router# show policy-map pm_hier2_child_0_2
          Policy Map pm_hier2_child_0_2
          Class cm_0
          priority level 1
          police percent 5 2 ms 0 ms conform-action transmit exceed-action drop violate-action drop
          queue-limit 77 packets
          Class cm_1
          Average Rate Traffic Shaping
          cir 80%
          bandwidth remaining ratio 80 
          Class class-default
          Average Rate Traffic Shaping
          cir 50%
          bandwidth remaining ratio 20 

          その他の関連資料

          関連資料

          関連項目

          マニュアル タイトル

          Cisco IOS コマンド

          『Cisco IOS Master Commands List, All Releases』

          QoS コマンド

          『Cisco IOS QoS Command Reference』

          標準

          標準

          タイトル

          この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

          --

          MIB

          MIB

          MIB のリンク

          この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

          選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

          http:/​/​www.cisco.com/​go/​mibs

          RFC

          RFC

          タイトル

          この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

          シスコのテクニカル サポート

          説明

          リンク

          シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          ATM VC での PPP セッション キューイングの機能情報

          次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

          プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

          表 2 ATM VC での PPP セッション キューイングの機能情報

          機能名

          リリース

          機能情報

          ATM VC での PPP セッション キューイング

          Cisco IOS XE Release 2.5

          ATM 仮想回線(VC)での PPP セッション キューイングにより、ユーザが指定したレートに PPP over Ethernet over ATM(PPPoEoA)セッションをシェーピングし、キューに入れることができます。

          この機能は、Cisco IOS Release XE 2.5 で、Cisco ASR 1000 シリーズ ルータに導入されました。

          Cisco and the Cisco Logo are trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and other countries. A listing of Cisco's trademarks can be found at www.cisco.com/​go/​trademarks . Third party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1005R)