QoS:ポリシングおよびシェーピング コンフィギュレーション ガイド、Cisco IOS XE Release 3S(Cisco ASR 1000)
QoS ポリシー アカウンティング
QoS ポリシー アカウンティング
発行日;2013/07/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

QoS ポリシー アカウンティング

QoS ポリシー アカウンティング機能により、システムのトラフィックを正確に示すことができます。 加入者に対する Quality of Service(QoS)構成の割り当ての柔軟性も高くなります。 また、QoS アカウンティングのハイ アベイラビリティ機能により、QoS アカウンティング統計情報の有効性が持続し、RADIUS アカウンティングの課金サーバにより、計画中の予期せぬルート プロセッサ(RP)スイッチオーバー時にアカウンティング カウンタが引き続き報告されます。 このモジュールでは、QoS ポリシー アカウンティングの設定、ユーザ テンプレートの使用、サブスクライバ アカウンティングの精度のアクティブ化の各方法について説明します。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、バグ検索ツールとプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

QoS ポリシー アカウンティングの前提条件

  • PPP over Ethernet(PPPoE)または PPP over Ethernet over ATM(PPPoEoA)セッションはイネーブルです。
  • RADIUS サーバが設定されます。
  • 認証、許可、アカウンティング(AAA)はイネーブルです。
  • RADIUS サーバの加入者のユーザ プロファイルが作成されます。
  • ポリシー マップが設定されます。
  • サービス テンプレートが設定されます。
  • トラフィック クラスが作成されます。
  • Stateful Switchover(SSO)および In-Service Software Upgrades(ISSU)の前提条件を満たす必要があります。 詳細については、『Cisco IOS High Availability Configuration Guide』を参照してください。

QoS ポリシー アカウンティングに関する制約事項

  • システムのフェールオーバーでは、次が発生します。
    • ポリシー マップに静的に設定された QoS アカウンティングの場合、QoS アカウンティング統計情報はゼロにリセットされます。
    • サービス テンプレートを使用して動的に設定された QoS アカウンティングの場合、新しいアクティブなルート プロセッサ(RP)にセッションは存在しなくなります。

    (注)  


    Cisco IOS XE Release 3.5S 以降のリリースでは、ハイ アベイラビリティ(HA)のサポートは、サービス テンプレートを通じて有効になるアカウンティング サービスに使用できます。 そのため、QoS アカウンティング統計情報およびサービス セッションは、システムのフェールオーバー中に保持され、新しいアクティブ RP で使用できます。


  • マルチキャストは、QoS ポリシー アカウンティング サービスではサポートされません。
  • 次の QoS アクションはサービス テンプレートではサポートされていません。
    • account
    • fair-queue
    • netflow-sampler
    • random-detect
  • 次の QoS フィルタはサービス テンプレートではサポートされていません。
    • atm
    • class-map
    • cos
    • destination-address
    • discard-class
    • fr-de
    • fr-dlci
    • input-interface
    • mpls
    • not
    • packet
    • source-address
    • vlan
  • サービス テンプレート定義の行は、Cisco IOS CLI によって許可された設定の最大行の長さを超えることはできません。 この範囲内に抑えるためにシェル変数名を短くすることができます。
  • セッションでアクティブになっているテンプレート サービスは変更できません。 代わりに、これを非アクティブにし、別のテンプレート サービスをアクティブにすることができます。
  • テンプレート サービスがアクティブである場合、従来の複雑なパラメータ化された文字列を使用して QoS ポリシーをセッションでアクティブに変更できない場合があります。
  • IP アドレスのパラメータ化は IPv4 および注釈のない名前付き ACL でのみサポートされます。 パラメータ化されたサービス アクティベーションで指定された IP アドレスは、「permit ip network mask any」および「permit ip any network mask」の固定パターンでクローン ACL に必ず追加されます。
  • サービス テンプレートは、PPP セッションのみでサポートされ、サブインターフェイスではアクティブにできません。
  • セッションでアクティブにできるのは常に 1 つの Turbo Button サービスのみです。 Turbo Button サービスは、親ポリシーの class-default における「service-policy xxxx」以外の QoS アクションを変更する(子ポリシーを変更する)すべてのサービスです。
  • シェル変数、QoS クラス マップ、アクセス コントロール リスト(ACL)の名前には、次の文字を含めることはできません。
    • !
    • $
    • #
    • -
    • ,
    • >
    • <
  • サービス名は、グループ アカウンティングに対してのみのアカウンティング レコードにエコーバックされます(サービス テンプレートで $_acctgrp を使用する場合)。
  • セッションでアクティブな入力/出力 QoS ポリシー名は、以前アクティブであった QoS ポリシー(または最後のマルチサービス許可変更(CoA)または Access-Accept で指定されたスタティック QoS ポリシー)を連結することで形成されます。
  • 同じサービス テンプレートからインスタンス化された 2 個のテンプレート サービスは、セッションで同時にアクティブにすることはできません。 ただし、無関係なサービス テンプレートからインスタンス化された複数のテンプレート サービスは、セッションで同時にアクティブにすることができます。
  • テンプレート サービスのサポートが提供されるのは、ローカルに終端された PPP に対して、および Layer 2 Tunneling Protocol(L2TP)アクセス コンセントレータ(LAC)で PPP によって転送されるセッションに対してのみです。
  • LAC で PPP によって転送されたセッションの場合、Access-Accept を介してテンプレート サービスを適用するには、次の設定を使用します。
    • vpdn authen-before-forward。
    • 認証プロファイルではなくユーザ許可プロファイル(PPP 認証後に受信される Access-Accept)にのみテンプレート サービスを指定します。
  • テンプレート サービスをアクティブにするのは、親の class-default の下の子ポリシー(2 レベルまで)に対して、および親ポリシー(Turbo Button サービス)に対してのみです。
  • デフォルトの QoS ポリシーは、2 レベルの深さ(親 + class-default の下の子)に限られ、class-default 以外のクラスの下には子ポリシーを設定しません。
  • テンプレート サービスを子レベルでアクティブにするために、デフォルトの親ポリシーの class-default の下で子ポリシーを設定する必要があります。
  • 構文エラー チェックに起因するロールバックのみがサポートされます。
  • サービスのアクティブ化または非アクティブ化が単一の CoA メッセージに複数含まれる場合、操作(アクティブ化または非アクティブ化)の失敗は、CoA 処理の開始前のセッション状態に復元するために、CoA が以前のすべての動作をロールバックする(取り消す)必要があることを意味します。 つまり、すべての操作が CoA で正常に処理されるか、まったく処理されないことになります。 CoA の否定 ACK(NACK)は RADIUS に送信されます。
  • ロールバックが Access-Accept の処理中に動作するようにするには、加入者サービスの複数承認処理を設定する必要があります。 Access-Accept でサービスの処理に失敗すると、Access-Accept での以前のすべてのサービスがロールバックされる(取り消される)ことになります。 Access-Accept サービス処理が失敗してもセッションが立ち上がります。
  • プラットフォームまたはデータ プレーンで発生するエラーは、ロールバックをトリガーしません(ロールバックが不完全なサービスに終わる可能性があります)。
  • テンプレート サービスがセッションで使用中またはアクティブである場合、サービス テンプレートを変更しないでください。 使用中のテンプレート サービスを表示するには、show subscriber policy ppm-shim-db コマンドを使用します。

QoS ポリシー アカウンティングの概要

RADIUS は AAA 管理を提供するネットワーキング プロトコルです。 特に、各 RADIUS アカウンティング メッセージには、入力と出力のカウンタが含まれます。 QoS ポリシー アカウンティング機能を使用するとカウンタ間の誤差を解消することができます。

グループでの QoS ポリシー アカウンティング機能

QoS ポリシー アカウンティング機能は、RADIUS サーバに対する次の情報をセッション単位に収集してレポートします。

  • Acct-Session-Id
  • 入出力パケット数/バイト数/ギガワード数、パケット数、および正常に送信されたパケットのバイト数
  • Parent-Session-Id
  • ポリシー名とクラス名またはグループ名(QoS ポリシー アカウンティング機能がグループでイネーブルの場合)
  • サービス名
  • ユーザ名

QoS ポリシー アカウンティング機能をグループでイネーブルにして、グループ名を割り当てる場合は、この機能は次の条件を満たすパケットを集計します。

  • 同じグループのトラフィック クラスで分類する
  • 同じターゲットに適用される入出力 QoS ポリシーに含まれている

別のアカウンティング ストリーム

トラフィック クラスをグループに割り当てない代わりに AAA 方式リストに割り当てた場合、トラフィック クラスごとに別の QoS ポリシー アカウンティング ストリームが作成されます。 別のアカウンティング ストリームにより、複数のクラスに適合するトラフィックを区別することができます。 ターゲット、方向、ポリシー名、クラス名にはそれぞれ固有の RADIUS Acct-Session-Id 値があります。

サービス テンプレート

サービス テンプレートを使用すると、CLI に新しい QoS ポリシーを定義せずに QoS パラメータを動的に変更することができます。 QoS ポリシーは、セッションの開始時、またはセッション確立後の任意の時点で変更できます。 アクティブな QoS を動的に変更する前に、現在のサービスを非アクティブ化します。

サービス テンプレートを理解するには、次の用語について知っておく必要があります。

  • サービス テンプレートは:
    • Cisco IOS シェル機能です
    • 入力 QoS ポリシー マップ定義を含みます
    • 出力 QoS ポリシー マップ定義を含みます
    • プログラム的に呼び出されます
    • シェル変数のデフォルト値を指定します
  • テンプレート サービスは:
    • 括弧付きの QoS サービス名です
    • 一致するシェル マップ テンプレート定義を含みます
    • サービス テンプレートのシェル関数の実行中に動的に作成されます
  • 最終的に有効な入力ポリシー マップ
  • 最終的に有効な出力ポリシー マップ

QoS ポリシー アカウンティング機能は、Cisco IOS シェルが、サービス テンプレートのシェル関数で使用される変数のデフォルト値を上書きする方法について説明します。 シェル マップ内の QoS ポリシー定義には、QoS アクション パラメータ値の代わりにシェル変数が含まれる場合があります。

サービス テンプレートの使用

サービス テンプレートを作成するには、テキスト エディタでサービス テンプレートを作成し、CLI にそのテンプレートをコピーします。 シェル マップ ブロックの内容はテキストとして扱われます。

サービス テンプレート ポリシー マップ(ポリシー マップ $_outgoing/$_incoming)を定義する際には、使用可能な CLI ヘルプまたはプロンプトはありません。 たとえば次の CLI 支援にはアクセスできません。

  • パーサーの自動実行
  • コマンド オプション
  • 範囲ヘルプ
  • 構文チェック

(注)  


CLI で使用可能なエディタはありません。そのため間違えた場合はサービス テンプレート全体を削除し、最初から再度設定する必要があります。


サービス テンプレートの確認

テキスト エディタにサービス テンプレートを作成する際の構文をチェックする機能はありません。 したがって、サービス テンプレートをアクティブにする前に、構文を確認する必要があります。 次のコード サンプルは、voice-service1 サービス テンプレートを確認する方法を示します。 独自のテンプレートを確認するには、voice-service1 をサービス テンプレート名で置き換えます。

(shell map voice-service1 police_rate=100000 prec_value=4 queue_size=1)
configure terminal
no policy-map test-svc_IN <-------- Removes previous service template verifications.
no policy-map test-svc_OUT <-------- Removes previous service template verifications.
no aaa-accounting group test_svc_GRP <-------- Removes previous service template verifications.
end
trigger voice-service1 _incoming=test-svc_IN _outgoing=test-svc_OUT _acctgrp=test-svc_GRP
show policy-map test-svc-IN <-------- 
Ensure that the output matches the expected service template template service with default values. 
show policy-map test-svc-OUT <-------- 
Ensure that the output matches the expected service template template service with default values.
 
サービス テンプレートの削除

サービス テンプレートを削除するには、コマンドラインで次のように入力します。

no shell map voice-service1 police_rate=100000 prec_value=4 queue_size=1 in_h=class-default out_h=class-default

voice-service1 は、サービス テンプレートの名前を意味します。

サンプル サービス テンプレート

サービス テンプレート

次に、サービス テンプレートの例を示します。

{
    configure terminal
    accounting group $_acctgrp list default
    policy-map $_outgoing
      class voip
        police $police_rate 60625 0 conform-action transmit exceed-action drop violate-action drop
	exit
        priority level 1
        queue-limit 8 packets
        set precedence $prec_value
        set cos 6
        aaa-accounting group $_acctgrp
      class voip-control 
        police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
        queue-limit $queue_size packets
        set precedence 6
        aaa-accounting group $_acctgrp
    policy-map $_incoming
      class voip
        police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 5
        aaa-accounting group $_acctgrp
      class voip-control
        police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 7
        aaa-accounting group $_acctgrp
}
処理パラメータのオーバーライド

処理パラメータのオーバーライドは、シェル変数が、QoS ポリシー内のクラスで入力されたポリシング、シェーピング、帯域幅、設定などの QoS アクションのパラメータの代わりに使用されるサービス テンプレートのタイプです。

テンプレート サービスを無効にすると、システムは以前アクティブだった QoS ポリシーを復元します。 QoS ポリシーは、名前は異なっている可能性がありますが、テンプレート サービスがアクティブになる前にアクティブになっている QoS ポリシーと構造的かつ機能的に同じです。

この例では、次のパラメータを使用したサービスが生成されます。

Reserved variable initialization before executing the service template shell function:
$_incoming = voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN
$_outgoing = voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT
$_acctgrp = aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP list default

セッションでアクティブな出力 QoS ポリシー:

policy-map output_parent
 class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default

セッションでアクティブな入力 QoS ポリシー:

policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default

voice-service1(police_rate=200000,prec_value=5,queue_size=32) をターゲット セッションでアクティブにすると、これがアクティブな出力ポリシーとなります。

policy-map output_parent$class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
 class class-default
   shape average 10000000
   service-policy output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
policy-map output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
      class voip
        police 200000 60625 0 conform-action transmit exceed-action drop violate-action drop
        priority level 1
        queue-limit 8 packets
        set precedence 5
        set cos 6
        aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
      class voip-control 
        police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
        queue-limit 32 packets
        set precedence 6
        aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
class class-default

voice-service1(police_rate=200000,prec_value=5,queue_size=32) をターゲット セッションでアクティブにすると、これがアクティブな入力ポリシーとなります。

policy-map input_parent$class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
 class class-default
   police cir 10000000 bc 312500 conform-action transmit exceed-action drop
   service-policy input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
policy-map input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
      class voip
        police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 5
        aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
      class voip-control
        police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 7
        aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
 class-default
処理のパラメータ化のデフォルト パラメータ

処理のパラメータ化のデフォルト パラメータは、シェル変数が、QoS ポリシー内のクラスで入力されたポリシング、シェーピング、帯域幅、設定などの QoS アクションのパラメータの代わりに使用されるサービス テンプレートのタイプです。

テンプレート サービスを無効にすると、システムは以前アクティブだった QoS ポリシーを復元します。 QoS ポリシーは、名前は異なっている可能性がありますが、テンプレート サービスがアクティブになる前にアクティブになっている QoS ポリシーと構造的かつ機能的に同じです。

セッションでアクティブな出力 QoS ポリシー:

policy-map output_parent
class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default

セッションでアクティブな入力 QoS ポリシー:

policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default
ip access-list extended voip-acl
 permit ip 10.1.1.0 0.0.0.255 any
ip access-list extended voip-control-acl
 permit ip 10.2.2.0 0.0.0.255 any
class-map match-any voip
 match access-group name voip-acl
!
class-map match-any voip-control
 match access-group name voip-control-acl
!
shell map voice-service1 police_rate=100000 prec_value=4 queue_size=1 in_h=class-default out_h=class-default
{
    configure terminal
    accounting group $_acctgrp list default
    policy-map $_outgoing
      class voip
        police $police_rate 60625 0 conform-action transmit exceed-action drop violate-action drop
	exit
        priority level 1
        queue-limit 8 packets
        set precedence $prec_value
        set cos 6
        aaa-accounting group $_acctgrp
      class voip-control 
        police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
        queue-limit $queue_size packets
        set precedence 6
        aaa-accounting group $_acctgrp
    policy-map $_incoming
      class voip
        police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 5
        aaa-accounting group $_acctgrp
      class voip-control
        police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 7
        aaa-accounting group $_acctgrp
}

voice-service1 をターゲット セッションでアクティブにすると、これがアクティブな出力ポリシーとなります。

policy-map output_parent$class-default$voice-service1><_OUT$class-default class 
		class-default
		shape average 10000000
		service-policy output_child$voice-service1><_OUT$class-default
policy-map output_child$voice-service1><_OUT$class-default
		class voip
			police 10000 60625 0 conform-action transmit exceed-action drop violate-action drop
 	 priority level 1
			queue-limit 8 packets
			set precedence 4
			set cos 6
			aaa-accounting group voice-service1><_GRP
		class voip-control 
			police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
			queue-limit 16 packets
			set precedence 6
			aaa-accounting group voice-service1><GRP
	class class-default

voice-service1 をターゲット セッションでアクティブにすると、これがアクティブな入力ポリシーとなります。

policy-map input_parent$class-default$voice-service1><_IN$class-default
	class class-default
	police cir 10000000 bc 312500 conform-action transmit exceed-action drop
	service-policy input_child$voice-service1><_IN$class-default		
policy-map input_child$voice-service1><_IN$class-default
	class voip
  police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
		set precedence 5
		aaa-accounting group voice-service1><_GRP
 class voip-control
  police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
		set precedence 7
		aaa-accounting group voice-service1><_GRP
	class-default
クラス名のオーバーライド

クラス名のオーバーライドは、シェル変数が、QoS ポリシー内のクラスで入力されたポリシング、シェーピング、帯域幅、設定などの QoS アクションのパラメータの代わりに使用されるサービス テンプレートのタイプです。 シェル変数は、サービス テンプレートのポリシー定義におけるクラス名の代わりに使用される可能性があります。 シェル変数は、クラス名を完全に置き換える場合があります。または、固定プレフィックス付きの可変サフィックスとして設定される可能性があります。

テンプレート サービスを無効にすると、システムは以前アクティブだった QoS ポリシーを復元します。 QoS ポリシーは、名前は異なっている可能性がありますが、テンプレート サービスがアクティブになる前にアクティブになっている QoS ポリシーと構造的かつ機能的に同じです。

セッションでアクティブな出力 QoS ポリシー:

policy-map output_parent
 class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default

セッションでアクティブな入力 QoS ポリシー:

policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default
! Pre-configured ACLs/class-maps
ip access-list extended aol_classifier_acl					   	! Locally pre-configured
 permit ip host 10.1.30.194 any
class-map match-all voice-control-aol_classifier_reference						! Locally pre-configured
  match access-group name aol_classifier_acl
! Other pre-configured ACLs/classes here (e.g., voice-aol_classifier_reference, voice-t_online, etc.)
! Service template:
shell map voice-aol-service1 prec_value=3 police_rate=100000 class_ref=t_online in_h=class-default out_h=class-default
{
    configure terminal
    accounting group $_acctgrp list default
    policy-map $_outgoing 
      class voice-control-$class_ref
        police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
        queue-limit 16 packets
        set precedence 6
        aaa-accounting group $_acctgrp
      class voice-$class_ref
        police $poice_rate 60625 0 conform-action transmit exceed-action drop violate-action drop
        priority level 1
        queue-limit 8 packets
        set precedence $prec_value
        set cos 6
        aaa-accounting group $_acctgrp
    policy-map $_incoming 
      class voice-control-$class_ref
        police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 7
        aaa-accounting group $_acctgrp
      class voice-$class_ref
        police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence $prec_value
        aaa-accounting group $_acctgrp
}

voice-aol-service1(class_ref=aol_classifier_reference) をターゲット セッションでアクティブにすると、これがアクティブな出力ポリシーとなります。

policy-map output_parent$class-default$voice-aol-service1<class_ref=aol_classifier_reference>_OUT$class-default
 class class-default
    shape average 10000000
   service-policy output_child$voice-aol-service1<class_ref=aol_classifier_reference>_OUT$class-default
policy-map output_child$voice-aol-service1<class_ref=aol_classifier_reference>_OUT$class-default
      class voice-control-aol_classifier_reference					! Reference to pre-configured class
        police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
        queue-limit 16 packets
        set precedence 6
        aaa-accounting group voice-aol-service1<class_ref=aol_classifier_reference>_GRP
      class voice-aol_classifier_reference					! reference to pre-configured class
        police 100000 60625 0 conform-action transmit exceed-action drop violate-action drop
        priority level 1
        queue-limit 8 packets
        set precedence 3
        set cos 6
        aaa-accounting group voice-aol-service1<class_ref=aol_classifier_reference>_GRP
class class-default

voice-aol-service1(class_ref=aol_classifier_reference) をターゲット セッションでアクティブにすると、これがアクティブな入力ポリシーとなります。

policy-map input_parent$class-default$voice-aol-service1<class_ref=aol_classifier_reference>_IN$class-default
 class class-default
    police cir 10000000 bc 312500 conform-action transmit exceed-action drop
   service-policy input_child$voice-aol-service1<class_ref=aol_classifier_reference>_IN$class-default
policy-map input_child$voice-aol-service1<class_ref=aol_classifier_reference>_IN$class-default
      class voice-control-aol_classifier_reference					! reference to pre-configured class
        police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 7
        aaa-accounting group voice-aol-service1<class_ref=aol_classifier_reference>_GRP
      class voice-aol_classifier_reference					! reference to pre-configured class
        police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 3
        aaa-accounting group voice-aol-service1<class_ref=aol_classifier_reference>_GRP
       class-default
IP アドレスのパラメータ化

IP アドレスのパラメータ化は、分類子が ACL にエントリを追加することによって、動的に変更できる処理のパラメータ化サービス テンプレートのタイプです。 ACL に追加されるエントリは、シェル変数の IP アドレスのリストです。

テンプレート サービスを無効にすると、システムは以前アクティブだった QoS ポリシーを復元します。 QoS ポリシーは、名前は異なっている可能性がありますが、テンプレート サービスがアクティブになる前にアクティブになっている QoS ポリシーと構造的かつ機能的に同じです。


(注)  


クラスは事前定義する必要があります。これらは動的に作成されません。


セッションでアクティブな出力 QoS ポリシー:

policy-map output_parent
 class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default

セッションでアクティブな入力 QoS ポリシー:

policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default
! Base ACLs:
ip access-list extended IPOne-control-acl					! Base ACL locally pre-configured
  permit ip any host 10.0.132.118
  permit ip host 10.0.132.118 any
  permit ip any host 10.1.245.122
  permit ip host 10.1.245.122 any
ip access-list extended IPOne-combined-acl						! Base ACL pre-configured
 permit ip any 10.0.132.0 0.0.0.127
 permit ip 10.0.132.0 0.0.0.127 any
 permit ip any 10.1.245.64 0.0.0.63
 permit ip 10.1.245.64 0.0.0.63 any
! Base class-maps:
class-map match-any voice-control						! Base class map pre-configured
  match access-list name IPOne-control-acl						!   Match on the base ACL
class-map match-any voice						! base class-map pre-configured
  match access-list name IPOne-combined-acl						!   Match on the base ACL
! Service template:
shell map voice-toi  prec_value=3 police_rate=100000 ip_list=10.2.1.0/28,10.2.1.0/29 in_h=class-default out_h=class-default
{
    configure terminal
    ! Class-map templates:
    classmap-template voice-control  $ip_list
    classmap-template voice  $ip_list
    ! Service parameter templates:
    policy-map $_outgoing 
      class voice-control-$ip_list					! class names MUST end with -$ip_list
        police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
        queue-limit 16 packets
        set precedence 6
        aaa-accounting group IPOne-aol
      class voice-$ip_list
        police $police_rate 60625 0 conform-action transmit exceed-action drop violate-action drop
        priority level 1
        queue-limit 8 packets
        set precedence $prec_value
        aaa-accounting group IPOne-aol
    policy-map $_incoming 
      class voice-control-$ip_list
        police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 7
        aaa-accounting group IPOne-aol
      class voice-$ip_list
        police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence $prec_value
        aaa-accounting group IPOne-aol

ターゲット セッションで voice-toi(ip_list=10.1.30.0/28,10.1.40.0/29) をアクティブにすると、これがアクティブな出力 QoS ポリシーになります。

policy-map output_parent$class-default$ voice-toi>ip_list=10.1.30.0/28,10.1.40.0/29<_OUT$class-default
 class class-default
    shape average 10000000
   service-policy output_child$voice-toi>ip_list=10.1.30.0/28,10.1.40.0/29<_OUT$class-default
policy-map output_child$voice-toi>ip_list=10.1.30.0/28,10.1.40.0/29<_OUT$class-default
      class voice-control-10.1.30.0/28,10.1.40.0/29
        police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
        queue-limit 16 packets
        set precedence 6
        aaa-accounting group IPOne-aol
      class voice-10.1.30.0/28,10.1.40.0/29
        police 100000 60625 0 conform-action transmit exceed-action drop violate-action drop
        priority level 1
        queue-limit 8 packets
        set precedence 3
        aaa-accounting group IPOne-aol
class class-default
 

ターゲット セッションで voice-toi(ip_list=10.1.30.0/28,10.1.40.0/29) をアクティブにすると、これがアクティブな入力 QoS ポリシーになります。

policy-map input_parent$class-default$voice-toi>ip_list=10.1.30.0/28,10.1.40.0/29<_IN$class-default
 class class-default
    police cir 10000000 bc 312500 conform-action transmit exceed-action drop
   service-policy input_child$voice-toi>ip_list=10.1.30.0/28,10.1.40.0/29<_IN$class-default
policy-map input_child$voice-toi>ip_list=10.1.30.0/28,10.1.40.0/29<_IN$class-default
      class voice-control-10.1.30.0/28,10.1.40.0/29
        police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 7
        aaa-accounting group IPOne-aol
      class voice-10.1.30.0/28,10.1.40.0/29
        police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 3
        aaa-accounting group IPOne-aol
 class-default
 

(注)  


次の設定が動的に作成されます。


 
! Internally created ACLs:
ip access-list extended IPOne-control-acl-10.1.30.0/28,10.1.40.0/29
  permit ip any host 10.0.132.118
  permit ip host 10.0.132.118 any
  permit ip any host 10.1.245.122
  permit ip host 10.1.245.122 any
  permit ip 10.1.30.0 0.0.0.15 any		! ACEs derived from $ip_list
  permit ip any  10.1.30.0 0.0.0.15
  permit ip 10.1.40.0 0.0.0.7 any
  permit ip any 10.1.40.0 0.0.0.7
ip access-list extended IPOne-combined-acl-10.1.30.0/28,10.1.40.0/29
  permit ip any 10.0.132.0 0.0.0.127
  permit ip 10.0.132.0 0.0.0.127 any
  permit ip any 10.1.245.64 0.0.0.63
  permit ip 10.1.245.64 0.0.0.63 any
  permit ip 10.1.30.0 0.0.0.15 any		! ACEs derived from $ip_list
  permit ip any 10.1.30.0 0.0.0.15
  permit ip 10.1.40.0 0.0.0.7 any
  permit ip any 0.0.0.7 10.1.40.0
! internally created class-maps:
class-map match-any voice-control-10.1.30.0/28,10.1.40.0/29
   match access-group name IPOne-control-acl-10.1.30.0/28,10.1.40.0/29
class-map match-any voice-10.1.30.0/28,10.1.40.0/29
   match access-group name IPOne-combined-acl-10.1.30.0/28,10.1.40.0/29
Turbo Button サービス

Turbo Button サービスは、入力親 class-default でのポリシング パラメータと、出力親 class-default でのシェーピング パラメータだけが、動的に変更可能な処理のパラメータ化サービス テンプレートのタイプです。

次に、Turbo Button サービスのサービス テンプレートの作成方法を示します。

セッションでアクティブな出力 QoS ポリシー:

policy-map output_parent
 class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default

セッションでアクティブな入力 QoS ポリシー:

policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default
shell map turbo-button in_police_val=20000000 $out_shape=20000000
configure terminal
accounting group $_acctgrp list default
policy-map $_outgoing
class class-default
shape average $out_shape
aaa-accounting group $_acctgrp
policy-map $_incoming
class class-default
police $in_police_val
aaa-accounting group $_acctgrp
Turbo Button のアクティブ化

次に、デフォルト値を使用して Turbo Button サービスをアクティブにする例を示します。

セッションでアクティブな出力 QoS ポリシー:

policy-map output_parent
 class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default

セッションでアクティブな入力 QoS ポリシー:

policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default
accounting group turbo-button>< list default

accounting group turbo-button>< list default
! Service outgoing:
	policy-map  turbo-button><_OUT
	class class-default
	shape average 20000000
	aaa-accounting group turbo-button>< list default
! Service incoming:
	policy-map  turbo-button><_IN
	class class-default
 police 20000000
aaa-accounting group turbo-button>< list default

サービスをターゲット セッションでアクティブにすると、これがアクティブな出力ポリシーとなります。

policy-map output_parent$turbo-button><_OUT$
class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
	class class-default
	shape average 20000000
aaa-accounting group turbo-button>< list default
service-policy output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
policy-map output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
class voip
police 200000 60625 0 conform-action transmit exceed-action drop violate-action drop
	priority level 1
	queue-limit 8 packets
	set precedence 5
	set cos 6

aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
	class voip-control 
	police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
	queue-limit 32 packets
	set precedence 6
aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
class class-default

      

サービスをターゲット セッションでアクティブにすると、これがアクティブな入力ポリシーとなります。

policy-map input_parent$turbo-button>
<_IN$class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
class class-default
   police cir 20000000 bc 312500 conform-action transmit exceed-action drop
   aaa-accounting group turbo-button>< list default

service-policy input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
policy-map input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default

   class voip
        police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
        set precedence 5
        aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
   class voip-control
								police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
								set precedence 7
        aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
class-default
Turbo Button の非アクティブ化

次に、VSA 252 0c turbo-button() のデフォルト値を使用して Turbo Button サービスを非アクティブにする例を示します。

セッションでアクティブな出力 QoS ポリシー:

policy-map output_parent
 class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default

セッションでアクティブな入力 QoS ポリシー:

policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default

サービスをターゲット セッションでアクティブにすると、これがアクティブな出力ポリシーとなります。

policy-map output_parent$class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
class class-default
  shape average 10000000
  service-policy output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
policy-map output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
  class voip
   police 200000 60625 0 conform-action transmit exceed-action drop violate-action drop
   priority level 1
   queue-limit 8 packets
   set precedence 5
   set cos 6
   aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
  class voip-control 
   police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
   queue-limit 32 packets
   set precedence 6
   aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP    
class class-default
      

サービスをターゲット セッションでアクティブにすると、これがアクティブな入力ポリシーとなります。

policy-map input_parent$class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
   class class-default
   police cir 10000000 bc 312500 conform-action transmit exceed-action drop
   service-policy input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
      
policy-map input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
  class voip
   police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
   set precedence 5
   aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
  class voip-control
   police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
   set precedence 7
   aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
  class-default
      
Turbo Button のオーバーライド

次に、VSA 250 Aturbo-button(in_police_val=30000000, out_shape_val=30000000) (Activation from Access-Accept) または VSA 252 0b turbo-button(in_police_val=30000000, out_shape_val=30000000) (Activation from CoA) のデフォルト値を使用して Turbo Button サービスをアクティブにする方法を示します。

セッションでアクティブな出力 QoS ポリシー:

policy-map output_parent
 class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default

セッションでアクティブな入力 QoS ポリシー:

policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default
accounting group turbo-button>in_police_val=30000000#out_shape_val=30000000 list default     
! Service outgoing:
 policy-map turbo-button>in_police_val=30000000#out_shape_val=30000000<_OUT
 class class-default
  shape average 30000000
  accounting group turbo-button>in_police_val=30000000#out_shape_val=30000000    
! Service incoming:
  policy-map turbo-button>in_police_val=30000000#out_shape_val=30000000<_IN
  class class-default
   police 30000000
   accounting group turbo-button>in_police_val=30000000#out_shape_val=30000000

サービスをターゲット セッションでアクティブにすると、これがアクティブな出力ポリシーとなります。

policy-map output_parent$turbo-button> in_police_val=30000000#out_shape_val=30000000<_OUT$class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
class class-default
 shape average 20000000
 accounting group turbo-button>in_police_val=30000000#out_shape_val=30000000
 service-policy output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
 policy-map output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
class voip
 police 200000 60625 0 conform-action transmit exceed-action drop violate-action drop
 priority level 1
 queue-limit 8 packets
 set precedence 5
 set cos 6
 aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
class voip-control 
 police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
 queue-limit 32 packets
 aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
class class-default
      

サービスをターゲット セッションでアクティブにすると、これがアクティブな入力ポリシーとなります。

policy-map input_parent$turbo-button>in_police_val=30000000#out_shape_val=30000000<_IN$class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
class class-default
 police cir 20000000 bc 312500 conform-action transmit exceed-action drop
 accounting group turbo-button>in_police_val=30000000#out_shape_val=30000000
 service-policy input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
policy-map input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
 class voip
  police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
  set precedence 5
  aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
 class voip-control
  police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
  set precedence 7
  aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
 class-default
Turbo Button オーバーライドの非アクティブ化の例

次に、VSA 252 0c turbo-button (in_police_val=30000000, out_shape_val=30000000) のデフォルト値を使用して Turbo Button オーバーライドを非アクティブにする例を示します。

セッションでアクティブな出力 QoS ポリシー:

policy-map output_parent
 class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default

セッションでアクティブな入力 QoS ポリシー:

policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default

サービスをターゲット セッションでアクティブにすると、これがアクティブな出力ポリシーとなります。

policy-map output_parent$class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
      
 class class-default
  shape average 10000000
  service-policy output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
policy-map output_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_OUT$class-default
  class voip
   police 200000 60625 0 conform-action transmit exceed-action drop violate-action drop
   priority level 1
   queue-limit 8 packets
   set precedence 5
   set cos 6
   aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
  class voip-control 
   police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
   queue-limit 32 packets
   set precedence 6
   aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
  class class-default

      

サービスをターゲット セッションでアクティブにすると、これがアクティブな入力ポリシーとなります。

policy-map input_parent$class-default$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
		class class-default
  police cir 10000000 bc 312500 conform-action transmit exceed-action drop
  service-policy input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
  policy-map input_child$voice-service1>police_rate=200000#prec_value=5#queue_size=32<_IN$class-default
  class voip
   police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
   set precedence 5
   aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
  class voip-control
   police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
   set precedence 7
   aaa-accounting group voice-service1>police_rate=200000#prec_value=5#queue_size=32<_GRP
  class-default
中間アカウンティング インターバルのオーバーライドの例

中間アカウンティング インターバルのオーバーライドは、アカウント中間値の動的な変更が可能なアカウンティング方式リスト定義での中間インターバル値の代わりに、シェル変数を使用できる処理のパラメータ化サービス テンプレートのタイプです。

次に、VSA 252 0b voice-service1(police_rate=200000,prec_value=5,acct_interval=600) のデフォルト値を使用して、アカウンティング グループのオーバーライドを実行する例を示します。

この例では、次のパラメータを使用したサービスが生成されます。

! Global AAA method list and accounting group parameters
aaa accounting network list-600
 action-type start-stop periodic interval 600
  accounting group voice-service1>policy_rate=200000#prec_value=5#acct_interval=600 <_GRP list list-600
! OUT policy-map:
 policy-map voice-service1>policy_rate=200000#prec_value-5#acct_interval=600 <_OUT
  class voip
   police 200000 60625 0 conform-action transmit exceed-action drop violate-action drop
   priority level 1
   queue-limit 8 packets
   set precedence 5
   set cos 6
   aaa-accounting group voice-service1>policy_rate=200000#prec_value=5#acct_interval=600 <_GRP
		class voip-control 
   police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
   queue-limit 32 packets
   set precedence 6
   aaa-accounting group 
      
OUT:
policy-map output_parent
 class class-default
   shape average 10000000
   service-policy output_child
policy-map output_child
class class-default
IN:
policy-map input_parent
 class class-default
   police 10000000
   service-policy input_child
policy-map input_child
 class-default

サービスをターゲット セッションでアクティブにすると、これがアクティブな出力ポリシーとなります。

policy-map output_parent$class-default$voice-service1>policy_rate=200000#prev_value=5#acct_interval=600 <_OUT$class-default
 class class-default
 shape average 10000000
 service-policy output_child$voice-service1>policy_rate=200000#prev_value=5#acct_interval=600 <_OUT$class-default
 policy-map output_child$voice-service1>policy_rate=200000#prev_value=5#acct_interval=600 <_OUT$class-default
 class voip
  police 200000 60625 0 conform-action transmit exceed-action drop violate-action drop
  priority level 1
  queue-limit 8 packets
  set precedence 5
  set cos 6
  aaa-accounting group voice-service1>policy_rate=200000#prec_value=5#acct_interval=600 <_GRP
  class voip-control 
  police 112000 1000 0 conform-action transmit exceed-action drop violate-action drop
  queue-limit 32 packets
  set precedence 6
  aaa-accounting group voice-service1>policy_rate=200000#prec_value=5#acct_interval=600 <_GRP     
	class class-default
      

サービスをターゲット セッションでアクティブにすると、これがアクティブな入力ポリシーとなります。

policy-map input_parent$class-default$voice-service1>policy_rate=200000#prec_value-5#acct_interval=600 <_IN$class-default
class class-default
 police cir 10000000 bc 312500 conform-action transmit exceed-action drop
 service-policy input_child$voice-service1>policy_rate=200000#prec_value=5#acct_interval=600 <_IN$class-default
policy-map input_child$voice-service1>policy_rate=200000#prec_value=5#acct_interval=600 <_IN$class-default
 class voip
  police 200000 9216 0 conform-action transmit exceed-action transmit violate-action drop
  set precedence 5
  aaa-accounting group voice-service1>policy_rate=200000#prec_value=5#acct_interval=600 <_GRP     
	class voip-control
  police 112000 21000 0 conform-action transmit exceed-action transmit violate-action drop
  set precedence 7
  aaa-accounting group voice-service1>policy_rate=200000#prec_value=5#acct_interval=600 <_GRP
 class class-default
    

サブスクライバ アカウンティングの精度

サブスクライバ アカウンティングの精度機能により、Accounting-Stop レコードの入出力パケット/バイト統計情報は、1 秒内まで正確であることが保証されます。

サブスクライバ アカウンティング データは、次のイベント中に認証、許可、アカウンティング(AAA)サーバに送信されます。

  • セッションまたはサービスのライフタイム中に設定されたインターバル
  • サービスのログオフ
  • セッションの切断

サブスクライバ アカウンティングの精度機能に値を設定するには、subscriber accounting accuracy milliseconds コマンドを使用します。

許可変更(CoA)ACK の順序指定

CoA ACK 順序指定は、QOS アカウンティング レコードがこの CoA に送信される前に、個々の CoA イベント用に CoA-ACK を送信します。 CoA は、単一または複数のサービスのアクティブ化または非アクティブ化を含む場合があります。

サービスがセッションにインストールできない場合、次の状況が発生します。

  • CoA 全体が失敗します。
  • Policy Manager は RADIUS サーバに CoA-NAK を送信します。
  • 前のサービス コンフィギュレーションが復元されます。

失敗が検出される前に 1 つ以上のサービスがインストールされると、次の状況が発生します。

  • CoA 全体が失敗します。
  • サービスはバックアウトされます。
  • Policy Manager は RADIUS サーバに CoA-NAK を送信します。
  • 前のサービス コンフィギュレーションが復元されます。

マルチサービス CoA は次のいずれかで構成されます。

  • QoS サービス:Policy Manager は、最終的に有効な 1 個のポリシー マップにサービスを組み合わせます。 すべてのサービスのセッションに適用されるのは、1 個の QoS ポリシーだけです。 ポリシーをインストールできない場合、システムはセッションを復元して前のポリシー マップを使用します。 事実上、セッションは CoA の前の状態に復元されます。
  • QoS およびインテリジェント サービス ゲートウェイ(ISG)サービス:Policy Manager は ISG サービスを最初に適用し、次に QoS サービスを適用します。 QoS ポリシーをインストールできない場合、システムはセッションを前のポリシー マップに復元します。 ISG と QoS の両方のサービスは、以前の状態に戻るまでロールバックされます。

マルチサービス CoA の場合、すべてのサービスが正常にインストールされると、1 個の CoA ACK のみが送信されます。

許可変更のロールバック

CoA のロールバック機能により、QoS ポリシー アカウンティングが CoA が発行される前の状態に復元されます。 また、CoA のロールバックは、CoA-NAK を使用して RADIUS サーバを正しく認知します。

CoA のロールバック機能は、構文の間違いと、アドミッション制御やリソース割り当ての失敗などのポリシー インストール障害に適用されます。

CoA が失敗すると、システムは CoA-NAK を送信し、QoS アカウンティング レコードを送信しません。 既存のサービスのアカウンティング レコードは前のカウンタを保持し、新しいパケットをカウントし続けます。

QoS アカウンティングのハイ アベイラビリティ

QoS アカウンティングがクラスでイネーブルになると、ポリシー アカウンティング機能は、次の 3 種類のイベントをサポートします。
  • 開始:新しいアカウンティング フローを示します。 開始レコードには、このフローに固有の統計情報と属性が含まれます。
  • 中間:どのくらいの頻度でフロー統計情報が報告されるかを示します。
  • 停止:アカウンティング フローの終りを示します。 停止レコードにも、このフローに固有の統計情報と属性が含まれます。

ポリシー アカウンティング機能は、アカウンティング フローの統計情報を収集し、RADIUS アカウンティングの課金サーバに情報を送信します。

QoS アカウンティングのハイ アベイラビリティ機能により、計画的または予想外のフェールオーバーが発生した場合に、開始、中間、停止の各アカウンティング レコードが影響を受けないようにします。 計画的または予想外のフェールオーバーが発生すると、QoS アカウンティングの HA 機能により、RADIUS アカウンティングの課金サーバへの情報のフローを中断せずに RP スイッチオーバーを発生させることができます。 この機能により、すべてのアクティブ セッションのすべての QoS サービスが中断することなく続行され、サービス アカウンティング カウンタが RP スイッチオーバー中保持するようになります。

ポリシー アカウンティング ステートの永続性

開始、停止、中間アカウンティングが Stateful Switchover(SSO)または In-Service Software Upgrade(ISSU)による影響を受けないようにするため、Policy Manager は、すべての QoS サービスおよびパラメータ化された CoA 機能をフェールオーバー時のスタンバイ RP と同期します。 さらに、ダイナミックな QoS の設定とポーリング間隔は、アクティブ RP とスタンバイ RP 間で同期化されます。

スタンバイ RP にパラメータ化された CoA イベントを同期するには、Policy Manager は次の機能を実行します。
  • プロビジョニング イベントをスタンバイ RP で同期するように CoA のリプレイを管理します。
  • アクティブ RP とスタンバイ RP の両方で同じサービス テンプレートを使用します。
  • アクティブ RP とスタンバイ RP の両方でセッションに適用する同じポリシー マップ名とクラス マップ名を作成します。
  • サービス テンプレートのアクティベーション中に定義済みの QoS ポリシー マップとクラス マップを使用します。

ポリシー アカウンティング カウンタの永続性

QoS アカウンティングの HA 機能により、ポリシー アカウンティング カウンタが SSO またはフェールオーバー中持続するようになります。 スイッチオーバーが発生すると、スタンバイ RP がアクティブ RP になり、以前アクティブだった RP からの統計情報を集計します。 新しくアクティブになった RP がスイッチオーバー後に定期的な更新を受信した場合は、集計した統計情報と、定期的な更新から取得した値を使用して、中間レコードが生成されます。 新しくアクティブになった RP がスイッチオーバー後に定期的な更新を受信しない場合は、以前アクティブだった RP から集計した統計情報だけを使用して、中間レコードが生成されます。

SSO と ISSU の詳細については、『Cisco IOS High Availability Configuration Guide』を参照してください。

QoS ポリシー アカウンティングを使用する方法

QoS ポリシー アカウンティングを使用する場合、トラフィック クラスにグループまたは AAA 方式リストを割り当て、次にポリシー アカウンティングのサービス テンプレートを設定し、最後にサブスクライバ アカウンティングの精度機能をアクティブにする必要があります。

(注)  


デフォルトでは、QoS ポリシー アカウンティングはトラフィック クラスに割り当てられていません。


トラフィック クラスにグループまたは AAA 方式リストを割り当てる

はじめる前に

グループまたは AAA 方式リストがすでに存在している必要があります。 トラフィック クラスに未定義のグループまたは AAA 方式リストを追加しようとすると、エラー メッセージが表示されます。

手順の概要

    1.    enable

    2.    configure terminal

    3.    aaa authentication ppp list-name method1

    4.    aaa accounting network methodlist-name

    5.    action-type start-stop

    6.    periodic interval minutes

    7.    accounting group group_name list list-name

    8.    policy-map policy-map-name

    9.    class class-default

    10.    accounting aaa list list-name [group-name]

    11.    end

    12.    show policy-map session

    13.    show accounting group group-name


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 aaa authentication ppp list-name method1


    例:
    Router(config)# aaa authentication ppp group radius
     

    有効な AAA 認証方式を指定します。

    • グループ RADIUS はグローバル RADIUS 認証をイネーブルにします。
     
    ステップ 4 aaa accounting network methodlist-name


    例:
    Router(config)# aaa accounting network list1
     

    RADIUS を使用する場合のサービスの AAA をイネーブルにします。

    • クラスまたはグループの中間インターバルを決定するアルゴリズムは、ここで指定した方式リストを使用します。
     
    ステップ 5 action-type start-stop


    例:
    Router(config)# action-type start-stop 
     

    プロセスの開始時に start アカウンティング通知を送信し、プロセスの終了時に stop アカウンティング通知を送信します。

     
    ステップ 6 periodic interval minutes


    例:
    Router(config)# periodic interval 1
     

    指定された場合、方式リストに中間インターバル値(1~71,582 分)を追加します。

    • 中間インターバルを定義していない場合、AAA で定義されたグローバル値が使用されます。
    • 方式リストが中間アップデートをディセーブルにすると、この方式リストを使用しているアカウンティング フローからは中間更新は生成されません。
     
    ステップ 7 accounting group group_name list list-name


    例:
    Router(config)# accounting group group_name AAAmethodlist AAAmethodlist1
     

    AAA 方式リストにプロパティを設定します。

    • 既存のトラフィック クラスに割り当てられたグループまたは AAA 方式リストで一時的にプロパティを上書きすることによって、このクラスにセッション単位の変更を加えることができます。 これで、各加入者に動的にカスタマイズされた QoS 設定を提供できるようになります。
     
    ステップ 8 policy-map policy-map-name


    例:
    Router(config)# policy-map p1
     

    ポリシー マップを作成します。

     
    ステップ 9 class class-default


    例:
    Router(config)# class class-default
     

    トラフィック クラスを作成します。

     
    ステップ 10 accounting aaa list list-name [group-name]


    例:
    Router(config)# accounting aaa list AAAmethodlist1
     

    グループまたは AAA 方式リストにトラフィック クラスを割り当てます。

    • 次に、グループのないリスト AAAmethodlist1 を使用してトラフィック クラスのインスタンスに対してイネーブルにされた QoS ポリシー アカウンティング機能を示します。
     
    ステップ 11 end


    例:
    Router(config)# end
     

    インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

     
    ステップ 12 show policy-map session


    例:
    Router# show policy-map session
     

    (任意)グループまたは AAA 方式リストのあるトラフィック クラスの QoS ポリシー アカウンティング機能の情報を表示します。

     
    ステップ 13 show accounting group group-name


    例:
    Router# show accounting group acc-group1
     

    (任意)グループから方式リストへの関連付けをすべて表示します。

    • グループ名を入力すると、そのグループに固有の情報が表示されます。
     

    サブスクライバ アカウンティング精度のアクティブ化

    手順の概要

      1.    enable

      2.    configure terminal

      3.    subscriber accounting accuracy milliseconds

      4.    end


    手順の詳細
       コマンドまたはアクション目的
      ステップ 1 enable


      例:
      Device> enable
       

      特権 EXEC モードをイネーブルにします。

      • パスワードを入力します(要求された場合)。
       
      ステップ 2 configure terminal


      例:
      Device# configure terminal
       

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 subscriber accounting accuracy milliseconds


      例:
      Device(config)# subscriber accounting accuracy 1000
      
       

      サブスクライバ アカウンティング精度機能の値を設定します。

       
      ステップ 4 end


      例:
      Device(config)# end
       

      特権 EXEC モードを開始します。

       

      トラブルシューティング サービス テンプレート

      サービス テンプレートに問題がある場合、これを修復するには、ルータのすべてのテンプレートのサービス ポリシー マップの使用情報を表示できます。

      手順の概要

        1.    enable

        2.    show subscriber policy ppm-shim-db


      手順の詳細
         コマンドまたはアクション目的
        ステップ 1 enable


        例:
        Router> enable
         

        特権 EXEC モードをイネーブルにします。

        • パスワードを入力します(要求された場合)。
         
        ステップ 2 show subscriber policy ppm-shim-db


        例:
        Router(config)# show subscriber policy ppm-shim-db
         

        ルータのすべてのテンプレートのサービス ポリシー マップと最終的に有効なポリシー マップの参照カウント(使用情報)を表示します。

         

        QoS ポリシー アカウンティングの設定例

        例:グループでの QoS ポリシー アカウンティング機能の使用

        次に、グループ化の例を示します。

        policy-map my-policy 
        class voip 
        police
        aaa-accounting group premium-services 
        class voip-control 
        police
        aaa-accounting group premium-services

        例:別のアカウンティング ストリームを生成する

        次に、voip と voip-control という 2 つの分類子の例を示します。 分類子は、1 つのターゲットに関連付けられた 1 つのポリシーに割り当てられます。 この設定で、2 つの別の QoS ポリシー アカウンティング ストリームが生成されます。

        policy-map my-policy
        class voip
        police 200000
        accounting aaa list AAA-LIST
        class voip-control
        police 100000
        accounting aaa list AAA-LIST
        

        その他の関連資料

        関連資料

        関連項目

        マニュアル タイトル

        Cisco IOS コマンド

        『Cisco IOS Master Commands List, All Releases』

        QoS コマンド

        『Cisco IOS QoS Command Reference』

        Cisco IOS のハイ アベイラビリティ

        『Cisco IOS High Availability Configuration Guide』

        標準

        標準

        タイトル

        この機能でサポートされる新規の標準または変更された標準はありません。また、既存の標準のサポートは変更されていません。

        --

        MIB

        MIB

        MIB のリンク

        この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

        選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

        http:/​/​www.cisco.com/​go/​mibs

        RFC

        RFC

        タイトル

        RFC 2866

        『RADIUS Accounting』

        シスコのテクニカル サポート

        説明

        リンク

        シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

        http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

        QoS ポリシー アカウンティング機能の機能情報

        次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

        プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

        表 1 QoS ポリシー アカウンティング機能の機能情報

        機能名

        リリース

        機能情報

        QoS アカウンティング HA

        Cisco IOS XE Release 3.5S

        QoS アカウンティングのハイ アベイラビリティ(HA)機能により、QoS アカウンティング統計情報の有効性が持続し、RADIUS アカウンティングの課金サーバにより、計画中の予期せぬルート プロセッサ(RP)スイッチオーバー時にアカウンティング カウンタが引き続き報告されます。

        Cisco IOS XE Release 3.5S では、このサービスは Cisco ASR 1000 シリーズ ルータに導入されました。

        コマンド debug qos accounting が変更されました。

        QoS ポリシー アカウンティング

        Cisco IOS XE Release 2.6

        Cisco IOS XE Release 3.2S

        Cisco IOS XE Release 3.8S

        QoS ポリシー アカウンティング機能により、システムのトラフィックを正確に示すことができます。 加入者に対する QoS 設定の割り当ての柔軟性も高くなります。

        スタティック CLI 駆動型のアカウンティングがサポートされます。

        Cisco IOS XE Release 2.6 では、Cisco ASR 1000 シリーズ Aggregation Services Router にこの機能が実装されました。

        Cisco IOS XE Release 3.2S では、ダイナミックなアクティベーションによって制御されないサービスの場合は、サービス テンプレート、加入者のサブセカンド精度、ダイナミックな CoA と中断のないアカウンティングがサポートされます。

        この機能により、show subscriber policy ppm-shim-db コマンドと subscriber accounting accuracy コマンドが追加されました。