QoS:ポリシングおよびシェーピング コンフィギュレーション ガイド、Cisco IOS XE Release 3S(Cisco ASR 1000)
階層型 Color-Aware ポリシング
階層型 Color-Aware ポリシング
発行日;2013/07/18   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

目次

階層型 Color-Aware ポリシング

階層型 Color-Aware ポリシング機能は、子から親にポリサーの順序付けを評価する場面に 2 つのレベルのポリシングを提供し、親レベルで特定のトラフィックを優先的に扱うことができます。 この機能は、次のサポートと変更を通じて、Cisco IOS XE Release 3.2S から Cisco ASR 1000 シリーズ アグリゲーション サービス ルータでイネーブルになります。

  • 階層型ポリシーでのデータ プレーンのポリシングの順序を反転させ、このポリシーが子から親に評価されるようにます。 以前のリリースでは、ポリシーは親から子に評価されていました。
  • Quality of Service(QoS)ポリシー内の Color-Aware ポリシングの限定的なサポート(RFC 2697、RFC 2698)。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。 最新の機能情報および警告については、バグ検索ツールとプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。 このモジュールに記載されている機能の詳細を検索し、各機能がサポートされているリリースのリストを確認する場合は、このモジュールの最後にある機能情報の表を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

階層型 Color-Aware ポリシングの前提条件

Cisco IOS XE Release 3.2S 以降のバージョンがインストールされていて、Cisco ASR 1000 シリーズ ルータで実行されている必要があります。

モジュラ Qos CLI(MQC)、マスター コントロール プロセッサ(MCP)ソフトウェアとハードウェア アーキテクチャなどの関連機能とテクノロジーについて知っておく必要があります。 その他の関連資料の項には、関連機能およびテクノロジー マニュアルへのリンクが記載されています。

階層型 Color-Aware ポリシングに関する制約事項

Color-Aware ポリシング機能には次の制約事項が適用されます。

  • Color-Aware クラス マップは、QoS グループのマッチングだけをサポートします。
  • Color-Aware クラスごとに 1 フィルタのみ(1 個の match ステートメント)がサポートされます。
  • Color-Aware 統計情報はサポートされません。既存のポリサー統計情報だけがサポートされます。
  • Color-Aware クラス マップの削除(no class-mapclass-map-name コマンドを使用)は、クラス マップが Color-Aware ポリサーで参照されている間は許可されません。 これは、すべての Color-Aware ポリサーから取り除く必要があります(no conform-colorclass-map-name または no exceed-colorclass-map-name コマンドを最初に使用)。
  • 階層型ポリサーの評価は、子から親への順序付けをサポートするために永続的に反転します(設定不可)。

階層型 Color-Aware ポリシングの概要

階層型の順序のポリシング

Cisco IOS XE Release 3.2S 以前は、Cisco ASR 1000 シリーズ プラットフォームは、評価順序が親から子である階層型ポリシーでのポリサーをサポートしていました。 階層型 Color-Aware ポリシング機能の導入により、評価順序が反転し、QoS ポリシーでポリサーが子から親へ評価されるようになります。 この順序はデフォルトの動作に対する永続的な変更で、設定不可です。 逆順ポリサー機能は、入出力方向の両方で共有されます。

次の単純な 2 つのレベルのポリサーの設定により、下記の図に示すように動作が変化します。

policy-map child
 class user1
  police 100k
 class user2
  police 100k
policy-map parent
 class class-default
  police 150k
  service-policy child



限定的 Color-Aware ポリシング

次の単純な 2 つのレベルの Color-Aware ポリサーの設定により、下記の図に示すように動作が変化します。

ip access-list extended user1-acl
 permit ip host 192.168.1.1 any
 permit ip host 192.168.1.2 any
ip access-list extended user2-acl
 permit ip host 192.168.2.1 any
 permit ip host 192.168.2.2 any
class-map match-all user1-acl-child
  match access-group name user1-acl
class-map match-all user2-acl-child
  match access-group name user2-acl
class-map match-all hipri-conform
 match qos-group 5
policy-map child-policy
 class user1-acl-child
   police 10000 bc 1500
    conform-action set-qos-transmit 5
class user2-acl-child
   police 20000 bc 1500
    conform-action set-qos-transmit 5
class class-default
   police 50000 bc 1500
policy-map parent-policy
 class class-default
  police 50000 bc 3000
   exceed-action transmit
   violate-action drop
   conform-color hipri-conform
  service-policy child-policy
図 1. 単純な 2 つのレベルの Color-Aware ポリサー


(注)  


「適合した」子のトラフィックに対する親レベルでのドロップを回避するには、親ポリサーのレートとバーストが、子の適合レートとバースト サイズの合計以上である必要があります。 不適切な(親から子への)レートおよびバースト サイズがコードにないかどうかチェックする機能はありません。 この制限を認識し、適切に設定する必要があります。 次の例では、Color-Aware ポリシングとともに明示的なマーキング アクションがサポートされ、Color-Aware ポリサーのマーキング アクションを同様に実行します。 これらのマーキング アクション(「set qos-group」など)が子ポリシーにある場合、結果として生成されるビット値は、親の Color-Aware ポリサー(子ポリサーのマーキング アクションの場合と同じ)によって評価されます:50k >= 10k (user1-acl-child) + 20k (user2-acl-child)


子クラスと親クラスでのトラフィックのポリシング

階層型 Color-Aware ポリシング機能がリリースされるまでは、ポリシングとマーキングは、通常、入力 QoS のオプションとして使用されていました。 たとえば、音声カスタマーは、音声制御では 112 kb/s、音声トラフィックでは 200 Kbps に制限されていました。 class-default クラスにはポリサーがありません。 唯一の制限は、xDSL 接続の物理的な帯域幅のみです。 次の図に示すように、カスタマーは 1000 kb/s まで送信できます。 ただし、この場合、より多くの音声と音声制御パケットが送信され、両方のクラスに対してトラフィックをポリシングする必要があります。

図 2. 子クラスでのトラフィックのポリシング

次の図に示すように、入力帯域幅全体を制御することが重要です。 重要な要件は、その全体の制限において Premium トラフィックが影響を受けないということです。 次の図に示すように、音声および音声制御パケットは全体の制限ではドロップされません。 子の class-default クラスから発生するパケットのみ、制限を満たすためにドロップされます。

図 3. 親クラスでのトラフィックのポリシング

最初のクラスは同様に機能します。 音声および音声制御は許容されるレベルにポリシングされ、class-default クラスは影響を受けません。 次のレベルでは、帯域幅全体は 500 Kb/s に制限され、class-default クラスから発生するパケットのみドロップする必要があります。 音声および音声制御は影響を受けないようにしておく必要があります。

ポリサーの実行順序は次のとおりです。

  1. 上記の図に示すように、子クラスのトラフィックをポリシングします。VoIP-Control クラスを 112 kb/s に、VoIP クラスを 200 kb/s に、class-default を 500 kb/s にポリシングします。
  2. 親ポリシー マップの class default のトラフィックをポリシングしますが、子の class default からのトラフィックのみをドロップし、残りの子クラスはドロップしません。 上の図に示すように、112 Kb/s の VoIP-Control および 200 kb/s の VoIP トラフィックは、親ポリサーでは影響を受けません。しかし、子からの 500 kb/s の class default は、親レベルでの 500 Kbps のポリシング ポリシー全体に適合するよう 188kb/s にポリシングされます。

階層型 Color-Aware ポリシングの設定方法

階層型 Color-Aware ポリシング機能の設定

手順の概要

    1.    enable

    2.    configure terminal

    3.    policy-map policy-map-name

    4.    class {class-name | class-default [fragment fragment-class-name]} [insert-before class-name] [service-fragment fragment-class-name]

    5.    police [cir cir][bc conform-burst] [pir pir][be peak-burst] [conform-action action [exceed-action action [violate-action action]]][conform-color hipri-conform]

    6.    service-policy policy-map-name

    7.    end


手順の詳細
     コマンドまたはアクション目的
    ステップ 1 enable


    例:
    Router> enable
     

    特権 EXEC モードをイネーブルにします。

    • パスワードを入力します(要求された場合)。
     
    ステップ 2 configure terminal


    例:
    Router# configure terminal
     

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 policy-map policy-map-name


    例:
    Router(config)# policy-map parent-policy
     

    ポリシー マップ コンフィギュレーション モードを開始して、ポリシー マップを作成します。

     
    ステップ 4 class {class-name | class-default [fragment fragment-class-name]} [insert-before class-name] [service-fragment fragment-class-name]


    例:
    Router(config-pmap)# class class-default
     

    ポリシーマップ クラス コンフィギュレーション モードを開始します。

    • 作成または変更するポリシーのクラス名を指定するか、ポリシーを指定する前にデフォルト クラス(一般に class-default クラスといいます)を指定します。 作成または変更する親クラスまたは子クラスの指定に必要な回数だけ次のコマンドを繰り返します。
    • class name :設定するクラス、またはポリシーを編集するクラスの名前。 クラス名は、クラス マップに使用するとともに、ポリシー マップのクラスにポリシーを設定する場合にも使用します。
    • class-default :ポリシーを設定または変更できるようデフォルト クラスを指定します。
    • fragment fragment-class-name :(任意)デフォルト トラフィック クラスをフラグメントに指定し、フラグメント トラフィック クラスに名前を付けます。
    • insert-before class-name :(任意)2 つの既存のクラス マップ間にクラス マップを追加します。 既存の 2 つのクラス マップ間に新しいクラス マップを挿入すると、既存のポリシー マップ コンフィギュレーションの柔軟性が向上します。 このオプションを指定しないと、クラス マップはポリシー マップに付加されます。
    (注)     

    このキーワードは、Flexible Packet Matching(FPM)ポリシーでだけサポートされています。

    • service-fragment fragment-class-name :(任意)クラスがフラグメントのコレクションを分類するように指定します。 このクラスにより分類されるフラグメントは、すべて同じフラグメント クラス名を共有している必要があります。
     
    ステップ 5 police [cir cir][bc conform-burst] [pir pir][be peak-burst] [conform-action action [exceed-action action [violate-action action]]][conform-color hipri-conform]


    例:
    Router(config-pmap-c)# police 50000 bc 3000 Router(config-pmap-c-police)# exceed-action transmit


    例:
    Router(config-pmap-c-police)# violate-action drop


    例:
    Router(config-pmap-c-police)# conform-color hipri-conform
     

    トラフィック ポリシングを設定し、指定のレートに準拠、超過、または違反としてマーク付けされたパケットに適用する複数のアクションを指定します。

    • ポリシー マップ クラス ポリス コンフィギュレーション モードを開始します。 1 つのアクションにつき 1 行を使用して、アクションを指定します。
    • cir :認定情報レート。 CIR がトラフィック ポリシングに使用されることを示します。
    • conform-action :(任意)レートが適合バースト値よりも少ない場合にパケットで実行されるアクション。
    • exceed-action :(任意)適合バースト内および適合バーストに超過バーストを加えたレートのパケットで実行されるアクション。
    • violate-action :(任意)適合バーストに超過バーストを加えたレートよりレートが超過しているパケットで実行されるアクション。 違反アクションを指定する前に、超過アクションを指定する必要があります。
    • conform-color :(任意)Color-Aware ポリシングを(設定済みポリサーで)イネーブルにし、適合カラーの決定に使用されるクラス マップを割り当てます。 hipri-conform キーワードは、使用されるクラス マップ(以前は class-map コマンドで設定)です。
     
    ステップ 6 service-policy policy-map-name


    例:
    Router(config-pmap-c-police)# service-policy child-policy
     

    ポリシー マップ内に QoS ポリシーとしてサービス ポリシー(階層型サービス ポリシーと呼ばれます)を作成します。

    • policy-map-name :QoS ポリシーとして使用する定義済みのポリシー マップの名前。 名前には最大 40 文字までの英数字を指定できます。
     
    ステップ 7 end


    例:
    Router(config-pmap-c-police)# end
     

    現在のコンフィギュレーション モードを終了します。

     

    次は、ポリシングの逆順を示す階層型 Color-Aware ポリシング機能の設定例です。

    policy-map child-policy
     class user1-acl-child
      police 10000 bc 1500
     class user2-acl-child
      police 20000 bc 1500
     class class-default
      police 50000 bc 1500
    policy-map parent-policy
     class class-default
      police 50000 bc 3000
      service-policy child-policy

    階層型 Color-Aware ポリシングの設定例

    階層型 Color-Aware ポリシング機能をイネーブルにする例

    次に、階層型 Color-Aware ポリシング機能をイネーブルにする例を示します。

    Router# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)# ip access-list extended user1-acl
    Router(config-ext-nacl)# permit ip host 192.168.1.1 any
    Router(config-ext-nacl)# permit ip host 192.168.1.2 any
    Router(config-ext-nacl)# ip access-list extended user2-acl
    Router(config-ext-nacl)# permit ip host 192.168.2.1 any
    Router(config-ext-nacl)# permit ip host 192.168.2.2 any
    Router(config-ext-nacl)# exit
    Router(config)# class-map match-all user1-acl-child
    Router(config-cmap)# match access-group name user1-acl
    Router(config-cmap)# class-map match-all user2-acl-child
    Router(config-cmap)# match access-group name user2-acl
    Router(config-cmap)# class-map match-all hipri-conform
    Router(config-cmap)# match qos-group 5
    Router(config-cmap)# exit
    Router(config)# policy-map child-policy
    Router(config-pmap)# class user1-acl-child
    Router(config-pmap-c)# police cir 10000 bc 1500
    Router(config-pmap-c-police)# class user2-acl-child
    Router(config-pmap-c)# police cir 20000 bc 1500
    Router(config-pmap-c-police)# exit
    Router(config-pmap-c)# exit
    Router(config-pmap)# exit
    Router(config)# policy-map parent-policy
    Router(config-pmap)# class class-default
    Router(config-pmap-c)# police cir 50000 bc 3000
    Router(config-pmap-c-police)# exceed-action transmit
    Router(config-pmap-c-police)# violate-action drop
    Router(config-pmap-c-police)# conform-color hipri-conform
    Router(config-pmap-c-police)# service-policy child-policy
    

    クラス マップでの複数エントリを拒否する例

    次に、クラス マップでの複数エントリの設定が拒否された試行の例を示します。

    Router# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)# class-map hipri-conform
    Router(config-cmap)# match qos-group 5
    Router(config-cmap)# match qos-group 6
    Only one match statement is supported for color-aware policing
    Router(config-cmap)# no match qos-group 6
    

    アクティブな Color-Aware クラス マップの削除を拒否する例

    次に、アクティブな Color-Aware クラス マップを許可できない例を示します。

    Router# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)# no class-map hipri-conform
    Class-map hipri-conform is being used
    

    階層型 Color-Aware ポリシング機能の設定を削除する例

    次に、階層型 Color-Aware ポリシング機能の設定を削除する方法の例を示します。

    Router# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)# no policy-map parent-policy 
    Router(config)# no policy-map child-policy
    Router(config)# no class-map hipri-conform
    Router(config)# no class-map user1-acl-child 
    Router(config)# no class-map user2-acl-child
    

    Cisco ASR 1000 シリーズ ルータの階層型 Color-Aware ポリシングの例

    次に、Cisco ASR 1000 シリーズ ルータで階層型 Color-Aware ポリシング機能をイネーブルにする設定例を示します。

    Router# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)# ip access-list extended user1-acl
    Router(config-ext-nacl)# permit ip host 192.168.1.1 any
    Router(config-ext-nacl)# permit ip host 192.168.1.2 any
    Router(config-ext-nacl)# ip access-list extended user2-acl
    Router(config-ext-nacl)# permit ip host 192.168.2.1 any
    Router(config-ext-nacl)# permit ip host 192.168.2.2 any
    Router(config-ext-nacl)# class-map match-all user1-acl-child
    Router(config-cmap)# match access-group name user1-acl
    Router(config-cmap)# class-map match-all user2-acl-child
    Router(config-cmap)# match access-group name user2-acl
    Router(config-cmap)# class-map match-all hipri-conform
    Router(config-cmap)# match qos-group 5
    Router(config-cmap)# policy-map child-policy
    Router(config-pmap)# class user1-acl-child
    Router(config-pmap-c)# police 10000 bc 1500
    Router(config-pmap-c-police)# conform-action set-qos-transmit 5
    Router(config-pmap-c-police)# class user2-acl-child
    Router(config-pmap-c)# police 20000 bc 1500
    Router(config-pmap-c-police)# conform-action set-qos-transmit 5
    Router(config-pmap-c-police)# class class-default
    Router(config-pmap-c)# police 50000 bc 1500
    Router(config-pmap-c-police)# policy-map parent-policy
    Router(config-pmap)# class class-default
    Router(config-pmap-c)# police 50000 bc 3000
    Router(config-pmap-c-police)# exceed-action transmit
    Router(config-pmap-c-police)# violate-action drop
    Router(config-pmap-c-police)# conform-color hipri-conform
    Router(config-pmap-c-police)# service-policy child-policy
    Router(config-pmap-c)# end
    Router#
    *Sep 16 12:31:11.536: %SYS-5-CONFIG_I: Configured from console by console
    Router# show class-map 
    Class Map match-all user1-acl-child (id 4)
    Match access-group name user1-acl
    Class Map match-all user2-acl-child (id 5)
    Match access-group name user2-acl
    Class Map match-any class-default (id 0)
    Match any 
    Class Map match-all hipri-conform (id 3)
    Match qos-group 5
    Router# show policy-map
    Policy Map parent-policy
    Class class-default
    police cir 50000 bc 3000 be 3000
    conform-color hipri-conform 
    conform-action transmit 
    exceed-action transmit 
    violate-action drop 
    service-policy child-policy
    Policy Map police
    Class prec1
    priority level 1 20000 (kb/s)
    Class prec2
    bandwidth 20000 (kb/s)
    Class class-default
    bandwidth 20000 (kb/s)
    Policy Map child-policy
    Class user1-acl-child
    police cir 10000 bc 1500
    conform-action set-qos-transmit 5
    exceed-action drop 
    Class user2-acl-child
    police cir 20000 bc 1500
    conform-action set-qos-transmit 5
    exceed-action drop 
    Class class-default
    police cir 50000 bc 1500
    conform-action transmit 
    exceed-action drop

    階層型 Color-Aware ポリシングが適用された show コマンドの例

    次に、階層型 Color-Aware ポリシング ポリシーが適用された場合の show policy-map interface コマンドからの出力例を示します。

    Router# show policy-map interface
    GigabitEthernet0/0/0 
    Service-policy input: parent-policy
    Class-map: class-default (match-any) 
    0 packets, 0 bytes
    5 minute offered rate 0000 bps, drop rate 0000 bps
    Match: any 
    police:
    cir 50000 bps, bc 3000 bytes, be 3000 bytes
    conformed 0 packets, 0 bytes; actions:
    transmit 
    exceeded 0 packets, 0 bytes; actions:
    transmit 
    violated 0 packets, 0 bytes; actions:
    drop 
    No color-aware policing statistics available
    conformed 0000 bps, exceed 0000 bps, violate 0000 bps
    Service-policy : child-policy
    Class-map: user1-acl-child (match-all) 
    0 packets, 0 bytes
    5 minute offered rate 0000 bps, drop rate 0000 bps
    Match: access-group name user1-acl
    police:
    cir 10000 bps, bc 1500 bytes
    conformed 0 packets, 0 bytes; actions:
    set-qos-transmit 5
    exceeded 0 packets, 0 bytes; actions:
    drop 
    conformed 0000 bps, exceed 0000 bps
    Class-map: user2-acl-child (match-all) 
    0 packets, 0 bytes
    5 minute offered rate 0000 bps, drop rate 0000 bps
    Match: access-group name user2-acl
    police:
    cir 20000 bps, bc 1500 bytes
    conformed 0 packets, 0 bytes; actions:
    set-qos-transmit 5
    exceeded 0 packets, 0 bytes; actions:
    drop 
    conformed 0000 bps, exceed 0000 bps
    Class-map: class-default (match-any) 
    0 packets, 0 bytes
    5 minute offered rate 0000 bps, drop rate 0000 bps
    Match: any 
    police:
    cir 50000 bps, bc 1500 bytes
    conformed 0 packets, 0 bytes; actions:
    transmit 
    exceeded 0 packets, 0 bytes; actions:
    drop 
    conformed 0000 bps, exceed 0000 bps

    その他の関連資料

    関連資料

    関連項目

    マニュアル タイトル

    Cisco IOS コマンド

    『Cisco IOS Master Commands List, All Releases』

    Quality of Service コマンド

    『Cisco IOS Quality of Service Solutions Command Reference』

    Quality of Service 設定情報

    『Cisco IOS QoS Configuration Guide, Cisco IOS XE Release 3S』

    標準

    標準

    タイトル

    この機能がサポートする新しい規格または変更された規格はありません。

    --

    MIB

    MIB

    MIB のリンク

    • CISCO-CLASS-BASED-QOS-MIB
    • CISCO-CLASS-BASED-QOS-CAPABILITY-MIB

    選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

    http:/​/​www.cisco.com/​go/​mibs

    RFC

    RFC

    タイトル

    RFC 2697

    A Single Rate Three Color Marker

    RFC 2698

    A Two Rate Three Color Marker

    シスコのテクニカル サポート

    説明

    リンク

    シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。 これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。 この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    階層型 Color-Aware ポリシングの機能情報

    次の表に、このモジュールで説明した機能に関するリリース情報を示します。 この表は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。 その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。

    プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 Cisco Feature Navigator にアクセスするには、www.cisco.com/​go/​cfn に移動します。 Cisco.com のアカウントは必要ありません。

    表 1 階層型 Color-Aware ポリシングの機能情報

    機能名

    リリース

    機能情報

    階層型 Color-Aware ポリシング

    Cisco IOS XE Release 3.2S

    階層型 Color-Aware ポリシング機能は、子から親にポリサーの順序付けを評価する場面に 2 つのレベルのポリシングを提供し、親レベルで特定のトラフィックを優先的に扱うことができます。